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Chapter 1: Welcome to Pro Tools
Welcome to Pro Tools®, brought to you by Avid® 
Technology. Pro Tools integrates powerful mul-
titrack digital audio and MIDI sequencing fea-
tures, giving you everything you need to 
record, arrange, compose, edit, mix, and master 
professional quality audio and MIDI for music, 
video, film, and multimedia.

Pro Tools Documentation
Pro Tools documentation provides you with 
workflow and reference information to help you 
successfully use Pro Tools.

Help is installed automatically during Pro Tools 
installation and can be accessed from within 
Pro Tools.

PDF Versions of Guides and Read Mes are in-
stalled automatically during Pro Tools installa-
tion. The main guides can be accessed from 
within Pro Tools. Additional documentation is 
available in the Pro Tools Documentation folder.

To view or print PDFs, you can use Adobe 
Reader or Apple Preview (Mac only).

Print Versions of Documentation are included 
with some Pro Tools software and hardware. 
Examples include Quick Setups and Installation 
guides.

Print-on-demand copies of the Pro Tools Refer-
ence Guide and some of the other guides in the 
Pro Tools guide set can be purchased separately 
from Avid (www.avid.com).
Launching Pro Tools Help
Pro Tools Help provides quick access to work-
flows and reference information while Pro Tools 
is open. Built-in search capabilities and an index 
are included to better support your Help needs.

To launch Help in Pro Tools:

 Choose Help > Pro Tools Help.

Accessing Guides in Pro Tools
PDF (Portable Document Format) versions of 
the main Pro Tools guides are accessible from 
the Pro Tools Help menu.

To access guides in Pro Tools:

 Choose Help, then a guide name (such as 
Menus Guide).

Guides Accessible in Pro Tools

The following guides are available from the 
Pro Tools Help menu:

• Audio Plug-Ins Guide

• Pro Tools Menus Guide

• Pro Tools Reference Guide

• Pro Tools Shortcuts

For information on these guides, see “Pro Tools 
Documentation in the Documentation Folder” 
on page 4.

For more information, see Chapter 4, 
“Using Help.”
Chapter 1: Welcome to Pro Tools 3
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Accessing Pro Tools Guides in 
the Documentation Folder
PDF (Portable Document Format) versions of 
many Pro Tools guides are installed with 
Pro Tools. They are accessible from the 
Pro Tools Documentation folder.

To access guides in Pro Tools Documentation 
folder:

1  Locate the Documentation folder on your hard 
drive.

• On Mac, go to Applications/Avid/
Documentation.

• On Windows, go to All Programs/Pro Tools/
Documentation.

2  Open the subfolder that has the documenta-
tion you want.

3  Double-click the PDF you want to view.

For information on guides in the Documenta-
tion folder, see “Pro Tools Documentation in 
the Documentation Folder” on page 4.

Pro Tools Documentation in the 
Documentation Folder
Pro Tools guides and Read Mes in the Documen-
tation folder are located in product-based sub-
folders, as follows:

Control Surfaces

C|24 Guide Supports Avid’s C|24™ 24-channel 
control surface for Pro Tools systems.

Command|8 Guide Supports Avid’s compact 
Command|8® control surface for Pro Tools and 
other supported Avid systems.

D-Command Guide Supports D-Command® 
worksurface for Avid ICON systems.

D-Control Guide Supports D-Control™ work-
surface for Avid ICON systems.
Pro Tools Reference Guide
Pro Tools EUCON Guide Provides information 
about setting up Pro Tools for use with
EuControl software and a EUCON™-compatible 
controller.

Hardware & Peripherals

003 Family User Guide Provides installation and 
operation information for 003®, 003+, and 003 
Rack Pro Tools systems.

192 Digital I/O Guide Supports 192 Digital I/O™  

audio interfaces for Pro Tools|HD and 
HD Native systems.

192 I/O Guide Supports 192 I/O™ audio inter-
faces for Pro Tools|HD and HD Native systems.

96 I/O Guide Supports 96 I/O™ audio interfaces 
for Pro Tools|HD and HD Native systems.

96i I/O Guide Supports 96i I/O™ audio inter-
faces for Pro Tools|HD and HD Native systems.

DigiTest Guide Provides information about us-
ing DigiTest to troubleshoot your Pro Tools|HD 
or HD Native system.

Expanded Systems Guide Provides instructions 
for expanding Pro Tools|HD systems with addi-
tional Pro Tools|HD cards and audio interfaces, 
with or without an expansion chassis.

HD IO Guide Provides a hardware overview, as 
well as detailed information for installing and 
configuring HD I/O audio interfaces for use with 
Pro Tools|HD and HD Native systems.

HD MADI Guide Provides a hardware overview, 
as well as detailed information for installing and 
configuring HD MADI audio interfaces for use 
with Pro Tools|HD and HD Native systems.

HD Native Install Guide Provides hardware in-
stallation instructions for HD Native systems.



HD OMNI Guide Provides a hardware overview, 
as well as detailed information for installing and 
configuring the HD OMNI audio interfaces for 
stand-alone use and for use with Pro Tools|HD 
and HD Native systems.

HD User Guide Provides hardware installation 
instructions for Pro Tools|HD (TDM) systems.

Mbox Mini User Guide Provides hardware instal-
lation and operation information for the Mbox® 
Mini audio interface.

Mbox Pro User Guide Provides hardware instal-
lation and operation information for the Mbox 
Pro audio interface.

Mbox User Guide Provides hardware installa-
tion and operation information for the Mbox au-
dio interface (3rd generation).

PRE Guide Provides detailed information for in-
stalling, configuring, and using PRE™, both 
stand-alone and with Pro Tools.

SurroundPanner Option Guide Supports the JL 
Cooper Surround Panner for Pro Tools HD and 
Pro Tools with Complete Production Toolkit.

SYNC HD Guide Supports the SYNC HD™ and 
SYNC I/O synchronization peripherals for 
Pro Tools|HD and HD Native systems.

Plug-Ins

Access Music Indigo Guide Provides detailed 
information for installing, authorizing, and us-
ing the Access Music Virus Indigo plug-in.

AIR Virtual Instruments Provides detailed infor-
mation for installing, authorizing, and using 
A.I.R. Virtual Instrument plug-ins (Hybrid, 
Strike, Structure, Transfuser, and Velvet).

Aphex Plug-Ins Guide Provides detailed infor-
mation for installing, authorizing, and using 
Aphex plug-ins.
Audio Plug-Ins Guide Describes the plug-ins in-
cluded free with Pro Tools, as well as additional 
plug-ins available for purchase separately.

Dolby Surround Tools Provides detailed infor-
mation for installing, authorizing, and using 
Dolby Surround Tools plug-ins.

Drawmer Dynamics Guide Provides detailed in-
formation for installing, authorizing, and using 
Drawmer Dynamics plug-ins.

Focusrite Plug-Ins Guide Provides detailed in-
formation for installing, authorizing, and using 
Focusrite plug-ins.

MDW EQ Plug-In Guide Provides detailed infor-
mation for installing, authorizing, and using the 
MDW EQ plug-in.

Sonic NoNOISE Guide Provides detailed infor-
mation for installing, authorizing, and using 
Sonic NoNoise plug-ins.

SymphonicOrchestraSE Guide Provides detailed 
information for installing, authorizing, and us-
ing the Symphonic Orchestra SE sample content 
for Structure.

Pro Tools

Glossary Provides a glossary of common DAW 
(Digital Audio Workstation) and Pro Tools 
terms.

Intro To Pro Tools Provides several introductory 
tutorials for using Pro Tools. 

Pro Tools Installation Guide Provides detailed 
information for installing and authorizing 
Pro Tools software, as well as information for 
optimizing your operating system for Pro Tools.

Pro Tools Menus Guide Covers all the Pro Tools 
on-screen menus.

Pro Tools Reference Guide Explains Pro Tools 
systems and software in detail. 
Chapter 1: Welcome to Pro Tools 5
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Pro Tools Shortcuts Lists keyboard and 
Right-click shortcuts for Pro Tools, including 
those shown in Pro Tools menus.

Sync & Surround Concepts Provides an intro-
duction to key synchronization, surround mix-
ing, and monitoring concepts for Pro Tools us-
ers.

What’s New In Pro Tools Provides an overview of 
new features in the current version of Pro Tools.

Read Mes

Read Me documents cover compatibility infor-
mation, known issues and workarounds, and 
corrections to Pro Tools guides. 

Toolkits & Options

Complete Prod Toolkit Provides detailed infor-
mation for installing, authorizing, and using the 
Complete Production Toolkit software option 
for Pro Tools.

Heat Option Guide Provides detailed informa-
tion for installing, authorizing, and using the 
HEAT software option for Pro Tools|HD sys-
tems.

MachineControl Guide Provides detailed infor-
mation for installing and using the Machine-
Control™ option. 

Satellite Link Guide Provides detailed informa-
tion for authorizing and using the Satellite Link 
software option.

Video Satellite Guide Provides detailed informa-
tion for authorizing and using the Video Satel-
lite software option.

Video Satellite LE Guide Provides detailed infor-
mation for authorizing and using the Video Sat-
ellite LE software option.
Pro Tools Reference Guide
Video

Avid Video Peripherals Guide Describes the use 
of the Avid Mojo SDI video peripheral with 
Pro Tools systems.

Pro Tools Avid Interop Provides a list of web re-
sources for interoperability with Pro Tools and 
Avid video editing systems.

Pro Tools Avid Interplay Describes how to use 
the Avid Interplay system to pass sequences and 
audio files back and forth between Avid video 
editing systems and Pro Tools HD audio editing 
and mixing systems.

Pro Tools Avid MediaNetwork Provides informa-
tion on setting up and using a Pro Tools client 
on Avid Unity MediaNetwork networked storage 
systems.

Pro Tools ISIS Guide Provides information on 
setting up and using a Pro Tools client on Avid 
Unity ISIS networked storage systems.

Conventions Used in 
Pro Tools Documentation
Pro Tools documentation uses the following 
conventions to indicate menu choices, keyboard 
commands, and mouse commands:
:

Convention Action

File > Save Choose Save from the 
File menu

Control+N Hold down the Control 
key and press the N key

Control-click Hold down the Control 
key and click the mouse 
button

Right-click Click with the right 
mouse button



The names of Commands, Options, and Settings 
that appear on-screen are in a different font.

The following symbols are used to highlight 
important information:

System Requirements and 
Compatibility Information
Avid can only assure compatibility and provide 
support for hardware and software it has tested 
and approved. 

For complete system requirements and a list of 
qualified computers, operating systems, hard 
drives, and third-party devices, visit:

www.avid.com/compatibility

User Tips are helpful hints for getting the 
most from your Pro Tools system.

Important Notices include information that 
could affect your Pro Tools session data or 
the performance of your Pro Tools system.

Shortcuts show you useful keyboard or 
mouse shortcuts.

Cross References point to related sections in 
this guide and other Avid documentation.
About www.avid.com
The Avid website (www.avid.com) is your best 
online source for information to help you get the 
most out of your Pro Tools system. The follow-
ing are just a few of the services and features 
available. 

Product Registration Register your purchase 
online. 

Support and Downloads Contact Avid Customer 
Success (technical support); download software 
updates and the latest online manuals; browse 
the Compatibility documents for system re-
quirements; search the online Knowledge Base 
or join the worldwide Pro Tools community on 
the User Conference. 

Training and Education Study on your own using 
courses available online or find out how you can 
learn in a classroom setting at a certified 
Pro Tools training center. 

Products and Developers Learn about Avid 
products; download demo software or learn 
about our Development Partners and their plug-
ins, applications, and hardware. 

News and Events Get the latest news from Avid 
or sign up for a Pro Tools demo.
Chapter 1: Welcome to Pro Tools 7
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Chapter 2: Pro Tools Concepts
Before you begin to use Pro Tools, you may find 
it helpful to review Pro Tools concepts. These 
concepts are the foundation of Pro Tools opera-
tion and functionality.

Hard Disk Audio Recording
Hard disk recording is a nonlinear (or random 
access) medium—you can go immediately to any 
spot in a recording without having to rewind or 
fast forward.

This differs from tape-based recording, which is 
a linear medium—where you need to rewind or 
fast forward to hear a particular spot in a re-
cording. To rearrange or repeat material in a 
linear system, you need to re-record it, or cut 
and splice it. 

Nonlinear systems have several advantages. You 
can easily rearrange or repeat parts of a record-
ing by making the hard disk read parts of the re-
cording in a different order or multiple times. In 
addition, this re-arrangement is nondestructive, 
meaning that the original recorded material is 
not altered.
Pro Tools Nonlinear Editing
Pro Tools is a nonlinear recording editing sys-
tem that lets you rearrange and mix recorded 
material nondestructively. Nonlinear editing 
simply means that you can cut, copy, paste, 
move, delete, trim, and otherwise rearrange any 
audio, MIDI, or video in the Pro Tools Edit win-
dow. 

Nonlinear editing provides significant advan-
tages over dubbing (re-recording), and cutting 
and splicing magnetic tape. It gives you the 
greatest possible flexibility for editing and ar-
ranging, and it is all nondestructive and “undo-
able.” Additionally, with nonlinear editing in 
Pro Tools, you will never introduce any degra-
dation of audio fidelity as you would with tape.
Chapter 2: Pro Tools Concepts 9
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DAE
DAE, the Pro Tools audio engine, is a real-time 
operating system for digital audio recording, 
playback, and processing. When you install 
Pro Tools, DAE is automatically installed on 
your system.

In the same way that a computer’s operating sys-
tem provides the foundation for programs that 
run on the computer, DAE provides the founda-
tion for much of the hard disk recording, digital 
signal processing, and mix automation required 
by Pro Tools and other products from Avid and 
its Development Partners.

Playback Engine
Pro Tools lets you adjust the performance of 
your system by changing system settings that af-
fect its capacity for processing, playback, and 
recording. These system settings are available in 
the Playback Engine (Setup > Playback Engine).

Pro Tools takes advantage of your computer’s 
host processor for certain tasks and optional 
host-based DSP processing. 

Pro Tools uses host (CPU) processing to provide 
audio track recording, playback, mixing, and ef-
fects processing. Both Pro Tools and Pro Tools 
HD use host processing to run Native AAX (Avid 
Audio Extension) and RTAS® (Real-Time Audio-
Suite) plug-ins for effects processing. Perfor-
mance is determined by your system and its 
Playback Engine settings. 
Pro Tools Reference Guide
The Playback Engine lets you set a hardware 
buffer size and allocate a percentage of CPU 
resources for these tasks.

On Pro Tools|HD systems, you can select the 
number of voices and voiceable tracks for your 
system and its sessions. Voice count choices are 
based on how much DSP processing you want to 
allocate for voicing. 

The Playback Engine is also where you assign 
dedicated resources for Automatic Delay Com-
pensation.

Playback Engine for Pro Tools|HD system

For more information, see “Configuring 
Pro Tools System Settings” on page 60. See 
also “System Resources” on page 21.



Core Audio
Apple’s Core Audio provides audio stream con-
nectivity between software applications and au-
dio hardware on Mac OS X. Pro Tools software 
can use audio interfaces with supported Core 
Audio drivers for playback and recording with 
up to 32 channels of I/O.

ASIO
Steinberg’s Audio Stream Input/Output (ASIO) 
provides audio stream connectivity between 
software applications and audio hardware on 
Windows. Pro Tools software can use audio in-
terfaces with supported ASIO drivers for play-
back and recording with up to 32 channels of 
I/O.

MIDI
MIDI (Musical Instrument Digital Interface) is a 
communication protocol for musical instru-
ments. This industry standard enables connec-
tions between a variety of devices from different 
manufacturers. Examples of MIDI-compatible 
equipment include synthesizers, sound mod-
ules, drum machines, MIDI patch bays, effects 
processors, MIDI interfaces, MIDI control sur-
faces, and MIDI sequencers. 

MIDI devices are equipped with 5-pin DIN con-
nectors, labeled as either IN, OUT, or THRU. 
The MIDI OUT port transmits messages. The 
MIDI IN port receives messages. The MIDI 
THRU outputs whatever is received from the IN 
port. MIDI devices are connected with MIDI ca-
bles that are available at most music stores. 

USB and FireWire-compatible MIDI devices 
send and receive MIDI messages to and from the 
computer over USB or FireWire.
The MIDI protocol provides 16 channels of 
MIDI per port. A single MIDI cable can transmit 
a separate set of messages for each of the 16 
channels. These 16 channels can correspond to 
separate MIDI devices or to multiple channels 
within a single device (if the device is multitim-
bral). Each channel can control a different in-
strument sound. For example, bass on 
channel 1, piano on channel 2, and drums on 
channel 10. Similar to a multitrack tape re-
corder, a MIDI sequencer can record complex 
arrangements—even using only a single multit-
imbral keyboard.

MIDI Terms
The following are some basic MIDI terms:

MIDI Instrument A hardware MIDI device or 
software instrument (such as an instrument 
plug-in).

MIDI Interface Hardware that lets computers 
connect to and communicate with MIDI devices 
(such as the M-Audio MIDISPORT). 

MIDI Device Any physical MIDI keyboard, sound 
module, effects device, or other equipment that 
can send or receive MIDI information.

MIDI signal flow

Not all devices will have all three MIDI 
ports (IN, OUT, and THRU).
Chapter 2: Pro Tools Concepts 11
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MIDI Controller Any MIDI device that transmits 
MIDI performance data. These include MIDI 
keyboards, MIDI guitar controllers, MIDI wind 
controllers, and others. Controllers transmit 
MIDI from their MIDI OUT ports.

MIDI Control Surface Any device (such as Com-
mand|8), which uses a MIDI connection to send 
control messages to a software program, but is 
not generally used to record MIDI information. 

Multitimbral The ability of one MIDI device to 
play several different instrument sounds (such 
as piano, bass, and drums) simultaneously on 
separate MIDI channels. This makes it possible 
for a single multitimbral MIDI instrument to 
play back entire arrangements.

MIDI Port A physical MIDI port on a MIDI inter-
face or a virtual MIDI port created in software. 
There are separate ports for MIDI In and Out. 
Physical MIDI ports connect to external MIDI 
devices using MIDI cables. Virtual MIDI ports 
connect software plug-ins and applications (see 
also “Virtual MIDI Nodes”).

MIDI Channel Up to 16 channels of MIDI perfor-
mance data can be transmitted on a single MIDI 
cable. The channel number separates the differ-
ent messages so your sound sources can receive 
the correct messages.

Program Change Event A MIDI command that 
tells a sound source which of its sounds (or 
sound patches) to use. The MIDI protocol lets 
you choose from a range of 128 patches.

Bank Select Message Many devices have more 
than 128 patches, which are arranged in banks. 
The Bank Select Message is a MIDI command 
that specifies the bank of patches from which to 
choose.
Pro Tools Reference Guide
Local Control A controller setting found on 
most MIDI keyboards that lets them play their 
own sound source. Disabling “local control” en-
sures that a device’s internal sound source is 
only played by external MIDI messages (such as 
those sent from Pro Tools when MIDI in 
Pro Tools is routed to the MIDI keyboard). 
When using Pro Tools, “local control” should 
usually be disabled (for example, when using 
MIDI Thru). When “local control” is off, your 
keyboard still transmits data to its MIDI OUT 
port.

Continuous Controller Events MIDI instructions 
that allow real-time changes to notes that are 
currently sounding. These include pitch bend, 
modulation, volume, pan, and many others.

System Exclusive Data MIDI data commonly 
used for sending and retrieving patch parameter 
information for storage purposes.

Virtual MIDI Nodes When using MIDI with in-
strument plug-ins in Pro Tools, virtual MIDI 
nodes are created. These nodes act like MIDI 
ports and provide software MIDI connections 
between Pro Tools and other MIDI software, 
such as instrument plug-ins. For example, when 
you insert Propellerhead’s Reason as a ReWire 
client on a track, the various MIDI inputs to 
Reason become available to Pro Tools MIDI and 
Instrument track MIDI outputs. 

Common Misconceptions About 
MIDI
MIDI is not audio, and by itself makes no sound. 
MIDI is control information only. It is like the 
piano roll for a player piano; it provides control 
information for what note to play when, for how 
long, at what volume, and with what sound (in-
strument). For example, when you strike a key 
on a MIDI keyboard, it sends a message to a 
MIDI instrument to play that particular note at 
that particular velocity using the selected sound 



(instrument). This could be its internal tone 
generator (like a synthesizer or sampler), an-
other external MIDI instrument, or an instru-
ment plug-in within Pro Tools. In order to play 
and hear a MIDI recording, you must have a 
MIDI instrument. Audio from an external MIDI 
instrument can be sent to an external mixer or 
monitored through your Pro Tools audio inter-
face (using either an Instrument track or Auxil-
iary track).

If you are using an external MIDI instrument, it 
must be connected to MIDI ports that are recog-
nized by your computer. These ports can be on a 
Pro Tools interface that has MIDI ports (such as 
an Mbox Pro) or some other MIDI interface 
(such as an M-Audio MIDISPORT).

To actually hear an external MIDI instrument, 
you need to connect its audio outputs to a mix-
ing console or connect it to one of the audio in-
puts of your Pro Tools audio interface.

Just as each Pro Tools system has unique hard-
ware features, each MIDI device has its own fea-
tures (and limitations) as to the number of 
voices and instruments it can play at one time. 
See the device’s documentation for information 
on its capabilities.

Signal paths for external MIDI instruments
MIDI in Pro Tools
Pro Tools provides powerful MIDI sequencing 
capabilities. You can record, enter, edit, and 
play back MIDI data on Pro Tools Instrument 
and MIDI tracks. These actions can be done in 
the Edit window, the MIDI Editor window, the 
Score Editor window, and the MIDI Event List. 

MIDI data in Pro Tools can be anything from 
MIDI note data (note number, on/off, velocity) 
to System Exclusive (Sysex) messages. MIDI 
data can be recorded or played back from both 
external MIDI devices with a MIDI interface 
(such as the M-Audio MIDISPORT or Mbox Pro) 
and other MIDI software (such as instrument 
plug-ins and ReWire client applications).

Synchronization
When you are working with multiple time-based 
systems, such as Pro Tools and an external deck, 
you want both systems to be synchronized. Syn-
chronization is where one system outputs clock 
source (such as timecode or MIDI Beat Clock) 
and another device synchronizes to or follows 
that clock source so that they work together. 
Pro Tools can be synchronized to other devices 
(or other devices can be synchronized to 
Pro Tools) using SMPTE/EBU timecode or MIDI 
Timecode.

For more information on different 
SMPTE/EBU formats, and other concepts 
related to timecode, see the Pro Tools Sync 
& Surround Concepts Guide.
Chapter 2: Pro Tools Concepts 13
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Surround Sound
Surround sound simply means having one or 
more speakers with discrete audio signals 
(channels) placed behind the listener in addi-
tion to the typical stereo pair. 

There are multiple types of surround formats in 
use (from three-channel LCR to 7.1, which has 
eight channels).

The most common surround format is 5.1, 
which refers to having 5 speakers and a sub-
woofer (the “.1”). 5.1 is used in movie theaters 
and home entertainment systems. Additionally, 
most DVDs are mixed to 5.1. The standard 
speaker placement for 5.1 for surround moni-
toring is stereo left and right speakers, and an 
additional center speaker in front, two more ste-
reo left and right speakers in the rear, and the 
sub-woofer on the side. 

Pro Tools HD and Pro Tools with Complete Pro-
duction Toolkit support mixing in surround for-
mats. In Pro Tools, each surround format is con-
sidered to be a greater-than-stereo multichannel 
format.

For information on fundamental surround 
concepts, see the Pro Tools Sync & Surround 
Concepts Guide.
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Pro Tools Sessions
When you start a project in Pro Tools, you cre-
ate a session. It can be helpful to understand the 
basic elements of a session.

Session File
A session file is the document that Pro Tools cre-
ates when you choose File > New Session and 
configure a new session. Pro Tools can open 
only one session file at a time. The session file is 
named with a .ptx (Pro Tools file) extension. 
Session files contain maps of all elements asso-
ciated with a project, including audio files, 
MIDI data, and all your edit and mix informa-
tion. It is important to realize that a Pro Tools 
session file does not contain any media files (au-
dio or video). Instead, it references audio, video, 
MIDI, and other files. You can make changes to 
a session and save those changes in a new ses-
sion file. This lets you create multiple versions 
of a session or back up your editing and mixing 
work. 

Session file icon



Tracks
Pro Tools tracks are where audio, MIDI, video, 
and automation data are recorded and edited. 
Pro Tools tracks also provide audio channels for 
routing internal busses, and physical inputs and 
outputs for audio and MIDI.

Pro Tools provides multiple types of tracks: 
audio, Auxiliary Input, Master Fader, VCA Mas-
ter, MIDI, Instrument, video, and click.

Audio, MIDI, Instrument, and video track data 
can be edited into clips or repeated in different 
locations to create loops, re-arrange sections or 
entire songs, or to assemble tracks using mate-
rial from multiple takes. 

Auxiliary Input tracks can route internal audio 
busses or physical inputs to internal busses or 
physical outputs. Auxiliary Inputs are typically 
used for audio effects busses, audio throughput 
(monitoring), and submixing.

Audio track in the Edit window (stereo track shown) 

MIDI track in the Edit window

Video track in Frames view
Master Fader tracks provide controls for physi-
cal audio output channels, including the volume 
level of your mix, panning, and plug-in inserts.

VCA Master tracks (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only) provide 
control of tracks in a Mix Group that has been 
assigned to the VCA Master.

Video tracks support QuickTime movies (all 
Pro Tools systems) and VC-1 video files (Win-
dows 7 only). Additionally, Pro Tools supports 
Avid video when using a supported Avid video 
peripheral. An individual video track can play 
back only one type of video at a time.

Audio, Auxiliary Input, Master Fader, and In-
strument tracks can be mono, stereo, or multi-
channel (Pro Tools HD and Pro Tools with 
Complete Production Toolkit only). When cre-
ating a new track, select from the list of channel 
formats supported by your system.

Pro Tools also lets you create a Click track so 
you can record while listening to a click. Click 
tracks can use the TL Metro plug-in (included 
with Pro Tools) or a MIDI instrument.

Voices
In Pro Tools, voices are unique, discrete audio 
streams that can be routed to and from Pro 
Tools audio tracks, and physical audio outputs 
and inputs on your Pro Tools audio interfaces. 
The audio paths to and from Pro Tools software 
routed to Pro Tools hardware use voices. If you 
exceed the number of available voices in your 
system, you have effectively exceeded the avail-
able number of audio paths.
Chapter 2: Pro Tools Concepts 15
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Typically, each audio channel for each track in 
your Pro Tools session uses a single voice. So, 
for a mono audio track, a single voice is used; for 
a stereo audio track, two voices are used. When 
using Punch Recording, two voices are needed 
for every single audio channel (one for playback 
and one for recording on punch in and out). In 
some situations, with Pro Tools|HD systems, 
more than one voice may be necessary for a sin-
gle channel (such as when using host processing 
on a TDM bus).

Voices can be allocated dynamically (with all 
Pro Tools systems, any available voices are au-
tomatically assigned as they are needed) or ex-
plicitly (with Pro Tools HD only, you can explic-
itly assign audio channels to specific available 
voices to ensure that audio on that channel is al-
ways voiced). 

On Pro Tools|HD systems, the number of avail-
able voices is dependent on the amount of dedi-
cated DSP processing in your system (see “Play-
back, Recording, and Voice Limits with 
Pro Tools HD” on page 49).

On all other Pro Tools systems, the full number 
of available voices for your system may be lim-
ited by the host processing power of your com-
puter (see “Pro Tools Capabilities with Different 
Hardware Configurations” on page 45).

Media Files
Pro Tools sessions create, import, export, and 
reference media files. Media files are audio, 
MIDI, and video files. Audio and video media 
files are stored separately from the Pro Tools 
session file. MIDI data is stored in the session 
file.

For more information about voicing in 
Pro Tools, see “Track Priority and Voice As-
signment” on page 241.
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Audio Files

When you record audio into a Pro Tools session, 
audio files are created. 

Audio files for each session are stored in a folder 
named “Audio Files.” Audio files are listed in 
the Pro Tools Clip List and can appear in an au-
dio track. A section of an audio file can be de-
fined as a clip. See “Clip” on page 17.

MIDI Files

When you record or enter MIDI into a Pro Tools 
session, all MIDI data is stored in the Pro Tools 
session file. You can import and export MIDI 
files to and from Pro Tools sessions, but MIDI 
recorded or otherwise created in a Pro Tools 
session does not automatically create new MIDI 
files.

Video Files

When you record or import video into a 
Pro Tools session, all video data is stored as the 
corresponding video file type (such as Quick-
Time). Video files can be created in (or copied 
to) the Video Files folder in the session folder. 
However, in most cases, Pro Tools references 
video files that have been captured by another 
application, such as Avid Media Composer®.

Audio file icons

MIDI file icon



Clip
A clip is a segment of audio, MIDI, or video data. 
A clip could be a drum loop, a guitar riff, a verse 
of a song, a recording take, a sound effect, some 
dialog, or an entire sound file. Clips are espe-
cially useful for arranging audio and MIDI. A 
clip can also have associated automation data. 
In Pro Tools, clips are created from audio files 
or MIDI data, and can be arranged in audio and 
MIDI track playlists. Clips can also be grouped 
(a “clip of clips”) and looped (repeated).

Audio clip

MIDI clip

Video clip (Frames view)

Clip group (Mixed audio and MIDI multitrack clip 
group)
Playlist
A playlist is a sequence of clips arranged on an 
audio, MIDI, or video track. Tracks have edit 
playlists and automation playlists. 

On audio tracks, an edit playlist tells the hard 
disk which audio clips to play in what order. For 
example, you can have separate audio clips for a 
song introduction, the first verse, the first cho-
rus, and so on. You can also use the same audio 
clip to access the same piece of audio multiple 
times at different locations and not use addi-
tional disk space. Different versions of the same 
original audio can be used in different places 
and have different effects applied. On MIDI and 
Instrument tracks, edit playlists can store mul-
tiple MIDI sequences (or performances) on a 
track. 

A playlist can be made up of a single clip or 
many separate clips. It can be made up of similar 
elements (such as clips from several different 
takes of a solo), or dissimilar elements (such as 
several sound effects). 

You can create any number of alternate edit 
playlists for a track. This lets you assemble dif-
ferent versions of performances or edits on a 
single track and choose between them from the 
Playlists menu on the track.

Playlist selector pop-up menu
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Each audio, Auxiliary Input, Instrument, Master 
Fader, and VCA track also has a single set of au-
tomation playlists. Automation playlists can in-
clude volume, pan, mute, and each automation-
enabled control for the insert and send assign-
ments on that track. 

MIDI controller data on Instrument and MIDI 
tracks is always included as part of the track 
playlist.

Channel
The term channel is used to describe several re-
lated components of a Pro Tools system. 

The first example of channel refers to a physical 
input or output of your Pro Tools system. For 
example, HD I/O provides up to 16 channels of 
audio input and output to a Pro Tools|HD or HD 
Native system, while the Mbox Pro audio inter-
face provides up to eight inputs and eight out-
puts.

The second use of the term channel refers to a 
channel strip in the Pro Tools Mix window. Each 
track in a Pro Tools session has a corresponding 
channel strip in the Mix window.

Audio and MIDI channel strips have similar 
controls, but those controls have slightly differ-
ent effects. For example, audio, Auxiliary Input, 
and Instrument track channel strip faders con-
trol the output gain to the mix bus for that chan-
nel, while MIDI channel strip faders send MIDI 
volume data (MIDI controller 7) to the selected 
MIDI instrument. 

The term “MIDI channel” also describes a 
separate aspect of MIDI operation. See 
“MIDI” on page 11.
Pro Tools Reference Guide
Channel strip in the Mix window (audio track)



Signal Routing
Pro Tools provides software-based mixing and 
signal routing controls for audio and MIDI. 
These controls are located in the Mix window. 
Some of these controls can also be accessed from 
the Edit window.

A common audio signal routing task is to sub-
mix multiple tracks to a single channel strip 
(such as an Auxiliary Input) for shared process-
ing and level control. 

The following example shows two audio tracks 
submixed to a stereo Auxiliary Input.

Submixing to an Auxiliary Input

Input from
stereo
bus path

Outputs to
stereo bus
path

Audio tracks

Inserts

Sends

Auxiliary
Input
Track
Signal Routing Options

Signal routing options include the following: 

Track Input and Output (I/O) Controls The most 
basic type of signal routing is track input and 
output. A track needs to have an assigned input 
path to record audio, and an assigned mapped 
output path in order to be audible through a 
hardware output. Signals can also be routed to 
or from other tracks in Pro Tools (or hardware 
inputs and outputs) using internal busses.

Auxiliary Input and Master Fader Tracks Auxil-
iary Inputs can be used as returns, submixers, 
and bus masters. Master Fader tracks are used as 
bus and output master level controls. Both Aux-
iliary Input and Master Fader tracks can have 
plug-in and hardware inserts.

MIDI Tracks MIDI tracks are generally used for 
routing MIDI from internal or external sources 
to external MIDI devices. MIDI data can also be 
routed to plug-ins on Auxiliary Inputs or Instru-
ment tracks.

Instrument Tracks Instrument tracks are the pri-
mary way to route MIDI to an instrument plug-
in and then route the plug-in’s sound to outputs, 
sends and busses, or other inserts. Instrument 
tracks can also be used to send MIDI to and 
monitor audio from external MIDI devices.

Sends Sends route audio from tracks to hard-
ware outputs, or to internal busses that are in 
turn routed to other tracks within Pro Tools. 
MIDI, Master Fader, and VCA Master tracks do 
not have sends.
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Plug-In and Hardware Inserts Plug-in process-
ing occurs completely within the Pro Tools sys-
tem. Hardware inserts use audio interface in-
puts and outputs for traditional insert routing 
to and from external effects and other devices. 
MIDI and VCA Master tracks do not have in-
serts.

Instrument Plug-Ins Instrument plug-ins are dif-
ferent from processing plug-ins in that they gen-
erate audio rather than process the audio signal 
from a track’s audio input or from hard disk. 
Instrument plug-ins are typically played by 
MIDI.

Paths Paths are any routing option in Pro Tools, 
including internal or external inputs, outputs, 
busses, and inserts. Pro Tools lets you name 
these paths, and these path names appear in the 
Audio Input and Output Path selectors and 
other menus. For more information, see 
Chapter 7, “I/O Setup.”

Mixing Formats Sessions can include combina-
tions of mono, stereo, and greater-than-stereo 
multichannel format tracks, busses, inputs, out-
puts, and inserts. Greater-than-stereo multi-
channel formats are supported with 
Pro Tools HD and Pro Tools with the Complete 
Production Toolkit option only.

Grouping and VCA Tracks Tracks can be 
grouped together for mixing so that their rela-
tive mix settings are maintained when changing 
a mix setting for any track in the group. For ex-
ample, changing the volume of one track affects 
the volume of all the other tracks in the group. 
VCA Master tracks (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only) control 
the relative mix settings for all tracks within the 
selected group.
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Tick-Based and Sample-
Based Time
Pro Tools lets you set any track timebase to 
either sample-based or tick-based. You can also 
set the Timeline to be viewed as tick-based or 
sample-based.

Audio in Pro Tools is sample-based by default. 
This means that if an audio clip is located at a 
particular sample location, it will not move from 
that location if the tempo changes in the ses-
sion—though its Bar|Beat location will change.

MIDI data in Pro Tools is tick-based by default. 
This means that if a MIDI clip is located at a par-
ticular Bar|Beat location, it will not move from 
that Bar|Beat location if the tempo changes in 
the session—though its sample location will 
change.

You can select whether a track is sample-based 
or tick-based when it is created, or change time-
bases later. 

Sample-Based Audio and MIDI

With a sample-based audio track, all clips in the 
track have an absolute location on the Timeline. 
Clips stay fixed to the sample time, regardless of 
where tempo or meter changes occur in a ses-
sion.

If you make a MIDI track sample-based, all 
MIDI events in the track have an absolute loca-
tion on the Timeline. MIDI events stay fixed to 
sample time, regardless of any tempo or meter 
changes in a session.



Tick-Based Audio and MIDI

Tick-based audio is fixed to a Bars|Beat loca-
tion, and moves relative to the sample Timeline 
when tempo and meter changes occur. However, 
MIDI events and tick-based audio respond dif-
ferently to tempo changes with respect to dura-
tion. MIDI note events change length when 
tempo or meter is adjusted, while audio clips do 
not (unless Elastic Audio is enabled). When 
Elastic Audio is not enabled on an audio track, 
meter and tempo changes affect only the start 
point (or sync point) for each audio clip in a 
tick-based track. If Elastic Audio is enabled on 
an audio track, tempo changes apply Elastic Au-
dio processing, which changes the duration of 
the audio clip.

Elastic Audio

Elastic Audio provides real-time and non-real-
time (rendered) Time Compression and Expan-
sion (TCE) of audio. Tick-based Elastic Audio 
tracks actually change the location of samples 
according to changes in tempo. The audio 
stretches or compresses to match changes in 
tempo. Elastic Audio also provides high-quality 
non-real-time clip-based pitch shifting.

Pro Tools Elastic Audio uses exceptionally high-
quality transient detection algorithms, beat and 
tempo analysis, and real-time or rendered TCE 
processing algorithms. Elastic Audio lets you 
quickly and easily tempo conform and beat 
match audio to the session’s Tempo ruler. It also 
provides an unprecedented degree of control 
over transient detection and TCE processing on 
an event-by-event basis.
With Elastic Audio, Pro Tools analyzes entire 
audio files for transient “events.” For example, 
an event can be a drum hit, a sung note, or chord 
played by a guitar. These detected events can 
then serve as control points for “warping” the 
audio. Pro Tools can warp (TCE) audio events 
automatically, such as when automatically con-
forming audio to the session tempo or quantiz-
ing audio events, or you can warp audio manu-
ally using the standard editing tools with the 
audio track set to Warp view.

Elastic Audio is useful in several common work-
flows: working with loops, correcting perfor-
mances, remixing, beat and pitch matching, and 
sound design and special effects. 

System Resources
Track count, plug-in processing, signal path and 
routing options, and voice availability are ulti-
mately limited by the combined resources avail-
able from the host computer and from your 
Pro Tools hardware. 

Pro Tools provides several ways to manage and 
conserve resources to maximize the perfor-
mance of your system. As you begin working 
with Pro Tools sessions and tracks, you can take 
advantage of the following features to extend the 
effectiveness of your available DSP and other re-
sources:

 Pro Tools lets you adjust the performance of 
your system by changing system settings that af-
fect its capacity for processing, playback, and re-
cording. See “Configuring Pro Tools System 
Settings” on page 60.
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 In order to free up needed DSP resources, 
Pro Tools allows for certain items (such as tracks 
and inserts) to be manually made inactive. Inac-
tive elements are viewable, editable, and re-
tained within the session. See “Active and 
Inactive Items” on page 22.

 All Pro Tools systems provide flexible voice 
options for audio tracks, to help maximize use of 
available voices in your system. For more infor-
mation on voice management and options, see 
“Voice Borrowing” on page 244. 

Active and Inactive Items
Pro Tools lets you make certain items (such as 
tracks and inserts) inactive, in order to free up 
DSP resources and mixer connections. 

Items in Pro Tools that can be made inactive 
include the following:

• Audio, Auxiliary Input, Master Fader, 
VCA Master, and Instrument tracks

• Track Inputs and Outputs

• Sends

• Side-chain inputs

• Plug-Ins

• Hardware inserts

• Paths (session-wide)

MIDI tracks cannot be made inactive. 

Side-chain inputs support direct active and 
inactive switching, but do not follow switch-
ing all or all selected side-chain inputs.
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In addition to manually setting Active and Inac-
tive modes, Pro Tools automatically makes 
items inactive if there are insufficient or un-
available resources. 

When active, items are fully engaged and opera-
tional.

When inactive, items are silent and off, although 
most associated controls can still be adjusted. 
Different inactive items affect available system 
resources in specific ways, as follows:

Plug-Ins When a plug-in is inactive on a track, 
its DSP is made available for other plug-ins and 
processing. Plug-In assignments can be made 
inactive manually or automatically (see “Auto-
matic and Manual Inactive Mode” on page 23). 

Paths and Path Assignments When a path or 
path assignment is inactive, its mixer resources 
are made available for other signal routing pur-
poses in the session. Paths and assignments can 
be made inactive manually or automatically (see 
“Automatic and Manual Inactive Mode” on 
page 23).

Tracks When a track is made inactive, its voices 
become available for another track. Inactive 
mono tracks free up one voice; inactive stereo 
and multichannel tracks free up one voice per 
channel. Additionally, when an audio, Auxiliary 
Input, Instrument, or Master Fader track is 
made inactive, its plug-ins, inserts, sends, and 
I/O assignments become inactive, and the asso-
ciated DSP used is freed up for use elsewhere in 
the session.



Display of Inactive Items

When items are inactive, their names appear in 
italics, and their background becomes dark 
gray. When a track is inactive, the entire chan-
nel strip is grayed out.

Active and inactive plug-ins, sends, and tracks

Active Inactive plug-in 

Inactive
track 
Automatic and Manual Inactive Mode

Active and Inactive modes are powerful options 
for session transfer and system resource man-
agement. Pro Tools provides automatic and 
manual Inactive mode switching. You can man-
ually make items inactive (or active) to selec-
tively manage system resources while editing 
and mixing.

Automatically Inactive Items

When opening a session, it is possible that not 
all signal paths, plug-ins, or audio interfaces 
used in the session will be available as defined 
on the current system. When opening a session, 
sufficient voices may also be unavailable if the 
session was created on a different Pro Tools sys-
tem type (for example, opening a session created 
on a Pro Tools|HD system on a Pro Tools system 
with an Mbox Pro audio interface).

Whenever this occurs, the session will open as it 
was last saved. All items that are unavailable, or 
cannot be loaded due to insufficient resources, 
are made inactive.

Manual Inactive Switching

You can manually apply Active or Inactive 
modes to manage system resources. By making 
an item inactive, its associated resources are 
made available elsewhere in the session. 
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DigiBase
DigiBase is a database management tool for 
Pro Tools. DigiBase expands upon basic 
Pro Tools search and import capabilities by pro-
viding powerful tools to manage your data both 
inside and outside of your sessions, on any hard 
drive connected to the system.

A database is a way of organizing data such that 
it can easily be searched, sorted, managed, and 
utilized. Your checkbook is an example of a da-
tabase file. For every check you write, you enter 
a new record. That record contains information 
about the check, such as when you wrote it, to 
whom you wrote it, and for what amount. This 
information is written in specific columns, or 
fields. Everything you need to know (the check’s 
metadata) is there, even though the check itself 
is not.

DigiBase browsers let you search, sort, and 
mange these databases by volume or catalog. 
You can use DigiBase browsers not only to orga-
nize your Pro Tools sessions and media files 
(audio, MIDI, and video), but also to audition 
and import by drag and drop.

For more information about DigiBase, see 
“DigiBase” on page 281.
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AAF, MXF, and OMF
Pro Tools lets you exchange audio, video, and 
sequences with other AAF-, MXF-, and OMF-
compatible applications (such as Avid editors).

Media Data (Media Files)
Media data represents raw audio or video mate-
rial and is stored in individual media files. Every 
time you record a piece of video or audio mate-
rial into an application, you are creating a media 
file. Audio media files hold samples (such as 
44,100 or 48,000 samples per second of record-
ing) while video media files use frames (24, 25, 
or 30 frames per second of recording).

The size of each media file depends on how 
much audio or video material it contains. For 
example, a file containing ten minutes of high 
resolution video might be approximately 
2.16 GB in size, whereas a ten-minute audio re-
cording at the might result in a 100 MB file. Me-
dia files tend to be large, since high quality au-
dio and video signals are data intensive. Video 
data generally requires considerably more stor-
age than audio data.



Metadata
Metadata is used to describe the following:

• Information embedded in a media file. This 
may include scene, take, sample rate, bit 
depth, external clip names, the name of the 
videotape from which the media file was cap-
tured, and even timecode values.

• Information embedded in Pro Tools sessions 
or other sequences, including what files are 
used, where they appear in a timeline, and au-
tomation.

• For AAF or OMF sequences, metadata also in-
cludes information embedded in unrendered 
AudioSuite™ effects (such as real-time EQ) on 
Avid workstations. Pro Tools skips unren-
dered effects on import. Rendered effects are 
media files that can be imported into 
Pro Tools.

• For AAF or OMF sequences, information 
about automation (clip-based gain or key-
frame gain).

AAF, OMF, and MXF Basics
AAF and OMF files are mechanisms for storing 
and retrieving media files and metadata so that 
projects can be freely exchanged between differ-
ent applications and platforms. MXF is a media 
file format that can be used with AAF (but not 
OMF) files.

Media data and metadata enable an application 
that receives AAF and OMF sequence files (such 
as Pro Tools) to automatically and quickly reas-
semble the composition. A simple metaphor for 
this approach is that media data files are the 
pieces of a puzzle and metadata is the set of in-
structions for assembling the puzzle.
In the simplest case, only an AAF or OMF se-
quence is exchanged. If this sequence points to 
existing media files, the size of the sequence file 
is relatively small and the export/import process 
is relatively fast. 

AAF and OMF sequences can also have media 
data embedded in them. This creates a single, 
larger file that is slower to export and import, 
but which may be easier to manage than thou-
sands of files stored on different volumes.

AAF

AAF is a sequence file format. AAF sequences 
are the best way to exchange projects and main-
tain valuable metadata. An AAF sequence can 
refer to OMF or MXF media files, or have OMF 
and MXF media files embedded within them. 
There is no such thing as an AAF audio or video 
media file.

Pro Tools will import, play back, and export an 
AAF sequence that either links to media files or 
has audio embedded within it.

When you import an AAF sequence with embed-
ded audio into Pro Tools, the audio will be ex-
tracted into mono tracks using the current ses-
sion’s audio file format.
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MXF

MXF is a media file format. There are MXF video 
files and MXF audio files, but there are no MXF 
sequences. An AAF sequence may refer to or in-
clude MXF media files, but OMF sequences can-
not refer to or include MXF files.

Pro Tools can import and play back MXF audio 
and video files created in Media Composer or 
other Avid applications.

OMF

OMF is both a media file and sequence format. 
OMF media files can be audio or video, and 
Pro Tools can import and play back OMF audio 
and video. Pro Tools can also export OMF audio, 
but not OMF video.

Pro Tools can import and play back OMF audio 
and video files created in Media Composer or 
other applications.

An OMF sequence cannot reference or have MXF 
media embedded within it.

Pro Tools can import an OMF sequence with 
embedded audio, but not embedded video.

MXF file icon

Video files digitized in Pro Tools are techni-
cally in the MXF format, but are intended 
only for use in Pro Tools and are not tested for 
compatibility with other applications.
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Pro Tools and Avid Terminology
Pro Tools and Avid use different terms to de-
scribe the same items. For example, a Pro Tools 
session is equivalent to an Avid sequence. The 
following table lists common Pro Tools ele-
ments and their Avid equivalents.

Pro Tools Avid (AAF or OMF)

session sequence

whole file clip master clip

clip subclip

plug-ins real-time audio effects

volume automation gain Avid keyframe volume

Whole audio files in the Clip List normally ap-
pear in bold type. However, master clip audio 
files imported from AAF or OMF into 
Pro Tools will not appear in bold type (indi-
cating clips) in the Pro Tools Clip List even 
though they are audio files.



Embedded Media and Linked Media
There are two types of AAF and OMF files: ones with embedded media, and ones with linked media. 
Embedded Media

Exporting to AAF or OMF with embedded media results in one large AAF or OMF file containing both 
the metadata and all associated media files.
When working with OMF embedded media or creating AAF embedded audio, Pro Tools limits file size 
to 2 GB. However, you may be able to use Pro Tools to open an AAF embedded audio file larger than 
2 GB if it was exported from another source.
AAF/OMF Interchange Workflow with Embedded Media

Avid Workstation Edited Sequence

Embedded AAF/OMF File (metadata and media)

Export AAF/OMF with Embedded Media

Refers to:

Original Source Media Files

Sequence (metadata) Consolidated Media Files
(with Handle)

creates...
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Linked Media
Pro Tools Reference Guide
Exporting AAF or OMF with linked media results in a single metadata file (.AAF or .OMF) and all as-
sociated media stored as separate files.

The main benefit to this approach is that fewer copies of media files may need to be made, so the ex-
port and import process can be much faster. Using this approach, it is less likely that you will encoun-
ter any file size limitations since the data is broken up into many smaller files.

The main disadvantage to this approach is that there are potentially many files (for example, one AAF 
or OMF file and hundreds of media files) that must be transported between systems.
AAF and OMF Interchange Workflow with Linked Media

Linked to:

Linked to:

Lin
ke

d 
to

:

Avid Workstation Edited Sequence

AAF/OMF File (metadata only)

Original Source Media Files

Translated Pro Tools Session File

Pro Tools Imports
Session File

Avid Workstation exports 
sequence edits and

file information as AAF
or OMF sequence



Chapter 3: Keyboard and Mouse Shortcuts
For increased operational speed and ease of use, 
there are many Pro Tools® keyboard and 
Right-click shortcuts.

A full list of Pro Tools shortcuts is available in 
online Help and in a PDF guide.

To access the full list of Pro Tools shortcuts in 
online Help:

1  Choose Help > Pro Tools Help.

2  Click Pro Tools Shortcuts on the Contents page 
(in the left pane of Help).

To access the full list of Pro Tools shortcuts in the 
Pro Tools Shortcuts Guide:

 Choose Help > Shortcuts.

Mouse Shortcuts
Right-Click Shortcuts

Pro Tools provides Right-Click shortcuts for 
choosing various Pro Tools commands and 
menus with any Right-Click capable mouse. 

Scroll-wheel Functions

Pro Tools lets you increment or decrement val-
ues in numerical fields by selecting the value 
and moving the mouse scroll wheel up or down. 

For a complete list of Right-Click shortcuts, 
see the Shortcuts Guide.
Global Key Commands
Some keyboard shortcuts apply to many func-
tions in Pro Tools.

Track Functions

Pro Tools provides keyboard shortcuts for the 
following track functions:

• Changing Automation mode

• Enabling playlists

• Adding plug-ins

• Record enabling, soloing, and muting 
tracks

• Record safing and solo safing tracks

• Assigning inputs, outputs, and sends

• Toggling volume/peak/delay display

• Clearing meters

• Changing track heights

For a complete list of keyboard shortcuts, 
see the Shortcuts Guide.

Command Windows Mac

Apply action to all 
channel strips/tracks

Alt+ 
action

Option+ 
action

Apply action to 
selected channel 
strips/tracks

Alt+ 
Shift+ 
action

Option+ 
Shift+ 
action
Chapter 3: Keyboard and Mouse Shortcuts 29



30
List and Parameter Selection

Pro Tools provides keyboard shortcuts for the 
following items:

• Selection of tracks in Track List

• Enabling of groups in Group List

• Automation Enable window parameters

• Setting Memory Location parameters

Controls and Editing Tools

Pro Tools provides keyboard shortcuts for mov-
ing plug-in controls, faders and sliders, the 
Scrubber, and automation data.

Keyboard Focus
The Keyboard Focus in Pro Tools determines 
how the alpha keys function. Depending on 
which Keyboard Focus is enabled, you can use 
the keys on your computer (alpha) keyboard to 
select clips in the Clip List, enable or disable 
groups, or perform an edit or play command.

You can only enable one of the three Keyboard 
Focus modes at a time. Enabling a Keyboard Fo-
cus will disable the one previously enabled.

Command Windows Mac

Toggle item and set 
all others to same 
new state

Alt-click item Option-
click item

Toggle item and set 
all others to opposite 
state

Control-click 
item

Command-
click item

Command Windows Mac

Fine adjust-
ment of sliders, 
knobs, and 
breakpoints

Hold Control 
while click-
ing the item

Hold Com-
mand while 
clicking the item
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There are three types of Keyboard Focus:

Commands Keyboard Focus When selected in 
the Tracks pane in the Edit window or in the 
Notes pane of any MIDI Editor window, this 
provides a wide range of single key shortcuts 
from the computer keyboard for editing and 
playing. The frontmost Edit or MIDI Editor win-
dow always receives Commands Keyboard Focus 
when it is enabled.

With Commands Keyboard Focus disabled, you 
can still access any of its key shortcuts by press-
ing the Start key (Windows) or Control (Mac) 
along with the key. See the Shortcuts Guide for a 
complete list of Commands Keyboard Focus 
shortcuts.

Clip List Keyboard Focus When selected, audio 
clips, MIDI clips, and clip groups can be located 
and selected in the Clip List by typing the first 
few letters of the clip’s name.

Group List Keyboard Focus When selected, Mix 
and Edit Groups can be enabled or disabled by 
typing the Group ID letter (in either the Mix or 
Edit window).

Keyboard Focus buttons

Clip List
Keyboard Focus

Group List
Keyboard Focus

Commands Keyboard Fo-
cus (Edit window)



To set the Keyboard Focus, do one of the 
following:

 Click the a–z button for the focus you want to 
enable.

– or –

 While pressing Command+Option (Mac) or 
Control+Alt (Windows), press one of the follow-
ing keys: 1 (Commands), 2 (Clip List), or 3 
(Group List).

Toolbar Focus
In the Edit window, the MIDI Editor pane can be 
displayed in addition to the Tracks pane (View > 

Other Displays > MIDI Editor). When the MIDI 
Editor pane is displayed, there are two separate 
Toolbars and Timelines in the Edit window: one 
for the Tracks pane and one for the MIDI Editor 
pane. Only one Toolbar and Timeline can be fo-
cused for Menu and Toolbar commands (includ-
ing the corresponding keyboard shortcuts) at a 
time. The focused Toolbar displays a yellow out-
line. 

If Keyboard Focus for the Edit window is en-
abled, it follows the selected Toolbar focus.

To enable Toolbar focus for the Tracks pane, do 
one of the following:

 Click the Toolbar at the top of the Edit 
window.

– or –

 Press Command+Option+4 (Mac) or 
Control+Alt+4 (Windows).

Although multiple plug-in windows can have 
a keyboard focus enabled, only the front-
most window receives any keyboard input.
To enable Toolbar focus for the MIDI Editor pane, 
do one of the following:

 Click the Toolbar right above the MIDI Editor 
pane.

– or –

 Press Command+Option+5 (Mac) or 
Control+Alt+5 (Windows).

Numeric Keypad Modes
The Operation preference for Numeric Keypad 
mode determines how the numeric keypad func-
tions for Transport.

There are two Shuttle Lock modes (Classic and 
Transport), and one Shuttle mode.

No matter which Numeric Keypad mode is se-
lected, you can always use the numeric keypad 
to select and enter values in the Event Edit Area, 
Edit Selection indicators, Main and Sub Coun-
ters, and Transport fields.

To set the Numeric Keypad Mode:

1  Choose Setup > Preferences and click the Op-

eration tab.

2  In the Transport section, select a Numeric 
Keypad mode (Classic, Transport, or Shuttle).

3  Click OK. 
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Shuttle Lock Modes
There are two Shuttle Lock modes (Classic and 
Transport). Both modes let you use the numeric 
keypad to shuttle forward or backwards at spe-
cific speeds.

• 5 is normal speed.

• 6–9 provide increasingly faster fast-for-
ward speeds.

• 1–4 provide progressively faster rewind 
speeds (4 is the slowest rewind Shuttle Lock 
speed, 1 is the fastest).

• Press 0 to stop Shuttle Lock, then press the 
number to resume Shuttle Lock speed.

• Press Escape or Spacebar to exit Shuttle 
Lock mode.

Custom Shuttle Lock Speed

(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

The highest fast-forward Shuttle Lock speed 
(key 9) can be customized.

Classic Mode

This mode emulates the way Pro Tools worked 
in versions lower than 5.0. With the Numeric 
Keypad mode set to Classic, you can:

• Play up to two tracks of audio in Shuttle 
Lock mode. Press the Control key (Mac) or 
the Start key (Windows), followed by 1–9 
for different play speeds. 

• Press Plus or Minus to reverse direction.

• Press 0 to stop Shuttle Lock, then press the 
number to resume Shuttle Lock speed.

• Press Escape or Spacebar to exit Shuttle 
Lock mode.

• Recall Memory Locations by typing the 
Memory Location, followed by a Period (.).

For information, see “Custom Shuttle Lock 
Speed” on page 566.
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Transport Mode

This mode lets you set a number of record and 
play functions, and also operate the Transport 
from the numeric keypad.

With the Numeric Keypad mode set to Transport, 
you can also:

• Play up to two tracks of audio in Shuttle 
Lock mode. Press the Control key (Mac) or 
the Start key (Windows), followed by 1–9 
for different play speeds. 

• Press Plus or Minus to reverse direction.

• Press 0 to stop Shuttle Lock, then press the 
number to resume Shuttle Lock speed.

• Press Escape or Spacebar to exit Shuttle 
Lock mode.

• Recall Memory Locations by typing Period 
(.), the Memory Location number, and Pe-
riod (.) again.

Function Key

Click on/off 7

Countoff on/off 8

MIDI Merge/Replace mode 9

Loop Playback mode on/off 4

Loop Record mode on/off 5

QuickPunch mode on/off 6

Rewind 1

Fast Forward 2

Record enable 3

Play/Stop 0



Shuttle Mode
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools offers another form of shuttling, dif-
ferent from that of the two Shuttle Lock modes. 
With the Numeric Keypad mode set to Shuttle, 
playback of the current Edit selection is trig-
gered by pressing and holding the keys on the 
numeric keypad—playback stops once the keys 
are released. Various playback speeds are avail-
able in both forward and reverse. In this mode, 
pre- and post-roll are ignored.

With the Numeric Keypad mode set to Shuttle, 
you can also:

• Recall Memory Locations by typing Period (.), 
the Memory Location number, and Period (.) 
again.

Playback Speeds Key

1x Forward 6

1x Rewind 4

4x Forward 9

4x Rewind 7

1/4x Forward 3

1/4x Rewind 1

1/2x Forward 5+6

1/2x Rewind 5+4

2x Forward 8+9

2x Rewind 8+7

1/16x Forward 2+3

1/16x Rewind 2+1

Loop Selection (1x) 0

Shuttle Lock modes are not available when 
the Numeric Keypad mode is set to Shuttle.
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Chapter 4: Using Help
Pro Tools Help provides quick access to work-
flows and reference information. Built-in search 
capabilities and an index are included to better 
support your Help needs.

The Help system is HTML-based and runs on 
most common web browsers. When running it 
in Pro Tools, it automatically uses the Pro Tools 
in-application Web browser. You can also run 
Help from outside of Pro Tools, using another 
browser (such as Safari or Explorer).

Accessing the Help System
There are several ways to access the Help sys-
tem.

• Open Help at its Welcome page from the 
Help menu in Pro Tools.

• Open Help at its Welcome page from within 
a Help browser in Pro Tools.

• Open Help at its Welcome page outside of 
Pro Tools

• Open a different version or language of 
Pro Tools Help.

The Pro Tools in-application Web browser 
is not available outside of Pro Tools. To use 
Pro Tools Help while Pro Tools is not run-
ning, use the default Web browser for your 
operating system.
To open Help within Pro Tools:

 Choose Help > Pro Tools Help.

– or –

 From the Pro Tools Online browser window 
(which can be accessed by choosing any of the 
Help browser commands in the Help menu), 
choose Help.

To open Help outside of Pro Tools (or to select a 
different version or language of Help):

1  Open your favorite online browser (such as Sa-
fari or Explorer).

2  Visit the Pro Tools Help launch page 
(http://apps.avid.com/ProToolsHelp/).

3  Follow the on-screen instructions to open the 
desired version of Help.

To close the Help system:

 Click the Help viewer’s Close button.
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Understanding the Help 
Display
The Help system uses the following main display 
elements and areas:

• Help topics open in the right pane of the Help 
viewer. This is the Topic pane.

• Buttons for controlling the Help display and 
for printing Help topics appear at the top of 
the Help viewer.

• The top area of each page of the Help system 
includes links that indicate the location of the 
currently displayed topic within its book and 
chapter

• Navigation tools (Contents, Index, and 
Search) open in the left pane of the Help 
viewer. For more information, see “Using the 
Contents and Index Tabs” on page 36 and “Us-
ing the Search Tab” on page 37.

Topic Pane

The information in Help displays in the Topic 
pane of the Help viewer. All topics have the fol-
lowing items above the main heading:

Hierarchy Links Use these links to verify the lo-
cation of the currently displayed topic within its 
chapter and to jump to relevant higher-level 
topics, including the Main Topic.

Show in Contents Button Use this button to lo-
cate the current topic in the Contents.

Previous Topic and Next Topic Buttons  Use 
these buttons to browse through the topics in 
the order in which they appear in the Contents.

Print Click this button to print one or more top-
ics. For more information, see “Printing Help 
Topics” on page 39. 
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Additional Pane Information

The Topic pane contains information about a 
specific aspect of your Pro Tools editing applica-
tion. The Help system includes task-oriented 
procedures as well as background and reference 
information. Note the following features of 
these topics:

• At the bottom of many topics are links to 
other relevant subjects.

• You might also see icons and information in 
Notes and Warnings that provide important 
details about the topic.

Hierarchy Links

The top area of each page of the Help system in-
cludes links that indicate the location of the cur-
rently displayed topic within its book and chap-
ter and let you jump to relevant higher-level 
topics, including the Main Topics for the chap-
ter.

Using the Contents and Index 
Tabs
The left pane of the Help browser is the display 
area for most of the Help system’s main naviga-
tion tools, including the Contents and Index 
tabs.

Contents Tab

The Contents tab displays a complete hierarchi-
cal list of all topics in the Help system. By de-
fault, the Contents tab shows only links to the 
first topic in each chapter. This lets you quickly 
see the overall organization of the Help system. 

You can expand and collapse the contents to 
view the logical organization of the Help system, 
and you can move to any topic by clicking its en-
try in the Contents.



The contents automatically synchronizes with 
the topic that currently displays in the Topic 
pane. When you move to a new topic, the con-
tents expands to the level of that topic and high-
lights the topic. This feature, like the hierarchy 
links at the top of each topic, lets you see exactly 
where the current topic is positioned within the 
logical organization of the Help system.

To display a topic from the contents:

 Click the Contents tab, and then click a topic’s 
entry in the contents. 

To expand or close a section in the contents:

 Click the Contents tab, and then click an 
opener or a book icon to the left of a link. 

Index Tab

The Index provides an alphabetized list of en-
tries similar to the index of a printed book. 

If Java is enabled in your browser, the Index dis-
plays as a dynamic index where the listing 
scrolls as you type a word in the text box. If you 
do not have Java enabled in your browser, or if 
your browser does not support Java implemen-
tations, a JavaScript version of the index dis-
plays, which lets you scroll manually through 
the entries.

To find topics by using the Index tab:

1  Click the Index tab. 

2  Click the first character of the topic in the Nu-
merics, Letters, Symbols list.

3  Scroll through the index. 

To view the topic associated with an index entry:

 Click the index entry.
Using the Search Tab
The Search tab lets you search the entire text of 
the Help system for one or more words and then 
lists the topics that include those words. The list 
of results is ranked, placing the topics that the 
Search feature considers most likely to be rele-
vant at the top of the list.

When you search for text, the text string auto-
matically highlights by default. You can turn 
these highlights off. You can also stop display-
ing highlights after a search by using the Back 
and Forward buttons to go to a different topic. 
When you come back to your searched topic, the 
highlights no longer display.

For more guidelines on using the Search feature 
effectively, see “Search Guidelines” on page 38.

To perform a basic search:

1  Click the Search tab. 

2  In the Search pop-up menu (located below the 
Search text box), click whether you want to 
search in “All Available Books” or a specific book 
(such as Pro Tools Shortcuts).

3  In the Search text box, type the word or words 
that you want to find. 

4  Click Go.

A list of topics and ranking numbers appears.
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Additional Search Information

The Search feature provides the best combina-
tion of usefulness and speed. To use Search suc-
cessfully, you should understand the following 
aspects of the Search feature:

• The Search feature uses a database of valid 
words. This database includes all words that 
are significant for identifying topics and ex-
cludes all other words. When you type words 
in the search text box, the system ignores any 
invalid words that you have typed and 
searches for valid words.

• The Search feature cannot search for words in 
a certain order. For example, if you type “TIFF 
graphics import” as a search entry, Search dis-
plays all topics that contains these three words 
regardless of their location in the topic. The 
results include topics where the three words 
appear together as a phrase, and also topics 
where the three words are scattered through-
out the topic.

• The Search feature cannot distinguish be-
tween words that are similar but not identical. 
For example, if you type “capture” as a search 
entry, Search displays topics that include that 
word, but it does not find topics that include 
related words such as “captures” or “captur-
ing.” If a search for a word fails to produce 
useful results, you might be more successful if 
you search again using one of the related 
words.
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Search Guidelines
Use the following rules for formulating search 
queries: 

• Searches are not case-sensitive, so you can 
type your search in uppercase or lowercase 
characters. 

• You can search for any combination of letters 
(a-z) and numbers (0-9). 

• Punctuation marks (such as the period, colon, 
semicolon, comma, and hyphen) are ignored 
during a search, unless they are part of the 
topic (such as .WAV). 

• You can search for a literal phrase by using 
quotation marks. You cannot search for quota-
tion marks. 

The Help system’s search functionality has a 
limitation when the Help system is running 
in the Safari browser. You can perform one 
search successfully, but subsequent searches 
do not return results until you clear the Sa-
fari cache. You can do this by quitting Safari 
and relaunching the Help, or by emptying the 
cache directly (select Safari > Empty Cache, 
or use the Command+Option+E keyboard 
shortcut). Other browsers, for example 
Mozilla Firefox, do not have this limitation.

Remember that Help includes a comprehen-
sive index. If Search does not produce useful 
results for a particular topic, you can often 
find the specific information you need 
quickly by using the index.



Printing Help Topics
You can print Help topics if you need to refer to 
them during a complicated procedure or to use 
for reference later.

See your browser documentation for more infor-
mation on print options.

To print a Help topic:

1  Click the topic pane within the browser win-
dow that you want to print.

2  Do one of the following:

• Click the Print button in the Topic pane.

• Right-click in the Topic pane and select 
Print.

• Select File > Print.

3  Select the print options.

4  Click Print.

On Mac OS X systems, the print button does 
not appear in Internet Explorer 5.2.

Topics that you print from Help have lim-
ited page layout and formatting features. If 
you want to print a higher quality version of 
Help information, Avid recommends that 
you print all or part of the PDF version of 
the appropriate guide. For a list of all Pro 
Tools guides and how to access them, see 
“Pro Tools Documentation” on page 3.
Copying from a Help Topic
You can copy information from a Help topic for 
use in another document (such a text file).

To copy information from a Help topic to another 
document:

1  Open or click the topic to make it active.

2  Select the text that you want to copy.

3  Choose Edit > Copy.

4  Place the mouse pointer in another applica-
tion, such as a word processing application.

5  Choose Edit > Paste to paste the copied text 
into a document. (You can also paste the text 
into the Search text box.)
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Chapter 5: Pro Tools Systems
There are two types of Pro Tools software:

Pro Tools 

You can run Pro Tools software with qualified 
Avid audio interfaces (such as Eleven® Rack, 
003®, Mbox® Pro, or M-Audio® Fast Track®). You 
can also run Pro Tools software with the built-in 
audio available on Mac computers (using Core 
Audio), or running with third-party audio inter-
faces that support Core Audio (Mac) or ASIO 
(Windows) drivers.

Pro Tools HD 

You can run Pro Tools HD software on 
Pro Tools|HD or HD Native hardware.

Pro Tools Software
Pro Tools software provides the following capa-
bilities (depending on your hardware configura-
tion:

• Up to 32 channels of I/O depending on your 
system and the number of audio hardware 

For a list of qualified audio interfaces and 
computers, visit 
www.avid.com/compatibility.
• Up to a total of 96 voiced mono or stereo audio 
tracks (up to 128 voiceable audio tracks) per 
session:

• Playback of up to 96 tracks, or a combina-
tion of playing back and recording up to 96 
tracks, mono or stereo, at 44.1 kHz and 
48 kHz

• Playback of up to 48 tracks, or a combina-
tion of playing back and recording up to 48 
tracks, mono tracks or stereo, at 88.2 kHz 
and 96 kHz

• Playback of up to 24 tracks, or a combina-
tion of playing back and recording up to 24 
tracks mono or stereo, at 176.4 kHz and 192 
kHz

• Up to 128 Auxiliary Input tracks

• Up to 64 Master Fader tracks

• Up to 512 MIDI tracks

• Up to 64 Instrument tracks

• A single QuickTime video track

• 16-bit or 24-bit audio resolution, at sample 
rates up to 192 kHz

• Automatic Delay Compensation (up to 16,383 
samples at 48 kHz)

• Non-destructive, random-access editing and 
mix automation

• Audio processing with up to 10 real-time plug-
ins per track, depending on your computer’s 
capabilities

• Up to 10 hardware inserts per track
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• Up to 10 sends per track

• Up to 256 internal mix busses for routing and 
mixing

Supported Hardware 
Configurations with Pro Tools 
Software
Pro Tools software supports the following hard-
ware configurations:

003 Family

Pro Tools software with 003 family hardware 
provides up to 18 channels of audio input and 
output at sample rates up to 48 kHz, and up to 
10 channels of audio input and output at sample 
rates up to 96 kHz. A 003 system includes:

• Pro Tools software

• One of the following:

• 003 audio and MIDI interface (with 
control surface)

• 003 Rack+ audio and MIDI interface

• 003 Rack audio and MIDI interface

Digi 002 Family

Pro Tools software with Digi 002 family hard-
ware provides up to 18 channels of audio input 
and output at sample rates of 44.1 or 48 kHz, 
and up to 10 channels of audio input and output 
at sample rates up to 96 kHz. A Digi 002™ system 
includes:

• Pro Tools software

For more information about the I/O 
capabilities of your audio interface with 
Pro Tools, see the documentation that 
came with your audio interface.
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• One of the following:

• 002 audio and MIDI interface (with 
control surface)

• Digi 002 Rack audio and MIDI interface

Eleven Rack

Pro Tools software with Eleven Rack hardware 
provides up to 8 channels of audio input and up 
to 6 channels of audio output at sample rates of 
88.2 or 96 kHz. An Eleven Rack system includes:

• Pro Tools software

• Eleven Rack audio and MIDI interface, and 
guitar effects processor

Mbox Family

An Mbox system includes:

• Pro Tools software

• One of the following:

• Mbox Pro (up to 8 channels of audio input 
and output at sample rates of 44.1 or 
48 kHz; and up to 6 channels of audio input 
and output at sample rates of 88.2 or 
96 kHz) or Mbox 2 Pro audio and MIDI in-
terface (up to 6 channels of audio input and 
up to 8 channels of audio output at sample 
rates of 44.1 or 48 kHz; and up to 4 chan-
nels of audio input and up to 6 channels of 
audio output at sample rates of 88.2 or 96 
kHz)

• Mbox (3rd generation) or Mbox 2 audio and 
MIDI interface (up to 2 channels of audio 
input and output at sample rates of 44.1 or 
48 kHz)

• Mbox Mini or Mbox 2 Mini audio interface 
(up to 2 channels of audio input and output 
at sample rates of 44.1 or 48 kHz)

• Mbox 2 Micro audio interface (stereo out-
put at sample rates of 44.1 or 48 kHz only)



M-Audio Interfaces

Pro Tools software with M-Audio hardware pro-
vides up to 32 channels of audio input and out-
put at sample rates up to 192 kHz depending on 
your audio interface. Pro Tools M-Audio sys-
tems includes:

• Pro Tools software

• A qualified M-Audio interface

Core Audio

Pro Tools software with Core Audio–compatible 
hardware provides up to 32 channels of audio 
input and output at sample rates up to 192 kHz 
depending on your audio interface. A Pro Tools 
Core Audio system includes:

• Pro Tools software

• A third-party audio interface with sup-
ported Core Audio drivers (including 
Built-in Mac audio hardware)

ASIO

Pro Tools software with ASIO-compatible hard-
ware provides up to 32 channels of audio input 
and output at sample rates up to 192 kHz de-
pending on your audio interface. A Pro Tools 
ASIO system includes:

• Pro Tools software

• A third-party audio interface with sup-
ported ASIO drivers

Processing Capacity

The total processing capacity of a Pro Tools sys-
tem depends on the processing power of your 
computer. Contact your dealer or visit 
www.avid.com for the latest system require-
ments and compatibility information.

For a current list of qualified M-Audio 
interfaces, visit the Avid website 
(www.avid.com).
Pro Tools Capabilities with Different 
Hardware Configurations

Pro Tools supports up to 32 channels of audio 
input and output, but the available input and 
output capabilities with Pro Tools varies de-
pending on your audio interfaces. For informa-
tion about the input and output capabilities of 
your audio interface, consult the documentation 
that came with your hardware.

If you open a Pro Tools session created on a 
Pro Tools HD system that contains more than 
the number of tracks supported on the your 
Pro Tools system, audio tracks beyond the sys-
tem’s voiceable track limit will be automatically 
set to inactive.

Pro Tools HD with 
Pro Tools|HD Hardware
Each system requires at least one Avid HD audio 
interface (sold separately). Pro Tools|HD sys-
tems can be expanded by adding Pro Tools|HD 
cards to increase track count and the amount of 
plug-in and mixer processing, and by adding ad-
ditional audio interfaces.

Pro Tools HD Software 
Capabilities with Pro Tools|HD 
Hardware
Pro Tools HD with Pro Tools|HD hardware on 
Mac or Windows provides the following capabil-
ities:

• Up to 160 channels of I/O depending on your 
system, and the number and type of installed 
audio interfaces

For details on transferring session mate-
rial between Pro Tools HD and Pro Tools 
systems, see “Sharing Sessions Created on 
Different Pro Tools Systems” on page 398.
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• Up to a total of 192 voiced audio tracks (up to 
768 voiceable audio tracks)

• Up to 512 Auxiliary Input tracks

• Up to 64 Master Fader tracks

• Up to 128 VCA Master tracks

• Up to 512 MIDI tracks

• Up to 128 Instrument tracks

• Up to 64 video tracks per session

• 16-bit, 24-bit, or 32-bit floating point audio 
resolution, at sample rates up to 192 kHz

• Non-destructive, random-access editing and 
mix automation

• Up to 7.1 surround mixing capability

• Automatic Delay Compensation (up to 4,095 
samples at 48 kHz)

• No latency monitoring

• Audio processing with up to 10 inserts per 
track (in any combination of real-time plug-in 
and hardware inserts), depending on your 
computer’s capabilities, and the number and 
type of installed audio interfaces

• Up to 10 sends per track

• Up to 256 internal mix busses for routing and 
mixing

Pro Tools|HD systems are available in the 
following configurations:

Pro Tools|HD 1

Includes:

• Accel Core (for PCIe) card or 
HD Core™ (for PCI) card

• Pro Tools HD software
Pro Tools Reference Guide
Pro Tools|HD 2 Accel

Includes:

• Accel Core (for PCIe) card or 
HD Core (for PCI) card

• HD Accel card 

• Pro Tools HD software

Pro Tools|HD 3 Accel

Includes:

• Accel Core (for PCIe) card or
HD Core (for PCI) card

• Two HD Accel cards

• Pro Tools HD software

Pro Tools|HD 2

Includes:

• HD Core card

• HD Process™ card

• Pro Tools HD software

Pro Tools|HD 3

Includes:

• HD Core card

• Two HD Process cards

• Pro Tools HD software

Expanded Pro Tools|HD Systems

You can expand your Pro Tools|HD system by 
adding Pro Tools|HD cards to your computer, 
either directly in the computer or using an ex-
pansion chassis. Expanding your Pro Tools sys-
tem provides increased track counts, adds to the 
amount of possible plug-in and mixer process-
ing, and lets you connect additional audio inter-

Pro Tools|HD PCI cards require a PCI to PCIe 
expansion chassis. For more information, see 
the Expanded Systems Guide.



faces. With support for up to 7 Pro Tools|HD 
cards in a single system, a Pro Tools|HD system 
can support up to 160 channels of simultaneous 
input and output. 

Pro Tools HD Software with 
HD Native Hardware
Each system requires at least one Avid HD audio 
interface (sold separately). HD Native systems 
can be expanded by adding additional HD audio 
interfaces.

Pro Tools HD Software 
Capabilities with HD Native 
Hardware
Pro Tools HD systems with HD Native hardware 
consist of the following:

• HD Native PCIe card

• Pro Tools HD software or Pro Tools software

• An authorized iLok for running Pro Tools HD 
or Pro Tools

• One or more Avid HD audio interfaces (sold 
separately)

• DigiLink Mini cable for connecting the HD 
Native card to an audio interface

• A MIDI interface (optional)

For more information, see the Expanded 
Systems Guide.

For detailed information about installing 
HD Native hardware, see the HD Native In-
stallation Guide. 
Pro Tools HD Software 
Capabilities with HD Native 
Hardware
Pro Tools HD with HD Native hardware on Mac 
or Windows provides the following capabilities:

• Up to 64 channels of I/O depending on your 
system, and the number and type of installed 
audio interfaces

• Up to a total of 256 voiced audio tracks (up to 
768 voiceable audio tracks):

• Up to 256 voices at 44.1 kHz or 48 kHz

• Up to 128 voices at 88.2 kHz or 96 kHz

• Up to 64 voices at 176.4 kHz or 192 kHz

• Up to 512 Auxiliary Input tracks

• Up to 64 Master Fader tracks

• Up to 128 VCA Master tracks

• Up to 512 MIDI tracks

• Up to 128 Instrument tracks

• Up to 64 video tracks per session

• 16-bit, 24-bit, or 32-bit floating point audio 
resolution, at sample rates up to 192 kHz

• Non-destructive, random-access editing and 
mix automation

• Up to 7.1 surround mixing capability

• Automatic Delay Compensation (up to 16,348 
samples at 48 kHz)

• FPGA-based low latency monitoring (LLM)

• Audio processing with up to 10 inserts per 
track (in any combination of real-time, host-
based plug-in and hardware inserts), depend-
ing on your computer’s capabilities, and the 
number and type of installed audio interfaces

• Up to 10 sends per track

• Up to 256 internal mix busses for routing and 
mixing
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Supported Avid HD Audio 
Interfaces
The following Avid HD audio interfaces are 
compatible with Pro Tools|HD and HD Native 
systems:

• HD I/O

• HD OMNI

• HD MADI

• 192 I/O

• 192 Digital I/O

• 96 I/O

• 96i I/O

Maximum I/O Configuration with Pro Tools|HD

Pro Tools|HD systems support up to a maximum 
combination of ten total of the following audio 
interfaces: 

• HD OMNI (only 1 HD OMNI interface is 
supported in a single Pro Tools|HD system)

• HD I/O (up to 10 HD I/O interfaces can be 
used simultaneously—requires 5 HD cards)

• HD MADI (up to 3 HD MADI interfaces can 
be used simultaneously—requires 6 HD 
cards)

• 192 I/O (up to 10 192 I/O interfaces can be 
used simultaneously—requires 5 HD cards)

• 192 Digital I/O (up to 10 192 Digital I/O in-
terfaces can be used simultaneously—re-
quires five HD cards)

• 96 I/O (up to 10 96 I/O interfaces can be 
used simultaneously—requires 5 HD cards)

• 96i I/O (up to 5 96i I/O interfaces can be 
used simultaneously—requires 5 HD cards)

Pro Tools|HD and HD Native systems require 
at least one HD I/O, HD OMNI, HD MADI, 
192 I/O, 192 Digital I/O, 96 I/O, or 96i I/O.
Pro Tools Reference Guide
Maximum I/O Configuration with HD Native

HD Native supports up to a maximum combina-
tion of up to 4 total of the following audio inter-
faces: 

• HD OMNI (only 1 HD OMNI interface is 
supported in a single HD Native system)

• HD I/O (up to 4 HD I/O interfaces can be 
used simultaneously)

• HD MADI (full connectivity with one 
HD MADI interface is possible when both 
DigiLink ports of the HD MADI are con-
nected to both DigiLink ports on the HD 
Native card)

• 192 I/O (up to 4 192 I/O interfaces can be 
used simultaneously)

• 192 Digital I/O (up to 4 192 Digital I/O in-
terfaces can be used simultaneously)

• 96 I/O (up to 4 96 I/O interfaces can be used 
simultaneously)

• 96i I/O (up to 2 96i I/O interfaces can be 
used simultaneously)



Playback, Recording, and Voice Limits with Pro Tools HD
The table below lists the audio playback, recording, and voiceable track limits with Pro Tools HD soft-
ware with Pro Tools|HD, HD Native, Core Audio, and ASIO hardware (including Pro Tools with Com-
plete Production Toolkit). Playback and recording voices refers to the number of unique simultaneous 
playback and record tracks on your system. Total voiceable tracks refers to the maximum number of 
audio tracks that can share the available voices on your system. (Mono tracks take up one voice. Ste-
reo and multichannel tracks take up one voice per channel.)

With Pro Tools|HD systems, voice limits are dependent on the session sample rate and the number of 
DSP chips dedicated to the system’s Playback Engine. Pro Tools HD can open sessions with up to 768 
audio tracks, but any audio tracks beyond that system’s voiceable track limit will be automatically set 
to Voice Off.
Pro Tools HD audio playback, recording and voice limits 
by hardware configuration
Core System Type Maximum I/O
Sample 
Rate (kHz)

Playback and 
Recording 
Voices 
(Mono Tracks of 
Simultaneous 
Playback and 
Recording)

Total 
Voiceable 
Tracks

Pro Tools|HD 1 32 channels 44.1/48 96 768

88.2/96 48 768

176.4/192 24 768

Pro Tools|HD 2,
Pro Tools|HD 3,
or any expanded 
Pro Tools|HD system

64 channels (HD 2)
96 channels (HD 3)
or up to 
160 channels (HD 5)

44.1/48 192 768

88.2/96 96 768

176.4/192 36 768

HD Native 64 channels 44.1/48 256 768

88.2/96 128 768

176.4/192 64 768

Core Audio and ASIO 
(Pro Tools HD or 
Pro Tools with 
Complete 
Production Toolkit)

32 channels 44.1/48 256 768

88.2/96 128 768

176.4/192 64 768
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Avid HD Audio Interfaces
The following table lists the input and output capabilities of the various Avid HD audio interfaces for 
Pro Tools|HD and HD Native systems. Each Pro Tools|HD card supports a maximum of 32 channels 
of I/O. The HD Native card supports a maximum of 64 channels of I/O. To record and play audio with 
Pro Tools HD with any of these hardware configurations, you must have at least one Avid HD audio 
interface connected to the first port of the first card in the system.

Avid HD audio interface channel capabilities
Pro Tools Reference Guide
Interface Type
Number of I/O
Channels

Sample 
Rates (kHz)

A/D
Conversio
n

D/A
Conversio
n

Digital I/O

HD I/O 16 in/16 out 44.1, 48, 88.2, 
96, 176.4, 192

24-bit 24-bit 24-bit

HD OMNI 8 in/8 out 44.1, 48, 88.2, 
96, 176.4, 192

24-bit 24-bit 24-bit

HD MADI 64 in/64 out 44.1, 48, 88.2, 
96, 176.4, 192

None None 24-bit

192 I/O 8 in/8 out 44.1, 48, 88.2, 
96, 176.4, 192

24-bit 24-bit 24-bit

192 Digital I/O 8 in/8 out 44.1, 48, 88.2, 
96, 176.4, 192

None None 24-bit

96 I/O 8 in/8 out 44.1, 48, 88.2, 
96

24-bit 24-bit 24-bit

96i I/O 16 in/2 out 44.1, 48, 88.2, 
96

24-bit 24-bit 24-bit



HD OMNI Audio Interface
HD OMNI is a professional digital audio inter-
face designed for use with Avid HD systems. HD 
OMNI provides a compact preamp, monitoring, 
and I/O solution for music production and re-
cording, and post production studios.

HD OMNI Features

HD OMNI provides up to 8 discrete channels of 
Pro Tools input and output, with 4-segment 
LED meters for input or output (selectable). 

Analog I/O

• 24-bit analog-to-digital (A/D) and digital-to-
analog (D/A) converters, with support for 
sample rates up to 192 kHz

• 2 high-quality Mic/DI preamps (Channels 
1–2)

• 2 combined XLR and 1/4-inch TRS front panel 
inputs for microphone and instrument level 
input

• 2 XLR back panel microphone inputs

• 2 1/4-inch TRS Send and 2 1/4-inch TRS Re-
turn back panel jacks for hardware inserts on 
channels 1 and 2

• 4 analog TRS line level back panel inputs 
(Channels 1–4)

HD OMNI provides multiple analog input 
connections, but only provides up to four 
channels of simultaneous analog input for 
Pro Tools.
• Soft Clip and Curv limiting circuits to protect 
against clipping on analog input

• 8 channels of analog back panel output using a 
DB-25 breakout cable (sold separately) with 
variable output gain

• 2 channels of analog back panel output using 
TRS (Mirrors channels 1–2 or 7–8 on DB-25 
connector)

• Front panel stereo 1/4-inch headphone jack

Digital I/O

• 8 channels of AES/EBU output (up to 192 kHz 
Single Wire) using a DB-25 breakout cable 
(sold separately)

• 2 channels of AES/EBU XLR input (up to 
192 kHz Single Wire)

• 2 channels of S/PDIF RCA input and output 
(up to 192 kHz)

• 8 channels of ADAT TOSLINK input and out-
put

• Support for ADAT S/MUX Optical for sample 
rates of 88.2 kHz, 96 kHz, 176.4 kHz, and 
192 kHz

• Support for two channels of S/PDIF Optical 
with sample rates of up to 96 kHz

• Real-time sample rate conversion (SRC) on 
Digital Inputs 1–2 of either AES/EBU, S/PDIF, 
or Optical (S/PDIF)

SRC is not supported with ADAT S/MUX.
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Monitoring

• An additional stereo “CUE” output path in 
Pro Tools® for headphone monitoring from 
the front panel headphone jack

• Front panel Control Room (MAIN/ALT) and 
Headphone monitoring volume control

• Flexible monitoring with fold-down from all 
stereo and surround formats (up to 7.1 sur-
round)

• Input mixer for low latency direct monitoring 
of a variety of incoming signals (configured in 
the Pro Tools Hardware Setup)

Synchronization

• Loop Sync input and output for connecting 
additional Pro Tools|HD interfaces and 
peripherals

• External Clock input and output for synchro-
nizing HD OMNI with external Word Clock 
devices

HD I/O Audio Interface
HD I/O is a multichannel digital audio interface 
designed for use with Avid HD systems. HD I/O 
features extremely high quality 24-bit analog-
to-digital (A/D) and digital-to-analog (D/A) 
converters, and supports sample rates of up to 
192 kHz. 

HD I/O comes in three standard configurations:

• 8 x 8 x 8 (8 analog in, 8 analog out, and 8 
digital in and out)

• 16 x 16 analog in and out

• 16 x 16 digital in and out

You can also add or remove HD I/O Analog Ex-
pansion cards (ADC and DAC) and HD I/O Dig-
ital Expansion cards for custom configurations. 

For more information, see the HD OMNI 
Guide.
Pro Tools Reference Guide
HD I/O Features

HD I/O provides up to 16 discrete channels of 
Pro Tools input and output, with 4-segment 
LED meters for input and output. 

Analog I/O

• Up to sixteen channels of 24-bit D/A and A/D 
converters for superior analog input and out-
put at sample rates of 44.1 kHz, 48 kHz, 
88.2 kHz, 96 kHz, 176.4 kHz, and 192 kHz 
with Analog In and Analog Out HD I/O cards

• Soft Clip and Curv limiting circuits to protect 
against clipping on analog input

Digital I/O

• Up to sixteen channels of 24-bit digital I/O, 
using AES/EBU, TDIF DB-25, or Optical at 
sample rates of 44.1, 48, 88.2, 96, 176.4, and 
192 kHz with a Digital HD I/O card

• Real-time sample rate conversion on digital 
inputs with a Digital I/O card (up to sixteen 
channels of AES/EBU, Optical, or TDIF)

• Support for S/MUX Optical for sample rates of 
88.2 kHz and higher

• Support for 2 channels of S/PDIF Optical (en-
closed) with sample rates of up to 96 kHz

• 2 channels of AES/EBU I/O (enclosed) with 
support for sample rates up to 192 kHz

• 2 channels of 24-bit-capable S/PDIF I/O (en-
closed) with support for sample rates up to 
192 kHz

Synchronization

• Loop Sync input and output for connecting ad-
ditional Avid HD audio interfaces and periph-
erals

• External Clock input and output for synchro-
nizing HD I/O with external Word Clock de-
vices



Expandability

• Optional addition of I/O cards to expand ana-
log or digital I/O

• Simultaneous use of multiple Avid HD audio 
interfaces to further expand system input and 
output

HD MADI Digital Audio Interface
HD MADI is a 64-channel, digital audio inter-
face designed for use with Avid HD systems. 
HD MADI supports the Multichannel Audio 
Digital Interface (MADI) format and sample 
rates of up to 192 kHz. HD MADI provides sim-
plified connectivity between your Avid HD sys-
tem and MADI-compatible audio equipment, 
such as routers, digital mixing consoles, and 
converters.

HD MADI Features
• 2 MADI Optical and Coaxial inputs and 2 

MADI Optical and Coaxial outputs for up to 64 
discrete channels of digital input and output 
(32 channels per DigiLink Mini port)

• Supports sample rates of 44.1, 48, 88.2, 96, 
176.4, and 192 kHz

• 24- or 16-bit resolution

• Sample Rate Conversion (SRC) on input or 
output

• Front panel clock and SRC indicators

• Front panel signal present LEDs for input and 
output

• BNC Word Clock I/O for synchronizing HD 
MADI with external 1x Word Clock

• BNC Loop Sync I/O for synchronizing 
HD MADI with additional Avid HD audio 
interfaces and peripherals (such as HD I/O, 
HD OMNI, or SYNC HD)

For more information, see the HD I/O Guide.
• Dedicated BNC Word Clock input and XLR 
AES/EBU input (clock input only) for external 
MADI synchronization (when using SRC on 
output)

• Clock support for the following formats: Inter-
nal, Loop Sync, Word Clock, AES/EBU, and 
MADI

• Varispeed modes (supports both 64- and 56-
channel standards)

192 I/O Audio Interface
192 I/O is a multichannel digital audio interface 
designed for use with Avid HD systems. 192 I/O 
features high quality 24-bit analog-to-digital 
(A/D) and digital-to-analog (D/A) converters, 
and supports sample rates of up to 192 kHz. 

You can also add or remove analog cards (ADC 
and DAC) and digital cards for custom configu-
rations. 

192 I/O Features
• Supports sample rates up to 192 kHz

• Supports both analog and digital connections, 
including AES/EBU, S/PDIF, TDIF, and ADAT 
Optical:

• Digital (Digital I/O Card): 8 channels, 
DB-25 (AES/EBU and TDIF), or one pair of 
Lightpipe (ADAT Optical) connectors; Ex-
pandable up to 16 of channels digital I/O 
with the addition of the 192 Digital expan-
sion card

• Analog: 8 channels, DB-25 (balanced) con-
nectors, inputs selectable between +4 dBu 
or –10 dBV, outputs +4 dBu only; Expand-
able up to 16 analog inputs or 16 outputs 
using an optional 192 AD or 192 DA expan-
sion card, respectively

For more information, see the HD MADI 
Guide.
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• Digital (Enclosure): 2 channels, XLR 
(AES/EBU) connectors; 2 channels RCA 
(S/PDIF) connectors

• Optical (Enclosure): 8 channels, one pair of 
Lightpipe (ADAT Optical) connectors 
(switchable to 2 channels, S/PDIF)

• Loop Sync In and Out for connecting Avid HD 
interfaces and peripherals

• External Clock In and Out receive or send 1x 
Word clock

192 Digital I/O Audio Interface
192 Digital I/O is a multichannel digital audio 
interface designed for use with Avid HD sys-
tems, and supports sample rates of up to 
192 kHz. 

192 Digital I/O Features
• Supports sample rates up to 192 kHz

• Supports digital connections, including 
AES/EBU, S/PDIF, TDIF, and ADAT Optical:

• Digital (2 Digital I/O Cards): 16 channels, 
DB-25 (AES/EBU and TDIF), or two pairs of 
Lightpipe (ADAT Optical) connectors

• Digital (Enclosure): 2 channels, XLR 
(AES/EBU) connectors; 2 channels RCA 
(S/PDIF) connectors

• Optical (Enclosure): 8 channels, one pair of 
Lightpipe (ADAT Optical) connectors (se-
lectable to 2 channels, S/PDIF)

• Loop Sync In and Out for connecting Avid HD 
interfaces and peripherals

• External Clock In and Out receive or send 1x 
Word clock

For more information, see the 192 I/O Guide.

For more information, see the 192 Digital I/O 
Guide.
Pro Tools Reference Guide
96 I/O Audio Interface
96 I/O is a multichannel digital audio interface 
designed for use with Avid HD systems. 96 I/O 
features high quality 24-bit analog-to-digital 
(A/D) and digital-to-analog (D/A) converters, 
and supports sample rates of up to 96 kHz. 

96 I/O Features
• Supports sample rates up to 96 kHz

• Supports analog and digital connections, in-
cluding AES/EBU, S/PDIF, and ADAT optical:

• Analog: 8 channels, 1/4-inch TRS (balanced 
or unbalanced) connectors, +4 dBu or 
–10 dBV

• Digital: 2 channels, XLR (AES/EBU) con-
nectors; 2 channels, RCA (S/PDIF) connec-
tors

• Optical: 8 channels, one pair of Lightpipe 
(ADAT Optical) connectors (switchable to 2 
channels, S/PDIF)

• External Clock In and Out receive or send 
1x Word clock

96i I/O Audio Interface
96i I/O is a multichannel digital audio interface 
designed for use with Avid HD systems. 96i I/O 
features high quality 24-bit analog-to-digital 
(A/D) and digital-to-analog (D/A) converters, 
and supports sample rates of up to 96 kHz. 

For more information, see the 96 I/O Guide.



96i I/O Features
• Supports sample rates up to 96 kHz

• 16 discrete channels of input, and 2 channels 
of output, with 4-segment LED meters on each 
channel. Audio inputs and outputs include:

• 16 channels of 24-bit, 96-kHz capable ana-
log input, with adjustable input sensitivity

• 2 channels of 24-bit, 96-kHz capable analog 
output, with selectable operating level

• 2 channels of 24-bit, 96 kHz-capable digital 
S/PDIF RCA input and output

• Loop Sync In and Out for connecting Avid HD 
interfaces and peripherals

• External Clock In and Out receive or send 1x 
Word clock

Additional Pro Tools 
Hardware Options
Pro Tools software systems also supports the 
following Pro Tools hardware options.

• PRE (Eight-channel microphone preamp)

• Eleven Rack (guitar processor)

• MIDI I/O (10 x 10 USB MIDI interface)

• Worksurfaces and MIDI control surfaces:

• Avid Artist Series controllers 

• Avid Pro Series controllers

• C|24

• Command|8

• M-Audio Keyboards (such as Axiom Pro)

• Third-party MIDI controllers (such as 
Mackie HUI, Peavey PC-1600, or CM Labs 
Motor Mix)

For more information, see the 96i I/O Guide.
Additional Pro Tools HD 
Hardware Options
Pro Tools HD also supports the following Avid 
HD hardware options.

• Synchronization peripherals (Pro Tools|HD 
and HD Native systems only):

• SYNC HD

• SYNC I/O

• PRE (Eight-channel microphone preamp)

• Eleven Rack (guitar processor)

• MIDI I/O (10 x 10 USB MIDI interface)

• Worksurfaces and MIDI control surfaces:

• Avid Artist Series controllers 

• Avid Pro Series controllers

• C|24

• Command|8

• D-Command

• D-Control

• M-Audio Keyboards (such as Axiom® Pro)

• Surround Panner Option

• Third-party MIDI controllers (such as 
Mackie HUI, JL Cooper CS-10, CM Labs 
Motor Mix, or Peavey PC-1600)

Pro Tools HD Software 
Options
Pro Tools|HD Systems with HEAT

Pro Tools|HD systems that have been upgraded 
with the HEAT software option. HEAT (Har-
monically Enhanced Algorithm Technology) is a 
paid software option that adds “analog color” to 
Pro Tools|HD systems. For more information, 
see the HEAT Software Option Guide.
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Pro Tools|HD and HD Native Systems with 
MachineControl

The MachineControl™ software option for 
Pro Tools HD is supported with Pro Tools|HD 
and HD Native systems. MachineControl is a 
paid software option for Pro Tools HD that en-
ables serial communication with Sony® 9-pin 
compatible synchronizers, and video or audio 
machines. For more information, see the Ma-
chine Control Guide.

Pro Tools|HD and HD Native Systems with 
Satellite Link

The Satellite Link option for Pro Tools HD is 
supported with Pro Tools|HD and HD Native 
systems. Avid Satellite Link is a paid option that 
lets you link up to 12 Pro Tools systems (or up to 
11 Pro Tools systems and an Avid Media Com-
poser®, Avid Symphony Nitris DX®, or Video 
Satellite LE system) over an Ethernet network so 
that you can cue, play, and stop the transports, 
make play selections, and solo tracks across any 
of the systems from any linked workstation. For 
more information, see the Satellite Link Guide.

Pro Tools|HD and HD Native Systems with 
Video Satellite Link

The Video Satellite Link option for Pro Tools 
HD is supported with Pro Tools|HD and HD Na-
tive systems. Video Satellite is a paid software 
option for Pro Tools HD that lets you link your 
Pro Tools|HD or HD Native system with a sepa-
rate computer running Avid Media Composer or 
Symphony Nitris DX software for synced video 
playback, capture, and conversion. For more in-
formation, see the Video Satellite Guide.
Pro Tools Reference Guide
Pro Tools|HD and Pro Tools|HD Native Systems 
with Video Satellite LE

The Video Satellite LE option for Pro Tools HD 
is supported with Pro Tools|HD and HD Native 
systems. Video Satellite LE is a paid software op-
tion for Pro Tools HD, which uses a separate 
computer running Pro Tools software for syn-
chronized QuickTime HD video playback. For 
more information, see the Video Satellite LE 
Guide.

Pro Tools with VENUE Link

For Pro Tools systems that have been connected 
to VENUE systems using ethernet, VENUE Link 
provides Pro Tools and VENUE system integra-
tion and interoperability.

Complete Production Toolkit
The Complete Production Toolkit software op-
tion for Pro Tools provides increased voice and 
track counts, and surround mixing, editing, and 
automation capabilities that are equal to 
Pro Tools HD. More specifically, Complete Pro-
duction Toolkit enables the following features 
in Pro Tools:

• Surround mixing, editing, and automation up 
to 7.1 (depending on the output capabilities of 
your audio interface)

• Up to a total of 256 voiced audio tracks (up to 
768 voiceable audio tracks) 

Use the Avid Down Mixer plug-in for moni-
toring surround sessions in stereo with au-
dio interfaces that have fewer than six out-
puts.



• Playback of up to or a combination of play-
ing back and recording up to 256 mono 
tracks or 128 stereo tracks (256 available 
voices) at 44.1 kHz and 48 kHz

• Playback of up to or a combination of play-
ing back and recording up to 128 mono 
tracks or 64 stereo tracks (128 available 
voices) at 88.2 kHz and 96 kHz

• Playback of up to or a combination of play-
ing back and recording up to 64 mono 
tracks or 32 stereo tracks (64 available 
voices) at 176.4 kHz and 192 kHz

• Up to 512 Auxiliary Input tracks per session

• Up to 128 Instrument tracks

• Fixed RAM Disk Cache allocation options

• TrackInput monitoring

• Ability to use QuickPunch™ on up to 64 tracks

• TrackPunch recording

• DestructivePunch recording

• Advanced Group dialog:

• VCA assignments

• Attributes tab

• Follow globals

• Momentary Solo Latch Back/Forward com-
mands

• Custom Shuttle Lock speeds

• Numeric Keypad set to Shuttle mode

• AutoFades

Pro Tools with Complete Production Toolkit 
displays up to 768 tracks, with a simultane-
ous voice limit of 256 tracks. Tracks in ex-
cess of the 256-voice limit are made inac-
tive.
• Advanced editing features:

• Continuous Scrolling

• Scrub Trim tool

• Replace Clip command

• Convert Clip Gain and Track Volume Auto-
mation

• Coalesce Clip Gain and Track Volume Auto-
mation

• TCE Edit to Timeline Selection command

• Selection of alternate field recorder audio 
channels in the Pro Tools Timeline

• Expanding alternate field recorder chan-
nels to new tracks

• Advanced automation features:

• AutoJoin with Latch mode

• Touch/Latch mode

• Trim mode

• Composite automation playlist

• Copy track automation to sends

• AutoMatch

• Prime controls for writing automation in 
Latch mode

• Glide automation

• Trim automation

• Write automation to Start, End, or All

• Write automation to next breakpoint or 
punch point

• Overwrite or extend Mute automation

• Snapshot automation

• Preview automation

• Capture automation

• VCA Master track automation
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• Advanced video features:

• Multiple video tracks

• Multiple video playlists

• Video editing

• Preferences

• Back/Forward Amount

• Shuttle

• Auto Clip Fade In/Out Length

• Use Absolute Pan Linking

• Suppress Automation “Write To” Warning

• Allow Latch Prime in Stop

• Coalesce when Removing Slaves from VCA 
Group

• Standard VCA Logic for Group Attributes

• Include Sends in Trim Mode

• AutoGlide Time

• Coalesce Trim Automation Options

• D-Control support

• D-Command support

For information about using D-Control and 
D-Command worksurfaces with Pro Tools, 
see the D-Command and D-Control Guides.
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Checking For Software 
Updates
Pro Tools can check for Pro Tools application 
and plug-in updates, either automatically or 
manually. An internet connection is required to 
be able to check for updates. Approximately ev-
ery two weeks, Pro Tools checks online for any 
available application and plug-in updates.

If updates are available for Pro Tools or any 
plug-ins, Pro Tools reports what updates (if 
any) are available and how important the up-
dates are for your system. You can visit the Avid 
website to locate, download, and install the ap-
propriate updates for your Pro Tools system.

To manually check for updates:

1  Launch Pro Tools.

2  Choose Help > Check For Updates.

3  Do one of the following:

• If no updates are available, click OK.

– or –

• If updates are available, do one of the 
following:

• Click Details to launch your web browser 
and see what updates are available for 
download.

• Click Not Now if you do not want to review 
or download updates until later.

To disable automatic checking for updates:

 In the Software Update dialog, select the 
Do Not Check For Updates Automatically option.

To enable automatic checking for updates:

1  Choose Help > Check For Updates. 

2  In the Software Update dialog, deselect the 
Do Not Check For Updates Automatically option.



Chapter 6: System Setup
You can review and update the setup of your sys-
tem to ensure it is configured for your needs.

Starting Up or Shutting Down 
Your System
To ensure that the components of your 
Pro Tools system communicate properly with 
each other, you need to start them in a particular 
order.

Start up your Pro Tools system in this order:

1  Make sure all your equipment (including your 
computer) is off.

2  Lower the volume of all output devices in your 
system. 

3  For Pro Tools|HD systems with an expansion 
chassis, turn on the chassis.

4  Turn on any external hard drives. Wait approx-
imately ten seconds for them to spin up to speed.

5  Turn on any worksurfaces (such as 
D-Command) or control surfaces (such as 
Command|8).

6  Turn on any MIDI interfaces, MIDI devices, or 
synchronization peripherals.
7  Do one of the following, depending on your 
Pro Tools system:

• For Pro Tools|HD systems, with the volume 
of all output devices lowered, turn on your 
your audio interfaces (such as HD OMNI or 
192 I/O). Wait at least fifteen seconds for 
your system hardware to initialize.

– or –

• For Pro Tools systems that use hardware re-
quiring external power (such as 003), with 
the volume of all output devices lowered, 
turn on the hardware.

8  Turn on your computer. 

9  Launch Pro Tools or any third-party audio or 
MIDI applications. 

Shut down your Pro Tools system in this order:

1  Quit Pro Tools and any other running applica-
tions. 

2  Turn off or lower the volume of all output de-
vices in your system. 

3  Turn off your computer.

To quit Pro Tools, choose File > Exit 
(Windows) or Pro Tools > Quit (Mac).
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4  Do one of the following depending on your 
Pro Tools system:

• For Pro Tools|HD and HD Native systems, 
turn off your Pro Tools audio interfaces.

– or –

• For Pro Tools systems that use hardware re-
quiring external power (such as 003), turn 
off the hardware.

5  For Pro Tools|HD systems with an expansion 
chassis, turn off the chassis.

6  Turn off any MIDI interfaces, MIDI devices, or 
synchronization peripherals.

7  Turn off any worksurfaces (such as 
D-Command) or control surfaces (such as 
Command|8).

8  Turn off any external hard drives.

Checking a Pro Tools|HD or 
HD Native System with 
DigiTest
Before you use Pro Tools, you may want to run 
the DigiTest diagnostic application to ensure 
that all Pro Tools|HD cards in the system are 
recognized, installed in the proper order, and 
have valid TDM FlexCable connections. You can 
also use DigiTest to validate your HD Native 
card. See the DigiTest Guide for more informa-
tion.
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Configuring Pro Tools System 
Settings
Pro Tools lets you adjust the performance of 
your system by changing system settings that 
affect its capacity for processing, playback, and 
recording. These system settings are available in 
the Playback Engine (Setup > Playback Engine).

In most cases, the default settings for your sys-
tem provide optimum performance, but you 
may want to adjust them to accommodate large 
or processing-intensive Pro Tools sessions. 

Playback Engine for Pro Tools|HD system



Current Engine
In the Playback Engine dialog, Pro Tools lets 
you select the audio engine for use with your au-
dio interfaces. The available options are deter-
mined by which audio interfaces are connected 
and have compatible drivers installed. 

Changing the Current Engine setting can be use-
ful if you have multiple audio interfaces con-
nected to your computer with different routing 
configurations in your studio, or if you want to 
prepare a session for use with a specific inter-
face on a different system (for example you 
might want to prepare a session created on your 
Pro Tools|HD system for use with the built-in 
audio on your Mac laptop).

To select which audio engine for Pro Tools uses:

1  Choose Setup > Playback Engine.

Playback Engine for Pro Tools with Mbox (3rd 
generation)
2  From the Current Engine selector, select your 
audio interface:

• For Pro Tools|HD and HD Native systems, 
use the default setting of HD TDM or HD Na-

tive.

• For supported Pro Tools and M-Audio au-
dio interfaces (such as the Mbox Pro or Pro-
Fire 2626), selecting the name of the 
corresponding interface uses the Direct I/O 
engine for Pro Tools. 

• For third-party audio interfaces with com-
patible CoreAudio (Mac) or ASIO (Win-
dows), select the name of the 
corresponding Core Audio (Mac) or ASIO 
(Windows) compatible audio interface.

• On Mac systems, if you are using built-in 
audio, select any of the available built-in 
options for playback or select Pro Tools Ag-

gregate I/O for simultaneous input and out-
put with the built-in I/O hardware options.

3  Click OK.

When changing engines with a Pro Tools session 
open, Pro Tools must close and relaunch the ses-
sion to be able to initialize the new engine.

On Pro Tools|HD systems, changing engines re-
quires that you quit and relaunch Pro Tools for 
the new setting to take effect.

When changing engines on any Pro Tools 
system, you may need to reset the default I/O 
settings to match the selected audio inter-
face.
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Pro Tools Aggregate I/O

(Mac Only)

On Mac systems using Core Audio, you can use 
Pro Tools with the built-in audio inputs and 
outputs on your Mac by selecting any of the 
available built-in inputs and outputs, or by se-
lecting the Pro Tools Aggregate I/O option for us-
ing a combination of built-in inputs and outputs 
simultaneously (for recording and monitoring). 

You can configure the Input and Output options 
for Pro Tools Aggregate I/O in the Mac Audio 
Setup, which can be accessed from the Pro Tools 
Hardware Setup.

Selecting Pro Tools Aggregate I/O in the Playback 
Engine (Mac only)

If you need simultaneous input (recording) 
and output (playback and monitoring) with 
Pro Tools using the built-in audio options 
on Mac, use the Pro Tools Aggregate I/O op-
tion. If you only need to playback audio for 
editing and mixing, select the appropriate 
built-in audio output option.
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Hardware Buffer Size
The Hardware Buffer Size (H/W Buffer Size) in 
the Playback Engine controls the size of the buf-
fer used to handle host processing tasks such as 
processing with host-based, or “Native” plug-ins 
(AAX and RTAS).

• Lower Hardware Buffer Size settings are useful 
for improving latency issues in certain record-
ing situations or for improving certain system 
performance problems:

• On all Pro Tools systems, lower settings re-
duce MIDI-to-audio latency (such as when 
playing a virtual instrument live and moni-
toring the instrument’s output). Lower set-
tings can also improve screen response or 
the accuracy of plug-in and mute automa-
tion data.

• On host-based Pro Tools systems, lower 
settings reduce all input-to-output moni-
toring latency on any record-armed tracks 
or Auxiliary Input tracks with live inputs.

• On Pro Tools|HD systems, lower settings 
reduce monitoring latency that occurs on 
tracks that have one or more Native plug-
ins. Lower settings can also improve the ac-
curacy of MIDI track timing on systems 
without a MIDI interface that supports time 
stamping. Lower settings also improve 
MIDI track timing on tracks using MIDI 
virtual instruments that do not support 
time stamping.

• Higher Hardware Buffer Size settings are use-
ful for sessions that are using more Native 
plug-ins for playback. These settings allow for 
more audio processing. They can also be use-
ful to reduce errors on machines that require a 
higher buffer size.



To change the Hardware Buffer Size:

1  Choose Setup > Playback Engine. 

2  From the H/W Buffer Size pop-up menu, select 
the audio buffer size, in samples. 

3  Click OK. 

Host Processors
The Host Processors setting in the Playback En-
gine determines the number of processors in 
your computer allocated for Native (AAX and 
RTAS) plug-in processing and other host pro-
cessing tasks.

With computers that have multiple processors, 
or that feature multi-core processing or hyper-
threading, this setting lets you enable multipro-
cessor support for host processing tasks. Used in 
combination with the CPU Usage Limit setting, 
the Host Processors setting lets you control the 
way host-processing tasks are handled by the 
system. 

For example: 

• For sessions with large numbers of Native 
plug-ins, you can allocate 2 or more proces-
sors to Native processing and set a high CPU 

Usage Limit.

• For sessions with few Native plug-ins, you can 
allocate fewer processors to host-based pro-
cessing and set a low CPU Usage Limit to leave 
more CPU resources available for automation 
accuracy, screen response, and video. 

• Increase these settings to accommodate DSP 
to Native plug-in conversion. Conversely, de-
crease these settings if you are only using DSP 
plug-ins or are converting Native plug-ins to 
DSP. DSP/Native conversion can be desirable 
during recording, depending on latency, voic-
ing needs, and record-monitoring capabilities 
of the specific DSP and Native plug-ins. 
• Depending on the importance of video and 
overall screen response, and on the density of 
automation being employed, try different 
combinations of Host Processors and CPU Us-

age Limit settings to achieve the best results. 
For example, to improve screen response in a 
medium-sized session using a moderate num-
ber of Native plug-ins, try reducing the num-
ber of Native plug-ins, but keep the CPU 

Usage Limit set to the maximum (up to 99% on 
a single processor system).

To set the number of Host Processors:

1  Choose Setup > Playback Engine.

2  From the Host Processors pop-up menu, select 
the number of available processors you want to 
allocate. The number of processors available 
varies depending on how many processors are 
available on your computer:

• Select 1 Processor to limit host processing 
for Pro Tools to one CPU in the system. 

• Choose 2 Processors to enable load balanc-
ing across two available processors for 
Pro Tools host processing tasks.

• On systems running four or more proces-
sors, choose the number of processors for 
Pro Tools host processing tasks.

3  Click OK.

System Usage Window and Host Processing

The System Usage window (Windows > System 

Usage) displays the combined amount of host 
processing occurring on all enabled processors 
with a single indicator, regardless of how many 
processors are available in the system. If the 
System Usage Window shows that you are at the 
limit of available resources, increase the num-
ber of Host Processors and adjust the CPU Us-

age Limit setting. (For more information, see 
“System Usage” on page 81.)
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CPU Usage Limit
The CPU Usage Limit setting in the Playback En-
gine controls the percentage of CPU resources 
allocated to Pro Tools host processing tasks. 
Used in combination with the Host Processors 
setting, the CPU Usage Limit setting lets you 
control the way Pro Tools tasks are carried out 
by the system.

• Lower CPU Usage Limit settings limit the ef-
fect of Pro Tools processing on other CPU-in-
tensive tasks, such as screen redraws, and are 
useful when you are experiencing slow system 
response, or when running other applications 
at the same time as Pro Tools.

• Higher CPU Usage Limit settings allocate more 
processing power to Pro Tools, and are useful 
for playing back large sessions or using more 
RTAS plug-ins. 

The maximum available CPU Usage Limit de-
pends on the number of processors in your com-
puter and on the number of processors you spec-
ify for host processing. This value can range 
from 85% for single-processor computers (ex-
cept for 003, 003 Rack+, 003 Rack, Digi 002, and 
Digi 002 Rack, which have a limit of 99%), and 
99% for multiprocessor computers (which dedi-
cate one entire processor to Pro Tools).

On multiprocessor computers, the maximum 
CPU Usage Limit is reduced when you use all 
your processors (as selected in the Host Process-

ing pop-up menu). For example, on dual-proces-
sors, the limit is 90%. On four-processor com-
puters, the limit is 95%.

Increasing the CPU Usage Limit may slow 
down screen responses on slower computers.
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To change the CPU Usage Limit:

1  Choose Setup > Playback Engine. 

2  From the CPU Usage Limit pop-up menu, select 
the percentage of CPU processing you want to al-
locate to Pro Tools. 

3  Click OK.

Host Engine (Error Suppression)
The Host Engine options in the Playback Engine 
determine error reporting during playback and 
recording. This is especially useful when work-
ing with instrument plug-ins.

On Pro Tools|HD systems, there is a single Host 

Engine option. On host-based Pro Tools sys-
tems, there are two Host Engine options.

• Enable error suppression only if you are expe-
riencing frequent errors that are interrupting 
your creative workflow. When error suppres-
sion is enabled, you can experience a degrada-
tion of audio quality. However, this may be 
acceptable in order to avoid interrupting play-
back and recording when working with instru-
ment plug-ins. 

• Disable error suppression when you need to 
ensure the highest possible audio quality, such 
as for a final mix.

To enable error suppression:

1  Choose Setup > Playback Engine.

2  Select Ignore Errors During Playback/Record.

3  If available, you can also select Minimize Addi-

tional I/O Latency.

4  Click OK.



Error Suppression Options

Ignore Errors During Playback/Record When en-
abled, Pro Tools continues to play and record 
even if the host processing requirements exceed 
the selected CPU Usage Limit. This can result in 
pops and clicks in the audio, but does not stop 
the transport.

Minimize Additional I/O Latency (Host-based 
Pro Tools Systems Only) When enabled, any ad-
ditional latency due to suppressing errors dur-
ing playback and record is minimized to 128 
samples. Suppressing errors requires at least 
128 samples of additional buffering on some 
systems. If this option is disabled, the buffer is 
half the H/W Buffer Size, or at least 128 samples 
(whichever is greater). If you are on an older, 
slower computer, you may want to disable this 
option to avoid adverse performance.

This option is only available if the Ignore Errors 

During Playback/Record option is enabled and 
the Pro Tools system you are using requires ad-
ditional buffering for error suppression, as fol-
lows:

• Windows:

• Mbox Pro and Mbox 2 Pro

• All Pro Tools systems with M-Audio de-
vices

• Mac:

• 003 family devices

• Eleven Rack

• Mbox family devices

• Digi 002 and 002 Rack

• All Pro Tools systems with M-Audio de-
vices

• Pro Tools Aggregate I/O
Number of Voices
(Pro Tools|HD Systems Only)

On Pro Tools|HD systems, the Number of Voices 
setting in the Playback Engine lets you control 
the number of available voices and how those 
voices are allocated to DSPs in your system. For 
example, the default number of voices on a 
Pro Tools|HD 1 system is 48 voices, using one 
DSP (at sample rates of 44.1 kHz or 48 kHz). 

Changing the number of voices affects 
DSP usage, the total number of voiceable tracks, 
and overall system performance. 

Depending on the session sample rate and the 
number of Pro Tools|HD cards in your system, 
there are different choices for voice count. For 
voice limits on different Pro Tools|HD systems, 
see “Playback, Recording, and Voice Limits with 
Pro Tools HD” on page 49.

To change the Number of Voices and DSP to 
allocate for voicing:

1  Choose Setup > Playback Engine.
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2  Select the number of voices and DSPs to allo-
cate for voicing by selecting a value from the 
Number of Voices pop-up menu as follows:

• Select minimum voice numbers if you are 
using high-bandwidth PCI or PCIe cards 
(such as video capture cards) along with 
your Pro Tools|HD cards. These settings 
place the lightest processing load on each 
allocated DSP chip, but generally require 
more DSP chips be dedicated to voicing and 
mixing (leaving fewer available for plug-
ins). 

• Select medium voice numbers when your 
Pro Tools|HD cards are in an expansion 
chassis, or when you are using other PCI or 
PCIe cards along with Pro Tools|HD cards. 
These settings generally provide an opti-
mum balance between number of chips 
needed for voicing, and the processing load 
placed on each. 

• Select higher voice numbers when your 
Pro Tools|HD cards are the only PCI or 
PCIe cards in your computer, or when you 
are using an expansion chassis to run 
higher track counts (such as 64 tracks at 
96 kHz) and you want more voices per DSP 
(such as 16 voices per DSP at 96 kHz). 
These settings use fewer DSP chips for mix-
ing (leaving more available for plug-ins) 
but place the highest processing load on 
each.

3  Click OK. 
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Sample Rate (Playback Engine)
(Pro Tools|HD Systems Only)

The Sample Rate setting in the Playback Engine 
determines the default sample rate when you 
create a new session. This setting is available 
only when there is no session open. Otherwise, 
the current session sample rate is displayed, but 
cannot be changed.

To change the default Sample Rate in the Playback 
Engine:

1  With no session open, choose Setup > Playback 

Engine. 

2  Select the sample rate from the Sample Rate 
pop-up menu.

3  Click OK.

The Sample Rate setting can affect the num-
ber of available voices.

You can change the sample rate when 
creating a new Pro Tools session by selecting 
a different sample rate in the New Session 
dialog. (See “Creating a New Session” on 
page 162.) You can also change the default 
Sample Rate in the Hardware Setup, as long 
as no session is open. 

To make a copy of a session with a new 
sample rate, use Save Copy In.



Delay Compensation Engine
The Delay Compensation Engine setting in the 
Playback Engine determines how much DSP re-
sources are dedicated to Pro Tools Delay Com-
pensation, which manages DSP and host-based 
delays in the Pro Tools mixer.

Within a session, you can choose to enable or 
disable Delay Compensation (Options > Delay 

Compensation).

To configure the Delay Compensation Engine:

1  Choose Setup > Playback Engine.

2  From the Delay Compensation Engine pop-up 
menu, select None, Short, Long, or Maximum.

3  Click OK.

Delay Compensation Settings

There are three settings in the Playback Engine 
to dedicate processing resources for Delay Com-
pensation:

None Allocates no resources for Delay Compen-
sation.

Short Provides 1,023 samples at 44.1/48 kHz, 
2,047 samples at 88.2/96 kHz, or 4,094 samples 
at 176.4/192 kHz of Delay Compensation for 
each channel. This is the most efficient setting. 
For sessions with only a few plug-ins that do not 
induce too much DSP and host–based delay, this 
setting should be sufficient.

Long Allocates 4,095 samples at 44.1/48 kHz, 
8,191 samples at 88.2/96 kHz, or 16,382 samples 
at 176.4/192 kHz of Delay Compensation for 
each mixer channel. For sessions with a lot of 
plug-ins resulting in a large amount of DSP and 
host–based delay, select this setting.

For more information, see “Delay Compen-
sation” on page 977. 
Maximum Allocates 16,383 samples at 
44.1/48 kHz, 32,767 samples at 88.2/96 kHz, or 
65,534 samples at 176.4/192 kHz of Delay Com-
pensation for each mixer channel. For sessions 
with plug-ins on mixer channels that result in 
more the 4,000 samples of delay at 48 kHz, select 
this setting. 

System Memory Allocation
(Pro Tools|HD Systems Only)

When you start your computer, Pro Tools auto-
matically reserves a portion of system memory 
for the Playback Buffer. This reserved memory 
is unavailable to other applications, even if 
Pro Tools is not running.

You can set Pro Tools to reserve only the mini-
mum amount of required memory, so that more 
system memory is available to other applica-
tions. 

To minimize system memory allocation:

1  Choose Setup > Playback Engine.

2  Select the Minimize System Memory Allocation 
option. 

3  Click OK. 

4  Do one of the following:

• On Mac systems, if prompted, enter your 
password, then restart your computer.

– or –

• On Windows systems, restart your com-
puter. 

The Maximum option is unavailable with 
Pro Tools|HD systems due to certain limita-
tions with TDM hardware.
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Cache Size
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

The Cache Size setting in the Playback Engine 
determines the amount of memory DAE allo-
cates to pre-buffer audio for playback and re-
cording. In most cases, the default setting of 
Normal is the optimum Cache Size for most ses-
sions.

Pro Tools HD and Pro Tools with Complete Pro-
duction Toolkit can also load audio files used in 
Pro Tools sessions into RAM for cached play-
back. Pro Tools prioritizes files closest to the 
current playhead location. This way, when you 
start playback, those files are already cached for 
playback. This is especially useful when working 
with shared media storage (such as with Avid 
Unity MediaNetwork and ISIS shared storage 
systems). 

To determine the maximum amount of RAM 
available for Disk Cache, Pro Tools polls the 
computer for the amount of RAM installed and 
subtracts 3 GB with Mac systems or 4 GB with 
Windows systems. 

For example, if your computer has 12 GB of 
RAM installed, the total amount of RAM avail-
able for the Disk Cache will be 9 GB (Mac) or 8 
GB (Windows).

Note that Windows systems reserve more RAM 
for the system than Mac systems.

You can use the Cache Meters in the System 
Usage window to determine whether or not 
to assign more or less RAM to the Disk Cache 
for the current session. See “Cache Meters” 
on page 81.
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To set the amount of RAM for use by the Disk 
Cache:

1  Choose Setup > Playback Engine.

2  From the Disk Cache selector, select the 
amount of RAM you want to allocate for Disk 
Cache.

3  Click OK.

Plug-In Streaming Buffer Size
(Structure Plug-In Only)

This setting appears in the Playback Engine only 
if the Structure sampler instrument plug-in is 
installed on your system (this applies to Struc-
ture LE and Structure Free as well). The Plug-In 

Streaming Buffer Size determines the amount of 
memory DAE allocates for streaming playback 
from disk with the Structure plug-in. This set-
ting only affects playback if disk streaming is ac-
tivated in Structure’s plug-in controls (see the 
AIR Virtual Instruments Guide for more infor-
mation).



The optimum Plug-In Streaming Buffer Size for 
most sessions is 250 ms; Level 2 (Default).

• Plug-In Streaming Buffer Size settings lower 
than 250 ms; Level 2 (Default) reduce the 
amount of system memory used for sample 
playback and frees up memory for other sys-
tem tasks. However, reliability of sample play-
back may decrease.

• Plug-In Streaming Buffer Size settings higher 
than 250 ms; Level 2 (Default) improve the re-
liability of sample playback, but they also de-
crease the amount of memory available for 
other system tasks, such as Native plug-in pro-
cessing.

To change the Plug-In Streaming Buffer Size:

1  Choose Setup > Playback Engine.

2  From the Plug-In Streaming Buffer Size pop-up 
menu, select a buffer size.

3  Click OK. 

Using a larger Plug-In Streaming Buffer Size 
leaves less system memory for other tasks. 
The default setting of 250 ms (Level 2) is 
recommended unless you are experiencing 
problems with the reliability of streaming 
playback from disk.
Optimizing the Plug-In 
Streaming Buffer Size
(Structure Plug-In Only)

This option appears in the Playback Engine only 
if the Structure plug-in is installed on your sys-
tem. This option is useful when you are playing 
samples from the same drive that contains audio 
for the current session. When this option is se-
lected, Pro Tools automatically optimizes the 
size of the Plug-In Streaming Buffer to facilitate 
disk access from both Pro Tools and Structure. 
The Plug-In Streaming Buffer Size pop-up menu 
is unavailable when this option is selected.

To set Pro Tools to automatically optimize the 
Plug-In Streaming Buffer Size:

1  Choose Setup > Playback Engine.

2  Select the Optimize for Streaming Content on 

Audio Drives option.

3  Click OK. 

Configuring MIDI Setup
If you plan to use any external MIDI devices 
with Pro Tools (such as controllers, keyboards, 
synthesizers, drum machines, samplers, se-
quencers, or sound modules), you may want to 
configure your MIDI setup using Audio MIDI 
Setup (Mac) or MIDI Studio Setup (Windows).

For information on configuring MIDI, see 
Chapter 10, “Configuring MIDI.”
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Configuring Pro Tools 
Hardware Settings
Pro Tools lets you configure the signal routing, 
digital I/O format, default sample rate, clock 
source, and other hardware-based settings de-
pending on your system configuration. These 
system settings are available in the Hardware 
Setup (Setup > Hardware).

Hardware Setup for HD OMNI, Main page

Hardware Setup for Mbox 2

Hardware Setup for an ASIO device
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Selecting an Audio Interface to 
Configure
The Peripherals list in the Hardware Setup lets 
you select any audio interface connected to your 
Pro Tools system associated with the selected 
Current Engine setting in the Playback Engine di-
alog.

To change the Current Engine setting to use a 
specific audio interface or DAE (such as HD 
TDM, 003, a third-party Core Audio or ASIO in-
terface, or Pro Tools Aggregate I/O), see “Cur-
rent Engine” on page 61).

For Avid HD audio interfaces (such as HD OMNI 
or HD I/O) you can configure the signal routing, 
digital I/O format, default sample rate, clock 
source, and other hardware-based settings for 
each HD peripheral connected to your system.

For Pro Tools audio interfaces (such as 003 or 
Mbox 2) you can configure the signal routing, 
digital I/O format, default sample rate, clock 
source, and other hardware-based settings de-
pending on your system configuration 

For third-generation Mbox family audio inter-
faces, M-Audio audio interfaces, and third-
party Core Audio (Mac) and ASIO (Windows) 
compatible audio interfaces, use the Launch 

Setup App button to launch the control panel for 
configuring your specific audio interface.



Launch Setup App
(Pro Tools with Mbox Family, M-Audio, or 
Third-Party Audio Interfaces Only)

Using the setup application (control panel) for 
your audio interface, you can change settings in 
the following areas depending on your audio in-
terface:

• Mixer Settings

• Output Settings

• Hardware Settings (including sample rate, 
hardware buffer size, and sync source).

To change control panel settings:

1  In the Hardware Setup dialog, click the Launch 

Setup App button.

2  To change settings in the Control Panel, see the 
documentation that came with your audio inter-
face.

3  When finished, close the Control Panel.

You can set the sample rate when creating a 
new Pro Tools session by selecting a differ-
ent sample rate in the New Session dialog.
Configuring Pro Tools 
Aggregate I/O
(Mac Only)

On Mac systems using Core Audio, you can se-
lect Pro Tools Aggregate I/O as the Current En-

gine to use the built-in audio inputs and outputs 
on your Mac computer. You can configure the 
Pro Tools Aggregate I/O setting in the Mac Au-
dio Setup, which can be accessed from the 
Pro Tools Hardware Setup.

To configure Pro Tools Aggregate I/O settings:

1  Choose Setup > Hardware.

2  In the Peripherals list, select Pro Tools Aggre-

gate I/O, or whichever Built-in input or output 
option is selected as the Current Engine in the 
Playback Engine.

3  Click the Launch Setup App button.

4  In the Audio Devices window of the Mac Audio 
Setup, configure the Pro Tools Aggregate I/O 
settings.

Hardware Setup for Pro Tools Aggregate I/O (Mac 
only)

The Pro Tools Aggregate I/O device is in-
tended for use only with the built-in audio 
on your Mac computer. For best perfor-
mance, use the default settings.
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Configuring Default Sample Rate 
Setting in Hardware Setup
The Sample Rate setting in the Hardware Setup 
dialog determines the default sample rate when 
you create a new session. This setting is avail-
able only when there is no session open. Other-
wise, the current session sample rate is dis-
played, but cannot be changed.

With Pro Tools|HD and HD Native hardware, 
you can change the default Sample Rate in the 
Hardware Setup, or in the Playback Engine.

On Pro Tools, you can only change the default 
sample rate in the Hardware Setup or using the 
control panel for M-Audio and third-party au-
dio interfaces.

Pro Tools Aggregate I/O in the Audio Devices window

With Pro Tools|HD and HD Native hard-
ware, the Sample Rate setting can affect the 
number of available voices.

You can change the sample rate when 
creating a new Pro Tools session by selecting 
a different sample rate in the New Session di-
alog.
Pro Tools Reference Guide
To change the default Sample Rate in the 
Hardware Setup:

1  Choose Setup > Hardware Setup. 

2  Select the sample rate from the Sample Rate 
pop-up menu.

3  Click OK.

Configuring Clock Source
The Pro Tools Hardware Setup lets you select 
the Clock Source for the system.

Internal If you are recording an analog signal di-
rectly into Pro Tools, you will usually use the 
Pro Tools Internal clock source. 

External If you are transferring material into 
Pro Tools from an external digital device, or if 
you utilize a common house clock signal, you 
will synchronize Pro Tools to that digital device 
or common signal. 

Depending on your audio interface, external op-
tions can include AES/EBU [Encl], S/PDIF, Opti-

cal [Encl], AES/EBU 1–8, TDIF, ADAT, and Word 

Clock. For details, see the guide for your audio 
interface.

To select the Clock Source:

1  Choose Setup > Hardware. 

2  Choose the clock source from the Clock Source 
pop-up menu.

3  Click OK. 

Changes made to Clock Source in the Session 
Setup window will be reflected in the Hard-
ware Setup window and vice versa.

Your digital input device must be connected 
and powered on for Pro Tools to synchro-
nize to it. If your input device is not pow-
ered on, leave the Clock Source set to Inter-
nal.



Configuring Digital Format and 
Hardware Routing
The Hardware Setup includes additional set-
tings for configuring the digital format and 
hardware routing for your system’s audio inter-
faces.

For an outline of the configuration of a 
Pro Tools|HD or HD Native system with one or 
more Avid HD interfaces, see “Configuring 
Pro Tools|HD and HD Native Hardware Set-
tings” on page 73.

Selecting Footswitch Control
(003 and 002 Only)

The footswitch connector on your 003 or 002 
family interface lets you use a footswitch pedal 
to control either playback start/stop or record-
ing punch in/out. Both QuickPunch audio 
punch-in and punch-out and MIDI punch-in 
and punch-out recording are supported. 

Record Punch In/Out Select this option to use a 
footswitch connected to your 003 or 002 family 
interface to punch in and punch out during re-
cording.

Playback Start/Stop Select this option to use a 
footswitch connected to your 003 or 002 family 
interface to start and stop playback.

To configure specific hardware settings for 
other Pro Tools, M-Audio, or third-party 
audio interfaces, see the documentation 
that came with your audio interface.
Configuring Pro Tools|HD and 
HD Native Hardware Settings
On Pro Tools|HD and HD Native systems, you 
configure Hardware settings for each audio in-
terface connected to your system (see Chapter 5, 
“Pro Tools Systems.”)

For example, Pro Tools|HD and HD Native sys-
tems can have HD I/O, HD OMNI, HD MADI, 
192 I/O, 192 Digital I/O, 96 I/O, or 96i I/O audio 
interfaces connected to Accel Core or HD Core 
and HD Accel or HD Process cards in the system. 
The HD I/O, HD OMNI, 192 I/O, 192 Digital I/O, 
and 96 I/O can also have additional interfaces 
attached using the Expansion port on each 
interface.

Identifying Audio Interfaces
If you have multiple audio interfaces of the same 
type connected to your system, before you make 
audio connections to them, you should confirm 
the identity of each interface. This ensures that 
you choose the appropriate interface in the Pe-
ripherals list when you define its inputs and out-
puts in the Hardware Setup. 

To identify audio interfaces in your system:

1  Choose Setup > Hardware.

2  From the Peripherals list, select an audio in-
terface connected to your system.

3  Make sure the Main page is shown.

4  Select the Identify option, located in the lower 
left corner of the Hardware Setup. This illumi-
nates all the LEDs on the front panel of the se-
lected audio interface. 

Use the Up and Down Arrow keys to scroll 
though the Peripherals list in the Hardware 
Setup.
Chapter 6: System Setup 73



74
5  Make a note of which interface in your studio 
setup corresponds to the identified interface. 

6  Repeat the above steps for each additional au-
dio interface in your setup.

Configuring Avid HD Audio 
Interfaces
HD OMNI supports up to eight channels of si-
multaneous I/O and multiple I/O formats (such 
as analog, AES/EBU, ADAT Optical, and 
S/PDIF). HD I/O, 192 I/O, 192 Digital I/O, 
96 I/O, and 96i I/O audio interfaces support six-
teen channels of simultaneous I/O and multiple 
I/O formats (such as analog, AES/EBU, ADAT 
Optical, S/PDIF, and TDIF). HD MADI supports 
up to 64 channels of MADI I/O.

The Main page of the Hardware Setup is where 
you define which physical inputs and outputs on 
your audio interface are routed to available in-
puts and outputs in Pro Tools. You can think of 
this window as a patchbay that allows you to 
route any of the inputs or outputs on your audio 
interfaces to channel assignments in the 
Pro Tools mixer.

Additional pages are available to configure 
other controls for each audio interface (such as 
setting operating levels).

Hardware Setup for HD I/O, Main page
Pro Tools Reference Guide
To configure Avid HD audio interfaces:

1  Choose Setup > Hardware.

2  From the Peripherals list, select the audio in-
terface connected to the first card in your sys-
tem. This will be the interface at the top of the 
list.

3  Click the Main tab.

4  From the Clock Source pop-up menu, select 
the appropriate clock source for the interface.

In many cases, you will use Internal. The other 
choices are for resolving Pro Tools to external 
clock sources. Depending on your audio inter-
face, Clock Source options can include: 
AES/EBU [Encl], S/PDIF, Optical [Encl], AES/EBU 

1–8, TDIF, ADAT, and Word Clock (optional 
Word Clock rates are available when operating 
at higher sample rates).

5  If you want to send clock output to other de-
vices attached to the audio interface, select the 
appropriate output from the Ext. Clock Output 
pop-up menu. 

6  Select which digital I/O port on your audio in-
terface enclosure is active by selecting the corre-
sponding option under Digital Format. 
Depending on the type of interfaces in your sys-
tem, choices include AES/EBU, S/PDIF, and Op-

tical (S/PDIF). Selecting Optical (S/PDIF) resets 
the Optical I/O port (which is, by default, eight 
channels of ADAT Optical I/O) to two channels 
of S/PDIF Optical I/O.

7  For S/PDIF compatibility with Tascam DA-30 
DAT recorders, select the Tascam option under 
S/PDIF Format.

Press Command+Left or Right Arrow keys 
(Mac) or Control+Left or Right Arrow keys 
(Windows) to move though the different 
pages of the Hardware Setup.



8  From the Input and Output channel pop-up 
menus, select the physical ports (such as Analog 

1–2 or Optical 1–2), that will be routed to the 
corresponding Pro Tools input and output chan-
nels (such as Ch 1–2, Ch 3–4), listed on the left 
side of the Main page.

Inputs and outputs of similar format are differ-
entiated in the input and output channel pop-up 
menus. For example, the AES/EBU inputs and 
outputs in the HD I/O enclosure are listed as 
AES/EBU [Encl], while the AES/EBU inputs and 
outputs on the factory-installed Digital I/O card 
are listed (in pairs) as AES/EBU 1–2, AES/EBU 

3–4, AES/EBU 5–6, and AES/EBU 7–8. For 
HD I/Os equipped with a second Digital I/O 
Card, the additional AES/EBU I/O ports on the 
optional card are listed as AES/EBU 9–10, 

AES/EBU 11–12, AES/EBU 13–14, and AES/EBU 

15–16.

9  Configure any specific controls for your audio 
interface:

• “Configuring HD OMNI Controls” on 
page 75.

• “Configuring HD I/O Controls” on page 76.

• “Configuring HD MADI Controls” on 
page 77.

• “Configuring 192 I/O and 192 Digital I/O 
Controls” on page 78.

• “Configuring 96 I/O Controls” on page 79.

• “Configuring 96i I/O Controls” on page 79.

10  For additional audio interfaces, select it in 
the Peripherals list, and repeat the above steps.

See your peripheral’s guide for additional 
configuration details and restrictions. For 
example, the Optical 1–8 channels (on the 
192 I/O enclosure) will not be available at 
session sample rates of 88.2 kHz or higher, 
while the ports on the 192 I/O Digital I/O 
card will still be available.
Configuring HD OMNI Controls

To configure HD OMNI in Pro Tools:

1  Choose Setup > Hardware.

2  From the Peripherals list, select the HD OMNI 
audio interface.

3  Click the Monitor tab and configure the op-
tions. When working with HD OMNI, you should 
always configure the Monitor page first.

4  Click the Main tab and configure the options.

For detailed information about configuring 
HD OMNI, see the HD OMNI Guide.

HD OMNI Hardware Setup, Monitor page

HD OMNI Hardware Setup, Main page
Chapter 6: System Setup 75



76
5  Click the Analog In tab and configure the 
options.

6  Click the Analog Out tab and configure the 
options.

7  Click the Mixer tab and configure the options.

8  When you are finished, click OK.

HD OMNI Hardware Setup, Analog In page

HD OMNI Hardware Setup, Analog Out page

HD OMNI Hardware Setup, Mixer page
Pro Tools Reference Guide
Configuring HD I/O Controls

To configure controls for HD I/O:

1  Choose Setup > Hardware.

2  From the Peripherals list, select the HD I/O au-
dio interface.

3  Click the Main tab and configure the options.

4  If you have at least one HD I/O AD card, click 
the Analog In tab and configure the options. If 
you have two HD I/O AD cards, this tab is la-
beled Analog In 1–8.

For detailed information about configuring 
HD I/O, see the HD I/O Guide.

HD I/O Hardware Setup, Main page

HD I/O Hardware Setup, Analog In page



5  If you have two HD I/O AD cards, click the An-

alog In 9–16 tab and configure the options.

6  If you have at least one HD I/O Digital card, 
click the Digital tab and configure the options.

7  If you have two HD I/O Digital cards, click the 
second Digital tab and configure the options.

8  When you are finished, click OK.

HD I/O Hardware Setup, Analog In 9–16 page

HD I/O Hardware Setup, Digital page
Configuring HD MADI Controls

To configure controls for HD MADI:

1  Choose Setup > Hardware.

2  From the Peripherals list, select either 
HD MADI Port 1 or HD MADI Port 2 and config-
ure the options.

3  When you are finished, click OK.

For detailed information about configuring 
HD MADI, see the HD MADI Guide.

HD MADI Hardware Setup

The settings for HD MADI Port 1 and 
HD MADI Port 2 are linked. Any changes 
are global regardless of which is selected in 
the Peripherals list.
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Configuring 192 I/O and 
192 Digital I/O Controls

To configure controls for a 192 I/O:

1  With the 192 I/O selected in the Peripherals 
list, click the Analog In tab for the following op-
tions:

• You can set your operating level on a chan-
nel-by-channel basis by selecting Reference 
Level +4 dBu or –10 dBV. These settings 
correspond to two different input connec-
tors on the back of the 192 I/O. See the 
192 I/O Guide for more information. 

• Each of the analog channels in the 192 I/O 
has two Input Trims, labeled A and B, for 
precisely calibrating and switching levels. 
You can select Input Trim A or B on a chan-
nel-by-channel basis. See the 192 I/O Guide 
for more information.

• You can select Soft Clip on a channel-by-
channel basis. The Soft Clip limiter attenu-
ates the incoming analog signal, providing 
extra protection from temporary clipping 
transients that can cause digital distortion 
when they exceed the maximum input of 
the unit. With Soft Clip enabled, 192 I/O 
supports an additional 4 dB of headroom by 
rounding off the top 4 dB to the clip point. 
This is useful for eliminating stray tran-
sients.

Hardware Setup for 192 I/O, Analog In page
Pro Tools Reference Guide
2  Click the Analog Out tab. Each of the analog 
channels in the 192 I/O has two Output Trims, 
labeled A and B, respectively. You can select Out-
put Trim A or B on a channel-by-channel basis.

To configure controls for a 192 Digital I/O or 
192 I/O with an optional Digital I/O card:

 On the 192 Digital I/O or a 192 I/O with an op-
tional Digital I/O card, click the Digital tab to set 
the Input Format (AES/EBU, TDIF, or ADAT Op-
tical) and enable real-time sample rate conver-
sion (in channel pairs, with the SR Conversion 
option).

Hardware Setup for 192 I/O, Analog Out page

At session sample rates above 48 kHz, sam-
ple rate conversion for the TDIF and Optical 
(ADAT) inputs on the Digital I/O card is au-
tomatically enabled on all eight inputs of 
the selected format. 

Hardware Setup for 192 I/O, Digital page



Configuring 96 I/O Controls

To configure controls for a 96 I/O:

1  With the 96 I/O selected in the Peripherals list, 
configure your I/O front panel meters for input 
or output metering from the Meters pop-up.

2  Click the Analog In tab for the following op-
tion:

• You can set your operating level on a chan-
nel-by-channel basis by selecting Reference 
Level +4 dBu or –10 dBV. See the 96 I/O 
Guide for more information on setting op-
erating levels.

3  Click the Analog Out tab for the following op-
tion:

• You can set your output level on a channel-
by-channel basis by selecting Reference 

Level +4 dBu or –10 dBV. See the 96 I/O 
Guide for more information on setting op-
erating levels.

Hardware Setup for 96 I/O, Analog In page

Hardware Setup for 96 I/O, Analog Out page
Configuring 96i I/O Controls

To configure controls for a 96i I/O:

1  With the 96i I/O selected in the Peripherals 
list, configure your I/O front panel meters for in-
put or output metering from the Meters pop-up.

2  Set input sensitivity by doing the following: 

• For Inputs 1–4, set the input trim slider to 
match the output level of the connected in-
strument. Choices range from –12 dBV to 
+4 dBu. If you do not know the output level 
of the device, use the default input trim 
level, then fine tune the input level sensitiv-
ity.

• For each input 5–16 being used, select 
–8 dBV or +4 dBu as appropriate to best 
match the output level of the connected in-
strument. 

3  Set Output levels (select –10 dBV or +4 dBu).

4  Click Done.

You can select analog or digital input as sources 
for 96i I/O channels 1–2. Only channels 1–2 can 
access the S/PDIF inputs. 

Hardware Setup for 96i I/O
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To select analog or digital input for channels 1-2:

1  Choose Setup > Hardware, and select 96i I/O in 
the Peripherals list to display the 96i I/O win-
dow. 

2  Click to set Ch 1–2 Input to Analog or S/PDIF, 
as appropriate. 

Configuring I/O Setup
The I/O Setup provides a graphical representa-
tion of the signal routing for each connected au-
dio interface, with controls to route physical 
ports on the audio interface to Pro Tools inputs 
and outputs. These controls mirror the routing 
controls found in the Hardware Setup—changes 
made to physical routing in one is always re-
flected in the other. 

The I/O Setup lets you label and map Pro Tools 
input, output, insert, and bus signal paths. The 
I/O Setup also provides important audition, me-
ter, and surround settings. For more informa-
tion, see Chapter 7, “I/O Setup.”

Routing a Pro Tools Output Pair 
to Multiple Destinations
Pro Tools channel pairs can be routed to multi-
ple physical outputs on an audio interface 
through the Hardware Setup. 

For example, if you assign Channels 1–2 to both 
outputs Analog 1–2 and Analog 3–4, when you 
send a signal to Pro Tools Channels 1–2, that 
signal will be routed simultaneously to both 
pairs of output ports on your audio interface.

The 96i I/O only supports analog and digital 
switching for channels 1–2, and only from 
within the Hardware Setup and I/O Setup. 
The 96i I/O does not support path remap-
ping within I/O Setup.
Pro Tools Reference Guide
This lets you send the same signal (such as a ste-
reo pair, a stem mix, or a multichannel mix) to 
multiple destinations (such as multiple master-
ing devices).

To route a Pro Tools output channel pair to 
multiple audio interface output ports:

1  Choose Setup > Hardware.

2  From the Peripherals list, select an interface.

3  Click the Main tab. 

4  Select an output port pair from an Output pop-
up menu.

5  Control-click (Mac) or Start-click (Windows) 
the same pop-up menu a second time to choose 
another available Output Port pair.

The output name updates with a plus sign (“+”) 
before it to indicate that multiple output ports 
are selected. In the pop-up menu, each physical 
port pair assigned to that Pro Tools output pair 
is indicated by a check mark.

6  Repeat the above steps to select additional out-
put destinations. The only limit to output 
choices is the number of outputs available in 
your system.

Pro Tools output pairs can also be routed to 
multiple audio interface outputs in the 
I/O Setup. For more information, see “Configur-
ing Hardware in I/O Setup” on page 97.

Only currently unassigned Output Port 
pairs are available.



System Usage
Meters in the System Usage window indicate 
how much of your system’s processing power is 
being used in processing audio, and when writ-
ing and playing back automation. 

Activity Meters
All versions of Pro Tools provide three common 
system Activity meters. Pro Tools|HD and 
HD Native systems also provide a meter for 
monitoring PCI activity.

PCI (Pro Tools|HD and HD Native Systems 
Only) Displays the amount of PCI bus activity.

CPU (Native) Displays the amount of CPU pro-
cessing activity for host-based plug-in process-
ing.

CPU (Clip) Displays the amount of processing 
activity for Real-Time Elastic Audio processing 
and clip gain.

Disk Displays the amount of hard disk process-
ing activity.

As these meters approach their limits, host pro-
cessing and recording or playback of automa-
tion data can be affected. If CPU or PCI Activity 
are high, a system error may occur. If Disk Ac-
tivity is high, Pro Tools may miss playback of 
some automation data during particularly dense 
periods of activity, such as while using the 
Bounce to Disk command. 

System Usage window (Pro Tools|HD system shown)
Cache Meters
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools HD provides two meters in the System 
Usage window for monitoring the Disk Cache: 
Disk Cache and Timeline Cached. These meters 
are only present if a fixed Cache Size is selected 
in the Playback Engine dialog.

Disk Cache Displays the percentage of how 
much of the allocated disk cache is filled. For ex-
ample, if the Cache Size in the Playback Engine 
is set to 1 GB and a session uses 250 MB of audio 
files, the Disk Cache meter reads 25%. If all of 
the audio in the session is cached (including 
files in the Clip List that are not on the time-
line), the Disk Cache meter appears green.

Timeline Cached Displays the amount of audio 
in the session Timeline cached in RAM. 

If the selected Cache Size in the Playback En-
gine is the same or greater than the amount of 
audio on the Timeline, the Timeline Cached me-
ter reads 100% and it appears green (indicating 
that all of the audio on the Timeline is cached in 
RAM). This is useful for letting you know how 
much audio can still be added to the Timeline 
and be cached in RAM.

If the total amount of audio in the Timeline is 
more than the selected Cache Size in the Play-
back Engine, the Timeline Cached meter shows 
the percentage of audio on the Timeline that is 

System Usage window showing Disk Cache and 
Timeline Cached meters
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cached in RAM. For example, if the selected 
Cache Size in the Playback Engine is 256 MB 
and the amount of audio on the Timeline is 1 
GB, the Timeline Cached meter reads 25%.

DSP Usage Meters
(Pro Tools|HD Systems Only)

Pro Tools|HD systems provide additional me-
ters below the Activity meter (see page 81): 

TDM Voices Allocated Displays the total number 
of TDM voices that can be allocated and the 
number of voices currently allocated. This in-
cludes all voices whether they are allocated ex-
plicitly or dynamically, as well as any voices 
used for routing RTAS processing. 

TDM Time Slots Used Displays the total number 
of TDM Time Slots available and the number of 
TDM Time Slots currently used.

DSP Usage (HD Core and HD Accel) Displays (in 
percent) how much of each DSP chip on each 
Pro Tools|HD card is currently being used for 
mixer configurations and TDM plug-ins.

System Usage window (Pro Tools HD 2 Accel shown)

System
Activity

TDM Voices
Allocated

TDM Time
Slots Used

DSP
Usage
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Managing System Resources

To monitor the usage of resources during a 
Pro Tools session:

 Choose Window > System Usage.

To reduce processing load, do one of the 
following:

 Reduce the density of automation in places 
where it shows the most activity. For details, see 
“Thinning Automation” on page 1047. 

– or –

 Turn off meters in Sends view, if enabled (by 
deselecting Show Meters in Sends View in the 
Display Preferences page). For details, see “Indi-
vidual Send Views and Meters” on page 961.

DSP Caching
(Pro Tools|HD Systems Only)

Pro Tools|HD systems maintain DSP caching 
(Plug-in and Mixer caching for allocated DSP) 
when closing and opening sessions. While this 
caching has no effect on the time it takes to open 
the first session after you launch Pro Tools, it 
does result in being able to open and close all 
subsequent Pro Tools sessions much more 
quickly, especially when using the Revert To 

Saved command or when opening similarly con-
figured sessions.

However, when using DSP caching, the System 
Usage window may not always accurately show 
the DSP resources your session is currently us-
ing. For an accurate display of current DSP us-
age, you can either disable DSP caching or purge 
the DSP cache.



To enable (or disable) DSP Caching:

1  Open the System Usage window (Windows > 

System Usage).

2  Click the DSP Cache pop-up menu and select 
(or deselect) Use DSP Cache.

To purge the DSP cache:

1  Open the System Usage window (Windows > 

System Usage).

2  Click the DSP Cache pop-up menu and select 
(or deselect) Purge Cache. This refreshes the 
System Usage display.

System Usage window, DSP Cache pop-up menu
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Chapter 7: I/O Setup
The I/O Setup provides tools to label, format, 
and assign Pro Tools input, output, insert, and 
bus audio signal paths both for individual ses-
sions as well as for your specific Pro Tools 
system. 
I/O Setup also provides controls for PRE (Mic 
Preamp) signal paths, and Delay Compensation 
settings for hardware inserts.
I/O Setup on a Pro Tools|HD system with HD OMNI and HD I/O

Channel Grid

Path Type tabs

Active/Inactive
Status

Options

Path Format selector

Path Name column

Path tools

Input and Output 
selectors

Interface Name label

Import/Export Settings
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The I/O Setup displays a graphical representa-
tion (cross-point matrix) of the signal routing 
for physical input and output paths for each 
connected audio interface. Like a virtual patch-
bay, I/O Setup controls let you route physical in-
puts and outputs on the audio interface to 
Pro Tools input and output channels. For 
Pro Tools|HD and HD Native systems, some of 
these controls mirror the routing controls found 
in the Hardware Setup —changes made to phys-
ical routing in one is always reflected in the 
other.

The I/O Setup also includes controls for creating 
internal mix busses and for creating and map-
ping output busses.

Opening the I/O Setup
The I/O Setup can be opened from the applica-
tion window (with a session closed), or from 
within a session (when a session is open).

To open the I/O Setup:

1  Make sure your audio interfaces are enabled 
and configured properly in the Hardware Setup. 
See “Configuring Pro Tools Hardware Settings” 
on page 70.

2  Choose Setup > I/O. 

Closing the I/O Setup

To close the I/O Setup and save changes:

 Click OK.

Pro Tools checks several settings for routing va-
lidity (to prevent feedback loops). If there are 
any overlapping or invalid settings, you will be 
required to correct them (see “Valid Paths and 
Requirements” on page 109).

To close the I/O Setup without saving changes:

 Click Cancel.
Pro Tools Reference Guide
Resizing the I/O Setup 

To resize the I/O Setup dialog, do one of the 
following:

 On Mac, drag the lower-right corner of the 
window.

– or –

 On Windows, drag any corner of the window.

Navigating in the I/O Setup

To scroll left or right in the I/O Setup:

 Press Option+Page Up/Down (Mac) or 
Alt+Page Up/Down (Windows).

Pro Tools Signal Paths
A signal path is a logical grouping of multiple 
inputs, outputs, or busses that has a single name 
and (channel) format. The I/O Setup lets you 
create, define and name paths according to the 
configuration of your studio and the needs of 
each project.

Main Paths and Sub-Paths

Paths in Pro Tools tracks and I/O Setup include 
main paths and sub-paths.

Main Paths Main paths are logical groupings of 
inputs, inserts, busses, or outputs. For example, 
a master stereo output path will include both its 
left and right channels. 

Sub-Paths A sub-path represents a signal path 
within a main path. For example, a default ste-
reo output bus path consists of two mono sub-
paths, left and right. Mono tracks and sends can 
be routed to either mono sub-path of the stereo 
output bus path. 



Paths in Sessions
In sessions, signals are routed to and from 
tracks, sends, and inserts using track Input, 
Output, Insert, and Send selectors.

When you click a track Input, Output, Insert or 
Send selector, the paths created and defined in 
the IO Setup appear in the list of available paths 
(see “Assigning Audio Inputs and Outputs to 
Tracks” on page 236).

Path Configurations and 
I/O Settings
Each Pro Tools system can have a different path 
configuration, determined by:

• On Pro Tools systems, the type of audio in-
terface or other physical I/O (including 
built-in hardware)

• On Pro Tools|HD and HD Native systems, 
the number and types of audio interfaces

Main and sub-paths in I/O Setup

It is especially useful to define and name 
sub-paths for complex mixing setups, such 
as a 5.1 Surround mix. 
Path configurations in Pro Tools are saved as 
I/O settings.

I/O Settings are saved with both the session and 
with the system. You can choose whether or not 
the IO settings saved with the session overwrite 
the IO settings saved with the system (see “Ses-
sions Overwrite Current I/O Setup When 
Opened” on page 96).

Unavailable items (including hardware, paths, 
or required resources) remain in the session as 
inactive items (see “Making Paths Active or In-
active” on page 107).

When you create a new session, you can specify 
which I/O Settings to use. For example, you can 
use the factory installed default settings, the 
“Last Used” setting, or one of any available cus-
tom I/O settings files.

Default I/O Settings

Pro Tools comes with default I/O Setup settings 
to get you started (see “Factory I/O Settings” on 
page 113). You should only need to open the I/O 
Setup if you want to customize I/O paths or if 
you change your system hardware (for example, 
adding an expansion card to HD I/O, or adding 
or removing an audio interface). 

You can always return to the default settings for 
an I/O Settings page by clicking the Default but-
ton. These paths are available in session tracks 
and are reflected in the I/O Setup. 

You can customize your I/O Setup configuration 
at any time, according to the needs of each proj-
ect (see “Customizing I/O Settings” on page 96).

See “Factory I/O Settings” on page 113 and 
“I/O Settings Files” on page 114 for more in-
formation.
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I/O Setup Pages
The I/O Setup provides tabs to open pages for 
configuring specific I/O Settings.

Opening a Specific I/O Setup 
Page

To open any specific I/O Setup page:

 Click the corresponding tab at the top of the 
I/O Setup.

Press and hold the Command key (Mac) or 
the Control key (Windows) and use the Left 
or Right Arrow keys to cycle through the dif-
ferent pages of the I/O Setup.

It is recommended that if you choose to cus-
tomize your I/O Setup, configure the system-
specific options first: Input, Output, Insert, 
Mic Preamps, and H/W Insert Delay. Then 
configure the Bus page. Once you have con-
figured your system, you should not need to 
change it unless you add or remove hard-
ware (such as audio interfaces) from your 
system. See “Customizing I/O Settings” on 
page 96.
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Input Page
The Input page of the I/O Setup lets you create 
and assign Pro Tools Input channels to receive 
audio from the physical inputs of your audio 
hardware. 

Configure input signal path names, formats, and 
source channel (analog or digital) on the Input 
page. Multichannel input paths (stereo or 
greater) can have any number of sub-paths. In-
put channels can have overlapping input paths. 
Input names, channel widths, and physical in-
put mappings are saved with the system and the 
session, and can be recalled from either.

I/O Setup, Input page



Output Page
The Output page of the I/O Setup lets you create 
and assign Pro Tools Output channels to send 
audio to the physical outputs of your audio 
hardware. 

Configure output signal path names and formats 
on the Output page. Output channels can have 
overlapping output paths. Output names, chan-
nel widths, and physical output assignments are 
saved with the system and the session, and can 
be recalled from either.

I/O Setup, Output page
Bus Page
The Bus page of the I/O Setup lets you create and 
edit internal mix busses and output busses. The 
Bus page also lets you map output busses to out-
put paths (as configured in the Output page of 
the I/O Setup). 

Configure bus path names and formats, and map 
any main bus path to any available output of the 
same width or greater. Multichannel bus paths 
(stereo or greater) can have any number of sub-
paths. Output bus and internal mix bus names 
and channel widths are saved with and recalled 
from the session. 

I/O Setup, Bus page

For information about configuring busses, 
see “Configuring Busses” on page 109.
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Insert Page
The Insert page of the I/O Setup lets you create 
and edit hardware insert signal paths for the 
Pro Tools mixer. Hardware inserts can route au-
dio through an external device connected to par-
allel inputs and outputs of a Pro Tools audio in-
terface. This lets you process audio on a track 
with a hardware insert in real time. 

Insert paths require audio interface inputs and 
outputs, and are determined by the configura-
tion of the Insert page in the I/O Setup for your 
system.

I/O Setup, Insert page

For information about using hardware 
inserts, see “Using Hardware Inserts” on 
page 1017.
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Mic Preamps Page
On the Mic Preamps page of the I/O Setup, sig-
nal paths for one or more PRE multi-purpose 
microphone preamplifiers can be mapped to au-
dio interfaces. For more information, see the 
PRE Guide.

H/W Insert Delay 
(Compensation) Page
To compensate for the delay (latency) of any ex-
ternal hardware devices (such as an effects unit) 
used in your session, you can set the amount of 
Hardware Insert Delay Compensation (in milli-
seconds) for each external device. These times 
will be used by the Delay Compensation Engine 
to time-align input paths when the hardware in-
sert is in use and Delay Compensation is en-
abled.

Mic Preamps page

Insert offset delay field

For more information, see “Setting a 
Hardware Insert Delay Offset” on 
page 983.



I/O Setup Signal Path 
Controls
Depending on the I/O Setup page, the I/O Setup 
provides the following controls in its graphical 
section for configuring signal routing paths.

Input and Output Selectors Let you select the 
physical ports on your audio interface to route 
to Pro Tools inputs and outputs. Ports are se-
lectable in channel pairs. Available ports for 
each displayed interface are based on Hardware 
Setup settings; for example, if the AES/EBU in-
puts and outputs of an interface are enabled in 
Hardware Setup, they are available for routing 
in I/O Setup. The functionality provided with 
the Input and Output selector is the same as that 
provided on the Main page of the Hardware 
Setup.

Path Name Column Shows paths that are avail-
able for selection, including the name of each 
defined path. Path names can be renamed.

Expand/Collapse Triangle Shows or hides the 
sub-paths associated with a main path (Input 
and Bus paths only).

I/O Setup, Signal Path controls (Input page shown)

Input selector

Expand/Collapse

Path Format selector

Channel Grid
triangle

Active/Inactive
Status box

Path Name
column
Active/Inactive Status Box Shows and changes 
the active/inactive status of each path.

Path Format Selector Shows and selects the 
type/format (such as Mono, Stereo, Quad, or 
5.1) of each defined path (greater-than-stereo 
multichannel formats are supported with 
Pro Tools HD and Pro Tools with Complete Pro-
duction Toolkit only).

Channel Grid Assigns paths to specific inter-
faces and channels. 

I/O Setup Buttons
Depending on the I/O Setup page, the I/O Setup 
can provide the following buttons for configur-
ing signal routing.

New Path Button Lets you create a new path on 
signal path pages for Input, Output, Insert, Bus, 
or Mic Preamp.

New Sub-Path Button Lets you create a new sub-
path on signal path pages for Input, Insert, or 
Bus.

Delete Path Button Lets you delete any selected 
path or sub-path on signal path pages for Input, 
Output, Insert, or Bus.

I/O Setup, Signal Path buttons (Input page shown)
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Import Settings Button Lets you import an I/O 
settings file to reconfigure I/O Setup. Import Set-

tings only imports the settings for the currently 
viewed page of the I/O Setup (such as the Input 
page).

Export Settings Button Lets you save I/O set-
tings as a file that can be imported into other 
sessions or used on other Pro Tools systems. Ex-

port Settings exports the settings for all pages of 
the I/O Setup.

Default Button Resets a path type to its default 
path configuration, depending on the physical 
hardware I/O you are using and how your hard-
ware is configured.

Show Last Saved Setup Appears in the 
I/O Setup in certain session transfer situations. 
For details on this feature, see “Show Last Saved 
Setup and Show Current Setup” on page 117.

Pop-Up Menu Selectors I/O Options Provide se-
lectors with pop-up menus to set paths or or-
ders. The Output and Bus pages provide a Con-
troller Meter Path selector. The Output page 
also provides selectors for Audition Paths (Clip 
List and DigiBase previewing), New Track De-
fault Output, Default Path Order, AFL/PFL Path 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only), and AFL/PFL Mutes 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only). See “I/O Setup Op-
tions” on page 92.

Cancel Button Closes the I/O Setup without sav-
ing changes.

Option-click (Mac) or Alt-click (Windows) 
the Import Settings button to import set-
tings to all pages of the I/O Setup.

Option-click (Mac) or Alt-click (Windows) 
the Default button to restore defaults to 
paths in all pages of the I/O Setup.
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OK Button Closes the I/O Setup and saves any 
changes.

I/O Setup Options
Pro Tools systems have several additional 
I/O Setup options depending on which page of 
the I/O Setup you are viewing. These include de-
fault signal routing for metering and audition-
ing, and default track layout for multichannel 
mix formats.

Compensate for Delays After 
Record Pass
(Pro Tools|HD and HD Native Systems Only)

Pro Tools provide two options for compensating 
for input and output latency (due to ADC and 
DAC) after recording.

Compensation for Input Delays After Record 
Pass

When enabled, this option provides automatic 
compensation for any analog or digital input de-
lay with Avid HD interfaces. Enable this option 
for all recording situations. When recording 
from a digital source, both the Compensation for 

Input Delays After Record Pass and the Compen-

sation for Output Delays After Record Pass op-
tions must be enabled.

The Compensation for Input Delays After Record 

Pass option is only available in the Input page of 
the I/O Setup.

I/O Setup, Signal Path options (Output page shown)



Compensation for Output Delays After 
Record Pass

When enabled, this option provides automatic 
compensation for any analog or digital output 
delay with Avid HD audio interfaces. Enable this 
option when you are synchronized to an exter-
nal clock source. When recording from a digital 
source, both the Compensation for Input Delays 

After Record Pass and the Compensation for Out-

put Delays After Record Pass options must be en-
abled.

The Compensation for Output Delays After Record 

Pass option is only available in the Output page 
of the I/O Setup.

Controller Meter Path
(D-Control, D-Command, C|24, and ProControl 
Only)

The Controller Meter Path selector determines 
the path displayed across the Output meters of 
D-Control or D-Command worksurfaces. For 
more details, see your control surface documen-
tation.

The Controller Meter Path selector is available in 
the Output and Bus pages of the I/O Setup.

Audition Paths
You can specify the output path through which 
files and clips are previewed (auditioned) in the 
Clip List or in DigiBase browsers, and when pre-
viewing AudioSuite processing.

The Audition Paths selector is available in the 
Output and Bus pages of the I/O Setup.

For information on previewing audio, 
see “Previewing Clips in the Clip List” 
on page 275 or “Previewing Audio in Di-
giBase” on page 305.
Using the Default Audition Path

When you preview a file or clip in the Clip List in 
a DigiBase browser, or when AudioSuite pro-
cessing, Pro Tools routes the audio output 
through the specified Audition Path. Pro Tools 
assigns a default Audition Path to the first avail-
able main Output path of the corresponding for-
mat. You can also select a different Audition 
Path in the I/O Setup.

Configuring Audition Paths

You can specify the monitoring outputs for au-
ditioning audio in the Clip List and DigiBase 
browsers, or for previewing AudioSuite process-
ing, using the Audition Paths pop-up menu. 

Audition Paths Main Menu The main menu con-
sists of all path format choices available on the 
current system (Mono and Stereo on all systems, 
and LCR and greater on Pro Tools HD or 
Pro Tools with Complete Production Toolkit 
only). 

Audition Paths Submenus Each path format 
choice has a submenu listing Output paths of 
that given format. (The mono submenu lists 
Output paths of any format.)

To configure an Audition Path:

 Select a path from the Audition Paths pop-up 
menu or submenus.
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Default Output Bus
You can specify the default output bus path as-
signment for new tracks, in each available for-
mat. 

The Default Output Bus selector is available in 
the Output and Bus pages of the I/O Setup.

To specify a default output for new tracks in the I/O 
Setup:

 Click the Default Output Bus pop-up menu and 
select a format and output bus path.

AFL/PFL Path
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only)

Tracks soloed in AFL (After Fader Listen) or 
PFL (Pre Fader Listen) Solo mode are routed to 
the current AFL/PFL Path, as set with the 
AFL/PFL Path selector.

The AFL/PFL Path selector is available in the 
Output and Bus pages of the I/O Setup.

The Default Output Bus can be set for inter-
nal mix bus paths, as well as for output bus 
paths.

See “Solo Modes” on page 248 for more in-
formation on using AFL or PFL Solo modes.
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To select the AFL/PFL Path output:

 Select a path from the AFL/PFL Path pop-up 
menu.

Setting AFL or PFL Path Levels

You can set a separate master AFL/PFL Path 
level for all AFL solos and all PFL solos.

To set the AFL/PFL Path level for AFL or PFL 
solos:

1  Choose Options > Solo Mode, and select a Solo 
mode, as follows:

• If you want to set the level for AFL solos, 
select AFL.

– or –

• If you want to set the level for PFL solos, 
select PFL.

2  In the Mix or Edit window, Control-click (Win-
dows) or Command-click (Mac) a Solo button on 
any track.

3  Adjust the AFL/PFL Path fader.

4  Click on the new fader position (or press Esc) 
to close the fader display.

Selecting None as the AFL/PFL Path disables 
AFL and PFL Solo modes. When None is se-
lected, AFL and PFL cannot be used.

If you do not see the AFL/PFL Path selector, 
confirm that you have installed the Sur-
round Mixer in the Plug-Ins (Used) folder. 
For information on switching Mixer plug-
ins, see the Pro Tools|HD User Guide.

Tracks do not need to be soloed to have the 
master AFL/PFL Path level adjusted. 

To set the AFL/PFL Path level to 0 dB, Con-
trol-Start-click (Windows) or Command-
Control-click (Mac) any Solo button.



AFL/PFL Mutes (Output Path)
(Systems without a D-Control or D-Command 
Control Surface)

If you are not using a D-Control or D-Command 
worksurface, your regular Pro Tools output path 
can be muted when you send a signal to the 
AFL/PFL Path. The muted path is set with the 
AFL/PFL Mutes (Output Path) selector.

The AFL/PFL Mutes selector is available in the 
Output and Bus pages of the I/O Setup.

To set which output path is muted when tracks are 
soloed in AFL or PFL Solo mode:

1  Choose Setup > I/O.

2  Click the Output tab to display the Output 
page.

3  Select a path from the AFL/PFL Mutes (Output 
Path) pop-up menu.

4  Click OK to save your changes to the I/O Setup 
and close the I/O Setup.

Low Latency Monitoring
(HD Native Systems Only)

With HD Native systems, the Output page of the 
I/O Setup lets you enable (or disable) Low La-
tency Monitoring. It also lets you specify any 
available Output path for Low Latency Monitor-
ing. The Output path for Low Latency Monitor-
ing can be of any channel width (from Mono to 
7.1). Low Latency Monitoring uses Outputs 1–2 
by default.

See “Solo Modes” on page 248 for more 
information on selecting and using AFL or 
PFL Solo modes.
To configure Low Latency Monitoring in the I/O 
Setup:

1  Open the I/O Setup dialog (Setup > I/O).

2  Click the Output tab.

3  Enable the Low Latency Monitoring option.

4  From the Low Latency Monitoring pop-up 
menu, select the Output path you want to use for 
Low Latency Monitoring.

5  Click OK to save your changes and close the 
I/O Setup.

Default Monitor Format
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

The Default Monitor Format pop-up menu lets you 
select the default monitor format (Stereo, 5.1, or 
7.1) for new Output paths and for when you click 
the Default button. 

This setting does not affect existing path defini-
tions or metering—it only specifies channel 
mapping in new 5.1-format paths. 

The Default Monitor Format selector is only avail-
able in the Output page of I/O Setup.

To choose a Default Monitor Format:

 Select the channel mapping from the Default 

Monitor Format pop-up menu. 

5.1 Path Order
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

The 5.1 Path Order pop-up menu lets you specify 
the default track layout for all new 5.1 format 
paths you create. 

For more information about multichannel 
mixing, see Chapter 47, “Pro Tools Setup 
for Surround.”
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The 5.1 Path Order selector is available in the In-
put, Output, and Insert pages of the I/O Setup.

To choose a new default 5.1-format path order 
(track layout):

1  Choose Setup > I/O. 

2  Click the Output tab.

3  Use the 5.1 Default Path Order setting to select 
the track layout you want (C|24/Film, 
SMPTE/ITU, DTS/ProControl Monitoring, or 
D-Command/D-Control). 

Sessions Overwrite Current 
I/O Setup When Opened
This option determines whether or not, when 
opening a session, Input, Output, and Insert I/O 
settings as currently configured on your system 
will be overwritten by any of these I/O Settings 
stored with a session. 

 When the Sessions Overwrite Current I/O Setup 

When Opened option is disabled, Pro Tools re-
calls these settings from the system. Choose this 
option when exchanging sessions among differ-
ent systems running Pro Tools 8.1 or higher (see 
“Session Interchange” on page 115).

 When the Sessions Overwrite Current I/O Setup 

When Opened option is enabled (default), 
Pro Tools recalls these settings from the session 
rather than the system. Choose this option when 
exchanging sessions with systems running 
Pro Tools 8.0.x and lower (see “Session Inter-
change” on page 115). 

Enable the Sessions Overwrite Current I/O 
Setup When Opened option for legacy 
Pro Tools behavior (versions lower than 
8.1). This option is enabled by default.

Enabling or disabling this option in any 
page of the I/O Setups affects all of the other 
pages as well.
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Customizing I/O Settings
The following shows how to customize your I/O 
settings for your particular studio setup. Mak-
ing sure that Sessions Overwrite Current I/O 

Setup When Opened option is not enabled en-
sures that your custom settings remain intact 
when opening sessions.

To customize I/O Settings:

1  Open the I/O Setup (Setup > I/O).

2  If desired, import I/O settings from an existing 
I/O settings .pio file (see “Importing I/O Set-
tings” on page 114).

3  For Pro Tools|HD and HD Native systems, dou-
ble-click the label above an interface and enter a 
name.

4  Click the Input tab:

• Create input paths and sub-paths with ap-
propriate widths and physical input assign-
ments that match your studio configuration 
(see “Signal Path Routing for Audio Out-
put” on page 100).

• Rename input paths and sub-paths to 
match your studio configuration.

If you are using an HD OMNI, be sure to 
configure the Monitor page of the Hardware 
Setup for HD OMNI before configuring the 
I/O Setup. For more information, see the HD 
OMNI Guide.

You can prepare a session for use on a differ-
ent system this way. Any paths for hardware 
that is not present on the current system will 
appear as inactive.

With systems using Pro Tools|HD or HD NA-
tive hardware, the I/O Setup bases default 
Input and Output path names on the custom 
name given to the interface.



5  Click the Output tab:

• Create output paths with appropriate 
widths and physical output assignments 
that match your studio configuration.

• Rename output paths to match your studio 
configuration. Use standard industry ter-
minology whenever possible (see “Recom-
mended Output Path Naming Schemes” on 
page 105).

6  If you plan on using hardware inserts, click the 
Insert tab:

• Create insert paths with appropriate widths 
and physical input and output assignments 
that match your studio configuration. 

• Name insert paths to match your studio 
configuration. Name insert paths using 
standard industry terminology if possible, 
such as “Compressor,” “Reverb,” “EQ,” and 
so on.

• Click the H/W Insert Delay tab and enter the 
correct insert delay in milliseconds for 
each input/output pair that you are using 
for hardware inserts. (See “H/W Insert De-
lay (Compensation) Page” on page 90.)

7  If you are using one or more PRE peripherals, 
click the Mic Preamps tab and configure it ac-
cordingly (see the PRE Guide).

8  Click the Bus tab.

9  Create internal mix bus paths and sub-paths. 
Ensure that output busses are mapped to the cor-
rect output paths (see “Output Busses” on 
page 109).

 Output busses are automatically created 
and mapped to outputs when new output 
paths are created.
10  In any of the I/O Setup pages, make sure that 
the Sessions Overwrite Current I/O Setup When 

Opened option is not enabled. This way, when 
opening sessions created on another system, 
your custom I/O settings remain intact.

11  If desired, export your I/O settings to create a 
backup of your current settings (see “Exporting 
I/O Settings” on page 115).

12  Click OK. You should not have to open the I/O 
Setup again unless you add or remove hardware 
to or from your system, or if you open a session 
created on a different system (see “Session Inter-
change” on page 115).

Configuring Hardware in 
I/O Setup
(Pro Tools|HD and HD Native Systems Only)

With Pro Tools|HD and HD Native systems, you 
can define which physical ports on your audio 
interface are routed to available input and out-
put channels in the I/O Setup. Any changes 
made here are also reflected in the Hardware 
Setup, and vice-versa (see “Configuring 
Pro Tools Hardware Settings” on page 70).

To configure I/O routing in I/O Setup:

1  Choose Setup > I/O.

2  Click the Input or Output tab to display the cor-
responding path type. 

3  Click the Input or Output selector for the first 
interface channel pair, located below the first 
audio interface icon.

 HD MADI, and Pro Tools systems such as 
the Mbox Pro and the 003 are “hard-wired” 
and cannot be changed. For third-party and 
built-in hardware, in the Hardware Setup 
click the Launch Setup App button to for 
available configuration options.
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4  From the pop-up menu, select a physical port 
pair (such as Analog 1–2), to route to a Pro Tools 
channel pair (such as A 1–2) in the Path Name 
column on the left.

5  Repeat the above step for additional channel 
pairs.

6  Click OK to save changes and close the I/O 
Setup.

Routing a Pro Tools Output Pair 
to Multiple Destinations
Pro Tools channel pairs can be routed to multi-
ple outputs on an audio interface through the 
I/O Setup. For example, if you assign both Ana-
log 1–2 and Analog 3–4 interface outputs to 
Pro Tools Output pair 1–2, when you send a sig-
nal to Pro Tools Outputs 1–2, that signal will be 
routed simultaneously to both pairs of output 
ports on your audio interface.

This lets you send the same signal (such as a ste-
reo pair, a stem mix, or a multichannel mix) to 
multiple destinations (such as multiple master-
ing devices).

I/O Channel selector pop-up menu

 The Monitor path for HD OMNI is fixed and 
cannot be changed in the I/O Setup. The 
Monitor path for HD OMNI can be config-
ured in the Monitor page of the Hardware 
Setup.
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The only limit to output choices is the number of 
outputs available in your system.

Pro Tools outputs pairs can also be routed to 
multiple audio interface outputs in the Hard-
ware Setup.

To route a Pro Tools output channel pair to 
multiple audio interface output ports:

1  Choose Setup > I/O.

2  Click the Output tab. 

3  Click the Output selector for an interface 
channel pair, just below an audio interface icon. 

4  From the pop-up menu, select a physical port 
pair (such as Analog 1–2) to route to the corre-
sponding Pro Tools channel pair (such as A 1–2) 
in the Path Name column on the left.

5  Start-click (Windows) or Control-click (Mac) 
the same Output selector and select an addi-
tional output pair from the same pop-up menu.

The output name updates with a plus sign (“+”) 
before it to indicate that multiple output ports 
are selected. In the pop-up menu, each physical 
port pair assigned to that Pro Tools output pair 
is indicated by a check mark.

6  Repeat the above steps to select additional out-
put destinations. 

7  Click OK to save changes and close the 
I/O Setup.

0utput path assignments can overlap in 
certain situations. See “Valid Paths and 
Requirements” on page 109 for details.



Signal Path Routing for Audio Input
The following example shows the signal path from the physical analog input of an HD OMNI audio in-
terface, and then through the Pro Tools audio input path to the Input of an audio track in the 
Pro Tools mixer:
Input signal path from an HD OMNI to the Pro Tools mixer as mapped in I/O Setup

3

2

1

(1) Physical Input For Avid HD interfaces, such 
as the HD OMNI, the physical inputs that are 
available to Pro Tools are set on the Main page 
of the Hardware Setup (this selector is mirrored 
in the Input page of the I/O Setup). 

For Pro Tools systems such as the Mbox Pro 
and the 003, physical inputs are fixed. For 
third-party and built-in hardware, in the 
Hardware Setup click the Launch Setup App 
button for available configuration options.
(2) Input Path Main input paths and sub-paths 
are routed (patched) to physical inputs using 
cross-point matrix mapping in the I/O Setup. In 
this example, audio input is routed from HD 
OMNI physical inputs Analog 1–2 to Pro Tools 
Input channels A 1–2.

(3) Track Input Input paths and sub-paths are 
routed to track inputs in the Pro Tools mixer by 
selecting the path (or sub-path) from the Track 
Input selector. In this example, input sub-path 
A1 is routed to the input of track “Audio 1.”
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Signal Path Routing for Audio Output
The following example shows the signal path from the output of an audio track, through an output bus 
mapped to an output path that is routed to a physical output on an HD I/O audio interface:
Pro Tools Reference Guide
Output signal path from an audio track to a physical output as mapped in I/O Setup

3

4

2

1

(1) Track Output Audio is played back from disk 
and routed from the Track Output to Output Bus 
“B 1–2.”

(2) Output Bus Path The Output Bus is defined 
on the Bus page of the I/O Setup. On the Bus 
page of the I/O Setup, the Output Bus “B 1–2” is 
mapped to Output “B 1–2,” which is defined on 
the Output page of the I/O Setup.
(3) Output Path On the Output page of the I/O 
Setup, the Grid is used to route the output path 
(to which the output bus is mapped) to physical 
outputs. 

(4) Physical Output For Avid HD audio inter-
faces, such as the HD OMNI, the physical out-
puts that are available to Pro Tools are set on the 
Main page of the Hardware Setup (this selector 
is mirrored in the Output page of the I/O Setup).



Creating New Paths
The I/O Setup lets you create new paths with 
custom names, formats, and assignments to 
physical I/O. Custom path names appear in a 
session’s track Input, Output, Insert, and Bus 
selectors.

To create a new path:

1  Choose Setup > I/O.

2  Click the Input, Output, Insert, or Bus tab to dis-
play the corresponding path type.

3  Click New Path. 

4  In the New Path dialog, specify the number of 
new paths you want to create, the channel width 
for each path, and the path name.

For Pro Tools systems such as the Mbox Pro 
and the 003, physical outputs are fixed. For 
third-party and built-in hardware, click the 
Launch Setup App button in the Hardware 
Setup for available configuration options.

New Paths dialog
5  Do any of the following:

• To add more paths, click the Add Row but-
ton.

– or –

• To remove a path, click the Remove Row 
button.

6  Enable (or disable) the New Paths options Add 

the Default Channel Assignments and Auto-Create 

Sub-paths.

7  Click Create.

8  Assign the path to a specific audio interface 
(Input, Output, and Insert pages only) in the 
Grid column. See “Assigning Paths to Hardware 
I/O” on page 107.

9  Repeat the previous steps to configure all path 
types (Input, Output, Insert, or Bus).

Add a new path by pressing Command+N 
(Mac) or Control+N (Windows), or by 
pressing Command+Plus (+) (Mac) or Con-
trol+Plus (+) (Windows) on the numeric 
keypad. 

To remove the last path from the New Path 
dialog Command+Minus (–) (Mac) or Con-
trol+Minus (–) (Windows).

When you create a new Output path, an out-
put bus is automatically created on the Bus 
page of the IO Setup, and is automatically 
mapped to the output path you created. See 
“Output Busses” on page 109.
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10  Click OK to save changes and close the I/O 
Setup. If there are any identically named paths, 
you will be instructed to correct them before the 
I/O Setup will close. For more information, see 
“Valid Paths and Requirements” on page 109.

New Paths Dialog
The New Paths dialog lets you create new paths 
on the Input, Output, Bus, and Insert pages of 
the I/O Setup.

New Path Row Settings

Number of New Paths Enter the number of new 
paths you want to create (or a certain type, like 
“Bus”).

Path Format Select the channel width from the 
Path Format selector.

Path Name Enter the path name. If you are cre-
ating more than one path, the number of each 
new path created will be appended to the path 
name (for example, Bus 1, Bus 2, Bus 3, and so 
on).

Add/Remove Rows Click the Add Row button to 
add more paths, or click Click the Remove Row 
button to remove paths.

Multichannel paths and mixing are ex-
plained in Chapter 47, “Pro Tools Setup for 
Surround.”

New Paths dialog

Number of new paths

Path Format Path Name

Add/Remove Row
Pro Tools Reference Guide
Move Row Icon Click and drag a Move Row icon 
up or down to reorder paths.

Add Default Channel 
Assignments Option
Enable Add Default Channel Assignments option 
if you want Pro Tools to automatically assign in-
put, output, and insert paths to physical inputs 
and outputs in the Grid (from the first available 
channel to the maximum number of channels 
available). If the number of new paths of a cer-
tain width exceeds the number of available 
channels, Pro Tools wraps around and starts 
over at channel 1. 

Move Row icon in the New Paths dialog



Auto-Create Sub-Paths Option
For input, bus, and insert paths, enable the Auto 

Create Sub-Paths option to have Pro Tools auto-
matically create the default set of sub-paths for 
the path format (channel width), as follows:

Default Sub-Paths

Main 
Path

Sub-Paths Sub-Path Name

Mono N/A N/A

Stereo 2 mono <main path 
name> followed 
by channel desig-
nation .L and .R

LCR 1 Stereo (LR), 3 
Mono (one for 
each channel)

Stereo: <main 
path name>.LR
Mono: <main 
path name>.L, 
.C, .R

LCRS 1 Stereo (LR), 4 
Mono (one for 
each channel)

Stereo: <main 
path name> .LR
Mono: <main path 
name>.L, .C, .R, 
.S

Quad 1 Stereo (LR), 4 
Mono (one for 
each channel)

Stereo: <main 
path name> .LR
Mono: <main path 
name>.L, .R, .Ls, 
.Rs

5.0 – 6.0 
– 7.0

1 Stereo (LR), 
5–7 Mono (one 
for each chan-
nel)

Stereo: <main 
path name>.LR
Mono: <main 
path name>.L, 
.C, .R, .Ls, .Rs, 
and so on

5.1 – 6.1 
– 7.1

1 Stereo (LR), 
6–8 Mono (one 
for each chan-
nel)

Stereo: <main 
path name>.LR
Mono: <main 
path name>.L, 
.C, .R, .Ls, .Rs, 
and so on, and 
LFE
Creating New Sub-Paths
You can create sub-paths for main paths in the 
Input, Bus, and Insert pages of the I/O Setup.

To create a new sub-path:

1  Select the page of the I/O Setup where you 
want to create sub-paths (such as the Input 
page).

2  Select the Main path for which you want to cre-
ate sub-paths.

3  Click New Sub-Path.

4  Name the new sub-path.

5  Select the Format for the new sub-path (such 
as Mono).

6  Click in the Grid to assign the new sub-path 
channels to available main path channels.

You cannot create sub-paths for outputs in 
the Outputs page of IO Setups. You can, 
however create overlapping output paths. 

With Pro Tools|HD systems, to optimize 
DSP resources, it is best to create mono sub-
paths for output busses and internal mix 
busses, rather than mono main paths.
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Editing Paths
The I/O Setup lets you edit or customize signal 
path definitions. 

Paths can be:

• Restored to default configurations

• Renamed, for easier identification after 
changing or renaming audio interfaces

• Selected and reordered to change menu or-
der in track selectors

• Selected and deleted

• Remapped to or from different sources or 
destinations

• Deactivated (or reactivated) to manage un-
available or unnecessary I/O resources

In addition, you can import and export your 
I/O Setup configurations as I/O Settings files, as 
well as set default path parameters. See “I/O Set-
tings Files” on page 114.

The following table lists the available attributes 
for each path type:

Interfaces can also be renamed.

Path options that can be edited by type

Path Type Path Options (Attributes)

Input Names, formats, and source 
channel (physical input)

Output Names, formats, and destination 
channel (physical output)

Insert Names, formats, and destination 
(physical inputs and outputs)

Bus Names, formats, output mapping
Pro Tools Reference Guide
Restoring Default Paths and 
Path Names
You can restore I/O Setup paths to their default 
state at any time. You may want to restore de-
faults if, for example, you replace or add an au-
dio interface to your system. 

To restore default paths and path names:

1  Choose Setup > I/O.

2  Click the Input, Output, Insert, or Bus tab to dis-
play the corresponding path type.

3  Click Default. Pro Tools does the following:

• If a session is open, deletes any paths that 
are not in use.

• Creates new default paths up to the capacity 
of your system’s available physical I/O and 
resources. 

• Resets path names to the default path 
names (see “Default Path Names” on 
page 106). These default path names appear 
in track Input and Output Path selectors.

4  Click OK to save changes and close the I/O 
Setup.

Option-click (Mac) or Alt-click (Windows) 
the Default button to set all pages of I/O 
Setup to the default settings.

Default stereo output paths



Renaming Paths
Path names can be customized in the I/O Setup.

To rename a path in the I/O Setup:

1  Double-click the path name.

2  Type a new path name.

3  Click OK to save changes and close the I/O 
Setup.

Recommended Output Path Naming 
Schemes

Generally, you will want to use standard naming 
schemes for output paths in your Pro Tools ses-
sions. This facilitates smoother session ex-
change between different Pro Tools systems. 

I/O paths can also be renamed directly from 
the Edit or Mix window by Right-clicking 
the Input or Output selector and choosing 
Rename.

New mono Input sub-path for Main path A 1-2
Here are some examples of standard industry 
naming schemes:

• Main A, Main B

• Studio A, Studio B

• Stereo A, Stereo B

• Meter

• Monitor

• Aux A, Aux B

• Cue A, Cue B, Cue C, Cue D, Cue E, Cue F, 
Cue G, Cue H, Cue I, Cue J

• Dial Main, Dial A, Dial B, Dial C, Dial B, 
Dial E

• Efx Main, Efx A, Efx B, Efx C, Efx D, Efx E

• Music Main, Music A, Music B, Music C, 
Music D, Music E

Renaming Interfaces 
Audio interfaces can be renamed in the IO 
Setup. When you rename Avid HD audio inter-
faces, default path names are based on the cus-
tom name given to the interface.

To rename an audio interface in the I/O Setup:

1  Double-click the label above an interface.

2  Type a new interface name.

3  Click OK to save changes and close the I/O 
Setup.

Interface Names
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Default Path Names

Default names for input, output, and insert 
paths are based on the hardware you are using 
for physical I/O. 

For Pro Tools|HD and HD Native systems, de-
fault path names are based on the names of in-
terfaces you are using. If you have renamed your 
interface, default path names are based on the 
custom name.

Selecting Paths
Individual and multiple paths can be selected in 
the I/O Setup Path Name column. Selected paths 
and sub-paths can be reordered higher or lower 
in the Path Name column to change their menu 
order in track Input, Output, Insert, and Bus se-
lectors. Paths can also be deleted. Sub-paths fol-
low their main paths when they are moved in the 
I/O Setup.

To select a main path or sub-path:

 Click the path name.

To select a range of paths:

1  Click the path name.

2  Shift-click an additional path name.

All paths between the first selected path name 
and the additional path name will also be 
selected.

Selecting paths in the I/O Setup
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To select or deselect noncontiguous paths, do one 
of the following:

 Command-click (Mac) or Control-click (Win-
dows) path names that are un-highlighted to se-
lect them.

– or –

 Command-click (Mac) or Control-click (Win-
dows) path names that are highlighted to dese-
lect them.

To select all paths and sub-paths:

 Option-click (Mac) or Alt-click (Windows) 
any path name that is un-highlighted.

To deselect all paths and sub-paths:

 Option-click (Mac) or Alt-click (Windows) 
any path name that is highlighted.

Reordering Paths
Selected paths and sub-paths can be reordered 
higher or lower in the Path Name column to 
change their menu order in track Input, Output, 
Insert, and Bus selectors.

To reorder paths in the I/O Setup and Track 
selectors:

1  Drag one or more selected path names up or 
down.

2  Click OK to save changes and close the I/O 
Setup.

Deleting Paths
Path definitions can be deleted from the current 
session to reflect changes to your hardware 
setup, or to clean up track selector menus by re-
moving unwanted or unnecessary path defini-
tions. After deleting a path, any tracks or send 
assignments to that path are reset to No Output.



To delete a main path or sub-path:

1  In the I/O Setup, select the path you want to 
delete.

2  Click Delete Path. 

3  Click OK to save changes and close the I/O 
Setup.

To delete all paths:

1  Option-click (Mac) or Alt-click (Windows) any 
path name.

2  Click Delete Path.

3  Click OK to save changes and close the I/O 
Setup.

Making Paths Active or Inactive
Pro Tools paths can be Active (on) or Inactive 
(off, or unavailable). Paths can be globally acti-
vated or deactivated in the I/O Setup. Making a 
signal path inactive will turn off the signal path 
on any and all tracks currently assigned to it.

Pro Tools also sets unavailable paths to inactive. 
Paths can be unavailable when hardware or 
other system resources are unavailable, such as 
when opening a session saved on a different 
system.

Tracks can also be made active or inactive. For 
information, see “Making Track Inputs and Out-
puts Inactive from the Edit or Mix Window” on 
page 239.

To globally activate or deactivate a path:

1  Choose Setup > I/O. 

2  Select a path type using the tabs at the top of 
the window. 
3  Set the Active/Inactive control for the path. 

Any tracks that were assigned to the now inac-
tive path will show that path's name in italics on 
the track's I/O selectors.

4  Click OK to save changes and close the I/O 
Setup. Path status is displayed as follows:

Italics Indicates the path is inactive.

Non-Italics Indicates the path is active.

Assigning Paths to Hardware 
I/O
Paths are assigned to specific inputs, outputs, 
and inserts in the Grid. Paths can be assigned to 
physical I/O in the Grid, and can be reassigned 
at any time.

To assign channels:

1  Select (or create) a main path or sub-path. 

2  Select the channel Format (such as Stereo).

Active (top) and inactive (bottom) path settings

With overlapping output paths of different 
channel widths, if the widest path is made 
inactive, all other overlapped output paths 
will not pass audio from Pro Tools.
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3  In the row for the selected path, click in the 
Grid column under an audio interface and chan-
nel. 

Other channels for the path type, if any, fill to 
the right. For example, when assigning a new 
stereo path, clicking in the path row under out-
put channel 1 fills both channel 1 and 2 (left 
to 1, right to 2). 

4  Click OK to save changes and close the I/O 
Setup.

If there are any invalid settings, you will be re-
quired to correct them before the I/O Setup will 
close. For more information, see “Valid Paths 
and Requirements” on page 109.

Assigning Paths with the Surround Mixer

(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

When assigning multichannel paths, the left 
channel (L) is assigned first to the clicked Grid 
box, and remaining channels fill immediately to 
the right according to the default path order. 

Assigning channels

To reassign channels in a path, see “Re-
assiging Paths” on page 108.
Pro Tools Reference Guide
Because some multichannel mixing formats use 
unique track layouts, Pro Tools lets you set the 
default format in the I/O Setup (see “I/O Setup 
Options” on page 92).

Reassiging Paths
You can move the individual assignments to dif-
ferent channels, to reorder the path’s definition 
(for example, changing a multichannel path to 
L-R-C-LFE-Ls-Rs). 

To reassign channels in a path:

 Drag the channel to the new location in the 
Grid. Other channel assignments move (shuffle) 
to accommodate dragged channels.

Channel Shuffling

Moving a signal from right to left results in a 
shuffle of other signals after the new destination 
channel. Moving a signal from left to right shuf-
fles any and all signals after the new destination 
channel and leaves the previous channel empty. 

Sub-Paths Follow Main Paths

When a main path is reassigned, its sub-paths (if 
any) are reassigned automatically to maintain 
consistent routing. For example, reassigning a 
stereo path to different hardware outputs re-
sults in any of its sub-paths moving with it. 

Customized Output paths for a 5.1 mix

Changing a path’s format erases any 
current channel assignment. 



Valid Paths and 
Requirements
While configuring the I/O Setup, certain rules 
apply for path definition and channel assign-
ment. All paths must be valid before the 
I/O Setup configuration can be applied. 

Though it is possible to set up invalid assign-
ments in the Channel Grid, Pro Tools will not 
accept an I/O Setup configuration unless all 
paths meet the path definition and channel as-
signment requirements, as follows:

Minimum Path Definitions All paths must have a 
name, be of a specific format, and have a valid 
I/O assignment. 

Valid Paths Channel assignment follows certain 
rules regarding overlapping paths. 

• There can be no partial overlaps between 
any two output paths.

• A newly-created output path must either be 
completely independent of other assign-
ments (not assigned to any other available 
I/O interface/channels), or it must be a path 
completely contained within a larger path 
(for example, an LCR sub-path within a 
larger 5.1 path).

Valid (complete) output path
Configuring Busses
Busses appear on the Bus page of the IO Setup. 
Pro Tools provides two types of busses:

• Output busses

• Internal mix busses

Output bus and internal mix bus settings are 
saved with and recalled from the session. The 
advantage of this is that when you take a session 
from one system to another, track and send as-
signments are maintained within the session. 
Where possible, Pro Tools can automatically re-
map the session’s output busses to the output 
paths of the system the session is being opened 
on.

Output Busses
Output busses are mapped (routed) to output 
paths, as configured on the Output page of the 
I/O Setup. Output paths are then assigned to the 
system’s physical audio outputs in the I/O Set-
ups Grid (see “Assigning Paths to Hardware I/O” 
on page 107).

Invalid (partial) output path

See “Session Interchange” on page 115 for 
more information exchanging sessions be-
tween systems, and on opening sessions in 
lower version of Pro Tools. Output busses do 
not exist in Pro Tools 8.0.x and lower. 
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When you create a new output path on the Out-
put page of the IO Setup, a new output bus of the 
same width is automatically created and mapped 
to that output path. Output busses are also cre-
ated and mapped according to default settings 
when creating a new session or restoring de-
faults (see “Restoring Default Paths and Path 
Names” on page 104).

Physical outputs for output paths are configured 
on the Outputs page of the I/O Setups (see “As-
signing Paths to Hardware I/O” on page 107).

Internal Mix Busses 
Pro Tools provides up to 256 internal mix bus-
ses and are used to route audio signal from track 
outputs and sends to other track inputs and 
plug-in side-chains. Common uses for internal 
mix busses include effects sends and returns 
(such as bussing sends from audio tracks to an 
Auxiliary Input track for plug-in effects pro-
cessing) and bus recording.

Internal mix busses can also be mapped to any 
outputs (see “Internal Mix Busses ” on 
page 110).

Creating and Mapping Busses to 
Outputs
Any available bus can be mapped to any of the 
available output paths of the same channel 
width or greater. For example, a mono bus can 
be mapped to a mono output path, a stereo bus 
can be mapped to a stereo output path, and a 5.1 
surround bus can be mapped to a 5.1 surround 
output path.

You can unmap busses from outputs at any time.

To create a bus and map it to an output path:

1  On the Bus page of the I/O Setup, click New 

Path.
Pro Tools Reference Guide
2  In the New Paths dialog, specify the number of 
new paths you want to create, the channel width 
for each path, and the path name.

3  Click Create to create the new paths.

4  Enable Mapping To Output for the path.

5  Select an output path from the Mapping To Out-

put selector.

Any signals from tracks or sends sent to the bus 
are now sent to the hardware outputs assigned 
to the corresponding Output paths.

To map all output busses of the same format to an 
output path:

 Option-click (Mac) or Alt-click (Windows) the 
Mapping To Output selector and select an output 
path (mono or stereo).

All mapped output busses of the same format 
(such as stereo) are all assigned to the same out-
put path. For example, you can assign all stereo 
output busses to output path A 1–2.

New Paths dialog

Unmapped “MAIN” output bus

Mapping the “MAIN” output bus to output path “A 1–2”



To map all output busses of the same format to 
one output path:

1  Do one of the following:

• Shift-click to select contiguous Output 
busses.

– or –

• Command-click (Mac) or Control-click 
(Windows) to select noncontiguous Output 
busses.

2  Option-Shift-click (Mac) or Alt-Shift-click 
(Windows) the Mapping To Output selector for 
one of the selected Output busses and select an 
output path (mono or stereo). 

Only the selected mapped output busses of the 
same format (such as stereo) are assigned to the 
same output path. For example, you can assign 
only the selected stereo output busses to output 
path A 1–2.

To map all busses of the same format to unique 
ascending output paths (cascading):

 Command-Option-click (Mac) or Control-Alt-
click (Windows) the Mapping to Output selector 
of the top-most output path and select the first 
output path. 

All busses of the same channel format are auto-
matically assigned to unique output path assign-
ments in ascending order. For example, for ste-
reo output paths, output bus A 1–2 is assigned to 
output path A 1–2, A 3–4 to A 3–4, A 5–6 to A 
5–6, and so on.
Mapping Mono Busses to Surround 
Paths
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

You can map a mono bus to any channel of a sur-
round output path, for example, route a dia-
logue track to the center channel of 5.1 output 
path. (This capability is available for all output 
channel widths except Stereo and Quad out-
puts.)

To map a mono bus to a channel of a surround 
output path:

1  On the Bus page of the I/O Setup, click New 

Path.

2  In the New Paths dialog, specify Mono channel 
width for the bus path, type a path name, and 
click Create.

3  Enable Mapping To Output for the path.

4  Select a multichannel output path from the 
Mapping To Output selector. The mono bus indi-
cator changes to “C” (Center) by default, and a 
pop-up menu becomes available.

Selecting a multichannel output path
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5  To assign another channel, click the mono bus 
indicator and select the channel from the pop-up 
menu.

To assign the same channel to all mono busses 
mapped to a multichannel output path:

 Option-click (Mac) or Alt-click (Windows) the 
mono bus indicator and select the channel from 
the pop-up menu. 

To assign the same channel to all selected mono 
busses mapped to a multichannel output path:

1  Do one of the following:

• Shift-click to select contiguous mono
busses in the Name column.

– or –

• Command-click (Mac) or Control-click 
(Windows) to select noncontiguous mono 
busses in the Name column.

2  Option-Shift-click (Mac) or Alt-Shift-click 
(Windows) a mono bus indicator and select the 
channel from the pop-up menu. 

To assign ascending (cascading) channels to all 
mono busses mapped to a multichannel output:

 Command-Option-click (Mac) or Control-Alt-
click (Windows) the mono bus indicator of the 
top-most mono bus and select the first channel 
from the pop-up menu. 

Assigning a channel to a mono bus
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To assign ascending (cascading) channels to all 
selected mono busses mapped to a multichannel 
output:

1  Do one of the following:

• Shift-click to select contiguous mono
busses in the Name column.

– or –

• Command-click (Mac) or Control-click 
(Windows) to select noncontiguous mono 
busses in the Name column.

2  Command-Option-Shift-click (Mac) or Con-
trol-Alt-Shift-click (Windows) the mono bus in-
dicator of the top-most mono bus and select the 
first channel from the pop-up menu. 

Resetting Busses
You can reset the number of available internal 
mix busses in your session to match your sys-
tem’s full capabilities by reverting to the default 
bus configuration.

To revert to the default bus configuration for your 
system:

1  Open the I/O Setup.

2  Click the Bus tab in the upper left.

3  From the pop-up menu to the right of the De-

fault button, select one of the following:

• All Busses 

• Output Busses 

• Internal Busses 

4  Click Default. 

Pro Tools creates 128 (out of 256 possible) 
internal busses by default. 

Resetting busses to the default setting will 
rename all busses to their default name 
(Bus 1–2, Bus 3–4, and so on).



5  Click OK to save changes and close the I/O 
Setup.

Active Busses

The Bus page of the I/O Setup displays the num-
ber of active internal mix busses. If the number 
of active busses exceeds the number of available 
busses (256), the display turns red. Delete or de-
activate any active busses in excess of the avail-
able number of busses to be able close the I/O 
Setup and save your settings.

Sorting Bus Paths
The Bus page provide controls to sort busses by 
name (ascending or descending), format (as-
cending or descending), or by mapped to output 
status (ascending only).

To sort bus paths by Name:

1  In the Bus page, click the Name column 
header. 

2  Click the Name column header again to toggle 
between ascending and descending sort order.

To sort bus paths by Format:

1  In the Bus page, click the Format column 
header. 

Sorting bus paths in the I/O Setup

Click to sort by Name Click to sort by map-
ping to output status

Click to sort by Format
2  Click the Format column header again to toggle 
between ascending and descending sort order.

To sort bus paths by Mapping To Output status:

 In the Bus page, click the Mapping To Output 

column header. 

Factory I/O Settings
Pro Tools provides factory I/O settings for ste-
reo and surround mixing, and are automatically 
installed with Pro Tools. These settings provide 
new sessions with generic path and sub-paths 
for either mixing format.

Factory I/O settings are available in the I/O Set-
tings pop-up menu of the Quick Start or New 
Session dialog.

Stereo Mix Settings
This Stereo Mix setting creates the maximum 
number of stereo paths, as determined by the 
available system’s I/O Setup and hardware con-
figuration.

Surround Mix Settings 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

The Surround Mix setting provides additional, 
surround-specific Output and Bus settings files. 

Using the “Stereo Mix” settings file has the 
same effect as clicking Default for every in-
dividual tab in I/O Settings. See “Restoring 
Default Paths and Path Names” on 
page 104.

See Chapter 47, “Pro Tools Setup for 
Surround.”
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I/O Settings Files
I/O settings files (.pio files) provide default path 
configurations for new sessions. I/O settings can 
be imported and exported for use with sessions 
shared between systems. I/O settings files are 
also available in the I/O Settings pop-up menu 
in the Quick Start and New Session dialogs.

For I/O settings files to be available in the Quick 
Start or New Session dialogs, I/O settings files 
must be saved to the IO Settings folder in the 
following locations:

Mac Applications/Avid/Pro Tools/IO Settings

Windows Program Files\Common 
Files\Avid\DAE\IO Settings

Last Used I/O Settings
If any changes are made to the I/O Setup, these 
changes are automatically saved to the IO Set-
tings folder as the Last Used settings file when 
the I/O Setup is closed (by clicking OK).

Last Used settings are available in the IO Set-
tings pop-up menu in the Quick Start or New 
Session dialog, or when importing I/O Settings 
in the I/O Setup.

Custom I/O Settings
Custom I/O Settings files can be created by 
changing I/O Setup settings (see “Customizing 
I/O Settings” on page 96), and then exporting 
the settings. These I/O settings can then be re-
stored by importing them into a system.

This lets you save settings for different projects, 
import settings to reconfigure the I/O Setup, 
and manage path definitions and signal routing 
setups. 
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Importing I/O Settings
I/O Settings can be imported before or after you 
open a session. I/O Settings are only imported 
for the current page of the I/O Setup. For exam-
ple, if you are viewing the Output page and im-
port I/O Settings, only the settings for the Out-
put page are imported. This helps to avoid 
overwriting your custom I/O Settings on other 
pages.

When you import I/O Settings, you can choose 
to delete any unused path definitions before im-
porting the new paths, or leave unused path def-
initions intact and add the new paths to the cur-
rent I/O Setup configuration.

To import I/O Settings:

1  Click the tab for the page of the I/O Setup for 
which you want to import settings.

2  Click Import Settings.

3  Select an I/O settings file in the Import Set-
tings dialog and click Import.

4  A dialog appears asking whether you want to 
delete existing paths. Do one of the following:

• Click Yes to remove any unused paths and 
add the imported paths to the current I/O 
Setup configuration.

– or –

• Click No to add the imported paths to the 
current I/O Setup configuration. 

You can also import I/O paths and path 
names, as well as other session data, from a 
different session by using the Import Session 
Data command (File > Import > Session 
Data). For information, see “Importing Ses-
sion Data” on page 352.

Option-click (Mac) or Alt-click (Windows) 
the Import Settings button to import set-
tings to all pages of I/O Setup.



If the import results in overlapping paths, the 
new paths will appear in the I/O Setup as Inac-
tive. See “Making Paths Active or Inactive” on 
page 107.

After importing I/O Settings, you can then reas-
sign path routing definitions in the I/O Setup by 
remapping, renaming, and deleting paths. See 
“Pro Tools Signal Paths” on page 86.

Exporting I/O Settings
When you export I/O settings, all pages of the 
I/O Setup are exported.

To export and save an I/O Setup configuration as a 
custom I/O Settings file:

1  Configure the I/O Setup settings.

2  Click Export Settings. 

3  Name and save the settings file. The settings 
file is appended with “.pio” to distinguish it as an 
I/O settings file.

To start sessions with a blank or empty 
I/O Setup, you can create and export an I/O 
Settings file in which all definitions have 
been deleted. 
Session Interchange
When exchanging a session between Pro Tools 
systems, you may need to reconfigure the ses-
sion’s I/O settings. This will depend on system 
ID, path names and path format, as well as on 
the Pro Tools versions of each system on which 
the session is transferred.

Path Names and Automatic 
Output Bus Remapping
A system ID is created and saved in a session for 
every computer the session is opened on (using 
the computer’s MAC address). If Pro Tools finds 
a matching system ID when opening a session, 
output paths are restored and no reconfigura-
tion is necessary.

When a Pro Tools session is opened on a system 
for the first time, Pro Tools attempts to auto-
matically remap output busses.

If Pro Tools does not find a matching system ID, 
Pro Tools attempts to remap output busses ac-
cording to the following criteria (in order):

Path Name and Format Path names must be ex-
actly the same, and of the same format. Use the 
suggested path naming schemes (see “Recom-
mended Output Path Naming Schemes” on 
page 105).

Path Format Only If matching path names are 
not found, Pro Tools remaps paths to existing 
paths of the same format (channel width).

Any output bus path that cannot be automati-
cally remapped is opened as Inactive. You must 
manually remap those paths to an active output 
path.
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Pro Tools Versions and Session 
Interchange
When exchanging a session between systems 
with different versions of Pro Tools software 
(such as your Pro Tools 10.0 system and a col-
league’s Pro Tools 7.x system), you can use the 
following to maintain paths and signal routing.

Pro Tools 8.1 and Higher

When exchanging sessions among systems run-
ning Pro Tools 8.1 or higher, it is generally rec-
ommended that the Sessions Overwrite Current 

I/O Setup When Opened option be disabled. This 
maintains any system IO settings when opening 
a session from another system (see “Sessions 
Overwrite Current I/O Setup When Opened” on 
page 96).

Pro Tools 8.0.x and Lower

When exchanging sessions with systems run-
ning lower versions of Pro Tools, it is generally 
recommended that the Sessions Overwrite Cur-

rent I/O Setup When Opened option be enabled 
(see “Sessions Overwrite Current I/O Setup 
When Opened” on page 96). In this case, any 
custom settings saved with the session that do 
not match your system may need to be reconfig-
ured manually in the I/O Setup to match your 
current studio setup.

If you created a backup of your I/O settings, 
you can import settings after opening the 
session (see “Importing I/O Settings” on 
page 114).
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Opening Older Sessions in Pro Tools 8.1 and 
Higher

When opening sessions created in Pro Tools 
8.0.x and lower in Pro Tools 8.1 or higher, output 
paths from the legacy session are re-created as 
output buses. If the Sessions Overwrite Current 

I/O Setup When Opened option is enabled, the 
output buses are mapped to session output 
paths.

Path Order and Overlapping Output Paths

When exchanging sessions between Pro Tools 
8.1 or higher and Pro Tools 8.0.x and lower, out-
put paths and sub-paths are changed as follows, 
depending on the order in which they appear in 
the I/O Setups.

 If a session created in Pro Tools 8.1 or higher 
contains overlapping paths with a larger path 
created above smaller paths in the I/O Setup, the 
smaller paths are converted to sub-paths of the 
larger path when the session is opened in 
Pro Tools 8.0.x and lower.

 If a session created in Pro Tools 8.1 or higher 
contains overlapping paths where a smaller path 
appears above a larger path in the I/O Setup, the 
larger path will be made inactive when the ses-
sion is opened in Pro Tools 8.0.x and lower.

If your hardware configuration has 
changed, you may need to manually recon-
figure output assignments in the Grid on the 
Output page of the IO Setup. See “Assigning 
Paths to Hardware I/O” on page 107.



Show Last Saved Setup and 
Show Current Setup
When a session is opened that contains path def-
initions for unavailable I/O interfaces, the 
I/O Setup lists those paths in italics. 

Clicking the Show Last Saved Setup button dis-
plays the audio interfaces used in the original 
session. This temporary display lets you check 
the last saved I/O configuration for reference 
while configuring the I/O settings for your sys-
tem. 

Once a session has been opened with unavailable 
I/O retained, you can then reassign tracks to 
available I/O paths. 
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Chapter 8: Preferences
The settings in the Pro Tools Preferences define 
how Pro Tools features work. The Preferences 
dialog has several tabbed pages in which you can 
specify your preferred settings.
To change Pro Tools preferences:

1  Choose Setup > Preferences.

2  Click the tab for the page that has preferences 
you want to change. 

3  Change preferences.

4  Click OK to save your changes and close the 
Preferences dialog.
Pro Tools Preferences on a Pro Tools|HD system (Display Preferences page shown)
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Global and Local Preferences
Pro Tools preferences are either global (system-
wide) or local (for the current session only). 

Global (System-Wide) Preferences Global pref-
erences are applied to all sessions. These prefer-
ences become the default preferences for any ex-
isting sessions that you subsequently open or 
any new sessions that are created.

Local (Current Session) Preferences Local pref-
erences are applied to the current session (if one 
is open). Local preferences are not applied to 
older sessions that are subsequently opened.

Preferences and New Sessions

New sessions use global preference settings, 
plus the most recent local preference settings. 
The most recent local settings refer to the last 
open session (unless subsequent changes were 
made in the Preferences from the application 
window).

Local (Current Session) 
Preferences List
All Preferences are global, except for the follow-
ing, which are local:

• Display Preferences

• Edit Window Default Length

• Always Display Marker Colors

• Default Track Color Coding options

• Default Clip Color Coding options
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• Operation Preferences

• Custom Shuttle Lock Speed

• Back/Forward Amount (Pro Tools HD and 
Pro Tools with Complete Production 
Toolkit only)

• PEC/Direct Style Input Monitoring 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only)

• DestructivePunch File Length (Pro Tools 
HD and Pro Tools with Complete Produc-
tion Toolkit only)

• Editing Preferences

• None

• Mixing Preferences

• Coalesce Trim Automation Options 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only)

• Processing Preferences

• Convert Imported “WAV” Files To 
AES31/BroadcastWave

• MIDI Preferences

• Play MIDI Notes When Editing

• Display Events as Modified by Real-Time 
Properties

• Automatically Create Click Track in New 
Sessions

• Default Thru Instrument

• Pencil Tool Resolution When Drawing Con-
troller Data

• Delay for External Devices Options 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only)

• Synchronization Preferences

• None



Display Preferences

Basics Section
Track Position Numbers Stay with Hidden 
Tracks When selected, tracks keep their track 
numbers even when hidden. When not selected, 
numbers are only assigned to tracks that are 
shown. In this case, shown tracks are then num-
bered sequentially, and hidden tracks are not 
numbered.

Tool Tips Display Options

Function Configures Tool Tips to show the basic 
function of the item.

Details Configures Tool Tips to show the com-
plete name of an abbreviated name or item (such 
as a track name). Details view can also show the 
hidden or abbreviated value of parameters, as 
well as input and output assignments. 
Edit Window Default Length

This preference sets a default length for the Edit 
window in hours, minutes, seconds, and frames 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only). This is useful if you 
want to assemble a session of a particular length 
or leave extra room to expand the Edit window’s 
work area in your session. The maximum length 
is 12 hours and 25 minutes at 48 kHz, and pro-
portionally less at higher sampling rates. For 
best scrollbar sensitivity, set the length to 
slightly longer (a minute or more) than the total 
session or song length.

“Organize Plug-In Menus By” Options

These option customize how plug-in menus are 
organized in the Insert selector or Plug-In selec-
tor.

Flat List Organizes plug-ins in a single list, in al-
phabetical order.

Category Organizes plug-ins by process cate-
gory (such as EQ, Dynamics, and Delay), with 
individual plug-ins listed in the category sub-
menus. Plug-Ins that do not fit into a standard 
category (such as the Signal Generator), or 
third-party plug-ins that have not had a cate-
gory designated by their developers, appear in 
the Other category. Plug-Ins can appear in more 
than one category. 

Manufacturer Organizes plug-ins by their manu-
facturer (such as Bomb Factory, Focusrite, or TL 
Labs), with individual plug-ins listed in the 
manufacturer submenus. Plug-Ins that do not 
have a Manufacturer defined will appear in the 
“Other” manufacturer folder. 

Most Avid-distributed third-party plug-ins will 
be grouped under Digidesign when Manufac-
turer view is enabled.
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Category and Manufacturer Organizes plug-ins 
in two levels of menus. The top menus display 
plug-ins by process category (such as EQ, Dy-
namics, and Delay), with individual plug-ins 
listed in the category submenus. The bottom 
menus display plug-ins by manufacturer (such 
as Bomb Factory, Focusrite, or TL Labs), with in-
dividual plug-ins listed in the manufacturer 
submenus.

Language Options (Windows Only)

You must have Administrator privileges for the 
Pro Tools application Properties to be able to 
change these options.

Language Sets the language to use in the 
Pro Tools application, independently of what 
language version of Windows is used.

Default Automatic Naming to English Causes au-
tomatically named session elements in a session 
to be named in English even when working with 
the Pro Tools application set to another lan-
guage.

Auto-Switch Input Language

When the Auto-Switch Input Language option is 
enabled, the input language is switched auto-
matically from English to the current OS input 
language when entering text. It automatically 
switches back to English for using Keyboard 
commands in Pro Tools. When disabled, English 
is used when entering test regardless of the cur-
rent OS input language.

Meters Section

Peak Hold Options

These options determine how long the peak in-
dicators on track meters stay lit after a peak is 
detected. 
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3 Seconds When selected, track meters display 
the last peak level for three seconds.

Infinite When selected, track meters display the 
last peak level until you click them to clear 
them.

None When selected, track meters do not hold 
the peak level.

Clip Indication Options

These options determine how long the clip indi-
cators on plug-in, send, and track meters stay lit 
after a clip is detected.

3 Second Clip Hold When selected, meters dis-
play the last clip indication for three seconds.

Infinite Clip Hold When selected, meters display 
the last clip indications until you click them to 
clear them.

No Clip Hold When selected, meters do not hold 
the clip indication.

Show Meters in Sends View

When the Sends view is displaying individual 
send controls, you can select this option to show 
send level meters. Deselecting this option can 
help speed up screen redraws and processing.

Warnings and Dialogs
Reset “Don’t Show This Again” Settings If you 
have made any changes the default Don’t Show 

This Again setting for any dialog in Pro Tools, 
you can click the Reset button to revert to the 
default settings.

Show Quick Start Dialog When Pro Tools 
Starts When selected, Pro Tools shows the Ses-
sion Quick Start dialog on launch. Deselect this 
option if you do not want to see the Pro Tools 
Quick Start dialog on launch.



Color Coding
Always Display Marker Colors Lets you choose 
to view Marker colors in the Markers ruler, re-
gardless of the settings you choose for Default 

Clip Color Coding. 

MIDI Note Color Shows Velocity When enabled, 
MIDI notes display varying shades of the as-
signed track color in MIDI notes view in the Edit 
window and in MIDI Editor windows. Notes 
with high velocities are darker and notes with 
lower velocities are lighter.

Default Track Color Coding Options

These color coding options determine the de-
fault color coding assignment for tracks in the 
Edit and Mix windows. The options are:

None Turns off color assignment for tracks.

Tracks and MIDI Channels Assigns a color to 
each track in the Mix or Edit window according 
to its voice or MIDI channel assignment.

Tracks and MIDI Devices Assigns a color to each 
track in the Mix or Edit window according to its 
voice assignment or MIDI device assignment.

Groups Assigns a color to each track according 
to its Group ID. If groups are suspended using 
the Suspend Groups command, the tracks color 
bars are not shown.

Track Type Assigns a color to each track accord-
ing to its type (audio, Auxiliary Input, Master 
Fader, VCA Master, MIDI, Instrument, or 
Video).
Default Clip Color Coding Options

These color coding options determine the de-
fault color coding assignment for tracks, Marker 
Locations, and clips residing in the track playlist 
and Clip List. The options are:

None Turns off color assignment for clips. Clips 
are drawn with black waveform or MIDI notes 
on a light gray background.

Tracks and MIDI Channels Assigns a color to 
each clip in the Edit window according to its 
voice or MIDI channel assignment.

Tracks and MIDI Devices Assigns a color to each 
clip in the Edit window according to its voice as-
signment or MIDI device assignment.

Groups Assigns a color to each clip according to 
the Group ID of its track. If groups are sus-
pended using the Suspend Groups command, all 
clips display black waveforms or MIDI notes on 
a light gray background.

Track Color Assigns a clip color based on the 
color assigned to the track.

Marker Locations Assigns a unique color to each 
marker area in the Marker ruler, including the 
area preceding the first marker.

Clip List Color Assigns a color to each clip based 
on its color in the Clip List.
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Operation Preferences

Transport Section
Timeline Insertion/Play Start Marker Follows Play-
back When selected, the Timeline Insertion and 
the Play Start Marker both move to the point in 
the Timeline where playback stops. When de-
selected, the Timeline Insertion and Play Start 
Marker do not follow playback, but return to the 
point in time where playback began.

Edit Insertion Follows Scrub/Shuttle When se-
lected, the edit cursor automatically locates to 
the point where scrubbing stops.

Audio During Fast Forward/Rewind When se-
lected, audio is audible during fast forward or 
rewind.

Press Start+N (Windows) or Control+N 
(Mac) to toggle the Timeline Insertion/Play 
Start Marker Follows Playback preference 
on and off.
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Latch Forward/Rewind When selected, fast for-
ward and rewind latch and continue until you 
press Stop, Play, Return To Zero, or Go To End 
on the Transport. When disabled, the Fast For-
ward and Rewind only last as long as you hold 
down the mouse after clicking either button on 
the Transport (or hold down the corresponding 
switch on a Control Surface).

Play Start Marker Follows Timeline 
Selection When enabled, the Play Start Marker 
snaps to the Timeline Selection In Point when 
you move the Timeline Selection, draw a new 
Timeline Selection, or adjust the Timeline Selec-
tion Start. When disabled, the Play Start Marker 
doesn’t move with the Timeline selection.

Reserve Voices for Preview in Context 
(Pro Tools|HD Systems Only) When enabled, 
Pro Tools reserves the appropriate number of 
voices for preview in context (previewing audio 
files in DigiBase during session playback). The 
number of available voices is reduced by the 
channel width of the selected audition paths on 
the Output page of the I/O Setup window. For 
example, if the number of playback voices is set 
to 48 in the Playback Engine, and you have a ste-
reo audition path selected in the I/O Setup, only 
46 voices will be available for tracks. If you have 
a 5.1 audition path, only 42 voices will be avail-
able. When this option is disabled, you will not 
be able to preview in context if there are not 
enough available voices. 

Custom Shuttle Lock Speed Sets the highest 
fast-forward Shuttle Lock speed (key 9) for 
Shuttle Lock modes (Classic or Transport). The 
range for this setting is 50–800%. 

For more information, see “Custom Shuttle 
Lock Speed” on page 566.



Back/Forward Amount (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
Only) Sets the default length of Back, Back and 

Play, Forward and Forward and Play. The time-
base of the Back/Forward Amount settings fol-
lows the Main Time Scale by default, or you can 
deselect the Follow Main Time Scale option and 
select another timebase format: Bars|Beats, 
Min:Sec, Timecode, Feet+Frames, or Samples.

Numeric Keypad Mode

Numeric Keypad mode determines how the nu-
meric keypad functions. You can always use the 
numeric keypad to select and enter values in the 
Event Edit Area, Edit Selection indicators, Main 
and Sub Counters, and Transport fields.

Classic Selects a Shuttle Lock mode that emu-
lates the way Pro Tools worked in versions lower 
than 5.0. With the Numeric Keypad mode set to 
Classic, you can play up to two tracks of audio in 
Shuttle Lock mode. Press the Start key (Win-
dows) or Control (Mac), followed by 0–9 for dif-
ferent play speeds. Press Plus (+) or Minus (–) 
to reverse direction. Recall Memory Locations 
by typing the Memory Location number, fol-
lowed by Period (.). 

Transport Selects a Shuttle Lock mode that lets 
you set a number of record and play functions, 
and also operate the Transport from the nu-
meric keypad. With the Numeric Keypad mode 
set to Transport, you can play up to two tracks of 
audio in Shuttle Lock mode. Press the Start key 
(Windows) or Control (Mac), followed by 0–9 
for different play speeds. Press Plus (+) or Mi-
nus (–) to reverse direction. Recall Memory Lo-
cations by typing Period (.), the Memory Loca-
tion number, and Period (.) again. 

To customize the highest fast-forward Shut-
tle Lock speed, see “Custom Shuttle Lock 
Speed” on page 566.
Shuttle (Pro Tools HD and Pro Tools with Com-
plete Production Toolkit Only) Selects a type of 
shuttling different from that of Shuttle Lock 
mode. With the Numeric Keypad mode set to 
Shuttle, playback is triggered by pressing and 
holding the keys on the numeric keypad—play-
back stops once the keys are released. Various 
playback speeds are available in both forward 
and reverse. You can also recall Memory Loca-
tions by typing Period (.), the Memory Location 
number, and Period (.) again.

Use Separate Play and Stop Keys 

When enabled, this option lets you start play-
back with the Enter key and stop playback with 
the 0 key on the numeric keypad. This is useful 
for quickly starting and stopping playback when 
auditioning loop transitions. The Use Separate 

Play and Stop Keys option is only available in 
Transport Numeric Keypad mode.

Auto Backup Section
Enable Session File Auto Backup When se-
lected, Pro Tools automatically saves backups of 
your Pro Tools session file while you work. 
Backups are saved to in the Session File Backups 
folder in your session folder. 

Keep Specifies the total number of incremental 
backups that are kept.

Backup Every Specifies how often the session is 
saved.

When this option is enabled, it overrides us-
ing the Enter key to add Memory Location 
markers. Instead, press Period (.) and then 
Enter on the numeric keypad to add a Mem-
ory Location marker.
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Video Section

High Quality QuickTime Image (DV25 Only)

When enabled, Pro Tools decompresses both 
fields of each interlaced frame of QuickTime 
video. When not enabled, Pro Tools only de-
compresses one field of each frame for “half-res” 
QuickTime playback.

When viewing a QuickTime movie in the 
Pro Tools Video window, select this option to 
display the movie at the highest possible resolu-
tion. For interlaced video that was transcoded 
from a progressive source, enable this option for 
a crisper image. Deselecting this option can help 
improve performance if your system experi-
ences problems playing back a session with 
QuickTime video.

Avid Video Errors Stop Playback

(Pro Tools HD with Avid Video Engine Only)

When selected, Pro Tools automatically stops 
playback of audio and video if a single frame of 
video is dropped.

When not selected, Pro Tools continues play-
back of audio even if frames are dropped. In 
most cases, video playback will recover within a 
few frames and continue playing audio and 
video in sync.

Avid Video NTSC Has Setup (NTSC-J)

(Pro Tools HD with Avid Video Engine Only)

This preference lets you adjust the level of NTSC 
video black output between 7.5 IRE (standard) 
or 0 IRE. When this option is selected, output 
level is 0 IRE.
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Record Section
Latch Record Enable Buttons When selected, 
multiple audio tracks can be record-enabled. 
When not selected, multiple audio tracks cannot 
be record-enabled. Record-enabling an audio 
track takes all other audio tracks out of record-
enabled mode.

Link Record and Play Faders When selected, 
Pro Tools does not remember separate fader lev-
els for tracks when they are record-enabled, al-
lowing you to maintain the same monitoring 
level for tracks during recording and playback. 

Audio Track RecordLock (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
Only) This option configures Pro Tools tracks to 
either emulate a digital dubber, or to maintain 
legacy behavior for track record status. 

• When selected, the record-enabled audio 
tracks remain record-enabled when play-
back or recording stops. 

• When not selected, record-enabled audio 
tracks are taken out of record enable when 
Pro Tools is stopped. This prevents tracks 
from remaining armed from pass to pass, 
emulating track record behavior of a digital 
dubber. 



Transport RecordLock (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
Only) This option lets the Transport Record (the 
Record button in the Transport controls) be 
configured to either emulate a digital dubber, or 
to maintain legacy behavior for the Transport 
master Record. 

• When selected, the Transport Record re-
mains armed when playback or recording 
stops. This saves having to re-arm the 
Transport between takes, emulating digital 
dubber behavior. 

• When not selected, the Transport Record 
disarms when Pro Tools is manually 
stopped or stops due to a loss of timecode. 
This replicates standard Pro Tools record-
ing behavior. 

The Transport RecordLock option is automati-
cally disabled and grayed out when Destructive 
Record mode is enabled.

Disable “Input” When Disarming Track 
(In “Stop”) (Pro Tools HD and Pro Tools with 
Complete Production Toolkit Only) For flexibil-
ity, TrackInput monitoring can be customized 
to remain selected regardless of track record 
status, or to automatically switch to Auto Input 
monitoring after a recording pass. This lets you 
optimize monitoring for a typical dubbing 
workflow (in which you might want tracks to re-
main in Input Only mode until explicitly 
switched to Auto Input monitoring) or a typical 
music tracking workflow (in which leaving a 
track in Input Only monitoring mode after re-
cording can result in accidental double-moni-
toring).

• When selected, taking an audio track out of 
record enable (any mode) takes it out of In-
put Only mode, regardless of the global 
monitor mode, and switches it to monitor 
audio from disk only. 
• When not selected, audio tracks remain in 
Input Only monitoring mode until explic-
itly switched to Auto Input monitoring. 

Mute Record-Armed Tracks While Stopped (Pro 
Tools HD and Pro Tools with Complete Produc-
tion Toolkit Only) This setting determines moni-
tor status of record-armed tracks. 

• When selected, Pro Tools mutes all record-
enabled tracks when the transport is 
stopped. Input can still be monitored while 
stopped using the TrackInput Monitor but-
ton.

• When not selected, Pro Tools does not mute 
audio input on record-enabled tracks when 
the transport is stopped.

PEC/Direct Style Input Monitoring (Pro Tools HD 
and Pro Tools with Complete Production Toolkit 
Only) This option changes the way the TrackIn-
put monitoring mode is indicated on-screen 
(and on supported control surfaces) to emulate 
“PEC” (playback) and “Direct” (input/bus) indi-
cation on some large format consoles. 

• When not selected, the TrackInput button 
shows the letter “I.” The button remains 
gray to indicate Auto Input mode and lights 
green to indicate Input Only mode.

• When selected, the TrackInput button re-
mains gray and shows the letter “D” to indi-
cated Input Only mode (“Direct”); it lights 
green and shows the letter “P” to indicate 
Auto Input mode (“Pec” or playback).

Automatically Create New Playlists When Loop 
Recording When selected, copies loop recorded 
alternate takes to new playlists in the track. This 
is especially useful to prepare for track compos-
iting in Playlists view after loop recording mul-
tiple alternate takes.
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Online Options

Record Online at Timecode (or ADAT) 
Lock When selected, online recording begins as 
soon as Pro Tools receives and locks to incom-
ing timecode.

Record Online at Insertion/Selection When se-
lected, online recording begins at the edit cursor 
location. Recording continues until Pro Tools 
stops receiving timecode. If you make a selec-
tion, Pro Tools records online for the length of 
the selection. 

DestructivePunch File Length (Pro Tools HD and 
Pro Tools with Complete Production Toolkit Only)

This preference sets the duration of consoli-
dated audio files when preparing tracks for De-
structivePunch mode. The default value for this 
setting is 25 minutes. 

Misc (Miscellaneous) Section
Clip Auto Fade In/Out Length (Pro Tools HD and 
Complete Production Toolkit Only) Sets a default 
length for fade-ins and fade-outs automatically 
applied to clip boundaries. Using automatic 
fade-ins and fade-outs saves you the trouble of 
editing to zero-crossings or creating numerous 
rendered fades in order to eliminate clicks or 
pops in playback. Autofades are not written to 
disk. Value range is from 0–10 ms for the Auto 

Clip Fade In/Out Length setting. A value of zero 
means that no auto-fading will occur. The Auto 
Fade value is saved with the session, and is auto-
matically applied to all free-standing clip 
boundaries until you change it.
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Calibration Reference Level (Pro Tools|HD and 
HD Native Systems Only) Sets a default calibra-
tion reference level in dB when Pro Tools is in 
Calibration mode. For audio interfaces that have 
trims (such as the HD I/O), see the interface’s 
guide for calibration instructions.

Delay Compensation Time Mode This option lets 
you choose whether information in the Delay 
Manager is displayed in milliseconds or sam-
ples. This option is only available when Delay 
Compensation is enabled (Options > Delay Com-

pensation).

If your system includes one or more EUCON 
controllers, be sure to disable “Auto-bank to 
selected track” in EuControl software before 
enabling Pro Tools Calibration Mode to en-
sure that faders remain silent. To make sure 
“Auto-bank to select track” is not enabled, 
open the EuControl Settings window, click 
to go to the General tab, and verify the set-
ting is not enabled. If necessary, click to dis-
able “Auto-bank to selected track.” After ex-
iting Calibration Mode, be sure to re-enable 
the “Auto-bank to selected track” setting (if 
necessary).



Editing Preferences

Clips Section
Clip List Selection Follows Edit 
Selection When selected, selecting a clip in a 
track also selects it in the Clip List. 

Edit Selection Follows Clip List 
Selection When selected, selecting a clip in the 
Clip List causes Pro Tools to highlight that clip’s 
occurrence in a track.

Auto-Name Separated Clips When selected, 
Pro Tools automatically names newly separated 
clips by appending a number to the clip’s name.

“Separate Clip” Operates On All Related 
Takes When selected, editing a clip with the 
Separate Clip command also affects all other re-
lated takes (recording passes) with the same 
User Time Stamp. This option helps you com-
pare different sections from a group of related 
takes.

Clip Gain Nudge Value This setting specifies the 
amount (from 0.1 dB to 6.0 dB) by which clip 
gain settings are adjusted when nudging clip 
gain.
Tracks Section
New Tracks Default To Tick Timebase When se-
lected, all new tracks default to ticks. When de-
selected, audio, Auxiliary Input, Master Fader, 
and VCA (Pro Tools HD only) tracks default to 
samples.

Memory Locations Section
Auto-Name Memory Locations When 
Playing When selected, Pro Tools gives new 
Memory Locations default names based on their 
time location in the session. The time units cur-
rently chosen in the View menu determine the 
units for the names. 

Recall Memory Location at Original Track When 
selected, Memory Locations that recall a selec-
tion also recall the track in which the selection 
was made.

Fades Section
Crossfade Preview Pre-Roll This setting speci-
fies the amount of pre-roll to be added when you 
are auditioning crossfades in the Fades dialog.

Crossfade Preview Post-Roll This setting speci-
fies the amount of post-roll to be added when 
you are auditioning crossfades in the Fades dia-
log.

QuickPunch/TrackPunch Crossfade Length 

Specifies a default length for crossfades created 
by QuickPunch or TrackPunch (Pro Tools HD 
and Pro Tools with Complete Production Tool-
kit only) recordings. Crossfades occur before 
the punch in and after the punch out. 

Preserve Fades when Editing This option pre-
serves fade-ins and fade outs, and converts sep-
arated crossfades into corresponding fade-ins 
and fade-outs.
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Default Fade Settings

Fade In Selects the default envelope shape for 
fade-ins when using the Smart Tool.

Fade Out Selects the default envelope shape for 
fade-outs when using the Smart Tool.

Crossfade Selects the default envelope shape for 
crossfades when using the Smart Tool.

REX Selects the default envelope shape for fades 
and crossfades between clips (“slices”) in im-
ported REX files.

Zoom Toggle Section
Vertical Zoom Selects either Selection or Last 

Used for the Zoom Toggle Vertical Zoom setting.

Horizontal Zoom Selects either Selection or Last 

Used for the Zoom Toggle Horizontal Zoom set-
ting.

Remove Range Selection After Zooming 
In When selected, the current Edit selection col-
lapses into an insertion point after zoom tog-
gling in. Zoom toggling back out reverts to the 
previous selection.

To apply a Fade In, Fade Out, or Crossfade 
to an Edit selection using the Default Fade 
settings, and without opening the Fades di-
alog, press Control+Start+F (Windows) or 
Command+Control+F (Mac).
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Track Height Selects Last Used, Medium, Large, 
Extreme, or Fit To Window for the Zoom Toggle 

Track Height setting.

Track View Selects Waveform/Notes, Warp/Notes, 
Last Used, or No Change for the Zoom Toggle 

Track View setting.

Separate Grid Settings When Zoomed In When 
selected, the Grid setting stored with Zoom tog-
gle is recalled when zoom toggling in. When this 
option is deselected, the same (current) grid set-
ting is used whether zoom toggling in or out.

Zoom Toggle Follows Edit Selection When se-
lected, zoom toggle automatically follows the 
current Edit selection. When disabled, changing 
the Edit selection has no affect on the currently 
toggled-in track.

Levels of Undo
This preference sets the maximum number of 
actions that can be undone with the multiple 
undo feature. Setting this to a lower number can 
speed up the performance of slower computers. 
Pro Tools supports up to 32 Levels of Undo.

Mixing Preferences



Setup Section
Sends Default to –INF When selected, the initial 
fader level of newly-created sends is set to – 
(no audible signal level). When not selected, the 
initial fader level of newly-created sends is set to 
0 dB.

Send Pans Default to Follow Main Pan When se-
lected, newly created sends have Follow Main Pan

turned on, so the Send Pan controls follow the
pan controls of the track. When not selected,
n e w l y  c r e a t e d  s e n d s  h a v e  Follow Main Pan

turned off.

Link Mix and Edit Group Enables When selected, 
this option links enabling and disabling of Mix 
and Edit Groups. For example, enabling Group 
A in the Mix Window automatically enables 
Group A in the Edit window.

Use Absolute Pan Linking (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
Only) This option affects behavior of grouped 
pan controls.

• When selected, grouped pan controls do 
not maintain relative offsets when any of 
the grouped pan controls is adjusted. All 
grouped pan controls snap to the absolute 
value of the adjusted control. 

• When not selected, grouped pan controls 
maintain relative offsets when any of the 
linked controls is adjusted.

Default EQ

This preference lets you choose any installed EQ 
plug-in as the default, which makes it available 
for quick assignment, both on-screen and on 
ICON worksurfaces (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
only). On-screen, the plug-in appears at the top 
of the Insert selector pop-up menu. On ICON 
worksurfaces, the plug-in appears first in the 
list of menu choices on the rotary encoders.
Default Dynamics

This preference lets you choose any installed 
Dynamics plug-in as the default, which makes it 
available for quick assignment, both on-screen 
and on ICON worksurfaces (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
only). On-screen, the plug-in appears at the top 
of the Insert selector pop-up menu. On ICON 
worksurfaces, the plug-in appears first in the 
list of menu choices on the rotary encoders.

Controllers Section
Edit Window Follows Bank Selection If you are 
using a supported control surface with 
Pro Tools, this option scrolls the Edit window to 
display the selected bank of tracks when you 
switch banks on the control surface, ensuring 
that the current bank is viewable on-screen.

Mix Window Follows Bank Selection If you are 
using a supported control surface with 
Pro Tools, this option scrolls the Mix window to 
display the selected bank of tracks when you 
switch banks on the control surface, ensuring 
that the current bank is viewable on-screen.

“Scroll to Track” Banks Controllers When using 
a control surface (such as D-Control or ProCon-
trol) you can select this option to bank control 
surface faders to a numbered track when using 
the Scroll to Track command.

Always Fill Channel Strips When Banking If you 
are using an ICON worksurface (Pro Tools HD 
and Pro Tools with Complete Production Tool-
kit only), or other supported control surface, 
you can select this option to maximize the num-
ber of channels displayed when banking. This 
setting optimizes the Bank commands to pre-
vent the display of a small number of channels at 
the extremes of the surface.
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Touch Timeout If you are writing automation in 
Touch mode and you stop moving a non-touch 
sensitive fader or encoder, Pro Tools continues 
to write automation for the Touch Timeout 
value.

After the Touch Timeout period, writing of au-
tomation stops and the automation data returns 
to its previous automation value at the rate spec-
ified in the AutoMatch Time setting.

Automation Section
Smooth and Thin Data After Pass When se-
lected, Pro Tools automatically smooths and 
then applies the specified amount of thinning to 
the automation data created in an automation 
pass. 

Degree of Thinning Specifies the amount of 
thinning performed on automation data when 
you using the Thin Automation command, or if 
you have selected the Smooth and Thin Data After 

Pass option. 

Plug-In Controls Default to Auto-Enabled When 
selected, all applicable controls of newly added 
plug-ins are enabled for automation. When not 
selected, the controls of newly added plug-ins 
must be manually enabled for automation. 

Suppress Automation “Write To” Warnings 
(Pro Tools HD and Pro Tools with Complete Pro-
duction Toolkit Only) When selected, Pro Tools 
suppresses the warnings that appear after invok-
ing any of the Write Automation To Start, Selec-

tion, End, or Punch commands and then stopping 
the transport.
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Latching Behavior for Switch Controls in 
“Touch” This option determines the behavior of 
switch-type controls (such as mute or plug-in 
bypass) when writing automation in Touch 
mode.

• When selected, controls in Touch mode will 
latch in their current state. If an existing 
breakpoint is encountered, writing of auto-
mation stops. If the transport is stopped 
while writing, the control will 
AutoMatch to the underlying value.

• When not selected, controls in Touch mode 
will not latch. 

Allow Latch Prime in Stop (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
Only) When selected and any tracks are in Latch 
mode, any automation-enabled controls on 
those tracks can be set to new values while the 
transport is stopped by touching or moving con-
trols, to prepare for the next automation pass. 

Coalesce when Removing Slaves from VCA 
Group (Pro Tools HD and Pro Tools with Com-
plete Production Toolkit Only) This option deter-
mines the behavior when removing slave tracks 
from a VCA-controlled group.

• When selected, any automation on the VCA 
Master is automatically coalesced (without 
confirmation) to its slave tracks when the 
tracks are removed from the group.

• When not selected, a confirmation dialog 
lets you choose whether or not to coalesce 
the VCA Master automation to the slave 
tracks.



Standard VCA Logic for Group Attributes 
(Pro Tools HD and Pro Tools with Complete Pro-
duction Toolkit Only) This option determines 
which Mix group attributes may be selected in 
the Group dialog when the group is assigned to a 
VCA Master. 

• When selected, the Main Volume, Mute, 
Solo, Record Enable, and Input Monitoring 
controls on slave tracks follow the VCA 
Master only and are not available to be in-
dependently linked. (This emulates the be-
havior of analog console VCA masters.)

• When deselected, the Main Volume, Mute, 
Solo, Record Enable, and Input Monitoring 
controls follow the VCA Master, but also re-
main available for independent linking 
with groups.

Include Sends in Trim Mode (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
Only) This option determines the Trim status of 
Send faders when a track is put in Trim mode.

• When selected, Send faders go into Trim 
mode along with the Main Volume fader. 

• When deselected, the Main Volume fader 
goes into Trim mode, but the Send fader 
stays in the corresponding standard Auto-
mation mode.

Include Control Changes in Undo Queue This 
option determines whether certain mixer con-
trol changes, such as moving a fader or pan con-
trol, are entered into the Undo queue.

• When selected, mixer control changes ap-
pear in the Undo queue, and are undone if 
any prior operation is undone.

• When deselected, mixer control changes 
will not appear in the undo queue, allowing 
you to undo other types of operations with-
out losing the current mixer settings.

Any set to default operations that affect mixer 
controls will be entered into the Undo queue.
AutoMatch Time If you are writing automation 
in Touch mode, when you release a fader or con-
trol, writing of automation stops and the auto-
mation data returns to its previous value. The 
rate of return to the previous value is the 
AutoMatch Time. 

AutoGlide Time (Pro Tools HD and Pro Tools with 
Complete Production Toolkit Only) Specifies 
how quickly Pro Tools transitions (glides) from 
one automation value to another, when 
AutoGlide mode is used.

After Write Pass, Switch To Options

These options select the Automation mode that 
Pro Tools tracks automatically switches to after 
an automation pass in Write (or Write Trim) 
mode. Select one of the following options:

Touch Switches to Touch mode after an automa-
tion pass in Write (or Write Trim) mode.

Latch Switches to Latch mode after an automa-
tion pass in Write (or Write Trim) mode.

No Change Stays in Write mode after an auto-
mation pass in Write (or Write Trim) mode. 

After an automation pass in Write Trim mode, 
tracks automatically switch to the Trim version 
of the specified setting.

Coalesce Trim Automation Options

(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

These options determine when Trim automation 
is committed to the main automation playlist on 
a track.

After Every Pass Sets Trim automation to co-
alesce when the transport is stopped at the end 
of each Trim automation pass. No Composite 
Playlist is indicated.
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On Exiting Trim Mode Sets Trim Automation to 
coalesce on a track when the track is taken out of 
Trim mode. A Composite Playlist can be viewed 
before committing Trim moves.

Manually Trim Automation can be coalesced 
only with the Coalesce Trim Automation com-
mand. A Composite Playlist can be viewed be-
fore committing Trim moves.

Processing Preferences

AudioSuite Section
Use AudioSuite Dither When selected, certain 
AudioSuite plug-ins automatically apply dither 
when processing. AudioSuite plug-ins that sup-
port automatic dithering include: Gain, Normal-
ize, Smack!, and Sonic NoNOISE.

Plug-In Specifies the plug-in used for dither pro-
cessing when the Use AudioSuite Dither option is 
selected.

Bit Depth Lets you select a bit depth for the dith-
ered audio (24-bit, 20-bit, 18-bit, or 16-bit).
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Default Handle Length

The Default Handle Length options let you set 
the default length for AudioSuite and clip gain 
handles.

Whole File When enabled, AudioSuite and clip 
gain rendering renders the whole file referenced 
by the selection or clip. 

Length This setting lets you specify the default 
Handle Length (from 0.00 to 60.00 seconds) for 
AudioSuite and clip gain rendering. AudioSuite 
and clip gain rendering renders the selection 
plus any additional available audio up to the 
specified Handle Length.

Import Section
Convert Imported “WAV” Files To AES31/Broad-
castWave When selected, this option applies to 
all newly imported WAV files, making them 
compliant with the AES31/EBU Broadcast stan-
dard.

Automatically Copy Files on Import When se-
lected, all audio files that are imported by drag-
ging and dropping are copied to the current ses-
sion’s Audio Files folder, regardless of whether 
the files need to be converted to the current ses-
sion’s file type, bit depth or sample rate. Addi-
tionally, when selected, the Copy from Source 

Media option is automatically enabled in the Im-
port Session Data dialog. The Automatically Copy 

Files on Import preference does not affect the Im-

port Audio command.

Convert Copied Files to Session Format When 
selected, files that have different file formats 
from the current session file format are copied 
and converted to the current session audio file 
format on import. For example, if the session 
file format is WAV and you import an AIF, the 
files is copied and converted to WAV on import. 



When this option is not selected, copied files re-
tain their original format (unless that file for-
mat is incompatible with Pro Tools, in which 
case it must be converted).

Do Not Convert Sample Rate on Import When 
selected, files with different sample rates than 
the session sample rate are not automatically 
converted when imported into the session. This 
means that files with mis-matched sample rates 
playback at a different speed (and pitch transpo-
sitions than when they were originally recorded 
(or converted).

Import REX Files as Clip Groups When selected, 
REX flies are imported as clip groups, all the un-
derlying slices are imported as individual clips 
contained within the clip group. When this op-
tion is not selected, importing REX files into a 
session converts them to the session’s audio file 
format, the individual slices are consolidated, 
and the slice information is used for Elastic Au-
dio analysis. These files remain tick-based after 
import and conversion. 

Automatically Create Fades When selected, 
crossfades are applied automatically to the 
sliced clips within clip groups created by im-
porting REX files. If the Import REX Files as Clip 

Groups option is not selected, the Automatically 

Create Fades option is not available. 

To change the default fade settings for REX files, 
click the REX button in the Default Fade Set-
tings section on the Editing Preferences page.

Drag and Drop From Desktop Conforms to 
Session Tempo

The Drag and Drop From Desktop Conforms to 

Session Tempo options determine whether or 
not REX, ACID, and audio files are imported as 
tick-based Elastic Audio and conformed to the 
session tempo.
No Files When enabled, REX and ACID files, and 
all other audio files are not conformed to the 
session tempo when imported by drag and drop 
from Windows Explorer or the Mac Finder. They 
are imported as sample-based files and con-
verted to the sessions audio file format.

REX and ACID Files Only When enabled, only 
REX and ACID files are conformed to the session 
tempo when imported by drag and drop from 
Windows Explorer or the Mac Finder. REX files 
are imported either as tick-based Elastic Audio 
or, if the Import REX Files as Clip Groups option 
is enabled, as tick-based clip groups. 

All Files When enabled, all audio files (including 
REX and ACID files) imported by drag and drop 
from Windows Explorer or the Mac Finder are 
imported as tick-based Elastic Audio and con-
form to the session tempo.

Sample Rate Conversion Quality

The Sample Rate Conversion Quality pop-up 
menu lets you select the default sample rate con-
version quality for importing audio files by drag 
and drop from any DigiBase browser, or Win-
dows Explorer or Mac Finder. The higher the 
quality of sample rate conversion you select, the 
longer Pro Tools will take to process the audio 
file.

TC/E (Time Compression/
Expansion) Section
TC/E Plug-In Lets you select the plug-in used for 
Time Compression and Expansion when you 
edit audio with the Time Compression/Expan-
sion Trim tool. This Trim tool works by using 
Time Compression/Expansion to match an au-
dio clip to the length of another clip, a tempo 
grid, a video scene, or other reference point. The 
Time Shift plug-in is selected by default.
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Default Settings Specifies the default settings 
used by the chosen Time Compression/Expan-
sion plug-in.

Elastic Audio Section
These preferences determine Elastic Audio us-
age and settings on new tracks, as well as for 
previewing and importing tick-based audio.

Default Plug-In Lets you select any Real-Time 
Elastic Audio plug-in as the default for preview-
ing and importing Elastic Audio. The selected 
default Elastic Audio plug-in is also used when 
new tracks are created with the Enable Elastic 

Audio on New Tracks option enabled. 

Default Input Gain Lets you attenuate the signal 
input to Elastic Audio plug-ins by 0 to –6 dB for 
preview and import. If you experience clipping 
due to Elastic Audio processing during preview 
or after import, you may want to set the Default 

Input Gain to slightly attenuate the audio signal 
input for Elastic Audio processing. This prefer-
ence also applies to any audio imported to an 
Elastic Audio-enabled track.

The Elastic Properties window inherits the De-

fault Input Gain setting. To apply further clip-
based input gain attenuation for Elastic Audio 
processing, select the clip and adjust the Input 

Gain setting in the Elastic Properties window 
(see “Elastic Properties Window” on page 902).

Enable Elastic Audio on New Tracks When se-
lected, new tracks are created with Elastic Audio 
enabled. The selected default Elastic Audio 
plug-in is used.

If the Enable Elastic Audio on New Tracks 
option is selected, you may want to also se-
lect the New Tracks Default to Tick Time-
base option in the Editing Preferences page.
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DSP Management Section
(Pro Tools|HD Systems Only)

These preferences determine DSP management 
behavior for converting DSP plug-ins to Native 
and also for the HEAT software option.

Open Unresourced DSP Plug-Ins as 
Native When this option is enabled, any DSP 
(TDM) plug-ins that exceed the available DSP 
processing are converted to Native (AAX or 
RTAS) format plug-ins wherever possible. When 
this option is disabled, any DSP plug-ins that ex-
ceed the available DSP processing are made in-
active. 

Enable HEAT in New Sessions (Pro Tools|HD 
Only) When enabled, new sessions are created 
with HEAT enabled for all audio tracks. When 
disabled, HEAT is disabled in new sessions by 
default. This option is only available if the 
HEAT software option is installed. For more in-
formation, see the HEAT Software Option Guide.

MIDI Preferences



Basics Section
Remove Range Selection After Opening the 
MIDI/Score Editor When selected, the MIDI Edi-
tor and Score Editor open with no Edit selection. 
When this option is disabled, the MIDI Editor 
and Score Editor open with the current Edit se-
lection intact.

Use MIDI to Tap Tempo When enabled, you can 
tap a MIDI keyboard to enter a new tempo value 
into a tempo field.

Display Events as Modified by Real-Time Proper-
ties When enabled, Pro Tools displays the ef-
fects of Real-Time Properties in the Edit, MIDI 
Editor, and Score Editor windows, and the MIDI 
Event List.

Use F11 Key for Wait for Note When enabled, 
pressing the F11 Function key puts MIDI re-
cording in Wait for Note mode. 

Automatically Create Click Track in New 
Sessions When enabled, Pro Tools automati-
cally creates a new click track in new sessions.

Default Thru Instrument

This option lets you set the default MIDI Thru 
instrument. You can select a predefined device 
from your available MIDI instruments, or select 
First Selected MIDI Track to use the assigned 
MIDI output of the first selected MIDI or Instru-
ment track. When multiple MIDI or Instrument 
tracks are selected, the instrument in the se-
lected track that is closest to the top of the Edit 
window (or closest to the left edge of the Mix 
window) is used. Select None to only route MIDI 
Thru record enabled MIDI and Instrument 
tracks.
Pencil Tool Resolution When Drawing 
Controller Data

This option lets you set the default resolution 
for MIDI controller data created with the Pencil 
tool. Setting this to a lower resolution helps 
avoid creating controller data that is unneces-
sarily dense. The value range is from 1 to 100 
milliseconds.

Global MIDI Playback Offset

This option lets you set an offset in samples to 
compensate for MIDI latency. Entering a value 
here has the same effect as setting an offset with 
the MIDI Track Offsets command. Offset values 
can be positive (later) or negative (earlier). 

Double-Clicking a MIDI Clip Opens

This option lets you specify what happens when 
you double-click MIDI clips with the Grabber 
tool on MIDI and Instrument tracks in the Edit 
window. 

MIDI Editor Opens the MIDI clip in a MIDI Edi-
tor window.

Score Editor Opens the MIDI clip in the Score 
Editor window.

MIDI Event List Opens the MIDI clip in the MIDI 
Event List.

Name Dialog Opens the Name dialog for the 
MIDI clip.

Note Display Options
These options set the reference for middle C as 
C3, C4, or MIDI note number 60.
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Delay for External Devices 
Section
These options only apply when a Delay Compen-

sation Engine is selected in the Playback Engine 
and Delay Compensation is enabled in Pro Tools. 
These options are distinct from the hardware 
offsets available for hardware inserts in the I/O 
Setup.

MIDI Timecode When selected, Pro Tools applies 
Delay Compensation to Pro Tools-generated 
MIDI Timecode (MTC). Enable this option when 
synchronizing video to Pro Tools using MTC.

MIDI Beat Clock When selected, Pro Tools ap-
plies Delay Compensation to Pro Tools-gener-
ated MIDI Beat Clock.

MIDI/Score Editor Display

Additional Empty Bars in the Score Editor

This setting lets you specify the default number 
of empty bars that appear in the Score Editor 
window after the end of the last MIDI clip in the 
session.

Synchronization Preferences
Pro Tools Reference Guide
Machine Control Section
Machine Chases Memory Location When se-
lected, navigating to a specific location in a ses-
sion with a Memory Location causes a connected 
transport to chase to that location.

Machine Follows Edit Insertion/Scrub When se-
lected, navigating to a specific location in a ses-
sion by moving the selection point or by scrub-
bing a track will cause a connected transport to 
chase to that location.

When the connected device is a linear device 
(such as a tape deck), select Linear Devices (jog) 
to set Pro Tools to send jog commands.

When the connected device is a non-linear de-
vice (such as a random-access video recorder or 
another Pro Tools system), select Non-Linear De-

vices (cue) to set Pro Tools to send cue com-
mands.

Machine Cues Intelligently (Pro Tools|HD and 
HD Native Systems Only) When selected, if you 
navigate to a cue point that is more than 10 sec-
onds from the current location, Pro Tools will 
command a connected transport to fast wind to 
the new location at full speed to within 10 sec-
onds of the cue point. Cueing will then slow to 
normal speed until the point is reached. This 
can significantly speed up tape cueing with cer-
tain video transports.

Stop at Shuttle Speed Zero (Pro Tools|HD and 
HD Native Systems Only) Causes Pro Tools to 
send a Stop command whenever you stop shut-
tling. This is useful if you have a machine that 
requires an explicit stop command to park cor-
rectly. 



Non-Linear Transport Error Suppression 
(Pro Tools|HD and HD Native Systems 
Only) When Transport = Pro Tools, keeps 
Pro Tools from sending a Stop command when 
taken offline. This prevents Pro Tools from 
stopping any other 9-pin devices connected to 
the system.

Synchronization Section
Minimum Sync Delay Sets the initial amount of 
prime time (in frames) your system’s devices 
need to achieve synchronization “lock.” This 
amount varies for each device. Pro Tools lock up 
delay is set by entering a value for Minimum Sync 

Delay in the Synchronization page of the Prefer-
ences. The lowest value available is 15 frames. 
Find the shortest possible lock-up time that your 
equipment can operate at consistently, and set 
this as the Minimum Sync Delay. On systems us-
ing MachineControl, enabling the Use Serial 

Timecode option will make machines lock up 
much faster. (Serial timecode requires both a 
qualified synchronization peripheral and exter-
nal devices to be locked to house video refer-
ence.)

Delay Before Locking to Longitudinal Timecode 
(Pro Tools|HD and HD Native Systems Only) Sets 
the amount of time (in frames) for Pro Tools to 
lock to incoming LTC. Use this option when 
locking Pro Tools to a stable timecode source 
(such as a non-linear tape machine or LTC gen-
erator) and not a linear tape machine.

Delay Before Locking to Serial Timecode 
(Pro Tools|HD and HD Native Systems Only) Sets 
the amount of time (in frames) for Pro Tools to 
wait before attempting to lock to machines that 
issue servo lock messages. This setting allows 
time for the servo mechanisms to achieve stable 
lock.
Remote Mode Section
(Pro Tools|HD and HD Native Systems Only)

Ignore Track Arming Sets Pro Tools to ignore in-
coming track arming (record enable) com-
mands. This is useful if you are using a master 
controller to arm tracks on other machines, but 
you do not want to arm tracks in Pro Tools.

Set Servo Lock Bit at Play Enable this option 
when using a synchronizer to control Pro Tools 
in Remote mode to minimize lock-up times dur-
ing recording.

Allow 9-Pin Track Arm Commands in Local 
Mode Sets Pro Tools to respond to incoming 
track arming (record enable) commands even 
when the system is not in Remote mode. This is 
useful if you are using a paddle device to control 
Pro Tools track arming or punching. 

Allow 9-Pin Transport Commands in Local 
Mode Sets Pro Tools to respond to incoming 
transport commands even when the system is 
not in Remote mode. This is useful when using 
Satellite Link in conjunction with a 9-pin con-
troller. You can receive the transport controls 
from the 9-pin controller, but not experience the 
lag-time associated with a 9-pin device.

Punch In Frame Offset Sets an offset (in frames) 
to compensate for punch in timing advances or 
delays.

Punch Out Frame Offset Sets an offset (in 
frames) to compensate for punch out timing ad-
vances or delays.

Delay After Play Command Sets the amount of 
time (in frames) for Pro Tools to wait after re-
ceiving a Play command before starting the au-
dio engine. This can prevent false starts when 
locking to synchronizers that are not fully sup-
ported by Pro Tools.
Chapter 8: Preferences 139



140
Satellites Section
(Pro Tools|HD and HD Native Systems with 
Satellite Link Only)

These preferences are available only with the 
Satellite Link option. The Pro Tools Satellite 
Link option lets you link up to 5 Pro Tools sys-
tems (or 4 Pro Tools systems and an Avid® Me-
dia Composer® with the Video Satellite option or 
a Video Satellite LE system) over an Ethernet 
network so that you can cue, play, and stop the 
transport, make play selections, and solo tracks 
across any of the systems from any linked work-
station.

Transmit Solos Causes a linked Pro Tools sys-
tem to send the solo status of its tracks to all 
other linked Pro Tools systems. On other linked 
systems that are set to receive solos, tracks fol-
low solo behavior as if the solo were on the local 
system. 

Receive Solos Causes a linked Pro Tools system 
to receive solos from all other linked Pro Tools 
systems that are set to transmit solo status of 
their tracks. Tracks on the receiving system fol-
lows solo behavior as if the solos were on the lo-
cal system. 

Solo Independent of Linked State Causes a 
Pro Tools system to send the solo status of its 
tracks to other satellite systems even when it is 
unlinked. This allows control of solo status 
across systems even when transport control is 
not enabled. 

DAE Errors Stop All Linked Systems Causes a 
DAE error on any linked Pro Tools system to 
stop the transport on all linked systems. When 
this option is not selected, linked systems will 
not stop if a DAE error occurs on one system. 
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Transmit Play Selections Causes a linked 
Pro Tools system to send the Edit window selec-
tion to all other linked Pro Tools systems. On 
other linked systems that are set to receive play 
selections, the selection is mirrored in the Edit 
window.

Receive Play Selections Causes a linked 
Pro Tools system to receive Edit window selec-
tions from all other linked Pro Tools systems 
that are set to transmit play selections.



Chapter 9: Peripherals
The settings in the Peripherals dialog define 
how Pro Tools works with various synchroniza-
tion, machine control, MIDI control surface, 
Ethernet worksurface, Mic Preamp, satellite 
peripherals and devices, and linked VENUE 
systems. 

To configure settings for Pro Tools peripherals:

1  Choose Setup > Peripherals.

2  Click the tab for the type of peripheral you 
want to configure. 

3  Change the settings.

4  Click OK to save your changes and close the 
Peripherals dialog.

Synchronization
The Synchronization page lets you configure 
Pro Tools for use with MIDI Timecode and a 
synchronization peripheral.

For information about synchronization pe-
ripherals, see the SYNC HD Guide.
MTC Reader and Generator
The MIDI Timecode (MTC) settings let you se-
lect the MIDI In and Out ports for MTC.

MTC Reader Port The MTC Reader Port setting 
lets you select the MIDI In port to which the 
MTC slave device is connected (the source of 
MTC information from the slave device). 

MTC Generator Port The MTC Generator Port set-
ting lets you select the MIDI Out port to which 
the master device is connected (this the destina-
tion of MTC information from Pro Tools).
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Synchronization Device
(Pro Tools|HD and HD Native Systems Only)

The Synchronization Device settings let you 
configure a synchronization peripheral, such as 
the SYNC HD or SYNC I/O.

Enable SYNC Peripheral

When this option is selected, any connected syn-
chronization peripheral is enabled for use with 
Pro Tools.

Current Firmware Version

This displays the firmware version for the con-
nected synchronization peripheral, such as a 
SYNC HD.

VITC Insertion Enabled

When this option is selected, VITC is inserted 
into the outgoing video signal—assuming that a 
video signal is present at a synchronization pe-
ripheral video input, and that the synchroniza-
tion peripheral is in a valid mode for inserting 
VITC. 

Pitch Memory Enabled

When this option is selected, the synchroniza-
tion peripheral will remain at a pitch (sample 
rate) that corresponds to the last known incom-
ing timecode speed. When deselected, the Syn-
chronization peripheral reverts to the selected 
sample rate. If Pitch Memory is disabled and the 
selected external clock reference is not avail-
able, then the synchronization peripheral re-
verts to the nominal, selected internal sample 
rate setting.

Idle MTC Enabled

When this option is selected, MTC is continu-
ously output. When not enabled, MTC output is 
muted when playback is idle.
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LTC Output Level

This setting adjusts the analog audio level of the 
LTC output, from –24 dBu to +9 dBu.

VITC Read Lines

This setting determines which line pair of in-
coming video signal is used for the VITC source. 
When set to Auto, the synchronization periph-
eral searches for the first valid line pair auto-
matically. Alternatively, this value can be set to 
specific VITC line pairs.

VITC Generate Lines

This setting determines the line pair of the out-
going video signal onto which the synchroniza-
tion peripheral inserts VITC. Normally, this 
should be left at the default (and preferred) set-
ting of 14/16. 

Bi-Phase/Tach Wiring

This setting lets you select from the following 
options for Bi-Phase or Tach wiring:

• Bi-Phase: FWD = A leads B

• Bi-Phase: FWD = B leads A

• Tach:FWD = B is Low

• Tach: FWD = B is High

Bi-Phase/Tach Pulses/Frame (2–254)

There are several different standards for the 
number of pulses-per-frame output by Bi-Phase 
or Tach devices. You can set the synchronization 
peripheral to operate from 2 to 254 pulses per 
frame from Pro Tools. The setting should match 
the PPF rate of the Bi-Phase/Tach encoder on 
the external device.



Reset Bi-Phase

This button lets you set the Bi-Phase/Tach start 
frame from Pro Tools. Click the button to up-
date the Timecode Display on the synchroniza-
tion peripheral to match the session timecode 
value.

Enable Dub Window

When this option is selected, you can insert a 
timecode window into a video signal with the 
following Window dub appearance settings: 

Vertical Position Sets the vertical position of the 
window dub, relative to the bottom of the video 
picture. The choices range from 10% From Bot-
tom to 50% From Bottom, in 10% increments.

Horizontal Position Sets the relative horizontal 
position of the window dub within the video pic-
ture. The choices include Extreme Left, Left, 
Center, Right and Extreme Right.

Size Sets the relative size of the window dub 
(Small or Large).

Color Sets the color of the timecode numbers 
and background of the window dub. The choices 
include White on Black Bkgnd, Black on White 
Bkgnd, White on Video Bkgnd, or Black on 
Video Bkgnd. (Video Bkgnd means that the 
background of the window dub is transparent, 

“10% from Bottom” vertical position is out-
side the standard “safe title” area, which 
means it may not be visible on some video 
monitors.

The “Extreme” horizontal positions are out-
side the standard “safe title” area, which 
means they may not be visible on some 
video monitors.
so that the timecode numbers are displayed di-
rectly on top of the video signal, without a con-
trasting background box.) The default setting is 
White on Black Bkgnd.

Machine Control
The Machine Control page lets you configure 
Pro Tools for use with MIDI Machine Control or 
9-Pin Machine Control.

MIDI Machine Control (Master)
Pro Tools provides the following for configuring 
MIDI Machine Control (Master) settings.

Enable

When the Enable option is selected, Pro Tools is 
the Master and it sends MMC commands to the 
slave device and receives MTC information back 
from the slave device.

For information about the MachineControl 
Software Option for Pro Tools, see the 
MachineControl Guide.
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MIDI Out Port

The MIDI Out Port pop-up menu lets you select 
the MIDI Out port to which the slave device is 
connected.

MMC ID

The MMC ID setting lets you specify the MMC 
ID number for which MMC information will be 
sent. MMC commands contain an ID number to 
identify which machine should respond to the 
MMC command. There are 128 MMC ID num-
bers, from 0–127. The default of ID #127 is a 
special setting that transmits to all 128 MMC 
IDs. With a setting of 127, Pro Tools will trans-
mit MMC commands to all MMC IDs. 

Preroll

The Preroll setting lets you specify a pre-roll 
time in frames for your MMC slave device. Pre-
roll is needed to provide the device with suffi-
cient time to lock to the timecode transmitted by 
Pro Tools. This value will vary depending on the 
external device. If the pre-roll time is insuffi-
cient, the device may not be ready to lock until 
after the current timecode position has passed.

MIDI Machine Control (Slave)
Pro Tools provides the following for configuring 
MIDI Machine Control (Slave) settings.

Enable

When the Enable option is selected, Pro Tools is 
the slave and it receives MMC commands from 
the master device and sends MTC information 
back to the slave device.

MMC ID

The MMC ID setting lets you specify the MMC 
ID number for which MMC information will be 
received.
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9-Pin Machine Control (Deck 
Control)
(Pro Tools|HD and HD Native Systems with 
MachineControl Only)

The 9-Pin Machine Control (Deck Control) settings 
let you configure a Machine Control device for 
Serial Deck Control mode with Pro Tools. Serial 
Deck Control mode is available whenever Ma-
chine Control is connected using the Serial Deck 
Control cable. When connected for Serial Deck 
Control mode, Machine Control enables all 
Pro Tools track arming, synchronization, and 
Transport features, as available on your system. 
Serial Deck Control mode also supports 9-pin 
serial timecode.

Enable

When the Enable option is selected, Pro Tools is 
in Serial Deck Control mode.

Port

The Port setting lets you select the 9-pin Ma-
chine Control port. The available choices depend 
on your platform and configuration

Machine Type

After you select a port, Pro Tools automatically 
polls the port to see what kind of machine is 
connected. If the machine is recognized, 
Pro Tools loads the corresponding Machine 

Type. This includes the corresponding track lay-
out and automatically enters the name of that 
machine into the Machine Track Arming win-
dow. However, if the machine is not recognized, 
the “Generic 1” personality is automatically 
loaded. 



Preroll

The Preroll setting lets you specify a variable 
amount of machine preroll to account for the 
time it may take the machine to achieve servo 
lock. Shorter preroll values are usually better for 
non-linear machines. Longer preroll values are 
usually better for older tape transports. The Ma-
chine preroll value is added to any preroll spec-
ified in the Transport window.

9-Pin Remote (Deck Emulation)
(Pro Tools|HD and HD Native Systems with 
MachineControl Only)

The 9-Pin Remote (Deck Emulation) settings let 
you configure Pro Tools for 9-Pin Remote (Deck 
Emulation) mode. This mode makes Pro Tools 
operate as a virtual tape deck, supporting most 
standard Sony P2 9-pin commands. By default, 
Pro Tools emulates a Sony BVW-75 model video 
deck. You can also configure Pro Tools to emu-
late other machines.

Enable

When the Enable option is selected, Pro Tools is 
in 9-Pin Remote (Deck Emulation) mode.

Port

The Port setting lets you select the 9-pin Ma-
chineControl port. The available choices depend 
on your platform and configuration

Machine Type

The Machine Type setting lets you select the ma-
chine description for specific machine control-
lers (such as the Soundmaster ATOM). By de-
fault, Pro Tools emulates a Sony BVW-75. 
Chase LTC

When Chase LTC is enabled, Pro Tools still re-
sponds to track arming and record commands. 
However, Pro Tools will chase incoming LTC in-
stead of behaving as a master or slave device 
with the machine controller. By slaving 
Pro Tools to the LTC source instead of slaving 
the machine to Pro Tools timecode, you can 
avoid the waiting (and tape wear) that occurs 
while a machine transport locates and bumps 
tape to the cue point. 

MIDI Controllers
The MIDI Controllers page lets you configure up 
to four different MIDI controllers for Pro Tools.

Number and Color

The number of the row indicates the order of the 
selected controllers. The color corresponds to 
the controller focus around Pro Tools track and 
plug-in controls.
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Type

The Type setting lets you select the MIDI con-
troller connected to your computer. Choose 
from any of the following types of MIDI control-
lers:

• Command|8

• HUI

• MotorMix

• Surround Panner

• M-Audio Keyboard

Receive From

The Receive From setting lets you select the 
MIDI In port to which your MIDI controller is 
connected.

Send To

The Send To setting lets you select the MIDI Out 
port to which your MIDI controller is con-
nected.

Number of Channels

The Number of Channels (# Ch’s) setting dis-
plays the number of control channels supported 
by the selected MIDI controller type.
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Ethernet Controllers
The Ethernet Controllers page lets you config-
ure up to seven different Ethernet controllers 
for Pro Tools.

Enable

When selected, Pro Tools is enabled for control 
by one or more Ethernet controllers (such as 
D-Command or C|24).

Ethernet Port

The Ethernet Port setting lets you specify the eth-
ernet port on your computer to which your con-
troller is connected.

Number and Color

The number of the row indicates the order of the 
selected controllers. The color corresponds to 
the colored controller focus border around 
Pro Tools track and plug-in controls.

Ethernet Controller

From the Ethernet Controller pop-up menu, se-
lect the Ethernet controller that you want to use.



Name

Click the Name button to enter a name for the 
selected Ethernet controller.

Enable EUCON (Extended User Control)

When selected, Pro Tools is enabled for control 
by one or more EUCON-compatible controllers. 
EUCON is an innovative high-speed Ethernet 
protocol developed by Avid to allow hardware 
control surface to directly communicate with a 
software application. 

Mic Preamps
The Mic Preamps page lets you configure up to 
nine different Mic Preamps (PRE) for Pro Tools.

For more information about using Pro Tools 
with EUCON, see the documentation in-
cluded with your controller.

For information about the PRE, see the PRE 
Guide.
Type

The Type setting lets you select none or PRE. Se-
lect the PRE option to declare any connected 
PRE.

Receive From

The Receive From setting lets you specify the 
MIDI In port to which the PRE is connected.

Send To

The Send To setting lets you specify the MIDI 
Out port to which the PRE is connected.

Defaults

Click the Reset button reset the corresponding 
PRE to its default settings.

Retain Current Settings

Select the Retain Current Settings option to re-
tain PRE channel settings when an existing ses-
sion with different settings is loaded. New ses-
sions will automatically retain the current 
settings.

Remote Lock-Out Mode

When the Remote Lock-Out Mode option is se-
lected, all connected PREs ignore their front 
panel controls.
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Satellites
The Satellites page lets you configure Pro Tools 
for use with Satellite Link, Video Satellite, and 
Video Satellite LE software options. 

The Pro Tools Satellite Link option lets you link 
up to 12 Pro Tools|HD and HD Native systems 
(or 11 Pro Tools|HD and HD Native systems and 
an Avid Media Composer with the Video Satel-
lite option or a Pro Tools Video Satellite LE sys-
tem) over an Ethernet network so that you can 
cue, play, and stop the transport, make play se-
lections, and solo tracks across any of the sys-
tems from any linked workstation. 

The Video Satellite option lets you link a 
Pro Tools|HD or HD Native system and a Media 
Composer system. The Video Satellite LE option 
lets you link a Pro Tools|HD (or HD Native) sys-
tem and a Pro Tools host-based system for mon-
itoring QuickTime HD video.

For more information, see the guide for 
your Satellite option.
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System Name

Type a name for the local system. This name ap-
pears in the list of available satellites in other 
connected systems with the Satellite Link op-
tion.

Mode

The Mode settings let you configure the satellite 
behavior of the local system. 

Administrator When enabled, the Administrator 
option sets the local system to be the adminis-
trator system for any satellite systems on the 
network. Satellite systems can be declared from 
the administrator system. 

Satellite When enabled, the Satellite option sets 
the local system to be a satellite system on the 
network. When a system is in Satellite mode, it 
becomes available to be declared as a satellite 
from any administrator system on the network. 

Administrator

When the local system is in Administrator 
mode, the Administrator settings let you declare 
satellites from that system. 

System 1–12 These pop-up menus let you de-
clare up to 11 satellite systems (in addition to 
the administrator system itself) from an admin-
istrator system. The number of the system indi-
cates the order of the declared satellites in the 
Transport window.



VENUE
The VENUE page lets you configure Pro Tools 
for use with a VENUE system over Ethernet 
using VENUE Link. 

Pro Tools VENUE Link lets you import VENUE 
Settings into Pro Tools, create Pro Tools mark-
ers from VENUE Snapshots, and locate to 
Pro Tools markers from VENUE Snapshots.

System Name

The System Name field lets you enter a name for 
your Pro Tools system.

VENUE System

The VENUE System selector lets you select a re-
mote VENUE system for recording to (or play-
back from) your Pro Tools system. You can also 
manually enter the IP addresses of the VENUE 
system.
Advanced Network Settings

The Advanced Network settings let you specify an 
IP address and port for VENUE Link communi-
cation. 

Interface For systems that have more than one 
Ethernet network connection, the Interface set-
ting lets you select which connection to use for 
VENUE Link communication. 

TCP/UDP Port For systems that have more than 
one Ethernet network connection, you can enter 
the TCP/UDP port number to be used for 
VENUE Link communication.
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Chapter 10: Configuring MIDI
If you are using external MIDI devices with 
Pro Tools (such as controllers or sound mod-
ules), you can customize your MIDI studio setup 
to display the names of your MIDI devices in 
Pro Tools.

MIDI Studio Setup (Mac)
Pro Tools recognizes the ports on your MIDI in-
terface as generic ports. With Mac OS X, you use 
Apple’s Audio MIDI Setup (AMS) utility to iden-
tify external MIDI devices connected to your 
MIDI interface and configure your MIDI studio 
for use with Pro Tools.

To configure your MIDI studio in AMS:

1  Do one of the following:

• Launch Audio MIDI Setup (located in Ap-
plications/Utilities).

– or –

• In Pro Tools, choose Setup > MIDI > MIDI 

Studio.

To ensure optimum performance, do not 
change the AMS configuration while 
Pro Tools is playing back. Stop the 
Pro Tools transport before launching AMS. 
2  If the MIDI Studio window is not showing, 
choose Window > MIDI Studio. 

AMS scans your system for connected MIDI in-
terfaces. If your MIDI interface is properly con-
nected, it appears in the window with each of its 
ports numbered.

3  To create a custom MIDI device for any exter-
nal MIDI devices connected to your MIDI inter-
face, click Add Device. A new external device 
icon with the default MIDI keyboard image ap-
pears.

4  Drag the new device icon to a convenient loca-
tion within the window.

Audio MIDI Setup (MIDI Devices tab)
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5  Connect the MIDI device to the MIDI interface 
by clicking the arrow for the appropriate output 
port of the device and dragging a connection or 
“cable” to the input arrow of the corresponding 
port of the MIDI interface.

6  Click the arrow for the appropriate input port 
of the device and drag a cable to the output ar-
row of the corresponding port of the MIDI inter-
face. 

7  Repeat steps 3–6 for each MIDI device in your 
MIDI setup.

To customize an external MIDI device in AMS:

1  Select the external device icon and click Show 

Info (or double-click the new device icon). 

Making MIDI input and output connections

To remove a connection, select the cable and 
press Delete.

External Device Icon
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2  Select a manufacturer and model for the new 
device from the corresponding pop-up menus. 
(If the Manufacturer and Model pop-up menus 
do not provide a name for your particular de-
vice, you can type a name.)

Naming a new MIDI device

 For Manufacturer and Model names, AMS 
refers to one or more files with the suffix 
“.middev” in the directory Root/Library/
Audio/MIDI Devices. Pro Tools installs a 
file that contains information for many 
commercially available MIDI devices, 
named “Digidesign Device List.middev.” If 
the Manufacturer or Model names for any of 
your external MIDI devices is not available 
in the AMS Manufacturer and Model pop-up 
menus, you can add them by editing the 
.middev file in any text editor (such as 
TextEdit). 

For more information, see “MIDI Patch 
Names” on page 701.



3  Click the More Information arrow to expand 
the dialog, then enable the appropriate MIDI 
channels (1–16) for the Transmits and Receives 
options. (These determine which channels the 
device will use to send and receive MIDI.) 

Enabling MIDI channels
4  Click the device image. The window expands 
to show images for various MIDI devices (such 
as keyboards, modules, interfaces, and mixers). 
Select an icon for your device. 

5  Select a device image and click Apply. 

6  Close the AMS window to quit the AMS appli-
cation. 

The device names you enter appear as MIDI in-
put and output choices in Pro Tools.

Selecting a device icon

To use your own custom icons, you can place 
TIFF image files in /Library/
Audio/MIDI Devices/Generic/Images, and 
they will appear as choices in the AMS
device window.
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MIDI Studio Setup (Windows)
MIDI Studio Setup (MSS) lets you configure the 
MIDI controllers and sound modules that are 
connected to your system, and control the rout-
ing of MIDI data between your MIDI equipment 
and Pro Tools.

MSS automatically finds MIDI interfaces, and 
lets you specify a custom name for each of the 
MIDI ports within the MIDI Studio Setup docu-
ment. 

MSS also supports XML-based patch file names 
for storing and importing patch names for your 
external MIDI devices. 

Entire MIDI Studio Setup configurations cre-
ated within MSS can be imported and exported. 

To configure your MIDI studio with MSS:

1  In Pro Tools, choose Setup > MIDI > MIDI Stu-

dio.

2  Configure the MIDI Studio Setup windows.

3  When you are finished configuring the MIDI 
Studio Setup, close the MIDI Studio Setup win-
dow.
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MIDI Studio Setup Window
The MIDI Studio Setup window is organized 
into three sections. Interface controls are at the 
top of the window. All the currently defined in-
struments are displayed in the Instrument Name 
list on the left side of the window. A detailed 
view of MIDI parameters is shown in the Prop-
erties section on the right.

Interface Controls

Create Adds a new instrument to the Instrument 
Name list.

Delete Deletes the instrument or instruments 
selected in the Instrument Name list.

Import Imports an existing MIDI Studio Setup 
file.

Export Exports the current MIDI Studio Setup 
file.

MIDI Studio Setup window



Show Duplicate Emulated Ports When this op-
tion is selected and you are using a MIDI inter-
face that supports time-stamping (such as MIDI 
I/O), in addition to the MIDI ports on Mbox 2, 
the MIDI Studio setup window shows both the 
DirectMusic time-stamped output ports, and 
non-stamped duplicate emulated output ports. 

Instrument List

The Instrument list contains all the currently 
defined instruments. Selecting an instrument in 
the list displays that instrument’s properties in 
the Properties section of the window.

Properties Section

The Properties section lets you edit information 
for new instruments, or instrument currently 
selected in the Instrument list.

When a previously defined instrument is se-
lected in the Instrument list, the Properties sec-
tion changes to reflect the properties of the se-
lected instrument.

To define an instrument with MIDI Studio Setup:

1  Choose Setup > MIDI > MIDI Studio.

2  Click Create.

3  In the Instrument Name field, type the name of 
your instrument, and press Enter.

Some MIDI Interfaces will not properly load 
or unload their drivers unless you quit and 
re-launch Pro Tools. Check the documenta-
tion that came with your MIDI interface for 
more information.

If you do not enter an instrument name, the 
Instrument Name field will automatically 
inherit information from the Manufacturer 
and Model pop-up menu. 
4  Set a manufacturer and model for the new de-
vice from the corresponding pop-up menus. If 
the Manufacturer and Model pop-up menus do 
not provide a name for your particular device, 
choose None.

5  From the Input pop-up menu, choose the input 
port on your MIDI interface that is connected to 
the MIDI Out of your instrument.

6  From the Output pop-up menu, choose the 
output port on your MIDI interface that is con-
nected to the MIDI In of your instrument.

7  Enable the appropriate MIDI channels (1–16) 
for the Send Channels and Receive Channels op-
tions (These determine which channels send and 
receive MIDI.)

Instrument Name

The Instrument Name field shows the user-de-
finable instrument name for the currently se-
lected instrument.

Manufacturer

The Manufacturer pop-up menu provides a list 
of MIDI equipment manufacturers. This list is 
derived from the XML-based MIDI device files. 

Model

The Model pop-up menu provides a list of MIDI 
devices, filtered by the manufacturer name. This 
list is derived from the XML-based MIDI device 
files provided with your Pro Tools installation.

For more information, see “MIDI Patch 
Names” on page 701.

For more information, see “MIDI Patch 
Names” on page 701.
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Input Port

The Input Port pop-up menu displays a list of 
available MIDI interface input ports. The MIDI 
interface port that is set and displayed here is 
the port through which MIDI data is sent from 
the external MIDI device specified in the Instru-
ment Name field into your MIDI interface.

Output Port

The Output Port pop-up menu displays a list of 
available MIDI interface output ports. The port 
set and displayed here is the port through which 
MIDI data is sent from your MIDI interface to 
the MIDI device specified in the Instrument 
Name field.

Send Channels

The Send Channels grid sets the send channels 
for the MIDI device specified in the Instrument 
Name field. 

Receive Channels

The Receive Channels grid sets the receive chan-
nels for the MIDI device specified in the Instru-
ment Name field.

If you set the input port to None, the defined 
instrument will not appear as a choice in a 
MIDI Input Selector. 

If you set the output port to None, the 
defined instrument will not appear as a 
choice in a MIDI Output Selector. 
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Chapter 11: Sessions
The first step in beginning a Pro Tools project is 
creating a new session. Sessions are represented 
by session files that can be saved, copied and 
made into templates.

Quick Start Session Dialog
Pro Tools provides a Quick Start dialog on 
launch that lets you quickly and easily create a 
new session or open an existing one. You can 
choose to show or hide the Quick Start dialog on 
launch in the Pro Tools Operation Preferences.

When you first launch Pro Tools, you are 
prompted by the Quick Start dialog to do one of 
the following:

• Create a new session from a template.

• Create a new blank session.

• Open any of the last ten most recent sessions.

• Open any other session on your system.

Press Control+Up Arrow or Down Arrow 
(Windows) or Command+Up Arrow or 
Down Arrow (Mac) to select different Ses-
sion Quick Start options. Also, you can use 
the Up and Down Arrows to select different 
items in the Recent Sessions and Session 
Templates lists.
Creating a New Session from a 
Template

To create a new session from a template:

1  Select Create Session from Template.

2  From the Session Template pop-up menu, se-
lect the category for the session templates you 
want.

Session Template pop-up menu, Quick Start dialog

You can create your own custom categories. 
For more information, see “Session Tem-
plates” on page 174. 
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3  Select the session template you want to use 
from the list (on the right).

4  If you want to change any of the session pa-
rameters, click the Session Parameters reveal 
button (to show the parameters) and do any of 
the following:

• Select the Audio File Type for the session.

• Select the Bit Depth (16 bit, 24 bit, or 32 bit 

float).

• If desired, select (or deselect) Interleaved to 
create interleaved multichannel audio files 
in the session.

• Select the Sample Rate.

5  Click OK.

6  In the Save dialog, name the session, choose 
where you want to save the session, and click 
Save.

Quick Start dialog, Session Parameters revealed

For optimum compatibility between 
Windows and Mac, set the file type to 
BWF (.WAV). 
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Creating a New Blank Session

To create a new blank session:

1  Select Create Blank Session.

2  If you want to change any of the session pa-
rameters, click the Session Parameters reveal 
button and do any of the following:

• Select the Audio File Type for the session.

• Select the Bit Depth (16 bit or 24 bit).

• Select the Bit Depth (16 bit, 24 bit, or 32 bit 

float).

• If desired, select (or deselect) Interleaved to 
create interleaved multichannel audio files 
in the session.

• Select the Sample Rate.

• Select the I/O Settings to use for the session. 
Several pre-configured I/O Settings are in-
cluded with your system, or you can select a 
custom I/O Setting. For more information, 
see Chapter 7, “I/O Setup.” 

3  Click OK.

Quick Start dialog, Create Blank Session



4  In the Save dialog, name the session, choose 
where you want to save the session, and click 
Save.

Opening a Recent Session

To open a recent session:

1  Select Open Recent Session.

2  Select any of the last ten recent sessions from 
the list (on the right).

3  Click OK.

Opening Any Session

To open any session:

1  Select Open Session.

2  Click OK.

3  In the Choose a Session dialog, navigate to the 
location of the session file and select it.

The Open Recent Session option is not avail-
able the first time you launch Pro Tools (or 
if you have cleared the Recent Sessions list 
by choosing File > Open Recent > Clear).

Quick Start dialog, Open Recent Session
4  Click Open.

Showing or Hiding the Quick 
Start Dialog on Launch

To prevent the Quick Start dialog from appearing 
when Pro Tools launches:

 Deselect the Show Quick Start Dialog when 

Pro Tools Starts option in either the Quick Start 
dialog or the Pro Tools Operation Preferences 
(Setup > Preferences).

To have the Quick Start dialog appear when 
Pro Tools launches:

1  Choose Setup > Preferences.

2  Click the Display tab.

3  In the Warnings & Dialogs section of the Dis-
play Preferences page, select the Show Quick 

Start Dialog when Pro Tools Starts option.

4  Click OK.

Sound Designer II (SD II) files are not 
supported on Pro Tools systems higher 
than version 8.0.3. When opening a 
session created with a lower version of 
Pro Tools that uses the SD II file format, 
you are prompted to convert the session 
and all SD II files to WAV.

Show Quick Start Dialog when Pro Tools Starts option
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Creating a New Session
The New Session dialog lets you create a new 
session from a template or create a new blank 
session (with no tracks or media).

Creating a New Session from a 
Template

To create a new session from a template:

1  Choose File > New.

2  In the New Session dialog, select Create Ses-

sion from Template.

3  From the Session Template pop-up menu, se-
lect the category for the session templates you 
want.

4  Select the session template you want to use 
from the list (on the right).

5  Select the Audio File Type for the session.

New Session dialog, Create Session from Template

For optimum compatibility between 
Windows and Mac, set the file type to BWF 
(.WAV). 
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6  Select the Bit Depth (16 bit, 24 bit, or 32 bit 

float).

7  If desired, select (or deselect) Interleaved to 
create interleaved multichannel audio files in 
the session.

8  Select the Sample Rate.

9  Click OK.

10  In the Save dialog, name the session, navigate 
to the location where you want to save the new 
session and click Save.

Creating a New Blank Session

To create a new blank session:

1  Choose File > New.

2  In the New Session dialog, select Create Blank 

Session.

3  Select the Audio File Type for the session.

4  Select the Bit Depth (16 bit, 24 bit, or 32 bit 

float).

Sound Designer II (SD II) files can be im-
ported and exported, but are not supported 
as the session Audio File Type on Pro Tools 
systems version 8.0.3 or higher.

New Session dialog, Create Blank Session



5  If desired, select (or deselect) Interleaved to 
create interleaved multichannel audio files in 
the session.

6  Select the Sample Rate.

7  Select the I/O Settings to use for the session. 
Several pre-configured I/O Settings are included 
with your system, or you can select a custom I/O 

Setting. For more information, see Chapter 7, 
“I/O Setup.” 

8  Click OK.

9  In the Save dialog, name the session, navigate 
to the location where you want to save the new 
session and click Save.

Bit Depths and Sample Rates
When selecting a bit depth or sample rate for 
your session, consider fidelity, any compatibil-
ity issues with others systems, and storage 
space. 

Bit depth and sample rate also have an effect on 
the amount of mixing power available in a ses-
sion. Fewer mixer channels are available with 
24-bit and 32-bit floating point sessions, and 
with sessions at higher sample rates.

Bit Depths
16-Bit Using 16-bit for audio files is useful for 
keeping audio file sizes down. You may want to 
use 16-bit for sessions with few tracks, and little 
mixing and plug-in processing. CDs (Compact 
Discs) use 16-bit bit depth.

24-Bit Using 24-bit for audio files is commonly 
used for most music production and post-pro-
duction sessions with multiple audio tracks, 
mixing, and plug-in processing. 24-bit files take 
up a third as much space as 16-bit files.
32-Bit Floating Point Using a 32-bit floating 
point bit depth for audio files in Pro Tools ses-
sions can help avoid clipping with AudioSuite 
rendering, or unnecessary dithering with 
AudioSuite rendering. It can also help avoid 
rounding errors in signal processing (which can 
occur during bit-depth conversion for file play-
back and real-time plug-in insert processing). 
However, 32-bit files take up a third more disk 
space and audio streaming bandwidth, which 
can be problematic with higher track counts 
when using slower hard drives.

You can change the bit depth for all newly re-
corded or imported (and converted) files in the 
session by selecting a different Bit Depth option 
in the Session Setup window.

To change the Bit Depth for the Pro Tools session:

1  Choose Setup > Session.

2  In the Session Setup window, select the desired 
bit depth from the Bit Depth selector. 

Sample Rates
44.1 kHz Is the sample rate used for CDs and is 
used in most common music production envi-
ronments.

48 kHz Is the standard sample rate for film and 
video projects, and is commonly used in post-
production environments. It is the sample rate 
used for DVDs.

Session Setup window, selecting 32 Bit Float
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88.2 kHz and 96 kHz Each of these sample rates, 
are twice the standard sample rates for CD audio 
and DVD audio respectively. Audio files re-
corded at higher sample rates take up more 
drive space, but provide higher resolution for 
time-based plug-in processing (which can help 
avoid aliasing). The 88.2 kHz and 96 kHz sample 
rate options are only available if you are running 
Pro Tools with audio hardware that supports 
these sample rates.

172.4 kHz and 192 kHz Each of these sample 
rates, are four times the standard sample rates 
for CD audio and DVD audio respectively. Audio 
files recorded at higher sample rates take up 
more drive space, but provide higher resolution 
for time-based plug-in processing (which can 
help avoid aliasing). The 176.4 kHz and 192 kHz 
sample rate options are only available if you are 
running Pro Tools with audio hardware that 
supports these sample rates.

Mixed Audio File Formats
Pro Tools supports mixed audio file formats 
(such as WAV and AIF) in a single session. 
When importing audio files into a Pro Tools ses-
sion, you can choose to Add them rather than 
Convert them regardless of the audio file format.

You can change the audio file format for all 
newly recorded or imported (and converted) 
files in a session by selecting a different Audio 

Format option in the Session Setup window.

To change the Audio Format for the Pro Tools 
session:

1  Choose Setup > Session.

2  In the Session Setup window, select the desired 
audio file format (AIF or WAV) from the Audio 

Format selector. 
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Interleaved Multichannel 
Versus Mutli-Mono Audio 
Files
For stereo and greater-than-stereo multichannel 
audio, Pro Tools supports both interleaved mul-
tichannel audio files and multi-mono audio files 
(versions of Pro Tools lower than 10.0 only sup-
port multi-mono audio files—interleaved multi-
channel audio file are converted to multi-mono 
on import).

An interleaved audio file contains all channel 
information, stored in an alternating single au-
dio “stream.” Interleaving distributes and “in-
terleaves” the consecutive bits of data. This 
helps protect against consecutive errors when 
the data is read back.

Multi-mono, or “split-mono” multi-channel au-
dio files are separate mono audio files that are 
treated together as a multichannel group of au-
dio files. This lets you each channel (file) inde-
pendently. For example, with stereo files, two 
separate files are created, where one file con-
tains the left channel, and the other file contains 
the right channel. The files are identified by the 
suffixes of “.L” and “.R”. The two files are 
linked, and are edited as a pair in stereo tracks 
in Pro Tools. However, you can decouple them 
and split them to individual mono audio tracks 
in Pro Tools so that the can be edited, processed, 
and mixed independently. 

You can change the Interleaved setting for the 
currently open session in the Session Setup win-
dow. When this option is enabled, all newly re-
corded or imported (and converted) stereo or 
greater-than-stereo multichannel files in the 
session will be interleaved audio files.



To enable (or disable) interleaved audio files for 
the Pro Tools session:

1  Choose Setup > Session.

2  In the Session Setup window, select (or dese-
lect) the Interleaved option.

Session Files and Folders
When you create a new session, Pro Tools auto-
matically creates a new folder named for your 
session. Within this folder is the session file, a 
WaveCache.wfm file, and several subfolders (in-
cluding, but not limited to, an Audio Files folder 
and a Clip Group folder).

Session File
The session file is the document that Pro Tools 
creates when you start a new project. Pro Tools 
can open only one session file at a time. The ses-
sion file is appended with the extension .ptx.

Typical session folder contents (Mac OS X shown)
Audio Files Folder
The Audio Files folder contains all audio re-
corded or converted during the session. 

When you record a new audio track, the track is 
saved as a new audio file to the Audio Files 
folder. You can also import other audio files 
into the session, and work with them as well. 

Fade Files Folder
The Fade Files folder may be present in legacy 
Pro Tools sessions. Versions of Pro Tools lower 
than 10.0 use rendered fades and cross-fades 
that are written to the “Fade Files” folder in the 
session folder.

Rendered Files Folder
The Rendered Files folder contains any tempo-
rary files created by Rendered Elastic Audio 
processing in the session. It may also contain 
temporary filtered analysis files (.aan) as a re-
sult of any changes to Elastic Audio analysis.

Clip Groups Folder
The Clip Groups folder is the default directory 
for any clip groups that you export from your 
Pro Tools session.

WaveCache File
The WaveCache.wfm file stores all of the wave-
form display data for the session. If you delete 
the WaveCache.wfm file, Pro Tools creates a 
new one the next time you open the session.

For details on allocating audio tracks to 
different hard drive locations, including 
shared media volumes, see “Recording with 
Multiple Hard Drives” on page 453.
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By storing waveform data in the WaveCache file, 
sessions open more quickly. The session Wave-
Cache file can be included whenever a session is 
transferred to another Pro Tools system (7.x 
and higher). 

Pro Tools also maintains a distinct WaveCache 
file inside the Databases folder, which retains 
waveform data for all files used on the system.

Deleting or trashing a WaveCache file does not 
harm the session or your system. However, the 
session will take longer to open because it has to 
recalculate waveform data for any associated 
audio files and store that data in a new Wave-
Cache file. 

Session File Backups Folder
The Session File Backups folder contains auto-
matically-generated backups of your Pro Tools 
sessions. These files are created when working 
on a session and the Operations preference for 
Enable Session File Auto Backup is enabled. (See 
“Enable Session File Auto Backup” on page 125.)

Renamed Audio Files Folder
This folder includes file names that have been 
renamed when you open a session that contains 
audio file names with incompatible characters, 
or, in certain situations, save a copy of a session 
to a Pro Tools version that does not support 
long file names.

For more information, see “Renamed Audio 
Files and the Renamed Audio Files Folder” on 
page 393.
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Opening a Session
When you open a session, Pro Tools looks in the 
session folder for audio and fade files linked to 
the session.

To open an existing session:

1  Choose File > Open Session.

2  Locate the session you want to open and click 
Open.

Opening a Session that Contains 
Fade Files
When opening a session created in a version of 
Pro Tools lower than 10.0, Pro Tools calculates 
and plays back all fades in real time. The “Fade 
Files” folder in the session folder is neither de-
leted nor used. Any rendered fades created in 
legacy sessions are calculated and played back in 
real time. Any new fades created in the session 
do not generate any new rendered fade files in 
the pre-existing “Fade Files” folder.

For more information on opening sessions 
created on different platforms, Pro Tools 
systems, or versions of Pro Tools software, 
see Chapter 18, “File and Session Manage-
ment and Compatibility.”

You can also open a session from a DigiBase 
browser by double-clicking it.

Sound Designer II (SD II) files are not sup-
ported on Pro Tools systems higher than 
8.0.3. When opening a session created with 
an lower version of Pro Tools that uses the 
SD II file format, you will be prompted to 
convert the session and all SD II files to 
WAV.



Opening a Session that Contains 
Unavailable Files
DigiBase notifies you if files are located but re-
side on Transfer volumes (such as CD or DVD), 
or if any required files cannot be found. For 
more information, see “Locating Audio Files” on 
page 391.

Opening a Session from a 
Transfer Volume
When opening a session from a Transfer volume 
(such as a CD or DVD), DigiBase prompts you to 
save the session on a Performance volume, and 
copy and convert any referenced media files. For 
more information, see “Locating Audio Files” on 
page 391.

Opening a Session that Contains 
Unavailable Resources
Pro Tools prompts you when opening a session 
that contains unavailable voices, I/O paths, DSP 
resources, or plug-ins. This is common when 
transferring sessions between systems with dif-
ferent Pro Tools hardware.

The Unavailable Resources dialog provides an 
initial report of the missing session compo-
nents. To save a text (.txt) file containing a more 
detailed Notes report, along with the resulting 
action, click Yes. The Notes report is named 
with the session name, followed by Notes.txt. 
You can choose to save this file in your Session 
folder, or in another location.

The following occurs when opening a session 
with unavailable items:

With all Pro Tools Systems:

 Inserts assigned to unavailable plug-ins are 
made inactive.
 Inputs, outputs, and sends that are assigned to 
unavailable paths are made inactive.

With Pro Tools|HD Systems Only:

 Any tracks beyond the maximum number of 
available voices on the current system are made 
inactive. 

With Pro Tools Host-based Systems Only:

 Any tracks beyond the maximum number of 
available voices on the current system are set to 
voice off.

Opening a Session with Audio 
File Names that Contain Illegal 
Characters
Pro Tools does not support audio file names that 
contain the following ASCII characters:

/ (Forward Slash)
\ (Backslash)
: (Colon)
* (Asterisk)
? (Question mark)
“ (Quotation marks)
< (Less-than symbol)
> (Greater-than symbol)
| (vertical line or pipe)
Any “high order” ASCII character (created 
with a key combination)

When opening sessions that contain audio files 
with illegal characters, Pro Tools automatically 
creates a renamed copy of each file (replacing 
these characters with an underscore “_”). Re-
named files are copied to the Renamed Audio 
Files folder. The original files are left intact in 
the Audio Files folder.
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Before the session opens, you are prompted to 
save a detailed report of the renamed files and 
their original file names to a Notes text file. Fol-
low the on-screen instructions. By default, the 
Notes text file is saved to the Session folder.

Opening a Session that was 
Saved with +6 dB Fader Gain
All Pro Tools 7.x and higher sessions have a 
+12 dB fader gain level. However, when saving a 
Pro Tools 7.x or higher session to a lower ver-
sion of Pro Tools that supports +6 dB and 
+12 dB fader gain, the new session can be saved 
with either a +6 dB or a +12 dB maximum fader 
gain.

When saving a +12 dB session as a +6 dB ses-
sion, Pro Tools alerts you that any automation 
settings over +6 dB will be lowered to +6 dB. See 
“Saving a Copy of the Session” on page 170.

In Pro Tools 7.x or higher, when opening a ses-
sion that was saved with a +6 dB maximum gain 
level, the session will update to a +12 dB range.
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Opening Recent Sessions
The Open Recent submenu in the File menu lets 
you open any of the 10 most recently opened 
Pro Tools sessions.

To open a recent session:

 Choose File > Open Recent and choose the ses-
sion you want to open.

If a session is open when choosing a recent ses-
sion, you are prompted to save it before 
Pro Tools closes the session and opens the cho-
sen recent session.

To open the most recent session:

 Control+Shift+O (Windows) or Com-
mand+Shift+O (Mac).

To clear the recent sessions submenu:

 Choose File > Open Recent and choose Clear.



Opening a Session with 
Plug-Ins Deactivated
Pro Tools lets you open sessions with all of the 
session’s plug-ins set to inactive. Since sessions 
with a lot of plug-ins can take a long time to 
load, this lets you quickly open any session for 
immediate visual inspection and audio playback 
(without plug-ins). If it is the session that you 
want to work with, you can easily reopen the ses-
sion with plug-ins activated.

To open a Pro Tools session with all plug-ins set to 
inactive:

1  In Pro Tools, choose File > Open Session.

2  In the Open Session dialog, locate and select 
the session you want.

3  Shift-click Open.

To re-open the same session with all plug-ins set 
to active, do one of the following:

 Choose File > Revert To Saved.

– or –

 Choose File > Open Recent and select the most 
recent session in the submenu.

Press Control+Shift+O (Windows) or 
Command+Shift+O (Mac) to open the 
most recent session.

Instead of reverting to the saved version of 
the session to open the session with all plug-
ins active, you can simply make an individ-
ual plug-in active by Control-Start-clicking 
(Windows) or Command-Control-clicking 
(Mac) it. To make an entire row of plug-ins 
active, Control-Alt-Start-click (Windows) 
or Command-Option-Control-click (Mac) 
any plug-in in the row of inserts.
Saving a Session
You should save regularly while working on 
your session to ensure that your work is pre-
served on your hard drive.

Saving the Session File
The Save command saves the changes you have 
made to your session and writes them over the 
previously saved version of the session file. The 
Save command cannot be undone.

To save a session:

 Choose File > Save.

Reverting to a Previously Saved 
Session File
If you have made changes to a session since you 
last saved it, you can discard those changes and 
revert to its previously saved state.

To revert to the last saved version of a session:

 Choose File > Revert to Saved.

If you have enabled the Operation preference 
for Auto Backup, you can also open up a 
backup copy of your session. This feature lets 
you specify the total number of incremental 
backups that are kept and how often the ses-
sion is saved. See “Auto Backup Section” on 
page 125.

Reverting to a previously saved session file 
can also be used to open a session with all of 
its plug-ins active, after opening it with all of 
its plug-ins inactive. See “Opening a Session 
with Plug-Ins Deactivated” on page 169.
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Saving the Session File with a 
New Name
To save a copy of the current session with a new 
name or to a different hard drive location, use 
the Save As command. The Save As command 
closes the current session and lets you keep 
working on the renamed copy. This is useful if 
you are experimenting and want to save succes-
sive versions of the session.

By working this way, you can quickly retrace 
your steps if you want to go back to an earlier 
version of your session. The Save As command 
saves a new version of the session file only, and 
does not duplicate versions of the audio or fade 
files.

To save a session with a new name:

1  Choose File > Save As. 

2  Type a new name for your session.

3  Click Save.

The renamed session file is saved in the session 
folder along with the original session (unless 
you specify a different destination). Any new 
audio files that you record in your renamed ses-
sion will be placed into the same Audio Files 
folder that was created for your original session. 
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Saving a Copy of the Session
To save a copy of the current session with or 
without its audio files and fade files, use the 
Save Copy In command. In addition, you can 
specify the session file format, audio file format, 
bit depth, and sample rate for the session copy.

To save a session copy in a new location:

1  Choose File > Save Copy In.

2  In the Save Session Copy dialog, choose a des-
tination and type a name for the new session file.

3  Choose a session file format (Save As Type) for 
the copied session.

4  Set the Audio File Type for the copied session. 
If the audio files need to be compatible with ei-
ther Windows or Mac, select BWF (.WAV) or 
AIFF.

5  Set the session Sample Rate and Bit Depth for 
the copied session.

For information on sharing sessions between 
different platforms, Pro Tools systems, or 
Pro Tools software versions, see Chapter 18, 
“File and Session Management and Compat-
ibility.”

Save Session Copy dialog



6  If applicable, select a Fader Gain level for the 
copied session.

7  If applicable, select Enforce Mac/PC Compati-

bility to create session and audio files that can be 
used on both Windows and Mac Pro Tools sys-
tems (see “Saving Copies of Mac Sessions to be 
Compatible with Windows” on page 396).

8  Select the Items to Copy for the copied session.

9  Click Save. 

How the Save Copy In Command 
Works
Unlike the Save As command, Save Copy In does 
not close the original session, so subsequent ed-
its are made to the original session. Session cop-
ies can be used to archive important sessions, 
for versioning, or as a means to prepare sessions 
for transfer to another Pro Tools system.

Save Copy In can save only the audio being used 
in the session. Any audio that was recorded or 
imported and then later removed from the ses-
sion, but not deleted from disk, is not included 
in the new session copy.

Using the Save Copy In command is the only way 
to change the sample rate of a session. The sam-
ple rate of each of the session’s copied audio 
files is converted to the selected sample rate. 
When saving a session copy to a different sample 
rate, Pro Tools uses the selected Sample Rate 

Conversion Quality option in the Import section 
of the Processing Preferences page (Setup > Pref-

erences).

To include all audio being used in the ses-
sion, select the All Audio Files option.

To include all audio being used in the ses-
sion, select the All Audio Files option.
When you save a copy of the session to a lower 
bit depth, Dither (and Noise Shaping) are ap-
plied. See the following table:

The dither setting used for any conversion is the 
Dither plug-in with Noise Shaping enabled.

Save Copy In Options
When saving a copy of a session, the Save Copy 

In command provides options.

Session Format
When saving a copy of a session with the Save 

Copy In command, you can save the session copy 
in the following formats, depending on your 
platform:

Mac:

• Latest; supports Pro Tools 10.0 sessions 
(.ptx)

• Pro Tools 7.x -> 9.x Session (.ptf )

• Pro Tools 5.1 -> 6.9 Session 

• Pro Tools 5.0 Session 

• Pro Tools 4 24-Bit Session 

• Pro Tools 4 16-Bit Session 

• Pro Tools 3.2 Session 

Dither and Noise Shaping with Save Copy In

Session Bit Depth Dither
Noise 
Shaping

24-bit to 24-bit No No

16-bit to 24-bit No No

24-bit to 16-bit Yes Yes

16-bit to 16-bit No No

For more information about using Dither, 
see “Dither” on page 984.
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Windows:

• Latest; supports Pro Tools 10.0 and higher 
sessions (.ptx)

• Pro Tools 7.x -> 9.x Session (.ptf )

• Pro Tools 5.1 -> 6.9 Session 

• Pro Tools 5.0 Session 

Session Parameters
When saving a copy of a session with the Save 

Copy In command, the following Session Param-
eters are available:

Audio File Type

You can save the session to reference BWF 
(.WAV) or AIFF audio files.

Using Mixed File Types

A session can use mixed audio file types. If your 
original session has mixed file types, they are 
not converted to the selected file type unless you 
specify that they be converted by selecting the 
Convert to Specified Format option in the Items 
To Copy section (see “Items to Copy” on 
page 173). 

Bit Depth

You can save the session at a Bit Depth of 16 Bit, 
24 Bit, or 32 Bit Float.

When saving sessions to versions lower than 
Pro Tools 5.1, multichannel tracks (includ-
ing stereo) and multi-mono plug-ins are 
lost. In this case, separate the tracks and 
plug-ins to individual mono tracks before 
saving as a Pro Tools 5.0 session or lower.
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Pro Tools 10.0 sessions can use audio files with 
different bit depths. If your original session has 
mixed bit depths, they are not converted to the 
selected bit depth unless you specify that they be 
converted by selecting the Convert to Specified 

Format option in the Items To Copy section (see 
“Items to Copy” on page 173).

When saving to a Session Format lower than 
10.0, if your session is in a different bit depth, 
audio files are converted to the new session bit 
depth, and copied to the specified location. 
Also, 32 Bit Float is not available for session for-
mats lower than 10.0.

Sample Rate

You can save the session at sample rates of 
44.1 kHz or 48 kHz (on Mbox 3rd generation, 
Mbox 2, Mbox Mini, and Mbox 2 Mini) and at 
sample rates up to 96 kHz (on 003, 003 Rack, 003 
Rack+, Digi 002, Digi 002 Rack, Eleven Rack, 
Mbox Pro, Mbox 2 Pro, and Pro Tools|HD sys-
tems with a 96 I/O or 96i I/O) or up to 192 kHz 
(on Pro Tools|HD systems with an HD I/O, HD 
OMNI, HD MADI, 192 I/O, or 192 Digital I/O). If 
your session is at a different sample rate, audio 
files are converted to the new session sample 
rate, and copied to the specified location.

Fader Gain

When saving a Pro Tools 7.x or higher session to 
a lower version that supports +12 dB fader gain, 
you can save the new session with either a +6 dB 
or a +12 dB maximum fader gain. When saving a 
+12 dB session as a +6 dB session, any automa-
tion over +6 dB will be lowered to +6 dB.

For information on bouncing to disk and 
dither, see “Dithering” on page 1082.



Enforce Mac/PC Compatibility

When saving a Pro Tools 7.x or higher session to 
a lower version, enable the Enforce Mac/PC 

Compatibility option to force Windows or Mac 
versions of Pro Tools to create sessions and au-
dio files that are compatible on both platforms. 

Limit Character Set

When saving a copy of a session to the current 
session format, you can choose to limit the char-
acter set to a single language by selecting the 
Limit Character Set option.

When saving a copy of a session to a lower ses-
sion format, the Limit Character Set option is au-
tomatically selected. Select a language from the 
Limit Character Set pop-up menu.

To choose the language encoding when saving a 
copy of a session: 

1  Choose File > Save Copy In. 

2  Select the Limit Character Set option. 

3  Choose the language you want to use from the 
Limit Character Set pop-up menu. 

For more information, see “Saving Copies 
of Mac Sessions to be Compatible with 
Windows” on page 396.
Items to Copy
When saving a copy of a session with the Save 
Copy In command, you can select which items 
are copied, as follows:

Audio Files

When this option is selected, all audio files are 
copied to the new location.

This setting is automatically selected if you se-
lect a Session Format lower than 10.0.

Convert To Specified Format

When the Convert To Specified Format option is 
selected, all copied audio files are converted to 
the specified audio file format settings in the 
Session Parameters section. When this option is 
not selected, any copied audio files retain their 
original audio file format settings (including 
sample rate and bit depth), and are exactly cop-
ied, bit-by-bit.

This option is automatically selected if you do 
any of the following:

• Save to a session format lower than 10.0.

• Enable Enforce Mac/PC Compatibility.

Don’t Copy Elastic Audio Rendered Files

When this option is selected, Elastic Audio Ren-
dered files are not copied to the new session’s 
Rendered Files folder. 

When opening the new session, Pro Tools opens 
the session with all available media and any 
missing Rendered files are regenerated auto-
matically.

Note that copying formats bit-by-bit is much 
faster than converting files.
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Main Playlist Only

When this option is selected, only the main play-
lists are included with the session copy. Any al-
ternate playlists are not included with the ses-
sion copy.

When this option is not selected, all playlists are 
included with the session copy.

Selected Tracks Only

When this option is selected, only the selected 
tracks in the source session are saved with the 
session copy. This option is automatically en-
abled when choosing File > Export > Selected 

Tracks As New Session.

When this option is not selected, all tracks in the 
source session are saved with the session copy. 
This option is automatically disabled when 
choosing File > Save Session Copy.

Session Plug-In Settings Folder

When this option is selected, the session’s 
Plug-In Settings folder is copied to the new loca-
tion. The references to these plug-in settings in 
the session are redirected to the copied settings 
files.

Root Plug-In Settings Folder

When this option is selected, the contents of the 
root-level Plug-In Settings Folder are copied 
into a folder named Place in Root Settings 
Folder, indicating that these files will need to be 
moved to the root level plug-in settings folder 
on the destination system before you can use 
them. The references to these settings files in 
the session are not redirected to point to the 
copied files.
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Movie/Video Files

When this option is selected, session video files 
(Avid or QuickTime) are copied to the new loca-
tion, and session references are updated to point 
to the copied video files.

Preserve Folder Hierarchy

When this option is selected, the relative ar-
rangement of session audio files located across 
different drives or folders is maintained. The 
main folder for the session copy will include 
subfolders for each drive or folder in the origi-
nal session and the destination subfolders will 
use the same names as the source drives and 
folders.

When this option is not selected, the Save Copy 

In command copies all files of the same type, re-
gardless of their location, into a single destina-
tion folder. 

Session Templates
In addition to the Session Templates provided in 
the Pro Tools Session Quick Start dialog, 
Pro Tools lets you create and share your own 
custom Session Templates. Pro Tools Session 
Template files use the suffix “.ptxt” to differen-
tiate them from regular Pro Tools session files 
(“.ptx”).



Creating and Saving Custom 
Templates

To create a custom Pro Tools Session Template:

1  Create a new Pro Tools session and configure it 
for the session template you want. 

2  Choose File > Save As Template.

3  Configure the Save Session Template dialog 
(see “Save Session Template Dialog” on 
page 175).

4  Select the Include Media option if there is any 
audio, MIDI, or video media in the session that 
you want included in the template. 

5  Click OK.

For example, if you are a songwriter you 
might simply want a session consisting of a 
stereo Instrument track with an instrument 
plug-in (such as Xpand! 2 with a piano pre-
set), a mono audio track (for tracking vo-
cals), a stereo Auxiliary Input track (for an 
effects bus), and a stereo Master Fader 
track. You can then use this template every 
time you sit down to work on a new song.

Save Session Template dialog

When the Include Media option is enabled, 
all media in the session is included in the 
template. If you want to include media in 
your session template, be sure that your ses-
sion only contains the media you want.
If you selected the Install Template In System op-
tion, your session template will be available in 
the Pro Tools Session Quick Start dialog. 

If you selected the Select Location For Template 
option, you are prompted by the Save As Tem-
plate dialog to save the file to another location 
on your system.

Save Session Template Dialog
The Save Template dialog provides the following 
options:

Install Template In System

Select this option to save the template file in the 
system folder referenced by the Pro Tools Ses-
sion Quick Start dialog (the Session Templates 
in the Pro Tools application folder).

Category

The Category pop-up menu is only available if 
the Install Template In System option is enabled. 
The Category pop-up menu lets you select the 
subdirectory in which to save the template file. 
It also provides options for adding a category 
and revealing the Session Templates folder in 
Windows Explorer or the Mac Finder.

Add Category Select this option from the Cate-

gory pop-up menu to create a new subdirectory 
in the Session Templates folder.

Name

The Name setting is only available if the Install 

Template In System option is enabled. This lets 
you type a new name for the template file. From 
the Name pop-up menu (to the right of the Name 
field), you can select from a list of all of the tem-

When you are ready to use a template as the 
basis for a new session, see “Creating a New 
Session from a Template” on page 162.
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plates available in the currently selected Cate-
gory. Selecting one places that name in the 
Name field, letting you overwrite, or create a in-
cremental version of, an existing template.

Select Location For Template

Select this option to save the template file to any 
directory location on your system. Note that the 
saved session template will not appear in the 
Pro Tools Session Quick Start dialog unless it is 
in a subdirectory (Category) in the Session Tem-
plates folder in the Pro Tools application folder.

Include Media

Select this option to include any audio, MIDI, or 
video media in the session with the template.

Creating New Sessions from 
Templates
You can create new session from templates by 
opening a template. You can open any Pro Tools 
Session Template file (.ptt) to start a new ses-
sion based on that template.

For information on creating new sessions 
from templates using the Quick Start dialog, 
see “Creating a New Session from a Tem-
plate” on page 159.
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To open a Pro Tools Session Template and save it 
as a new session:

1  Choose File > New. 

2  In the New Session From dialog, select the Cre-

ate Session from Template option.

3  Select the Audio File Type, Sample Rate, and Bit 

Depth for the new session that will be created 
from the template. 

4  If desired, enable the Interleaved option.

5  Click OK.

6  In the Save New Session As dialog, navigate to 
the location where you want to save the new ses-
sion and click Save.

New Session dialog



Closing a Session
Pro Tools only lets you work on just one session 
at a time. The Close Session command closes 
your current Pro Tools session but leaves the 
Pro Tools application running. Pro Tools 
prompts you to save a session when closing it, 
but it is recommended that you save your work 
using the Save or Save As command before clos-
ing a session.

To close a session:

 Choose File > Close Session.

Exiting or Quitting Pro Tools
When you exit (Windows) or quit (Mac) the 
Pro Tools application, Pro Tools prompts you to 
save any open session before exiting or closing 
the application.

To exit Pro Tools in Windows:

 Choose File > Exit.

To quit Pro Tools on the Mac:

 Choose Pro Tools > Quit Pro Tools.
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Chapter 12: Pro Tools Main Windows
Pro Tools provides two complementary ways of 
viewing tracks in a session: 

Mix Window Shows tracks as channel strips, like 
a mixing board (see “Mix Window” on 
page 180).
Edit Window Shows tracks and track material 
against the Timeline (see “” on page 181). 

To toggle between the Mix and Edit windows, 
press Control+Equals (=) (Windows), or 
press Command+Equals (=) (Mac).
Pro Tools windows

Edit window

Mix window

Transport window

Plug-In window

DigiBase browser
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Pro Tools provides several other types of 
windows:

Transport Window Lets you control the trans-
port and transport-related functions (see 
“Transport Window” on page 187).

Plug-In Windows Let you control plug-in param-
eters, such as Frequency and Q for an EQ (see 
“The Plug-In Window” on page 998). 

MIDI Editor Windows Lets you edit MIDI data 
(see Chapter 33, “MIDI Editors”).

Score Editor Window lets you edit MIDI data as 
music notation (see Chapter 34, “Score Editor”).

DigiBase Browsers Let you manage, audition, 
and import media for Pro Tools sessions (see 
“DigiBase Browsers” on page 192).

In-App Web Browsers Let you access the Avid 
Marketplace and Pro Tools Online (see “In-Ap-
plication Web Browser” on page 195).
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Mix Window
In the Mix window, tracks appear as channel 
strips just like a mixing console, with controls 
for:

• Inserts

• Sends

• Input and output assignments

• Volume

• Panning

• Record enable

• Track Input monitoring

• Automation mode

• Solo and Mute

• Instrument controls

• HEAT controls (Pro Tools HD only)

• Mic preamps

To display the Mix window:

 Choose Window > Mix.

To display all Mix window view options:

 Select View > Mix Window > All.

For information on selecting individual view 
options, see “Views in the Mix and Edit Win-
dows” on page 950.



Pro Tools Mix window

Inserts 
(A–E) View 
(page 952)

Track List 
(page 232)

Volume
fader

(page 218)

Pan knob
(page 218)

Level meter 
(page 219)

Stereo
Audio Track 
(page 210)

Auxiliary
Input 

(page 211)

Delay
Compensation

View (page 953)

Master
Fader 

(page 212)

AutoMatch 
indicator 

(page 1033)

Track Path selectors 
(page 236 and 

page 245)

Mono
Audio Track 
(page 210)

MIDI
Track 

(page 213)

Sends (A–E) 
View 

(page 952)

Automation 
Mode selector
(page 1024)

Track
Comments

View 
(page 951)

Voice selector 
(page 242)

Track Name 
(page 222)

Mix Group List 
(page 255)

Group ID
indicator 

(page 258)

Instrument
Track

(page 213)

Instrument 
View

(page 951)

Mix Window
View selector

(page 950)

Show/Hide 
Track List/Group List 

View 
(page 232)

Channel strips 
(page 211)

Solo/Mute 
(page 247)

Input Monitoring / 
Record Enable
(page 456 and 

page 450)
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Edit Window
The Edit window provides a Timeline display of audio, video, MIDI notes, as well as other MIDI data 
and mixer automation for recording, editing, and arranging on tracks. As in the Mix window, each 
track has controls for record enable, solo, mute, and automation mode.
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Pro Tools Edit window
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To display the Edit window:

 Choose Window > Edit.

To display all Edit window view options:

 Select View > Edit Window > All. 

Edit window view options can be selected indi-
vidually. See “Views in the Mix and Edit Win-
dows” on page 950.

Edit Window Toolbar
At the top of the Edit window is the Edit Win-
dow Toolbar and menu. This Toolbar provides 
access to the editing modes, tools, options, indi-
cators, and displays for Pro Tools. You can cus-
tomize the Toolbar in the Edit, MIDI Editor, or 
Score Editor windows by re-arranging, showing, 
and hiding the available controls and displays.

Edit Toolbar Controls and Displays

The following controls and displays in the Edit 
Window Toolbar are always shown.

Edit Modes

The Edit mode affects the movement and place-
ment of audio and MIDI clips (and MIDI notes), 
how commands like Copy and Paste function, 
and also how the various Edit tools (Trim, Selec-
tor, Grabber, and Pencil tools) work. For more 
information, see “Edit Modes” on page 539.

Edit mode buttons
Edit Tools

Edit tools are used for editing audio, MIDI, and 
automation data in Pro Tools. For more infor-
mation, see “Edit Tools” on page 543.

Counters and Edit Selection Indicators

The Counters and Edit selection indicators pro-
vide information where selections are in the 
Timeline. 

Main Counter Displays the current Edit inser-
tion location in the Main Timebase ruler.

Sub Counter Displays the current Edit insertion 
location in the Sub Timebase ruler.

Cursor Location Displays the current cursor lo-
cation in the Main Timebase ruler.

Cursor Value Displays the value of the current 
cursor value in peak amplitude (audio), pitch 
(MIDI), or according to the current automation 
or controller data type. 

Edit tools

Edit window indicators

Automatic Delay Compensation

Timeline Data Online Status

Session Data Online Status

Cursor Location

Main and Sub Counters

Edit Selection

Cursor Value

MIDI Selection

Track Solo

Track Mute
indicator

indicator
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Edit Selection Indicators Display the Start, End, 
and Length of the current Edit selection.

MIDI Selection Indicators and Controls Display 
the current MIDI Edit selection (MIDI note 
number, and Note On and Note Off velocities) 
and provide controls for MIDI editing.

Timeline Data Online Status Indicator Is green 
when all files in use in track playlists are avail-
able for playback. If files are offline, being pro-
cessed, or otherwise unavailable for playback, 
this indicator is red.

Session Data Online Status Indicator Is green 
when all audio and fade files referenced by the 
session are available for playback. If files are of-
fline, being processed, or otherwise unavailable 
for playback, this indicator is red.

Delay Compensation Status Indicator Is dis-
played when Delay Compensation is enabled 
(Options > Delay Compensation). When Delay 

Compensation is disabled, this indicator is not 
displayed.

Track Solo Indicator Lights yellow when any 
track in the session is soloed. When no tracks in 
the session are soloed, the Track Solo indicator 
appears dim green. For systems using Satellite 
Link, the Track Solo indicator lights dim yellow 
when a track is soloed on any satellite system.

If the Track Solo indicator is lit, you can click it 
to clear all solo’d tracks in the session.

Track Mute Indicator Lights orange when any 
track in the session is muted. When no tracks in 
the session are muted, the Track Mute indicator 
appears dim green. (Note that because Mute is 
an automatable mixing function, the Track Mute 
indicator does not function to clear all mutes 
when clicked.)
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Grid and Nudge

The Grid and Nudge selectors let you set the 
Grid and Nudge values for editing in Pro Tools. 
For information on the Grid Value selector, see 
“Configuring the Grid” on page 542. For infor-
mation on the Nudge Value selector, see “Defin-
ing the Nudge Value” on page 599.

Showing and Hiding Additional 
Controls in the Edit Window

To show or hide controls in the Edit window 
toolbar:

1  Do one of the following:

• Click the Edit Window Toolbar menu (in 
the upper-right corner of the window).

– or –

• Right-click in the Toolbar.

2  From the menu, select or deselect any of the 
following depending on which window you are 
configuring:

Grid and Nudge value selectors

Edit Window Toolbar menu

Grid Value selector

Nudge Value selector



Zoom Controls When selected, the Zoom con-
trols are displayed in the Edit window toolbar.

Transport When selected, the Transport controls 
are displayed in the Edit window toolbar.

MIDI Controls When selected, the MIDI controls 
are displayed in the window toolbar.

Synchronization When selected, the Synchroni-
zation controls and indicators are displayed in 
the Edit window toolbar.

Minimal When selected, the Zoom, Transport, 
MIDI, and Synchronization controls are not dis-
played in the Edit window toolbar.

All When selected, the Zoom, Transport, MIDI, 
and Synchronization controls are all displayed 
in the Edit window toolbar.
Expanded Transport When selected, the Ex-
panded Transport controls are displayed in the 
Edit window toolbar if Transport is also se-
lected.

Track List When selected, the Track List is 
shown on the left of the Edit window.

Clip List When selected, the Clip List is shown 
on the right of the Edit window.

Universe When selected, the Universe view is 
shown near the top of the Edit window.

MIDI Editor When selected, the MIDI Editor view 
is shown at the bottom of the Edit window.

Rearranging Controls and 
Displays

To rearrange controls and displays in the Edit, 
MIDI Editor, or Score Editor window toolbar:

 Control-click (Windows) or Command-click 
(Mac) the control or display you want to move 
and drag it to a new location in the toolbar.

For example, if you want the Counters and Edit 
Selection indicators to the right of the Transport 
controls in the toolbar, Control-click (Windows) 
or Command-click (Mac) and drag them to the 
right of the Transport controls.

Moving the Counters and Edit Selection indicators
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Edit Window Zoom Buttons
The Edit window also provides Zoom buttons in 
the lower right and upper right corners of the 
tracks pane.

Vertical and Horizontal Zoom In and Out 
Buttons

In addition to the Zoom controls in the Toolbar, 
Pro Tools provides horizontal and vertical zoom 
buttons in the lower-right corner of the Edit 
window. 

Vertical Zoom Buttons Zoom the track heights 
proportionally in the Edit window.

Horizontal Zoom Buttons Zoom the Timeline 
just like the Horizontal Zoom controls in the 
Edit window toolbar.

Horizontal Zoom button, Edit window

Vertical Zoom button, Edit window
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Audio and MIDI Zoom In and Out Buttons

Pro Tools also provides Audio and MIDI Zoom 
In and Out buttons in the upper-right corner of 
the Edit window. These controls function ex-
actly the same as the Audio and MIDI Zoom con-
trols in the Toolbar, and let you zoom in and out 
vertically on audio waveforms and MIDI notes 
respectively.

In the Edit window, MIDI Vertical Zoom 
only affects tracks not in Clips view.

Audio Zoom button, Edit window

MIDI Zoom button, Edit window



Edit Window Default Length
Pro Tools lets you set a default length for the 
Edit window in hours, minutes, seconds, and 
frames. This is useful if you want to assemble a 
session of a particular length or leave extra 
room to expand the Edit window’s work area in 
your session. The maximum length is 12 hours 
and 25 minutes at 48 kHz, and proportionally 
less at higher sampling rates. For best scrollbar 
sensitivity, set the length to slightly longer (a 
minute or more) than the total session or song 
length.

To set the default length for the Edit window:

1  Choose Setup > Preferences.

2  On the Display page, enter the value in hours, 
minutes, seconds, and frames for the Edit Win-

dow Default Length setting.

3  Click OK.

Transport Window
The Transport window can be set to show basic 
transport controls, counters, MIDI controls, 
and expanded features. The counters in the 
Transport window mirror the controls and 
counters at the top of the Edit window.

To display the Transport window:

 Choose Window > Transport.
Basic Transport Controls and 
Counters

Online Puts Pro Tools online so that playback 
and recording is triggered by an external time-
code source.

Return to Zero Locates to the beginning of the 
session.

Rewind Rewinds from the current play location. 
You can also click repeatedly to rewind incre-
mentally, by an amount based on the Main Time 
Scale, as follows:

Transport window showing basic transport controls 
and counters (Main and Sub Counters and MIDI not 
shown)

Press Enter (Windows) or Return (Mac) to 
Return to Zero.

You can Right-click the Return to Zero but-
ton to access the Write to Start and Write to 
All automation commands.

With the Numeric Keypad mode set to 
Transport, you can rewind by pressing 1.

Start, End, and Length
Selection indicators

Online

Rewind

Fast Forward Stop
Play

RecordReturn to Zero

Go to End

Pre-
Roll

Post-
Roll

Track Record Enable indicator

TrackInput Monitor 
indicator

Transport Window menu
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Fast Forward Fast forwards from the Timeline 
insertion point. You can also click repeatedly to 
fast forward incrementally (by an amount based 
on the Main Time Scale).

Go to End Locates to the end of the session.

Stop Stops playback or recording.

Play Starts playback or (if the Record button was 
clicked first) recording from the Timeline inser-
tion point or the Play Start Marker location if 
Dynamic Transport mode is enabled.

Rewind and Fast Forward Increments

Main Time Scale Format
Increment 
Amount

Min:Sec 1 second

Timecode 1 frame

Bars|Beats 1 bar

Feet+Frames 1 foot

Sample 1 second

With Numeric Keypad mode set to Trans-
port, you can fast forward by pressing 2.

You can press Control+Enter (Windows) or 
Option+Return (Mac) on the alphanumeric 
keyboard to locate to the end of the session.

You can Right-click the Go to End button to 
access automation commands Write to End 
and Write to All.

You can also stop the transport by pressing 
the Spacebar, or with the Numeric Keypad 
mode set to Transport, pressing 0.

You can also begin playback by pressing the 
Spacebar, or with the Numeric Keypad 
mode set to Transport, pressing 0.
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Right-clicking the Play button lets you select the 
playback mode from a pop-up menu:

• Half-Speed

• Prime for Playback

• Loop

• Dynamic Transport

With the Transport stopped, Start-click Play 
(Windows) or Control-click Play (Mac) to toggle 
Loop Playback mode. When enabled, a loop 
symbol appears in the Play button and Pro Tools 
plays continuously from the beginning of the se-
lection to the end.

Record Arms Pro Tools for recording (the but-
ton flashes). Clicking Play then starts recording 
on record-enabled tracks only.

Right-clicking the Record button lets you select 
the record mode from a pop-up menu:

• Normal

• Loop

• Destructive

• QuickPunch

• TrackPunch (Pro Tools HD only)

• Destructive Punch (Pro Tools HD only)

To initiate playback at half-speed, you can 
also press Shift+Spacebar (Windows or 
Mac) or Shift-click (Mac) the Play button.

For more information on loop playback and 
Dynamic Transport mode, see “Loop Play-
back Mode” on page 428.

You can also begin recording immediately 
by pressing F12, pressing Control+Spacebar 
(Windows) or Command+Spacebar (Mac), 
or with the Numeric Keypad mode set to 
Transport, pressing 3.



You can also cycle through the Pro Tools record 
modes with the Transport stopped, by Start-
clicking (Windows) or Control-clicking (Mac) 
the Record button.

The Record button changes to indicate the cur-
rently selected mode: blank for Nondestructive, 
“D” for Destructive, a loop symbol for Loop Re-
cord, “P” for QuickPunch, “T” for TrackPunch, 
and “DP” for DestructivePunch.

Track Record Enable Indicator When lit (red), 
indicates that at least one audio track is cur-
rently record-enabled. When off (gray), no 
tracks are currently record-enabled. 

TrackInput Monitor Indicator When lit (green), 
indicates that at least one audio track is cur-
rently set to Input Only monitoring (regardless 
of record enable status). When off (gray), all 
tracks are in Auto Input monitoring.

Transport Window Menu Lets you select what 
options to show in the Transport window: Coun-

ters, MIDI Controls, Synchronization, Minimal, All, 
and Expanded Transport.

Pre-Roll During playback or record, specifies the 
amount of audio that plays before the Play 
(Timeline) Cursor or Play Start Marker location, 
or beginning of the Timeline selection. Pre-roll 
is particularly useful with punch recording since 
it gives you time to “catch the beat” before 
reaching the punch-in point. To set the pre-roll 
amount, type a new value in this field, or drag 
the Pre-Roll flag in the Main Timebase ruler.

Post-Roll During playback or record, specifies 
the amount that plays after the end of a Timeline 
selection. Post-roll is useful in punch recording 
since playback continues after the punch-out 
point so you can check for a smooth transition 

To initiate recording at half-speed, you can 
press Control+Shift+Spacebar (Windows) 
or Command+Shift+Spacebar (Mac).
to previously recorded material. To set the post-
roll amount, type a new value in this field, or 
drag the Post-Roll flag in the Main Timebase 
ruler.

Start Specifies the beginning of the play or re-
cord range. You can set the start point by enter-
ing a location in this field, or by dragging the 
corresponding Timeline Selection or Play Start 
Marker in the Main Timebase ruler. For more 
information, see “Timeline Selection Markers” 
on page 465.

End Specifies the end of the play or record 
range. You can set the end point by entering a 
location in this field, or by dragging the corre-
sponding Timeline Selection Marker in the Main 
Timebase ruler. For more information, see 
“Timeline Selection Markers” on page 465.

Length Specifies the length for the play or re-
cord range. You can set the length by entering a 
location in this field, or by selecting a range in 
any Timebase ruler.

MIDI Controls

When the Timeline and Edit selections are 
linked, you can make an Edit selection in a 
track’s playlist to set the play and record 
range. See “Linking or Unlinking Timeline 
and Edit Selections” on page 569.

Transport window, MIDI controls

Tempo Ruler 
Enable

Wait for Note

Count Off Meter

Metronome Click

MIDI Merge

Tempo

Tempo Resolution (Beat Value) pop-up menu
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To view the MIDI controls in the Transport, do one 
of the following:

 Select View > Transport > MIDI Controls.

– or –

 Control-click (Windows) or Command-click 
(Mac) the Expand/Collapse “+” button in the 
Transport window to display the MIDI controls.

Wait for Note When selected, recording does not 
begin until a MIDI event is received. This en-
sures that you begin recording when you’re 
ready to play, and that the first note, or other 
MIDI data, is recorded precisely at the begin-
ning of the record range.

Metronome Click When selected, Pro Tools gen-
erates a metronome pulse that can be set to trig-
ger built-in sounds or MIDI instruments during 
playback and recording.

Expand/Collapse button, Transport Window with MIDI 
controls

You can press F11 to turn on Wait for Note, 
unless the MIDI preference for “Disable F11 
for Wait for Note” is enabled.

On Mac, the Desktop Keyboard Shortcut 
uses the same key command that Pro Tools 
uses for Wait For Note (F11). To use F11 for 
Wait For Note in Pro Tools, be sure to dis-
able the Desktop Keyboard Shortcut in the 
Apple System Preferences.
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The Pro Tools metronome is configured in the 
Click/Countoff Options dialog. Double-click the 
Metronome Click button to open the 
Click/Countoff Options dialog.

Count Off When selected, Pro Tools counts off a 
specified number of measures (indicated in the 
button) before playback or recording begins.

Double-click the Count Off button, to open the 
Click/Count Off Options dialog.

MIDI Merge When selected (Merge mode), 
recorded MIDI data is merged with existing 
track material. When deselected (Replace 
mode), recorded MIDI data replaces existing 
track material.

Tempo Ruler Enable (Conductor) When selected, 
Pro Tools uses the tempo map defined in the 
Tempo ruler. When deselected, Pro Tools 
switches to Manual Tempo mode and ignores 
the Tempo ruler.

In Manual Tempo mode, you can enter a BPM 
value in the tempo field, or tap in the tempo with 
the T key on your alphanumeric keyboard.

Current Meter Displays the session’s current me-
ter based on the play location. Double-click the 
Current Meter indicator to open the Change Me-
ter window.

With the Numeric Keypad mode set to 
Transport, press 7 to enable the Metronome 
Click.

With the Numeric Keypad mode set to 
Transport, press 8 to enable the Count Off.

With the Numeric Keypad mode set to 
Transport, press 9 to enable MIDI Merge.



Current Tempo Displays the session’s current 
tempo based on the play location. In Manual 
Tempo mode, you can enter a BPM value into 
this field, or manually tap in a tempo with a 
computer keyboard or an external MIDI key-
board.

MIDI Editor Windows
MIDI Editor windows let you view and edit 
MIDI notes and controller data. You can open 
multiple MIDI Editor windows to work on dif-
ferent parts of your MIDI arrangements sepa-
rately. MIDI Editor windows show Instrument 
and MIDI track data superimposed in Notes 
view, or on separate tracks in Notation view, and 
lets you view and edit MIDI controller data 
(such as velocity, pitch bend, and mod wheel) in 
controller lanes under the Notes pane.

For more information, see Chapter 33, “MIDI 
Editors.”
Displaying the MIDI Editor in the 
Edit Window
You can choose to show (or hide) a MIDI Editor 
pane at the bottom of the Edit window (below 
the Tracks pane). 

To show (or hide) the MIDI Editor view in the Edit 
window, do one of the following:

 Select (or deselect) View > Other Displays > 

MIDI Editor.

 Click the MIDI Editor Show/Hide icon in the 
lower left corner of the Tracks pane in the Edit 
window.

 Double-click the divider below the Tracks 
pane in the Edit window.

 From the Edit Window menu, select (or dese-
lect) MIDI Editor.

Score Editor Window
The Score Editor window lets you view and edit 
Instrument and MIDI tracks as music notation. 
It automatically transcribes MIDI performances 
in real-time. You can print a score of your ses-
sion or just parts from individual tracks.

For more information, see Chapter 34, 
“Score Editor.”
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Eleven Rack Control Window
(Eleven Rack Only)

The Eleven Rack Control window is a special 
window in Pro Tools that lets you control 
Eleven Rack entirely from your computer. It can 
be accessed when using Eleven Rack as an inter-
face with Pro Tools, as well as when connected 
to another Pro Tools system as a hardware in-
sert for control over USB. 

The Eleven Rack Control window is only avail-
able when an Eleven Rack is connected to your 
Pro Tools system.

Eleven Rack Control window

For more information, see the Eleven Rack 
User Guide.
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DigiBase Browsers
DigiBase databases are accessed through Di-
giBase browsers. Browsers provide an intuitive 
user interface to DigiBase databases with many 
convenient features for various file management 
tasks (such as search and sort functions).

Browsers in Pro Tools are analogous to windows 
in your computer’s operating system (such as 
Windows Explorer or the Mac Finder), but are 
specially designed for working in Pro Tools. 
Multiple browsers can be displayed simultane-
ously, and arranged independently with custom 
display settings for each.

Browsers let you search and sort audio files, 
video files, and sessions. These files are dis-
played in browsers and can be dragged directly 
into the current Pro Tools session.

When offline items are needed, Pro Tools lets 
you find the correct matching files, then relink 
to online media. 

To open the Workspace browser, press Alt+; 
(Windows) or Option+; (Mac). 

To bring all DigiBase browsers to the front, 
press Alt+J (Windows) or Option+J (Mac). 

To send all DigiBase browsers to the back, 
press Alt+Shift+J (Windows) or 
Option+Shift+J (Mac)



The main elements of a DigiBase browser (see 
the figure below) include the following: 

Title Bar Shows the browser type (Workspace, 
Volume, Project, or Catalog), and the name of 
its associated volume, session or catalog. 

Toolbar Provides the Browser menu, Search 
icon, View Presets (numbered 1–5), and 
browser navigation tools. 

Column Headers Display the type of metadata 
displayed in the Items List. Column Headers can 
be:

• Resized by dragging the column border, or 
rearranged by dragging the Column head-
ers.

• Dragged to either of two available panes, 
the Fixed or Scrolling panes.
Items List Displays the contents of a volume, 
folder, session, or Catalog database. Each col-
umn in the items list displays metadata (such as 
file name and format) for volumes, folders, and 
files in the Items List. 

There are three types of Pro Tools browsers 
available on all supported systems:

• The Workspace browser

• Volume browsers

• The Project browser

• Catalogs
Main elements of a DigiBase browser (Volume browser shown).

Toolbar

Items
List

Fixed pane Scrolling pane

Pane split

Show/Hide

Column
headers

TItle bar
C
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Workspace Browser
The Workspace browser provides access to all 
your mounted volumes, as well as the folders 
and files they contain. 

Using the Workspace browser, you can:

• Access all mounted volumes.

• Access all Catalogs.

• Search across multiple volumes and Cata-
logs simultaneously.

• Designate volumes for Record and Play-
back, Playback Only, or Transfer.

• Unmount volumes.

• View, manage, audition, and import indi-
vidual items in any catalog or mounted vol-
ume.

• Update databases for entire volumes.

Volume Browsers
Volume browsers provide file management for 
local and network volumes. Volumes are format-
ted partitions on a physical drive (hard drive). 
Open a Volume browser by double-clicking a 
volume in the Workspace browser. Any changes 
made in Volume browsers (such as copying, de-
leting, or moving files and folders) is mirrored 
on the volumes themselves. Volumes include 
mounted hard drives, network storage, and 
CD/DVD-ROMs.

Using Volume browsers you can:

• View, manage, audition, and import indi-
vidual items on the volume.

• Update a database for contents of the 
volume.

For more information about the Workspace 
browser, see “Workspace Browser” on 
page 318.
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Project Browser
The Project browser provides powerful search 
and management tools for the files referenced in 
your current session, regardless of where they 
are stored. Using the Project browser, you can:

• Show all the media files associated with the 
current session, including any missing 
files.

• View, manage, audition, and spot individ-
ual items.

Catalogs 
Catalogs provide the highest level of Pro Tools 
file management. Catalogs make it easy to orga-
nize files from multiple sources into libraries of 
favorite files. Catalogs can be sorted and 
searched, even when the files they reference are 
offline. Catalogs can also be shared. 

Using Catalogs, you can:

• Collect and organize files from any combi-
nation of volumes.

• Create catalogs of complete volumes to 
view and search even if a volume is offline.

• View, manage, audition, and import indi-
vidual items in the catalog.

• Update a database for contents of catalog.

For detailed information about the Project 
browser, see “Project Browser” on page 321.

For detailed information about Catalogs, 
see “Catalogs” on page 323.



Task Window
The Task window is a utility for viewing and 
managing all of the background tasks that you 
initiate with Pro Tools. Use the Task window to 
monitor, pause, or cancel background tasks such 
as file copies, searches, indexing, and fade cre-
ation.

Relink Window
The Relink window provides tools and features 
for relinking sessions and catalogs to media 
files. Use Relink tools to search and reacquire 
missing files for use in the current session. 

In-Application Web Browser
Pro Tools provides easy access to the online 
Avid Store, as well as web-based Pro Tools Help, 
the Knowledge Base, and other online resources 
using two new in-application Web browsers. 

Avid Marketplace Provides a secure web connec-
tion to Avid’s online commerce web pages for 
Pro Tools.

Pro Tools Online Provides easy access to web-
based Pro Tools Help, the Knowledge Base, and 
Avid Audio community forums.

For detailed information about the Task 
window, see “Task Window” on page 327.

For detailed information about the Relink 
window, see “Relink Window” on page 314.
To launch the Pro Tools in-application Web 
browser for online commerce:

1  Ensure that you have an internet connection.

2  Choose one of the following from the Market-

place menu:
• Your Account

• Plug-ins 
• Support and Training

• Upgrades 

To launch the Pro Tools in-application Web 
browser for online resources:

1  Ensure that you have an internet connection.

2  Choose one of the following from the Help 
menu:

• Pro Tools Help 

• Pro Tools Knowledge Base 

• Avid Audio Forums 

Pro Tools In-Application Web 
Browser Navigation Controls
The Pro Tools in-application Web browser pro-
vides a few simple navigation controls in the 
Web Browser Tool Bar.

Pro Tools Web browser showing Your Account Log In 
page

Go Backward
Go Forward

Go Home
Refresh

Locations
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Go Backward Clicking the Go Backward button 
navigates back to the previously viewed page.

Go Forward Clicking the Go Forward button 
navigates forward to the next page.

Go Home Clicking the Home button navigates to 
the starting page for the currently selected Loca-
tion.

Refresh Clicking the Refresh button reloads the 
currently viewed page.

Locations Clicking a location button navigates 
to the corresponding starting page on the Avid 
website. The Avid Marketplace and Pro Tools 
Online browsers provide different Location op-
tions.

Launch in External Web Browser

To browse the internet beyond what is available 
though the Pro Tools in-application Web 
browser, you can launch the currently viewed 
page in the default Web browser for your oper-
ating system.

To launch the currently viewed page in the default 
web browser for your operating system:

 Click the Launch in External Web Browser 
icon in either the Avid Marketplace window or 
the Pro Tools Online window.

Launch in External Web Browser icon
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Avid Marketplace
The Marketplace menu in Pro Tools lets you ac-
cess your Avid Account, the Avid online store 
(to shop for plug-ins, upgrades, or Avid sup-
port). 

To log in to your online Avid account:

 Choose Marketplace > Your Account.

To access the Avid online store for plug-ins:

 Choose Marketplace > Plug-ins.

To access the Avid online store for support and 
training, do one of the following:

 Choose Marketplace > Support and Training.

– or –

 Choose Help > Purchase Avid Support and 

Training.

To access the Avid online store for software 
upgrades:

 Choose Marketplace > Upgrades.

Your Account Log In page

You can also access the Avid online store 
from the AudioSuite menu and from track 
Insert selectors for plug-ins by choosing the 
Avid Marketplace option.



Pro Tools Online
In addition to the local resources that are in-
stalled with Pro Tools, the Help menu provides 
access to the Pro Tools Online browser.

To access the Pro Tool online resources from the 
Help menu:

 Click Help and choose one of the following:

• Pro Tools Help 

• Pro Tools Knowledge Base 

• Avid Audio Forums 

Pro Tools Help

The Pro Tools Help command provides access to 
web-based Pro Tools Help within the Pro Tools 
web browser. You will always have access to the 
latest Pro Tools Help files as they become avail-
able (independently of major Pro Tools re-
leases). You will also have access to localized 
Pro Tools Help files as translations become 
available. Note that web-based Pro Tools Help 
defaults to the English version if your localized 
language is not currently available. 

Pro Tools web browser showing the online Avid 
Knowledge Base
If you are not connected to the Internet, 
Pro Tools will open the local English Help files 
that are installed with Pro Tools.

Pro Tools Knowledge Base

The Pro Tools Knowledge Base command pro-
vides access to the online Avid Knowledge Base 
using the new Pro Tools in-application web 
browser. The Avid Knowledge Base provides ex-
tensive information for you to solve any prob-
lems you may encounter with Pro Tools (includ-
ing compatibility information and software 
updates).

Avid Audio Forums

The Avid Audio Forums command provides ac-
cess to the online Avid Audio Forums using the 
new Pro Tools in-application web browser. The 
Avid Audio Forum provide a broad-based user 
community where you can interact with other 
Pro Tools users.

You can also access Pro Tools Help online 
using Safari or Explorer. This can be use-
ful if Pro Tools is not running, or if you 
want to change the version or language of 
Help you are using. For more information 
visit the Avid website 
(http://apps.avid.com/ProToolsHelp).
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Managing Windows

Window Configurations
Pro Tools provides a powerful means of manag-
ing the configuration of windows in your ses-
sion, as well as the internal configurations of the 
Edit, Mix, MIDI Editor, Score Editor, and Trans-
port windows. Use the Window Configuration 
List to create (or delete) and manage stored 
Window Configurations. Pro Tools lets you 
store up to 99 Window Configurations. Window 
Configurations are saved with the session.

Creating New Window 
Configurations

To create a new Window Configuration:

1  Open the windows you want to include in the 
Window Configuration and position them where 
you want on the screen.

Create a session template with your favorite 
Window Configurations. You can then use 
the template when you start a new session, 
or you can use Import Session Data to 
import Window Configurations into your 
current session.
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2  Do one of the following:

• Choose Window > Configurations > New 

Configuration. 

– or –

• If the Window Configuration List is open, 
choose New Configuration from the Window 

Configuration List pop-up menu.

3  In the New Window Configuration dialog, do 
one of the following:

• Select Window Layout and whether or not to 
include the Edit, Mix, Targeted MIDI Edi-
tor, Score Editor, and Transport window 
display settings.

– or –

• Select a Window Display Settings option 
from the pop-up menu (Edit Window, Mix 

Window, MIDI Editor (Targeted), Score Editor 

Window, or Transport Window.

4  Name the Window Configuration.

5  You can type a different number for the new 
Window Configuration. If the number you type 
is already used by another Window Configura-
tion, you are prompted to replace it or Cancel. 
Otherwise, Pro Tools automatically fills in the 
first available number (1–99) for the Window 
Configuration. 

New Window Configuration dialog



6  Type any comments for the new Window Con-
figuration.

7  Click OK to store the new Window Configura-
tion, or Cancel.

The new Window Configuration is added to the 
Window Configuration List.

To create a new Window Configuration at a 
specific numbered slot:

 On the numeric keypad, type Period (.), a 
number (1–99), and then Plus (+) to add a new 
Window Configuration at that number slot. 

Recalling Window 
Configurations
You can use the Window Configuration List to 
recall stored Window Configurations. You can 
also use the Number Keypad on your computer 
keyboard to recall a specific Window Configura-
tion.

To recall a Window Configuration, do one of the 
following:

 Select the Window Configuration from Win-

dow > Configurations.

 In the Window Configuration List, click the 
Window Configuration to recall it.

 On the numeric keypad, press Period (.), the 
number of the Window Configuration (1–99), 
and then Asterisk (*).

The Pro Tools session’s screen layout updates 
with the stored Window Configuration.

If a Window Configuration already exists at 
that numbered slot, the new Window Con-
figuration overwrites it.
Undoing Window Configurations
Pro Tools lets you revert to the previous Win-
dow Layout and Window Settings with a single 
level of undo. This is useful, for example, if you 
recall a Window Configuration, but then decide 
you want to revert to the previous screen state.

To undo a Window Configuration:

 On the numeric keypad, press Period (.), 0, 
and then Asterisk (*). 

To redo a Window Configuration:

 On the numeric keypad, press Period (.), 0, 
and then Asterisk (*).

If Auto-Update Active Configuration is enabled, 
undoing the Window Configuration reverts to 
the previously stored Window Configuration 
without automatically saving changes (see “Up-
dating Window Configurations” on page 200).

Editing Window Configurations
You can change which properties are stored with 
Window Configurations, as well as the number, 
name, or comments. 

To edit a Window Configuration:

1  In the Window Configuration List, select the 
Window Configuration you want to edit.

2  From the Window Configuration List pop-up 
menu, select Edit <Name>. 

3  In the Edit Window Configuration dialog, edit 
the configuration and click OK.
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Updating Window 
Configurations
After you recall a stored Window Configuration, 
you can make changes to the window layout and 
window settings, and then update the stored 
Window Configuration with your changes. You 
can do this manually, or you can have Pro Tools 
automatically update the active configuration.

To manually update a Window Configuration, do 
one of the following:

 Choose Window > Configurations > Update Ac-

tive Configuration.

The active Window Configuration updates to in-
clude any changes to its included properties 
(Window Layout and Window Display Settings).

– or –

 From the Window Configuration List pop-up 
menu, choose Update <Name>.

The selected Window Configuration updates 
with any changes to its included properties.

To have Pro Tools automatically update the active 
Window Configuration, do one of the following:

 Select Window > Configurations > Auto-Update 

Active Configuration.

– or –

 From the Window Configuration List pop-up 
menu, select Auto-Update Active Configuration.

When Auto-Update Active Configuration is se-
lected, the active Window Configuration up-
dates with every change to the Window Layout 
and Window Display Settings.

Window Configurations that do not include 
Window Layout and only store Window Display 
Settings cannot be made active and thus won't 
automatically update. If you want to update a 
Pro Tools Reference Guide
Window Configuration with changes to the 
Window Display Settings (such as the width of 
the Clip List in the Edit window), use the Update 

command in the Window Configuration List.

Clearing Window Configurations
Clearing a window configuration removes it and 
its associated slot number while keeping the slot 
numbers of other window configurations un-
changed. The Clear command is useful if you 
want to insert another configuration it the same 
slot. 

To clear a Window Configuration:

1  In the Window Configuration List, select the 
Window Configuration you want to clear.

2  From the Window Configuration List pop-up 
menu, select Clear <Name>. 

Deleting Window Configurations
Deleting a Window Configuration removes the it 
and its slot number, and renumbers any subse-
quent Window Configurations.

To delete a Window Configuration:

1  In the Window Configuration List, select the 
Window Configuration you want to delete.

2  From the Window Configuration List pop-up 
menu, select Delete <Name>. 

To delete all Window Configurations:

 From the Window Configuration List pop-up 
menu, select Delete All.



Importing Window 
Configurations
You can import Window Configurations from 
another session using Import Session Data. 

To import Window Configurations:

1  Choose File > Import > Session Data.

2  Select the Window Configurations option.

3  If you only want to import Window Configura-
tions, click the Session Data to Import pop-up 
menu and select None.

4  Click OK.

Arranging Windows
Pro Tools provides commands to tile or cascade 
all open windows. Floating windows (such as 
plug-in windows) and the Transport window are 
not affected by these commands.

To arrange windows:

 Choose Window > Arrange and select one of the 
following:

Tile Arranges all open windows in a tiled pattern 
on the screen.

Tile Horizontal Arranges all open windows in a 
horizontally tiled pattern on the screen. This 
option is not available if there are too many win-
dows open.

Tile Vertical Arranges all open windows in a ver-
tically tiled pattern, side by side, on the screen. 
This option is not available if there are too many 
windows open.

Cascade Arranges all open windows in cascad-
ing pattern on the screen.
Hiding All Floating Windows
The Hide All Floating Windows command hides or 
shows all floating windows. This is useful for 
quickly clearing the screen of all floating win-
dows so that you can work in the Edit or Mix 
windows. 

To hide or show all floating windows:

 Select or deselect Window > Hide All Floating 

Windows.

Closing Windows

To close an open window: 

1  Make sure the window you want to close is in 
the foreground.

2  Do one of the following:

• Click the Close button for the window. 

– or –

• Choose Window > Close Window.

Press Control+Alt+Start+W (Windows) or 
Command+Option+Control+W (Mac) to 
hide or show all floating windows.

Press Control+W (Windows) or 
Command+W (Mac) to close the front-
most window.
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How Windows Configuration 
Works
A Window Configuration can store the location 
and size of all open windows, including:

• Edit window

• Mix window

• Targeted MIDI Editor window

• Score Editor window

• Workspace browser

• Project browser

• DigiBase browsers

• Session Setup window

• Time, Tempo, and Event Operations win-
dows

• MIDI Event List

• Real-time MIDI Properties window

• Beat Detective window

• Plug-In windows

• Panner windows

• Mic Pre windows
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• All floating windows listed in the Window 
menu:

• Task Manager window

• Transport window

• Big Counter window

• Automation window

• Memory Locations window

• Machine Track Arming window

• Video Universe window

• Video window

• Color Palette window

• Undo History window

• Eleven Rack Control window

• Disk Space window

• System Usage window

A Window Configuration can also store the 
Window Display settings for the Edit, Mix, Tar-
geted MIDI Editor, Score Editor, and Transport 
windows.

The location and size of the Window Config-
uration List is not stored with Window Con-
figurations.



Window Configuration List
The Window Configuration List lets you recall 
and manage stored Window Configurations, as 
well as create new Window Configurations.

To open the Window Configuration List:

 Select Window > Configurations > Window Con-

figuration List.

Window Configuration List

Press Command+Option+J (Mac) or 
Control+Alt+J (Windows) to show or hide 
the Window Configuration List.
Window Configuration 
Properties
Window Configurations can be stored and re-
called with the layout of windows in your 
Pro Tools session, as well as with the settings for 
the Edit, Mix, and Transport windows. You can 
specify which of these properties are stored for 
each Window Configuration either in the New 
Window Configuration dialog or the Edit Win-
dow Configuration dialog.

Number Is the number of the slot in which the 
Window Configuration is stored (1–99). You 
can type Period (.), the number of the Window 
Configuration, and then Asterisk (*) on the nu-
meric keypad on your computer keyboard to re-
call the Window Configuration stored in that 
slot.

Name Is the name of the stored Window Config-
uration.

Window Layout When enabled, stores the size 
and location of all open windows.

Include Edit, Mix, Targeted MIDI Editor, Score Ed-
itor, and Transport Display Settings When en-
abled, stores all window display settings for the 
Edit, Mix, Targeted MIDI Editor, Score Editor, 
and Transport windows with the Window Con-

Edit Window Configuration dialog
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figuration (such as whether or not the Clip List 
is shown in the Edit window). This option is 
only available when the Window Layout option is 
enabled.

Window Display Settings Stores only the win-
dow display settings for the selected window 
(Edit, Mix, Targeted MIDI Editor, Score Editor, 
or Transport):

• Edit Window Display Settings

• Width of the Track List and Group List

• Height of the Track List

• Width of the Clip List

• What rulers are shown (the main ruler is al-
ways shown) 

• What track columns are shown (such as In-
serts, Sends, or Comments)

• Tempo editor display

• Whether Transport controls are shown in 
the Edit window

• Edit Window Toolbar arrangement

• Mix Window Display Settings

• Width of the Track List and Group List

• Height of the Track List

• What track rows are shown (such as Inserts, 
Sends, or Comments)

• Narrow/wide mixer view

• Score Editor

• MIDI Editor (Targeted)

• MIDI Editor (Untargeted)

• Transport Window Display Settings

• Counters display

• MIDI controls display

• Expanded view

Comments Lets you type comments for the Win-
dow Configuration.
Pro Tools Reference Guide
Window Configuration 
Commands and Options
There are three main types of Window Configu-
ration commands and options

• View Filter icons

• Window Configuration List pop-up menu 
items

• Active Window configuration options

View Filter Icons
Using the View Filter icons, the Window Config-
uration List lets you show or hide Window Con-
figurations based on whether or not they are 
stored with Window Layout, Edit Window set-
tings, Mix Window settings, Score Editor win-
dow settings, MIDI Editor Window settings, or 
Transport Window settings.

Window Configuration List view filter icons

Window Layout

Edit Window settings

Mix Window settings

Transport Window settings

MIDI Editor Window (targeted) settings

Score Editor Window settings



To show or hide Window Configurations in the 
Window Configuration List, do one of the 
following:

 Click the View Filter icon to show or hide Win-
dow Configurations that include that property 
(Window Layout, Edit Window Settings, Mix 
Window Settings, Score Editor Window Set-
tings, MIDI Editor Window Settings, or Trans-
port Window Settings). 

– or –

 Select or deselect the View Filter item in the 
Window Configuration List pop-up menu.

Window Configuration List Pop-
Up Menu
You can select viewing and sorting options, 
along with commands for creating and removing 
Window Configurations, from the pop-up menu 
in the Window Configuration List.

View Filter Lets you show or hide Window Con-
figuration filter icons in the Window Configura-
tion List as well as show or hide Window Config-
urations with Window Layout, Edit Window 
Settings, Mix Window Settings, Score Editor 
Window Settings, MIDI Editor Window Set-
tings, or Transport Window Settings. 

Show Comments Lets you show or hide Com-
ments in the Window Configuration List.

Window Configuration List pop-up menu
New Configuration Creates a new Window Con-
figuration. This command is also available from 
Window > Configurations.

Update <Name> Updates the selected Window 
Configuration with any changes to the layout 
and settings of windows depending on the Win-
dow Configuration’s properties. This command 
is also available from Window > Configurations.

Edit <Name> Opens the Edit Window Configura-
tion dialog where you can edit the properties of 
the selected Window Configuration.

Clear <Name> Clears the selected Window Con-
figuration without deleting the slot (number).

Delete All Deletes all Window Configurations.

Insert Slot Before <Name> Inserts a new slot be-
fore the selected Window Configuration and, if 
necessary, increments the number of each fol-
lowing slot.

Delete <Name> Slot Deletes the selected Win-
dow Configuration and its slot (number), and 
renumbers each subsequent slot.

Auto-Update Active Configuration Automati-
cally updates the active Window Configuration 
as you make changes to the layout and settings 
of windows. If Auto-Update Active Configuration 
is enabled, the number of the active configura-
tion is also displayed in the Window menu. This 
command is also available from Window > Con-

figurations.

Number of active Window Configuration displayed in 
Window menu
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Active Window Configuration
The active Window Configuration is indicated 
by a diamond to the left of the Window Config-
uration Number in the Window Configuration 
List and in the Configurations submenu (Win-

dow > Configuration). If Auto-Update Active Con-

figuration is enabled, the number of the active 
configuration is also displayed in the Window 
menu. Only Window Configurations that in-
clude Window Layout can be made active. 

Menus
Pro Tools menus provide commands and op-
tions for configuring and working with 
Pro Tools, sessions, and session material.

Pro Tools Main Menus
Pro Tools includes the following main menus:

File Provides commands that are used to create 
and maintain Pro Tools sessions.

Edit Provides commands that are used to edit 
and manipulate the current selection and affect 
data in the Timeline or the clipboard.

View Provides options and commands to cus-
tomize what is shown in various windows. 

Track Provides commands that are used to cre-
ate, manage, and edit tracks.

Window Configuration List showing active 
configuration

For detailed information on Pro Tools main 
menus and Clip List menus, see the Menus 
Guide.
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Clip Provides commands that are used to man-
age and edit clips.

Event Provides commands for editing audio and 
MIDI events.

AudioSuite Provides AudioSuite plug-ins. 

Options Provides commands that let you select 
several editing, recording, monitoring, play-
back, and display options.

Setup Provides commands to open dialogs and 
windows or configure various Pro Tools hard-
ware and software parameters.

Window Provides commands to toggle the dis-
play of various Pro Tools windows.

Help Provides access to searchable Pro Tools 

Help and to the online Pro Tools Knowledge 

Base. The Help menu also provides easy access 
to the following PDF documentation (installed 
with Pro Tools): Audio Plug-Ins Guide, Pro Tools 
Menus Guide, Pro Tools Reference Guide, and 
Pro Tools Shortcuts Guide. 

The Help menu also provides access to Additional 

Software Options (where you can research Avid 
product offering for expanding your Pro Tools 
system) and to the Check For Updates command 
(so that you can be sure that your Pro Tools soft-
ware and plug-ins are always up to date).



Track, Clip, and Group List 
Menus
The Track, Clip, and Group Lists provide pop-up 
menus for managing and working with the con-
tents of each list, as follows:

Track List Menu Provides commands to show 
and hide tracks in the Mix, Edit, MIDI Editor, 
and Score Editor windows. The Track List pop-
up menu also lets you sort the contents of the 
Track List. 

Group List Menu (Edit Groups and Mix 
Groups) Provides commands to create, display, 
suspend, and delete Mix and Edit Groups.

Clip List Menu (Edit Window Only) Provides 
commands to find, select, sort, clear, rename, 
time stamp, compact, export, and recalculate 
waveform overviews of items in the Clip List. 
The pop-up menu also lets you set the drop or-
der for clips dragged from the Clip List and 
dropped in the Timeline. 

For more information, see “The Track List” 
on page 232.

For more information, see “The Group List” 
on page 257

For more information, see Chapter 15, “The 
Clip List.”
Track Name and Clip Name 
Right-Click Menus
Track and clip names provide Right-click menus 
for managing and working with tracks or clips, 
as follows:

Track Name Right-Click Menu Right-clicking a 
track name in the Edit window, Mix window, or 
the Track List provides access to various track 
commands (such as show/hide, make active/in-
active, rename, duplicate, and delete tracks). 

Clip Name Right-Click Menu (Edit Window Only) 

Right-clicking a clip name in the Clip List pro-
vides commands to clear, rename, time stamp, 
or replace clips. The pop-up menu also lets you 
export clip definitions or selected clips as files, 
recalculate waveform overviews, select the par-
ent file of selected clips in the DigiBase Work-
space Browser, or select a clip as an object in the 
Edit window.

Group Name and Track Group ID 
Indicator Pop-Up Menus
When you click and hold on a group name in the 
Group List, or click on a Group ID indicator in a 
track, a pop-up menu provides access to various 
group commands (such as selecting tracks in a 
group).

For more information, see “Track Name 
Right-Click Menu” on page 235.

For more information, see Chapter 15, “The 
Clip List.”

For more information, see “Group Name 
and Track Group ID Indicator Pop-Up 
Menus” on page 258.
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Tool Tips
Pro Tools provides Tool Tips in all main win-
dows. Holding the cursor for a few seconds over 
an abbreviated name, or unlabeled icon or tool, 
displays either the function or details of the 
item (depending on the Tool Tips preferences 
settings).

To configure Tool Tips for Pro Tools:

1  Choose Setup > Preferences, and click the Dis-

play tab.

2  In the Basics section, enable the Tool Tips op-
tions you want displayed. 

Function Shows the functional name of different 
Pro Tools items (such as specific buttons, indi-
cators, modes, selectors, and Edit tools).

Details Shows abbreviated or hidden Pro Tools 
names or values for different Pro Tools items 
(such as insert names, gain levels, settings, and 
routing assignments).

3  Click OK. 

To turn off Tool Tips, leave both options 
deselected.
Pro Tools Reference Guide



Chapter 13: Tracks
Pro Tools provides different types of tracks for 
working with audio, MIDI and video in 
Pro Tools sessions. 

Track Types
In a Pro Tools session, you can have several dif-
ferent types of tracks. These can include audio, 
Auxiliary Input, Master Fader, VCA Master 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only), MIDI, Instrument, 
and video tracks.

Audio, Auxiliary Input, Master Fader, and VCA 
Master Tracks

Pro Tools provides mono, stereo, and multi-
channel format audio, Auxiliary Input, Master 
Fader, and VCA Master tracks.

Audio Tracks Audio tracks let you record to disk 
and play back from disk recorded or imported 
audio files.

Auxiliary Input Tracks Auxiliary Input tracks can 
be used as effects sends, destinations for sub-
mixes, as a bounce destination, as inputs to 
monitor or process audio (such as audio from 
external MIDI instruments), and for many other 
audio routing tasks.

Video track features are described in 
Chapter 51, “Working with Video in 
Pro Tools”
Master Fader Tracks Master Fader tracks control 
the overall level of audio paths that are routed to 
physical output paths. For example, you could 
have 24 tracks in a session with channels 1–8 
routed to Analog Output 1–2, channels 9–16 to 
Analog Output 3–4, and channels 17–24 to Ana-
log Output 5–6. You could then create three 
master faders, one to control each of these out-
put pairs.

Master Fader tracks have additional uses (such 
as controlling submix levels). For more infor-
mation, see “Master Fader Tracks and Signal 
Flow” on page 942.

VCA Master Tracks (Pro Tools HD and Pro Tools 
with Complete Production Toolkit Only) VCA 
Master tracks (or VCA Masters) emulate the op-
eration of voltage-controlled amplifier channels 
on analog consoles, where a VCA channel fader 
would be used to control, group, or offset the 
signal levels of other channels on the 
console.

VCA Master tracks do not pass audio, so they do 
not have inputs, outputs, inserts, or sends. A 
Mix Group is assigned to a VCA Master track, 
which appears in the VCA track’s Assignment 
selector.

The controls of the tracks in that Group, called 
the slave tracks, are modified by the controls on 
the VCA Master. For more information, see 
“VCA Master Tracks” on page 945.
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MIDI Tracks

MIDI tracks record, store, and playback MIDI 
data. You cannot select a track format when you 
create a MIDI track, because audio does not pass 
through it.

Instrument Tracks

Instrument tracks are a special type of track that 
provide both MIDI and audio capabilities in a 
single channel strip. Instrument tracks simplify 
using software and hardware instruments to re-
cord and monitor MIDI instruments.

Video Tracks

Video tracks let you add or import QuickTime 
(Windows and Mac) or Windows Media Video 
(Windows Vista only).

With an Avid video peripheral and Pro Tools, 
you can add or import Avid video to the 
Pro Tools Timeline (see Chapter 51, “Working 
with Video in Pro Tools.”)

Video tracks only appear in the Edit window, 
and video can be viewed in the Video window.
Pro Tools Reference Guide
Track Formats

Mono Tracks

A mono audio, Auxiliary Input, Master Fader, or 
Instrument track controls volume, and, in some 
cases, panning, for a single channel of audio. A 
mono audio track uses a single voice. A mono 
track can also be routed to a multichannel out-
put.

Stereo Tracks

A stereo audio, Auxiliary Input, Master Fader, 
or Instrument track is a single channel strip for 
two channels of audio as a stereo pair. Stereo au-
dio tracks use two voices. 

Multichannel Tracks 

(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

A multichannel track is a single channel strip 
that plays multiple channels of audio (from 3 to 
8 channels at a time). This allows Pro Tools to 
support multichannel mixing formats including 
LCRS, 5.1, 6.1, and others. Audio, Auxiliary In-
put, Master Fader, and Instrument tracks can all 
use any supported multichannel format.

For more information on surround mixing with 
Pro Tools, see the following:

• Chapter 47, “Pro Tools Setup for Surround”

• Chapter 48, “Multichannel Tracks and 
Signal Routing”

• Chapter 49, “Surround Panning and Mix-
ing”



Track Channel Strips
(Mix Window)

Audio Track Channel Strips

Each audio track has its own set of channel strip 
controls, including volume, pan, record enable, 
input monitoring (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only), auto-
mation mode, solo, mute, and voice assignment.

Mono audio track channel strip 

Inserts (A–E shown)

Sends (A–E shown)

Audio Input/Output Paths

Solo/Mute buttons

Automation Mode selector

Track Name button

Pan knob

Level meter

Volume fader

Group ID

Output Window button

Track Comments

Track Type indicator

Voice selector

Track Record Enable button

Volume/Peak/Delay indicator

Pan indicator

Delay Compensation view

TrackInput Monitor button

Track Color Coding

Track Color Coding

HEAT track controls 
(Pro Tools HD with HEAT option only)
Auxiliary Input Track Channel Strips

Each Auxiliary Input track has its own set of 
channel strip controls, including volume, pan, 
automation mode, solo, and mute.

Stereo Auxiliary Input track channel strip 

Inserts (A–E shown)

Sends (A–E shown)

Audio Input/Output Path selectors

Solo/Mute buttons

Automation Mode selector

Track Name button

Pan knobs

Level meters

Volume fader

Group ID

Track Comments

Track Type indicator

Volume/Peak/Delay indicator

Pan indicators

Delay Compensation view

Track Color Coding

Output Window button

Track Color Coding
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Master Fader Track Channel Strips

Each Master Fader track has its own set of chan-
nel strip controls, including volume and auto-
mation mode. 

Stereo Master Fader track channel strip 

Inserts (A-E shown)

Audio Output Path selectors

Automation Mode selector

Track Name button

Level meters

Volume fader

Group ID

Track Comments

Track Type indicator

Volume/Peak/Delay indicator

Delay Compensation view

Track Color Coding

Output Window button
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VCA Master Track Channel Strips
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Each VCA Master track has its own set of chan-
nel strip controls, including volume, record en-
able, input monitoring, automation mode, solo, 
and mute. 

For more information, see “VCA Master 
Tracks” on page 945.

VCA Master track

Automation Mode selector

Mute

TrackInput

Solo

Record 
Enable

Track Type indicator

Track Comments

Track Color Coding

Volume indicator

Group ID

Track Color Coding

Volume
fader



MIDI Track Channel Strips

Each MIDI track has its own set of channel strip 
controls, including MIDI volume, pan, record 
enable, automation mode, solo, mute, patch as-
signment, and channel assignment. 

Instrument Track Channel Strips

Each Instrument track has its own set of channel 
strip controls, including audio (like an Auxiliary 
Input track) volume, pan, automation mode, 
solo, and mute, and MIDI (like a MIDI track) re-

MIDI channel strip 

MIDI Input selector

MIDI Volume fader

MIDI Pan knob

Track Name button

MIDI Velocity meter

Automation Mode selector

MIDI Output selector

Record Enable

Patch Select

MIDI Pan indicator

MIDI Volume indicator
Track Type indicator

Group ID

Track Comments

Solo/Mute buttons

Track Color Coding

Track Color Coding
cord enable. Instrument tracks have an addi-
tional Instruments view that provides controls 
for MIDI input, output, mute, volume, and pan 
(like on a MIDI track).

Stereo Instrument track channel strip, Instruments 
view shown

Inserts (A–E shown)

Sends (A–E shown)

Audio Input/Output Path selectors

Solo/Mute buttons

Automation Mode selector

Track Name

Level meters

Volume fader

Group ID

Output Window button

Track Comments

Track Type indicator
Volume/Peak/Delay indicator

Pan knobs

Delay Compensation view

Record Enable

Patch Select

MIDI Input selector

MIDI Output selector

MIDI meter (Velocity)

MIDI Volume

MIDI Mute button

Track Color Coding

MIDI Pan

Pan indicators
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Track Controls and 
Indicators
(Edit Window)

Audio Track Controls
Each audio track has its own set of track con-
trols, including Track Name, Playlist, Record 
Enable, Input Monitoring (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
only), Solo, Mute, Track View, Track Height, 
Timebase, Elastic Audio, Voice Assignment, and 
Automation mode. 

Edit window track controls for a mono audio track 
(medium track height)

Automation Mode selector

Mute button

Voice selector

Track Height selector

Playlist selector

Track Name

Solo button
TrackInput Monitor button

Timebase selector

Track View selector

Elastic Audio plug-in selector

Record Enable button

Show/Hide Automation lanes
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Auxiliary Input Track Controls
Each Auxiliary Input track has its own set of 
track controls, including Track Name, Solo, 
Mute, Track View, Track Height, Timebase, and 
Automation mode. 

Master Fader Track Controls
Each Master Fader track has its own set of track 
controls, including Track Name, Track View, 
Track Height, Timebase, and Automation mode. 

Edit window track controls for a stereo Auxiliary Input 
track (medium track height)

Edit window track controls for a stereo Master Fader 
track (medium track height)

Mute button

Track Height selector
Track Name

Timebase selector

Track View selector

Solo button

Automation Mode
selector

Show/Hide Automation lanes

Track Height
selector

Track Name

Track View 
selector

Automation mode

Timebase selector

Show/Hide Automation lanes



VCA Master Track Controls
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Each VCA Master track has its own set of track 
controls, including Track Name, Playlist, Re-
cord Enable, Input Monitoring, Solo, Mute, 
Track View, Track Height, Timebase, and Auto-
mation mode. 

Edit window track controls for a VCA Master track 
(medium track height)

Mute button

Track Height selector

Track Name

Solo button
TrackInput Monitor button

Record Enable button

Automation Mode selector
Timebase selector

Show/Hide Automation lanes
MIDI Track Controls
Each MIDI track has its own set of track con-
trols, including Track Name, Playlist, Record 
Enable, Solo, Mute, Track View, Track Height, 
Patch, Timebase, and Automation mode. 

Edit window track controls for a MIDI track (medium 
track height)

Mute button

Track Height selector

Playlist selector

Track Name
Solo button

Record Enable button

Automation Mode selector
Patch selector

Timebase selector

Track View selector

Show/Hide Controller lanes
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Instrument Track Controls
Each Instrument track has its own set of track 
controls, including Track Name, Playlist, Re-
cord Enable, Solo, Mute, Track View, Track 
Height, Patch, Timebase, and Automation 
mode.

Video Track Controls
Each video track has its own set of track con-
trols, including Track Name, Playlist, Online, 
Track View, and Track Height. 

Edit window track controls for a stereo Instrument 
track (medium track height)

Edit window track controls for a video track (medium 
track height)

Mute button

Track Height selector

Playlist selector

Track Name

Solo button

Record Enable button

Track View selector

Automation Mode selector

Patch selector

Timebase selector

Show/Hide Automation and Controller lanes

Online button

Track Height selector
Playlist selectorTrack Name

Track View selector

Frame Rate indicator
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Edit Window Views
In addition to track controls and playlists (of 
clips of events on the Timeline), the Edit win-
dow provides the following views that corre-
spond to channel strip controls in the Mix win-
dow:

• Comments

• Mic Preamps

• Instruments

• Inserts (A–E and F–J)

• Sends (A–E and F–J)

• I/O

• Real-Time Properties

• Track Color

Comments View
Comments view lets you type and view com-
ments for a specific track.

Mic Preamps View
The Mic Preamps view shows controls for tracks 
with physical audio inputs routed through PRE. 

See also “Views in the Mix and Edit Win-
dows” on page 950.

For more information on Comments view, 
see “Adding Comments to Tracks” on 
page 222.

For more information, see the PRE Guide.



Instruments View
Instruments view provides MIDI controls for In-
strument tracks: MIDI Input selector, MIDI 
Output selector, MIDI Volume, MIDI Pan, and 
MIDI Mute.

Inserts View (A–E and F–J)
Inserts view provides up to ten inserts (software 
plug-ins and hardware I/O inserts for generat-
ing and processing audio) on each audio, Auxil-
iary Input, Master Fader, and Instrument track. 

Sends View (A–E and F–J)
Sends view shows send assignments in each au-
dio, Auxiliary Input, and Instrument track. 

I/O View
In the Edit window, I/O view provides Input and 
Output selectors on audio, Auxiliary Input, 
Master Fader (output only), MIDI, and Instru-
ment tracks (corresponding to the controls of 
the same name in the Mix window).

For more information, see “Assigning MIDI 
Input and Output for Instrument Tracks” 
on page 246.

For more information on inserts, see 
Chapter 44, “Plug-In and Hardware In-
serts.”

For more information, see “Configuring 
Sends View in the Mix and Edit Windows” 
on page 959.

Edit window I/O view (audio track)

Input Path selector

Output Path selector

Volume indicator

Pan indicator

Output Window button
To show the I/O View in the Edit window:

 Select View > Edit Window > I/O.

Volume/Peak/Channel Delay Indicator

The Volume indicator on an audio track has 
three display modes: Volume, Peak, and Chan-
nel Delay.

To toggle the Volume indicator display:

 Control-click (Windows) or Command-click 
(Mac) the indicator to toggle it between the fol-
lowing modes:

Volume Indicator (and Pop-Up Fader) Shows the 
current volume, or input level of a track as set by 
the track Volume fader. In I/O view (Edit win-
dow), click the Volume indicator to display the 
Volume pop-up fader, which can be used to ad-
just the volume.

Peak Indicator Functions as a headroom indica-
tor based on the last peak playback level. To re-
set the peak counter, click anywhere in the me-
ter. Values range from – (no signal) to 0 dB. 

Channel strips in the Mix window always 
display Input and Output selectors as well as 
volume and pan values, so there is no I/O 
view display option for the Mix window.

For details on Input and Output selectors, 
see “Assigning Audio Inputs and Outputs to 
Tracks” on page 236.

Edit window I/O view, Volume pop-up fader (audio 
track)
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Pan Indicator

The Pan indicator displays the current pan set-
ting of a track. Pan values range from <100 (full 
left) to 100> (full right). Pan controls are only 
available for stereo tracks or for mono tracks 
routed to a stereo output.

In I/O view (Edit window), click the Pan indica-
tor to display the Pan pop-up slider, which can 
be used to adjust panning.

Pan Slider

The Pan slider controls the balance of a track be-
tween the assigned output pair. It only appears 
if you are using stereo tracks or mono tracks 
routed to a stereo output.

The Pan slider on a MIDI track is effective only 
if you are controlling a sound module that sup-
ports MIDI panning.

Edit window I/O view, Pan pop-up slider (audio track)

Greater-than-stereo multichannel tracks do 
not provide a Pan indicator in I/O view. You 
can view and adjust multichannel panning 
in the track’s Output window or in the Mix 
window.

Send Pan controls can be linked to the Main 
Pan controls of a track by enabling the 
Follow Main Pan button in Send window.
Pro Tools Reference Guide
Volume Fader

The Volume fader controls the playback level of 
a track when it is playing back, and the monitor 
level of the track when it is recording. You can 
link the record and monitor levels by enabling 
the Link Record and Play Faders option in the 
Operation preferences.

The maximum fader gain for a volume fader is 
+12 dB.

MIDI Volume Fader

If your MIDI sound module supports volume, 
the volume fader on a MIDI or Instrument track 
can send a value of 0–127 to the MIDI volume 
controller.

Real-Time Properties

In the Edit window, Real-Time Properties view 
provides access to Real-Time Properties con-
trols (such as Quantize or Transpose) on MIDI 
and Instrument tracks. For more information, 
see “MIDI Real-Time Properties” on page 709.

Track Color

In the Edit window, Track Color view displays 
the Track Color strip at the left-most side of the 
Track controls.



Track Level Meter
On audio tracks, level meters indicate the level 
of the signal being recorded or played back from 
the hard drive. On Auxiliary Input, Master 
Fader, and Instrument tracks, level meters indi-
cate the level of the signal being played through 
the channel output. Green indicates nominal 
levels; Yellow indicates pre-clipping (–6 dB be-
low full scale); and Red indicates clipping. When 
an audio track is record-enabled, these meters 
indicate record levels.

On MIDI tracks, and in Instruments view for In-
strument tracks, the meter shows the MIDI ve-
locity of the most recent MIDI event.

Pre- and Post-Fader Metering

You can globally set audio track level meters to 
indicate pre- or post-fader levels. When pre-
fader metering is selected, the level meters show 
levels independent of fader position. With post-
fader metering, the level meters respond to 
fader position.

To toggle track level metering between pre- fader 
and post-fader metering:

 Select Options > Pre-Fader Metering.

Peak Hold

Pro Tools meters provide a Peak Hold feature 
with three options: 3 Second, Infinite, or None.

To choose a Peak Hold setting:

1  Choose Setup > Preferences and click the 
Display tab.

2  Select a Peak Hold option.

3  Click OK.

To clear a meter:

 Click anywhere on the meter. 
To clear all meters, do one of the following:

 Option-click (Mac) or Alt-click (Windows) 
any meter.

 Choose Track > Clear All Clip Indicators.

 Press Option+C (Mac) or Alt+C (Windows).

Clip Indication 

Pro Tools meters provide Clip Indication with 
three options: 3 Second, Infinite, or None. If clip-
ping occurs, the topmost LED will stay lit (red).

To choose a Clip Indication setting:

1  Choose Setup > Preferences and click the 
Display tab.

2  Select a Clip Indication option.

3  Click OK.

To clear a clip indicator:

 Click anywhere on the meter. 

To clear all clip indicators, do one of the following:

 Option-click (Mac) or Alt-click (Windows) 
any meter.

 Choose Track > Clear All Clip Indicators.

 Press Option+C (Mac) or Alt+C (Windows).

Clip indicators appear in plug-in, send, and 
track windows.
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Wide Meters View
Wide Meters view expands the width of the level 
meters for tracks in both the Mix and Edit win-
dows, to make the track level meters easier to 
read. Wide Meters view are also available Nar-
row Mix view.

To toggle Wide Meters View on or off:

 Command-Option-Control-click (Mac) or 
Control-Alt-Start-click (Windows) any track 
level meter in the Mix or Edit window.

Adjusting Track Width
(Mix Window)

The Narrow Mix command lets you view all 
tracks/channels in the Mix window at a reduced 
width to conserve screen space in a large ses-
sion. (See “Track Height” on page 230, to adjust 
track height in the Edit Window.)

To reduce the width of tracks in the Mix window:

 Select View > Narrow Mix.

To display tracks at normal width:

 Deselect View > Narrow Mix.

Wide Meters view, Mix and Edit windows

You can toggle track width by pressing Com-
mand+Option+M (Mac) or 
Control+Alt+M (Windows).
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Creating Tracks
You can create mono and stereo tracks on all 
Pro Tools systems. With Pro Tools HD or 
Pro Tools with the Complete Production Toolkit 
option, you can also create multichannel tracks 
(from LCR to 7.1).

When new tracks are created, they are given a 
default name that can be changed at any time.

 To insert new tracks next to a specific track in 
a session, select that track by clicking the track’s 
name in the Mix or Edit window before opening 
the New Tracks dialog. The new tracks are added 
immediately after the selected track. 

 To insert new tracks after the last tracks in a 
session, make sure that no track names are se-
lected on-screen before opening the New Tracks 
dialog.

You can also add tracks to your session by 
importing them from preexisting sessions. 
See “Importing Session Data” on page 352.



To create new tracks:

1  Do one of the following to open the New Tracks 
dialog:

• Choose Track > New.

– or –

• Right-click any Track Name in the Mix or 
Edit windows, or Track List, and choose 
New.

2  Select the type of track you want to add from 
the Track Type pop-up menu. 

3  Select the track format (mono, stereo, or one of 
the multichannel surround formats) from the 
Track Format pop-up menu. Surround formats 
are available on Pro Tools|HD systems or 
Pro Tools with the Complete Production Toolkit 
option.

Press Control+Shift+N (Windows) or 
Command+Shift+N (Mac) to open the New 
Tracks dialog

New Tracks dialog

To auto-scroll the Track Type pop-up menu 
in the New Tracks dialog, press Command 
(Mac) or Control (Windows) and use the 
Up/Down Arrow keys.

To auto-scroll the Track Format pop-up 
menu, press Command (Mac) or Control 
(Windows) and use the Left/Right Arrow 
keys.

Number of new tracks

Track Format

Track Type

Track Timebase

Add/Remove Row
4  Select the timebase (samples or ticks) from the 
Track Timebase pop-up menu.

5  Enter the number of new tracks.

6  Do any of the following:

• To add more tracks, click the Add Row but-
ton.

– or –

• To remove a track, click the Remove Row 
button.

7  To reorder tracks, drag a Move Row icon up or 
down.

8  Click Create.

To auto-scroll the Track Timebase pop-up 
menu, press Command+Option (Mac) or 
Control+Alt (Windows) and use the 
Up/Down Arrow keys.

If you are creating various multiple new 
tracks, you can move to the next or previous 
row’s Number of New Tracks field by press-
ing Tab or Shift+Tab.

Add a new track by pressing Command+N 
(Mac) or Control+N (Windows), or by 
pressing Command+Plus (+) (Mac) or 
Control+Plus (+) (Windows) on the 
numeric keypad. 

To remove the last track from the New 
Tracks dialog Command+Minus (–) (Mac) 
or Control+Minus (–) (Windows).

Move Row icon in the New Tracks dialog

Move Row icon
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Default Track Names
When creating new audio, Auxiliary Input, Mas-
ter Fader, VCA Master, MIDI, and Instrument 
tracks, Pro Tools names them as “Audio,” 
“Aux,” “Master,” “VCA,” “MIDI, or “Inst” ac-
cordingly and numbers them consecutively. For 
example, when you create the first two audio 
tracks in a new session, their default names are 
“Audio 1” and “Audio 2.” You can rename 
tracks and also log comments for each track.

Naming Tracks
Track names are used to auto-name recorded 
audio files and clips (see “Default Track Names” 
on page 222).

To rename a track:

1  Do one of the following:

• In the Mix or Edit window, double-click the 
Track Name button for the track you want 
to rename.

– or –

• In the Track List, or Mix or Edit window, 
Right-click the track name for the track you 
want to rename.

2  In the Track Name/Comments dialog, type a 
new track name.

Track Name/Comments dialog
Pro Tools Reference Guide
3  Click Previous or Next to rename other dis-
played tracks.

4  Click OK.

Adding Comments to Tracks

To add comments to a track, do one of the 
following:

 From the track channel strip, click directly in 
the Comments area, type any comments for the 
track, and press Enter (Windows) or Return 
(Mac). 

– or –

 In the Edit or Mix window, double-click the 
Track Name button for a track. Then click di-
rectly in the Comments area, type any comments 
for the track, and press Enter (Windows) or Re-
turn (Mac). 

Track Numbering
With Track Number view enabled, each track is 
assigned a number corresponding to its position 
in the Mix and Edit Windows. When tracks are 
reordered, they are renumbered to maintain po-
sitional sequence.

To enable Track Number view:

 Choose View > Track Number.

To move to the previous or next track in the 
Track Name/Comments dialog, you can 
press Control (Windows) or Command 
(Mac) and use the Up/Down or Left/Right 
Arrows.

To enter a carriage return in the Comments 
area, press Shift+Enter (Windows) or 
Shift+Return (Mac) on the alphanumeric 
keyboard.



To navigate directly to any track number:

1  Choose Track > Scroll to Track.

2  In the Scroll To Track dialog, enter the Track 

Position Number.

3  Click OK.

The track is selected, and the windows scroll as 
follows:

• The Mix window tracks scroll to bring the 
selected track as close to the left as possi-
ble. 

• The Edit window tracks scroll to bring the 
selected track as close to the top as possi-
ble. 

Selecting Tracks
Tracks need to be selected for operations such as 
duplicating tracks or adding tracks to a group. 
One or more tracks can be selected at a time.

To select a track:

 Click the name of an unhighlighted track in its 
track channel strip.

Press Command+Option+F (Mac) or 
Control+Alt+F (Windows) to open the 
Scroll to Track dialog.

Scroll To Track dialog

To select a range of tracks:

1  Click the name of an unhighlighted track in its 
track channel strip.

2  Shift-click an additional button.

All tracks between the first track selected and 
the additional track will also be selected.

To select or deselect noncontiguous tracks, do 
one of the following:

 Command-click (Mac) or Control-click (Win-
dows) Track Name buttons that are unhigh-
lighted to select them.

– or –

 Command-click (Mac) or Control-click (Win-
dows) Track Name buttons that are highlighted 
to deselect them.

To select all tracks:

 Option-click (Mac) or Alt-click (Windows) 
any Track Name button that is unhighlighted.

To deselect all tracks:

 Option-click (Mac) or Alt-click (Windows) 
any Track Name button that is highlighted.

Selected and unselected tracks

selected track
unselected track
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Selecting Tracks when Making Edit Selections

Pro Tools lets you link Track selection with Edit 
selections. When Track and Edit selections are 
linked, you can make a selection within a track 
or across multiple tracks for editing and each as-
sociated track is selected (track names automat-
ically highlight). 

To link Track and Edit selections:

 Select Options > Link Track and Edit Selection.

Scrolling a Track into View

To scroll a track into view:

 In the Track List, or Mix or Edit window, 
Right-click the track name and select Scroll into 

View.

The track is selected, and the windows scroll as 
follows:

• The Mix window tracks scroll to bring the 
selected track as close to the left as possi-
ble. 

• The Edit window tracks scroll to bring the 
selected track as close to the top as possi-
ble. 
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Deleting Tracks
When you delete tracks, your audio or MIDI clip 
data remains in the Clip List, but your arrange-
ment of the clips on the deleted track (the 
track’s playlist) will be lost. 

If the track contains playlists that are not as-
signed to any track, you are prompted to delete 
or retain them.

To delete a track:

1  Click the name of the track in its track channel 
strip to select it. 

2  Do one of the following:

• Choose Track > Delete.

– or –

• In the Track List, or Mix or Edit window, 
Right-click the track name and select De-

lete.

3  Click OK to remove the selected tracks from 
the session.

The Delete Track command cannot be 
undone.

To select multiple tracks, Command-click 
(Mac) or Control-click (Windows) addi-
tional Track Names.

To select a range of tracks, Shift-click 
additional Track Names.



Duplicating Tracks
The Duplicate Track command lets you dupli-
cate one or more tracks, including their audio or 
MIDI data, playlists, automation, and other at-
tributes.

To duplicate one or more tracks:

1  Select the tracks you want to duplicate.
\

2  Do one of the following:

• Choose Track > Duplicate. 

• Press Option+Shift+D (Mac) or 
Alt+Shift+D (Windows).

• Right-click the name of the track in the 
Track List, or Mix or Edit window, and 
select Duplicate.

For information, see “Selecting Tracks” on 
page 223.

Duplicate Tracks dialog
3  In the Duplicate Tracks dialog, configure the 
following options as needed:

• Enter how many copies you want to create 
in the Number of Duplicates filed. 

• To copy the currently active (visible) Edit 
playlist from the source track, select Active 

Playlist. 

• To copy all Edit playlists on the source 
track, select Alternate Playlists

• To copy all automation from the source 
track, select Automation. 

• To copy all plug-in and insert assignments, 
select Inserts. 

• To copy all sends and send assignments, 
select Sends.

• To maintain all Mix and Edit Group assign-
ments, select Group Assignments. 

4  If duplicating multiple tracks, do one of the 
following:

• If you want all the newly created tracks to 
follow the last selected source track (to the 
far-right of the Mix window, and at the bot-
tom of the Edit window), select the Insert af-

ter Last Selected Track option.

– or –

• If you want each newly-created track to be 
inserted directly after its source track, de-
select this option.

5  Click OK to duplicate tracks according to the 
settings in the Duplicate Tracks dialog. Click 
Cancel to close the dialog and not create dupli-
cate tracks. 

In the Mix window, each duplicate track is cre-
ated to the right of its original track. In the Edit 
window, each duplicate track is created below 
its original track. When duplicating multiple 
tracks, you can also choose to have the new 
tracks follow the last selected track (or have 
each new track follow its source track).
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Duplicating VCA Slave Tracks
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Duplicating a VCA slave track without duplicat-
ing its group assignments will coalesce any au-
tomation on the duplicate track. The coalesced 
duplicate plays back exactly as if it were in the 
VCA group. For more information, see “VCA 
Master Tracks” on page 945.

Track Views
The Track View determines which data is dis-
played and edited in the track’s playlist area. 
Track View data can be set to Playlists, Blocks, 
Analysis, Warp, Waveform, Volume, Volume 
Trim, Mute, Pan, Send, or an automated control 
or continuous controller, based on the track 
type and your Pro Tools system.

Audio Tracks Can be set to Blocks, Playlists, 
Analysis, Warp, Waveform, Volume, Volume Trim, 
Mute, Pan, Send controls, or any plug-in con-
trols that are enabled for automation. By de-
fault, audio tracks are set to Waveform view 
where track material is graphically drawn with 
amplitude waveforms (a time-domain represen-
tation of sound). This Track View provides the 
necessary detail for important clip edits.

Auxiliary Input Tracks Can be set to Volume, Vol-

ume Trim, Mute, Pan, Send controls, or any plug-
in controls that are enabled for automation. 

Master Fader Tracks Can be set to Volume, Vol-

ume Trim, or any plug-in controls that are en-
abled for automation.

VCA Master Tracks (Pro Tools HD and Pro Tools 
with Complete Production Toolkit Only) Can be 
set to Volume, Volume Trim, or Mute.
Pro Tools Reference Guide
MIDI Tracks Can be set to Blocks, Clips, Notes, 
Velocity, Volume, Mute, Pan, Pitch Bend, Mono Af-

ter Touch, Program Change, Sysex, and any con-
tinuous controller type. MIDI tracks are com-
monly set to Notes or Clips, each of which 
displays notes in a “piano roll” format. Use Clips 
view to edit and arrange MIDI clips. Use Notes 
view for inserting and editing MIDI notes. Other 
MIDI track views are useful for editing velocity, 
controller data, program changes, and Sysex 
events.

Instrument Tracks Can be set to Blocks, Clips, 
Notes, Velocity, Volume, Mute, Pan, Pitch Bend, 
Mono After Touch, Program Change, Sysex, and 
any continuous controller type for MIDI; as well 
as Volume, Volume Trim, Mute, Pan, Send con-
trols, or any plug-in controls that enabled for 
automation. Instrument tracks are commonly 
set to Notes or Clips, each of which displays 
notes in a “piano roll” format. Use Notes view 
for inserting, editing, and copying and pasting 
MIDI notes. Use Clip view to arrange, capture, 
or consolidate clips. Other Instrument track 
views are useful for editing automation, control-
ler data, program changes, and Sysex events.

Video Tracks For information on video track 
views, see “Video Track View” on page 1174.

Blocks Tracks View
With the Track View set to Blocks, audio and 
MIDI clips are displayed as empty blocks bear-
ing the clip’s name. This Track View is most use-
ful once you have finished capturing and editing 
clips at the waveform or MIDI event level and 
are moving and rearranging them. Screen re-
draws are fastest with this format.



Playlists Tracks View
(Audio Tracks Only)

With the Track View set to Playlists, alternate 
playlists for audio tracks are revealed in Playlist 
lanes under the Main Playlist on the track. This 
view is useful for track compositing, letting you 
select the best parts from a track’s alternate 
playlists and copy them to the main playlist.

Analysis and Warp Tracks View
(Audio Tracks Only)

With the Track View set to Analysis or Warp, you 
can edit Elastic Audio analysis and warp mark-
ers on Elastic Audio-enabled tracks.

Waveform View
(Audio Only)

With the Track View set to Waveform, you can 
edit and arrange audio clips on audio tracks. 
Waveforms are time-domain representations of 
the audio data and can be shown as normal or 
rectified waveforms, and calculated using Peak 
or Power mode.

Track View set to Waveform for audio track

On audio tracks, the Waveform is also vis-
ible in Playlists, Analysis, Warp, and Au-
tomation views.
Clips View
(MIDI Only)

With the Track View set to Clips, you can edit 
and arrange MIDI clips on MIDI and Instrument 
tracks.

Notes View
(MIDI Only)

With the Track View set to Notes, you can insert 
and edit MIDI notes on MIDI and Instrument 
tracks.

Automation and Controller 
Views
When an audio or Instrument track is displayed 
as Volume, Pan, or another automated control, 
or when a MIDI or Instrument track is set to one 
of the continuous controller types (such as Vol-

ume or Pitch Bend), the data for that track ap-
pears in the form of a line graph with a series of 
editable breakpoints. The breakpoints can be 
dragged to modify the automation data, and new 
breakpoints can be inserted with the Pencil tool 
or a Grabber tool. MIDI and Instrument tracks 
also provide Velocity view for editing MIDI ve-
locities.

Track View set to Clips for MIDI track

Track View set to Pan for audio track
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Setting Track Views
To set the Track View:

 Click the Track View selector for the track and 
select the view from the pop-up menu.

The track displays the new view. If the track is 
part of an active Edit Group, all tracks in the 
group are set to the new view.

For details on inserting and editing control-
ler data for MIDI tracks, see “Continuous 
Controller Events” on page 697.

You can also edit automation and controller 
data in lanes below the track’s main playlist 
view. For details on editing automation 
data for audio tracks, see Chapter 45, “Au-
tomation.” 

Audio Track View selector

Auxiliary Track View selector
Pro Tools Reference Guide
Master Fader Track View selector

VCA Master Track View selector (Pro Tools HD and 
Pro Tools with Complete Production Toolkit only)

MIDI Track View selector

Instrument Track View selector



Changing Track Views
For audio, Auxiliary Input, MIDI, and Instru-
ment tracks, you can change to the next or pre-
vious Track View, or toggle between pre-defined 
common views.

Changing to Previous or Next Track View

When changing to the next or previous Track 
View, Track View list ordering is maintained as 
shown in the Track View selector.

To change to the previous or next Track View:

1  Click in the track you want to change. To 
change views on multiple tracks, Shift-click or 
drag the Selector tool to select additional tracks, 
or select a group.

2  Do one of the following:

• To change to the previous or next Track 
View on all selected tracks, press Con-
trol+Command (Mac) or Control+Start 
(Windows) and the Left or Right Arrow key.

– or –

• To change to the previous or next Track 
View on all tracks, press Command+Op-
tion+Control (Mac) or Control+Alt+Start 
(Windows) and the Left or Right Arrow key.

Track Views at the beginning of the list 
(such as Blocks for audio or MIDI tracks) 
cannot be changed to the previous Track 
View. Tracks Views at the end of the list 
(such as a MIDI controllers option) cannot 
be changed to the next Track View.
Toggling Common Track Views

The most common editing view for audio tracks 
are Waveform and Volume view. The most com-
mon editing views for MIDI and Instrument 
tracks are Notes and Clips view. Pro Tools pro-
vides an easy way to toggle these views.

To toggle Track Views on tracks containing the edit 
cursor (or an Edit selection):

1  Click in the track you want to toggle. To toggle 
multiple tracks, Shift-click or drag with the Se-
lector tool to select additional tracks.

2  Do one of the following:

• Press Start+Minus (Windows) or Con-
trol+Minus (Mac) on the alphanumeric 
keyboard.

– or –

• With Commands Keyboard Focus enabled 
(see “Keyboard Focus” on page 30), press 
Minus on the alphanumeric keyboard.

Audio tracks are toggled between Waveform and 
Volume view. MIDI and Instrument tracks are 
toggled between Notes and Clips view.

To toggle Track Views for all tracks, press 
Option+Control+Minus (Mac) or 
Alt+Start+Minus (Windows) on the 
alphanumeric keyboard.

To toggle Track Views for all tracks with 
Command Focus enabled, press 
Option+Minus (Mac) or Alt+Minus 
(Windows) on the alphanumeric keyboard.
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Master Views for Tracks
Audio, MIDI, and Instrument tracks have Track 
Views that act as “master.” When a track is dis-
played in its Master view, any edits performed 
apply to all data in the track. For instance, when 
an audio track is set to Waveform, copying and 
pasting affects not just the waveform informa-
tion, but all of the automation data as well. 

The Master view is based on the type of track, as 
follows:

• Audio tracks: Waveform and Blocks

• MIDI and Instrument tracks: Clips, Blocks, 
and Notes (when using the Selector tool)

Track Height
Tracks can be viewed in the Edit window at any 
of eight heights: Micro, Mini, Small, Medium, 
Large, Jumbo, Extreme and Fit To Window. 
Larger track heights are particularly useful for 
precise editing, especially for MIDI. Smaller 
track heights are useful for conserving screen 
space in a large session.

You can adjust track heights on an individual 
track basis or set all tracks to the same height. 
Track heights can be changed during playback.
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To set the Track Height, do one of the following:

 Click the small arrow to the left of the Track 
name to get the Track Height pop-up menu.

– or –

 Right-click on the vertical zoom scale just to 
the right of the track controls and choose the 
height from the pop-up menu.

The track is resized to the new height. If the 
track is part of an Edit Group, all tracks in the 
group are set to the new height.

To resize all tracks proportionally:

 Click Edit window Vertical Zoom In or Out 
button.

Track Height pop-up menu 

Press Control+Up/Down Arrow key (Mac) 
or Start+Up/Down Arrow key (Windows) to 
increase/decrease track height of any track 
that contains a selection or in which the edit 
cursor is currently placed.

Vertical Zoom In and Out buttons, Edit window



Continuously Variable Track 
Height
In the Edit window, you can continuously resize 
the Track Height of any given track by dragging 
the lower boundary of the Track Controls 
column. 

To resize the Track Height of any track in the Edit 
window:

 Drag the bottom line of any given track’s Track 
Controls column up or down. The cursor 
changes to indicate that you can resize the track.

The track’s Track Height changes incrementally.

Adjusting the Track Height of an audio track

Hold Command (Mac) or Control 
(Windows) while adjusting track height for 
continuous, non-incremental adjustments.

To continuously resize all tracks, Option-
drag (Mac) or Alt-drag (Windows).

To continuously resize all selected tracks, 
Option-Shift-drag (Mac) or Alt-Shift-drag 
(Windows).
Track Controls and Track Height
The Track Height affects how the various track 
controls appear in the Edit window. For in-
stance, when a track’s height is set to Small, 
most of the buttons are reduced in size.

When the Track Height is set to Mini or Micro, 
only controls for Record, Solo, and Mute appear, 
and the menus for Playlist, Track Timebase, 
Track Height, and Track View are accessed from 
the same selector.

When the Track Height is set to Medium, Large, 
Jumbo, or Extreme, all track controls are dis-
played at their full size.

Track Height set to Small

Track Height set to Mini

Track Height set to Large
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The Track List
The Track List (at the left of both the Mix and 
Edit windows) shows all tracks in the session. It 
allows you to show or hide a track in the Mix, 
Edit, MIDI Editor, and Score Editor windows. 
Even though a track is hidden, the material on 
the track will still play as part of the session. In-
active tracks appear in italics in the Track List.

Show/Hide Track List and Group 
List

To show (or hide) the Track List (and Group List), 
do one of the following:

 From the Edit window menu, select (or dese-
lect) Track List.

– or –

 Click the Show/Hide Track List/Group List View 
button in the Mix or Edit window.

The Track List can also be used to create 
new tracks when importing media from 
DigiBase. See “Importing Files with Drag 
and Drop” on page 335. 

Track List

Track List menu
Track name

Track Type icon

Track Color Code

Track Show/Hide
Pro Tools Reference Guide
Track List Menu
The pop-up menu at the top of the Track List 
provides commands that allow you to show or 
hide all tracks, tracks currently selected on-
screen, or specific types of tracks (audio, Auxil-
iary Input, Master Fader, MIDI, Instrument, 
VCA Master, or Inactive tracks). 

The Sort Tracks By command lets you set the 
track order according to Name, Type, Edit Group, 
Mix Group, or Voice. The sort order will be re-
flected in the Track List in the Mix, Edit, MIDI 
Editor, and Score Editor windows. 

Show/Hide Track List /Group List, in Edit Window

Show Only option



When a track that is a member of an active group 
is hidden from view, editing operations per-
formed on other members of the group in the 
Edit window will not affect the hidden track. In 
the Mix window, however, all operations other 
than record-enable will affect a hidden track 
that is a member of an active group.

The options in the Track List menu in the Score 
Editor window are different from the Mix, Edit, 
and MIDI Editor windows. For more informa-
tion, see “Track List” on page 742.

Showing and Hiding Tracks
The Mix and Edit windows are linked in terms of 
which tracks are shown or hidden. However, the 
Score Editor window and MIDI Editor windows 
are all unique in terms of which tracks are 
shown or hidden. For example, hiding a specific 
track in the Edit window also hides it in the Mix 
window, but not in the Score Editor or MIDI Ed-
itor windows. Also, hiding a specific track in a 
MIDI Editor window hides it only in that MIDI 
Editor window.

Sort Tracks By options

With Pro Tools HD, even if a track is 
hidden from view, its position relative to 
other tracks still affects its voiceable track 
playback priority (see “Voice Borrowing” on 
page 244 for details).
To hide a track, do one of the following:

 Click the Track Show/Hide icon in the Track 
List.

– or –

 In the Track List (or on the track channel 
strip), Right-click the track name and select 
Hide (or Hide and Make Inactive if the track is ac-
tive and you also want to make the track inac-
tive).

To show a track that is currently hidden, do one of 
the following:

 Click the Track Show/Hide icon in the Track 
List.

– or –

 In the Track List (or on the track channel 
strip), Right-click the track name and select 
Show (or Show and Make Active if the track is ac-
tive and you also want to make it active).

Shown track icon in the Track List

Hidden track icon in the Track List
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To show all tracks:

 Click the Track List menu and choose Show All 

Tracks.

To hide all tracks:

 Click the Track List menu and choose Hide All 

Tracks.

To show a range of tracks:

1  Select a range of hidden tracks in the Track 
List.

2  Click the Show/Hide icon of hidden track at 
the top of the Track List.

3  Shift-click the Show/Hide icon of hidden track 
at the bottom of the selection.

All tracks that occur between the first track se-
lected and the last track will also be selected.

You can also show all tracks by Option-click-
ing (Mac) or Alt-clicking (Windows) the 
Show/Hide icon of any track that is hidden.

You can also hide all tracks by Option-click-
ing (Mac) or Alt-clicking (Windows) the 
Show/Hide icon of any track that is shown.

To reorder tracks on-screen, drag the track 
names to new positions within the Track List 
or in the Mix or Edit window.

You can also select a range of tracks by mov-
ing the cursor to the left of the track names so 
the Marquee appears, and dragging around 
the track names you want to select.
Pro Tools Reference Guide
To show or hide a range of tracks in the Track List 
with the Marquee:

1  Move the cursor to the left of a track name un-
til the Marquee with a small “+” symbol appears.

2  Click on the track in the list and drag up or 
down over the Show/Hide icons (to show or hide 
the track and the tracks immediately above or 
below it).

To show or hide non-contiguous tracks:

 Click the Show/Hide icon for the tracks you 
want to show or hide.

Mix/Edit Groups and Hidden 
Tracks
In the Mix window, if a hidden track is part of an 
enabled group, all Mix window operations per-
formed on other members of the group also af-
fect the hidden track—with the exception of au-
dio or MIDI record-enabling. If you solo, mute, 
or automation write-enable a grouped track, any 
group members that are hidden are soloed, 
muted, or automation write-enabled as well. 

In the Edit window, however, editing operations 
performed on members of an enabled group do 
not affect hidden tracks that are also members of 
the enabled group. 

Clipping and the Track List
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

When a track, send, or plug-in clips, the Track 
List displays the track’s name in red. Both 
shown and hidden tracks display clipping indi-
cation. 



Track Numbering and Hidden 
Tracks
In the Mix and Edit windows, Track Position 
Numbers can include hidden tracks in their 
numbering sequence, or ignore them, as follows:

• Numbers are only assigned to tracks that are 
shown (when Track Position Numbers Stay with 

Hidden Tracks is not selected in the Display 
Preferences page). In this case, active tracks 
are then numbered sequentially. Hidden 
tracks are un-numbered.

– or –

• Tracks keep their Track Position Numbers 
even when hidden (when Track Position Num-

bers Stay With Hidden Tracks is selected in the 
Display Preferences page).

Track Name Right-Click 
Menu
(Mix Window, Edit Window, MIDI Editor 
Windows, or Track List)

When you Right-click a track name in the Mix 
window, Edit window, MIDI Editor windows, or 
the Track List, a pop-up menu provides access to 
the following commands:

Hide/Show Hides (or shows) the track (or se-
lected tracks if any).

Hide and Make Inactive Hides the track and 
makes it inactive (or selected tracks if any).

Make Active/Inactive Toggles the active status of 
the track (or all selected tracks in the Mix or 
Edit window only).

Scroll Into View Scrolls the track to the top of the 
Edit window or to the left of the Mix window.
Export MIDI (MIDI and Instrument Tracks 
Only) Exports the MIDI data from one or more 
MIDI or Instrument tracks to a standard MIDI 
file. For more information, see “Exporting MIDI 
Files” on page 350.

Coalesce VCA Master Automation (Pro Tools HD 
and Pro Tools with Complete Production Toolkit 
Only) Coalesces the VCA automation to the slave 
tracks of the VCA.

Coalesce Trim Automation (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
Only) Coalesces Trim automation on the track 
(or selected tracks if any).

Clear Trim Automation (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
Only) Clears Trim automation on the track (or 
selected tracks if any).

Locked (Video Track Only) Toggles the 
locked/unlocked status of the video track (or se-
lected video tracks if any).

New Opens the New Track dialog.

Rename Opens the Track Name dialog.

Duplicate Duplicates the track (or selected 
tracks if any).

Split Into Mono (Multichannel Tracks Only) 

Splits a multichannel track (or selected multi-
channel tracks if any) into their mono compo-
nent tracks.

Delete Deletes the track (or selected tracks if 
any).

MIDI Real-Time Properties (MIDI and Instrument 
Tracks Only) Opens the Real-Time Properties 
window for the track. 

Open in New MIDI Editor (MIDI and Instrument 
Tracks Only) Opens the track in a new MIDI Ed-
itor window. 
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Open in Score Editor (MIDI and Instrument Tracks 
Only) Opens the track in the Score Editor win-
dow.

Open in MIDI Event List (MIDI and Instrument 
Tracks Only) Opens the track in the MIDI Event 
List.

Notation Display Track Settings (MIDI and Instru-
ment Tracks Only) Opens the Notation Display 
Track Settings window for the track. Music no-
tation can only be viewed in the Score Editor or 
in MIDI Editor windows set to Notation view.

Expand Channels to New Tracks Expands multi-
channel audio files imported from a field re-
corder to new tracks, such that every channel re-
sides on its own mono audio track. Pro Tools 
also automatically conforms all expanded tracks 
to the edits in the guide (expanded) track. You 
can expand multichannel files to new tracks or-
dered by channel name, by channel number, by 
channel name and number, or by Timecode 
only.

Assigning Audio Inputs and 
Outputs to Tracks
Inputs for audio, Auxiliary Input, and Instru-
ment tracks can be assigned to audio interface 
channels or busses. Outputs for audio, Auxiliary 
Input, Master Fader, and Instrument tracks can 
also be assigned to audio interface channels or 
busses.

Input/output assignments for three mono audio tracks

Track Input 
set to Audio 2

Track Input 
set to Bus 2

Track set to 
No Input
Pro Tools Reference Guide
For stereo and multichannel surround tracks, 
inputs and outputs appear as stereo pairs and 
multichannel groups. The available inputs, out-
puts, and busses are defined as paths in the 
I/O Setup dialog (see Chapter 7, “I/O Setup”). 

Automatic Input and Output 
Assignments
When adding tracks to a new session, inputs are 
automatically assigned in ascending order. For 
example, if you have an audio interface with 
eight inputs, creating four new mono audio 
tracks will automatically add four audio tracks 
with inputs assigned to the first four paths de-
fined in the I/O Setup dialog. When creating ste-
reo tracks, inputs are automatically assigned to 
subsequent input pairs.

The outputs automatically assigned to new 
tracks are determined by the New Track Default 

Output Bus specified in the I/O Setup dialog.

Assigning Audio Inputs
(Audio, Auxiliary Input, and Instrument Tracks)

To assign an audio input of an audio, Auxiliary 
Input, or Instrument track:

1  In order to assign audio track inputs in the 
Edit window, select View > Edit Window > I/O.

2  In the Mix or Edit window, click the track’s In-
put Path selector and choose from the available 
audio interface channels and busses. Stereo and 
multichannel surround tracks have inputs avail-
able as pairs and multichannel groups.

The Input Path selector lets you route any audio 
input or any of the Pro Tools internal busses to 
an audio, Auxiliary Input, or Instrument track. 
The choices available in this pop-up menu are 



determined by the Input Path configuration in 
the I/O Setup. Inputs in use by another track ap-
pear bold in the Input Path selector pop-up 
menu.

To automatically assign all track inputs (of the 
same type and channel width) to unique ascending 
Input paths (cascading):

 Command-Option-click (Mac) or Control-Alt-
click (Windows) the Input Path selector of the 
left-most Input Path selector and select the first 
Input Path (mono or stereo, depending on 
whether your tracks are mono or stereo). 

All visible tracks of the same channel width 
(mono or stereo) are auto-assigned to unique 
Input Path assignments in ascending order. For 
example, Track 1 to A1, Track 2 to A2, Track 3 to 
A3, and so on.

To remove an input assignment:

 Select No Input from the Input Path selector.

Instrument tracks automatically assign the 
audio output from the instrument plug-in in-
serted on the track to the track audio Input.

‘

Input Path selector
Assigning Audio Outputs
(Audio, Auxiliary Input, Master Fader, and 
Instrument Tracks)

To assign an audio output of an audio, Auxiliary 
Input, Master Fader, or Instrument track:

1  In order to assign audio track outputs in the 
Edit window, select View > Edit Window > I/O.

2  In the Mix or Edit window, click the track’s 
Output Path selector and choose from the avail-
able audio interface channels and busses. Stereo 
and multichannel surround tracks have outputs 
available as pairs and multichannel paths.

The Output Path selector lets you route a track 
to any configured audio output or internal bus. 
The choices available in this pop-up menu are 
determined by the Output Bus Path configura-
tion in the I/O Setup. Outputs in use by another 
track appear bold in the Output Path selector’s 
pop-up menu.

Output Path selector

Command-Option-click (Mac) or Control-
Alt-click (Windows) the Output Path selec-
tor of the left-most track and select the first 
Output Path (mono or stereo). All visible 
tracks are automatically assigned to unique 
Output Bus Path assignments in ascending 
order. For example, Track 1 to A1–2, Track 
2 to A3–4, Track 3 to A5–6, and so on.
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To remove an output assignment:

 Select No Output from the Output Path selec-
tor. Playlists become dimmed for tracks with no 
output assignment.

Create and Assign New Track from 
Track Output

Pro Tools lets you create a new Auxiliary Input, 
Audio, or Instrument track from the Output se-
lector and automatically assign the Output of 
the original track to the Input of the new track 
using an available internal mix bus.

To create a new track from a track output:

1  On an existing track, click the Output selector 
for the track and select New Track.

2  In the New Destination dialog, select the 
Width, Type, and Time Base for the new track.

3  Type a Name for the new track.

4  Select (or deselect) whether you want the new 
track to be created next to the current track.

5  Click OK.

Assigning an audio track, Auxiliary Input, 
Master Fader, or Instrument track to “No 
Output” will cause its automation data for 
pan and plug-in controls to be lost. 

New Destination dialog
Pro Tools Reference Guide
Pro Tools creates a new track with the output of 
the originating track automatically routed to the 
input of the new track using an available inter-
nal mix bus. 

When creating a new internal mix bus, the new 
bus will be named after what you typed for the 
new track. For example, if you entered the name 
“Drum Sub,” Pro Tools creates a new Auxiliary 
Input track named “Drum Sub” and also creates 
an internal mix bus named “Drum Sub.”

New Auxiliary Input track with audio track output 
automatically assigned to Bus 1–2



Assign Existing Track from a Track Output

Pro Tools lets you assign the Output of a track to 
the Input of an existing track using an available 
internal mix bus. Note that the destination track 
must be set to either an internal mix bus or to No 

Input in order to be available for assignment.

To assign the output of a track to an available input 
on an existing track:

1  On an existing track, click the Output selector 
for a track and select Track.

2  From the Track submenu, select the destina-
tion track you want.

Pro Tools automatically routes the track or send 
to the input of the selected track using an avail-
able internal mix bus.

Assigning a track output to an existing Auxiliary Input 
track
Renaming Track Inputs and 
Outputs from the Edit or Mix 
Window
I/O path names can be renamed in the Edit or 
Mix windows, or in the I/O Setup.

To rename an I/O path in the Edit or Mix window:

1  In the Edit or Mix window, Right-click the In-
put selector or Output selector for a track, and 
choose Rename from the pop-up menu.

2  In the Rename I/O dialog, type a name for the 
I/O Path, and click OK.

Making Track Inputs and 
Outputs Inactive from the Edit 
or Mix Window
Track Input, Output, and Bus Path assignments 
can be made inactive using the corresponding 
selector on the track. Making a track’s Input or 
Output inactive silences that Input or Output, 
while retaining all automation and playlist data. 
For Pro Tools|HD systems, inactive Inputs and 
Outputs do not consume resources for TDM 
mixer connections, but any active assigned 
plug-ins on the track continue to use their re-
quired DSP resources. For Pro Tools host-based 
systems, inactive Inputs and Outputs do not 
consume host-processing resources. RTAS plug-
ins require CPU resources, and TDM plug-ins 
use the DSP available on Pro Tools|HD cards. 

‘

Rename I/O dialog
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You can make track inputs and outputs inactive 
(or active) directly from the Edit or Mix win-
dows. Inactive I/O Paths are grayed out.

To make a track’s Input or Output Path inactive (or 
active), do one of the following:

 In the Edit or Mix window, Right-click the In-
put selector or Output selector for a track, and 
choose Make Inactive (or Make Active) from the 
pop-up menu.

– or –

 Command-Control-click (Mac) or Control-
Start-click (Windows) the Input or Output selec-
tor in the Mix or Edit window.

To make all tracks’ Inputs or Outputs assigned to 
the same path inactive (or active), do one of the 
following:

 In the Edit or Mix window, Option-Right-click 
(Mac) or Alt-Right-click (Windows) the Input 
selector or Output selector for a track, and 
choose Make Inactive (or Make Active) from the 
pop-up menu.

– or –

 Command-Option-Control-click (Mac) or 
Control-Alt-Start-click (Windows) the Input or 
Output selector in the Mix or Edit window.

You can also make a path globally inactive 
(or active) in the I/O Setup dialog. See 
“Making Paths Active or Inactive” on 
page 107.
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To make all selected tracks’ Inputs or Outputs 
assigned to the same path inactive (or active), do 
one of the following:

 In the Edit or Mix window, Option-Shift-
Right-click (Mac) or Alt-Shift-Right-click (Win-
dows) the Input selector or Output selector for a 
track, and choose Make Inactive (or Make Active) 
from the pop-up menu.

– or –

 Command-Option-Control-Shift-click (Mac) 
or Control-Alt-Start-Shift-click (Windows) the 
Input or Output selector in the Mix or Edit win-
dow.

Toggling Multiple Paths

If a track has only one main output assignment, 
Command-Control-click (Mac) or Control-
Start-click (Windows) the track’s Output Path 
selector to toggle the main output to inactive. 
When there are multiple assignments, the track 
selector will be displayed for you to specify the 
Input, Output, Insert, or Bus Path. 

If a Send (A–J) has multiple Output Path as-
signments and one of those is toggled active 
or inactive, then all of the Output Path as-
signments for that Send (A–J) are toggled 
active or inactive.



Track Priority and Voice 
Assignment
Track priority and voice assignment are depen-
dent on your Pro Tools hardware and software 
configuration.

Pro Tools|HD systems provide a certain number 
of voices (simultaneous channels of audio play-
back and recording), depending on the system. 
For example, a Pro Tools|HD 1 system can pro-
vide up to 96 voices of audio playback and re-
cording, at 44.1 or 48 kHz. For details on 
Pro Tools system capabilities, see “Playback, 
Recording, and Voice Limits with Pro Tools 
HD” on page 49.

Pro Tools systems let you play or record up to 96 
simultaneous stereo or mono tracks. For details 
on system capabilities, see “Pro Tools Capabili-
ties with Different Hardware Configurations” 
on page 45.

Track Priority
While your Pro Tools hardware allows a fixed 
number of voices, Pro Tools software allows for 
additional audio tracks beyond that fixed num-
ber of voices. While all of these tracks can be re-
corded to or imported, arranged, and cued for 
playback, not all of them can be played back si-
multaneously. 

When the number of tracks exceeds the number 
of available voices, tracks with lower priority 
may not be heard. For these situations, 
Pro Tools assigns priorities to tracks that com-
pete for the available voices. Because there can 
be more tracks than available voices, Pro Tools 
provides multiple ways of adjusting the play-
back priority of audio tracks. See “Changing a 
Track’s Playback Priority” on page 241 and 
“Freeing up Voices on a Track” on page 242.
With Pro Tools|HD systems, you can assign spe-
cific voices to multiple tracks such that those 
voices are shared by more than one track. This 
feature is called voice borrowing. The combina-
tion of playback/record tracks and shared 
voiced tracks comprises the total number of 
voiceable tracks on a Pro Tools|HD system. 

To set multiple tracks to the same voice, see 
“Setting Voice Assignment” on page 242. For 
additional information on voice borrowing, 
see“Voice Borrowing” on page 244).

Changing a Track’s Playback Priority

Tracks with higher positions (leftmost in the 
Mix window or topmost in the Edit window) 
have priority over tracks in lower positions in a 
session. 

To increase a track’s priority, do any of the 
following:

 In the Mix window, drag the Track Name but-
ton to the left of other tracks in the session. 
Tracks at the left of the Mix window have higher 
priority than those on the right.

 In the Edit window, drag the Track Name but-
ton above other tracks in the session. Tracks at 
the top of the Edit window have higher priority 
than those below.

 In the Track List, drag the Track Name to a 
higher position in the list. Tracks at the top of 
this list have higher priority than those below.
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Freeing up Voices on a Track

You can also adjust the relative priority of tracks 
by freeing up the voices of individual tracks, 
making them available to other tracks in the ses-
sion. 

To free up the voice of a track, do one of the 
following:

 Click the Voice selector of the track and set it 
to Off. See “Setting Voice Assignment” on 
page 242.

 Deactivate the track by Control-Start-clicking 
(Windows) or Command-Control-clicking (Mac) 
its track type icon in the Mix window.

 Make sure the track does not have an Output 
Path or Send assignment. 

 With Pro Tools HD, you can temporarily free a 
track’s voice during playback by muting it (see 
“Mute Frees Assigned Voice” on page 250).

Setting Voice Assignment
A track’s voice assignment can be turned off or 
set to be dynamically allocated, and with 
Pro Tools HD, can also be explicitly assigned to 
a specific voice number.

On all Pro Tools systems, you can use Dynami-
cally Allocated Voicing to automatically take 
care of voice management in the background, 
assigning voices not in use by other tracks.

Pro Tools supports Dynamically Allocated 
Voicing only; it does not support explicit voice 
assignments.
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With Pro Tools HD, tracks assigned to a specific 
voice number take priority over dynamically al-
located tracks and support voice borrowing (see 
“Voice Borrowing” on page 244). To ensure that 
a track is heard, or that it is available for Quick-
Punch, TrackPunch, or DestructivePunch re-
cording, assign an explicit voice to that track.

For stereo and multichannel tracks, voices ap-
pear in pairs and multichannel groups. Voices 
already explicitly assigned to another track ap-
pear in bold in the Voice selector’s pop-up 
menu.

With Pro Tools HD, QuickPunch, Track-
Punch, and DestructivePunch require addi-
tional voices. For more information, see 
Chapter 24, “Punch Recording Modes.”

With Pro Tools HD, the initial insert of a 
Native (host-based) plug-in uses additional 
voices in certain situations. See “Voice Us-
age and Total Latency for Native (Host-
Based) Plug-Ins” on page 991.



To set the voice assignment for a track:

 Click the Voice selector and set the track to 
Dyn, Off, or select a voice number (Pro Tools HD 
only).

Voice selector for stereo audio track (Pro Tools HD 
shown)

Elastic Audio and RTAS plug-ins are not 
allowed on explicitly voiced tracks 
(Pro Tools HD only). Use Dynamically Allo-
cated Voicing for tracks on which you want 
to use Elastic Audio or RTAS plug-ins.
Voice Assignment with Complete 
Production Toolkit

Complete Production Toolkit lets you play or re-
cord up to 192 voices simultaneously at 44.1 or 
48 kHz and up to 96 voices at 88.2 or 96 kHz. 
Each channel of an audio track uses a single 
voice. For example, you can have up to 192 
mono audio tracks or up to 96 stereo audio 
tracks at 44.1 or 48 kHz. 

Maximum track counts are only supported with 
multiple hard drives and faster Avid-qualified 
systems.

Track Priority and Dynamic Voicing

The lowest-numbered (highest priority) audio 
tracks that are active and have their voice as-
signment set to DYN (Dynamically Allocated 
Voicing) are the tracks that play back. (The total 
number of tracks that play back depends on the 
maximum number of voiced audio tracks al-
lowed by your system.)

Tracks that are higher-numbered (lower prior-
ity) than these tracks do not play back and you 
cannot record to them. Their Dynamically Allo-

cated Voicing button are blue to indicate they are 
unavailable for playback or recording.

Tracks do not play back when they are inactive or 
their voice assignment is set to Off.
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When working with more than the maximum 
number of voiced audio tracks allowed by your 
system, you can only play back audio from 
higher-numbered (lower priority) tracks by 
changing the track priority by doing any of the 
following:

• Make a lower-numbered track inactive 
(click the Track Name and select Track > 

Make Inactive).

• Set the voice assignment in a lower-num-
bered track to Off (click the Voice selector 
and select Off).

• Drag the Track Name button of the higher-
numbered track to the left (Mix window) or 
upwards (in the Edit window or Track List) 
until it is in the range of the maximum 
number of voiced audio tracks allowed by 
your system. The previously last voiced au-
dio track is moved out of range and its voice 
assignment is changed to Off.

When the priority of the higher-numbered track 
is changed, its voice assignment is automatically 
changed from Off to DYN.

Automatic Assignment of Ascending 
Voices
(Pro Tools|HD Systems Only)

You can automatically assign all tracks or all se-
lected tracks to successive voices. For example, 
you may want to select eight audio tracks and re-
assign them to voices 9–16.

To assign all audio tracks to successive voices:

 While pressing Control+Alt (Windows) or 
Command+Option (Mac), select the starting 
voice number from the Voice selector for the 
track at the far left of the Mix window, or at the 
top of the Edit window.
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The voice is assigned to the first track, with suc-
cessive voices assigned to tracks (with the same 
format) of lower priority. 

To assign all selected audio tracks to successive 
voices:

1  Select the audio tracks by Control-clicking 
(Windows) or Command-clicking (Mac) their 
names.

2  While pressing Control+Alt+Shift (Windows) 
or Command+Option+Shift (Mac), select the 
starting voice number from the Voice selector 
for the left (Mix window) or top (Edit window) 
selected track.

The voice is assigned to the starting track, with 
successive voices assigned to currently selected 
tracks (with the same format) of lower priority. 

Voice Borrowing
(Pro Tools|HD Systems Only)

Pro Tools|HD systems feature voice borrowing, 
which lets you assign more than one track to the 
same voice. The track with the highest priority 
takes over that voice, but when a hole opens up 
in the higher-priority track, its shared voice is 
temporarily available, and the track with the 
next highest priority “sounds through” and be-
gins to play. When the original track returns, 
the track that had sounded through relinquishes 
the shared voice to the higher priority track. 

To select multiple tracks, Command-click 
(Mac) or Control-click (Windows) addi-
tional Track Names.

To select a range of tracks, Shift-click 
additional Track Names.



The following example demonstrates the con-
cept of voice borrowing:

In the figure above, the two visible tracks are as-
signed to the same voice. There is an open area 
in the top track where no clip appears. At this 
point, the voice is free since it is not being used, 
and the next highest priority track assigned to 
that voice (the bottom track) sounds through 
the open area and plays.

By experimenting with track priority, voice 
assignment, and arranging clips so that they are 
positioned to sound through holes in 
higher priority tracks, you can find many useful 
ways to maximize voiceable tracks with 
Pro Tools HD.

Assigning MIDI Inputs and 
Outputs to Tracks
MIDI recording and playback is supported with 
MIDI tracks and Instrument tracks.

MIDI ports in your system can be named and 
configured for use in Pro Tools (for Windows, 
see “Configuring MIDI Studio Setup” and for 
Mac, see “Configuring AMS”). 

“Rhythm” clips play only when there is no “Lead” clip
Assigning MIDI Track Input
Pro Tools lets you assign specific MIDI ports 
and channels to a MIDI track input. The default 
selection of All receives all incoming MIDI data 
from all ports on all channels. Use the MIDI In-
put selector to specify a MIDI port and channel 
for input.

To assign a MIDI track input:

 Click the track’s MIDI Input selector and as-
sign a port and channel for MIDI input. Chan-
nels already assigned to another track appear in 
bold.

For information on assigning MIDI input to 
Instrument tracks, see “Assigning MIDI In-
put and Output for Instrument Tracks” on 
page 246.

In the Edit window, select View > Edit 
Window > I/O to access any track’s Input se-
lector.

MIDI Input selector (MIDI Track shown)
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Assigning MIDI Track Output
Pro Tools lets you assign specific MIDI ports 
and channels to a MIDI track output. The de-
fault selection of none sends MIDI data to no 
port on any channel. Use the MIDI Output selec-
tor to specify a MIDI port and channel for out-
put.

To assign a MIDI track (and all its clips) to a 
specific MIDI device channel:

 Click the track’s MIDI Output selector and as-
sign a port and channel for MIDI output. Chan-
nels already assigned to another track appear in 
bold.

MIDI tracks in Pro Tools cannot contain 
multiple channels of MIDI data.

For information on assigning MIDI output 
to Instrument tracks, see “Assigning MIDI 
Input and Output for Instrument Tracks” 
on page 246.

In the Edit window, select View > Edit 
Window > I/O to access any track’s Output 
selector.

MIDI Output selector (MIDI track shown)
Pro Tools Reference Guide
To assign multiple destinations to a single MIDI 
track:

 Control-click (Mac) or Right-click (Mac or 
Windows) the MIDI Output selector and select 
additional channels from any device.

Assigning MIDI Input and Output 
for Instrument Tracks
Instrument tracks have a specific view for MIDI 
controls, including MIDI Input and Output se-
lectors.

To view Instrument track MIDI controls, do one of 
the following:

 Select View > Mix Window > Instruments.

– or –

 Select View > Edit Window > Instruments.

For information on recording and 
importing MIDI data, see Chapter 23, “MIDI 
Recording.”

In addition to assigning MIDI input and 
output for recording and playing back MIDI 
data, Instrument tracks can also be used to 
monitor the audio from your hardware 
MIDI instruments and instrument plug-ins. 
See “Signal Routing for Monitoring and 
Submixing” on page 970.

Instruments view, Mix window

MIDI Input selector

MIDI Output selector



Instrument Track MIDI Input

Pro Tools lets you assign specific MIDI ports 
and channels to an Instrument tracks’ MIDI in-
put. The default selection of All receives all in-
coming MIDI data from all ports on all channels. 
Use the MIDI Input selector to specify a MIDI 
port and channel for input.

Channels in use by another track input appear 
bold in the MIDI Input pop-up menu.

To assign an Instrument track MIDI input:

 Click the track’s MIDI Input selector and as-
sign a port and channel for MIDI input. Chan-
nels already assigned to another track appear in 
bold.

Instrument Track MIDI Output

Pro Tools lets you assign specific MIDI ports 
and channels to an Instrument tracks’ MIDI out-
put. The default selection of none sends MIDI 
data to no device, port, or node on any channel. 
Use the MIDI Output selector to specify a MIDI 
port and channel for output.

Channels in use by another track input appear as 
bold in the MIDI Input pop-up menu.

To assign an Instrument track MIDI output:

 Click the track’s MIDI Output selector and as-
sign a port and channel for MIDI output. Chan-
nels already assigned to another track appear in 
bold.
Soloing and Muting Tracks 
The Solo and Mute buttons can be engaged at 
any time during playback. The Solo and Mute 
buttons affect MIDI as well as audio tracks. It is 
possible to have more than one track soloed or 
muted at the same time in a session.

Track grouping also affects mute and solo be-
havior. Muting or soloing a track that is a mem-
ber of an active Mix Group will mute or solo all 
other tracks that are a member of that active Mix 
Group as well.

Soloing Tracks

To solo tracks:

1  Click the Solo button on a track. The button is 
highlighted and all other tracks are muted.

2  Click the Solo button on another track. The 
buttons for both tracks are highlighted and all 
other tracks are muted.

To un-solo tracks:

 Click the Solo button on soloed tracks.

Instrument tracks have separate sets of Solo 
and Mute buttons for MIDI and audio mon-
itoring.

For information on creating and modifying 
groups for track soloing and muting, see 
“Grouping Tracks” on page 255.
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Solo Button
The Solo button normally mutes other tracks so 
that the selected track can be auditioned inde-
pendently.

With Pro Tools HD, this behavior is selected as a 
Solo mode, called “Solo In Place.” Additional 
Solo modes are provided to change how the Solo 
button works. See “Solo Modes” on page 248.

Solo Modes
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

With Pro Tools HD and Pro Tools with Com-
plete Production Toolkit, the Solo button can be 
used to:

• Mute other tracks so that the selected track 
can be auditioned alone.

– or –

• Route a selected track to a separate output.

Solo button behavior is defined by the Solo 
mode, as follows:

SIP (Solo In Place) The Solo button mutes other 
tracks. When this mode is enabled, tracks can be 
solo safed (see “Solo Safe Mode” on page 250).

AFL (After Fader Listen) The Solo button routes 
the track’s post-fader/post-pan signal to the 
AFL/PFL Path output. The AFL/PFL Path is con-
figured in the Output page of the I/O Setup dia-
log (see “AFL/PFL Path” on page 94). 

With AFL, the level you hear is dependent on the 
fader level for that track. Additionally, there is a 
separate master level setting for AFL that affects 
the output of any or all tracks you solo in AFL 
mode (see “AFL/PFL Path” on page 94). This 
level setting is independent of the PFL level 
setting.
Pro Tools Reference Guide
PFL (Pre Fader Listen) The Solo button routes 
the track’s pre-fader/pre-pan signal to the 
AFL/PFL Path output. The AFL/PFL Path is con-
figured in the Output page of the I/O Setup dia-
log (see “AFL/PFL Path” on page 94). 

With PFL, the fader level and pan are ignored, 
and the level you hear is dependent on the sig-
nal’s recorded level. Additionally, there is a sep-
arate master level setting for PFL that affects the 
output of any or all tracks you solo in PFL mode 
(see “AFL/PFL Path” on page 94). This level set-
ting is independent of the AFL level setting.

To select a Solo mode:

1  Choose Options > Solo Mode.

2  Select SIP, AFL, or PFL.

AFL and PFL Solo modes require the 
Surround Mixer plug-in. 

Custom Pan Depth settings are unavailable 
when either AFL or PFL Solo mode is 
enabled.

If Mutes Frees Assigned Voice is enabled, 
muted tracks will not be audible in PFL 
mode.

The Solo mode for all soloed tracks can be 
changed “on-the-fly” from any Solo mode to 
either SIP or AFL. Previously soloed tracks 
will switch their solo behavior to the new 
mode.

Switching the Solo mode for all soloed tracks 
“on-the-fly” to PFL clears all previously so-
loed tracks before entering PFL mode. This 
prevents potentially large boosts in level.



DSP Usage when Using AFL or PFL Mode

AFL and PFL are accomplished by Pro Tools cre-
ating a “behind the scenes” mixer to route the 
signal to the chosen AFL/PFL Path. Depending 
on the size of your main mixer, Pro Tools will 
devote a substantial portion of its available DSP 
when using AFL/PFL mode.

Un-declaring the AFL/PFL Path will free up all 
DSP resources previously used for AFL/PFL 
mode.

Using AFL/PFL on Pro Tools Systems with a 
D-Control or D-Command

AFL/PFL is optimized for Pro Tools systems us-
ing a D-Control or D-Command control surface, 
where the XMON automatically switches its 
monitor source between the main output and 
the AFL/PFL output from Pro Tools.

Using AFL/PFL on Pro Tools Systems without 
D-Control or D-Command

If you are not using a D-Control or D-Command 
control surface, your regular Pro Tools output 
path is not necessarily muted when you send a 
signal to the AFL/PFL Path. If you need the main 
signal to automatically mute when an AFL/PFL 
signal is invoked, you need to do the following: 

1  Configure the output path for AFL or PFL so-
loed tracks.

2  Select the main output path that will mute 
when you solo a track in AFL or PFL mode (see 
“AFL/PFL Mutes (Output Path)” on page 95).

3  Set up your hardware to monitor both the main 
and AFL/PFL paths simultaneously.

For more information on using XMON and 
AFL/PFL, see your control surface guide.
When AFL or PFL is selected as a Solo mode and 
a track is soloed, the main output path will mute 
and the AFL/PFL signal will appear at the 
AFL/PFL Path for monitoring.

Solo Latch Options
Solos can be latched (where pressing subsequent 
buttons adds them to the soloed mix of tracks), 
unlatched, or temporarily latched (Pro Tools 
HD and Pro Tools with Complete Production 
Toolkit only).

To select a Solo Latch mode:

 Choose Options > Solo Mode and select from 
the following options:

Latch When selected, pressing subsequent Solo 
buttons adds them to the soloed mix of tracks.

X–OR (Cancels Previous Solos) When selected, 
pressing subsequent Solo buttons cancels previ-
ous solos.

Momentary (Pro Tools HD and Pro Tools with 
Complete Production Toolkit Only) When se-
lected, Solo buttons are not sticky. A track is so-
loed only when its Solo switch is held down.

With a qualified control surface, additional 
tracks can be soloed by pressing their SOLO 
switches (as long as at least one Solo button is 
held down). When no SOLO switch is held down, 
all soloed tracks will unsolo.

To override X–OR mode and solo more than 
one track at a time, press and hold the Solo 
button on the first track. Subsequently 
pressed Solo buttons will latch.
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Temporarily Latching Solos in Momentary 
Solo Mode

(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

To temporarily latch solos:

1  Choose Options > Solo Mode > Momentary.

2  Press and hold the Solo button on the first 
track that will be soloed.

3  While still holding the first Solo button, press 
additional Solo buttons. Solo buttons will re-
main soloed as long as one Solo button is held.

Solo Safe Mode
Pro Tools lets you solo safe a track. This pre-
vents the track from being muted even if you 
solo other tracks. This feature is useful for 
tracks such as Auxiliary Inputs that are being 
used as a submix of audio tracks, or effects re-
turns, allowing the audio or effects track to re-
main in a mix even when other tracks are soloed. 
It is also useful to solo safe MIDI tracks so that 
their playback is not affected when you solo au-
dio tracks.

To solo safe a track:

 Control-click (Windows) or Command-click 
(Mac) the Solo button on the track. This pre-
vents the track from being muted even if you 
solo other tracks. The Solo button changes to a 
transparent color in Solo Safe mode.

To return a solo safe track to normal:

 Control-click (Windows) or Command-click 
(Mac) the Solo button on the track again.

As long as at least one Solo button is held 
down, all the solos will remain latched.

AFL or PFL soloed tracks (Pro Tools HD 
only) cannot be solo safed.
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Mute Button
The Mute button silences a chosen track. More 
than one track can be muted at one time. If Op-

tions > Mute Frees Assigned Voice (Pro Tools HD 
only) is enabled, muting a track will allocate its 
voice to the next highest priority voiceable track 
(assigned to the same voice).

To mute a track:

 Click the Mute button on the track.

To unmute a track:

 Click the Mute button again.

Mute Frees Assigned Voice
(Pro Tools|HD Systems Only)

Selecting Options > Mute Frees Assigned Voice 
and muting a track disables playback of that 
track, and surrenders control of its voice to the 
next highest priority track with the same voice 
assignment.

With this option enabled, there may be a delay 
(ranging in length from one to several seconds 
depending on the processing power of your sys-
tem) between the time you mute or unmute a 
track and when you hear the effect on playback. 

Muting a track with Mute Frees Assigned 
Voice enabled does not free up the voice for 
QuickPunch, TrackPunch, or Destructive-
Punch recording.



MIDI Mute

The Mute button on a MIDI track mutes MIDI 
data, not audio. Muting MIDI results in no MIDI 
data being passed to the MIDI output. On In-
strument tracks, the track’s Mute button mutes 
the audio signal and the MIDI Mute button is 
only available in Instruments view.

Making Tracks Inactive
Audio, Auxiliary Input, Master Fader, VCA Mas-
ter (Pro Tools HD and Pro Tools with Complete 
Production Toolkit only), and Instrument tracks 
can be made inactive. Inactive tracks use no DSP 
or voices. Plug-Ins, sends, voices, and automa-
tion on inactive tracks are all disabled. Tracks 
may also be automatically made inactive if a ses-
sion is opened on a system with less DSP power 
than the system that it was created on.

To toggle a track active/inactive:

 Command-Control-click (Mac) or Control-
Start-click (Windows) the Track Type indicator 
in the Mix window.

Playlists for inactive tracks are dimmed and 
track controls are grayed out.

MIDI Mute button, Instruments view, Mix window

MIDI tracks cannot be made inactive.
To make one or more tracks inactive or active, do 
one of the following:

 Select the track and select Track > Make Inac-

tive/Active. 

– or –

 Right-click the Track Name in the Track List, 
or Mix or Edit windows and choose Make Inac-

tive/Active.

Color Coding for Tracks, 
Clips, Markers, and Groups
Separate colors can be assigned to audio and 
MIDI clips, tracks, markers, and groups. Clips 
shown in Waveform and Block Views in the Edit 
window are drawn in color. Tracks shown in the 
Track List, Group List, and Mix and Edit win-
dows have associated color bars.

Color Bars

Color coding at the track level is displayed using 
color bars, as follows:

Mix Window Track colors are displayed in hori-
zontal color bars that appear above each channel 
strip, and below the track name. 

Edit Window Track colors are displayed in verti-
cal color bars that appear to the left of each 
track.

Track List Track colors are displayed in vertical 
color bars that appear to the left of each track 
name.

To select multiple tracks, Command-click 
(Mac) or Control-click (Windows) addi-
tional Track Names.

To select a range of tracks, Shift-click the 
Track Names bounding the range of tracks 
you want selected.
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Group List Track colors are displayed in vertical 
color bars that appear to the left of each Group 
Name.

Default colors are automatically assigned to 
tracks, but you can override those colors by 
choosing from a color palette of 96 possible col-
ors. For more information, see “Color Palette” 
on page 253.

Display Page Preferences for 
Color Coding
Color Coding options determine how colors are 
assigned to the display of tracks and clips.

To change Color Coding options:

1  Choose Setup > Preferences.

2  Click the Display tab.

3  Select or deselect the Always Display Marker 

Colors option.

4  Select the MIDI Note Color Shows Velocity op-
tion.

5  Select or deselect the Apply Color Coding to 

Track Channel Strip option.

6  Select a Default Track Color Coding option.

7  Select a Default Clip Color Coding option.

8  Click OK.

Always Display Marker Colors

This option lets you view Marker colors in the 
Markers ruler, regardless of the option you 
choose for the Default Clip Color Coding option. 
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MIDI Note Color Shows Velocity

When this option is enabled, MIDI notes display 
varying shades of the assigned track color in 
MIDI notes view in the Edit window and in MIDI 
Editor windows. Notes with high velocities are 
darker and notes with lower velocities are 
lighter.

Default Track Color Coding

The Default Track Color Coding options deter-
mine how colors are assigned to the display of 
tracks. 

None Turns off default color assignment for 
tracks.

Tracks and MIDI Channels Assigns a color to 
each track in the Mix or Edit window according 
to its voice assignment or MIDI channel assign-
ment.

Tracks and MIDI Devices Assigns a color to each 
track in the Mix or Edit window according to its 
voice assignment or MIDI device assignment.

Groups Assigns a color to each track according 
to its Mix or Edit Group ID. If groups are sus-
pended using the Suspend Groups command, the 
tracks color bars are not shown.

Track Type Assigns a color to each track accord-
ing to its type (audio, Auxiliary Input, Master 
Fader, VCA Master, MIDI, Instrument, or 
video).



Default Clip Color Coding

The Default Clip Color Coding options determine 
how colors are assigned to the display of tracks, 
clips in the track playlist and Clip List, and 
Marker Locations. 

None Turns off default color assignment for 
clips. Clips are drawn as black waveforms or 
black MIDI notes on a light gray background.

Tracks and MIDI Channels Assigns a color to 
each clip in the Edit window according to its 
voice or MIDI channel assignment.

Tracks and MIDI Devices Assigns a color to each 
clip in the Edit window according to its voice as-
signment or MIDI device assignment.

Groups Assigns a color to each clip according to 
the Group ID of its track. If groups are sus-
pended (using the Suspend Groups command) 
all clips display black waveforms or MIDI notes 
on a light gray background.

Track Color Assigns a clip color based on the 
color assigned to the track. (See “Color Palette” 
on page 253.)

Marker Locations Assigns a unique color to each 
marker area in the Marker ruler, including the 
area preceding the first marker.

Clip List Color Assigns a color to each clip based 
on its color in the Clip List. When this Default 

Clip Color Coding option is enabled, the assigned 
clip color is maintained even if the clip is placed 
in a track set to a different color coding. 

Enabling any Default Clip Color Coding op-
tion other than Clip List Color will override 
Clip List Color and reassign the parent track 
color to copies of the clip placed in tracks. 
Copies of the clip in the Clip List will retain 
their unique color.
Color Palette
The Color Palette lets you make color selections 
for tracks, clips, groups and markers. 

The Color Palette supports independent clip 
color coding in the Clip List and in tracks.

To apply a color from the Color Palette:

1  Choose Window > Color Palette.

2  Do one of the following:

• In the Apply to Selected pop-up menu, se-
lect the destination for color coding: 
Tracks, Marker, Group, Clips in Tracks, or 
Clips in Clip List.

– or –

• Select a track, marker, group, track clip, or 
Clip List clip in the appropriate Pro Tools 
window. The Apply to Selected menu will 
display the type of item you have selected.

Color Palette window

If selecting a marker does not display the 
Marker option in the Apply to Selected 
pop-up menu, then the Always Display 
Marker Colors option in the Display Prefer-
ences page is deselected. See “Always Dis-
play Marker Colors” on page 252 for more 
information.

Apply to Selected

Hold

Default
NoneApply to Channel Strip

Saturation

Last assigned color

Brightness
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3  Select a color from the palette, or select one of 
the following:

Default Removes any custom coloring and re-
stores the color to the default color orientation. 
See “Display Page Preferences for Color Coding” 
on page 252 for more information.

None Turns off color assignment. Affected clips 
are drawn with black waveform or MIDI notes 
on light gray background. Affected tracks and 
groups no longer show their color bars.

Using the Hold Button 
The Color Palette provides a Hold button to sim-
plify the process of assigning the same colors to 
multiple items (such as track and clips).

By default, the Hold button is off. When off, the 
Color Palette automatically highlights the as-
signed color (if any) of items as you select them. 

When the Hold button is enabled, the assigned 
color selected in the Color Palette persists and 
does not change when a different track or clip is 
selected. 

To use the Hold button to assign the same color to 
multiple items: 

1  Click the Hold button to enable it. The Hold 
button becomes white, and the currently se-
lected color is now highlighted with a wider 
white outline. 

2  Select additional tracks or clips to which you 
want to assign the same color. Because the Hold 
button is enabled, the Color Palette does not fol-
low item selection; it remains (or “holds”) at the 
last currently assigned color. 

3  Click the assigned color again to assign it to 
the new selection of tracks or clips. Use the Apply 

to Selected pop-up menu to determine which se-
lected elements are affected. 
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4  To turn off Hold and return the Color Palette to 
its default mode, click the Hold button until it 
turns off. 

Applying Track Color Coding to 
Channel Strips
The Color Palette lets you apply the Track color 
coding to channel strips in the Mix and Edit 
windows.

To apply track color coding to channel strips:

1  Enable the Apply to Channel Strip button.

2  If necessary, adjust the Saturation slider to get 
the color saturation you want. 

3  If necessary, adjust the Brightness slider. 

Color Coding applied to channel strips, Mix window



Chapter 14: Grouping Tracks
Pro Tools provides a relative grouping function 
for linking tracks and their controls. 

Grouping Tracks
Groups are useful for editing several tracks in 
exactly the same way, or for mixing several 
tracks (such as a pair of stereo tracks or a sub-
mix) while keeping them at the same relative 
volume level. 

Pro Tools provides the following grouping 
features:

• Up to 104 different groups are available, ar-
ranged in 4 banks of 26 Group IDs.

• Groups can be nested (subgroups within 
groups).

• Grouped faders or controllers preserve 
their levels relative to each other.

• Groups are assignable to an available VCA 
Master track (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only).

Mix Groups, Edit Groups, and 
Mix/Edit Groups
Mix Groups only affect mixing functions and 
Edit Groups only affect editing. Mix/Edit 
Groups link the grouping functions of the Mix 
Group and the Edit Group.
Edit Groups

Edit Groups affect the following items in the 
Edit and MIDI Editor windows:

• Track View

• Track Height

• Track Timebase

• Audio and MIDI editing functions

• Automation editing functions

Mix Groups in Pro Tools HD and 
Pro Tools with Complete Production 
Toolkit

Mix Groups in Pro Tools HD and in Pro Tools 
with Complete Production Toolkit can be set to 
affect the following items:

• Main Mute

• Solo

• Send Level 

• Send Mute

• Main Volume

• Main Pan

• Main LFE Level

• Record Enable

• Input Monitoring (Pro Tools HD only)

• Automation Mode

• Send Pan

• Send LFE Level

• Plug-In Controls

• Plug-In Bypass
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Mix Groups in Pro Tools

Mix Groups in Pro Tools always affect the fol-
lowing:

• Main volume

• Automation mode

Mix Groups in Pro Tools can also be set to affect 
the following:

• Main Mute

• Solo

• Send Level 

• Send Mute

Grouping Limitations

Grouping does not affect these parameters:

• Voice assignment

• Output assignment

• Inserting plug-ins

• Elastic Audio plug-ins

In Pro Tools HD and Pro Tools with Com-
plete Production Toolkit, when the Main 
Pan attribute is enabled for groups, grouped 
behavior applies to the Link, Front inverse, 
Rear inverse and Front/Rear inverse controls 
in stereo and multichannel panner windows.
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Selectable Group Attributes
You can select which parameters, or attributes, 
are linked in groups by the following methods:

• By making the group an Edit Group, a Mix 
Group, or both (Mix/Edit Group).

• With Mix and Mix/Edit Groups, by selecting 
from a list of attributes for the group.

• With Mix Groups in Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
only, by choosing whether the selected attri-
butes apply globally to all groups or to indi-
vidual groups.

Linking Mix and Edit Groupings

The Link Mix and Edit Group Enables option links 
group enabling between the Mix and Edit win-
dows. 

Pro Tools allows you to create groups that are 
both Mix and Edit Groups, but in some cases you 
may prefer not to link enabling of Mix and Edit 
Groups. For example, when you are using the 
Mix window for mixing, you may prefer to work 
with large, nested groups. However, in the Edit 
window or a MIDI Editor window, you may want 
to perform editing tasks within a smaller group. 
Disabling the Link Mix and Edit Group Enables 
preference lets you work with different groups 
in the two windows.

To unlink Mix and Edit Groups:

1  Choose Setup > Preferences and click the Mix-

ing tab. 

2  Deselect the Link Mix and Edit Group Enables 
option. 

3  Click OK.



Mix Groups and VCA Masters
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

An existing Mix Group can be assigned to a VCA 
Master, or a new Mix Group can be assigned to a 
VCA Master while it is being created. Only one 
group can be assigned to a VCA Master at a time. 
A VCA Master cannot control a group that in-
cludes itself.

Group Controls
Menus and commands for creating and modify-
ing groups are accessible in the following:

• Group List

• Group name in the Group List

• Group ID indicator on a track

• Track > Group menu

The Group List
The Pro Tools track grouping functions are lo-
cated at the left side of the Mix, Edit, and MIDI 
Editor windows in the Group List. This scrolling 
window contains the names of all the groups in 
your session, as well as a pop-up menu for ac-
cessing grouping commands. From this menu, 
you can select and enable groups.

By default, every session has a group named All, 
which includes every track in the session. The 
All group cannot be edited or deleted.

For information on assigning groups to VCA 
Masters, see “Assigning Groups to VCA 
Masters” on page 947.
Show/Hide Track List/Group List View 
Button

To show the Group List (and Track List):

 Click the Show/Hide Track List/Group List 
View button in the Mix, Edit, or MIDI Editor 
window.

Group ID

To the left of each name in the Group List is a 
letter denoting its Group ID (“a” through “z”).

Group List

Group List menu
Click to 
select a 
group by 
typing its 
letter

Click to 
activate a 
group 

Click to 
select 
group 
members 
on-screen

Show/Hide 
Group List

Group IDsColors
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Group Symbols

To the left of each Group ID (“a” through “z”) is 
a symbol indicating whether that group is se-
lected in the current window (either the Mix or 
Edit window). There are three types of Group 
symbols, as shown in the following figure:

The Group symbols indicate the following:

Filled-in Circle Indicates that all members of the 
group are currently selected, and no members 
from outside the group are selected

Hollow Circle Indicates that only some members 
of the group are currently selected

Circle with a Dot Indicates that all members of 
the group are currently selected, plus additional 
members outside the group

Group List Menu

The pop-up menu at the top of the Group List 
provides the following commands:

New Group Executes the Track > Group com-
mand.

Display Provides commands to show Edit groups 
only, Mix groups only, or all groups (Edit, Mix, 
and Mix/Edit).

Suspend All Groups Suspends group behavior 
for all Mix and Edit groups.

Modify Groups Opens Group dialog to modify 
existing groups only.

Group Symbols

Hollow Circle

Filled In Circle

Circle with a Dot
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Delete Active Groups Deletes only currently ac-
tive groups.

Group Name and Track Group ID 
Indicator Pop-Up Menus
When you click and hold on a group name in the 
Group List (or Right-click), or click a Group ID 
indicator in a track, a pop-up menu provides the 
following commands:

Tracks Displays track membership in group.

Attributes Displays attributes of group.

Modify Opens Group dialog to modify existing 
groups only.

Duplicate Opens Group dialog for duplicated 
group.

Delete Deletes a single group.

Select Tracks in Group Selects tracks in the 
group.

Show/Hide Tracks in Group Shows or hides 
tracks in the current group.

Show Only Tracks in Group Shows only the 
tracks in the group and hides all other tracks.

Group List menu



Show All Tracks Shows all tracks in the session.

Group Dialog 
Whether you are creating or modifying groups 
with the Group List, a tracks’s Group ID indica-
tor, or the Track > Group menu command, you 
use the Groups dialog.

The Group dialog lets you create new groups and 
assign attributes to groups.

Group Name pop-up menu

Group ID indicator pop-up menu
Group Dialog in Pro Tools HD and 
Pro Tools with Complete Production 
Toolkit

In Pro Tools HD and Pro Tools with Complete 
Production Toolkit, the Group dialog has three 
pages:

Tracks Lets you add and remove tracks from the 
current group.

Attributes Lets you select which parameters are 
linked for the current Mix or Mix/Edit Group.

Globals Lets you select parameters to use as a 
template that can be applied to individual 
groups by selecting the Follow Globals option.

Group dialog (Pro Tools HD and Pro Tools with 
Complete Production Toolkit
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Group Dialog in Pro Tools

In Pro Tools, the Group dialog has a single page.

Working with Groups

Creating Groups
You can select the tracks you want to add to a 
group before creating it, or add and remove 
tracks from a group after it has been created.

Creating Groups in Pro Tools HD and 
Pro Tools with Complete Production 
Toolkit

To create a group in Pro Tools HD or Pro Tools 
with Complete Production Toolkit:

1  Select the tracks you want to include in the 
group. (If you do not select tracks at this time, 
you can add tracks later.)

Group dialog (Pro Tools)
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2  Do one of the following:

• Choose Track > Group.

– or –

• Choose New Group from the Group List 
menu.

3  Type a name for the group.

4  Select the type of group to create: Edit, Mix, or 
Mix/Edit.

5  Choose a Group ID from the ID pop-up menu. 
Four banks of 26 are available: a–z, 2a–z, 3a–z, 
4a–z. (If you do not choose a Group ID, 
Pro Tools automatically assigns the next avail-
able ID to a new group.) 

Selecting a Group Type

Choosing a Group ID



6  Click Tracks in the Group dialog, and do any of 
the following:

• To add the tracks that are currently selected 
in the session to the group, click the Add 
button at the bottom of the Group dialog.

• To add tracks to the group, select the track 
names in the Available track list, and click 
Add or press A on the computer keyboard.

• To remove tracks from the group, select the 
track names in the Currently In Group list, 
and click Remove or press R on the com-
puter keyboard.

• Double-click track names in either list to 
move them to the opposite column.

• To replace all tracks in the group with the 
tracks that are currently selected in the ses-
sion, click the Replace button at the bottom 
of the Group dialog.

Selecting track names to add to a group

In either list, Shift-click to select a range of 
track names. Control-click (Windows) or 
Command-click (Mac) to select discontigu-
ous track names.
7  If the group is a Mix Group or a Mix/Edit 
Group, do the following:

• Set the Attributes for the Group (see “Set-
ting Group Attributes” on page 264).

• If you want to assign the group to an avail-
able VCA, select the VCA Master track from 
the VCA pop-up menu.

8  Click OK.

Creating Groups in Pro Tools

To create a group in Pro Tools:

1  Select the tracks you want to include in the 
group. (If you do not select tracks at this time, 
you can add tracks later.)

2  Do one of the following:

• Choose Track > Group.

– or –

• Choose New Group from the Group List 
menu.

3  Type a name for the group.

4  Select the type of group to create: Edit, Mix, or 
Mix/Edit.

5  Choose a Group ID from the ID pop-up menu. 
Four banks of 26 are available: a–z, 2a–z, 3a–z, 
4a–z. (If you do not choose a Group ID, 
Pro Tools automatically assigns the next avail-
able ID to a new group.) 

Choosing a VCA track to control a group
Chapter 14: Grouping Tracks 261



262
6  Do any of the following:

• To add the tracks that are currently selected 
in the session to the group, click the Add 
button at the bottom of the Group dialog.

• To add tracks to the group, select the track 
names in the Available track list, and click 
Add or press A on the computer keyboard.

• To remove tracks from the group, select the 
track names in the Currently In Group list, 
and click Remove or press R on the com-
puter keyboard.

• Double-click track names in either list to 
move them to the opposite column.

• To replace all tracks in the group with the 
tracks that are currently selected in the ses-
sion, click the Replace button at the bottom 
of the Group dialog.

7  Select the items to be Linked Within Groups 
(Mutes, Solos, Send Mute, Send Levels).

8  Click OK.

In either list, Shift-click to select a range of 
track names. Control-click (Windows) or 
Command-click (Mac) to select discontigu-
ous track names.

Linked Within Groups options (Pro Tools)
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Modifying Groups

To modify a group:

1  Do one of the following:

• Choose Modify Groups from the Group List 
menu. 

• In the Mix window, click the Group ID indi-
cator on a track and choose Modify from the 
pop-up menu. 

• Right-click the Group name in the Group 
List and choose Modify from the pop-up 
menu.

2  In the Groups dialog, choose the group you 
want to modify from the ID pop-up menu.

3  Change any of the following for the current 
group:

• Group name

• Group type (Edit, Mix, or Mix/Edit)

• VCA status (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

• Follows Global status (Pro Tools HD and 
Pro Tools with Complete Production Tool-
kit only)

• Track membership

• Attributes (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

• Linked Within Group items (Pro Tools HD 
and Pro Tools with Complete Production 
Toolkit only)

4  Click OK.



To modify the settings for the “All” group in 
Pro Tools HD and Pro Tools with Complete 
Production Toolkit:

1  Right-click the “All” group name in the Group 
List and choose Modify from the pop-up menu.

2  In the Group dialog, select Edit, Mix, or Mix/Edit 
to change the settings for the “All” group. If you 
select Edit only or Mix only, the “All” group will 
apply only to that Group type. 

3  For Mix or Mix/Edit Groups, you can change 
any of the following:

• Follows Global status

• Attributes

4  Click OK. 

Modify ALL Group dialog
To modify the settings for the “All” group in 
Pro Tools:

1  Right-click the “All” group name in the Group 
List and choose Modify from the pop-up menu.

2  In the Group dialog, select Edit, Mix, or Mix/Edit 
to change the settings for the “All” group. If you 
select Edit only or Mix only, the “All” group will 
apply only to that Group type. 

3  For Mix or Mix/Edit groups, you can change 
any of the following Linked Within Groups op-
tions:

• Mutes 

• Solos 

• Send Mutes 

• Send Levels 

4  Click OK. 

Deleting Groups
One or all groups can be deleted at a time.

To delete a single group, do one of the following:

 In the Mix window, click the Group ID indica-
tor on a track and choose Delete from the pop-up 
menu. 

– or –

 Right-click the Group name in the Group List 
and choose Delete from the pop-up menu.

Modify ALL Group dialog

Deleting a group cannot be undone.
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To delete all currently active groups

 Choose Delete Active Groups from the Group 
List menu. 

Duplicating Groups
You can duplicate a group and modify its set-
tings in order to quickly set up a mix. 

To duplicate a group:

1  Do one of the following:

• Click the Group ID indicator on a track and 
choose Duplicate from the pop-up menu. 

– or –

• Right-click the Group name in the Group 
List and choose Duplicate from the pop-up 
menu.

2  Change any of the following for the current 
group:

• Group name

• Group type (Edit, Mix, or Mix/Edit)

• VCA status (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

• Follows Global status (Pro Tools HD and 
Pro Tools with Complete Production Tool-
kit only)

• Track membership

• Attributes (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

• Linked Within Group items (Pro Tools only)

3  Click OK. 

The “All” group cannot be deleted.
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Setting Group Attributes
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

When creating a Mix Group or a Mix/Edit 
Group, you can select the Mix window parame-
ters that will be linked for that group. These 
linked parameters are the attributes of the 
group.

You can select attributes in the Globals page and 
then set individual groups to follow the Global 
settings, or you can select attributes for groups 
individually. 

Selecting Attributes in the 
Global Page

To select attributes in the Global page:

1  While creating or modifying a group, click 
Globals in the Group dialog.

Globals page of Group dialog



2  Select the base set of attributes for groups in 
your session. 

3  Click OK to save the group and the new Globals 
settings.

To select attributes for an individual group:

1  While creating or modifying a Mix Group or a 
Mix/Edit Group, do one of the following:

• Click Attributes in the Group dialog, and 
select the attributes you want to link. 

– or –

• Enable Follow Globals to follow the base set 
of attributes. The Attributes page grays out 
to indicate that the group is following the 
selections in the Globals page.

For information on selecting attributes, see 
“Selecting Group Attributes” on page 265.

For information on selecting attributes, see 
“Selecting Group Attributes” on page 265.
2  Click OK to save the settings.

Selecting Group Attributes
The following attributes can be selected for 
Global settings and for individual groups.

Track controls:

• Main Volume

• Main Mute

• Main Pan

• Main LFE Level

• Record Enable

• Input Monitoring

• Solo

• Automation Mode

Attributes page of Group dialog
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Send controls (Sends A–J):

• Send Level

• Send Mute

• Send Pan

• Send LFE Level

Insert controls (Inserts A–J):

• Plug-In Controls

• Insert Bypass

To select the attributes for a group, do any of the 
following:

 Select individual attributes by clicking their 
checkboxes.

 To select or deselect all attributes, Alt-Shift-
click (Windows) or Option-Shift-click (Mac) any 
attribute.

 To select or deselect all attributes for a single 
Send or Insert (across a row), Start-click (Win-
dows) or Control-click (Mac) any attribute in 
that row. 

 To select or deselect attributes for a single 
control across all Sends, all Inserts, or for the 
four track controls (down a column), Alt-click 
(Windows) or Option-click (Mac) any attribute 
in that column. 
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Saving Group Attribute Presets
You can define six Group presets that can be re-
called on either the Attributes or Globals page 
whenever you are creating or modifying a Mix or 
Mix/Edit Group. 

To save the current attribute settings as a Group 
preset:

1  In the Groups dialog, click Save. (Follow 
Globals must be unchecked to save a setting 
from the Attributes page.)

2  In the Save Group Settings dialog, select one of 
the six preset locations from the Location pop-up 
menu, and click Save.

To recall a Group preset:

 Click the corresponding Preset button (1–6) in 
the Groups dialog. (Follow Globals must be un-
checked to recall a setting in the Attributes 
page.)

Saving a Group preset

Selecting a Group Settings Location 

To save the current attribute settings 
directly to a preset location, Control-click 
(Windows) or Command-click (Mac) the 
preset button.

Recalling a Group preset



Enabling Groups
Editing operations are not applied to members 
of a group that are hidden with the Track List. 
Mix operations (with the exception of record-
enabling of tracks) are applied to hidden tracks.

Pro Tools lets you create separate groups for ed-
iting and mixing. You set this option when you 
use the New Group command. Groups that apply 
to both editing and mixing can be decoupled.

To enable a group:

 In the Group List, click the name of the group 
you want to enable. The name is highlighted to 
indicate that it is enabled.

To enable additional groups, click their names 
in the Group List. 

Moving a fader of a group member causes all 
other group members to move relative to it. If a 
fader belongs to multiple groups, and the groups 
conflict when faders are moved, the fader will 
follow the top-most or “parent” group to which 
it belongs.

To disable a group:

 In the Group List, click the name of the group 
you want to disable. The name is unhighlighted 
to indicate that it is not enabled.
Keyboard Selection of Groups
The Group List Keyboard Focus lets you type a 
Group ID letter to automatically toggle that 
group’s enable status.

 In the Mix window, the Group List Keyboard 
Focus is always enabled. 

 In the Edit window, you need to enable the 
Group List Keyboard Focus to use it.

To enable the Edit Group List Keyboard Focus, do 
one of the following:

 Click the Keyboard Focus button in upper 
right of the Edit Group List.

– or –

 Press Control+Alt+3 (Windows) or Com-
mand+Option+3 (Mac).

To enable and disable groups using the Edit and 
Mix Group List Keyboard Focus:

 With Group List Keyboard Focus enabled, type 
the Group ID letter (a–z) to automatically enable 
or disable the corresponding group.

Group List Keyboard Focus enabled
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Temporarily Isolating Control of 
an Item from Group Operation
You can temporarily isolate control of a group 
item from group operation by Right-clicking on 
the item.

The following items can be isolated from group 
operation:

• Pan slider (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

• Channel Record Enable (Pro Tools HD and 
Pro Tools with Complete Production Tool-
kit only)

• Channel TrackInput (Pro Tools HD only)

• Send Pan slider 

• Channel Volume fader

• Channel Pan slider

• Channel Mute button

• Channel Solo button

• Channel Record Enable button

• Channel TrackInput button

• Send fader

• Send Pan slider

You can also temporarily suspend group 
behavior for a track by Control-clicking 
(Mac) or Start-clicking (Windows) a group 
function.
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Grouped Control Offsets
When the following controls are grouped with 
offsets and moved to their extremes, relative 
offsets are preserved when the controls are 
moved back from their extremes:

• Main Volume

• Main Pan (Pro Tools HD and Pro Tools with 
Complete Production Toolkit only)

• Send Level

• Send Pan

For example, when a grouped Volume fader is 
moved to its maximum value, any other faders 
in that group that had higher values will remem-
ber their relative offset whenever the first fader 
is pulled down again.

In Automation views, this “overflow” is indi-
cated on the automation playlist by blue auto-
mation breakpoints at the extremes of the auto-
mation playlist.

Setting Group Pan Controls to 
Ignore Offsets
By default, offsets are preserved for grouped pan 
controls. In some workflows, it is desirable to 
have grouped pan controls match absolute val-
ues rather than preserve offsets.

To set grouped pan controls to ignore offsets:

1  Choose Setup > Preferences and click the Mix-

ing tab.

2  Select the Use Absolute Pan Linking option.

When this option is enabled, grouped pan con-
trols will snap to the absolute value of the pan 
control that is being adjusted.



Chapter 15: The Clip List
The Edit Window displays all audio clips, MIDI 
clips, and clip groups in a single, comprehensive 
Clip List. 

All clips of all types that are recorded, imported, 
or created by editing appear in the Clip List. 
Items can be dragged from the list to tracks and 
arranged in any order. You can also preview au-
dio and MIDI clips and clip groups in the Clip 
List.

Clip List

Click Show/Hide Clip List button 
to hide Clip List

Drag to resize width 
of Clip List

Clip List menu

Keyboard Focus
Because clip information can become lengthy, 
the Clip List can be scrolled or resized as neces-
sary. 

Clip List Menu
The Clip List menu provides tools to search, se-
lect, sort, export, clear, and manage items in the 
Clip List.

To access the Clip List menu:

 In the Edit window, click the Clip List menu.

Use the Clip List as a bin for storing your fa-
vorite audio loops and MIDI clips. Save the 
session as a template and the clips are avail-
able for future sessions (see “Session Tem-
plates” on page 174).

Clip List menu
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Displaying Clips in the Clip List
The Clip List can show all clip types (audio, 
MIDI, video, Groups, Auto-Created), or only 
certain clip types. This is useful for isolating the 
type of clips you want to work with while editing 
and arranging. For example, when arranging 
clip groups, you may want the Clip List to show 
only clip groups.

To show or hide certain types of clips in the Clip 
List:

 Click the Clip List menu (at the top of the Clip 
List) and choose Show. From the submenu, se-
lect or deselect the clip type you want to show or 
hide. 

Audio Shows or hides audio clips in the Clip 
List.

MIDI Shows or hides MIDI clips in the Clip List.

Video Shows or hides video clips in the Clip List.

Groups Shows or hides clip groups in the Clip 
List.

Auto-Created Shows or hides automatically-cre-
ated clips (of all types) in the Clip List. These are 
clips that were created as a by-product of cut-
ting, pasting, and separating other clips. Since 
these auto-created clips can become numerous, 
hiding them (by deselecting the option) helps 
you to avoid scrolling through an unnecessarily 
long Clip List. 

In the Clip List, whole-file audio clips are dis-
played in bold, and stereo and multichannel au-
dio clips can be expanded to display individual 
channels.

Hiding Auto-Created clips can be useful 
when importing clip groups (or REX files as 
clip groups), because these file types can 
contain so many separate clips that it be-
comes difficult to read the Clip List.
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If the Clip List Selection Follows Edit Selection op-
tion is enabled in the Editing preferences, se-
lecting a clip or clip group in the Clip List selects 
it on any track where it is present in assigned 
playlists. Likewise, selecting a clip or clip group 
on a track selects it in the Clip List.

Displaying File Info for Audio 
Clips
In addition to clip names, the Clip List can also 
display information about the clip’s color cod-
ing, type (audio, MIDI, and clip group), time-
base, Elastic Audio processing, and parent file:

Color Displays Track Color Coding as assigned 
with Default Clip Color Coding option in Dis-
play Preferences page, or as assigned in the 
Color Palette.

Icon Displays the icon for audio and MIDI clips, 
and clip groups.

Timebase Displays the timebase (samples or 
ticks) for audio and MIDI clips, and clip groups.

Warp Indicator Displays the Warp Indicator icon 
if Elastic Audio processing has been applied to 
the clip.

File Name Displays the parent file name.

Disk Name Displays the name of the hard drive 
on which referenced file resides.

Full Path Displays the full directory path of the 
clip’s parent file.

Channel Name Displays the channel name for 
audio files imported from field recorders.

Scene and Take Displays the scene and take for 
audio files imported from field recorders.



Pro Tools displays only the clip name in the Clip 
List by default. 

Sorting and Searching in the 
Clip List
Most sessions will contain many clips, which 
can make it challenging to swiftly locate a par-
ticular clip in the Clip List. Pro Tools lets you 
sort and search clips in the Clip List to quickly 
locate any clip you want.

Sorting Clips

To sort clips in the Clip List:

1  Click the Clip List menu (at the top of the Clip 
List) and choose Sort By. 

2  From the submenu, select a basis for sorting. 
Different options are available for audio and 
MIDI clips. See “Sort By Options” on page 271.

3  To set whether clips are listed in ascending or 
descending order, click the Clip List menu, 
choose Sort By, and select Ascending or Descend-

ing.

Clips with file information shown in the Clip List

When editing, the Clip List can become clut-
tered with auto-created clips. You can hide 
auto-created clips by choosing Show in the 
Clip List menu, and deselecting Auto-Cre-
ated.
Sort By Options
The Sort By options let you sort clips to help 
keep track of large numbers of clips.

Audio clips can be sorted by:

• Clip Type

• Name

• Length

• Original Time Stamp

• User Time Stamp

• Timebase

• Start in Parent

• End in Parent

• File Name

• File Length

• File Creation Date

• File Modification Date

• Disk Name (audio and clip groups only

• Track Format/Width

• By Channel Name

• By Scene and Take

MIDI clips can be sorted by:

• Name, Length

• Original Time Stamp

• User Time Stamp

• Timebase

• Start in Parent

• End in Parent

Clips can also be sorted by Clip Type (Audio and 
MIDI), or in Ascending or Descending order.
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Finding Clips
Use the Find command to display all clips in a 
list whose names contain a particular word or 
phrase.

To find and display clips in the Clip List:

1  Do one of the following:

• Click the Clip List menu and choose Find. 

– or –

• Press Command+Shift+F (Mac) or Con-
trol+Shift+F (Windows).

2  In the Find Clips dialog, do any of the follow-
ing: 

• Select By Name and type the name, or any 
portion of the name, for clips you want to 
find. The search string appears at the top of 
the Clip List.

• Select Include Subsequently Added Clips to 
limit the display to newly added clips. A 
plus (+) sign appears at the top of the Clip 
List to indicate this option is selected.

• Select both options to start with a list of 
named clips and allow display of added 
clips.

Find Clips dialog
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Clips of any type whose name match the word or 
phrase you searched are displayed in the Clip 
List. The search string is displayed at the top of 
the Clip List in brackets. 

3  Click OK.

To repeat a previous search:

1  Click the Clip List menu, and choose Find.

2  Click the small arrow to the right of the text 
field in the Find dialog and select a text string 
from the Find History pop-up menu. 

The Find History is saved with the session. 

Found Clips in the Clip List

Text entered into the Find dialog is saved 
in a Find History, letting you quickly re-
peat previous searches with a minimum of 
retyping.

An example of a Find history



In addition to storing each text string previously 
entered, you can insert multiple entries into the 
Find History manually (without having to per-
form each Find in order to store words or 
phrases). 

To compile a Find History without performing each 
search:

1  Click the Clip List menu, and choose Find. 

2  Type the name, or any portion of the name, for 
the clips you want to find. 

3  Click and hold the double arrow to the right of 
the text field in the Find dialog and choose 
Insert Entry from the pop-up menu. 

4  Type another entry and choose Insert Entry 
again to add additional search strings to the 
history. 

To remove an entry from the history:

1  Select it from the Find History pop-up menu so 
it is displayed in the text field. 

2  Choose Remove Entry from the Find History 
pop-up menu. 

To clear the Find History:

 Choose Remove All Entries from the Find His-

tory pop-up menu. 

Clip List while searching
Selecting Clips in the Clip 
List
In the Clip List, you can select clips so they can 
be dragged to tracks, processed with AudioSuite 
plug-ins, or exported.

To select or deselect a clip in the Clip List, do the 
following:

 Click a clip name that is unhighlighted to se-
lect it.

– or –

 Click a clip name that is highlighted to dese-
lect it.

To select a range of clips in the Clip List, do one of 
the following:

 Move the cursor to the left of the clip names, 
so the Marquee appears, and drag around the 
clips you want to select.

– or –

 Click the name of a clip in the Clip List, and 
Shift-click an additional clip name.

All clips that occur between the first clip se-
lected and the additional clip will also be se-
lected.

Clips selected with Marquee
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To select or deselect a range of clips with the 
Marquee:

1  Move the cursor to the left of the clip name un-
til the Marquee icon with a small “+” symbol ap-
pears:

• To select clips, the Marquee should be to 
the left of an unhighlighted clip name.

• To deselect clips, the Marquee should be to 
the left of a highlighted clip name.

2  Click on the clip name and drag up or down (to 
select or deselect clips immediately above or be-
low the clip name).

To select or deselect noncontiguous clips, do one 
of the following:

 Command-click (Mac) or Control-click 
(Windows) clip names that are unhighlighted to 
select them.

– or –

 Command-click (Mac) or Control-click 
(Windows) clip names that are highlighted to 
deselect them.

Keyboard Selection of Clips
If Clip List Keyboard Focus is enabled, you can 
type the first few letters of a clip’s name and 
Pro Tools will automatically locate and select 
the clip in the Clip List.

To select multiple noncontiguous clips in 
the Clip List, press and hold Command 
(Mac) or Control (Windows) when making 
subsequent selections.
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To enable and use the Clip List Keyboard Focus:

1  Click the Keyboard Focus button in the upper 
right of the Clip List.

2  Type the first or first few letters of the clip to 
automatically locate and select it. Once a clip is 
located and selected, it can be dragged to a track.

Keyboard selection of audio clips locates clips 
based on their clip name, not on the names for 
their parent audio files or the volumes on which 
they reside.

Select Options
In the Clip List, you can select specific clips so 
they can be dragged to tracks, processed with 
AudioSuite plug-ins, or exported.

To select specific clips in the Clip List:

 From the Clip List menu, choose Select, and 
then choose one of the Select options:

All Selects all clips in the Clip List.

Unused Selects clips that have not been placed 
in a track in the current session. Offline clips ap-
pear in the Clip List italicized and dimmed.

Clip List Keyboard Focus enabled



Unused Except Whole Files Selects clips that 
have not been placed in a track in the current 
session, but do not include Whole-file clips. 
Whole-file clips are clips that were created when 
recording or importing audio, consolidating ex-
isting clips, and when nondestructively process-
ing with an AudioSuite plug-in. Whole-file au-
dio clips reference an entire audio file that 
resides on your hard drive. Whole-file audio 
clips are displayed in bold in the Clip List 

Offline Selects clips whose parent files cannot be 
located, or are not available, when opening a 
session or importing a track. Offline clips ap-
pear in the Clip List as italicized and dimmed; 
they appear in playlists as light blue clips with 
italicized names.

Previewing Clips in the Clip 
List
You can preview audio and MIDI clips and clip 
groups in the Clip List. Previewing follows the 
master Audition path as selected in the Output 
page of the I/O Setup. The base level for pre-
viewing is determined by the Master Fader (or 
Auxiliary Input) level assigned to the Audition 
path.

To preview a clip in the Clip List:

 Option-click (Mac) or Alt-click (Windows) the 
clip name. 

Audio clips and clip groups play back through 
the specified Audition Path (see “Audition 
Paths” on page 93).

The Preview Volume control in the Import 
Audio dialog also affects the preview 
volume when auditioning clips in the 
Clip List.
Sample-based clips play back at their native 
tempo. Tick-based MIDI and Elastic Audio pro-
cessed clips play back at the session tempo 
(based on the location of the playback cursor). 
You can also preview clips from the Clip List 
during session playback.

MIDI clips play back using the Default Thru In-
strument selected in the MIDI Preferences page 
(see “The Default Thru Instrument” on 
page 483).

Auditioning Discrete Signals in 
Multichannel Items
In the Clip List, multichannel clips are audi-
tioned through the Audition Path specified in 
the I/O Setup. Signals can be auditioned “in-
place,” or through all outputs, as described be-
low. 

Audition In-Place

When auditioning a mono component of a mono 
component clip, the mono clip can be played 
from the corresponding channel of its parent 
mono component clip. This playback method is 
called audition in-place.

To audition in-place:

1  In the Clip List, make sure the stereo or multi-
channel clip is in expanded view (showing .L, .R, 
and other component channels). 

2  Alt-click (Windows) or Option-click (Mac) the 
clip for the channel you want to audition. 

Audition to All Outputs

When auditioning a mono component of a mono 
component clip, the clip can be routed equally to 
all outputs of the parent clip’s Audition Path.
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To audition through all channels of the main 
audition path:

 Shift-Option-click (Mac) or Shift-Alt-click 
(Windows) on the signal in the Clip List. 

Stereo and Multichannel 
Clips in the Clip List
Stereo and multichannel clips, whether im-
ported or recorded into Pro Tools, are displayed 
as single items in the Clip List. For example, two 
mono source clips named “Main Piano.L” and 
“Main Piano.R” are listed as “Main Piano (Ste-
reo).” An expand/collapse triangle indicates ste-
reo and multichannel clips. 

Stereo and multichannel clips are displayed in 
the Clip List by default in collapsed view. The in-
dividual clips can be displayed by clicking the 
arrow to the left of the clip to expand the name.

To expand or collapse all stereo and multichannel 
clips:

 Press Option (Mac) or Alt (Windows) while 
clicking the expand/collapse triangle.

Individual items of an expanded-view stereo or 
multichannel clip can be selected independently 
of the other associated clips in the Clip List.

Stereo clips, expanded (top) and collapsed (bottom)
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Rules for Stereo and 
Multichannel Clips
For stereo and multichannel audio clips to be 
shown as collective clips, the component clips 
must be the same length. If an existing stereo or 
multichannel clip has been dragged onto multi-
ple mono tracks and edited such a way that one 
or more components are no longer the same 
length, the stereo display is removed and the 
clips are displayed as individual clips in the Clip 
List.

Naming and Displaying Clips 
in the Clip List
A typical session can become cluttered with doz-
ens of tracks and hundreds of clips. There are a 
number of things you can do to keep track of and 
manage a session’s clips, including:

• Renaming existing clips

• Specifying how auto-created clips are 
named

• Hiding auto-created clips

• Removing unused clips

Renaming Clips
In the course of a session you can rename clips 
to give them more descriptive names, or to 
shorten or simplify existing names. When re-
naming a clip that was auto-created during edit-
ing, the clip becomes a user-defined clip and is 
displayed in the Clip List even when auto-cre-
ated clips are hidden.

If a clip resides in a track, you can easily rename 
it by double-clicking it with one of the Grabber 
tools. However, if the clip does not reside in a 
track, or if you want to rename several clips, use 
the Rename command in the Clip List.



You can also rename a clip in a track using the 
Rename command in the Clip List menu or the 
Right-click menu.

To rename one or more clips from the Clip List:

1  If you will be renaming an auto-created clip, 
select Show > Auto-Created from the Clip List 
menu.

2  Select one or more clips to be renamed in the 
Clip List.

3  Do one of the following:

• From the Clip List menu, choose Rename.

– or –

• Right-click on any selected clip and select 
Rename from the pop-up menu.

4  In the Name dialog, type a new name for the 
clip. If a whole-file audio clip was selected, spec-
ify whether to rename just the clip, or both the 
clip and the disk file.

5  Click OK to rename the clip. If renaming mul-
tiple clips, you are prompted, successively, to re-
name each clip.

If the Clip List Selection Follows Edit Selec-
tion option in the Editing Preferences page 
is enabled, you can highlight a clip in the 
Clip List by selecting it in a track.

Name dialog
Auto-Naming Options
You can specify the auto-naming options for a 
clip when new clips are created from it in the 
course of editing. 

Auto-naming of clips does not affect the names 
of parent audio files. Instead, it stores pointers 
to the clips within the parent source file.

To set auto-naming options for a clip:

1  Select a clip in the Clip List.

2  Choose Auto Rename from the Clip List menu.

3  In the Rename Clips dialog, enter the text to be 
used when naming clips created from the se-
lected clip.

Name Determines the root name for the auto-
created clips.

Number Sets the start number for the sequen-
tially numbered new clips.

Zeros Determines the number of zeros that oc-
cur before the auto numbers.

Suffix Specifies text to be appended to the end of 
the name, following the auto numbering.

4  Click OK.

Rename Selected Clips dialog
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Managing Clips in the Clip 
List
In the course of editing a session, the Clip List 
can quickly fill up with many clips—with ones 
you have created intentionally and also with 
those that are automatically created by cutting, 
pasting, and separating other clips, or import-
ing Clip Group files (or REX files as clip groups). 
Pro Tools lets you hide or remove clips in your 
session so you do not have to scroll through a 
long Clip List.

Hiding Auto-Created Clips
You can hide clips that were automatically cre-
ated during the course of editing.

To hide auto-created clips:

 From the Clip List menu, deselect Show > 

Auto-Created. With this option deselected, only 
user-defined clips appear in the Clip List.

User-defined clips include:

• Whole-file clips

• Clips created during recording

• Imported clips

• Renamed clips

• Clips created as a result of AudioSuite pro-
cessing

• New clips created with the Clip > 

Capture command or the Edit > Separate 

Clip commands

• Clips created by trimming whole-file 
audio clips
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When auto-created clips are hidden, Pro Tools 
warns you if the number of auto-created clips 
exceeds a certain threshold, and gives you the 
option of deleting them. If you choose to delete 
them, all auto-created clips are deleted at the 
same time. 

To ensure that you keep any specific auto-cre-
ated clips, rename them. When you name a clip, 
it is promoted from being an auto-created clip to 
a user-defined clip (see “Renaming Clips” on 
page 276).

Removing Unwanted Clips
In the Clip List, you can select unwanted clips 
and then use the Clear command to remove them 
from the session. Whole-file clips can also be 
permanently removed from the hard drive on 
which they are stored.

To find and remove unused clips in a session:

1  Do any of the following:

• For MIDI clips, from the Clip List menu, 
choose Select > Unused.

– or –

• For audio clips, from the Clip List menu, 
choose Select, then choose Unused, Unused 

Except Whole Files, or Offline (as appropri-
ate).

2  After all unused clips are selected, choose 
Clear from the Clip List menu.

The Clear command cannot be undone.



3  In the Clear Audio dialog, do one of the follow-
ing:

• Click Remove to remove the unused clips 
from the session.

– or –

• If clearing a whole-file audio clip and you 
want to permanently remove the audio file 
from your hard drive, click Delete.

When deleting audio files for multiple clips, 
Pro Tools presents a warning dialog for each au-
dio file. 

To bypass repeated warning dialogs:

 Option-click (Mac) or Alt-click (Windows) the 
Delete button in the Clear dialog. This perma-
nently deletes each successive audio file from 
your hard drive (for each of the unused clips) 
without any further warning. 

Clear Selected dialog (audio clips)

Use this “power delete mode” with caution: 
Deletion of these files cannot be undone.
Clip Name Right-Click 
Commands
When you Right-click a clip name in the Clip 
List, a pop-up menu provides access to the fol-
lowing commands:

Clear Removes selected clips from the session.

Rename Renames selected clips.

Time Stamp Redefines the time stamp of se-
lected clips.

Replace Clip Replaces multiple instances of a 
clip with another clip.

Compact Compacts selected clips.

Export Clip Definitions Exports definitions for 
selected clips.

Export Clips as Files Exports selected clips as 
files.

Recalculate Waveform Overviews Redraws 
waveforms for selected clips.

Select Parent in Workspace Highlights the par-
ent file of selected clip in the DigiBase Work-
space Browser.

Reveal in Finder (Mac)/Reveal in Explorer (Win-
dows) lets you reveal the parent file for any in-
dividual clip in the Finder (Mac) or Windows 
Explorer (Windows).

Object Select in Edit Window Selects clip as an 
object in the Edit window.
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Chapter 16: DigiBase
DigiBase combines an intuitive, browser-style 
interface with an integrated databasing engine, 
optimized for Pro Tools data and media man-
agement.

DigiBase browsers provide extensive databasing 
tools for searching, sorting, auditioning, and 
importing of audio, MIDI, video, plug-in set-
tings (.txf), and session files. Multiple browsers 
can be displayed and arranged, with custom dis-
play settings provided to optimize your work en-
vironment. 
DigiBase Data Flow
The following figure shows the data flow of a 
Pro Tools session and DigiBase browsers. Ar-
rows show how files can be moved between the 
elements.

For information on dragging and dropping 
files from DigiBase browsers to your 
Pro Tools session, see “Importing Files with 
Drag and Drop” on page 335.
Data flow between a Pro Tools session and DigiBase browsers

Workspace browser

Volume browsers Catalogs

Project browser

Relink window Task window

Pro Tools 
session
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DigiBase Browsers
DigiBase databases are accessed through Digi-
Base browsers. DigiBase browsers provide an in-
tuitive user interface to DigiBase databases with 
many convenient features for various file man-
agement tasks (such as search and sort func-
tions).

DigiBase browsers in Pro Tools are analogous to 
windows in your computer’s operating system, 
but are specifically designed for Pro Tools work-
flow. Multiple browsers can be displayed simul-
taneously, and arranged independently with 
custom display settings for each.

DigiBase browsers let you search and sort audio 
files, video files, and sessions. Audio, video, and 
session files displayed in DigiBase browsers can 
be dragged directly into the current Pro Tools 
session.

When offline items are needed, Pro Tools lets 
you find the correct matching files, then relink 
to online media. 

The following types of DigiBase browsers are 
available with all supported systems:

• The Workspace browser

• Volume browsers

• The Project browser

• Catalogs
Pro Tools Reference Guide
Workspace Browser

The Workspace browser provides access to all 
your mounted volumes, as well as the folders 
and files they contain. 

Using the Workspace browser, you can:

• Access all mounted volumes.

• Access all Catalogs.

• Search across multiple volumes and Cata-
logs simultaneously.

• Designate volumes for Record and Play-
back, Playback Only, or Transfer.

• Unmount volumes.

• View, manage, audition, and import indi-
vidual items in any catalog or mounted vol-
ume.

• Update databases for entire volumes.

Volume Browsers

Volume browsers provide file management for 
local and network volumes. Volumes are format-
ted partitions on a physical drive (hard drive). 
Open a Volume browser by double-clicking a 
volume in the Workspace browser. Any changes 
made in Volume browsers (such as copying, de-
leting, or moving files and folders) is mirrored 
on the volumes themselves. Volumes include 
mounted hard drives, network storage, and re-
movable media (such as CD-ROMs).

Using Volume browsers you can:

• View, manage, audition, and import indi-
vidual items on the volume.

• Update a database for contents of the vol-
ume.

For detailed information about the Work-
space browser, see “Workspace Browser” on 
page 318.



Project Browser

The Project browser provides powerful search 
and management tools for the files referenced in 
your current session, regardless of where they 
are stored. Using the Project browser, you can:

• Show all the media files associated with the 
current session, including any missing 
files.

• View, manage, audition, and spot individ-
ual items.

Catalogs 

Catalogs provide the highest level of Pro Tools 
file management. Catalogs make it easy to orga-
nize files from multiple sources into libraries of 
favorite files. Catalogs can be sorted and 
searched, even when the files they reference are 
offline. Catalogs can also be shared. 

Using Catalogs, you can:

• Collect and organize files from any combi-
nation of volumes.

• Create catalogs of complete volumes to 
view and search even if a volume is offline.

• View, manage, audition, and import indi-
vidual items in the catalog.

• Update a database for contents of catalog.

For detailed information about the Project 
browser, see “Project Browser” on page 321.

For detailed information about Catalogs, 
see “Catalogs” on page 323.
Task Window
The Task window is a utility for viewing and 
managing all of the background tasks that you 
initiate with Pro Tools. Use the Task window to 
monitor, pause, or cancel background tasks such 
as file copies, searches, and indexing.

Relink Window
The Relink window provides tools and features 
for relinking sessions and catalogs to media 
files. Use Relink tools to search and reacquire 
missing files for use in the current session. 

Performance and Transfer 
Volumes
DigiBase lets you view, manage, and import ses-
sions and media from both Performance and 
Transfer volumes.

Performance Volumes Are storage volumes 
(hard drives) that are suitable for playback and 
have been designated in the Workspace browser 
as Record and Playback (R) or Playback Only (P) 
of media files in a Pro Tools session.

Transfer Volumes Are volumes that are not sup-
ported for media playback in Pro Tools (such as 
shared network volumes or CD-ROMs), or stor-
age volumes (hard drives) that have been desig-
nated in the Workspace browser as Transfer (T) 
volumes. Transfer volumes cannot be used to re-

For detailed information about the Task 
window, see “Task Window” on page 327.

For detailed information about the Relink 
window, see “Relink Window” on page 314.
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cord or play back media in a Pro Tools session. 
Designated Transfer (T) volumes can be useful 
for transferring session and media files between 
different Pro Tools systems.

Digidesign Databases
The information displayed in DigiBase browsers 
is stored in individual databases. Pro Tools cre-
ates these databases automatically for all 
mounted volumes, including Transfer volumes, 
on your system drive.

Digidesign databases use three file types:

volume.ddb Stores media and session file meta-
data for a particular volume.

catalog.ddb Stores media and session file meta-
data for a user defined Catalog. Cataloged media 
and session files are can reside on multiple vol-
umes, including Transfer volumes.

Wavecache.wfm Stores waveform overviews for 
all audio files referenced by each session.

Volume Databases

For each volume (whether they be local hard 
drives, removable media, or shared network 
storage), a database file is created in a folder 
named Digidesign Databases, on the system 
drive.

On Mac, they are stored in Library/Application 
Support/Avid/Pro Tools/Databases/Volumes/.

For more information on volume designa-
tions, see “Audio and Video Volume Desig-
nators” on page 319.
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On Windows, these databases are stored in 
Program Files\Avid\Pro Tools\Databases\
Volumes\. 

Sharing Database Files
Database files can be shared among users. This 
is particularly useful for Transfer volumes, 
eliminating duplicate processing (indexing) 
time.

For example, shared volumes (such as network 
storage volumes) tend to be large, and indexing 
can be a time consuming task. To avoid dupli-
cate effort, one user can manually index part or 
all of the shared volume just once, then email 
the database files to other users. Database files 
can be added by placing them within each user’s 
Volumes folder. Periodic manual indexing then 
keeps all databases current.

Sharing Catalogs

Catalogs can be created for a particular project 
and then shared among multiple systems to help 
facilitate more efficient workflow. Catalogs are 
stored as database files on your system drive. 

On Mac, Catalog database files are stored in the 
Library/Application Support/Avid/Pro Tools/
Databases/Catalogs folder.

On Windows, Catalog database files are stored 
in the Program Files\Avid\Pro Tools\Databases\
Catalogs folder. 

If you delete the Database folder, all exist-
ing database information is lost. To recre-
ate a deleted Database folder, re-index your 
storage volumes (see “Indexing DigiBase 
Databases” on page 288).



DigiBase Browser Windows and Tools
DigiBase browsers display all files in their database, including Pro Tools and non-Pro Tools files. Un-
known file types can be shown, as well as aliases, and desktop folders. 
Basic DigiBase browser tools, panes, and columns (Volume browser shown)

Toolbar

Items List

Fixed pane Scrolling pane

Pane split

Show/Hide

Title bar

Column headers

Columns Search icon View Presets Browser menuPreview controls

Browser Back arrow
To maximize processing speed and protect vital 
components, DigiBase does not display all fold-
ers. For example, in Windows, DigiBase brows-
ers do not display the Program Files, Windows, 
Digidesign Databases, WU Temp, or System 
Volume Information folders; and on Mac, Digi-
Base browsers do not display the System, Appli-
cations, Library, or Digidesign Databases fold-
ers. This excludes them from being indexed, 
searched, sorted, or affected in any way by Di-
giBase tasks. You should not store Pro Tools 
session or media files in any of these folders.
The main elements of a DigiBase browser in-
clude the following. 

Title Bar Shows the browser type (Work-space, 
Volume, Project or Catalog), and the name of its 
associated volume, session or catalog. 

Toolbar Provides the Browser menu, Search 
icon, View Presets (numbered 1–5), DigiBase 
browser navigation tools, and preview tools. 

Items List Displays the contents of a volume, 
folder, session, or Catalog database in rows. 
C
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Columns Identifies the type of metadata dis-
played in the items list (such as file name and 
format) for volumes, folders, and files in the 
Items List.

• Columns can be resized by dragging the 
column border, or rearranged by dragging 
the Column headers.

• Columns can be dragged to either of two 
available panes, the Fixed or Scrolling 
panes.

Each row of data in a DigiBase browser repre-
sents an Item (such as a file or folder). Data 
about each item is displayed in columns. Col-
umns can be arranged and placed in either the 
Fixed pane or the Scrolling pane. 

Opening DigiBase Browsers
There are several ways to open, close, and navi-
gate within DigiBase browsers.

To open the Workspace browser:

 Choose Window > Workspace. 

To open a Volume browser:

1  Open the Workspace browser (Window > Work-

space). 

2  Double-click a volume or folder in the Items 
List. A new Volume browser opens.

To open the Project browser: 

1  Open a Pro Tools session.

2  Choose Window > Project.
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To open a Catalog browser:

1  Open the Workspace browser (Window > Work-

space). 

2  Click the Expand/Collapse icon next to the 
Catalogs icon to show all Catalogs, if they are not 
already visible. 

3  Double-click a Catalog. 

To open another Volume or Catalog in a new 
DigiBase browser window and leave the current 
Volume or Catalog browser open:

 Command-double-click (Mac) or Control-
double-click (Windows) the Volume or Catalog. 

Viewing the Contents of a 
Volume, Folder, or Catalog

To expand or collapse the currently selected 
folder, do one of the following:

 Click the Expand/Collapse icon next to the 
folder.

– or –

 Select a volume, folder, or Catalog, and press 
the Right Arrow key to expand, or the left Arrow 
key to collapse.

To move up one level in a DigiBase browser: 

 Click the Back arrow in the DigiBase Browser 
toolbar. 

To move up one level in a DigiBase browser, 
press Command+Up Arrow key (Mac) or 
Control+Up Arrow key (Windows).



Moving DigiBase Browsers to 
the Foreground or Background

To bring all open DigiBase browsers to the 
foreground:

 Choose Window > Browsers > Bring to Front. 

To send all DigiBase browsers to the background:

 Choose Window > Browsers > Send to Back. 

All open DigiBase browsers are moved to the 
background, bringing the other windows to the 
foreground. DigiBase browsers remain open and 
accessible. 

To bring an open DigiBase browser to the 
foreground:

 Choose Window > Browsers, and select an open 
DigiBase browser from the submenu.

To cycle to the next or previous DigiBase browser:

 Press Control+Left/Right Arrow keys (Win-
dows) or Command+Left/Right Arrow keys 
(Mac).

Closing DigiBase Browsers

To close all DigiBase browsers:

 Option-click (Mac) or Alt-click (Windows) the 
Close box of any DigiBase browser. 

To bring all DigiBase browsers to the fore-
ground, press Option+J (Mac) or Alt+J 
(Windows).

To send all DigiBase browsers to the back-
ground, press Option+Shift+J (Mac) or 
Alt+Shift+J (Windows).

Because the Task window is a utility and not 
a browser, it remains open.
Working wIth Items in 
DigiBase Browsers

Opening Sessions

To open a Pro Tools session listed in a DigiBase 
browser:

 With no Pro Tools session currently open, 
double-click a Pro Tools session file in any Digi-
Base browser. 

Opening AAF and OMF 
Sequences
AAF and OMF sequences can be opened from 
DigiBase browsers.

You can also drag and drop AAF and OMF se-
quences from DigiBase browsers into the cur-
rent session.

To open an AAF or OMF sequence from a DigiBase 
browser:

1  Do one of the following:

• With no Pro Tools session currently open, 
double-click the AAF or OMF sequence in a 
DigiBase browser.

– or –

• Drag the AAF or OMF sequence from a 
DigiBase browser to the Timeline in an 
open session.

2  Configure the Import Session Data dialog.

3  Click OK.
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Creating and Opening DigiBase 
Browser Folders
DigiBase browsers let you create and manipulate 
folders (file system sub-directories). All folders 
have Expand/Collapse icons to show their con-
tents. Dragging items onto a folder icon is the 
same as dragging into an open DigiBase 
browser. 

To create a new folder in a Volume browser or 
Catalog:

1  Choose New Folder from the Browser menu. 

2  Type a name for the folder, and click OK. (Click 
Cancel to cancel the new folder.)

In Volume browsers, the folder is created on 
disk. In Catalogs, the folder is created in the 
Catalog only. The Items List updates as new 
items are added. 

To open a folder in the current DigiBase browser:

 Double-click the folder, or click the Ex-
pand/Collapse icon for the item. 

To create and open a folder in its own new 
DigiBase browser:

 Command-double-click (Mac) or Control-
double-click (Windows) the folder. The previous 
(parent) DigiBase browsers window remains 
open. 

With a browser in the foreground and the 
folder selected, press Command+Down Ar-
row key (Mac) or Control+Down Arrow key 
(Windows) to open a folder in the current 
DigiBase browser.

With a browser in the foreground and the 
folder selected, press Control+Alt+Down 
Arrow key (Windows) or Command+Op-
tion+Down Arrow key (Mac) to open a 
folder in its own new browser.
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Scrolling and Moving Selections

To scroll the active pane up or down:

 Press the Page Up or Page Down key.

To scroll to the top or bottom of the active pane:

 Press Home (for the top) or End (for the bot-
tom).

To move items up or down in the current DigiBase 
browser:

1  Select items in a DigiBase browser, and make 
sure that window is in the foreground. 

2  Press the Up or Down Arrow key.

Text Entry in DigiBase Browsers
Many text fields can be edited to replace or up-
date data for an item. 

To enter an edit to a text field and exit, and return 
to the previous display state:

 Press Enter.

To revert to the previous text and cancel a text edit:

 Press Esc.

Indexing DigiBase Databases
Indexing is the process of reading media files, 
extracting just the metadata for each file, then 
storing that data in an associated database so 
that it may be displayed in the columns of a 
DigiBase browser. Once a volume or folder has 
been fully indexed, it can be searched very 
quickly because all of the metadata has already 
been sorted and organized.

For details on column editing, see “Column 
Data” on page 294.



If a volume or folder has not been indexed, it is 
indexed automatically the first time it is opened 
in a DigiBase browser. Volumes or folders con-
taining a lot of media files can take a long time 
to index. For this reason, you may want to man-
ually index specific volumes or files prior to 
starting a project to help expedite workflow.

Indexing while Browsing
The first time you open a Volume browser for a 
volume or folder that has never been indexed, 
Pro Tools automatically begins to fill the data-
base for that level of the volume. Files and fold-
ers appear in the browser Items List, along with 
metadata in the columns for each item. Indexing 
continues until you either close the browser, or 
until that folder is completely indexed. 

The next time you open that browser, metadata 
for items that have already been indexed is visi-
ble immediately. If the browser or folder was 
closed before indexing was complete, or if the 
contents of the folder have changed since the 
last time it was browsed, Pro Tools automati-
cally updates the database the next time it is 
opened. This way, the database is always up to 
date for the folder you are browsing. (View the 
Task Manager to see current activity.)

Indexing while Browsing saves time because it 
only fills the database for items on the level of 
the volume that you are currently browsing. For 
example, if you are browsing the root level of the 
volume, it indexes only the folders and files on 
the root level. If you open a folder, Pro Tools in-
dexes just the items in that folder. As a result, a 
database is only indexed for the parts of the vol-
ume that you have browsed. However, searches 
are faster and more complete when a volume is 
already completely indexed. 
Manual Indexing
Manual indexing fills in all missing data, and 
updates changed data for selected folders and all 
of their sub-folders. 

To update the index for a folder and all sub-folders:

1  Select the item in a DigiBase browser Items 
List. 

2  Choose Update Database for Selected from the 
Browser menu. 

To update the index for an entire volume:

1  Select the volume to update in the Workspace 
browser. 

2  Choose Update Database for Selected from the 
Browser menu. 

Last Indexed Date Display

The Last Indexed column shows the date that the 
index for that folder and all of its sub-folders 
was updated. Keep in mind that individual sub-
folders may have been updated more recently.

Automatic Updating for Pro Tools Actions

Whenever Pro Tools adds, deletes, or modifies a 
file on a volume or in a session, the appropriate 
database is immediately updated to reflect the 
change. 

Changes that are made with Windows Ex-
plorer or the Mac Finder (such as copying or 
moving files) are not tracked by Pro Tools 
and are only indexed if the necessary folder 
is browsed or if a manual index is per-
formed.
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DigiBase Browser Menu 
All DigiBase browsers provide a Browser menu 
in the upper right corner of their toolbar. Digi-
Base Browser menus provides commands spe-
cific to each type of browser, as described below. 

Not all DigiBase browser commands are avail-
able in all browsers, as noted.

New Folder Creates a new folder on the current 
volume, or within the current Catalog. In Vol-
ume browsers, a new folder is created on disk. 
Available in Catalog and Volume browsers only. 
For more information, see “Creating and Open-
ing DigiBase Browser Folders” on page 288.

New Catalog Creates a new, empty Catalog. 
Available in the Workspace browser only.

Create Catalog from Selection Creates a fully in-
dexed catalog of the selected items.

Calculate Waveform Calculates the waveform 
displays for selected audio files, or all files con-
tained in selected folders. 

Update Database for Selected Updates the data-
base for the currently selected volumes or fold-
ers. Available in Workspace and Volume brows-
ers only.

DigiBase Browser menu icon

For more information, see “Waveforms” on 
page 303.
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Calculate Elastic Analysis Calculates Elastic Au-
dio analysis data for all selected audio files. An-
alyzed files are indicated by a check mark to the 
left of the file name. Analyzed files where a 
tempo has been detected are also updated as 
tick-based, display their duration in Bars|Beats, 
and display their native tempo in the Tempo col-
umn.

Clear Elastic Analysis Clears Elastic Audio anal-
ysis data for all selected audio files. Files cleared 
of Elastic Audio analysis data revert to sample 
timebase, display their duration in minutes and 
seconds, and do not report a tempo.

Select Offline Files Selects all files that are cur-
rently offline.

Select Transfer Files Selects all files identified as 
Transfer files (files found on media that do not 
support playback). 

Select Online Files Selects all files that are on-
line. 

Invert Selection Reverses (inverts) the current 
selection.

Reveal in Finder/Explorer Opens the corre-
sponding parent window in the Finder (Mac) or 
Explorer (Windows) for the currently selected 
file. 

Reveal in Browser Opens the parent browser for 
the selected item. The selected item is high-
lighted in its parent browser.

Relink Offline Opens the Relink window. Avail-
able in the Project browsers only.

Relink Selected Opens the Relink window, with 
all selected files from the current browser dis-
played and selected as Files to Match. Available 
in Catalogs and Project browsers only.

For more information, see “Elastic Audio 
Analysis” on page 303.



Copy and Relink Copies items currently selected 
in the Project browser to a chosen location, and 
relinks the session to the copies instead of the 
originals. Use this to easily move files from a 
Transfer to a Performance volume. This com-
mand is also available in Catalogs to copy items 
and relink the current Catalog to the copies. 

Duplicate Selected Creates a duplicate of the se-
lected items in the same location. 

Lock Selected Locks all selected items. Any files 
already locked remain so. Locking a folder locks 
all files and sub-folders it contains. 

Unlock Selected Unlocks the selected items. 

Delete Selected Deletes any selected item. In the 
Workspace, Project, and Volume browsers, de-
leting an item deletes it from the disk. In Cata-
logs, you are asked whether you want to clear 
the items from the Catalog (leaving your disks 
unchanged) or delete the files referenced by the 
Catalog items. 

Unmount Lets you unmount any online volume. 
Available in the Workspace browser only. 

Auto-Preview Enables or disables automatic pre-
view of files. When this option is enabled, se-
lecting a file in the browser starts preview. The 
Preview button updates to show that Auto-Pre-

view is enabled. Additionally, the Preview but-
ton updates to show an Auto-Preview icon.

While Pro Tools is running, always use the 
Unmount command in the Workspace 
browser menu to unmount the volume, or 
quit Pro Tools and then unmount the 
volume. 
Loop Preview Previews the selected file by loop-
ing playback of the file. If multiple files are se-
lected, only the first selected file previews. 
When Loop Preview mode is enabled, the Pre-
view button updates to show a Loop Preview 
Mode icon.

Spacebar Toggles File Preview Enables or dis-
ables the Spacebar for starting and stopping pre-
view. When this option is disabled, use the Pre-
view button to start and stop preview. In this 
mode, the spacebar starts and stops session 
playback. This lets you play back the session 
and, with the Audio Files Conform to Session 

Tempo option enabled, preview the selected au-
dio file in time with the session.

Audio Files Conform to Session Tempo Con-
forms all tick-based audio files with Elastic Au-
dio analysis, as well as REX and ACID files, to 
the session tempo. This option lets you play 
back the session and simultaneously preview the 
selected files in time with the session. This op-
tion is only available when a session is open. For 
more information, see “Conforming Preview to 
the Session Tempo” on page 308. 

When the Audio Files Conform to Session Tempo 
option is enabled, Pro Tools analyzes un-ana-
lyzed files on preview or import. Audio files that 
have been analyzed as tick-based can then be 
previewed at the session tempo and conform to 
the session tempo on import.

When the Audio Files Conform to Session Tempo 
option is disabled, any tick-based audio files 
with Elastic Audio analysis, and REX and ACID 
files preview and import at their native tempo. 

When a browser is front-most, Control+P 
(Windows) or Command+P (Mac) starts 
and stops preview. Also, the Esc key stops 
preview.
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Additional DigiBase Commands 
in Catalogs
In Catalogs, the following additional commands 
are available to manage Comments in selected 
items. 

Copy Database Comments to Clip Names Cop-
ies an item’s Database comments to its Clip 
Name. 

Copy File Comments to Clip Names (Mac 
Only) Copies an item’s File Comments to its Clip 
Name. 

DigiBase Browser Panes and 
Display
DigiBase browsers display an Items List consist-
ing of various columns (such as file name, size, 
creation date, and sample rate). The Items List 
is split into two panes. Individual columns can 
be placed in either pane, and all columns can be 
shown or hidden, resized, reordered, and 
sorted. 

Moving Columns Between Panes
Columns in DigiBase browsers can be placed in 
either pane. Move columns you frequently need 
to see into the left-hand pane. Columns that you 
use less often can be moved to the right-hand 
pane. 

For more information on Comments, see 
“Comments Fields” on page 296.
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To move columns between panes:

 Drag the column header to a different pane. 

To show or hide the right-hand pane:

 Click the Show/Hide icon in the lower right 
corner of the left-hand pane. 

Arranging and Resizing Columns

To rearrange columns in a pane:

 Drag the column header to a new position.

To resize a column:

 Drag the column header boundary to a new 
width. 

Showing and Hiding Columns
You can show or hide individual columns in 
DigiBase browsers to fit your workflow. The de-
fault column display includes the items you 
would use in most sessions.

Show/Hide Pane icon



To show or hide individual columns:

 Control-click (Mac), Start-click (Windows), 
or Right-click a column label and select or dese-
lect the column name from the pop-up menu. 

To show or hide all columns:

 Control-click (Mac), Start-click (Windows), 
or Right-click a column header and choose ALL 
or NONE from the pop-up menu. (Only the 
Name and Clip Name columns remain when you 
choose NONE.)

To show the default set of columns:

 Control-click (Mac), Start-click (Windows), 
or Right-click a column header and choose DE-

FAULT from the pop-up menu. 

View Presets
Pro Tools lets you save up to five preset views 
for each type of DigiBase browser, and the 
Relink window. Presets can be recalled by click-
ing a View Preset button. View Presets are spe-
cific to each type of DigiBase browsers.

Showing and hiding columns
To store a View Preset:

1  Open a DigiBase browser, or the Relink win-
dow. 

2  Arrange columns and views. 

3  Command-click (Mac) or Control-click (Win-
dows) one of the five View Preset buttons. 

To recall a saved preset:

 Click the appropriate View Preset button.

About View Preset 1

Preset 1 becomes the default layout for other 
DigiBase browsers of its type when they are 
opened for the first time. 

Sorting Columns
Columns can be sorted in ascending or descend-
ing order, and multiple sorts can be applied (up 
to four levels).

To sort by columns:

 Click the column title header. 

It is often helpful to perform a secondary sort 
(for example, to sort by tape and timestamp). 

Browser View preset buttons
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To add a secondary sort:

 Option-click (Mac) or Alt-click (Windows) the 
column title for the secondary sort criteria. 

To toggle the current sort order between 
ascending and descending:

 Click the Sort toggle arrow, at the top of the 
vertical scroll bars. 

Column Data
In DigiBase browsers, each row of data repre-
sents an item in a database (such as a file, ses-
sion, or volume). Each column displays specific 
data for an item, as follows.

Status The Status column is the first column on 
the left, and it displays the status of each item, 
as follows.

Performing a secondary sort

Status Icons and Display

Icon Text Status

none Black Online

none Blue italics Offline

T Blue italics Transfer

 Blue Elastic Audio 
Analysis 
Calculated

Primary Sort Secondary Sort
Pro Tools Reference Guide
Name Displays the name of the file, folder, vol-
ume, catalog, or session. This text field is edit-
able in all DigiBase browsers except Catalogs. 

A Designates volumes for audio R (Record and 
Playback), P (Playback only), or T (Transfer). 
Available in the Workspace browser only.

V Designates volumes as video R (Record and 
Playback), P (Playback only), or T (Transfer). 
Available in the Workspace browser only. 

Kind Displays whether the volume, folder, cata-
log, or file. For files, this column displays what 
kind of file it is: session file, audio file, video 
file, or other. This field cannot be edited. For au-
dio files, this column also indicates whether the 
file is sample-based to tick-based.

Size Displays the size of a file in kilobytes. For 
folders, the total size of all files in the folder is 
displayed. This field cannot be edited.

Date Indexed Displays the last indexed date for 
the item. This field cannot be edited.

Capacity Displays the total capacity of a volume. 
This field cannot be edited. 

Free Displays the unused space on volumes. This 
field cannot be edited. 

Waveform Displays a graphical overview of an 
audio file. See “Waveforms” on page 303 for 
more information.

Duration Displays the duration of a file in abso-
lute time (minutes and seconds), regardless of 
the timecode format. For clip groups, MIDI, 
tick-based Elastic Audio files, REX, and ACID 
files, Duration displays Bars and Beats. This 
field cannot be edited.

For more information, see “Audio and 
Video Volume Designators” on page 319.



File Comment Displays any embedded com-
ments associated with the file. File comments 
are supported with BWF and SD II files, but are 
not supported with AIFF files. File Comments 
always remain with the file when copied, con-
verted, or transferred. See “Comments Fields” 
on page 296 for more information.

Database Comment Displays user comments 
stored with the database, with support for 
Finder comments. Available in the Project 
browser and Catalogs only. See “Comments 
Fields” on page 296 for more information.

Date Modified Displays the last modified date for 
the item. This field cannot be edited.

Date Created Displays the creation date of an 
item. This field cannot be edited. 

Number of Channels Displays the number of 
channels in an audio file: mono, stereo, or 3–8 
as appropriate for supported multichannel files. 
This field cannot be edited.

Format Displays the audio file format: WAV, 
WAV (ACID) for ACID files, WAV (BWF), AIFF, 
MP3, or ReCycle for REX files. This field cannot 
be edited. 

Sample Rate Displays an audio file’s sample 
rate. This field can be edited in DigiBase brows-
ers for WAV and SDII files only. This can be use-
ful when dealing with audio that has been pulled 
up or down, or to force a sample rate conversion 
to occur if that is necessary before importing a 
file that otherwise would not require conver-
sion.

Bit Depth Displays an audio file’s bit depth. This 
field cannot be edited.

When importing SD II files into Pro Tools 
8.0.3 sessions or higher, they must be con-
verted to a supported session file format 
(.WAV or .AIF).
Tempo Displays the tempo associated with clip 
group, MIDI, tick-based Elastic Audio files, 
REX, and ACID files, and session files. This field 
cannot be edited.

Video Compression Displays the compression 
ratio of video files where applicable.

Frame Rate Displays the frame rate of video files 
where applicable.

Original Time Stamp Displays the original time 
stamp (timecode location) of audio or video 
files.

User Time Stamp Displays the user time stamp, 
if any, of audio files only.

Path Displays the directory path to the item. 

Unique ID Displays the unique ID for a Pro Tools 
file. 

Tape This column displays the original Avid 
tape name if the item is an OMF file (audio or 
video). If an audio file was originally recorded 
in Pro Tools, this field displays the name of the 
original session. 

TC Rate This column displays the frame rate of 
the item if the item is an AAF sequence or an 
OMF sequence or file: 24, 25, 29.97, 30, drop or 
non-drop. For sequences, the frame rate at the 
start of the sequence is displayed.

Channel Names Displays the channel name and 
number data embedded in multichannel audio 
files. You can edit the Channel name for mono 
BWF files only. When editing the channel name, 
anything entered in parentheses is discarded. 
However, the channel number will always be 
preserved.

Video files originally recorded in Pro Tools 
with AVoption|XL do not display a tape 
name.
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Scene Displays scene number data embedded in 
audio files. 

Take Displays take number data embedded in 
audio files.

Shoot Date Displays origination date and time 
information embedded in audio files. However, 
many field recorders do not populate the Shoot 
Date field, relying instead on the file’s Creation 
Date to indicate date of production. When 
Pro Tools imports a field recorder file, it checks 
to see if the Shoot Date field is populated. If it is 
empty, Pro Tools copies the Creation Date of the 
original source file to the Shoot Date field of the 
new imported files. This field cannot be edited.

Sound Roll Displays sound roll number data 
(This data is usually named “Tape” in BWF files, 
but is distinct from the date displayed in the Di-
giBase Tape column). This field cannot be ed-
ited.

Sound Roll TC Displays the starting timecode of 
audio files. This field cannot be edited.

Sound Roll TC Rate Displays the frame rate in-
formation embedded in audio files: 24, 25, 
29.97, 30, drop or non-drop. This field cannot be 
edited.

User Bits Displays text information embedded 
in audio files. This field can be used for user 
comments, or auto-generated info with certain 
field recorders.

Tape ID Displays tape ID information embedded 
in audio files. This field cannot be edited.

Project Displays the project name data embed-
ded in audio files.

Circled Indicates if the status of a take is set to 
“circled” (No or Yes) in audio files. This is usu-
ally for indicating which take should be used.
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Plug-In Name Displays the name of the plug-in 
for Plug-In Settings files (.txf).

Plug-In Manufacturer Name Displays the plug-in 
manufacturer’s name for Plug-In Settings files 
(.txf).

Link Path Displays the path to the file used for 
relinking. Available in the Relink window only. 

Clip Name Displays the name of the file, or the 
Avid clip name when the item is an AAF or OMF 
file. The Clip Name is what appears in the Time-
line and Clip List when a file is imported into a 
session. This field can be edited in Catalogs 
only, and can be generated using either of the 
Copy Comments to Clip Name commands in the 
Browser menu (see “Additional DigiBase Com-
mands in Catalogs” on page 292). 

Comments Fields
Comments about individual files can be stored 
in the database, and embedded with the file’s 
metadata wrapper. 

There are two types of comments fields: File 
Comments and Database Comments.

File Comments

File Comments are stored with the metadata of 
the file itself. Not all file types support File 
Comments. Indexing stores File Comments in 
the database, allowing them to be searched and 
viewed even if the file is offline. File Comments 
can be edited in DigiBase browsers, as long as 
the files or their parent media are not defined as 
read-only. 

You can also add and edit File Comments to 
Pro Tools Session files from the Project 
browser. File Comments cannot be edited in 
Catalogs.



Database Comments

(Catalogs and Project Browsers Only)

Database Comments in a Catalog are stored in 
the Catalog database. Database comments in the 
Project browser are stored in the Session. Data-
base Comments, which can be up to 256 charac-
ters in length, are searchable, cross-platform, 
and editable. For more information, see “Com-
ments and Catalogs” on page 324. 

Adding and Editing Comments

To add, view, or edit a Comment:

1  Click the Comments field. The field expands to 
display the entire contents of the field if neces-
sary. 

2  Enter or edit a comment. 

3  Press Enter, or click outside the text box to 
close it. 

Selecting Items
To select a single item in a DigiBase browser:

 Click the icon for an item. When selected, the 
item Name is highlighted. 

To select multiple items:

 Marquee-select a group of items, or Shift-click 
additional items. Command-click (Mac) or Con-
trol-click (Windows) to select multiple noncon-
tinuous items. 

You can also type the first letter, or the first 
few letters, of the item you want to select in 
a DigiBase browser. For example, if you 
have a folder full of drum loops, and the one 
you are looking for is named “Ska Loop,” 
just type the letters S and K on your com-
puter keyboard and the first item that starts 
with “sk” will be highlighted in the list.
To select all items listed:

 Press Command-A (Mac) or Control-A (Win-
dows).

To select all Transfer files in the current window:

 Choose Select Transfer Files from the Browser 
menu. 

To select all offline files:

 Choose Select Offline Files from the Browser 
menu.

To select all online files:

 Choose Select Online Files from the Browser 
menu. 

To reverse the current selection:

 Choose Invert Selected from the Browser 
menu. 

Moving, Copying, Duplicating, 
and Deleting Items
Moving, copying, duplicating, and deleting 
items in DigiBase browsers follow the same 
rules and behavior as in the operating system. 
For example, moving a file to another volume 
copies the file, and Pro Tools warns you if an 
items is about to be overwritten or replaced. 
Dragging an item from a Catalog to a Volume 
browser always makes a new copy of the item. 
Chapter 16: DigiBase 297



298
Moving Items

To move items:

 Select one or more items and drag them to a 
new location. Moving to a new location on the 
same volume moves the item, while moving to a 
different volume copies the item. 

Copying Items

To copy and move items:

 Select one or more items and Option-drag 
them to a new location. 

Duplicating Items

To duplicate one or more items:

1  Select one or more items. 

2  Choose Duplicate Selected from the Browser 
menu.

Deleting Items and Folders
You can select and delete files and folders in all 
browsers. If a selected item resides on a read-
only volume, it cannot be deleted. 

For Catalogs, see “Deleting Catalog Items” on 
page 298 for additional information. 

You can drag items directly into the Time-
line or Clip List of the current session. See 
“Importing Files with Drag and Drop” on 
page 335.

To Duplicate selected items in DigiBase 
browser, press Command-D (Mac) or Con-
trol-D (Windows).
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To delete one or more items:

1  Select one or more items.

2  Do one of the following:

• Press Delete.

– or –

• Choose Delete Selected from the Browser 
menu. 

3  Pro Tools asks you to verify that you want to 
permanently delete selected files from disk. 
Click Delete to proceed, or click Cancel to leave 
your files and disks unchanged. 

To delete locked files:

1  Select one or more items. 

2  Press Command+Delete (Mac) or Control+De-
lete (Windows).

Deleting Catalog Items
When you delete a folder or item from a Catalog, 
Pro Tools lets you choose whether to delete only 
the alias from the Catalog, or also delete the 
original files from the disk. 

To delete an item from a Catalog. 

1  Open a Catalog and select one or more items. 

2  Do one of the following:

• Press Delete.

– or –

• Choose Delete Selected from the Browser 
menu. 

To skip the warning dialog, hold down the 
Option key while pressing Delete (or while 
choosing Delete Selected). 



3  When prompted, do one of the following: 

• To remove the aliases for the selected items 
from the Catalog, click Aliases. 

– or –

• To delete the selected items from disk (and 
remove their aliases from the Catalog), 
click Files. 

Deleting Folders in Catalogs

Deleting a folder from a Catalog does not delete 
the folder on disk (even if you choose to delete 
all files from disk). Because Catalogs are “snap-
shots” of items, their aliases only include files 
that resided in the corresponding folder at the 
time the Catalog was created. To avoid potential 
data loss, folders are never deleted from disk, 
even though you might choose to delete Files in-
stead of Aliases. 

Searching Items
DigiBase provides powerful search capabilities 
so you can quickly search and find files. 

The Workspace browser lets you search across 
multiple volumes and catalogs (if available). All 
other DigiBase browsers let you search the cur-
rently displayed contents of that individual 
browser. 

Performing a search filters the Items List or 
Search Results pane to display only found items 
that match the search criteria. 

The Relink window provides specialized search 
capabilities for finding and relinking missing 
files. For more information, see “Linking and 
Relinking Files” on page 310. 
Search Features for All Systems
All systems provide the following search capa-
bility:

• Search by item Name, Kind, and Date Modi-
fied.

• Results of a search are displayed in the Items 
List, where they can immediately be selected 
for auditioning, copying, and other opera-
tions. In the Workspace browser, a separate 
“Search Results” pane displays found items. 

• Utilize search syntax modifiers, such as OR, 
wildcard characters, and greater than/less 
than. See “Search Modifiers” on page 301. 

• Search in Quick or Advanced Search mode. 
Quick mode assumes (fills in) wildcard char-
acters for faster data entry while searching. 
Advanced Search mode lets you specify wild-
card characters for more precise searching. 
See “Search Modes” on page 302 for more in-
formation.

• Search by any data column, such as Comments 
fields, sample rate, format, and tempo 

• Save the results of a search as a new Catalog.
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Starting a Search

To search the current DigiBase browser:

1  Click the Search icon to display the Search 
pane. 

2  Do one of the following:

• Type text into the File Name field to search 
by name, or type a date, or select a kind 
from the Kind pop-up menu. See “Entering 
Data for Searches” on page 300 for more in-
formation.

– or –

• Choose additional search criteria as 
needed. Press Tab to move to the next avail-
able search field, or Shift+Tab to move to 
the previous.

3  Click the Search button, or press Return (Mac) 
or Enter (Windows).

Search icon and Search pane

You can also start a search by pressing Com-
mand+F (Mac) or Control+F (Windows).

Search
Pane 

Search icon
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Searching begins, indicated by the spinning ar-
rows in the toolbar, and by the Search button 
changing to Stop. The Results List (at the bot-
tom of the DigiBase browser) fills with items 
that match the search criteria. Items can be se-
lected and auditioned as they are found. 

To stop a search:

 During a search, click the Stop button. 

This stops the search routine, and the Stop but-
ton changes back to Search. Whatever results 
have already been found continue to be dis-
played, and all entries in search fields are re-
tained. 

To reset your search settings:

 Click Reset to clear all criteria in search fields, 
and return to the main Browser view (all items). 
The Search pane remains open.

To close the search pane and return to the 
complete Browser view:

 Click the browser Search icon to toggle the 
Search pane closed or open.

The search is stopped, the Search (and Search 
Results pane) close, and the window returns to 
show the main Browser view. 

Entering Data for Searches

Field Formats and Searching
The following describe the types of data formats 
available (not all search fields are available on 
all systems). 

Text Fields Allow direct entry of text. By default, 
the field is empty. 



Pull-Down Menus Provide options for certain 
fields. For example, the Bit Depth pull-down 
provides choices for Any, 16-bit, or 24-bit.

Date and Time Accepts date and time entries in a 
variety of formats.

Timecode Uses standard Pro Tools timecode en-
try shortcuts in hh:min:sec:frames.

Search Modifiers
Certain fields have small pull-down menus con-
taining modifiers, which limit the search criteria 
entered in the field. 

Modifiers include:

• Equal to (=)

• Not Equal to () 

• Less Than (<)

• Greater Than (>)

• Less Than or Equal to (<=)

• Greater Than or Equal To (>=)

• Range (<…>)

About Range-Limited When enabled, a second 
search field is added so that a range of two val-
ues can be entered (such as two dates). 
Pro Tools finds all items that fall between or are 
equal to those two values.

Wildcard Characters (* and ?)
An asterisk (*) can be entered at the beginning 
or end of a text entry when you want to perform 
wildcard searches. For example, if you want to 
find all files with a name that ends with scratch, 
you could enter *scratch in the Search field. This 
finds files with names such as vocal.scratch, and 
dialog2.scratch. 
A question mark (?) can be used for single-char-
acter wildcards. For example, a search on f?ee 
finds free, and f lee. A similar search on f*ee finds 
frendlee, f lippee, f lee, free, and so on. 

OR Searches
The Plus (+) and Minus (–) buttons add and de-
lete OR rows to find results that match the crite-
ria either in the top row or the additional rows.

To add and use OR rows in a search:

1  Click the (+) button to add an OR row identical 
to the upper row, but with no entries in the 
search fields. 

2  To add an additional OR row, click the Plus (+) 
button again. (An empty OR row has no effect on 
the search.)

3  Enter search criteria.

For example, to find all files named either Dog 
or Bark:

• Type Dog in the first File Name field.

• Add an OR row.

• Type Bark in the second File Name field.

4  Click Search. 

To remove OR rows:

 Click the Minus (–) button to delete the bot-
tom OR row. 

AND Searches
If you enter two or more words in a text field, 
Pro Tools finds files that contain all of those 
words. For example, if you type Dog Bark, only 
files that contain both the words Dog and Bark 
are found.
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Quotations Marks for Text 
Strings
Text enclosed in quotation marks is searched as 
one text string. For example, if you type “Dog 
Bark” (with quotes), only items with Dog Bark 
anywhere in the File Name are considered a 
match.

Search Modes
DigiBase provides two different text searching 
environments:

Quick Search Mode Applies wildcards before 
and after each text string. For example, a Quick 
search for Dog finds Dogs, dog_bark, and 
howling_dogs.

Advanced Search Mode Does not automatically 
apply any wildcards. Therefore, an Advanced 
search on Dog finds Big Dog, but not Dogs (un-
less you manually add a wildcard, as described 
in “Wildcard Characters (* and ?)” on page 301). 

In addition, Advanced Search recognizes word 
breaks such as underscores and capitalization. 
For example, an Advanced search on Dog also 
finds Big_Dog (Big-underscore-Dog) and Big-
Dog, though it would not find BigDogs.
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To enable Advanced Search mode:

 Click to enable the Advanced Search mode op-
tion. 

To return to Quick Search mode:

 Click to deselect the Advanced Search mode.

About the Search Process
Searches are conducted in two passes, each indi-
cated by Search Status displayed in the Search 
pane (and the Task window). 

Searching Databases The existing databases are 
searched first. While this is the fastest search 
pass, this search pass can only be as accurate as 
the database (in other words, if the database is 
not completely up to date you might not find the 
files you want). 

File System Search Pass This is the second pass 
of a search. This search is not as fast as the Da-
tabase pass, but it is more thorough because it is 
not relying on the database, which may or may 
not be current.

Advanced Search mode option, in Search pane

Toggling search mode affects all DigiBase 
browsers. 

Each pass is completed before the next pass 
begins.



Saving Search Results as a 
Catalog

To save the results of your search as a Catalog:

1  Choose Edit > Select All, or press Command+A 
(Mac) or Control+A (Windows), to select all 
items in the Items List.

2  From the Browser menu, choose Create Cata-

log.

Waveforms
The Waveform column displays waveforms for 
audio files. Waveform display depends on the 
following:

• Waveforms are displayed if they have already 
been calculated and stored, either with the file 
metadata or in the global Waveform cache.

• When a file is imported into a session, a wave-
form is automatically calculated for it, if nec-
essary. 

• Waveforms are gray if they have not been 
stored with the file metadata or in the global 
Waveform cache. 

The waveform overview is stored in the file, or 
in the Digidesign Databases folder on your sys-
tem drive. For more information, see “Wave-
Cache” on page 303.

For more information, see “Catalogs” on 
page 323.

Waveform displays in a DigiBase browser
Summed Waveforms for Multichannel Files

Waveform displays for stereo and multichannel 
files are summed. 

Calculating Waveforms for 
Display
If an audio file item does not have a waveform, 
the waveform must be calculated to be visible in 
a DigiBase browser Waveform display. 

To calculate waveforms in a DigiBase browser:

1  Select online audio files, or folders containing 
audio files, in a DigiBase browser.

2  Choose Calculate Waveform from the Browser 
menu. 

WaveCache
A global WaveCache file stores waveforms that 
cannot be written back to the sound file, such as 
read-only files, files on network and other read-
only volumes, and interleaved files. WaveCache 
files are stored in the Digidesign Databases 
folder on your system drive. 

Elastic Audio Analysis
You can both calculate and clear Elastic Audio 
analysis for selected audio files in DigiBase 
browsers. Only AIFF and WAV files are sup-
ported for Elastic Audio analysis and process-
ing. Any other file format (such as MP3) must be 
converted to AIFF or WAV for Elastic Audio 
analysis and processing.
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To calculate Elastic Audio analysis:

1  In a DigiBase browser, select the files you want 
to analyze.

2  Do one of the following:

• From the Browser menu, choose Calculate 

Elastic Analysis.

• Right-click one of the selected files and 
choose Calculate Elastic Analysis from the 
pop-up menu.

• Preview the file with the Audio Files Con-

form to Session Tempo option enabled.

Analyzed files are indicated by a check mark to 
the left of the file name. 

Analyzed files in which a regular tempo was de-
tected are updated as tick-based, display their 
duration in Bars|Beats, and display their native 
tempo in the Tempo column. 

Even though the MP3 file formats are not di-
rectly supported by Elastic Audio, you can 
import them into a WAV- or AIFF-based 
session and then use the converted files on 
Elastic Audio-enabled tracks. File formats 
that do not match the session are converted 
automatically on import.

For more information on Elastic Audio, see 
Chapter 41, “Elastic Audio.”
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Analyzed files in which no tempo was detected 
remain sample-based. These files typically con-
tain only a single transient (such as a snare hit) 
or they are longer files without a readily identi-
fiable regular tempo (such as entire songs).

To clear Elastic Audio analysis:

1  In a DigiBase browser, select the files with 
Elastic Audio analysis that you want to clear.

2  Do one of the following:

• From the Browser menu, choose Clear Elas-

tic Analysis.

– or –

• Right-click one of the selected files and 
choose Clear Elastic Analysis from the pop-
up menu.

Files cleared of Elastic Audio analysis data re-
vert to sample timebase, display their duration 
in minutes and seconds, and do not report a 
tempo.

On Mac, if you do not see the Elastic Audio 
Analysis icon or the duration does not 
change to tick-based during the preview 
process, check the permissions for the folder 
in the Mac Finder. You must have write ac-
cess of the directory for this feature to work.



File Timebase and Elastic Audio 
Analysis Icons
DigiBase browsers provide three icons to indi-
cate whether a file has Elastic Audio analysis 
and the file’s timebase.

Elastic Audio Analysis Icon Indicates that the 
file has Elastic Audio analysis data.

Sample-Based File Icon Indicates that the file is 
sample-based. The file’s duration is displayed in 
minutes and seconds.

Tick-Based File Icon Indicates that the file is 
tick-based. The file’s duration is displayed in 
Bars|Beats and the file’s native tempo is dis-
played in the tempo column.

Elastic Audio and Timebase icons in DigiBase 
browsers

Tick-based Sample-based
file icon

Elastic Audio
Analysis icon file icon
Previewing Audio in DigiBase
Audio files can be previewed in DigiBase brows-
ers. Previewing follows the master Audition 
path as selected in the Output pane of the 
I/O Setup (see “Audition Paths” on page 93). 
The base level for previewing is determined by 
the Master Fader (or Auxiliary Input) level as-
signed to the Audition path. You can also adjust 
the Preview Volume in the DigiBase browser.

To preview an audio file in a DigiBase browser:

1  Select an audio file in a browser Items List. 
Make sure the DigiBase browser is the fore-
ground (active) window. 

2  Do one of the following:

• Click the Waveform Preview button (the 
speaker icon to the left of the waveform dis-
play). Click again to stop auditioning.

• If Spacebar Toggles File Preview is selected 
in the Browser menu, press the Spacebar. 
Press the Spacebar again to stop audition-
ing.

• Press Control+P (Windows) or Com-
mand+P (Mac) to start and stop preview-
ing. 

• Press the Esc key to stop previewing. 

To audition from a specific location within the file:

 Click in the waveform display at the location. 

If the Auto-Preview option is enabled, pre-
viewing starts as soon as the file is selected 
in a DigiBase browser.

Auditioning an audio file
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Interleaved Files

When previewed in DigiBase, interleaved audio 
files with more than two channels are summed 
to mono for auditioning. 

Multi-Mono Files

Multi-mono files must be previewed one file at a 
time. 

Split Stereo Files Preview Together

When selecting one of a pair of Split Stereo files, 
such as “Drums.L” and “Drums.R,” both files 
preview together. To preview only the selected 
channel of a split stereo pair, press the Shift key 
and start preview.

Some Pro Tools operations can cause 
temporary interruptions in DigiBase 
auditioning. 

MIDI files can be previewed from the ses-
sion Clip List, but not from DigiBase 
browsers. See “Previewing Clips in the Clip 
List” on page 275.
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Preview Controls and 
Indicators
Every DigiBase browser provides the following 
preview controls in the Toolbar: Preview, Vol-
ume, Meters, Audio Files Conform to Session 
Tempo, and Elastic Audio Plug-In.

Preview Button

The Preview button starts and stops preview of 
audio files selected in DigiBase browsers. You 
can also Right-click the Preview button to 
change the Preview mode and set whether or not 
the spacebar toggles file preview. 

Volume

The Volume control in DigiBase browsers lets 
you boost or attenuate the gain for previewing 
selected files. 

Preview controls in DigiBase browsers

DigiBase Browser, Preview button Right-click menu

Preview
button

Volume
Meters

Elastic Audio
Plug-In selector

Audio Files Conform 
to Session Tempo

button



To change the volume for previewing in DigiBase 
browsers:

1  Click the Volume field to display the Volume 
fader.

2  Adjust the Volume fader (from –INF to 
+12 dB).

Meters

The meters display the level of the audio and 
also provide clip indicators. For mono files, the 
mono signal is shown in both meters. For stereo 
files, the top and bottom meters show the left 
and right channels respectively. Greater than 
stereo multichannel files are displayed as 
summed mono in both meters.

The Clip LED lights when clipping occurs and 
clears automatically after 3 seconds.

Audio Files Conform to Session Tempo Button

The Audio Files Conform to Session Tempo but-
ton mirrors the corresponding Browser menu 
command. When enabled, all tick-based audio 
files with Elastic Audio analysis, as well as REX 
and ACID files, conform to the session tempo. 
This lets you play back the session, and then si-
multaneously preview the selected files in time 
with the session. The Audio Files Conform to 
Session Tempo button is only available when a 
session is open, otherwise it is disabled and 
grayed out.

DigiBase Browser, Preview Volume fader
When the Audio Files Conform to Session 
Tempo button is enabled, Pro Tools analyzes 
any un-analyzed files on preview or import. 
Tick-based audio files conform to the session 
tempo during preview and on import. Sample-
based files, those where no tempo has been de-
tected, always preview and import at their orig-
inal speed and duration.

When the Audio Files Conform to Session 
Tempo button is disabled, any tick-based audio 
files with Elastic Audio analysis, and REX and 
ACID files preview at their native tempo. 

Elastic Audio Plug-In Selector

The Elastic Audio Plug-In selector lets you se-
lect any Real-Time Elastic Audio plug-in as the 
default plug-in for previewing and importing 
Elastic Audio. Changing the plug-in in any Digi-
Base browser also affects the Elastic Audio De-

fault Plug-In option in the Processing prefer-
ences.

Preview Modes
DigiBase browsers provide three Preview 
modes: Normal Preview, Loop Preview, and 
Auto-Preview.

Normal Preview
Normal Preview simply plays the selected audio 
file and stops at the end of the file. Deselect 
Loop Preview and Auto-Preview for Normal Pre-
view mode.

For more information, see “Conforming 
Preview to the Session Tempo” on page 308

For information on Elastic Audio plug-ins, 
see “Elastic Audio Plug-Ins” on page 888.
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Loop Preview
Loop Preview plays the selected file by looping 
playback of the file. If multiple files are selected, 
only the first selected file previews. When Loop 
Preview mode is enabled, the Preview button 
updates to show a Loop Preview Mode icon.

To loop preview a file in a DigiBase browser:

1  Do one of the following:

• In the Browser menu, select Loop Preview. 
The Browser Preview button updates to 
show the Loop Preview icon.

– or –

• Right-click the Preview button and select 
Loop Preview.

2  Select an audio file in a DigiBase browser’s 
Items List. Make sure the DigiBase browser is 
the foreground (active) window. 

3  Do one of the following:

• Click the Browser Preview button.

• Click the Waveform Preview button.

• If Spacebar Toggles File Preview is selected 
in the Browser menu, press the Spacebar.

Control-click (Mac) or Start-click (Win-
dows) the Preview button to toggle Loop 
Preview mode on and off.

DigiBase Preview button, Loop Preview mode
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To stop loop audition:

 Do one of the following:

• Click the Browser Preview button again.

• If Spacebar Toggles File Preview is selected 
in the Browser menu, press the Spacebar 
again.

• Press Command+P (Mac) or Control+P 
(Windows). 

• Press the Esc key. 

Auto-Preview
Auto-Preview plays the audio file as soon as it is 
selected. Additionally, the Preview button up-
dates to show an Auto-Preview icon.

To automatically preview files when selected:

 Do one of the following:

• From the Browser menu, select Auto-Pre-

view. The Preview button updates to show 
that Auto-Preview is enabled.

• Right-click the Preview button and select 
Auto-Preview.

Conforming Preview to the 
Session Tempo
Pro Tools lets you preview Elastic Audio ana-
lyzed files at the session tempo. The selected de-
fault Elastic Audio plug-in is used for preview-
ing Elastic Audio analyzed audio files at the 

Command-click (Mac) or Control-click 
(Windows) the Preview button to toggle 
Auto-Preview mode on and off.

DigiBase Preview button, Auto-Preview enabled



session tempo. Additionally, other tick-based 
files, such as REX and ACID files, can also be 
previewed at the session tempo and in time with 
playback. 

To preview files at the session tempo:

1  In the session, place the insertion point at the 
location where you want to preview the file in 
DigiBase.

2  In a DigiBase browser, select the file you want 
to preview.

3  Do one of the following:

• Click the Audio Files Conform to Session 
Tempo button. It highlights when enabled.

• From the Browser menu, select Audio Files 

Conform to Session Tempo.

• Right-click the file you want to preview and 
select Audio Files Conform to Session Tempo 
from the pop-up menu.

4  Click the Preview button in the DigiBase 
browser and the file plays at the session tempo.

Preview in Context
Pro Tools lets you preview audio files in Digi-
Base browsers while playing back a Pro Tools 
session. Tick-based audio files (those with 
tempo detected Elastic Audio analysis, as well as 
REX and ACID files) can play back in tempo, and 
at the corresponding bar and beat location, with 
session playback. Tick-based audio files audi-
tion at the session tempo when the Audio Files 

Conform to Session Tempo option is enabled. 
Reserve Voices for Preview in Context
(Pro Tools HD Only)

Preview in context (previewing audio files in Di-
giBase during session playback) uses disk voices 
for playback. The number of voices required de-
pends on the channel width of the selected Au-
dition Paths on the Output page of the I/O Setup 
window. For example, if a stereo audition path 
selected in the I/O Setup requires 2 voices for 
preview in context, whereas a 5.1 audition path 
requires 6 voices. If one or more voices are not 
available for preview in context because they are 
in use by disk tracks (or routing for RTAS pro-
cessing), the Preview button in DigiBase brows-
ers will be unavailable during session playback. 

Pro Tools provides an option to reserve voices 
for preview in context. The number of reserved 
voices is determined by the channel width of the 
selected Audition Paths in the I/O Setup. Voices 
reserved for preview in context are unavailable 
for disk tracks.

To reserve for voices for preview in context: 

1  Choose Setup > Preferences.

2  Select the Operation tab.

3  Enable the Reserve Voices For Preview In Con-

text option.

4  Click OK to close the Preferences dialog.

Deselect the Spacebar Toggles File Preview 
option in the Browser menu to be able to 
start and stop session playback with the 
spacebar without starting and stopping au-
ditioning in the DigiBase browser. Use Com-
mand+P (Mac) or Control+P (Windows) to 
start and stop preview in the front-most 
DigiBase browser during session playback. 
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Linking and Relinking Files
A Pro Tools session is made up of references, or 
links, to audio files and other session media. Au-
dio and video files must be stored on suitable 
Performance volumes and be properly linked in 
order to be playable in the session.

The following types of files are not playable:

Transfer Files Files that are stored on volumes 
not suitable for playback, such as network vol-
umes or CD-ROMs.

Missing Files Files that cannot be found where 
the session expects them, either because they 
have been moved, or because they are stored on 
volumes that are not currently mounted (offline 
volumes).

The process of reacquiring missing files is re-
ferred to as relinking. Relinking can involve cer-
tain sub-tasks, depending on the situation.

• Transfer files must first be copied to a suitable 
Performance volume. The session is then 
relinked to the copies on the Performance vol-
umes instead of the original Transfer files.

• Volumes may be searched for missing files 
and, when the files are found, Pro Tools 
relinks the session to the file's new location.

• Files that reside on offline volumes must first 
have their volumes mounted (brought online) 
before they can be relinked.

Catalogs have unique linking characteris-
tics. See “Relinking and Aliases in Catalogs” 
on page 317. 
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Choosing When to Relink
Pro Tools lets you relink files while opening a 
session or after a session is already open, as fol-
lows:

 Relinking when opening a session ensures that 
the session opens with all media playable. Auto-
matic and manual relinking can be performed. 
See “Opening a Session with Missing Files” on 
page 312. 

 Relinking later (after a session is already 
open) is the fastest way to open the session, but 
all missing items remain offline and unplayable. 
When items are needed, go to the Project 
browser to relink offline items. See “Missing 
Files in an Open Session” on page 313.

Forcing a Relink

If you cannot relink to the original file, you can 
force a relink to another file. See “Force Relink-
ing Files” on page 317. 



Transfer Files
Unlike missing files, Transfer files are files that 
have been found but which reside on volumes 
unsuitable for playback, such as CD-ROMs or 
network drives. These volumes appear as Trans-
fer volumes in the Workspace browser. 

Opening a Session with Transfer 
Files
If a session finds files on a volume unsuitable for 
playback, a dialog appears prompting you to 
copy them to a suitable volume. 

To copy Transfer files found when opening a 
session, do one of the following: 

 Click Yes to open the Copy and Relink dialog.

– or –

 Click No to open the session with all Transfer 
files offline. When opened, the session’s Project 
browser indicates Transfer files with a “T” in 
their Status column.

Transfer Files in an Open Session

To make Transfer files playable in the current 
session:

1  Choose Window > Project.

2  Double click the Audio Files folder to display 
all of the audio files.

3  Choose Select Transfer Files from the Browser 
menu. 

4  Choose Copy and Relink from the Browser 
menu. 

5  Specify a location for the copied files on a valid 
Performance volume and click OK. 

6  Repeat for video files, as necessary. 
Copy and Relink 
The Copy and Relink command is a file manage-
ment option in the Project browser and in Di-
giBase Catalogs. 

Copy and Relink provides a convenient way to 
copy files and relink the session or Catalog to 
the copies rather than to the originals. 

To copy items to a new location and Relink to the 
copies:

1  Do one of the following:

• Choose Window > Project. 

– or –

• Open the appropriate Catalog. 

2  Select the items you want to copy and relink. 
You can select any media files (online, offline, 
and Transfer files). 

3  Choose Copy and Relink Selected from the 
Browser menu. 

4  If the default location for the copies (the ses-
sion’s Audio Files folder) is not appropriate, 
specify a different location and click Choose. 

5  The files are copied to the chosen destination 
and the session or Catalog is relinked in the 
background. 
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Missing Files
Files are missing if they are not found in the 
same location as when the session was last 
saved. This could be because you moved the files 
or the session folder, or because the files are on 
a volume that is not currently mounted. 

Opening a Session with Missing 
Files

To open a session with missing files:

1  When you open a session, Pro Tools opens the 
session with all available media, then shows you 
how many files are missing (if any) and asks how 
you want to proceed. (If told that files are un-
suitable for playback, see “Transfer Files” on 
page 311.)

2  Select one of the following:

• Skip All—or press Command+S (Mac) or 
Control+S (Windows).

• Manually Find Relink—or press Com-
mand+M (Mac) or Control+M (Windows).

• Automatically Find Relink—or press Com-
mand+A (Mac) or Control+A (Windows).

3  Select Regenerate Missing Rendered Files With-

out Searching to exclude rendered Elastic Audio 
files from the relink process and regenerate 
them instead.

4  Click OK.

Missing files warning when opening a session
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Skip All

Use the Skip All option to skip all missing files. 
This option is the fastest way to open the session 
utilizing all available media. Missing files are 
offline in the session, and shown in the Clip List 
and the Project browser with italic text. 

Manually Find and Relink

This option opens the Relink window. Use the 
Relink window to search, compare, verify, and 
relink missing files. Files can be relinked one at 
a time or in batches. See “Relink Window” on 
page 314 for more information. 

Automatically Find and Relink

Automatically Find and Relink is the simplest 
method to relink sessions to required media, but 
it provides no way to compare files or verify 
links. This option cannot be undone. The Auto-

matically Find and Relink option does the follow-
ing: 

• Searches all Performance volumes for all miss-
ing items with matching Name, ID, Format, 
and Length.

• Links missing items to the first matches 
found.

• Commits links for all items possible, in the 
background. 

Links, once committed, cannot be undone 
once the session is saved. The only way to 
revert to previous links is to close the session 
without saving changes. 



• If some files remain unlinked, the Task win-
dow opens and a failed task appears in the 
Paused Tasks pane. Double-click the Task icon 
to open the Relink window and manually find 
and relink files.

Regenerate Missing Rendered Files Without 
Searching

Enable this option to exclude rendered Elastic 
Audio files from the relinking process (rendered 
files are recalculated instead). This option is 
available when Automatically Find and Relink or 
Manually Find and Relink is enabled. 

Even if all of the missing files are later 
found and relinked, the failed task remains 
in the Task Window. Like all failed tasks, it 
must be manually selected and deleted. See 
“About Failed Tasks” on page 329. 
Missing Files in an Open Session
You can open the Project browser to select and 
relink some or all missing files. 

To relink missing (offline) files in an open session:

1  Choose Window > Project.

2  Choose Relink Offline from the Browser menu 
to open the Relink window. 

3  Configure the Relink window as needed. See 
“Relink Window” on page 314 for more informa-
tion. 

To relink selected files in an open session:

1  Choose Window > Project. 

2  Select the files to relink. Any file can be 
relinked, even if it is not an offline file. 

3  Choose Relink Selected from the Browser 
menu. 

4  Configure the Relink window as needed. See 
“Relink Window” on page 314 for more informa-
tion. 
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Relink Window
The Relink window provides tools for all relinking tasks. 
Pro Tools Reference Guide
Main elements in the Relink window

Files to Relink

Candidates

Areas to Search

Menu and toolbar
Menu and Toolbar Includes the Relink menu, 
View Presets, and relinking buttons. Status is 
displayed at the far right.

Areas to Search Selects volumes on which to 
search for missing items. 

Files to Relink Lists missing files.

Candidates Lists files that match the “relinking 
criteria” for a particular missing file. The Link 
icon next to the candidate can be toggled on or 
off to link (or unlink) the proposed candidate to 
the selected missing file. 

The Relink window controls each phase of the 
relinking process. 

The following topics explain how to: 

• Open the Relink window (“Opening the Relink 
Window” on page 315). 
• Select volumes and folders to search and not 
search (“Selecting Areas to Search” on 
page 315).

• Search, compare, and link individual files to 
one or more candidates (“Relinking Individual 
Missing Files” on page 315). 

• Quickly match and link missing files in 
batches, with the ability to adjust the criteria 
by which files are matched (“Relinking Multi-
ple Missing Files” on page 316).

• Toggle links on or off for any candidate 
(“Force Relinking Files” on page 317).

• Compare and review links before committing 
(“Committing Links” on page 317).



Opening the Relink Window
When opening a session with missing files, use 
the Manually Find and Relink option to open the 
Relink window. 

The Relink window can also be accessed after a 
session is open. 

To access the Relink window from an open 
session:

1  Choose Window > Project. 

2  Choose Relink Offline from the Browser menu. 

Selecting Areas to Search
Selecting volumes and folders in the Areas to 
Search pane lets you focus the search for missing 
files. This can speed the relinking process by 
limiting the number of volumes or folders to 
search. In addition, excluding folders from a 
search for missing files also lets you redirect a 
session or Catalog to a more appropriate copy of 
an item.

To select volumes or folders to include or exclude 
in a search:

1  Configure the Areas to Search pane to display 
the appropriate volume, Catalog, or folder. 

Volumes selected to include in the search
2  Click each item’s Search column to toggle it to 
be included or excluded in the search. A check 
next to an item indicates it will be included in 
the search. All folders within items are also 
checked.

Single and Multi-File Relinking
The Relink window can be used to relink one 
missing file at a time, or to relink missing files 
in batches. 

Relinking Individual Missing Files

In some situations, individual files must be 
relinked one at a time in order to relink the ses-
sion to the correct file. This is necessary if mul-
tiple copies of a media file are online, or when-
ever you want the most control and flexibility 
over the relinking process. 

To relink a missing file:

1  Configure the Areas to Search pane. 

2  Select one item in the Files to Relink list. 

3  Click Find All Candidates. 

Find All Candidates, for relinking a selected missing 
file
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Pro Tools searches the selected volumes and dis-
plays all files that match File Name or Unique ID 
in the Candidates list. Link icons indicate if a 
Candidate is already linked.

4  Click the Link icon next to the appropriate 
Candidate to which you want to relink. A Link 
icon next to an item indicates it will be relinked 
to the item currently selected in the Files to 
Relink list.

5  Click the Link icon next to other Candidates, if 
you want to relink to additional missing files.

6  Click the Commit Links button.

Relinking Multiple Missing Files 

Using the Find Links button, multiple files can 
be matched and linked in one procedure. 

OMF video clips can only be relinked to a 
session if they have matching Unique IDs.

QuickTime video clips can only be relinked 
to a session by file name and file format 
(QuickTime).

To control matching and linking criteria 
when relinking an individual missing file, 
use the Find Links button. Find Links is ex-
plained in “Relinking Multiple Missing 
Files” on page 316.

Link icon, indicating Linked status
Pro Tools Reference Guide
To relink multiple missing files:

1  Configure Areas to Search. (See “Selecting Ar-
eas to Search” on page 315.)

2  Select one or more items in the Files to Relink 
list. The Find Links button becomes available. 

3  Click Find Links. 

4  Configure criteria for relinking, if necessary, 
in the Linking Options dialog:

• By default, Find by Name and ID is enabled.

• To add additional matching criteria, select 
an option from the Linking Options dialog. 
(Modification Date is only applicable to 
Catalogs.)

• If Match Duration is enabled, Pro Tools only 
selects files of the same length or greater. 

5  Click OK to continue (or click Cancel to return 
to the Relink window). 

Pro Tools searches for an acceptable candidate 
for the first missing file (the first item selected 
in the Files to Relink list). A link icon appears 
next to each file as Pro Tools finds and links the 
first acceptable candidate to the missing file. 

Linking options



The Link Path column shows the location of the 
selected candidate. Pro Tools continues search-
ing, matching, and linking for each missing file 
in the Files to Relink list. 

6  To view a candidate for a missing file, select to 
highlight the missing file. That file’s candidate 
appears in the Candidates pane, where you can 
view its information and waveform.

7  If you are not satisfied with the candidate for a 
particular missing file, you can click Find All 

Candidates for the selected file (see “Relinking 
Individual Missing Files” on page 315). 

Force Relinking Files
If you want to link to a substitute file (for exam-
ple, if you know a file has the same audio or 
video but does not have a matching File Name or 
Unique ID), you can force a relink.

 To force relink an audio file, its file format 
(WAV, AIFF, or MXF), sample rate and bit depth 
must match those of the original file.

 To force relink a video file, its format (Quick-
Time, Avid, MXF, or OMF) and frame rate must 
match those of the original file.

To force a relink:

1  Choose Window > Project. 

2  Choose Relink Offline from the Browser menu. 

3  In the Relink window, select one item in the 
Files to Relink list. 

4  Navigate in the Areas to Search pane to locate 
the file you want to relink.

5  Drag the file to the Candidates pane in the 
Relink window.

6  Click the Link icon next to the file you dragged 
to the Candidates pane. 

7  Click the Commit Links button.
Committing Links
There is no Undo for relinking. Once a file has 
been relinked and the session saved, the session 
always remembers the new link (the original 
link is forgotten). For this reason, no files are 
actually relinked until you click Commit Links. 

To commit links:

1  Use the Relink window to link files as ex-
plained in “Single and Multi-File Relinking” on 
page 315. 

2  Click Commit. You are asked to verify commit-
ting links. 

3  Do one of the following:

• Click Yes to commit links. 

– or –

• Click No to stop without affecting files. 

Relinking and Aliases in 
Catalogs
Catalogs are collections of “aliases” or “short-
cuts” to actual files. If the files are moved, an 
item in a Catalog can become unlinked from the 
file it references. 

To relink a Catalog:

1  Open the Catalog. 

2  Select items to relink. 

3  Choose Relink Selected from the Browser menu 
in that Catalog window. 

The Automatically Find and Relink option 
is the only relinking process that does not 
ask you to verify links before they are com-
mitted. If you use this option and are unsat-
isfied with the results, close the session 
without saving to prevent the new links 
from being committed. 
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Workspace Browser
The Workspace browser is your starting point for managing media. The Workspace browser is always 
available while Pro Tools is running, even if no session is open.
Pro Tools Reference Guide
Workspace browser, with the Search pane displayed

Browser name

Menu and toolbar

Items List

Search Results

Volume designators

Fixed pane Scrolling pane

Search 
pane

Pane split

Show/Hide
Only the Workspace browser lets you do the fol-
lowing:

• Designate volumes as Performance volumes 
(Playback or Record volumes) or as Trans-
fer volumes. 

• View and access all available volumes

• Unmount volumes

• Create, view, and access Catalogs.

• Search multiple volumes and Catalogs si-
multaneously. 

The Workspace browser is similar to your com-
puter’s desktop, in that it shows all of the 
mounted local and network volumes. The Work-
space browser has all the common DigiBase 
browser elements, including an Items list, View 
presets, and access to all files. In addition, the 
Workspace browser provides drive allocation 
settings, access to catalogs, and the ability to 
search multiple volumes and catalogs simulta-
neously.



Opening the Workspace 
Browser

To open the Workspace browser: 

1  Launch Pro Tools.

2  Choose Window > Workspace.

Audio and Video Volume 
Designators
The Workspace includes columns for Audio and 
Video Volume designators. These two columns 
display, and let you designate, whether a volume 
is a Record, Playback, or Transfer volume. 

R (Record and Playback) Able to play audio and 
video files already on the volume, and record 
new files. 

P (Playback Only) Can play audio and video files 
already on the volume, but cannot have new files 
recorded to it. 

T (Transfer) Can only be used for storing, trans-
ferring, or auditioning files, and cannot be used 
for recording or playback. 

To change a volume designator:

1  Open the Workspace browser.

Press Option+; (Mac) or Alt+; (Windows) 
to open the Workspace browser.

If you have a Pro Tools system with multiple 
drives, and you intend to record multiple 
tracks simultaneously, you may want to des-
ignate the System drive as a Playback only 
or Transfer only drive for optimal perfor-
mance.
2  Click and select the appropriate Audio or 
Video designator for the volume. 

Mounting and Unmounting 
Volumes
The Workspace browser lets you unmount vol-
umes while Pro Tools is running, and shows 
newly mounted volumes as they come online. 

To unmount a volume from within the Workspace 
browser:

1  Select a volume in the Workspace browser. 

2  Choose Unmount Volumes from the Browser 
menu. 

The Workspace browser closes the database file 
for the selected online volume and removes it 
from the Workspace browser, and unmounts the 
disk from the computer.

Pro Tools alerts you if the volume being un-
mounted has files referenced in the Timeline.

Designating a volume in the Workspace

Always use the Unmount command in the 
Workspace browser menu to unmount vol-
umes, or quit Pro Tools and then unmount 
the volume. Do not use any other method to 
unmount a volume while Pro Tools is run-
ning. 
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Catalogs in the Workspace 
Browser
The Workspace browser provides special tools 
for creating and accessing Catalogs. Once Cata-
logs have been created, they appear in the Work-
space browser in the Catalogs folder. 

To show all Catalogs: 

1  Open the Workspace browser. 

2  Click the Expand/Collapse icon next to the 
Catalogs folder.

To open an individual Catalog:

 Double-clicking a catalog opens a DigiBase 
browser window for that catalog. 

Searching in the Workspace 
Browser
The Workspace browser provides the most com-
prehensive DigiBase search capabilities. The 
Workspace browser lets you perform searches 
across a single volumes, multiple volumes, or 
across any combination of volumes, folders, and 
Catalogs. You select which volumes to include in 
the search, and which to exclude. The Work-
space also provides a separate Search Results 
pane to view, select and manage the results of 
searches. 

Viewing Catalogs in the Workspace. 

For complete instructions on creating and 
working with Catalogs, see “Catalogs” on 
page 323.
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The Search Results pane lets you maintain the 
results of searches, while still viewing and con-
figuring options for additional searches. 

To search from the Workspace:

1  Choose Window > Workspace to open the 
Workspace browser. 

2  Click the Search icon to display the Workspace 
Search pane. 

3  Configure search criteria. 

4  Click next to each item in the Areas to Search 
list to include or exclude volumes to be searched. 
Checked items and their sub-folders are in-
cluded in the search. (The next time you open a 
Search pane in the Workspace, these settings re-
main in effect.)

5  Click Search. 

6  The results of the search are shown in the 
Search Results pane. 

Search and Search Results panes in the Workspace

For more information on searching, see 
“Searching Items” on page 299. 

Search 
pane

Areas to 
search

Search 
results



Project Browser
The Project browser displays and manages all the files related to the current session, regardless of 
what volume they reside on.
Project browser

Folders
and files

Browser
menu and

toolbar
The Project browser is similar to the Clip List in 
that it contains all files associated with a ses-
sion, with the added data, searching, and sorting 
capabilities of DigiBase browsers. 

Unlike the Clip List, however, individual clips 
are not displayed in the Project browser (in 
which only complete files are listed). 

Use the Project browser and its Browser menu 
commands to:

• View all media files associated with a ses-
sion

• Identify, select, and relink offline files

• Identify, select, copy, and relink Transfer 
files
Opening the Project Browser 

To open the Project browser:

1  Launch Pro Tools and open a session.

2  Choose Window > Project.

The Project browser displays the following:

Audio Files Folder Contains all of the audio files 
currently referenced by the session, regardless 
of where they are located. 

Render Sources Folder Contains all files that 
have been imported into the session, but are still 
being converted, copied, or processed. 

Video Files Folder Contains any video files ref-
erenced by the session.

Press Alt+O (Windows) or Option+O (Mac) 
to open the Workspace browser.
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Each of the folder types in the Project browser 
has an Expand/Collapse icon. Clicking the icon 
shows or hides all of the files in the sub-group. 
The folders displayed in the Project browser are 
session-specific groupings of files, not physical 
folders on disk. 

Locating Parent Files of Clips
The Project browser can be set to automatically 
highlight the parent file of any clip selected in 
the Pro Tools Clip List.

To highlight the parent file of a selected clip:

1  Select a clip in the Clip List. If the Clip List Se-

lection Follows Track Selection preference is en-
abled, you can select a clip on a track.

2  From the Clip List menu, select Select Parent in 

Project Browser.

When the Select Parent in Project Browser 
option is enabled, the Project browser auto-
matically highlights the parent file of any 
file or clip selected in the Clip List. 
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About the Project Browser

No Drag and Drop to the Project 
Browser

To import a file from another DigiBase browser 
into the current session, you must drag files to 
the Timeline or Clip List. You cannot import a 
file into a session by dragging it to the Project 
browser. (You can, however, spot files from the 
Project browser into the current session using 
drag/drop.)

Deleting Items in the Project Browser

Deleting items in the Workspace browser or in 
Volume browsers deletes the files from disk. 
Video and session files cannot be deleted in the 
Project browser. 

Deleting an item from the Project browser lets 
you remove items from the current session, or 
delete them from disk (using the Pro Tools Clear 
Clips dialog). 

Copy and Relink Restrictions

In the Project browser, the Copy and Relink com-
mand (in the Browser menu) cannot be used on 
session files, or on offline audio files. Use the 
Relink window to first bring items online. In ad-
dition, the Relink Selected command cannot be 
used on session files. 

Updating the Project Browser

The Project browser is automatically updated 
whenever a file is added to or deleted from the 
session, so it is always fully indexed and up to 
date. 

For instructions on searching, sorting, and 
working with the Project Browser, see “Proj-
ect Browser” on page 321.



Catalogs 
While Volume browsers are designed to be an accurate representation of the file structure on a given 
volume, Catalogs are similar to having a Favorites folder, and serve as a way to collect and organize 
frequently used items regardless of where they are stored. A Catalog is analogous to a folder full of 
aliases or shortcuts. Placing a file in a Catalog does not create a copy of the file, and does not change 
where the file is stored. Rather, it stores a reference (or alias) to the file so that it can be found and 
manipulated without having to search for its physical location. 
Catalog browser

Catalog name

Menu and 
toolbar

Items List

Fixed pane Scrolling pane
Pane split

Show/Hide
Opening a Catalog Browser
Catalogs are displayed in the Workspace 
browser.

Catalogs item in the Workspace
To open a Catalog browser:

1  Open the Workspace browser.

2  Click the Catalogs Expand/Collapse icon. 

3  Do one of the following:

• Click the Expand/Collapse icon for the Cat-
alog to view its contents in the Workspace. 

– or –

• Double-click the Catalog name to open it in 
its own browser window. 
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Clip Names in Catalogs
Clip names are the names that appear in the 
Timeline and Clip List when a file is imported 
into a session. 

For most files, the clip name is the same as the 
file name. For OMF Files, the clip name is the 
name that appears in the Avid bin. 

Clip names can only be edited in a Catalog. Ed-
iting the clip name does not affect the actual file; 
however, if you add the same file to a new Cata-
log, it retains its original clip name. When you 
drag a file from a Catalog into a session, the ed-
ited clip name is what appears in the Timeline 
and Clip List. 

If the Clip Name is longer than 32 characters, 
Pro Tools truncates the name automatically 
when imported into the session. 

Comments and Catalogs
Catalogs provide commands for managing OS 9 
Finder comments, Database comments, and Clip 
Names.

Database Comments in a Catalog are stored in 
the Catalog database. Database Comments, 
which can be up to 256 characters in length, are 
searchable, cross-platform, and editable. 

Copy OS 9 Finder Comment to Database Com-
ments (Mac Only) Copies an item’s OS 9 Finder 
comments to its Database comments.

OS 9 Finder comments (from the OS 9 Get 
Info window) are not supported in OS X Get 
Info windows. Use the Copy OS 9 Finder 
Comment to Database Comments command 
to utilize any OS 9 Finder comments stored 
with your media. 
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Copy OS X Finder Comment to Database Com-
ments (Mac Only) Copies an item’s OS X Finder 
comments to its Database comments.

Copy Database Comments to Clip Names Cop-
ies an item’s Database comments to Clip Name. 

Copy File Comments to Clip Names Copies an 
item’s File Comments to Clip Name. 

Creating Catalogs
Catalogs can be added to the Workspace as new, 
empty Catalogs, or you can select items first and 
then save a Catalog of all selected items. 

To create a new, empty Catalog:

1  Open the Workspace browser. 

2  Choose New Catalog from the Browser menu. 

3  Type a unique name and click OK. 

To catalog a selection of items: 

1  Open any DigiBase browser (including an ex-
isting Catalog). 

2  Select the items you want to include in the new 
Catalog. 

3  Choose Create Catalog from Selection from the 
Browser menu. 

A new, fully indexed Catalog database of the se-
lected items is created. 

Creating Catalogs of Folders

To create a Catalog of an entire folder and all its 
contents: 

1  Open the Workspace browser, if not already 
open. 

2  Drag and drop a single folder onto the Catalog 
icon in the Workspace browser. 



Pro Tools first indexes the folder, then a fully 
indexed Catalog is created, with the same name 
as the dropped folder.

Renaming a Catalog
Catalogs can be renamed at any time. 

To rename a Catalog:

1  Click the Catalog item in the Workspace 
browser until its name highlights. 

2  Type a new name for the Catalog. 

Modifying Catalogs

To add items to a Catalog, do one of the following:

 Open the Catalog and drop new items from an-
other DigiBase browser. 

– or –

 Click the main Catalogs icon in the Work-
space, to expand your view of all existing Cata-
logs, then drop items onto any Catalog. 

To add a folder to a Catalog:

1  Open the Catalog.

2  Choose Create Folder from the Browser menu. 

To delete items from a Catalog:

1  Select the items. 

2  Press the Delete key, or choose Delete Selected 
from the Browser menu. A warning dialog ap-
pears.

3  In the warning dialog, do one of the following:

• Click Cancel to cancel the delete operation.

• Click Delete Files to delete aliases and asso-
ciated files from disk.

• Click Delete Aliases to delete only the 
aliases and not the associated files.
This operation cannot be undone.

Consolidating Files with 
Catalogs
Catalogs are excellent tools for consolidating 
files from a variety of sources. 

For example, create a Catalog named “Thumps” 
and fill it with sound effects from three different 
volumes. You can then drag the Catalog from the 
Workspace browser to another volume, and a 
folder named “Thumps” is created on that vol-
ume. All of the files referenced by the Catalog 
are automatically copied to the volume. Folders 
and sub-folders, if any, and their contents are 
included in the copy. 

Updating Catalogs
Since a Catalog database is not linked to any 
particular volume, there is a limit to the abilities 
of the Update Index command. When Update Da-

tabase for Selected is selected from the Browser 
menu in a Catalog, Pro Tools searches for the 
items represented by the aliases in the Catalog 
and updates the following information:

Metadata Metadata for all files found online, in-
cluding File comments, are updated.

Database Comments Database Comments are 
not updated, because they are unique to each 
Catalog and are not part of the file’s metadata.

Relinking Catalog Items
If files are ever missing from a Catalog, use the 
Relink window to locate, copy, and relink files. 
For more information, see “Linking and Relink-
ing Files” on page 310. 
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Deleting Catalogs

To delete a Catalog:

1  Select one or more Catalogs in the Workspace 
browser. 

2  Press the Delete key, or choose Delete Selected 
from the Browser menu. A warning dialog ap-
pears.

3  In the warning dialog, do one of the following:

• Click Cancel to cancel the delete operation.

• Click Delete Files to delete aliases and asso-
ciated files from disk.

• Click Delete Aliases to delete only the 
aliases and not the associated files.

This operation cannot be undone. 

Importing Catalog Items
You can import online and offline items from 
Catalogs into the current session. 

Importing Online Items from a Catalog

Dragging and dropping audio files to the 
Pro Tools Clip List and Timeline is identical to 
dragging and dropping from Volume browsers. 

Importing Offline Items from a Catalog

With Catalogs, it is possible to search and im-
port files that are offline. For example, if you 
have a music cue that you know you want to use, 
but it resides on a CD-ROM or other unmounted 
volume, you can spot the file from a Catalog to 
the session Timeline, and it is automatically im-
ported into the session when the volume is 
mounted. 

For more information, see “Importing Files 
with Drag and Drop” on page 335. 
Pro Tools Reference Guide
The first step is to add files to a Catalog (files 
must be online to be added to a Catalog). Once 
added to a Catalog, if the items are taken offline 
they are listed in italicized text. 

Offline files can be dropped from a Catalog to 
the Timeline just like online files. When you 
drop the files, a dialog appears asking if you 
want to relink the files or skip relinking. Click 
Skip All to load all the items as offline files (in 
the Timeline, their clips appear in light blue). In 
the Project browser, these items are listed in the 
Render Sources folder, to ensure that Pro Tools 
remembers that these items need to be relinked. 

Whenever the volume containing the offline 
items is mounted, Pro Tools automatically 
starts to import the files, in the background. 
This is true even if you have saved the session, 
quit, and relaunched Pro Tools. 

Once the items are completely imported, they 
appear as online items in the Timeline, Clip List, 
and in the Project browser. 

If the offline items match the session sample 
rate, bit depth, and file format, no conversion is 
necessary. As long as the volume is playable, the 
items become playable in the session as soon as 
the volume is mounted. 

If the volume is unsuitable for playback, you are 
informed that some items must be copied to 
suitable volumes first. 

For more information on Transfer files, 
missing files, and relinking, see “Relink 
Window” on page 314.



Task Window
For maximum performance and flexibility with 
file management tasks, Pro Tools provides the 
Task window. File management with Pro Tools 
involves nearly constant creating, copying, con-
verting, processing, searching, and indexing 
files. These tasks occur in the background, let-
ting you continue recording, editing, and mix-
ing without delay. 

The Task window lets you monitor, pause and 
cancel ongoing tasks including file copying, fade 
regeneration, and indexing. 

You cannot drag and drop items to or from 
the Task window.
Opening the Task Window

To open the Task Window:

 In Pro Tools, choose Window > Task Manager.

Task Window Messages
If any background task cannot be successfully 
completed, the Task window comes to the fore-
ground to notify you. The incomplete task is 
shown in the Paused Tasks pane of the Task win-
dow. 

Because the Task window is a floating window, it 
does not interrupt current work. This allows you 
to continue recording and editing, and postpone 
file management until a more convenient time.

Press Option+’ (Mac) or Alt+’ (Windows) to 
open the Workspace browser.
Task window, maximum view

Paused Tasks

Active Tasks

View Toggle (Maximize/Minimize)

Status
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Task Window Views
The Task window provides a maximized and 
minimized view.

To toggle between maximized and minimized 
views:

 Click the View Toggle icon in the top of the 
Task window. 

Task Window Tools, Columns, 
and Displays
The Task window menu provides commands for 
Task window operations.

The following data is always displayed in the 
Task window (both views):

Item Name Indicates affected item, whether a 
file, database, or other supported item.

Status Action being taken (for example, copy-
ing, processing, indexing and so on).

Progress Indicates the progress of the task or its 
sub-tasks, which include assessing the size of 
the items and the estimated amount of time nec-
essary to complete the task. 

Progress Indicator Indicates processing is ongo-
ing. 

Quantification Shows percentage of progress of 
the current task.

Active Tasks Pane

The upper Active Tasks pane shows the tasks 
that are in progress or waiting to start. The cur-
rently executing task is at the top. Tasks in this 
pane will be processed. 

Task window, minimum view
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As tasks complete, they disappear from the 
queue.

Any task that fails to complete successfully is 
moved to the Paused Tasks pane (see below). 
The Status column displays a description of the 
failure.

Paused Tasks Pane

The Paused Tasks pane is displayed below the 
Active Tasks pane, and is separated by a move-
able horizontal divider. Tasks listed in this pane 
will not be processed until they are moved back 
to the Active Tasks pane. 

Pausing and Cancelling Tasks
The Task window lets you pause, resume, and 
cancel tasks. 

To pause a task:

 Drag the appropriate task from the Active 
Tasks pane to the Paused Tasks pane. 

The task moves to the top of the Paused Tasks 
pane. 

To pause all tasks:

 Choose Pause All from the Task window menu.

To resume a task:

 Drag a task from the Paused Tasks pane to the 
Active Tasks pane. The task returns to its previ-
ous position in the queue. 

To resume all paused tasks:

 Select Resume All from the Task window 
menu. All tasks in the Paused Tasks pane (except 
failed tasks) are moved to the Active Tasks pane. 



To cancel a task:

1  Highlight any task in either pane of the Task 
window.

2  Press Delete to remove it from the Task win-
dow. 

To cancel all tasks:

1  Select any single task in either pane. 

2  Press Command+A (Mac) Control+A (Win-
dows) to select all the tasks in that pane.

3  Press Delete.

This command cannot be undone.

About Cancelling Tasks

Some tasks involve one or more sub-tasks. De-
leting a task cannot undo sub-tasks already 
completed. For example, if importing and con-
verting multiple files appears as a single task, 
deleting that task before it is completed stops 
the import and conversion process, but files al-
ready converted and imported remain on disk. If 
you want to cancel a task involving multiple 
sub-tasks, you can instead let the process com-
plete and then use Undo to completely undo all 
sub-tasks, as available. 

Closing Sessions with Pending 
Tasks
If you close a session or quit Pro Tools while 
tasks are still pending (either in the Active or 
Paused Tasks panes of the Task window) 
Pro Tools asks if you want to cancel, or complete 
the pending tasks. You can choose to open the 
Task window and wait for pending tasks to com-
plete, cancel the pending tasks, or quit. If you 
quit, some tasks are cancelled. Tasks that in-
volve file copies are remembered and restarted 
when you relaunch Pro Tools. 
About Failed Tasks

The Paused Tasks pane shows any tasks that 
could not be completed. The reason for the fail-
ure is shown in the Status column. 

Failed Tasks cannot be resumed, and must be 
deleted manually from the Paused Tasks pane. 

If Automatically Find and Relink was unable to 
find all files in a session, a failed task is placed in 
the Paused Tasks pane of the Task window. It re-
mains there unless you manually remove it from 
the Task window (even if you have since found 
the files through a subsequent search and relink 
task). 

Task Prioritization
A task that is in progress may be interrupted by 
a task of higher priority. When this happens, the 
partially completed task is halted and resched-
uled later in the queue, and shown with a prog-
ress bar in the Active Tasks pane. When the 
higher priority task is finished the first incom-
plete task in the queue resumes.

Tips for Using the Task Window

Pause Tasks During Playback 

A global preference Pause During Playback is 
provided in the Task window Browser menu. 
When enabled, Active Tasks are paused when-
ever Pro Tools is playing (or recording). This 
setting is especially useful when working on 
slower CPUs, or whenever you want to minimize 
system load for maximum playback and record-
ing performance. This preference maintains its 
setting until the next time it is changed. 
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Stored Tasks
Any task that imports files into a session is 
stored with a session when it is closed, and re-
sumes when the session is re-opened. 

For example, if you Import Session Data with 
Copy From Source Media selected, then Save and 
Close the session before the copy completes, the 
copy tasks resume when the session is reopened. 

Grouped Tasks
Some tasks consist of many smaller tasks. For 
instance, Copy and Relink may require hundreds 
of individual files to be copied. To help manage 
these tasks, they are grouped under the originat-
ing command. So in the example of a Copy and 

Relink command, one copy task would appear 
with an Expand/Collapse icon in the Task win-
dow. Clicking the icon shows each of the indi-
vidual sub-tasks.

If there is more than one grouped task in the 
queue, all of the sub-tasks for the first group 
must be completed before the sub-tasks of the 
second group can be processed.

If the session is saved and closed while several of 
these group tasks are in the queue, and if those 
tasks are the type that can be interrupted and 
saved when closing the session, all of the tasks 
reappear as part of the same group when the ses-
sion is reopened. 
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Chapter 17: Importing and Exporting Session 
Data
Pro Tools lets you import and export a variety of 
data into and out of a session, including audio 
and MIDI files, clip groups, video files, track 
playlists, I/O configurations, and signal routing 
configurations.

You can import individual audio and MIDI files 
into a session, or import entire audio or MIDI 
tracks, along with all of their attributes, from 
another session. Additionally, with Pro Tools 
HD, you have the option of importing any com-
bination of track attributes from another ses-
sion, such as a track’s audio or MIDI playlists, 
signal routing, plug-ins, or automation (see 
“Importing Session Data” on page 352). 

When you are working with video, you can im-
port and export video files from a session (see 
Chapter 51, “Working with Video in 
Pro Tools”). 
Importing and Exporting 
Data to and from a Session
Importing

Pro Tools lets you import audio, video, MIDI, 
clip groups, or session files into the current 
Pro Tools session by:

• Dragging and dropping from: 

• A DigiBase browser

• Mac Finder or Windows Explorer

• Using the File menu Import commands:

• Session Data

• Audio

• MIDI

• Video

• Clip Groups

• VENUE Channel Names as Track Names

Session data, audio files and clips can be im-
ported to existing tracks, new tracks, the Track 
List, or the Clip List in a Pro Tools session.
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Exporting

Pro Tools lets you export audio, video, MIDI, 
clip groups, and session data by:

• Using the Send Via DigiDelivery command

• Using the Export to Sibelius or Send to Sibelius 
command (MIDI only)

• Using the File menu Export commands:

• Selected Tracks as New AAF/OMF 

• Selected Tracks as New Session

• MIDI 

• Sibelius 

• Session Info As Text 

• Using the Tracks Right-click menu:

• Send To Sibelius command (Score Editor 
only)

• Export MIDI command

• Using the Clip List menu:

• Export Clip Definitions command

• Export Clips as Files command

• Export Clip Groups command
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Audio Conversion on Import
Depending on the properties of the audio files 
you are importing, you can add, copy, or convert 
the files:

 When files are added to a Pro Tools session, 
they remain at their current hard drive location 
and are not moved or copied. The session refer-
ences the original files wherever they are on 
your system. Additionally, the files referenced 
by the session retain their original file format, 
sample rate, and bit depth.

 When files are copied into the session, the 
original files remain wherever they are on your 
system and are copied to the session’s Audio 
Files folder and are then added to the session. 
The session references the copied files, not the 
original files. Additionally, the copied files ref-
erenced by the session retain their original file 
format, sample rate, and bit depth.

 When files are converted into the session, the 
original files remain wherever they are on your 
system, converted to the session file format, 
sample rate, and bit depth, and are written to the 
session’s Audio Files folder. The session refer-
ences the converted files, not the original files. 



Files that Can Be Added to a Session without 
Conversion

Any audio file of a supported file format (WAV 
and AIFF) and bit depth (16, 24, and 32-bit 
float) can be added to sessions without conver-
sion. Audio files with sample rates that do not 
match the session sample rate can be added to 
the session without conversion, but will play-
back at a different pitch and speed from files 
that match the session sample rate.

Files that Must Be Converted on Import

Audio files formats other than WAV and AIFF 
must be converted on import. Pro Tools auto-
matically converts these files to the current ses-
sion file format on import. Also, if the session is 
not enabled for Interleaved files, Pro Tools 
splits interleaved audio files into multiple mono 
files on import.

If clip definitions are present in an audio file, 
you can convert and import the audio for a clip 
without importing the entire parent audio file 
using the Import Audio command.

You can enable the Automatically Copy 
Files on Import option in the Processing 
Preferences page to be sure to always copy 
files to the session’s Audio Files folder when 
importing audio by drag and drop.

Pro Tools 7.x and higher does not support 
audio file names that contain certain ASCII 
characters (see “Opening a Session that 
Contains Audio File Names with Illegal 
Characters” on page 393).
Supported Audio File Formats
Audio files of the following types can be im-
ported into Pro Tools sessions without conver-
sion:

• AIFF

• WAV or BWF (.WAV) (including support for 
WAV Extensible and RF64)

Audio files of the following types can be im-
ported into Pro Tools sessions, but will be con-
verted to the current session file format on im-
port:

• AAC audio (including audio with AAC, 
Mp4, and M4a file extensions)

• ACID files

• MP3

• MXF audio

• QuickTime (Mac only)

• ReCycle (REX 1 and 2) files

• SD II

• SD I

• Sound Resource (AIFL—Mac only)

• WMA (Windows Media—Windows only)

Pro Tools cannot import protected AAC or 
MP4 files with the .M4p file extension. 
These files are protected under the rules of 
digital rights management.
Chapter 17: Importing and Exporting Session Data 333



334
Sample Rate Conversion Quality
The Sample Rate Conversion Quality setting de-
termines the quality of sample rate conversion 
used when converting and importing audio into 
a session. It can also applied when exporting 
files at different sample rate and when bouncing 
to disk. There are five possible settings, ranging 
from Low (fastest, but lowest quality) to Tweak 

Head (highest quality, but slowest). The higher 
the quality of sample rate conversion you 
choose, the longer Pro Tools will take to process 
the audio file.

The Sample Rate Conversion Quality options are 
available in the Import Audio, the Import Ses-
sion Data, the Export Clips as Files, and the 
Bounce to Disk dialogs. In each case, the Sample 

Rate Conversion Quality setting is local to that 
specific dialog. The Sample Rate Conversion 

Quality preference only applies to conversion on 
import by drag and drop.

To set the sample rate conversion quality for 
importing audio by drag and drop:

1  Choose Setup > Preferences and click the 
Processing tab.

2  From the Sample Rate Conversion Quality pop-
up menu, select a quality setting. For most appli-
cations, the Good or Better setting will yield very 
good results.

3  Click OK.

Sample Rate Conversion Quality preference

The Import Audio, Import Session Data, 
and Bounce To Disk dialogs provide local 
controls for sample rate conversion quality.
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Bit Depth Conversion and 
Dithering
If the Convert Copied Files on Import preference 
is enabled (Setup > Preferences > Processing), 
the following occurs when importing audio files 
with different bit depths than the current ses-
sion bit depth:

• When importing audio at a lower bit depth 
than the session, Pro Tools converts the file 
to match the session bit depth by adding 
empty bits. For example, when importing a 
16-bit file into a 24-bit session, Pro Tools 
converts the file to 24-bit.

• When importing audio at a higher bit depth 
than the session, Pro Tools automatically 
applies a preset, noise-shaped dither and 
converts the file to the session bit depth. 
For example, when importing a 24-bit file 
into a 16-bit session, dither is applied auto-
matically and the file is converted to 16-bit.



Importing Interleaved Files
When using the Import Audio command, inter-
leaved stereo files are automatically imported to 
stereo tracks. With Pro Tools HD and Pro Tools 
with Complete Production Toolkit, greater-
than-stereo multichannel audio files are auto-
matically imported to tracks with the corre-
sponding multichannel audio file format. 

If the Interleaved option is enabled for the ses-
sion, or is enabled on import, interleaved files 
are imported to the session and remain inter-
leaved files. If this option is not enabled, inter-
leaved files are split into multi-mono.

Conversely, split stereo (dual mono) audio files 
can be automatically imported to stereo tracks. 
Split stereo audio files must have the channel 
identifiers “.L” and “.R” in their names (for ex-
ample, filename.L and filename.R), and the files 
must be the same length. In Windows, or in 
Mac/PC Compatibility mode, these files will 
have a 3-letter file extension appended after the 
“.L” or “.R” channel identifier.
Importing Files with Drag 
and Drop
Pro Tools lets you import audio, MIDI, video, 
and session files by dragging and dropping files 
from a DigiBase browser, Windows Explorer, or 
Mac Finder to the Pro Tools application icon, 
the session Timeline, a track, the Track List, or 
the Clip List. 

Figure  on page 336 illustrates some of the op-
tions available to import files using drag and 
drop from DigiBase browsers. 

To import files into the Clip List:

1  Select audio, video, MIDI, clip group, REX, or 
ACID files in a DigiBase browser, or Windows 
Explorer, or Mac Finder. 

2  Drag the selected files onto the Clip List. 

To import files into an existing track:

1  Select the files you want to import in a Digi-
Base browser, or Windows Explorer or Mac 
Finder. 

2  Drag the selected file to a location on an exist-
ing, compatible track. The file is imported and 
placed where it was dropped. 

To import files as new tracks:

1  Select the files you want to import in a Digi-
Base browser, or Windows Explorer or Mac 
Finder. 

2  Do any of the following:

• Shift-drag files and drop anywhere in the 
Edit window. 

• Drop files to the Track List.

• Drop files to empty space in the Edit win-
dow, below or between tracks. 
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Importing from browsers by drag and drop 

Importing does not always convert or copy audio files. See “Audio Conversion on Import” on page 332.

Importing using drag and drop does not necessarily bring the Edit window to the foreground. For ex-
ample, dragging and dropping a file from a browser into a track leaves the source browser in the fore-
ground (not the Edit window). Always verify the active, foreground window or browser before con-
tinuing.

Drop files in the 
Clip List to import 

Drop media or session files
to existing tracks, or to the
Track List to add as new tracks

Catalogs

Workspace

Volumes



To import and spot files into a track:

1  Enable Spot mode. 

2  Select the files you want to import in a Digi-
Base browser, or Windows Explorer, or Mac 
Finder. 

3  Drag the files onto an existing, compatible 
track. The Spot dialog appears.

4  Enter the appropriate timecode location 
(where you want to spot the imported file).

5  Click OK.

To import and spot an audio file by its Waveform in 
DigiBase browsers: 

1  In a DigiBase browser, Control-click (Win-
dows) or Command-click (Mac) the file’s Wave-
form display at the approximate reference point 
you want to use for placement in a track. 

2  While continuing to press Control (Windows), 
or Command (Mac), drag the waveform onto an 
existing audio track (the source audio file and 
the destination audio track must have the same 
number of channels).

Snapping to Head and Tail
You can drag and drop files to tracks and have 
them snap to the head or the tail of the current 
Edit selection or insertion point. When snap-
ping to head, the beginning of the imported file 
snaps to the beginning of the Edit selection. 
When snapping to tail, the end of the imported 
file snaps to the beginning of the Edit selection.

To import and snap to head:

 Start-drag (Windows) or Control-drag (Mac) a 
file onto a track. 
To snap to head and copy the file to the session 
Audio files folder:

 Alt-Start-drag (Windows) or Option-Control-
drag (Mac) a file onto a track. 

To snap to tail:

 Control-Start-drag (Windows) or Command-
Control-drag (Mac) a file onto a track. 

To snap to tail and copy the file to the session 
Audio Files folder: 

 Control-Alt-Start-drag (Windows) or Com-
mand-Option-Control-drag (Mac) a file onto a 
track. 

Elastic Audio on Import
When importing any audio file by drag and drop 
to an Elastic Audio-enabled track, the audio file 
is imported and analyzed (if not already ana-
lyzed). If the imported audio file is tick-based, it 
is conformed to tempo using the track’s Elastic 
Audio plug-in. If it is a sample-based audio file, 
such as a single drum hit or short sound effect, it 
maintains its original duration. Longer audio 
files with no detectable tempo also remain sam-
ple-based.

You can also import audio by drag and drop to 
create new tick-based Elastic Audio-enabled 
tracks.

When importing tick-based audio by drag and 
drop from DigiBase browsers to the Track List 
or empty space in the Edit window, Pro Tools 
creates a new tick-based, Elastic Audio-enabled 
track using the default Elastic Audio plug-in se-
lected in the Processing Preferences page (see 
“Elastic Audio Options” on page 344).
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If you are importing an audio file by drag and 
drop from Windows Explorer or Mac Finder to 
the Track List or to empty space in the Edit win-
dow, files are imported as sample-based or as 
tick-based Elastic Audio depending on the Drag 

and Drop from Desktop Conforms to Session 

Tempo preference (see “Drag and Drop From 
Desktop Conforms to Session Tempo” on 
page 344).

Importing Elastic Audio from 
DigiBase to the Clip List
With the Audio Files Conform to Session Tempo 
option enabled, dragging and dropping tick-
based audio from DigiBase browsers to the Clip 
List (or to the Track List), creates two separate 
clips in the Clip List. The first is a sample-based 
whole file clip and the second is a tick-based 
copy of the same clip.

Importing Tempo from 
Tick-Based Audio
If there are no tracks in the session, and you im-
port a tick-based audio file to the Clip List, 
Track List, or empty space in the Edit window, 
you are prompted to either import the tempo 
from the file or use the default session tempo. 
To keep the default session tempo, and have the 
loop conform to the session tempo, click Don’t 

Import. 

If the session already contains at least one track 
(regardless of track type), you are not prompted 
to import the tempo from the file and the file is 
conformed to the session tempo.
Pro Tools Reference Guide
Importing Audio Files and 
Clips Using the Import Audio 
Command
The Import Audio command lets you import au-
dio files or clips into your Pro Tools session.

To import audio files or clips into a session using 
the Import Audio command:

1  Choose File > Import > Audio. 

2  In the Import Audio dialog, locate and select 
an audio file to display its properties and associ-
ated clips.

You can choose to display only a certain file type 
(such as WAV) by selecting the type from the 
Show pop-up menu. To display all supported file 
types, select All Documents from the Show pop-
up menu.

To import entire tracks from other sessions, 
see “Importing Session Data” on page 352.

Import Audio dialog



In the import list, audio files are distinguished 
from clips by their icons.

3  To preview a selected file or clip before you im-
port it, click the Play and Stop buttons in the Im-
port Audio dialog.

Adjust the preview volume with the vertical 
slider. To navigate to a particular location in the 
file, use the horizontal slider under the Play and 
Stop buttons. 

The audition output path defaults to channels 
1–2. For Pro Tools systems with more than 2 
channels of output, the audition path can be 
changed in the I/O Setup (see “Audition Paths” 
on page 93).

File and Clip icons in the Import Audio dialog

On Mac, Sound Resource files must have the 
“.SFIL” extension to be imported by 
Pro Tools. 

The Preview Volume control in the Import 
Audio dialog also affects the preview volume 
when auditioning clips in the Clip List.

Audio File icon

Audio Clip icon
4  Do any of the following:

• To place a file or clip in the Import list, se-
lect the file and click Add or Convert. 

• To import all files and clips in the current 
directory, click Add All or Convert All. 

• To remove a file or clip from the Import list, 
select it and click Remove. 

• To remove all files and clips, click Remove 

All.

5  When you have added all audio files and clips 
to the Import list, you can apply sample rate con-
version by doing the following:

• Enable Apply SRC.

• Specify the Source Sample Rate either by 
typing a number, or by selecting a sample 
rate from the pop-up menu.

• Select the sample rate conversion quality 
from the Quality pop-up menu. This setting 
overrides the Sample Rate Conversion Qual-

ity setting in the Processing Preferences 
page.

6  Click Done.

7  If you are copying or converting files, choose a 
location for the new files. Choose a folder on a 
valid audio drive, such as the Audio Files folder 
for the current session. 

Pro Tools lets you add files to a session that 
are at a different sample rate than your 
session. In the comments field of the Import 
Audio dialog, a warning is posted that these 
files will play back at the wrong speed and 
pitch if they are not converted.
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8  In the Audio Import Options dialog, select 
where the imported files will go in the session:

New Track Each audio file is imported into its 
own individual track and into the Clip List. 

When importing audio into a track, you can also 
choose the location in the track where the audio 
file will begin (such as Session Start).

Clip List Audio files are imported into the Clip 
List without creating a new track. Imported au-
dio files appear in the Clip List and can then be 
dragged to audio tracks.

9  If you chose to create a new track, choose a lo-
cation for the imported file in the track:

Session Start Places the file or clip at the start of 
the session. 

Song Start Aligns the beginning of the file or 
clip to the Song Start point. 

Selection Aligns the beginning of the file or clip 
to the edit cursor or to the beginning of a selec-
tion in the Timeline.

Spot Displays the Spot dialog, which lets you 
spot the file or clip to a precise location based on 
any of the Time Scales.

10  Click OK.

Audio Import Options dialog
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Importing Audio from 
Audio CDs
Pro Tools lets you import tracks from audio CDs 
using the same methods that you use to import 
audio files, as follows:

• Drag and drop CD audio from the CD 
folder.

• Drag and drop files from DigiBase Browser.

• Use the Import Audio command.

Before importing CD audio, make sure your 
hard drive has enough space for the converted 
audio files.

Because the transfer is made in the digital do-
main, there is no signal loss.

The sample rate for audio CDs is 44.1 kHz. 
Therefore, if your session’s sample rate is set to 
48 kHz or higher, Pro Tools will convert the 
sample rate for the imported audio. Before im-
porting CD audio, set the Sample Rate Conver-

sion Quality preference accordingly. For more in-
formation, see “Sample Rate Conversion 
Quality” on page 334.

Importing CD audio with either drag and 
drop method lets you continue working in 
the session foreground (such as in the Mix or 
Edit window), while the Task Manager 
(Window > Task Manager) works in the 
background (importing and converting the 
audio until the import is completed). For 
more information on the Task Manager, see 
“Task Window” on page 327.



Importing ACID and REX 
Files
ACID files and REX 1 and 2 files are converted to 
the session audio file type. Depending on the 
preferences settings, ACID and REX files can be 
imported as sample-based clips or as tick-based 
Elastic Audio clips. For REX files only, 
Pro Tools uses any slice data to create Event 
markers with 100% confidence. ACID files are 
analyzed for Elastic Audio events just like WAV 
files, and so events are detected with varying de-
grees of confidence.

REX files can also be imported as tick-based clip 
groups. 

To import ACID and REX flies as sample-based 
clips:

1  Choose Setup > Preferences and click the Pro-

cessing tab.

2  Disable the Import REX Files as Clip Groups op-
tion.

3  Select No Files as the Drag and Drop from Desk-

top Conforms to Session Tempo preference.

4  Click OK to close the Preferences dialog.

5  When importing by drag and drop from Di-
giBase browsers, make sure that the Audio Files 

Conform to Session Tempo option is disabled.

6  Import the ACID and REX files you want by 
drag and drop from a DigiBase browser or the 
Desktop, or using the Import Audio command 
(see “Importing Audio Files and Clips Using the 
Import Audio Command” on page 338).

For information on Elastic Audio, see 
Chapter 41, “Elastic Audio.”

For information on clip groups, see “Clip 
Groups” on page 851).
To import ACID and REX files as tick-based Elastic 
Audio clips:

1  Choose Setup > Preferences and click the Pro-

cessing tab.

2  Disable the Import REX Files as Clip Groups op-
tion.

3  Select REX and ACID Files Only or All Files as 
the Drag and Drop from Desktop Conforms to Ses-

sion Tempo preference.

4  Click OK to close the Preferences dialog.

5  Do one of the following:

• Import the REX files you want by drag and 
drop from a DigiBase browser 

• Import the REX files you want by drag and 
drop from the Desktop.

• Use the Import Audio command (see “Im-
porting Audio Files and Clips Using the Im-
port Audio Command” on page 338).

To import REX files as tick-based clip groups:

1  Choose Setup > Preferences and click the Pro-

cessing tab.

2  Select the Import REX Files as Clip Groups op-
tion.

3  To apply real-time crossfades to the files, en-
able the Automatically Create Fades option (see 
“Automatic Fades for Imported REX Files” on 
page 342).

4  Select REX and ACID Files Only or All Files as 
the Drag and Drop from Desktop Conforms to Ses-

sion Tempo preference.

5  Click OK to close the Preferences dialog.
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6  Do one of the following:

• Import the REX files you want by drag and 
drop from a DigiBase browser 

• Import the REX files you want by drag and 
drop from the Desktop.

• Use the Import Audio command (see “Im-
porting Audio Files and Clips Using the Im-
port Audio Command” on page 338).

Automatic Fades for Imported REX Files

If the Import REX Files as Clip Groups option is 
enabled in the Processing Preferences page, 
Pro Tools can automatically apply real-time 
crossfades to the clips or “slices” in imported 
REX format files. 

To apply real-time crossfades to REX files:

1  Choose Setup > Preferences and click the Pro-

cessing tab.

2  Enable the Import REX Files as Clip Groups op-
tion.

3  Enable the Automatically Create Fades option.

4  In the Preferences dialog, click the Editing tab. 

5  Under Default Fade Settings, click REX.

6  In the REX Auto-Crossfades dialog, select the 
shapes you want for crossfades, and click OK. 

7  Click OK to close the Preferences dialog.

Depending on your edits or tempo changes 
after importing REX files, fades can be de-
leted and you will have to recreate them 
manually.
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Importing Multichannel Audio 
Files from a Field Recorder
Pro Tools lets you use any of its import methods 
to import monophonic and polyphonic audio 
files recorded by a field recorder. When you im-
port these types of files, they must be converted 
to an audio format compatible with Pro Tools.

Importing Monophonic Audio 
Files
A monophonic audio file contains one mono 
channel and relevant metadata from a single 
multichannel recording. 

When you import monophonic audio files that 
were recorded simultaneously, they are con-
verted to multichannel clips and displayed to-
gether in the Clip List. Any metadata is also im-
ported with the files.

Importing Polyphonic Audio 
Files
A polyphonic audio file contains multiple mono 
channels and relevant metadata recorded simul-
taneously in a multichannel recording.

When imported into Pro Tools, a polyphonic au-
dio file is divided into individual monophonic 
audio files written to disk—one file for each 
channel. Clips for each channel appear in the 
playlist, and a multichannel clip appears in the 
Clip List with the channels expandable under-
neath. Any metadata is also imported with the 
files. 

For more information on importing files 
from a field recorder, see Chapter 52, 
“Working with Field Recorders in 
Pro Tools.”



Import Options and 
Preferences
Pro Tools provides several options and prefer-
ences that affect audio import. Configure 
Pro Tools to match your most common work-
flows. For example, if you frequently work by 
importing REX files for loop-based composi-
tion, you can configure Pro Tools to always im-
port REX files to conform to tempo and create 
new tick-based Elastic Audio tracks.

Convert Imported “WAV” Files To AES31/Broad-
castWave When selected, this option applies to 
all newly imported WAV files, making them 
compliant with the AES31/EBU Broadcast 
standard.

Automatically Copy Files on Import When se-
lected, all audio files that are imported by drag-
ging and dropping are copied to the current ses-
sion’s Audio Files folder, regardless of whether 
the files need to be converted to the current ses-
sion’s file type, bit depth, or sample rate. Addi-
tionally, when selected, the Import Session Data 
dialog defaults to Copy from Source Media. The 
Automatically Copy Files on Import preference 
does not affect the Import Audio command.

Import options in the Processing Preferences page
Convert Copied Files to Session Format When 
selected, files that have different file formats 
from the current session file format are copied 
and converted to the current session audio file 
format, bit depth, and sample rate on import. 
For example, if the session file format is WAV, 
24-bit, 48 kHz and you import an AIF, 16-bit, 
44.1 kHz file, the file is copied and converted to 
WAV, 24-bit, 48 kHz on import. When this op-
tion is not selected, copied files retain their 
original format (unless that file format is in-
compatible with Pro Tools, in which case it must 
be converted).

Do Not Convert Sample Rate on Import When 
selected, files with different sample rates than 
the session sample rate are not automatically 
converted when imported into the session. This 
means that files with mis-matched sample rates 
play back at a different speed (and pitch trans-
positions than when they were originally re-
corded (or converted).

Import REX Files as Clip Groups When selected, 
REX flies are imported as clip groups, all the un-
derlying slices are imported as individual clips 
contained within the clip group. When this op-
tion is not selected, importing REX files into a 
session converts them to the session’s audio file 
format, the individual slices are consolidated, 
and the slice information is used for Elastic Au-
dio analysis. These files remain tick-based after 
import and conversion. 

Automatically Create Fades When selected, 
crossfades are applied automatically to the 
sliced clips within clip groups created by im-
porting REX files. If the Import REX Files as Clip 

Groups option is not selected, the Automatically 

Create Fades option does not apply. 

To change the default fade settings for REX files, 
click the REX button in the Default Fade Set-
tings section on the Editing Preferences page 
(see “Fades Editing Preference” on page 345).
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Drag and Drop From Desktop Conforms to 
Session Tempo

The Drag and Drop From Desktop Conforms to 

Session Tempo options determine whether or 
not REX, ACID, and all other audio file formats 
dragged and dropped from Windows Explorer or 
Mac Finder are imported as tick-based Elastic 
Audio and conformed to the session tempo.

None When enabled, all audio files, including 
REX and ACID files, are not conformed to the 
session tempo when imported by drag and drop 
from Windows Explorer or the Mac Finder. They 
are imported as sample-based files and con-
verted to the sessions audio file format.

REX and ACID Files Only When enabled, only 
REX and ACID files are conformed to the session 
tempo when imported by drag and drop from 
Windows Explorer or the Mac Finder. REX files 
are imported either as tick-based Elastic Audio 
or, if the Import REX Files as Clip Groups option 
is enabled, as tick-based clip groups. 

All Files When enabled, all audio files are im-
ported as tick-based Elastic Audio and conform 
to the session tempo.

Sample Rate Conversion Quality

The Sample Rate Conversion Quality preference 
determines the quality of sample rate conver-
sion used when converting and importing audio 
into a session by drag and drop. Sample rate 
conversion is used in a variety of Pro Tools pro-
cesses including converting and importing au-
dio files of different formats into a session, and 
bouncing and saving tracks to a different sample 
rate or bit depth. The higher the quality of sam-
ple rate conversion you choose, the longer 
Pro Tools will take to process the audio file.
Pro Tools Reference Guide
Elastic Audio Options

The Elastic Audio preferences determine which 
Elastic Audio plug-in is used for preview and 
import, and whether or not new tracks are cre-
ated with Elastic Audio enabled using the se-
lected default plug-in.

Default Plug-In Lets you select any Real-Time 
Elastic Audio plug-in as the default plug-in for 
previewing and importing Elastic Audio. The se-
lected default Elastic Audio plug-in is also used 
when new tracks are created with Elastic Audio 
enabled. The Elastic Audio Plug-In selector in 
DigiBase browsers inherits the selected default 
plug-in. Likewise, changing the selected plug-in 
in DigiBase browsers updates the selected De-

fault Plug-In in the Processing preferences.

Default Input Gain Lets you attenuate the signal 
input to Elastic Audio plug-ins by 0 to –6 dB for 
preview and import. If you experience clipping 
due to Elastic Audio processing during preview 
or after import, you may want to set the Default 

Input Gain to slightly attenuate (lower) the audio 
signal input for Elastic Audio processing. This 
preference also applies to any audio imported to 
an Elastic Audio-enabled track.

If you commit any clips on a track (by disabling 
Elastic Audio on the track) that were imported 
with the Default Input Gain applied, their clip-
based In put Gain is reset to 0.

Processing Preferences, Elastic Audio 



The Elastic Properties window inherits the De-
fault Input Gain preference. To apply further 
clip-based Input Gain for Elastic Audio process-
ing, select the clip and adjust the Input Gain set-
ting in the Elastic Properties window (see “Elas-
tic Properties Window” on page 902).

Enable Elastic Audio on New Tracks When se-
lected, new tracks are created with Elastic Audio 
enabled. The selected default Elastic Audio 
plug-in is used. When importing audio to new 
tracks, new tracks are created with Elastic Audio 
enabled if this option is enabled.

Tracks Preference

When the New Tracks Default To Tick Timebase 
option is enabled, all new tracks default to ticks. 
This includes importing audio to new tracks. 
When deselected, audio, Auxiliary Input, Mas-
ter Fader, and VCA (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only) tracks 
default to samples. MIDI and Instrument tracks 
always default to ticks.

If the Enable Elastic Audio on New Tracks 
option is selected, you may want to also 
select the New Tracks Default to Tick Time-
base option in the Editing Preferences page.
Fades Editing Preference

The Default Fade Settings for REX files in the Ed-
iting preferences lets you select the default en-
velope shape for fades and crossfades between 
clips (“slices”) in imported REX files. Fades are 
only applied to imported REX files if the Import 

REX Files as Clip Groups option and the Automat-

ically Create Fades option are both enabled on 
the Processing Preferences page.

Exporting Audio
Pro Tools supports exporting audio clips as au-
dio files, exporting left and right audio files as 
stereo interleaved files, and exporting clip in-
formation.

You can also export audio from Pro Tools by 
bouncing or consolidating audio tracks. For 
more information, see “Bounce to Disk” on 
page 1084 and “Consolidating Clips” on 
page 611.

REX Auto-Crossfades preference and dialog
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Exporting a Clip as a New Audio 
File
You can export clips as audio files with the 
Export Clips as Files command. Use this 
command if you intend to use a clip in other ses-
sions (or other audio applications) without us-
ing its parent source file. 

This command also provides a way to convert 
clips to a different audio format, sample rate, or 
bit depth.

To export clips as new audio files:

1  In the Clip List, select the clips you want to ex-
port.

2  From the Clip List menu, choose Export Clips 

as Files. 

Warped clips (Elastic Audio) will be ex-
ported unwarped at their original duration.

Export Selected dialog
Pro Tools Reference Guide
3  In the Export Selected dialog, set the File Type, 
Format, Bit Depth, and Sample Rate. In addition, 
specify the Conversion Quality, and choose the 
Destination Directory.

When you export clips to a lower bit depth, 
Dither (with or without Noise Shaping) is ap-
plied as shown in the following table.

The Dither used for any conversion is the Avid 
Dither plug-in (with or without Noise Shaping 
enabled.

Dither and Noise Shaping with Export Selected dialog

Bit Depth Dither
Noise 
Shaping

32-bit float to 32-bit 
float

Yes Yes

32-bit float to 24-bit Yes Yes

32-bit float to 16-bit Yes Yes

32-bit float to 8-bit Yes No

24-bit to 32-bit float No No

24-bit to 24-bit No No

24-bit to 16-bit Yes Yes

24-bit to 8-bit Yes No

16-bit to 32-bit float No No

16-bit to 24-bit No No

16-bit to 16-bit No No

16-bit to 8-bit Yes No

For more information about using Dither, 
see “Dither” on page 984.



4  If you are exporting to an 8-bit file, enable the 
Use Squeezer option. This optimizes the dynam-
ics of the exported audio by preprocessing it us-
ing compression, limiting, and gating before 
conversion to 8-bit resolution (for more infor-
mation, see “Use Squeezer” on page 1090).

5  To share with SoundCloud, select the Share 
with SoundCloud option (see “Share with 
SoundCloud” on page 1091).

6  Select an option for how Pro Tools should re-
solve duplicate file names. 

Prompting for Each Duplicate Prompts you for a 
file name for any file that has the same name as 
a file in your destination directory. 

Auto Renaming Automatically changes the 
name of any duplicate file by adding a number at 
the end of the file name (such as file_01). 

Replacing with New Files Replaces files with the 
same name with the new files.

7  Click Export to export the new audio files.

Exporting Stereo or 
Multichannel Interleaved Files
You can use the Export Clips as Files command to 
export audio clips to stereo or multichannel in-
terleaved files for use in other applications. 
(Pro Tools cannot use interleaved files directly 
in the Timeline—these must be converted into 
multiple mono files.) For example, for this to 
work with a stereo file, the selected clips must 
have identical names with “.L” and “.R” suffixes 
(for instance, vocals_01.L and vocals_01.R). 
These clips appear as a stereo clip in the Clip 
List.

Pro Tools HD and Pro Tools with Complete Pro-
duction Toolkit also let you bounce multichan-
nel interleaved files of any supported file type. 
To export clips as a stereo or multichannel 
interleaved file:

1  Select the stereo or multichannel audio clip in 
the Clip List or in the track playlist. If the clips 
appear on mono tracks in the session, select the 
two mono clips.

2  From the Clip List menu, choose Export Clips 

as Files.

3  In the Export Selected dialog, select Stereo In-

terleaved in the Format pop-up menu. For multi-
channel clips, the Stereo Interleaved option 
produces a multichannel interleaved file.

4  Configure any other output settings, then click 
Export to export the new stereo interleaved file.

Exporting Clip Definitions
Pro Tools stores clip definitions for audio files 
within each session. If you want to use an audio 
file’s clips in another session, or with another 
application that supports them, you can export 
the clip information. 

The Export Clip Definitions command does not ex-
port clips as audio files (unlike the Export Clips 

as Files command). Instead, it stores pointers to 
the clips within the parent source file.

To export clip definitions for an audio file:

1  In the Clip List, select any clips or clip groups 
for which you want to export definitions. You do 
not have to select the parent file audio clip.

2  Choose Export Clip Definitions from the Clip 
List menu.

3  Click Export.

If you plan to transfer Pro Tools session 
data to another session, you should export 
clip definitions for sessions containing mul-
tiple takes created with Loop Record.
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Importing MIDI Files
You can import Standard MIDI Files (SMF) into 
your Pro Tools sessions.

Pro Tools provides several ways to import MIDI 
files into an open session.

• “Importing MIDI Files Using Pro Tools 
Menu Commands” on page 348.

• “Importing MIDI Files with Drag and Drop” 
on page 349.

Pro Tools does not import proprietary sequence 
files. To use sequences from other MIDI applica-
tions in a Pro Tools session, you will need to 
first save them as Standard MIDI Files. See the 
manufacturer’s documentation for details on 
saving Standard MIDI Files.

There are two types of Standard MIDI Files, both 
of which are supported by Pro Tools:

• Type 0 MIDI files store data for all MIDI chan-
nels in a single track. When importing these 
files, Pro Tools separates the data by channel 
and places each track’s data in separate clips 
and tracks.

• Type 1 MIDI files, sometimes referred to as 
multitrack MIDI files, contain multiple tracks 
of MIDI data. When importing these files, 
each track’s data is placed on its own new 
MIDI track in the Pro Tools session.
Pro Tools Reference Guide
Importing MIDI Files Using 
Pro Tools Menu Commands
Pro Tools provides commands to import MIDI 
files.

To import Standard MIDI Files into a session using 
the Pro Tools File menu:

1  Choose File > Import > MIDI and select the file 
you want to import.

2  In the MIDI Import Options dialog, choose 
where the imported file will go:

New Track Creates a new track where the file will 
be imported.

Clip List Imports the file into the Clip List, 
where it will be available to place into tracks.

3  If you chose to create a new track, choose a lo-
cation for the imported file in the track:

Session Start Places the file or clip at the start of 
the session. 

Song Start Aligns the beginning of the file to the 
Song Start point. 

MIDI Import Options dialog



Selection Aligns the beginning of the file to the 
edit cursor or to the beginning of a selection in 
the Timeline.

Spot Displays the Spot dialog, which lets you 
spot the file to a precise location based on any of 
the Time Scales.

4  Select any of the following Import options:

Import Tempo Map From MIDI File When se-
lected, overwrites any existing tempo and meter 
map with tempo and meter information read 
from the MIDI file. 

Import Key Signature From MIDI File When se-
lected, overwrites any existing key signatures 
with key signature information read from the 
MIDI file. 

Remove Existing Instrument Tracks When se-
lected, deletes any existing Instrument tracks. 
Selecting this option does not remove any cur-
rent MIDI tracks. All existing MIDI clips will be 
left in the Clip List.

Remove Existing MIDI Tracks When selected, 
deletes any existing MIDI tracks. Enabling this 
option does not remove any current Instrument 
tracks. All existing MIDI clips will be left in the 
Clip List.

Remove Existing MIDI Clips When selected, de-
letes existing MIDI clips (all data on all MIDI 
and Instrument tracks) but leaves existing MIDI 
and Instrument tracks in place. 

5  Click OK.

The MIDI file will be imported according to the 
settings in the Import MIDI Settings dialog.

If the Standard MIDI File contains markers, 
they are only imported if the current session 
does not contain any markers.
6  In the Mix window, click the MIDI Output se-
lector for each new track and assign a MIDI in-
strument and channel.

Importing MIDI Files with Drag 
and Drop
You can drag and drop MIDI files from a Digi-
Base browser, Windows Explorer, or Mac Finder 
to the Timeline, a track, the Track List, or the 
Clip List.

To import MIDI into the Clip List:

1  Select MIDI files in a DigiBase browser, or 
Windows Explorer, or Mac Finder. 

2  Drag the files onto the Clip List of the current 
session. 

To import MIDI into an existing track:

1  Select MIDI files in a DigiBase browser, Win-
dows Explorer, or Mac Finder. 

2  Drag the files onto an existing track in the Edit 
window of the current session. 

To import MIDI into new tracks:

1  Select MIDI files in a DigiBase browser, Win-
dows Explorer or Mac Finder. 

2  Do one of the following:

• From the DigiBase browser, Shift-drag the 
files anywhere in the Edit window of the 
current session.

• Drag the files to the Timeline of the current 
session.

• Drag the files to the Track List.

For more information on using DigiBase 
browsers, see “DigiBase” on page 281.
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Exporting MIDI Files
To export a session’s MIDI tracks for use in an-
other MIDI application, or for playback with an 
external (hardware) MIDI sequencer, you can 
export Pro Tools MIDI and Instrument tracks as 
a Standard MIDI File. 

MIDI can be exported from Pro Tools as a 
merged, single, multichannel track (Type 0), or 
as multiple tracks (Type 1).

If your Pro Tools session uses key signatures 
and meters, they are exported with the MIDI 
file.

To export all MIDI and Instrument tracks in the 
current session:

1  Make sure to unmute any MIDI tracks in the 
session that you want included in the exported 
MIDI file. (Or, conversely, mute any MIDI tracks 
you do not want included in the exported MIDI 
file.) For Instrument tracks, enable or disable 
the MIDI mute button (Instruments view).

2  Choose File > Export > MIDI. The Export MIDI 
Settings dialog opens.

3  From the MIDI File Format pop-up menu, select 
1 (multitrack) or 0 (single track).

4  If the Song Start time is different from the Ses-
sion Start time, select Session Start or Song Start 
from the Location Reference pop-up menu.

Export MIDI Settings dialog
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5  Enable or disable the Apply Real-Time Proper-

ties option.

6  Click OK.

7  Specify a folder destination and name for the 
MIDI file.

8  Click Save. 

Pro Tools exports all unmuted MIDI and Instru-
ment tracks in the current session to a Standard 
MIDI File and writes it to your hard drive. Ex-
ported MIDI information includes notes, con-
troller events, program changes, and System Ex-
clusive data, as well as events for tempo, meter, 
and markers.

The SMPTE start time for the session or the song 
(depending on the selection from the Location 

Reference pop-up menu) is also exported. This 
ensures that the exported tracks, when played 
from another MIDI application, will align with 
the correct SMPTE frames, and also synchronize 
correctly to tape and video devices, or 
Pro Tools.

See your third-party MIDI sequencer documen-
tation to determine whether it supports import-
ing SMPTE start times from MIDI files.

Items Not Exported with MIDI Files

Mute automation and muted clips do not affect 
exported MIDI. As long as a MIDI track is not 
muted by clicking its Mute button, or an Instru-
ment track is not muted by clicking its MIDI 
Mute button (Instruments view), all of its MIDI 
data is exported.

Chord symbols and chord diagrams are not ex-
ported with MIDI files.

Pro Tools automatically adds the “.mid” ex-
tension when exporting MIDI files.



When exporting MIDI files from Pro Tools, de-
vice assignments for tracks are not retained 
(though channel assignments are). If you export 
MIDI or Instrument tracks from Pro Tools and 
later re-import them, you will need to reassign 
the tracks to devices in your studio.

All playlist information for MIDI and Instru-
ment tracks is lost when exporting. For example, 
tracks that previously contained dozens of MIDI 
clips will be flattened and only contain single 
clips after exporting and re-importing.

Exporting Individual MIDI and 
Instrument Tracks
You can also export individual MIDI and Instru-
ment tracks as MIDI files. This can be useful for 
storing libraries of your favorite MIDI se-
quences or Sysex data (such as bulk or individ-
ual patch dumps for your external MIDI de-
vices), or for importing MIDI into notation 
applications (other than Sibelius).

To export a single MIDI or Instrument track as a 
MIDI file:

1  Do one of the following:

• Right-click the Track name of an unselected 
track in the Edit or Mix window, or in the 
Track List.

– or –

• In the Track List, or Mix or Edit window, 
Control-Right-click (Windows) or Com-
mand-Right-click (Mac) the track name. 

2  From the Right-click menu, select Export MIDI.

3  Set the Export MIDI settings in the Export 
MIDI Settings dialog.

4  Click OK.
5  In the Save dialog, type a name for the MIDI 
file, specify where you want to save it, and click 
Save.

To export all selected Pro Tools Instrument or MIDI 
tracks as a MIDI file:

1  Select the tracks you want to export to a MIDI 
file.

2  Right-click the Track name of one of the se-
lected tracks in the Edit or Mix window, or in the 
Track List.

3  From the Right-click menu, select Export MIDI.

4  Set the Export MIDI settings.

5  Click OK. 

6  In the Save dialog, type a name for the MIDI 
file, specify where you want to save it, and click 
Save.

Exporting Sibelius Files
Pro Tools can export the score of your session as 
a Sibelius file (.sib). You can choose to export 
the score as Sibelius file for later use or score 
transfer, or to open the score in Sibelius imme-
diately (if Sibelius) is installed on your com-
puter. Sibelius uses the Pro Tools transcription 
of MIDI in your session as seen in the Pro Tools 
Score Editor window (for more information, see 
“Exporting Scores” on page 756). 

Alt-Right-click (Windows) or Option-Right-
click (Mac) to export all tracks to a single 
MIDI file.

Alt-Shift-Right-click (Windows) or Option-
-Shift-Right-click (Mac) to export all se-
lected tracks as a single MIDI file.

Sibelius 5.x or higher is required to open 
.sib files exported from Pro Tools.
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Importing Session Data
You can import entire tracks from other 
Pro Tools sessions into the current Pro Tools 
session using the Import Session Data command 
or drag and drop. 

With Pro Tools, you can import tracks and you 
can select specific session data (such as automa-
tion and routing) to import. You can also import 
main playlist options—either replacing existing 
options or overlaying elements onto existing 
tracks.

To import tracks or their attributes:

1  Open or create a new session.

2  Do one of the following:

• Choose File > Import > Session Data, select 
the session to import data from, and click 
Open. 

– or –

• Drag the session file whose tracks or attri-
butes you want to import from a DigiBase 
browser, Windows Explorer, or Mac Finder 
into empty space in the Edit window or to 
the Track List.

3  If the Fader Gain setting of the session is dif-
ferent, you will be prompted to keep or change 
the Fader Gain before the Session Data dialog 
opens.
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4  In the Source section, select tracks to import 
by clicking the pop-up menu to the right of each 
track name and selecting New Track. 

5  For each track you select, you can choose to 
import it as a new track, or choose a destination 
track from the corresponding pop-up menu. 
Click Match Tracks to automatically match 
source and destination tracks with the same 
names. 

6  Select any additional track data you want to 
import from the Track Data to Import pop-up 
menu. 

7  Select from among the Main Playlist Options to 
choose how you want to import the source 
tracks. 

8  If applicable, choose options for how media 
files should be imported from the Audio Media 

Options and the Video Media Options pop-up 
menus. 

9  Choose the Timecode Mapping Options for im-
ported data. 

10  If the sample rates of the sessions are differ-
ent, select the sample rate for the source session 
from the Source Sample Rate pop-up menu. 

11  To import the meter and tempo maps from 
the source session, select the Import Tempo/Me-

ter Map option.

12  To import key signatures from the source ses-
sion, select the Import Key Signature Map option.

To select multiple tracks, Alt-click (Win-
dows) or Opt-click (Mac) on any track pop-
up menu and select Import As New Track.

If the destination Pro Tools system does not 
support surround mixing, surround tracks 
are not displayed in the Source Track List.



13  To import Markers and Memory Locations 
from the source session, select the Import 

Marker/Memory Locations option.

14  To import Window Configurations, select the 
Import Window Configurations option.

15  With Pro Tools HD, select the Import Mic Pre 

Settings option to import any Mic Pre settings 
from the source session.

16  Click OK when you are finished.

17  If you chose to copy or consolidate media, 
choose a location to place the media files.

Importing Grouped Playlists 
from Other Sessions
You can import tracks that use Grouped Play-
lists from another Pro Tools session, and the 
playlist grouping function will remain intact for 
those imported tracks. There is, however, a re-
striction for importing from pre-Pro Tools 6.1 
sessions: After importing a partial set of 
grouped playlists (such as tracks 1–7 of a 10-
track group), you cannot subsequently import 
tracks 8–10 and have them rejoin the playlist 
group for tracks 1–7.

Imported tracks are made inactive if their 
source media is unavailable, or if the cur-
rent session does not contain an equivalent 
output path.
Importing Sessions and Tracks 
by Drag and Drop
Session files can be dragged into the current 
session to import (and spot) audio, video, MIDI, 
clip group, REX and ACID files, tracks, and ses-
sion data. 

• Dragging a session to the Clip List imports all 
the clips from that session (without importing 
tracks). 

• Dragging a session to a track in Pro Tools lets 
you import tracks.

• Dragging a session to a track playlist in 
Pro Tools opens the Import Session Data dia-
log, letting you select tracks and attributes to 
import. The imported session data will begin 
wherever you drop the session in the Timeline.

To import tracks and other session data by drag 
and drop:

1  Open a browser.

2  Drag a Pro Tools session file, or an AAF or 
OMF sequence, into the current session, as fol-
lows: 

• Drag onto an existing track to overlay or 
overwrite data on the target tracks. Hold 
the Shift key while dragging if you intend to 
replace the current track playlists with 
those being imported (the Shift key pre-
configures the settings in the Import Ses-
sion Data dialog).

• Drag to empty space in the Edit window to 
create new tracks for the imported session 
data. 

• Configure the Import Session Data options 
(see “Import Session Data Dialog” on 
page 354). 
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Copying During Import
If no conversion is necessary, and the files re-
side on a suitable Performance volume, 
Pro Tools references the original version of the 
media. You can also choose to copy media while 
importing by using key commands, or enabling 
the Automatically Copy Files on Import prefer-
ence. Copies are created in the session’s Audio 
Files Folder. 

To manually copy files on import:

 Alt-drag (Windows) or Option-drag (Mac) the 
files. A copy is created in the session Audio Files 
folder. 

When importing sessions or tracks, the Import 
Session Data dialog lets you specify whether to 
reference the source media, or copy it.

To automatically copy files on import:

1  Choose Setup > Preferences, and click the Op-

erations tab.

2  Select Automatically Copy Files on Import. 

3  Click OK to close the Preferences dialog.

Using Undo after Importing 
Using Undo after importing any files to the 
Timeline removes the files from the Timeline. 
However, the files remain in the session (in the 
Clip List and Project browser) and are offline. If 
you do not remove or delete the files from the 
session manually, Pro Tools will report them as 
missing files the next time the session is opened. 
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Import Session Data Dialog
The Import Session Data dialog lets you view the 
properties of the source session, select which 
tracks to import, and with Pro Tools HD, choose 
which attributes of those tracks you want to im-
port into the current session.

Source Properties
The Import Session Data dialog displays proper-
ties for the source session. These properties in-
clude source session name, session type, start 
time of the session, audio bit depth, and sample 
rate. For Pro Tools 5.1 or higher sessions, the 
program that created the session and the ses-
sion’s audio file type are listed.

Import Session Data dialog (Pro Tools HD)



Text Encoding

Pro Tools allows entry and display of any lan-
guage characters supported in Unicode any-
where in the Pro Tools application. This lets you 
use multiple languages in session names, and in 
path names, file names and clip names. 

However, Pro Tools 7.3.x and lower does not 
support Unicode. When importing data from 
sessions or OMF sequences created or saved 
with older versions of Pro Tools, you may need 
to identify the language encoding used in the 
imported elements. 

To choose the language encoding when importing 
data from a legacy Pro Tools session:

1  Choose File > Import > Session Data.

2  Choose the language used in the legacy session 
from the Text Encoding pop-up menu.

Audio Media Options
The following Audio Media Options are avail-
able in the Import Session Data dialog:

Link to Source Media (Where Possible) This op-
tion lets you avoid duplicating audio files by re-
ferring to the original files when possible. If the 
source files do not reside on supported playback 
media (such as a CDs or DVDs), or if they re-
quire bit depth or sample rate conversion, the 
source files are copied instead. This option al-
lows the current session to refer to files that do 
not match the current session’s audio file for-
mat. 
Copy from Source Media This option copies all 
audio files related to the imported tracks from 
the source media to a new specified location, 
and converts the files to the current session’s 
audio file format, bit depth, and sample rate if 
necessary. This is useful if you are importing 
tracks from a source such as CD or DVDs or 
shared storage, and you want to place the audio 
files on a different hard drive.

Consolidate from Source Media This option 
consolidates audio while copying it. This is use-
ful if you want to copy only the clips of the audio 
files used in the source tracks, without copying 
unused audio. This option copies and converts 
consolidated audio to the current session’s au-
dio file format, bit depth, and sample rate if nec-
essary. 

When you choose this option, you can also 
choose the Handle Size (in milliseconds) applied 
to consolidated audio. Handle is the amount of 
the original audio file that is preserved before 
and after each clip in case you need to make any 
edits (such as applying fades or trimming) to the 
new clips.

Force to Target Session Format This option cop-
ies and converts any files that do not match the 
current session’s file format, bit depth, and 
sample rate. Files that do match the current ses-
sion’s file type, bit depth and sample rate are re-
ferred to directly and not copied.

Consolidate From Source Media is not 
available when importing Elastic Audio 
tracks.
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Video Media Options

In the Import Session Data dialog, you can ei-
ther choose to leave video media files in their 
original locations or copy them to a new loca-
tion. This is useful if you are importing tracks 
from a source such as CDs or DVDs or shared 
storage, and you want to place video files on a 
different drive.

Link to Source Media

Select this option to avoid duplicating video 
files by referring to the original files. 

Copy from Source Media

Select this setting to copy all video files related 
to the imported tracks from the source media to 
a new specified location. 

Import as Offline Satellite Media

(Pro Tools HD Only)

Select this option to import a video track with 
offline media. You will be able to see cuts and 
clip names, but the video media remains offline. 
You can view the video media on a connected 
Video Satellite system. This option is only avail-
able when New Satellite Track is selected for the 
video track.

Timecode Mapping Options
In the Import Session Data dialog, you can spec-
ify where the imported tracks are placed in the 
current session. Times are indicated in time-
code.
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The following Timecode Mapping Options are 
available:

Maintain Absolute Timecode Values This option 
places tracks at the locations where they were 
located in the source session. For example, if the 
current session starts at 00:01:00:00, and the 
session from which you are importing starts at 
10:00:00:00, the earliest imported tracks can ap-
pear in your session is 9 hours and 59 minutes 
after the start of the session.

Maintain Relative Timecode Values This option 
places tracks at the same offset from session 
start as they had in the source session. For ex-
ample, if the source session starts at 01:00:00:00 
and contains a track that starts at 01:01:00:00, 
and the current session start is 02:00:00:00, the 
track will be placed at 02:01:00:00 in the current 
session. 

Map Start Timecode To This option places tracks 
relative to their original session start time. 
(Times are expressed in hh:mm:ss:ff) For exam-
ple, if the current session starts at 00:01:00:00, 
and the session from which you are importing 
starts at 10:00:00:00, you can reset the start 
timecode to 00:01:00:00, to avoid placing files 9 
hours and 59 minutes from the start of your ses-
sion.

Adjust Session Start Time to Match Source 
Start Time

When selected, the Adjust Session Start Time to 

Match Source Start Time option lets you auto-
matically set the start time of the current 
Pro Tools session to match the start time of the 
session, or AAF or OMF sequence you are im-
porting. 



Track Offset Options
In the Import Session Data dialog, you can spec-
ify a track offset in addition to any offset in-
curred with the Timecode Mapping Options. Any 
imported audio is offset in the current session’s 
Timeline by the specified amount. You can enter 
values in Minutes:Seconds, Bars|Beats, Samples, 
Timecode, or Feet/Frames. 

Sample Rate Conversion (SRC) 
Options
In the Import Session Data dialog, you can set 
options that control how sample rate conversion 
is applied to imported audio files. If the source 
session and the current session have the same 
sample rate, this portion of the dialog is unavail-
able.

The following Sample Rate Conversion (SRC) 

Options are available:

Source Sample Rate For audio files created in 
any session, no matter what the session sample 
rate is, you can have the sample rate conversion 
process treat the files in several ways to com-
pensate for pull-up, pull-down, and NTSC or 
PAL frame rates. This setting allows you to 
choose the sample rate from which you want the 
sample rate conversion process to start. 

Destination Sample Rate The destination sample 
rate is always set to the sample rate of your cur-
rent session.

Conversion Quality This option lets you set the 
quality of the sample-rate conversion process 
(see “Sample Rate Conversion Quality” on 
page 334).
Source Tracks
This area of the Import Session Data dialog lists 
the tracks in the source session that can be im-
ported, each with a corresponding pop-up 
menu. 

Operation/Destination Track 
Pop-Up Menus
In the Import Session Data dialog, each source 
track has a corresponding pop-up menu that 
lists options for importing the track as well as 
for possible destination tracks in the current 
session. The pop-up menus display the following 
items:

Do Not Import Neither the source track nor any 
of its attributes are imported. 

Import as New Track The source track and all at-
tributes selected in the Track Data to Import pop-
up menu are imported into a new track in the 
current session. 

Destination Track Names The names of possible 
destination tracks in the current session are 
listed at the bottom of the pop-up menu. Im-
ported playlists and all attributes selected in the 
Track Data to Import pop-up menu will be placed 
in the destination track you select. 

Only destination tracks that match the track 
type (audio, Instrument, MIDI, Auxiliary Input, 
or Master Fader) and the channel format (mono, 
stereo, or any of the supported multichannel for-
mats) of the source track appear in the pop-up 
menu. 
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Matching Tracks
In the Import Session Data dialog, you can make 
sure track names match when you are importing 
playlists from source tracks with the same name 
as destination tracks in the current session 
(such as a new cut of a scene). Click Matching 

Tracks to automatically match the track names. 
Tracks must have the same name, track type, 
and channel format to be automatically 
matched.

Track Data to Import
In the Import Session Data dialog, the Track 

Data to Import pop-up menu is where you select 
which attributes of the selected tracks you want 
to import into the current session. 

Selected attributes are applied to all tracks that 
you choose to import into the current session.

Replacing Track Attributes

When you import an attribute of the source 
track into an existing track in the current ses-
sion, it replaces the corresponding attribute in 
the destination track. If you choose not to im-
port an attribute of the source track, the corre-
sponding attribute in the destination track is re-
tained. 

Replacing Track Path Names

When you import a track’s input, output, send 
output or hardware insert assignments, any cus-
tom path names and I/O configurations from the 
source session are not imported. You can import 
path names and I/O configurations by importing 
I/O Setup settings. For more information, see 
“Factory I/O Settings” on page 113. 
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Selecting Track Data to Import

You can select All, None, or any combination of 
the listed track data to import. The following are 
available for import:

All Imports all of the source track’s playlists, ac-
cording to the Main Playlist Option setting, and 
all of the attributes in the Track Data to Import 
list.

None Imports only the source track’s main play-
list, according to the Main Playlist Options set-
ting, and no other attributes of the source track. 

Alternate Playlists Imports all of the alternate 
playlists from source track. The alternate play-
lists appear in the playlist pop-up menu of the 
destination track. 

Clips and Media Imports all of the audio files or 
clips in the source track, and places them in the 
Clip List. 

Clips Gain Imports the clip gain settings for all 
imported audio clips. 

Volume Automation and Setting Imports the 
source track’s Volume fader setting and any au-
tomation data on the track’s Volume Automa-
tion playlist. The Volume fader setting and any 
Volume automation data in the destination 
track are replaced. 

Pan Automation and Setting Imports the source 
track’s Pan Slider settings and any automation 
data on the track’s Pan Automation playlist. The 
Pan Slider setting and any Pan automation data 
in the destination track are replaced.

Mute Automation and Setting Imports the 
source track’s Mute setting and any automation 
data on the track’s Mute automation playlist. 
The Mute setting and any Mute automation data 
in the destination track are replaced.



Main Output Assignments Imports the source 
track’s channel output assignments, including 
any multiple output assignments. The channel 
output assignments in the destination track are 
replaced.

Send Output Assignments Imports the source 
track’s send output assignments. Any Send out-
put assignments in the destination track are re-
placed.

Plug-In Assignments Imports the source track’s 
plug-in assignments. Any plug-ins in the desti-
nation track are removed, and their associated 
settings and automation are lost. 

If the source track uses a plug-in that is not 
available on the destination system, it appears 
in the destination track and is made inactive. 

Plug-In Settings and Automation When the 
source track’s plug-in assignments are im-
ported, this option imports the track’s plug-in 
settings and any automation data associated 
with the plug-ins. If no plug-in assignments are 
imported, this option has no effect.

Elastic Audio Track State Imports the source 
track’s Elastic Audio track state. Any Elastic Au-
dio settings in the destination track are re-
placed.

HW Insert Assignments Imports the source 
track’s hardware Insert assignments. Any Insert 
assignments in the destination track are re-
placed.

Voice Assignments Imports the source track’s 
voice assignment from the source session. Any 
voice assignments in the destination track are 
replaced. 

Input Assignments Imports the source track’s 
channel input assignment. The Input assign-
ment in the destination track is replaced. 
Side-Chain Assignments When the source 
track’s plug-in assignments are imported, this 
option imports any side-chain assignments as-
sociated with the plug-ins. If no plug-in assign-
ments are imported, this option has no effect.

Track Active State Imports the active/inactive 
state of the source track from the source session. 

Track Comments Imports the track comments 
associated with the source track. Any comments 
in the destination track are replaced. 

Track Colors Imports the track color associated 
with the source track. Any color for the destina-
tion track is changed. 

Record Safe/Solo Safe Settings Imports the re-
cord safe and solo safe settings of the source 
track from the source session. Any record safe 
or solo safe settings in the destination track are 
replaced. 

Track View Settings Imports the track height 
and playlist view of the source track from the 
source session. 

Mix/Edit Groups Imports track groups from the 
source session.

ICON Custom Fader Groups (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
Only) Imports any ICON Custom Fader Groups 
from the source session.

ICON Automation Snapshots (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
Only) Imports any ICON Automation Snapshots 
from the source session.

HEAT Switch Settings (Pro Tools|HD Systems 
with the HEAT Software Option Only) Imports 
any stored HEAT switch settings from the 
source session.
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Import Options
The following Import Options are available in 
the Import Session Data dialog:

Import Tempo/Meter Map Imports the meter and 
tempo maps, as they appear in the Tempo and 
Meter Conductor rulers, from the source ses-
sion. Any Tempo or Meter events in the destina-
tion session are replaced. 

Import Key Signature/Chord Map Imports all key 
signatures (if present) and chord markers into 
Pro Tools with the imported session data. Any 
key signatures and chord markers in the desti-
nation session are replaced.

Import Marker/Memory Locations Imports mark-
ers and Memory Locations as they appear in the 
Marker ruler, from the source session. Any 
markers and Memory Locations in the destina-
tion session are retained. Imported marker and 
Memory Locations are assigned the next avail-
able Marker/Memory Location numbers.

Import Window Configurations Imports the 
Window Configurations from the source ses-
sion.

Import Mic Pre Settings Imports any Pro Tools 
Mic Pre settings from the source session. Any 
Mic Pre settings in the destination session are 
replaced. 

Import HEAT Master Settings (Pro Tools HD with 
HEAT Only) Imports any HEAT Master settings 
from the source session, including Bypass, 
Drive, and Tone settings. The HEAT Master set-
tings in the destination session are replaced.
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Main Playlist Options
In the Import Session Data dialog, you can select 
from the following options to control how the 
main playlist from each source track is imported 
to the destination track in the current session. 

Import – Replace Existing Playlists Imports the 
main playlist from the source track. When you 
import the playlist into an existing track, the 
main playlist in the destination track is deleted 
and replaced with the imported playlist. 

 If you select this option and import all of the 
source track’s attributes, this is equivalent to im-
porting the entire track. 

 If you select this option and do not import any 
of the source track’s attributes, you replace the 
audio playlists while keeping your current mixer 
settings.

Import – Overlay New On Existing Playlists Im-
ports the main playlist from the source track. 
When you import the playlist into an existing 
track, any existing playlist data that overlaps 
data imported from the source track is trimmed 
and replaced with the imported data. Any play-
list data in the destination track that does not 
overlap remains in the destination track. 

Do Not Import Does not import the main playlist 
from the source track. No audio is imported; 
only the attributes selected in the Track Data to 

Import list are imported to the selected tracks. 
When selected, importing all of the source 
track’s input, output, send, insert and plug-in 
attributes is equivalent to importing a channel 
strip.



Importing AAF and OMF 
Sequences
Pro Tools lets you open AAF and OMF se-
quences as new Pro Tools sessions, or you can 
import AAF and OMF sequences into existing 
Pro Tools sessions. Pro Tools can import AAF 
and OMF sequences exported from other 
Pro Tools sessions, from Avid Media Composer, 
or from third-party applications (such as Final 
Cut Pro, Logic Audio, Adobe Premiere Pro, and 
Nuendo).

When importing AAF sequences generated from 
an Avid video editing application, Pro Tools can 
import mono, stereo, and 5.1 and 7.1 surround 
audio tracks. Mono tracks with 5.1 or 7.1 sur-
round panning can also be imported, with pan-
ning information intact. (Greater-than-stereo 
multichannel formats are supported with 
Pro Tools HD and Pro Tools with Complete Pro-
duction Toolkit only.)

When opening and importing an AAF or OMF 
sequence, the New Session dialog opens and 
prompts you to name and save the sequence as a 
new session. Once you name and save the new 
session, the Import Session Data dialog opens. 
For more information, see “AAF/OMF Source 
Track Translation Settings” on page 369.
Pro Tools can import the following types of files 
sourced from Avid editors:

• AAF or OMF sequences (including those 
with embedded audio)

• Individual Avid video files in the MXF or 
OMF format

• OMF and MXF audio files

To import AAF or OMF sequences into Pro Tools, 
do one of the following:

 Use the File > Import > Session Data command.

 Use the File > Open Session command.

 Drag and drop them from any DigiBase 
browser or the desktop.

To import individual Avid MXF or OMF video files 
into Pro Tools, do one of the following:

 Use the File > Import > Video command.

– or –

 Drag and drop them from any DigiBase 
browser or the desktop.

To import individual OMF or MXF audio files into 
Pro Tools, do one of the following:

 Use the File > Import > Audio command.

– or –

 Drag and drop them from any DigiBase 
browser or the desktop.

Multi-channel import and export are only 
possible with AAF sequences.

Avid Mojo SDI or Avid Mojo is required for 
importing MXF and OMF video.

For more information, see “Importing an 
AAF or OMF Sequence into an Existing Ses-
sion” on page 363.
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Importing an AAF or OMF 
Sequence as a Pro Tools 
Session
The easiest way of using Pro Tools to edit a se-
quence exported from an Avid application (such 
as Media Composer) is to open it as a new ses-
sion.

To open and import an AAF or OMF sequence in 
Pro Tools:

1  Launch Pro Tools.

2  Choose File > Open Session.

3  In the Open Session dialog, navigate to the 
AAF or OMF sequence you want to import.

4  Click Open.

5  Select the Audio File Type, Sample Rate, and Bit 

Depth to use for the session.

6  If desired, select the Interleaved option.

7  Click OK.

8  Name your session in the Save As field.

9  Click Save. 

10  The Import Session Data dialog opens.

Pro Tools cannot play video files embedded 
within an AAF or OMF sequence.

You can open and import OMF or AAF se-
quences that reference audio files with mixed 
sample rates or bit depths.
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11  Depending on how you want to import the au-
dio, select the appropriate option from the Audio 

Media Options pop-up menu (see “Audio Media 
Options” on page 365).

12  Depending on how you want to import the 
video, select the appropriate option from the 
Video Media Options pop-up menu (see “Video 
Media Options” on page 366).

13  Change other settings and options as neces-
sary (see “Import Options when Importing AAF 
or OMF Sequences” on page 365). 

14  Click OK.

Pro Tools creates a new session file in the loca-
tion you’ve specified, along with the following 
new items:

• Audio Files folder

• Clip Groups folder

• Session File Backups folder 

• Video Files folder

• cache.wfm file

Import Session Data dialog



This session will match the audio file type, sam-
ple rate, and bit depth of the audio in the OMF 
or AAF you selected. Pro Tools does not import 
video embedded in a sequence. 

If a Video Satellite system is available, Pro Tools 
can import the video metadata from a sequence 
to a satellite track. In this case, the video itself is 
played back from the Video Satellite machine, in 
tandem with Pro Tools playback.

Multi-Cam Resolution Files

On an Avid system, Multi-Cam Resolution files 
display multiple individual camera angles of the 
same scene. The Avid operator chooses which of 
the Multi-Cam files (and therefore camera an-
gles) will be dominant, at the time of creating an 
AAF or OMF export. When you import an AAF 
or OMF sequence into a Pro Tools session, only 
the clip representing the dominant camera angle 
will be displayed.

For more information, see the Video 
Satellite Guide.

During the import, if there are any errors, clip 
name truncations, or other notes (such as 
missing effect renderings), a dialog appears 
asking you if you want a detailed report of the 
changes. Click Yes and choose where you want 
to save the log. The log is a text file that you 
can open in any text editing application.

Every AAF and OMF file has a filename and 
unique identifier stored in the AAF and OMF 
metadata, and a name which is displayed on 
the desktop. Truncating a clip name in the 
translation process does not change the AAF 
or OMF filename or unique ID.
Importing an AAF or OMF 
Sequence into an Existing 
Session
You can import an AAF or OMF sequence con-
taining audio and video media into an existing 
Pro Tools session. 

To open and import audio and/or video tracks from 
an OMF or AAF sequence:

1  Launch Pro Tools, and open an existing 
Pro Tools session.

2  Choose File > Import > Session Data, and select 
the AAF or OMF sequence that you want to im-
port.

3  In the Import Session Data dialog, deselect any 
source tracks that you do not want imported. (If 
importing Session Data from AAF or OMF se-
quences, all tracks are selected by default. If you 
are importing tracks from a Pro Tools session, 
no tracks are selected by default.)

4  Select the AAF/OMF translation settings (see 
“AAF/OMF Source Track Translation Settings” 
on page 369).

5  Select the Audio Media Options (see “Audio Me-
dia Options” on page 365).

6  Select the Video Media Options (see “Video Me-
dia Options” on page 366).

7  Select the Timecode Mapping Options (see 
“Timecode Mapping Options” on page 367).

You can also open an AAF or OMF sequence 
by dragging it from any location on your com-
puter or the DigiBase browser to the Pro Tools 
Timeline.

Source Tracks
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8  Set the Track Offset Options (see “Track Offset 
Options” on page 367).

9  Set the Sample Rate Convert Options (see 
“Sample Rate Conversion Options” on page 368).

10  Change other settings and options as neces-
sary (for more information about the Import 
Session Data dialog, see “Import Session Data 
Dialog” on page 354). 

11  Click OK.

12  If your audio or video source media is on a 
volume that is not suitable for playback (shown 
as a Transfer volume in the Workspace browser), 
Pro Tools displays a dialog that guides you to 
copy the media to a volume designated for Play-
back or Record. (Click Yes.)

Pro Tools imports the audio and video media to 
the Timeline. Audio tracks with mixed sample 
rates are automatically converted to the same 
sample rate as the session.

Now you are ready to edit or mix the audio files 
in Pro Tools.

If there are any errors or clip name trunca-
tions, a dialog will appear asking you if you 
want a detailed report of the changes. Click 
Yes and choose where you want to save the log.
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Importing AAF/OMF Audio 
Sequences with Mixed Sample 
Rates or Bit Depth
You can open and import AAF or OMF se-
quences with mixed sample rates and bit-depths 
into Pro Tools.

Audio files that are not of the same sample rate 
as a session must be converted to be used with 
the session. When an audio file is converted, a 
new file with the correct file type, and sample 
rate is created and placed in a folder you choose. 
Audio files with mixed bit-depths (and match-
ing sample rates) can be imported without con-
version.

Importing Audio from AAF 
Sequences with Unsupported 
Video Formats
Pro Tools lets you import audio from AAF se-
quences containing unsupported video formats, 
including high-definition Avid video files with 
frame rates over 30 frames per second.

The following rules apply when importing AAF 
sequences of this type:

• Supported audio in these sequences will play 
back, but unsupported video will not.

• Unsupported video appears in the Timeline as 
orange blocks.

You can use the Source Sample Rate settings 
to compensate for any pull up or pull down 
factors that may have been applied to the au-
dio prior to importing. In a sequence with 
files of mixed sample rates, set the Source 
Sample Rate in proportion to the Target sam-
ple rate of the session, and the pull up or pull 
down compensation will be applied correctly 
to all files in proportion with their original 
sample rate.



Importing AAF/OMF Sequences 
Containing Media Mixdowns
Pro Tools with an Avid video peripheral lets you 
import AAF and OMF sequences exported from 
Avid editing applications by selecting File > Im-

port > Session Data or by dragging them from the 
desktop or a DigiBase browser to Pro Tools. For 
more information, see “Importing Session Data” 
on page 352. 

If the sequence contains a video mixdown, the 
video mixdown and its corresponding metadata 
are displayed in two separate video tracks on the 
Timeline.

If the sequence contains an audio mixdown, the 
audio mixdown and its corresponding metadata 
are displayed in two separate video tracks on the 
Timeline.

Import Options when 
Importing AAF or OMF 
Sequences
When importing AAF or OMF sequences, 
Pro Tools provides the following import options 
through the Import Session Data dialog:

• Audio Media options

• Video Media options

• Timecode Mapping options

• Track Offset options

• Sample Rate Conversion options

• AAF/OMF Source Track Translation set-
tings

• Main Playlist options
Audio Media Options
When importing AAF or OMF tracks into 
Pro Tools, use the Audio Media Options pop-up 
to select whether to copy, consolidate, or link to 
the source audio media.

Link to Source Audio Media (Where Possible)

Select this option to translate the AAF or OMF 
file to a Pro Tools session that refers to as many 
of the original media files as possible. In this 
case, the Pro Tools session points to the BWF 
(WAV) or AIF files from the source project. 

When importing audio embedded in an AAF se-
quence, Pro Tools copies the audio to a new 
drive or folder even if this setting is selected.

Copy from Source Media

Use this setting to copy referenced audio to a 
new drive or folder. 

You can perform sample rate conversion on au-
dio during translation.

OMFI Audio Media and Copy from Source Media 
Mode

When importing an AAF or OMF sequence with 
the Copy from Source Media option enabled, 
Pro Tools can copy OMFI format .WAV and .AIF 
audio files directly into the session. However, 
Pro Tools treats OMFI audio files as read-only. 

Destructive edits or processes (such as the Pen-
cil tool) cannot be applied to these files, unless 
they are first converted into standard audio 
files.

Audio Media Options
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To convert OMFI audio files during import:

 Choose Force to Target Format mode, rather 
than Copy from Source Media mode, when set-
ting import options. For more information, see 
“Force to Target Session Format” on page 366. 

To convert an OMFI audio file that exists in the 
current session:

1  Select the audio to be converted.

2  Apply the Consolidate command to convert the 
selected audio (Edit > Consolidate Clip).

3  Edit and process your newly converted files as 
normal.

Consolidate from Source Media

Use this setting to copy the audio from the 
source project to the Pro Tools session, while re-
moving all unused areas in the copies. For exam-
ple, you might only be using ten seconds of a 
ten-minute audio file in your project. Consoli-
dating this audio saves a great deal of disk space 
by preserving only the audio you use and a user-
defined amount of handle, and discarding the 
rest.

You can sample-rate convert the audio during 
translation.

Force to Target Session Format

Use this setting to convert source media to the 
session audio file format if the source media file 
format differs from the session file format.

Handle Size (Milliseconds)

If you have selected Consolidate from Source Me-

dia, you can specify the number of milliseconds 
of each original audio file to retain both before 
and after the clip boundaries defined in the 
source project. This enables you to extend clip 
boundaries even after you’ve consolidated, by 
the amount you specify.
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It is a good idea to have at least 1000 millisec-
onds of handle, so you can “trim out” edits that 
sound “clipped” or “up-cut.”

Video Media Options
When importing AAF or OMF tracks into 
Pro Tools, use the pop-up menu in the Video 
Media Options section to copy or link to the 
source video media.

Link to Source Media

Select this option to avoid duplicating video 
files by referring to the original files. 

Copy from Source Media

Select this setting to copy all video files related 
to the imported tracks from the source media to 
a new specified location. 

Import as Offline Satellite Media

(Pro Tools HD Only)

Select this option to import a video track with 
offline media. You will be able to see cuts and 
clip names, but the video media remains offline. 
You can view the video media on the connected 
Video Satellite system. This option is only avail-
able when New Satellite Track is selected for the 
video track.

Video Media Options



Timecode Mapping Options
When importing AAF or OMF tracks into 
Pro Tools, you can specify where the imported 
tracks are placed in the current session. Times 
are indicated in timecode.

Maintain Absolute Timecode Values

This option places tracks at the locations where 
they were located in the source session. For ex-
ample, if the current session starts at 
00:01:00:00, and the session from which you are 
importing starts at 10:00:00:00, the earliest im-
ported tracks can appear in your session is 9 
hours and 59 minutes after the start of the ses-
sion.

Maintain Relative Timecode Values

This option places tracks at the same offset from 
session start as they had in the source session. 
For example, if the source session starts at 
01:00:00:00 and a contains a track that starts at 
01:01:00:00, and the current session start is 
02:00:00:00, the track will be placed at 
02:01:00:00 in the current session. 

Map Start Timecode to hh:mm:ss:ff

This option places tracks relative to their origi-
nal session start time. For example, if the cur-
rent session starts at 00:01:00:00, and the ses-
sion from which you are importing starts at 
10:00:00:00, you can reset the start timecode to 
00:01:00:00, to avoid placing files 9 hours and 59 
minutes from the start of your session.

Timecode Mapping Options
Adjust Session Start Time to Match Source 
Start Time

This option changes the start time of the current 
session to match the start time of the AAF or 
OMF sequence being imported. When this op-
tion is enabled, the Map Start Timecode to 

hh:mm:ss:ff option (and its timecode entry box) 
are disabled.

Track Offset Options
When importing AAF or OMF tracks into 
Pro Tools, specify a track offset in addition to 
any offset incurred with the Timecode Mapping 
options. Any imported audio is offset in the cur-
rent session’s timeline by the specified amount. 
Values can be entered in Bars|Beats, Min:Sec, 
Timecode, Feet+Frames, or Samples. 

If the sequence being imported has a later 
start time than the current session, the 
Maintain Absolute Timecode Values option 
is disabled.

In some cases, when clips in the current ses-
sion are situated near the time boundaries 
of the session, enabling Adjust Session Start 
Time and choosing to Maintain Relative 
Timecode Values can put clips in danger of 
being moved out of bounds. In these cases, a 
warning is displayed and Pro Tools does not 
adjust the session start time.

Track Offset Options
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Sample Rate Conversion 
Options
When importing AAF or OMF tracks into 
Pro Tools, these settings let you convert the 
sample rate of the session’s audio files. For ex-
ample, you can convert from 48 kHz to 44.1 kHz, 
or from 44.1 kHz to 48 kHz. Avid HD Native and 
Pro Tools|HD systems support sample rates 
higher than 48 kHz (88.2 kHz, 96 kHz, 
176.4 kHz, and 192 kHz). These settings also en-
able you to convert to compensate for the 0.1% 
speed change (pull-up or pull-down) between 
24 fps film and 29.97 fps NTSC video, or the 4% 
speed change (pull-up or pull-down) between 
24 fps film and 25 fps PAL video.

Source Sample Rate

This setting lets you specify the sample rate of 
the audio material you are working with in 
Pro Tools, independent of the project sample 
rate settings.

For example, you may receive a project origi-
nated on Media Composer at 44.1 kHz. If you 
want to work at 48 kHz in Pro Tools, you should 
set the Source Audio Sample Rate setting to 
44,100 and the Destination Audio Sample Rate 
to 48,000.

Sample Rate Conversion Options

See “Speed Correction for Film, NTSC Video, 
and PAL Video” on page 1166, for informa-
tion about converting between different 
speeds and sample rates.
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These settings can also be used to correct for 
pull-up or pull-down problems. For example, 
you may receive an AAF or OMF transfer from a 
Film Composer that contains audio media at 
“film speed” when played back at 48 kHz. You 
may want to convert all the audio files and edits 
to play back at NTSC video speed and 48 kHz. 

In this case, set the Source Audio Sample Rate 
setting to 47,952 and the Destination Audio 
Sample Rate to 48,000. These settings tell 
Pro Tools that you want to fit 47,952 of the orig-
inal “film speed” samples into 48,000 of the new 
“video speed” samples. With these settings, you 
sample-rate-convert the material to NTSC video 
speed. 

You can set the Source Audio Sample Rate either 
by selecting one of the predefined sample rates 
from the pop-up menu, or by typing a value into 
the text box.

Destination Sample Rate

This setting determines the target session’s au-
dio sample rate setting, as shown in the Session 
Setup window, and the sample rate of all audio 
files in the target session. Available settings in-
clude Pro Tools standard sample rates of 
44.1 kHz or 48 kHz. Avid HD Native and 
Pro Tools|HD systems support sample rates 
higher than 48 kHz (88.2 kHz, 96 kHz, 
176.4 kHz, and 192 kHz).

If this setting differs from the Source Audio 
Sample Rate setting, audio is sample-rate con-
verted digitally to the Destination Audio Sample 
Rate.

See “Speed Correction for Film, NTSC Video, 
and PAL Video” on page 1166, for informa-
tion about converting between different 
speeds and sample rates.



Conversion Quality Pop-Up Menu

This pop-up menu lets you select settings corre-
sponding to Pro Tools sample rate conversion 
settings. The Tweak Head (Slowest) option pro-
vides the best results.

AAF/OMF Source Track 
Translation Settings
Pro Tools provides specific options for “trans-
lating” audio clips when importing AAF se-
quences or OMF files and sequences.

Import Rendered Audio Effects

Enabling the Import Rendered Audio Effects op-
tion imports clips as audio clips, retaining the 
rendered effects (such as EQ) that were applied 
to the clip. You may want to disable this if you 
plan to use Pro Tools audio effects and audio 
processing exclusively for your audio post pro-
duction work. The resulting audio with this set-
ting disabled is the unprocessed source mate-
rial.

Import Clip Gain

The Import Clip Gain setting lets you import clip-
based gain settings, or ignore clip-based gain 
entirely. Media Composer and other Avid prod-
ucts provide clip-based gain to adjust the vol-
ume of an individual audio clip. 

Translation settings
Clip-based gain differs from standard Pro Tools 
volume adjustments for an entire track, or vol-
ume breakpoint automation. Enable this option 
to import clip-based gain data from the incom-
ing sequence.

Import Volume Automation

The Import Volume Automation setting lets you 
import volume breakpoint automation, or ig-
nore it entirely. Media Composer and other Avid 
products provide volume automation, for con-
tinuous volume change throughout a sequence.

Pan Odd Tracks Left/Even Tracks Right

The Pan Odd Tracks Left/Even Tracks Right set-
ting enables you to set the basic track pan set-
ting so that odd-numbered tracks translate with 
full-left panning, and even-numbered tracks 
translate with full-right panning. This is useful 
if you want to pan the currently unpanned audio 
full-left or full-right.

Markers To Import

Avid Media Composer sequences can contain 
metadata points called Markers that serve a sim-
ilar purpose to the Markers in Pro Tools, adding 
color-coded contextual information to the time-
line. Even though markers are associated with 
specific tracks in Media Composer, you can im-
port markers into Pro Tools without importing 
those tracks.

The Pan Odd Tracks Left/Even Tracks Right 
setting is not supported when importing 
multi-channel audio tracks from an AAF. 
When importing multi-channel tracks, the 
setting is greyed-out and any imported ste-
reo channels are panned hard right and 
hard left.
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When exporting an AAF from Media Composer, 
Marker information is included and can be im-
ported into Pro Tools, thus preserving this data.

To import all Markers: 

 Click the Markers to Import menu and select All.

To import no Markers:

 Click the Markers to Import menu and select 
None.

To import Markers based on marker color:

1  Click the Markers to Import menu.

2  Select the colors of markers you want to im-
port. Check marks appear next to the selected 
colors.

Once imported, the new Markers can be edited 
as normal. 

Markers can only be imported from AAF se-
quences. 

Unlike Pro Tools Markers, which only mark 
specific points in time in a session, Media 
Composer Markers point specifically to in-
dividual audio or video tracks. Information 
on which track each Marker was associated 
with can be found in the Comments section 
in the Memory Locations window in 
Pro Tools.

When Media Composer Markers are im-
ported to Pro Tools as Markers, the associ-
ated comment text is added to the Marker 
name in Pro Tools (up to 31 characters). 
Comments over 31 characters can be viewed 
in full in the Memory Locations window in 
Pro Tools.
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Track Data to Import Pop-Up Menu

The Track Data to Import pop-up menu lets you 
select which attributes of the selected tracks you 
want to import into the current session. The se-
lected attributes are applied to all tracks that 
you choose to import into the current session. 
For more information about Track Data To Im-

port options, see “Track Data to Import” on 
page 358.

Importing RTAS Plug-In Settings from AAF

Avid Media Composer 5 and higher lets you pro-
cess audio tracks with RTAS plug-ins. Pro Tools 
lets you import RTAS plug-in data from audio 
tracks in Media Composer-generated AAF se-
quences. Plug-in type, order, and control set-
tings are preserved.

When importing an AAF into Pro Tools, use the 
Track Data to Import menu to specify whether or 
not to import the plug-ins and plug-in settings.

To import plug-in settings when importing AAF 
tracks or sequences:

1  Open the Track Data to Import menu.

2  Do one of the following:

• Choose All.

– or –

• Choose Some, and ensure that Plug-in As-

signments is checked.

Pro Tools cannot export RTAS plug-in data 
when outputting an AAF for use with Media 
Composer. Because Pro Tools mixes often 
contain complex busing, routing, and plug-
in automation, tracks should be printed or 
bounced to retain new processing changes 
before exporting to AAF.



To avoid importing plug-in settings when 
importing AAF tracks or sequences:

1  Open the Track Data to Import menu.

2  Choose Some, and ensure that Plug-in Assign-

ments is unchecked.

Main Playlist Options
When importing AAF or OMF tracks into 
Pro Tools, you can choose how the main playlist 
from each source track is imported to the desti-
nation track in the current session. See “Main 
Playlist Options” on page 360.

Media Composer Export 
Options for Audio and Video 
Mixdowns
You can request the following export options for 
the AAF you are receiving from an Avid applica-
tion:

• To export both a video mixdown and its 
corresponding editing metadata, the Avid 
video editor should select Video Mixdown 
from the Export Method pop-up menu, 
then select Mixdown with Video Edits in the 
Export Settings dialog.

• To export both an audio mixdown and its 
corresponding editing metadata, the Avid 
video editor should select Add Audio Mix-
down Track(s) in the Export Settings dia-
log.

• To export directly to DigiDelivery, the Avid 
video editor should choose DigiDelivery 
from the Export Method pop-up menu.
Audio File Format 
Compatibility Issues

AIFC Audio File Format
Avid Media Composer and other Avid editors 
support audio files in the AIFC format, a version 
of the Audio Interchange File Format (AIFF) 
that supports compressed media. Pro Tools can 
import and use this format, but not compress 
audio in this format.

Sound Designer II Audio File 
Format

Support for AAF Sequences Referencing SDII 
Audio Files

Pro Tools lets you import AAF sequences that 
reference Sound Designer II (SDII) audio files. 
However, any referenced Sound Designer II files 
will need to be converted to the session file for-
mat (WAV or AIF). Pro Tools does this automat-
ically.

Translation Notes File
If there are any errors, clip name truncations, or 
other notes (such as missing effect renderings), 
during import of an AAF or OMF file or se-
quence, a dialog appears asking if you want a de-
tailed report of the changes. Click Yes and 
choose where you want to save the translation 
notes file.

With Pro Tools 8.0.3 and higher, Sound De-
signer II files are no longer supported as a 
session file format. You can still import and 
export SDII files, but the must be converted 
to the session file format (WAV or AIF) on 
import. 
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The Translation Notes File can be opened by 
most word processing applications that can read 
plain text files.

Translation Notes Format

Translation Notes are presented in the following 
format:

Track Name <Timecode Start–Timecode End> 
“clip name (if available)”;message

Translation Notes and Categories

The Translation Notes File is separated into dif-
ferent categories. The following are sample mes-
sages in each category, with explanations of 
what has happened and solutions if necessary.

Parsing Errors

Example

A1<01:00:00:00–01:00:04:20>error reading
component “Assertion in OMF_Objects2x.cpp”, 
line 2871;substituting fill.

This error indicates a problem that may have 
originated in Pro Tools or the application that 
produced the AAF or OMF file. In the translated 
composition, there will be silence or video black 
at the given interval.

Missing Renderings

Example 1

A1<01:00:02:00–01:00:07:01> no rendering for
effect:EFF_AUDIO_EQMB;using bypass clip.

This indicates the presence of an effect for 
which there is no rendering. The “bypass clip” is 
the (unprocessed) source material for the effect. 
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Example 2

V1<01:00:48:25–01:00:49:26>no rendering for
effect: omfi:effect: VideoRepeat;substituting
silence/video black.

For some effects, the length of the output is dif-
ferent than the length of the input. In this case, 
substituting a bypass when a rendering is miss-
ing doesn't make sense, because it won't sync 
properly. Pro Tools substitutes silence or video 
black.

Ignored Effects
A1<01:00:02:00–01:00:07:01>ignoring render-
ing for effect: EFF_AUDIO_EQMB;using bypass 
clip.

This indicates that the user has selected “Ignore 
Rendered Audio Effects” in Pro Tools. This note 
is a convenience so that if something is odd in 
the translated sequence, the user can determine 
if an effect that was ignored is actually required.

Incomplete Rendering

A1<00:00:28:29-00:00:31:17>incomplete
rendering for effect Audio MultiBand EQ;using
bypass clip.

This indicates that an effect was not rendered 
completely at a fade boundary in an Avid sys-
tem. On import, Pro Tools bypassed the incom-
plete rendering and imported the audio without 
the effect. If you need the effect, re-render the 
effect and fade on the Avid system, and export 
again.Miscellaneous Errors (Misc Errors)

Example

A1<01:00:00:00–01:00:16:06>“Jag film to 
Whirl.01.Sub.06.new.01”; insufficient source
material for clip;shortening clip by 1 sample.



This Translation Note is primarily informa-
tional, informing you that Pro Tools was not 
able to translate the AAF or OMF sequence ex-
actly, and has had to make an adjustment so 
Pro Tools can understand it.

This error occurs because applications don’t al-
ways calculate the number of samples in a frame 
in the same way. In some cases, there may be one 
too few samples of media to support a given clip 
from the Pro Tools standpoint. In this situation, 
there can potentially be an audio “pop.” 

Exporting Pro Tools Tracks 
as AAF or OMF Sequences
Pro Tools lets you export individual tracks in 
AAF or OMF format. Use the Export Selected 

Tracks as AAF/OMF command.

AAF and OMF sequences exported from 
Pro Tools do not support video files. They also 
do not retain information about plug-in assign-
ments, parameters, markers, routing, or group-
ing. It is recommended that you render any ef-
fects prior to export.

Pro Tools can export AAF or OMF sequences 
linked to RF64 audio files, which are special 
WAV files that can be larger than 2 GB 
(normal WAVs must be under 2 GB). How-
ever, Avid video editing applications cannot 
open WAV files larger than 2 GB. Keep file 
size in mind when exporting AAF/OMF for 
Avid video users.
To export selected audio tracks as an AAF or OMF 
sequence:

1  In Pro Tools, select the tracks you want to ex-
port. Choose either mixed or unmixed files.

2  Choose File > Export > Selected Tracks as 

OMF/AAF.

3  From the Export As pop-up menu, select AAF 
or OMF.

Export to OMF/AAF dialog

Shift-click to select multiple tracks; or 
Option-click (Mac) or Alt-click (Windows) 
to select all tracks.
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4  If desired, select Enforce Avid Compatibility.

5  Be sure to select the correct Target Project 

Timecode Format option for the project as set for 
the project in your target application (such as 
Avid Media Composer).

6  Set the Sample Rate Conversion Options as nec-
essary.

7  Set the Audio Media Options settings as neces-
sary:

• Ensure that the Format and Bit Depth match 
the settings in your target project (as set for 
the project in your video software applica-
tion).

– or –

• Select a Copy Option (Link to Source Media, 
Copy from Source Media, or Consolidate 

from Source Media).

8  If you’re exporting a sequence that contains 
stereo, 5.1 or 7.1 tracks and want those tracks to 
retain proper channel layouts upon export, en-
able the Export Stereo, 5.1 and 7.1 Tracks as 

Multi-Channel option.

9  Select other export options.

10  Click OK.

Enforce Avid Compatibility limits the sample 
rate options to 44.1 or 48 kHz, and enables ex-
porting of clip gain data. Dithering without 
noise shaping will be applied to files being ex-
ported from 24-bit to 16-bit.

For more information, see “Export Options 
when Exporting to AAF or OMF Sequences” on 
page 378.
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11  In the Publishing Options dialog, type the 
Pro Tools Comment and Sequence Name.

12  Click OK. 

13  In the Save dialog, navigate to a folder where 
you can easily locate the AAF or OMF sequence 
when it is time to distribute it to another editor 
or import it into Media Composer.

14  Click Save.

15  In the “Please Choose a Folder for Converted 
Audio Files” dialog, navigate to a folder where 
the media files can be easily located (such as the 
same folder where AAF or OMF sequence re-
sides).

16  Click Choose (Mac) or Use Current Folder 

(Windows).

Pro Tools exports the composition and related 
media to the appropriate folders.

Publishing Options dialog (Export Selected Tracks as 
OMF/AAF) shown

Some video editors (such as Avid Media Com-
poser), require all media files to be in specific 
folders to allow proper relinking.



Exporting Multichannel Audio 
Tracks
When exporting AAF, stereo, 5.1, and 7.1 tracks 
can be exported as multichannel tracks, or as 
split-mono tracks. When exporting to OMF, 
multi-channel tracks are always exported as 
multiple mono files.

Exporting Clip Gain
When exporting to AAF with the Enforce Avid 

Compatibility option on, Pro Tools generates 
Media Composer-style clip gain data, based on 
the clip gain data on each track. 

The clip gain of Pro Tools clips with static vol-
ume between -inf dB and +12 dB will translate 
directly to clip-based gain upon export. Dy-
namic clip gain and values above 12 dB will be 
rendered for each clip in the resulting media, to 
optimize compatibility with Avid video editing 
applications.

Exporting Volume Automation to OMF

Pro Tools does export volume automation to 
OMF, but only if the Enforce Avid Compatibility 
option is disabled.

Video tracks cannot be exported to AAF or 
OMF from Pro Tools.

To export clip-based gain data, the Enforce 
Avid Compatibility option must be enabled.

Clip-based gain is not exported when ex-
porting to OMF format.
Exporting Fades
While Pro Tools supports generating audio 
fades in real time, all fades in the session are 
rendered to disk upon AAF or OMF export, to 
optimize compatibility with Avid video editing 
applications.

Clip Groups
Pro Tools cannot export tracks with clip groups 
when exporting to AAF or OMF. Before export-
ing tracks from a sequence containing clip 
groups to AAF or OMF, ensure that any tracks 
containing clip groups are not selected.

Exporting Pro Tools Tracks 
as MXF Audio Files
You can export MXF audio files using the fol-
lowing commands:

• Export Selected Tracks as OMF/AAF
• Bounce to Disk
• Export Selected Clips as Files

Exporting AAF Sequences 
Containing MXF Audio
Use Export Selected Tracks as OMF/AAF to ex-
port individual tracks or an entire Pro Tools 
session as an AAF sequence referring to MXF 
audio files.

Fades are rendered and exported even when 
creating an AAF/OMF sequence with the 
Link to Source Media option enabled.

Tracks are exported in their entirety and time 
selections are ignored.

Volume and pan automation is not exported 
if Quantize Edits to Frame Boundaries or 
Avid Compatibility Mode are enabled.
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To export selected audio tracks from Pro Tools as 
an AAF sequence referring to MXF audio files:

1  In Pro Tools, select the tracks you want to ex-
port.

2  Choose File > Export > Selected Tracks as 

OMF/AAF.

3  Under OMF/AAF Options, select AAF from the 
Export As pop-up menu.

4  Select Enforce Avid Compatibility.

5  Ensure the Target Project Timecode Format is 
correct for the Avid application project to which 
you are exporting the AAF sequence. 

6  Under the Audio Media Options section, select 
MXF from the Audio Format pop-up menu.

7  Verify the Audio Bit-Depth setting is acceptable 
for the recipient of this export. 

8  If you’re exporting a sequence that contains 
stereo, 5.1 or 7.1 l tracks and want to export 
those tracks as multi-channel audio files, enable 
the Export Stereo, 5.1 and 7.1 Tracks as Multi-

Channel option.

9  Click OK. 

10  In the Publishing Options dialog, type the 
Pro Tools Comment and Sequence Name. 

An OMF sequence cannot reference MXF me-
dia files. When using the Export Selected 
Tracks as OMF/AAF dialog, choose AAF in the 
Export As pop-up menu to enable MXF in the 
Audio Format menu.

Enforce Avid Compatibility creates frame-ac-
curate edits, wraps the files as OMFI (unless 
you choose MXF), and limits the sample rate 
options to 44.1 or 48 kHz. Dithering without 
noise shaping will be applied to files being ex-
ported from 24-bit to 16-bit.
Pro Tools Reference Guide
Pro Tools will create a sequence with the name 
you supply. The comment appears in the Avid 
application bin in the Pro Tools Comment col-
umn.

11  Click OK.

12  In the Name the AAF File to Export dialog, 
navigate to a folder where you can easily locate 
the AAF sequence when it is time to distribute it 
to another editor or import it into 
Media Composer.

13  Click Save.

14  In the Please Choose a Folder for Converted 

Audio Files dialog, navigate to a folder where the 
media files can be easily located (such as the 
same folder where AAF or OMF sequence re-
sides).

15  Click Choose (Mac) or Use Current Folder 
(Windows).

Pro Tools exports the AAF sequence to the se-
lected folder, and exports the related media to 
the OMFI MediaFiles folder (OMF files) or the 
Avid MediaFiles folder (MXF files).

16  If you are ready to import the files into the 
Avid application, exit Pro Tools.

Some video editors (such as Avid Media Com-
poser), require all media files to be in specific 
folders to allow proper relinking.

For more information on working in 
Avid applications, see the appropriate 
Avid application guide.



Exporting MXF Audio Files Using 
Bounce to Disk
You can use the Bounce to Disk command to cre-
ate pre-mixed MXF audio files of the current 
Pro Tools session. This does not export all of the 
individual files on the Timeline, but it does 
guarantee that the mix you hear in another ap-
plication will be identical to the mix you hear in 
Pro Tools, including all panning, effects and au-
tomation.

To export to MXF using Bounce to Disk:

1  After you have finished recording and mixing 
a session in Pro Tools, highlight the length of 
the session in the timeline ruler (or on a track), 
plus an additional amount of time to avoid cut-
ting off any reverb tails that might continue past 
the end of the clip.

2  Choose File > Bounce To > Disk.

3  In the Bounce dialog, select the Bounce 

Source. 

Pro Tools Bounce to Disk dialog
4  Select Enforce Avid Compatibility.

5  Select MXF for the File Type.

6  Select a Sample Rate and Bit Depth. 

7  Click Bounce.

8  In the Publishing Options dialog, do the fol-
lowing: 

• Type the Pro Tools Comment and Clip 

Name.

– or –

• Choose a Target Project Timecode Format 
that matches the Avid application project to 
which you are exporting the MXF audio. 

All audible audio in the selection will be ex-
ported to two multi-mono audio files.

9  In the Save Bounce As dialog, choose the drive 
where you want to save the files.

10  Click Save.

Pro Tools will begin bouncing to disk. Pro Tools 
bounces are done in real time, so you hear audio 
playback of your mix during the bounce process 
(though you cannot adjust it).

Enforce Avid Compatibility creates frame-ac-
curate edits, wraps the files as OMFI (unless 
you choose MXF), and limits the sample rate 
options to 44.1 or 48 kHz. Dithering without 
noise shaping will be applied to files being ex-
ported from 24-bit to 16-bit.

Publishing Options dialog
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Exporting a Clip as a New MXF 
File
You can export clips as MXF audio files with the 
Export Selected As Files command. Use this 
command if you intend to use a clip in other ses-
sions or other audio applications without using 
its parent source file. 

This command also provides a way to convert 
clips to a different sample rate or bit depth.

To export clips as new MXF files:

1  In the Clips List, select the clips you want to 
export.

2  From the Audio Clips List pop-up menu, 
choose Export Selected As Files.

Export Selected dialog
Pro Tools Reference Guide
3  In the Export Selected dialog, select the En-

force Avid Compatibility option.

4  Select MXF from the Audio Format pop-up 
menu.

5  Set the bit resolution and sample rate. In addi-
tion, specify the Conversion Quality and Desti-
nation Directory.

6  Click OK.

Export Options when 
Exporting to AAF or OMF 
Sequences
Pro Tools provides several translation settings 
when exporting tracks to OMF/AAF, including 
OMF/AAF Options, Sample Rate Conversion Op-
tions, and Audio Media Options.

OMF/AAF Options
When exporting tracks to AAF or OMF, 
Pro Tools provides the following OMF/AAF Op-
tions:

Enforce Avid Compatibility creates frame-ac-
curate edits, wraps the files as OMFI (unless 
you choose MXF), and limits the sample rate 
options to 44.1 or 48 kHz. Dithering without 
noise shaping will be applied to files being ex-
ported from 24-bit to 16-bit.

Export to OMF/AAF Options



Enforce Avid Compatibility

If the Enforce Avid Compatibility option is en-
abled, all AAF and OMF files and sequences will 
meet the specific requirements of Avid Video 
workstations. Sample rates are limited to 
44.1 kHz or 48 kHz. Exported clips will be pad-
ded to the nearest frame boundaries (Quantize 
Edits to Frame Boundaries). This padding en-
sures that the placement of a file in the Timeline 
will be the same on sample-accurate as well as 
frame-accurate systems. 

Target Project Timecode Format

Select the timecode format for the project into 
which this file or sequence will be imported. 
This may be different from the timecode format 
of the current session. This parameter allows 
clips to be placed correctly in sessions with dif-
ferent timecode formats, and also calculates 
how many samples must be added to pad clips to 
frame boundaries.

Quantize Edits to Frame Boundaries

Pro Tools allows sample-accurate placement of 
clips. In Pro Tools, you can place a clip of any 
length at any position, without any requirement 
for aligning clips with frame boundaries.

However, most video editing programs, such as 
Media Composer, only support frame-accurate 
editing. In these programs, you can only edit 
sounds on whole frame boundaries, limiting 
your precision.

Selecting Enforce Avid Compatibility will auto-
matically select Quantize Edits to Frame Boundar-

ies.

When exporting a sequence with multi-
channel audio tracks, the Enforce Avid 
Compatibility option must be enabled.
The Quantize Edits to Frame Boundaries option 
allows Pro Tools to export your sample-accurate 
Pro Tools edits into an AAF or OMF file so they 
appear as frame-accurate.

When you quantize edits to frame boundaries, 
you must enter a handle size (length) under Au-
dio Media Options. See “Consolidate Handle 
Size (Milliseconds)” on page 382.

A master clip consisting of the clip plus the han-
dle size (length) on both front and back will be 
exported. The exported sequence creates a sub-
clip which is equivalent to the original clip, but 
extended to the farthest frame boundaries. For 

The Quantize Edits to Frame Boundaries set-
ting must be selected when you are translating 
your Pro Tools session for use in frame-accu-
rate editing workstations. Therefore, it is au-
tomatically selected whenever you export 
tracks with Enforce Avid Compatibility 
checked.

Original clip

Clip exported with handles

Subclip: Clip stretched to farthest frame boundaries

Subclip with OFFs (One-frame files) laid over end 
frames
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example, if the clip starts at 1:15 and 500 sam-
ples, the subclip would start at 1:15; and if the 
clip ends at 4:00 and 500 samples, the subclip 
would end at 4:01.

Because quantizing edits to frame boundaries 
extends the clips, extra undesired audio may be 
heard. To prevent this extra audio from playing, 
special one-frame sound files are rendered to 
duplicate the original boundaries of the clip. In 
the exported sequence, these one-frame files are 
placed over the start and end frames of the ex-
tended clip so you cannot hear the extension.

One-frame files (OFFs) are imported into Avid 
workstations as part of the AAF or OMF se-
quence like any other sound file. In the Avid 
Timeline, they appear as one-frame edits on ei-
ther side of a subclip.

If you decide you need to extend the subclip at 
any point, discard the OFF and trim the subclip 
as needed.

Export Stereo, 5.1, and 7.1 Tracks as Multi-
Channel

Select this option to make Pro_Tools export au-
dio from multi-channel tracks as multi-channel 
audio files, rather than sets of multiple mono 
files.

This solution is only available when you ex-
port a sequence, not when you export individ-
ual files. 

If Quantize Edits to Frame Boundaries is se-
lected, Pro Tools volume automation will not 
be exported.
Pro Tools Reference Guide
Sample Rate Conversion 
Options

These settings allow you to convert the sample 
rate of your Pro Tools session during export to 
AAF or OMF by sample-rate converting each au-
dio file, and adjusting the edits in the resulting 
AAF or OMF file to compensate for this change.

You might want to change the sample rate of a 
session if you are exporting to a system or are at 
a stage in the process that requires a different 
sample rate.

For example, your session contains audio media 
at 29.97 fps (NTSC video) at 48 kHz, while the 
film composer to whom you are exporting your 
session requires audio media at 24 fps (film 
speed) at 48 kHz. To convert all the audio files 
and edits to play back at 24 fps (film speed) at 48 
kHz, you would set the Source Audio Sample 
Rate setting to 48,048 (a pull-up rate of 0.1%) 
and the Destination Audio Sample Rate to 
48,000. These settings tell Pro Tools that you 

Sample Rate Conversion Options

See “Speed Correction for Film, NTSC Video, 
and PAL Video” on page 1166, for informa-
tion about converting between different 
speeds and sample rates.

Check the Audio and Video pull options be-
fore applying a sample rate conversion to the 
entire session.



want to fit 48,048 of the original video speed 
samples into 48,000 of the new film speed sam-
ples. With these settings, you sample-rate con-
vert the video material to film speed.

Source Audio Sample Rate

This setting allows you to specify the sample 
rate of the material you are working with in 
Pro Tools, independent of the session’s sample 
rate settings.

Destination Audio Sample Rate

This setting allows you to specify the sample 
rate for audio files after the AAF or OMF trans-
lation. 

If this setting differs from the Source Audio 

Sample Rate setting, audio is sample-rate con-
verted digitally to the Destination Audio Sample 

Rate.

Sample Rate Conversion Quality

These settings correspond to Pro Tools sample 
rate conversion settings. It is not recommended 
that you use the Low (Fastest) setting. The Tweak 

Head (Slowest) setting provides the highest 
quality sample rate conversion.

Audio Media Options

When exporting tracks to AAF or OMF, 
Pro Tools provides the following Audio Media 
Options:

Audio Media Options
Audio Format

Choose whether you want the resulting AAF or 
OMF file to refer to BWF (.WAV), AIFF, SD II 
(Mac and OMF only), MXF (AAF only), or em-
bedded files. The audio files will be converted 
accordingly.

Bit-Depth

Select 16-bit or 24-bit as the target bit-depth for 
the exported media. Pro Tools will apply the Au-
dioSuite dithering algorithm, without noise 
shaping, when reducing bit-depth from 24-bit to 
16-bit.

Source Media

When exporting tracks from Pro Tools to AAF 
or OMF, there are three ways that Pro Tools can 
handle source audio media (as set in the Export 
to OMF/AAF dialog’s Audio Media Options pop-
up menu).

Link To Source Media Creates an AAF or OMF 
file that refers to as many of the original media 
files as possible. In this case, the AAF or OMF 
file points to the BWF (.WAV), MXF, AIFC, or 
Sound Designer II files from the source project.

Copy From Source Media Copies audio to an-
other drive or folder. You can sample-rate con-
vert the audio during this translation.

If you create AIFF or BWF (.WAV) audio, the 
audio files have extra OMF data attached to 
them. Though most applications will not have 
problems reading these audio files, they may 
not be compatible with all applications.

MXF is only available if you have selected the 
Enforce Avid Compatibility option.
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Consolidate From Source Media Copies only the 
part of the files that are actually used by the ses-
sion. For example, you may only be using a ten 
second clip of a ten-minute audio file in your 
session. Consolidating this audio saves a great 
deal of disk space by copying only the audio you 
use, and discarding the rest. 

Consolidate Handle Size (Milliseconds) Speci-
fies the number of milliseconds of the original 
audio file to retain at the beginning and end of 
each audio clip that is created. This lets you ex-
tend clip boundaries even after you have consol-
idated, by the amount you specify. It is a good 
idea to have at least 1000 milliseconds (one sec-
ond) of handle, so you can “trim out” edits that 
sound “clipped” or “up-cut.” Consolidate Handle 

Size is only available when Consolidate From 

Source Media is selected.

Export Stereo, 5.1, and 7.1 Tracks as Multi-
Channel

When exporting a sequence with multi-channel 
(stereo, 5.1 or 7.1) tracks, enable this option to 
retain proper channel layouts upon export.

Publishing Options
When exporting AAF or OMF files from 
Pro Tools, specific publishing options that pro-
vide information about the sequence or media 
are available through the Publishing Options di-
alog. These options will vary depending on 
which method of exporting files you use.

Consolidate Source Audio Media is the only 
usable option for a Pro Tools to AAF or OMF 
translation when Quantize Edits to Frame 
Boundaries is selected. See “Quantize Edits to 
Frame Boundaries” on page 379.
Pro Tools Reference Guide
OMF Options

Pro Tools Comment Identifies the source of the 
file, and defaults to the name of the current ses-
sion. The Pro Tools Comment field does not ap-
pear if you are using the Export Selected as 

Tracks command, since audio on one track may 
have many different sources.

Sequence Name This is the name that will be 
displayed when the file is imported into another 
AAF- or OMF-compatible program. The se-
quence name is not the file name that will ap-
pear in the finder. This field defaults to the 
Pro Tools clip name. When exporting more than 
one clip, all clip names are automatically set to 
the clip name.

Target Project Timecode Format This is the 
timecode format for the project into which this 
file or sequence will be imported. This may be 
different from the timecode format of the cur-
rent session. This parameter allows clips to be 
placed correctly in sessions with different time-
code formats, and also calculates how many 
samples must be added to pad clips to frame 
boundaries.

Time Stamping

When you export to AAF or OMF, all exported 
media is time stamped. A time stamp is a specific 
timecode location stored within an individual 
media file.

The time stamp can indicate:

• Timecode location on the source tape

• Where the file was originally recorded in 
the Pro Tools Timeline

• Where a clip was placed in an Avid or 
Pro Tools Timeline

• User entered timecodes



Time stamps can be stored in three different 
places within a media file:

• In a clip definition

• In the file format metadata (for 
example, .WAV file wrappers)

• In the AAF or OMF wrapper

Exporting a Clip

If you are exporting a clip, the time stamp will 
be the start point of the clip, relative to the point 
where the file originally started to record. For 
example, if you record a file from 1:00 to 1:30, 
then trim it to start at 1:15, the time stamp for 
the exported clip would be 1:15. This is true 
even if the clip is slipped elsewhere in the Time-
line.

Exporting a Clip as Part of a Sequence

When you export a clip as part of a sequence, the 
clip’s original time stamp reflects the clip’s po-
sition in the Timeline of the sequence.

Exporting a File

Recorded in Pro Tools If the file was recorded in 
Pro Tools, the time stamp is the location in the 
Timeline at which the recording began. For in-
stance, if you record the file from 1:00 to 2:00, 
the time stamp would be 1:00.

AudioSuite If the file was created by AudioSuite, 
the time stamp depends on the rendering mode 
used when the file was rendered. If Create Indi-

vidual Files mode is selected, the time stamp of 
the new file matches the original time stamp of 
the source file. If Create Continuous File is se-
lected, the time stamp of the new file matches 
the position of source file on the timeline.
Existing Time Stamp If a file is imported with an 
existing time stamp, it will remain the time 
stamp for the exported file as well. If the origi-
nal file contained a time stamp in the format 
wrapper, it will be copied to the OMF wrapper 
when exported.

Exporting a File With No Time Stamp

If you import a file that does not contain a time 
stamp (such as a sound effect from a CD), the 
time stamp will be 0 when it is exported.

Importing Files from an Avid AAF or 
OMF Sequence

If you import a file from an Avid AAF or OMF 
sequence, the media file's source tape time 
stamp becomes the original time stamp of the 
new Pro Tools file. The User Timestamp main-
tains the original time stamp.

Export Selected Tracks as 
New Session
Pro Tools lets you export any selected tracks in a 
session as a new session. This command replaces 
the Export Session Data command in lower ver-
sions of Pro Tools. This feature is especially use-
ful in collaborative situations. 

For example, you might be working on a large 
post-production session and you want your col-
laborator to work on only some dialog in the ses-
sion while you continue working on other parts 
of the session. You can now select the dialog 
tracks and export them as a new session. Your 
collaborator can then open the new session and 

DigiBase provides columns for specific Avid 
OMF metadata, including: Clip Name, Tape, 
FPS, Original Timestamp, and User Time-
stamp.
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edit the dialog. When your collaborator is done, 
you can import the session data from the dialog 
session to update the dialog tracks in your big 
session.

To export selected tracks as a new session:

1  Select the tracks you want to export as a new 
session.

2  Choose File > Export > Selected Tracks As New 

Session. The Save Session Copy dialog opens. 
(You can also open the Save Session Copy dialog 
by choosing File > Save Copy In.)

3  In the Save Session Copy dialog, verify that the 
Selected Tracks Only option is enabled.

4  Configure the Session Format and Session Pa-
rameters settings and options as desired.

5  Configure the Items to Copy settings and op-
tions as desired.

6  You can also enable the Main Playlist Only op-
tion if you don’t want to include any of the alter-
nate playlists associated with any of the selected 
tracks in the new session.

7  Click OK. The Save dialog opens.

8  In the Save dialog, name the session.

9  Navigate to where you want to save the session.

Save Session Copy dialog
Pro Tools Reference Guide
10  Click Save.

A copy of the session that contains only the se-
lected tracks from the source session is saved to 
the specified location.

Exporting Sessions as Text
You can use the Export Session Info as Text com-
mand to create a text file that contains extensive 
information about your session. 

This text file can contain a list of audio files, au-
dio clips, audio track EDL (Edit Decision List) 
information, extended timestamp information, 
and information about crossfades.

Track EDLs are exported as tab-delimited text—
that is, with tabs between each column heading, 
and tabs between each event parameter. You can 
use this data in a program for reading EDLs, or 
you can format the EDL data into tables using a 
word processor or spreadsheet application.

To export a session as text:

1  Choose File > Export > Session Info as Text.

2  Select whether to include the File List, Clip 
List, and track EDLs.

3  If you choose to include track EDLs, select 
whether to show subframes, and whether to in-
clude user timestamps. Also select an option for 
crossfade handling.

4  If you choose to include track EDLs, select the 
Time Format for the exported session text from 
the pop-up menu.

5  Select the File Format for exported text using 
the pop-up menu.

For information on the Save Session Copy 
dialog settings and options, see “Save Copy 
In Options” on page 171.



6  When you have set your options, click OK. 

7  Select a location and type a filename for the 
exported text file. In Windows, Pro Tools adds 
the correct 3-letter filename extension, while on 
the Mac, the file extension “.txt” is added.

Exported Session Text Files

Session Information

The session text file starts with basic informa-
tion about the session. This information in-
cludes the session name, sample rate, bit depth, 
timecode format, and number of audio tracks, 
audio clips, and audio files, as shown in the fol-
lowing example.

File List and Clip List

Next, if you choose to include them, are the lists 
of audio files and clips.

Track EDLs

The final item, if exported, is the list of track 
EDLs. A track EDL lists the track name, and all 
edits, including the event number, the clip 
name, clip start and end time, and clip duration. 
The clip timestamp is also exported, if you select 
this option. Subframes are shown in each time 
field if you select this option.

Session Information example

SESSION NAME: Ripleys II-092700

SAMPLE RATE: 48000.000000

BIT DEPTH: 24-bit

TIMECODE FORMAT: 30 Frame

# OF AUDIO TRACKS: 19

# OF AUDIO clipS: 203

# OF AUDIO FILES: 54
Export Session Info as Text 
Options

Include File List/Clip List

You can choose to export a list of the session’s 
audio files and clips. The File List provides a list 
of all the audio files and fades in the session, and 
their hard drive locations. The Clip List displays 
all audio clips in the session, and the source au-
dio file for each clip.

Include Track EDLs (Playlists)

You can export track EDLs (playlists). Track 
EDLs can be used to spot-check clip placement 
and edits, or in a conforming program for post 
applications. In extreme circumstances the EDL 
can be used to recreate the entire session.

Export Session Info as Text dialog

MIDI track EDLs are not exported.
Chapter 17: Importing and Exporting Session Data 385



386
When exporting track EDLs, the following op-
tions are available:

Show Subframes This option allows you to ex-
port subframe time information with track 
EDLs, if used in your session.

Include User Timestamps You can include user 
timestamps with track EDLs. User timestamps 
indicate a user-defined session location for the 
clip, or the original location of the clip when re-
corded.

Fade Handling For track EDLs, you can choose 
whether to show crossfades, not to show them, 
or to combine crossfaded clips. When clips are 
combined, their durations and locations are 
listed up to the center of the crossfade (for the 
leading clip) and from the center of the cross-
fade (for the following clip).

Time Format You can select the appropriate time 
format that exported EDL information is based 
on. For example, for post work, you might select 
SMPTE time, but for music creation locked to a 
grid, you might select Bars:Beats. 

File Format

On Mac, you can choose to export to any of sev-
eral different text formats. These include stan-
dard text formats, and Microsoft Word and Ex-
cel formats. On Windows, Pro Tools always only 
exports to a .txt file.
Pro Tools Reference Guide
Importing and Exporting Clip 
Group Files
Pro Tools can export and import the clip group 
file format (.rgrp). This lets you do the follow-
ing:

• Separate clip group metadata from audio 
files to avoid unnecessary file copy opera-
tions when exporting audio clip groups 
composed from multiple source files.

• Export MIDI data as part of a clip group.

• Create multitrack loops.

Clip group files store the following metadata:

• References to all audio files within the clip 
group

• Clip names and relative location in tracks

• Embedded fades and crossfades

• Clip group names and format (single or 
multitrack)

• All MIDI data present in the clip group 
(such as notes, controllers, and Sysex)

• Track names

• Elastic Audio Warp markers and TCE factor

• Clip timebase (samples or ticks)

• Sync points

• Loops

• Tempo map

Clip group files do not store the following:

• Audio

• Automation 

• Plug-Ins

• Track routing

• Meter map 

• Clip List information



Pro Tools provides several ways to import clip 
groups into an open session:

• “Importing Clip Groups with Pro Tools 
Menu Commands” on page 387

• “Importing Clip Groups with Drag and 
Drop” on page 387

Importing Clip Groups with 
Pro Tools Menu Commands

To import a clip group with Pro Tools menu 
commands:

1  Choose File > Import > clip groups and select the 
clip group you want to import.

2  In the Clip Group Import Options dialog, 
choose where the clip group will go:

New Track Creates a new track where the clip 
group will be imported.

Clip List Imports the clip group into the Clip 
List, where it will be where it will be available to 
place into tracks. 

3  If you chose to create a new track, choose a lo-
cation for the imported group in the track:

Clip Group Import Options dialog
Session Start Places the group at the start of the 
session. 

Song Start Aligns the beginning of the group to 
the Song Start point. 

Selection Aligns the beginning of the group to 
the edit cursor or to the beginning of a selection 
in the Timeline.

Spot Displays the Spot dialog, which lets you 
spot the group to a precise location based on any 
of the Time Scales.

4  Select any of the following import options:

Import Tempo Map from Clip Group File When 
selected, replaces the session tempo map with 
the tempo map of the clip group. This option is 
only available when importing the clip group to 
the Session Start.

5  Click OK. 

Importing Clip Groups with Drag 
and Drop
You can drag and drop clip groups from a 
DigiBase browser or from Windows Explorer or 
the Mac Finder to the Timeline, a track, the 
Track List, or the Clip List.

To import clip groups into the Clip List:

1  Select one or more clip groups in a DigiBase 
browser, Windows Explorer or Mac Finder. 

2  Drag the files onto the Clip List of the current 
session. 

To import clip groups into an existing track:

1  Select one or more clip groups in a 
DigiBase browser or from Windows Explorer or 
Mac Finder. 

2  Drag the files onto an existing track in the Edit 
window of the current session. 
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To import clip groups into new tracks:

1  Select one or more clip groups in a DigiBase 
browser, Windows Explorer or Mac Finder. 

2  Do one of the following:

• From the DigiBase browser, Shift-drag the 
files anywhere in the Edit window of the 
current session.

• Drag the files onto any empty space in the 
Edit window of the current session.

• Drag the files to the Track List.

Exporting Clip Groups

To export a clip group:

1  Select one or more clip groups in the Clip List.

2  From the Clip List menu, choose Export Clip 

Groups. The Export Clip Groups dialog opens.

3  The Destination Directory defaults to the 
auto-created Clip Groups folder in the session 
folder. You can change the Destination Directory 
by clicking the Choose button, navigating to a 
new location, and clicking Choose. Click Reset 
to reset the Destination Directory to the default 
location.

Export Clip Groups dialog
Pro Tools Reference Guide
4  Enable one of the following options for resolv-
ing duplicate clip group file names:

• Prompting for Each Duplicate (default)

• Auto Renaming 

• Replacing with New Files 

5  Click OK. 

Exporting Clip Groups to Another Hard Drive

Generally, if you are exporting clip groups to an-
other hard drive, you should copy any refer-
enced audio files. This way you can move clip 
groups not only from one session to another, but 
from one system to another.

To export a clip group to a different hard drive and 
include its audio files:

1  Export one or more clip groups to the new 
drive.

2  Create a new session on the new drive.

3  Choose Setup > Preferences.

4  In the Preferences dialog, click the Processing 
tab and select Automatically Copy Files on Import.

5  Click OK to close the Preferences dialog.

6  Import all previously exported clip groups by 
dragging and dropping them into the session. 

The audio files folder of the new session now 
contains all files referenced by the clip groups.



Send via DigiDelivery
Aspera DigiDelivery® is a system for efficient 
and reliable transfer of digital media files over 
the Internet. Send via DigiDelivery lets you send a 
Pro Tools session and all of its related files using 
DigiDelivery from within Pro Tools.

Like the Save Copy In command, DigiDelivery 
copies all files of the same type, regardless of their 
location, into a single destination folder.

Anyone can send and receive files from a 
DigiDelivery system, even if they do not own a 
DigiDelivery network appliance, as follows:

 To send a delivery, senders must have an Inter-
net connection, an account on a DigiDelivery 
network appliance, and the DigiDelivery client 
application. 

 To receive a delivery, recipients only need an 
Internet connection and the DigiDelivery client 
application. An account on the network appli-
ance is not needed.

DigiDelivery is not compatible with 
Mac OS X Lion.

For more information about DigiDelivery, 
visit the Aspera website 
(http://www.asperasoft.com).
To send a session from Pro Tools using 
DigiDelivery:

1  Choose File > Send via DigiDelivery.

2  Do one of the following:

• If the DigiDelivery client is not installed on 
your system, Pro Tools will launch your 
Web browser, and connect to the DigiDeliv-
ery site where you can download the cur-
rent DigiDelivery client.

– or –

• If the DigiDelivery client is installed on 
your system, the Send to DigiDelivery dia-
log will open.

3  In the Send to DigiDelivery dialog, select 
which files to include.

You have the option to include:

• Audio files

• Fade files (Pro Tools 9 and lower only)

• Video files

• Plug-In settings files

• Visible Timeline files only (files that are 
referenced in the current session Timeline 
on tracks that are shown)

Include in Delivery dialog
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4  Click OK. The DigiDelivery client will launch, 
and the DigiDelivery Send Wizard (Page 1) will 
open. On this page you can name the delivery 
and add or remove files.

5  Complete the remaining DigiDelivery Send 
Wizard pages and send the file, following the in-
structions that came with the DigiDelivery client 
software.
Pro Tools Reference Guide



Chapter 18: File and Session Management 
and Compatibility
When working with Pro Tools, you will encoun-
ter several different kinds of computer files. 
Pro Tools systems require that you keep certain 
files in specific hard drive locations in order to 
function properly:

• Pro Tools software files (such as the appli-
cation and plug-ins files) should be located 
on your Startup drive (the drive that con-
tains your operating system and other sys-
tem-related files).

• Data files (such as session files, audio files, 
and video files) can be located on any com-
patible drive connected to your computer’s 
internal or external SAS, SATA, IDE/ATA, 
FireWire, or SCSI busses (including SCSI 
HBA). 

You can specify the location of new session files 
when creating new sessions (see “Creating a 
New Session” on page 162).

In Pro Tools sessions, use the Disk Allocation 
command to specify where you want newly re-
corded audio files to be stored (see “Working 
with Hard Drives for Recording” on page 452).

Although Pro Tools lets you record to your 
system drive, this is generally not recom-
mended. You should record to system drives 
only when necessary—for example, if your 
computer system has just one hard drive, or 
it your other hard drives are completely full.
Audio File Management

Unique File IDs
Pro Tools tags each audio file in a session with a 
unique identifier that allows it to distinguish a 
particular file even if its name or location has 
changed.

Locating Audio Files
With Pro Tools, you manage links to audio and 
other media files using the Relink window. 

Pro Tools classifies storage volumes according 
to their suitability for performance (recording 
or playback) or transfer (storage or copying) of 
audio and other media files. Audio files must be 
stored on suitable Performance volumes and be 
properly linked in order to be playable in a 
Pro Tools session.

If you have a system with multiple drives, 
you can designate the System drive as a 
Playback only or Transfer only drive for op-
timal performance (see “Audio and Video 
Volume Designators” on page 319).
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When you open a session, if Pro Tools deter-
mines that audio files are not located on a Per-
formance volume, or if it is unable to locate au-
dio files contained in the session, you can locate 
or copy the files in order to play back the ses-
sion. This process is called relinking. 

Transfer Files

Transfer files reside on volumes unsuitable for 
playback, such as CD or DVD discs, or network 
drives.

To open a session containing Transfer files:

 Open the Pro Tools session. If any files are on 
a volume unsuitable for playback, Pro Tools 
prompts you to do one of the following:

• Click Yes to open the Copy and Relink win-
dow.

– or –

• Click No to open the session with all Trans-
fer files offline. 

To make Transfer files playable in the current 
session:

1  Choose Window > Project.

2  Double-click the Audio Files folder to display 
all of the audio files.

3  Choose Select Transfer Files from the Browser 
menu. 

4  Choose Copy and Relink from the Browser 
menu. 

5  Specify a location for the copied files on a valid 
Performance volume.

6  Click OK. 

For more information on storage volume 
classifications, see “Performance and 
Transfer Volumes” on page 283.
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Missing Files

A file is missing if it is not found in the same lo-
cation as when the session was last saved. 

To open a session with missing files:

1  Open the Pro Tools session. If any files are 
missing, Pro Tools posts a Missing Files warn-
ing.

2  Choose one of the following options:

Skip All Ignores all missing files. Missing files 
appear offline in the session.

Manually Find and Relink Opens the Relink win-
dow, where you can search, compare, verify, and 
relink missing files.

Automatically Find and Relink Searches all Per-
formance volumes for all missing files with 
matching name, unique file ID, format, and 
length, and automatically commits links to 
missing files where possible. 

3  To exclude any Rendered Elastic Audio files 
from the relink process and regenerate them in-
stead, select Regenerate Missing Rendered Files 

Without Searching.

4  Click OK. 

For more information on relinking Transfer 
files, see “Linking and Relinking Files” on 
page 310.

Missing files warning when opening a session



Renamed Audio Files and the 
Renamed Audio Files Folder
Renamed audio files are located in the auto-cre-
ated Renamed Audio Files folder in the 
Pro Tools session folder. Files can be renamed 
when you open a session that references audio 
file names with incompatible characters. Files 
can also be renamed in certain situations when 
saving a copy of a session to a Pro Tools version 
that does not support long file names

Opening a Session that Contains Audio File 
Names with Illegal Characters

Pro Tools 7.x and higher does not support audio 
file names that contain the following ASCII 
characters:

/ (Forward Slash)
\ (Backslash)
: (Colon)
* (Asterisk)
? (Question mark)
“ (Quotation marks)
< (Less-than symbol)
> (Greater-than symbol)
| (vertical line or pipe)
Any “high order” ASCII character (created 
with a key combination)

When opening sessions that contain audio file 
names with illegal characters, Pro Tools auto-
matically creates a renamed copy of each file 
that contains illegal characters (replacing these 
characters with an underscore “_”). Renamed 
files are copied to the Renamed Audio Files 
folder. The original files are left intact in the 
Audio Files folder.

For more information on missing files, see 
“Linking and Relinking Files” on page 310.
Before the session opens, you are prompted to 
save a detailed report of the renamed files and 
their original file names to a Notes text file. By 
default, the Notes text file is saved to the Session 
folder.

Saving a Copy of a Session that Contains Long 
Audio File Names

When saving files to Pro Tools 6.9.x and lower 
(using Save Copy In), audio files with file names 
that exceed the limits of the destination format 
are truncated and located in the Session folder, 
as follows:

• If the new session is saved to the same direc-
tory as the original, a Renamed Audio Files 
folder is created in the session’s original 
folder, and the renamed audio files are placed 
in it.

• If the new session is saved to a different direc-
tory than the original and the All Audio Files 
option is not checked, a new Session folder is 
created, which includes an Audio Files folder 
and a Renamed Audio Files folder. Renamed 
audio files are included in the Audio Files 
folder.

• If the new session is saved to a different direc-
tory than the original and the All Audio Files 
option is checked, a new Session folder is cre-
ated, which includes an Audio Files folder. Re-
named audio files are included in the Audio 
Files folder.

It is possible to have a Pro Tools 7.x or 
higher session that contains audio file 
names with illegal characters. If you Save 
Copy In the session to Pro Tools 6.9.x or 
lower with Mac/PC Compatibility on, the 
tracks are renamed with legal characters. If 
Mac/PC Compatibility is off, the characters 
are not changed.
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WAV File Compatibility
Convert Imported WAV files to 
AES31/BroadcastWave

Pro Tools always creates AES31/Broadcast com-
pliant BWF (.wav) files when the file originates 
in Pro Tools. Non-BWF .wav files can be added 
to BWF (WAV) format Pro Tools sessions with-
out conversion. This option ensures that all 
WAV files are imported, and if necessary, con-
verted to BWF (WAV), compliant with the 
AES31/EBU Broadcast standard.

AES31/Broadcast Wave is a variant of the stan-
dard audio WAV file type. The AES31 format 
contains SMPTE time stamps and other infor-
mation beyond the raw PCM audio data. 

This variant complies with standards set by the 
AES (Audio Engineering Society) and EBU (Eu-
ropean Broadcasters Union). Choose this option 
to ensure compatibility with other workstations 
that recognize this file type. 

To make imported WAV files compliant with the 
AES31/EBU Broadcast standard:

1  Choose Setup > Preferences and click the Pro-

cessing tab.

2  Select the Convert Imported “.wav” Files to 

AES31/BroadcastWave option.

3  Click OK.

WAVE Extensible File Format 

Pro Tools 10 supports the WAVE Extensible file 
format for audio files. This file format specifies 
multiple audio channel data (surround sound) 
along with speaker positions, which is stored 
within the audio file header. These audio files 
are identified in DigiBase browsers with the des-
ignation “WAV (BWF EXT)” in the Attributes 
field. 
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If you are working with greater-than-stereo 
multichannel track formats in your Pro Tools 
sessions, it is recommended that you use the 
WAV file format.

RF64

Pro Tools 10 supports the RF64 audio file for-
mat. RF64 is an extension to the WAV audio file 
format that addresses the 4 gigabyte size limita-
tion of other WAV audio file formats. RF64 au-
dio files are identified in DigiBase browsers with 
the designation “MBWF” in the Attributes field.

Sharing Sessions Created on 
Different Computer Platforms

Working with Mac-Based HFS+ 
Drives on Windows Computers
Either the HFS+ Disk Support option or the 
MacDrive Utility is required to mount HFS+ 
drives on an NTFS system for use with 
Pro Tools.

When using the WAV file format in Pro Tools 
10 sessions, the corresponding channel order 
for each channel of greater-than-stereo, in-
terleaved multichannel files is displayed in 
the Clip List.

Lower versions of Pro Tools cannot read 
RF64 files. These files have to be manually 
edited and consolidated so that they are no 
larger than 4 GB in order to be available to 
systems running lower versions of Pro Tools.



HFS+ Drive Support Option
(Windows Only)

Pro Tools for Windows support recording and 
playback of sessions directly from Mac-format-
ted (HFS+) drives using the HFS+ Disk Support 
option. The HFS+ Disk Support option is auto-
matically installed with Pro Tools software by 
default.

When using the HFS+ Disk Support option for 
recording and playback on a Windows system, 
the session file and all associated files (such as 
audio and MIDI files) must be stored on Mac-
formatted (HFS+) drives. Recording and play-
back of a session from a mixture of Windows- 
and Mac-formatted drives is not supported.

Moving Sessions on Windows 
Systems to Mac-Based HFS+ 
Drives
(From Window-Based NTFS Drives Only)

There are specific steps for transferring session 
files from Windows-based NTFS drives to Mac-
based HFS+ drives.

To transfer Pro Tools Windows sessions from 
NTFS drives to HFS+ drives:

1  Set the HFS+ Disk Support Options or the 
MacDrive Options to Backup/File Transfer.

2  Do one of the following:

• Drag the session folder from the NTFS 
drive to the HFS+ drive.

– or –

• Open the Windows session on the NTFS 
drive, choose Save Copy In, and save a copy 
of the session to the HFS+ drive.

For more information, see Chapter 19, 
“Mac HFS+ Disk Support Option 
(Windows Only).”
Moving Mac-Based Sessions on 
HFS+ Drives to Windows 
Systems
(To Windows-Based NTFS Drives Only)

There are specific steps for transferring files 
from Mac-based HFS+ drives to Windows-based 
NTFS drives.

To transfer Pro Tools Mac sessions from HFS+ 
drives to NTFS drives:

1  Set the HFS+ Disk Support option or the Mac-
Drive Options to Normal Use.

2  Do one of the following:

• Drag the session folder from the HFS+ 
drive to the NTFS drive.

– or –

• Open the Mac session on the HFS+ drive, 
and when prompted, choose Save Copy In 

and save a copy of the session to the HFS+ 
drive. 

To save (or create) Mac sessions to be com-
patible on Windows systems, see “Saving 
Copies of Mac Sessions to be Compatible 
with Windows” on page 396.

When transferring Pro Tools sessions from 
HFS+ drives to NTFS drives, Pro Tools ses-
sions cannot relink to audio files that have 
Mac characters that are illegal in Windows. 
These characters are automatically con-
verted to underscore (“_”) characters. These 
files are saved to the Renamed Audio Files 
folder. You need to manually relink each 
file by File ID. See “Missing Files” on 
page 392.

To save session with no illegal characters, 
see “Saving Copies of Mac Sessions to be 
Compatible with Windows” on page 396.
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If the session previously used SD II files, the 
files are converted to the new audio file format.

Recording and Playback from 
HFS+ Drives on Windows
Windows supports recording and playback of 
sessions directly from Mac-formatted (HFS+) 
drives using either the HFS+ Disk Support op-
tion or the MacDrive software application.

When using either the HFS+ Disk Support op-
tion or MacDrive for recording and playback on 
a Windows system, the session file and all audio 
files must be stored on Mac-formatted (HFS+) 
drives. Recording and playback of a session 
from a mixture of Windows- and Mac-formatted 
drives is not supported.

To record or play back from HFS+ drives with 
Windows using MacDrive:

1  In Windows, go to the MacDrive Control Panel.

2  Choose Options > File Names and select the In-

ternational Use option.

3  Delete all options listed under “File Name 
Maps.”

4  In Pro Tools, choose Window > Workspace and 
make sure that all Mac-formatted volumes are 
set to R (record) or P (playback) in the A (Audio) 
and V (Video) columns. 

In older versions of Pro Tools, Mac-for-
matted HFS+ drives could only be used as 
Transfer volumes when connected to Win-
dows systems using MacDrive.

For information on using the HFS+ Disk 
Support option, see the Mac HFS+ Disk Sup-
port Option Guide.
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Saving Copies of Mac Sessions 
to be Compatible with Windows
(Save Copy In to Pro Tools 6.9.x and Lower 
Only)

Sessions created and saved as Pro Tools 7.x and 
higher sessions are always compatible on both 
Windows and Mac systems.

If you create a Pro Tools 6.9.x or lower session 
on a Mac system, the session is only compatible 
on Windows systems if the Enforce Mac/PC Com-

patibility option is selected when using the Save 

Copy In command. In addition, there are cross-
platform limits to consider when completing the 
Save Copy In command.

Cross-Platform Session Limits

When saving (or creating) a copy of a Pro Tools 
session that you want to be compatible on both 
Mac and Windows, keep in mind the following 
limits and how Pro Tools deals with them:

Audio File Types

The recommended file format for cross-plat-
form interoperability is BWF (.WAV). To sup-
port optimal session interchange, Pro Tools de-
faults to BWF format for new sessions.

Pro Tools lets you save, bounce, and export in a 
variety of audio file formats, including WAV, 
AIFF, SD II, MP3, and QuickTime. 

File Name Extensions

For cross-platform compatibility, all files in a 
session must have a 3-letter file extension added 
to the file name. Pro Tools 5.1 to 6.9.x session 
files have the extension “.pts,” and Pro Tools 5 
sessions have the extension “.pt5.” Wave files 
have the “.wav” file extension, and AIFF files 
have the “.aif” file extension.



Incompatible ASCII Characters

Clip names, track names, file names, and plug-in 
settings cannot use ASCII characters that are in-
compatible with either system. 

When importing files into a session, incompati-
ble characters are converted to underscores 
(“_”) and the renamed files are placed in the Re-
named Files folder.

The following characters cannot be used in 
Windows sessions:

/ (Forward Slash)
\ (Backslash)
: (Colon)
* (Asterisk)
? (Question mark)
“ (Quotation marks)
< (Less-than symbol)
> (Greater-than symbol)
| (vertical line or pipe)
Any “high order” ASCII character (created 
with a key combination)
Saving Cross-Platform Sessions

To save an existing session to Pro Tools 6.9.x or 
lower and maintain Mac and Windows 
compatibility:

1  Choose File > Save Copy In.

2  In the Save Session Copy dialog, choose a des-
tination and type a name for the new session file.

3  Set the Audio File Type to AIFF or BWF (.WAV). 
These file formats are compatible with either 
platform.

4  Set the Sample Rate and Bit Depth for the ses-
sion.

5  Select Enforce Mac/PC Compatibility. This op-
tion must be selected to make the session cross-
platform compatible.

6  Select the Items to Copy options for the new 
session.

7  Click Save. 

If the session previously used SD II files, the 
files are converted to the new audio file format.

Pro Tools can convert a file created on a 
Mac and saved without the “Enforce 
Mac/PC compatibility” option selected to a 
Windows compatible file. For more infor-
mation, see “Sharing Sessions Created on 
Different Computer Platforms” on page 394.
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Sharing Sessions Created on Different Pro Tools Systems
Pro Tools makes it easy to share sessions between Pro Tools HD and Pro Tools. There are some im-
portant differences between systems that can affect how session material is transferred. The following 
table also includes Pro Tools systems with the Complete Production Toolkit.
Pro Tools Reference Guide
For details on transferring sessions between Windows and Mac systems, see “Sharing Sessions Created 
on Different Computer Platforms” on page 394.
Differences between Pro Tools systems
Feature
Pro Tools|HD 
Systems

HD Native Systems
Pro Tools with 
Complete 
Production Toolkit

Pro Tools

Maximum 
number of 
audio tracks

up to 768 tracks (up 
to 192 voiceable)

up to 768 tracks (up 
to 256 voiceable)

up to 768 tracks (up 
to 256 voiceable)

up to 128 
tracks (up to 
96 voiceable)

Maximum 
number of 
Auxiliary 
Input tracks

512 512 512 128

Maximum 
number of 
Instrument 
tracks

512 512 512 64

Maximum 
number of 
internal mix 
busses

256 internal mix 
busses

256 internal mix 
busses

256 internal mix 
busses

256 internal 
mix busses

Inserts per 
track

up to 10 inserts up to 10 inserts up to 10 inserts up to 10 
inserts

Sends per 
track

up to 10 sends up to 10 sends up to 10 sends up to 10 
sends



Opening Pro Tools HD Sessions 
in Pro Tools
A Pro Tools HD session can be opened with 
Pro Tools, but certain session components open 
differently or not at all.

When opening a Pro Tools HD 10.0 session in 
Pro Tools 10.0, the following occurs:

Tracks

• Any tracks beyond the first 128 are made inac-
tive.

• Any Instrument tracks beyond 64 are made in-
active.

• Any Auxiliary Input tracks beyond 128 are 
made inactive.

• DSP plug-ins with Native equivalents are con-
verted; those without equivalents are made in-
active.

• Multichannel surround tracks are removed 
from the session.

• Unavailable input and output paths are made 
inactive.

• HEAT (if present) is removed.

Groups

• Mix Groups keep only Main Volume informa-
tion.

• Mix/Edit Groups keep only Main Volume and 
Automation Mode information.

• Automation overflow information for grouped 
controls is be preserved.

• Group behavior of Solos, Mutes, Send Levels, 
Send Mutes is be preserved.

Pro Tools with Complete Production Toolkit 
provides seamless session interchange with 
Pro Tools HD. For a complete list of features 
supported by Complete Production Toolkit, 
see “Complete Production Toolkit” on 
page 56
• Solo Mode and Solo Latch settings are 
dropped.

Video

• Only the main video track is displayed.

• Only the first QuickTime movie in the session 
is displayed or played back.

• If the session contains QuickTime movies in 
the Clip List but no video track, the session 
opens with a new QuickTime Movie track con-
taining the first QuickTime movie from the 
Clip List.

• The Timeline displays and plays back only the 
video playlist that was last active. Alternate 
video playlists are not available.

Sharing Sessions Created on 
Different Pro Tools Software 
Versions
Pro Tools makes it easy to share sessions be-
tween different software versions of a particular 
Pro Tools system. 

Pro Tools 10.0 sessions cannot be opened with 
lower versions of Pro Tools. To save a Pro Tools 
10.0 session so it is compatible with a lower ver-
sion of Pro Tools, use the File > Save Copy In 
command to select the appropriate session for-
mat.

Saving Pro Tools 10.0 Sessions 
to Pro Tools 7 –> 9 Format
To save a Pro Tools 10.0 session so it is compat-
ible with Pro Tools version 7.x through 9.x, use 
the File > Save Copy In command to choose the 
Pro Tools 7 –> 9 Session format.
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When saving a Pro Tools 10.0 session to 
Pro Tools 7 –> 9 format, the following occurs:

• Any audio tracks beyond 256 are made inac-
tive

• Clip gain settings are dropped. If you want to 
apply any clip gain settings prior to saving the 
session copy, you will need to manually render 
clip gain settings.

• Fades have to be rendered when the session is 
opened in a lower version of Pro Tools.

• Sessions with mixed file formats and bit-
depths must convert all files to the same file 
format and bit depth.

• Sessions with files that have a bit depth of 
32-bit floating point must be converted to 
24-bit or 16-bit.

• For sessions with RF64 files larger than 4 GB, 
these files will be unavailable to lower ver-
sions of Pro Tools. (You will need to manually 
edit and consolidate these files so that the au-
dio can be available to lower versions of 
Pro Tools.)

Opening Pro Tools 9.0 Sessions 
with Pro Tools 8.1 and 8.5
A Pro Tools 9.0 session can be opened with 
Pro Tools 8.1 and 8.5, but certain session com-
ponents open differently or not at all.

When opening a Pro Tools 9.0 session with 
Pro Tools 8.1 or 8.5, the following occurs: 

• Any audio tracks beyond 256 are made inac-
tive.

• Any internal mix busses beyond 128 are made 
inactive.

When opening a Pro Tools 9.0 session with 
Pro Tools 8.1 or 8.5, you are warned that 
you are opening a session created with a 
newer version of Pro Tools and that not all 
session components will be available.
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• The Stereo Pan Depth reverts to –2.5 dB.

Opening Pro Tools 9.0 Sessions 
with Pro Tools 8.0
A Pro Tools 9.0 session can be opened with 
Pro Tools 8.0, but certain session components 
open differently or not at all.

When opening a Pro Tools 9.0 session with 
Pro Tools 8.0, the following occurs: 

• All that occurs when opening a Pro Tools 9.0 
session with Pro Tools 8.1.

• Output bus assignments are removed.

• HEAT (if present) is removed.

Opening Pro Tools 9.0 Sessions 
with Pro Tools 7.4.x
A Pro Tools 9.0 session can be opened with 
Pro Tools 7.4.x, but certain session components 
open differently or not at all.

When opening a Pro Tools 9.0 session with 
Pro Tools 7.4.x, the following occurs: 

• All that occurs when opening a Pro Tools 9.0 
session with Pro Tools 8.0.

• Inserts F–J and any associated automation are 
removed.

• Clips from audio files larger than 2 GB 
appear offline.

When opening a Pro Tools 9.0 session with 
Pro Tools 8.0, you are warned that you are 
opening a session created with a newer ver-
sion of Pro Tools and that not all session 
components will be available.

When opening a Pro Tools 9.0 session with 
Pro Tools 7.4.x, you are warned that you 
are opening a session created with a newer 
version of Pro Tools and that not all session 
components will be available.



• Pitch transpositions of Elastic clips are 
removed.

• Chord markers are removed.

Opening Pro Tools 7.4 or Higher 
Sessions with Pro Tools 7.3.x or 
7.2
A Pro Tools 7.4–9.x session can be opened with 
Pro Tools 7.3.x or 7.2, but certain session com-
ponents open differently or not at all.

When opening a Pro Tools 7.4.x or higher 
session with Pro Tools 7.3.x or 7.2, the 
following occurs: 

• All that occurs when opening a Pro Tools 8.x 
or higher session with Pro Tools 7.4.x.

• Elastic Audio-enabled tracks open without 
Elastic Audio and clip durations revert to the 
timing of the original source file.

• Sessions with mixed language characters sup-
ported in Unicode may not open or, if they do 
open, Pro Tools displays “garbage” text.

Opening Pro Tools 7.2 or Higher 
Sessions with Pro Tools 7.1 or 
7.0
A Pro Tools 7.2–9.x session without video tracks 
or VCA Masters can be opened with Pro Tools 
7.1 or 7.0, but certain session components open 
differently or not at all.

When opening a Pro Tools 7.4–9.x session 
with Pro Tools 7.3.x, you are warned that 
you are opening a session created with a 
newer version of Pro Tools and that not all 
session components will be available.

When opening a Pro Tools 7.4–9.x session 
with Pro Tools 7.2, 7.1, or 7.0, you are not 
be warned that not all session components 
will be available.
When opening a Pro Tools 7.4–9.x session with 
a version of Pro Tools 7.1 or 7.0 the following 
occurs: 

• All that occurs when opening a Pro Tools 7.4 
or higher session with Pro Tools 7.3.x or 7.2.

Tracks

• VCA Master tracks are removed and any unco-
alesced VCA automation is dropped.

• Any uncoalesced Trim automation is dropped.

Groups

• All groups beyond the first 26 (Bank 1, Groups 
a–z) are dropped.

• Mix Groups keep only Main Volume informa-
tion.

• Mix/Edit Groups keep only Main Volume and 
Automation Mode information.

• Automation overflow information for grouped 
controls is not preserved.

• Group behavior of Solos, LFEs, Mutes, Send 
Levels, Send Mutes is not preserved.

• Solo Mode and Solo Latch settings are 
dropped.

Video

• Only the main video track is displayed.

• Only the first QuickTime movie in the session 
is displayed or played back.

• If the session contains QuickTime movies in 
the Clip List but no video track, the session 
opens with a new QuickTime Movie track con-
taining the first QuickTime movie from the 
Clip List.

Sessions created with Pro Tools HD 7.2–9.x 
that contain video tracks or VCA Masters 
can only be opened with Pro Tools HD 
7.1cs3 and higher.
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• The Timeline displays and plays back only the 
video playlist that was last active. Alternate 
video playlists are not available.

• Video clips and video clip groups are not 
shown or saved.

Opening Sessions Created with 
Pro Tools HD 7.2–9.x with 
Pro Tools LE 8.0
A session created with Pro Tools HD 7.2–9.x 
session that does not contain video tracks or 
VCA Masters can be opened with Pro Tools LE 
8.0, but certain session components open differ-
ently or not at all.

When opening a session created with Pro Tools 
HD 7.x–9.x in Pro Tools LE 8.0, the following 
occurs:

Tracks

• Any tracks beyond the first 48, as well any in-
active tracks, are set to voice off.

• Any assignments to busses beyond 32 are 
made inactive.

• Any Instrument tracks beyond 32 are made in-
active.

• TDM plug-ins with RTAS equivalents are con-
verted; those without equivalents are made in-
active.

• Multichannel surround tracks are removed 
from the session.

• Unavailable input and output paths are made 
inactive.

• Any Delay Compensation settings are re-
moved.

Session created with Pro Tools HD 7.2 or 
higher that contain video tracks or VCA 
Master tracks can only be opened with 
Pro Tools LE 7.0cs3 and higher.
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• VCA Master tracks are removed and any unco-
alesced VCA automation is dropped.

• HEAT (if present) is removed (Pro Tools HD 
8.1 or higher sessions with HEAT option only).

• Output Bus assignments are removed 
(Pro Tools HD 8.1 or higher sessions only).

Groups

• In Pro Tools LE 7.1 or lower only, all groups 
beyond the first 26 (Bank 1, Groups a–z) are 
dropped.

• Mix Groups keep only Main Volume informa-
tion.

• Mix/Edit Groups keep only Main Volume and 
Automation Mode information.

• Automation overflow information for grouped 
controls is be preserved.

• Group behavior of Solos, Mutes, Send Levels, 
Send Mutes is be preserved.

• Solo Mode and Solo Latch settings are 
dropped.

Video

• Only the main video track is displayed.

• Only the first QuickTime movie in the session 
is displayed or played back.

• If the session contains QuickTime movies in 
the Clip List but no video track, the session 
opens with a new QuickTime Movie track con-
taining the first QuickTime movie from the 
Clip List.

• The Timeline displays and plays back only the 
video playlist that was last active. Alternate 
video playlists are not available.

• In Pro Tools LE 7.1 or lower only, video clips 
and video clip groups are not shown or saved.



Saving Pro Tools 10.0 Sessions 
to Pro Tools 5.1 -> 6.9 Format
Pro Tools 7.x and higher sessions cannot be 
opened with Pro Tools versions 6.9.x through 
5.1. 

To save a Pro Tools 10.0 session so it is compat-
ible with Pro Tools version 6.9.x through 5.1, 
use the File > Save Copy In command to choose 
the Pro Tools 5.1 -> 6.9 Session format.

When saving a Pro Tools 10.0 session to 
Pro Tools 5.1 -> 6.9 format, the following 
occurs:

• All that occurs when saving a Pro Tools 10.0 
session to Pro Tools 7–>9 session format.

Tracks

• Any audio tracks beyond 256 are removed.

• Any internal mix busses beyond 128 are re-
moved.

• Output bus assignments are removed.

• HEAT (if present) is removed.

• Elastic Audio-enabled tracks are saved un-
transposed, unwarped, and clip durations re-
vert to the timing of the original source file.

• Instrument tracks are split into separate Aux-
iliary Input and MIDI tracks.

• VCA Master tracks are removed and VCA au-
tomation is coalesced to the corresponding 
slave tracks.

Pro Tools 8.x and higher supports file sizes 
up to 3.4 GB, and Pro Tools 10 sessions sup-
port file sizes over 4 GB. However Pro Tools 
5.1 through 6.9 on Mac only support file 
sizes up to 2 GB. 
If your session references audio files larger 
than 2 GB, be sure to edit and consolidate 
clips as necessary to reference only files 
smaller than 2 GB.
• Trim automation playlists are coalesced to 
their corresponding automation playlists.

• Fader Gain levels and automation breakpoints 
higher than +6 dB are changed to +6 dB.

• Long names are shortened to 31 characters.

• The following attributes are dropped:

• Clip groups

• Clip loops

• Sample-based MIDI clips

• Sample-based MIDI tracks

• Inserts F–J and any associated automation

• Sends F–J and any associated automation

• Marker/Memory Locations 201–999

Groups

• All groups beyond the first 26 (Bank 1, Groups 
a–z) are dropped.

• Mix Groups keep only Main Volume informa-
tion.

• Mix/Edit Groups keep only Main Volume and 
Automation Mode information.

• Automation overflow information for grouped 
controls is not preserved.

• Group behavior of Solos, LFEs, Mutes, Send 
Levels, Send Mutes is not preserved.

• Solo Mode and Solo Latch settings are 
dropped.

Video

• Only the main video track is displayed.

• Only the first QuickTime movie in the session 
is displayed or played back.

• If the session contains QuickTime movies in 
the Clip List but no video track, the session 
opens with a new QuickTime Movie track con-
taining the first QuickTime movie from the 
Clip List.
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• The Timeline displays and plays back only the 
video playlist that was last active. Alternate 
video playlists are not available.

• Video clips and video clip groups are not 
shown or saved.

Language Compatibility

• The Limit Character Set option must be en-
abled and you must select a single language 
and character set.

Saving Pro Tools 10.0 Sessions 
to Pro Tools 5.0 Format
Pro Tools 5.1 and higher sessions cannot be 
opened with Pro Tools version 5.0.

To save a Pro Tools 10.0 session so it is compat-
ible with Pro Tools version 5.0, use the File > 

Save Copy In command to choose the 
Pro Tools 5.0 Session format.

When saving a Pro Tools 10.0 session to 
Pro Tools 5.0 format, the following occurs:

• All that occurs when saving a Pro Tools 10.0 
session to Pro Tools 5.0 format.

• Multichannel surround tracks are removed 
from the session.

• Inactive tracks are removed from the session.

• Tracks assigned to “No Output” are routed to 
busses 31 and 32.

• Tracks or sends assigned to busses 33–64 are 
routed to busses 31 and 32.

• Tracks assigned to multichannel paths or 
subpaths of multichannel paths are routed to 
busses 31 and 32.

• Sends assigned to multichannel paths or 
subpaths of multichannel paths are dropped.

• Tracks or sends assigned to stereo paths refer-
ring to even/odd channels (such as 2–3) are 
routed to busses 31 and 32.
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• Multi-mono plug-in instances are dropped.

Language Compatibility

Unicode Support for Languages
Pro Tools supports entry and display of any lan-
guage characters supported in Unicode any-
where in the Pro Tools application. This lets 
you:

• Use multiple languages in session names, 
and in path names, file names and clip 
names within the same session.

• Search for terms in multiple languages in 
DigiBase browsers. 

Pro Tools Automatic Naming 
Language
When working in a language other than English, 
you can set Pro Tools to automatically name ses-
sion elements (such as clips, tracks, and I/O 
paths) in English. This is useful when sharing 
sessions with other users working in English. 

To set the Automatic Naming Language to match 
the language selected for the Pro Tools 
application:

1  Choose Setup > Preferences and click the Dis-

play tab.

2  Choose the language you want to use in 
Pro Tools from the Language pop-up menu.

3  Deselect the Default Automatic Naming to Eng-

lish option.



Pro Tools Application Language
(Windows Only)

You can choose the language you want to use in 
the Pro Tools application, independently of 
what language version of Windows you are us-
ing.

To select the language for Pro Tools:

1  Choose Setup > Preferences and select the Dis-

play tab.

2  Choose the language you want to use in 
Pro Tools from the Language pop-up menu.

Multilingual Application Support 
for Pro Tools Systems
(Localized OS on Mac Only)

Localized versions of Pro Tools (such as 
Pro Tools Korean, simplified Chinese, or Japa-
nese) can be opened on a qualified Mac that sup-
ports English and the localized language ver-
sions of Mac. You can also select a different 
language in any localized version of Pro Tools 
(including English) in the Apple System Prefer-
ences.

To change to a different language version of 
Pro Tools:

1  Close Pro Tools if it is currently open.

2  Launch Apple System Preferences.

3  Click International (the “flag” icon).

4  Click the Language tab.

5  In the Languages column, drag the language 
you want to the top of the list.

6  Close the International window.
7  Do one of the following:

• If you are changing from a localized lan-
guage to English, launch Pro Tools.

– or –

• If you are changing from one localized lan-
guage to another (or from English to a lo-
calized language), log out and log in from 
the Apple menu, then launch Pro Tools.

If you want your computer to start with the 
previous language (after working on a dif-
ferent language version) follow the above 
steps and change the International prefer-
ence back to the previous language.
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Chapter 19: Mac HFS+ Disk Support Option 
(Windows Only)
The Mac HFS+ Disk Support option lets you in-
terchange sessions between Mac-based and 
Windows-based Pro Tools systems using local 
HFS+ (Mac OS Extended) formatted hard 
drives. 

With the Mac HFS+ Disk Support option in-
stalled on a Windows computer, you can mount 
an HFS+ drive on a Windows-based Pro Tools 
system, and record and play back Pro Tools ses-
sions directly on that drive as if it were natively-
formatted for Windows. 

When using the Mac HFS+ Disk Support op-
tion for recording and playback on a Win-
dows-based system, the session file and all 
associated files (such as audio and MIDI 
files) must be stored on Mac-formatted 
drives. Recording and playback of a session 
from a mixture of Windows- and Mac-for-
matted drives is not supported.

If you use the Format Mac Disk command 
that is installed as part of the Mac HFS+ 
Disk Support option to initialize or parti-
tion a Mac-formatted drive, it will not be 
officially supported as a Playback/Record 
drive. Though Pro Tools may be able to play 
back and record to such a drive, only HFS+ 
disks formatted on a Mac using Apple Disk 
Utility are supported for playback and re-
cording.
Installing the Mac HFS+ Disk 
Support Option
The Mac HFS+ Disk Support option is available 
as part of the Pro Tools installation procedure. 
If you did not install it with Pro Tools, you can 
run the Pro Tools installer again. 

To install the Mac HFS+ Disk Support option:

1  Make sure you are logged in as an Administra-
tor for the account where you want to install 
Pro Tools.

2  Do one of the following:

• Insert the Pro Tools Installer disc in your 
DVD drive. 

– or –

• Download the Pro Tools installer online.

While the Mac HFS+ Disk Support option 
will allow your system to read/write HFS 
(Mac Standard format) disks, HFS drives 
are not supported for either record/play-
back or transfer.
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3  Do one of the following:

• If Windows AutoRun is enabled, a mini-
browser appears. Select Install Pro Tools to 
begin installation. 

– or –

• If Windows AutoRun is disabled, locate and 
double-click Setup.exe. Then, in the resul-
tant mini-browser, select Install Pro Tools to 
begin installation.

4  In the Installer Wizard, select Modify, and click 
Next.

5  Select the Mac HFS+ Disk Support option for 
installation, and click Next.

6  Follow the on-screen instructions to proceed 
with the installation.

7  When Installation is complete, click Finish. 

Removing the Mac HFS+ Disk 
Support Option
If you need to remove the Mac HFS+ Disk Sup-
port option from your computer, use the unin-
stall command in Windows.

To remove the Mac HFS+ Disk Support Option 
from your computer:

1  Choose Start > Control Panel > Programs and 

Features.

2  Select HFS+ Disk Support.

3  Click Uninstall.

4  Follow the on-screen instructions to remove 
the option.

The HFS+ Disk Support option only works 
on a computer that has a valid installation 
of the Pro Tools application. If you remove 
the Pro Tools application from your system, 
the HFS+ Disk Support option will also be 
removed.
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Media Compatibility
The Mac HFS+ Disk Support option enables 
Windows and other software running under 
Windows to access nearly any type of Mac disk. 
Windows, however, must be able to communi-
cate with the drive to allow Mac HFS+ Disk Sup-
port to function. 

If you are currently able to use your removable 
media drive with normal PC-formatted disks, 
you can be confident that Windows is success-
fully communicating with the drive, and that 
Mac HFS+ Disk Support will be able to recognize 
Mac disks when they are inserted.

If the disk device is new to your Windows sys-
tem (as would be the case, for example, when 
plugging an external drive from a Mac OS sys-
tem into your Windows PC FireWire adapter for 
the first time), it is likely that it will be recog-
nized by Windows and work properly without 
requiring the installation of driver software 
from the drive or adapter manufacturer, but this 
is not guaranteed. 

When attaching a removable media drive, if 
Windows presents no drive letter for the remov-
able drive, the hardware may not be properly in-
stalled, or driver software may be necessary. 
When attaching a Mac external hard drive, Win-
dows will not present a drive letter unless both 
the drive and the Mac HFS+ Disk Support option 
are properly installed. 

If you are using SCSI or Fibre Channel drives, 
you can watch for notification from the SCSI or 
Fibre Channel adapter during the boot process 
detailing detected drives. If a newly-attached 
SCSI drive is not detected, check for ID conflicts 
and proper termination. Regardless of the drive 



type, if it is not detected, look for faulty cables, 
check both drive and adapter configuration, and 
try PC-formatted disks in order to confirm 
whether the drive is working. 

The Mac HFS+ Disk Support option works with 
the following:

 Zip, CD-ROM, CD-R/RW, DVD±RW/±R, Jaz, 
iPod, hard drives, SyQuest, MO, ORB and nearly 
any other disk device that works with Windows 
can be accessed.

 High-density (1.44MB) Mac floppies can be 
accessed on any Windows system with a floppy 
drive. 

Session Compatibility
The Mac HFS+ Disk Support option enables 
Windows to recognize Pro Tools sessions cre-
ated on Mac-based Pro Tools 7.x–9.x (.ptf) and 
Pro Tools 5.x–6.x (.pts) systems.

Mac-based Pro Tools 5.x–6.x sessions that refer-
ence audio files in Sound Designer II (SD II) for-
mat are not supported on Windows.

Low-density (400KB and 800KB) Mac 
floppies cannot be accessed due to physical 
differences between the floppy drives in 
Mac OS systems and Windows PCs. 

While it is possible to use the Mac HFS+ 
Support option with drives mounted as part 
of a Storage Area Network (SAN), this con-
figuration not been qualified.

Mac RAID disk volumes are not supported 
by the Mac HFS+ Disk Support option.
If your Mac-based Pro Tools session includes 
any audio files in SD II format, you will need to 
return to the Mac-based Pro Tools system and 
re-save the session so that its audio files are 
Windows-compatible, then open it on your Win-
dows system.

To save a Mac-based Pro Tools 5.x–6.x session 
with SD II files to be Windows compatible: 

1  Open the session on the Mac-based Pro Tools 
system.

2  Choose File > Save Session Copy In.

3  In the Save Session Copy dialog, select Enforce 

Mac/PC Compatibility.

4  Choose the audio file type (.WAV), sample 
rate, and bit depth for the session.

5  Choose a destination and enter a name for the 
new session. 

6  Click Save.

Viewing Mac Drive and File 
Properties
When you view properties for a Mac-formatted 
drive or a file or folder on a Mac-formatted 
drive, you can view the Mac-specific properties 
of that drive, file or folder from its shortcut 
menu. 

You can also display the Mac properties of files 
in the Windows Explorer Details view.

To view the properties of a Mac drive, file or folder:

1  Right-click the element whose properties you 
want to view, and choose Properties from the 
shortcut menu.

2  In the Properties window, click the HFS+ Disk 

Support tab. 

3  Click OK to close the Properties window.
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The following information is displayed for the 
element, where applicable: 

Mac name Displays the file’s true Mac name as it 
exists on disk. This may be different from the 
name reported by Windows due to the fact that 
certain Mac filenames automatically have Win-
dows file extensions added to them, and the ne-
cessity of changing some Mac file names slightly 
to conform to Windows file-naming rules. 

Data size Displays the size of the file's data fork, 
where cross-platform data is usually stored. 

Resource size Displays the size of the file's re-
source fork, where additional data, usually Mac-
specific, is stored. 

Backed up Displays the date that the file was last 
backed up, if ever. 

File type and File creator For files, displays the 
four-character codes stored by Mac OS that in-
dicate the type of data contained in the file and 
the software that created the file.

Files on volume and Folders on volume For 
drives, displays the numbers of files and folders 
on the drive. 

Advanced Opens a window with additional ad-
vanced attributes of the disk, folder or file. Only 
the Name Locked attribute can be changed in 
this window. The other attributes are shown 
only for your reference. 
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Viewing Multisession and 
Dual-Format Discs
When you mount a Mac-formatted multisession 
CD or a dual-format CD, you can select view op-
tions for each from the disc shortcut menu. 

Dual-Format Mac CD-ROMs

Some CD-ROMs have both Windows (ISO-9660) 
and Mac (HFS or HFS+) volumes on them. You 
can choose which volume to access from the disc 
shortcut menu. The effect is much like ejecting 
one disc and inserting another. Mac HFS+ Disk 
Support remembers which volume, Windows or 
Mac, you last used on a particular disc, and will 
return you to that setting if that disc is used 
again. 

To switch display of a CD between Windows and 
Mac volumes:

 Right-click the disc whose display you want to 
change, and choose Show Mac Files or Show Win-

dows Files from the shortcut menu. 

Multisession Mac CD-Rs

A list of available volumes appears in the disc 
shortcut menus of multisession CD-Rs. Select-
ing a new volume causes the current volume to 
disappear, and the new volume to appear in its 
place. The effect is much like ejecting one disc 

On some computers, after choosing a new 
volume on a multisession CD-R or a new file 
set on a dual-format CD-ROM, the name of 
the disk as it appears under Windows Ex-
plorer may not be properly updated. Refer 
to the disc shortcut menu or its contents, 
rather than the name of the disc, to assure 
that the volume is available.



and inserting another. Mac HFS+ Disk Support 
remembers which session you last used on a par-
ticular disc, and will return you to that session if 
that disc is used again. 

To choose which volume of a multisession CD to 
display:

1  Right-click the multisession disc whose dis-
play you want to change, and choose 
Mac Volumes from the shortcut menu. 

2  Choose the name of the volume you want to 
display from the submenu.

Setting the File Naming Mode
When you view files on a Mac-formatted drive, 
you can change the way the filenames are dis-
played for that drive from the shortcut menu.

To set the file naming mode for a Mac drive:

1  Right-click the drive whose file naming mode 
you want to change, and choose Mac File Names 
from the shortcut menu.

2  Choose one of the following from the sub-
menu:

Normal This mode maximizes compatibility 
with a wide range of software, and preserves in-
ternational characters where possible.

Mac HFS+ Disk Support does not change the 
names of files on the Mac-formatted drive, it 
only affects the way they are displayed in 
Windows. Similarly, setting the File Naming 
Mode does not affect filenames on disk, it 
only changes the way they are displayed in 
Windows. 
International This mode is appropriate for a disk 
containing files named using international Uni-
code characters, in cases where preservation of 
those characters is important, but compatibility 
with a wide range of software is less important. 
This is the default setting. 

Backup/File Transfer This mode is appropriate 
for tape backups of Mac disks, or transfers of 
files from one Mac disk to another, including 
between a true Mac disk and an NTFS volume 
storing a Services for Mac network share. This 
mode preserves Unicode characters, but, unlike 
the other two modes above, does not append ar-
tificial file name extensions for software-com-
patibility purposes.

Partitioning Mac Drives
The HFS+ Disk Manager gives you the ability to 
create and delete partitions on Mac-formatted 
hard drives.

When using HFS+ Disk Manager, make sure to 
note the following:

• While you can leave part of a disk unused 
(called Unallocated space by HFS+ Disk Man-
ager), you will not be able to make a PC parti-
tion or volume (FAT, FAT32, NTFS, or 
otherwise) in the unallocated space. The only 
thing you can do with unallocated space is to 
make additional Mac partitions in it in the fu-
ture, or simply leave it unused.

If you use this command to partition a Mac-
formatted drive, it will not be officially sup-
ported as a Playback/Record volume. 
Though Pro Tools may be able to play back 
and record to such a drive, only HFS+ disks 
formatted on a Mac using Apple Disk Utility 
are supported for playback and recording
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• You cannot use HFS+ Disk Manager to add a 
Mac partition to a PC-partitioned disk. Using 
Mac HFS+ Disk Manager on a PC-partitioned 
disk will destroy all PC partitions.

• You cannot use Mac HFS+ Disk Manager to re-
size a partition and retain its contents. The 
only way to resize a partition is to delete and 
recreate it at a different size, which will result 
in the loss of any files in the original partition.

• Mac HFS+ Disk Manager works only with 
fixed hard drives; it cannot be used to parti-
tion removable disks.

To partition a Mac drive:

1  Make sure Pro Tools is not running.

2  Click the Start menu and choose Programs > 

Digidesign > HFS+ Disk Support > Create or 

Change Mac Hard Disks.

In the Modify Mac Volumes window, Mac-for-
matted drives appear with a small red apple icon 
next to them.

3  Click a Mac-formatted drive to display its par-
titions.

4  To add a partition where unallocated space is 
available, select the Free Space listed under the 
drive and do the following;

• Click New Volume.

• Enter a name for the new partition.

• Set the size of the partition by entering it in 
the Size box or by adjusting the slider.

5  To change or remove a partition, select the 
partition and do any of the following:

• Click Format Volume to rename or change 
the format of the partition.

• Click Delete Volume to remove the parti-
tion.

6  When you have finished configuring the parti-
tions, click Finish. 
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Initializing Mac Drives
The HFS+ Disk Manager gives you the ability to 
initialize the drive in HFS+ format.

This process will erase any data on the drive.

To initialize a Mac-formatted drive:

1  Click the Start menu and choose Programs > 

Digidesign > HFS+ Disk Support > Create or 

Change Mac Hard Disks.

In the Modify Mac Volumes window, Mac-for-
matted drives appear with a small red apple icon 
next to them.

2  Select the Mac-formatted drive you want to 
initialize.

3  Click Initialize Disk. 

4  When formatting is complete, click Finish. 

All formatting and maintenance of HFS+ 
drives for Pro Tools should be carried out 
when the drives are connected to a Mac, us-
ing Apple Disk Utility. If you use this com-
mand to initialize a Mac-formatted drive, 
the drive will be qualified only as a Transfer 
drive in Pro Tools. 



Mac HFS+ Disk Support 
Warnings

Volume Check
Whenever a disk is mounted, Mac HFS+ Disk 
Support checks the disk to see if it was properly 
unmounted the last time it was used.

If there are signs that it wasn't unmounted cor-
rectly, Mac HFS+ Disk Support displays a warn-
ing so that you will know there is a risk that the 
disk was improperly unmounted. 

If Mac HFS+ Disk Support displays a Volume 
Check warning, do one of the following:

 To mount the drive, click Mount Anyway. 

 To cancel mounting the drive, click Cancel.

Mac HFS+ Disk Support will only mount such a 
drive in Read-Only state, so it cannot be used to 
record in Pro Tools. 

Note that this warning does not mean that the 
disk has been judged to be corrupt; it merely 
means that there is a significant risk, and that 
the disk should be remounted and then correctly 
unmounted on a Mac system before reconnect-
ing it to a Windows system.

If the problem persists, the disk should either be 
repaired or reformatted (using Mac OS X Disk 
Utility) in order to avoid future problems.
Disk Protection
Whenever an attempt is made to change the par-
titioning on Mac disk by any Windows software 
other than HFS+ Disk Manager, Mac HFS+ Disk 
Support steps in to mediate the situation.

This is done because if Windows software other 
than HFS+ Disk Manager makes changes to the 
partitioning on a Mac disk, the disk will no lon-
ger be Mac-partitioned or Mac-formatted, and 
all contents of the Mac disk will be lost.

Sometimes this is a desirable outcome, if a Mac 
disk is no longer needed, and you want to repar-
tition and reformat it for use exclusively with 
Windows. In this case, you should select Erase 
the Mac Disk.

At other times, however, Mac HFS+ Disk Sup-
port steps in and protects a Mac disk from acci-
dental damage. In that case, you should select 
Don’t Change the Mac Disk.

If you decide that you really do want to change 
partitions on the Mac disk, but want it to remain 
a Mac disk when you are done, you should select 
Modify the Mac Disk.
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Part IV: Playback and
Recording





Chapter 20: Playing Back Track Material
After importing or recording audio or MIDI to 
tracks, you will want to play back the material 
when editing and mixing.

Starting and Stopping Playback

To start playback, do one of the following:

• Click Play in the Transport. 

• Press the Spacebar.

• With the Numeric Keypad mode set to 
Transport or Shuttle, press 0 on the nu-
meric keypad.

• If the Numeric Keypad mode is set to Trans-
port, and the Use Separate Play and Stop 
Keys option is enabled, press Enter on the 
numeric keypad.

• If you have a worksurface or MIDI control 
surface connected and configured, press 
the Play switch.

• If Pro Tools is online and slaved to another 
deck, press play on the master deck (see 
“Putting Pro Tools Online” on page 1153).

For more information about the Numeric 
Keypad modes, see “Numeric Keypad 
Modes” on page 31.
To stop playback, do one of the following:

• Click Stop in the Transport. 

• Press the Spacebar.

• With the Numeric Keypad mode set to 
Transport or Shuttle, press 0 on the nu-
meric keypad.

• If you have a worksurface or MIDI control 
surface connected and configured, press 
the Stop switch.

• If Pro Tools is online and slaved to another 
deck, press stop on the master deck (see 
“Putting Pro Tools Online” on page 1153).

Example: Playing Back Audio

To play back audio:

1  Import or record audio to a track.

2  Assign the track’s Output selector to your main 
monitoring path.

3  To have playback start from the beginning of 
the session, click Return to Zero in the Trans-
port.

4  Start playback.

5  The audio plays through the selected Output 
Path. Adjust the track’s volume and pan faders as 
necessary.

6  When you are finished, stop playback.
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Example: Playing Back MIDI

To play back MIDI (and monitor the audio): 

1  Import, record, or enter MIDI into an Instru-
ment or MIDI track.

2  For an Instrument track, do the following:

• Set the Instrument track’s audio Output se-
lector to the main monitoring path.

• If you are using an Instrument Plug-In, in-
sert the plug-in on the track. The track’s 
MIDI Output selector (in Instrument view) 
should be automatically set to the plug-in.

• If you are using an external MIDI device 
(not an Instrument plug-in), set the MIDI 
Output selector in Instrument view to the 
MIDI device (port) and channel you want to 
play back.

• If you are using an external MIDI device 
(not an Instrument plug-in), set the Instru-
ment track’s audio Input selector to the In-
put path to which your MIDI device’s audio 
outputs are connected.

3  For a MIDI track, do the following:

• If you are using an Instrument plug-in, cre-
ate an Auxiliary Input or Instrument track 
insert the Instrument plug-in on the track.

• If you are using an external MIDI device 
(not an Instrument plug-in), create an Aux-
iliary Input or Instrument track to monitor 
the audio from an external MIDI device or 
Instrument plug-in.

• If you are using an external MIDI device 
(not an Instrument plug-in), set the Auxil-
iary Input or Instrument track’s audio Input 
selector to the Input path to which your 
MIDI device’s audio outputs are connected.
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• Set the Auxiliary Input or Instrument 
track’s audio Output selector to the main 
monitoring path.

• Set the MIDI track’s output selector to the 
Instrument plug-in, or MIDI device (port), 
and channel you want to play back.

4  To have playback start from the beginning of 
the session, click Return to Zero in the Trans-
port.

5  Start playback.

6  The MIDI plays the selected MIDI device, and 
the audio from the MIDI device is monitored 
through the selected Output Path on the Auxil-
iary Input or Instrument track. Adjust the MIDI, 
Auxiliary Input, or Instrument track’s volume 
and pan faders as necessary.

7  When you are finished, stop playback.

Playback Location
The playback location is the point in the 
Pro Tools Timeline where you can begin playing 
back audio or MIDI in your session.

The playback location is displayed in counters 
and indicators in the Edit window, Transport 
window, and Big Counter. The playback location 
(or Edit selection) is also indicated by a play-
back or edit cursor in the Timeline or playlist of 
the Edit window.

For information about synchronizing exter-
nal MIDI devices with Pro Tools for play-
back and recording using MIDI Beat Clock, 
see “MIDI Beat Clock” on page 433, and for 
information about using MIDI Timecode, 
see “Generating Timecode” on page 1154.



Pro Tools also provides a pre-roll control for 
setting playback to begin before the playback lo-
cation. See “Basic Transport Controls and Coun-
ters” on page 187.

Counters and Indicators that 
Display the Playback Location

Main and Sub Counters and Edit Selection 
Indicators

At the top of the Edit window, the playback lo-
cation is displayed in the Main and Sub coun-
ters, and the Edit Selection Start indicator. If no 
selection is made, the playback location is also 
displayed in the Edit Selection End indicator.

Counters and Edit Selection indicators can also 
be displayed in the Transport window.

To display the Main Counter in the Transport 
window:

 Select View > Transport > Counters. 

Main and Sub Counters, Edit Selection indicators

Transport with Counters displayed

 Control-click (Mac) or Start-click (Win-
dows) the Expand/Collapse button in the 
Transport window to show or hide counters.

Option-click (Mac) or Alt-click (Windows) 
the Expand/Collapse button in the Trans-
port window to show or hide counters and 
MIDI controls.
To display the Sub Counter in the Transport 
window:

1  Select View > Transport > Counters.

2  Select View > Transport > Expanded.

To display Edit Selection indicators in the 
Transport window:

 Select View > Transport > Expanded.

The Big Counter

The current playback location can also be dis-
played in the Big Counter.

To display the Big Counter:

 Choose Window > Big Counter.

Cursors that Indicate the 
Playback (or Edit) Location
There are two types of cursors in the Pro Tools 
Edit window for indicating the current playback 
or Edit selection:

Playback Cursor

The playback cursor is a solid line that moves 
across the Edit window to indicate the current 
playback location.

The selected Scrolling Option determines how 
the Edit window scrolls during playback, and 
how the playback cursor functions. See “Scroll-
ing Options” on page 424 for details.

Big Counter window
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Edit Cursor

The edit cursor is a flashing line that appears 
when you click with the Selector tool in a track’s 
playlist. The flashing edit cursor indicates the 
start point for any editing tasks performed. If 
you make a selection and perform an edit, the 
selection is the target of the edit.

Locating the Playback Cursor when It Is 
Off-Screen

Use the Playback Cursor locator to locate the 
playback cursor when it is off-screen.

The Playback Cursor locator appears on the 
right edge of the Main Timebase ruler if the 
playback cursor is located beyond the time visi-
ble in the Edit window. If the playback cursor is 
located before the time visible in the Edit win-
dow, the Playback Cursor locator appears on the 
left edge of the Main Timebase ruler.

For example, if the Scrolling option is set to 
None, the playback cursor moves off-screen af-
ter it has played past the time currently visible 
in the Edit window. The Playback Cursor locator 
appears on the right edge of the Main Timebase 
ruler after the playback cursor has moved be-
yond the time visible in the Edit window.

The Playback Cursor locator is red when a track 
is record-enabled and blue when no track is re-
cord-enabled.

Playback Cursor locator, recording enabled (playback 
cursor located after currently viewed audio)
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To locate the playback cursor when it is off-
screen:

 Click the Playback Cursor locator in the Main 
Timebase ruler.

The Edit window changes to center the playback 
cursor on-screen.

Setting the Playback 
Location
Pro Tools provides commands for different 
ways of setting or moving the playback location 
in a session. These include finding a passage in a 
song, moving to a different section of your ar-
rangement, or comparing different sections.

Setting Playback Location Using 
the Selector Tool
To set where playback begins, you can click any-
where in a track with the Selector tool (as long as 
the Timeline and Edit selections are linked). See 
“Linking or Unlinking Timeline and Edit Selec-
tions” on page 569).

Setting a playback point with the Selector tool



To begin playing from a specific point within a 
track:

1  Make sure that Options > Link Timeline and Edit 

Selection is enabled.

2  With the Selector tool, click in the track where 
you want playback to begin.

3  Start playback.

4  Stop playback.

To jump to a different location and begin playing 
from there, do one of the following:

 When playback is stopped, click with the Se-
lector tool at the point you want to start play-
back and click Play in the Transport window.

– or –

 During playback, click the new location in any 
Timebase Ruler.

With the Timeline and Edit selections linked, 
you can click a clip or MIDI note with the Time 
Grabber tool to automatically update the Time-
line with the selection’s start time, letting you 
play from that point.

Setting Playback Location with 
Basic Transport Controls
Transport controls in the Transport window and 
top of the Edit window can be used to move the 
playback location. These include Rewind, Fast 
Forward, and Return to Zero (to move playback 
location to the beginning of the session). For 
more information, see “Basic Transport Con-
trols and Counters” on page 187.
Setting Playback Location with 
the Main Counter or Edit 
Selection Start Indicator

To set the playback location using a Main Counter 
(or the Edit Selection Start indicator):

1  Do one of the following:

• Click in one of the counters.

– or –

• Press asterisk (*) on the numeric keypad to 
highlight the Main Counter in the Edit win-
dow (or the Main Counter in the Transport 
window or Big Counter window, if either 
are displayed).

2  Type in the new location. Press Period (.) to 
cycle through to the different time fields.

3  Press Enter to accept the new value and auto-
matically locate there.

Setting Playback Location with 
Fast Forward/Rewind
You can use the Fast Forward and Rewind but-
tons in the Transport window to move the play-
back location. If the Operation preference for 
Audio During Fast Forward/Rewind is selected, 
the scanned audio is heard (similar to a CD 
player) when clicking the Fast Forward and Re-
wind buttons.

You can also fast forward or rewind incremen-
tally by repeatedly clicking the appropriate but-
ton. The size of these increments is determined 
by the Main Time Scale:

Bars|Beats Moves to the beginning of the previ-
ous or next bar.

Min:Sec Moves back or forward in one-second 
steps.
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Timecode Moves back or forward in one-second 
steps (while adjusting for current SMPTE for-
mat).

Feet+Frames Moves back or forward in one-foot 
steps.

Samples Moves back or forward in one-second 
steps.

Setting Playback Location with 
Back and Forward Commands
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools provides four Back/Forward com-
mands (sometimes called “rollback”) for mov-
ing the playback location in the Edit window. 

You can also move the playback location in mul-
tiple increments by repeating the command (See 
“Repeating Back/Forward Commands” on 
page 423).

Back Moves the playback location backward by 
the Back/Forward Amount.

Back and Play Moves the current playback loca-
tion backward by the Back/Forward Amount and 
automatically begins playback.

Forward Moves the playback location forward by 
the Back/Forward Amount.

Forward and Play Moves the current playback 
location forward by the Back/Forward Amount 
and automatically begins playback.

Setting the Back/Forward Amount

The length of the Back/Forward move is deter-
mined by the Back/Forward Amount preference 
in the Operation page (Setup > Preferences).

Back/Forward commands also work when 
controlling a 9-pin device. See the Machine-
Control Guide for details.
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To configure the Back/Forward Amount:

1  Choose Setup > Preferences and click the Op-

eration tab.

The timebase of the Back/Forward Amount set-
tings follows the Main Time Scale by default, or 
you can deselect Follow Main Time and select 
any of the following timebase formats:

• Bars|Beats

• Min:Sec

• Timecode

• Feet+Frames

• Samples

2  Do one of the following:

• Select a preset amount in the Back/Forward 

Amount pop-up menu.

– or –

• In the Back/Forward Amount field, enter a 
custom amount.

Using Back or Forward Commands

To move the playback location backward by the 
Back/Forward Amount:

 Press Command (Mac) or Control (Windows), 
and click Rewind in the Transport window.

To move the playback location forward by the 
Back/Forward Amount:

 Press Command (Mac) or Control (Windows), 
and click Fast Forward in the Transport window.

To move the playback location backward by the 
Back/Forward Amount and then begin playback:

 Press Command+Option (Mac) or Con-
trol+Alt (Windows), and click Rewind in the 
Transport window.



To move the playback location forward by the 
Back/Forward Amount and then begin playback:

 Press Command+Option (Mac) or Con-
trol+Alt (Windows), and click Fast Forward in 
the Transport window.

Repeating Back/Forward Commands

All the Back/Forward commands can be repeated 
in order to increase the amount of the total Back 
or Forward move.

To repeat Back/Forward moves:

1  Press and hold Command (Mac) or Control 
(Windows).

2  Click Rewind or Fast Forward the number of 
times you want to repeat moving the playback 
location backwards or forwards by the specified 
Back/Forward Amount.

Extending Selections with Back or Back and 
Play Commands

The Back or Back and Play commands can be 
used to extend a selection backwards by the 
length of the specified Back/Forward Amount. 

To extend a selection with Back or Back and Play 
commands:

1  Specify the Back/Forward Amount. (See “Set-
ting the Back/Forward Amount” on page 422.)

2  With the Selector tool, drag within a track to 
make a selection.

Although you cannot extend a selection with 
the Forward or Forward and Play com-
mands, you can use the following proce-
dures with Forward or Forward and Play to 
move the start point of a current selection.
3  Do one of the following:

• To extend the selection backwards by the 
Back/Forward Amount, press Shift+Com-
mand (Mac) or Shift+Control (Windows) 
and click Rewind in the Transport window.

– or –

• To extend the selection backwards by the 
Back/Forward Amount and then begin 
playback, press Shift+Command+Option 
(Mac) or Shift+Control+Alt (Windows) and 
click Rewind in the Transport window.

Additional Ways of Moving the 
Playback Location
You can also move the playback location with 
the following:

Shuttle Lock Modes With either Shuttle Lock 
mode (Classic or Transport) you can use the nu-
meric keypad to shuttle forward or backwards at 
specific speeds. For more information, see 
“Shuttle Lock Modes” on page 32.

Memory Locations Memory Locations can be 
used to move the playback location (or Edit se-
lection). When a Memory Location is recalled, 
the playback location (or Edit selection) up-
dates. Memory Locations can be recalled from 
the Memory Locations window and from the nu-
meric keypad. In addition, Marker Memory Se-
lections can be recalled by clicking them in the 
Markers ruler. For more information, see “Re-
calling Memory Locations” on page 816.

Tabbing to Transients With the Tab to Tran-
sients button enabled, you can automatically 
navigate to transients in audio waveforms, plac-
ing the cursor just before the detected transient 
peak. For more information, see “Tabbing to 
Transients” on page 580.
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Scrolling Options
You can configure how contents of the Edit win-
dow scroll during playback and recording. 

To configure Scrolling options:

 Choose Options > Scrolling and select one of 
the following options:

None The Edit window does not scroll during or 
after playback. The playback cursor moves 
across the Edit window, indicating the playback 
location.

After Playback The playback cursor moves 
across the Edit window, indicating the playback 
location. When playback has stopped, the Edit 
window scrolls to the final playback location.

Page The playback cursor moves across the Edit 
window, indicating the playback location. When 
the right edge of the Edit window is reached, its 
entire contents are scrolled, and the playback 
cursor continues moving from the left edge of 
the window. For more information, see “Page 
Scrolling During Playback” on page 424.

Continuous (Pro Tools HD and Pro Tools with 
Complete Production Toolkit Only) See “Contin-
uous Scrolling During Playback” on page 424.

Center Playhead (Pro Tools HD Only) See “Cen-
ter Playhead Scrolling” on page 425.

Making a selection in the Timeline or a 
playlist, or manually scrolling the Timeline 
while in Page Scroll or Continuous Scroll 
mode suspends page scrolling. To resume 
page scrolling and jump to the current play-
back location, click the Playback Cursor 
locator in the Main Timebase ruler (see 
“Locating the Playback Cursor when It Is 
Off-Screen” on page 420).
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Page Scrolling During Playback
You can set Pro Tools to scroll the track display 
while playing, and also have the edit cursor ap-
pear wherever playback stops.

To make the track display and the edit cursor 
follow playback:

 Enable the Timeline Insertion/Play Start 
Marker Follows Playback button in the Edit win-
dow.

Continuous Scrolling During 
Playback
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

When this scrolling option is selected, the Edit 
window’s contents scroll continuously past the 
playback cursor, which remains in the center of 
the window. With this option, playback is al-
ways based on the Timeline selection (unlike the 
Center Playhead Scrolling option). Continuous 

Timeline Insertion/Play Start Marker Follows Playback 
button enabled

You can enable or disable the Timeline In-
sertion/Play Start Marker Follows Playback 
option in the Operation Preferences.

Press Control+N (Mac) or Start+N (Win-
dows) to toggle the Timeline Insertion/Play 
Start Marker Follows Playback preference 
on and off.



Scrolling During Playback uses host processing 
power, so use this option with host-based 
Pro Tools systems only when absolutely neces-
sary.

Center Playhead Scrolling
(Pro Tools HD Only)

When this scrolling option is selected, the Edit 
window’s contents scroll continuously past the 
Playhead, which is a blue line in the center of the 
window (or a red line when recording).

The Playhead indicates where playback begins 
when clicking Play in the Transport window.

To move the Playhead to a particular location 
for playback, you can scroll there in a ruler (see 
“Scrolling in a Timebase Ruler” on page 583), 
use the Edit window’s horizontal scroll bar, or 
type the location into one of the Edit Selection 
indicators or one of the Counters.

Moving the Playhead with these methods does 
not update the Timeline selection. However, up-
dating the Timeline selection automatically 
moves the Playhead to the Timeline insertion 
point.

With the Playhead enabled, you can jump to and 
play an Edit or Timeline selection. For details, 
see “Playing Timeline and Edit Selections with 
the Playhead” on page 427.

Center Playhead Scrolling option
Half-Screen Edit Window
When the Scrolling option is set to Continuous or 

Center Playhead, a half-screen appears at the far 
left of the Edit window (before the beginning of 
the session) when the Playhead is at the begin-
ning of the session.

Playing Selections
Once an Edit selection is made, you can audition 
it by clicking Play in the Transport window. If 
enabled, the pre- and post-roll amounts play as 
well.

To play a selection:

1  Select Options > Link Timeline and Edit Selec-

tion.

2  With the Selector or Time Grabber tool, make 
a track selection.

3  If you want to use pre-roll or post-roll, enable 
and set the pre-roll and post-roll amounts. For 
details, see “Setting Pre- and Post-Roll” on 
page 468.

Center Playhead Scrolling and Dynamic 
Transport mode cannot be used at the same 
time. Selecting Center Playhead Scrolling 
disables Dynamic Transport mode (if it is 
enabled). Likewise, enabling Dynamic 
Transport mode when Center Playhead 
Scrolling is selected automatically changes 
the Scrolling option to No Scrolling.

Half-screen for Center Playhead Scrolling option
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4  Click Play in the Transport window, or press 
the Spacebar.

All tracks play for the range of the selection, in-
cluding pre-roll and post-roll if enabled.

To play an Edit selection with Link Timeline and 
Edit Selection disabled:

 Choose Edit > Selection > Play Edit.

To play a Timeline selection with Link Timeline and 
Edit Selection disabled:

 Choose Edit > Selection > Play Timeline.

Auditioning Pre-Roll and Post-
Roll
You can audition and play just the pre-roll or 
post-roll material for a selection.

To play from the pre-roll point to the start of a 
selection, or to the current Cursor location:

 Press Option+Left Arrow (Mac) or Alt+Left 
Arrow (Windows).

To play to the post-roll point from the end of a 
selection, or from the current Cursor location:

 Press Command+Right Arrow (Mac) or Con-
trol+Right Arrow (Windows).

Auditioning Start and End Points 
for Selections
There may be times when you want to audition 
the start or end of an audio selection without 
hearing the entire selection. This allows you to 
check, for instance, whether the beginning or 
end of a selection includes any unwanted clicks 
or pops.
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To audition a selection start point:

 Press Command+Left Arrow (Mac) or Con-
trol+Left Arrow (Windows).

When auditioning the beginning of a selection, 
the selection plays from the start point for a du-
ration equal to the post-roll amount.

To audition a selection start point with pre-roll:

 Press Command+Option+Left Arrow (Mac) or 
Control+Alt+Left Arrow (Windows).

To audition a selection end point:

 Press Option+Right Arrow (Mac) or 
Alt+Right Arrow (Windows).

When auditioning the end of a selection, play-
back begins before the end point by the pre-roll 
amount.

To audition a selection end point with post-roll:

 Press Command+Option+Right Arrow (Mac) 
or Control+Alt+Right Arrow (Windows).

Playback ranges for auditioning start/end points

plays start
(for post-roll amount)

plays pre-roll + start

plays end
(for pre-roll amount)

plays end + post-roll



Playing Timeline and Edit 
Selections with the Playhead
(Pro Tools HD Only)

When the Scrolling option is set to Center Play-

head, selections in the Timeline do not deter-
mine when playback begins. The Playhead itself 
denotes where playback begins when clicking 
Play in the Transport.

Timeline and Edit selections, however, can still 
be played when the Playhead is enabled.

To play an Edit selection with the Playhead 
enabled:

1  Deselect Options > Link Timeline and Edit Selec-

tions.

2  Select Options > Scrolling > Center Playhead.

3  With the Selector or Time Grabber tool, make 
a track selection.

4  Choose Edit > Selection > Play Edit.

The Playhead jumps to the Edit selection and 
plays it from beginning to end, and then stops.

To play a Timeline selection with the Playhead 
enabled:

1  Deselect Options > Link Timeline and Edit Selec-

tions.

2  Select Options > Scrolling > Center Playhead.

3  Drag with the Selector tool in any Timebase 
ruler to set the play range.

4  Choose Edit > Selection > Play Timeline.

The Playhead jumps to the Timeline selection 
and plays it from beginning to end, and then 
stops.
Moving the Playhead
When the Scrolling option is set to Center Play-

head, the Playhead can be moved forward or 
back to the next clip boundary in the selected 
track.

To move the Playhead through a track’s clip 
boundaries:

1  Make sure the Tab to Transients button is not 
enabled (see “Tabbing to Transients” on 
page 580).

2  Click in the track with the Selector tool.

3  Do one of the following:

• Press Tab to move the Playhead forward to 
the next clip boundary.

– or –

• Press Option+Tab (Mac) or Control+Tab 
(Windows) to move the Playhead back to 
the previous clip boundary.

Playback Modes
Pro Tools provides several Playback modes: 

• Normal Playback mode

• Half-Speed Playback mode

• Prime for Playback mode

• Loop Playback mode

• Dynamic Transport mode

Normal Playback Mode
Normal Playback mode is simply when none of 
the other Playback modes are selected. In Nor-
mal Playback mode, Pro Tools plays back at the 
session sample rate.
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Half-Speed Playback Mode
Use Half-Speed Playback mode to learn or tran-
scribe difficult passages in recorded tracks.

To play at half-speed:

1  Do one of the following:

• Shift-click the Play button in the Transport.

– or –

• Right-click the Play button in the Transport 
and select Half-Speed. Then click Play to 
start Half-Speed Playback.

2  Click Stop in the Transport to stop playback.

Prime for Playback Mode
When playing back a large number of tracks, 
Pro Tools may take a little longer to actually 
start playback. To avoid this delay, put 
Pro Tools in Prime for Playback mode before 
starting playback.

To enable Prime for Playback mode and start 
playback:

1  Do one of the following:

• Option-click (Mac) or Alt-click (Windows) 
Play in the Transport to put Pro Tools in 
Prime for Playback mode. 

– or –

• Right-click the Play button and select Prime 

for Playback.

The Stop button lights and the Play button 
flashes.

You can also play at half-speed by pressing 
Shift+Spacebar.
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2  436To begin playback instantaneously, click 
Play. 

3  Click Stop to stop playback.

Loop Playback Mode
When Loop Playback mode is enabled, the se-
lected track range repeats on playback. If there 
is no selection, playback occurs normally from 
the current Cursor location. 

Looping playback is a useful way to check the 
rhythmic continuity of a selection when work-
ing with musical material. If you’re working 
with one-bar selections, you can loop playback 
to see if the material loops cleanly. If it seems to 
skip, you should then adjust the length of the se-
lection until it works “musically” within the 
context of the playlist and the other tracks.

To loop playback of a selection:

1  Select Options > Link Timeline and Edit Selec-

tion.

2  With the Selector tool, select the track range 
you want to loop.

When synchronizing to timecode, use Prime 
for Playback mode to play back large num-
bers of tracks. This decreases the time it 
takes to lock to timecode.

A selection must be at least 500 ms in length 
for it to loop on playback.



3  Enable Loop Playback by doing one of the fol-
lowing:

• Select Options > Loop Playback. 

• Right-click the Play button in the Transport 
window and select Loop from the pop-up 
menu.

• Control-click (Mac) or Start-click (Win-
dows) the Play button in the Transport win-
dow. 

• Press Command+Shift+L (Mac) or Con-
trol+Shift+L (Windows).

• With the Numeric Keypad mode set to 
Transport, press 4 on the numeric keypad.

When enabled, a loop symbol appears in the Play 
button in the Transport window.

4  Click Play in the Transport window.

Playback begins from the pre-roll point (if en-
abled) and continues to the selection’s end 
point, where it loops back to the selection’s start 
point.

5  Click Stop in the Transport window to stop 
playback.

Loop Playback and Audio Recording

Looping playback does not enable loop record-
ing. Use Loop Record mode to loop during re-
cording (see “Loop Recording Audio” on 
page 473).

Loop Playback enabled
Dynamic Transport Mode
Dynamic Transport mode lets you decouple the 
playback location from the Timeline selection. 
This means that you can start playback from 
anywhere on the Timeline without losing your 
Timeline or Edit selections. For example, you 
can use Dynamic Transport mode in conjunc-
tion with Loop Playback mode to quickly audi-
tion loop transitions.

When Dynamic Transport mode is enabled, the 
Main Timebase ruler expands to double-height 
and reveals the new Play Start Marker. The Play 
Start Marker determines where playback starts 
when the Transport is engaged. You can posi-
tion the Play Start Marker independently of the 
Timeline Selection. The Play Start Marker can 
be repositioned during playback and playback 
continues from the new location.

To enable or disable Dynamic Transport mode, do 
one of the following:

 Select or deselect Options > Dynamic Trans-

port.

 Right-click the Play button in the Transport 
window and select Dynamic Transport from the 
pop-up menu.

 Press Command+Control+P (Mac) or Con-
trol+Start+P (Windows) to toggle Dynamic 
Transport mode on or off.

Enabling Dynamic Transport mode auto-
matically disables Link Timeline and Edit 
Selection, and automatically enables Loop 
Playback mode.
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To reposition the Play Start Marker, do one of the 
following:

 With any Edit tool selected, click in the Play 
Start Marker strip in the Main Timebase ruler.

 With any Edit tool selected, drag the Play Start 
Marker to a new location.

 Click Fast Forward or Rewind in the Transport 
to relocate the Play Start Marker forward or 
backward by the standard Fast Forward and Re-
wind increment amount.

Center Playhead Scrolling (Pro Tools HD 
only) and Dynamic Transport mode cannot 
be used at the same time. Selecting Center 
Playhead Scrolling disables Dynamic 
Transport mode (if it is enabled). Likewise, 
enabling Dynamic Transport mode when 
Center Playhead Scrolling is selected auto-
matically changes the Scrolling option to No 
Scrolling.

Dynamic Transport mode, Play Start Marker shown in 
expanded Main Timebase ruler

Double-click anywhere in the Play Start 
Marker strip in the Main Timebase ruler to 
move the Play Start Marker to that location 
and start playback.

Play Start Marker

Timeline selection

Play Start Marker strip
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To change the Timeline Selection Start or End 
Markers:

1  Make a Timeline selection with the Selector 
tool by dragging in the Main Timebase ruler. If 
the Link Timeline and Edit Selection option is en-
abled, you can make an Edit selection with the 
Selector or any of the Grabber tools.

2  With any Edit tool selected, drag either the 
Timeline Selection Start or End Markers left or 
right, extending or constricting the Timeline se-
lection.

To move the Timeline selection:

 With any Edit tool selected, drag the selection 
on the Main Timeline ruler to another location.

Changes to the Timeline selection during 
playback temporarily interrupt playback. 
To minimize this interruption, reduce the 
DAE Playback Buffer size in the Playback 
Engine dialog.

Dynamic Transport mode, moving the Edit selection

When the Link Timeline and Edit Selection 
option is disabled, Option-drag (Mac) or 
Alt-drag (Windows) the Timeline selection 
to snap the Edit selection to the Timeline se-
lection and move both in tandem.



Play Start Marker Follows Timeline Selection

When enabled, the Play Start Marker snaps to 
the Timeline Selection In Point when you move 
the Timeline Selection, draw a new Timeline Se-
lection, or adjust the Timeline Selection Start. 
When disabled, the Play Start Marker doesn’t 
move with the Timeline selection.

To have the Play Start Marker always snap to the 
Timeline Selection In Point:

1  Choose Setup > Preferences.

2  Click the Operation tab.

3  Select Play Start Marker Follows Timeline Selec-

tion.

4  Click OK.

Timeline Insertion/Play Start Marker Follows 
Playback

When enabled, the Play Start Marker moves to 
the point in the Timeline when playback stops. 
When disabled, the Play Start Marker does not 
follow playback. 

When not in Dynamic Transport mode, the 
Timeline Insertion follows playback.

To have the Timeline Insertion and the Play Start 
Marker follow playback:

1  Choose Setup > Preferences.

2  Click the Operation tab.

3  Select Timeline Insertion/Play Start Marker Fol-

lows Playback.

4  Click OK.

Press Control+N (Mac) or Start+N (Win-
dows) to toggle the Timeline Insertion/Play 
Start Marker Follows Playback preference 
on and off.
Using Dynamic Transport Mode 
with Loop Playback
Use Dynamic Transport mode in conjunction 
with Loop Playback to specify the loop start and 
end points with the Timeline selection while us-
ing the Play Start Marker to specify where play-
back begins. This is especially useful for audi-
tioning loop transitions. Note that enabling 
Dynamic Transport mode automatically enables 
Loop Playback mode.

To audition a loop transition:

1  Enable Dynamic Transport mode.

2  Ensure that Loop Playback mode is enabled.

3  Make a Timeline selection to loop.

4  Reposition the Play Start Marker before the 
Timeline Selection Out Point.

5  Start playback.

Playback starts before the loop end point and 
continues across the loop point through the loop 
start. You can reposition the Timeline Selection 
Start and End Markers by dragging them left or 
right, even during playback. 

Dynamic Transport mode, auditioning the loop 
transition
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Using Separate Play and Stop 
Keys
When enabled, the Use Separate Play and Stop 

Keys option lets you start playback with the En-
ter key and stop playback with the 0 key on the 
numeric keypad. This is useful for quickly start-
ing and stopping playback when auditioning 
loop transitions.

To use separate play and stop keys on the numeric 
keypad:

1  Choose Setup > Preferences.

2  Click the Operation tab.

3  Select Transport for Numeric Keypad.

4  Select Use Separate Play and Stop Keys.

5  Click OK.

The Enter key starts playback. The Zero key 
stops playback. Pressing Zero twice locates the 
Play Start Marker to the Timeline Selection 
start.

This option overrides using the Enter key to 
add Memory Location markers. Press Pe-
riod (.) and then Enter on the numeric key-
pad to add a Memory Location marker.
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Keyboard Shortcuts for 
Relocating the Play Start Marker
In Dynamic Transport mode, you can use key-
board shortcuts to quickly relocate the Play 
Start Marker either during playback or when the 
Transport is stopped. 

To move the Play Start Marker to the Timeline 
Selection Start:

 Press Period (.) on the numeric keypad and 
then the Left Arrow.

To move the Play Start Marker to the Timeline 
Selection End:

 Press Period (.) on the numeric keypad and 
then the Right Arrow.

To move the Play Start Marker to the Edit Selection 
Start:

 Press Period (.) on the numeric keypad and 
then the Down Arrow.

To move the Play Start Marker to location of the 
Playhead:

 Press Period (.) on the numeric keypad and 
then the Up Arrow.

To nudge the Play Start Marker backward (rewind):

 Press 1 on the numeric keypad.

To nudge the Play Start Marker forward (fast 
forward):

 Press 2 on the numeric keypad.

To move the Play Start to a specific bar:

 With Bars|Beats selected as the Main Time-
base ruler, do the following on the numeric key-
pad:

• Press Asterisk (*).

• Type the bar number.

• Press Enter.



Recording in Dynamic Transport 
Mode
Recording in Dynamic Transport mode lets you 
start playback independently of the Timeline se-
lection. Use the Play Start marker as a manual 
pre-roll before the Timeline selection. Record-
ing punches in and out based on the Timeline se-
lection. 

MIDI Beat Clock
Pro Tools can transmit MIDI Beat Clock to syn-
chronize external MIDI devices that receive 
MIDI Beat Clock (such as drum machines, hard-
ware sequencers, or arpeggiators) with the 
Pro Tools session tempo for playback and re-
cording. Some instrument plug-ins also support 
MIDI Beat Clock for synchronizing to the 
Pro Tools tempo.

For information about synchronizing exter-
nal MIDI devices with Pro Tools for play-
back and recording using MIDI Timecode, 
see “Generating Timecode” on page 1154.
Transmitting Beat Clock

To transmit MIDI Beat Clock:

1  Choose Setup > MIDI > MIDI Beat Clock.

2  In the MIDI Beat Clock dialog, select the En-

able MIDI Beat Clock option.

3  Select the devices you want to receive MIDI 
Beat Clock. If your MIDI interface does not sup-
port transmitting MIDI Beat Clock to separate 
ports, only the interface appears as a destina-
tion.

4  Enter the correct negative offset values (such 
as “–200” samples) for each port that is enabled 
for transmitting MIDI Beat Clock (see “Measur-
ing Beat Clock Latency” on page 434).

5  Click OK.

MIDI Beat Clock dialog
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Sending MIDI Beat Clock Over 
IAC
(Mac Only)

You can synchronize other MIDI applications 
that use the Apple Inter-Application Communi-
cation (IAC) driver to Pro Tools by transmitting 
MIDI Beat Clock on the IAC bus.

To transmit MIDI Beat Clock on the IAC bus:

1  Choose Setup > MIDI > MIDI Studio.

2  In the MIDI Devices window of Audio MIDI 
Setup, double-click the IAC Driver icon. 

3  Configure the IAC Driver ports and confirm 
that it is online.

4  Choose Setup > MIDI > MIDI Beat Clock.

5  In the MIDI Beat Clock dialog, select the En-

able MIDI Beat Clock option.

6  Select the IAC Driver ports you want to enable 
for sending MIDI Beat Clock.

7  Click OK.
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MIDI Beat Clock Offsets
You can set an offset for MIDI Beat Clock on a 
port-by-port basis with your MIDI interface and 
external MIDI devices. This lets you adjust the 
timing for each device where some devices 
sound late due to different, fixed latencies. 
Where appropriate, enter negative offset values 
in samples for each port to correctly synchro-
nize the audio signals from your external MIDI 
devices with Pro Tools playback. 

Measuring Beat Clock Latency

To determine the correct MIDI Beat Clock offset for 
an external MIDI device:

1  Ensure that your computer and external MIDI 
device are correctly connected and configured 
for MIDI, and that its audio output is correctly 
connected to audio inputs on your Pro Tools au-
dio interface.

2  Ensure that your external MIDI device is con-
figured to receive MIDI Beat Clock, and that it is 
correctly configured to play back a simple rhyth-
mic pattern “on the beat.”

3  Create a new Pro Tools session.

4  In the MIDI Beat Clock dialog, ensure that 
MIDI Beat Clock is enabled and that the device is 
selected.

5  Set the Main Time Scale to Bars|Beats.

6  Create a new audio track and select the audio 
input channels for your external MIDI device.

7  Record enable the audio track and start re-
cording. MIDI Beat Clock is sent to the external 
MIDI device, which starts playing back the pat-
tern.

8  Stop recording after a few bars.

9  Enable both Snap to Grid and Show Grid.



10  With the Selector tool, place the edit cursor on the beat grid prior to a prominent transient in the 
waveform that is “on the beat.” 

11  Enable Tab to Transients and Shift+Tab to the transient. The duration of this selection is the ap-
proximate amount of latency for your external MIDI device (see Figure  below).
12  Switch the Main Time Scale to Samples. The length of the selected clip in samples is the MIDI Beat 
Clock latency for that device.

13  In the MIDI Beat Clock dialog, enter the Sample Offset value as a negative number.

Measuring the offset for MIDI Beat Clock in samples
MIDI Beat Clock Sample Offset
Since MIDI is not sample accurate, you may want to make several measurements at different 
grid locations and average them to come up with the best value for the MIDI Beat Clock Offset.
Once you have measured the latency for your MIDI Beat Clock-enabled devices, be sure to keep 
a record of these values in case you need to re-enter the MIDI Beat Clock Sample Offset in other 
sessions.
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Chapter 21: Record Setup
Before you start recording in Pro Tools, you 
need to set up your Pro Tools system, a session, 
and one or more tracks for recording. You will 
also need to configure how Pro Tools monitors 
the input you intend to record. 

While some of the information here is relevant 
to preparing to record MIDI, there are more spe-
cific setup details for MIDI recording in 
Chapter 23, “MIDI Recording.”

For information on recording audio, see 
Chapter 22, “Audio Recording.”

Record Setup Overview
Record setup includes the following:

Hardware Setup for Recording

• “Configuring Pro Tools Hardware I/O for Re-
cording” on page 438

• “Connecting a Sound Source” on page 439

For information on digitizing (recording) 
video in Pro Tools, see Chapter 51, “Work-
ing with Video in Pro Tools” or the Avid 
Video Peripherals Guide.
Session Setup for Recording

• Configuring a new or existing session for re-
cording:

• “Working with Hard Drives for Recording” 
on page 452

• “Recording with a Click” on page 440

• “Setting the Session Meter and Tempo” on 
page 442

• Setting a Record Mode. See “Record Modes” 
on page 445

Track Setup for Recording

• Configuring one or more tracks for recording:

• “Configuring Default Names for Audio Files 
and Clips” on page 448

• “Assigning Hardware I/O on a Track” on 
page 449

• “Record Enabling Tracks” on page 450

• “Recording with Multiple Hard Drives” on 
page 453

Monitoring Setup for Recording

• “Selecting a Record Input Monitoring Mode” 
on page 456

• “Setting Monitor Levels for Record and Play-
back” on page 458

• “Reducing Monitoring Latency” on page 458

• “Recording with Delay Compensation” on 
page 459
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Configuring Pro Tools 
Hardware I/O for Recording
Before you start recording, make sure your 
Pro Tools system hardware is connected and 
configured properly. For details on connecting 
Pro Tools to your studio and configuring your 
Hardware in the Hardware Setup dialog, see the 
User Guide that came with your system. For in-
formation on how to route signal paths in 
Pro Tools, see Chapter 7, “I/O Setup.”

Input Connections and Audio 
Levels
Avid HD audio interfaces operate as line-level 
devices and offer no pre-amplification. Low-
level sources like microphones and electric gui-
tars need to be pre-amplified. You can do this 
with a quality mixing board or dedicated pre-
amp (such as PRE).

003 Rack+ has eight inputs with preamps, to 
which you can connect low-level signals.

003, 003 Rack, Digi 002, and Digi 002 Rack have 
four inputs with preamps, to which you can con-
nect low-level signals, and four additional line-
level inputs with switchable gain.

Eleven Rack has one Mic input with a preamp 
and 1 instrument-level Guitar input with a spe-
cial variable-impedance circuit called True-Z 
(for more information, see the Eleven Rack User 
Guide.)

Mbox (3rd generation), Mbox 2, Mbox Pro, 
Mbox 2 Pro, Mbox Mini, and Mbox 2 Mini each 
have two inputs with preamps, to which you can 
connect low-level signals.

 PRE can be remote-controlled from within 
Pro Tools sessions.
Pro Tools Reference Guide
For input information for qualified M-Audio de-
vices, see your M-Audio documentation.

For all systems, volume and pan controls for 
tracks in Pro Tools only affect monitoring lev-
els—not the recording input gain. The LED me-
ters on Pro Tools audio interfaces indicate both 
full-code (highest level before clipping) and true 
clipping of Pro Tools output signals. The on-
screen meters in Pro Tools indicate only true 
clipping.

Digital Clipping

Clipping occurs when you feed a signal to a re-
corder or mixer that is louder or “hotter” than 
the device allows. On many analog tape decks, a 
little clipping adds a perceived warmth to the 
sound due to tape compression. In digital re-
cording, however, clipping causes digital distor-
tion, which is undesirable and should always be 
avoided. 

Set Input Levels

When you feed a signal into any audio recording 
system, including Pro Tools, make sure to adjust 
the input level to optimize the dynamic range 
and signal-to-noise ratio of the recorded file. If 
the input level is too low, you will not take full 
advantage of the dynamic range of your 
Pro Tools system. If the input level is too high, 
the waveform can clip and distort the recording. 
Set the input levels high, but not high enough to 
clip.

As a general rule of thumb, try to set levels so 
that they peak within –6 dB to –12 dB on the in-
put meter without triggering the clipping indi-
cator on your audio interface. Depending on the 
type of material you are recording and its dy-
namic range and peak content, you may want to 
record with higher or lower levels.



You can display a track’s input levels in its Vol-
ume/Peak/Delay indicator. Normally, this indi-
cator is set to be a Volume indicator. When you 
change it into a Peak indicator, it can function 
as a headroom indicator based on the last peak 
playback level.

To display a track’s peak level:

 Control-click (Windows) or Command-click 
(Mac) a track’s Volume indicator to step through 
the different indicator modes (Volume, Peak, 
and Channel Delay) until the indicator displays 
peak (pk) level.

Calibration Mode
(Pro Tools HD Only)

You can use the Calibration mode in Pro Tools 
to adjust the input and output levels for your au-
dio interface so they match those of your mixing 
console and other audio devices in your studio.

HD I/O has one set of adjustable trim pots for its 
inputs. Additionally, the reference level for the 
input can be set to +4 dBu or –10 dBV. For more 
information on calibrating HD I/O, see the HD 
I/O Guide.
192 I/O has two sets of adjustable trim pots for 
its inputs, and two sets of adjustable trim pots 
for its outputs. Additionally, the reference level 
for the input can be set to +4 dBu or –10 dBV. 
For more information on calibrating 192 I/O, 
see the 192 I/O Guide.

There are no input or output trims on the fol-
lowing audio interfaces: HD OMNI, HD MADI, 
192 Digital I/O, 96 I/O, and 96i I/O. Some 
Pro Tools audio interfaces that do not have out-
put trims (such as the 96i I/O) offer software-
controllable input levels, adjustable from Setup 

> Hardware (see the guide for your particular au-
dio interface).

Connecting a Sound Source
Depending on your Pro Tools audio interfaces, 
you can connect different types of sound sources 
(such as musical instruments, mics, and mixer 
outputs). See the User Guide for your Pro Tools 
system. For additional information, see the doc-
umentation that came with your sound source.

If you connect a sound source to a Pro Tools in-
put that was not previously configured to accept 
input, you may need to reconfigure you hard-
ware in the Hardware Setup dialog (see your 
User Guide). You may also need to reset your I/O 
signal paths in I/O Setup (see Chapter 7, “I/O 
Setup.”).
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Recording with a Click
(Optional)

If you intend to work with MIDI or Instrument 
tracks in your session, or if the audio you’re 
working with is bar and beat-oriented, you can 
record your tracks while listening to a click. This 
ensures that recorded material, both MIDI and 
audio, aligns with the session’s bar and beat 
boundaries.

When your track material lines up with the 
beats, you can take advantage of some very use-
ful editing functions in Pro Tools, such as quan-
tizing MIDI and audio events or clips, quantiz-
ing individual MIDI notes, and copying and 
pasting measures and song sections in Grid 
mode.

Creating a Click Track
Pro Tools lets you create a Click track using the 
Click plug-in. You can also create a click track 
using the TL Metro plug-in (included with 
Pro Tools) or using a MIDI instrument.

Material that is recorded without listening 
to a click can still be aligned to bar and beat 
boundaries in Pro Tools with Beat Detective 
(see Chapter 31, “Beat Detective”), or by us-
ing the Identify Beat command to determine 
the tempo (see “Identify Beat Command” on 
page 794).

For more information on the Click or the TL 
Metro, see the Audio Plug-Ins Guide.
Pro Tools Reference Guide
To create a click track using the Click plug-in:

 Choose Track > Create Click Track.

Pro Tools creates a new Auxiliary Input track 
named “Click” with the Click plug-in already in-
serted. In the Edit window, the click track’s 
Track Height is set to Mini. You can create more 
than one click track and each subsequent click 
track is named in sequence. For example, Click 
1, Click 2, and Click 3.

To hear the click during playback and recording, 
configure the Click Options (see “Click Options” 
on page 441) and ensure that Click is enabled 
(see “Enabling the Click” on page 441).

To create a click track using MIDI:

1  Create a new (mono) Auxiliary Input or In-
strument track.

2  Do one of the following:

• From the track’s Input selector, select the 
path to which the MIDI device is con-
nected.

– or –

• Insert an instrument plug-in on the track 
(such as TL Metro or Xpand2).

3  Configure the Click/Countoff options, and be 
sure to select the port for the MIDI device or in-
strument plug-in from the Output pop-up menu 
(see “Click Options” on page 441).

4  Enable Click (see “Enabling the Click” on 
page 441).



Enabling the Click
Click tracks must be enabled to be heard during 
playback or recording.

To enable the click from the MIDI menu:

 Select Options > Click.

To enable the click in the Transport:

1  Display the MIDI controls in the Transport by 
doing one of the following:

• Select View > Transport > MIDI Controls.

• From the Transport window menu, select 
MIDI Controls.

• Control-click (Windows) or Command-
click (Mac) the Expand/Collapse “+” button 
in the Transport window to display the 
MIDI controls.

• Alt-click (Windows) or Option-click (Mac) 
the Expand/Collapse “+” button in the 
Transport window to display the MIDI con-
trols and the Counters.

Selecting MIDI Controls from the Transport window 
menu

Expand/Collapse “+” button, Transport Window with 
MIDI Controls
2  In the Transport, click the Metronome button 
so it is highlighted.

3  To hear the click count off when recording or 
playing, click the Count Off button in the Trans-
port so it is highlighted.

Hearing the countoff before recording helps mu-
sicians to start playing at the right time and in 
tempo. The Count Off button in the Transport 
window displays the number of bars counted be-
fore the transport starts.

Click Options
Pro Tools provides options and controls for 
driving a click. The following steps are for con-
figuring and enabling a click using the Click 
plug-in or MIDI.

Metronome button, enabled

Count Off button, enabled

The countoff is ignored when Pro Tools is 
online and synchronized to SMPTE time-
code.
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To configure click options:

1  Open the Click/Countoff Options dialog by do-
ing one of the following:

• Choose Setup > Click/Countoff.

– or –

• Double-click the Metronome button in the 
Transport window.

2  In the Click/Countoff Options dialog, do one 
of the following:

• If using the TL Metro or Click plug-in, se-
lect None in the Output pop-up menu.

– or –

• If playing a click using MIDI, select the port 
number (device) and channel for the click 
from the Output pop-up menu. 

3  Specify the note, velocity, and duration for the 
accented and unaccented notes. 

When listening to the click in your Pro Tools 
sessions, the accented note sounds on the first 
beat of each measure and the unaccented note 
sounds on the remaining beats.

Click/Countoff Options dialog

If one is connected, you can also play new 
note values on a MIDI controller keyboard.
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4  Select whether the click is heard During Play 

and Record, or Only During Record, or Only Dur-

ing Countoff.

5  If using a countoff, specify the number of Bars 
to be counted off. To hear the countoff only 
when recording, select that option.

6  Click OK.

Setting the Session Meter 
and Tempo 
(Optional)

Setting the Session Meter
When opening a new session in Pro Tools, the 
meter defaults to 4/4. If you intend to record 
with a click in a meter other than 4/4, make sure 
to set the meter accordingly.

If a session’s meter does not match the music 
you’re recording, the accented clicks will not 
line up with what you’re playing, and, as a re-
sult, the recorded material may not align with 
the bars and beats in the Edit window.

Meter events, which can occur anywhere within 
a Pro Tools session, appear in the Meter ruler. 
For more information on inserting and editing 
meter events, see “Meter Events” on page 797.



To set the meter for a session:

1  Double-click the Current Meter button in the 
Transport window.

2  Enter the Meter for the session and set the Lo-

cation to 1|1|000 (to ensure that the inserted me-
ter event replaces the default).

3  From the Click pop-up menu, select a note 
value for the beat. (For example, if you are in 
6/8, select a dotted-quarter note).

4  Click OK to insert the new meter event.

Setting the Session Tempo
When opening a new session in Pro Tools, the 
tempo defaults to 120 BPM. If you intend to re-
cord with a click at a tempo other than 120 BPM, 
make sure to set the tempo accordingly.

Meter button

Meter Change window

Tempo events, which can occur anywhere 
within a Pro Tools session, appear in the 
Tempo ruler. For more information on in-
serting and editing tempo events, see 
“Tempo” on page 775.
To change the session tempo:

1  Double-click the Song Start Marker in the Edit 
window (see “Song Start Marker” on page 774).

2  Enter the BPM value for the session. 

3  Set the Location to 1|1|000 (to ensure that the 
inserted tempo event replaces the default).

4  From the Resolution pop-up menu, select the 
note value for the beat. (For example, if you are 
in 6/8, select a dotted-quarter note.)

5  Click OK.

Using Manual Tempo Mode
In Manual Tempo mode, Pro Tools ignores 
tempo events in the Tempo track and instead 
plays back a Manual Tempo. This tempo can be 
set with the Tempo slider, or if you are not sure 
of the actual tempo, by tapping in the tempo.

While you can adjust the Manual Tempo during 
playback, doing so momentarily interrupts play-
back.

You can type in a specific tempo, or you can 
use the T key to tap in the tempo.

Tempo Change window
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To set the Manual Tempo with the Tempo slider:

1  To view the MIDI controls in the Transport 
window, select View > Transport > MIDI Controls.

2  In the Transport window, click the Tempo 
Ruler Enable button (Conductor) button so it be-
comes unhighlighted. Pro Tools switches to 
Manual Tempo mode. In this mode, any tempo 
events in the Tempo track are ignored.

3  To base the BPM value on something other 
than the default quarter-note, click the Tempo 
Resolution selector and select a different note 
value. (For example, if you are in 6/8, select a 
dotted-quarter note.)

4  To enter a new tempo, do one of the following:

• Drag the Tempo value up or down. For finer 
resolution, press Control (Windows) or 
Command (Mac) while dragging.

– or –

• Click the Tempo value, type a new number, 
and press Enter.

To exit Manual Tempo mode and enable the Tempo 
track:

 Click the Tempo Ruler Enable (Conductor) 
button in the Transport window so it becomes 
highlighted.

Manual Tempo mode

Tempo value in BPM

Tempo Ruler 
Enable button

Tempo Resolution selector
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To set the Manual Tempo by tapping:

1  Ensure that the MIDI controls are shown in the 
Transport window (select View > Transport > 

MIDI Controls).

2  In the Transport window, click the Tempo 
Ruler Enable (Conductor) button so it becomes 
unhighlighted. Pro Tools switches to Manual 
Tempo mode. In this mode, any tempo events in 
the Tempo track are ignored.

3  Do one of the following:

• Click in the Tempo field so it becomes 
highlighted and tap the “T” key on your 
computer keyboard repeatedly at the new 
tempo.

– or –

• If the Use MIDI to Tap Tempo option is en-
abled in the MIDI Preferences, click in the 
Tempo field so it becomes highlighted and 
tap in the tempo by playing a note repeat-
edly at the new tempo on your MIDI key-
board controller.

To compute the new tempo, Pro Tools averages 
the last eight (or fewer) taps to determine the 
correct tempo. The computed BPM value ap-
pears in the Transport window’s Tempo field.

To lock in the new tempo:

 Take Pro Tools out of Manual Tempo mode by 
clicking the Tempo Ruler Enable (Conductor) 
button, then set the default tempo for the Song 
Start Marker to the new tempo.



Record Modes
For recording audio, Pro Tools provides the fol-
lowing Record modes:

• Normal (Nondestructive)

• Destructive

• Loop

• QuickPunch

• TrackPunch (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

• DestructivePunch (Pro Tools HD and 
Pro Tools with Complete Production Tool-
kit only)

To select the Record mode, do one of the 
following:

 Select the Record mode in the Options menu. 
If no Record mode is selected, Pro Tools is in 
Normal (Nondestructive) Record mode.

– or –

 Right-click the Record button in the Transport 
and select the Record mode from the pop-up 
menu.

The Record button changes to indicate the se-
lected Record mode as follows: 

• Blank for Normal (Nondestructive) 

• “D” for Destructive

• Loop symbol for Loop Record

• “P” for QuickPunch

• “T” for TrackPunch (Pro Tools HD only)

• “DP” for DestructivePunch (Pro Tools HD 
only)

You can also cycle through the Pro Tools re-
cord modes with the Transport stopped, by 
Start-clicking (Windows) or Control-click-
ing (Mac) the Record button.
Normal (Nondestructive) Record 
Mode
In Normal, Nondestructive Record mode, 
Pro Tools records audio nondestructively, 
which means that if you record over a track’s ex-
isting clips, the audio is not erased from your 
hard drive. Both the new and old audio files re-
main on your hard drive, available as clips from 
the Clip List.

In Normal Record mode, the record range can be 
defined by selecting a range in a ruler or in a 
track’s playlist, or by specifying start and end 
points in the Transport window. If there is no 
selection, recording begins from the current 
Cursor location and continues until the Trans-
port’s Stop button is clicked.

The pre- and post-roll settings allow material to 
be heard up to and after the start and end points, 
which is useful when punch recording (see “Au-
dio Punch Recording Over a Specified Range” on 
page 470).

Destructive Record mode enabled

When recording, you can preserve disk space 
by removing unwanted record takes (see 
“Removing Unwanted Clips” on page 278) 
and compacting audio files (see “Compact-
ing an Audio File” on page 611).

To set a record range by selecting within a 
track’s playlist, the Timeline and Edit selec-
tions must be linked. See “Linking or Un-
linking Timeline and Edit Selections” on 
page 569.
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Destructive Record Mode
In Destructive Record mode, recording over ex-
isting clips replaces the original audio perma-
nently, which allows you to keep disk use to a 
minimum. However, if you have sufficient drive 
space, it is usually best to use Pro Tools in Non-
destructive Record mode, to avoid losing any 
previously recorded material.

When defining the record range and setting pre- 
and post-roll, Destructive Record mode works 
the same as Normal (Nondestructive) mode.

Unlike the other record modes, it is not possible 
to cancel or undo record takes when using De-
structive Record mode (see “Canceling a Record 
Take” on page 463).

Loop Record Mode
Loop Record mode lets you record take after 
take (nondestructively) while the same section 
of audio repeats. This is a convenient technique 
for quickly recording multiple takes of a part 
without losing spontaneity.

The time range that is looped and recorded—
which must be at least one second in length—is 
defined by selecting a range in a ruler or in a 
track’s playlist, or by specifying start and end 

In Destructive Record mode, the waveform 
overview is not redrawn until you stop 
recording.

Destructive recording is not supported with 
AudioSuite rendered clips with handles. You 
can consolidate such clips if you need to use 
Destructive Record mode.
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points in the Transport window. The pre-roll 
setting, if enabled, is used during the first re-
cord pass, but on each successive loop the pre- 
and post-roll times are ignored.

When using Loop Record mode, each successive 
take appears as a clip in the Clip List and each is 
numbered sequentially. The various takes, 
which are identical in length and start time, are 
easily auditioned and placed in the track at the 
correct location with the Matches pop-up menu 
(see “Selecting Alternate Takes” on page 475).

QuickPunch
QuickPunch gives you the ability to manually 
and instantaneously punch in (initiate record-
ing) and punch out (stop recording) on record-
enabled audio tracks during playback by click-
ing the Record button in the Transport. Record-
ing with QuickPunch is nondestructive.

When using QuickPunch, Pro Tools begins re-
cording a new file when playback begins, auto-
matically generating clips in that file at each 
punch in/out point. These clips appear in the 
track’s playlist; and the complete audio file ap-
pears in the Clip List along with the QuickPunch 
created clips. Up to 200 of these “running 
punches” can be performed in a single pass.

To set a record range by selecting within a 
track’s playlist, enable the Link Timeline 
and Edit Selection option. See “Linking or 
Unlinking Timeline and Edit Selections” on 
page 569.

In Loop Record mode, the waveform over-
view is not redrawn until you stop 
recording.



Though you can punch record in the other re-
cord modes by manually specifying the record 
range, only QuickPunch provides instantaneous 
monitor switching on punch-out.

TrackPunch 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

TrackPunch lets individual tracks be punched 
in, punched out, and taken out of record enable 
without interrupting online recording and play-
back. 

TrackPunch is a nondestructive recording 
mode. When a track is TrackPunch-enabled, 
Pro Tools begins recording a new file when play-
back begins. During playback, you may record 
arm or disarm, or punch in or out a combination 
of any or all TrackPunch enabled tracks. 

TrackPunch automatically creates clips in that 
file at each punch-in and punch-out point. 
These clips appear in the track’s playlist, and the 
complete audio file appears in the Clip List 
along with the TrackPunch created clips. Up to 
200 of these “running punches” can be per-
formed in a single pass. 

For more information on QuickPunch, see 
“QuickPunch Audio Recording” on 
page 505.

For more information on TrackPunch, see 
“TrackPunch Audio Recording” on 
page 506.
DestructivePunch
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Destructive Punch is a destructive recording 
mode that lets you instantaneously punch in 
(start recording) and punch out (stop recording) 
on individual audio tracks during playback, 
while preserving a contiguous audio file on each 
punched track. 

Record Modes and MIDI
In addition to the various record modes, there is 
also a MIDI Merge button in the Transport win-
dow that determines how MIDI is recorded. 
When enabled (Merge mode), recording over ex-
isting MIDI clips results in the new data being 
merged with the old. When the MIDI Merge but-
ton is disabled (Replace mode), the new material 
replaces the old.

MIDI recording works the same whether using 
Nondestructive or Destructive Record mode. In 
addition, neither QuickPunch nor TrackPunch 
need to be enabled to punch on-the-fly with 
MIDI—this capability is available in Nonde-
structive and Destructive Record modes.

Unlike audio loop recording, the state of the 
MIDI Merge toggle determines whether existing 
material is replaced or merged.

For more information on DestructivePunch, 
see “DestructivePunch Audio Recording” on 
page 510.

MIDI Merge button, enabled
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Unless MIDI Merge is enabled, MIDI recording 
is destructive (though you can undo a MIDI re-
cord pass), either overwriting or adding to clip 
material. One exception to this rule is when 
Loop Record mode is enabled; in this mode, ex-
isting track clips are replaced with new clips 
when new material is recorded. The old clips re-
main intact and available from the Clip List, and 
from the Matches pop-up menu. In Loop Record 
mode, MIDI Merge has no effect, so its button is 
dimmed.

Configuring Default Names 
for Audio Files and Clips 
(Optional)

Track names define new file and clip names 
when recording to a track (see “Naming Tracks” 
on page 222).

When recording to an audio track, the resulting 
file and clip names are based on the name of the 
track. For example, after recording for the first 
time on a track called “Electric Gtr,” an audio 
file is created with the name “Electric Gtr_01.” 
In addition, a clip appears in the Clip List with 
the name “Electric Gtr_01.” This clip is a whole-
file clip.

Subsequent record takes on the same track are 
named identically, but the digits (indicating the 
take number) are incremented (for example, 
“Electric Gtr_02.”) A second set of digits (such 
as used in “Electric Gtr_01-01”) indicates that 
the clip was auto-created from an edit. 

QuickPunch, TrackPunch, and Destructive 
Punch modes use a different method for 
numbering clips. For details, see “Track-
Punch Audio Recording” on page 506.
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When recording MIDI tracks, a similar naming 
scheme is used, though with only one set of dig-
its. For example, after recording to a track called 
“Synth 1,” a clip is created called “Synth 1-01.” 
Subsequent clips for that track, generating ei-
ther from additional record takes or clip edits, 
are numbered sequentially (for example, “Synth 
1-02”).

To rename a track:

1  Do one of the following:

• In the Mix or Edit window, double-click the 
Track Name button for the track you want 
to rename.

– or –

• In the Track List in the Mix, Edit, MIDI Ed-
itor, or Score Editor window, Right-click 
the track name for the track you want to re-
name.

2  In the Track Name/Comments dialog, type a 
new track name.

3  Click OK.

Names for Stereo Audio Tracks
When recording to stereo audio tracks, audio 
file and clip names for the left and right chan-
nels are appended with a “.L” and “.R” suffix.



Names for Multichannel Tracks 
(Pro Tools HD or Pro Tools with Complete 
Production Toolkit Only)

When recording to multichannel surround 
tracks, audio file and clip names for each chan-
nel are appended with the following suffixes:

Assigning Hardware I/O on a 
Track
Before recording to a track, you must specify the 
input and output signal path for the material 
you are recording. You will do this by assigning 
a hardware input (recording source) and an out-
put bus (for monitoring recording) on the track.

Multichannel 
Format

File and Clip Suffixes

LCR L, C, R

Quad L, R, Ls, Rs

LCRS L, C, R, S

5.0 L, C, R, Ls, Rs

5.1 L, C, R, Ls, Rs, LFE

6.0 L, C, R, Ls, Cs, Rs, LFE

6.1 L, C, R, Ls, Cs, Rs

7.0 L, C, R, Lss, Rss, Lsr, Rsr

7.1 L, C, R, Lss, Rss, Lsr, Rsr, LFE

7.0 SDDS L, Lc, C, R, Rc, Ls, Rs

7.1 SDDS L, Lc, C, R, Rc, Ls, Rs, LFE
To assign I/O on a track:

1  Assign a hardware input (recording source) by 
doing one of the following:

• In the Mix window, select the correspond-
ing hardware input for your source from the 
track’s Input Path selector.

– or –

• In the Edit window, with I/O view enabled, 
select the corresponding hardware input 
for your source from the track’s Input Path 
selector.

Input Path selector, Mix window

Input Path selector, Edit window
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2  Assign an output bus (for monitoring record-
ing) by doing one of the following:

• In the Mix window, select the correspond-
ing output bus for monitoring (such as 
“Monitor” or “A 1–2”) from the track’s Out-
put Path selector.

– or –

• In the Edit window, with I/O view enabled, 
select the corresponding output bus for 
monitoring (such as “Monitor” or “A 1–2”) 
from the track’s Output Path selector.

Output Path selector, Mix window

Output Path selector, Edit window
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Record Enabling Tracks
To record audio or MIDI to a track you must 
first enable the track’s Record Enable button. To 
record simultaneously to multiple tracks, record 
enable multiple audio, Instrument, or MIDI 
tracks. 

When one or more tracks are record-enabled, 
click the Record button in the Transport to arm 
recording, and then click the Play button in the 
Transport to start recording.

To record enable an audio, MIDI, or Instrument 
track:

 From either the Mix or Edit window, click the 
track’s Record Enable button to toggle record en-
able on or off for the track. The track’s Record 
Enable button flashes red, the track’s fader is 
solid red, and the Track Record Enabled indica-
tor in the Transport turns red (indicating at least 
one track is record-enabled).

MIDI and Instrument tracks can be record-
enabled during playback or record. To re-
cord enable audio tracks, the Transport 
must be stopped, or QuickPunch, Track-
Punch, or DestructivePunch must be en-
abled. For more information on Quick-
Punch, TrackPunch, and DestructivePunch, 
see “Record Modes” on page 445.



To record enable multiple audio tracks:

 From either the Mix or Edit window, click each 
audio track’s Record Enable button to toggle re-
cord enable on or off for each track.

To record enable multiple MIDI and Instrument 
tracks:

 From either the Mix or Edit window, Shift-
click each MIDI or Instrument track’s Record 
Enable button to toggle record enable on or off 
for each track.

Record-enabled audio track in Mix and Edit windows

Press Shift+R to record enable any track 
containing the Edit cursor on an Edit 
selection.

If Latch Record mode is not enabled, Shift-
click each track’s Record Enable button to 
toggle record enable on or off for each track. 
See “Latch Record Enable Buttons Prefer-
ence” on page 452.

Edit window

Mix window
To record enable MIDI and Instrument tracks using 
the Up/Down Arrows:

 While pressing Command (Mac) or Control 
(Windows), press the Up/Down Arrows to record 
enable the previous or next MIDI or Instrument 
track. The previous (or next) record track is no 
longer record-enabled.

To record enable all audio tracks, or all MIDI and 
Instrument tracks:

 Option-click (Mac) or Alt-click (Windows) the 
Record Enable button to toggle record enable on 
or off for all audio tracks, or all Instrument and 
MIDI tracks. 

For record-enable, Pro Tools treats MIDI and 
Instrument tracks as the same type. Conse-
quently, Option-clicking (Mac) or Alt-clicking 
(Windows) the Record Enable button on any 
MIDI or Instrument track will record enable all 
MIDI and Instrument tracks in the session.

To record enable all selected audio tracks, or all 
selected MIDI and Instrument tracks:

 Option-Shift-click (Mac) or Alt-Shift-click 
(Windows) the Record Enable button on any se-
lected audio, or MIDI or Instrument track to tog-
gle record enable on or off for all selected audio, 
or MIDI and Instrument tracks.

To keep the previous track record-enabled 
while enabling new tracks, press 
Command+Shift+Up/Down (Mac) or 
Control+Shift+Up/Down (Windows).

Record enabling a track that is part of a Mix 
Group does not record enable the other 
tracks in the Group. To record enable all 
tracks in a group, click directly to the left of 
the group’s name in the Group List to select 
all tracks in the group, and then Option-
Shift-click (Mac) or Alt-Shift-click (Win-
dows) the Record Enable button of one of the 
tracks to record enable the selected tracks.
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Latch Record Enable Buttons 
Preference
When the Latch Record Enable Buttons option is 
selected in the Operation Preferences, you can 
record enable additional audio tracks by clicking 
their Record Enable buttons. Previously record-
enabled tracks remain enabled. The Latch Re-

cord Enable Buttons option affects audio tracks 
only.

When the Latch Record Enable Buttons option is 
deselected, record enabling a subsequent audio 
track disables the previously record-enabled au-
dio track.

To enable the Latch Record Enable Buttons 
preference:

1  Choose Setup > Preferences and click the 
Operation tab.

2  Select Latch Record Enable Buttons.

Record Safe Mode
Pro Tools provides a Record Safe mode on a per 
track basis that prevents tracks from being re-
cord-enabled by accident. Use Record Safe mode 
to protect important audio or MIDI data on a 
track from being recorded over.

To put an audio, MIDI, or Instrument track in 
Record Safe mode:

 Command-click (Mac) or Control-click (Win-
dows) the track’s Record Enable button. The Re-
cord Enable button is grayed out.

Command-click (Mac) or Control-click (Win-
dows) again to take the track out of Record Safe 
mode.
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To put all audio, MIDI, and Instrument tracks in 
Record Safe mode:

 Command-Option-click (Mac) or Control-Alt-
click (Windows) the Record Enable button on 
any track.

Command-Option-click (Mac) or Control-Alt-
click (Windows) again to take all tracks out of 
Record Safe mode.

To put all currently selected tracks into Record 
Safe mode:

 Command-Option-Shift-click (Mac) or Con-
trol-Alt-Shift-click (Windows) the Record En-
able button on any of the selected tracks to 
toggle them in and out of Record Safe mode.

Working with Hard Drives for 
Recording

Monitoring Drive Space
Pro Tools lets you check how much drive space 
is available. The Disk Usage window shows the 
available drive space for each drive connected to 
your system as text and as a gauge display.

To monitor available space on your drive during a 
Pro Tools session:

 Choose Window > Disk Space.

Disk Usage window



To display available drive space in Text Only view 
only:

 From the Disk Usage menu, select Text Only.

Recording with Multiple Hard 
Drives
(Optional)

By default, Pro Tools records audio files to the 
Audio Files folder inside the session folder. If 
you have multiple hard drives for recording, you 
can use the Disk Allocation window to specify 
other hard drive locations to record audio files 
on a track-by-track basis.

Hard drives that are full do not appear in the 
Disk Allocation window.

To increase system performance, Pro Tools can 
record and play each track from a different hard 
drive. You can also automatically distribute any 
newly created tracks to multiple audio drives 
with Round Robin Allocation.

Navigating in the Disk Allocation Window

To resize the Disk Allocation window:

 Drag the lower-right corner of the window ac-
cording to standard convention for your operat-
ing system (Windows or Mac).

To scroll up or down in the Disk Allocation 
window:

 Press Page Up or Page Down.

Disk Usage window, selecting Text Only view
Allocating Audio Drives in Your 
System

To allocate the audio drives in your system:

1  Choose Setup > Disk Allocation.

2  In the Disk Allocation window, assign a hard 
drive for each track by clicking in the Root Me-
dia Folder column and selecting a volume from 
the Disk Allocation pop-up menu.

Only drives designated as R (Play and Record) 
can be selected in the Disk Allocation window. 
For more information, see “Performance and 
Transfer Volumes” on page 283.

Disk Allocation window

Disk Allocation pop-up menu
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A folder with the session name is created on 
each hard drive, containing subfolders for audio 
and fade files.

• To assign a track to a different hard drive, 
click the track and select a drive name.

• To assign all tracks to the same hard drive, 
press Option (Mac) or Alt (Windows) while 
selecting a drive name.

• To make a continuous selection, Shift-click 
a track name (in the Track column) to ex-
tend the selection to include already-se-
lected tracks and all tracks in between.

• To make a noncontiguous selection, Com-
mand-click (Mac) or Control-click (Win-
dows) a track name in the Track column to 
extend the selection to include already-se-
lected tracks without including tracks in-
between.

3  To save recorded audio files to an existing 
folder (without creating another session folder), 
select Customize Allocation Options, then click 
Change and choose the folder. To create subfold-
ers in this folder, select the Create Subfolders for 

Audio, Video, and Fade Files option.

4  To automatically distribute any newly created 
tracks among the drives connected to your sys-
tem, select the Use Round Robin Allocation for 

New Tracks option.

If you are using Round Robin Allocation and 
want audio to be recorded to your system’s 
start-up drive, do the following:

• Open the Workspace browser (Window > 

Workspace) and set the Volume Designator 
for your system volume to R (Record and 
Playback). See “Workspace Volume Desig-
nation” on page 455.

Round Robin Allocation is not supported 
with partitioned hard drives.
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5  When you are finished, click OK.

Saving Disk Allocation Settings
To save Disk Allocation settings for use with fu-
ture sessions, save the session as a template. For 
details, see “Session Templates” on page 174.

Disk Allocation and Cross-
Platform Sessions
To ensure cross-platform operation, it is re-
quired that Mac Pro Tools sessions and their as-
sociated audio files be on Mac-formatted (HFS 
or HFS+) drives. Windows Pro Tools sessions 
and their associated audio files must be on Win-
dows-formatted NTFS drives. 

If you want to exclude individual, valid, 
mounted volumes from Round Robin Allo-
cation passes, open the Workspace browser 
and make the volume safe, by designating it 
as P (Playback only) or T (Transfer). For 
more information, see “Audio and Video 
Volume Designators” on page 319.

See “Saving Copies of Mac Sessions to be 
Compatible with Windows” on page 396 
and “Sharing Sessions Created on Different 
Computer Platforms” on page 394.

On Windows, with the HFS+ Disk Support 
option installed, you can record to and play 
back from Mac-formatted HFS+ drives. For 
more information, see the Mac HFS+ Disk 
Support Option Guide.



Reallocating Tracks
When opening a session where some of the pre-
viously assigned hard drives are no longer avail-
able (or do not match the current session plat-
form), Pro Tools automatically reassigns tracks 
to the volume where the session file is stored. In 
such cases, use Disk Allocation if you need to re-
allocate tracks to other drives.

Workspace Volume Designation
The Workspace volume designation can alter 
disk availability, thus affecting Disk Allocation. 
From the Workspace browser, you can designate 
volumes as Record, Playback, or Transfer. If you 
change a drive’s designation, making it read-
only (Play Only or Transfer), check the Disk Al-
location window for any tracks formerly allo-
cated to that drive. For more information, see 
“Audio and Video Volume Designators” on 
page 319.

Recording to the System Volume
Although Pro Tools lets you record to your sys-
tem volume, this is generally not recommended. 
Performance for audio recording and playback 
on system drives is not as good as on non-system 
hard drives.

Record to system drives only when absolutely 
necessary, such as if your computer system has 
only one hard drive, or if your other hard drives 
are completely full.

Reallocating tracks does not affect the previ-
ously recorded audio. Reallocating tracks 
only affects where new audio recording is 
saved.
By default, the system volume is not included in 
Round Robin Allocation (regardless of volume 
designation in the Workspace browser). To in-
clude the System Volume in Round Robin Allo-
cations, see “Allocating Audio Drives in Your 
System” on page 453.

Open Ended Record Allocation
The Operation preference for Open Ended Re-

cord Allocation determines how much of your 
available hard drive space is allocated whenever 
you record into one or more tracks in Pro Tools.

When this allocation preference is set to Use All 

Available Space, the drive’s entire available 
space is allocated. This setting lets you record 
lengthy takes, or longer sessions. 

However, when allocating all available space, 
Pro Tools may take a little longer to begin re-
cording. You can reduce this delay by allocating 
a specific amount of time for recording. 

In general, the Use All Available Space prefer-
ence makes hard drives work harder. In addition 
to record and punch lag times, many systems see 
better overall recording performance when the 
Open Ended Record Allocation setting is limited.

If you have a Pro Tools system with multiple 
drives, and you intend to record multiple 
tracks simultaneously, you may want to des-
ignate the System drive as a Playback only 
or Transfer only drive for optimal perfor-
mance.

You can also avoid recording delays by put-
ting Pro Tools in Record Pause mode before 
beginning to record. See“Prime for Record 
Mode” on page 464.
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To allocate a specific amount of time to recording:

1  Choose Setup > Preferences and click the 
Operation tab.

2  Under Open Ended Record Allocation, select 
Limit To and enter the number of minutes to be 
allocated.

The number of minutes specified is allocated for 
each record-enabled track. 

3  When you are finished, click OK.

Selecting a Record Input 
Monitoring Mode
Pro Tools offers two modes of input monitoring: 
Auto Input and Input Only. These monitoring 
modes determine how input signals are moni-
tored during playback, recording, or while the 
transport is stopped.

Auto Input Monitoring
In Auto Input mode, when session playback is 
stopped, Pro Tools monitors audio input. When 
playback is started for a punch-in, Pro Tools 
monitors existing track material up until the 
punch point. While punched in, the input signal 

Open Ended Record Allocation, Operation preference
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is monitored. On punch-out, monitoring 
switches back to the existing track material. 
This is similar to the auto-switching logic found 
on digital and analog multitrack tape machines.

Input Only Monitoring
In Input Only mode, when a track is record-en-
abled, Pro Tools monitors audio input only, re-
gardless of any punch-in/out selection or state.

For Pro Tools, the Input Monitor Enabled Status 
indicator (in the Transport window) lights 
green when Input Only mode is enabled.

For Pro Tools HD, the indicator lights green 
when one or more tracks have TrackInput en-
abled (see “Selecting Record Monitor Modes 
with TrackInput Monitoring” on page 457).

When in Auto Input mode, the switch back to 
monitoring track material on punch-out is not 
instantaneous.

With Pro Tools HD, tracks are in Auto Input 
mode by default, and a monitoring control 
(TrackInput button) is provided for each 
track. See “Selecting Record Monitor Modes 
with TrackInput Monitoring” on page 457.

Input Monitor Enabled Status, Transport window



Selecting a Record Monitor 
Mode

For record-enabled tracks to use Auto Input 
Monitoring:

 Select Track > Auto Input Monitoring.

For record-enabled tracks to use Input Only 
Monitoring:

 Select Track > Input Only Monitoring.

Selecting Record Monitor Modes 
with TrackInput Monitoring
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

TrackInput monitoring lets you toggle individ-
ual audio tracks between Auto Input and Input 
Only monitoring modes at any time, during 
playback, recording, while stopped, and even 
when a track is not record-enabled. TrackInput 
monitoring provides the necessary monitoring 
flexibility for overdubbing and mixing, and is 
similar to input switching on analog multitrack 
recorders and similar machines.

When the TrackInput button in a track is en-
abled (green), the track monitors audio in Input 
Only mode. 

To toggle between Auto Input and Input 
Only monitoring, press Option+K (Mac) 
or Alt+K (Windows).

TrackInput Monitor button On (Input Only), in the Edit 
Window
When the TrackInput button in a track is dis-
abled, the track monitors in Auto Input mode.

To toggle the monitoring mode of audio tracks, do 
one of the following:

 To toggle individual tracks, click the TrackIn-
put Monitor button for each track you want to 
toggle.

 To toggle all tracks in the session, Option-
click (Mac) or Alt-click (Windows) a TrackInput 
Monitor button.

 To toggle all selected tracks in the session, Op-
tion-Shift-click (Mac) or Alt-Shift-click (Win-
dows) a selected track’s TrackInput Monitor 
button.

To toggle the TrackInput button states of all 
record-enabled tracks, do one of the following:

 To change all record-enabled tracks to Auto 
Input monitoring, select Track > Set Record 

Tracks to Auto Input.

– or –

 To change all record-enabled tracks to Input 
Only monitoring, select Track > Set Record 

Tracks to Input Only.

TrackInput Monitor button Off (Audio Input), in the Edit 
Window

Press Shift+I to enable the TrackInput Mon-
itor button for any track containing the Edit 
cursor on an Edit selection.

To toggle record-enabled tracks between 
Auto Input and Input Only monitoring, 
press Option+K (Mac) or Alt+K (Windows).
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Disable “Input” When Disarming Track

When the Disable “Input” When Disarming Track 

(in “Stop”) option is enabled in the Operation 
Preferences, TrackInput monitoring is disabled 
whenever a track is taken out of record enable. 
This is useful for certain workflows, such as 
when you are recording on a series of tracks, one 
at a time.

Disabling this option allows TrackInput buttons 
to remain enabled when deselecting the track 
Record Enable button.

Setting Monitor Levels for 
Record and Playback
Pro Tools remembers two different fader levels 
for monitoring each audio track: one for when 
the track is record-enabled, and one for when it 
is not record-enabled. 

Pro Tools keeps track of these two states for 
fader levels automatically. If you adjust a fader 
when a track is record-enabled and then turn off 
record enable for the track, the fader returns to 
its playback level.

When audio tracks are record-enabled, their 
volume faders in the Mix window turn red, indi-
cating that the record monitor level is active.

Link Record and Play Faders
When the Link Record and Play Faders option is 
selected in the Operation Preferences, Pro Tools 
does not keep track of record and play levels for 
audio tracks. In this case, record enabling an au-
dio track has no effect on the fader level for the 
track. This lets you maintain a consistent mix 
regardless of whether you are recording or just 
listening.
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Reducing Monitoring Latency
There will inevitably be some audio delay, or la-
tency, in the monitoring signal (even if only a 
few samples) due to the process of converting an 
analog signal to a digital signal (input) and back 
again (output). There may be additional latency 
due to mixer configurations and processing.

Pro Tools|HD systems have additional latency 
when using host-based plug-ins (RTAS and 
AAX) because these plug-ins also use your com-
puter’s host processor.

Host-based Pro Tools systems use the host pro-
cessor in your computer for all audio process-
ing, playback, and recording, so there is always a 
small amount of latency in the system. For ex-
ample, there may be some audible delay between 
the incoming signal and outgoing signal when 
monitoring recording through Pro Tools. 

With Pro Tools, latency occurs as follows:

• All Pro Tools systems can have RTAS MIDI-
to-audio latency (such as when playing an 
RTAS virtual instrument live and monitor-
ing the instrument’s output).

• Pro Tools systems have input-to-output 
monitoring latency on any record-armed 
tracks or Auxiliary Inputs with live inputs.

• Pro Tools|HD systems have monitoring la-
tency on tracks that have one or more host-
based plug-ins. 

The latency amount is related to the H/W Buffer 

Size setting—the larger the buffer size the 
greater the latency. You can reduce the amount 
of monitoring latency by reducing the H/W Buf-

fer Size setting. However, even at the smallest 
buffer size, there is still some latency. 



In addition, reducing the buffer size limits the 
number of simultaneous audio tracks you can 
record without encountering performance er-
rors.

While there may be times when you want a 
larger buffer size, such as when you have higher 
track counts with more plug-ins, you will gener-
ally want the smallest possible buffer size when 
latency is present during recording and moni-
toring.

If you are monitoring the recording source with 
an external mixer before it is routed to 
Pro Tools, you will not hear any latency.

To set the Hardware Buffer Size:

1  Choose Setup > Playback Engine.

2  Choose the number of samples from the H/W 

Buffer Size pop-up menu.

3  Click OK.

Recording with Delay 
Compensation
Generally, you will want to record with Delay 
Compensation enabled to maintain phase coher-
ent time alignment between tracks with differ-
ent DSP delays. However, you will generally 
want to avoid using inserts on recording tracks 
or tracks used for controlling the levels of cue 
mixes. For more information, see “Delay Com-
pensation” on page 977.

For more information on H/W Buffer Size 

setting, see “Hardware Buffer Size” on 
page 62.

Computers with slower CPUs may not be 
able to use a H/W Buffer Size setting lower 
than 512 samples buffer size without en-
countering performance errors.
Zero Latency Monitoring
(Mbox, Mbox 2, Mbox Mini, and Mbox 2 Mini 
Only)

Mbox (3rd generation), Mbox 2, Mbox Mini, and 
Mbox Mini 2 give you the ability to monitor your 
analog input signals while recording, without 
hearing any latency. This zero-latency analog 
monitoring is controlled by the front panel Mix 
knob, which you can use to blend and adjust the 
mix between the interface’s analog input and 
Pro Tools playback. For more information, see 
your system’s User Guide.

Low Latency Monitoring
(HD Native, 003, 003 Rack, 003 Rack+, Digi 002, 
Digi 002 Rack, Mbox Pro, Mbox Pro 2, and Core 
Audio and ASIO Interfaces with Built-in Mixers 
Only)

HD Native, 003, 003 Rack, 003 Rack+, Digi 002, 
Digi 002 Rack, Mbox Pro, and Mbox Pro 2 sys-
tems can use the Low Latency Monitoring option 
to record with an extremely small amount of 
monitoring latency, to as many tracks as each 
system supports.

Likewise, certain Core Audio and ASIO audio in-
terfaces that have a built-in mixer (such as the 
RME Fireface or the MOTU 828) can use the Low 

Latency Monitoring option.

Only tracks with inputs set to a physical output 
(not an internal mix bus) use Low Latency Mon-
itoring.

If your Core Audio or ASIO hardware does 
not have a built-in mixer, Low Latency 
Monitoring does not function. If you do en-
able Low Latency Monitoring with such 
hardware, monitoring will not available for 
record-enabled tracks in Pro Tools.
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To use Low Latency Monitoring:

1  Do one of the following:

• For HD Native systems, assign each track to 
the selected Low Latency Monitoring Path 
as set in the I/O Setup Output page (see 
“Low Latency Monitoring” on page 95). 
Only tracks assigned to these outputs use 
Low Latency Monitoring.

– or –

• For all other systems, assign each track out-
put to either Output 1 or Output 2 (mono), 
or both (stereo). Only tracks assigned to 
these outputs use Low Latency Monitoring.

2  Record enable audio tracks by clicking their 
Record Enable buttons.

3  Select Options > Low Latency Monitoring. 

When Low Latency Monitoring is enabled, any 
plug-ins and sends assigned to record-enabled 
tracks (routed to the selected Low Latency Mon-
itoring Path with HD Native systems, or to Out-
puts 1–2 with all other systems) are automati-
cally bypassed, and must remain bypassed. Also, 
these tracks do not register on meters for Master 
Faders.

In Pro Tools with the Complete Production 
Toolkit option, Low Latency Monitoring is 
not available in surround sessions.
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Low Latency Monitoring and 
Bounce To Disk

With Low Latency Monitoring enabled, only audio 
tracks are included with the Bounce to Disk com-
mand—Auxiliary Input and Instrument tracks 
are ignored. To include Auxiliary Input and In-
strument tracks, disable Low Latency Monitoring 
before using Bounce to Disk. 

External input cannot be recorded during a 
Bounce to Disk. To include external input in 
your bounce, it must be recorded to new au-
dio tracks before using Bounce to Disk (see 
“Bounce to Disk” on page 1084).



Chapter 22: Audio Recording
In Pro Tools, you record audio to audio tracks. 
Audio tracks can be mono, stereo, or multichan-
nel as appropriate for the recording source. 

When recording a mono source, record to a sin-
gle, mono audio track in Pro Tools. A single, 
mono audio file is written to disk, and the file 
appears as a clip both in the track’s playlist and 
in the Clip List.

When recording a stereo audio source, record to 
a single, stereo audio track in Pro Tools. A sin-
gle, mono audio file is written to disk for each 
channel of a stereo track: one for the left chan-
nel, and one for the right channel. These files 
appear as a stereo clip both in the track’s playlist 
and in the Clip List.

Recording a multichannel source to a multi-
channel track (Pro Tools HD and Pro Tools with 
Complete Production Toolkit only) is similar to 
recording stereo audio tracks. A single, mono 
audio file is written for each channel in the 
track, and these files appear as multichannel 
clips in both the track’s playlist and in the Clip 
List (see “Multichannel Audio Tracks” on 
page 1109). 
Before Recording
Before you start recording in Pro Tools, you 
need to set up your Pro Tools system, a session, 
and one or more tracks for recording. You will 
also need to configure how Pro Tools monitors 
the input you intend to record. For information, 
see Chapter 21, “Record Setup.”

Basic Recording Steps

To record an audio track:

1  From the track’s Input Path selector, select the 
audio Input Path you want to record (see “As-
signing Hardware I/O on a Track” on page 449).

2  From the track’s Output Path selector, select 
the main monitoring path.

3  Select the Record Enable button for the audio 
track. It lights red.

4  Adjust the output level of your sound source 
(instrument, mixer, or preamp). Monitor the 
track’s meter levels in Pro Tools to ensure that 
levels peak within at least –6 dB to –12 dB on 
the input meter without triggering the clipping 
indicator on your audio interface.

Record enabling a track in the Mix window
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5  Do one of the following:

• In the Mix window, adjust the track’s vol-
ume and pan faders. These settings are for 
monitoring purposes only and do not affect 
the recorded material.

– or –

• In the Output window for the track, adjust 
the track’s Volume fader and Pan sliders. 
These settings are for monitoring purposes 
only and do not affect the recorded mate-
rial. (See “Output Windows for Tracks and 
Sends” on page 965.)

6  Choose Window > Transport to display the 
Transport window. Click Return to Zero to go to 
the beginning of the session. 

7  Click Record in the Transport window to arm 
Pro Tools for recording. The Record button 
flashes red to indicate that Pro Tools is ready to 
record.

8  Ensure that Normal Record mode is selected 
(see “Record Modes” on page 445).

9  When you are ready to start recording, click 
Play or press the Spacebar.

If using Countoff, Pro Tools counts off the spec-
ified number of measures and then begins re-
cording. See “Recording with a Click” on 
page 440.

10  Record your performance.

Transport window

Fast Forward

Record

Go to End

Play
Stop

Rewind

Return to Zero

Online
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11  Click Stop in the Transport window or press 
the Spacebar when you are finished recording.

The newly recorded audio is written to disk and 
appears as an audio clip both in the track’s play-
list and in the Clip List.

To play back the audio track:

1  Click the Record Enable button for the audio 
track so that it is no longer record-enabled. 
Track volume faders now function as playback 
level controls.

2  To have playback start from the beginning of 
the session, click Return to Zero in the Trans-
port.

3  To start playback, click Play in the Transport 
or press the Spacebar.

If a record-enabled track is in Auto Input 
Monitor mode, you will hear “through” the 
input while the Transport is stopped. The 
track automatically switches to playback 
when you press play, then back to Input 
mode when you either stop, or punch into 
record. For more information, see “Auto In-
put Monitoring” on page 456.



Undo or Cancel Audio Recording
Once you have recorded an audio track and the 
transport is stopped, you can undo the record 
take.

To undo an audio recording:

 Once the Transport has been stopped, choose 
Edit > Undo Record Audio. 

The track’s playlist is restored to its previous 
state and material is discarded as follows:

• When in normal Record mode, only the 
most recent take is discarded.

• When in Loop Record mode, all takes from 
each record pass are discarded.

• When using QuickPunch, TrackPunch, or 
DestructivePunch mode, all punches from 
the last recording pass are discarded.

If no actions are available to undo, the menu 
displays a grayed out Can’t Undo.

If you undo a record pass during recording, 
Pro Tools removes any previously undone re-
cord pass from the session and lets you 
delete the previous record pass from your 
hard drive.
Canceling a Record Take
While recording, it is possible to discard the 
current record take. This removes the audio (re-
corded up to that point) from your hard drive 
and deletes the clip from the track’s playlist and 
the Clip List. When using Loop Record mode, all 
takes from each record pass are discarded. Can-
celing recording when in Destructive Record 
mode is prohibited. 

To cancel a record take while recording:

 Press Command+Period (.) (Mac) or Con-
trol+Period (.) (Windows) before the Transport 
is stopped.

Recording Multiple Audio Tracks
Pro Tools can record multiple audio tracks si-
multaneously, up to the track recording limits of 
your system. To record to multiple tracks, con-
figure and record enable each track, then record. 
Follow the same steps as in “Basic Recording 
Steps” on page 461.

For each record-enabled track, a new audio file 
is written to disk, and a new clip is created that 
appears both in the track’s playlist and in the 
Clip List.

If you have a Pro Tools system with multiple 
drives, and you intend to record multiple 
tracks simultaneously, you may want to des-
ignate the System drive as a Transfer only 
drive for optimal performance.
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Recording Shortcuts
In addition to clicking the Record button in the 
Transport or Edit window to arm Pro Tools re-
cording, you can arm and start recording with 
the following keyboard shortcuts:

• Press F12 to start recording immediately.

• Press Command+Spacebar (Mac) or Con-
trol+Spacebar (Windows) to start recording.

• Press 3 on the numeric keypad (when the Nu-
meric Keypad mode is set to Transport) to start 
recording.

Prime for Record Mode
When recording a large number of tracks or 
channels, or playing back a large number of 
tracks while recording, Pro Tools may take a lit-
tle longer to begin recording. To avoid this de-
lay, put Pro Tools in Prime for Record mode be-
fore beginning to record.

On Mac systems, to use F12 for recording, the 
Mac “Dashboard” feature must be 
disabled or remapped. See your User Guide 
for details.

On Mac systems, to use Command+Spacebar 
for recording, the Mac “Spotlight” feature 
must be disabled or remapped. See your User 
Guide for details.

To initiate recording at half speed, press 
Command+Shift+Spacebar (Mac) or Con-
trol+Shift+Spacebar (Windows). For 
details, see “Half-Speed Recording” on 
page 480.
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To enable Prime for Record mode and start 
recording:

1  Click Record in the Transport. The Record but-
ton flashes.

2  Do one of the following:

• Option-click (Mac) or Alt-click (Windows) 
Play in the Transport to put Pro Tools in 
Prime for Record mode.

– or –

• Right-click the Play button and select Prime 

for Record.

The Stop button lights and both the Play and Re-
cord buttons flash.

3  To begin recording instantaneously, click Play. 

4  Click Stop to stop recording.

Setting Punch and Loop 
Points
The start and end points of a record range for 
punch and loop recording can be set by the fol-
lowing methods:

• Select a range in a track’s playlist (with Op-

tions > Link Timeline and Edit Selection en-
abled).

• Select a range in a Timebase ruler.

• Drag the Timeline Selection Markers in the 
ruler.

• Enter start and end times in the Transport 
window.

• Recall a Memory Location that includes an 
Edit selection (with Options > Link Timeline 

and Edit Selection enabled).

When synchronizing to timecode, use Prime 
for Record mode to record or play back large 
numbers of tracks. This decreases the time it 
takes to lock to timecode.



To set the record range in a track’s playlist:

1  If you want to constrain the selection to the 
current Grid value, set the Edit mode to Grid. 

2  Select Options > Link Timeline and Edit Selec-

tion.

3  Do one of the following:

• With the Selector tool, select the record 
range in a track’s playlist.

– or –

• If a clip’s start and end points define the re-
cord range, select the entire clip.

Playlist selection

You can also enter a start and end point 
during playback. Press the Down Arrow to 
set the start point, and press the Up Arrow 
to set the end points. Note that when in Grid 
mode, start and end point when entered in 
this manner do not snap to the grid.
To set the record range in a Timebase ruler:

1  If you want to constrain the selection to the 
current Grid value, set the Edit mode to Grid. 

2  Select the record range in any Timebase ruler.

Timeline Selection Markers
When tracks are record-enabled, Timeline Se-
lection Markers for start and end times appear 
as red up and down arrows in the Main Time-
base ruler. If no tracks are record-enabled, the 
Timeline Selection Markers are blue.

The Timeline Selection Markers can be moved, 
either separately or at the same time, to set re-
cord and play ranges.

Timeline selection

If the Selector tool is not active, you do not 
need to manually select it. Other Edit tools 
(such as the Time Grabber tool) automati-
cally turn into the Selector tool when used in 
Timebase rulers.

Timeline Selection Markers in the Main Timebase 
ruler
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To set the record range by dragging the Timeline 
Selection Markers:

1  If you want the Timeline Selection Markers to 
snap to the current Grid value, set the Edit mode 
to Grid 

2  Drag the first Timeline Selection Marker 
(down arrow) to the start point of the range.

3  Drag the second Timeline Selection Marker 
(up arrow) to the end point of the range.

Start, End, and Length Fields
In its Expanded view, the Transport window can 
display start, end, and length times, and pre- 
and post-roll settings. When setting a record or 
play range, the range is reflected in these fields.

Dragging a Timeline Selection Marker (start time) in 
the Main Timebase ruler

If the current record range is already the 
right length and the range needs only to be 
moved to a new location, Option-drag (Mac) 
or Alt-drag (Windows) either Timeline Se-
lection Marker to move both to a new loca-
tion (while keeping the same length).

Transport window with Start, End, and Length fields 
displayed
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You can enter locations in the start and end 
fields to set the record or play range. The Time-
line Selection Markers in the Main Timebase 
ruler are updated accordingly.

To set the record range by entering start and end 
times in the Transport window:

1  To see the start, end, and length times, do one 
of the following:

• Select View > Transport > Expanded.

– or –

• Shift-click the Expand/Collapse “+” button 
in the Transport window.

2  Do one of the following:

• In the Transport window, click in the Start 
field.

– or –

• Press Option+Forward Slash (/) (Mac) or 
Alt+Forward Slash (/) (Windows) on the 
numeric keypad to select the start field in 
the Transport window.

3  Type in the start location and press Op-
tion+Forward Slash (/) (Mac) or Alt+Forward 
Slash (/) (Windows) on the numeric keypad to 
enter the value and automatically move to the 
end field.

4  Type in the end location and press Enter to ac-
cept the value.

Use the Period (.) or Left/Right Arrow keys 
to move through the different time fields for 
Start and End. Use the Up/Down Arrow keys 
to increase or decrease the numerical val-
ues.



Memory Locations
You can store Edit selections as Memory Loca-
tions, which can also include current pre- and 
post-roll values.

To save an Edit selection with a Memory Location:

1  Ensure that Options > Link Timeline and Edit 

Selection is selected.

2  Set the record range by making an Edit or 
Timeline selection, or by entering start and end 
times in the Transport window.

3  To save the pre- and post-roll values, enable 
and set the pre- and post-roll amounts by enter-
ing them in the Transport window, or by drag-
ging the Pre- and Post-Roll Flags in the ruler 
that represents the Main Time Scale (see “Set-
ting Pre- and Post-Roll” on page 468).

4  Press Enter on the numeric keypad or click the 
Add Marker/Memory Location button in the Edit 
window.

5  In the New Memory Location dialog, set Time 
Properties to Selection, and if saving pre- and 
post-roll values, select the Pre/Post Roll Times 
option in the General Properties section.

For more information on Memory Locations, 
see Chapter 37, “Memory Locations.”
6  Type a name for the new Memory Location.

7  Click OK.

To recall an Edit selection with a Memory Location:

1  Make sure to select Options > Link Timeline and 

Edit Selection.

2  Choose Windows > Memory Locations.

New Memory Location dialog

Memory Locations window
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3  Do one of the following:

• In the Memory Locations window, click the 
name or number of the Memory Location.

– or –

• Recall the Memory Location by typing Pe-
riod (.), the Memory Location number, and 
Period (.) again on the numeric keypad. 
(See “Numeric Keypad Modes” on page 31).

The start and end times and pre- and post-roll 
settings stored with the Memory Location are 
recalled.

Setting Pre- and Post-Roll
Pre- and post-roll times appear as flags in the 
ruler that represents the Main Time Scale. When 
pre- and post-roll are enabled, the flags are 
green, otherwise they are gray.

Pre- and post-roll amounts can be entered in the 
Transport window, set from a track’s playlist or 
Timebase ruler, or by recalling a Memory Loca-
tion.

Green Pre- and Post-Roll Flags (enabled) in the Main 
Timebase ruler
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Setting Pre- and Post-Roll in the 
Transport Window
Pre- and post-roll can be enabled and set in the 
Transport window.

To set and enable the pre- and post-roll times in 
the Transport window:

1  Select View > Transport > Expanded.

2  In the Transport window, click in the pre-roll 
field.

3  Type in the pre-roll amount and press Forward 
Slash (/) on the numeric keypad to enter the 
value and automatically move to the post-roll 
field.

4  Type in the post-roll amount and press Enter 
to accept the new value.

5  To enable either pre- or post-roll, click the ap-
propriate button so it is highlighted.

Pre-roll enabled for 2 beats; Post-roll disabled

Use the Period (.) or Left/Right Arrow keys 
to move through the different time fields for 
pre and post-roll. Use the Up/Down Arrow 
keys to increase or decrease the numerical 
values.



Setting Pre- and Post-Roll in a 
Playlist
You can use the Selector tool to enable and dis-
able pre- and post-roll by clicking in a track’s 
playlist.

To set and enable the pre- and post-roll by clicking 
in a playlist:

1  Select Options > Link Timeline and Edit Selec-

tion.

2  With the Selector tool, select the record range 
in the track’s playlist.

3  With the Selector tool, Option-click (Mac) or 
Alt-click (Windows) in the track’s playlist before 
the selection to enable the pre-roll at that loca-
tion.

4  With the Selector tool, Option-click (Mac) or 
Alt-click (Windows) in the track’s playlist after 
the selection to enable the post-roll at that loca-
tion.

To disable the pre- and post-roll by clicking in a 
playlist:

1  With the Selector tool, Option-click (Mac) or 
Alt-click (Windows) in the Edit selection near 
the start to disable the pre-roll.

2  With the Selector tool, Option-click (Mac) or 
Alt-click (Windows) in the Edit selection near 
the end to disable the post-roll.

3  Drag the Pre-Roll Flag to the Timeline Selec-
tion In Point.

4  Drag the Post-Roll Flag to the Timeline Selec-
tion Out Point.

In the Timeline, you can reset the pre- and 
post-roll to zero. First, drag the Pre-Roll 
Flag to the Timeline Selection In Point, then 
drag the Post-Roll Flag to the Timeline Selec-
tion Out Point.
Enabling Pre/Post-Roll from the 
Options Menu
Pre- and post-roll (as a pair) can be enabled and 
disabled from the Options menu.

To enable both pre/post-roll from the Options 
menu:

 Select Options > Pre/Post-Roll.

Dragging Pre- and Post-Roll 
Flags in the Timebase Ruler
The Pre- and Post-Roll Flags can be moved in 
the Main Timebase ruler, either separately or at 
the same time, to set their location.

To set the pre- and post-roll amounts by dragging 
in the Main Timebase ruler:

1  If you want the Pre- and Post-Roll flags to snap 
to the current Grid value, set the Edit mode to 
Grid.

2  Drag the Pre-Roll Flag to a new location in the 
ruler.

3  Drag the Post-Roll Flag to a new location in the 
Timebase ruler.

Dragging a Pre-Roll Flag in a Timebase ruler

To set pre- and post-roll values to the same 
amount, Option-drag (Mac) or Alt-drag 
(Windows) either the Pre- or the Post-Roll 
Flag in the ruler. The deselected flag will 
immediately reset to the same value, and 
will adjust accordingly as you drag the 
selected flag.
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Audio Punch Recording Over 
a Specified Range
You can set Pro Tools to automatically punch re-
cord over a specific range in an audio track (for 
example, to replace a portion of a recorded 
track). The range’s start (punch in) and end 
(punch out) points must be specified before re-
cording.

Though there are several ways to set record and 
play ranges (see “Setting Punch and Loop 
Points” on page 464), perhaps the easiest is to 
select within the track’s playlist the range for re-
cording.

During the recording process, playback begins 
at the pre-roll time (if enabled) and proceeds to 
the start time (the punch-in point), where re-
cording begins. When the end time (the punch-
out point) is reached, Pro Tools automatically 
switches out of Record mode and continues 
playing through the specified amount of 
post-roll. This automated punch-in/out feature 
is a powerful and precise way of recording or 
re-recording on a track.

To manually punch in and out on record-
enabled audio tracks during playback, see 
Chapter 24, “Punch Recording Modes.”

To set a record or play range by selecting 
within a playlist, the Edit and Timeline se-
lections must be linked (select Options > 
Link Timeline and Edit Selection).
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To punch record on an audio track:

1  Do one of the following:

• To record nondestructively, make sure that 
Options > Destructive Record is not selected.

– or –

• If you do want to permanently record over 
the specified record range, select Options > 

Destructive Record.

2  Record enable the track.

3  Select Options > Link Timeline and Edit Selec-

tion.

4  With the Selector tool, drag in the track’s play-
list or in one of the Timebase rulers until the se-
lection encompasses the punch range (see 
“Setting Punch and Loop Points” on page 464).

Timeline selection for punch recording with Pre-roll 
and Post-roll

If you are recording in any mode other than 
Destructive Record mode, punches do not 
permanently replace previously recorded 
material. If you do want to permanently re-
cord over the specified record range (and 
keep only the most recent take), select 
Options > Destructive Record.

Punch In Punch Out 

Pre-roll flag Post-roll flag

Pre-roll 
enabled

Post-roll 
enabled



5  To hear any existing track material up to the 
start point, or after the end point, enable and set 
pre- and post-roll times (see “Setting Pre- and 
Post-Roll” on page 468).

6  Click Record in the Transport to arm Pro Tools 
for recording.

7  Click Play to start recording.

Pro Tools starts recording from the punch-in 
(start) point. If there is any pre-roll, recording 
starts when the punch-in (start) point is 
reached. Recording continues until the punch-
out (end) point is reached (unless you manually 
stop recording first). If post-roll is enabled, 
playback continues for the specified post-roll 
amount.

If recording nondestructively, a new audio file is 
written to your hard drive and a new audio clip 
appears both in the track and the Clip List.

If recording in Destructive Record mode, the 
new audio overwrites the previous material in 
the existing audio file and clip.

Monitoring during Punch-Ins

Pro Tools provides two monitoring modes for 
recording: Auto Input monitoring and Input 
Only monitoring (see “Selecting a Record Input 
Monitoring Mode” on page 456).

Recording Additional Takes
After recording to an audio track, you can re-
cord additional takes to the same track. Any of 
these additional takes can be used in the main 
playlist. For information about accessing alter-
nate takes, see “Alternate Takes” on page 475.
Recording additional takes in Destructive Re-
cord mode overwrites previous take. To keep the 
audio from previous takes, record the new takes 
in Normal (Nondestructive) Record mode.

To nondestructively record a new take on the same 
track:

1  Ensure that Normal Record mode is selected 
(see “Record Modes” on page 445).

2  Record enable the track.

3  Do one of the following:

• To record from the beginning of the ses-
sion, click Return to Zero in the Transport.

– or –

• If Options > Link Timeline and Edit Selection 
is enabled, click anywhere in the track’s 
playlist to begin recording from that point.

4  Click Record in the Transport to arm Pro Tools 
for recording.

5  Click Play to start recording.

6  Click Stop to stop recording.

An audio file for the new take is written to disk 
and appears as an audio clip both in the track’s 
playlist and in the Clip List.

The audio from the original take remains on 
your hard drive, and is still available as a clip in 
the Clip List.

For information on audio file and clip 
names for new takes, see “Configuring De-
fault Names for Audio Files and Clips” on 
page 448.

To record a specific track range, with pre-
cise start and end points, see “Audio Punch 
Recording Over a Specified Range” on 
page 470.
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To destructively record over a previous take:

1  Do one of the following:

• Select Options > Destructive Record. When 
in Destructive Record mode. 

– or –

• Right-click the Record button in the Trans-
port and select Destructive.

A “D” appears in the Record button.

2  Record enable the track.

3  Do one of the following:

• To record from the beginning of the track, 
click Return to Zero in the Transport.

– or –

• If Options > Link Timeline and Edit Selection 
is enabled, click anywhere in the track’s 
playlist to begin recording from that point.

4  Click Record in the Transport to arm Pro Tools 
for recording.

5  Click Play to start recording.

6  When finished, click Stop to stop recording.

The audio for the new take is written to disk, 
permanently overwriting the original. The new 
material replaces the original material within 
the existing clip and the clip is not renamed.

Destructive Record mode enabled

To record a specific track range, with pre-
cise start and end points, see “Audio Punch 
Recording Over a Specified Range” on 
page 470.
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Appending New Material to the 
End of a Track
You can also append new material to the end of 
a track. 

To append new material to the end of a track:

1  Do one of the following:

• Click the Go to End button in the Transport 
to locate to the end of the track (this locates 
the end of the session).

– or –

• Tab to the end point of the last clip on the 
track.

2  From there, begin recording. 

Pro Tools adds the new material to the end of 
the track. If using Destructive Record mode, the 
new audio is appended to the audio file and clip 
from the first take. In Nondestructive Record 
mode, a new file and clip are created.

Recording to a New Playlist
Instead of recording over existing audio clips, 
there is another way to nondestructively record 
new takes to the same track. Do this by creating 
a new playlist for the track, then record just as 
before.

Tracks can have multiple edit playlists, each of 
which stores a list of clips strung together in a 
particular order. Also, since playlists follow 
groups, duplicating or selecting alternate play-
lists for a track in an enabled group will affect all 
tracks in the group.



To record to a new playlist for a track:

1  From the track’s Playlist selector, choose New.

2  Type a name for the new playlist. 

3  Click OK.

When a new playlist is created, its name replaces 
the track name. Names for new audio files and 
clips are based on the track name.

4  Record enable the track.

5  To start from the beginning of the session, 
click Return to Zero in the Transport.

6  Click Record in the Transport to arm Pro Tools 
for recording.

7  Click Play to start recording.

8  Click Stop to stop recording.

An audio file for the new take is written to disk 
and appears as an audio clip both in the track’s 
new playlist and in the Clip List.

Selecting a previous playlist from track’s Playlist 
selector recalls its clips as they previously ap-
peared in the track. At any time, all clips from 
all playlists are available in the Clip List, and 
can be mixed and matched between playlists and 
tracks.

Playlist selector

For more information on playlists and play-
list editing, see “Playlists” on page 633.
Loop Recording Audio
Pro Tools provides a loop recording feature that 
lets you record take after take while the same 
section of audio repeats over and over. This is a 
convenient technique for quickly recording 
multiple takes of a part without losing sponta-
neity.

When loop recording, you must first specify the 
start and end points for the loop. Though there 
are several ways to set record and play ranges 
(see “Setting Punch and Loop Points” on 
page 464), the easiest is to select the range to be 
looped in the track’s playlist (ensure that Op-

tions > Link Timeline and Edit Selection is se-
lected).

The pre-roll setting, if enabled, is used only dur-
ing the first record pass. Pre- and post-roll times 
are ignored on each successive loop. To compen-
sate for this, you may want to make the loop 
range slightly longer. Later, you can trim back 
the recorded takes to the proper length with the 
Trim tool (see “Using the Trim Tools” on 
page 553).

When loop recording audio, Pro Tools creates a 
single audio file that includes all takes. Takes 
appear as individual clips in the Clip List and are 
numbered sequentially. Once you stop record-
ing, you can audition any of the recorded takes.

To use alternate takes created with Loop Re-
cord in other sessions (such as when 
using Import Session Data), export clip def-
initions (see “Exporting Clip Definitions” 
on page 347). If clip definitions are not ex-
ported, alternate takes created with Loop 
Record will be inaccessible when imported 
into another session. 
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To loop record an audio track:

1  Do one of the following:

• Select Options > Loop Record. When Loop 
Record mode is enabled, a loop symbol ap-
pears in the Record button.

– or –

• Right-click the Record button in the Trans-
port and select Loop.

2  Record enable the audio track by clicking its 
Record Enable button.

3  Select Options > Link Timeline and Edit Selec-

tion.

4  With the Selector tool, select the loop range on 
the track. For other methods of setting the re-
cord range, see “Setting Punch and Loop Points” 
on page 464.

5  To hear track material up to the start point of 
the loop, enable pre-roll and set the pre-roll time 
(see “Setting Pre- and Post-Roll” on page 468).

6  Click Record in the Transport to arm Pro Tools 
for recording.

7  Click Play to start recording.

The Record button flashes during the pre-roll. 
When the start point is reached, Pro Tools be-
gins recording. When the end point is reached, 
Pro Tools loops back to the start time and con-
tinues recording.

8  To cancel all recorded takes while loop record-
ing, press Command+Period (.) (Mac) or Con-
trol+Period (.) (Windows).

9  When finished, click Stop to stop recording.

Loop Recording enabled
Pro Tools Reference Guide
If you stop recording before you reach the mid-
point of the loop, Pro Tools discards that take. If 
you record more than half of the looped take, 
Pro Tools leaves the take in the track when you 
stop recording.

The recorded takes appear as clips in the Clip 
List and are numbered sequentially. The most 
recently recorded take appears in the active 
playlist on the track. For details on auditioning 
the different takes, see “Selecting Alternate 
Takes” on page 475.

Loop Playback and Audio Recording

Pro Tools ignores Loop Playback when record-
ing. The only way to loop while recording is to 
enable Loop Record mode.

Automatically Create New 
Playlists When Loop Recording
When loop recording, Pro Tools creates a single 
file containing all recording passes where each 
recording pass is a clip in the file. On the track, 
only the last recording pass is present as a clip in 
the main playlist. All other clips (recording 
passes) are hidden and can only be recalled as 
matching alternate clips (takes). When enabled, 
the new Automatically Create New Playlists When 

Loop Recording option in the Operation Prefer-
ences page automatically copies each clip (take) 
to a new playlist in the track. This facilitates us-
ing Playlists view for auditioning and selecting 
alternate takes.

To automatically create new playlists when loop 
recording:

1  Choose Setup > Preferences and click the Op-

eration tab.

2  In the Recording section, enable the Automati-

cally Create New Playlists When Loop Recording 
option.



Alternate Takes
When punch recording or loop recording, 
Pro Tools creates matching alternate takes 
(clips). Pro Tools lets you exchange clips in the 
main playlist on tracks with matching alternate 
clips from other playlists associated with the 
same track, from other tracks, or from the Clip 
List. Matching alternate clips are clips that meet 
certain criteria, for example, clips that have the 
same User Time Stamp match (see “Matching Al-
ternate Clips” on page 644).

Selecting Alternate Takes
After recording multiple takes with loop or 
punch recording, you can replace the current 
take in the track’s active playlist with any of the 
previous takes. All takes are numbered sequen-
tially. 

Selecting Alternate Takes from the Clip 
List

To select a take from the Clip List:

1  In the Edit window, select the current clip 
(take) with the Time Grabber tool.

2  Option-click (Mac) or Alt-click (Windows) 
different clips in the Clip List to audition them.

3  Control-drag (Mac) or Start-drag (Windows) 
the clip you want from the Clip List into the 
playlist.

The clip replaces the previous take and snaps 
precisely to the correct location.
Selecting Alternate Takes on a Track

Each clip resulting from a punch or loop record 
pass has an identical start time (the User Time 
Stamp). You can select and audition alternate 
takes from the Right-click Matches submenu or 
the Alternate Takes pop-up menu—even during 
playback. 

To select an alternate take:

1  Ensure that Track ID (or Track Name) is se-
lected and that Clip Start is selected in the 
Matching Criteria window (see “Matching Crite-
ria Window” on page 476).

2  Do one of the following:

• Right-click the clip with the Selector or the 
Grabber tool, and select a matching alter-
nate take from the Matches submenu in the 
pop-up menu.

• If the take currently residing in the track is 
selected, Command-click (Mac) or Control-
click (Windows) anywhere on the selected 
take with the Selector tool, and select a dif-
ferent take from the Alternate Takes pop-up 
menu.

• With the Selector tool, Command-click 
(Mac) or Control-click (Windows) at the 
precise beginning of the loop or punch 
range and select a different take from the 
Alternate Takes pop-up menu.

Right-click Matches submenu
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The selected matching alternate clip (take) re-
places the clip in the main playlist and snaps 
precisely to the correct location.

One way to ensure that subsequent recording 
takes have the same User Time Stamp (and as 
such can be available as matching alternate 
clips) is to store punch and loop record selec-
tions as Memory Locations. Then, if you later 
need to record additional takes, recall the corre-
sponding Memory Location. 

To change the User Time Stamp of other clips so 
that they can be available as alternate matching 
clips for a specific location, use the Time Stamp 
command in the Clip List menu. 

Matches and Multiple Tracks
If you have loop recorded on multiple tracks, 
and each track contains multiple takes with 
identical User Time Stamps, you can change all 
takes simultaneously.

To switch takes for multiple tracks:

1  Configure the Matching Criteria window (see 
“Matching Criteria Window” on page 476), so 
that the following options are enabled:

• Track Name 

– and –
• Selection Range

Alternate Takes pop-up menu
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2  With the Selector tool, select the take range for 
each track you want to replace.

3  Do one of the following:

• Right-click the Edit selection and select a 
different matching alternate take from the 
Matches submenu.

– or –

• Command-click (Mac) or Control-click 
(Windows) the Edit selection and select a 
different take from the Alternates pop-up 
menu.

The selected take replaces the previous take and 
snaps precisely to the correct location on each 
track.

Matching Criteria Window
The Matching Criteria window lets you select 
the criteria for matching alternate clips. This 
lets you refine the list of available matching 
clips in the Alternate Takes pop-up menu and 
Clip Right-click Matches submenu.

Matching Criteria window

Matching Criteria affects MIDI as well as 
audio clips.



Alternates Match Options

The following Alternates Match options can be 
selected in any combination:

Track ID Any clips recorded to the same track 
are considered matching. Use this option for se-
lecting alternate takes from loop or punch re-
cording.

Track Name Any clips that share the same root 
name with the track or playlist are considered 
matching. For example, the Matches for a track 
named “Gtr.L” would show the clips “Gtr.L_01” 
and “Gtr.L_02-01,” but not “Guitar.L_01.” 

Clip Rating Any clips that have the same Rating 
are considered matching. Enable this option if 
you have rated clips (see “Rating Clips” on 
page 613). 

In Addition To Match Options

The following In Addition To Match options are 
mutually exclusive.

All Any clips that include the time location of 
the Edit cursor; or any clips that are either 
partly or fully within the current time range of 
the Edit selection.

Clip Start Any clips that have the same start time 
as the time location of the Edit cursor or Edit se-
lection.

Clip Start and End Any clips that have the same 
start and end times as the Edit selection.

Selection Range Any complete clips that are en-
tirely within the Edit selection.

None No other criteria in addition to the se-
lected Alternates Match options are used to fil-
ter matching alternate clips.
Expanding Alternate Takes to 
New Playlists or Tracks
Pro Tools lets you copy alternate takes to new 
playlists or tracks. This is especially useful for 
auditioning, editing, and mixing multiple alter-
nate takes or channels. Alternate takes are cre-
ated when punch and loop recording.

Expanding Alternate Takes to New 
Playlists

Expanding alternate takes to new playlists read-
ily facilitates track compositing. Once you have 
expanded alternate takes to new playlists on a 
track, you can audition and edit them in Play-
lists view to assemble the best takes in the main 
playlist.

To expand alternate takes to new playlists:

1  Identify the clip on the main playlist with 
matching alternate clips (takes). 

2  Do one of the following:

• Right-click the clip and choose Matches > 

Expand Alternates To New Playlists.

• If the clip is selected, with the Selector tool, 
Command-click (Mac) or Control-click 
(Windows) anywhere on the selected clip 
and choose Matches > Expand Alternates To 

New Playlists.

• If the clip is not selected, with the Selector 
tool, Command-click (Mac) or Control-
click (Windows) at the precise beginning of 
the loop or punch range and choose 
Matches > Expand Alternates To New Play-

lists.
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All matching alternate clips are copied to new 
playlists on the track. To view all playlists for 
the track, select Playlists view. In any track 
view, you can also select any available alternate 
playlist as the main playlist from the Playlist se-
lector. For more information, see “Playlists 
View” on page 639.

Expanding Alternate Takes to New 
Tracks

Expanding alternate takes to new tracks readily 
facilitates auditioning, editing, and mixing al-
ternate takes, each on separate tracks.

To expand alternate takes to new tracks:

1  Identify the clip on the main playlist with 
matching alternate clips (takes). 

2  Do one of the following:

• Right-click the clip and choose Matches > 

Expand Alternates To New Tracks.

• If the clip is selected, with the Selector tool, 
Command-click (Mac) or Control-click 
(Windows) anywhere on the selected clip 
and choose Matches > Expand Alternates To 

New Tracks.

• If the clip is not selected, with the Selector 
tool, Command-click (Mac) or Control-
click (Windows) at the precise beginning of 
the loop or punch range and choose 
Matches > Expand Alternates To New 

Tracks.

3  Then choose one of the following from the Ex-
pand Alternates To New Tracks sub-menu:

By Track Name Names all new tracks after the 
source track name.

By Clip Name Names each new tracks after the 
corresponding original clip names that you see 
in the Matches list.
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By Track and Clip Name Names all new tracks 
after the source track name, but with the corre-
sponding original clip names in parenthesis.

All matching alternate clips are copied to new 
tracks.

Recording from a Digital 
Source
If you plan to use a DAT player, digital-output 
CD recorder, or other digital device with your 
Pro Tools system, make sure it supports the cor-
rect digital format. For example, your Pro Tools 
audio interface’s AES/EBU inputs and outputs 
should only be connected to another AES/EBU 
device.

Avid HD Audio Interface Digital 
Options
The HD I/O, HD OMNI, 192 I/O, 192 Digital I/O, 
and 96 I/O include AES/EBU, S/PDIF, and ADAT 
digital options. Additionally, the HD I/O with a 
Digital Expansion card, 192 I/O, and 
192 Digital I/O include TDIF digital I/O options. 
The 96i I/O includes only the S/PDIF digital op-
tion.

HD MADI includes both optical and coaxial 
MADI I/O (for more information, see the 
HD MADI Guide). 

On HD I/O, HD OMNI, 192 I/O, 192 Digital I/O, 
or 96 I/O, Pro Tools can receive digital audio 
from the factory-installed Optical (ADAT) I/O at 
any time (if it is not set to S/PDIF). However, 

For additional information on configuring 
your particular Pro Tools system for record-
ing from a digital source, see your User 
Guide.



Pro Tools can only receive digital audio from 
one of its enclosure [Encl] digital sources—
AES/EBU, S/PDIF, or Optical (S/PDIF)—at a 
time.

Enclosure digital sources come standard with 
Avid HD audio interfaces and are labelled on-
screen as [Encl] versions, to differentiate them 
from digital inputs and outputs available on the 
Digital card installed in HD I/O or 192 I/O. For 
example, the AES/EBU inputs and outputs that 
come standard in the 192 I/O enclosure are 
identified as AES/EBU [Encl].

The additional digital ports on the HD I/O, 
192 I/O and 192 Digital I/O are TDIF, AES/EBU, 
and ADAT. Pro Tools can only receive digital 
audio from one of these ports at a time.

However, inputs on both the HD I/O and 192 I/O 
enclosure I/O and Digital card can be used si-
multaneously. For example, on an HD I/O, it is 
possible to clock off a source from one of the en-
closure inputs and have another digital input 
from the digital ports doing a sample rate con-
version, thus having two digital sources.

Pro Tools Audio Interface Digital 
Options
003, 003 Rack, 003 Rack+, Digi 002, and 
Digi 002 Rack include S/PDIF and ADAT 
digital I/O. 

Eleven Rack includes S/PDIF and AES/EBU 
digital I/O.

Mbox (3rd generation), Mbox 2, Mbox Pro, and 
Mbox Pro 2 include only the S/PDIF digital op-
tion.

All digital outputs are active at all times, so you 
can actually send digital audio to different digi-
tal devices simultaneously at mix time. 
Recording from Digital Sources

To record from a digital source with Pro Tools:

1  Connect the digital output of the recording 
source to the appropriate digital input of your 
audio hardware.

2  If you want to start a new session with a differ-
ent sample rate, do the following:

• Choose File > New Session

• Select the sample rate.

• Configure the rest of the New Session dia-
log accordingly.

• Click Save.

3  Specify the format (digital) of the inputs of the 
audio interface to which the digital recording 
source is connected: 

• Choose Setup > Hardware.

• Choose the audio interface.

• Select the digital format for the appropriate 
channel pair (such as AES/EBU or S/PDIF). 

4  For Pro Tools HD, select the appropriate Clock 

Source in the Session Setup window or Hardware 
Setup dialog.

5  Create a new stereo audio track.

6  Assign the Input Path selector for the track to 
the appropriate input. Since this is a digital 
transfer, you do not need to worry about input 
levels.

Some Pro Tools audio interfaces only have 
two channels that can be set for analog or 
digital. For example, Mbox (3rd generation) 
has S/PDIF L–R (Stereo) digital inputs and 
In 1–2 analog inputs. Mbox (3rd genera-
tion) can record through analog and digital 
inputs simultaneously. 
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7  Assign the Output Path selector for the track to 
the appropriate output for monitoring (such as A 
1–2). 

8  In the Options menu, ensure that the following 
options are deselected: Destructive Record, 
Loop Record, QuickPunch, TrackPunch, and De-
structivePunch.

9  To have recording start from the beginning of 
the session, click Return to Zero in the Trans-
port.

10  Record enable the new audio track.

11  Click Record in the Transport to arm 
Pro Tools for recording.

12  Click Play to start recording.

13  Start playback on the recording source.

14  When the material from the source has fin-
ished, click Stop in the Transport.

15  Stop playback on the recording source.

After a Digital Transfer
(Pro Tools|HD Systems Only)

After you have finished recording digitally, set 
the Clock Source pop-up menu in the Session 
Setup window back to Internal. Otherwise, 
Pro Tools will not switch back to its own inter-
nal clock and may not record or play audio prop-
erly. Failure to switch back to Internal synchro-
nization typically results in pitch problems (fast 
or slow playback), clicks and pops, or DAE er-
rors, since a DAT machine or CD Recorder that 
is idle can default to a different sample rate or 
stop outputting a sample rate clock altogether.
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Half-Speed Recording
Pro Tools lets you play and record at half-speed. 
This capability is similar to that of a tape deck 
where you can record material at half-speed and 
then play it back at normal speed (faster and up 
an octave), or record material at normal speed 
and play it back at half-speed (slower and down 
an octave), for special effects.

Use half-speed recording to record difficult to 
play MIDI tracks or to record complex automa-
tion moves. 

To record at half-speed:

1  Record enable the tracks you want to record at 
half-speed.

2  Click Record in the Transport to arm Pro Tools 
for recording.

3  Press Command+Shift+Spacebar (Mac) or 
Control+Shift+Spacebar (Windows). Recording 
begins and all existing track material plays at 
half-speed.

4  When you have finished recording, click Stop.

For information on Half-Speed Playback, 
see “Half-Speed Playback Mode” on 
page 428.



Chapter 23: MIDI Recording
Although recording MIDI in Pro Tools is similar 
to recording audio, there are some important 
differences:

 Unlike audio, MIDI recording is almost always 
destructive. See “Record Modes and MIDI” on 
page 447 for details.

 Unlike audio tracks, MIDI and Instrument 
tracks can be record-enabled on-the-fly during 
playback or recording.

 MIDI and Instrument tracks have an Input se-
lector that determines which port on your MIDI 
interface (devices) and which MIDI channel is 
routed and recorded to the track. If the MIDI In-
put selector is set to All, all channels for all de-
vices are routed to the track. 

 Similar to Auxiliary Inputs, Instrument tracks 
have audio Input and Output selectors. These se-
lectors are different than the Instrument track’s 
selectors for MIDI Input and Output and are pri-
marily used for monitoring audio from MIDI in-
struments or instrument plug-ins. 

 It is not necessary to use QuickPunch, Track-
Punch, or DestructivePunch to punch in on-the-
fly with MIDI or Instrument tracks. This capa-
bility is available both in Normal (Nondestruc-
tive) Record mode and Destructive Record 
mode.
Recording from MIDI Devices
The MIDI Inputs for record-enabled MIDI and 
Instrument tracks determine what MIDI data is 
recorded in Pro Tools. MIDI Inputs can be set to 
a specific device (port) and channel, or they can 
be set to All, where all channels for all devices 
are merged to the track.

MIDI and Instrument tracks in Pro Tools do not 
contain multiple channels and always play back 
on the track’s assigned MIDI output device and 
channel. Multiple MIDI devices and channels 
can be simultaneously recorded to multiple 
tracks.

The following Pro Tools options determine 
whether you can record from a MIDI controller 
(such as a MIDI keyboard or drum pad):

 Devices that are assigned as a MIDI Controller 
in the Peripherals dialog (Setup > Peripherals) 
are ignored when MIDI tracks are recorded. This 
is to avoid recording data from MIDI control 
surfaces (such as Command|8).

 To record and play MIDI, the device must be 
enabled in the MIDI Input Enable dialog. For 
more information, see “Enabling Input Devices” 
on page 482.
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In addition, the following options affect how 
MIDI data is recorded in Pro Tools:

 The MIDI Input Filter can filter out MIDI mes-
sages that you may not want to record, such as 
Polyphonic Aftertouch or System Exclusive data. 
For more information, see “MIDI Input Filter” 
on page 484.

 Input Quantize, when enabled, automatically 
quantizes (time corrects) all MIDI notes that are 
recorded. For more information, see “Input 
Quantize” on page 484.

Enabling Input Devices
To record from a MIDI device (such as a MIDI 
keyboard) in Pro Tools, the device must be en-
abled in the MIDI Input Enable dialog. You can 
also use this dialog to make sure unwanted notes 
from certain devices, such as drum machines or 
arpeggiators, are not recorded.

MIDI Control Surfaces In order to use any MIDI 
control surfaces (such as Command|8), they 
must be enabled in the MIDI Input Enable dia-
log.

MMC In order for Pro Tools to synchronize to 
MIDI Machine Control (MMC), the MMC source 
must be enabled in the MIDI Input Enable dia-
log. For more information on using MMC with 
Pro Tools, see “Using MIDI Machine Control” 
on page 1155.
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To enable input devices:

1  Choose Setup > MIDI > Input Devices.

2  In the MIDI Input Enable dialog, do the fol-
lowing:

• Select the MIDI devices you want to record. 
Also, select any device to be used as a con-
trol surface.

– and –

• Deselect any input devices you want to ig-
nore while recording MIDI.

3  Click OK.

MIDI Input Enable dialog

Devices do not need to be selected to receive 
MIDI data from Pro Tools. For example, a 
device used exclusively as a sound module 
does not need to be selected in the MIDI In-
put Enable dialog.



MIDI Thru
To monitor MIDI tracks while recording, enable 
MIDI Thru. When enabled, Pro Tools routes 
MIDI from your controllers to the device and 
channels assigned to the currently record-en-
abled MIDI track.

To enable MIDI Thru:

 Select Options > MIDI Thru.

The MIDI preference for Global MIDI Play-
back Offset and individual MIDI track off-
sets do not affect MIDI routed with MIDI 
Thru.

When MIDI Thru is enabled, System Exclu-
sive (Sysex) events are echoed to the MIDI 
device assigned to the record-enabled 
track—but only if the Sysex events are 
smaller than 256 bytes.

When using MIDI Thru, you should disable 
Local Control, if present, on your MIDI 
devices. Otherwise, your MIDI device may 
receive double MIDI notes, which can lead 
to stuck notes. If you are unsure how to dis-
able Local Control for your instrument, see 
the manufacturer’s documentation.
The Default Thru Instrument
In addition to any MIDI tracks that are record-
enabled, you can also route MIDI to the Default 
Thru Instrument. This saves the extra steps of 
creating a MIDI track and record enabling it to 
hear a particular MIDI device and channel.

Unlike MIDI tracks, which only receive MIDI 
from the device and channel assigned to its 
MIDI Input selector, all incoming MIDI data is 
routed to the Default Thru Instrument.

If the Default Thru Instrument is assigned to a 
record-enabled MIDI track, Pro Tools only 
routes incoming MIDI to the record-enabled 
track.

To configure a default Thru instrument:

1  Choose Setup > Preferences. 

2  Click the MIDI tab. 

3  Do one of the following:

• Select a specific device from the Default 

Thru Instrument pop-up menu to play MIDI 
through on that device by default. 

• Select Follows First Selected MIDI Track to 
have MIDI preview assignment follow MIDI 
track selection. When multiple MIDI tracks 
are selected, previewing uses the topmost 
MIDI track in the Edit window or the left-
most MIDI track in the Mix window. 

• To disable the Default Thru Instrument, se-
lect None.

The Default Thru Follows First Selected 
MIDI Track Selection option also lets you 
play an instrument without having to create 
and record-enable a MIDI or Instrument 
track.
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MIDI Input Filter
Use the MIDI Input Filter to prevent certain 
types of MIDI messages from being recorded. 
The MIDI Input Filter can be set to record All 
messages, Only the specified messages, or All Ex-

cept the specified messages.

For example, to filter out program changes:

1  Choose Setup > MIDI > Input Filter.

2  In the MIDI Input Filter dialog, select the All 

Except option.

3  Select the option for Program Changes. Leave 
all other messages deselected.

4  Click OK.

When using the All Except option, the selected 
types of MIDI messages are not recorded. Con-
versely, when using the Only option, only the se-
lected types of MIDI messages are recorded.

MIDI Input Filter dialog
Pro Tools Reference Guide
Input Quantize
When Input Quantize is enabled in the Input 
Quantize Event Operations dialog (Event > Event 

Operations > Input Quantize), all recorded MIDI 
notes are quantized automatically. Quantizing 
MIDI on input is useful for achieving rhythmi-
cally precise MIDI recordings. However, to pre-
serve all of the original nuance of your recorded 
MIDI tracks (such as rubato phrasing), disable 
this option.

Wait for Note
The Wait for Note button, located in the Trans-
port window, determines how Pro Tools begins 
recording. When enabled, Pro Tools does not 
start recording until a MIDI event is received. 
This ensures that recording begins only when 
you start playing, and that the first note, or 
other MIDI data, is recorded precisely at the be-
ginning of the set record range (start time).

Wait for Note can be used when recording nor-
mally, when punching in, or when loop record-
ing. If pre-roll is enabled, it occurs after the 
MIDI event is received and before recording be-
gins.

For more information on Input Quantize, 
see “Input Quantize Command” on 
page 933. 

Wait for Note and Countoff are mutually 
exclusive and cannot both be enabled at the 
same time. If, for instance, Countoff is 
enabled and you click the Wait for Note but-
ton, Countoff is disabled. Furthermore, 
Wait for Note starts recording immediately, 
ignoring any specified Pre-roll.



To enable Wait for Note:

1  To view the MIDI controls in the Transport 
window, select View > Transport > MIDI Controls.

2  In the Transport window, click the Wait for 
Note button so it becomes highlighted.

Transport window with MIDI Controls

Wait for Note button, enabled

With the Operation preference for “Use F11 
for Wait for Note” enabled, you can press 
F11 to turn on Wait for Note. (On Mac sys-
tems, the Mac “Desktop” keyboard shortcut 
must be disabled or remapped.)
MIDI Merge/Replace
The MIDI Merge button, located in the Trans-
port window, determines how MIDI is recorded 
when overdubbing or punching in. When MIDI 
Merge is on (Merge mode), recorded MIDI is 
merged with existing track material. When 
MIDI Merge is off (Replace mode), existing data 
within the punched clip is replaced by the newly 
recorded material.

The MIDI Merge button can be turned on and off 
during playback and recording. In Loop Record 
mode, MIDI Merge has no effect, and the button 
is dimmed.

To enable MIDI Merge:

1  To view the MIDI controls in the Transport 
window, select View > Transport > MIDI Controls.

2  In the Transport window, click the MIDI Merge 
button so it becomes highlighted.

To enable MIDI Merge with a keyboard 
shortcut, set the Numeric Keypad mode to 
Transport, and press the 9 key on the nu-
meric keypad. 

You can also paste and merge MIDI notes 
using Paste Special commands. See “Special 
Paste Function for Automation Data” on 
page 1056.

MIDI Merge button, enabled
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Configuring MIDI or 
Instrument Tracks for 
Recording
To configure one or more MIDI or Instrument 
tracks for recording:

1  Create a new MIDI or Instrument track, or use 
an existing MIDI or Instrument track.

2  For Instrument tracks, select View > Mix 

Window > Instruments or View > Edit Window > 

Instruments.

3  From the track’s MIDI Input selector, select the 
device and channel to be recorded. (For Instru-
ment tracks, the MIDI Input selector is available 
in Instruments view.)

4  From the MIDI Output selector, select the de-
vice and channel for MIDI playback.

MIDI track Input selector

Instrument track MIDI Input selector
Pro Tools Reference Guide
5  To assign multiple destinations to a single 
MIDI or Instrument track, Control-click (Mac) 
or Start-click (Windows) the MIDI Output selec-
tor and select additional channels from any de-
vice. When multiple destinations are selected for 
a single MIDI track, a plus sign (“+”) appears 
next to the first destination name in the track’s 
MIDI Output selector.

6  To assign a default program change to the 
track, do the following:

• Click the Patch Select button.

• Make the necessary selections for program 
and bank select.

• Click Done.

MIDI track Output selector, Mix window

Instrument track MIDI Input selector, Mix window

Default program changes are sent whenever 
the track is played. For more information, 
see “Patch Select (Program and Bank 
Changes)” on page 700.



7  If recording to multiple MIDI or Instrument 
tracks, repeat the preceding steps for each track, 
then continue to the next step.

8  To use a click, enable and configure the click, 
and set a default tempo and meter for the session 
(see “Recording with a Click” on page 440).

9  Enable either Wait for Note or Countoff in the 
Transport window. 

10  To replace existing track material, disable 
MIDI Merge in the Transport window (see “MIDI 
Merge/Replace” on page 485).

11  To automatically quantize material as it is re-
corded, enable Input Quantize (Event > Event Op-

erations > Input Quantize). See “Input Quantize” 
on page 484.

12  To start recording from the beginning of the 
session, click Return to Zero in the Transport.

13  Record enable the MIDI or Instrument track 
by clicking its Record Enable button.

14  Make sure that Options > MIDI Thru is se-
lected, then play your MIDI controller. The 
MIDI device or instrument plug-in assigned to 
the track’s MIDI Output sounds, and the track’s 
meters register MIDI activity (note velocity).

You are now ready to record MIDI data to the re-
cord-enabled MIDI and Instrument tracks.

To record enable additional MIDI and In-
strument tracks, Shift-click their Record En-
able buttons.

To monitor audio from an external MIDI 
instrument, select the corresponding audio 
Input Path for your MIDI instrument on the 
Instrument track (or use an Auxiliary Input 
track). See “Signal Routing for Monitoring 
and Submixing” on page 970.
Recording MIDI and 
Instrument Tracks
In Pro Tools, you can record to one or more 
MIDI and Instrument tracks. Recording simul-
taneously to multiple tracks lets you:

• Record from multiple MIDI devices at the 
same time, such as when recording several 
performers.

• Record multiple channels from the same de-
vice, such as recording from a split keyboard.

• Transfer MIDI tracks from an external MIDI 
sequencer.

To record to one or more MIDI or Instrument 
tracks:

1  Configure a MIDI or Instrument track for re-
cording (see “Configuring MIDI or Instrument 
Tracks for Recording” on page 486).

2  Ensure that the track to which you want to re-
cord is record enabled.

To take full advantage of the MIDI editing 
capabilities in Pro Tools, make sure to re-
cord tick-based MIDI tracks with a click. 
This ensures that recorded data aligns with 
the session’s bar and beat boundaries. You 
can also record to sample-based MIDI tracks 
without a click and derive the tempo and 
meter from the performance.

To record audio from a MIDI instrument or 
instrument plug-in, bus the audio output of 
the Instrument or Auxiliary Input track that 
is monitoring the instrument to an audio 
track. Record enable the audio track and 
start recording. See “Recording Audio from 
a MIDI Instrument” on page 496.
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3  Ensure that Normal Record mode is selected 
(see “Record Modes” on page 445).

4  Click Record in the Transport to arm Pro Tools 
for recording (Record Ready mode). The Track 
Record Enabled indicator lights red.

5  Do one of the following:

• Click Play to start recording. If using 
Countoff, Pro Tools counts off the specified 
number of measures and then begins re-
cording. 

– or –

• If Wait for Note is enabled, do not click the 
Play button; recording will begin automati-
cally as soon as you start playing (when a 
MIDI event is received).

6  Play your MIDI controller.

7  When you are finished playing, click Stop in 
the Transport to stop recording.

For each record-enabled track, a new MIDI clip 
is created and appears both in the playlist and in 
the Clip List.

To record enable additional MIDI and In-
strument tracks, Shift-click their Record En-
able buttons.

Record button in Record Ready mode

Press F12 to start recording immediately. 
You can also press Command+Spacebar 
(Mac) or Control+Spacebar (Windows) to 
start recording. For more information, see 
“Recording Shortcuts” on page 464.
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MIDI Clips Are Created on 
Barlines
When recording MIDI, or when manually enter-
ing MIDI notes, the beginning and ending of 
MIDI clips are created on bar boundaries. This 
greatly facilitates arranging MIDI clips in a mu-
sically meaningful way, in whole bar lengths.

The beginning of a recorded MIDI clip always 
starts on the barline immediately before the first 
MIDI note (Note On) of the clip. Likewise, the 
MIDI clip ends on the barline immediately fol-
lowing the last note (Note Off) of the clip. 

Recording Over Existing MIDI 
Clips
Unlike audio clips, existing MIDI clips are never 
overwritten even though MIDI data within clips 
can be overwritten. When MIDI Merge mode is 
disabled and recording MIDI on a track with ex-
isting clips, newly recorded MIDI data over-
writes existing MIDI data within existing clips, 
but the existing clip boundaries remain. New 
MIDI clips are only created to fill the gaps be-
tween existing MIDI clip boundaries. Typically, 
new MIDI clips are always created on barlines. 
However, if existing clip boundaries are not on 
barlines, newly created clips are bound by the 
existing clips.

It is possible to have the Note On of a MIDI 
note be in one MIDI clip, and its Note Off be 
in a subsequent MIDI clip. It is also possible 
to have the clip end before the Note Off, re-
sulting in notes that extend 
beyond the clip boundary. However, Note 
Ons can never precede the beginning of a 
clip. 



Playing Back Recorded MIDI

To play back recorded MIDI and Instrument tracks:

1  To start from the beginning of the session, 
click Return to Zero in the Transport.

2  Click Play in the Transport to begin playback.

The recorded MIDI data plays back through each 
track’s assigned Output device (port) and chan-
nel.

Undoing MIDI Recording
You can undo previous MIDI record takes.

To undo a MIDI recording:

 Once the Transport has been stopped, choose 
Edit > Undo MIDI Recording. 

The track’s playlist is restored to its previous 
state. However, the following conditions apply:

• If you punched in and out several times be-
fore stopping the Transport, only the last 
punch is undone.

• When using Loop Record mode, all takes 
from each record pass are discarded.

To monitor audio from an external MIDI 
instrument, select the corresponding audio 
Input Path for your MIDI instrument on the 
Instrument track (or use an Auxiliary Input 
track). See “Signal Routing for Monitoring 
and Submixing” on page 970.
Canceling a Record Take
It is also possible to discard the current record 
take before the Transport is stopped.

To cancel a take while recording:

 Press Command+Period (.) (Mac) or Con-
trol+Period (.) (Windows) before the Transport 
is stopped.

When in Loop Record mode, all takes from each 
record pass are discarded.

MIDI Punch Recording Over a 
Specified Range
You can set Pro Tools to automatically punch re-
cord over a specific range in a MIDI or Instru-
ment track. The range’s start (punch in) and end 
(punch out) points must be specified before re-
cording.

To punch in on a MIDI or Instrument track:

1  Configure a MIDI or Instrument track for re-
cording (see “Configuring MIDI or Instrument 
Tracks for Recording” on page 486).

2  Ensure that Normal Record mode is selected 
(see “Record Modes” on page 445).

3  In the Transport window, disable Wait for Note 
and Countoff.

4  Select Options > Link Timeline and Edit Selec-

tion.

5  With the Selector tool, select the punch range 
in the track’s playlist.

For other methods of setting the record 
range, see “Setting Punch and Loop Points” 
on page 464.
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6  To hear existing track material up to the start 
point, or after the end point, enable and set pre- 
and post-roll times (see “Setting Pre- and Post-
Roll” on page 468).

7  Record enable the track containing the previ-
ous take.

8  Click Record in the Transport to arm Pro Tools 
for recording. The Record button flashes.

9  Click Play to start recording.

If pre-roll is enabled, the track material leading 
up to the punch-in point plays. You can start 
playing during the pre-roll to get the “feel.” 
MIDI is not recorded until the start point is 
reached.

When the start point is reached, Pro Tools be-
gins recording. Recording continues until the 
end point is reached. If post-roll is enabled, 
playback continues for the specified post-roll 
amount.

10  When you have finished recording, click Stop 
in the Transport. The newly recorded MIDI data 
appears in the track.

Punch Recording During 
Playback with MIDI
You do not have to set a record range to punch in 
on a MIDI or Instrument track. In fact, you can 
punch in and out on-the-fly at any time during 
playback. Unlike audio tracks, it is not neces-
sary to enable QuickPunch to perform real-time 
punch recording.
Pro Tools Reference Guide
To punch record on-the-fly with MIDI:

1  Configure a MIDI or Instrument track for re-
cording (see “Configuring MIDI or Instrument 
Tracks for Recording” on page 486).

2  Ensure that Normal Record mode is selected 
(see “Record Modes” on page 445).

3  In the Transport window, disable Wait for Note 
and Countoff.

4  Record enable the track containing the previ-
ous take.

5  Click Play in the Transport to start playback. 

6  When you reach the punch-in point, do one of 
the following:

• Click Record in the Transport.

– or –

• For Pro Tools systems that support a con-
nected footswitch, press the footswitch at 
the punch-in point.

The Record button in the Transport and the 
track’s Record Enable button stop flashing and 
stay lit during recording.

7  To punch out, click Record again (or press the 
footswitch).

Pro Tools exits Record mode and continues 
playing. You can perform additional punches 
during the same pass.

Foot switches are supported by 003 family 
interfaces, Digi 002, Digi 002 Rack, Mbox 
Pro, and Mbox 2 Pro, as well as any 
Pro Tools system with a supported control 
surface (such as C|24 or Command|8).



MIDI Clips and Punch Recording
Depending on the record range, new clips may 
be created after punch recording. 

For example, if MIDI Merge mode is disabled, 
recording overwrites any existing MIDI data 
within the record range. Since the start and end 
times for recording are located within both of 
the existing clips, newly recorded notes are writ-
ten into both of the existing clips, and into a new 
clip created to fill the space between them.

When selecting an entire clip, or a section 
within a clip, before punching, no new clips are 
created. In this instance, only the material re-
siding within the existing clip changes, with no 
new material recorded outside the clip.

Unlike audio recording, MIDI recording in this 
scenario is destructive. Newly recorded MIDI 
data overwrites existing MIDI data while leaving 
the existing clip boundaries intact.

Clip added after punch record

new clipnewly recorded
material

After punch record

Before punch record
If the MIDI data within a clip is altered because 
of a record take, the original material is either 
lost (unless you choose Edit > Undo MIDI Re-
cording) or combined with new material (if 
MIDI Merge was enabled during recording). If 
an existing clip contains material you want to 
keep, use Duplicate to make a copy of the clip 
(“Duplicating Clips” on page 844), or duplicate 
the track’s playlist or record in a new playlist to 
keep a backup (see “Working with Playlists” on 
page 633).

Loop Recording MIDI
Loop recording with MIDI is supported by two 
methods: 

• In Normal (Nondestructive) Record mode, en-
able Loop Playback and MIDI Merge for drum 
machine style loop recording.

– or –

• Use Loop Record mode to record multiple 
takes on each record pass. This is similar to 
loop recording audio.

Loop Recording in MIDI Merge 
Mode
For MIDI loop recording, use Normal (Nonde-
structive) Record mode with Loop Playback and 
MIDI Merge enabled. With this method, MIDI is 
recorded and merged to the same clip with each 
new record pass—for example, you can record 
hi-hats on the first pass and kick and snare on 
the next.

For drum machine style step entry, use Step 
Input (see “Step Input Command” on 
page 934).
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Make sure that MIDI Merge is enabled in the 
Transport window, otherwise (in Replace mode) 
each subsequent take destructively replaces the 
previous take.

To loop record in MIDI Merge mode:

1  Configure a MIDI or Instrument track for re-
cording (see “Configuring MIDI or Instrument 
Tracks for Recording” on page 486).

2  Ensure that Normal Record mode is selected 
(see “Record Modes” on page 445).

3  Select Options > Loop Playback. When Loop 
Playback is enabled, a loop symbol appears in 
the Play button.

4  Record enable the MIDI or Instrument track. 
Ensure that no audio tracks are record-enabled.

5  In the Transport window, click the MIDI Merge 
button so it is highlighted.

6  Disable Wait for Note and Countoff in the 
Transport window.

7  Select Options > Link Timeline and Edit Selec-

tion.

8  With the Selector tool, select the loop range in 
the track’s playlist.

You can record enable a different MIDI or 
Instrument track on-the-fly while loop re-
cording. While pressing Command (Mac) or 
Control (Windows), use the Up/Down Ar-
rows to record enable the previous or next 
MIDI or Instrument track.

Loop Playback enabled

For other methods of setting the record 
range, see “Setting Punch and Loop Points” 
on page 464.
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9  To hear track material up to the start point of 
the loop, enable and set the pre-roll time (see 
“Setting Pre- and Post-Roll” on page 468).

10  Click Record in the Transport to arm 
Pro Tools for recording. The Record button 
flashes.

11  Click Play to start recording.

The Record button flashes during pre-roll. 
When the start point is reached, Pro Tools be-
gins recording. When the end point is reached, 
Pro Tools loops back to the start point and con-
tinues playing and recording.

12  Play your MIDI controller. Newly recorded 
MIDI data appears as a clip in the record track. 
On each successive take, recorded material 
shows up in the clip, without replacing material 
from previous takes.

13  To switch to a new record track, press Com-
mand (Mac) or Control (Windows), and press 
the Up/Down Arrow keys to record enable the 
previous or next MIDI or Instrument track.

14  When you are finished recording, click Stop 
in the Transport.

The newly recorded MIDI data appears as a 
MIDI clip in the track’s playlist, and in the Clip 
List.



Loop Recording Multiple Takes
When recording MIDI in Loop Record mode, 
new clips are created each time new material is 
received during a record pass. This differs some-
what from loop recording audio, where 
Pro Tools creates a single audio file that com-
prises all takes, which appear as individual clips 
in the Clip List.

You can use MIDI loop recording to record suc-
cessive takes without stopping the record pro-
cess, thereby capturing your creative spontane-
ity. Another advantage with this method of 
recording MIDI, which is nondestructive, is that 
all existing and newly recorded clips remain in-
tact (and available in the Clip List).

To record MIDI in Loop Record mode:

1  Configure a MIDI or Instrument track for re-
cording (see “Configuring MIDI or Instrument 
Tracks for Recording” on page 486).

2  Select Options > Loop Record. When Loop Re-
cord mode is enabled, a loop symbol appears in 
the Record button.

3  If you have not done so already, record enable 
the MIDI or Instrument track by clicking its Re-
cord Enable button. Make sure no audio tracks 
are record-enabled.

4  Disable Wait for Note and Countoff in the 
Transport window.

5  Select Options > Link Timeline and Edit Selec-

tion.

Loop Recording enabled
6  With the Selector tool, select the loop range in 
the track’s playlist.

7  To hear track material up to the start point of 
the loop, enable and set the pre-roll time (see 
“Setting Pre- and Post-Roll” on page 468).

8  Click Record in the Transport to arm Pro Tools 
for recording. The Record button flashes.

9  Click Play to start recording.

The Record button flashes during the pre-roll. 
When the start point is reached, Pro Tools be-
gins recording. When the end point is reached, 
Pro Tools loops back to the start point and con-
tinues playing and recording.

10  Play your MIDI controller. A new MIDI clip 
containing the newly recorded material is auto-
matically created and appears in the track’s play-
list, replacing the previous clip.

Clips are replaced (nondestructively) during 
subsequent record passes when new MIDI mate-
rial is received.

11  When you are finished recording, click Stop 
in the Transport.

The recorded takes appear as clips in the Clip 
List and are numbered sequentially. The takes, 
which are the same length and easily inter-
changeable, can be selected from the Matches 
pop-up menu—even while the session plays or 
loops.

For other methods of setting the record 
range, see “Setting Punch and Loop Points” 
on page 464.
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To select the various record takes:

1  Ensure that the Matching Criteria window is 
correctly configured (see “Matching Criteria 
Window” on page 476).

2  Do one of the following:

• Right-click the clip with the Selector or 
Grabber tools, and select a take from the 
Matches submenu in the pop-up menu. 

• With the Selector tool, Command-click 
(Mac) or Control-click (Windows) at the 
precise beginning of the loop or punch 
range and select a different take from the 
Alternates pop-up menu.

• If the take currently residing in the track is 
selected, with the Selector tool, Command-
click (Mac) or Control-click (Windows) 
anywhere on the selected take and select a 
different take from the Alternates pop-up 
menu.

The selected take (clip) replaces the previous 
take and snaps precisely to the correct location.

Selecting an alternate MIDI take

For more information on auditioning and 
managing takes, see “Selecting Alternate 
Takes” on page 475.
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MIDI Step Input
Step Input lets you use a MIDI keyboard (or any 
other MIDI controller that sends MIDI note 
data) to enter notes individually, one step at a 
time. This gives you precise control over note 
placement, duration, and velocity. With MIDI 
Step Input you can also create musical passages 
that might be difficult to play accurately, or at 
faster tempos. 

Recording System Exclusive 
Data
Pro Tools supports recording and playing Sys-
tem Exclusive data (Sysex) with MIDI tracks. 
This allows you to use MIDI tracks in Pro Tools 
to store patch and configuration data for your 
MIDI devices, or to record real-time Sysex 
changes for a particular parameter of a MIDI de-
vice that cannot be controlled by a standard 
MIDI controller.

To record a Sysex dump at the beginning of a MIDI 
track:

1  Make sure that the MIDI OUT for the device 
sending the Sysex is connected to your MIDI in-
terface’s MIDI IN.

2  In the MIDI Input Filter dialog, enable Only 
and System Exclusive.

3  Configure a MIDI track for recording (see 
“Configuring MIDI or Instrument Tracks for Re-
cording” on page 486).

4  Ensure that Normal Record mode is selected 
(see “Record Modes” on page 445).

5  Record enable a MIDI track.

6  Enable Wait for Note in the Transport window.

For more information on Step Input, see 
“Step Input Command” on page 934.



7  To start recording from the beginning of the 
session, click Return to Zero in the Transport.

8  When you are ready to begin recording, click 
Record in the Transport window. 

The Record, Play, and Wait for Note buttons 
flash, indicating that Pro Tools is waiting for 
MIDI data.

9  Initiate the Sysex transfer from the MIDI de-
vice, according to the manufacturer’s instruc-
tions. Pro Tools automatically begins recording 
as soon as it starts to receive Sysex data.

10  When the Sysex transfer is complete, click 
Stop in the Transport.

The newly recorded MIDI data appears as a 
MIDI clip in the track’s playlist, and in the Clip 
List. MIDI clips that contain System Exclusive 
data appear blank when the Track View is set to 
Clips.

To see the Sysex event blocks, which indicate the 
location of the data, set the Track View to Sysex 
(see “Clips View for MIDI and Instrument 
Tracks” on page 527). 

For information on moving and copying of 
Sysex data, see “System Exclusive Events” 
on page 705.
To send Sysex data from Pro Tools to an external 
MIDI device:

1  For the device receiving the System Exclusive 
data, make sure its MIDI IN is connected to the 
MIDI interface’s MIDI OUT. Also, make sure the 
device is set to receive Sysex. Some devices re-
quire that memory protect be off. For more in-
formation, see the manufacturer’s instructions.

2  Make sure that the MIDI track containing the 
Sysex data is not record enabled.

3  Click the track’s MIDI Output selector and as-
sign the device from the pop-up menu.

4  Configure the external MIDI device to receive 
Sysex data according to the manufacturer’s in-
structions.

5  Click Play in the Transport to begin playback. 
Pro Tools begins playing and transmits the pre-
viously recorded Sysex to the assigned MIDI de-
vice.
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Recording Audio from a MIDI 
Instrument
Typically, you will monitor the audio from MIDI 
instruments (both hardware and plug-ins) using 
Instrument and Auxiliary Input tracks. During 
the final mixdown, audio from Instrument and 
Auxiliary Input tracks can be included when us-
ing Bounce to Disk, or on a bussed recording 
path if recording to a new track. 

Recording Audio from an 
Instrument Plug-In

To record audio from an instrument plug-in:

1  Create a new Instrument track.

2  Insert an instrument plug-in on that track.

3  Do one of the following:

• Record your MIDI performance on the In-
strument track.

– or –

• Manually enter MIDI data in the Instru-
ment track.

4  Create a new audio track with the same num-
ber of channels as the Instrument track (such as 
stereo).

5  Set the Instrument track’s Audio Output Path 
selector to a bus (for example, Bus 1–2).

6  Set the audio track’s Audio Input Path selector 
to the same bus.

When using instrument plug-ins, you may 
want to record the audio from a MIDI in-
strument to a new track before mixing in or-
der to free up DSP resources.

You can also record the MIDI and audio 
from your performance at the same time.
Pro Tools Reference Guide
7  Set the audio track’s Audio Output Path selec-
tor to the main monitoring path).

8  Record enable the audio track.

9  Do one of the following:

• To record from the beginning of the ses-
sion, click Return To Zero in the Transport.

– or –

• Make a Timeline selection for the record 
range.

10  Click Record in the Transport to arm 
Pro Tools for recording.

11  Click Play in the Transport to start recording.

12  When your previously recorded MIDI perfor-
mance is finished playing, click Stop in the 
Transport to stop recording.

Bus recording audio from an instrument plug-in



Recording Audio from an 
External MIDI Instrument
You can record audio from an external MIDI in-
strument in one of two ways:

• By bussing audio from the output of the In-
strument (or Auxiliary Input) track used to 
monitor the MIDI instrument to an audio 
track for recording. 

• By setting the audio track’s Audio Input Path 
selector to the same Audio Input Path as the 
Instrument (or Auxiliary Input) track used for 
monitoring the external MIDI instrument. 

This second method avoids any additional la-
tency associated with bussing. However, be sure 
to mute the Instrument (or Auxiliary Input) 
track used for monitoring while recording the 
same audio path to the audio track.
Chapter 23: MIDI Recording 497



498
 Pro Tools Reference Guide



Chapter 24: Punch Recording Modes
Punch recording is used in many areas of audio 
production for film, video, and music.

Introduction to Punch 
Recording Modes
Once basic track material has been recorded, it 
is often necessary to replace some, but not all, of 
the audio that makes up each track. Punch re-
cording lets you manually “punch” one or more 
audio tracks in and out of recording on-the-fly 
(without stopping the Transport). 

You do not need to use QuickPunch or any 
other audio punch recording mode to punch 
on-the-fly with MIDI tracks. MIDI tracks 
can be punched while in Normal (Nonde-
structive) Record mode, and in Destructive 
Record mode.
Pro Tools Punch Recording 
Modes
Pro Tools provides three different manual 
punch recording modes: 

QuickPunch A nondestructive Record mode that 
lets record-enabled tracks be punched in and 
punched out during playback by clicking the Re-
cord button in the Transport. QuickPunch mode 
is available on all systems. 

TrackPunch (Pro Tools HD and Pro Tools with 
Complete Production Toolkit Only) A nonde-
structive Record mode that lets individual 
tracks be punched in, punched out, and taken 
out of record enable without interrupting online 
recording and playback.

DestructivePunch (Pro Tools HD and Pro Tools 
with Complete Production Toolkit Only) A de-
structive Record mode that maintains a single 
continuous audio file per punch track, and lets 
individual tracks be punched in, punched out, 
and taken out of record enable without inter-
rupting online recording and playback.

To automatically punch in and out on re-
cord-enabled audio tracks over a specific 
range, see “Audio Punch Recording Over a 
Specified Range” on page 470.
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System, Session, and Track 
Guidelines for Punch 
Recording
This topic lists the basic settings and guidelines 
for Pro Tools punch recording, including the 
following: 

• “Voice Requirements for Punch Recording” 
on page 500. 

• “Delay Compensation and Destructive-
Punch Mode” on page 501.

• “Audio Files, Clips and Takes” on page 502.

• “Preferences for Punch Recording” on 
page 502 (for crossfades, as well as trans-
port and monitor configuration settings).

Voice Requirements for 
Punch Recording
The maximum number of tracks that can be 
punched depends on the type of system you are 
using, as well as the number of available voices. 
The following topics provide guidelines for 
voice usage with punch recording that can be 
useful when managing resources during ses-
sions. 

Pro Tools

(QuickPunch Only)

QuickPunch capabilities for Pro Tools depends 
on the total number of voices available. This will 
vary depending on the number of tracks and 
plug-ins in use in the current session (which af-
fects the number of available voices). 

QuickPunch uses CPU processing power, 
and may reduce the number of tracks and 
plug-ins you can use.
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Similarly, installing the Complete Production 
Toolkit option expands your system’s voice ca-
pabilities; this can increase the number of avail-
able voices, which then increases the number of 
tracks which can be punched. 

To make more voices available for punch 
recording:

1  Identify tracks that are not record-enabled, 
and do not need to be heard while recording.

2  Make those tracks inactive. 

Pro Tools HD and Pro Tools with Complete 
Production Toolkit

(QuickPunch, TrackPunch, and 
DestructivePunch)

When using any punch recording mode with 
Pro Tools HD or Pro Tools with Complete Pro-
duction Toolkit, two voices are required for each 
record-enabled mono track. This means that you 
can punch record up to half the total number of 
voices available on your system. For example, a 
Pro Tools|HD Accel system configured for 192 
voices can simultaneously punch record on up 
to 96 mono tracks with QuickPunch (or 48 ste-
reo tracks).

If the required number of voices for the record-
enabled tracks is not available when switching 
to QuickPunch, TrackPunch, or Destructive-
Punch mode, you are prompted to free up the 
necessary voices.

For details on voice capabilities, see 
“Pro Tools Capabilities with Different 
Hardware Configurations” on page 45.



To make more voices available for punch 
recording:

1  Identify tracks that are not record-enabled, 
and do not need to be heard while recording, and 
do any of the following:

• Set voice assignments for tracks to Off.

• Make tracks inactive.

• Group all RTAS plug-ins before TDM plug-
ins.

Voices that are in use by other tracks, but not re-
cord-enabled, may be “stolen” during punch re-
cording as necessary. 

When any punch recording mode is enabled, 
voice playback priority is as follows (from high-
est to lowest playback priority):

• Tracks with assigned voices that are not re-
cord-enabled.

• Tracks with assigned voices that are record-
enabled.

• Tracks with Dynamically Allocated Voicing 
that are not record-enabled.

• Tracks with Dynamically Allocated Voicing 
that are record-enabled.

If a session has plenty of available voices, you 
should have no trouble punch recording tracks 
using Dynamically Allocated Voicing. However, 
if you are running out of voices, and want to en-
sure that a track is heard when punch recording, 
assign it a voice.

Dynamically Allocated Voicing

When punch recording with a Pro Tools|HD sys-
tem configured for its maximum number of 
voices, make sure to set the voice assignment for 
each audio track to Dyn (for Dynamically Allo-
cated Voicing). This ensures that Pro Tools han-
dles the distribution of voices between each set 
of voices automatically. For example, for a 
192-voice configured Pro Tools|HD Accel sys-
tem, Dynamically Allocated Voicing distributes 
voices evenly across four sets of voices (1–48, 
49–96, 97–144, and 145–192).

If you do not use Dynamically Allocated Voic-
ing, the voices must be evenly distributed be-
tween all DSP engines. For example, to use 
QuickPunch on 32 tracks without Dynamically 
Allocated Voicing, tracks 1–16 must be assigned 
to voices 1–16 and tracks 17–32 must be as-
signed to voices 33–48.

Delay Compensation and 
DestructivePunch Mode
When using DestructivePunch to punch in on an 
existing recording, make sure the Delay Com-
pensation settings are the same as when the 
original file was recorded. If they differ, the 
punched-in audio will not be time-accurate to 
the original recording.

 If Delay Compensation was inactive when re-
cording the original file, it should be deactivated 
while using DestructivePunch.

 If Delay Compensation was active when re-
cording the original file, it should be kept active 
while using DestructivePunch. 

To ensure that the Delay Compensation path on 
record tracks remains consistent while using 
DestructivePunch, you need to prevent 
Pro Tools from using the Low Latency monitor-
ing path when record tracks switch to Input 
monitoring.

To apply Delay Compensation to a track where 
Delay Compensation was suspended, do one of 
the following:

 Right-click the Track Compensation indicator 
on the track and select Auto Low Latency Off.
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 Command-Control-click (Mac) or Control-
Start-click (Windows) the Track Compensation 
indicator on the track.

To apply Delay Compensation to all selected 
tracks where Delay Compensation was 
suspended, do one of the following:

 Shift-Right-click the Track Compensation in-
dicator on the track and select Auto Low Latency 

Off.

– or –

 Command-Control-Shift-click (Mac) or Con-
trol-Start-Shift-click (Windows) the Track Com-
pensation indicator on the track.

Audio Files, Clips and Takes

QuickPunch and TrackPunch Modes

QuickPunch and TrackPunch are nondestructive 
recording modes. Instead of replacing audio 
while punching, QuickPunch and TrackPunch 
create new audio files for each pass (a pass is one 
cycle of starting and stopping the Transport).

Pro Tools begins recording a new audio file 
when playback begins, automatically generating 
clips in that file at each punch-in and punch-out 
point. Up to 200 of these “running punches” can 
be performed in a single pass. QuickPunch and 
TrackPunch provide instantaneous monitor 
switching on punch-out. 

After recording with QuickPunch or Track-
Punch, the new audio clips appear in the Clip 
List. This includes the whole-file audio clip en-
compassing all punches from the record pass, 
along with the clips derived for each punch.

For more information, see “Delay Compen-
sation” on page 977.
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Names for the punched clips are numbered con-
secutively starting with “01.” For example, if 
QuickPunch is used to punch in twice on a track 
called “Lead Gtr,” a clip for the parent audio file 
appears and is named “Lead Gtr_01,” and two 
clips for the punches are named “Lead Gtr_01-
01” and “Lead Gtr_01-02.” 

If you stop playback and record additional 
punches with QuickPunch (or TrackPunch), a 
new whole file clip is created (since one is cre-
ated for each pass), and subsequent clips are 
named by incrementing the first two digits in 
the name. For example, on the second pass, the 
punched clips are named “Lead Gtr_02-01,” 
“Lead Gtr_02-02,” and so forth. 

DestructivePunch Mode

DestructivePunch is a destructive recording 
mode which permanently replaces pre-existing 
track material with newly recorded “punch” au-
dio. Pro Tools only records while tracks are 
punched in, inserting new material and replac-
ing audio in the track playlist. 

Preferences for Punch 
Recording
(Crossfade, Transport, and Record Settings)

Pro Tools provides several punch-related 
preference settings that let you specify how 
crossfades, monitoring and transport functions 
are to perform during and after recording 
passes. These settings optimize Pro Tools fades, 
transport and track behavior for different types 
of tasks, including dubbing, mixing, and over-
dubbing. 



Crossfades while Punch Recording

Pro Tools places crossfades at each in and out 
point, for smooth transitions between punch 
clips. You can specify the crossfade length for 
QuickPunch and TrackPunch modes (Destruc-
tivePunch uses a fixed crossfade length which 
cannot be changed). After punch recording is 
completed, all crossfades can be edited in the 
same manner as standard crossfades (see 
Chapter 29, “Fades and Crossfades”). 

QuickPunch/TrackPunch Crossfade Length

Pro Tools can automatically write a crossfade 
for each punch point when using QuickPunch 
and TrackPunch. The length for these crossfades 
is set with the QuickPunch/TrackPunch Cross-

fade Length option on the Editing Preferences 
page.

To set the QuickPunch/TrackPunch Crossfade 
Length:

1  Choose Setup > Preferences and click the 
Editing tab.

2  Enter a new value (in msec) for the Quick-

Punch/TrackPunch CrossFade Length. A good 
general-purpose crossfade length for punches is 
10 milliseconds. If you set the preference to 
zero, Pro Tools will not create any crossfades at 
the punch-in/out points.

3  Click OK.

If a value other than zero is specified for the 
QuickPunch/TrackPunch Crossfade Length, 
Pro Tools writes a pre-crossfade at the punch-in 
point (the fade occurs up to but not into the 
punched clip boundary), and a post-crossfade at 
punch-out (after the punched clip).
Regardless of the current QuickPunch/Track-
Punch Crossfade Length setting, Pro Tools al-
ways executes a 4 millisecond “monitor only” 
crossfade (which is not written to disk) to avoid 
distracting pops or clicks that might occur as 
you enter and exit record mode.

DestructivePunch and Crossfades

DestructivePunch uses a fixed 10-millisecond 
linear crossfade at each in and out point. After 
punch recording is completed, crossfades can be 
edited in the same manner as standard cross-
fades (see Chapter 29, “Fades and Crossfades”). 

Transport and Record Settings

Transport and Record preferences for punch re-
cording appear on the Operation Preferences 
page. These preferences specify how track and 
Transport record status respond during, be-
tween, and after punches and passes.

TrackPunch preferences
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Transport RecordLock

This setting lets the Transport Record be config-
ured to either emulate a digital dubber, or to 
maintain legacy behavior for the Transport mas-
ter Record. 

 When not enabled, the Transport Record dis-
arms when Pro Tools is manually stopped or 
stops due to a loss of timecode. This replicates 
legacy Pro Tools recording behavior. 

 When enabled, the Transport Record remains 
armed when playback or recording stops. This 
saves having to re-arm the Transport between 
takes, emulating digital dubber behavior. 

Destructive Recording and Transport RecordLock

As a precaution against accidentally recording 
over previous material, the Transport Record-

Lock option is automatically disabled and 
grayed out when Destructive record mode is en-
abled. 

Audio Track RecordLock

This setting lets Pro Tools tracks either emulate 
a digital dubber, or maintain legacy behavior for 
track record status. 

 When the Audio Track RecordLock option is 
enabled, the record-enabled audio tracks remain 
armed when playback or recording stops. 

Punching out of record by pressing Record 
on the Transport takes the transport out of 
record enable.
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 When the Audio Track RecordLock option is 
not enabled, record-enabled audio tracks are 
taken out of record enable when Pro Tools is 
stopped. This prevents tracks from remaining 
armed from pass to pass, emulating track record 
behavior of a digital dubber.

Synchronization and Track 
Arming Options for Punch 
Recording
(SYNC HD or SYNC I/O Only)

Synchronization settings for online punch re-
cording vary depending on the type and capabil-
ities of your Pro Tools system and other devices 
in your studio. 

The MachineControl™ option for Pro Tools HD 
lets you remotely arm tracks on supported 9-pin 
decks (or V-LAN for Transport only). 

For examples of how these settings can be 
applied, see “Example TrackPunch and De-
structivePunch Workflows” on page 515.

For basic timecode and synchronization 
information for Pro Tools, see Chapter 50, 
“Working with Synchronization.”

Choose Setup > Machine Track Arming 
Profiles to configure your system, and 
choose Window > Machine Track Arming to 
display the Machine Track Arming window. 

For information on remote track arming 
with MachineControl, see the Machine-
Control Guide. 



QuickPunch Audio Recording
QuickPunch is available on all systems and lets 
you instantaneously punch in and out all record-
enabled audio tracks during playback by click-
ing the Record button in the Transport. 

Recording with QuickPunch

To punch on-the-fly with QuickPunch:

1  Do one of the following:

• Select Options > QuickPunch. 

– or –

• Right-click the Record button in the Trans-
port and select QuickPunch.

When QuickPunch is enabled, a “P” appears in 
the Record button in the Transport. 

2  Check or reconfigure the crossfade setting for 
punch recording (see “QuickPunch/TrackPunch 
Crossfade Length” on page 503).

3  Click the track Record Enable button to record 
enable each track on which you want to punch 
in. 

Many Pro Tools systems also let you use a 
footswitch to punch in and out. See the 
guide that came with your Pro Tools audio 
interface, control surface, or ICON worksur-
face (Pro Tools HD and Pro Tools with Com-
plete Production Toolkit only).

QuickPunch enabled

If you cannot record enable tracks due to 
voice limitations, see “Voice Requirements 
for Punch Recording” on page 500.
4  Prepare to record by cueing Pro Tools to an ap-
propriate location. To use pre-roll, enable a pre-
roll value in the Transport window.

5  Start playback by clicking Play in the Trans-
port window.

6  Do one of the following:

• When you reach the punch-in point, click 
Record in the Transport.

– or –

• For Pro Tools systems that support using a 
connected footswitch, step on the foot-
switch at the punch-in point.

The Record button stops flashing and stays lit 
during recording.

7  To punch out, click Record again (or step on 
the footswitch).

As Pro Tools continues playing, you can per-
form additional punches (up to 200). When re-
cording multiple punches during a single pass, a 
single audio file is recorded from which 
Pro Tools creates the appropriate clips.

After a QuickPunch recording pass, the punched 
track’s playlist in the Edit window displays the 
clips created by punching. You can use any of 
the Trim tools after punch recording to open up 
the head or tail of QuickPunch recorded clips, or 
to reveal the parent audio file that was recorded 
in the background. This lets you compensate for 
any late or missed punches. 

For information on file and clip naming, see 
“Audio Files, Clips and Takes” on page 502. 
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QuickPunch with an Edit Selection

If you make an Edit selection and use Quick-
Punch, the following rules apply:

 If the Transport is not online, recording be-
gins and stops whenever you click the Record 
button in the Transport—regardless of the selec-
tion’s start or end point. 

 If the Transport is online, punch-in/out be-
havior is controlled by the Online Options set-
ting on the Operation Preferences page. 

• If you select Record Online at Insertion/Se-

lection, QuickPunch punches in and out 
only within the selection (or in the case of 
an insertion point, only after the insertion 
point). 

• If you select Record Online at Timecode 

Lock, QuickPunch disregards the selection 
and punches in and out whenever you want 
(after Pro Tools has locked to timecode).

TrackPunch Audio Recording
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

TrackPunch mode lets you punch tracks in and 
out individually (one at a time) or punch multi-
ple tracks in and out simultaneously. Track-
Punch is a nondestructive punch mode which 
leaves previous material on disk. (To destruc-
tively replace audio on disk, see “Destructive-
Punch Audio Recording” on page 510). 

For information about online playback with 
Pro Tools, see the User Guide that came with 
your system. For information about syn-
chronization with TrackPunch and Destruc-
tivePunch recording, see “Synchronization 
and Track Arming Options for Punch Re-
cording” on page 504. 
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TrackPunch Setup
Before using TrackPunch in a record pass you 
must configure Pro Tools, session, and track 
settings.

Configure Pro Tools

To configure Pro Tools: 

1  Configure tracks, voicing, and other Track-
Punch settings as needed (see “System, Session, 
and Track Guidelines for Punch Recording” on 
page 500). 

2  Make sure Pro Tools is not recording or play-
ing back (the Transport is stopped). 

Enable TrackPunch Mode

To enable TrackPunch mode:

 Do any of the following: 

• Select Options > TrackPunch.

• Right-click the Record button in the Trans-
port, and select TrackPunch from the pop-
up menu.

• Start-click (Windows) or Control-click 
(Mac) the Record button in the Transport to 
cycle through available Record modes until 
TrackPunch mode is selected (a “T” indi-
cates TrackPunch mode). 

• Press Command+Shift+T (Mac) or Con-
trol+Shift+T (Windows).



Transport Display of TrackPunch Status

The Transport Record button indicates Track-
Punch and Record status as follows:

When TrackPunch mode is enabled:

 A “T” appears in the Record button in the 
Transport. 

 If at least one track is TrackPunch-enabled, 
the Record button lights solid blue. 

When TrackPunch mode is enabled and the 
transport is armed for recording:

 If no tracks are TrackPunch-enabled, the Re-
cord button in the Transport flashes gray and 
red. 

 If at least one track is TrackPunch-enabled, 
the Record button flashes blue and red.

 If at least one TrackPunch-enabled track is 
also record-enabled, the Record button flashes 
blue and red, and the record LED lights.

 Whenever at least one audio track is record-
ing, the Transport Record button lights solid 
red. 

TrackPunch and TrackInput Status indicators in the 
Transport window

TrackPunch mode, with at least one TrackPunch-
enabled track

Input Status
indicator

TrackPunch Record Enable 
Status indicatorenabled
TrackPunch Enabling Tracks
Before each pass, you must TrackPunch enable 
all tracks that you intend to punch (you can 
TrackPunch enable tracks without record en-
abling them). 

To TrackPunch enable one audio track: 

 Control-click (Mac) or Start-click (Windows) 
the track’s Record Enable button. 

To TrackPunch enable or disable all audio tracks:

 Option-Control-click (Mac) or Alt-Start-click 
(Windows) a track’s Record Enable button. 

To TrackPunch enable or disable all selected audio 
tracks: 

 Option-Control-Shift-click (Mac) or Alt-
Start-Shift-click (Windows) a track’s Record En-
able button. 

When TrackPunch enabled, Track record enable 
buttons light solid blue.

Create track groups for each stem or set of 
tracks on which you plan to punch, then use 
the Group List to quickly select all tracks in 
the group. 
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Track Record Status Display

Each track’s Record Enable button indicates its 
TrackPunch and record enable status as follows:

• When a track is TrackPunch-enabled but not 
record-enabled, its Record Enable button 
lights solid blue. 

• When a track is both TrackPunch-enabled and 
record-enabled, its Record enable button 
flashes blue and red. 

• When a track is record-enabled only, its Re-
cord Enable button flashes red. 

• While a track is recording (in any mode), its 
Record Enable button lights solid red.

Record Enable button, enabled

Red (not flashing) indicates recording (all modes)
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Monitoring and Levels

To complete the setup for TrackPunch: 

1  Configure monitoring for record-enabled 
tracks by selecting a mode from the Track menu, 
or using the TrackInput button, as appropriate. 
Choices include:

• Set Record Tracks to Auto Input 

• Set Record Tracks to Input Only 

Selecting either monitoring mode only affects 
tracks that are record-enabled. 

2  Start playback and compare levels of the input 
source with audio on disk. Click the TrackInput 
button to toggle the track source. When lit 
(green), the track is monitoring input. When un-
lit (gray), the track is monitoring from disk (see 
“Selecting Record Monitor Modes with TrackIn-
put Monitoring” on page 457). 

3  When you are satisfied with your levels, you 
are ready to start punch recording. 

Using TrackPunch
After you have configured Pro Tools, tracks, and 
levels, you can record with TrackPunch in sev-
eral ways. 

Punching In on Individual Tracks

To punch in on individual tracks:

1  Make sure Pro Tools is in TrackPunch mode.

2  Control-click (Mac) or Start-click (Windows) 
the Record Enable button for each track you 
want to punch in, so that the track is Track-
Punch-enabled only. The track’s Record Enable 
button should light solid blue. 

3  Click Record in the Transport to enter the 
TrackPunch Record Ready mode. The Record 
button flashes blue and red.



4  Click Play in the Transport to begin playback.

5  During playback, punch in and out on individ-
ual TrackPunch-enabled tracks by clicking their 
respective Record Enable buttons. 

6  While continuing local or remote playback, do 
any of the following:

• Punch in on other TrackPunch enabled 
tracks individually.

• After punching out, take tracks out of re-
cord enable then record enable different 
TrackPunch enabled tracks. 

• Repeat as needed to punch other stems, 
tracks, or takes. 

7  Stop playback. When you are finished with the 
record pass, track Record Enable status and 
transport Record Arm status follow the current 
Audio Track RecordLock and Transport Record-

Lock preference settings. 

After a TrackPunch recording pass, the punched 
track’s playlist in the Edit window displays the 
clips created by punching. You can use any of 
the Trim tools after punch recording to open up 
the head or tail of TrackPunch recorded clips, or 
to reveal the parent audio file that was recorded 
in the background. This lets you compensate for 
any late or missed punches. 

For information on file and clip naming, see 
“Audio Files, Clips and Takes” on page 502. 
Punching In on Multiple Tracks 
Simultaneously

To punch in on multiple tracks simultaneously:

1  Enable TrackPunch mode. 

2  Click the Record Enable button on each track 
you want to punch in, so that the track is both 
TrackPunch- and Record-enabled. The track’s 
Record Enable button flashes blue and red.

3  Do either of the following: 

• During playback, click Record in the Trans-
port to punch in and out on all TrackPunch-
enabled tracks simultaneously. 

– or –

• Click Record in the Transport first, then 
Option-Shift-click (Mac) or Alt-Shift-click 
(Windows) a track’s Record Enable button 
to simultaneously punch in and out on all 
currently selected TrackPunch enabled 
tracks.

4  Stop playback. When you are finished with the 
record pass, track Record Enable status and 
transport Record Arm status follow the current 
Audio Track RecordLock and Transport Record-

Lock preference settings. 
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Start Recording on All Tracks
You can choose to begin a punch pass in record, 
to punch out and back in as needed. 

To punch in on all tracks:

1  Enable TrackPunch mode (see “Transport Dis-
play of TrackPunch Status” on page 507).

2  Click the Record Enable button on each track 
you want to punch in, so that the track is both 
TrackPunch- and Record-enabled. The track’s 
Record Enable button flashes blue and red. 

3  Click Record in the Transport to enter the 
TrackPunch Record Ready mode. The Record 
button flashes blue and red.

4  Click Play in the Transport to begin playback.

5  During playback, punch out and back in on in-
dividual TrackPunch-enabled tracks by clicking 
their respective Record Enable buttons.

6  Stop playback. When you are finished with the 
record pass, track Record Enable status and 
transport Record Arm status follow the current 
Audio Track RecordLock and Transport Record-

Lock preference settings. 
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DestructivePunch Audio 
Recording
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

DestructivePunch is a destructive recording 
mode that lets you punch in and out on during 
playback, while preserving a contiguous audio 
file on each punched track. Like TrackPunch 
mode, DestructivePunch mode lets you punch 
tracks in and out individually (one at a time) or 
punch multiple tracks in and out simultane-
ously. 

Unlike QuickPunch and TrackPunch, Destruc-
tivePunch replaces audio within the target par-
ent file. DestructivePunch is essentially a de-
structive version of TrackPunch mode. Where 
TrackPunch always records audio to a new file 
in the background, DestructivePunch destruc-
tively records audio directly into the original 
file, using a fixed 10-millisecond linear cross-
fade. No additional clips are created when re-
cording in DestructivePunch mode. Up to 200 
“running punches” can be performed in a track 
during a single DestructivePunch pass.

DestructivePunch recording is not supported 
with AudioSuite rendered clips with handles. 
You can consolidate such clips if you need to 
use DestructivePunch.



DestructivePunch Setup
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Before using DestructivePunch in a record pass 
you must configure Pro Tools, session, and 
track settings. 

Configure Pro Tools for 
DestructivePunch

To configure Pro Tools: 

1  Configure tracks, voicing, and other settings 
as needed (see “System, Session, and Track 
Guidelines for Punch Recording” on page 500). 

2  Make sure Pro Tools is not recording or play-
ing back (the Transport is stopped). 

Enable DestructivePunch Mode

To enable DestructivePunch mode:

 Do one of the following:

• Select Options > DestructivePunch.

• Right-click the Record button in the Trans-
port and select DestructivePunch.

• Control-click (Mac) or Start-click (Win-
dows) the Record button in the Transport to 
cycle through available Record modes until 
DestructivePunch mode is indicated by 
“dp” in the Transport Record Enable but-
ton. 

Power waveform view is not available in 
Destructive Punch mode.
Transport Display of DestructivePunch Status

When DestructivePunch mode is enabled:

 The letters “dp” appears in the Record button 
in the Transport. 

 If at least one track is DestructivePunch-en-
abled, the Record button in the Transport lights 
solid blue.

When DestructivePunch mode is enabled and the 
transport is armed for recording:

 If no tracks are DestructivePunch-enabled, 
the Record button in the Transport flashes gray 
and red. 

 If at least one track is DestructivePunch-en-
abled, the Record button flashes blue and red.

 If at least one DestructivePunch-enabled track 
is also record enabled, the Record button flashes 
blue and red, and the record LED lights.

 Whenever at least one audio track is record-
ing, the Record button lights solid red.

Transport Record Enable button with 
DestructivePunch mode enabled
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Prepare Tracks for 
DestructivePunch Recording
In order for a track to be enabled for Destruc-
tivePunch recording, the track must contain a 
contiguous audio file that meets the following 
requirements:

• The file must start at the beginning 
(sample 0) of the session. 

– and –

• The File Length must be equal to or greater 
than the DestructivePunch File Length set-
ting (see “DestructivePunch File Length” 
on page 512). 

If a track does not contain a file that meets these 
requirements, you can do any of the following to 
meet the requirements:

• Move the current file in the track Timeline 
so that its beginning aligns with the session 
start.

• Use the Consolidate command to create a 
continuous file of the required length.

• Change the DestructivePunch File Length 
setting so that the current file is equal to or 
greater than the required length.

• Use the Prepare DPE Tracks command to 
consolidate audio on all DestructivePunch-
enabled tracks. (See “Using the Prepare 
DPE Tracks Command” on page 512.)

DestructivePunch File Length

To use DestructivePunch on an audio track, the 
track must contain a contiguous audio file of a 
minimum length, which is set in the Pro Tools 
Operation preferences page.
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To set DestructivePunch File Length:

1  Choose Setup > Preferences and click the Op-

eration tab. 

2  Type a value for DestructivePunch File Length. 

3  Click OK.

Using the Prepare DPE Tracks Command

To prepare a track for DestructivePunch 
recording:

1  Enable DestructivePunch mode (“Enable De-
structivePunch Mode” on page 511). 

2  Make sure the tracks you want to prepare are 
DestructivePunch-enabled (see “Destructive-
Punch Enabling Tracks without Record Enabling 
Them” on page 513).

3  Choose Options > Prepare DPE Tracks. 

Pro Tools consolidates audio on all Destructive-
Punch-enabled tracks from the beginning of the 
session to the value specified in the Destructive-

Punch File Length preference. 

Enabling Tracks for 
DestructivePunch Recording
You can enable tracks for DestructivePunch 
without record enabling them. This lets you 
punch in on individual tracks at any time after 
starting playback by clicking their respective 
Record Enable buttons. 

Or, you can simultaneously DestructivePunch 
enable tracks and record enable them. This lets 
recording begin as soon as the transport is re-
cord-armed and playback begins. (See “Destruc-
tivePunch-Enabling and Record-Enabling 
Tracks Simultaneously” on page 513.)

For clips with any clip gain settings other 
than 0 dB, the Prepare DPE Tracks com-
mand automatically renders all clip gain 
and resets all clip gain to 0 dB.



DestructivePunch Enabling Tracks without 
Record Enabling Them

This method lets you use the Prepare DPE Tracks 
command to consolidate files for Destructive-
Punch recording. 

To DestructivePunch-enable an audio track:

 Control-click (Mac) or Start-click (Windows) 
the track’s Record Enable button to toggle the 
button to solid blue.

To DestructivePunch-enable all audio tracks: 

 Option-Control-click (Mac) or Alt-Start-click 
(Windows) a track’s Record Enable button to 
toggle all Record Enable buttons to solid blue.

To DestructivePunch-enable all selected audio 
tracks:

 Control-Option-Shift-click (Mac) or Alt-
Start-Shift-click (Windows) a track’s Record En-
able button to toggle the Record Enable buttons 
for the selected audio tracks solid blue.

DestructivePunch-Enabling and Record-
Enabling Tracks Simultaneously

This method can be used when tracks already 
meet the requirements for DestructivePunch re-
cording.

Create a VCA group for each stem or set of 
tracks on which you plan to punch, and use 
the VCA Record Enable button to arm all 
tracks in the group for DestructivePunch. 
For more information, see “VCA Master 
Tracks” on page 945.
To simultaneously DestructivePunch enable and 
record enable an audio track:

 Click the track’s Record Enable button. The 
track’s Record Enable button flashes blue and 
red. 

To simultaneously DestructivePunch enable and 
record enable all audio tracks:

 Option-click (Mac) or Alt-click (Windows) a 
track’s Record Enable button. All tracks’ Record 
Enable buttons flash blue and red.

To simultaneously DestructivePunch enable and 
record enable all selected audio tracks:

 Option-Shift-click (Mac) or Alt-Shift-click 
(Windows) a track’s Record Enable button. The 
Record Enable buttons for the selected audio 
tracks flash blue and red.

Track Record Status Display

When Pro Tools is in DestructivePunch mode, 
each track’s Record Enable button indicates its 
DestructivePunch and record enable status as 
follows:

• When a track is both DestructivePunch-en-
abled and record-enabled, its Record Enable 
button flashes blue and red. 

• When a track is DestructivePunch-enabled 
but not record-enabled, its Record Enable but-
ton lights solid blue. 

• When a track is record-enabled only, its Re-
cord Enable button flashes red.

• While a track is recording (in any mode), its 
Record Enable button lights solid red.
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Monitoring and Levels

To complete the setup for DestructivePunch: 

1  Configure monitoring for record-enabled 
tracks by selecting a mode from the Track menu, 
as appropriate. Choices include:

• Set Record Tracks to Auto Input 

• Set Record Tracks to Input Only 

Selecting either monitoring mode only affects 
tracks that are record-enabled. 

2  Start playback. 

3  To compare levels of the input source with au-
dio on disk, click the TrackInput button. When 
lit (green), the track is monitoring input. When 
unlit (gray), the track is monitoring from disk 
(see “Selecting Record Monitor Modes with 
TrackInput Monitoring” on page 457). 

When you are satisfied with your levels, you are 
ready to start punch recording. 

Using DestructivePunch 
After you have configured Pro Tools, tracks, and 
levels, you can use DestructivePunch to record 
in several ways.

Punching In On Single Tracks

To punch in on single tracks:

1  Enable DestructivePunch mode (“Enable De-
structivePunch Mode” on page 511). 

2  Control-click (Mac) or Start-click (Windows) 
the Record Enable button for each track you 
want to punch in, so that the track is Destruc-
tivePunch-enabled only. The track’s Record En-
able button lights solid blue. 
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3  Click Record in the Transport to enter Record 
Ready mode. The Record Enable button flashes 
blue and red.

4  Click Play in the Transport to begin playback.

5  During playback, punch in and out on individ-
ual DestructivePunch-enabled tracks by clicking 
their Record Enable buttons.

6  Stop playback. When you are finished with the 
record pass, track Record Enable status and 
transport Record Arm status follow the current 
Audio Track RecordLock and Transport Record-

Lock preference settings. 

Punching In on Multiple Tracks

To punch in on multiple tracks simultaneously:

1  Enable DestructivePunch mode (“Enable De-
structivePunch Mode” on page 511). 

2  Click the Record Enable button on each track 
you want to punch in, so that the track is both 
DestructivePunch-enabled and Record-enabled. 
Each track’s Record Enable button flashes blue 
and red. 

3  Click Play in the Transport to begin playback.

4  During playback, click Record in the Transport 
to punch in and out on all DestructivePunch-en-
abled tracks simultaneously. 

5  Stop playback. When you are finished with the 
record pass, track Record Enable status and 
transport Record Arm status follow the current 
Audio Track RecordLock and Transport Record-

Lock preference settings.



Starting Recording Immediately 
on Multiple Tracks

To punch in on multiple tracks:

1  Enable DestructivePunch mode (“Enable De-
structivePunch Mode” on page 511). 

2  Click the Record Enable button on each track 
you want to punch in, so that the track is both 
DestructivePunch-enabled and Record-enabled. 
Each track’s Record Enable button flashes blue 
and red. 

3  Click Record in the Transport to enter Record 
Ready mode. The Record button flashes blue and 
red.

4  Click Play in the Transport to begin playback.

5  During playback, punch out and back in on in-
dividual DestructivePunch-enabled tracks by 
clicking their respective Record Enable buttons.

6  Stop playback. When you are finished with the 
record pass, track Record Enable status and 
transport Record Arm status follow the current 
Audio Track RecordLock and Transport Record-

Lock preference settings. 
Example TrackPunch and 
DestructivePunch Workflows
TrackPunch and DestructivePunch let you use 
Pro Tools punch recording in many ways. For 
example, DestructivePunch lets Pro Tools be 
used as a digital dubber for film re-recording 
(dubbing) and mixing (see “Film Dubbing and 
Mixing” on page 516). 

Keyboard shortcuts and preference settings for 
recording and input monitoring provide flexi-
bility that makes TrackPunch or Destructive-
Punch equally useful for the following work-
flows commonly performed in film, video, and 
music production:

• Loading dailies (see “Loading Dailies Using 
RecordLock” on page 517)

• Recording Foley (see “Foley Recording” on 
page 517)

• Tracking and overdubbing in music produc-
tion and any other recording situation (see 
“Tracking and Overdubbing Music” on 
page 518)

Because Pro Tools can be networked, Track-
Punch (and all other) audio files and whole ses-
sions can be available for secure transfer to 
other systems for review, editing, and archiving. 

If you are not already familiar with routing, 
selecting, and grouping Pro Tools tracks, 
see Chapter 13, “Tracks” and Chapter 43, 
“Basic Mixing.”

Throughout these examples, references to 
TrackPunch can also be applied to Destruc-
tivePunch (just remember that TrackPunch 
is nondestructive, while DestructivePunch is 
a destructive punch mode). 
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Film Dubbing and Mixing 
Film dubbing and mixing features of Track-
Punch and DestructivePunch let you do the fol-
lowing:

• Arm and punch Pro Tools audio tracks re-
motely from a master synchronizer such as 
SoundMaster through P2 commands at any 
time, without having to stop playback and 
while maintaining timecode lock. (Requires 
the MachineControl option.)

• Toggle Pro Tools audio tracks between input 
and disk monitoring. 

• Use Pro Tools as the timecode master (gener-
ating) or when slaving. 

• Punch non-destructively with TrackPunch, or 
destructively with DestructivePunch. 

A typical pre-dub session includes the following 
steps:

1  Configure synchronization between Pro Tools 
and other devices as appropriate. 

2  Choose Setup > Preferences and click the 
Operation tab.

3  Select (enable) Transport RecordLock. This 
keeps the Transport Record armed after the 
transport stops.

4  Deselect Audio Track RecordLock. This causes 
the audio track record to disarm when the trans-
port stops.

In Remote mode, Transport RecordLock has 
no effect. The synchronizer determines the 
behavior.

In Remote mode, Audio Track RecordLock 
has no effect. The synchronizer determines 
the behavior.
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5  Do either of the following: 

• Select Options > TrackPunch to enable 
TrackPunch mode for non-destructive 
punch recording. 

• Select Options > DestructivePunch to enable 
DestructivePunch recording. 

6  Create 32 new tracks, then do the following: 

• Assign their inputs.

– and –

• Group them into eight-track groups. 

7  Click the record enable buttons in the first 
eight tracks to TrackPunch enable the first eight 
tracks (or, the group for the first pre-dub).

8  Assign the console paddles to the first eight-
track group in the session. 

9  Begin the pre-dub pass. Use the console pad-
dles to arm Pro Tools, and to punch in and out 
on the first group. 

10  When the first pre-dub is over and all tracks 
are punched out, clear all TrackPunch or De-
structivePunch enabled tracks.

11  Select the next group of tracks and Track-
Punch- or DestructivePunch-enable them.

12  Punch in and out on the second group of 
tracks. 

13  Repeat the preceding steps as necessary.

Use the Group List to quickly select all 
tracks in the group, and Alt-Shift-click 
(Windows) or Option-Shift-click (Mac) to 
record-enable all the tracks in the group.



Loading Dailies Using 
RecordLock
Dailies and similar types of transfers are com-
prised of multiple takes or scenes, each recorded 
while locked to unique time-of-day timecode. In 
between each take, timecode does not continue 
but stops completely. Because of this, the time-
code on dailies and similar source material is 
said to be “discontinuous” or discontinuous 
(also known as broken timecode). 

By default, Pro Tools drops out of recording 
when it goes offline due to broken timecode. 
However, you can change this behavior so that 
Pro Tools will instead remain armed, waiting to 
begin recording again when lock is re-estab-
lished with the timecode of the next take. 

To configure RecordLock for loading:

1  Choose Setup > Preferences and click the 
Operation tab. 

2  Enable Transport RecordLock. 

3  Enable Audio Track RecordLock. 

4  Configure synchronization and other settings 
as required. 

5  Put Pro Tools online, and start the external 
source player. 

6  Whenever timecode drops out or stops, 
Pro Tools remains online and waits to receive 
new timecode. The Transport and record-en-
abled tracks remain record-enabled. When time-
code resumes, Pro Tools begins recording to a 
new audio file (properly time stamped based on 
the incoming code). 

Because Pro Tools has a 13-hour Timeline 
limit, you must use multiple sessions to load 
dailies if the span is more than 13 hours.
Foley Recording 
Foley recording is one of the more specialized 
forms of recording in film production with 
unique monitoring requirements. Between 
punches and takes, inputs must be muted while 
Foley artists move themselves and equipment as 
they progress through a scene. 

TrackInput monitoring can be configured to 
support Foley style TrackPunch recording using 
the Mute Record-Armed Tracks While Stopped 
preference.

To configure Pro Tools for Foley-style punch 
record monitoring: 

1  Choose Setup > Preferences and click the 
Operation tab.

2  Enable Mute Record-Armed Tracks While 

Stopped.

3  Configure synchronization and other settings 
for Pro Tools and your other devices. 

4  Enable TrackPunch or DestructivePunch mode 
and proceed with punch recording. 

When recording online and Mute Record-Armed 

Tracks While Stopped is enabled, record-enabled 
tracks mute when the Transport is stopped. In-
put can still be monitored at any time by using 
the TrackInput switch. 
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Tracking and Overdubbing 
Music 
Modern multitrack recording requires the 
flexibility to “capture the moment” by allowing 
on-the-fly record enabling and punch recording, 
as provided by TrackPunch. Features of Track-
Punch for all tracking, overdubbing, and punch-
ing situations include the following:

• Record enable tracks on-the-fly. 

• Punch tracks in and out using on-screen 
Record Enable buttons, remotely from a 
synchronizer, from a control surface, or 
using a foot switch. 

• Compare and match levels using 
TrackInput switching. 
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Chapter 25: Editing Basics
Use the Edit window in Pro Tools to edit and ar-
range audio, video, and MIDI. Track material 
can be edited nondestructively and in real time 
during playback. 

The Edit window also lets you graphically edit 
other data, as follows:

Editing Clips and Selections See Chapter 28, 
“Editing Clips and Selections.” Also, see 
Chapter 38, “Arranging Clips.”

Editing Fades and Crossfades See Chapter 29, 
“Fades and Crossfades.”

Editing Elastic Audio See Chapter 41, “Elastic 
Audio.”

Editing MIDI See Chapter 32, “MIDI Editing.” 

Editing Automation See Chapter 45, “Automa-
tion.”

Editing Video See Chapter 51, “Working with 
Video in Pro Tools.”

Nondestructive Editing
The vast majority of audio editing in Pro Tools 
is nondestructive. Whether cutting, pasting, 
trimming, separating, or clearing clips, you are 
only performing these functions on a map of the 
actual media (such as audio files). The source 
files remain untouched. However, certain pro-
cesses or tools work destructively (can perma-
nently change audio files on your hard disk), as 
noted in other topics.
While editing for MIDI tracks is in some in-
stances destructive, with a few precautions you 
can keep important MIDI tracks and clips safe 
when performing edits (see “Nondestructive 
MIDI Editing” on page 530).

Editing during Playback
Pro Tools lets you perform many editing tasks 
while the session plays. This powerful capability 
lets you interactively modify and edit a session, 
hearing the changes as you make them. 

Following are just a few examples of editing and 
arranging tasks that can be performed while 
playing back a Pro Tools session:

• Capture, separate, cut, copy, paste, and trim 
clips.

• Place, spot, or rearrange clips.

• Add fades or crossfades to audio clips.

• Quantize MIDI notes and audio events.

• Transpose and otherwise modify MIDI 
tracks.

• Nudge audio or MIDI clips.

• Audition different playlists.

• Adjust or scale automation and MIDI con-
tinuous controller data.

• Insert real-time plug-ins.

Use Loop and Dynamic Transport modes for 
auditioning and editing loops during play-
back. See “Playback Modes” on page 427.
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• Apply Real-Time (and Rendered) Elastic 
Audio processing.

• Process audio with an AudioSuite plug-in.

• Automation editing.

There are a few things that cannot be changed 
while Pro Tools plays, as noted in relevant top-
ics.

Track Material
Each time you record or import audio, video, 
and MIDI, Pro Tools creates clips for the new 
track data, which not only indicate where the 
material begins and ends, but also provides vi-
sual feedback on its general character and con-
tent. When you record additional takes, or 
“punch in” on a specific location within a track, 
Pro Tools creates additional clips.

Clips are also created by cutting and pasting, re-
sizing, separating, and re-capturing existing 
clips. Clips in a session are listed in the Clip List, 
where they can be dragged to existing tracks. A 
track can contain any number of clips, in any ar-
rangement. The order and location of clips in a 
track define its playlist. 

In addition to audio and MIDI clips, tracks pro-
vide automation playlists of any automation 
data (such as volume and pan). Automation can 
be recorded and edited in the Mix, Edit, and 
MIDI Editor windows (see Chapter 45, “Auto-
mation”). 
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Clip Types
There are different types of audio and MIDI 
clips, based on how they are created:

Whole-File Audio Clips These audio clips are 
created when recording or importing audio, 
consolidating existing clips, and when nonde-
structively processing with an AudioSuite plug-
in. Whole-file audio clips reference an entire au-
dio file that resides on your hard drive. Whole-
file audio clips are displayed in bold in the Clip 
List (see Chapter 15, “The Clip List”). Normal 
clips often reference only a portion of the parent 
audio file and are created in the course of edit-
ing and, in some instances, when punch record-
ing or loop recording. 

User-Defined Clips These are clips that are ex-
plicitly defined, such as when you record or im-
port audio or MIDI; capture, separate, or con-
solidate a selection; trim a whole-file audio clip; 
or rename an existing clip.

Auto-Created Clips These clips are automatically 
created in the course of editing, and, in some in-
stances, when punch recording over existing 
clips. Since these clips can accumulate rapidly in 
a session, you can hide them in the Clip List. 
Auto-created clips can be turned into user-de-
fined clips by renaming them.

For information on video clips, see 
Chapter 51, “Working with Video in 
Pro Tools.”

For more information, see “Naming and 
Displaying Clips in the Clip List” on 
page 276. 



Offline Clips Clips are off line when their parent 
files cannot be located, or are not available, 
when opening a session or importing a track. Of-
fline clips appear in the Clip List as italicized 
and dimmed; they appear in playlists as light 
blue clips with italicized names. Offline clips 
can be edited like other clips, but they cannot be 
processed with AudioSuite plug-ins. 

Multichannel Clips These clips, which are dis-
played as a single clip in the Clip List, reference 
multiple clips and audio files for stereo and sur-
round tracks. Multichannel clips can be ex-
panded (by clicking the triangle next to their 
name) to see the individual channels, which can 
be dragged independently to tracks.

Clip Groups A clip group is a collection of any 
combination of audio and MIDI clips that looks 
and acts like a single clip. Clip groups are essen-
tially containers holding one or more clips. Clip 
groups can be created on a single track or on 
multiple adjacent audio, MIDI, and Instrument 
tracks. Clip groups let you “nest” multiple clips 
into “macro” clips for groove and tempo manip-
ulation, editing, and arranging (see “Clip 
Groups” on page 851). 

Warped Clips Clips on Real-Time Elastic Audio-
enabled tracks can be warped. Warped clips are 
identified with a Warp Indicator icon in the up-
per-right corner of clips on tracks and to the left 
of clip names in the Clip List. Warped clips re-
sult from the application of Elastic Audio pro-
cessing. Elastic Audio processing can be applied 
manually in Warp view or using the TCE Trim 
Tool in Waveform view, or automatically using 
tempo conform, quantization, or transposition 
(see “Warped Clips” on page 898). 
Audio Clips and Waveforms
When the Track View for audio tracks is set to 
Waveform, Pro Tools draws a waveform diagram 
of the audio. Audio waveforms tell you several 
things about the recorded sound.

In the figure above, the “peaks” represent places 
in the recording where the attack of the sound 
causes the volume to increase momentarily. 
These are followed by “valleys,” where the vol-
ume decreases.

Different types of sounds produce different 
types of waveforms. Drums, for example, gener-
ally produce waveforms with sharp transients 
(peaks of short duration) that are clearly de-
fined. A drum hit has a loud, sharp attack and a 
rapid decay.

Other sounds, such as vocals or sustained syn-
thesizer pads, produce very different wave-
forms. These sounds have less pronounced 
peaks and valleys because they generally have 
softer attacks and longer decays.

Waveform Views
Pro Tools provides a several different Waveform 
View options. Depending on the editing task, 
you may want to display waveforms in any num-
ber of different ways.

Audio waveform of a drum track
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Calculating Waveform 
Overviews
Waveforms can be calculated using Peak or 
Power overviews. 

To set how the Waveform view is calculated:

 Choose View > Waveforms and select one of 
the following:

• Peak 

– or –

• Power 

Peak When selected, the waveform display is 
calculated based on the sample-by-sample peak 
level. Peak view is traditionally how Pro Tools 
calculates the waveform overview and can be 
used for normal or rectified views. Peak view 
clearly displays any clipping in the waveform.

Power When selected, the wave form display is 
calculated according to the Root Mean Square 
(RMS). Power view can be used for normal or 
rectified views. Power view is useful for better 
seeing the characteristics of the audio in the 
waveform representation when zoomed out be-

Normal Peak Waveform view with Outlines

When zoomed in to the sample level, 
Pro Tools always displays Peak view.
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yond the sample level. For mastering applica-
tions in particular, it can be more revealing of 
the sonic characteristics of the audio than Peak 
view.

Rectified Waveforms
Rectified waveforms are displayed so that their 
positive and negative waveform excursions (the 
portions that fall above and below the center 
line) are summed together and viewed as a sin-
gle positive-value signal. This view lets you see 
more waveform detail in normal or reduced 
track height views. It can be particularly useful 
when editing volume automation data, since it 
depicts waveform levels as starting at the bot-
tom of the track. Rectified view is available in 
both Peak and Power views.

Normal Power Waveform view with Outlines

Peak view is always shown during record-
ing. Power waveform view is calculated and 
shown only after you stop recording.

Power view is not available in Destructive 
Punch mode or when zoomed to the sample 
level.



To show waveforms rectified (or normally):

 Select (or deselect) View > Waveforms > 

Rectified.

Outlined Waveforms
Outlined waveforms provide more visual defini-
tion of the waveform, especially when viewed 
from a distance. However, you may want to dis-
able Outlines when you need to do precise, de-
tailed editing in Peak waveform view. Outlines 
are not displayed when you are zoomed in to the 
sample level.

Rectified Peak Waveform view with Outlines

Rectified Power Waveform view with Outlines

When zoomed in to the sample level, 
Pro Tools always displays waveforms in 
Normal Peak view.
To show (or hide) waveform outlines:

 Select (or deselect) View > Waveforms > 

Outlines.

Peak Waveform view without Outlines

Power Waveform view without Outlines

Rectified Peak Waveform view without Outlines

Rectified Power Waveform view without Outlines
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Guidelines for Editing 
Waveforms
With the Selector tool in the Edit window, you 
can select portions of audio waveforms and di-
vide them into segments called clips, so that you 
can rearrange and manipulate them in tracks.

While editing musical material, try to create 
clips that let you maintain a consistent beat. If 
you always define clips so that they contain a 
whole number of beats, you will be able to string 
the clips together and maintain a smooth, steady 
rhythm.

It is sometimes useful to have a steady, well-de-
fined reference waveform (such as a drum track 
or click track) as a guide when selecting and de-
fining other clips. If you have played in time 
with the beat, it should be easier to create rhyth-
mically accurate clips by referring to the refer-
ence waveform.

Some important rules to keep in mind when de-
fining clips:

 Whenever possible, begin a clip precisely be-
fore a volume peak, and end it immediately be-
fore another volume peak.

 Whenever possible, make sure a clip starts and 
ends on exactly the same part of a beat.

 Use the following Pro Tools features to help 
you edit rhythmic material or audio with clear 
transients into precise clips:

• Tab to Transients (see “Tabbing to Tran-
sients” on page 580.)

• Editing to a Grid (see “Grid Mode” on 
page 541)

• Beat Detective (see Chapter 31, “Beat De-
tective”)
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Avoiding Clicks and Pops
If an edited clip begins or ends at a point of high 
amplitude, you may hear a click when Pro Tools 
plays from one clip to another. In order to avoid 
clicks or pops do any of the following:

 Make sure that the start and end points of your 
selection are as close as possible to the point 
where the amplitude of the waveform tapers 
down to meet the zero-crossing line (the center 
line of the track’s waveform display). If neces-
sary, use the zooming tools in the Edit window 
(see “Zooming Options” on page 544) to display 
waveforms in greater detail.

 Apply a crossfade between clips where a click 
or pop occurs. See “Creating a Crossfade” on 
page 625 for details.

 With Pro Tools HD and Pro Tools with Com-
plete Production Toolkit, use the AutoFade fea-
ture to apply real-time fade-ins/outs to all clip 
boundaries that do not touch or overlap other 
clips. See “Using AutoFades” on page 626 for de-
tails.

Selection that begins and ends at zero crossings



Nondestructive Audio Editing
When editing an audio track’s playlist in 
Pro Tools, you are not actually cutting and mov-
ing pieces of sound as you would if you were cut-
ting and splicing analog tape. Instead, Pro Tools 
creates a map of the audio file on your hard disk, 
which describes the order in which to play vari-
ous portions of the audio.

When trimming audio clips with any of the Trim 
tools, or when editing the placement or order of 
clips within a track, you can use multiple play-
lists to easily return to a track’s previous state. 
For more information, see “Playlists” on 
page 633.

Audio Clips and Automation 
Data
Automation data for audio resides in tracks and 
not in the Clip List. This means that when you 
drag an audio clip from the Clip List to a new 
track, no automation data is placed in the track. 
However, if you drag an audio clip from an ex-
isting track (that contains automation data) to 
another track, the automation from the source 
track is placed in the destination track.

You can edit automation data by switching track 
views or by revealing the automation lanes un-
der the track.

For more information on automation, see 
Chapter 45, “Automation.”
MIDI Clips and MIDI Data
The two most common Track Views you will use 
for MIDI and Instrument tracks are Notes and 
Clips:

 Use Clips view for arranging clips.

 Use Notes view for inserting and editing indi-
vidual MIDI notes, and for working with and af-
fecting groups of notes.

Clips View for MIDI and 
Instrument Tracks
MIDI and Instrument tracks can be viewed as 
Clips, which is similar to Waveform view for au-
dio tracks. While a track’s notes are visible in 
Clips view, individual note editing is not avail-
able in this view. Instead, all editing occurs 
across a time range encompassing all track data, 
including continuous controller events, pro-
gram changes, and System Exclusive events.

Use Clips view to define clips that represent 
song sections and clips, or to rearrange or as-
semble track material.

In Clips view, the vertical zoom is automatically 
scaled to fit the entire range of pitches of MIDI 
notes on a track.

For more information on setting Track 
View, see “Track Views” on page 226.

To toggle the Track View between Notes and 
Clips, click in the track you want to toggle 
and press Start+Minus (Windows) or Con-
trol+Minus (Mac) on the alphanumeric 
keyboard.

You can double-click a MIDI clip to open it 
in the MIDI Editor window. See Chapter 33, 
“MIDI Editors.”
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There are a few things to consider when select-
ing, copying and cutting, and trimming MIDI 
clips:

 When cutting or clearing a clip or clip group 
selection that includes a note’s start point, the 
entire note is removed. This is even the case 
when only a portion of the note (that includes its 
start point) is selected.

 When cutting or clearing a clip or clip group 
selection that includes a note’s end point (but 
not its start point), the note remains and over-
laps the edge of the clip.

 Similar rules also apply when MIDI clips or 
clip groups containing MIDI clips are trimmed 
with any of the Trim tools. If the MIDI clip’s start 
point is moved beyond a note’s start point, the 
note is removed. If the clip’s end point is 
trimmed so that a note’s start point is within the 
clip but its end point is not, the note remains and 
overlaps the edge of the clip.

Cutting a MIDI clip with note overlap
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When moving and placing MIDI clips with over-
lapping notes, the notes always move with the 
clips. When placing MIDI clips with overlapping 
notes next to or near another clip, the overlap-
ping notes extend into the next clip on the track.

MIDI Clips Created on Barlines

When recording MIDI, or when manually enter-
ing MIDI notes, the beginning and ending of re-
sulting MIDI clips are constrained to bar bound-
aries. This facilitates arranging MIDI clips in a 
musically meaningful way, in whole bar lengths.

The beginning of a recorded MIDI clip always 
starts on the barline immediately before the first 
MIDI note (Note On) of the clip. Likewise, the 
MIDI clip ends on the barline immediately fol-
lowing the last note (Note Off) of the clip. 

MIDI Clips and Continuous Controller 
Events

Continuous controller events reside in MIDI 
clips and not in tracks. This means that when 
dragging clips that contain controller data from 
either a track or the Clip List, the controller data 
is written to the destination track.

You can edit continuous controller events by 
switching track views or by revealing the con-
troller lanes under the track.

To separate MIDI notes, rather than leave 
them hanging, when separating, cutting or 
copying clips, make the Edit selection you 
want, switch to Notes view and use the Sepa-
rate At Selection command, then switch back 
to Clips view and make the edit (separating, 
cutting, or copying).

For more information on editing MIDI con-
troller data, see Chapter 32, “MIDI Editing.”



MIDI Mute Automation

Unlike continuous controller events, which rep-
resent nuances that are part of a MIDI perfor-
mance, Mute in Pro Tools is an automation 
playlist that actually mutes the MIDI engine. 
Mute automation does not correspond to actual 
MIDI events and is therefore not exported when 
saving as a Standard MIDI File.

Notes View for MIDI and 
Instrument Tracks
When a MIDI or Instrument track’s Track View 
is set to Notes, MIDI notes are displayed in a 
“piano roll” format. Each note is displayed as a 
small rectangle with its vertical placement indi-
cating pitch and its horizontal placement indi-
cating location in time (and duration).

To the left of the MIDI or Instrument track’s 
playlist is a vertical mini-keyboard, complete 
with octave numbering, for pitch reference. You 
can click the mini-keyboard to play pitches us-
ing the track’s selected MIDI output. Arrows at 
the top and bottom of the mini-keyboard (not 
available in the smaller track heights) are used 
to scroll the Notes display up and down.

MIDI track displaying notes

Up Arrow

Down Arrow

MIDI note above the current display

Keyboard reference MIDI note
In Notes view, the pitch range of MIDI notes 
that can be displayed depends on the track 
height, and on the current zoom value. Any time 
a track’s notes do not fit within its current 
height, notes above or below the viewed area are 
displayed as single-pixel lines at the very top 
and bottom of the range.

To scroll the Notes display up or down for a MIDI or 
Instrument track, do one of the following:

 Click either the up or down arrow of the mini-
keyboard.

 With any of the Edit tools (such as the Time 
Grabber tool) selected, press Control+Alt+Start 
(Windows) or Command+Option+Control 
(Mac) and drag up or down on the mini-key-
board.

 If you have a mouse with a scroll wheel, move 
the cursor over the track and Control-Alt-Start-
scroll (Windows) or Command-Option-Control-
scroll (Mac) up or down to scroll the notes dis-
play up or down.

Clicking the mini-keyboard clears the cur-
rent Edit selection. For more information, 
see “Selecting MIDI Notes” on page 686.

Scrolling notes with the Up Arrow on mini-keyboard

Scrolling Notes display by dragging
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Using the Edit tools, notes can be inserted, de-
leted, transposed, trimmed, and moved. For 
more information, see “Manually Editing MIDI 
Notes” on page 686.

Nondestructive MIDI Editing
While editing audio clips is usually nondestruc-
tive, this is generally not the case for MIDI clips. 
For instance, if a MIDI clip resides in just one 
track at a single location, editing for that clip is 
destructive. This means that altering the pitch, 
duration, or placement of notes in Notes view 
permanently alters the clip.

However, if the Mirror MIDI Editing option is dis-
abled, when editing a MIDI clip that appears 
elsewhere in the session (either on the same 
track at another location or in a different play-
list, or in another track), editing is nondestruc-
tive and creates a new auto-created clip. To go 
back to the previous material, drag the original 
clip from the Clip List, or return to a previously 
saved playlist.

One way to safely return to a track’s previ-
ous state is with playlists. Before you edit 
notes, trim clips, or rearrange the order of 
clips, make a duplicate of the track’s exist-
ing playlist and then edit the duplicate (see 
“Playlists” on page 633).

To apply edits to all instances of a MIDI 
clip, enable Mirrored MIDI Editing mode 
(see “Mirrored MIDI Editing” on page 681).
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Naming Clips
You can rename clips to give them more descrip-
tive names, or to simplify existing names. When 
renaming a clip that was auto-created during 
editing, the clip becomes a user-defined clip and 
is displayed in the Clip List even when auto-cre-
ated clips are hidden.

To rename a clip on a track:

1  Do one of the following:

• Select the clip you want to rename and then 
choose Clip > Rename.

• With any of the Edit tools, Right-click the 
the clip that you want to rename and select 
Rename from the pop-up menu.

• Press Control+Shift+R (Windows) or Com-
mand+Shift+R (Mac).

• With the Grabber tool, double-click the clip 
you want to rename. For MIDI clips, the 
Name Dialog option must be selected as the 
Double-Clicking a MIDI Clip Opens setting in 
the MIDI Preferences.

2  In the Name dialog, type a new name for the 
clip. If a whole-file audio clip was selected, spec-
ify whether to rename just the clip, or both the 
clip and the disk file.

3  Click OK to rename the clip. 

For details on renaming clips, see “Renam-
ing Clips” on page 276.

Name dialog



Displaying Clip Names, Clip 
Times, and Other Data
Clip names and times can sometimes get in the 
way of editing audio waveforms and MIDI data. 
In these instances, you may want to disable their 
display. In other instances, such as arranging or 
spotting Foley, displaying clip names and times 
is extremely useful.

To enable or disable the display of clip names in 
playlists:

 Select or deselect View > Clip > Name.

To display clip times:

 From View > Clip, select one of the following 
options:

No Time Disables display of clip times.

Current Time Displays start and end times for 
clips.

Original Time Stamp Displays the Original Time 
Stamp for each clip. The Original Time Stamp is 
the original timecode location for the clip when 
it was first recorded or created.

User Time Stamp Displays the User Time Stamp 
for each clip. The User Time Stamp, which de-
faults to the Original Time Stamp, can be rede-
fined with the Time Stamp command.

Displaying Clip Data on All Channels

For stereo and greater-than-stereo multichannel 
tracks, clip data can be shown on all channels.

Display enabled for clip names, Overlap, and times
To enable or disable the display of clip data on all 
channels:

 Select or deselect View > Clip > Display on All 

Channels.

Displaying Other Clip Information

You can also choose to display the following in 
clips:

Sync Points Can be displayed on clips in play-
lists. This is useful when visually spotting to 
timecode or in arranging in Grid mode. For 
more information, see “Sync Points” on 
page 837.

Processing State For clips that are processed 
with Elastic Audio, displays a Warp indicator in 
playlists and in the Clip List. See “Warped Clips” 
on page 898.

Channel Name and Scene And Take 
Information Can be displayed in clips in playlists 
and in the Clip List. This is useful for working 
with multichannel recordings and metadata 
made by field recorders. For detailed informa-
tion on workflows for field recorders, see 
Chapter 52, “Working with Field Recorders in 
Pro Tools.”

Rating Can be displayed on clips in playlists. 
This is useful for arranging when working with 
multiple playlists and alternate takes. See “Rat-
ing Clips” on page 613.

Clip Overlaps Can be displayed on clips in play-
lists. This is useful for arranging and when 
working with tick-based audio tracks. See “Clip 
Overlap and Underlap” on page 595.

Clip Gain Line Shows the Clip Gain Line for all 
clips in the Edit window. The Clip Gain Line lets 
you edit the clip gain settings for any given clip 
using breakpoint editing, much like with track-
based volume automation. See “Clip Gain Line” 
on page 604.
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Clip Gain Info Shows the Clip Gain Fader icon at 
the beginning of the clip, in the lower left cor-
ner. If the clip uses static clip gain, the static 
Clip Gain value (–144 dB to +36.0 dB) for a clip 
is displayed to the right of the Clip Gain Fader 
icon. For a clip that has dynamic clip gain (using 
breakpoint gain settings), the Clip Gain value is 
not shown. For more information, see “Clip 
Gain Info View” on page 603.

Multiple Undo
Pro Tools can keep track of up to 32 of the last 
undoable operations, allowing you to return to a 
previous editing state. 

The Undo operations in Pro Tools are stored in a 
queue, in the order in which they were invoked. 
When choosing Edit > Undo, the most recent op-
eration is undone. If you choose Undo again, the 
next operation in the queue is undone. You can 
also choose Edit > Redo to redo an operation, 
which moves back through the Undo queue by 
one step.

When the number of operations in the Undo 
queue reaches the maximum specified level of 
Undo (set in the Editing Preferences page), per-
forming another undoable operation will re-
move the oldest operation at the top of the 
queue.

To undo the last operation, do one of the following:

 Choose Edit > Undo.

– or –

 Press Control+Z (Windows) or Command+Z 
(Mac).

If no actions are available to undo, the 
menu displays Can’t Undo.
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To redo the last undone operation, do one of the 
following:

 Choose Edit > Redo.

– or –

 Press Shift+Control+Z (Windows) or 
Shift+Command+Z (Mac).

Undo History Window
You can use the Undo History window to view 
the queue of the undoable and redoable opera-
tions and return to any previous state. The Undo 
History can show edit creation times, enabling 
you to revert to the state a session held at a par-
ticular time. 

To show (or hide) the Undo History window:

 Choose Window > Undo History.

To undo operations in the Undo History window:

 Click the operation (bold) in the list to undo. 

If no actions are available to redo, the menu 
displays Can’t Redo.

Undo History Window

Undoable
operations

Redoable 
operations

Creation times

Options selector



All operations in the queue that were performed 
after the operation you select are also undone. 
In the Undo History window, undoable opera-
tions are shown in bold and redoable operations 
(operations that have already been undone) are 
shown in italics.

To redo operations in the Undo History window:

 Click the operation (italics) in the list to redo.

The operation you choose, as well as all the op-
erations in the queue before it, are redone.

To toggle display of creation times in the Undo 
History window:

 Click the Options pop-up menu and choose 
Show Creation Times. 

To undo all the operations in the Undo Queue:

 Click the Options pop-up menu and choose 
Undo All.

To redo all the operations in the Redo Queue:

 Click the Options pop-up menu and choose 
Redo All.

Clearing the Undo Queue

To manually clear the Undo Queue

 Click the Options pop-up menu and choose 
Clear Undo Queue.

Other operations that clear the Undo Queue in-
clude:

• Deleting a track, or clearing a clip from the 
Clip List

• Selecting Select > Unused, or Select > Un-

used Audio Except Whole Files in the Clip 
List menu
When the number of operations in the Undo 
History reaches the maximum level of Undo, 
performing another undoable operation re-
moves the oldest operation at the top of the 
Undo History queue. When the oldest operation 
is one operation away from being pushed out of 
the queue, it is shown in red.

Levels of Undo and Memory
Because Pro Tools needs to keep track of the 
playlists for all tracks that are edited, the use of 
multiple levels of Undo can be memory inten-
sive. You can lower the Levels of Undo setting 
(Editing Preferences) in Pro Tools to reduce the 
amount of system memory (RAM) used by the 
Undo queue. If you have plenty of memory avail-
able for Pro Tools, you can use a higher Levels 

Of Undo setting.

To set the Levels of Undo in Pro Tools:

1  Choose Setup > Preferences and click the 
Editing tab.

2  Click in the Levels of Undo field and type a 
value between 1–32.

3  Click OK.

Use the Undo History window to view a 
queue of undo operations and return to a 
previous state.

Levels of Undo preference
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Basic Editing Commands
Pro Tools provides many standard edit com-
mands (such as Cut, Copy, and Paste). Pro Tools 
also provides many specialized edit commands 
that are optimized for audio and MIDI produc-
tion (such as Repeat Paste to Fill).

Cut, Copy, Paste, and Clear
Use the Cut, Copy, Paste, and Clear commands 
to rearrange and edit track material. Edits can 
operate on entire clips selected with the Time 
Grabber tool, or on track ranges selected with 
the Selector tool. Edits can also work across 
multiple tracks (see “Editing Across Multiple 
Tracks” on page 537).

Track View and Edit Content
When cutting or copying track material, the 
Track View determines the type of data placed 
on the Clipboard. When editing in a track’s Mas-
ter View (Waveform view for audio tracks and 
Clips view for MIDI or Instrument tracks), se-
lections can include all underlying automation 
and controller data (“Automation Follows Edit 
Option” on page 1030). Thus, cutting an audio 
clip can also cut any volume, pan, mute, send, 
continuous controller, or plug-in automation 
that is also on the track. This saves you from 
having to individually cut from each automation 
playlist on the track.

You can Cut, Copy, and Paste noncontiguous 
clips by selecting them with the Object Grab-
ber tool.

Audio waveform data
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When selecting groups of MIDI notes in Notes 
view with any of the Grabber tools (by drawing a 
rectangle around them), only the note data is 
placed on the Clipboard. When selecting a time 
range of MIDI notes (in Notes view) with the Se-
lector tool, all controller data in the track is se-
lected (similar to selecting with the Selector tool 
for audio tracks in Waveform view).

When a track is displaying automation data or 
controller data, only that data is placed on the 
Clipboard. Also, whenever you cut or copy auto-
mation data, bounding breakpoints are created 
at each end of the selected area, in order to pre-
serve the slope of the automation both inside 
and outside the selection.

If tracks are grouped, copying and pasting on 
any of the tracks affects each of the other tracks 
in the group. Tracks that are hidden—even if 
they are part of a group being edited—are not 
affected by edits.

The Shuffle Clips option affects how material is 
cut and pasted:

Automation data with Cut and Pasted audio clip

Use Control+Start+V (Windows) or Com-
mand+Control+V (Mac) to special paste 
automation data into another automation 
type. For example, you can copy Pan auto-
mation into a Volume automation playlist.



• When Shuffle Clips is enabled, the Cut com-
mand leaves no empty space, since the clips to 
the right of the cut slide over, closing the gap. 
Otherwise the Cut command leaves an empty 
space corresponding to the data removed from 
the track. 

• When Shuffle Clips is enabled, pasted data 
causes all clips to slide over to make room for 
the pasted material. Otherwise, pasted data 
can overlap an adjacent clip.

New clips are often auto-created when perform-
ing edits. For instance, when clearing a selection 
from a clip, new clips are auto-created from the 
material residing outside of the selection.

Cut and Copy Commands
Use the Cut command to remove the selection 
from the track and place it on the Clipboard.

Use the Copy command to place a copy of the se-
lection on the Clipboard so it can be pasted to 
another track, or to the same track at a different 
location, while leaving the original intact and in 
place.

To cut or copy a selection or clip:

1  If you want to constrain the selection to the 
current Grid value, enable Snap to Grid. 

2  Set the Track View for the tracks you want to 
edit.

When displaying waveforms for audio tracks, or 
notes or clips for MIDI tracks, selections include 
underlying automation and controller data. If 
the track is displaying automation data, only the 
automation data is affected by the edits.

For more information on the Shuffle Clips 
option, see “Shuffle Mode” on page 539.
3  Make an Edit selection of the material you 
want to Cut or Copy.

4  Do one of the following:

• Choose Edit > Cut to remove the selection 
and place it on the Clipboard.

– or –

• Choose Edit > Copy to place the selection on 
the Clipboard, without removing it.

If a portion of a clip was cut or copied, the ma-
terial on the Clipboard appears as a new clip in 
the Clip List. If a portion of a clip was cut, new 
clips are auto-created from the material residing 
outside of the selection. 

When Shuffle Clips is enabled, any subsequent 
clips slide over to fill any empty space.

Deleting Underlying Clip Data

When removing a clip or selection, you can 
choose to remove or keep the underlying clip 
data.

To delete a clip or selection along with the 
underlying clip data:

 Choose Edit > Cut.

To delete a clip or selection without removing the 
underlying clip data:

 Choose Edit > Clear.

For information on making Edit selections, 
see “Selecting Track Material” on page 571.
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Paste Command
Use the Paste command to place the contents of 
the Clipboard at the Edit insertion point, and 
overwrite any material already there.

To paste a selection or clip:

1  If you want to constrain the insertion point or 
the selection to the current Grid value, enable 
Snap to Grid. 

2  Do one of the following:

• With the Selector tool, click in a track at the 
point where you want to paste the material.

– or –

• Use the Selector or Time Grabber tool to 
make a selection where the material will be 
placed.

3  Choose Edit > Paste.

If pasting at an insertion point with Shuffle 
Clips enabled, material to the right of the paste 
point is shifted to the right. Otherwise, any ma-
terial within the paste range is overwritten.

If pasting into a selection with Shuffle Clips en-
abled, the selection is replaced by the Clip-
board’s contents with the adjacent material slid 
left or right as necessary. Otherwise, the selec-
tion is also replaced but with the surrounding 
material remaining unchanged.

With the Grabber tool, Start-click (Win-
dows) or Control-click (Mac) a clip to con-
form it to the current selection.

When working with MIDI, you can merge 
the contents of the Clipboard with material 
in the destination track using Edit > Paste 
Special > Merge. For more information, see 
“Paste Special” on page 1056.
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Clear Command
Use the Clear command to remove a selection 
from a track without placing it on the Clipboard.

To clear a selection or clip:

1  If you want to constrain the selection to the 
current Grid value, enable Snap to Grid. 

2  Set the Track View for the tracks you want to 
edit.

When displaying waveforms for audio tracks, or 
notes or clips for MIDI tracks, selections include 
underlying automation and controller data. If 
the track is displaying automation data, only the 
automation data is affected by the edits.

3  Make an Edit selection.

4  Choose Edit > Clear to remove the selection.

If a portion of a clip was cleared, new clips are 
auto-created from the material residing outside 
of the selection. When Shuffle Clips is enabled, 
any subsequent clips slide over to fill any empty 
space.

Special Cut, Copy, Paste, and 
Clear Commands
Use the four “special” Edit menu commands 
(Cut Special, Copy Special, Paste Special, and 
Clear Special) for cutting, copying, pasting, and 
clearing automation (volume, pan, mute, and 
plug-in automation) on audio, Auxiliary Input, 
Master Fader, VCA Master, and Instrument 
tracks. These commands can also be used for 
MIDI controller data on MIDI and Instrument 



tracks. There are also Cut Special, Copy Special, 
and Clear Special commands for cutting, copy-
ing, and clearing clip gain settings (see “Clip 
Gain” on page 602).

Repeat To Fill Selection
The Repeat to Fill Selection command lets you 
automatically fill a selection with audio or MIDI 
clips or data without requiring that you manu-
ally duplicate the clips. To use Repeat to Fill Se-

lection, Cut or Copy a clip, then make a selection 
and use the command to fill the selection. When 
pasting audio clips, you are prompted to specify 
a crossfade to be used for the pasted clips. 

If you fill an area that is an exact multiple of the 
copied clip size (for example, filling 16 bars with 
a 4-bar clip), the copied selection is pasted as 
many times as it takes to fill the selection. If you 
fill an area that is not an exact multiple of the 
copied clip size (for example, filling 15 seconds 
of a track with a 2-second clip of room noise), 
the remaining selection area is filled with an au-
tomatically trimmed version of the original se-
lection.

To fill a selection with Repeat to Fill Selection:

1  Select the clip you want to copy.

2  Choose Edit > Copy.

3  Select the area you want to fill using the Selec-
tor tool and choose Edit > Paste Special > Repeat 

to Fill Selection.

You cannot paste MIDI controller data to 
automation data nor automation to MIDI.

For more information, see “Cutting, Copying, 
and Pasting Automation” on page 1053.
4  Do one of the following:

• If pasting audio clips to larger areas, the 
Batch Fades dialog opens. Configure the di-
alog to create crossfades between each 
pasted clip, then click OK.

– or –

• If you do not want crossfades for the 
pasted audio, click Cancel in the Batch 
Fades dialog.

Editing Across Multiple 
Tracks
When working with data from multiple tracks, 
there are some important points to remember. 
For example, if any selected tracks are set to 
their master view (see “Master Views for 
Tracks” on page 230), edits affect not only audio 
and MIDI for the selected tracks, but all automa-
tion and controller data as well.

If all selected tracks are displayed as automation 
data, edits only affect the type of automation 
data displayed in each track. Furthermore, if 
track 1 displays Pan automation, track 2 dis-
plays Volume automation, and track 3 displays 
Mute automation, the Cut command cuts only 
pan data from track 1, volume data from track 2, 
and mute data from track 3.

To copy all types of automation on all selected 
tracks when copying only automation or controller 
data:

 Choose Edit > Copy Special > All Automation.

For more information on selecting data on 
multiple tracks, see “Selecting Across Multi-
ple Tracks” on page 577.
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To paste to multiple tracks:

1  Do one of the following:

• Place the insertion point in each of the des-
tination tracks by Shift-clicking in them.

• Make a selection in one of the Timebase 
rulers.

2  Choose Edit > Paste.

When you paste multiple types of data, whatever 
data has been copied is pasted into the correct 
type of playlist. Automation data is pasted into 
the corresponding automation playlist. Audio or 
MIDI data is pasted into the audio or MIDI play-
list. You do not need to set target tracks to the 
specific type of data being pasted for the paste to 
work correctly.

If all destination tracks in a multitrack paste are 
displayed as automation, the paste replaces any 
previous data on the target track without shuf-
fling—regardless of whether Shuffle Clips is en-
abled.
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Chapter 26: Edit Modes and Tools
Pro Tools provides four Edit modes and various 
Edit tools to help you successfully edit material.

Edit Modes
Pro Tools has four Edit modes: Shuffle, Spot, 
Slip, and Grid. Grid mode provides two modes of 
operation, Relative and Absolute, explained be-
low. The Edit mode is selected by clicking the 
corresponding button in the upper left of the 
Edit window.

The Edit mode affects the movement and place-
ment of audio and MIDI clips (and MIDI notes), 
how commands like Copy and Paste function, 
and also how the various Edit tools (Trim, Selec-
tor, Grabber, and Pencil tools) work.

Edit mode buttons

Use the Accent key ( ` ) to toggle through the 
Edit modes.
Shuffle Mode
In Shuffle mode, you can move, trim, delete, cut, 
or paste clips freely within a track or to other 
tracks, but their movement is constrained by 
other clips. That is, if you place several clips in a 
track, they automatically snap to each other. 
You can then “shuffle” their order, but you can-
not separate them from each other and you can-
not make them overlap as in Slip mode. How-
ever, if there is silence between existing clips, 
and the clips are shuffled, the silence is main-
tained, and not removed.

In Shuffle mode, adding another clip to the be-
ginning of a track moves all subsequent clips to 
the right (later in time) by the length of the 
added clip. 

When using any of the Trim tools in Shuffle 
mode, changing a clip’s start or end point auto-
matically moves any subsequent clips as neces-
sary. The placement and insertion of MIDI notes 
is not affected by Shuffle mode.

Press F1 to enable Shuffle mode. 
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Shuffle Lock
With certain workflows, it is important to ex-
clude Shuffle mode in order to ensure that clips 
stay time-aligned while editing. Shuffle Lock 
prevents you from inadvertently entering Shuf-
fle mode by disabling all key commands and 
control surface switches for Shuffle mode. You 
cannot invoke Shuffle Lock while in Shuffle 
mode. 

To lock out Shuffle Mode:

 While in any Edit mode other than Shuffle 
mode, Control-click (Windows) or Command-
click (Mac) the Shuffle button on-screen. A lock 
icon appears in the Shuffle button. 

To unlock Shuffle Mode:

 Control-click (Windows) or Command-click 
(Mac) the locked Shuffle button on-screen.

Shuffle Lock enabled
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Slip Mode
In Slip mode, clips can be moved freely within a 
track or to other tracks. In this mode, it is pos-
sible to place a clip so that there is space be-
tween it and other clips in a track. When the 
track is played back, this space is silent. It is also 
possible to move a clip so that it overlaps or 
completely covers another clip.

Use Slip mode when you want the Trim, Selec-
tor, Grabber, and Pencil tools to work without 
any restrictions to placement in time.

Spot Mode
Use Spot mode to place clips at precise loca-
tions. In Spot mode you can specify a frame lo-
cation (or a location based on any of the other 
time formats), capture an incoming Timecode 
address, or use a clip’s time stamps as reference 
points for spotting. This can be particularly use-
ful when performing post production tasks 
around SMPTE frame locations. 

When Spot mode is enabled, Pro Tools asks you 
to specify a destination location when a clip is 
dragged from the Clip List, a DigiBase browser, 
Windows Explorer, or the Mac Finder.

Press F2 to enable Slip mode. 

Press F3 to enable Spot mode. 



Grid Mode
In Grid mode, clips and MIDI notes that are 
moved, trimmed or inserted “snap” to the cur-
rently selected Grid value, or to precise incre-
ments on a user-definable time grid. 

Displaying Grid Lines

To show (or hide) the Grid lines in the Edit window 
or in a MIDI Editor window, do one of the following:

 Select (or deselect) the Grid button.

– or –

 Click the Name of the currently selected Time-
base ruler.

Press F4 to enable Grid mode. 

Grid button selected in the Edit window

Turning on Grid lines from a Timebase ruler
Absolute and Relative Grid
Grid mode can be applied in Absolute or Rela-
tive mode: 

 In Absolute Grid mode, moving any clip snaps 
the clip start to Grid boundaries. If a clip’s start 
point falls between beats, and the Grid is set to 
1/4 notes, dragging the clip will snap its start 
time to the nearest 1/4 note (the current abso-
lute Grid value). 

 In Relative Grid mode, clips can be moved by 
Grid (or Nudge) units. If a clip’s start point falls 
between beats and the Grid is set to a 1/4 note 
(assuming the 1/4 note gets the beat), dragging 
the clip will be constrained to 1/4 notes, preserv-
ing the clip’s relative position to the nearest beat. 
For more information on Relative Grid mode, 
see “Sliding Clips in Grid Mode” on page 833. 

To select Absolute or Relative Grid mode:

 Click the Grid mode selector and choose Abso-

lute or Relative. 

To temporarily suspend Grid mode and 
switch to Slip mode while dragging a clip, 
hold down the Control key (Windows) or 
Command key (Mac) after clicking the 
mouse.
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Snap To Grid
Pro Tools lets you enable Snap To Grid while in 
Shuffle, Slip, or Spot mode. When in any of these 
modes with Snap To Grid also enabled, placing 
the Edit cursor and making Edit selections is 
constrained by the Grid, but any clip editing is 
also affected by the other selected Edit mode. 

For example, in Shuffle mode, with Snap To Grid 
enabled, you can make a selection in a clip based 
on the Grid, cut the selection, and any clips to 
the right of the edit shuffle to the left.

To enable Snap To Grid while in another Edit 
mode:

 Shift-click the Grid mode button.

To enable Shuffle, Slip, or Spot while in Grid mode:

 Shift-click the Shuffle, Slip, or Spot mode but-
ton.

Shuffle mode with Snap To Grid enabled

Press Shift+F4 to enable Snap To Grid while 
in another Edit mode.

Press F1+F4 to enable Snap To Grid and 
Shuffle mode; press F2+F4 to enable Snap 
To Grid and Slip mode; and press F3+F4 to 
enable Snap To Grid and Spot mode.
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Configuring the Grid
The actual Grid size, chosen from the Grid value 
selector can be based on a time value using the 
Main Time Scale; or, if the Follow Main Time 

Scale option is deselected, another time format 
can be used for the Grid size. 

The Grid Value indicator and selector are lo-
cated in the Edit window. Also, the Score Editor 
window and MIDI Editor windows each provide 
an independent Grid Value indicator and selec-
tor.

Grid Value indicator and pop-up menu

The current Grid value is also used for the 
Quantize to Grid command (see “Quantiz-
ing Clips to Grid” on page 601) and Sepa-
rated Clip At Grid command (see “Separate 
Commands” on page 592).



The Clips/Markers option in the Grid Value 
menu allows events to be placed freely (as in Slip 
mode), but they will snap to clip locations (start, 
end, and sync points), markers, and Edit selec-
tions when placed near them.

Grid Mode Lock
To ensure that you do not inadvertently change 
the Grid mode setting when using Edit mode 
keyboard shortcuts, you can enable Edit/Tool 

Mode Keyboard Lock.

To lock (or unlock) the selected Grid mode:

1  Click the Grid mode selector and choose Abso-

lute or Relative.

2  Select (or deselect) Options > Edit/Tool Mode 

Keyboard Lock.

MIDI notes inserted with the Pencil tool ig-
nore the Clips/Markers option, and instead 
snap to the time value selected in the Grid 
Value selector.
Edit Tools
Pro Tools provides the following Edit tools: the 
Zoomer, Trim, Selector, Grabber, Scrubber, and 
Pencil tools, and the multifunctional Smart 
Tool. 

To select an Edit tool:

 Click the icon for the tool you want in the 
Toolbar. 

The Zoomer, Trim, Grabber, and Pencil tools 
have multiple modes, which you can select from 
a pop-up menu when you click the tool.

Zoom Buttons Use the Zoom buttons to zoom in 
and out vertically and horizontally on MIDI and 
audio track material. You can also store and re-
call five Zoom presets.

Zoomer Tool Use the Zoomer tool to select a 
zoom view in a track.

Zoom buttons and Edit tools

You can use F5 (Zoomer), F6 (Trim), F7 
(Selector), and F8 (Grabber), F9 (Scrubber), 
and F10 (Pencil) to select and toggle 
through the modes for each tool. 

Press the Escape key to toggle through the 
Edit tools.

Zoom Toggle

Smart Tool Pencil
Zoomer

Trim
Selector

Grabber

Scrubber
Zoom buttons
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Zoom Toggle Use the Zoom Toggle to switch be-
tween the current zoom view and a defined 
zoom view.

Trim Tools Use the Trim tools to trim clips and 
clip groups.

Selector Tool Use the Selector to make selec-
tions on tracks.

Grabber Tools Use the Grabber tools to select, 
separate, or move clips on tracks.

Smart Tool Use the Smart tool to Trim, Select, or 
Grab clips in tracks.

Scrubber Tool Use the Scrubber tool to scrub 
through track material.

Pencil Tool Use the Pencil tool to draw automa-
tion and MIDI data.

Zooming Options
Zooming options in Pro Tools include Zoom 
buttons, the Zoomer tool, the Zoom Preset but-
tons, and the Zoom Toggle command.

For information on using the Edit tools in 
Notes view on MIDI and Instrument tracks, 
see Chapter 32, “MIDI Editing.”

For information on using the Edit tools in 
Warp view and Analysis view on Elastic Au-
dio-enabled tracks, see “Editing in Warp 
View” on page 893 and “Editing in Analysis 
View” on page 899.
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Zoom Buttons
Pro Tools includes different Zoom buttons for 
zooming in and out on track data.

The Edit window, MIDI Editor windows, and the 
Score Editor window also provide Zoom buttons 
above and below the right vertical scroll bar (see 
“Edit Window Zoom Buttons” on page 186, 
“MIDI Editor Zoom Controls” on page 724, and 
“Score Editor Zoom Controls” on page 745.)

Horizontal Zoom In and Out 
Buttons
The Horizontal Zoom In and Out buttons let you 
zoom in and out horizontally on track data.

To zoom in horizontally for all tracks, do one of the 
following:

 Click the Horizontal Zoom In button.

 Drag on the Horizontal Zoom In button to 
zoom in continuously.

 Press Control+] (Windows) or Command+] 
(Mac).

To zoom out horizontally for all tracks, do one of 
the following:

 Click the Horizontal Zoom Out button.

 Drag on the Horizontal Zoom Out button to 
zoom out continuously.

 Press Control+[ (Windows) or Command+[ 
(Mac).

Horizontal Zoom Out and In buttons 



Audio and MIDI Zoom In and Out 
Buttons
The Audio and MIDI Zoom buttons let you zoom 
in and out vertically on audio and MIDI data re-
spectively.

To zoom in vertically for all audio tracks, do one of 
the following:

 Click the Audio Zoom In button. 

 Drag on the Audio Zoom In button to zoom 
continuously.

 Press Control+Alt+] (Windows) or 
Command+Option+] (Mac).

To zoom out vertically for all audio tracks, do one 
of the following:

 Click the Audio Zoom Out button. 

 Click the Audio Vertical Zoom buttons.

 Press Control+Alt+[ or Control+Alt+] 
(Windows) or Command+Option+[ or 
Command+Option+] (Mac). 

Audio Vertical Zoom button

MIDI Vertical Zoom button

MIDI Vertical Zoom only affects tracks in 
not in Clips view.
To zoom all audio vertically to show the default 
waveform height:

 Press Control+Alt+Start+[ (Windows) or 
Command+Option+Control+[ (Mac).

To zoom in vertically for all MIDI and Instrument 
tracks, do one of the following:

 Click the MIDI Zoom In button.

– or –

 Press Control+Shift+] (Windows) or 
Command+Shift+] (Mac).

To zoom out vertically for all MIDI and Instrument 
tracks, do one of the following:

 Click the MIDI Zoom Out button.

– or –

 Press Control+Shift+[ (Windows) or 
Command+Shift+[ (Mac).

To zoom MIDI vertically to show all notes (lowest to 
highest) in MIDI and Instrument tracks:

 Press Control+Start+Shift+[ (Windows) or 
Command+Control+Shift+[ (Mac)

To zoom in or out vertically for a single MIDI or 
Instrument track:

1  Make sure the Track View is not set to Clips.

2  Select the Zoomer tool. 

3  Hold Start (Windows) or Control (Mac) and 
drag upwards to zoom in, or downward to zoom 
out.
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Additional Zoom Key Commands

To return to the previous zoom level, do one of the 
following:

 Alt-click (Windows) or Option-click (Mac) 
any of the Horizontal, Audio, or MIDI Zoom but-
tons.

– or –

 Press Control+Alt+E (Windows) or 
Command+Option+E (Mac).

To zoom in horizontally on the Edit selection 
without affecting vertical zoom:

 Press Alt+F (Windows) or Option+F (Mac).

If the selection contains MIDI notes, the se-
lected MIDI notes are vertically scrolled to show 
in tracks as necessary.

To zoom in horizontally on a selection without 
affecting vertical zoom or scrolling, do one of the 
following:

 Press Alt+Start+F (Windows) or 
Option+Control+F (Mac).

– or –

 Press Control+Start+] (Windows) or 
Command+Control+] (Mac).

To zoom horizontally to show the entire session, 
do one of the following:

 Double-click the Zoomer tool in the toolbar.

 Press Alt+A (Windows) or Option+A (Mac).

Audio waveforms revert to the default vertical 
zoom; on tracks set to Notes view, MIDI notes 
zoom vertically to show all notes in the track 
(same as the vertical zoom in Clips view); and 
the Tempo Editor zooms vertically to show all 
tempo events.
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To zoom horizontally to show the entire session 
without affecting vertical zoom or scrolling, do 
one of the following:

 Press Alt+Start+A (Windows) or 
Option+Control+A (Mac).

– or –

 Press Control+Start+[ (Windows) or 
Command+Control+[ (Mac).

To set horizontal zoom to “overview scale” (256 
samples per pixel):

 Control-click (Windows) or Command-click 
(Mac) the Zoomer tool.

Zoomer Tool
Use the Zoomer tool to zoom in and out around 
a particular area within a track. 

The Zoomer tool offers two modes: 

Normal Zoom The Zoomer tool remains selected 
after zooming. 

Single Zoom The previously selected Edit tool is 
automatically reselected after zooming.

Press the F5 key to select the Zoomer tool 
and toggle between Normal and Single 
Zoom modes.



Normal Zoomer Tool

To zoom around a certain point in a track:

1  Do one of the following:

• Click the Zoomer tool pop-up menu and se-
lect Normal Zoom mode.

– or –

• Right-click on any track and select Tools > 

Zoomer Tools > Normal Zoom.

2  Click once with the Zoomer tool at a location 
within the track. All tracks are zoomed in by one 
level and the Edit window is centered around the 
zoomed location.

3  To zoom back to the previous level, Alt-click 
(Windows) or Option-click (Mac) with the 
Zoomer tool.

Zoomer tool
To zoom into a particular track area:

1  Do one of the following:

• Click the Zoomer tool pop-up menu and se-
lect Normal Zoom mode.

– or –

• Right-click on any track and select Tools > 

Zoomer Tools > Normal Zoom.

2  Do either of the following:

• To zoom horizontally only, drag with the 
Zoomer tool in the track’s playlist.

– or –

• To zoom horizontally and vertically, press 
Control (Windows) or Command (Mac) 
while dragging in the track’s playlist.

The zoomed area fills the entire Edit window.

Zooming horizontally with Zoomer tool
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Single Zoom Mode 
Single Zoom mode returns you to the previously 
selected tool after a zoom has been performed.

For example, when using the Smart Tool you can 
click the Single Zoomer tool, and once the Zoom 
operation has been performed, Pro Tools auto-
matically switches back to the Smart Tool.

To use Single Zoom mode, do one of the following:

 Click the Zoomer tool pop-up menu and select 
Single Zoom mode.

 Right-click on any track and select Tools > 

Zoomer Tools > Single Zoom.

 Press the F5 key to toggle to Single Zoom 
mode.

Single Zoom is identified with an arrow to the 
right of the Zoomer icon. 

Normal Zoom mode does not have the arrow.

Zooming in a Ruler

To zoom horizontally in a ruler:

1  Press Control+Start (Windows) or Com-
mand+Control (Mac) and move the cursor into 
the ruler area, so the Zoomer tool appears.

Single Zoom mode
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2  Do one of the following:

• Click once to zoom in one level around a 
certain point.

– or –

• Drag to zoom in around a particular ruler 
range.

Continuous Zoom with the 
Zoomer Tool
Use the Zoomer tool to zoom in or out continu-
ously. 

To use continuous zoom on one track or a group of 
tracks:

1  Select the Zoomer tool. 

2  Hold the Start key (Windows) or Control 
(Mac) and do one of the following:

• Drag up to continuously zoom in vertically. 

• Drag down to continuously zoom out verti-
cally. 

• Drag to the right to continuously zoom in 
horizontally.

• Drag to the left to continuously zoom out 
horizontally.

For horizontal zoom, all tracks zoom together. 
Tracks will zoom in or out centered horizontally 
on the location where you click. 

Zooming in a ruler



Vertical Zooming In or Out of All 
Audio Tracks Continuously

To vertically zoom in or out of all audio tracks 
using continuous zoom:

 Drag up or down on the Audio Zoom In or Out 
button. 

To vertically zoom in or out of all MIDI and 
Instrument tracks that are set to Notes view using 
continuous zoom:

 Drag up or down on the MIDI Zoom In or Out 
button. Any waveform height offsets will be 
maintained.

To zoom horizontally and show the entire session, 
and to reset the audio waveform to show the 
default height, zoom MIDI to show all notes in a 
track, and zoom the Tempo Editor to show all 
tempo events, do one of the following:

 Double-click the Zoomer tool. 

 Press Alt+A (Windows) or Option+A (Mac).

To only zoom horizontally to show the entire 
session without affecting vertical zoom or 
scrolling:

 Press Alt+Start+A (Windows) or 
Option+Control+A (Mac).

To set all audio track waveform heights to match 
the waveform height of the topmost audio track in 
the Edit window:

 Control-Shift-click (Windows) or Command-
Shift-click (Mac) the Audio Zoom button. All 
waveform height offsets will be lost.

This will also affect your MIDI note heights.

To reset the default audio waveform heights 
without affecting the horizontal zoom level 
or MIDI note heights, press Control+
Alt+Start+[ (Windows) or Command+
Option+Control+[ (Mac).
To set all MIDI and Instrument track note heights to 
match the note height of the topmost MIDI or 
Instrument track in the Edit window:

 Control-Shift-click (Windows) or Command-
Shift-click (Mac) the MIDI Zoom button. All 
note height offsets will be lost.

Zoom Preset Buttons
Pro Tools lets you save up to five horizontal Edit 
window Zoom presets, which can be recalled by 
typing a number or by clicking a Zoom Preset 
button. 

To store a view as a Zoom preset:

1  Use the Zoomer tool to configure the Track 
View. 

2  Click and hold one of the Zoom Preset buttons 
(1–5) and choose Save Zoom Preset from the 
Zoom Preset pop-up menu. The preset button 
flashes momentarily, and any previously stored 
Zoom preset at that number is replaced. 

To recall a saved Zoom preset, do one of the 
following:

 Click the appropriate Zoom Preset button 
(1–5). 

– or –

 Click and hold the Zoom Preset button and 
choose Recall Zoom Preset from the Zoom Pre-
set pop-up menu.

Zoom Preset pop-up menu
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Zoom Toggle
Zoom Toggle lets you define and toggle between 
zoom states in the Edit window.

Zoom Toggle Parameters
The Zoom Toggle stores and recalls the follow-
ing parameters:

• Vertical Zoom

• Horizontal Zoom

• Track Height

• Track View

• Grid setting

Zoom Toggle Preferences 
The Zoom Toggle preferences determine how 
Zoom Toggle works. Adjust the Zoom Toggle 
preferences to fit your workflow. 

To change the Zoom Toggle preferences:

1  Choose Setup > Preferences.

2  Click the Editing tab.

3  Change the Zoom Toggle settings and options.

Zoom Toggle preferences

For MIDI Editing, set the Zoom Toggle pref-
erences as follows: Vertical Zoom to Last 
Used, Horizontal Zoom to Last Used, Track 
View to Waveform/Notes, and Track Height 
to Fit to Window.
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4  Click OK.

Vertical Zoom

Selection When selected, zoom toggling in 
zooms vertically to the current Edit Selection.

Last Used When selected, zoom toggling in 
zooms vertically to the last stored Zoom Toggle 
state for MIDI notes in Notes view only. 

Horizontal Zoom

Selection When selected, zoom toggling in 
zooms horizontally to the current selection. 
This is especially useful for audio editing.

Last Used When selected, zoom toggling in 
zooms horizontally to the last stored Zoom Tog-
gle state. This option can emulate a separate ed-
itor window. This is especially useful for editing 
MIDI notes.

Remove Range Selection After Zooming In 

When the Remove Range Selection After Zoom-
ing In option is selected, the current Edit selec-
tion collapses into an insertion point after zoom 
toggling in.

Track Height

Last Used When selected, zoom toggling in 
changes all tracks containing an Edit Selection 
to the last used Track Height.

Medium When selected, zoom toggling in 
changes all tracks containing an Edit Selection 
to the Medium Track Height.

For audio editing, set the Zoom Toggle pref-
erences as follows: Vertical Zoom to Selec-
tion, Horizontal Zoom to Selection, Track 
Height to Fit to Window, and Track View to 
No Change.



Large When selected, zoom toggling in changes 
all tracks containing an Edit Selection to the 
Large Track Height.

Jumbo When selected, zoom toggling in changes 
all tracks containing an Edit Selection to the 
Jumbo Track Height.

Extreme When selected, zoom toggling in 
changes all tracks containing an Edit Selection 
to the Extreme Track Height.

Fit To Window When selected, zoom toggling in 
changes all tracks containing an Edit Selection 
to the Fit To Window Track Height.

Track View

Waveform/Notes When selected, zoom toggling 
in changes the Track View for audio tracks to 
Waveform view, and changes the Track View for 
Instrument and MIDI tracks to Notes view.

Warp/Notes When selected, zoom toggling in 
changes the Track View for audio tracks to Warp 
view, and changes the Track View for Instru-
ment and MIDI tracks to Notes view.

Last Used When selected, zoom toggling in 
changes the Track View to the last used Track 
View that was stored with Zoom Toggle.

No Change When selected, the track view does 
not change when zoom toggling in or out.

Separate Grid Settings When Zoomed In

When this option is selected, the Grid setting 
stored with Zoom toggle is recalled when zoom 
toggling in. When this option is deselected, the 
same (current) grid setting is used whether 
zoom toggling in or out. 
Zoom Toggle Follows Edit Selection

When selected, this option ensures that zoom 
toggle automatically follows the current Edit se-
lection. When disabled, changing the Edit selec-
tion has no affect on the currently toggled-in 
track.

Using Zoom Toggle 
Depending on the Zoom Toggle preferences set-
tings, the Zoom Toggle button in the Edit win-
dow lets you define a zoom state and toggle be-
tween it and the current zoom state, or it zooms 
to the settings in the Zoom Toggle preferences. 
When Zoom Toggle is enabled, the Edit window 
displays the stored zoom state. Additionally, 
any changes made to the view while Zoom Tog-
gle is enabled are also stored in the zoom state.

When Zoom Toggle is disabled, the Edit window 
reverts to the last zoom state.

To store a zoom state using Zoom Toggle:

1  Set the Zoom Toggle preferences.

2  Make an Edit selection.

3  Click the Zoom Toggle button. It lights to in-
dicate that Zoom Toggle is enabled and 
Pro Tools zoom toggles in based on the settings 
of the Zoom Toggle preferences.

Zoom Toggle button in the Edit window
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If Last Used is selected for any of the following, 
you can adjust the corresponding zoom, height, 
or view in the Edit window to update the stored 
zoom state:

• Vertical Zoom

• Horizontal Zoom

• Track Height

• Track View

To modify the stored Zoom Toggle state, do one of 
the following:

 Change the Zoom Toggle preferences.

– or –

 If Last Used is selected for any of the Vertical 
Zoom, Horizontal Zoom, Track Height, or Track 
View preferences, do the following:

• Make sure the Zoom Toggle button is lit 
(enabled). 

– and –

• Adjust the Track Height, Vertical Zoom, 
Track View, or the Grid depending on which 
preferences are set to Last Used. Changes 
are stored as the new Zoom Toggle state.

To clear the stored Zoom Toggle state:

1  Make sure the Zoom Toggle button is lit (en-
abled). 

2  Alt-click (Windows) or Option-click (Mac) the 
Zoom Toggle button.

In Commands Keyboard Focus mode (see 
“Keyboard Focus” on page 30), press the 
E key to enable or disable Zoom Toggle.

Press Alt+Shift+E (Windows) or Op-
tion+Shift+E (Mac) to cancel Zoom Toggle 
without reverting to the previous view.
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To use Zoom Toggle without changing playlist 
views:

1  Make a selection on one or more tracks.

2  Do one of the following:

• Press Alt+Start+E (Windows) or Op-
tion+Control+E (Mac).

– or –

• With Commands Keyboard Focus enabled 
(see “Keyboard Focus” on page 30), press 
Alt+E (Windows) or Option+E (Mac).

Using the Zoom Toggle



Auto-Toggle When Changing 
Selection
When Zoom Toggle is enabled, selecting a dif-
ferent range of material, or selecting material on 
a different track affects Zoom Toggle as follows: 

• Changing the selection length does not re-
zoom the window, the current zoom level is 
maintained. 

• Changing the selection to a different track 
sets the toggle-in state for track height and 
view. However, horizontal zoom remains 
unchanged. When moving the selection 
from a toggled in track, the toggled out 
track height and view are restored.

Zooming with a Scroll Wheel
If you have a mouse with a scroll wheel, you can 
use the scroll wheel to zoom in and out of tracks, 
both vertically and horizontally.

To continuously zoom horizontally using a scroll 
wheel:

 Hold Alt (Windows) or Option (Mac) while 
turning the mouse scroll wheel.

To continuously zoom audio (vertical zoom) in the 
Edit window:

 Hold Alt+Shift (Windows) or Option+Shift 
(Mac) while turning the mouse scroll wheel.

To continuously zoom MIDI (vertical zoom) in the 
Edit window:

 Hold Alt+Start (Windows) or Option+Control 
(Mac) while turning the mouse scroll wheel.

Auto-Toggle does not work for Edit selec-
tions across multiple tracks that are Zoom-
toggled to Fit to Window.
To scroll the contents of the Edit window or Mix 
window horizontally:

1  Focus the window you want to scroll by click-
ing in it or bringing it forward.

2  Hold the Shift key while turning the mouse 
scroll wheel. 

Using the Trim Tools
Trim tools provide clip, note, and data trimming 
functions. The following Trim tools are avail-
able:

• Trim tool; also called the Standard Trim 
tool

• Time Compression/Expansion Trim tool; 
also called the TCE Trim tool

• Scrub Trim tool (Pro Tools HD and 
Pro Tools with Complete Production Tool-
kit Only)

• Loop Trim tool

The Standard and Scrub Trim tools are only con-
strained by the boundaries of the whole-audio 
file referenced by the clip. The TCE Trim tool is 
only constrained by the maximum TCE amount 
when using the TCE Trim tool.
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Trim Tool
With the Trim tool, you can quickly shorten or 
expand a clip (up to the entire length of the 
source audio file). The first time you trim a clip, 
Pro Tools automatically adds it to the Clip List 
as a new clip (with a name derived from the orig-
inal) in order to differentiate it from the origi-
nal.

The Trim tool is a nondestructive tool and does 
not actually modify the original audio or MIDI 
data (when working on clips). To return to the 
length of the original clip, drag it from the Clip 
List, or resize the edited clip with the Trim tool 
to its original length.

Use of the Trim tool is affected by the current 
Edit mode: Shuffle, Slip, Spot, or Grid (see “Edit 
Modes” on page 539).

To trim a clip with the Trim tool:

1  Select the Trim tool. 

If necessary, do one of the following:

• Click the Trim tool pop-up menu and select 
Standard.

– or –

• Right-click on any track and select Tools > 

Trim Tools > Standard.

The Trim tool can also be used to lengthen 
and shorten MIDI notes (see “Trimming 
Note Start and End Times” on page 689), 
and also to scale automation and controller 
data up or down “Drawing Automation” on 
page 1048.

Trim tool
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2  Move the cursor near the start or end of the 
clip, so the Trim Tool cursor appears.

To reverse the direction of the Trim tool, press 
Alt (Windows) or Option (Mac).

3  Do one of the following:

• If trimming the end, drag left to shorten the 
clip, right to lengthen.

– or –

• If trimming the start, drag right to shorten 
the clip, left to lengthen.

When trimming clips in a stereo or multichan-
nel track, all channels are trimmed.

When using Shuffle mode, subsequent clips are 
slid as necessary to make room for the edited 
clip. If using Grid mode, the dragged start/end 
times snap to the nearest Grid boundary. If us-
ing Spot mode, the Spot dialog opens, where you 
can enter the new location for the clip’s start or 
end point.

Trim tool

When working with audio, you cannot trim 
past the boundaries of adjacent clips.



Time Compression/ 
Expansion Trim Tool
The Time Compression/Expansion Trim tool 
(TCE Trim) is a convenient tool for matching an 
audio clip to the length of another clip, a tempo 
grid, a video scene, or to practically any other 
reference point you want.

Elastic Audio TCE Trim Tool
On Elastic Audio-enabled tracks, the TCE tool 
uses the track’s selected Elastic Audio plug-in 
(Real-Time or Rendered) to apply Real-Time or 
Rendered Elastic Audio processing. The result-
ing clip displays a Warp indicator to indicate 
Elastic Audio processing.

Time Compression/Expansion Trim tool over a clip

The TCE Trim tool unloops and consoli-
dates looped clips.

You can match an Edit selection to the length 
of a Timeline selection by selecting Edit > 
TCE Edit to Timeline Selection command (see 
“TCE (Time Compression and Expansion) 
Edit To Timeline Selection” on page 612.

For information on Elastic Audio plug-ins, 
see “Elastic Audio Plug-Ins” on page 888.
AudioSuite TCE Trim Tool
On audio tracks without Elastic Audio enabled, 
the Time Compression/Expansion Trim tool 
works by using the Time Compression/Expan-
sion (TCE) AudioSuite plug-in selected in the 
Pro Tools Processing preferences to create a 
new audio file. 

Time Compression/Expansion 
Plug-In Preferences
You can select which AudioSuite plug-in is used 
for trimming with the TCE Trim tool on non-
Elastic Audio-enabled audio tracks. 

To set the AudioSuite plug-in for use with the TCE 
Trim tool:

1  Choose Setup > Preferences.

2  Click the Processing tab.

3  From the TC/E Plug-In pop-up menu, select the 
AudioSuite plug-in to be used with the Time 
Compression/Expansion Trim tool.

4  From the Default Settings pop-up menu, select 
the plug-in setting best suited to the material 
you work with most (such as Stereo Mix Default).

5  Click OK.

 TC/E Preferences

For more information about AudioSuite 
plug-ins, see Chapter 40, “AudioSuite Pro-
cessing.”
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Using the TCE Trim Tool in Grid 
Mode
The TCE Trim tool can be used in Grid mode to 
match a clip to the tempo of a session or a sec-
tion of a session. For example, you might import 
a one-bar drum loop with a tempo of 90 BPM 
into a session with a tempo of 120 BPM. In Grid 
mode, you can use this tool to simply and 
quickly “time compress” the drum loop to the 
length of one measure, with no noticeable to 
minimal loss of audio fidelity. 

To use the TCE Trim tool in Grid mode:

1  Set the Edit mode to Grid.

2  Do one of the following:

• Click the Trim tool pop-up menu and select 
TCE.

– or –

• Right-click on any track and select Tools > 

Trim Tools > TCE.

3  With the TCE Trim tool, drag the audio clip’s 
start or end point to compress or expand the clip 
to the Grid (for example, by quarter notes). 

Trimming clips while in Relative Grid mode 
will trim the clips in grid increments while 
maintaining their relative offset (if any) 
from the grid.

Time Compression/Expansion Trim tool
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Using the TCE Trim Tool in Slip 
Mode

To use the TCE Trim tool in Slip mode:

1  Set the Edit mode to Slip.

2  Click the Trim tool pop-up menu and select 
TCE.

3  With the TCE Trim tool, drag the clip’s start or 
end point to compress or expand the clip freely. 

Using the TCE Trim Tool in Spot 
Mode
In Spot mode, clicking with the TCE Trim tool in 
a clip opens the Spot dialog. You can specify the 
location you want the clip to start or end at, or 
the duration of the clip, and the clip is automat-
ically compressed or expanded as specified.

To use the TCE Trim tool in Spot mode:

1  Set the Edit mode to Spot.

2  Click the Trim tool pop-up menu and select 
TCE.

3  Click the clip near its start or end point. The 
Spot dialog opens. Using any Time Scale, enter a 
new start or end time (or duration) for the clip, 
then click OK. 



Scrub Trim Tool
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

The Scrub Trim tool is a convenient tool for au-
ditioning material (on up to two tracks) to find a 
trim point. You can drag in a track to hear the 
audio information, then trim at a specific loca-
tion by releasing the mouse button.

This action creates a new clip. Note that the 
Scrub Trim tool changes into a “right trim” or 
“left trim” shape as it is placed over the right or 
left side of a clip. To reverse the direction of the 
Scrub Trim tool, press Alt (Windows) or Option 
(Mac) before you click the clip.

Scrub playback speed and direction vary with 
controller movement. Scrubbed audio is routed 
through the track signal path, so you hear any 
effects in the signal path.

To scrub trim a track:

1  Do one of the following:

• Click the Trim tool pop-up menu and select 
Scrub. 

– or –

• Right-click on any track and select Tools > 

Trim Tools > Scrub.

The tool changes to a speaker with a bracket.

2  Drag within a track to the left or right. Audio 
from a scrubbed track is routed through the 
track signal path, including any TDM effects. 
When you locate the trim point, release the 
mouse button to trim the clip.

Scrub Trim tool over a clip
To scrub trim two tracks, drag with the Scrub 
Trim tool between two adjacent tracks.

To scrub with finer resolution (without having 
to zoom in), press Control (Windows) or Com-
mand (Mac) while scrubbing.

Loop Trim Tool
Use the Loop Trim tool to create or trim looped 
clips (see “Clip Looping” on page 847). 

Creating Loops with the Loop 
Trim Tool

To create loop clips using the Loop Trim tool:

1  Do one of the following:

• Click the Trim tool pop-up menu and select 
Loop.

– or –

• Right-click on any track and select Tools > 

Trim Tools > Loop.

2  Position the cursor over the top half of an un-
looped audio or MIDI clip, or clip group. The 
cursor changes to indicate that you can loop trim 
the clip. (Positioning the cursor over the bottom 
half of the clip results in the Standard Trim cur-
sor.)

Loop Trim tool

Loop Trim cursor
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3  Do one of the following:

• Click at the end of the clip, and drag left or 
right to the point you want the loop to stop.

– or –

• Click at the beginning of the clip, and drag 
left or right to the point you want the loop 
to start.

Trimming Looped Clips
You can trim looped clips in two ways:

• Loop Trim a looped clip to change how long 
the clip is looped. For example, Loop Trim a 
looped clip from 2 bars to four bars. With a 1 
bar clip, the number of loops changes from 2 
to 4. Each loop iteration remains the same 
length, but the length of the entire looped clip 
changes.

• Trim the source clip (loop iteration) while 
keeping the overall loop length unchanged. 
The number of loop iterations within the 
looped clip changes accordingly. For example, 
trim a 2 bar loop iteration of a 4 bar looped 
clip to 1 bar. The 4 bar looped clip remains 
constant, but the number of loop iterations 
changes from 2 to 4. Each loop iteration’s 
length changes, but how long the clip is looped 
does not.

Looped clip

Loop Trim tool

Loop icon
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To Loop Trim a looped clip:

1  Select the Loop Trim tool.

2  Move the cursor over the top half of the looped 
clip (not over a Loop icon). The cursor indicates 
the Loop Trim tool.

3  Trim the looped clip.

The number of loops increases or decreases to 
fill the new length of the entire looped clip.

Loop Trim tool

Loop trimming a looped clip

Hold down the Start key on Windows, or the 
Control key on Mac, while trimming to trim 
in loop iteration increments.

Trimming a looped clip does not trim any 
underlying Fades.



To trim the source clip (loop iteration) of a looped 
clip:

1  Select the Loop Trim tool.

2  Move the cursor over a Loop icon in the looped 
clip, or anywhere along the bottom of the clip. 
The cursor indicates the Trim tool icon.

3  Trim the start or end of the loop iteration.

The number of trimmed loop iterations in-
creases or decreases to fill the original length of 
the entire looped clip.

Loop Trim tool

Trimming a looped clip

Trimmed looped clip
Using the Selector Tool
Use the Selector tool to place the edit cursor in a 
track or Timebase ruler, or to make Timeline se-
lections or Edit selections on tracks.

Placing the Edit Cursor

To place the edit cursor with the Selector tool:

1  Select the Selector tool in the Edit window.

2  Click the location in a track or on a Timebase 
ruler.

Making an Edit Selection with 
the Selector Tool

To make an Edit selection with the Selector tool:

1  Select the Selector tool in the Edit window.

2  Do one of the following:

• To make an Edit selection in a single track, 
drag in the track.

• To make an Edit selection across multiple 
tracks, drag across the tracks.

• If Link Timeline and Edit Selection is en-
abled, drag on the Timebase ruler to make 
an Edit selection across all tracks.

Placing the edit cursor with the Selector tool
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To select an entire clip with the Selector tool:

1  Select the Selector tool in the Edit window.

2  Double-click a clip on a track.

To select an entire track with the Selector tool:

1  Select the Selector tool in the Edit window.

2  Triple-click in the track.

Making a Timeline Selection 
with the Selector Tool

To make a Timeline selection with the Selector 
tool:

1  Select the Selector tool in the Edit window.

2  Do one of the following:

• Drag on a Timebase ruler.

– or –

• If Link Timeline and Edit Selection is en-
abled, drag in a track.

Making a selection with the Selector tool
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Using the Grabber Tools
Use the Grabber tools to select, move, separate, 
and arrange clips on tracks. There are three 
modes for the Grabber tool: Time Grabber, Sep-
aration Grabber, and Object Grabber. For more 
information about arranging clips, also see 
Chapter 38, “Arranging Clips.”

Time Grabber Selects an entire clip on a track 
with a single click. For more information on se-
lecting clips, see “Selecting Track Material” on 
page 571.

Separation Grabber Cuts and pastes an Edit se-
lection from one location to another by drag-
ging. For more information, see “Separation 
Grabber Tool” on page 594.

Object Grabber Lets you select multiple, non-
contiguous clips. For more information, see 
“Object Selections” on page 573.

Time Grabber tool

Separation Grabber tool

Object Grabber tool



To select one of the Grabber tools, do one of the 
following:

 Click the Grabber tool in the Edit window and 
select the Grabber tool from the pop-up menu.

– or –

 Right-click on any track and select the Grab-
ber tool from Tools > Grabber Tools.

Using the Smart Tool
With the Smart Tool, you can instantly access 
the Selector, Grabber, and Trim tools, and you 
can also perform fades and crossfades. The posi-
tion of the cursor in relation to a clip or note, or 
within an automation playlist, determines how 
the Smart Tool functions.

To select the Smart Tool, click its icon in the up-
per left of the Edit window, or press F6+F7 (or 
F7+F8) simultaneously.

Selecting a Grabber tool

Smart Tool enabled in the Edit window
The Smart Tool in Waveform 
View (Audio) or Clips View 
(MIDI)

The following capabilities are available with the 
Smart Tool when working with audio tracks in 
Waveform or Blocks view, or MIDI or Instru-
ment tracks in Clips view:

 For the Selector tool, position the cursor over 
the middle of the clip, in the upper half of the 
clip.

 For the Grabber tool, position the cursor over 
the middle of a clip, in the lower half of the clip.

 For the Trim tool, position the cursor near the 
clip’s start or end point. 

 For a fade-in or fade-out, position the cursor 
near an audio clip’s start or end point, near the 
top of the clip. Once the Fade cursor appears, 
drag into the clip to set the fade length. The fade 
is created automatically with the Default Fade 
Settings (in the Editing Preferences page).

Smart Tool in Waveform view

Fade-In Fade-Selector tool

Grabber tool

Trim 
tool

(start)

Trim tool 
(end)

Crossfade
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 For a crossfade, position the cursor between 
two adjacent audio clips, near the bottom of the 
clip. Once the Crossfade cursor appears drag left 
or right to set the crossfade length. The cross-
fade is created automatically with the Default 
Fade Settings (in the Editing Preferences page).

The Smart Tool in Warp View

The following capabilities are available with the 
Smart Tool when working with Elastic Audio-
enabled audio tracks in Warp view, or MIDI or 
Instrument tracks in Clips view:

 For the Selector tool, position the cursor over 
the middle of the clip, in the upper half of the 
clip.

 For the Grabber tool, position the cursor over 
the middle of a clip, in the lower half of the clip, 
but not over an Event marker or Warp marker.

 For Elastic Audio warping, position the cursor 
over an Event marker or a Warp marker, in the 
lower half of the clip (for more information on 
warping audio, see “Editing in Warp View” on 
page 893).

To temporarily switch the Smart Tool to the 
Scrubber, place the cursor over the clip so 
that the Selector tool is enabled, then press 
Start (Windows) or Control (Mac).

Smart Tool in Warp view

Selector tool

Grabber tool

Trim 
tool

(start)

Trim tool 
(end)
Pro Tools Reference Guide
 For the Trim tool, position the cursor near the 
clip’s start or end point, in the upper half of the 
clip. 

The Smart Tool in Notes View

The following capabilities are available with the 
Smart Tool when working with MIDI and In-
strument tracks in Notes view in the Edit win-
dow and in MIDI Editor windows:

 For the Marquee Selector, position the cursor 
so it does not cover any notes.

 For the Grabber tool, position the cursor over 
the note, near its middle. 

 For the Trim tool, position the cursor near the 
note start or end point.

To temporarily switch the Smart Tool to the 
Scrubber, place the cursor in the upper half 
of the clip so that the Selector tool is en-
abled, then press Start (Windows) or Con-
trol (Mac).

Smart Tool in Notes view

Selector tool (marquee)

Grabber toolTrim note start Trim note end



 For the Velocity Trim tool, position the cursor 
over the note and press Control (Windows) or 
Command (Mac).

The Smart Tool in Automation 
and Controller Views
The following capabilities are available with the 
Smart Tool when working in both automation 
and controller views:

 For the Selector tool, position the cursor any-
where in the bottom 75% of the playlist for the 
Selector tool. Drag with the Selector tool to se-
lect breakpoints. 

 For Trim tools, position the cursor in the top 
25% of the playlist for the Trim tool. Drag with 
the Trim tool to trim breakpoints. Press Control 
(Windows) or Command (Mac) while trimming 
for fine control.

 For Grabber tools, Control (Windows) or 
Command (Mac) for the Grabber tool, then click 
in on the automation line to create breakpoints.

Trimming the velocity of a note

To temporarily switch the Smart Tool to 
the Pencil tool, press Start (Windows) or 
Control (Mac). 

To temporarily switch the Smart Tool to 
the Eraser, press Alt+Start (Windows) or 
Option+Control (Mac). 
To edit existing breakpoints, move the cursor 
near a breakpoint for the Grabber tool.

For fine control with the Grabber tool, press 
Control (Windows) or Command (Mac)—or 
continue to hold the key if you are creating a 
new breakpoint. 

To vertically constrain Grabber tool movement, 
press Shift.

To vertically constrain Grabber tool movement 
with fine control, press Control+Shift (Win-
dows) or Command+Shift (Mac). 

The Smart Tool with Stereo and 
Multichannel Tracks
When using the Smart Tool on stereo and multi-
channel tracks, individual channels cannot be 
independently edited. All edits affect all chan-
nels as a whole. 

Tool switching for the Smart Tool in stereo and 
multichannel tracks is determined by the posi-
tion within the entire track, and not within indi-
vidual channels.

Using the Scrubber Tool
The Scrubber tool lets you “scrub” up to two 
tracks of audio in the Edit Window. Scrubbing is 
a technique that originated in tape editing, 
where the tape was rocked back and forth past 
the playhead at slower than normal speeds to 
find a particular location (usually for cutting 
and splicing).
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While viewing an audio waveform in Pro Tools 
can be helpful in visually finding an edit point, 
sometimes a waveform display (because of its 
sonic characteristics) may not reveal the desired 
spot in the audio material. By scrubbing back 
and forth in Pro Tools, you can listen and locate 
an exact edit point. 

When the Edit Insertion Follows Scrub/Shuttle 
option is enabled in the Operation Preferences 
page, the edit cursor automatically locates to the 
point where scrubbing stops.

When the Scrolling option is set to Continuous 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only) or Center Playhead 
(Pro Tools HD only), clicking with the Scrubber 
in a track’s playlist centers the Edit window 
around that point, and moves the Playhead 
there. With these Scrolling Options, scrubbed 
material moves past the Playhead, which re-
mains stationary and centered.

To scrub a single audio track:

1  Select the Scrubber tool.

2  Drag within the track: left for reverse or right 
for forward.

The distance and speed with which you drag 
(with either the mouse, or the scrub wheel on a 
control surface) determine the length and speed 
of the scrubbed audio. Audio from the scrubbed 
track is routed to its output, along with any ef-
fects assigned to the track.

The resolution for the Scrubber is dependent on 
the zoom factor for the scrubbed track.

Scrubbing an audio track with the Scrubber
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To scrub multiple audio tracks, do one of the 
following:

 With the Scrubber selected, drag between two 
adjacent tracks.

– or –

 Scrub within a selection that contains multi-
ple tracks.

When scrubbing multiple tracks, only the first 
two tracks are heard.

You can temporarily switch the Selector tool 
to the Scrubber tool by Start-clicking (Win-
dows) or Control-clicking (Mac). For finer 
resolution, Control-Start-click (Windows) 
or Command-Control-click (Mac).

Scrubbing between two audio tracks

The maximum number of channels 
scrubbed in Pro Tools is eight, which lets 
you scrub a 7.1 track, two stereo tracks 
(four channels), but not two 5.1 surround 
tracks (12 channels).



Scrub/Shuttle Mode
When scrubbing normally, you can scrub at nor-
mal playback speeds or slower. Scrub/Shuttle 
mode, however, lets you scrub at several times 
normal speed, which is helpful in playing 
through large ranges and locating material.

To scrub in Shuttle mode (at several times normal 
speed):

1  Select the Scrubber tool.

2  While pressing Alt (Windows) or Option 
(Mac), drag within the track—left for reverse, 
right for forward. The Fast Forward and Rewind 
buttons in the Transport window engage. 

The distance and speed dragged determine the 
speed for the scrubbed audio.

Shuttle Lock Mode
Shuttle Lock mode lets you use the numeric key-
pad to shuttle up to two tracks forward or back-
wards at specific speeds: 5 is normal speed, 
numbers from 6 up to 9 provide increasingly 
faster fast-forward speeds, and numbers from 4 
down to 1 provide progressively faster rewind 
speeds (4 is the slowest rewind Shuttle Lock 
speed, 1 is the fastest). If multiple tracks are se-
lected, only the first two tracks are shuttled.
To play one or two tracks with the shuttle lock: 

1  With Pro Tools HD, make sure the Operation 
preference for Numeric Keypad mode is not set 
to Shuttle (see “Operation Preferences” on 
page 124).

2  With the Selector tool, click in the track where 
you want playback to begin. To shuttle on two 
tracks, Shift-click in a second track.

3  Press the Start key (Windows) or Control 
(Mac) and a number on the numeric keypad: 0–9 
(9 is fastest, 5 is normal speed, and 0 stops shut-
tling).

Once Shuttle Lock mode is initiated, Fast For-
ward and Rewind become highlighted in the 
Transport window.

4  Press additional keys to change the playback 
speed, or press Plus (+) or Minus (–) to switch 
the playback direction (plus for forward, minus 
for backward).

5  To stop playback, press Start+0 (Windows) or 
Control+0 (Mac).

To exit Shuttle Lock mode, do one of the following:

 Press Stop in the Transport window.

– or –

 Press the Spacebar.
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Custom Shuttle Lock Speed
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Use the Custom Shuttle Lock Speed preference 
to customize the highest fast-forward Shuttle 
Lock speed (key 9) to better match your editing 
and auditioning needs.

To configure Custom Shuttle Lock Speed:

1  In Pro Tools, select Setup > Preferences and 
click the Operation tab. 

2  Be sure that the Numeric Keypad mode is set to 
Transport or Classic (see “Operation Prefer-
ences” on page 124).

3  Enter a percentage for the Custom Shuttle Lock 

Speed setting. The range for this setting is 
50–800%. You can use the Up and Down Arrow 
keys to increase or decrease the setting. 

4  Click OK. 

The Custom Shuttle Lock Speed setting is saved 
with your Pro Tools system preferences (not 
with the session).

To enable Custom Shuttle Lock Speed:

 Press Start+9 (Windows) or Control+ 9 (Mac) 
on the numeric keypad.
Pro Tools Reference Guide
Numeric Keypad Set to 
Shuttle
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools offers another form of shuttling, dif-
ferent from that of Shuttle Lock mode. With the 
Numeric Keypad mode set to Shuttle, playback of 
the current Edit selection is triggered by press-
ing and holding the keys on the numeric key-
pad—playback stops once the keys are released. 
Various playback speeds are available in both 
forward and reverse. In this mode, pre- and 
post-roll are ignored.

To shuttle with the Numeric Keypad mode set to 
Shuttle:

1  Choose Setup > Preferences and click the Op-

eration tab.

2  Set the Numeric Keypad mode to Shuttle and 
click OK.

3  With the Selector tool, click in the track where 
you want playback to begin. To shuttle on two 
tracks, Shift-click in a second track.

4  Press and hold any of the following keys (or 
key combinations) on the numeric keypad to 
trigger playback.

5  Press a different key to switch the playback di-
rection or speed. Release to stop.

Shuttle Speed Rewind Key Forward Key

1 X Speed 4 6

4 X Speed 7 9

1/4 X Speed 1 3

1/2 X Speed 4+5 5+6

2 X Speed 7+8 8+9



Using the Pencil Tool
The Pencil tool lets you draw several types of 
Pro Tools data:

• audio waveforms (see “Waveform Repair 
with the Pencil Tool” on page 567)

• MIDI data (see “Using the Pencil Tool” on 
page 682)

• tempo changes (see “Editing Tempo Events 
in the Tempo Editor” on page 781)

• automation (see “Drawing Automation” on 
page 1048). 

Waveform Repair with the Pencil 
Tool
On audio tracks, the Pencil tool lets you destruc-
tively “redraw” waveform data. This tool is most 
commonly used to repair a pop or click in an au-
dio file. A pop or click appears as a sudden sharp 
spike in a waveform. This tool only becomes ac-
tive when the Edit window is zoomed in to the 
sample level.

Although you can Undo a Pencil tool edit, it is 
recommended that you create a backup copy of 
the target audio before using the Pencil tool. 
You can do this by using the AudioSuite Dupli-
cate plug-in.

The Pencil tool is a destructive editing tool 
that permanently modifies the audio file on 
disk and should be used with caution.

For information about the AudioSuite 
Duplicate plug-in, see the Audio Plug-Ins 
Guide.
To destructively edit an audio waveform with the 
Pencil tool:

1  Locate the area you want to edit.

2  Using the Zoomer tool or the Zoom buttons, 
zoom down to the sample level so the waveform 
appears as a continuous thin line. Adjust the 
Track Height, as necessary, to edit the waveform 
with greater precision. You can also use vertical 
zoom for greater visual resolution.

3  Select the Pencil tool.

4  Carefully draw with the Pencil tool by drag-
ging over the area of the waveform.

Do not over-edit or the results may be undesir-
able. However, you can use the Undo command 
to undo your previous edit.

The Pencil tool can independently edit different 
channels of a multichannel track. 

Try to limit editing to smoothing over a very 
small problem area, and keep the “fixes” in char-
acter with the shape of the surrounding wave-
form. 

You can recall zoom levels with the Zoom 
Preset buttons (see “Zooming Options” on 
page 544), or with Memory Locations (see 
“Recalling Memory Locations” on 
page 816). The default setting for Zoom Pre-
set 5 is at the sample level for Pencil editing.

Pencil tool

Repairing a “pop” with the Pencil tool
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Edit/Tool Mode Keyboard 
Lock
Enable Options > Edit/Tool Mode Keyboard Lock 
to lock the currently selected Edit Tools (Zoom, 
Trim, Grabber, and Pencil only) in place and 
prevent them from being inadvertently changed 
when using keyboard shortcuts. However, even 
when Edit/Tool Mode Keyboard Lock is enabled, 
Edit Tool types can still be changed using the 
mouse or by using the Right-click menu. You 
can also switch between tools (such as switching 
from the Grabber to the Trim) using keyboard 
shortcuts.

To lock (or unlock) the current Edit Tool modes:

1  Select the Edit Tool modes you want (such as 
the Standard Trim tool, Time Grabber tool, and 
the Free Hand Pencil tool). 

2  Select (or deselect) Options > Edit/Tool Mode 

Keyboard Lock.
Pro Tools Reference Guide



Chapter 27: Making Selections
Pro Tools provides many tools for selecting ma-
terial in the Edit window.

Linking or Unlinking Timeline 
and Edit Selections
Pro Tools lets you link or unlink the Timeline 
and Edit selections. 

When the Timeline and Edit selections are 
linked, selecting in a track’s playlist (making an 
Edit selection) also defines the play and record 
range (the Timeline selection).

Unlinking Timeline and Edit selections lets you 
make a selection within a track for editing pur-
poses that is distinct from the selection in the 
Timeline (which determines the playback and 
recording range).

To link or unlink the Timeline and Edit selections, 
do one of the following:

 Select or deselect Options > Link Timeline and 

Edit Selection.

– or –

 In the Edit window, a MIDI Editor window, or 
the Score Editor window, click the Link Timeline 
and Edit Selection button so it becomes high-
lighted (selected) or un-highlighted (not se-
lected). Enabling or disabling the Link Timeline 
and Edit Selection button in any editor window 
affects all editor windows.
If you are working on a film or video scene, you 
may want to unlink the Timeline and Edit selec-
tions to find or audition material that is at a dif-
ferent location than the current Timeline selec-
tion. Edit selections can be played (choose Edit > 

Selection > Play Edit) without disrupting the cur-
rent Timeline selection. Once you find the mate-
rial, you can then go back to the Timeline selec-
tion and place it within the context of the scene.

The following figure illustrates another reason 
why you might want to unlink the Timeline and 
Edit selections. In this example, the Timeline se-
lection sets a range to be looped on playback, 
while a MIDI clip (residing within the loop) is 
selected for editing purposes. 

During playback, the Edit selection can be 
nudged, quantized, or transposed while the loop 
plays back completely independent and uninter-
rupted.

Link Timeline and Edit Selection button enabled in the 
Edit window

Press Shift+Forward Slash (/) to toggle Link 
Timeline and Edit Selection on and off.
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While you could theoretically do this with the 
Timeline and Edit selections linked, as soon as 
playback is stopped, the playback range would 
then be updated to that of the more recent edit 
range, or to a single note when editing MIDI.

Timeline and Edit Selection 
Markers
Timeline selections are displayed in the Main 
Timebase ruler with Timeline Selection Markers, 
which appear as blue arrows (red when record-
ing). In addition, there are Pre- and Post-Roll 
Flags (which are green when enabled) indicating 
the location for pre- and post-roll.

When the Timeline and Edit selections are un-
linked, Edit selections are displayed in the ruler 
with Edit Markers, which appear as black brack-
ets.

If the Timeline and Edit selections are linked, 
Edit selections are represented by the blue 
Timeline Selection Markers.

Timeline and Edit selections unlinked

Timeline Selection Markers with Pre- and Post-Roll 
Flags

Edit Markers
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See the following topics for more information 
on working with Timeline and Edit selections:

• “Selecting Track Material” on page 571

• “Timeline Selections” on page 581

• “Setting Punch and Loop Points” on 
page 464

• “Setting Pre- and Post-Roll” on page 468

Linking or Unlinking Track 
and Edit Selections
Pro Tools lets you link or unlink Track selection 
with Edit selections.

When Track and Edit selections are linked, you 
can make a selection within a track or across 
multiple tracks for editing and each associated 
track is selected (track names automatically 
highlight). This lets you quickly apply track-
level commands (such as Track View toggle, 
change track heights) and have the command 
apply to all tracks you are working on. 

When Track and Edit selections are unlinked, 
making an Edit selection does not automatically 
select all associated tracks. 

To link or unlink Track and Edit selection, do one of 
the following:

 Select or deselect Options > Link Track and Edit 

Selection.

– or –

 In the upper left of the Edit window, under the 
Edit tools, click the Link Track and Edit Selec-
tion button so it becomes highlighted (selected) 
or un-highlighted (not selected).



Selecting Track Material
Before audio and MIDI material can be edited, it 
must first be selected. The Track View deter-
mines how the material is viewed and selected. 

When you make a selection, it appears as a high-
lighted area of the tracks, and is also indicated 
by blue start and end arrows (Timeline Selection 
Markers) in the Main Timebase ruler. If any 
track (audio or MIDI) in the session is record-
enabled, even if it is hidden, these markers ap-
pear red. 

If the Timeline and Edit selections are unlinked, 
the Edit selection range is indicated by Edit 
Markers in the Main Timebase ruler. See “Link-
ing or Unlinking Timeline and Edit Selections” 
on page 569 for details.

Link Track and Edit Selection enabled

Timeline Selection Markers indicating Edit selection
Selections and Edit Groups

When making selections on tracks that are part 
of an Edit Group, all tracks within the group be-
come selected.

Selections and Hidden Tracks

When editing tracks that are part of an active 
Edit Group, any tracks within the group that are 
hidden are not affected by the edits. To edit all 
members of a group, make sure they are visible 
by highlighting their names in the Track List. 

Selections in Multiple Tracks

To make a selection in multiple tracks:

 With the Selector tool, drag vertically to in-
clude adjacent tracks in a selection (drag hori-
zontally to define the time range). 

Selecting Clips

To select a portion of a clip:

 With the Selector tool, drag within a clip (left 
or right) to select the material on a single track. 
(You can also use the Selector tool across multi-
ple, adjacent tracks to make multitrack selec-
tions.)

Selecting a portion of a clip
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To select an entire clip, do one of the following:

 Click the clip with the Time Grabber tool.

– or –

 Double-click the clip with the Selector tool.

To select two clips and the time range between 
them:

1  With the Time Grabber, click the first clip.

2  Shift-click the second clip. Both clips are se-
lected, along with the time range between them 
(including any other clips).

To select an entire track, do one of the following:

 Click in the track with the Selector tool and 
then choose Edit > Select All.

– or –

 Triple-click with the Selector tool in the track.

To select all clips in all tracks:

1  Select the “All” Edit Group in the Group List 
pop-up menu.

2  Do one of the following:

• Click in any track with the Selector tool and 
choose Edit > Select All.

– or –

• Triple-click with the Selector tool in any 
track.

Press Control+A (Windows) or Com-
mand+A (Mac) for Select All.

Another way to select all clips in all tracks, 
without having to select the “All” Edit 
Group, is to press Enter (Windows) or Re-
turn (Mac), then press Control+A (Win-
dows) or Command+A (Mac). The Link 
Timeline and Edit Selection option must be 
enabled.
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Clip List Selection Follows Edit 
Selection
When the Editing preference for Clip List Selec-

tion Follows Edit Selection is enabled, selecting a 
clip in a track also causes the clip to become se-
lected in the Clip List.

Conversely, if the Editing preference for Edit Se-

lection Follows Clip List Selection is enabled, se-
lecting a clip in the Clip List causes the initial 
occurrence of that clip to become selected 
within the track.

Selecting All from Timebase 
Rulers

To select all material in all displayed audio and 
MIDI tracks:

1  Enable Link Timeline and Edit Selection (Op-

tions > Link Timeline and Edit Selection).

2  Double-click in any Timebase ruler. All clips in 
all displayed audio and MIDI tracks are selected. 
Tracks that are hidden are not selected.

To select all material in all tracks, including 
Conductor events:

1  Enable Link Timeline and Edit Selection (Op-

tions > Link Timeline and Edit Selection).

2  While pressing Control (Windows) or Option 
(Mac), double-click in any Timebase ruler. All 
clips in all displayed audio and MIDI tracks are 
selected, including all events in each of the Con-
ductor tracks.



Making Selections While Playing
Pro Tools lets you make on-the-fly selections 
with the Up and Down Arrow keys.

To make a selection while playing:

1  Enable Link Timeline and Edit Selection (Op-

tions > Link Timeline and Edit Selection).

2  With the Selector tool, click somewhere near 
the beginning of the track in which you want to 
make the selection.

3  Click Play in the Transport window (or press 
the Spacebar) to begin playback.

4  When playback reaches the point where you 
want the selection to begin, press the Down Ar-
row key.

5  Press the Up Arrow key at the point where you 
want the selection to end. The selected range be-
comes highlighted.

6  To stop playback, click Stop in the Transport 
(or press the Spacebar).

To automatically scroll to the beginning of the 
selection (or to the location of the on-screen 
cursor), press the Left Arrow key. To scroll to 
the end of the selection, press the Right Arrow 
key.

While in Page Scroll or Continuous Scroll mode, 
making a selection in the Timeline or a playlist 
during playback as the playback cursor moves 
off-screen suspends page scrolling. To resume 
page scrolling and jump to the current playback 
location, click the Playback Cursor locator in the 
Main Timebase ruler (see “Locating the Play-
back Cursor when It Is Off-Screen” on 
page 420).
Object Selections 
Use the Object Grabber tool to select noncontig-
uous clips on one or more tracks. Noncontigu-
ous selections must encompass entire clips. If 
you want a noncontiguous selection to include a 
portion of a clip, first turn the portion into a 
new clip with the Separate Clip command (see 
“Separate Commands” on page 592).

To select noncontiguous clips:

1  Set the Edit mode to either Slip or Grid.

2  Click the Grabber tools pop-up menu and se-
lect Object.

3  Shift-click each clip you want to include in the 
selection. The clips can even reside on different 
tracks.

Each clicked clip is surrounded by a dark bor-
der, indicating it is selected.

The Object Grabber tool ignores Edit Groups 
when making selections. For instance, selecting 
a clip on a grouped track does not cause clips in 
the other tracks in the group to become selected.

The Object Grabber is not available when 
the Edit mode is set to Shuffle or Spot.

Object Grabber tool

Noncontiguous selection
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Object to Time Selection 
You can convert between Time- and Object-
based selections. Time selections are made with 
the Selector and Time Grabber tools. Object se-
lections are made with the Object Grabber tool.

Converting to an Object selection is useful when 
you are working with large selections, especially 
across multiple tracks, and you want to remove 
certain clips from the selection.

Converting to a Time selection is useful if you 
want to select all clips between a noncontiguous 
Object selection.

To change a Time selection to an Object selection:

1  Drag with the Selector tool in any track to de-
fine a selection, or select in a Timebase ruler to 
select across all tracks.

2  With the Object Grabber tool selected, double-
click the Grabber icon in the toolbar. Clips fall-
ing within the selection range become selected 
as objects. Clips that were partially selected be-
come deselected.

Selected clips

Clips selected as objects
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To select clips that were partially selected, press 
Start (Windows) or Control (Mac) while double-
clicking the Grabber icon.

To change an Object selection to a Time selection:

1  Select any number of clips with the Object 
Grabber tool.

2  Double-click the Selector tool in the toolbar. 
The time range between the first and last clip be-
comes selected.

When using the Object Grabber tool on tracks 
that belong to an Edit Group, clips in the other 
grouped tracks are selected if they fall within the 
range of the selected clip.

Changing a Selection Length
The selection range can be shortened or length-
ened. This does not affect the material within 
the selection.

To change the length of a selection, do one of the 
following:

 With the Selector tool, position the cursor 
over one end of the current selection and Shift-
click, or Shift-drag left or right.

 In the Main Timebase ruler, drag the Timeline 
Selection Marker for the selection’s start or end 
point.

Dragging a Timeline Selection Marker



 If Link Timeline and Edit Selection is disabled, 
drag the Edit Marker to change the selection 
length.

To make a long-length selection:

1  With the Selector tool, click at where you want 
the selection to start.

2  Scroll to the end point and Shift-click at the 
point where you want the selection to end. 

To verify the start and end points of a long selec-
tion, press the Left Arrow key to scroll to the be-
ginning of the selection, or press the Right Ar-
row key to scroll to the end.

Nudging a Selection Range
The selection range (not the material within the 
selection) can be moved by the Nudge value.

To nudge a selection range:

1  Configure the Nudge value. For details, see 
“Defining the Nudge Value” on page 599.

2  Make the initial selection with the Selector 
tool.

3  While pressing Shift, press Plus (+) or 
Minus (–) on the numeric keypad to move the 
selection range by the Nudge value.

Edit Markers
Nudging Selection Start/End 
Points
Start and end points for selections can be moved 
by nudging them.

To move a selection start or end point by the 
Nudge value:

1  Configure the Nudge value. For details, see 
“Defining the Nudge Value” on page 599.

2  Make the initial selection with the Selector 
tool.

3  Do one of the following:

• While pressing Alt+Shift (Windows) or Op-
tion+Shift (Mac), press Plus (+) or 
Minus (–) on the numeric keypad to move 
the selection’s start point by the Nudge 
value.

– or –

• While pressing Control+Shift (Windows) 
or Command+Shift (Mac), press Plus (+) or 
Minus (–) on the numeric keypad to move 
the selection’s end point by the Nudge 
value.
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Extending Selections
You can extend selections to clip start and end 
points, to include an adjacent clip, or to Markers 
and Memory Locations.

To extend a selection to a clip start or end point:

1  With the Selector tool, select a portion of a 
clip, or click anywhere in the clip.

2  Do one of the following:

• Press Shift+Tab to extend the selection to 
the clip’s end point.

– or –

• Press Control+Shift+Tab (Windows) or Op-
tion+Shift+Tab (Mac) to extend the selec-
tion to the clip’s start point.

To extend a selection to include an adjacent clip:

1  Select the first clip with the Time Grabber tool.

2  Do one of the following:

• With Tab to Transients disabled, press 
Start+Shift+Tab (Windows) or Con-
trol+Shift+Tab (Mac) to extend the selec-
tion to the next clip boundary.

– or –

• Press Control+Start+Shift+Tab (Windows) 
or Option+Control+Shift+Tab (Mac) to ex-
tend the selection to include the previous 
clip boundary.
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To extend a selection to a Marker or Memory 
Location:

1  Do one of the following:

• Click in a track with the Selector tool at the 
start or end point.

– or –

• Make a selection with the Selector or Time 
Grabber tool.

2  Do one of the following:

• Shift-click a Marker in the Markers ruler.

– or –

• Shift-click a Memory Location in the Mem-
ory Locations window.

The selection is extended from the original In-
sertion point to the Marker or Memory Loca-
tion.

Using the Edit Selection 
Indicators (Start, End, and 
Length)
The Edit Selection indicators at the top of the 
Edit window can define precise Edit selections. 
Time values for the Edit Selection indicators use 
the time format for the Main Time Scale.

Edit Selection indicators 



To make a selection with the Edit Selection 
indicators:

1  Click with the Selector tool in the track you 
want to select.

2  Click in the Start field at the top of the Edit 
window.

3  Type in the start point for the selection and 
press the Forward Slash key (/) to enter the value 
and automatically move to the end field.

4  Type in the end point for the selection and 
press Enter to accept the value.

Numeric Entry Shortcuts for Selection 
Indicators

You can use the following shortcuts for entering 
values in the Edit Selection indicators:

• Press the Forward Slash (/) key to cycle 
through the three Edit Selection indicators.

• Use Period (.) or the Left and Right Arrow 
keys to move through the different time fields 
in each Edit Selection indicator.

• Press the Up or Down Arrow keys to increase 
or decrease numerical values.

• Move the mouse scroll wheel up or down to in-
crease or decrease numerical values.

• Drag in a field to scroll to a new value. For 
finer resolution, Control-drag (Windows) or 
Command-drag (Mac).

• Press Control (Windows) or Command (Mac) 
and Plus (+) or Minus (–), then type a number, 
to add or subtract from the current field value. 
For example, to add 10 to a current field value, 
press Control (Windows) or Command (Mac) 
and Plus (+) key, type “10,” and press Enter.

• Press Escape to exit the Edit Selection indica-
tors without entering any values.

These shortcuts can also be used to enter start 
and end values in the Transport window.
Calculator Entry Mode

You can perform calculator-style editing of val-
ues in the Edit Selection indicators.

To subtract time values:

1  In the Edit Selection indicator, highlight the 
time field you want to change.

2  Press Minus (–) on the numeric keypad.

3  Type the amount you want to subtract from the 
current time value, then press Enter.

4  Press Enter again to apply the change.

To add time values:

1  In the Edit Selection indicator, highlight the 
time field you want to change.

2  Press Plus (+) on the numeric keypad.

3  Type the amount you want to add to the cur-
rent time value, then press Enter.

4  Press Enter again to apply the change.

Selecting Across Multiple 
Tracks
To perform edits across multiple tracks or all 
tracks, you must first select the tracks. Do this 
by including other tracks in the selection, or by 
selecting in a Timebase ruler (for all tracks).

To make a selection in multiple tracks:

 With the Selector tool, drag vertically to in-
clude adjacent tracks in a selection (drag hori-
zontally to define the time range). 

To extend a selection to another track:

1  Using the Selector or Time Grabber tool, make 
a selection in the first track or tracks.

2  Shift-click in additional tracks with the Selec-
tor tool. An identical range is selected for each 
additional track.
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To shorten or lengthen the selection across each 
of the tracks, press Shift while dragging to 
change the range of the selection.

To select across all tracks, do one of the following:

 Enable the All Edit Group and make a selec-
tion in any track.

– or –

 Drag with the Selector tool in any Timebase 
ruler (make sure the Timeline and Edit Selec-
tions are linked).

These selections include all tracks in the Edit 
window, but do not include the Conductor 
tracks (for Tempo, Meter, and Markers).

To select across all tracks, including the 
Conductor tracks (for Tempo, Meter, and Markers):

 Alt-drag (Windows) or Option-drag (Mac) 
with the Selector tool in any Timebase ruler.

Moving and Extending 
Selections Between Tracks
With Commands Keyboard Focus enabled, Edit 
selections can be moved or extended to adjacent 
tracks.

To move a selection to an adjacent track:

1  Enable Commands Keyboard Focus (see “Key-
board Focus” on page 30).

2  With the Selector or Time Grabber tool, make 
a selection.

Commands Keyboard Focus button enabled 
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3  Do one of the following:

• Press P on your computer keyboard to move 
the selection to the previous track.

– or –

• Press semicolon (;) to move the selection to 
the next track.

In either instance, the original Edit selection be-
comes deselected.

To extend a selection to an adjacent track:

1  Enable Commands Keyboard Focus (see “Key-
board Focus” on page 30).

2  With the Selector or Time Grabber tool, make 
a selection.

3  Do one of the following:

• Press Shift+P to extend the selection to the 
previous track.

– or –

• Press Shift+Semicolon (;) to extend the se-
lection to the next track.

In either instance, the original Edit selection re-
mains selected.

With Commands Keyboard Focus disabled, 
press Start+P (Windows) or Control+P 
(Mac) to move the selection to the previous 
track, or Start+Semicolon (;) (Windows) or 
Control+Semicolon (;) (Mac) to move the 
selection to the next track.

With Commands Keyboard Focus disabled, 
press Start+Shift+P (Windows) or Con-
trol+Shift+P (Mac) to extend the selection 
to the previous track, or Start+Shift+Semi-
colon (;) (Windows) or Con-
trol+Shift+Semicolon (;) (Mac) to extend 
the selection to the next track.



To remove the bottom track from a selection:

 Press Alt+Start+Semicolon (;) (Windows) or 
Option+Control+Semicolon (;) (Mac) to remove 
the bottom track.

Other Useful Selection 
Techniques
Following are some additional selection tech-
niques.

To position the edit cursor precisely at a clip start, 
end, or sync point:

1  Make sure the Tab to Transients button is not 
enabled. (See “Tabbing to Transients” on 
page 580.)

2  Click with the Selector tool in the track.

3  Do one of the following:

• Press Tab to move the cursor to the next 
clip or clip group start, end, or sync point.

– or –

• Press Control+Tab (Windows) or Op-
tion+Tab (Mac) to move the cursor to the 
previous clip or clip group start, end, or 
sync point.

To make a selection with the Scrubber:

1  Choose Setup > Preferences and click the 
Operation tab.

2  Select the option for “Edit Insertion Follows 
Scrub/Shuttle,” then click OK.

3  Scrub with the Scrubber to find an appropriate 
start point for the selection, then release.

4  While pressing Shift, scrub to an appropriate 
end point for the selection, then release. The 
range between the initial and final scrub be-
comes selected.
To move a selection to an adjacent clip on the 
same track:

1  Select a clip with the Time Grabber.

2  Do one of the following:

• Press Start+Tab (Windows) or Control+Tab 
(Mac) to move the selection to the next clip. 

– or –

• Press Control+Start+Tab (Windows) or Op-
tion+Control+Tab (Mac) to move the selec-
tion to the previous clip.

In either instance, the original clip becomes de-
selected.

To slide an Edit selection in the Main Timebase 
ruler:

1  With the Selector or Time Grabber tool, make 
a selection.

2  While pressing Alt (Windows) or Option 
(Mac), move the cursor over either of the Time-
line Selection Markers in the ruler (the Time 
Grabber appears).

3  Drag left or right to move the Edit selection 
back or forward in time while preserving its 
length.

If Link Timeline and Edit Selection is disabled 
(Options > Link Timeline and Edit Selection), Alt-
drag (Windows) or Option-drag (Mac) the Edit 
Markers instead.

Sliding an Edit selection in the Main Timebase ruler
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Right-Click Commands and 
Selection Preservation
You can use Right-click commands with key 
combinations to perform operations on objects 
while maintaining selections in the Edit and Mix 
windows. For example, you can maintain selec-
tions in the following areas while carrying out 
certain commands:

• Clip selections in the Timeline

• Clip name selections in the Clip List

• Track selections

To apply a command to an object while keeping the 
current selection:

 Control-Right-click (Windows) or Command-
Right-click (Mac) the object and choose a com-
mand from the pop-up menu.

Tabbing to Transients
With the Tab to Transients button enabled, you 
can automatically navigate to transients in au-
dio waveforms in Waveform view, placing the 
cursor just before the detected transient peak. 
This lets you define selections and play ranges, 
as well as start and end points for new clips, 
without having to zoom in on the waveform. 

In Warp view, Tab to Transients tabs to all Event 
and Warp markers in a clip. Normal Tab tabs to 
clip boundaries and all Warp markers. In Anal-
ysis view, pressing Tab always tabs to Event 
markers, regardless of whether or not Tab to 
Transients is enabled.

Tab to Transients button enabled 
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For MIDI and Instrument tracks in Notes view, 
pressing Tab always tabs to the next note, re-
gardless of whether or not Tab to Transients is 
enabled. In Clips view, Tab to Transients tabs to 
notes and Normal Tab tabs to clip boundaries. 

For MIDI notes, when tabbing to chords, each 
note in the chord is recognized as a single event. 
This lets you tab to each note in the chord.

When Tab to Transients is enabled, the Tabbing 
function also locates the cursor to clip start and 
end points, but not to sync points.

To set the start and end points of a selection with 
Tab to Transients:

1  In the upper left of the Edit window, click the 
Tab to Transients button so it becomes selected.

2  If you will be setting the play range with this 
selection, enable Options > Link Timeline and Edit 

Selection.

3  Click in the audio track just before the begin-
ning of the material you want to select.

4  Press Tab repeatedly until the cursor locates to 
the transient where you want to start the selec-
tion.

If necessary, you can move to the previous tran-
sient by pressing Control+Tab (Windows) or 
Option+Tab (Mac).

5  Press Shift+Tab until the cursor locates to the 
end of the material you want to select.

To move the selection end point to the previous 
transient, press Control+Shift+Tab (Windows) 
or Option+Shift+Tab (Mac).

To toggle Tab to Transients on and off, press 
Control+Alt+Tab (Windows) or Com-
mand+Option+Tab (Mac).



Once selected, the material can be looped for re-
cording or playback, or it can be turned into a 
new clip with the Separate or Capture command.

Tab to Transients Across Multiple 
Tracks

With the edit cursor inserted across multiple 
tracks, you can use Tab to Transients to tab to 
the next transient on any of those tracks. When 
transients on multiple tracks are closely aligned, 
Tab to Transients tabs to the first transient on 
any of those tracks.

Timeline Selections
With the Link Timeline and Edit Selection op-
tion disabled, selections can be made in the 
Timeline that are distinct and separate from 
Edit selections.

With the Timeline and Edit selections linked, 
any Edit selections that are made are mirrored 
in the Timeline, and any Timeline selection is 
mirrored as an Edit selection across all tracks.

Whether the Timeline and Edit selections are 
linked or not, the range indicated by the Time-
line Selection Markers always determines the 
range for playback and recording (except when 
in Dynamic Transport mode, see “Dynamic 
Transport Mode” on page 429).

With Pro Tools HD, when the Scrolling option is 
set to Center Playhead, it determines where 
playback begins (see “Playing Timeline and Edit 
Selections with the Playhead” on page 427).

Peak transients are usually visible in the 
waveform. However, some low-frequency 
transients may not appear as visible peaks 
in the waveform.
To make a Timeline selection with the Selector 
tool:

1  If you want to constrain the selection to the 
current Grid value, set the Edit mode to Grid. 

2  Drag with the Selector tool in any Timebase 
ruler.

The Timeline selection is indicated in the Main 
Timebase ruler by the blue Timeline Selection 
Markers (or if a track is record-enabled, the 
Timeline Selection Markers are red). The start, 
end, and length for the Timeline selection is dis-
played in the corresponding fields in the Trans-
port window.

Making a Timeline selection with the Selector tool

To select all tracks, including Conductor 
tracks, press Alt (Windows) or Option (Mac) 
while dragging in a Timebase ruler with the 
Selector tool.
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To set the Timeline selection by dragging the 
Timeline Selection Markers:

1  If you want to constrain movement to the cur-
rent Grid value, set the Edit mode to Grid. 

2  With the Time Grabber, drag the first Timeline 
Selection Marker (down arrow) to set the start 
point.

3  Drag the other Timeline Selection Marker (up 
arrow) to set the end point.

To set the Timeline selection by typing into the 
Transport window:

1  If necessary, resize the Transport window to 
Expanded view so the start and end times are 
displayed (View > Transport > Expanded).

2  Do one of the following:

• In the Transport window, click in the start 
field.

– or –

• Press Alt+Forward Slash (/) (Windows) or 
Option+Forward Slash (/) (Mac) on the nu-
meric keypad to select the start field in the 
Transport window.

3  Type in the new start location and press For-
ward Slash (/) to enter the value and automati-
cally move to the end field.

4  Type in the new end location and press Enter 
to accept the value.

Dragging a Timeline Selection Marker

Shortcuts for entering start and end values 
in the Transport window are listed in “Nu-
meric Entry Shortcuts for Selection Indica-
tors” on page 577.
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Sliding a Timeline Selection
Like Edit selections, Timeline selections can be 
slid in the Main Timebase ruler.

To move a Timeline selection in the Main Timebase 
ruler:

1  While pressing Alt (Windows) or Option 
(Mac), move the cursor over either of the Time-
line Selection Markers (the Time Grabber ap-
pears).

2  Drag left or right to move the Timeline selec-
tion back or forward in time, while preserving 
its length.

Timeline Selections to/from Edit 
Selections
When the Timeline and Edit selections are un-
linked, you can copy selections between them.

To change the Timeline selection to match the 
current Edit selection:

 Choose Edit > Selection > Change Timeline to 

Match Edit.

To change the Edit selection to match the current 
Timeline selection:

 Choose Edit > Selection > Change Edit to Match 

Timeline.

Press Alt+Shift+5 (Windows) or Op-
tion+Shift+5 (Mac) to change the Timeline 
selection to match the Edit selection.

Press Alt+Shift+6 (Windows) or Op-
tion+Shift+6 (Mac) to change the Edit se-
lection to match the Timeline selection.



Navigating the Timeline with the 
Edit Window Counters and 
Indicators
The counters and indicators at the top of the 
Edit window display the current playback loca-
tion and Edit selection. These include the Main 
and Sub Counters, and the Edit Selection Start, 
End, and Length indicators.

All Edit window counters and indicators (except 
the Sub Counter) let you enter a location in their 
counter display to navigate to a specific time lo-
cation.

The Main Counter displays the playback loca-
tion in the time format for the Main Time Scale. 
The Sub Counter can be set to any of the other 
Time Scale formats for another timing refer-
ence.

The Edit Selection indicators (to the right of the 
Main and Sub counters) display the Start and 
End times, and Length of the current Edit selec-
tion according to the Main Timebase.

The Main and Sub Counters, as well as the Edit 
Selection indicators, also appear in the Trans-
port window when it is set to display Counters.

Main and Sub Counters, Edit Selection indicators
To navigate with the Edit window Main Counter (or 
one of the Edit Selection indicators):

1  Do one of the following:

• Click in one of the counters.

– or –

• Press asterisk (*) on the numeric keypad to 
highlight the Main Counter in the Edit win-
dow (or the Main Counter in the Transport 
window or Big Counter window, if either 
are displayed).

2  Type in the new location. Press Period (.) to 
cycle through to the different time fields.

3  Press Enter to accept the new value and auto-
matically locate there.

Scrolling in a Timebase Ruler
You can scroll the contents of the Edit window 
by dragging in a ruler. While this does not actu-
ally update the session’s Current Location, it 
does let you conveniently shift the display left or 
right for the sake of finding and editing mate-
rial.

This method of scrolling is especially useful 
when using the Continuous Scrolling option, 
which does not update or follow Timeline selec-
tions.

To scroll the entire contents of the Edit window 
from a ruler:

 While pressing Control+Alt+Start (Windows) 
or Command+Option+Control (Mac), drag left 
or right in any of the Timebase rulers.

Scrolling in a ruler
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Scrolling with a Scroll Wheel
If you have a mouse with a scroll wheel, you can 
use the scroll wheel to scroll vertically or hori-
zontally in any Pro Tools window that has a 
scroll bar (such as the MIDI Event List).

To scroll a Pro Tools window vertically:

1  Place the mouse over the window you want to 
scroll (for example, in the Edit window you 
might want to scroll either the track display or 
the Clip List).

2  Scroll the scroll wheel up or down to scroll the 
window up or down.

To scroll a Pro Tools window horizontally:

1  Place the mouse over the window you want to 
scroll (for example, in the Edit window you 
might want to scroll either the track display or 
the Clip List).

2  Shift-scroll the scroll wheel up or down to 
scroll the window to the left or right.

Auto-Scrolling Tracks in the 
Mix and Edit Windows
If you are working with more tracks than can be 
displayed at one time in the Mix or Edit win-
dows, you can select a track in one window and 
Pro Tools will automatically scroll to that track 
in both windows.

To auto-scroll the Mix and Edit windows to show a 
track, do one of the following:

 In the Track List, Right-click the track name 
and select Scroll Into View.

– or –

 In the Track List, Control-click (Mac) the 
track name and select Scroll Into View.
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The track becomes selected, and the Mix and 
Edit windows both scroll to display the selected 
track.

Navigating to Tracks Using 
Track Position Numbers
With Track Number View enabled, each track is 
assigned a number corresponding to its position 
in the Mix and Edit Windows. You can scroll di-
rectly to any track by its positional number.

To navigate directly to any track using Track 
Position Numbers:

1  Choose View > Track Number.

2  Choose Track > Scroll to Track.

3  In the Scroll To Track dialog, enter the Track 
Number for the track you want to view.

4  Click OK.

The track is selected, and the windows scroll as 
follows:

• The Edit window tracks scroll to bring the se-
lected track as close to the top as possible. 

• The Mix window tracks scroll to bring the se-
lected track as close to the left as possible. 

When tracks are reordered, Track Position 
Numbers are reassigned to keep them in nu-
merical sequence.

Press Control+Alt+F (Windows) or Com-
mand+Option+F (Mac) to Scroll to Track.

Scroll To Track dialog



Universe View
The Universe view displays an overview of the entire Pro Tools session above the tracks pane in the 
Edit window. 
Universe view at the top of the Edit window
This overview represents audio and MIDI mate-
rial on all tracks in the session that are not hid-
den (including tracks that are inactive, or that 
contain offline clips). The order in which mate-
rial is displayed in the Universe view corre-
sponds to the track order in the Edit window.

In the Universe view, audio, MIDI, and video 
clips on tracks are represented by horizontal 
lines that are the same colors as the clips on the 
tracks. Each audio track is represented at the 
same height regardless of how many channels it 
has. Additionally, tracks that show Automation, 
Controller, or Playlist lanes are represented 
with increasing height for each lane shown.
Since Auxiliary Input, Master Fader, and VCA 
Master tracks do not contain audio or MIDI 
clips, they are displayed as blank areas in the 
Universe view.

Showing the Universe Window

To show or hide the Universe view in the Edit 
window, do one of the following:

 Select or deselect View > Other Displays > Uni-

verse.

 Double-click the divider above the Main 
Timebase ruler. 
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 From the Edit window pop-up menu, select or 
deselect Universe.

 Click the Show/Hide Universe view button.

Selecting Universe view from the Edit window pop-up 
menu

Clicking the Show/Hide Universe view button
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Framed Area in the Universe 
View
The framed area in the Universe view represents 
what is visible in the Tracks pane in the Edit 
window. If you change what is displayed in the 
Edit window—by zooming, scrolling horizon-
tally or vertically, hiding or showing tracks, or 
changing track heights—the framed area in the 
Universe view relocates and resizes accordingly. 
During playback, if the Edit window is set to 
scroll, the framed area in the Universe view also 
scrolls.

When all tracks are visible in the Edit window 
and the session is zoomed all the way out, with 
all clips visible, the entire Universe window is 
framed.

Framed area representing what part of the session is 
viewed in the Tracks pane of the Edit window



Navigating with the Universe 
View
By clicking in the Universe view, you can scroll 
the material displayed in the Edit window hori-
zontally, vertically, or both. This provides a con-
venient method of focusing the Edit window 
anywhere in the session.

To navigate the session using the Universe view:

1  Ensure that Universe view is shown (View > 

Other Displays > Universe).

2  Click anywhere in the Universe view to move 
the framed area and the Edit window updates ac-
cordingly.

Resizing the Universe View
You can resize the height of the Universe view to 
fit the total number of tracks in the session, or to 
show more of the Edit window.

To resize the height of the Universe view:

1  Click the area between the bottom of the Uni-
verse window and the top of the Timebase rulers. 
The cursor changes to show that you can resize 
the Universe view.

2  Drag up to decrease the height of the Universe 
view or drag down to increase the height of the 
Universe view.
Scrolling the Universe View
If you have more tracks in the session than are 
visible in the Universe view, you can scroll up or 
down to show the other tracks.

To scroll the Universe view up or down:

 Click the Scroll Up or Scroll Down Arrows on 
the right of the Universe view.

Resizing the Universe view

Scroll Up and Down Arrows in the Universe view
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Navigating Your Pro Tools 
Session
In addition the Universe view, Pro Tools let you 
quickly and easily navigate your session using 
keyboard shortcuts. This topic provides an over-
view of the essential key commands for navigat-
ing and making Edit selections in your session.

Zooming to the Entire Session 
and to the Edit Selection

To zoom your entire session into view:

1  Press Alt+Start+A (Windows) or Option+Con-
trol+A (Mac) to horizontally fit the begging and 
end of your session to the length of the Edit win-
dow.

2  Press Alt+Start+Up Arrow (Windows) Op-
tion+Control+Up Arrow (Mac) to fit all of the 
tracks in your session to the height of the Edit 
window.

Now that you can see your entire session in the 
Edit window, identify the location to view for 
editing.

To zoom to an Edit selection:

1  With the Selector or the Grabber tool, make an 
Edit selection.

2  Press Alt+Start (Windows) or Option+Con-
trol+F (Mac) to fit the length of the selection to 
the length of the Edit window.

3  Press Control+Start+Up Arrow (Windows) or 
Command+Control+Up Arrow (Mac) to zoom 
the Track Height of the Edit selection to fit to the 
height of the Edit window.

Press F7 for the Selector tool or F8 for the 
Grabber tool.
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To zoom to an Edit selection using Zoom Toggle:

1  With the Selector or the Grabber tool, make an 
Edit selection.

2  Press Start+E (Windows) or Control+E (Mac) 
to enable Zoom Toggle.

3  Do one of the following:

• Press Start+E (Windows) or Control+E 
(Mac) again to revert to the preview zoom 
state.

– or –

• Press Alt+Shift+E (Windows) or Op-
tion+Shift+E (Mac) to cancel Zoom Toggle 
without reverting to the previous view.

Creating Edit Selections with 
Tab to Transients

If editing audio with clear transients, use Tab to 
Transients to make Edit selections:

1  Press Control+Alt+Tab (Windows) or Com-
mand+Option+Tab (Mac) to toggle Tab to Tran-
sients on and off.

2  With the Selector tool, place the Edit cursor 
before the first transient your want in your se-
lection.

3  Press Tab to place the Edit cursor at the first 
transient.

4  Press Shift+Tab to make an Edit to the next 
trnansient.

Press F7 for the Selector tool or F8 for the 
Grabber tool.

Set the Track Height option for Zoom Toggle 
to Fit To Window in the Editing Preferences.



You can also do the following:

• Press Control+Tab (Windows) or Op-
tion+Tab (Mac) to move the Edit cursor to 
the previous transient.

– and –

• Press Control+Shift+Tab (Windows) or Op-
tion+Shift+Tab (Mac) to extend the selec-
tion to the previous transient.

Making an Edit Selection During 
Playback

To make an Edit selection during playback:

1  Place the Edit cursor in the track or across 
multiple tracks where you want to make the se-
lection.

2  Start playback.

3  Press the Down Arrow to place the Edit cursor 
at the current playback location and mark the 
beginning of the Edit selection.

4  Press the Up Arrow to mark the end point of 
the Edit selection.

5  Stop playback.

6  Do one of the following:

• Press the Left arrow to locate the beginning 
of the Edit selection.

– or –

• Press the Right arrow to locate the end of 
the Edit selection.
Changing the Edit Selection
Pro Tools provides several keyboard shortcuts 
for moving and extending or decreasing the 
range of an Edit (or Timeline) selection.

To move the selection down to the next track:

 Press Start+; (semicolon) (Windows) or Con-
trol+; (semicolon) (Mac).

To move the selection up to the next track:

 Press Start+P (Windows) or Control+P (Mac).

To move the selection forward by the selection 
amount:

 Press Control+Alt+Start+’ (single quote) 
(Windows) or Command+Control+Option+’ 
(single quote) (Mac).

To move the selection backward by the selection 
amount:

 Press Control+Alt+Start+L (Windows) or 
Command+Control+Option+L (Mac).

To double the Edit selection:

 Press Control+Alt+Start+Shift+’ (single 
quote) (Windows) or Command+Control+Op-
tion+Shift+’ (single quote) (Mac).

To halve the Edit selection:

 Press Control+Alt+Start+Shift+L (Windows) 
or Command+Control+Option+Shift+L (Mac).

To extend the Edit selection down across 
tracks, Press Start+Shift+; (semicolon) 
(Windows) or Control+Shift+; (semicolon) 
(Mac).

To extend the Edit selection up across 
tracks, Press Start+Shift+P (Windows) or 
Control+Shift+P (Mac).
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Moving the Insertion to the 
Beginning or End of the 
Selection
With the Transport stopped, you can use the 
Down and Up Arrows on your alphanumeric 
keyboard to the beginning or end of the Edit (or 
Timeline) selection (and collapse the selection).

To move the insertion to the beginning of the 
selection:

 Press the Down Arrow.

To move the insertion to the end of the selection:

 Press the Up Arrow.

Restoring the Last Selection
There are times when editing that you can loose 
your selection. If you loose the current Edit (or 
Timeline) selection and want to restore it, use 
the Restore Last Selection command. 

To restore the last selection:

 Choose Edit > Restore Last Selection.

You can also press Control+Alt+Z (Win-
dows) or Command+Option+Z (Mac) to re-
store the previous selection.
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Changing Track Heights

To fit the Track heights of tracks containing he Edit 
selection to the height of the Edit window:

 Press Control+Start+Up Arrow (Windows) or 
Command+Control+Up Arrow (Mac).

To change Track height proportionally for tracks 
containing the Edit selection:

 Press Start+Up or Down Arrows (Windows) or 
Control+Up or Down Arrows (Mac).

To change Track views for all tracks together:

 Press Alt+Start+Up or Down Arrows (Win-
dows) or Option+Control+Up or Down Arrows 
(Mac).

Changing Track Views

To change Track views for tracks containing the 
Edit selection:

 Press Control+Start+Left or Right arrows 
(Windows) or Command+Control+Left or Right 
arrows (Mac).

To change Track views for all tracks together:

 Press Control+Alt+Start+Left or Right arrows 
(Windows) or Command+Option+Control+Left 
or Right arrows (Mac).



Chapter 28: Editing Clips and Selections
Clips are the basic building blocks for arranging 
audio and MIDI in Pro Tools. Understanding 
how clips are created, edited, and arranged is es-
sential to taking full advantage of the editing ca-
pabilities of Pro Tools.

This topic covers basic editing functions as they 
apply to clips and clip groups, and selections, 
which for the most part apply to both MIDI and 
audio data. 

For editing procedures more specific to MIDI, 
see Chapter 32, “MIDI Editing.” For editing pro-
cedures specific to video, see “Video Clips” on 
page 1181.
Creating New Clips
Pro Tools provides several commands for creat-
ing clips and clip groups, each of them having a 
slightly different effect on the selection. When 
you create a new clip or clip group, it appears in 
the Clip List and in the track’s playlist. When 
creating a new clip from an existing clip, the 
original clip remains in the Clip List. New clips 
are named automatically (see “Auto-Naming 
Options” on page 277). 

Capture Clip Command
The Capture Clip command defines a selection as 
a new clip and adds it to the Clip List. From 
there, the new clip can be dragged to any exist-
ing tracks.
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To capture a new clip:

1  With the Selector tool, drag in an existing clip 
to select the material for the new clip.

2  Choose Clip > Capture.

3  Type a name for the new clip and click OK.

The new clip appears in the Clip List. The origi-
nal clip remains intact and unchanged.

Separate Commands
The Separate commands define a selection 
within an existing clip, or a partially selected 
clip, as a new clip and separate it from sur-
rounding material. The Separate commands can 
also be applied to MIDI notes (see “Separating 
MIDI Notes” on page 690).

New clips appear in the tracks in which they are 
created, separate from the data surrounding 
them. They also appear in the Clip List. 

There are three different Separate commands:

At Selection (or Edit Cursor) Creates new clip 
boundaries at the selection start and end points. 
If there is no selection and the edit cursor is 
placed within the clip, the clip is split into two 
new clips at the insertion point. Likewise, MIDI 
notes can be separated at the selection start and 
end points (or at the Edit cursor).

Selecting a portion of a clip

Press Control+R (Windows) or Com-
mand+R (Mac) for Capture Clip.
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On Grid Creates new clips according to the se-
lected Grid value (see “Defining the Grid Value” 
on page 833). Likewise, MIDI notes can be sepa-
rated on the grid.

At Transients Automatically creates clip bound-
aries on detected transients within a selection. 
This uses the same algorithm for transient de-
tection as the Tab to Transients feature (see 
“Tabbing to Transients” on page 580). On Elas-
tic Audio-enabled tracks, the Separate At Tran-

sients command uses the transient events de-
tected by Elastic Audio analysis (see “Elastic 
Audio Analysis” on page 886). Separate At Tran-

sients only applies to audio and is not applicable 
to MIDI notes or clips.

To separate one or more clips (or MIDI notes) at the 
selection (or at the edit cursor):

1  Do one of the following:

• With the Selector tool, make an Edit selec-
tion.

– or –

• With the Selector tool, click at the point 
where you want to separate the clip (or 
MIDI note).

2  Do one of the following:

• Choose Edit > Separate > At Selection.

– or –

• With an Edit selection, Right-click near the 
cursor position or selection and choose 
Separate from the pop-up menu.

3  If the Editing preference for Auto-Name Sepa-

rated Clips is disabled, type a name for the new 
clip when prompted, then click OK.

Press Control+E (Windows) or 
Command+E (Mac) for Separate At Selection.



To separate clips (or MIDI notes) according to the 
current grid resolution:

1  Make an Edit selection.

2  Choose Edit > Separate > On Grid.

3  In the Pre-Separate Amount dialog, type a 
pre-separate amount in milliseconds. This can 
be useful to pad the beginnings of the new clips.

4  Click OK.

To separate audio clips at transients:

1  Make an Edit selection.

2  Choose Edit > Separate > At Transients.

3  In the Pre-Separate Amount dialog, type a 
pre-separate amount in milliseconds. This can 
be useful to pad the beginnings of the new clips.

4  Click OK.

Auto-Name Separated Clips 
Option
With the Auto-Name Separated Clips option in 
the Editing Preferences page selected, Pro Tools 
automatically names separated clips for you. 
The name is a numbered variation of the origi-
nal clip’s name.

Pre-Separate Amount dialog
By separating a clip, additional clips are auto-
created from data on either side of the separa-
tion, which have new numbers assigned to their 
names. The original clip remains intact and un-
changed on the Clip List.

“Separate Clip” Operates On All 
Related Takes
When the “Separate Clip” Operates on All Related 

Takes option is enabled in the Editing Prefer-
ences, editing a clip with the Separate Clip com-
mand also affects all other related takes with the 
same User Time Stamp.

This option helps you compare different sec-
tions from a group of related takes. For example, 
you can quickly separate an entire group of re-
lated vocal takes into sections, then audition 
and select the best material from each section 
independently.

If this option is selected, make sure the Track 

Name and Clip Start and End options are also se-
lected in the Matching Criteria window (see 
“Matching Criteria” on page 645). If they are 
not, all clips in the session that have the same 
User Time Stamp will be affected.

In most instances, you will want to disable the 
Separate Clip Operates On All Related Takes op-
tion, to prevent a large number of clips from be-
ing created when you use the Separate Clip com-
mand.

The Clip List can quickly fill up with auto-
created clips. For easier clip management, 
click the Clip List menu, deselect Show > 
Auto-Created to hide all auto-created clips 
in the Clip List.
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Separating Multiple Tracks
The following figure illustrates a separation 
across one mono audio track and two stereo 
tracks. For some tracks, the selection resides 
within a clip, while others reside at the start or 
end of a clip.

Once separated, this material can be moved or 
copied to another location.

Separating across multiple tracks
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Separation Grabber Tool
You can use the Separation Grabber tool to au-
tomatically separate an Edit selection and move 
it to another location or another track.

To separate a selection with the Separation 
Grabber tool:

1  With the Selector tool, make an Edit selection. 
The selection can reside within a single clip, 
across adjacent clips within the same track, or 
across multiple tracks.

2  From the Grabber tools pop-up menu, choose 
the Separation Grabber tool.

3  Drag the selection to the new location, or to 
another track.

A new clip (or clips) containing the previous se-
lection is created, separate from the original se-
lection. New clips are also created from the ma-
terial outside the original selection.

Separation Grabber tool

Dragging selection to later in track with Separation 
Grabber tool



To separate a selection without affecting the 
original clips:

1  With the Selector tool, make an Edit selection. 
The selection can reside within a single clip, 
across adjacent clips within the same track, or 
across multiple tracks.

2  From the Grabber tools pop-up menu, choose 
the Separation Grabber tool.

3  While pressing Alt (Windows) or Option 
(Mac), drag the selection to the new location, or 
to another track.

New clips containing the previous selection are 
created and placed at the new location. The orig-
inal selection and clips remain intact.

Dragging to another track with the Separation Grabber 
tool
Clip Overlap and Underlap
When a tick-based audio track has multiple 
clips, an increase in tempo can cause neighbor-
ing clips to overlap. Audio clips can be set to dis-
play a small “dog-ear” corner to indicate over-
lapping clip boundaries. 

To toggle the display of overlap and underlap clip 
boundaries:

 Choose View > Clip > Overlap.

Changing Clip Overlap/Underlap

After tempo changes with tick-based audio, and 
other edits, clips may overlap in undesired ways. 
To correct this, a clip can be brought to the 
front, or sent behind neighboring clips as 
needed.

To change the clip overlap or underlap:

1  In the Edit window, choose the clip or clips you 
want to re-order.

2  Do one of the following:

• Choose Clip > Bring to Front to make the clip 
overlap the neighboring clips.

– or –

• Choose Clip > Send to Back to make the clip 
underlap the neighboring clips. 

If multiple overlapping clips are selected, 
Pro Tools will apply the command to each clip as 
that clip relates to the neighboring clip on the 
right. 

Clip overlap and underlap

Overlap clip

Underlap clip

Overlap clip
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Healing Separated Clips
The Heal Separation command returns sepa-
rated clips to their original state—provided the 
clips are still next to each other and their rela-
tive start and end points have not changed since 
the separation.

If you have trimmed or otherwise changed the 
start or end points of the two clips, or moved 
them further away from each other, you will not 
be able to repair them with the Heal Separation 
command. It is not possible to heal two clips 
created from different audio files.

To heal a separation between two clips:

1  With the Selector tool, make a selection that 
includes part of the first clip, the entire separa-
tion between the clips, and part of the second 
clip.

2  Choose Edit > Heal Separation.

If the clips do not heal with Heal Separation, do one 
of the following to return the separated clips to a 
single clip:

 Delete one of the two separated clips (verify 
that Slip mode is enabled so the gap does not 
close) and use the Trim tool to expand the re-
maining clip to its original length (see “Using 
the Trim Tools” on page 553).

– or –

 Delete both of the separated clips and drag the 
original clip from the Clip List to the original lo-
cation (see “Placing Clips in Tracks” on 
page 823).

Press Control+H (Windows) or 
Command+H (Mac) to Heal Separation.
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Trimming Clips
In addition to the Trim tools (see “Using the 
Trim Tools” on page 553), Pro Tools provides 
several options for editing clip and clip group 
boundaries. 

Trim to Selection Command
The Trim to Selection command removes data be-
fore and after a clip or MIDI note selection, leav-
ing only the selection. This command lets you 
quickly remove all data in a clip (and in some in-
stances the entire track) except for the current 
selection.

To trim unwanted data from a clip or note:

1  With the Selector tool, select a portion of a clip 
or note (or a range of notes).

2  Choose Edit > Trim Clip > To Selection to re-
move material outside of the selection.



Trim to Insertion Commands
You can trim a clip or MIDI note by automati-
cally removing the material between the Edit in-
sertion point and the start or end point of the 
clip.

To trim from a start point to insertion:

1  With the Selector tool, click inside the clip or 
note where you want the new start point to be.

2  Choose Edit > Trim Clip > Start To Insertion. The 
clip’s start point is automatically trimmed to the 
insertion point.

To trim from an end point to insertion:

1  With the Selector tool, click inside the clip or 
note where you want the new end point.

2  Choose Edit > Trim Clip > End To Insertion. The 
clip’s end point is automatically trimmed to the 
insertion point.

Press Alt+Shift+7 (Windows) or Option+
Shift+7 (Mac) to Trim Start To Insertion.

Clip end trimmed to insertion

Press Alt+Shift+8 (Windows) or Option+
Shift+8 (Mac) to Trim Start To Insertion.
Trim to Fill Selection Commands
The Trim to Fill Selection commands let you au-
tomatically reveal underlying material in the 
gaps between clips, or before and after individ-
ual clips, as follow:

To trim from a start point to fill gaps:

1  With the Selector tool, select across at least 
one gap between clips.

2  Choose Edit > Trim Clip > Start to Fill Selection.

The start point of the clip behind the gap is au-
tomatically trimmed (expanded) to the previous 
clip, or as far as possible if there is not enough 
underlying material to cover the gap.

To trim from an end point to fill gaps:

1  With the Selector tool, select across at least 
one gap between clips.

2  Choose Edit > Trim Clip > End To Fill 

Selection. 

Clip start trimmed to fill gap
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The end point of the clip in front of the gap is 
automatically trimmed (expanded) to the next 
clip, or as far as possible if there is not enough 
underlying material to cover the gap.

To trim from a clip’s start and end points to fill the 
Edit selection:

1  With the Selector tool, make an Edit selection 
that includes the clip you want to trim out.

2  Choose Edit > Trim Clip > To Fill Selection.

The start point of the clip is automatically 
trimmed (expanded) to the Edit selection start, 
or as far as possible if there is not enough under-
lying material to cover the selection, and the end 
point of the clip is automatically trimmed out 
(expanded) to the Edit selection end, or as far as 
possible if there is not enough underlying mate-
rial to cover the selection.

The Trim to Fill Selection command is the inverse 
of the Trim to Fit Selection command: where the 
Trim to Fill Selection command trims a clip out to 
match the Edit selection, the Trim to Fit Selection 
command trims a clip in to match the Edit selec-
tion.

Clip end trimmed to fill gap
Pro Tools Reference Guide
Trimming with Nudge
You can trim the start and end points of clips (or 
MIDI notes) by the current Nudge value.

To trim a clip’s start or end point by the Nudge 
value:

1  Configure the Nudge value (see “Defining the 
Nudge Value” on page 599).

2  With the Time Grabber tool, select the clip you 
want to trim.

3  Do one of the following:

• While pressing Alt (Windows) or Option 
(Mac), press Plus (+) or Minus (–) on the 
numeric keypad to trim the clip’s start 
point by the Nudge value.

– or –

• While pressing Control (Windows) or Com-
mand (Mac), press Plus (+) or Minus (–) on 
the numeric keypad to trim the 
clip’s end point by the Nudge value.

Nudging Clips
Pro Tools can nudge clips (or MIDI notes) by 
precise increments with the Plus (+) and Minus 
(–) keys on the numeric keypad. The amount of 
the nudge is determined by the value specified 
in the Nudge Value pop-up menu. The Nudge 
function can be used in any of the Edit modes.

Nudging can be invaluable for adjusting the 
“groove” of a musical phrase or a sound effect 
relative to other elements in the session. Since 
Pro Tools can nudge material during playback, 
you can nudge continuously in real time to ad-
just the timing relationship between tracks.

Nudge can also be used to adjust the placement 
of automation breakpoints. For more informa-
tion, see “Editing Automation” on page 1049.



Defining the Nudge Value
The Nudge value determines how far clips and 
selections are moved when nudging. 

Start and end points for selections can also be 
moved by the Nudge value (see “Nudging Selec-
tion Start/End Points” on page 575). In addi-
tion, clips can be trimmed by the Nudge value 
(see “Trimming with Nudge” on page 598).

To set the Nudge value:

1  Do one of the following:

• From the View > Main Counter menu, select 
the Time Scale for the Nudge value.

– or –

• To keep the Main Time Scale and use a dif-
ferent time format for the Nudge value, de-
select Follow Main Timebase in the Nudge 
Value pop-up menu.

2  Specify a Nudge value by doing one of the fol-
lowing:

• From the Nudge value pop-up menu in the 
Edit window, select the Nudge value.

– or –

• To specify a Nudge value not listed in the 
Nudge Value pop-up menu, click the Nudge 
Value indicator and type in the value.

Nudge Value pop-up menu showing Timecode
Nudging with Nudge

To nudge one or more clip:

1  Configure the Nudge value (see “Defining the 
Nudge Value” on page 599).

2  With the Time Grabber or Selector tool, select 
the clip, clips, or clip groups you want to nudge. 
The clips can reside on multiple tracks. Only 
clips that are completely selected are nudged.

3  Do one of the following:

• On the numeric keypad, press Plus (+) to 
move the selection forward by the Nudge 
value.

– or –

• Press Minus (–) to move the selection back 
by the Nudge value.

The Nudge command works the same regardless 
of the Edit mode. Adjacent clips are overlapped 
in Shuffle mode, the Spot dialog does not appear 
when in Spot mode, and shifted material does 
not snap to the Grid when in Grid mode.

Nudging Clips on Multiple 
Tracks and in Multichannel 
Tracks
When nudging a selection of multiple clips 
within a single track or across multiple tracks, 
that also contains silence, any automation data 
residing within the silence is also nudged.
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Nudging by Next Nudge Value
In addition to nudging by the current Nudge 
value, you can also nudge by the next larger 
value in the Nudge pop-up menu. 

For example, if the Nudge value is set to 1 frame 
and you want to nudge by a larger value, you can 
nudge by the Nudge value of 10 frames.

To nudge forward or back by the next larger Nudge 
value:

1  Enable Commands Keyboard Focus (see “Key-
board Focus” on page 30). 

2  Select the clips or notes you want to nudge.

3  Do one of the following:

• Press Forward Slash (/) to nudge the se-
lected material forward by the next Nudge 
value.

– or –

• Press M to nudge the selection back by the 
next Nudge value.

When Commands Keyboard Focus is not en-
abled, press Start+Forward Slash (/) (Win-
dows) or Control+Forward Slash (/) (Mac) 
to nudge the selected material 
forward by the next Nudge value, and press 
Start+M (Windows) or Control+M (Mac) to 
nudge the selected material back by the next 
Nudge value.
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Nudging a Clip’s Contents
Often a clip’s start point will reside at the cor-
rect location, perhaps at a SMPTE frame or bar-
line, but the material within the clip starts too 
late or early. You can, in effect, nudge a clip’s 
audio waveform or MIDI notes without displac-
ing the clip’s start and end points.

This “sliding” of clip contents is only possible if 
there is material residing outside the clip’s start 
and end points—from the clip having been 
trimmed, or perhaps captured from a larger clip.

To nudge the contents of a clip without changing 
the clip start and end points:

1  Configure the Nudge value (see “Defining the 
Nudge Value” on page 599).

2  With the Time Grabber tool, select the clip 
whose contents you want to nudge.

3  While pressing the Start key (Windows) or 
Control (Mac), press Plus (+) or Minus (–) on 
the numeric keypad to move the material by the 
Nudge value.

Nudging clip contents

Clip contents are slid, moving waveform material 
into and out of the current clip boundaries

before

after



Quantizing Clips to Grid
The Quantize to Grid command adjusts the place-
ment of selected audio and MIDI clips so that 
their start points (or sync points, if present) 
align precisely to the nearest Grid boundary.

To quantize individual MIDI notes or Elastic 
Audio Events, use the Quantize Event Opera-
tions. You can also use the Quantize Event Op-
eration to quantize audio clips (see “Quantize 
Command” on page 910).

To quantize one or more clips:

1  Select the Grid value (see “Defining the Grid 
Value” on page 833).

2  With the Selector or Time Grabber tool, select 
the clip or clips you want to quantize. The clips 
can be on multiple tracks. Only clips that are en-
tirely selected will be quantized.

3  Choose Clip > Quantize to Grid. Clip start times 
(or sync points) are aligned to the nearest 
boundaries for the defined Grid. 

For MIDI clips, only the clips are quantized and 
all MIDI data contained within the clips (such as 
notes) are moved equally, thereby retaining 
their rhythmic relationships. 

For Elastic Audio clips, only the clips are quan-
tized and all Elastic Audio Events contained 
within the clips (such as transient events) are 
moved equally, thereby retaining their rhythmic 
relationships. 

Press Control+0 (Windows) or 
Command+0 (Mac) to Quantize to Grid.
Editing Stereo and 
Multichannel Tracks
Clips on individual channels within stereo and 
multichannel tracks cannot be independently 
selected. All selections for these tracks are time-
based, which means that selections made with 
the Selector or Time Grabber tool extend to each 
and every channel in the track.

When clips in multichannel tracks are edited 
with any of the Trim tools or dragged with the 
Time Grabber tool, material on all channels is 
affected equally as a group.

Split Selected Tracks
To edit a specific channel within a stereo or 
multichannel track without affecting the other 
channels, you can split the track into separate 
mono tracks. Once the edits have been made to 
the separated material, you can then drag or 
copy it back to the original multichannel track.

To split a stereo or multichannel track:

1  Select one or more stereo or multichannel 
tracks (see “Selecting Tracks” on page 223). 

2  Choose Track > Split Into Mono. Clips from the 
channels on the selected tracks are placed on 
new, mono audio tracks.

To quantize individual MIDI notes or Elas-
tic Audio Events, use the Quantize Event 
Operations. You can also use the Quantize 
Event Operation to quantize audio clips. For 
more information see “Quantize Command” 
on page 910).
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Names for the new tracks are based on the 
source track name and channel suffix. For exam-
ple, if a stereo track called “Funkit” is split, two 
new tracks called “Funkit.L” and “Funkit.R” are 
created.

Output and send assignments and volume and 
pan settings are retained in the new tracks. 
Mono equivalents of stereo and multi-mono 
plug-in assignments are assigned in the new 
tracks. However, multichannel plug-in assign-
ments are not assigned in the new tracks.

Dragging Clips to and from 
Stereo and Multichannel Tracks

When dragging clips to or from stereo or 
multichannel tracks, the following rules apply:

 Provided the number of tracks and channels 
are the same for the source and destination, you 
can drag clips between multichannel tracks and 
mono tracks.

 The source and destination for dragged clips 
can be mixed. For example, you can drag clips 
from a 5.0 track (containing five channels) to a 
stereo track and three mono audio tracks.

Dragging a stereo clip to two mono audio tracks
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 When dragging multichannel clips to mono 
tracks, the destination tracks must be 
adjacent.

 When dragging clips from mono tracks to a 
multichannel track, the source tracks need not 
be adjacent.

Multichannel clips can also be dragged from the 
Clip List, to multichannel tracks of the same for-
mat, groups of mono audio tracks, or a combina-
tion of both. 

Conversely, a collection of single, mono clips 
can be dragged from the Clip List to multichan-
nel tracks—provided the dragged number of 
clips matches the number of channels in the des-
tination track.

Clip Gain
Pro Tools provides clip-based gain for quick and 
easy gain matching of clips (formerly called re-
gions in Pro Tools) from different sources in a 
Pro Tools session. Clip-based gain is applied 
pre-mixer (pre-fader and before any plug-in 
processing). This is especially useful when 
working with field recordings and sample li-
braries in post-production sessions.

By adjusting the clip gain for individual clips on 
a single track, you can match their relative gain 
levels so that you do not have to execute com-
plex track volume automation to compensate.

Multiple clips with different (static) Clip Gain settings



The clip gain settings stay with the clip, which 
means you can move, and copy and paste clips 
with their corresponding clip gain settings. Clip 
gain settings can now be imported from AAF 
and OMF sequences exported from Media Com-
poser. Likewise, clip gain settings can be ex-
ported from Pro Tools with AAF sequences (but 
not OMF) to be imported into Media Composer.

All clips have a clip gain of 0 dB by default. Clip 
gain can be adjusted from –144 dB to +36.0 dB.

Static Versus Dynamic Clip Gain

You can have either static or dynamic clip gain 
settings for a single clip. Static clip gain simply 
means that there is a single gain setting for the 
entire clip (see “Simple Clip Gain Adjustment” 
on page 605). Dynamic clip gain means that you 
can have gain settings for a clip that vary over 
time (see “Graphically Editing Clip Gain” on 
page 605).

Clip Gain Info View
When Clip Gain Info view is enabled (View > 

Clip > Clip Gain Info), the Clip Gain Fader icon is 
shown at the beginning of the clip, in the lower 
left corner. If the clip uses static clip gain, the 
static Clip Gain value (–144 dB to +36.0 dB) for 
the clip is displayed to the right of the Clip Gain 
Fader icon. For a clip that has dynamic clip gain 
(using breakpoint gain settings), the Clip Gain 
value is not shown. 
Clip Gain commands (including the Clip Gain 
Fader and its Right-click commands) only apply 
to the single, whole clip with which it is associ-
ated.

To show or hide Clip Gain icon, do one of the 
following:

 Select or deselect View > Clip > Clip Gain Info.

– or –

 Press Control+Shift+“=” (Equal) (Mac) or 
Start+Shift+“=” (Equal) (Windows).

Clip Gain Fader Icon Right-Click Menu

You can Right-click the Clip Gain Fader icon for 
any individual clip to access relevant clip gain 
commands for that clip. 

The Clip Gain Fader icon Right-click menu op-
erates independently of the Clip Gain sub-menu 
that is accessible when Right-clicking on an Edit 
selection. When rendering clip gain settings, the 
resulting clip provides handles for trimming out 
the clip based on the Default Handle Length set-
tings in the Processing Preferences.

Clip Gain icon

Clip Gain Icon Right-click menu
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Bypass Clip Gain

When Bypass Clip Gain is selected in the Right-
click menu, the current clip gain settings are by-
passed and the clip plays back with 0 dB gain ad-
justment.

Clear Clip Gain

Choose Clear Clip Gain in the Right-click menu 
to clear the clip gain settings for the clip.

Render Clip Gain

Choose Render Clip Gain in the Right-click menu 
to render the current clip gain settings for the 
clip. After the clip is rendered with its new gain, 
the clip gain settings are reset to 0 dB.

Show/Hide Clip Gain Line

Select Show/Hide Clip Gain Line in the Right-
click menu to show or hide the Clip Gain Line 
for all clips.

Clip Gain Line
The Clip Gain Line lets you edit the clip gain set-
tings for any given clip using breakpoint edit-
ing, much like with track-based volume automa-
tion. However, unlike track-based volume 
automation, the clip gain settings are always as-
sociated with the clip rather than with the track. 
The Clip Gain Line can be shown or hidden for 
all clips in the Edit window.

Clip Gain Line (with multiple breakpoints)
Pro Tools Reference Guide
To show or hide the Clip Gain Line, do one of the 
following:

 Select or deselect View > Clip > Clip Gain Line.

 Press Control+Shift+“-” (Hyphen) (Mac) or 
Start+Shift+“-” (Hyphen) (Windows).

 Right-click the Clip Gain Fader icon on any 
clip and choose Show Clip Gain Line or Hide Clip 

Gain Line.

 Right-click any clip and choose Clip Gain > 

Show Clip Gain Line or Clip Gain > Hide Clip Gain 

Line.

Clip Gain Line and Crossfades

Clip gain is applied on a clip-by-clip basis. 
When cross-fading between clips, the Clip Gain 
Line for the first clip carries through the fade 
out segment of the crossfade and the Clip Gain 
Line for the second clip carries through the fade 
in segment of the crossfade. Consequently, 
crossfades can display two Clip Gain Lines, one 
for the first clip and one for the second clip.

The Clip Gain Line is only shown when the 
track height is set to Small or larger.

Clip Gain Lines prior to applying a crossfade

Clip Gain Lines after applying a crossfade



Editing Clip Gain
Pro Tools lets you adjust the gain settings for a 
clip using the Clip Gain Fader for quick and easy 
adjustments, or using breakpoint editing on the 
Clip Gain Line for detailed clip gain control. 

Simple Clip Gain Adjustment

You can adjust clip gain using the Clip Gain 
Fader icon for quick and easy clip gain adjust-
ments.

To boost or attenuate the current clip gain settings 
for a single clip:

1  Ensure that the Clip Gain Info option is en-
abled.

2  Click the Clip Gain Fader icon on the clip and 
drag the Clip Gain fader up or down to boost or 
attenuate the clip gain settings for the clip.

If a clip is Edit-locked and you attempt to 
edit clip gain, you are prompted to Cancel 
or Allow the edit.

Clip Gain fader, adjusting static clip gain value
Graphically Editing Clip Gain

You can graphically edit clip gain using break-
points on the Clip Gain Line for individual clips. 
When you drag a clip gain breakpoint up or 
down, the change in the gain setting value is nu-
merically indicated. Dragging a clip gain break-
point to the left or right adjusts its timing. 

Using the Grabber Tool

Using the Grabber tool, you can add, adjust, and 
delete individual clip gain breakpoint settings.

To add a clip gain breakpoint with the Grabber 
tool:

1  Ensure that the Clip Gain Line option is en-
abled.

2  Select the Grabber tool.

Clip Gain fader, adjusting all breakpoint clip gain 
values

Press Command (Mac) or Control (Win-
dows) while adjusting the Clip Gain fader 
for fine control.
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3  Click at any point on the Clip Gain Line for the 
clip to add a breakpoint. The Grabber points and 
displays a Plus sign (“+”).

To adjust a clip gain breakpoint with the Grabber 
tool:

1  Ensure that the Clip Gain Line option is en-
abled.

2  Select the Grabber tool.

3  Click any breakpoint on the Clip Gain Line and 
move it up or down to adjust the gain, or left to 
right to adjust the timing. The gain setting is 
displayed in dB over the selected breakpoint.

To delete a clip gain breakpoint with the Grabber 
tool:

1  Ensure that the Clip Gain Line option is en-
abled.

2  Select the Grabber tool.

Adding a clip gain breakpoint with the Grabber tool

Press Control+Shift+E (Mac) or 
Start+Shift+E (Windows) to add a Clip 
Gain breakpoint at the current Edit loca-
tion.

Adjusting a clip gain breakpoint with the Grabber tool
Pro Tools Reference Guide
3  Option-click (Mac) or Alt-click (Windows) the 
breakpoint you want to delete. The Grabber 
points and displays a Minus sign (“–”).

Using the Pencil Tool

The Pencil tool lets you create new breakpoints 
by clicking once on the graph line. Pro Tools lets 
you use the Free Hand, Line, Triangle, Square, 
and Random Pencil Tool shapes for drawing clip 
gain. The Parabolic and S-Curve Pencil Tool 
shapes are not available for editing clip gain.

When drawing clip gain settings with the Pencil 
tool, its effect is bounded by the Edit selection if 
the pencil gesture crosses into the selection. 
However, if the pencil gesture is entirely outside 
of a selection, it creates clip gain breakpoints 
outside of the selection. 

Deleting a clip gain breakpoint with the Grabber tool

Using the Pencil tool (Free Hand) to draw clip gain 
settings

Using the Pencil tool (Free Hand) to draw clip gain 
settings bound by the Edit selection



To add clip gain breakpoints with the Pencil tool:

1  Ensure that the Clip Gain Line option is en-
abled.

2  Select the Pencil tool.

3  Do one of the following:

• Click once on the Clip Gain Line to add a 
single breakpoint.

– or –

• Click and drag on the Clip Gain Line to 
draw breakpoints.

To delete a clip gain breakpoint with the Pencil 
tool:

1  Ensure that the Clip Gain Line option is en-
abled.

2  Select the Pencil tool.

3  Option-click (Mac) or Alt-click (Windows) the 
breakpoint you want to delete. 

Using the Trim Tools

The Trim tools let you adjust all selected break-
points up or down by dragging anywhere within 
that selection. Unlike track-based Volume auto-
mation, which scales when trimming, clip gain 
provides true trimming (where clip gain settings 
maintain their fixed relations to one another 
when trimming).

To trim the selected clip gain settings up or down:

1  Ensure that the Clip Gain Line option is en-
abled.

Using the Trim tool to boost or attenuate clip gain 
breakpoints
2  Make an Edit selection that includes the clip 
gain settings that you want to adjust. 

3  Select the Trim tool.

4  Click and drag up or down over the Clip Gain 
Line within the Edit selection.

Nudging Clip Gain

Pro Tools lets you nudge the selected clip gain 
settings up or down by the Nudge Clip Gain By 

amount specified in the Pro Tools Editing Pref-
erences. You can also nudge the selected clip 
gain settings back or forward in the clip by the 
specified nudge amount.

To set the Nudge Clip Gain By amount:

1  Choose Setup > Preferences.

2  Click the Editing tab.

3  Enter the desired value for the Nudge Clip Gain 

By setting.

4  Click OK.

To nudge the selected clip gain up:

 Press Control+Shift+Up Arrow (Mac) or 
Start+Shift+Up Arrow (Windows).

To nudge the selected clip gain down:

 Press Control+Shift+Down Arrow (Mac) or 
Start+Shift+Down Arrow (Windows).

You can also nudge Clip Gain up or down 
with EUCON. See the Artist Series and 
Pro Tools guide for more info. 

If you have a mouse with a scroll wheel, you 
can use the scroll wheel to nudge the se-
lected clip gain settings up or down. Press 
Control+Shift (Mac) or Start+Shift (Win-
dows) and scroll the scroll wheel up or 
down.
Chapter 28: Editing Clips and Selections 607



608
To nudge the selected clip gain back, do one of the 
following:

 Press Control+Shift+“–” (Minus) (Mac) or 
Start+Shift+“–” (Minus) (Windows).

 Press Control+Shift+M (Mac) or 
Start+Shift+M (Windows).

 Press Control+Shift+“,” (Comma) (Mac) or 
Start+Shift+“,” (Comma) (Windows).

To nudge the selected clip gain forward, do one of 
the following:

 Press Control+Shift+“+” (Plus) (Mac) or 
Start+Shift+“+” (Plus) (Windows).

 Press Control+Shift+“.” (Period) (Mac) or 
Start+Shift+“.” (Period) (Windows).

 Press Control+Shift+“/” (Slash) (Mac) or 
Start+Shift+“/” (Slash) (Windows).

Clearing Clip Gain

Pro Tools lets you clear the clip gain settings for 
the current Edit selection. This resets the clip 
gain for the selection to 0 dB. For clips only par-
tially included in the Edit selection, only the clip 
gain settings within the Edit selection are af-
fected.

To clear clip gain, do one of the following:

 Right-click a clip or Edit selection and choose 
Clip Gain > Clear Clip Gain.

 Right-click the Clip Gain Fader icon for a sin-
gle clip and choose Clear Clip Gain.

 Select a clip or make an Edit selection and 
choose Edit > Clip Special > Clear Clip Gain.

 Select a clip or make an Edit selection and 
press Control+Shift+B (Mac) or Start+Shift+B 
(Windows).

 Press Option (Mac) or Alt (Windows) and 
click Clip Gain Fader icon for a single clip.
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Cutting, Copying, and Pasting Clip Gain

Pro Tools lets you cut, copy, and paste clip gain 
settings, so that you can apply the clip gain set-
tings from one clip to any other. Clip gain set-
tings cannot be cut, copied, or pasted across clip 
boundaries.

To cut clip gain settings:

1  Select a single whole clip or make an Edit se-
lection within a single whole clip.

2  Do one of the following:

• Choose Edit > Cut Special > Cut Clip Gain.

– or –

• Press Control+Shift+X (Mac) or 
Start+Shift+X (Windows).

The selected clip gain settings are cut and copied 
to the clipboard. Clip gain breakpoints on the 
clipboard are time-stamped with the playback 
times in the timebase of the track being copied 
(which means you can cut and paste clip gain 
settings from clips on tick-based tracks and have 
the pasted clip gain settings match the corre-
sponding bar:beat locations of clips on other 
tick-based tracks).

To copy clip gain settings:

1  Select a single whole clip or make an Edit se-
lection within a single whole clip.

2  Do one of the following:

• Choose Edit > Copy Special > Copy Clip 

Gain.

• Press Control+Shift+C (Mac) or 
Start+Shift+C (Windows).

• Right-click any single whole clip selection 
and choose Clip Gain > Copy Clip Gain.

You can cut clip gain settings from any Edit 
selection. However, if you want to cut and 
paste clip gain settings, you can only paste 
the clip gain settings cut from a single clip.



The selected clip gain settings are copied to the 
clipboard. Clip gain breakpoints on the clip-
board are time-stamped with the playback times 
in the timebase of the track being copied (which 
means you can copy and paste clip gain settings 
from clips on tick-based tracks and have the 
pasted clip gain settings match the correspond-
ing bar:beat locations of clips on other tick-
based tracks).

To paste clip gain settings:

1  Cut or Copy the clip gain settings you want.

2  Do one of the following:

• Select another clip.

• Make an Edit selection within a single 
whole clip.

• Place the Edit In Point where you want the 
cut or copied clip gain settings to be pasted.

3  Do one of the following:

• Choose Edit > Paste Clip Gain.

– or –

• Press Command+V (Mac) or Control+V 
(Windows).

The clip gain settings on the clipboard are 
pasted into the clip starting at the Edit In Point. 
The clip gain settings are pasted in their en-
tirety, but only apply to a single clip. If the 
pasted clip gain settings extend beyond the end 
of the clip, they are all still associated with the 
clip. This means that if you trim out the clip 
later, the pasted clip gain is revealed. When 
pasting clip gain within a clip (rather than to a 
single whole clip of the same duration), break-
points are added before and after the pasted data 
so that any clip gain settings outside the paste 
do not change.
Converting Clip Gain and Track 
Volume Automation
(Pro Tools HD or Pro Tools with Complete 
Production Toolkit Only)

Pro Tools lets you convert clip gain settings to 
track-based volume automation, as well as let-
ting you convert track-based volume automa-
tion to clip gain settings. 

When converting clip gain settings to volume 
automation, the clip gain settings are cut from 
the clip and pasted to track-based volume auto-
mation at the same timeline locations as the 
clip. 

When converting track-based volume automa-
tion to clip gain, the volume automation is cut 
from the track volume automation playlist and 
pasted to the clip. Once volume automation has 
been converted to clip gain, the clip gain set-
tings stay with the clip when moved, cut, copied, 
or pasted.

To convert clip gain settings to track-based 
volume automation:

1  Select a clip or make an Edit selection.

2  Choose Edit > Automation > Convert Clip Gain to 

Volume Automation.

To convert track-based volume automation to clip 
gain:

1  Select a clip or make an Edit selection.

2  Choose Edit > Automation > Convert Volume to 

Clip Gain.

Any clip gain settings above +12 dB are lost 
when converted to volume automation. Also, 
clip gain settings within crossfades are cross-
faded as part of the volume automation.
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Coalescing Clip Gain and Track 
Volume Automation
(Pro Tools HD or Pro Tools with Complete 
Production Toolkit Only)

Pro Tools lets you coalesce clip gain settings to 
track-based volume automation, as well as let-
ting you coalesce track-based volume automa-
tion to clip gain settings. 

When coalescing clip gain settings to volume au-
tomation, the clip gain settings are cut from the 
clip and coalesced with track-based volume au-
tomation at the same timeline locations as the 
clip. 

When coalescing track-based volume automa-
tion to clip gain, the volume automation is cut 
from the track volume automation playlist and 
coalesced with the selected clip gain settings. 
Once volume automation has been coalesced to 
clip gain, volume automation is set to 0 dB for 
the selection.

To coalesce clip gain settings to track-based 
volume automation:

1  Select a clip or make an Edit selection.

2  Choose Edit > Automation > Coalesce Clip Gain 

to Volume Automation.

To coalesce track-based volume automation to 
clip gain settings:

1  Select a clip or make an Edit selection.

2  Choose Edit > Automation > Coalesce Volume to 

Clip Gain.

Any clip gain settings above +12 dB are lost 
when it is coalesced to volume automation. 
Also, clip gain within crossfades is cross-
faded as part of the volume automation.
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Bypassing Clip Gain
Pro Tools lets you bypass the current clip gain 
settings for any selected whole clip. This means 
that you can hear the clip without any clip gain 
adjustments without losing your current clip 
gain settings. 

To bypass (or unbypass) clip gain for a clip, do one 
of the following:

 Select one or more whole clips and choose Clip 

> Clip Gain > Bypass Clip Gain (or choose Clip > 

Clip Gain > Unbypass Clip Gain).

 Right-click the Clip Gain Fader icon for a clip 
and select (or deselect) Bypass.

 Right-click a clip or an Edit selection and 
choose Clip Gain > Bypass Clip Gain (or choose 
Clip Gain > Unbypass Clip Gain).

The clip gain settings for any whole clips within 
the Edit selection are bypassed (or unbypassed).

Rendering Clip Gain
Pro Tools lets you render the current clip gain 
settings for any selected whole clip. Rendering 
clip gain applies the current clip gain settings to 
a new clip and sets the clip gain settings for the 
new clip to 0 dB.

To render clip gain for a clip, do one of the 
following:

 Select one or more whole clips and choose 
Clip > Clip Gain > Render Clip Gain.

 Right-click the Clip Gain Fader icon for a clip 
and choose Render Clip Gain.

 Right-click a clip or an Edit selection and 
choose Clip Gain > Render Clip Gain.



Clip gain for any whole clips within the Edit se-
lection is rendered and their clip gain settings 
are reset to 0 dB.

Consolidating Clips
During the course of normal edit operations, 
any track can accumulate many clips. However, 
once a track or track range (such as a verse or 
chorus) reaches a satisfactory state, you may 
want to consolidate multiple clips into a single 
clip.

When consolidating an entire audio track or just 
an Edit selection, a new audio file is written that 
consists of the entire selection, including any 
blank space. 

For clips with any clip gain settings other 
than 0 dB, the Prepare DPE Tracks com-
mand (for DestructivePunch) automatically 
renders all clip gain settings and resets all 
clip gain settings to 0 dB.

When processing in an AudioSuite mode 
that renders in clip gain, any clip gain set-
tings are rendered first, and then Audio-
Suite processing is applied. Clip gain is reset 
to 0 dB for the resultant clip. However, 
when creating individual files with Audio-
Suite, or overwriting files clip-by-clip, clip 
gain settings are preserved. For more infor-
mation, see “Conditions for AudioSuite 
Rendering with Handles, Fades, Clip Gain, 
and Metadata” on page 875.
When consolidating, muted clips are treated as 
silence. Otherwise, whether or not a track is 
muted, or contains Mute automation, does not 
affect the Consolidate command.

To consolidate clips within a track:

1  Do one of the following:

• Using the Time Grabber or Selector tool, se-
lect the clips you want to consolidate. 

– or –

• To select all clips in a track, triple-click in 
its playlist with the Selector tool.

2  Choose Edit > Consolidate.

Compacting an Audio File
The Compact command deletes unused portions 
of audio files to conserve disk space, and to pre-
pare for cleaner hard drive back-ups. The Com-

pact Selected command also deletes any audio 
files for which there are no clips on tracks refer-
encing those files.

Because it permanently deletes audio data, the 
Compact command should be used only after 
you have completely finished your editing and 
are sure that you have no further use for the un-
used audio data.

Consolidating an audio track does not 
consolidate underlying automation data. 
To create a single file with automation data 
applied to the audio, use Bounce to Disk 
(see “Bounce to Disk” on page 1084).

Press Alt+Shift+3 (Windows) or 
Option+Shift+3 (Mac) to Consolidate.
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The Compact command can pad the clips of the 
compacted file by a selectable amount. If clips in 
your session use crossfades, or if you want to 
pad the clips for the sake of any future trim-
ming, you should enter an appropriate amount 
of padding (in milliseconds).

To compact an audio file:

1  In the Clip List, select the clip or clips you 
want to compact.

2  From the Clip List menu, choose Compact.

3  Enter the amount of padding in milliseconds 
that you want for each clip in the file.

4  Click Compact to compact the file or Cancel to 
cancel the command. 

Once the Compact command has been com-
pleted, the session is saved automatically.

Processing Audio with 
AudioSuite Plug-Ins
The AudioSuite plug-ins included with your 
Pro Tools system can be used to process and 
modify audio clips or even entire audio files. Do 
this in order to apply a specific AudioSuite pro-
cess (such as Normalization or DC Offset Re-
moval) to any number of audio clips in your ses-
sion.

The Compact command is destructive and 
cannot be undone. It permanently alters the 
original audio files. There is no way to 
recover data deleted by this command.

For more information about AudioSuite 
plug-ins, see Chapter 40, “AudioSuite Pro-
cessing.”
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TCE (Time Compression and 
Expansion) Edit To Timeline 
Selection
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

When the Edit and Timeline selections are un-
linked, you can compress or expand an audio se-
lection to fit the Timeline selection. On audio 
tracks, TCE Edit to Timeline Selection uses the 
TCE AudioSuite Plug-In selected in the Process-
ing preferences (see “Processing Preferences” on 
page 134). On Elastic Audio-enabled tracks, TCE 

Edit To Timeline Selection uses the track’s se-
lected Elastic Audio plug-in (see “Elastic Audio 
Plug-Ins” on page 888).

To fit an Edit selection to the Timeline:

1  Deselect Options > Link Timeline and Edit Selec-

tion.

2  With the Selector tool, select the audio mate-
rial to be compressed or expanded.

3  In any Timebase ruler, select the time range 
where you want to fit the audio material.

4  Choose Edit > TCE Edit to Timeline Selection. 
The Edit selection is compressed or expanded to 
the length of the Timeline selection.

TCE Edit to Timeline Selection 
on Multiple Tracks and Channels
The TCE Edit to Timeline command can be used 
on multichannel selections, and selections 
across multiple tracks. All clips are compressed 
or expanded equally by the same percentage 
value, based on Edit selection range. This en-
sures that the rhythmic relationship 
between the different channels or tracks is 
maintained.



Fitting an Audio Clip to an Edit 
Selection
Clips can be dragged from the Clip List to fit 
within an Edit selection. The dragged clip is 
compressed or expanded to fit within the selec-
tion. On audio tracks, fitting an audio clip to the 
Edit selection uses the TCE AudioSuite Plug-In 
selected in the Processing preferences (see “Pro-
cessing Preferences” on page 134). On Elastic Au-
dio-enabled tracks, it uses the track’s selected 
Elastic Audio plug-in (see “Elastic Audio Plug-
Ins” on page 888).

To fit an audio clip to an Edit selection:

1  With the Selector tool, make an Edit selection 
in an audio track.

2  Control-Alt-drag (Windows) or Command-
Option-drag (Mac) the clip from the Clip List to 
the track with the selection. The start of the clip 
is positioned at the selection start, and the clip is 
compressed or expanded to match the length of 
the selection.

Fit to Selection on Multiple 
Tracks and Channels
The Fit to Selection command supports dragging 
multiple clips from the Clip List to multiple 
tracks, or multichannel tracks.

However, all dragged clips are compressed or 
expanded equally by the same percentage value, 
based on length of the clip last clicked before 
dragging.
Rating Clips
You can rate different clips on a scale of 1 to 5, 
where 5 is the highest (or best) and 1 is the low-
est (or worst). Clip rating is useful for identify-
ing which takes (clips) you like the most when 
compositing playlists. You can display or hide 
the clip rating in clips to facilitate track compos-
iting or regular editing. You can also show or 
hide Playlist lanes based on the ratings of clips 
in the playlist (see “Filtering Lanes” on 
page 644).

To rate a clip:

1  Select the clip.

2  Do one of the following:

• Choose Clip > Rating, and select a ranking of 
1 to 5. 

– or –

• Right-click the clip, choose Rate, and select 
a ranking of 1 to 5. 

To display ratings in clips:

 Select View > Clip > Rating.

To hide ratings in clips:

 Deselect View > Clip > Rating.

You can rate selected clips during playback 
by pressing Control+Alt+Start (Windows) 
or Command+Option+Control (Mac) and 
then typing the rating number (1–5) on the 
numeric keypad.

Clip with Rating shown
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Chapter 29: Fades and Crossfades
Pro Tools calculates fades and crossfades in 
RAM in real-time. You can quickly and easily 
apply a fade-in or fade-out on a audio clip, as 
well as apply crossfades between adjacent audio 
clips. Crossfading is the process of fading be-
tween two clips of audio to prevent pops, clicks, 
or sudden changes in sound. Crossfades have 
many applications, from smoothing transitions 
between clips to creating special audio effects. 
The crossfade duration, position, and shape are 
all user-definable. 

About Crossfades and Curves
To create a crossfade between two clips, use the 
Selector tool to select across the end point of the 
first clip and the start point of the second. The 
length of the selection determines the length of 
the crossfade. Though fades may appear to be 
discrete clips, they cannot actually be separated 
from the clips in which they were created. You 
can, however, create fade-ins and fade-outs for 
individual clips (see “Creating Fades at the Be-
ginnings and Ends of Clips” on page 623).

Use the Fades dialog to select, view, and manip-
ulate the curves used to perform fades and 
crossfades. Different volume curves can be as-
signed to the fade-out and fade-in portions of 
crossfades. The Fades dialog can also be used to 
audition a fade or crossfade before applying it.
The type of selection you make determines the 
character of the crossfade.

Standard Crossfade (Centered)

This type of selection creates a crossfade on both 
sides of the splice point, which affects the vol-
ume of clip 1 and clip 2. It is the most common 
type of crossfade.

This crossfade type requires that clip 1 contain 
audio material beyond its end point, and clip 2 
contain audio material before its start point.

 Since crossfades are created by fading 
between overlapping audio material, a 
crossfade cannot be performed on clips 
that do not contain audio material 
beyond their clip boundaries.

If a clip references insufficient data to exe-
cute a selected fade or crossfade, you are 
prompted to either skip those fades or to ad-
just the bounds of the selection to be able to 
execute those fades.

Centered crossfade

splice
point fade-in curvefade-out curve

crossfade selection

clip 2clip 1
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Pre Crossfade

This type of selection creates a crossfade before 
the splice point. This lets you maintain the vol-
ume of the very beginning of clip 2 instead of 
fading across it, which is useful if there is a 
strong attack at the beginning of clip 2 that you 
want to preserve. When making selections for 
crossfades that occur on the border of two clips, 
you can use the Tab key to move the cursor to 
the exact beginning or end of a clip.

This crossfade type requires that clip 2 contain 
audio material before its start point.

Post Crossfade

Pre crossfade

Post crossfade

crossfade selection

clip 2clip 1

splice
point

crossfade selection

clip 2clip 1

splice
point

crossfade selection

clip 2clip 1

splice
point
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This type of selection creates a crossfade after 
the splice point. It is useful if you want to main-
tain the amplitude of clip 1 until its very end. 
When making selections for crossfades that oc-
cur on the border of two clips, you can use the 
Tab key to move the cursor to the exact begin-
ning or end of a clip.

This crossfade type requires that clip 1 contain 
audio material beyond its end point.

Overlapping Crossfades View
Pro Tools lets you view overlapping waveforms 
in crossfades. 

To show (or hide) overlapping crossfades:

 Select (or deselect) View > Waveform > Over-

lapping Crossfades.

Fades Dialog
When choosing the Edit > Fades command you 
can use the Fades dialog to select, view, and pre-
view fades and crossfades, and to edit the curves 
used to perform fades and crossfades. A fade-in 
shows the In Shape settings, but not the Out 
Shape settings, and likewise a fade-out shows 
the Out Shape settings, but not the In Shape set-
tings.

Overlapping Crossfades view



The controls in the Fades dialog include:

Audition 

Fades dialog, fade-out

Fades dialog, crossfade
Click this button to audition fades. Pro Tools 
supports fade auditioning directly from your au-
dio interface outputs.

View First Track (Crossfades Only) 

If you are cross-fading between more than one 
track, this button allows you to view and pre-
view the audio of the first in a pair of adjacent 
tracks.

View Second Track (Crossfades Only) 

If you are cross-fading between more than one 
track this button allows you to view and preview 
the audio of the second in a pair of adjacent 
tracks.

View Both Tracks (Crossfades Only) 

Click this button to display the waveforms of the 
first two adjacent tracks in a multitrack cross-
fade. 

Fade Curves Only 

Click this button to display the specified fade 
curves without showing the actual audio wave-
forms. This is the default view when you open 
the Fades dialog.
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Fade Curves and Separate Waveforms 

Click this button to display the specified fade 
curves along with separate views of the fade-in 
and fade-out waveforms.

Fade Curves and Superimposed Waveforms 

Click this button to display the specified fade 
curves along with superimposed views of the 
fade-in and fade-out waveforms. 

Fade Curves and Summed Waveform 

Click this button to display the specified fade 
curves along with a single waveform represent-
ing the summation of the any crossfaded audio.

Zoom In 

Click this button to scale the view of the wave-
form’s amplitude upwards. Control-click (Win-
dows) or Command-click (Mac) for the default 
view scale.
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Zoom Out 

Click this button to scale the view of the wave-
form’s amplitude downwards. Control-click 
(Windows) or Command-click (Mac) for the de-
fault view scale.

Fade-Out Shape Settings
The Out Shape setting lets you define the shape 
of the fade-out from a clip for a fade, or from 
clip 1 for a crossfade. 

Standard Selects a single continuous fade curve. 
This creates a general-purpose fade that can be 
edited by dragging the curve itself.

S-Curve Selects an S-shaped curve, which in-
verts its beginning and end characteristics. This 
makes it possible to fade out faster at the curve’s 
start and slower at its end, for example. S-
shaped curves can be useful with material that is 
difficult to crossfade effectively. S-curves can be 
edited by dragging the curve in the curve editor.

Preset Curves Seven commonly used preset 
curves are provided for fast crossfade creation. 
These can be edited by dragging the end points 
of the curve in the curve editor portion of this 
dialog. The seven presets are as follows:

Fade-in Shape



 Preset Curve 1 stays at full volume throughout 
the fade, then immediately drops the volume at 
the end of the fade.

 Preset Curve 2 fades out relatively slowly, 
keeping the volume fairly high throughout the 
duration of the fade.

 Preset Curve 3 fades out slightly faster, keep-
ing the volume slightly lower during the fade.

 Preset Curve 4 fades out with a linear fade. 
This is the default curve.

 Preset Curve 5 fades out quickly at the begin-
ning of the crossfade.

Preset Curve 1

Preset Curve 2

Preset Curve 3

Preset Curve 4

Preset Curve 5
 Preset Curve 6 drops the volume even more 
quickly at the beginning of the fade.

 Preset Curve 7 silences any audio at the begin-
ning of the fade.

Link Settings
(Crossfades Only)

The Link setting links the selected fade-out and 
fade-in curves of a crossfade. If you adjust one 
curve, the corresponding curve is also adjusted. 
This ensures that the resulting crossfade is an 
equal power or equal gain crossfade, depending 
on which one you select.

Equal Power Recommended for material that is 
not phase coherent, as in the case of a crossfade 
between two completely different types of mate-
rial. Use this option to avoid the volume drop 
that can occur with an Equal Gain crossfade. 
With this fade, you can Alt-click (Windows) or 
Option-click (Mac) the fade curve to reset it to 
its default shape.

Preset Curve 6

Preset Curve 7

Fade Link
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Equal Gain Recommended for material that is 
phase-coherent or nearly phase-coherent, as in 
the case of a crossfade between identical 
clips/instruments (for example, a repeated 
drum loop). Use this option to avoid clipping 
that can occur when using an Equal Power cross-
fade. With this fade, you can Alt-click (Win-
dows) or Option-click (Mac) the fade curve to 
reset it to its default shape.

None Disables linking between the fade-out and 
fade-in curves, and lets you freely adjust them 
separately, including start and end points. This 
option also allows you to create custom cross-
fade shapes. 

When Link is set to Equal Power or Equal Gain, 
you can edit only the fade-in portion of the 
curve, by pressing Alt (Windows) or Option 
(Mac) while dragging. To edit only the fade-out 
portion of the curve, press Control (Windows) 
or Command (Mac) while dragging.

Slope Settings
(Fade-In or Fade-Out Only)

Adjusting the end point of a fade curve

Fade Link
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The Slope settings affect the slope of the fade-in 
or fade-out. Select either Equal Power or Equal 

Gain. For more information on Equal Power and 
Equal Gain fades, see “Link Settings” on 
page 619.

Use Dither

The Use Dither option turns on a preset, noise-
shaped dither function that improves audio per-
formance when fading in or fading out of si-
lence, and crossfading between low amplitude 
clips. Dithering is usually not necessary when 
applying fades to clips with audio at high ampli-
tudes. You can disable Dither while editing 
fades in the Fades dialog to speed up previews 
and fade recalculation, then re-enable Dither to 
create the final fade or crossfade.

Fade-In Shape Settings
The In Shape setting lets you define the shape of 
the fade-in to a clip for a fade, or to clip 2 for a 
crossfade. 

Standard Selects a single continuous fade curve. 
This creates a general-purpose fade that can be 
edited by dragging the curve itself.

S-Curve Selects an S-shaped curve, which in-
verts its beginning and end characteristics. This 
makes it possible to fade in faster at the start of 
the curve, and slower at the end. S-shaped 
curves are useful with material that is difficult 
to fade effectively. S-curves can be edited by 
dragging the curve in the curve editor.

Dither option for Fades



Preset Curves Seven commonly used preset 
curves are provided for fast creation. These can 
be edited by dragging the end points of the curve 
in the curve editor portion of this dialog. The 
seven presets are as follows:

 Preset Curve 1 fades in at full volume immedi-
ately at the beginning of the fade and keeps it 
there throughout the fade.

 Preset Curve 2 fades in quickly in the begin-
ning, reaching full amplitude fairly early in the 
fade.

 Preset Curve 3 fades in moderately fast.

 Preset Curve 4 fades in with a linear fade 
curve. This is the default curve.

Preset Curve 1

Preset Curve 2

Preset Curve 3

Preset Curve 4
 Preset Curve 5 fades in slowly at the beginning 
of the fade.

 Preset Curve 6 fades in even more slowly than 
the previous curve.

 Preset Curve 7 silences any audio until the end 
of the fade.

Typical Curve Combinations
Following are the available combinations of 
fade-out and fade-in curves.

Linear Crossfade This is a good general purpose 
crossfade with a smooth, even transition be-
tween clip 1 and clip 2.

Preset Curve 5

Preset Curve 6

Preset Curve 7

Linear Crossfade

1. Out 2. In
Chapter 29: Fades and Crossfades 621



622
Equal Power Crossfade This is a good general 
purpose crossfade useful in cases where a linear 
crossfade seems to create a noticeable drop in 
volume across the splice point.

Overlap Fade This combination of curves keeps 
both clips at full amplitude throughout the 
crossfade: clip 2 “jumps in” at the beginning and 
clip 1 “jumps out” at the end.

Fade and Crossfade Preferences
You can set default fade and crossfade settings. 
These settings load as your “base” settings when 
you use the Create Fades command, and the 
Fade to Start and Fade to End commands.

To set the fade and crossfade preferences:

1  Choose Setup > Preferences and click the 
Editing tab.

Equal Power Crossfade

Overlap Crossfade

1. Out 2. In

1. Out 2. In
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2  Set the Pre-Roll and Post-Roll times for Fade 
previews.

3  Click Fade In and set the default shape for 
fade-ins when using the Smart Tool, then click 
OK.

4  Click Fade Out and set the default shape for 
fade-outs when using the Smart Tool, then click 
OK.

5  Click Crossfade and set the default shape for 
crossfades when using the Smart Tool, then click 
OK.

6  Click OK.

Fade preferences

To apply the default fade or crossfade 
shape, make an Edit selection and press 
Control+Start+F (Windows) or 
Command+Control+F (Mac).



Creating Fades at the 
Beginnings and Ends of Clips
Pro Tools lets you create fade-ins and fade-outs 
at the beginnings and ends of clips. 

With Pro Tools HD, you can also use an auto-
matic fade-in/out option, which applies real 
time fade-ins/outs to all clips during playback 
automatically. For more information, see “Us-
ing AutoFades” on page 626.

Creating Fade-Ins and Fade-
Outs
Depending on how you make the selection, you 
can position a fade-in or fade-out at the exact 
beginning or end of a clip, or position it so it ex-
tends into a blank area of the track. The length 
of the selection in the clip determines the length 
of the fade-in or fade-out.

You can also fade to the beginning or end of a 
clip from an insertion point.

Although fades appear to be discrete clips, they 
cannot be separated from the clips in which they 
were created. 

When changing tempo in a tick-based audio 
track, fade-ins and fade-outs remain with their 
parent clips. Fades maintain their absolute du-
ration and are consequently recalculated after 
any tempo changes.

Clip with a fade-in
To create a fade-in:

1  Select the beginning of the clip that you want 
to fade in. The selection must extend to the exact 
beginning of the clip or a blank area prior to the 
clip in the track.

2  Do one of the following:

• Choose Edit > Fades > Create. 

– or –

• Press Control+F (Windows) or 
Command+F (Mac).

3  Select the fade-in curve and configure the 
other Fade settings.

4  Click the Audition button to audition the fade.

5  Adjust the curve by dragging it or by selecting 
a different shape from the In Shape pop-up 
menu.

6  Click OK. 

The selected fade curve appears in the clip.

Selecting the beginning of a clip for a fade-in

To apply a Fade In using the Default Fade 
In setting (in the Editing Preferences page), 
and without opening the Fades dialog, press 
Control+Start+F (Windows) or 
Command+Control+F (Mac).
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To create a fade-out:

1  Select the end of the clip that you want to fade 
out. The selection must extend to the exact end 
of the clip or a blank area after the clip in the 
track.

2  Do one of the following:

• Choose Edit > Fades > Create. 

– or –

• Press Control+F (Windows) or 
Command+F (Mac).

3  Select the fade-out curve and configure the 
other Fade settings.

4  Click the Audition button to audition the fade.

5  Adjust the curve by dragging it or by selecting 
a different shape from the Out Shape pop-up 
menu.

6  Click OK. 

Pro Tools calculates the fade and the selected 
fade curve appears in the clip.

Selecting the end of a clip for a fade-out

To apply the Fade Out using the Default Fade 
Out setting (in the Editing Preferences page), 
and without opening the Fades dialog, press 
Control+Start+F (Windows) or 
Command+Control+F (Mac).

Fade lengths can be resized with any of the 
Trim tools, including Nudge Trim 
commands. See “Using the Trim Tools” on 
page 553 and “Trimming with Nudge” on 
page 598.
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To fade from the insertion point to a clip start 
point:

1  Place the cursor at a location in the clip.

2  Do one of the following:

• Choose Edit > Fades > Fade To Start.

– or –

• Press Alt+D (Windows) or 
Control+D (Mac).

The fade is applied based on the Fade In prefer-
ences (see “Fade and Crossfade Preferences” on 
page 622).

To fade from the insertion point to a clip end point:

1  Place the cursor at a location in the clip.

2  Do one of the following:

• Choose Edit > Fades > Fade To End.

– or –

• Press Alt+G (Windows) or 
Control+G (Mac).

The fade is applied based on the Fade Out pref-
erences (see “Fade and Crossfade Preferences” 
on page 622).



Creating a Crossfade
To create a crossfade between two clips:

1  With the Selector tool, click at the point where 
you want the crossfade to begin in the first clip 
and drag to where you want it to end in the sec-
ond clip. Crossfade selections can begin and end 
anywhere in their respective clips.

2  Do one of the following:

• Choose Edit > Fades > Create.

– or –

• Press Control+F (Windows) or 
Command+F (Mac).

3  Use the view buttons to adjust the view of the 
crossfade. It may take a few moments to calcu-
late the waveform display for long selections.

4  Select an Out Shape and an In Shape.

5  Select a Linking option.

6  Click the Audition button to audition the 
crossfade. For long crossfades, it may take 
Pro Tools a few moments to calculate and load 
the audio into playback RAM. 

7  Do one of the following:

• Adjust the curves by selecting different pre-
set shapes with the Out Shape and In Shape 
pop-up menus.

– or –

• Drag the Fade-In and Fade-Out curves to a 
custom shape. By choosing None as the 
Linking option, you can drag the beginning 
or end points of a fade curve to adjust its 
beginning or end point.

To apply a Crossfade using the Default 
Crossfade setting (in the Editing Prefer-
ences), and without opening the Fades di-
alog, press Control+Start+F (Windows) or 
Command+Control+F (Mac).
8  Click the Audition button to audition the 
crossfade again.

9  When the crossfade sounds right, click OK. 

To remove a crossfade, do one of the following:

 Select the area of the track containing any 
crossfades you want to delete and choose Edit > 

Fades > Delete. 

 Select the crossfade with the Time Grabber 
tool and press Backspace (Windows) or Delete 
(Mac). 

 Right-click the crossfade with any of the edit 
tools and select Delete Fades from the pop-up 
menu. 

To trim a crossfade:

1  Select the crossfade with the Time Grabber 
tool, or double-click it with the Selector tool.

2  With any of the Trim tools, trim either side of 
the crossfade. The crossfade is recalculated to 
reflect the newly trimmed length.

Crossfades on Tick-Based Audio 
Tracks
Crossfades are re-rendered after changing 
tempo in a tick-based audio track. The new 
crossfade is the same duration as the crossfade 
prior to the tempo change. 

If there is not enough audio material to com-
plete the crossfade, or if the new crossfade area 
falls outside of valid clip boundaries, the cross-
fade is removed.

Crossfade lengths can be resized with any of 
the Trim tools, including Nudge Trim com-
mands. See “Using the Trim Tools” on 
page 553 and “Trimming with Nudge” on 
page 598.
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Pre and Post Crossfade 
Selections
By making a selection that begins or ends pre-
cisely on the border of two clips, you can create 
“pre” or “post” crossfades. Use the Tab key to 
place the insertion point at the exact beginning 
or end of a clip.

To create a pre- or post-crossfade:

1  With the Selector tool, click in the track that 
contains the clips you want to crossfade.

2  Do one of the following:

• Press Tab to move forward to the next 
clip boundary. 

– or –

• Press Control+Tab (Windows) or 
Option+Tab (Mac) to move back to the 
previous clip boundary.

3  Extend the selection as follows:

• Shift-drag to adjust your selection, or press 
Shift+Tab to extend the selection forward 
to the next clip boundary. 

– or –

• Press Control+Shift+Tab (Windows) or 
Option+Shift+Tab (Mac) to extend the 
selection back to the previous clip bound-
ary.

4  Do one of the following:

• Choose Edit > Fades > Create.

– or –

• Press Control+F (Windows) or 
Command+F (Mac).

5  Select a fade type and click OK.
Pro Tools Reference Guide
Using AutoFades
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools HD and Pro Tools with Complete Pro-
duction Toolkit can automatically apply real-
time fade-ins and fade-outs to all clip boundar-
ies in the session on playback. Specify the dura-
tion (0 to 10 ms) for automatic real-time fades 
with the Auto Clip Fade In/Out Length preference 
in the Operation Preferences page). These fade-
ins and fade-outs are performed during play-
back and do not appear in the Edit window.

The automatic fade-in/out option also has an ef-
fect on Voice borrowing in a session. Whenever 
a lower-priority virtual track “pops thru” a si-
lence in a higher-priority track on the same 
voice, a fade-in and fade-out is applied to the 
transition.

This feature is especially useful in post produc-
tion situations such as dialogue tracking. For 
example, you can assign both a dialogue track 
and a “room tone” track with matching back-
ground to the same voice. You can then set the 
AutoFade option to a moderate length (4 ms or 
so) so that whenever a silence occurs in the dia-
log, playback switches smoothly to and from the 
background track without clicks or pops.

Using automatic fade-ins/outs saves you the 
trouble of editing to zero-crossings or creating 
numerous rendered fades in order to eliminate 
clicks or pops in playback. However, those clicks 
or pops still exist in the underlying sound file. 
Consequently, those anomalies still appear if the 
Duplicate AudioSuite plug-in or the Export Clips 

AutoFades are not applied to AudioSuite 
processing.



As Files command (from the Clip List) are used 
to duplicate multiple clips as a continuous file. 
To render these real-time auto fades to disk, 
choose File > Bounce to > Disk.

To set the length of automatic fade-ins/outs:

1  Choose Setup > Preferences and click the 
Operation tab. 

2  Type a value between 0 and 10 ms for the Clip 

Auto Fade In/Out Length. A value of zero (the de-
fault) means that no auto-fading will occur.

3  Click OK. The AutoFade value is saved with the 
session, and is automatically applied to all free-
standing clip boundaries until you change it.

Creating Fades and 
Crossfades in Batches
Using Batch Fades, you can create many fades at 
once. Select across several clips and use the Cre-
ate Fades command to create crossfades for each 
clip transition. If your selection includes clips 
that already have crossfades, this feature lets 
you modify them.

To apply crossfades between multiple clips:

1  With the Selector tool, click in the first clip in 
which you want to create a crossfade. Make sure 
that the selection includes the entire clip.

2  Drag to extend the selection to include the last 
clip you want to crossfade. Make sure that the se-
lection includes the entire clip.

Selected clips for Batch Fades
3  Do one of the following:

• Choose Edit > Fades > Create.

– or –

• Press Command+F (Mac) or Control+F 
(Windows).

4  In the Batch Fades dialog, select whether you 
want to Create New Fades, Create New Fade-Ins 

& Outs, Adjust Existing Fades, or a combination 
of these options. 

If you choose to create new fades and new fade-
ins and outs, new crossfades are created at each 
clip boundary that is bordered by another se-
lected clip, a fade-in is created at the start of the 
first clip, and a fade-out is created at the end of 
the last clip.

5  Select the placement of the Fades: Pre-Splice, 
Centered, or Post-Splice (see “About Crossfades 
and Curves” on page 615). 

6  Enter a crossfade length in milliseconds.

7  Click OK. 

Batch Fades dialog
Chapter 29: Fades and Crossfades 627



628
Pro Tools creates the fades for all selected clips.

Moving and Nudging Fades 
and Crossfades
Fades and crossfades can be moved or nudged in 
tracks, independently of their contributing 
clips. Moving or nudging fade-ins or fade-outs 
reveals or hides audio as the fade is moved from 
the edge of a contributing clip. Moving or nudg-
ing crossfades changes the overlap point of the 
contributing clips. Moving or nudging fades is 
also constrained by underlying clip boundaries.

Moving or Nudging Fades or 
Crossfades within Clips

To move or nudge a fade or crossfade within its 
contributing clips:

1  Select the fade or crossfade by doing one of the 
following:

• Use the Time Grabber tool to select the 
fade.

– or –

• Use the Selector tool to select a range that 
includes the fade.

Fade lengths can be resized with any of the 
Trim tools, including Nudge Trim com-
mands. See “Using the Trim Tools” on 
page 553 and “Trimming with Nudge” on 
page 598.

Selecting a fade with the Time Grabber
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2  Move the fade by doing one of the following:

• Drag the fade with the Time Grabber tool to 
a new location on the track.

– or –

• Nudge the fade by pressing Plus (+) or 
Minus (–) on the numeric keypad to move 
the fade forward or backward on the track.

Moving Clips Containing Fades 
or Crossfades
When you move or nudge a clip selection that 
contains a fade-in, fade-out, or crossfade, the 
fade moves with the selection.

To move a clip selection with fades or crossfades:

1  Do one of the following:

• Click a clip with the Time Grabber tool (or 
double-click with the Selector tool) to se-
lect the clip along with the fade (in or out).

– or –

• Select multiple clips that include the fades 
and crossfades you want to move. 

Dragging the fade with the Time Grabber

Result of moved fade



2  Move the clip selection by doing one of the fol-
lowing:

• Drag the clip selection with the Grabber 
tool to a new location on the track.

– or –

• Nudge the clip selection by pressing Plus 
(+) or Minus (–) on the numeric keypad to 
move the clip forward or backward on the 
track.

Nudging Clips Adjacent to Fade-
Ins or Fade-Outs
When you nudge a clip selection adjacent to a 
fade-in or fade-out, but do not select the fade, 
the adjacent fade stretches or shrinks to main-
tain the fade start or end point. The amount of 
change depends on the amount of audio material 
outside the fade start or end point.

To a nudge clip without its fade:

1  Select the clip, but not the fade.

2  Nudge the clip by pressing Plus (+) or Minus 
(–) on the numeric keypad.

Dragging a clip with its fade

Selecting a clip without its fade

Nudging a clip without its fade
Moving Clips Adjacent to 
Crossfades
When you move either of the clips that contrib-
utes to a crossfade, the clips separate. The status 
of the fade depends on the Preserve Fades when 
Editing preference (in the Editing Preferences 
page). 

To separate crossfaded clips and retain the 
corresponding fades:

1  Choose Setup > Preferences and click the Edit-

ing tab.

2  Select Preserve Fades when Editing.

3  Click OK to close the Preferences dialog.

4  Use the Time Grabber or Separation Grabber 
tool to select one of the contributing clips to a 
crossfade.

5  Drag the selected clip with the Grabber.

To separate crossfaded clips and remove the fade:

1  Choose Setup > Preferences and click the Edit-

ing tab.

2  Deselect Preserve Fades when Editing.

3  Click OK to close the Preferences dialog.

Selecting a clip with a crossfade

Separating clips while preserving fades
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4  Use the Time Grabber or Separation Grabber 
tool to select one of the contributing clips to a 
crossfade.

5  Drag the selected clip with the Grabber.

Nudging Clips Adjacent to 
Crossfades
When you nudge either of the clips that contrib-
utes to a crossfade, the fade stretches to preserve 
the relative position of the crossfade start and 
end points. The amount of stretch depends on 
the amount of overlap between the contributing 
clips. 

If you nudge a clip beyond the boundary of 
available audio for the crossfade, the fade is re-
moved.

To nudge a clip and stretch its crossfade:

1  Use the Time Grabber tool to select one of the 
contributing clips to the crossfade.

Selecting a clip with a crossfade

Separating clips while removing fades

Selecting a clip with a crossfade
Pro Tools Reference Guide
2  Nudge the clip by pressing Plus (+) or 
Minus (–) on the numeric keypad.

Separating Clips that Include 
Fades or Crossfades
You can create clips from track material that 
overlaps with fades or crossfades. If the Preserve 

Fades when Editing option is enabled in the Ed-
iting Preferences page, the fades from the source 
clip are adjusted to the new clip.

To separate a clip that overlaps with a fade or 
crossfade:

1  With the Selector tool, drag to select the mate-
rial for the new clip.

2  Choose Edit > Separate Clip > At Selection.

Where your selection overlaps any fade-ins or 
fade-outs, the fade is trimmed to fit the selec-
tion.

Stretching the crossfade by nudging

Selecting material that overlaps a fade-in

Result of Separate Clip command on fade-in



Where your selection overlaps a crossfade, the 
crossfade is separated into a fade-out and fade-
in at the selection boundary.

Selecting material that overlaps a crossfade

Result of Separate Clip command on crossfade

If the Preserve Fades when Editing option is 
not enabled in the Editing preferences, any 
fades within the selection are deleted when 
editing.
Trimming Clips that Include 
Fades or Crossfades
You can trim clips that include fades or cross-
fades.

Trimming a Clip to a Fade 
Boundary
You can trim clips that are adjacent to fade and 
crossfade boundaries. 

To trim a clip on a fade boundary:

 With the Trim tool, click the clip boundary 
and drag to trim the clip. The fade remains con-
stant and follows the new clip boundary.

Dragging a clip boundary with the Trim tool 

Result of trimming the clip
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Trimming to a Selection Across 
Fades or Crossfades
You can trim clips to selections that include 
fades or crossfades.

To trim a clip to a selection that includes fades, do 
one of the following:

 Make a selection in the track and choose Edit > 

Trim > To Selection. You can Trim across multiple 
clips and fades. Affected fades are adjusted to 
the new clip boundaries.

– or –

 Click with the Selector in the clip and choose 
Edit > Trim > Start to Insertion or End to Insertion. 
You can trim to clip or fade boundary in the 
track.

Trimming to a selection across multiple fades
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Fade Boundaries and Shapes 
Displayed in Automation 
View
Fade boundaries and fade shapes are shown and 
can be edited in Automation views, allowing for 
more precise viewing and editing of automation 
data. For more information on Automation and 
Automation views, see Chapter 45, “Automa-
tion.”

Fade information in Automation view



Chapter 30: Playlists
The ability to create playlists is a powerful fea-
ture of Pro Tools. Each track maintains a “main” 
playlist and any number of “alternate” edit play-
lists.

Edit playlists let you take a snapshot of a track’s 
current arrangement of clips, thereby freeing 
you to experiment with alternate arrangements, 
returning as necessary to previously saved play-
lists.

A playlist, which can consist of a single clip or 
many clips, can only be assigned to a track if it is 
not in use by another track. While you can create 
an almost unlimited number of edit playlists, 
which are shared among all tracks, each track 
has its own dedicated automation playlist.

Automation playlists for audio, Auxiliary Input, 
Master Fader, and Instrument tracks store data 
for volume, pan, mute, and plug-in controls. Au-
tomation playlists for MIDI tracks, however, 
store only mute information; continuous con-
troller events, program changes, and Sysex 
events are stored in MIDI clips and therefore re-
side within edit playlists for both MIDI and In-
strument tracks (see Chapter 45, “Automation”).
Working with Playlists
When you create a new track, it contains a sin-
gle, empty playlist until you record, import, or 
drag and drop material to it.

New playlists can be created that are empty or 
duplicates of the current playlist. Once created, 
you can recall, rename, and delete playlists as 
needed by using the Playlist selector.

New and duplicated playlists are auto-named 
with the track name, followed by a Period (.) and 
the playlist number. For example, the first du-
plicated playlist on a track named “Kick” is 
auto-named “Kick.01,” subsequent duplicated 
playlists are auto-named “Kick.02,” “Kick.03,” 
and so on.

Audio material can be dragged and dropped 
onto a track from the Clip List, DigiBase 
browsers, from Windows Explorer or the 
Mac Finder.

Playlist selector
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Creating a Playlist
You can create new empty playlists for record-
ing or importing audio and MIDI. This can be 
useful for creating alternate takes of audio or 
MIDI, or for constructing alternate arrange-
ments.

To create a new (empty) playlist:

1  Click the track’s Playlist selector and choose 
New.

2  Type a name for the new playlist and click OK. 

An empty playlist with the specified name ap-
pears in the track.

Duplicating a Playlist
When you edit a track, you can work with a copy 
of the track's playlist and keep the original play-
list arrangement intact.

To duplicate a track’s current playlist:

1  Click the track’s Playlist selector and choose 
Duplicate from the pop-up menu.

2  Type a name for the new playlist and click OK. 

The duplicated playlist appears in the track and 
the track’s name is changed to the name of the 
new playlist.

Press Control+\ (Mac) or Start+\ (Windows) 
to create a new playlist for the first selected 
track in the session.

Press Command+Control+\ (Mac) or 
Control+Start+\ (Windows) to duplicate the 
main playlist for first selected track in the 
session.
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Assigning a Playlist to Another 
Track
By default, a playlist is typically available only 
for the track on which it was created. However, 
if the playlist is no longer in use on its original 
track or any other track, it can be reassigned in 
another track using the Other Playlists feature. 
When a playlist is reassigned to another track 
(assigned on any track), it is unavailable to 
other tracks including the track on which it 
originated.

An audio playlist’s timebase is saved with the 
playlist. When assigning an unassigned playlist 
to any track, the track assumes the saved time-
base of the playlist.

To assign a track playlist:

 Click the track’s Playlist selector and do one of 
the following:

• Select one of the track’s playlists.

– or –

• Select a playlist from a different track by 
clicking the Other Playlists submenu, and 
selecting a playlist.

The selected playlist appears in the track and the 
track’s name is updated to that of the selected 
playlist.

Selecting a playlist from a different track



Renaming a Playlist
You can rename a playlist by renaming the track 
to which it is assigned. 

To rename a track’s assigned playlist:

1  Double-click the track’s name.

2  Type a new name and click OK. 

Both the track and playlist names are updated.

Deleting a Playlist
You can delete a playlist from a session entirely. 
However, since playlists require minimal disk 
space, you do not need to delete them to con-
serve storage.

To delete one or more playlists from a track:

1  Click the track’s Playlist selector and choose 
Delete Unused.

2  Select the unassigned playlists you want to de-
lete. Shift-click (Windows or Mac), Control-
click (Windows), or Command-click (Mac) to se-
lect multiple playlists.

3  Click OK to delete the selected playlists. This 
operation cannot be undone.

You can also delete playlists in Playlists 
view. Right-click the Playlist Name on a 
lane or in the Track List and choose Delete.

When deleting a track from a session, you 
have the option of deleting or keeping its 
playlists, so they can be used on other 
tracks.
Playlists and Edit Groups
Creating new playlists with grouped tracks auto-
matically increments the suffixes of the playlist 
names for each track of the active edit group. 
This lets you revert back to an earlier take by 
switching the playlist takes by group. 

Using this method, you can add new tracks to 
the existing group and the suffixes for their 
playlist names are synchronized with the origi-
nal tracks. 

Empty playlists are created automatically to 
keep the playlist takes synchronized when 
switching back to the earliest playlist takes in 
the group.

To keep your playlist names and performances 
synchronized (example workflow):

1  Create new tracks and group them together.

2  Make sure the group is enabled.

3  Create a new playlist (by clicking the Playlist 
selector in one of the tracks in the group and 
choosing New). The default suffix will now be 
“.01”—signifying take 1.

4  Record take 1, then create a new playlist. The 
playlists on all tracks in the group increment to 
“.02.”

5  Create new tracks (for example, for an addi-
tional musician or microphone), then add these 
tracks to the group (or create a new group with 
all the tracks).

6  Increment all the playlists by clicking the Play-
list selector in one of the tracks in the group and 
choosing New.

For more information on grouping tracks, 
see “Grouping Tracks” on page 255.
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All the playlists will now have the same suffix 
appended to them. (Creating additional playlists 
in any of the group tracks will increment all of 
their playlists to keep them synchronized.)

7  If you want to hear the .01 take on the first 
group of tracks, you can switch any playlist in 
the group back to playlist .01.

All tracks in the group have playlists numbered 
with .01 suffixes (even those tracks that were 
added to the original group after the earlier 
takes). Empty playlists are automatically cre-
ated on these newly-added members so that 
playlist numbers match across all members of 
the group. 

Elastic Audio and Alternate 
Playlists
Alternate playlists on Elastic Audio-enabled, 
tick-based tracks are only affected by tempo 
changes. Otherwise, alternate playlists are not 
affected by editing Warp or Event markers in the 
main playlist.

Track Compositing
Pro Tools provides track compositing tools for 
audio tracks. Track compositing is the process 
of assembling various selections from alternate 
takes, or playlists, to construct the best possible 
version of a performance from multiple record-
ing passes. Using Playlists view for an audio 
track, you can select the best parts from the 
track’s alternate playlists and copy them to the 
main playlist. This lets you quickly and easily 
create the “perfect take” from multiple alternate 
playlists.
Pro Tools Reference Guide
Track Compositing Example
In this workflow, you will be introduced to some 
common track compositing tasks:

• Configure a session for this workflow.

• Loop record multiple takes on an audio 
track.

• Audition and select the best take.

• Copy the best take to the main playlist.

To configure a session:

1  Open an existing Pro Tools session or create a 
new one.

2  Choose Setup > Preferences, and click the 
Operation tab.

3  On the Operation page, in the Record section, 
select the Automatically Create New Playlists 

When Loop Recording option.

4  Click OK.

Enabling the Automatically Create New Playlists 
When Loop Recording option in the Operation 
Preferences



To loop record multiple takes:

1  Create a new audio track (stereo or mono), or 
use an existing track.

2  Make sure the source you want to record is cor-
rectly connected and routed to the track input.

3  From the Track View selector, select Playlists. 

4  To hear track material up to the start point of 
the loop, enable pre-roll and set the pre-roll 
time.

5  Enable Loop Recording by doing one of the fol-
lowing:

• Select Options > Loop Playback.

– or –

• Right-click the Play button in the Transport 
and select Loop.

6  Make sure that Options > Link Timeline and Edit 

Selection is selected.

7  With the Selector tool, select the loop range on 
the track. 

8  Record enable the audio track by clicking its 
Record Enable button.

9  Click Record in the Transport to arm Pro Tools 
for recording.

10  Click Play to start recording.

11  When finished, click Stop to stop recording.

12  If you do not want to make another loop re-
cord pass, record disable the audio track.
After you have stopped loop recording, notice 
that all of the loop recording takes are revealed 
in Playlist lanes below the main playlist (includ-
ing the whole audio file clip of all of the loop re-
cord passes).

Playlists view showing multiple alternate playlists

If the Automatically Create New Playlists 
When Loop Recording option was disabled 
before you started loop recording, Right-
click the clip in the main playlist and choose 
Matches > Expand Alternates to New Play-
lists.
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To hide the playlist for the whole file clip, do one of 
the following:

 Right-click on the Playlist lane and choose 
Hide.

– or –

 With the same Edit selection that you used for 
loop recording intact, Right-click the Track 
Name or any of the Playlist Lane Names and 
choose Filter Lanes > Show Only Lanes With > 

Clips Within the Edit Selection.

To audition alternate playlists:

1  Enable Loop Playback by doing one of the fol-
lowing:

• Select Options > Loop Playback.

– or –

• Right-click the Play button in the Transport 
and select Loop.

2  With the same Timeline selection intact, and 
and the same pre-roll/post-roll settings enabled, 
start playback. The main playlist plays back.

3  Click the Solo button for the alternate playlist 
lane you want to audition. Repeat this step for 
each playlist lane. (Soloing a Playlist lane only 
solos the playlist in the track, it does not mute 
any other tracks in the session.)

Filtering Playlist lanes viewed
Pro Tools Reference Guide
To select and copy the best take to the main 
playlist:

1  Once you have identified the best take, make 
any changes to the Edit selection. This is the se-
lection that will be copied to the main playlist.

2  Do one of the following:

• Choose Edit > Copy Selection To > Main 

Playlist.

• Right-click the selection and choose Copy 

Selection to Main Playlist.

• Click the Copy Selection to Main Playlist 
button for the Playlist lane.

Copying the Edit selection in an alternate playlist to 
the main playlist

Press Alt+Start+V (Windows) or Op-
tion+Control+V (Mac) to copy the selection 
to the main playlist.

Copy Selection to
Main Playlist button



Playlists View
Playlists view lets you view the main playlist in 
the track, and also any alternate playlists associ-
ated with the track. Alternate playlists are dis-
played directly below the track in Playlist lanes.

You can edit alternate playlists in Playlists view 
just like the main playlist in Waveform view. In 
Playlists view, edits that are applied to range se-
lections are applied to all shown alternate play-
lists. Alternate playlists that are not shown are 
not affected.

To view the Playlist lanes for a track:

 From the Track View selector, select Playlists.

\

Before starting work with Track Composit-
ing, duplicate the track’s Main Playlist to 
keep it intact as a backup alternate playlist.

Clip groups are not supported in Playlists 
Track View.

Selecting Playlists Track view

You can also Control-Alt-click (Windows) 
or Command-Control-click (Mac) the Play-
list selector to toggle between Playlists view 
and Waveform view.
If the track does not contain any alternate play-
lists in addition to the main playlist, only a sin-
gle, empty Playlist lane is shown under the main 
playlist. You can drag and drop audio to this 
lane from the Clip List, DigiBase Browsers, or 
other audio tracks to create an alternate playlist 
for the track, in addition to the main playlist.

If the track contains one or more alternate play-
lists in addition to the main playlist, they are 
displayed in lanes under the main playlist. Re-
gardless, the bottom Playlist lane is always 
empty and can be used for adding clips to create 
new alternate playlists.

Dropping audio from Clip List to create an alternate 
playlist

Track with alternate playlists in Playlists Track view
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Auditioning Alternate Playlists
Only the main playlist plays back through the 
track audio output path. To hear an alternate 
playlist, you need to solo the Playlist lane. The 
soloed lane then plays through the track audio 
output path instead of the main playlist.

To audition an alternate playlist:

1  Click the Solo button for the Playlist lane you 
want to audition. (Soloing a Playlist lane only 
solos the playlist in the track, it does not mute 
any other tracks in the session.)

2  Start Pro Tools playback.

Soloing an alternate playlist

Press Shift+S to solo any one Playlist lane 
containing the Edit cursor. If more than one 
Playlist lane contains the Edit cursor, the 
topmost lane is soloed.

Use Start+P and Start+“;” (Windows) or 
Control+P and Control+“;” (Mac) to move 
the Edit cursor up and down through 
Playlist lanes.
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Copying Alternate Playlists to 
the Main Playlist
Once you have found a selection in an alternate 
playlist that you want to use in the main playlist, 
copy and paste the selection to the main playlist. 
In this way you can construct the best combina-
tion of selections from alternate playlists. 

In addition to manually copying and then past-
ing to the main playlist, Pro Tools provides sev-
eral commands for copying and pasting the se-
lection to the main playlist:

Copy Selection To Main Playlist Copies and 
pastes the selection to the main playlist. Any 
material already on the main playlist at the same 
location is overwritten.

Copy Selection to New Playlist Creates a new, 
empty main playlist and copies and pastes the 
selection to the new main playlist

Copy Selection to Duplicate Playlist Duplicates 
the current main playlist and copies and pastes 
the selection to the duplicate of the main play-
list. The previous main playlist moves to a new 
Playlist lane.



To copy a selection in an alternate playlist to the 
main playlist:

1  In Playlists view, make a selection in an alter-
nate playlist.

2  Do one of the following:

• Click the Copy Selection To Main Playlist 
button in the Playlist Lane controls.

• Choose Edit > Copy Selection to Main Play-

list.

• Right-click the selection and choose Copy 

Selection To Main Playlist.

Making a selection in an alternate playlist

Press Alt+Start+V (Windows) or Op-
tion+Control+V (Mac) to copy the selection 
to the main playlist.
The selection from the alternate playlist is cop-
ied to the same time location in the main play-
list.

To copy a selection in an alternate playlist to a new 
main playlist:

1  In Playlists view, make a selection in an alter-
nate playlist.

2  Choose Edit > Copy Selection to New Playlist.

Selection copied to the main playlist

Selection copied to a new main playlist
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To copy a selection in an alternate playlist to a 
duplicate of the main playlist:

1  In Playlists view, make a selection in an alter-
nate playlist.

2  Choose Edit > Copy Selection to Duplicate 

Playlist.

Dragging Clips to Playlists 
Lanes
You can drag and drop clips to any available 
Playlist lane on any track that has the same 
channel width. For example, you cannot drag 
and drop a stereo clip to a mono track Playlist 
lane. Similarly, you can drag clips from any 
Playlist lane to any other track of the same chan-
nel width.

Selection copied to a duplicate of the main playlist
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Editing in Playlist Lanes
You can edit clips in Playlist lanes in the same 
way that you do in the main playlist. You can 
even move clips between different Playlist lanes 
(including the main playlist), between different 
tracks, and to different points in time. However, 
you will not be able to hear your edits on Playlist 
lanes unless the lane you are editing is soloed 
(see “Auditioning Alternate Playlists” on 
page 640).

Reordering Playlist Lanes
You can reorder Playlist lanes the same way you 
reorder tracks.

To reorder Playlist lanes:

 Click the name of the alternate playlist and 
drag it to the location you want.

Reordering Playlist lanes



Resizing Playlist Lanes
You can resize Playlist lanes the same way you 
resize tracks. 

To resize the track and all Playlist lanes together, 
do one of the following:

 Click the line in between lanes and drag up or 
down. The track and all Playlist lanes resize ac-
cordingly.

– or –

 Right-click the vertical scale between the 
playlist area and the Playlist Lane controls and 
select the lane size you want. The track and all 
Playlist lanes resize accordingly.

To resize a single Playlist lane, do one of the 
following:

 Control-click the line in between lanes and 
drag up or down. The upper lane resizes accord-
ingly.

– or –

Press Start+Up/Down Arrow key (Win-
dows) or Control+Up/Down Arrow key 
(Mac) to resize heights for tracks, playlists, 
and lanes containing the Edit cursor or Edit 
selection.

Resizing a Playlist lane
 Control-Right-click the vertical scale between 
the playlist area and the Playlist Lane controls 
and select the lane size you want.

Renaming Alternate Playlists
You can rename alternate playlists the same way 
you rename tracks. 

To rename an alternate playlist:

1  Double-click the name of the alternate playlist.

2  In the resulting Name dialog, type the name 
you want.

3  Click OK.

Alternate Playlists in the Track 
List
When an audio track is set to Playlists view, all 
of its associated playlists appear listed under the 
track name in the Track List. The names of asso-
ciated alternate playlists are indented to distin-
guish Playlist lanes from tracks. From the Track 
List you can show and hide alternate playlists. 

Selecting a preset size for a Playlist lane
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You can also access the Right-click menu for al-
ternate playlists, which lets you apply Show or 
Hide, Scroll Into View, Rename, Delete, and Filter 

Lanes commands.

Filtering Lanes
You can filter Playlist lanes to show or hide 
them based on different criteria.

To filter Playlist lanes:

1  Right-click the Track Name or the Playlist 
Name.

2  From the Right-click menu, select one of the 
following:

• Show All Lanes 

• Show Only Lanes With > Clips Within The 

Edit Selection 

• Show Only Lanes With > Clips Outside The 

Edit Selection 

• Show Only Lanes With > “Clips Rated >= 

1–5” 

• Hide All Lanes 

• Hide Only Lanes With > Clips Within The Edit 

Selection 

• Hide Only Lanes With > Clips Outside The 

Edit Selection 

• Hide Only Lanes With > “Clips Rated >= 1–5” 

Playlist lanes are shown and hidden accord-
ingly.

Track List showing Playlist lanes for “Audio 1” track
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Matching Alternate Clips
Pro Tools lets you exchange clips in the main 
playlist on tracks with matching alternate clips 
from other playlists associated with the same 
track, from other tracks, or from the Clip List. 
Matching alternate clips are clips that meet cer-
tain criteria. For example, clips that have the 
same User Time Stamp are matches. 

There are several ways to create matching alter-
nate clips in Pro Tools:

• When punch recording (audio or MIDI), 
Pro Tools creates matching clips for the origi-
nal clip (if any) and the new punch recorded 
clip. 

• When loop recording (audio or MIDI), 
Pro Tools creates multiple matching clips for 
each recording pass. 

• When duplicating playlists (audio or MIDI), 
there will be matching alternate clips between 
playlists.

• When importing multichannel audio from a 
field recorder, there will be matching alternate 
clips between channels.

Pro Tools also provides several ways to access 
and audition multiple matching alternate clips:

• Use the Clip Right-click menu to select match-
ing alternate clips according to certain crite-
ria.

• Use the Alternate Takes pop-up menu to select 
matching alternate clips.

• Use the Expand Alternates to New Tracks com-
mand to copy matching alternate clips to new 
tracks.

• Use the Expand Alternates to New Playlists 
command to copy matching alternate clips to 
new alternate playlists on the same track. 
Then use Playlists view to access the alternate 
playlists.



Matching Criteria
The Matching Criteria window lets you select 
the criteria for matching alternate clips. This 
lets you refine the list of available matching 
clips in the Alternate Takes pop-up menu and 
Clip Right-click Matches submenu.

To configure the Matching Criteria options for 
matching alternate clips:

1  Do one of the following:

• Right-click the clip with the Selector or the 
Grabber tool and select Matches > Match 

Criteria.

– or –

• With the Selector tool, Control-click (Win-
dows) or Command-click (Mac) at the pre-
cise beginning of the loop or punch range 
and select Match Criteria.

2  In the Matching Criteria window, select any 
combination of the following Alternates Match 
options:

• Track ID

• Track Name

• Clip Rating

Matching Criteria window

Matching Criteria affects MIDI as well as 
audio clips.
3  Select one of the following In Addition To op-
tions:

• All

• Clip Start

• Clip Start and End

• Within Selection

• None

4  Leave the Matching Criteria window open to 
change the settings as appropriate while com-
positing tracks. Close the Matching Criteria win-
dow when you are done.

Matching Criteria Options

Alternates Match Options
The following Alternates Match options can be 
selected in any combination:

Track ID Any clips recorded to the same track 
are considered matching. Use this option for se-
lecting alternate takes from loop or punch re-
cording.

Track Name Any clips that share the same root 
name with the track or playlist are considered 
matching. For example, the Matches for a track 
named “Gtr.L” would show the clips “Gtr.L_01” 
and “Gtr.L_02-01,” but not “Guitar.L_01.” 

Clip Rating Any clips that have the same Rating 
are considered matching. Enable this option if 
you have rated clips (see “Rating Clips” on 
page 613). 

Matching Criteria settings are saved with 
your Pro Tools session.
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In Addition To Match Options
The following In Addition To Match options are 
mutually exclusive.

All Any clips that include the time location of 
the Edit cursor; or any clips that are either 
partly or fully within the current time range of 
the Edit selection.

Clip Start Any clips that have the same start time 
as the time location of the Edit cursor or Edit se-
lection.

Clip Start and End Any clips that have the same 
start and end times as the Edit selection.

Within Selection Any complete clips that are en-
tirely within the Edit selection.

None No other criteria in addition to the se-
lected Alternates Match options are used to fil-
ter matching alternate clips.

Selecting Alternate Takes on 
Tracks
Each clip resulting from a punch or loop record 
pass has an identical start time (the User Time 
Stamp). You can select and audition alternate 
takes from the Right-click Matches submenu or 
the Alternate Takes pop-up menu—even during 
playback.

To select an alternate take:

1  Configure the Matching Criteria window if 
necessary (see “Matching Criteria” on page 645).
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2  Do one of the following:

• Right-click the clip with the Selector or the 
Grabber tool, and select a matching alter-
nate take from the Matches submenu in the 
pop-up menu.

• If the take currently residing in the track is 
selected, with the Selector tool, Control-
click (Windows) or Command-click (Mac) 
anywhere on the selected take and select a 
different take from the Alternate Takes 
pop-up menu.

• With the Selector tool, Control-click (Win-
dows) or Command-click (Mac) at the pre-
cise beginning of the loop or punch range 
and select a different take from the Alter-
nate Takes pop-up menu.

The selected matching alternate clip (take) re-
places the clip in the main playlist and snaps 
precisely to the correct location.

Right-click Matches submenu

Alternate Takes pop-up menu



One way to ensure that subsequent recording 
takes have the same User Time Stamp (and as 
such can be available as matching alternate 
clips) is to store punch and loop record selec-
tions as Memory Locations. Then, if you later 
need to record additional takes, recall the corre-
sponding Memory Location. 

To change the User Time Stamp of other clips so 
that they can be available as alternate matching 
clips for a specific location, use the Time Stamp 
command in the Clip List menu. 

Matches and Multiple Tracks
If you have loop recorded on multiple tracks, 
and each track contains multiple takes with 
identical User Time Stamps, you can change all 
takes simultaneously.

To switch takes for multiple tracks:

1  Configure the Matching Criteria window (see 
“Matching Criteria” on page 645), so that the fol-
lowing options are enabled:

• Track Name 

– and –
• Selection Range

2  With the Selector tool, select the take range for 
each track you want to replace.

3  Do one of the following:

• Right-click the Edit selection and select a 
different matching alternate take from the 
Matches submenu.

– or –

• Control-click (Windows) or Command-
click (Mac) the Edit selection and select a 
different take from the Alternates pop-up 
menu.

The selected take replaces the previous take and 
snaps to the correct location on each track.
Automatically Create New 
Playlists when Loop 
Recording
When loop recording, Pro Tools creates a single 
file containing all recording passes where each 
recording pass is a clip in the file. On the track, 
only the last recording pass is present as a clip in 
the main playlist. All other clips (recording 
passes) are hidden, but can be recalled as match-
ing alternate clips (takes).

When enabled, the new Automatically Create New 

Playlists When Loop Recording option in the Op-
eration Preferences page automatically copies 
each clip (take) to a new playlist in the track. 
This facilitates using Playlists view for audition-
ing and selecting alternate takes.

To automatically create new playlists when loop 
recording:

1  Choose Setup > Preferences and click the 
Operation tab.

2  In the Recording section, enable the Automati-

cally Create New Playlists When Loop Recording 
option.

3  Click OK.

For more information on loop recording, see 
“Loop Recording Audio” on page 473.
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Expanding Alternate Takes 
to New Playlists or Tracks
Pro Tools lets you copy alternate takes and 
channels to new playlists or tracks. This is use-
ful for auditioning, editing, and mixing multiple 
alternate takes or channels. Alternate takes are 
created when punch and loop recording. Alter-
nate channels are included with files imported 
into Pro Tools from field recorders.

Expanding Alternate Takes to 
New Playlists
Expanding alternate takes to new playlists read-
ily facilitates track compositing. Once you have 
expanded alternate takes to new playlists on a 
track, you can audition and edit them in Play-
lists view to assemble the best takes in the main 
playlist.

To expand alternate takes to new playlists:

1  Identify the clip on the main playlist with 
matching alternate clips (takes). 

2  Do one of the following:

• Right-click the clip and choose Matches > 

Expand Alternates To New Playlists.

• If the clip is selected, with the Selector tool, 
Control-click (Windows) or 
Command-click (Mac) anywhere on the se-
lected clip and choose Matches > Expand Al-

ternates To New Playlists.

• If the clip is not selected, with the Selector 
tool, Control-click (Windows) or 
Command-click (Mac) at the precise begin-
ning of the loop or punch range and choose 
Matches > Expand Alternates To New Play-

lists.
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All matching alternate clips are copied to new 
playlists on the track. To view all playlists for 
the track, select Playlists view. In any track 
view, you can also select any available alternate 
playlist as the main playlist from the Playlist se-
lector.

Expanding Alternate Takes to 
New Tracks
Expanding alternate takes to new tracks readily 
facilitates auditioning, editing, and mixing al-
ternate takes, each on separate tracks.

To expand alternate takes to new tracks:

1  Identify the clip on the main playlist with 
matching alternate clips (takes). 

2  Do one of the following:

• Right-click the clip and choose Matches > 

Expand Alternates To New Tracks.

• If the clip is selected, with the Selector tool, 
Control-click (Windows) or 
Command-click (Mac) anywhere on the se-
lected clip and choose Matches > Expand Al-

ternates To New Tracks.

• If the clip is not selected, with the Selector 
tool, Control-click (Windows) or 
Command-click (Mac) at the precise begin-
ning of the loop or punch range and choose 
Matches > Expand Alternates To New 

Tracks.

3  Then choose one of the following from the Ex-
pand Alternates To New Tracks sub-menu:

By Track Name Names all new tracks after the 
source track name.

By Clip Name Names each new tracks after the 
corresponding original clip names that you see 
in the Matches list.



By Track and Clip Name Names all new tracks 
after the source track name, but with the corre-
sponding original clip names in parenthesis.

All matching alternate clips are copied to new 
tracks.

Expanding Alternate 
Channels to New Playlists or 
Tracks
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

When working with a mono clip that is part of a 
multichannel recording imported from a field 
recorder, you can expand that clip (or a selected 
portion of it) to new playlists that reflect its 
matching alternate channels while preserving 
any edits or fades (see Chapter 52, “Working 
with Field Recorders in Pro Tools”).

Conditions for Alternate 
Channel Availability
An alternate channel is available to replace the 
original channel (represented by the clip or por-
tion of a clip selected on the Timeline) if all of 
the following are true:

• Both channels are part of a multichannel 
recording made simultaneously on one or 
more field recorders.

• Certain metadata matches between the 
original channel and the alternate channel.

• The metadata embedded during shooting 
and recording has been preserved prior to 
import into Pro Tools.
With multichannel recordings from one or more 
field recorders, both channels must overlap at 
least once between their start timecode and end 
timecode positions, and must also meet one of 
the following conditions:

• Matching Scene and Take

• Matching Shoot Date (applies only if Scene 
and Take contain any information for both 
channels)

• Matching Tape name

• Matching Sound Roll name

• Alternate channel Sound Roll name 
matches current channel Tape name

• Alternate channel Tape name matches cur-
rent channel Sound Roll name

Expanding Channels to New 
Playlists

To expand alternate channels to new playlists:

1  In the Timeline, do one of the following:

• To expand only a portion of the clips on the 
track, make a selection that includes or 
overlaps any number of clips on a track, and 
Right-click (Windows or Mac) or Control-
click (Mac) the selection.

– or –

• To expand all of the clips on the track, 
Right-click (Windows or Mac) or Control-
click (Mac) the track name.

2  Choose the Expand to New Playlists pop-up 
menu, and select one of the following methods 
by which to expand alternate channels for the se-
lection to new tracks:

• By Channel Name

• By Channel Number

• By Channel Name and Number

• By Timecode Only
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If alternate channels are available, Pro Tools ex-
pands them to new playlists (including the 
channel represented in the original track) ac-
cording to the selected option.

Expanding Channels to New 
Tracks

To expand alternate channels to new tracks:

1  In the Timeline, do one of the following:

• To expand only a portion of the clips on the 
track, make a selection that includes or 
overlaps any number of clips on a track, and 
Right-click (Windows or Mac) or Control-
click (Mac) the selection.

– or –

• To expand all of the clips on the track, 
Right-click (Windows or Mac) or Control-
click (Mac) the track name.

2  Choose the Expand Channels to New Tracks 
pop-up menu, and select one of the following 
methods by which to expand alternate channels 
for the selection to new tracks:

• By Channel Name

• By Channel Number

• By Channel Name and Number

• By Timecode Only

If alternate channels are available, Pro Tools ex-
pands them to new tracks (including the channel 
represented in the original track) according to 
the chosen parameters.

It is not possible to rename files encoded 
with XML metadata. The file extension will 
always be .A1 and .A2 (even for stereo files). 
Also, it is not possible to rename files with a 
.L/.R suffix. As a result, Pro Tools does not 
always recognize these channels as a stereo 
pair.
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Expanding Channels by 
Timecode Only
The Expand To New Tracks By Timecode Only 

command lets you expand an entire track or 
only selected clips to new playlists on the same 
track or to new separate tracks, thus revealing 
all other clips recorded at the same timecode lo-
cation, regardless of channel name or number. 
This is especially useful when expanding edited 
guide tracks to original source audio that was 
recorded while referenced to timecode, but 
where channel names or numbers were not writ-
ten to the audio files. 

Example Workflow: Working with a Guide Track for 
Live Concert Videos

1  Multitrack audio is recorded in Pro Tools 
while chasing timecode. A mono or stereo mix is 
recorded simultaneously as a guide track for the 
video editor.

2  The picture and audio guide tracks are edited 
in a video editing application. 

3  The edited audio guide tracks are exported 
from the video editor as an AAF (or OMF) se-
quence, including handles of at least 2 frames. 

4  The AAF (or OMF) sequence is imported into 
Pro Tools as a new session. The original source 
audio files and unedited guide track are also im-
ported into the session.

5  The original unedited guide track is relinked 
to the session (see “Relinking the Original 
Unedited Guide Track” on page 651).

6  The Pro Tools editor Right-clicks the name of 
the guide track and selects Expand Channels to 

New Tracks > By Timecode Only. The original 
source tracks expand to new tracks with edits 
and fades that match the guide track.



Relinking the Original Unedited Guide Track

After importing the AAF (or OMF) sequence and 
original source audio files into the session, it is 
recommended that you relink the edited guide 
track to the original unedited source audio.

To relink the original unedited guide track:

1  Open the Project Browser for the session and 
open the Audio Files folder. 

2  Right-click the edited guide track audio file in 
the browser and choose Relink Selected.

3  In the upper pane of the Relink window, navi-
gate to the original unedited guide track audio 
file that was recorded in Pro Tools. 

4  In the Select Files To Relink pane, select the 
edited guide track file.

5  Drag the original unedited guide track audio 
file into the Candidates pane. If a dialog appears 
stating that one or more files are shorter than 
the media file you are trying to relink, click Yes 
to select it for relinking anyway.

6  Check the box to the left of the file in the Can-
didates pane so that the Link icon appears. 

7  Click Commit Links at the top of the Relink 
window and then close the Relink window.

8  You can now Right-click the name of the guide 
track and select Expand To New Tracks > By 

Timecode Only. All expanded tracks should be 
synchronous with the guide track.

If the original unedited file is not available, 
you can relink to any of the source audio 
files as long as they have the same start and 
end times as the guide track.
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Chapter 31: Beat Detective
Beat Detective is a powerful tool for analyzing, 
editing, and manipulating audio or MIDI data 
that has an inherent rhythmic character.

Beat Detective analyzes an audio or MIDI selec-
tion, identifies its peak transients or accented 
notes, and generates beat triggers based on the 
detected peak transients or MIDI notes. From 
these beat triggers, Beat Detective can: 

• Extract tempo and beat information to create 
Bar|Beat Markers that can be used to define 
the session’s tempo map. See “Generating 
Bar|Beat Markers with Beat Detective” on 
page 664.

• Extract tempo and groove information as 
groove templates, called DigiGrooves. These 
templates can be applied to audio or MIDI us-
ing Beat Detective or Groove Quantize (see 
“DigiGroove Templates” on page 665.

• Separate an audio selection into discrete clips, 
and then conform (or “quantize”) separated 
clips to the session’s tempo map, or to groove 
templates. See “Separating Clips with 
Beat Detective” on page 667 and “Conforming 
Clips with Beat Detective” on page 668.
Beat Detective and Source 
Material
Beat Detective is most effective with audio or 
MIDI that has clear attack transients or accent 
patterns (including most instruments used in 
popular music, such as drums, guitar, or bass). 
Beat Detective will be less successful with audio 
material with soft attacks, or legato phrasing 
(such as strings and vocals).

Uses for Beat Detective
Beat Detective can be useful in many situations, 
including:

Extracting Tempo from Audio and MIDI Beat De-
tective can generate Bar|Beat Markers, from 
which it can extract the tempo—even if the 
audio or MIDI contains varying tempos, or 
material with a swing feel. Additionally, once 
Bar|Beat Markers have been generated, other 
audio and MIDI clips and events can be quan-
tized to them. 

Creating DigiGrooves Beat Detective can extract 
groove templates, called DigiGrooves, from an 
audio or MIDI selection. DigiGrooves can be 
used to apply the groove, or feel of the captured 
passage to other audio selections (using Groove 
Conform) or MIDI data (using Groove 
Quantize). 
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Conforming Audio Clips Beat Detective can con-
form (“quantize”) audio with a different tempo, 
or with varying tempos, to the session’s current 
tempo map, or to a groove template. 

“Tighten Up” Performances Beat Detective can 
be used to improve the timing of some audio 
material by calculating and extracting its aver-
age tempo, and then conforming its rhythmic 
components—clips separated with Beat Detec-
tive—to the session’s tempo map.

Loop Matching Since Beat Detective can extract 
tempo and beat information from audio and 
MIDI, and conform audio to an existing tempo 
map or groove template, this makes it very use-
ful for aligning loops with different tempos or 
grooves. If a loop is at a different tempo than the 
current session, Beat Detective lets you quickly 
separate each beat in the loop and conform them 
to the tempo map (as an alternative to time com-
pressing or expanding the loop, which can alter 
the pitch and tone of the audio). 

Remixes Beat Detective can be used for remixes 
or creating new rhythms. It can extract tempo 
from the original drum tracks, or in some in-
stances the original stereo mix. New audio or 
MIDI tracks can then be conformed to the orig-
inal material, or the original material can be 
conformed to new drum tracks, achieving an en-
tirely new feel.

When working with tick-based audio, use 
Beat Detective’s Clip Separation 
command to quickly separate audio clips 
into individual “hits” (or slices). You can 
also create a clip group of the separated clips 
to facilitate editing and arranging.
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Smoothing Post Production Edits (Audio 
Only) Beat Detective’s Edit Smoothing can be 
used to automatically clean up foley tracks that 
contain many clips requiring trimming and 
crossfading, effectively removing the gaps of si-
lence between the clips (thus retaining the room 
tone throughout the track).

Beat Detective Requirements
Beat Detective is available with all Pro Tools
systems.

RAM Requirements for Beat Detective

Beat Detective operations can require a large 
amount of RAM, especially when working with 
multiple tracks and lengthy selections. To avoid 
low memory situations with Beat Detective, do 
the following:

• If you begin to experience slower Beat Detec-
tive response, add more RAM to your com-
puter. 

• If your computer does not have extra RAM, 
work with shorter selections, or individual 
tracks.

• Set the Editing preference for Levels of Undo 
to a smaller value (see “Levels of Undo and 
Memory” on page 533). Memory-intensive ed-
iting operations, such as Edit Smoothing (au-
dio only) with Beat Detective, can use up a 
large amount of memory when in the Undo 
queue.



The Beat Detective Window
Beat Detective is managed from the Beat Detective window.
Beat Detective window
To open the Beat Detective window, do one of the 
following:

 Choose Event > Beat Detective.

– or –

 Press Control+8 (Windows) or Command+8 
(Mac) on the numeric keypad.

Beat Detective is a floating window that can be 
left open while working. This lets you adjust the 
controls in real time during playback, while 
viewing the beat triggers that appear in your se-
lection in the Edit window.

Beat Detective Modes
The Beat Detective window is divided into three 
sections: Operation, Selection, and Detection. 
Depending on the Operation mode, the controls 
in the Action section change. The Selection op-
tions for Beat Detective are available in each of 
the Operation modes.
The Beat Detective modes include the following:

Operation Lets you choose to analyze either 
MIDI or audio material.

Bar|Beat Marker Generation Generates Bar|Beat 
Markers corresponding to transients detected in 
the audio selection or according to accent pat-
terns with MIDI notes.

Groove Template Extraction Extracts the rhyth-
mic and dynamic information from audio or 
MIDI, and saves this information to the Groove 
Clipboard, or as a DigiGroove template.

Clip Separation (Audio Only) Separates and cre-
ates new clips based on transients detected in 
the audio selection.

Clip Conform (Audio Only) Conforms all sepa-
rated clips within the selection to the current 
tempo map. Beat Detective can conform audio 
clips to groove templates (such as DigiGroove 
templates) in addition to standard quantization.

Edit Smoothing (Audio Only) Fills the gaps be-
tween conformed clips by automatically trim-
ming them, and inserts crossfades.
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Defining a Beat Detective 
Selection
Whether you will be generating Bar|Beat Mark-
ers, extracting a DigiGroove template, or sepa-
rating clips to be conformed, you must always 
define the audio or MIDI selection to be ana-
lyzed. The Beat Detective window provides tools 
to define and capture the selection range, time 
signature, and swing (sub-division) content for 
the selected audio.

For Beat Detective to generate beat triggers that 
are metrically accurate, the length and meter of 
the selection must be correctly defined. In addi-
tion, the selection should not contain any meter 
or tempo changes.

To define a selection for Beat Detective:

1  In the Edit window, select a range of audio or 
MIDI material in a single track or in multiple 
tracks.

To ensure the best possible results with Beat 
Detective, make sure the selected passage 
starts exactly on the attack of the first beat. 

Use Loop playback to check the accuracy of 
your selection.

To keep the Edit selection intact while play-
ing or looping from any location, deselect 
Options > Link Timeline and Edit Selection.

Making an audio selection for Beat Detective
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Make sure the selection’s start and end points 
fall cleanly on the beat. To zero in on an audio 
clip’s start and end points, zoom to the sample 
level and use the Tab to Transients option (see 
“Tabbing to Transients” on page 580).

2  Choose Event > Beat Detective.

3  You must define or capture the selection every 
time you make a new selection or change the 
tempo map. To define the selection range, do one 
of the following:

• If the tempo and meter of the audio selec-
tion do not match the session’s default 
tempo and meter, enter the Time Signature, 
and Start Bar|Beat and End Bar|Beat loca-
tions. For a four-bar selection that starts on 
beat 1, enter 1|1 and 5|1.

• If the tempo and meter of the audio selec-
tion do not match the session’s default 
tempo and meter, and you are unsure of the 
length of the material, enter the Time Sig-

nature and the Start Bar|Beat location; then 
start playback, and click the Tap End B|B 

button repeatedly to automatically 
calculate the End Bar|Beat. When using Tap 

End B|B with long selections, continue to 
tap until the End Bar|Beat stabilizes. Once 
stabilized, you may need to manually 
adjust the number to the nearest bar 
boundary.

To avoid losing an existing selection, save 
and recall an Edit selection by saving it as a 
Memory Location. See Chapter 37, “Memory 
Locations.”



• If the selection’s tempo and meter match 
the session tempo and meter (see “Calculat-
ing Tempo with Beat Detective” on 
page 658), and it aligns correctly with the 
session’s bars and beats, click the Capture 

Selection button. The correct Time Signa-

ture, and Start Bar|Beat and End Bar|Beat 
values will be filled in automatically.

4  To improve Beat Detective’s accuracy in ana-
lyzing swung notes, select the Contains option 
that indicates the smallest sub-division of the 
beat contained in the selection. The Contains op-
tion includes quarter-notes, eighth-notes, six-
teenth-notes (the default setting), thirty-
second-notes, and a triplet modifier. The se-
lected Contains option determines the groove 
template grid locations for DigiGroove tem-
plates.

Beat Detective, Selection options

As long as the audio material is correctly 
aligned with the session’s tempo map, use 
Capture Selection each time you make a new 
selection or make any changes to the tempo 
map (such as changing tempo or meter).

The Selection definition is not retained 
when a session is closed and re-opened
Beat Detective Analysis
Beat Detective provides several analysis algo-
rithms for beat detection appropriate to differ-
ent types of audio material.

High Emphasis Works well with high frequency, 
inharmonic material, such as cymbals and hi-
hats, while avoiding low frequency material.

Low Emphasis Works well with low frequency 
material, such as bass guitar and kick drum, as 
well as with most harmonic material, such as pi-
ano or rhythm guitar.

Enhanced Resolution Works well with the 
broadest range of material, such as full mixes 
and loops.

Beat Detection Across Multiple Tracks

When analyzing a selection with multiple 
tracks, Beat Detective analyzes each indepen-
dently. Transients that are detected in any track 
appear as Beat Triggers across all selected tracks 
regardless of whether or not the detected tran-
sient resides in any other track. However, for 
closely aligned events on multiple tracks, Beat 
Detective only identifies the first detected tran-
sient of a beat event. 

For example, if you have four drum tracks—
kick, snare, and a pair of overheads—transients 
in the overhead mics tracks occur a little later 
than the closely miked snare and kick tracks be-
cause it takes more time for the sound to travel 
from the source to the microphones. If you make 
a selection across all four tracks and analyze 
them using Beat Detective, only the transients in 
the kick and snare tracks will be identified as 
beat triggers because the transients on over-
heads will be recognized as being part of the 
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same beat events (only a little bit late). For in-
formation on individually analyzing multiple 
tracks, see “Using Collection Mode” on 
page 673.

Calculating Tempo with Beat 
Detective 
If you know the meter, and start and end points 
of the audio selection, use Beat Detective to cal-
culate its tempo.

To calculate a selection’s tempo with Beat 
Detective:

1  Make an Edit selection in the Edit window or a 
MIDI Editor window (MIDI only) and define the 
selection in the Beat Detective window as de-
scribed in “Defining a Beat Detective Selection” 
on page 656.

2  Select Bar|Beat Marker Generation.

3  In the Detection section (Normal mode), click 
Analyze.

4  Set Sensitivity set to 0%.

5  Click Generate.

Bar|Beat Markers are automatically generated at 
the beginning and end of the selection, indicat-
ing the material’s tempo and meter.

Beat Detective, Detection mode
Pro Tools Reference Guide
Generating Beat Triggers
Once you have accurately defined the selection 
range, Beat Detective can generate beat triggers 
based on detected MIDI notes or audio peak 
transients. The range and type of transients 
found can be adjusted with the Detection set-
tings, allowing you to zero in on the bars, beats, 
and sub-beats in the material, while avoiding 
the non-rhythmic content.

To generate beat triggers from an audio selection:

1  In the Edit window, make an audio selection.

2  Select Audio from the Operation pop-up menu.

3  In the Beat Detective window, select one of the 
following modes:

• Bar|Beat Marker Generation

• Groove Template Extraction 

• Clip Separation (audio only)

4  Define or capture the selection as described in 
“Defining a Beat Detective Selection” on 
page 656.

5  From the Analysis pop-up menu, choose a de-
tection algorithm.

6  Click Analyze.

7  Depending on the rhythmic content of the se-
lection, set the Resolution to Bars, Beats, or Sub-

Beats.

8  Adjust the Sensitivity until beat triggers appear 
on the beats and sub-beats in the selection.

Beat Detective generated Bar|Beat Markers 
identifying tempo and meter



Bar triggers are indicated with thick lines, beat 
triggers with medium lines, and sub-beat trig-
gers with thin lines. 

9  You can zoom to the sample level and click the 
Scroll Next button to scroll to the next trigger 
within the selection. To scroll to the previous 
trigger, Alt-click (Windows) or Option-click 
(Mac) the Scroll Next button (see “Navigating 
Consecutive Beat Triggers” on page 663). This is 
useful to confirm that the beat triggers are ap-
pearing in the appropriate locations. If false trig-
gers appear between the beats or sub-beats 
(representing non-rhythmic material), delete 
them (see “Deleting Beat Triggers” on page 662), 
or reduce the Sensitivity value.

10  To display the metric locations for the trig-
gers, select the Show Trigger Time option.

11  If you cannot get the beat triggers to appear at 
the right locations, repeat steps 5–10, trying one 
of the other Analysis algorithms (High or Low 
Emphasis).

Beat triggers

BarBeat Sub-Beats
To generate beat triggers from a MIDI selection:

1  In the Edit window, set the MIDI track you 
want to use to Notes view.

2  In the Edit window, or in a MIDI Editor win-
dow, make a selection across a range of MIDI 
notes. Make certain that the selection start and 
end points are at musically relevant locations, 
such as barlines.

3  Choose Event > Beat Detective.

4  Select MIDI from the Operation pop-up menu.

5  In the Beat Detective window, select one of the 
following modes:

• Bar|Beat Marker Generation

• Groove Template Extraction 

6  Define the selection range. If the tempo and 
meter of the audio selection do not match the 
session’s default tempo and meter, enter the Time 

Signature, and Start Bar|Beat and End Bar|Beat 
locations. For example, for a four-bar selection 
that starts on beat 1, enter 1|1 and 5|1.

7  If your MIDI track contains chords, choose one 
of the following MIDI chord recognition algo-
rithms from the Analysis pop-up menu:

• Last Note

• First Note

• Loudest Note

• Average Location

• Highest Note

• Lowest Note

8  Click Analyze. 
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MIDI Chord Recognition
Since MIDI notes in a chord may be played at 
slightly different moments, Beat Detective in-
terprets notes that are close together (closer 
than half the time value that is set in the Selec-
tion Contains field) as a chord. 

Beat Detective uses the criteria you set in the 
Analysis pop-up menu to interpret the location 
of the beat in relation to the chord.

Last Note Sets the beat trigger to the start of the 
last note played in the chord.

First Note Sets the beat trigger to the start of the 
first note played in the chord.

Loudest Note Sets the beat trigger to the start of 
the note in the chord played with the highest ve-
locity.

Average Location Sets the beat trigger to a point 
that represents the average between the start of 
the first note played in the chord, and the last 
note played in the chord.

Highest Note Sets the beat trigger to the start of 
the highest note played in the chord.

Lowest Note Sets the beat trigger to the start of 
the lowest note played in the chord.

MIDI chord analysis

First
Note Last

Note

Highest Note

Lowest Note
Pro Tools Reference Guide
Realign Session
Beat Detective’s Realign Session function lets 
you generate Bar|Beat markers without tick-
based material shifting. This is useful if you 
want to extrapolate Bar|Beat markers from tick-
based material to align the tempo map and 
Bar|Beat grid to the tick-based material. 

Generating Bar|Beat markers in sessions with 
tick-based material, such as MIDI tracks and 
tick-based audio tracks, can cause the tick-
based material to shift in absolute time. This can 
be useful if you want to align the tick-based ma-
terial to Bar|Beat markers generated from sam-
ple-based material.

When you generate Bar|Beat Markers in a ses-
sion that contains tick-based audio or MIDI, 
Beat Detective gives you the option to preserve 
the position of the session’s tick-based material, 
or to allow the material to shift.

You can also switch tick-based material, 
such as a MIDI performance, to be sample-
based and then manually insert Bar|Beat 
markers.

Realign Session dialog



To generate Bar|Beat Markers with Beat Detective 
in a session with tick-based tracks:

1  In the Edit window, make an audio or MIDI se-
lection.

2  In the Beat Detective window, select Bar|Beat 

Marker Generation.

3  Define or capture the selection as described 
in“Defining a Beat Detective Selection” on 
page 656.

4  Set the Resolution to Bars or Beats.

5  Click Generate. 

6  Do one of the following:

• In the Realign Session dialog, choose Pre-

serve Tick Position if you want to let the 
tick-based material shift in absolute time.

– or –

• Choose Preserve Sample Position if you 
want to have the tick-based material main-
tain its absolute position. This option can 
be useful when adding a meter and tempo 
map to a freely played performance.

7  Click OK.
Tips for Getting Useful Beat 
Triggers
Use the following tips to verify beat triggers:

 To focus on a particular area in the selection, 
unlink the Timeline and Edit Selections and set 
the playback range by clicking or dragging in any 
Timebase ruler.

 Check the thickness of the beat triggers to see 
if they align properly with the audio material. 
Thick triggers fall on barlines, medium triggers 
fall on beats, and thin triggers fall on sub-beats. 

 Select the option for Show Trigger Time and 
see if the (assumed) metric locations of the trig-
gers align with the material. A false trigger 
should be moved or deleted because it can cause 
subsequent triggers to appear in the wrong loca-
tions (see “Editing Beat Triggers” on page 662).

 Consider whether lengthy selections should 
first be broken down into smaller selections, 
which could be more easily managed. For exam-
ple, working in 8- or 4-bar sections might yield 
better results more quickly. 

 Beat triggers are preserved when switching 
between audio and MIDI modes. This allows us-
ing MIDI triggers for editing audio, or collecting 
triggers from combinations of MIDI and audio 
tracks.

 For selections across multiple tracks, consider 
whether it may be easier to work with them indi-
vidually, or in Collection mode. See “Detection 
(Normal) and Collection Mode” on page 673.
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Editing Beat Triggers
Even though Beat Detective offers a great deal of 
flexibility in how transients are detected, there 
may be times when beat triggers must be de-
leted, moved, or manually inserted. Addition-
ally, triggers can be promoted so they are re-
tained at lower sensitivity settings. 

Deleting Beat Triggers
False triggers, which do not represent an actual 
beat or sub-beat in the source material, may ap-
pear when raising the Sensitivity to detect quiet 
material. In these instances you can locate and 
manually delete any false triggers.

To delete a beat trigger:

1  With the Beat Detective window open, select 
any Grabber tool in the Edit window.

2  Locate the false trigger you want to delete. 
Transients for false triggers usually have smaller 
peaks than the other trigger points, and typi-
cally fall between the sub-beats.

3  Alt-click (Windows) or Option-click (Mac) the 
trigger to delete it.

Moving Beat Triggers
You can adjust the placement of triggers to allow 
for the attack of their transients, or to compen-
sate for an individual transient that is slightly 
ahead of or behind the beat.

Deleting a beat trigger
Pro Tools Reference Guide
To move a beat trigger:

1  With the Beat Detective window open, select 
any Grabber tool in the Edit window.

2  Locate the beat trigger you want to move and 
drag it left or right.

Inserting Beat Triggers
If an important beat or sub-beat is not detected, 
because it is too quiet, you can manually insert a 
beat trigger.

To insert a beat trigger:

1  With the Beat Detective window open, select 
any Grabber tool in the Edit window.

2  Click in the selection where you want to insert 
the new trigger. After inserting a beat trigger, 
you can drag it left or right to adjust its place-
ment (see “Moving Beat Triggers” on page 662).

Promoting Beat Triggers
To ensure that important beat triggers do not 
disappear when lowering the Sensitivity, you can 
promote them. This is useful if a selection has 
numerous false triggers (too many to bother de-

Moving a beat trigger

If you click too close to an existing trigger, 
the existing trigger will be moved to the new 
location.



leting) at a Sensitivity level where crucial, nec-
essary beat triggers are also displayed. If lower-
ing the Sensitivity and the needed triggers to 
disappear, simply promote them first.

To promote a beat trigger:

1  Raise the Sensitivity until the transient is de-
tected and a beat trigger appears.

2  Control-click (Windows) or Command-click 
(Mac) the beat trigger to promote it. 

3  If necessary, repeat steps 1–2 to promote addi-
tional beat triggers.

4  Lower the Sensitivity to a value where the false 
triggers disappear.

Once beat triggers are promoted, they will only 
disappear if the Sensitivity value is set to 0%. To 
demote all beat triggers in the selection—re-
turning them to their original state—click the 
Analyze button.

Redefining a Beat Trigger’s 
Metric Location
It is vital that beat triggers are accurately placed 
at the correct metric location. If a detected tran-
sient is slightly off the beat, Beat Detective may 
assign it, as well as other transients in the selec-
tion, to the wrong metric location.

For example, if you have a bass track where a 
note was intended to be a downbeat, but was 
played too early, Beat Detective may define its 
location as occurring a little before the down-

Promoting a beat trigger
beat. If you then separate and conform the clip 
containing this note, it will be moved to the 
wrong location. Subsequent clips may be moved 
to the wrong locations as well.

If a beat trigger is not assigned the correct met-
ric location, relocate it using Identify Trigger.

To change the metric location of a beat trigger:

1  Double-click the beat trigger you want to relo-
cate. The Identify Trigger dialog opens.

2  In the Identify Trigger dialog, enter the correct 
location for the trigger, then click OK. 

Navigating Consecutive Beat 
Triggers
Use the Scroll Next button to move from the cur-
rently selected beat trigger to the next beat trig-
ger. To move to the previous beat trigger, Alt-
click (Windows) or Option-click (Mac) the Scroll 

Next button. This is particularly useful for edit-
ing consecutive beat triggers when zoomed in at 
the sample level.

Identify Trigger dialog
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Generating Bar|Beat Markers 
with Beat Detective
Once Beat Detective has accurately detected the 
peak transients in the audio selection and accu-
rately generated beat triggers, the triggers can 
be converted to Bar|Beat Markers. Bar|Beat 
Markers generated by Beat Detective create a 
tempo map that can be used throughout the ses-
sion.

Once a tempo map has been generated, other au-
dio clips and MIDI notes can be conformed to 
the Bar|Beat Markers generated by Beat Detec-
tive.

If you want to match the audio material to the 
session’s existing tempo map or a groove tem-
plate, do not generate Bar|Beat Markers from 
the material. Instead, use Beat Detective to sep-
arate and conform the material (see “Separating 
Clips with Beat Detective” on page 667).

To generate Bar|Beat Markers with Beat Detective:

1  Make an Edit selection.

2  In the Beat Detective window, select Bar|Beat 
Marker Generation mode.

3  Define or capture the selection as described in 
“Defining a Beat Detective Selection” on 
page 656.

4  Set the Resolution to Bars or Beats, and config-
ure the Detection setting so the selection’s peak 
transients (or MIDI Note Ons) are accurately de-
tected (see “Generating Beat Triggers” on 
page 658).

5  Click Generate. 

If you are simply aligning a sloppy part to 
the other tracks, you probably do not need to 
generate Bar|Beat markers.
Pro Tools Reference Guide
Bar|Beat Markers are generated, based on the 
beat triggers, and appear in the Tempo ruler.

Working with Sub-Beats
Tempo is derived from Bar|Beat Markers. 
Groove, or feel, is derived from Sub-Beats—the 
deviation of subdivisions of the beat from the 
strict tempo grid determines the groove or feel. 

To extract the groove from a selection, set the 
Detection Resolution to Sub-Beats. This ensures 
that the inner rhythms within each bar (if they 
indeed exist) are represented when generating 
Bar|Beat Markers. These Bar|Beat Markers can 
then be used to quantize other audio clips or 
MIDI tracks, thereby conforming to the 
Bar|Beat Markers generated by Beat Detective.

Bar|Beat Markers generated at Bar resolution

Bar|Beat Markers generated at Beat resolution

When quantizing clips or MIDI notes to 
Bar|Beat Markers on sub-beats that 
represent a swing feel, make sure to use a 
straight quantize value (with the Swing 
option for Quantize disabled).



DigiGroove Templates
Beat Detective allows the fine timing nuances of 
a rhythmic performance to be extracted and 
saved as a groove template, called a DigiGroove 
template. DigiGrooves can be saved locally to 
the Groove Clipboard, or saved to disk as Di-
giGrooves. 

Groove templates can be used to transfer the feel 
of a particular performance to:

• Selected audio clips using Groove Conform 
(see “Groove Conform” on page 670).

• Selected MIDI data using Groove Quantize 
(see “Groove Quantize” on page 916).

Groove templates are “quantization maps” de-
rived from real musical performances. The 
rhythmic character of each performance is ana-
lyzed and stored as a groove template. Beat De-
tective analyzes an audio selection for transient 
peaks according to a defined threshold and 
maps the rhythmic relationships to a 960 parts 
per quarter note (ppq) template.

When creating DigiGroove templates, Beat De-
tective also analyzes the dynamics of a perfor-
mance. MIDI velocity data is saved from MIDI 
tracks, and accents and peak levels in audio data 
are incorporated into the groove template as ve-
locity data, which can be applied to change the 
dynamics of MIDI tracks. 

Beat Detective translates the amplitude of sig-
nals in audio tracks to MIDI velocity according 
to a linear scale. For example:

• A 0 dBFS signal equals a MIDI velocity of 
127.

• A signal at –6 dBFS equals a MIDI velocity 
of 64.

• A signal at –12 dBFS equals a MIDI velocity 
of 32.

• A –48 dBFS equals a MIDI velocity of 1.
Capturing this information is very important to 
preserving the feel of a performance, and can 
add life to MIDI tracks that lack dynamics. 

Extracting Groove Templates

To extract a Groove Template:

1  In the Edit window, make an Edit selection (in-
cluding audio or MIDI). The selection should 
consist of one or more complete bars, starting 
and ending on downbeats.

2  In the Beat Detective window, select Groove 

Template Extraction.

3  Define or capture the selection as described in 
“Defining a Beat Detective Selection” on 
page 656.

4  Configure the Detection options so the selec-
tion’s peak transients (or MIDI Note Ons) are ac-
curately detected (see “Generating Beat 
Triggers” on page 658).

5  Click Extract. 

6  In the Extract Groove Template dialog, enter 
comments about the groove. You can enter a 
maximum of 255 characters to describe the 
groove. Comments can be viewed using the Show 
Info button in the Beat Detective window.

Beat Detective only captures duration data 
from MIDI tracks, not from audio tracks.

When extracting Groove Templates, the 
captured selection must not include Bar|Beat 
Markers. Otherwise, the accuracy of the 
Groove Template will be compromised.
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7  Do one of the following:

• To save the extracted template for use in the 
current session, without writing the tem-
plate file to disk, click Save To Groove Clip-

board. (This template will be lost when you 
close the current session.)

• To save the extracted template to disk in or-
der to use it in other sessions or share it 
with other Pro Tools users, click Save To 

Disk. Enter a name for the template and 
click Save. (Do not change the location of 
DigiGroove template files and folders or 
they will not be available in your sessions.) 

• Click Cancel to cancel without saving the 
template. 

Extract Groove Template dialog

Use folders and subdirectories to organize 
DigiGroove templates. However, be sure 
they are always located in C:\
Program Files\Digidesign\Pro Tools\
Grooves (Windows) or Applications/
Digidesign/Pro Tools/Grooves (Mac). 
Groove template files located elsewhere will 
not be available in either Groove Quantize 
or Beat Detective. 
Pro Tools Reference Guide
Swing Content for Generating 
Groove Templates
When defining swing content of the selection, 
select the Contains eighth-note option if the au-
dio selection has a heavily swung eighth-note 
groove. If the audio selection has relatively 
straight eighth-notes, use the Contains six-
teenth-note option. This lets the resultant Di-
giGroove template be applied more easily else-
where. Although a groove might be based upon 
non-swung eighth-note material, you might 
want to apply the template to material that con-
tains sixteenth-notes. If a template only has 
eighth-note resolution, but the material being 
conformed contains sixteenth-notes, adjacent 
sixteenth-notes will be mapped to the same 
eighth-note location.

Groove Extrapolation
Beat Detective’s ability to extract tempo data 
from a wide range of material is enhanced by its 
powerful “groove extrapolation” logic. Groove 
extrapolation automatically generates beat trig-
gers for inclusion in groove templates even if a 
peak transient is not detected. For example, a 
drum loop might not have a hit on beat 3, conse-
quently no peak transient is detected and no 
beat trigger is generated. Beat Detective will ex-
trapolate from other beat triggers in the selec-
tion and create a trigger for beat 3 in the groove 
template.

In addition, extrapolated triggers preserve the 
feel of triggers generated from detected peak 
transients. For example, if a bar of kick drum 
detected three beat triggers, all of which were 20 
ticks ahead of the beat, any extrapolated beat 
triggers will also be mapped 20 ticks ahead of 
the beat.



Separating Clips with 
Beat Detective 
(Audio Only)

Once beat triggers appear in your selection, they 
can be used to define start and end points for 
new clips that can be separated automatically. 
The new clips can then be conformed to the ses-
sion’s existing tempo map, or to a groove tem-
plate.

If you want to clean up the timing for the selec-
tion, without affecting the tempo, make sure to 
first calculate the tempo by generating Bar|Beat 
Markers (see “Calculating Tempo with Beat De-
tective” on page 658).

To separate clips with Beat Detective:

1  In the Edit window, make an audio selection.

2  In the Beat Detective window, select Clip Sep-

aration.

3  Define or capture the selection as described in 
“Defining a Beat Detective Selection” on 
page 656.

4  Configure the Detection options so the selec-
tion’s peak transients are accurately detected 
(see “Generating Beat Triggers” on page 658).

5  Click Separate. 

Clips are separated based on the detected beat 
triggers.
Trigger Pad

When separating clips, the Beat Detective win-
dow displays an option called Trigger Pad.

Type a value (0–50 ms) in this field to pad clip 
start points—where the point of separation is 
located in relation to the beat trigger (tran-
sient). This creates a space between the clip start 
point and the clip sync point, thereby ensuring 
that the attack portion of the material remains 
intact.

When conforming separated clips, the clip sync 
point determines where the clip is placed (see 
“Sync Points” on page 837). 

Detection settings, Clip Separation mode

Separated clip with 20 ms Trigger Pad

Clip start Sync point 
(point of separation)

20 ms

(beat trigger)
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Separating Multiple Tracks
You can use beat triggers from a single track, or 
subset of tracks, to separate a group of tracks. 

In the following example, the defined selection 
is a drum loop consisting of two bars of 5/4. The 
kick, snare, hi-hat, and overhead microphones 
are recorded to separate tracks.

Analyzing the loop’s kick drum track, with the 
detection Resolution set to Beats, Beat Detective 
places beat triggers at the transients on beats 1 
and 4.

Extending the selection to the snare, hi-hat, and 
overhead microphones tracks, and then per-
forming the separation, results in separated 
clips in each of the drum tracks at the same lo-
cation, based on the beat triggers from the kick 
drum track. 

Kick drum track with beat triggers

Kick drum, snare, hi-hat, and overhead microphones 
tracks with beat triggers
Pro Tools Reference Guide
The separated clips can then be conformed as a 
group.

You can also use Collection mode when working 
with multiple tracks. Collection mode lets you 
analyze and detect triggers on tracks individu-
ally, and if you choose, add only the unique trig-
gers from the current track to the overall collec-
tion. For more information, see “Detection 
(Normal) and Collection Mode” on page 673. 

Conforming Clips with Beat 
Detective 
(Audio Only)

After clips have been separated with Beat Detec-
tive, the clips can then be conformed using one 
of two modes: 

Standard Conform Uses the session’s current 
tempo map (Grid)

Groove Conform Uses groove templates.

Beat Detective will conform any selected clip, 
whether or not it was separated with Beat Detec-
tive. However, in order to successfully conform 
clips with Beat Detective, the clip start points 
must correspond to the start of the material that 
will align with the session’s bars and beats. This 
should generally not be a problem if the clips 
were separated with Beat Detective (rather than 
manually separated or trimmed).



Standard Conform
This is similar to using the Clip > Quantize to Grid 
command, but with one important difference: 
With a single operation, Beat Detective can ad-
just the position of all clips, whether they have a 
straight or swing feel.

To conform clips using Standard Conform:

1  In the Beat Detective window, select Clip Con-

form.

2  Make sure Standard is selected.

3  In the Edit window, if not already selected, se-
lect the separated clips you want to conform. 
Make sure the selection’s start and end points 
fall cleanly on the beat.

4  In the Beat Detective window, define or recap-
ture the selection as described in “Defining a 
Beat Detective Selection” on page 656.

5  To affect how strongly the clips are conformed 
to the Grid (tempo map), select the Strength op-
tion and specify a percentage value with either 
the slider or by typing in a value: 

• Lower percentage values preserve the orig-
inal feel of the clips.

• Higher percentage values align the clips 
more tightly to the tempo map, with 100% 
aligning precisely to the tempo map.

Beat Detective, Standard Conform options

To “tighten up” the original feel while 
retaining it, set the Strength option to 
85–88%.
6  To affect which clips are conformed, select the 
Exclude Within option and specify a percentage 
value with the slider or by typing in a value:

• Lower percentage values ensure that clips 
further away from the Grid are conformed, 
while those closer to the Grid are not.

• Higher percentage values ensure that 
clips closer to the Grid, as well as those fur-
ther away, are conformed.

7  To achieve a swing feel for the conformed 
clips, select the Swing option and whether the 
swing is based on eighth-notes or sixteenth-
notes, then specify a percentage value with the 
slider or by typing in a value:

• Smaller percentage values yield less swing, 
with 0% yielding none.

• Larger percentage values yield more swing, 
with 100% yielding a triplet, swing feel.

• Percentage values between 100–150 move 
the clips beyond a triplet, swing feel, to-
ward the next sixteenth-note boundary 
(provided the Swing note value is set to 
eighth-notes).

To “tighten up” the original feel while 
retaining it, set the Exclude Within option 
to 10–15%.

If Beat Detective has successfully captured 
enough of the sub-beats from a selection be-
fore separating, you can successfully con-
form with the Swing option to change the 
groove from a “straight” feel to one that is 
swung. You can also import a groove tem-
plate containing a swing feel (see “Groove 
Conform” on page 670).
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8  Click Conform to automatically conform all 
clips in the selection.

9  Audition the new conformed clips by clicking 
Play in the Transport. 

10  Do one of the following:

• If necessary, select Edit > Undo, and repeat 
steps 4–8 trying a different set of Conform 
settings.

– or –

• If necessary, apply Edit Smoothing (see 
“Edit Smoothing” on page 671).

Groove Conform
Instead of using a grid based on the session’s 
tempo map, Groove Conform uses a grid based 
on a groove template, or DigiGroove. Di-
giGrooves can be used to apply the feel of a cap-
tured passage to the selected audio clips. For in-
formation about creating DigiGroove templates, 
see “DigiGroove Templates” on page 665.

Clips conformed with Beat Detective
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To conform clips using Groove Conform:

1  In the Beat Detective window, select Clip Con-

form.

2  Select Groove.

3  In the Edit window, if not already selected, se-
lect the separated clips you want to conform. 
Make sure the selection’s start and end points 
fall cleanly on the beat.

4  In the Beat Detective window, define or recap-
ture the selection as described in “Defining a 
Beat Detective Selection” on page 656.

5  From the Groove Template pop-up menu, se-
lect the Groove Clipboard or a saved groove tem-
plate (for information on creating groove 
templates, see “DigiGroove Templates” on 
page 665).

6  To see comments about the selected template, 
click Show Info. 

Beat Detective, Groove Conform options

When using Groove Conform, the captured 
selection must not include Bar|Beat Mark-
ers. Otherwise, the accuracy of the Groove 
Template will be compromised.



7  To affect how strongly the clips are conformed 
to the groove template, select the Timing option 
and specify a percentage value with either the 
slider or by typing in a value: 

• Lower percentage values preserve the orig-
inal feel of the clips.

• Higher percentage values align the clips 
more tightly to the groove templates grid, 
with 100% aligning precisely to the tem-
plate grid.

• If the slider is set to 200%, clips move to a 
location that is twice the difference be-
tween the original clip location and the po-
sition of the referenced template event. 

For example, if a note was played at Bar 1|1|060 
(a 16th note), and the corresponding template 
event is at 1|1|073, a slider value of 100% results 
in the note being shifted to 1|1|073; a slider 
value of 200% shifts the note to 1|1|086. 

8  To conform the material before applying the 
groove template, enable the Pre-Process Using 

Standard Conform option.

With this option enabled, Beat Detective con-
forms clips to the current Standard Conform 
settings before applying the groove template. 
For material in which the performance was not 
accurate, enabling Pre-Process Using Standard 

Conform can lead to better results by ensuring 
that the performance is accurately mapped to 
the correct bars, beats, and sub-beats before the 
groove template is applied. Experimentation is 
the best way to determine when it is appropriate 
to use this option. 

When conforming an audio passage to a 
heavily swung groove template, enabling 
Pre-Process using Standard Conform will 
often yield better results.
9  Click Conform to automatically conform all 
clips in the selection.

10  Audition the new conformed clips by clicking 
Play in the Transport. 

11  Do one of the following:

• If necessary, select Edit > Undo, and repeat 
steps 4–9 trying a different groove template 
or Groove Conform settings.

– or –

• If necessary, apply Edit Smoothing (see 
“Edit Smoothing” on page 671).

Edit Smoothing 
(Audio Only)

After clips are conformed, there may be gaps be-
tween the clips. These gaps can cause the mate-
rial to sound unnatural on playback.

Beat Detective can automatically fill the gaps be-
tween clips, and even add crossfades if you 
choose. The Edit Smoothing option can be used 
with clips that have been conformed, or with a 
track that contains many clips that need to be 
trimmed and crossfaded (such as in a sound ef-
fects track). This automated process of smooth-
ing clip edits can save many hours of tedious ed-
iting.

Beat Detective, Smoothing options
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To use Edit Smoothing on conformed clips:

1  In the Beat Detective window, select Edit 

Smoothing.

2  Select a Smoothing option:

Fill Gaps Select this option to trim clip end 
points so that the gaps between clips are filled.

Fill And Crossfade Select this option to trim clip 
end points and automatically add a pre-fade (in 
ms) directly before each clip start point.

3  In the Edit window, if not already selected, se-
lect the range of conformed audio clips you want 
to smooth. Make sure the selection’s start and 
end points fall cleanly on the beat.

4  Click Smooth to smooth the edits for the se-
lected clips.

5  Audition the results by clicking Play in the 
Transport. 

6  If necessary, select Edit > Undo, and repeat 
steps 2–5 trying a different Crossfade Length.

Edit Smoothing Creates Sync 
Points
After smoothing edits with Beat Detective, sync 
points (corresponding to the material’s start 
point) are automatically created for the con-
formed clips. This allows you to later conform 
the clips to a different tempo map or groove 
template, or use different Conform settings. 

Clips before and after Edit Smoothing
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However, sync points are only created as they 
are needed: If gaps between clips are created 
during Clip Conform, Fill Gaps in Edit Smooth-
ing mode will trim clips to fill the gap and a sync 
point will be created at each clip’s original start 
point. If there is no gap between clips, no sync 
point will be created by Edit Smoothing.

Consolidating Clips after Edit 
Smoothing
The process of separating, conforming, and 
smoothing with Beat Detective can leave tracks 
with many clips and many crossfades. If you are 
working with multiple tracks, the density of 
these edits may lead to system performance 
problems.

Once you are satisfied with the results from Beat 
Detective, it is recommended that you flatten 
the tracks with the Consolidate command. For all 
clips selected, Consolidate creates a single, con-
tiguous audio file to reduce the session’s edit 
density. See “Consolidating Clips” on page 611. 

For more information on clip sync points, 
see “Sync Points” on page 837.

If performance is not an issue, use the Clip 
Group command for easier editing and ma-
nipulation of clips. This can be useful for ar-
ranging beats that were sliced with Beat De-
tective, especially if you plan on changing 
tempos with tick-based audio tracks. For 
more information on clip groups, see “Clip 
Groups” on page 851.

Before consolidating a large selection across 
multiple tracks, make sure there is enough 
RAM available. See “RAM Requirements for 
Beat Detective” on page 654.



Detection (Normal) and 
Collection Mode 
In some instances, it may be difficult for Beat 
Detective to successfully analyze multiple tracks 
with the same Detection settings. With Beat De-
tective’s Collection mode, you can collect a set 
of beat triggers from different tracks, each with 
different Detection settings, and use the collec-
tion of triggers to generate Bar|Beat Markers or 
DigiGroove templates, or separate new clips. 
Collection mode is the only way to analyze and 
create beat triggers on one track, and apply 
them to another track.

This method of selectively adding beat triggers 
from separate analysis passes on different 
tracks, until you get only the triggers you want, 
is potentially much more effective than manu-
ally deleting, inserting, or adjusting incorrect or 
false triggers.

Drum Tracks and Collection 
Mode
Suppose you have drum tracks for kick, snare, 
hi-hat, and overhead mics. If you analyze a se-
lection across all of the tracks, you may get 
many false triggers when you raise the Sensitiv-
ity slider high enough to capture the hi-hat ma-
terial (coming mainly from the tracks for the 
overhead mics). 

However, if you analyze only the track for the 
overhead mics, the resulting beat triggers are 
slightly later than the material on the other 
tracks (since it will take more time for the sound 
to reach the overhead mics). If you then extend 
the selection to the other drum tracks and sepa-
rate them, the clips from the kick, snare, and 
tom tracks will be cut slightly late.

Using Collection mode, you can analyze each 
drum track separately, one at a time, optimizing 
the Detection settings for each track until you 
get the triggers you want. The triggers for each 
track can be added successively to the collec-
tion, or you can choose to collect only the 
unique triggers from a track. The collection of 
triggers that results can then be used to generate 
Bar|Beat Markers or a DigiGroove template, or 
separate new clips.

Using Collection Mode
Collection mode is available in Bar|Beat Marker 
Generation, Groove Template Extraction, or 
Clip Separation mode (audio only), and is ac-
cessed by selecting Collection in the Detection 
pop-up menu.

Overhead mics generate late beat triggers

Beat Detective, Collection mode options
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To use Collection mode:

1  In the Edit window, make an audio selection 
on a single track. Make sure the selection’s start 
and end points fall cleanly on the beat.

2  In the Beat Detective window, select one of the 
following modes:

• Bar|Beat Marker Generation

• Groove Template Extraction 

• Clip Separation (audio only)

3  Define or capture the selection as described in 
“Defining a Beat Detective Selection” on 
page 656.

4  Configure the Detection options so the selec-
tion’s peak transients are accurately detected 
(see “Generating Beat Triggers” on page 658).

5  From the Detection pop-up menu, select Collec-

tion.

6  In the Detection (Collection Mode) section, 
click Add All to add all the current beat triggers 
to the collection. 

7  From the Detection pop-up menu, select Nor-

mal and move the selection to the next track you 
want to analyze. Make sure to keep the selection 
range constant for each track. 

8  Configure the Detection options so the selec-
tion’s peak transients are accurately detected 
(see “Generating Beat Triggers” on page 658).

Press Start+P (Windows) or Control+P 
(Mac) to move the selection up, or 
Start+Semi-colon (Windows) or Con-
trol+Semi-colon (Mac) to move the selec-
tion down.

With Commands Keyboard Focus enabled, 
press “P” to move the selection up, or Semi-
colon (;) to move the selection down. Hold 
down the Shift key to retain and add to the 
current selection
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9  Select Collection again.

10  Do one of the following:

• In the Detection (Collection Mode) section, 
click Add Unique to add only the unique 
triggers from the track to the collection. 
When you choose to add unique triggers, 
Pro Tools looks for triggers that are close to 
triggers already collected from other 
tracks. Where triggers already exist, the 
newly detected triggers are discarded.

• Click Add All to add all triggers to the col-
lection.

• Click Clear All to clear all triggers from the 
collection.

Each new set of triggers added to the collection 
appears in a different color. If successive trig-
gers in the collection are located closely to-
gether (for example, because of microphone 
leakage), Beat Detective keeps only the earlier 
triggers.



Overhead mic track displaying a collection of beat triggers containing unique triggers generated from the kick, 
snare, and hi-hat tracks

1. Beat triggers 
detected in Kick track
added to collection

2. Unique beat triggers 
detected in Snare track
added to collection

3. Unique beat triggers 
detected in Hi-hat track
added to collection

4.Collected beat triggers 
applied to Overhead
microphones track
11  Repeat steps 7–10 for each additional track 
you are analyzing.

The beat triggers stored in the Collection mode 
are saved with sessions. Therefore, when a ses-
sion is opened later, the previous collection ma-
terial is still there (until it is cleared). 

12  Once the beat triggers have been added to the 
collection, you can use them to generate 
Bar|Beat Markers or groove template, or sepa-
rate clips. However, this must be done from the 
Collection Mode section (when the triggers are 
displayed in multiple colors).

To separate clips across multiple tracks, 
make sure to extend the selection to any ad-
ditional tracks before separating.
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Part VI: MIDI





Chapter 32: MIDI Editing
Pro Tools provides powerful MIDI editing tools. 
You can create and edit individual MIDI notes 
and controller events with the Pencil, Trim, and 
Grabber tools in the Edit window, MIDI Editor 
windows (see Chapter 33, “MIDI Editors”), and 
the Score Editor window (Chapter 34, “Score 
Editor”). 

You can use the various Event Operations (such 
as Quantize, Transpose, Change Velocity, and 
Change Duration) to destructively transform 
groups of MIDI notes in terms of pitch, timing, 
dynamics, and phrasing (see Chapter 42, “Event 
Operations”). 

Additionally, you can use Real-Time Properties 
to nondestructively affect MIDI on playback or 
play-through (see “MIDI Real-Time Properties” 
on page 709). 

Pro Tools also provides numerous zoom and 
view tools that are optimized for MIDI editing.

For information on clip-specific editing for 
both MIDI and audio, see Chapter 28, “Ed-
iting Clips and Selections.”
MIDI Editing Options
Pro Tools provides a few options for determin-
ing MIDI editing behavior. These options are 
available in the Edit window, MIDI Editor win-
dows, and the Score Editor window. However, 
these options are only available if there is at 
least one MIDI or Instrument track in your 
Pro Tools session.

Play MIDI Notes When Editing
When enabled, the Play MIDI Notes When Edit-
ing option causes MIDI notes to play (send a 
MIDI Note On message) when editing. 

MIDI Editing Controls in the Edit window

Play MIDI Notes When Editing

Default Note Duration

Default Note On Velocity
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Default Note Duration
The Default Note Duration setting lets you de-
fine the default note duration for inserting notes 
manually. The Edit window, MIDI Editor win-
dows, and Score Editor window can each have a 
different Default Note Duration setting.

To select a Default Note Duration:

1  Click the Default Note Duration setting in the 
Edit window, a MIDI Editor window, or the Score 
Editor window.

2  Select the Default Note Duration value you 
want. (For example, select the 1/4 Note option to 
insert quarter notes with the Pencil tool.)

The Default Note Duration setting updates to 
show the selected note value.

Selecting a Default Note Duration in the Edit window

Default Note Duration, quarter note selected
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3  To define a dotted or triplet duration, do one 
of the following:

• To dot the selected Default Note Duration 
value, click the Default Note Duration set-
ting and select Dotted.

– or –

• To make the selected Default Note Duration 
value a triplet, click the Default Note Dura-
tion setting and select Triplet.

Follow Grid

Select the Follow Grid option to have the Default 
Note Duration follow the selected Grid value. To 
stop following the Grid value, select the rhyth-
mic value for the Default Note Duration setting.

Default Note On Velocity
The Default Note On Velocity setting lets you 
define the default Note On velocity for inserting 
notes manually. The Edit window, MIDI Editor 
windows, and Score Editor window can each 
have a different Default Note On Velocity set-
ting.

To define the Default Note On Velocity, do one of 
the following:

 Click the Default Note On Velocity setting in 
the Edit window, a MIDI Editor window, or the 
Score Editor window and drag up or down.

– or –

 Click the Default Note On Velocity setting in 
the Edit window, a MIDI Editor window, or the 
Score Editor window, type a new number and 
press Enter.

Default Note On Velocity



Mirrored MIDI Editing
Mirrored MIDI Editing lets you edit MIDI clips 
and have your edits apply to every copy of the 
same MIDI clip. This can be particularly useful 
when editing looped MIDI clips.

To enable Mirrored MIDI Editing, do one of the 
following:

 Select Options > Mirror MIDI Editing.

– or –

 Enable the Mirrored MIDI Editing button in 
the Edit window, MIDI Editor window, or Score 
Editor window.

In Mirrored MIDI Editing mode, the Mirrored 
MIDI Editing button flashes Red once as an edit 
is made to alert you that your edit is being ap-
plied to more than one clip.

To disable Mirrored MIDI Editing, do one of the 
following:

 Deselect Options > Mirror MIDI Editing.

– or –

 Disable the Mirrored MIDI Editing button in 
the Edit window, MIDI Editor window, or Score 
Editor window.

Mirrored MIDI Edit button in the Edit window

If Mirrored MIDI Editing mode is disabled, 
and you edit notes of looped clips in Notes 
view, the edit flattens the loop. Similarly ed-
iting clip groups separates the clip groups.
Setting the Grid Value
When inserting MIDI notes with the Pencil tool, 
the Grid value determines the Note On location 
of each note, or other characteristics, based on 
the Pencil tool shape (see “Using the Pencil 
Tool” on page 682). The Edit window, MIDI Ed-
itor windows, and Score Editor window can each 
be set to a different Grid value.

To set the Grid value for MIDI editing:

1  Click the Grid Value selector and select 
Bars|Beats. If the Follow Main Time Scale option 
is enabled you can simply set the Main Time 
Scale to Bars|Beats (see “Setting the Main Time 
Scale” on page 770).

2  Click the Grid Value selector again and select a 
note value (such as 1/4, 1/8, or 1/16).

Selecting the Grid value in the Edit window
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3  To define a dotted or triplet value, do one of 
the following:

• To dot the selected Grid value, click the 
Grid Value selector again and select Dotted.

– or –

• To make the selected Grid value a triplet, 
click the Grid Value selector again and se-
lect Triplet.

4  Verify the default session meter and tempo 
(see “Setting the Session Meter” on page 442 and 
“Setting the Session Tempo” on page 443).

To show (or hide) grid lines in the Edit window or in 
a MIDI Editor window:

 Select (or deselect) the Grid button.

Using the Pencil Tool
The Pencil tool is useful for creating and editing 
MIDI data. The first five Pencil tool shapes (Free 
Hand, Line, Triangle, Square, and Random) can 
be used to create MIDI notes with varying dura-
tions and velocities. In the Edit window MIDI 
Editor windows, and the Score Editor window, 
note velocities are determined by the Pencil tool 
shape). The various Pencil tool shapes can be 
particularly useful for drawing and editing dif-

For more information on Grid mode, see 
“Grid Mode” on page 541.

Grid button selected in the Edit window
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ferent types of MIDI control data—for example, 
try using Line for volume, Triangle for pan, Free 
Hand for pitch bend, and Square or Random for 
velocity.

To select the Pencil tool shape:

1  Click the Pencil tool icon in the Toolbar for the 
Pencil tool shape pop-up menu.

2  Select a Pencil tool shape.

Pencil Tool Shapes for MIDI

Free Hand

In the Edit window on MIDI and Instrument 
tracks in Notes view, in MIDI Editor windows, 
and in the Score Editor, the Free Hand shape in-
serts a single MIDI note whose velocity is de-
fined by the Default Note On Velocity setting. 
The pitch, location, and duration of the note are 
determined by where on the track you click with 
the mouse.

Parabolic and S-Curve Pencil shapes are 
used for drawing tempo events only in the 
Tempo Editor. See “Drawing Tempo Events” 
on page 782.

Pencil tool shapes available for MIDI



When editing MIDI velocities or continuous 
controller data, the Free Hand shape draws 
freely according to the movement of the mouse. 
The shape is reproduced as a series of steps ac-
cording to the Pencil Tool Resolution When 
Drawing Controller Data MIDI preference.

Line

In the Edit window on MIDI and Instrument 
tracks in Notes view, in MIDI Editor windows, 
and in the Score Editor, the Line shape inserts a 
series of MIDI notes on a single pitch whose ve-
locities are defined by the Default Note On Ve-
locity setting. The duration and spacing for the 
inserted notes are determined by the current 
Grid value and the Default Note Duration set-
ting.

When editing MIDI velocities or continuous 
controller data, the Line shape draws in a 
straight line from click to release. MIDI contin-
uous controller values change in steps according 
to the Pencil Tool Resolution When Drawing Con-

troller Data option in the MIDI Preferences page.

Triangle

In the Edit window on MIDI and Instrument 
tracks in Notes view, in MIDI Editor windows, 
and in the Score Editor, the Triangle shape in-
serts a series of MIDI notes on a single pitch 
whose velocities oscillate between the Default 
Note On Velocity setting and 127 according to a 
triangle pattern. The duration and spacing for 
the inserted notes are determined by the current 
Grid value and the Default Note Duration set-
ting.
When editing MIDI velocities or continuous 
controller data, the Triangle shape draws a tri-
angular pattern that changes direction accord-
ing to the current Grid value. MIDI controller 
values change in steps according to the Pencil 

Tool Resolution When Drawing Controller Data op-
tion in the MIDI Preferences page.

Square

In the Edit window on MIDI and Instrument 
tracks in Notes view, in MIDI Editor windows, 
and in the Score Editor, the Square shape inserts 
a series of MIDI notes on a single pitch whose 
velocities alternate between the Default Note On 
Velocity setting and 127. The duration and spac-
ing for the inserted notes are determined by the 
current Grid value and the Default Note Dura-
tion setting.

When editing MIDI velocities or continuous 
controller data, the Square shape draws a square 
pattern that repeats at a rate based on the cur-
rent Grid value.

Random

In the Edit window on MIDI and Instrument 
tracks in Notes view, in MIDI Editor windows, 
and in the Score Editor, the Random shape in-
serts a series of MIDI notes on a single pitch 
whose velocities change randomly within the 
range between the Default Note On Velocity set-
ting and 127. The duration and spacing for the 
inserted notes are determined by the current 
Grid value and the Default Note Duration set-
ting.

When editing MIDI velocities or continuous 
controller data, the Random shape draws a se-
ries of random values that change at a rate based 
on the current Grid value.
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Inserting MIDI Notes
In addition to recording, step recording, and 
importing MIDI into Pro Tools, you can manu-
ally insert MIDI notes using the Pencil tool. 

To insert a MIDI Note On a track in the Edit window:

1  In the Edit window, set the MIDI or Instru-
ment track to Notes view. 

2  Select the Pencil tool and make sure it is set to 
Free Hand. The cursor will change to the Pencil 
tool when located over the playlist area of a 
MIDI or Instrument track in Notes view.

3  To insert quarter notes on the beat, do the fol-
lowing:

• Set the Main Time Scale to Bars|Beats.

• Set the Edit mode to Grid.

• Set the Grid value to quarter notes.

• Set the Default Note Duration value either 
to quarter notes (or to Follow Grid).

4  Move the Pencil tool into the playlist area for 
the MIDI or Instrument track. Use the Edit win-
dow’s ruler and the track’s mini-keyboard as a 
reference to locate the pitch and time location 
you want.

When inserting MIDI notes or other MIDI 
data with the Pencil tool, MIDI clip bound-
aries are created on the nearest barlines.
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When using the Pencil tool, the Cursor location 
and value are displayed in the Window Toolbar.

5  When you reach the pitch and time location 
you want, click to insert the note.

Cursor location and value

MIDI note inserted with the Pencil tool

With the Smart Tool active (see “Using the 
Smart Tool” on page 561), Start-click 
(Windows) or Control-click (Mac) to change 
the cursor to the Pencil tool and insert MIDI 
notes; Option-Control-click (Mac) or 
Alt-Start-click (Mac) to delete notes.

With Grid mode enabled, the start point of 
the MIDI note snaps to the nearest Grid 
boundary by default. With the Free Hand 
Pencil tool, press Control (Windows) or 
Command (Mac) after clicking and holding 
to temporarily suspend Snap to Grid.

Cursor Timeline location

Cursor pitch location
Pencil Cursor



The velocity for inserted notes is determined by 
the Default Note On Velocity setting. The dura-
tion is determined by the Default Note Duration 
value. When in Grid mode, the Note On location 
is determined by the Grid value. 

If the Play MIDI Notes When Editing option is 
enabled, each note sounds as it is inserted.

The Pencil tool can be dragged after clicking 
(and before releasing) to adjust the note’s pitch 
or duration. Drag right to lengthen the note 
without changing its start point. Drag left to 
shorten the note without changing its end point.

Inserting a Series of Notes
In the Edit window and in MIDI Editor windows, 
the Line, Triangle, Square, and Random Pencil 
tool shapes can be used to enter a series of iden-
tical pitches with varying velocities. The dura-
tion and spacing for the inserted notes are de-
termined by the current Grid value and the 
Default Note Duration setting. 

When the Default Note Duration is greater than 
the Grid value, the inserted notes are truncated 
to match the Grid value and not overlap.

Adjusting the duration for an inserted note

With the Grid mode enabled, the end point 
of the MIDI note snaps to the nearest Grid 
boundary by default. Control-drag (Win-
dows) or Command-drag (Mac) with the 
Pencil tool to temporarily suspend Snap to 
Grid.
The note velocities are determined by the Pencil 
tool shape:

• Use the Line shape to enter notes with iden-
tical velocities.

• Use the Triangle shape for a ramp up and 
down of velocities. 

• Use the Square shape for alternating veloc-
ities of loud and soft. 

• Use the Random shape for a series of notes 
with random velocities.

For example, to insert a series of notes with 
random velocities in the Edit window:

1  In the Edit window, set the MIDI or Instru-
ment track to Notes view. 

2  Select the Pencil tool and make sure it is set to 
Random.

3  To insert consecutive quarter notes on the 
beat, do the following:

• Set the Main Time Scale to Bars|Beats.

• Set the Edit mode to Grid.

• Set the Grid value to quarter notes.

• Set the Default Note Duration value either 
to quarter notes (or to Follow Grid).

With these settings, the notes are inserted 
spaced one quarter note apart.

4  Click at the point to insert the first note and 
drag to the right until the number of notes you 
want have been inserted.

Inserting a series of notes with the Pencil tool
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Manually Editing MIDI Notes
All aspects of a MIDI note can be edited in the 
Edit window or in a MIDI Editor window, in-
cluding start and end points, duration, pitch, 
and velocity. The Selector, Grabber, and Pencil 
tools can operate on individual notes or groups 
of notes.

Selecting MIDI Notes
MIDI notes must be selected before they can be 
edited.

To select MIDI notes, do one of the following:

 With the Pencil tool or any Grabber tool, 
Shift-click each note.

 With any Grabber tool, move the cursor to 
where there are no notes (the Marquee appears) 
and click and draw a rectangle around the group 
of notes you want to edit.

When using a Grabber tool, if any portion of the 
rectangle touches a note (either its start or end 
point), the note is included in the selection. 
However, selections made with a Grabber tool 
are object selections and do not include under-
lying controller and automation data for the 
MIDI track.

Selecting notes with a Grabber tool
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 With the Selector tool, drag across a range of 
notes.

When using the Selector tool, a note’s start point 
must be included in order for it to be selected. 
When a MIDI or Instrument track is in Notes or 
Clips view, selections made with the Selector 
tool are range selections and include all under-
lying controller and automation data.

To deselect one or more notes from a selection:

 With the Pencil tool or any Grabber tool, 
Shift-click the notes so they become deselected.

Selecting notes with the Selector tool

With the Selector tool, Alt-click (Windows) 
or Option-click (Mac) to get the Note Selec-
tor tool in the Edit window and MIDI Editor 
windows (the Selector tool always make note 
selections in the Score Editor). The Note 
Selector tool selects all MIDI notes within the 
duration of the selection as objects and does 
not select any other MIDI events (such as 
controller data or program changes).

You can also select notes in the Select/Split 
Notes window. See “Select/Split Notes Com-
mand” on page 931.



Selecting and Auditioning MIDI 
Notes with the Mini-Keyboard
Use the mini-keyboard on MIDI and Instrument 
tracks to select and play notes on that track. You 
can click on the mini-keyboard with any Edit 
tool.

To play a note on a MIDI or Instrument track, and 
select all notes of that pitch on the track:

 With any Edit tool selected, click a key on the 
mini-keyboard.

Playing a note with the mini-keyboard and selecting all 
notes of that pitch

Alt-click (Windows) or Option-click (Mac) 
to play notes without making a selection.

Control-click (Windows) or Command-click 
(Mac) to select or deselect notes, and to 
make noncontiguous selections.
To select and play a range of notes on a MIDI or 
Instrument track:

 With any Edit tool selected, click a key and 
drag up or down on the mini-keyboard.

Selecting Only MIDI Notes Using 
the Note Selector Tool
In Notes or Velocity view on MIDI and Instru-
ment tracks in the Edit window, or in a MIDI Ed-
itor window, the Selector tool makes a time 
range selection that includes all MIDI event 
types in addition to MIDI notes and velocities 
(such as program changes, and continuous con-
troller data). The Note Selector tool can be used 
to select only MIDI notes and velocities in a time 
range selection. 

Playing a range of notes with the mini-keyboard and 
selecting all notes of including those pitches

You can also Shift-click on the mini-keyboard 
to extend or contract the range of notes.
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To select only MIDI notes and velocities with the 
Note Selector tool:

1  Select the Selector tool.

2  On MIDI or Instrument tracks in the Edit win-
dow in Notes or Velocity view, or in a MIDI Edi-
tor window, Alt-drag (Windows) or Option-drag 
(Mac) over the time range that includes the 
notes you want to select.

When using the Smart tool and pressing Alt 
(Windows) or Option (Mac), the Selector is 
available in the upper part of the Track and the 
Note Selector is available in the lower part of the 
track.

Using the Grabber Tools
Use the Grabber tools to select, move, separate, 
and arrange clips on tracks. There are three 
modes for the Grabber tool: Time Grabber, Sep-
aration Grabber, and Object Grabber. For more 
information about arranging clips, also see 
Chapter 38, “Arranging Clips.”

Transposing Notes
MIDI notes can be transposed by dragging them 
up or down with the Pencil tool or any Grabber 
tool. If several notes are selected before drag-
ging, each is transposed.

Selecting only MIDI notes using the Note Selector tool
Pro Tools Reference Guide
To transpose a MIDI note:

1  Set the MIDI or Instrument track to Notes 
view.

2  Select the Pencil tool or any Grabber tool.

3  While pressing Shift, drag the note up or 
down.

The Shift key ensures that the transposed note 
maintains its original start point. 

While dragging, each new note sounds and the 
Cursor Location Value indicator (in the Edit 
window) indicates the number of semitones and 
direction (+/–) for the transposition.

Transposing with a Grabber tool

Press and hold Control (Mac) or Start (Win-
dows), and then press Plus (+) on the nu-
meric keypad transpose the selected MIDI 
notes up by one semitone or press Minus (–) 
on the numeric keypad transpose the se-
lected MIDI notes down by one semitone.

To transpose a copy of the note, leaving the 
original unchanged, press Alt (Windows) or 
Option (Mac) while dragging.

MIDI notes can also be transposed using the 
Transpose Event Operation (see “Trans-
pose” on page 929) or MIDI Real-Time 
Properties (see “MIDI Real-Time Proper-
ties” on page 709). 



Moving Notes
Like clips, MIDI notes can be dragged left or 
right with the Pencil tool or any Grabber tool to 
change their start point. If several notes are se-
lected before dragging, they are all moved to-
gether.

To move a MIDI note:

1  Set the MIDI or Instrument track to Notes 
view.

2  With the Pencil tool or any Grabber tool, drag 
the note left or right (press Shift while dragging 
to preserve the note’s pitch).

As the note is dragged, the Cursor Location 
Value indicator (in the Edit window) displays 
the new start point.

If the Edit mode is set to Grid, the dragged note 
snaps to the nearest Grid boundary. If the Edit 
mode is set to Spot, the Spot dialog opens.

Trimming Note Start and End 
Times
Like clips, start and end points for MIDI notes 
can be adjusted with the Trim tool. If several 
notes are selected when performing the trim, 
each note is changed.

To copy the selected notes, leaving the orig-
inals intact, press Alt (Windows) or Option 
(Mac) while dragging.

The placement of MIDI notes can also be ad-
justed with Shift (see “Shift Command” on 
page 838) or Nudge (see “Nudging Clips” on 
page 598).

The Trim tool can also be used on MIDI 
clips. For more informations, see “Time 
Compression/ Expansion Trim Tool Func-
tionality on MIDI Clips” on page 695.
To change the start or end points for a group of 
MIDI notes:

1  Set the MIDI or Instrument track to Notes 
view.

2  Using the Pencil tool or any Grabber tool, 
Shift-click each note you want to trim.

3  Do one of the following:

• Select the Trim tool. 

– or –

• Use the Pencil tool.

4  Move the cursor near the beginning of any of 
the highlighted notes, so the Trim tool appears. 
Drag right to shorten the notes, or drag left to 
lengthen them.

If the Edit mode is set to Grid, the dragged start 
or end point snaps to the nearest Grid boundary. 
If the Edit mode is set to Spot, the Spot dialog 
opens, where you can enter the new location for 
the note’s start or end point.

Notes can also be trimmed with the Trim Clip to 

Selection command (see “Trim to Selection 
Command” on page 596) and the Trim To Inser-

tion command (see “Trimming with Nudge” on 
page 598).

Changing note end times with the Trim tool

When in Grid mode, use the Control key 
(Windows) or the Command key (Mac) to 
temporarily disable Grid mode.
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Trimming MIDI Notes with 
Nudge
You can trim the start and end points of selected 
MIDI notes by the current Nudge value.

To trim the selected MIDI notes start or end points 
by the Nudge value:

1  Configure the Nudge value (see “Defining the 
Nudge Value” on page 599).

2  With the Time Grabber tool, select the MIDI 
notes you want to trim.

3  Do one of the following:

• While pressing Alt (Windows) or Option 
(Mac), press Plus (+) or Minus (–) on the 
numeric keypad to trim the start point of 
the selected MIDI notes by the Nudge value.

– or –

• While pressing Control (Windows) or Com-
mand (Mac), press Plus (+) or Minus (–) on 
the numeric keypad to trim the numeric 
keypad to trim the end point of the selected 
MIDI notes by the Nudge value.

Transposing MIDI Notes with 
Nudge
You can transpose selected MIDI notes by semi-
tonal increments using Plus (+) or Minus (–) on 
the numeric keypad.

To transpose the selected MIDI notes by 
semitones:

1  With the Time Grabber tool, select the MIDI 
notes you want to transpose.
Pro Tools Reference Guide
2  Do one of the following:

• While pressing Start (Windows) or Control 
(Mac), press Plus (+) on the numeric key-
pad transpose the selected MIDI notes up 
by one semitone.

– or –

• While pressing Start (Windows) or Control 
(Mac), press Minus (–) on the numeric key-
pad transpose the selected MIDI notes 
down by one semitone.

Separating MIDI Notes
The Separate command lets you separate MIDI 
notes at the Edit cursor location or at the bound-
aries of the Edit selection. When in Notes view 
in the Edit window and in MIDI Editor windows, 
separating MIDI clips creates new MIDI notes 
but does not create new MIDI clips. However, 
when in Clips view in the Edit window, separat-
ing MIDI clips only creates new MIDI clips. 
Also, if the Edit selection includes any audio 
tracks, the Separate command separates only 
clips on MIDI and Instrument tracks regardless 
of the Track View setting.

To separate MIDI notes at the Edit cursor location 
or at the boundaries of the Edit selection:

1  Make an Edit selection or place the Edit cursor 
at the location where you want to separate one or 
more MIDI notes.

2  Do one of the following:

• Choose Edit > Separate > At Selection.

– or –

• Right-click in the Notes pane and choose 
Separate.

Press Control+E (Windows) or 
Command+E (Mac) to separate MIDI notes 
at the selection.



To separate MIDI notes on the grid:

1  Set the Grid value.

2  Make an Edit selection or a marquee selection 
that includes the MIDI notes you want to sepa-
rate.

3  Choose Edit > Separate > On Grid.

4  In the Pre-Separate Amount dialog, click OK.

Separate and Consolidate Tools 
for MIDI Notes
In Notes view in the Edit window and in MIDI 
Editor windows, both the Pencil and Grabber 
tools can be used to separate MIDI notes and to 
consolidate MIDI notes. 

The cursor updates to show a “knife” for the 
Separate tool and a “bandage” for the Consoli-
date tool.

To separate a MIDI note with the Separation tool:

 With the Grabber or Pencil tool, Start-Shift-
click (Windows) or Control-Shift-click (Mac) on 
the MIDI note at the location where you want the 
separation.

MIDI note separated into two using the Separate Tool
To consolidate MIDI notes with the Consolidate 
tool:

 With the Grabber or Pencil tool, Start-Shift-
click (Windows) or Control-Shift-click (Mac) 
between the separated MIDI notes.

Consolidating MIDI Notes
The Consolidate command lets you combine two 
or more consecutive MIDI notes of the same 
pitch into a single MIDI note.

To consolidate MIDI notes:

1  Select the MIDI notes you want to consolidate.

2  Do one of the following:

• Choose Edit > Consolidate.

– or –

• Right-click the selected notes and choose 
Consolidate.

Muting MIDI Notes
The Mute command lets you mute individual 
MIDI notes. If entire clips are selected, the Mute 
command prompts you to either mute clips or 
MIDI notes.

Consolidating MIDI notes into one using the 
Consolidate Tool

Press Alt+Shift+3 (Windows) or 
Option+Shift+3 (Mac) to consolidate adja-
cent selected MIDI notes of the same pitch.
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To mute one or more MIDI notes:

1  Select the MIDI notes you want to mute.

2  Do one of the following:

• Choose Edit > Mute Notes.

– or –

• Right-click the selected MIDI notes and 
choose Mute Notes.

To unmute one or more MIDI notes:

1  Select the MIDI notes you want to unmute.

2  Do one of the following:

• Choose Edit > Unmute Notes.

– or –

• Right-click the selected MIDI notes and 
choose Unmute Notes.

Manually Editing Note Velocities
When a MIDI or Instrument track is set to Ve-
locity view, or when the Velocity lane is revealed 
under a track, each note’s attack velocity is rep-
resented with a velocity stalk. The taller the ve-
locity stalk, the higher the velocity value 
(0–127).

To edit MIDI velocity in the Edit window:

1  Do one of the following:

• Set the MIDI or Instrument track to Veloc-
ity view.

– or –

Press Control+M (Windows) or 
Command+M (Mac) to mute and unmute 
selected MIDI notes.
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• Reveal the Controller lane for the MIDI or 
Instrument track and show Velocity.

2  Select any Grabber tool.

3  Drag the top (diamond) of the velocity stalk up 
or down.

Revealing the Velocity Lane

Dragging a velocity stalk



The velocities for a range of notes can be edited 
with any Pencil tool.

To draw velocity values for a crescendo:

1  Do one of the following:

• Set the MIDI or Instrument track to Veloc-
ity view.

– or –

• Reveal the Controller lane for the MIDI or 
Instrument track and show Velocity.

2  Select the Pencil tool with the shape set to 
Line.

3  Click at the beginning of the note range, near 
the bottom of the velocity range, and drag to the 
right and up until the line encompasses the 
range of notes you want to include in the fade.

You can also use the Trim tool to scale the veloc-
ities for all selected notes. This is useful if you 
like the velocity relationship between the notes, 
but want them all to be louder or softer.

Changing velocities with the Line shape

When in Velocity view, the Trim tool can be 
used to trim note durations in 
addition to changing velocities.
To scale velocities with the Trim tool:

1  Set the MIDI or Instrument track to Velocity 
view.

2  Using the Selector tool or any Grabber tool, se-
lect the range of notes to be edited.

3  With the Trim tool, click near the range of se-
lected notes and drag up or down. Dragging up 
increases the velocities for each note and drag-
ging down decreases them.

Velocity Trim Tool

To trim the velocity of one or more selected MIDI 
notes:

 With the Grabber tool selected, Control-click 
(Windows) or Command-click (Mac) the note 
and drag up or down. Notice that the Grabber 
tool changes to the Velocity Trim tool.

Changing velocities with the Trim tool

Editing simultaneous velocities
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Drag up to increase the velocity value, or down 
to decrease it. While dragging, the diamond 
turns blue and the associated note becomes se-
lected. The dragged velocity values are reflected 
in the Cursor Location Value indicator (in the 
Edit window).

Auditioning Velocity Changes
If the Play MIDI Notes When Editing option is 
enabled, Pro Tools plays the note at the new ve-
locity when editing velocities for MIDI notes 
with the Grabber tool. This lets you hear when 
you have the velocity setting you want for a 
MIDI note.

Typing in Note Attributes
When an individual note is selected with the 
Pencil tool or any Grabber tool, its attributes are 
displayed in the Event Edit area.

Pitch is listed by note name and octave number. 
Attack and release velocities are listed with their 
MIDI values (0–127). Edit Selection Start, End, 
and Length times are displayed in the Main 
Time Scale.

If two notes have the same start time (with 
velocity stalks on top of each other), Con-
trol-drag (Windows) or Command-drag 
(Mac) the actual note up or down to adjust 
its velocity.

Event Edit Area showing MIDI track information 

Pitch
Attack Velocity

Release Velocity
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To change an attribute for a MIDI note:

1  In the Edit window, with a MIDI or Instrument 
track set to Notes View, select the note with the 
Pencil tool or any Grabber tool.

2  Click in the Attributes text box and do one of 
the following:

• Enter the new value on the numeric keypad.

• Press the Up or Down Arrow to increment 
or decrement to the new value.

• Drag up or down to scroll to the new value. 

• Play the new note value on your MIDI key-
board controller.

Press Forward Slash (/) to move between the 
fields in the Event Edit area.

Multiple Notes and Event Edit 
Area
When multiple notes are selected, you can enter 
values in the Event Edit area fields to affect all 
selected notes. A triangle (delta symbol) to the 
left of the displayed note indicates that multiple 
notes are selected.

A new value in the Start field moves the first 
note in the selection to that location, with all 
other notes moving with it.

You can also change attributes of MIDI 
notes in the MIDI Event List (see 
Chapter 35, “MIDI Event List”).

Multiple notes in the Event Edit area



Values entered in the pitch and velocity fields 
add to or subtract from the values for all se-
lected notes. For example, to transpose all se-
lected notes down an octave, enter a value of –12 
for pitch.

Deleting MIDI Notes
In addition to deleting selected notes with the 
Clear command in the Edit menu, individual 
notes can also be deleted with the Pencil tool.

To delete a group of MIDI notes with the Clear 
command:

1  Using the Grabber or Selector tool, select the 
notes to be deleted (see “Selecting MIDI Notes” 
on page 686).

2  Do one of the following:

• Choose Edit > Clear to delete the selected 
notes. The track’s underlying controller 
data remains intact.

• With any Edit tool, Right-click any selected 
note and choose Clear.

• Press the Backspace (Windows) or Delete 
(Mac) key.

When deleting MIDI notes within a time 
range selection, all underlying controller 
and automation data is also deleted.
To delete a single MIDI note with the Pencil tool:

 With the Pencil tool selected, Alt-click (Win-
dows) or Option-click (Mac) the note. The Pencil 
tool changes to an Eraser when Alt (Windows) or 
Option (Mac) is pressed.

Time Compression/
Expansion Trim Tool 
Functionality on MIDI Clips
The Time Compression/Expansion Trim tool is 
useful for matching a MIDI clip to the length of 
another clip, a tempo grid, or any other refer-
ence point.

Deleting a note with Pencil tool

Program change events and Sysex events can 
also be deleted by Alt-clicking 
(Windows) or Option-clicking (Mac) them 
with the Pencil tool.
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With the Time Compression/Expansion Trim 
tool, you can move the MIDI clip’s start or end 
point to expand or compress the clip, scaling the 
MIDI data accordingly regardless of the track’s 
timebase (ticks or samples).

Using the Time Compression/
Expansion Trim Tool in Grid 
Mode
The Time Compression/Expansion Trim tool 
(TCE Trim tool) can be used in Grid mode to 
match a clip to the tempo of a session or a sec-
tion of a session, or to create “double time” or 
“half time” performances.

To compress or expand MIDI clips in Grid mode:

1  Set the Edit mode to Grid.

2  If necessary, set the MIDI or Instrument track 
to Clips view.

3  Select the TCE Trim tool.

4  With the TCE Trim tool, drag the MIDI clip’s 
start or end point to compress or expand the clip 
to the Grid (for example, by quarter notes). A 
new MIDI clip is automatically created, and ap-
pears both in the playlist and in the Clip List.

Before trimming a MIDI clip with the Time 
Compression/Expansion Trim tool

After trimming a MIDI clip with the Time 
Compression/Expansion Trim tool
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Using the Time Compression/
Expansion Trim Tool in Slip 
Mode

To compress or expand MIDI clips in Slip mode:

1  Set the Edit mode to Slip.

2  Set the MIDI or Instrument track to Clips view.

3  Select the TCE Trim tool.

4  With the TCE Trim tool, drag the MIDI clip’s 
start or end point to compress or expand the clip 
freely A new MIDI clip is automatically created, 
and appears both in the playlist and in the Clip 
List.

Using the Time Compression/
Expansion Trim Tool in Spot 
Mode
In Spot mode, clicking with the TCE Trim tool in 
a clip opens the Spot dialog. You can specify the 
location where you want the clip to start or end, 
or the duration of the clip, and the clip is auto-
matically compressed or expanded as specified.

To compress or expand MIDI clips in Spot mode:

1  Set the Edit mode to Spot.

2  Set the MIDI or Instrument track to Clips view.

3  Select the TCE Trim tool.

4  Click the MIDI clip near its start or end point. 
The Spot dialog opens. Using any Time Scale, en-
ter a new start or end time (or duration) for the 
clip, and then click OK. A new MIDI clip is auto-
matically created, and appears both in the play-
list and in the Clip List.



Using the Time Compression/
Expansion Trim Tool in Shuffle 
Mode
In Shuffle mode, the trimmed clip will always 
begin at the original clip’s start point regardless 
of whether you trim from the front to the rear or 
from the rear to the front.

To compress or expand MIDI clips in Shuffle mode:

1  Set the Edit mode to Shuffle.

2  Set the MIDI or Instrument track to Clips view.

3  Select TCE Trim tool.

4  With the Time Compression/Expansion Trim 
tool, drag the MIDI clip’s start or end point to 
compress or expand the clip freely. A new MIDI 
clip is automatically created, and appears both 
in the playlist and in the Clip List.

Continuous Controller Events
Continuous controller events for MIDI and In-
strument tracks are displayed in the form of a 
line graph with a series of editable breakpoints. 
Controller events for MIDI and Instrument 
tracks differ from automation data for audio 
tracks in that the breakpoints are stepped (in-
stead of vector-based), where each breakpoint 
represents a single controller event. 
To show MIDI Controller data for a track, do one of 
the following:

 Select the corresponding Track View from the 
Track View menu.

– or –

 Reveal the corresponding MIDI Controller 
lane under the track.

Continuous controller events that can be in-
serted and edited in Pro Tools include:

• volume

• pan

• pitch bend

• aftertouch (mono)

• MIDI controllers, 0–127

Instrument track displaying MIDI Volume events in 
MIDI Volume view

Instrument track displaying MIDI Volume lane

Polyphonic aftertouch cannot be viewed in 
the Edit window. To view polyphonic after-
touch in Pro Tools, use the MIDI Event List 
(see Chapter 35, “MIDI Event List”).

Reveal Controller lanes
Controller Type selector
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MIDI controller #7 (volume) and #10 (pan) are 
treated by Pro Tools as automation data. This 
means that these controller events (along with 
Mutes) can be recorded and automated from the 
Mix window; in addition, each MIDI or Instru-
ment track’s automation mode affects how these 
events are played back and recorded. While a 
MIDI track’s volume, pan, and mute events can 
be suspended, all other controller events in the 
track always play. Instrument tracks support 
both MIDI volume, pan, and mute, and audio 
volume, pan, and mute.

To avoid overwriting existing MIDI volume and 
pan automation data, record in MIDI Merge 
mode. When recording in MIDI Merge mode, ex-
isting volume and pan data play back while re-
cording new MIDI data. 

Continuous controller events (including volume 
and pan) can be recorded from an external MIDI 
controller (such as a keyboard or control sur-
face), and they can be inserted in a MIDI track’s 
playlist using the Pencil tool or any Grabber 
tool.

Inserting and Editing Controller 
Events
Continuous controller events can b edited with 
any of the following methods:

 Individual breakpoints can be dragged with 
any Grabber tool to adjust their location or 
value.

 A group of selected breakpoints can be scaled 
up or down with any of the Trim tools.

 New controller events can be drawn in with 
the Pencil tool to replace existing events. Events 
can be drawn with the Pencil tool (set to Free 
Hand, Line, Triangle, Square, or Random).

 Controller events can be cut or copied and 
pasted, as well as nudged or shifted.
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Setting Resolution for Inserted 
Controller Events
When inserting controller events with the Pencil 
tool, the density of the events is determined by 
the Pencil Tool Resolution When Drawing Control-

ler Data setting in the MIDI Preferences page.

To set the Pencil tool resolution:

1  Choose Setup > Preferences, then click the 
MIDI tab.

2  Type a value (1 to 100 milliseconds) for Pencil 

Tool Resolution When Drawing Controller Data. 

3  Click OK.

To copy continuous MIDI controller events 
and paste to a different MIDI controller, use 
Special Paste (Edit > Paste Special > To 
Current Automation Type). For example, 
you might want to use the same control data 
for volume and a cut-off filter, or for pan 
and pitch bend. For more information, see 
“Special Paste Function for Automation 
Data” on page 1056.

Edits to volume data affect all tracks within 
an enabled Edit Group. This is not the case, 
however, for other controller playlists (such 
as pan). To insert and edit other controller 
types across all tracks in an Edit Group, 
press the Start key (Windows) or Control 
(Mac) while performing the edits.



To edit a continuous controller event with the 
Pencil tool, the controller first has to be added 
to the Automated MIDI Controllers list.

To manually enable a continuous controller for 
automation: 

1  Do one of the following:

• Click the Track View selector for the MIDI 
or Instrument track you want to edit, and 
select Add/Remove Controller from the 
controllers submenu.

– or –

• If Controller lanes are revealed under the 
MIDI or Instrument track you want to edit, 
click the Controller Type selector for the 
Controller lane under the track and select 
Add/Remove Controller from the control-
lers submenu.

The controller is automatically added to the 
Automated MIDI Controllers list when you 
record controller information from an ex-
ternal device.

Selecting Add/Remove Controllers from the Track 
View selector
2  In the Automated MIDI Controllers dialog, se-
lect the MIDI Controllers range for the control-
ler you want to automate. 

3  Select the controller that you want to automate 
from the list on the left, and click Add. The se-
lected controller is added to the Automated 
MIDI Controllers list on the right.

Selecting Add/Remove Controllers from the Controller 
Type selector on a Controller lane

Selecting the MIDI Controllers range
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4  Repeat steps 2 and 3 as necessary until you 
have added all of the MIDI controllers you want 
for automation.

5  To remove a controller from the Automated 
MIDI Controllers list, select it in the list on the 
Right and click Remove.

6  Click OK to close the Automated MIDI Con-
troller dialog.

Patch Select (Program and 
Bank Changes)
Each MIDI and Instrument track can have a de-
fault program change that is sent each time the 
track plays. Additional program changes can be 
inserted at any point within the track.

Automated MIDI Controllers dialog

When you record continuous controller in-
formation from an external MIDI device, 
the controller is automatically added to the 
MIDI Controllers list.

Program changes are sent to external MIDI 
devices. Instrument plug-ins in Pro Tools do 
not respond to program change informa-
tion.
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About Program and Bank 
Changes
The MIDI protocol lets you choose from a range 
of 128 programs (0–127). However, most MIDI 
instruments have several banks of 128 pro-
grams. To specify a bank, a bank select message 
must be sent. Some instruments use Controller 0 
to switch the bank while others use Controller 
32; some use a combination of the two. The 
Patch Select dialog in Pro Tools lets you use ei-
ther of these bank select messages when insert-
ing a program change event. Check the manufac-
turer’s documentation for your MIDI device to 
see which Controller value it uses.

Default Program Change
The default program change for each MIDI track 
is specified by clicking on the Patch Select but-
ton, from either the Mix or Edit window. Once 
specified, the default program change message 
is sent to your instrument when playing the 
track.

If you do not know what bank select com-
mand your instrument uses, you can record 
MIDI to Pro Tools while making a bank 
change from the instrument. Then review 
the bank select information your instrument 
has recorded into Pro Tools in the MIDI 
Event List.

Some older MIDI devices (such as the Kurz-
weil K1000) use a program change instead 
of a Bank Select message to switch banks. 
For these devices you may find it necessary 
to send two program change messages to ac-
cess a particular program, where the first 
sets the bank and the second sets the pro-
gram.



To set the default program change for a MIDI or 
Instrument track:

1  From the Mix or Edit window, click the Patch 
Select button.

2  Do one of the following:

• In the Patch Select dialog, select a program 
number.

– or –

• If you are using patch name files, select a 
patch name (see “MIDI Patch Names” on 
page 701).

3  Click Done.

Patch Select buttons

Patch Select dialog
Once selected, the program number (or patch 
name) appears in the Patch Select button in the 
Edit window.

Unlike recorded and inserted program change 
events, the default program change does not ap-
pear in the track’s playlist.

To clear the default program change, select 
None in the Patch Select dialog.

MIDI Patch Names
Pro Tools supports XML (Extensible Markup 
Language) for storing and importing patch 
names for external MIDI devices (such as MIDI 
instruments). Pro Tools installs MIDI patch 
name files (.midnam) for the factory default 
patch names of many common MIDI devices.

Patch name files are sorted by manufacturer and 
are located:

• On Windows, in Program Files\Common 
Files\Digidesign\MIDI Patch Names\ 
Digidesign

• On Mac, in /Library/Audio/ MIDI Patch 
Names/Digidesign

On Mac, these files reside in /Library/Audio/
MIDI Patch Names/Avid. 

Patch Select button, Edit window

MIDI patch name files (.midnam) can be ed-
ited in any text editor, or you can use third-
party patch librarian and editor software to 
create your own custom patch names.
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On Windows, these files reside in Program Files\ 
Common Files\Avid\MIDI Patch Names\ 
Digidesign.

To import MIDI patch names into Pro Tools:

1  Choose Setup > MIDI > MIDI Studio.

2  Do one of the following depending on your 
computer platform:

• On Mac, verify the MIDI Device name in 
the MIDI Studio window (see “MIDI Studio 
Setup (Mac)” on page 151).

– or –

• On Windows, verify the MIDI Device name 
in the MIDI Studio Setup window (see 
“MIDI Studio Setup (Windows)” on 
page 154).

3  Verify the Instrument or MIDI track output is 
correctly assigned to the MIDI device.

4  Click the Instrument or MIDI track Patch Se-
lect button.

For information on configuring MIDI on 
Windows and Mac systems, see Chapter 10, 
“Configuring MIDI.”

Patch Select button, Edit window

Patch Select button, Mix window
Pro Tools Reference Guide
5  In the Patch Select dialog, click Change.

6  In the Open dialog, do one of the following de-
pending on your computer platform:

• On Mac, navigate to /Library/Audio/MIDI 
Patch Names/Digidesign/<name of manu-
facturer>, and select the MIDI Patch Name 
file (.midnam) for the MIDI device.

– or –

• On Windows, navigate to Program 
Files\Common Files\Digidesign\MIDI 
Patch Names\Digidesign\<name of manu-
facturer>, and select the MIDI Patch Name 
file (.midnam) for the MIDI device.

7  Select the MIDI Patch Name file (.midnam) for 
the MIDI device.

Patch Select dialog

Change button



8  Click Open. The Patch Select dialog is popu-
lated by patch names from the selected file.

9  For MIDI devices that have multiple banks of 
patches, select which bank of patches you want 
from the Bank pop-up menu.

Once patch names have been imported into 
Pro Tools, they are available for that MIDI de-
vice in all sessions.

To clear patch names:

1  In the Patch Select dialog, click the Clear but-
ton.

2  Click Done.

Patch Select dialog with patch names

Choosing a bank in Patch Select dialog
Inserting and Editing Program 
Changes
Program changes can be inserted into a track’s 
playlist with the Pencil tool. Existing program 
changes can be edited, moved, and copied and 
pasted.

To insert a program change with the Pencil tool:

1  Do one of the following: 

• Set the MIDI or Instrument track to Pro-
gram Change view.

– or –

• Reveal the Controller lane for the MIDI or 
Instrument track and show Program 
Change.

2  If you want the inserted event to snap to a Grid 
value, enable Grid mode. 

3  Click with the Pencil tool in the track’s playlist 
at the point where you want to insert the pro-
gram change.

4  In the Patch Select dialog, select a program 
number (or patch name) and, if necessary, spec-
ify a bank change value.

5  Click Done to insert the program change event 
in the track’s playlist.

On some instruments, changing programs 
during playback can interrupt playback. To 
avoid this, place program change events in 
the track where there are no notes sounding.

Program change event
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To edit a program change event:

1  With the Pencil tool or any Grabber tool, dou-
ble-click the program change event you want to 
edit.

2  In the Patch Select dialog, select the new pro-
gram number, or name and specify a bank 
change value (if necessary).

3  Click Done.

To move a program change event:

 With the Pencil tool or any Grabber tool, drag 
the program change event left or right.

If the Edit mode is set to Grid, the dragged event 
snaps to the nearest Grid boundary. If the Edit 
mode is set to Spot, the Spot dialog opens.

To delete a program change event:

1  With the Track View or Controller lane set to 
Program Change view, click the program change 
event with any Grabber tool to select it.

2  Do one of the following:

• Choose Edit > Clear to remove the selected 
events from the track.

– or –

• Press the Backspace (Windows) or Delete 
(Mac).

The placement of program changes can also 
be adjusted with Shift (see “Shift Com-
mand” on page 838) or Nudge (see “Nudg-
ing Clips” on page 598).

If the clip contains other events you want to 
delete, you can delete the clip and the Pro-
gram Change event will also be deleted.

Individual program change events can also 
be deleted by Alt-clicking (Windows) or 
Option-clicking (Mac) them with the Pencil 
tool.
Pro Tools Reference Guide
Auditioning Programs
When the Patch Select dialog is open, Pro Tools 
can automatically scroll through the different 
patches for a track’s assigned MIDI device.

To audition patches:

1  If you want to audition patches for a MIDI 
track or Instrument during playback, click Play 
in the Transport.

2  Open the Patch Select dialog by clicking the 
Patch Select button, or by inserting or editing a 
program change event in a MIDI or Instrument 
track.

3  Click a program number (or patch name)—the 
starting point from which you will scroll 
through the patches.

4  Type a value for the number of seconds that 
will elapse between each program change.

5  Select the Increment Patch option.

After the specified number of seconds, 
Pro Tools selects the next patch and transmits 
the program change to the track’s assigned MIDI 
output.

6  When you are finished auditioning settings, 
deselect the Increment Patch option and select 
the program number (or patch name) you want 
and click Done.



System Exclusive Events
System Exclusive (Sysex) events can be recorded 
to MIDI or Instrument tracks in Pro Tools (see 
“MIDI Step Input” on page 494). Once the 
events are recorded, they appear in the track’s 
playlist as blocks when the Track View is set to 
Sysex or a Controller lane set to Sysex is shown.

While the contents of recorded System Exclusive 
events cannot be directly edited in Pro Tools, 
the events can be moved or nudged, copied and 
pasted, or deleted.

To record a Sysex event:

1  Create a new MIDI track.

2  Set the MIDI track Input to the MIDI port to 
which your MIDI device is connected.

3  Configure your MIDI device to send Sysex 
(such as a bulk dump).

4  Start recording in the Transport.

5  Start the Sysex transfer from your MIDI de-
vice.

6  When the Sysex transfer from your MIDI de-
vice is complete, click Stop in the Transport.

Sysex event block, Sysex view shown

To begin recording the Sysex transfer from 
your MIDI device at the Timeline insertion 
point, enable Wait For Note.
To move a Sysex event:

1  Do one of the following: 

• Set the MIDI or Instrument track to Sysex 
view.

– or –

• Reveal the Controller lane for the MIDI or 
Instrument track and show Sysex.

2  With any Grabber tool, drag the Sysex event 
left or right.

If the Edit mode is set to Grid, the dragged event 
snaps to the nearest Grid boundary. If the Edit 
mode is set to Spot, the Spot dialog opens.

To delete one or more Sysex events:

1  Do one of the following: 

• Set the MIDI or Instrument track to Sysex 
view.

– or –

• Reveal the Controller lane for the MIDI or 
Instrument track and show Sysex.

2  Do one of the following:

• Choose Edit > Clear to remove the selected 
events from the track.

– or –

• Press the Backspace (Windows) or Delete 
(Mac).

The placement of Sysex event blocks can 
also be adjusted with Shift (see “Shift Com-
mand” on page 838) or Nudge (see “Nudg-
ing Clips” on page 598).

Individual Sysex event blocks can also 
be deleted by Alt-clicking (Windows) or 
Option-clicking (Mac) them with the 
Pencil tool.
Chapter 32: MIDI Editing 705



706
Note and Controller Chasing

Note Chasing
Note Chasing allows long, sustained MIDI notes 
to be heard when playing from a point after their 
start time. For example, if a note’s start time is 
at 1|1|000 and lasts for 8 measures (until 
9|1|000), note chasing lets you begin playing 
from bar 5 and still hear the note that started at 
1|1|000 as it continues to sustain until 9|1|000.

Note Chasing is an option that can turned on and 
off individually for each MIDI or Instrument 
track. By default, new MIDI and Instrument 
tracks have Note Chasing enabled.

To enable Note Chasing for a MIDI track:

 Click the track’s Playlist selector and select the 
Note Chasing option.

Make sure to disable Note Chasing when work-
ing with samplers that are playing loops. If a 
MIDI track, for example, is triggering a 4-bar 
drum loop and you begin playing at bar 3, the 
loop will begin playing at the wrong time and be 
out of synchronization with the other tracks. 

Note Chasing enabled in Playlist selector
Pro Tools Reference Guide
Controller and Program Chasing
Pro Tools always chases continuous controller 
events and program changes for MIDI tracks. 
This ensures that controller values and patches 
for MIDI devices are always set correctly.

For example, suppose a MIDI track lasting 32 
measures starts with a MIDI volume of 127 and 
in the last bar fades down to 0. If after playing 
the track in its entirety you attempt to play from 
bar 8, the initial MIDI volume of 127 is chased 
and sent to the track’s assigned device—other-
wise the track would not be heard since the most 
recent volume event sent would have been 0.

Chasing also occurs for a MIDI track’s default 
program change, along with any program 
change events residing within the track. There-
fore, if you have chosen a default program 
change for a track, when playing from any point 
within the track, the program change event is 
sent to the track’s assigned device.

Default Controller Values and 
Chasing
Though new MIDI tracks appear to have default 
values for continuous controller playlists, this is 
actually not the case. For example, when viewing 
a MIDI track’s Mod Wheel playlist, you’ll see 
that the breakpoint line is set to a default of 
zero. However, since the modulation wheel on 
your MIDI controller may be purposely set to a 
different value, the default value in the track is 
not transmitted when playing.

For example, if you record Mod Wheel automa-
tion that changes from 0–90 towards the end of 
the track, and you then play from the beginning 
of the track, or from anywhere before the 
change, having the Mod Wheel value remains at 
90 until the 0 value is reached is not likely to be 
what you want.



To ensure that the default controller value for a 
playlist is sent (and chased), click the initial 
breakpoint at the beginning of the track, move it 
slightly, and set it back to the default value.

Offsetting MIDI Tracks
Pro Tools can offset MIDI tracks globally or in-
dividually.

Global MIDI Playback Offset
Pro Tools provides a preference for MIDI offset 
that lets MIDI and Instrument tracks play back 
earlier or later (than audio tracks) by the speci-
fied number of samples. The offset affects play-
back only and does not alter in any way how 
MIDI data is displayed in the Edit window.

This capability is provided in large part to com-
pensate for the audio monitoring latency in 
host-based Pro Tools. If you are monitoring the 
output of external MIDI instruments with an ex-
ternal mixer or sound system (or headphones), 
there is no latency. If, however, you are moni-
toring the output of your MIDI devices through 
a Pro Tools interface (such as 003 family de-
vices), your MIDI tracks sound slightly later 
than your audio tracks. The larger the setting for 
the H/W Buffer Size (128, 256, 512, or 1024 sam-
ples), the larger the latency.

By configuring the Global MIDI Playback Offset 
setting, you can align your MIDI tracks to play 
back slightly earlier (by a specified number of 
samples), thereby compensating for any latency 
when monitoring audio in Pro Tools host-based 
systems.

When Delay Compensation is active, MIDI 
and Instrument tracks are automatically 
delay-compensated to provide low latency 
monitoring. For more information, see “De-
lay Compensation for MIDI” on page 982.
To configure the Global MIDI Playback Offset:

1  Choose Setup > Preferences and click the MIDI 
tab.

2  Enter the number of samples (–10,000 to 
10,000) for the Global MIDI Playback Offset set-
ting. A negative value causes the MIDI tracks to 
play back earlier than the audio tracks; a posi-
tive value causes the MIDI tracks to play back 
later.

To allow for monitoring latency in Pro Tools 
host-based systems, set the offset to a value that 
is roughly equivalent to the H/W Buffer Size.

3  Click OK.

Individual MIDI and Instrument Track 
Offsets

You can offset individual MIDI and Instrument 
track offsets in Pro Tools to compensate for de-
lays in MIDI devices (the time it takes to trigger 
events on a sampler or synth).

For example, if you have some kick drums that 
are being played by an audio track in Pro Tools 
and want them to be exactly synchronized with 
kick drums that are being played by a MIDI de-
vice, you may need to use a MIDI offset. In this 
example, it will usually take at least 5 ms to trig-
ger the MIDI notes, and it could take even lon-
ger, depending on the MIDI device.

The Global MIDI Playback Offset can also be 
set from the MIDI Track Offsets window. 
You can also apply MIDI Real-Time Proper-
ties delay to offset MIDI (see “MIDI Real-
Time Properties” on page 709).
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You can measure the latency for a MIDI device 
assigned to a MIDI track by recording its audio 
output back into Pro Tools. Compare the sample 
locations for the recorded audio events against 
the original MIDI notes to calculate the latency.

To configure a MIDI or Instrument track offset for a 
track:

1  Choose Event > MIDI Track Offsets.

2  Click in the Sample Offset column for the 
MIDI or Instrument track and enter the number 
of samples (–10,000 to 10,000) for the offset. A 
negative value causes the MIDI or Instrument 
tracks to play back earlier than the audio tracks; 
a positive value causes the MIDI or Instrument 
tracks to play back later.

Measuring MIDI latency

MIDI Track Offsets window

MIDI Note On

Audio Transient recorded 
from MIDI device

Approximate offset
in samples
Pro Tools Reference Guide
The equivalent offset in milliseconds is dis-
played in the msec Offset column. This value 
cannot be edited, but updates when a new value 
is entered in the Sample Offset column.

3  Press Enter (Windows) or Return (Mac) to ac-
cept the entered offset value.

To reset all offsets for all MIDI and Instrument 
tracks, click the Reset button in the upper left of 
the window.

Stuck Notes
If you encounter stuck notes with any of your 
MIDI devices, you can silence them with the All 

MIDI Notes Off command.

To turn off all stuck notes:

 Choose Event > All MIDI Notes Off. 

Remove Duplicate Notes
The Remove Duplicate Notes command is used to 
remove duplicate MIDI notes. If a note starts 
within the first 25% of the duration of a note of 
the same pitch which is already sounding (or 
within an eighth-note, whichever is shorter), it 
is considered a duplicate and is combined with 
the previous note. If it starts later than that, the 
first note is shortened so that it ends at the same 
tick at which the new one starts.

To remove duplicate notes:

1  Make an Edit selection including the duplicate 
notes you want to remove.

2  Choose Event > Remove Duplicate Notes.

Press Control+Shift+Period (.) (Windows) 
or Command+Shift+Period (.) (Mac) for 
the All MIDI Notes Off command.



MIDI Real-Time Properties
MIDI Real-Time Properties let you change some 
MIDI properties of MIDI and Instrument tracks 
(or MIDI clips) during playback. There are five 
types of MIDI Real-Time Properties: Quantize, 
Duration, Delay, Velocity, and Transpose. 

MIDI Real-Time Properties can be adjusted dur-
ing playback, so you can listen to the results. 
Once you have found the settings you want, you 
can write the settings to the selected tracks or 
clips. This overwrites the corresponding MIDI 
properties on selected tracks or clips and resets 
the Real-Time Properties display to its default 
settings.

Real-Time Properties can be adjusted in the 
Real-Time Properties view in the Edit window, 
or in the Real-Time Properties window.

For MIDI Real-Time Properties to apply to 
incoming MIDI data with MIDI Thru 
enabled, the corresponding MIDI and 
Instrument tracks must be record-enabled.
Real-Time Properties View
Real-Time Properties view in the Edit window 
only applies to tracks. To apply Real-Time Prop-
erties to clips, use the Real-Time Properties 
window (see “Real-Time Properties Window” on 
page 710).

To enable Real-Time Properties view in the Edit 
window:

 Select View > Edit Window > Real-Time Proper-

ties. 

For Micro, Mini, and Small track heights, the 
Real-Time Properties column only displays one 
or two properties, accordingly. The first one or 
two properties that are enabled are displayed 
automatically.

To select a different Real-Time Property in Mini or 
Small track height view:

 Control-click (Windows) or Command-click 
(Mac) on a real-time property element to select a 
different element from the pop-up menu.

Real-Time Properties column in the Edit window

Real-Time Properties pop-up menu with Mini Track 
Height
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Real-Time Properties Window
Using the Real-Time Properties window, you 
can apply Real-Time Properties to selected 
tracks or clips.

To open the Real-Time Properties window:

 Choose Event > MIDI Real-Time Properties. 

The Real-Time Properties window can be used to 
apply either track-based or clip-based Real-Time 
Properties by making an Edit selection and se-
lecting tracks or clips from the Apply To pop-up 
menu.

Expanded Real-Time Properties Window

In the Real-Time Properties window, Quantize, 
Duration, and Velocity each provide an ex-
pand/collapse triangle to show or hide addi-
tional settings. 

Real-Time Properties window with properties enabled
Pro Tools Reference Guide
Enabling Real-Time Properties

To enable Real-Time Properties:

1  Select a track, or make an Edit selection.

2  In Real-Time Properties view in the Edit win-
dow, or in the Real-Time Properties window, se-
lect Real-Time Properties by clicking the 
property name (Quantize, Duration, Delay, Ve-
locity, or Transpose). Enabled Real-Time Prop-
erties are highlighted and display their settings.

3  If you are using the Real-Time Properties win-
dow and Link Track and Edit Selection mode is 
enabled, select the track or clip to affect from 
the Apply To pop-up menu.

4  Configure the Real-Time Properties settings 
(see “Real-Time Properties Settings” on 
page 711).

Real-Time Properties window, expanded view

When using Real-Time Properties, enable 
Link Track and Edit Selection mode to make 
a track selection from an Edit selection (see 
“Linking or Unlinking Track and Edit Selec-
tions” on page 570).

Expand/collapse
triangles



Enabled Real-Time Properties are heard on 
playback and play through for the selected 
tracks and clips.

Real-Time Properties 
Settings

Quantize
Quantize either can be based on a grid or a 
groove template. For grid quantize, additional 
tuplet and grid offset settings are available in 
addition to the standard MIDI quantize proper-
ties. For groove quantize, additional controls 
are provided to set the extent to which the 
groove’s duration and velocities are applied. 
Both grid and groove quantize also let you set a 
strength amount, an “include” range, and a ran-
domize amount.

Quantize Pop-Up Menu Select the quantize 
value, including all standard note rhythm values 
between whole notes and 64th notes, including 
dotted and triplet options. This pop-up menu 
also provides access to all standard and custom 
groove templates.

Quantize cannot be applied as a Real-Time 
Property to MIDI Input and Thru.

Selecting a Grid Quantize value or a Groove Template
Swing Value Enter the amount of swing as a per-
centage between 0 and 300%. 

Tuplet Value Enable Tuplet and enter the ratio 
for the tuplet (1–99), such as 3 to 2 or 5 to 4. Tu-

plet is only available in the expanded Real-Time 
Properties window.

Offset Value Enable Offset and enter the offset 
value in Ticks between –2000 and 2000. Offset is 
only available in the expanded Real-Time Prop-
erties window.

Strength Value Enable Strength and enter the 
amount as a percentage between 0 and 100%. 
Strength is only available in the expanded Real-
Time Properties window.

Include Enable Include and enter the range be-
tween 0 and 100%. Include is only available in 
the expanded Real-Time Properties window.

Random Enable Random and enter a percentage 
between 0 and 100%. Random is only available in 
the expanded Real-Time Properties window.

Duration
Duration can be used to increase or decrease the 
duration of MIDI notes by a fixed amount or by 
a percentage. This is useful for creating legato or 
staccato passages.

Duration Mode Pop-Up Menu

Select one of the following options from the Du-
ration Mode pop-up menu: Set, Add, Subtract, 
Scale, Legato/Gap, or Legato/Overlap.

Duration cannot be applied as a Real-Time 
Property to MIDI Input and Thru.
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Set Select to set notes to the specified duration.

Add Select to add the specified duration to the 
current duration of each note.

Subtract Select to subtract the specified dura-
tion from the current duration of each note.

Scale Select to scale the current duration of each 
note by a percentage from 1 to 400%.

Legato/Gap Select to extend each note to the fol-
lowing note. The specified duration is the sub-
tracted to create a consistent gap between notes.

Legato/Overlap Select to extend each note to the 
following note. The specified duration is then 
added to create a consistent amount of overlap.

Duration Amount

If the Ticks/Notes pop-up menu is set to ticks, 
enter a duration as a number of quarter-notes 
plus a number of ticks, such as 4|000. If the 
Ticks/Notes pop-up menu is set to a note size, 
enter a number to by which to multiply that note 
size, such as 7 16th-notes.

Selecting a Duration mode
Pro Tools Reference Guide
Ticks/Notes Pop-Up Menu

The Ticks/Notes pop-up menu lets you select ei-
ther Ticks or a note size for Note Durations. 
There is also a Ticks/Notes pop-up menu for the 
Minimum and Maximum Durations options.

Minimum and Maximum Durations

Enable either or both minimum and maximum 
durations and enter a value in quarter notes plus 
ticks or as a multiple of a note size. The Mini-
mum (Min) and Maximum (Max) Durations op-
tions are only available in the expanded Real-
Time Properties window.

Delay
Delay lets you delay or advance all MIDI data in 
the selected clip or track. Select “+” from the 
Delay pop-up menu to delay MIDI data, or select 
“–” to advance MIDI data. Select Ticks or Milli-
seconds (MS) from the Ticks/Milliseconds pop-
up menu. Enter the Delay amount in Tick or Mil-
lisecond values. Delay is limited to a maximum 
of value of 2000 ms or 999 ticks.

Real-Time Properties Ticks/Notes pop-up menus



Velocity
Velocity lets you change MIDI velocity by a per-
centage or by constant value. Enter a percentage 
value in the Dynamics field to scale velocity 
around the median velocity of 64. You can also 
enter an offset by adding (+) or subtracting (–) 
values between 1 and 127. You can also enter 
Minimum and Maximum Velocity value limits. 
The Minimum (Min) and Maximum (Max) Ve-
locity options are only available in the expanded 
Real-Time Properties window.

Transpose
Transpose lets you transpose MIDI notes up or 
down by a specified number of octaves and 
semitones, or in key by scale steps (based on the 
Key Signature ruler). You can also transpose to a 
specified pitch. Select By, To, or In from the 
Transpose pop-up menu to transpose by an in-
terval, to a specific pitch, or in key by scale 
steps. 

Real-Time Properties Ticks/Milliseconds pop-up 
menus

Duration cannot be applied as a Real-Time 
Property to MIDI Input and Thru.

Velocity can be applied as a Real-Time 
Property to MIDI Input and Thru on record-
enabled MIDI and Instrument tracks.
To transpose by an interval, enter the number of 
octaves and semitones as a positive or negative 
numbers. 

To transpose to a specific pitch, enter the MIDI 
note name.

To transpose in key by scale steps, enter the 
number of steps as a positive or negative num-
bers. For example, enter +2 to transpose up by 
thirds in key (a unison plus a second equals a 
third).

Transpose can be applied as a Real-Time 
Property to MIDI Input and Thru on record-
enabled MIDI and Instrument tracks.
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Real-Time Properties on 
Tracks and Clips
Real-Time Properties can be configured to apply 
to an entire track (all clips on that track), or on 
a clip-by-clip basis. Track-level properties also 
provide real-time MIDI input processing of ve-
locity and transposition.

The presence of track-based Real-Time Proper-
ties are indicated by a “T” displayed in the upper 
right-hand corner of MIDI clips. Clip-based 
Real-Time Properties are indicated by an “R” 
displayed in the upper right-hand corner of the 
clip. Clips boundaries including the “T” and the 
“R” displays are indicated in Notes view and in 
MIDI Editor windows, but not in the Score Edi-
tor window.

Clip-Based Real-Time Properties

Clip-based Real-Time Properties can only be ap-
plied using the Real-Time Properties window 
(Event > MIDI Real-Time Properties). Real-Time 
Properties can be applied to multiple clips. Once 
Real-Time Properties have been assigned to a 
clip, the clip can be moved or copied and pasted 
and retain its Real-Time Properties.

Track-based and clip-based Real-Time Property 
indicators

Indicates
track-based

Real-Time Properties

Indicates
clip-based

Real-Time Properties
Pro Tools Reference Guide
Track-Based Real-Time Properties

All track-based Real-Time Properties consis-
tently apply to MIDI data throughout the entire 
track. However, clips with clip-based Real-Time 
Properties will take precedence over any track-
based Real-Time Properties. You can clear clip-
based Real-Time Properties by selecting the clip 
and clicking the Clear Clip Properties button in 
the Real-Time Properties window (see “Writing 
Real-Time Properties to Tracks or Clips” on 
page 714).

For greater flexibility, when Real-Time Proper-
ties are assigned on a track basis they are actu-
ally contained in a track playlist. This lets you 
create multiple playlists containing different 
Real-Time Property settings.

Writing Real-Time Properties 
to Tracks or Clips
Once you have found the settings you want, you 
can write Real-Time Properties to the selected 
tracks or clips using the Real-Time Properties 
window. Real-Time Properties are applied to the 
current MIDI data on the track or in a clip.

To write Real-Time Properties to tracks:

1  Enable Link Track and Edit Selection.

2  Select one or more tracks to which you want to 
apply Real-Time Properties.

3  Open the Real-Time Properties window (Event 

> MIDI Real-Time Properties).

4  Select Tracks from the Real-Time Properties 

Apply To pop-up menu.

5  Configure the Real-Time Property settings.



6  Do one of the following:

• Click the Write to Track button in the Real-
Time Properties window.

– or –

• Choose Track > Write MIDI Real-Time Prop-

erties.

To write Real-Time Properties to clips:

1  Select one or more clips to which you want to 
apply Real-Time Properties.

2  Open the Real-Time Properties window (Event 

> MIDI Real-Time Properties).

3  If Link Track and Edit Selection is enabled, se-
lect Clips from the Real-Time Properties Apply To 
pop-up menu.

4  Configure the Real-Time Property settings.

5  Click the Write to Clip button.

To clear Real-Time Properties from a clip:

1  Select the clip for which you want to clear 
Real-Time Properties.

2  Open the Real-Time Properties window (Event 

> MIDI Real-Time Properties).

3  Select Clips from the Real-Time Properties Ap-

ply To pop-up menu.

4  Click the Clear Clip Properties button.

Real-Time Properties In the 
MIDI Event List
In the MIDI Event List, the presence of track-
based Real-Time Properties are indicated by a 
“T” displayed to the right of each event. Clip-
based Real-Time Properties are indicated by an 
“R.”

For more information on the MIDI Event 
List, see Chapter 35, “MIDI Event List.”
Display of Real-Time 
Properties Effects
The Display Events as Modified by the Real-Time 

Properties option determines if Pro Tools dis-
plays the effects of Real-Time Properties in both 
the Edit window, MIDI Editor windows, the 
Score Editor window, and the MIDI Event List. 
The Edit window, MIDI Editor windows, the 
Score Editor window, and the MIDI Event List 
all display the effects of Real-Time Properties 
when the Display Events as Modified by Real-

Time Properties option is enabled. With this op-
tion disabled, the effects of Real-Time Proper-
ties are heard but not seen—you see the notes 
and other MIDI events at their original loca-
tions, pitches, durations, and velocities, but you 
hear them as they are affected by the Real-Time 
Properties settings. 

To enable or disable the Display Events as 
Modified by Real-Time Properties option:

1  Choose Setup > Preferences, and click the MIDI 
tab.

2  Enable or disable the Display Events as Modi-

fied by Real-Time Properties option.

3  Click OK.
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Real-Time Properties Effects Displayed in the 
MIDI Event List

The MIDI Event List takes into account the ef-
fect of Real-Time Properties whenever the Dis-

play Events as Modified by Real-Time Properties 
option is enabled. When editing or inserting an 
event in a track or clip with active Real-Time 
Properties, Pro Tools takes the properties into 
account and edits or inserts the event in a differ-
ent place if necessary to match the effect of the 
Real-Time Properties.

Real-Time Properties Effects Displayed in the 
Edit Window

MIDI events appear where they sound in the 
Edit window, MIDI Editor windows, and the 
Score Editor window, with the Display Events as 

Modified by Real-Time Properties option enabled 
in the MIDI preferences. However, MIDI events 
are not actually written to their modified loca-
tions until you write the Real-Time Properties to 
the track or clip.

When moving MIDI events, the actual locations 
(pitch or time) move by the amount the events 
are dragged, but the effect of Real-Time Proper-
ties is displayed.

When inserting an event in a track or clip with 
active properties, Pro Tools takes the properties 
into account and edits or inserts the event in a 
different place if necessary to match the effect of 
the Real-Time Properties.
Pro Tools Reference Guide
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Pro Tools provides MIDI Editor windows for detailed MIDI editing.
MIDI Editor window

Solo

Zoom controls

Cursor location Target

Notation View

Mute

Link Timeline and Edit Selection

Edit Tools MIDI Editor menu

Default Note Duration

Play MIDI Notes While Editing

Default Note Velocity

Velocity, Controller and Superimposed MIDI
and Instrument tracks

Track List

Groups List

Key Focus

Automation lanes

Edit modes

Mirrored MIDI Editing

Grid 
selector

Nudge 
selector

Track Edit selector
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Superimposed MIDI and Instrument Tracks

MIDI Editor windows display and let you edit 
MIDI data (notes, velocities, and continuous 
controller data) for one or more MIDI or Instru-
ment tracks. When displaying multiple tracks in 
a MIDI Editor window, MIDI notes from differ-
ent tracks are superimposed. MIDI Editor win-
dows can also show Auxiliary Input tracks.

Automation and Controller Lanes

Velocity, other continuous controller data 
(MIDI and Instrument tracks), and automation 
data (Instrument and Auxiliary Input tracks 
only), can be edited along with MIDI notes and 
appear in Controller lanes under the Notes pane. 
Velocities for MIDI notes on multiple tracks are 
also superimposed in the Velocity lane. How-
ever, for all other automation and controller 
data, additional lanes are shown for each auto-
mation or controller type for each track. 

For example, if two Instrument tracks are shown 
in a MIDI Editor window, the MIDI notes for 
each track are superimposed in the Notes pane 
and the velocities for each track are superim-
posed in the Velocity lane. However, you would 
see two Mod Wheel Controller lanes, one for 
each track; and you would see two Volume lanes, 
one for each track.
Pro Tools Reference Guide
Opening a MIDI Editor 
Window
To open a MIDI Editor window, do one of the 
following:

 Choose Window > MIDI Editor.

 In the Edit window, Right-click a MIDI clip on 
the track, or the track name in the track controls 
or in the Track List, and choose Open In MIDI Ed-

itor.

 In the Score Editor window, Right-click any-
where on the score, or on a track name in the 
Track List, and choose Open In MIDI Editor.

To open additional MIDI Editor windows, do one of 
the following:

 Deselect the Target button in the open MIDI 
Editor window and open another MIDI Editor 
window.

– or –

 Right-click in the open MIDI Editor window 
and select Open in New MIDI Editor.

To bring an open MIDI Editor window to the front:

 Choose Window > MIDI Editor and select the 
MIDI Editor window you want.

Press Start+“=” (Windows) or Control+“=” 
(Mac) to open a MIDI Editor window.

If the MIDI Editor option is selected as the 
“Double Clicking a MIDI Clip Opens” setting 
in the Pro Tools MIDI Preferences, you can 
double-click a MIDI clip to open it in a MIDI 
Editor.

To cycle through all open MIDI Editor win-
dows, press Start+“=” (Windows) or 
Control+“=” (Mac) repeatedly until the 
window you want is in the front.



MIDI Editor Window Toolbar
The MIDI Editor window toolbar is similar to 
the Edit window toolbar, but with a few excep-
tions. Each MIDI Editor window and the Edit 
window can be configured independently of one 
another. For example, you can have Notation 
view enabled in one MIDI Editor window, but 
not another; or you can have a MIDI Editor win-
dow set to Grid mode, but the Edit window set to 
Slip mode. You can also customize the toolbar in 
MIDI Editor windows.

Solo and Mute Buttons
In a MIDI editor window, the Solo and Mute 
buttons affect tracks in all windows. They let 
you either audition the tracks shown in the cur-
rent MIDI Editor window without the rest of the 
mix, or let you hear just the mix without the 
tracks shown in the MIDI Editor window.

Solo

The Solo button lets you solo all the tracks cur-
rently displayed in the MIDI Editor window.

Mute

The Mute button lets you mute all the tracks 
currently displayed in the MIDI Editor window.
Mixed Mute and Solo States

The Solo and Mute buttons are global controls in 
that they affect all tracks shown in a MIDI Edi-
tor window. If you independently solo or mute 
tracks in the Edit window that are also shown in 
a MIDI Editor window, the appearance of the 
Solo and Mute buttons updates to indicate 
mixed states. Mixed solo and mute states occur 
when one or more tracks shown in the MIDI Ed-
itor window, but not all, are soloed or muted.

Notation View
The Notation view button lets you view MIDI 
notes in the MIDI Editor window as music nota-
tion. In Notation view, MIDI and Instrument 
tracks are not superimposed, but are shown as 
staves just like in the Score Editor window.

Notation view enabled in a MIDI Editor window

You can access the Notation Display Track 
Settings in a MIDI Editor window when in 
Notation view. Select the Notation Display 
Track Settings option from the Track List 
menu or Right-click in the Notes pane and 
select the Notation Display Track Settings 
option from the Right-click menu. For more 
information, see “Notation Display Track 
Settings” on page 746.
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Edit Tools
The Edit tools in MIDI Editor windows can be 
viewed as a single tool with a pop-up menu for 
selecting other tools, or as an expanded, com-
plete row of Edit tool icons just like in the Edit 
window. The Edit tools in MIDI Editor windows 
function exactly the same way for MIDI data as 
in the Edit window. Edit tool settings can be set 
independently in each MIDI Editor window, and 
are independent of tool selection in the Edit 
window and Score Editor.

To view the Expanded Edit tools in a MIDI Editor 
window, do one of the following:

 Click the MIDI Editor Window Toolbar menu 
and select Expanded Edit Tools.

– or –

 Right-click in the toolbar and select Expanded 

Edit Tools.

To revert to the single Edit Tool icon with the Edit 
Tool pop-up menu:

 Deselect Expanded Edit Tools.

MIDI Editing Controls
The MIDI Editing controls function exactly the 
same way in MIDI Editor windows as in the Edit 
window.

MIDI Editing controls

Link Timeline and 

Default Note Duration

Play MIDI Notes While Editing

Default Note Velocity

Mirrored MIDI Editing

Track Edit selector

Edit Selection
Pro Tools Reference Guide
Track Edit Selector

If more than one MIDI or Instrument track is 
shown in the MIDI Editor window, the Track 
Edit selector lets you select which track is “pen-
cil-enabled.” You can manually insert MIDI 
notes only in pencil-enabled tracks. You can 
also pencil-enable tracks in the Track List (see 
“Manually Inserting MIDI Notes” on page 729).

Default Note Duration

The Default Note Duration selector lets you de-
fine the default note duration for manually in-
serted notes.

Default Note On Velocity

The Default Note On Velocity setting lets you 
define the default Note On velocity for manually 
inserted notes.

Play MIDI Notes When Editing

When enabled, Play MIDI Notes When Editing 
causes MIDI notes to sound when you insert 
them with the Pencil tool, click them with the 
Grabber tool, Tab to them, or select them with 
the Note Selector tool. 

Link Timeline and Edit Selection

When this button is enabled, the Timeline and 
Edit selections are linked. When it is disabled, 
you can make Timeline and Edit selections inde-
pendently of one another.

Play MIDI Notes When Editing, Link Time-
line and Edit Selection, and Mirrored MIDI 
Editing are all global settings that are avail-
able in the Edit window, MIDI Editor 
windows, and in the Score Editor window.



Mirrored MIDI Editing

Mirrored MIDI Editing lets you edit MIDI clips 
and have your edits apply to every copy of the 
same MIDI clip. This can be particularly useful 
when editing looped MIDI clips.

Edit Modes
The Edit modes in MIDI Editor windows func-
tion exactly the same way for MIDI data as in the 
Edit window. Edit mode settings are unique to 
each MIDI Editor window and are also set inde-
pendently of the Edit window.

Cursor Location Display
The Cursor Location display in MIDI Editor 
windows functions exactly the same way in 
MIDI Editor windows as in the Edit window. 

Edit Selection Display
The Edit Selection display in MIDI Editor win-
dows functions exactly the same way for MIDI 
data in MIDI Editor windows as in the Edit win-
dow. The Selection display can be shown or hid-
den in the Toolbar.

To show (or hide) the Edit Selection display in a 
MIDI Editor window, do one of the following:

 Click the MIDI Editor Window Toolbar menu 
and select (or deselect) Selection Display.

– or –

If Mirrored MIDI Editing mode is disabled, 
and you edit notes of looped clips in Notes 
view, the edit flattens the loop. 
Similarly editing clip groups separates the 
clip groups.
 Right-click in the toolbar and select (or dese-
lect) Selection Display.

Grid and Nudge Selectors
When the Expanded Grid/Nudge Display option is 
enabled in the MIDI Editor Window menu, the 
Grid and Nudge selectors in MIDI Editor win-
dows function exactly the same way for MIDI 
data in MIDI Editor windows as in the Edit win-
dow. 

When the Expanded Grid/Nudge Display option is 
disabled in the MIDI Editor Window menu, you 
can toggle between Grid Display and Nudge Dis-
play using the Grid/Nudge Display selector.

Target
Generally, the Target button for MIDI Editor 
windows functions just like the Target button 
for Plug-In, Output, and Send windows. Addi-
tionally, the Target button in a MIDI Editor win-
dow synchronizes its Timeline location view to 
the Timeline location view in the Edit window. 
Any changes to the Edit selection in the Edit 
window are reflected in the Targeted MIDI Edi-
tor window. There can only be one targeted 
MIDI Editor window at a time. The targeted 
MIDI Editor window can also be stored in a 
Window Configuration. 

One or more untargeted MIDI Editor windows 
can remain open and available at the same time, 
just like untargeted Plug-In windows. Targeting 
an untargeted MIDI Editor window disables any 
other targeted MIDI Editor window.

Grid/Nudge Display selector, selecting Nudge display
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The front-most window, regardless of whether it 
is targeted, always receives Keyboard Command 
focus and control surface focus.

To enable or disable the Target for a MIDI Editor 
window:

 Click the Target button for the MIDI Editor 
window so that it is highlighted (targeted) or 
unhighlighted (untargeted).

MIDI Editor Window Menu
The MIDI Editor Window menu provides access 
to MIDI Editor Window Display options and 
Scrolling options.

Targeted MIDI Editor window

Untargeted MIDI Editor window
Pro Tools Reference Guide
MIDI Editor Window Display 
Options

Expanded Edit Tools

When selected, the Expanded Edit Tools option 
displays all of the Edit Tools in the MIDI Editor 
window toolbar. 

When this option is not selected, only the icon 
for the selected Edit tool is displayed. Any of the 
other Edit tools can be selected from the Edit 
Tool pop-up menu.

Expanded Grid/Nudge Display

When selected, the Expanded Grid/Nudge Display 

option displays the Nudge selector in addition 
to the Grid selector in the MIDI Editor window 
toolbar.

Expanded Edit tools displayed in a MIDI Editor window

Edit Tool pop-up menu

Grid and Nudge selectors



Selection Display

When selected, the Selection Display option 
shows the Edit Selection Display in the MIDI Ed-
itor window toolbar.

Track List

When selected, the Track List option displays the 
Track List in the MIDI Editor window.

Scrolling Submenu
The Scrolling submenu lets you select the scroll-
ing options for the MIDI Editor window inde-
pendently of other MIDI Editor windows and 
the Edit window. The scrolling options include:

No Scrolling The MIDI Editor window does not 
scroll during or after playback. The playback 
cursor moves across the MIDI Editor window, 
indicating the playback location.

After Playback The playback cursor moves 
across the MIDI Editor window, indicating the 
playback location. When playback has stopped, 
the MIDI Editor window scrolls to the final play-
back location.

Page The playback cursor moves across the 
MIDI Editor window, indicating the playback 
location. When the right edge of the MIDI Editor 
window is reached, its entire contents are 
scrolled, and the playback cursor continues 
moving from the left edge of the window.

Selection display
Continuous The MIDI Editor window scrolls 
continuously past the playback cursor, which re-
mains in the center of the window. With this op-
tion, playback is always based on the Timeline 
selection (unlike the Center Playhead Scrolling 
option).

Center Playhead (Pro Tools HD Only) The MIDI 
Editor window scrolls continuously past the 
Playhead, which is represented as a blue line in 
the center of the window (or a red line when re-
cording).

Follow Edit Window When selected, the MIDI 
Editor window follows the scrolling option se-
lected for the Edit window (Options > Edit Win-

dow Scrolling).

Customizable Toolbar
You can customize the toolbar in MIDI Editor 
windows by rearranging, and showing and hid-
ing the available controls and displays just like 
in the Edit window or the Score Editor window.

Changing Toolbar Display Options

To change the toolbar display options in a MIDI 
Editor window toolbar:

1  Do one of the following:

• Click the MIDI Editor Window Toolbar 
menu.

– or –

• Right-click in the toolbar.

2  From the pop-up menu, select or deselect any 
of the following:

• Expanded Edit Tools

• Expanded Grid/Nudge Display

• Selection Display
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Rearranging Controls and Displays

You can rearrange the controls and displays in 
the MIDI Editor window toolbar just like in the 
Edit window or the Score Editor window.

To rearrange controls and displays in a MIDI Editor 
window toolbar:

 Control-click (Windows) or Command-click 
(Mac) the controls or displays you want to move 
and drag them to the location in the Toolbar you 
want.

MIDI Editor Zoom Controls
Vertical and Horizontal Zoom In and Out 
Buttons

In addition to the Zoom controls in the Toolbar, 
Pro Tools provides horizontal and vertical zoom 
buttons in the lower-right corner of MIDI Editor 
windows. 

Vertical Zoom Buttons Zoom the lane heights 
proportionally for Automation and Controller 
lanes.

Horizontal Zoom Buttons Zoom the Timeline 
just like the Horizontal Zoom controls in the 
MIDI Editor window toolbar.

Horizontal and Vertical Zoom In and Out buttons
Pro Tools Reference Guide
MIDI Zoom In and Out Buttons

Pro Tools provides MIDI Zoom In and Out but-
tons in the upper-right corner of MIDI Editor 
windows. These controls function exactly the 
same as the MIDI Zoom controls in the toolbar, 
and let you zoom in and out vertically on MIDI 
notes.

Track List
The Track List in MIDI Editor windows lets you 
show or hide MIDI, Instrument, and Auxiliary 
Input tracks in the MIDI Editor window. The 
Track List settings are unique to each MIDI Ed-
itor window. However, the order of tracks in the 
Track List is global. Sorting or changing the 
order of tracks affects the Track List in every 
window.

MIDI Zoom In and Out buttons

Track List

Track List menu

Track name
Track Type icon

Track Color Code
Track Show/Hide

Pencil Enable



Track List Columns
In MIDI Editor windows there are four columns 
for the Track List: 

Show/Hide Indicates which tracks are shown or 
hidden in the MIDI Editor window.

Track Color Displays the track color for each 
track by type or by track.

Name Displays the name for each track.

Pencil Lets you enable a track for manually en-
tering MIDI notes with the Pencil tool.

Track List Menu
The Track List menu lets you show and hide 
MIDI, Instrument, and Auxiliary Input tracks in 
the MIDI Editor window (see “Showing and Hid-
ing Tracks” on page 725). 

The Track List menu also lets you sort tracks in 
the Track List by Name, Type, Edit Group, Mix 
Group, or Voice (see “Sorting Tracks in the 
Track List” on page 726).

Showing and Hiding Tracks

To show MIDI, Instrument, and Auxiliary Input 
tracks in a MIDI Editor window:

 Enable the Track Show/Hide icon in the Track 
List for tracks you want to show in the MIDI Ed-
itor window.

To show all MIDI, Instrument, and Auxiliary Input 
tracks in a MIDI Editor window:

 From the Track List pop-up menu, select Show 

All Tracks.
To show only selected MIDI, Instrument, and 
Auxiliary Input tracks in a MIDI Editor window:

1  In the Track List, select the MIDI, Instrument, 
and Auxiliary Input tracks you want to show in 
the MIDI Editor window.

2  From the Track List pop-up menu, select Show 

Only Selected Tracks.

To show all tracks of a single type (MIDI or 
Instrument) in a MIDI Editor window:

 From the Track List pop-up menu, choose 
Show Only, and select the track type you want.

To hide MIDI, Instrument, and Auxiliary Input 
tracks in a MIDI Editor window:

 Disable the Track Show/Hide icon for tracks 
you want to hide in the MIDI Editor window.

To hide all (but one) MIDI, Instrument, and 
Auxiliary Input tracks in a MIDI Editor window:

 From the Track List pop-up menu, select Hide 

All Tracks. 

All but the top MIDI or Instrument track in the 
Track List are hidden. MIDI Editor windows re-
quire that at least one MIDI or Instrument track 
always be shown in the window.

To hide selected MIDI, Instrument, and Auxiliary 
Input tracks in a MIDI Editor window:

1  In the Track List, select the MIDI, Instrument, 
and Auxiliary Input tracks you want to hide.

2  From the Track List pop-up menu, select Hide 

Selected Tracks.
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Sorting Tracks in the Track List
You can sort tracks in the Track List by the fol-
lowing criteria:

Name Sorts the order of tracks in the Track List 
by Track Name.

Type Sorts the order of tracks in the Track List 
by Track Type.

Edit Group Sorts the order of tracks in the Track 
List by Edit Groups.

Mix Group Sorts the order of tracks in the Track 
List by Mix Groups.

Voice Sorts the order of tracks in the Track List 
by Voice allocations.

Track List Right-Click Menu
In addition to common track management com-
mands, the Track List Right-click menu shares 
commands with both the Track List pop-up 
menu and the Notes Pane Right-click menu.

To access the MIDI Editor Track List Right-click 
menu:

 Right-click on any Track Name in the Track 
List.

Track List Right-click Menu Options

The following options are available depending 
on the track type (Auxiliary Input, Instrument, 
or MIDI).

Hide Hides the selected track.

Hide and Make Inactive Hides the selected track 
and makes it inactive.

Make Inactive Makes the selected track inactive.

Export MIDI Exports the selected track as a MIDI 
file.
Pro Tools Reference Guide
New Opens the New Track dialog.

Rename Renames the selected track.

Duplicate Duplicates the selected track.

Split into Mono Splits the selected stereo Instru-
ment or Auxiliary Input track into two mono 
tracks.

Delete Deletes the selected track.

MIDI Real-Time Properties Opens the MIDI Real-
Time Properties window for the selected track.

Open in New MIDI Editor Opens the tracks dis-
played in the current MIDI Editor window in a 
new MIDI Editor window. The new MIDI Editor 
window will be untargeted.

Open in Score Editor Opens the shown tracks in 
the Score Editor window.

Open in MIDI Event List Opens the selected track 
in the MIDI Event List.

Notation Display Track Settings Opens the Nota-
tion Display Track Settings window.

Group List
The Group List in MIDI Editor windows pro-
vides the same functionality as in the Edit win-
dow. You can create, edit, and delete Edit 
Groups using the Group List in any MIDI Editor 
window. The Group List is linked between the 
Edit window and all MIDI Editor windows.

For information on grouping tracks, see 
Chapter 14, “Grouping Tracks.”



Timebase and Conductor 
Rulers
Timebase and Conductor rulers in MIDI Editor 
windows function exactly the same as in the Edit 
window. However, the Edit window and each 
MIDI Editor window can have a unique view of 
the Timeline in terms of which Timebase and 
Conductor rulers are shown, and in terms of 
zoom level and time location. 
Superimposed Notes View
The Notes pane in MIDI Editor windows lets you 
view and edit MIDI notes superimposed from 
different MIDI and Instrument tracks such that 
you can easily edit multitrack arrangements in a 
single constellation of color-coded notes. The 
Notes pane lets you edit MIDI notes much the 
same way as in Notes view on MIDI and Instru-
ment tracks in the Edit window, except you can 
edit MIDI notes on multiple MIDI and Instru-
ment tracks at the same time.

You can also view and edit MIDI notes in No-
tation view in the Notes pane (see “Notation 
View” on page 732).
MIDI Editor window, Notes pane with five superimposed Instrument tracks
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Color Coding MIDI Notes
Pro Tools Reference Guide
You can color code MIDI notes by Track or by Velocity.

Color Coding by Track

When Color Coding by Track is enabled, tracks in the MIDI Editor are temporarily assigned one of 
sixteen fixed colors, in the order they appear in the track list.

To Color Code MIDI notes by Track:

 Enable the Color Code MIDI Notes By Track button
Color Coding by Velocity

When Color Coding by Velocity is enabled, MIDI notes are all the same red color (hue) on all tracks 
displayed, and MIDI notes vary in color saturation (from a light red to a dark red) based on the Note 
On velocity. Notes with low velocities are lighter in color and those with high velocities are darker.

To Color Code MIDI notes by Velocity:

 Enable the Color Code MIDI Notes By Velocity button.

Color Code MIDI Note By Track Enabled in MIDI Editor window
Color Code MIDI Notes By Velocity enabled in MIDI Editor window



No Color Coding

When neither Color Coding by Track nor Color Coding by Velocity are enabled, notes are drawn in the 
MIDI Editor in as the same color they are in the Edit window—using the color coding options as set 
in the Track Color Coding settings in the Display Preferences.
No Color Code enabled in MIDI Editor window
Editing MIDI Notes
You can edit any note on any track shown in the 
Notes pane. You edit MIDI notes in the Notes 
pane the same way as in Notes view for MIDI and 
Instrument tracks in the Edit window, except 
that notes from different tracks are superim-
posed. 

Manually Inserting MIDI Notes
Using the Pencil tool, you can manually insert 
MIDI notes to any pencil-enabled track shown 
in the Notes pane. If only one track is viewed in 
the MIDI Editor window, that track will auto-
matically be pencil-enabled. If multiple super-
imposed tracks are shown in the Notes pane, 
MIDI notes will be inserted on the pencil en-
abled tracks only.

For more information on editing MIDI 
notes, see Chapter 32, “MIDI Editing.”

For more information on manually insert-
ing MIDI notes, see “Inserting MIDI Notes” 
on page 684.
To insert MIDI notes on a specific track in the 
Notes pane:

1  Do one of the following:

• Select the track you want pencil-enabled 
from the Track Edit selector in the Toolbar.

– or –

• Click the Pencil column in the Track List to 
pencil-enable the track you want.

Selecting a track for editing

Only tracks that are currently shown in the 
MIDI Editor window are available in the 
Track Edit selector pop-up menu.

“Blad Pad Midi” track pencil-enabled
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2  With the Pencil tool, click at a time and pitch 
location to insert a MIDI note on the pencil-en-
abled track with the default Note On velocity and 
the selected Default Note Duration.

Notes Pane Right-Click Menu
The Notes Pane Right-click menu provides sev-
eral useful commands for editing, exporting, 
and viewing MIDI data.

To access the MIDI Editor Right-click menu:

 Right-click anywhere in the Notes pane.

Inserting a MIDI note on track “Inst 3” 

To pencil-enable multiple contiguous 
tracks, Shift-click in the Pencil column of 
the range of tracks you want. To pencil-en-
able multiple discontiguous tracks, Control-
click (Windows) or Command-click (Mac) 
in the Pencil column of any additional 
tracks. Alt-click (windows) or Option-click 
(Mac) to pencil-enable all tracks. Manually 
inserted notes are written to all pencil-en-
abled tracks.
Pro Tools Reference Guide
Notes Pane Right-Click Menu 
Options

Tools

The Tools submenu lets you select any Edit tools 
relevant to the Score Editor.

Zoomer Selects the Zoomer tool.

Trim Selects the Trim tool.

Selector Selects the Selector tool.

Grabber Selects the Grabber tool.

Scrubber Selects the Scrubber tool.

Pencil Selects the Pencil tool.

Smart Selects the Smart tool.

Zoomer Tools Lets you select Normal Zoom or 
Single Zoom.

Pencil Tools Lets you select any of the Pencil 
tools.

Insert

The Insert submenu lets you insert key changes, 
meter changes, and chord symbols at the loca-
tion of the Edit cursor.

Key Inserts a key change.

Meter Inserts a meter change.

Chord Inserts a chord symbol.

Cut

The Cut command cuts the current Edit selec-
tion.

Copy

The Copy command copies the current Edit se-
lection.



Paste

The Paste command pastes the clipboard to the 
current Edit selection or at the current Edit cur-
sor location. Any MIDI notes already present at 
the same location are overwritten.

Merge

The Merge command pastes the clipboard to the 
current Edit selection or at the current Edit cur-
sor location and merges the pasted data with any 
MIDI notes already present at the same location.

Clear

The Clear command clears (deletes) the current 
Edit selection.

Separate

The Separate command lets you separate MIDI 
notes at the Edit cursor location.

Consolidate

The Consolidate command lets you consolidate 
selected multiple consecutive MIDI notes of the 
same pitch.

Mute Notes

The Mute Notes (or Unmute Notes) command lets 
you mute (or unmute) selected MIDI notes.

MIDI Real-Time Properties

Selecting the MIDI Real-Time Properties option 
opens the MIDI Real-Time Properties window.

Event Operations

The Event Operations submenu lets you select 
any of the Event Operations windows (such as 
Quantize or Change Velocity).
Open In New MIDI Editor

Selecting the Open In New MIDI Editor option 
opens all shown tracks in a new MIDI Editor 
window.

Open In Score Editor

The Open In Score Editor option opens the shown 
tracks in the Score Editor window.

Open in MIDI Event List

The Open In MIDI Event List option opens the se-
lected track in the MIDI Event List.

Display Notation

Selecting the Display Notation option changes the 
MIDI Editor to Notation view. Deselecting this 
option reverts the MIDI Editor to Notes view.
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Notation View
The Notes pane in MIDI Editor windows can also display MIDI notes in standard music notation. In 
Notation view, each MIDI and Instrument track is displayed independently, with one track per staff. 
Pro Tools Reference Guide
MIDI Editor window, Notes pane in Notation view
In MIDI Editor windows, notation is displayed 
as a continuous timeline and not in page view as 
in the Score Editor window. 

For information on editing notation, see 
“Editing Notes” on page 749.
To enable Notation view:

 Enable the Notation view button in the MIDI 
Editor window toolbar.

– or –

 Right-click in the Notes pane and select 
Notation View.

Notation view enabled in a MIDI Editor window



Editing in Notation view in a MIDI Editor win-
dow works the same way as in the Score Editor 
window, but with the advantage of having access 
to Velocity, Controller, and Automation lanes. 

Double Bar in Notation View
The Double Bar button is only available in Nota-
tion view. When enabled, the Double Bar option 
shows the final double bar line in the MIDI Edi-
tor window. The double bar line is located at the 
end of the last MIDI clip or event in the session.

When the Double Bar option is disabled, there 
will be a number of empty bars at the end of the 
last event in the session. The number of empty 
bars is determined by the Additional Empty Bars 

In The Score Editor setting in the MIDI Prefer-
ences page (Setup > Preferences). Disable the 
Double Bar option to manually enter notes in the 
Score Editor after the last MIDI clip or event in 
the session.

Note that in Notation view, the Trim tool 
functions as the Grabber tool when over a 
note and as the Note Selector tool when not 
over a note.

In Notation view, the Edit mode is 
automatically set to Grid and cannot be 
changed.

Double Bar enabled in a MIDI Editor window
Notation View Right-Click Menu
When in Notation view, the Notes Pane Right-
click menu provides slightly different options 
than when in Superimposed Notes view. 

In both views, the following options are avail-
able:

• Tools

• Insert

• Cut

• Copy

• Paste

• Clear

• Separate

• Consolidate

• Mute

• MIDI Real-Time Properties

• Event Operations

• Open In New MIDI Editor

• Open In Score Editor

• Open In MIDI Event List.

• Display Notation

In Notation view, the additional Notation Display 

Track Settings option is available in the Right-
click menu. Select this option to open the Nota-
tion Display Track Settings dialog and configure 
the display settings for tracks in Notation view. 
For information on the Notation Display Track 
Settings dialog, see “Notation Display Track Set-
tings” on page 746.
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Velocity, Controller, and Automation Lanes
MIDI Editor windows let you edit velocities, MIDI controller data, and automation for all shown 
MIDI, Instrument, and Auxiliary Input tracks in lanes under the Notes pane.
Pro Tools Reference Guide
Velocity, Controller, and Automation lanes for two stereo Instrument tracks

Show/Hide lanes

Velocity lane
(2 tracks superimposed)

Remove lane
Add lane

Controller/Automation
Type selector

Paired Automation 
lanes for separate
tracks
You can move and resize Automation and Con-
troller lanes just like in the Edit window.

When viewing multiple MIDI and Instrument 
tracks, the velocities for notes on separate 
tracks are superimposed in a single lane, just 
like notes in the Notes pane. However, all other 
Controller lanes are grouped by automation and 
controller type, and provide individual lanes for 
each shown track.

To show or hide lanes under the Notes pane:

 Click the Show/Hide Lanes button.
To add lanes:

 Click the Add Lane button.

To remove lanes:

 Click the Remove Lane button.

To change the Automation or Controller type for a 
lane:

 Click the Automation or Controller Type se-
lector and select the Automation or Controller 
type you want.



Chapter 34: Score Editor

The Score Editor window lets you view, edit, arrange, and print MIDI from your session as music 
notation. MIDI notes are transcribed in real-time whether you record, import, draw (with the Pencil 
tool), or Step Enter MIDI. 
Score Editor window

Edit tools

Default Note Duration

Track List
Page controls Zoom controls

Grid selectorCursor location Target

Play MIDI Notes While Editing
Mirrored MIDI Editing

Double Bar

Default Note Velocity

Score Editor menu

Selection

Link Edit and Timeline Selection
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Opening the Score Editor 
Window
To open the Score Editor window:

 Choose Window > Score Editor.

To open the Score Editor window with a single 
MIDI or Instrument track shown:

1  Ensure that there is no Edit selection.

2  Right-click the Track name of an unselected 
track in the Edit or Mix window, or in the Track 
List of the Edit, Mix, or MIDI Editor window.

3  From the Right-click menu, choose Open In 

Score Editor.

To open the Score Editor window with the current 
Edit selection shown:

1  In the Edit window or in a MIDI Editor win-
dow, make an Edit selection on one or more 
tracks that includes what you want shown in the 
Score Editor window.

2  Right-click the Edit selection and choose Open 

In Score Editor.

Press Alt+Start+“=” (Windows) or 
Option+Control+“=” (Mac) to show the 
Score Editor window.

If the Score Editor option is selected as the 
“Double Clicking a MIDI Clip Opens” setting 
in the MIDI Preferences page, you can dou-
ble-click a MIDI clip to open it in the Score 
Editor.
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Edit Tools
The Edit tools in the Score Editor window func-
tion much the same as in the Edit window, but 
with a few differences for editing music nota-
tion.

Zoomer
Use the Zoomer tool to zoom in and out around 
a particular area in the score. 

The Zoomer tool provides two modes: 

Normal Zoom The Zoomer tool remains selected 
after zooming. 

Single Zoom The previously selected Edit tool is 
automatically reselected after zooming.

Normal Zoom Mode

To zoom around a certain point in the score:

1  Click the Zoomer tool pop-up menu and select 
Normal Zoom mode.

2  Click once with the Zoomer tool at a location 
within the score. The score is zoomed in by one 
level and is centered around the zoomed loca-
tion.

3  To zoom back to the previous level, Alt-click 
(Windows) or Option-click (Mac) with the 
Zoomer tool.

Press the F5 key to select the Zoomer tool 
and toggle between Normal and Single 
Zoom modes.

Also see “Score Editor Zoom Controls” on 
page 745



To marquee zoom to a particular area of the score:

1  Click the Zoomer tool pop-up menu and select 
Normal Zoom mode.

2  Drag in the score, making a marquee selection 
of the area to which you want to zoom.

The zoomed area fills the entire Edit window.

Single Zoom Mode 

Single Zoom mode returns you to the previously 
selected tool after a zoom has been performed.

For example, when using the Pencil tool you can 
select the Single Zoomer tool, and once the 
Zoom operation has been performed, Pro Tools 
automatically switches back to the Pencil tool.

Single Zoom is identified with an arrow to the 
right of the Zoomer icon. (Normal Zoom mode 
does not show the arrow.)

To use Single Zoom mode:

 Click the Zoomer tool pop-up menu and select 
Single Zoom mode.

Marquee zooming with the Zoomer tool
Trim
The Trim tool lets you lengthen or shorten the 
duration of a note in the Score Editor window.

Note Selector
Use the Note Selector tool to select notes on one 
or more staves in the Score Editor window. Se-
lected notes highlight blue. Selected notes can 
be deleted, moved, transposed, and processed 
(using Event Operations). 

Grabber
Use the Grabber tool to select one or more notes 
in the Score Editor window. You can also use the 
Grabber tool to move single notes, or all selected 
notes, to a different pitch or time location.

Pencil
Use the Pencil tools to insert, select, move, or 
delete notes in the Score Editor window. The 
various Pencil tools differ in how they draw note 
durations, repeated notes, and velocities, but 
function in the same fashion as drawing notes 
on tracks in Notes view in the Edit window or in 
a MIDI Editor window.

Press the F6 key to select the Trim tool.

Press the F7 key to select the Note Selector 
tool.

The Note Selector tool makes a range 
selection that only includes MIDI notes and 
velocities. It does not include any other 
MIDI data, such as program changes or con-
tinuous controller data. 

Press the F8 key to select the Grabber tool.
Chapter 34: Score Editor 737



738
To select a Pencil tool:

 Click the Pencil tool pop-up menu and select 
the Pencil tool you want.

The following Pencil tools are available in the 
Score Editor:

Free Hand

The Free Hand Pencil tool lets you draw single 
notes of varying duration. 

Note velocities are determined by the Default 
Note Velocity setting (see “Default Note On Ve-
locity” on page 739). 

The minimum duration of the note is deter-
mined by the selected Default Note Duration 
(see “Default Note Duration” on page 739).

Line

The Line Pencil tool lets you draw multiple 
notes of the same pitch and duration. 

Note velocities are determined by the Default 
Note Velocity setting (see “Default Note On Ve-
locity” on page 739). 

The duration is determined by the selected De-
fault Note Duration (see “Default Note Dura-
tion” on page 739). 

The start time for each note is determined by the 
selected Grid value (see “Grid” on page 741).

Press the F10 key to select the current Pencil 
tool. Press the F10 key repeatedly to cycle 
through the different Pencil tools.
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Triangle

The Triangle Pencil tool lets you draw a series of 
MIDI notes on a single pitch whose velocities os-
cillate between the defined Default Note Veloc-
ity and 127 in a triangle pattern. The duration of 
each note is determined by the current Grid 
value.

The duration is determined by the selected De-
fault Note Duration (see “Default Note Dura-
tion” on page 739). 

The start time for each note is determined by the 
selected Grid value (see “Grid” on page 741).

Square

The Square Pencil tool lets you draw a series of 
MIDI notes on a single pitch whose velocities al-
ternate between the defined Default Note Veloc-
ity and 127 in a square pattern. The duration of 
each note is determined by the current Grid 
value.

The duration is determined by the selected De-
fault Note Duration (see “Default Note Dura-
tion” on page 739). 

The start time for each note is determined by the 
selected Grid value (see “Grid” on page 741).

Random

The Square Pencil tool lets you draw a series of 
MIDI notes on a single pitch whose velocities 
change randomly within the range between the 
defined Default Note Velocity and 127 in a 
square pattern. The duration of each note is de-
termined by the current Grid value.

The duration is determined by the selected De-
fault Note Duration (see “Default Note Dura-
tion” on page 739). 

The start time for each note is determined by the 
selected Grid value (see “Grid” on page 741).



Default Note Duration
The Default Note Duration selector lets you de-
fine the default note duration for manually in-
serted notes.

To define the Default Note Duration:

 From the Default Note Duration selector, se-
lect a note value. Select the Follow Grid option if 
you want the Default Note Duration to use the 
selected Grid value.

If you want dotted note values, also select the 
Dotted option.

If you want triplet note values, also select the 
Triplet option.

Default Note On Velocity
The Default Note On Velocity setting lets you 
define the default Note On velocity for manually 
inserted notes.

Default Note Duration selector
Play MIDI Notes When 
Editing
When enabled, the Play MIDI Notes When Edit-
ing option causes MIDI notes to sound when you 
insert them with the Pencil tool or drag them 
with the Grabber tool. 

Link Timeline and Edit 
Selection
When this button is enabled, the Timeline and 
Edit selections are linked. When it is disabled, 
you can make Timeline and Edit selections inde-
pendently of one another.

Play MIDI Notes When Editing enabled in the Score 
Editor window

Link Timeline and Edit Selection enabled in the Score 
Editor window
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Mirrored MIDI Editing
Mirrored MIDI Editing lets you edit MIDI clips 
and have your edits apply to every copy of the 
same MIDI clip. This can be particularly useful 
when editing looped MIDI clips.

In Mirrored MIDI Editing mode, the Mirrored 
MIDI Editing button flashes Red once as an edit 
is made to alert you that your edit is being ap-
plied to more than one clip.

To enable Mirrored MIDI Editing, do one of the 
following:

 Select Options > Mirror MIDI Editing.

– or –

 Select the Mirrored MIDI Editing button in 
the Edit window, MIDI Editor window, or Score 
Editor window.

To disable Mirrored MIDI Editing, do one of the 
following:

 Deselect Options > Mirror MIDI Editing.

– or –

 Disable the Mirrored MIDI Editing button in 
the Edit window, MIDI Editor window, or Score 
Editor window.

Mirrored MIDI Editing disabled in the Score Editor 
window

If Mirrored MIDI Editing mode is disabled, 
and you edit notes of looped clips in Notes 
view, the edit flattens the loop. Similarly, 
editing clip groups separates the clip 
groups.
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Double Bar
When enabled, the Double Bar option shows the 
final double bar line in the Score Editor window. 
The double bar line is located at the end of the 
last MIDI clip or event in the session. Enable the 
Double Bar option when you are ready to print 
the score.

When the Double Bar option is disabled, there 
will be a number of empty bars at the end of the 
last MIDI clip in the session. The number of 
empty bars is determined by the Additional 

Empty Bars In The Score Editor setting in the 
Pro Tools MIDI Preferences (Setup > Prefer-

ences). Disable the Double Bar option to manu-
ally enter notes in the Score Editor after the last 
MIDI clip.

Cursor Location
The Cursor Location display provides informa-
tion about the current cursor location in 
Bars|Beats|Ticks and pitch.

Double Bar enabled in the Score Editor window

Cursor Location indicator in the Score Editor window



Grid
The Grid selector lets you define the Grid value 
for MIDI notes inserted and displayed in the 
Score Editor window. 

To set the Grid value for the Score Editor window:

 From the Grid Value pop-up menu, select a 
note value.

If you want dotted note values, also select the 
Dotted option.

If you want triplet note values, also select the 
Triplet option.

Inserting Notes on the Grid
When inserting MIDI notes with the Pencil tool 
(using the Line, Triangle, Square, or Random 
shapes), the Grid value determines the Note On 
location and the Default Note Duration value 
determines the note duration (see “Default Note 
Duration” on page 739). 

Setting the Grid value
For example, if the Default Note Duration is set 
to quarter notes and the Grid is set to half notes, 
drawing with the Line Pencil tool creates alter-
nating quarter notes and quarter note rests.

If the selected Grid value is shorter than the De-
fault Note Duration, the Grid value determines 
both the Note On location and note duration for 
notes inserted with the Pencil tool. For example, 
if the Default Note Duration is set to quarter 
notes and the Grid is set to eighth notes, draw-
ing with the Line Pencil tool creates a sequence 
of eighth notes.

Score Editor Window Target
When the Target is enabled for the Score Editor 
window, navigating the Edit window automati-
cally navigates the Score Editor window as well. 
For example, if in the Edit window you navigate 
to bar 32, beat 3 in a MIDI track, when you view 
the Score Editor window it too will show the 
same location.

When the Target is disabled, the Score Editor 
does not update to show the current Edit win-
dow selection or Edit cursor location.

Inserting notes on the Grid
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Score Editor Window Menu
The Score Editor Window menu provides access 
to the Expanded Edit Tools, Selection Display, 
Track List, and Scrolling options.

Expanded Edit Tools
When selected, the Expanded Edit Tools option 
displays all of the relevant Edit Tools in the 
Score Editor window toolbar. 

When this option is not selected, only the icon 
for the selected Edit tool is displayed. Any of the 
other Edit tools can be selected from the Edit 
Tool pop-up menu.

Selection Display
When selected, the Selection Display option 
shows the Edit Selection Display in the MIDI Ed-
itor window toolbar.

Track List
When selected, the Track List option displays the 
Track List in the Score Editor window.

Selection display
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Scrolling
The Scrolling submenu lets you select the scroll-
ing options for the Score Editor window inde-
pendently of the Edit window and any MIDI Ed-
itor windows. The scrolling options include:

No Scrolling The Score Editor window does not 
scroll during or after playback. The playback 
cursor moves across the Edit window, indicating 
the playback location.

After Playback The playback cursor moves 
across the Score Editor window, indicating the 
playback location. When playback has stopped, 
the Score Editor window scrolls to the final play-
back location.

Page The playback cursor moves across the 
Score Editor window, indicating the playback 
location. When the right edge of the current 
page shown in the Score Editor window is 
reached, it scrolls to the next page and the play-
back cursor continues moving from the left edge 
of the window.

Follow Edit Window When selected, the Score 
Editor window follows the scrolling option se-
lected for the Edit window (Options > Edit Win-

dow Scrolling).

For Pro Tools|HD systems, the Continuous 
and Center Playhead scrolling options are 
not available in the Score Editor window. If 
the Score Editor window is set to the Follow 
Edit Window scrolling option and the Edit 
window is set to either the Continuous or 
Center Playhead scrolling options, the Score 
Editor window scrolls by page.



Customizable Toolbar
You can customize the toolbar in the Score Edi-
tor window by re-arranging, and showing or 
hiding the available controls and displays just 
like in the Edit window or MIDI Editor windows.

Changing Toolbar Display 
Options

To change the toolbar display options in the Score 
Editor window toolbar:

1  Do one of the following:

• Click the Score Editor Window Toolbar 
menu.

– or –

• Right-click in the Toolbar.

2  From the pop-up menu, select or deselect any 
of the following:

• Selection Display

• Expanded Edit Tools

Rearranging Controls and 
Displays

To rearrange controls and displays in a MIDI Editor 
window toolbar:

 Control-click (Windows) or Command-click 
(Mac) the controls or displays you want to move 
and drag them to a new location in the Toolbar.
Track List
The Track List lets you show and hide MIDI and 
Instrument tracks in the Score Editor. It also 
provides access to the Notation Display Track 
Settings and Score Setup (see “Notation Display 
Track Settings” on page 746 and “Score Setup” 
on page 747).

To show or hide the Track List in the Score Editor 
window:

 From the Score Editor Window menu, select or 
deselect Track List.

Showing and Hiding Tracks
Use the Track List to show and hide MIDI and 
Instrument tracks as staves in the score.

To show MIDI and Instrument tracks in the Score 
Editor:

 Enable the Track Show/Hide icon in the Track 
List for tracks you want to show in the score.

Partial Score: Violin I and Violin II shown; all other 
tracks are hidden
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To show all MIDI and Instrument tracks in the 
Score Editor:

 From the Track List pop-up menu, select Show 

All Tracks.

To show only selected MIDI and Instrument tracks 
in the Score Editor:

1  In the Track List, select the MIDI and Instru-
ment tracks you want to show in the score.

2  From the Track List pop-up menu, select Show 

Only Selected Tracks.

To hide MIDI and Instrument tracks in the Score 
Editor:

 Disable the Track Show/Hide icon in the Track 
List for tracks you want to hide in the score.

To hide all MIDI and Instrument tracks in the Score 
Editor:

 From the Track List pop-up menu, select Hide 

All Tracks.

To hide selected MIDI and Instrument tracks in the 
Score Editor:

1  In the Track List, select the MIDI and Instru-
ment tracks you want to hide in the score.

2  From the Track List pop-up menu, select Hide 

Selected Tracks.
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Page Controls
The Score Editor window provides controls for 
navigating forward and backward by page. The 
current page number is displayed in the lower-
left corner of the window.

To display the next page of the score:

 Click the Page Forward button.

To display the previous page of the score:

 Click the Page Back button.

To display any specific page of the score:

1  Click the Current Page display.

2  Type the page number for the page you want to 
view.

3  Press Enter (Windows) or Return (Mac).

Score Editor Page controls

Page Forward

Page Back
Current Page Display



Score Editor Zoom Controls
In addition to the Zoomer tool, the Score Editor 
provides Zoom In and Out buttons in the lower 
right hand corner of the window. It also pro-
vides a Zoom selector that lets you zoom to a 
preset percentage or page size. When using 
these Zoom controls, the Score Editor zooms 
around the current Edit selection.

To zoom in one level:

 Click the Zoom In button.

To zoom out one level:

 Click the Zoom Out button.

To zoom to a preset percentage:

1  Click the Zoom selector.

2  From the Zoom pop-up menu, select the zoom 
percentage.

Score Editor Zoom controls

Zoom In
Zoom Out

Zoom selector
To zoom to a page size:

1  Click the Zoom selector.

2  From the Zoom pop-up menu, select the page 
size.

Zoom to Page Sizes
The Zoom pop-up menu provides the following 
page sizes:

Fit Page Width Zooms so that the width of one 
page fits in the Score Editor window.

Fit Page Height Zooms so that the height of the 
page fits in the Score Editor window.

Fit Page Zooms so that an entire page fits in the 
Score Editor window.

Fit 2 Pages Zooms so that two pages fit horizon-
tally in the Score Editor window.

Selecting a zoom percentage from the Zoom pop-up 
menu
Chapter 34: Score Editor 745



746
Notation Display Track 
Settings
The Notation Display Track settings determine 
how individual MIDI and Instrument tracks ap-
pear in the Score Editor. You can set the Clef, 
Display Quantization, and whether or not to dis-
play the track at “concert pitch” or as a trans-
posing instrument (such as a B-flat tenor sax).

To configure the Notation Display Track settings:

1  Do one of the following:

• From the Track menu in the Score Editor, 
select Notation Display Track Settings.

• Right-click in the Score Editor and select 
Notation Display Track Settings.

• Double-click a Clef on a Staff.

2  From the Track pop-up menu, select the MIDI 
or Instrument track whose Notation Display Set-
tings you want to change.

3  Configure the settings.

4  Repeat the preceding steps for other MIDI and 
Instrument tracks as necessary.

Notation Display Track Settings
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Notation Display Track Settings 
Options

Track

From the Track pop-up menu, select the track 
you want to configure.

Clef

From the Clef pop-up menu, select the Clef you 
want for the selected track from the following 
options:

• Grand Staff

• Treble Clef

• Bass Clef

• Alto Clef

• Tenor Clef

Display Transposition

From the Key pop-up menu, select the key of 
Transposition for the track. For instruments 
that transpose from another octave, you can also 
adjust the Octave slider. For example, for a Bass 
Clarinet track, select the Key of B-flat and set 
the Octave slider to +1. This way, when you 
print the Bass Clarinet part, the player will be 
able to read the part and concert pitch will 
sound correctly a major ninth below where the 
part is written.

Attributes

The Attributes tab lets you specify the notation 
display quantization settings for the selected 
track. If the Clef is set to Grand Staff, you can 
also set the Split Point to divide notes between 
the treble and bass clefs.



Follow Globals

When the Follow Globals option is selected, the 
track attributes use the global attributes settings 
(see “Globals” on page 747). This option is en-
abled for all tracks by default.

Display Quantization

The Display Quantization setting lets you select 
the quantization grid for the display of MIDI 
notes in music notation. MIDI notes in 
Pro Tools still maintain their original start time 
and duration, but this setting affects what note 
values are displayed. The notation display is 
quantized to the nearest select note value.

Straighten Swing

When enabled, the Straighten Swing option 
causes “swung” notes to be displayed as straight 
notation. For example, a run of swung eighth 
notes will be displayed as straight eighth notes.

Allow Note Overlap

Pro Tools only displays a single rhythmic line 
on a single staff. When two notes that start at 
different times overlap, the first note will be 
truncated when the second note begins. If the Al-

low Note Overlap option is enabled, Pro Tools 
displays the full length of overlapping notes us-
ing tied notes.

Notation Display Track Settings window, Attributes tab
Split Point

When the Clef for the selected track is set to 
Grand Staff, the selected Split Point setting de-
termines at which pitch the notes are placed in 
either the upper or lower staff of the Grand 
Staff.

Automatic When selected, Pro Tools splits notes 
between the upper and lower staves of the Grand 
Staff based on logical note groupings.

Fixed When selected, you can specify a particu-
lar pitch at which to split notes between the up-
per and lower staves of the Grand Staff.

Globals

The Globals tab provides the same settings as the 
Attributes tab (see “Attributes” on page 746). 
You can select which tracks follow the settings 
in the Globals tab in the Attributes tab for each 
track.

Score Setup
The Score Setup window lets you set up the page 
layout and staff spacing. You can enter the Title 
and Composer for the score. You can also select 
what elements of the score to display. Changes 
to the Score Setup update instantly in the Score 
Editor.

To open the Score Setup, do one of the following:

 Choose File > Score Setup.

 From the Tracks menu in the Score Editor win-
dow, select Score Setup.

 Right-click in the Score Editor window and se-
lect Score Setup.
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Score Setup Window Options

Information

Title Enter the Title for the score. This appears 
at the top of the first page.

Composer Enter the Composer for the score. 
This appears in the upper right-hand corner of 
the first page.

Display

The Display options determine which score ele-
ments you want displayed in the score. Deselect 
the elements you do not want displayed in the 
score.

Score Setup window
Pro Tools Reference Guide
Title and Composer Select to display the Title 
and Composer on the score.

Page Numbers Select to display Page Numbers 
at the bottom of each page.

Bar Numbers Select to display Bar Numbers at 
the beginning of each system above the top staff.

Track Names Select to display Track Names for 
each staff at the beginning of the score.

Chord Symbols Select to display chord symbols 
in the score.

Chord Diagrams Select to display Chord Dia-
grams (guitar tablature) in the score (see “Chord 
Symbols and Diagrams” on page 754).

Spacing

Between Staves Enter the spacing you want be-
tween staves.

Between Systems Enter the spacing you want 
between systems.

Below Title and Composer Enter the spacing you 
want between the Title and Composer and the 
first staff of the score.

Below Chord Symbols and Diagrams Enter the 
spacing you want between Chord Symbols and 
Diagrams and the top stave of each system.

Layout

Page Size Select the page size (Letter, Legal, Tab-

loid, or A4).

Disable the Chord Diagrams option when 
printing charts and lead sheets where you 
just want to see chord symbols.

On pages where the music is vertically justi-
fied, the distance between staves and systems 
will be larger than the numbers specified.



Portrait Select to set the page orientation to Por-
trait.

Landscape Select to set the page orientation to 
Landscape.

Staff Size Enter the Staff Size.

Page Margins Enter the size for the top, bottom, 
left, and right page margins. 

Inches Select to enter Stave Size and Page Mar-
gins in inches.

Millimeters Select to enter Stave Size and Page 
Margins in millimeters.

Editing Notes
MIDI note editing in the Edit window, MIDI Ed-
itor windows, and the Score Editor window all 
affect the same MIDI data. When editing in one 
window, your edits are reflected in all other win-
dows. 

The Score Editor provides simple score editing 
tools for entering, moving, and transposing 
MIDI notes as music notation: 

• The Trim tool lets you lengthen or shorten the 
duration of notes.

• The Note Selector tool lets you make object se-
lections of notes in the score.

• The Grabber tool lets you select and move 
notes to another time or pitch location on the 
same track. 

• The Pencil tool lets you insert notes and move 
them to another time or pitch location on the 
same track.

Selecting Notes
You can use either the Note Selector tool or the 
Grabber tool to select notes on one or more 
staves.
To select notes on one or more staves with the 
Note Selector tool:

1  Click the Note Selector tool.

2  Drag in the score to highlight the notes you 
want to select.

To make a marquee selection on one or more 
staves with the Grabber tool:

1  Click the Grabber tool.

2  Drag in the score to highlight the notes you 
want to select.

Transposing Notes
You can use the Grabber tool or the Pencil tool 
to manually transpose a note up or down. You 
can also use the Transpose Event Operation 
(Event > Event Operations > Transpose) to trans-
pose selected notes.

Selecting notes with the Note Selector tool

Selecting notes with the Grabber tool
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To transpose a single note:

1  Click the Grabber tool.

2  Drag the note you want to transpose up or 
down.

To transpose all selected notes:

1  Click the Grabber tool.

2  Drag around the notes you want to Transpose 
to select them.

3  Drag any of the selected notes up or down to 
transpose them.

Moving Notes
Use the Grabber tool to move selected notes 
from one time location to another time location 
on the same staff. When moving notes in the 
Score Editor, the underlying MIDI notes main-
tain their position relative to the Grid.

To move notes to another time location:

1  Click the Grabber tool.

2  If you want to move more than one note, drag 
around the notes you want to move to select 
them.

Transposing a note with the Grabber tool

Transposing selected notes with the Grabber tool
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3  Drag any of the selected notes to another time 
location on the same staff.

Inserting Notes
Use the Pencil tool to manually insert notes in 
the Score Editor. When you insert a note, the 
Score Editor automatically places it on the Grid 
and creates rests where appropriate.

To manually insert a note:

1  Select the Default Note Duration setting you 
want (see “Default Note Duration” on page 739).

2  Select the Grid setting you want (see “Grid” on 
page 741).

3  Select the Default Note On Velocity (see “De-
fault Note On Velocity” on page 739).

4  Click the Pencil tool and select Free Hand.

Moving selected notes with the Grabber tool

You can also Nudge notes in the Score Editor 
by the currently selected Grid value.

You can also enter notes by recording MIDI, 
importing MIDI from a file, or using Step Input 
(Event > Event Operations > Step Input).



5  With the Free Hand Pencil tool, do any of the 
following:

• Single-click at the time location and pitch 
you want to enter a single note of the se-
lected Default Note Duration.

– or –

• Click at the time location and pitch you 
want and drag to the right to increase the 
duration of the note. Release the mouse 
when you have the duration you want.

To manually insert multiple notes of the same 
pitch:

1  Select the Default Note Duration setting you 
want (see “Default Note Duration” on page 739).

2  Select the Grid setting you want (see “Grid” on 
page 741).

3  Select the Default Note On Velocity (see “De-
fault Note On Velocity” on page 739).

Entering a single note with the Pencil tool

Entering a single longer note with the Pencil tool
4  Click the Pencil tool and select any of the fol-
lowing shapes:

• Line

• Triangle

• Square

• Random

5  Click at the time location and pitch you want 
and drag to the right. Repeated notes of the se-
lected Default Note Duration are entered on the 
selected Grid. The Note On velocities for each 
note are determined in part by the Default Note 
On Velocity setting and the selected Pencil tool 
shape (see “Pencil” on page 737).

Rests
The Score Editor automatically adds rests as 
necessary. Rests cannot be moved or inserted 
manually.

Entering multiple note of the same pitch with the Line 
Pencil tool
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Score Editor Right-Click 
Menu
The Score Editor Right-click menu provides sev-
eral useful commands for editing, exporting, 
and formatting the score and MIDI data.

To access the Score Editor Right-click menu:

 Right-click anywhere on the score.

Score Editor Right-Click Menu 
Items

Tools

The Tools submenu lets you select any Edit tools 
relevant to the Score Editor.

Zoomer Selects the Zoomer tool.

Note Selector Selects the Note Selector tool.

Grabber Selects the Grabber tool.

Pencil Selects the Pencil tool.

Insert

The Insert submenu lets you insert key changes, 
meter changes, and chord symbols into the score 
at the location of the Edit cursor.

Key Inserts a key change.

Meter Inserts a meter change.

Chord Inserts a chord symbol.

Cut

The Cut command cuts the current Edit selec-
tion.

Copy

The Copy command copies the current Edit se-
lection.
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Paste

The Paste command pastes the clipboard to the 
current Edit selection or at the current Edit cur-
sor location. Any MIDI notes already present at 
the same location are overwritten.

Merge

The Merge command pastes the clipboard to the 
current Edit selection or at the current Edit cur-
sor location and merges the pasted data with any 
MIDI notes already present at the same 
location.

Clear

The Clear command clears (deletes) the current 
Edit selection.

Event Operations

The Event Operations submenu lets you select 
any of the Event Operations windows (such as 
Quantize or Change Velocity).

Open in MIDI Editor

Choosing the Open in MIDI Editor option opens 
the tracks shown in the Score Editor in a MIDI 
Editor window.

Open in MIDI Event List

The Open In MIDI Event List option opens the se-
lected track in the MIDI Event List.

Notation Display Track Settings

Choosing the Notation Display Track Settings op-
tion opens the Notation Display Track Settings 
dialog (see “Notation Display Track Settings” on 
page 746).



Score Setup

Choosing the Score Setup option opens the 
Score Setup dialog (see “Score Setup” on 
page 747).

Send to Sibelius

Choosing the Send to Sibelius option command 
sends the score exactly as it appears in the Score 
Editor window to Sibelius notation software (see 
“Exporting Scores” on page 756).

Print Score

Choosing the Print Score command prints the 
score (see “Printing Scores” on page 756).

Key Changes
You can add, edit, and delete Key Signatures in 
your score. Key Signatures affect the note spell-
ing of MIDI notes in the score. For example, 
MIDI note number 58 (“B-flat 3”) is B-flat in F 
major, but it is A-sharp in B major.

To add a Key Signature:

1  With the Note Selector, Grabber, or Pencil tool, 
Right-click at the location in the score where you 
want to change key and select Insert > Key 

Change.

2  In the Key Change dialog, select the mode 
(major or minor), the key, its location and range, 
and how you want it to affect pitched tracks.

3  Click OK.

The selected Key Signature is displayed in the 
score and the note spellings for notes after the 
key change are updated accordingly.

You can also add and delete Key Signatures 
in the Key Signatures ruler in the Edit win-
dow or in any MIDI Editor window.
To edit a Key Signature:

1  With the Grabber tool, double-click the Key 
Signature you want to edit.

2  Enter values in the Key Change dialog and 
click OK.

To delete a Key Signature:

 With the Grabber tool, Alt-click (Windows) or 
Option-click (Mac) the Key Signature you want 
to delete.

Meter Changes
You can add, edit, and delete Meters in your 
score. Meter changes affect the number of bars 
in the score (and in your session). When chang-
ing meter, notes are not moved, but the barlines 
will be redrawn.

To add a Meter change:

1  Do one of the following:

• Choose Event > Time Operations > Change 

Meter.

– or –

• With the Note Selector, Grabber, or Pencil 
tool, Right-click at the location in the score 
where you want to change meter and select 
Insert > Meter Change.

You can also add and delete Meters in the 
Meter ruler in the Edit window and in MIDI 
Editor windows.
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2  In the Meter Change dialog, do the following:

• Enter the Location and Meter for the meter 
change.

– and –

• If you want the inserted meter event to fall 
cleanly on the first beat of the nearest mea-
sure, select the Snap To Bar option.

3  Select a note value for the number of clicks to 
sound in each measure. For a dotted-note click 
value, select the dot (.) option in addition to the 
note value.

4  Click OK to insert the new meter.

Meter Change dialog

For some meters, it may be desirable to use a 
dotted value for the click. For instance, if us-
ing a meter of 6/8, a dotted quarter note 
click (yielding two clicks per measure) is 
generally more suitable than a straight 
eighth note click (six clicks per measure).
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To edit a Meter change:

1  With the Grabber tool, double-click the Meter 
event you want to edit.

2  Enter values in the Meter Change dialog and 
click OK.

To delete a Meter change:

 With the Grabber tool, Alt-click (Windows) or 
Option-click (Mac) the Meter event you want to 
delete.

Chord Symbols and Diagrams
You can add, edit, and delete chord symbols and 
chord diagrams (guitar tablature) in your score. 
Chord symbols have no effect on MIDI data. 
Also, chord symbols are not included when ex-
porting MIDI data from Pro Tools to a MIDI file, 
but they are included when exporting to a Sibel-
ius file (.sib) or when using the Send to Sibelius 
command.

You can also add and delete chord symbols in 
the Chord Symbol ruler in the Edit window 
and in MIDI Editor windows. However, 
Chord Diagrams (guitar tab) are only 
displayed in the Score Editor window.



To insert a chord symbol:

1  With the Note Selector, Grabber, or Pencil tool, 
Right-click at the location in the score where you 
want to add a chord symbol and select Insert > 

Chord.

2  In the Chord Change dialog, select the name 
for the root of the Chord from the Chord selector 
(such as D).

3  Select the quality from the Chord Quality se-
lector (such as major or minor).

4  Select the bass note of the chord from the Bass 
selector (such as B-flat for an inverted G minor 
chord).

5  Select a Chord Diagram (guitar tablature) 
from the available options.

6  Click OK.

Chord Change dialog

Chord selector
Chord Quality

selector Bass selector

Chord Diagrams
The selected chord symbol is placed above the 
top staff in the system.

To edit a chord symbol:

1  With the Grabber tool, double-click the chord 
symbol you want to edit.

2  Make changes in the Chord Change dialog, and 
click OK.

To move a chord symbol:

 With the Grabber tool, drag the chord symbol 
to a new location.

To delete a chord symbol:

 With the Grabber tool, Alt-click (Windows) or 
Option-click (Mac) the chord symbol you want 
to delete.

To display or hide chord symbols in the score:

 In the Score Settings dialog (File > Score 

Setup), enable or disable the Chord Symbols op-
tion.

To display or hide chord diagrams (guitar tab) in 
the score:

 In the Score Settings dialog (File > Score 

Setup), enable or disable the Chord Diagrams 

option.

Chord symbol and diagram in the score
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Exporting Scores
Pro Tools lets you export the score from your 
session as a Sibelius (.sib) file. You can then 
open your score in Sibelius as transcribed by 
Pro Tools, edit the notation in Sibelius, and 
print the score and parts from Sibelius.

To export a score from Pro Tools:

1  Configure the score for your session in Score 
Editor window.

2  Choose File > Export > To Sibelius.

3  Select a destination and click Save.

To send the score from your Pro Tools session to 
Sibelius, do one of the following:

1  Configure the score for your session in the 
Score Editor window.

2  Do one of the following:

• Choose File > Send to Sibelius.

– or –

• Right-click in the Score Editor and choose 
Send to Sibelius.

Pro Tools exports all Instrument and MIDI 
tracks shown in the Score Editor to Sibelius as a 
.sib file and launches Sibelius if it is installed on 
your computer. You can then further edit the 
notation in Sibelius and print the score or parts 
from Sibelius.

Sibelius 5.x or higher is required to open 
.sib files exported from Pro Tools.
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Printing Scores
Pro Tools lets you print the score from your 
Pro Tools session. The score will be printed ex-
actly as it appears in the Score Editor window. 
Configure the Score Setup and show or hide any 
MIDI and Instrument tracks. Only those tracks 
that are shown in the score will be printed.

To print the score from your Pro Tools session:

1  Open the Score Editor window and configure 
your score.

2  Choose File > Print Score.

3  Configure the Print dialog as necessary and 
click OK (Windows) or Print (Mac).

Press Control+P (Windows) or Command+P 
(Mac) to print the score.



Chapter 35: MIDI Event List
The MIDI Event List displays a detailed list of all 
events in a single MIDI or Instrument track. The 
events are displayed with text and numbers, al-
lowing you to precisely edit their location, 
length, and event values.

Events in the MIDI Event List can be copied and 
pasted, selected, or deleted. Any MIDI event 
(except Sysex data) can be inserted and edited in 
the list. Certain MIDI event types can be hidden 
with the View Filter.

MIDI Event List

Unlike playlists in the Edit window, you can 
insert and display polyphonic aftertouch in 
the MIDI Event List.

Mute data for MIDI and Instrument tracks 
is not displayed in the MIDI Event List.

Track selector

MIDI Event List menuNumber of Events

Target
Opening the MIDI Event List
To open the MIDI Event List, do one of the 
following:

 Choose Window > MIDI Event List.

– or –

 Right-click a MIDI or Instrument track name 
in the Mix or Edit window, or in the Track List.

Track Selector
The Track selector in the MIDI Event List both 
indicates the currently displayed MIDI or In-
strument track and can be used to choose a dif-
ferent MIDI or Instrument track to be displayed.

Number of Events
The number of MIDI events on the selected track 
are displayed at the top of the MIDI Event List.

Target
The Target button for the MIDI Event List deter-
mines whether or not the MIDI Event List fol-
lows the Edit cursor and Edit selections in the 
Edit window and MIDI Editor windows. For ex-
ample, when the Target is enabled, the Events 
shown in the MIDI Event List update to show the 

Press Alt+Equal (Windows) or 
Option+Equal (Mac) to open the MIDI 
Event List.
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event in the Edit selection in the Edit window. 
When the Target is disabled, the MIDI Event 
List shows the same events regardless of changes 
to the Edit selection in other windows.

MIDI Event List Menu
The MIDI Event List menu contains commands 
and options for the MIDI Event List (see “MIDI 
Event List Options” on page 764). 

Columns in the MIDI Event List
Information for the events in the MIDI Event 
List is displayed in the following three columns:

Start Column Displays the start location, using 
the Main Time Scale, for each event. Locations 
can also be displayed in the Sub Time Scale when 
the Show Sub Counter option is selected in the 
Options pop-up menu.

The playback cursor appears as a blue arrow 
(red, when tracks are record-enabled) in the 
Start column.

When several events reside at the same location, 
the location is only indicated for the top event, 
with the others dimmed. The dimmed locations 
can be edited by double-clicking them.

MIDI Event List columns

double-click 
to edit

simultaneous
MIDI events

Playback cursor
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Event Column Displays the event type, indicated 
by an icon, and associated event values.

Length/Info Column Displays the end point or 
length for notes, depending on which option is 
selected in the Options pop-up menu. Also dis-
played are the names for continuous controller 
events and program changes.

View Filter for MIDI Event List
You can use the View Filter to specify which 
event types are displayed in the MIDI Event List. 
This can help you zero in on only the events you 
want to affect; it also protects MIDI events from 
being edited or deleted. Events not displayed in 
the MIDI Event List still play back.

The View Filter can be set to display “all” mes-
sages, “only” the specified messages, or “all ex-
cept” the specified messages.

When inserting an event type that has been 
filtered from the MIDI Event List, that event 
type will no longer be filtered.



Example: To filter the display of aftertouch and 
System Exclusive Messages in the MIDI Event 
List:

1  In the MIDI Event List, choose View Filter from 
the MIDI Event List menu.

2  In the MIDI Event List View Filter dialog, se-
lect the All Except option.

3  Select the options for Mono Aftertouch, Poly-

phonic Aftertouch, and System Exclusive. Leave 
all other messages deselected.

When using the All Except option, the selected 
events are not displayed. Conversely, when us-
ing the Only option, only the selected events are 
displayed.

4  Click OK.

With the MIDI Event List as the front-most 
window, press Control+F (Windows) or 
Command+F (Mac) to open the MIDI Event 
List View Filter dialog.

MIDI Event List View Filter dialog
Navigating in the MIDI Event List
You can use the Tab and Arrow keys to move 
through the MIDI Event List. You can also locate 
to the Edit start point, or any other specified lo-
cation.

To move through the MIDI Event List, do any of the 
following:

• Double-click to edit a value.

• Press Tab or the Down Arrow to move to the 
next event (with or without the edit field se-
lected).

• Press Control+Tab (Windows) or Option+Tab 
(Mac) or the Up Arrow to move to the previous 
event (with or without the edit field selected).

• With an edit field selected, press the Right Ar-
row to move to the next edit field to the right.

• With an edit field selected, press the Left Ar-
row to move to the next edit field to the left.

To keep the last event selected, press Shift while 
moving to the next or previous event.

To go to the Edit start point:

 In the MIDI Event List, choose Scroll To Edit 

Selection from the MIDI Event List menu.

To go to a specific location in the MIDI Event List:

1  In the MIDI Event List, choose Go To from the 
MIDI Event List menu.

2  In the Go To dialog, choose a format from the 
Time Scale pop-up menu.

With the MIDI Event List as the front-most 
window, press Control+G (Windows) or Com-
mand+G (Mac) to open the Go To dialog.
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3  If using Timecode, you can select the Use Sub-

frames option.

4  Enter the location you want to go to, then click 
OK.

The following items from the MIDI Event List 
menu affect navigating in the MIDI Event List:

• When the Page Scroll During Playback op-
tion is selected, the MIDI Event List scrolls 
during playback.

• When Scroll During Edit Selection is se-
lected, the MIDI Event List is scrolled auto-
matically when the Edit selection changes 
in the Edit window.

Go To dialog
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Inserting Events in the MIDI 
Event List
You can insert events in the MIDI Event List by 
choosing an event type from the MIDI Event List 
menu. Following are several examples of insert-
ing events in the MIDI Event List.

To insert a note in the MIDI Event List:

1  From the MIDI Event List menu, select Insert > 

Note.

2  Enter the location, pitch, attack (Note On) and 
release (Note Off ) velocities, and length for the 
new note. To move between the Event Entry 
fields, use the Left and Right Arrow keys. 

When a field is selected, enter a value with any 
of the following methods:

• Enter the value on the numeric keypad.

• Drag up or down to scroll to the value.

• Play the note on your MIDI controller key-
board, then press Enter (Windows) or Re-
turn (Mac) on the alphanumeric keyboard 
to confirm the value.

With the MIDI Event List as the front-most 
window, press Control+N (Windows) or 
Command+N (Mac) to Insert a note.

Event Entry fields for note

With the Start field selected, you can auto-
matically enter the location of another event 
already in the track by clicking that event.

Pitch

Attack velocity

Release velocity



3  Do one of the following:

• To insert the note and remain in Event 
Entry mode, press Enter on the numeric 
keypad.

• To insert the note and exit Event Entry 
mode, press Enter (Windows) or Return 
(Mac) on the alphanumeric keyboard.

• To exit Event Entry mode, without insert-
ing the note event, press Escape on the 
alphanumeric keyboard.

To insert a controller event in the MIDI Event List:

1  From the MIDI Event List menu, choose Insert 

> Controller.

2  Enter the location, controller “type” number, 
and controller value for the new event. The con-
troller name is displayed in the Length/Info col-
umn, to the right of the controller value. To 
move between the Event Entry fields, use the 
Left and Right Arrow keys.

With the MIDI Event List as the front-most 
window, press Control+L (Windows) or 
Command+L (Mac) to Insert a controller 
event.

Event Entry fields for controller event

Controller number Controller name

Controller value
When a field is selected, enter a value with any 
of the following methods:

• Enter the value on the numeric keypad.

• Press the Up or Down Arrow to scroll to the 
value.

• While pressing Control (Windows) or Com-
mand (Mac), drag up or down to scroll to 
the value.

• Play the controller event on your MIDI con-
troller keyboard, then press Enter (Win-
dows) or Return (Mac) on the 
alphanumeric keyboard to confirm the 
value.

3  Do one of the following:

• To insert the controller event and remain in 
Event Entry mode, press Enter on the nu-
meric keypad.

• To insert the controller event and exit Event 
Entry mode, press Enter (Windows) or Re-
turn (Mac) on the alphanumeric keyboard.

• To exit Event Entry mode, without insert-
ing the controller event, press Escape on 
the alphanumeric keyboard.

With the Start field selected, you can auto-
matically enter the location of another event 
already in the track by clicking that event.
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To insert a program change in the MIDI Event List:

1  From the MIDI Event List menu, choose Insert 

> Program Change.

2  Enter the location for the new event.

3  Enter a Program Change number and Bank Se-
lect value (if necessary). The program change 
name is displayed in the Info column.

You can click in the Length/Info column to open 
the Program Change window (for details, see 
“Patch Select (Program and Bank Changes)” on 
page 700). 

4  Do one of the following:

• To insert the program change and remain in 
Event Entry mode, press Enter on the nu-
meric keypad.

• To insert the program change and exit 
Event Entry mode, press Enter (Windows) 
or Return (Mac) on the alphanumeric key-
board.

• To exit Event Entry mode, without insert-
ing the program change, press Escape on 
the alphanumeric keyboard.

With the MIDI Event List as the front-most 
window, press Control+P (Windows) or 
Command+P (Mac) to Insert a program 
change event.

Event Entry fields for program change

With the Start field selected, you can auto-
matically enter the location of another event 
already in the track by clicking that event.

Program number Program name

Controller 0 value

Controller 32 value
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Inserting Another Event
After inserting an event, you can easily insert 
another event of the same type. The event type 
to be inserted is indicated at the bottom of the 
Insert menu.

Example: After inserting a note, to insert another, 
do one of the following:

 From the MIDI Event List menu, select Insert > 

Another Note.

Editing Events in the MIDI 
Event List
Events in the MIDI Event List can be edited, se-
lected, deleted, and copied and pasted.

To edit an event in the MIDI Event List:

1  Do one of the following:

• Double-click the event field you want to 
edit.

– or –

• To edit a selected event, press Control+En-
ter (Windows) or Command+Enter (Mac).

With the MIDI Event List as the front-most 
window, press Control+M (Windows) or 
Command+M (Mac) to Insert a note.

When the option for Insert At Playback Lo-
cation is enabled (see “MIDI Event List Op-
tions” on page 764), you can use the key-
board shortcuts for inserting “another” 
event to insert events on-the-fly.



2  Enter a new value with any of the following 
methods:

• Enter the new value on the numeric keypad.

• While pressing Alt (Windows) or Option 
(Mac), press the Up or Down Arrow to 
scroll to a new value.

• While pressing Control (Windows) or Com-
mand (Mac), drag up or down to scroll to a 
new value.

• Play the new note or controller value on 
your MIDI controller keyboard, then press 
Enter (Windows) or Return (Mac) on the al-
phanumeric keyboard to confirm.

3  Do one of the following:

• To enter the new event value and move to 
another field or event, use the Arrow keys.

• To enter the new value and remain in Edit 
Entry mode, press Enter on the numeric 
keypad.

• To enter the new value and exit Edit Entry 
mode, press Enter (Windows) or Return 
(Mac) on the alphanumeric keyboard.

• To exit Edit Entry mode without entering 
the new value, press Escape on the alphanu-
meric keyboard.

Selecting Events in the MIDI 
Event List

To select a range of events in the MIDI Event List, 
do one of the following:

 Click the event at the beginning of the selec-
tion and drag to the ending event.

– or –

 Shift-click the event at the beginning of the se-
lection, then Shift-click the ending event.
To select noncontiguous events in the MIDI Event 
List:

 Control-click (Windows) or Command-click 
(Mac) each event.

To deselect an event in the MIDI Event List:

 Control-click (Windows) or Command-click 
(Mac) the selected event.

Deleting Events in the MIDI 
Event List

To delete an event in the MIDI Event List:

 Alt-click (Windows) or Option-click (Mac) the 
event you want to delete.

To delete a selection of events in the MIDI Event 
List:

1  Select the events you want to delete by either 
dragging in the Start column, or by Shift-click-
ing each event.

2  To view only the events you want to delete, use 
the View Filter (see “View Filter for MIDI Event 
List” on page 758). Events not displayed cannot 
be deleted.

3  Do one of the following:

• Choose Edit > Clear to delete all selected 
events.

– or –

• Press Backspace (Windows) or Delete 
(Mac) on the alphanumeric keyboard.

Notes selected in the MIDI Event List can be 
modified by any of the commands in the 
Event Operations window (see Chapter 42, 
“Event Operations”).
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Copying and Pasting Events in 
the MIDI Event List

To copy and paste events in the MIDI Event List:

1  Select the events you want to copy in the MIDI 
Event List.

2  Choose Edit > Copy.

3  Do one of the following:

• To paste the material at an existing event’s 
location, click the event in the MIDI Event 
List.

– or –

• To paste the material at any location, 
choose Go To from the Options menu in the 
MIDI Event List, enter the location where 
you want to paste, and click OK.

4  Choose Edit > Paste. The events from the Clip-
board are pasted, replacing any existing events 
already there.

Selecting in the MIDI Event List

To paste events without overwriting other 
events, use the Merge Paste Special 
command.
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MIDI Event List Options
The MIDI Event List menu provides the follow-
ing options:

Show Sub Counter Displays event times in the 
Sub Time Scale.

Go To Opens the Go To dialog, where you can 
specify a location, based on any of the supported 
Time Scales, to which the Edit insertion point is 
moved.

Scroll To Edit Selection Scrolls the MIDI Event 
List to the Edit start point or Edit insertion 
point.

Page Scroll During Playback Scrolls the MIDI 
Event List during playback.

Show Note Length Displays note lengths, in-
stead of note end times, in the Length/Info col-
umn of the MIDI Event List.

Show Note End Time Displays note end times, 
instead of note lengths, in the Length/Info col-
umn of the MIDI Event List.

Insert Provides a submenu of options that let 
you insert any type of MIDI event.

Insert At Edit Location Defaults the location for 
inserted events defaults to the Edit start point or 
Edit insertion point.

Insert At Playback Location Lets you insert 
events in the MIDI Event List in real time while 
listening to the session playback. 

Insert At Playback Location With Grid Snaps the 
location for events inserted in real time to the 
grid.

View Filter Opens the View Filter dialog, where 
you can specify which events are displayed in 
the MIDI Event List (see “View Filter for MIDI 
Event List” on page 758).
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Chapter 36: Time, Tempo, Meter, Key, and 
Chords
In Pro Tools, editing and arranging is typically 
done on tracks against a fixed Timeline. 

Clips and events can be anchored to points in 
absolute time, or relative time, as measured on 
the session’s Timeline. The Timeline includes 
two different types of rulers for measuring time: 
Timebase rulers and Conductor rulers.

The Timebase rulers can measure time in two 
different ways: sample-based time (absolute 
time) and tick-based time (relative time). For 
example, the Minutes:Seconds ruler measures 
absolute time and the Bars|Beats ruler measures 
relative time.

The relative time of the Bars|Beats ruler is deter-
mined in part by tempo and meter. Tempo, Me-
ter, and Key Signature rulers reside in Conduc-
tor tracks. Tempo and meter events affect the 
timing of tick-based tracks, and also provide the 
tempo and meter map for the Bar:Beat grid and 
Click. You can edit tempo events in the Tempo 
ruler or Tempo Editor. 

Key changes can affect MIDI notes when apply-
ing transposition. You can edit key and key 
changes in the Key Signature ruler.

Pro Tools also provides a Markers ruler 
for Memory Location (see Chapter 37, 
“Memory Locations”).
Timebase Rulers and 
Conductor Rulers

Timebase Rulers
Any or all of the following Timebase rulers can 
be displayed at the top of the Edit window and in 
MIDI Editor windows:

Bars|Beats Displays the Time Scale in bars and 
beats. Use this Time Scale if you are working 
with musical material that must align with bars 
and beats. The Bars|Beats Time Scale is relative 
and is affected by the session’s tempo and meter 
map.

All rulers displayed 
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Minutes:Seconds Displays the Time Scale in 
minutes and seconds. As you zoom in farther 
with the Zoomer tool, the Time Scale begins to 
display tenths, hundredths, and thousandths of 
a second. The Minutes:Seconds Time Scale is ab-
solute.

Timecode Displays the Time Scale in SMPTE 
frames. The Timecode Rate and Session Start 
time are set from the Session Setup window. The 
Timecode Time Scale is absolute, based on the 
frame rate.

Pro Tools supports the following frame rates:

• 23.976 FPS

• 24 FPS

• 25 FPS

• 29.97 FPS

• 29.97 FPS Drop

• 30 FPS

• 30 FPS Drop

To ensure your tracks align with the bars 
and beats in your session, record with a click 
(see “Recording with a Click” on page 440). 
Material that is recorded without listening 
to a click can still be aligned to bar and beat 
boundaries in Pro Tools with the Identify 
Beat command (see “Identify Beat Com-
mand” on page 794), or with Beat Detective 
(see Chapter 31, “Beat Detective”).
Pro Tools Reference Guide
Secondary Timecode Ruler A secondary time-
code ruler, labeled Time Code 2, lets you refer-
ence video frame rates in the Timeline that are 
different from the session Timecode rate. How-
ever, you cannot Spot to the Timecode 2 ruler 
and it cannot be set as the Main Time Scale. The 
secondary timecode ruler can be set to show any 
Pro Tools supported frame rate. The Timecode 2 
ruler can also display the following additional 
frame rates:

• 50 FPS

• 59.94 FPS

• 59.94 FPS Drop

• 60 FPS

• 60 FPS Drop

Feet+Frames Displays the Time Scale in feet and 
frames for referencing audio-for-film projects. 
The Feet+Frames time display is based on the 35 
millimeter film format. The Feet+Frames Time 
Scale is absolute, based on the frame rate.

Samples Displays the Time Scale in samples. 
This format is very useful for high-precision 
sample editing. The Samples Time Scale is abso-
lute, based on the sample rate.

In addition to providing a timing reference for 
track material, the Timebase rulers are also used 
to define Edit selections for track material, and 
Timeline selections for record and play ranges.

With the Selector tool, drag in any Timebase 
ruler to select material across all tracks in 
the Edit window or MIDI Editor window. To 
include the Conductor tracks in the selec-
tion, press Alt (Windows) or Option (Mac) 
while dragging.



Conductor Rulers
Any or all of the following Conductor rulers can 
be displayed:

• Markers

• Tempo (and Tempo Editor)

• Meter

• Keys (and Key Signature Staff )

• Chords

The Meter and Tempo rulers indicate changes in 
meter and tempo within the Session. The Key 
Signature ruler indicates changes of key. The 
Chord Symbols ruler shows chord markers. The 
Markers ruler displays markers to important 
track locations.

Displaying Rulers

To display all rulers:

 Select View > Rulers > All.

To remove a ruler from the display, do one of the 
following:

 Option-click the ruler’s name (to the left of the 
ruler display).

– or –

 Choose View > Rulers, and deselect a ruler 
option.

To display only the Main Time Scale in the 
Timebase ruler:

 Select View > Rulers > None (“Main Time 
Scale” on page 770.)

For more information on Memory Location 
markers, see Chapter 37, “Memory Locations.”
To add a specific ruler to the display, such as the 
Markers ruler, for instance:

 Select View > Rulers > Marker.

To change the display order for the rulers:

 Drag a ruler’s name up or down to a new
location.

To copy the range selection from a Conductor 
ruler to make an Edit selection in the top track in 
the Edit window (or in the Notes pane in MIDI 
Editor windows):

 Press Control+; (semicolon) (Mac) or 
Start+; (semicolon) (Windows).

Ruler View Selector
The Timebase and Conductor rulers can also be 
configured with the Ruler View selector.

Ruler View selector in the Edit Window.
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Main Time Scale
While all Timebase rulers can be displayed si-
multaneously in the Edit and MIDI Editor win-
dows, there is only one that represents the Main 
Time Scale. This ruler is also called the Main 
Timebase ruler. 

The Main Time Scale determines the time for-
mat used for:

• The Main Counter in the Transport

• The Main Counter at the top of the Edit 
window or MIDI Editor window

• Start, End, and Length values

• Pre- and post-roll amounts

• Grid and Nudge values

The Main Time Scale can be set to the following 
formats:

• Bars|Beats 

• Minutes:Seconds

• Timecode

• Feet+Frames

• Samples

Setting the Main Time Scale

To set the Main Time Scale, do one of the 
following:

 Click a Main Counter selector (located at the 
top of the Edit or Transport window (when it is 
set to display Counters) and select a Time Scale.

Main Counter selector (in the Edit window)
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 If a Timebase ruler is displayed, click its name 
so it becomes highlighted.

Navigating with the Main 
Counters
The Main Counters (at the top of the Edit win-
dow and in the Transport window) provide a 
convenient way to navigate to a specific time lo-
cation. 

To navigate with a Main Counter:

1  Click in a Main Counter.

2  Type in a location.

3  Press Enter (Windows or Mac) or Return (Mac) 
to automatically navigate to a new location.

Setting the Main Time Scale to the timebase 
currently displayed in the Sub Counter 
switches the two Time Scales, setting the Sub 
Time Scale to the previous timebase of the 
Main Time Scale.

Switching the Main Time Scale from Bars|Beats to 
Min:Sec

The Main Counter indicator in the 
Transport window only displays when the 
Transport is set to display Counters.



The Sub Counter
Below each Main Counter is a Sub Counter that 
can be shown or hidden. The Sub Counter pro-
vides an additional timing reference.

To show (or hide) the Sub Counter in the Edit 
window:

 From the Main Counter selector, select (or de-
select) the Show Sub Counter option. 

To show the Sub Counter in the Transport window:

 From the Transport Window menu, ensure 
that the Counters and Expanded Transport op-
tions are enabled.

To set the Time Scale for the Sub Counter:

 Click the Sub Counter selector and select a 
Time Scale.

Sub Counter selector (in the Edit window)
Tick-Based Timing
Pro Tools is a sample-based program with an in-
ternal MIDI resolution of 960,000 pulses per 
quarter note (ppq). However, when the Time 
Scale is set to Bars|Beats, the display resolution 
in Pro Tools is 960 ppq and the Timebase is tick-
based. 

When working in Bars|Beats, you will often 
want to specify tick values for a number of oper-
ations, including:

• Placing and spotting clips

• Setting lengths for clips or MIDI notes

• Locating and setting play and record ranges 
(including pre- and post-roll)

• Specifying settings in the Quantize and 
Change Duration pages of the Event Opera-
tions window

• Setting the Grid and Nudge values

In the Bars|Beats Time Scale, Pro Tools is 
tick-based (960 ticks to a quarter note). 
Some amount of sample-rounding may oc-
cur when placing events at certain locations 
(see “Sample Rounding and Edit Opera-
tions” on page 774).

When the Main Time Scale is set to 
Bars|Beats, and you are using tempo 
changes, set the Linearity Display Mode to 
Linear Tick Display (see “Changing the Lin-
earity Display Mode” on page 787). This 
will keep the Bars|Beats ruler fixed (at the 
selected zoom level) and sample-based rul-
ers such as Minutes:Seconds will scale to fit 
any tempo changes while bar lengths remain 
constant. 
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The following table lists the number of ticks for 
each of the main note sizes:

Tick- and Sample-Based 
Timebases
Pro Tools lets you set any track timebase to ei-
ther sample-based or tick-based.

Audio tracks in Pro Tools are sample-based by 
default. This means that audio clips and events 
are located at specific sample locations, and they 
do not move from that location if the tempo 
changes in the session—even though their bar 
and beat locations do change.

MIDI and Instrument tracks in Pro Tools are 
tick-based by default. This means that MIDI 
clips and events are located at a specific bar and 
beat locations, and they do not move from that 
location if the tempo changes in the session—
even though its sample location does change.

Note Value Normal Dotted Triplet

1/2 note 1920 2880 1280

1/4 note 960 1440 640

1/8 note 480 720 320

1/16 note 240 360 160

1/32 note 120 180 80

1/64 note 60 90 40
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Sample-Based Audio and MIDI
With a sample-based audio track, all audio clips 
in the track have an absolute location on the ab-
solute Timeline (for example, on the Samples or 
Minutes:Seconds Timebase ruler). Audio stays 
fixed to the sample time, regardless of any 
tempo or meter changes occur in a session.

On sample-based MIDI and Instrument tracks, 
all MIDI events in the track have an absolute lo-
cation on the absolute Timeline (for example, on 
the Sample or Minutes:Seconds Timebase ruler). 
MIDI events stay fixed to the sample time, re-
gardless of where tempo or meter changes occur 
in a session.

Tick-Based Audio and MIDI
Tick-based audio is fixed to the relative time of 
the Bars|Beats Timebase ruler, and moves rela-
tive to the sample Timeline when tempo and me-
ter changes occur. However, MIDI and Elastic 
Audio events, and tick-based audio clips 
(non–Elastic Audio) respond differently to 
tempo changes in respect to duration. MIDI note 
events and Elastic Audio clips change their du-
ration when tempo is adjusted, while non–Elas-
tic Audio audio clips do not. Tempo changes af-
fect only the location of the beginning (or sync 
point) of each audio clip in a tick-based 
(non–Elastic Audio) audio track.

You can select whether a track is sample-based 
or tick-based when it is created, or change time-
bases later. 

To have all new tracks default to tick-based, 
enable the New Tracks Default to Tick Time-
base option in the Editing Preferences.



Tick-Based Elastic Audio
Tick-based Elastic Audio tracks automatically 
apply Real-Time (or Rendered) Elastic Audio 
processing (TCE) when changing tempo. For 
more information, see “Tempo Changes and 
Tick-Based Elastic Audio Tracks” on page 779.

Switching Timebases
All Pro Tools tracks can be switched between 
being sample-based or tick-based.

Track height affects how various track controls 
appear in the Edit window. The Timebase selec-
tor, which is used for switching a track’s time-
base, is only visible in Medium or larger track 
heights.

To switch the timebase of a track, do one of the 
following:

 If the track’s height is set to Medium or larger, 
click the Timebase selector for the track and se-
lect the timebase. The Timebase selector icon 
changes to reflect your choice.
.

Timebase selector (samples)
.

– or –

 If the track’s height is set to Small (or smaller), 
click the Track Height selector and select the 
timebase from the Track Timebase submenu.

Alternate Playlist Timebases
When you change a track’s timebase, you can 
choose to apply the timebase change to that 
track only, or to the active Playlist and all alter-
nate playlists for that track. 

To configure a timebase change to affect 
timebases of all playlists in a track:

 Click the Timebase selector (or Track Height 
Selector) and enable the Selection Changes Alter-

nate Playlists option. 

Groups
When you change the timebase for an audio 
track that is part of an active Edit group, all the 
tracks in the group will change to the same time-
base.

Timebase selector (ticks)

Track Height pop-up menu
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Audio Clip Location
In tick-based audio tracks, the location of an au-
dio clip is determined by the clip’s start point, 
unless the clip contains a sync point.

If the clip contains a sync point, the sync point 
determines where the audio clip is fixed to the 
grid. 

Marker Location
When creating markers and Selection Memory 
Locations, you can specify whether they have an 
Absolute (sample-based) or Bar|Beat (tick-
based) reference. For more information, see 
“Bar|Beat and Absolute Reference” on page 815.

Sample Rounding and Edit 
Operations
When audio material in Pro Tools is sample-
based, some amount of sample-rounding may 
occur with some edits when the Main Time Scale 
is set to Bars|Beats. This is most evident when 
you need audio clips to fall cleanly on the beat 
(as when looping) and notice that the material is 
sometimes a tick or two off. With a few simple 
precautions, this can be avoided.

To ensure that selections are precisely aligned to 
the grid for looping, copying, duplicating, or re-
peating, consider the following: 

 If you use the Selector tool, enable Grid mode 
and select the appropriate grid value (such as 
sixteenth notes).

 For the greatest accuracy, type the selection 
Start and End points in the Event Edit area. 

 Do not select the material with any of the 
Grabber tools (or by double-clicking with the Se-
lector tool). 
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Song Start Marker
The Song Start Marker defines the initial tempo 
for Bar|Beat-based material. New sessions open 
with a default tempo of 120 BPM.

When a new session is created, the Song Start 
Marker has no associated meter event. A meter 
event is added automatically at the Song Start if 
you add another meter event anywhere else on 
the Meter ruler.

The Song Start Marker can be moved, but it can-
not be deleted.

To move the Song Start Marker by dragging:

 In the Tempo ruler with any Edit tool, drag the 
Song Start Marker left or right.

Song Start Marker

The position of the Song Start Marker can 
also be changed in the Time Operations 
window, see “Move Song Start” on page 805.

Dragging the Song Start Marker



If the Edit mode is set to Grid, the Song Start 
Marker moves in increments of the current Grid 
value. 

To edit the initial tempo in the Song Start Marker:

1  In the Tempo ruler, double-click the Song Start 
Marker.

2  In the Change Tempo dialog, enter a new BPM 
value.

3  Click OK.

Tempo
The Tempo ruler lets you edit Tempo events one 
at a time or according to tempo curves. You can 
edit tempo visually in the Tempo Editor, or 
make precise changes in tempo using the Tempo 
Operations window. 

To display the Tempo ruler:

 Select View > Rulers > Tempo.

To move the Song Start Marker only, with-
out moving any tick-based data, press 
Start+Shift (Windows) or Control+Shift 
(Mac) while dragging. When dragging the 
Song Start Marker only, dragging is con-
strained to whole bar increments only. 

To set the default session tempo, see “Set-
ting the Session Meter and Tempo” on 
page 442.

You can use Beat Detective to generate 
Bar|Beat markers (tempo map). For more 
information, see “Generating Bar|Beat 
Markers with Beat Detective” on page 664.

When working with tempo changes and tick-
based material, set the Linearity Display 
Mode to Linear Tick Display. 
Tempo Events
Tempo events can be assigned to the Song Start 
Marker to replace the default tempo (of 120 
BPM), and they can be inserted anywhere else 
within the session to change tempo. 

Current Tempo

As tempo events are encountered during play-
back, the session’s current tempo is displayed in 
the Transport window.

Inserting Tempo Events

To insert a tempo event:

1  Click in the Tempo ruler where you want to in-
sert the tempo event.

2  Click the Add Tempo Change button at the left 
of the Tempo ruler.

In Manual Tempo mode, the Tempo track is 
ignored and the session plays at the tempo 
defined in the Transport window, See “Us-
ing Manual Tempo Mode” on page 443.

Current Tempo in Transport window

Add Tempo Change button
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3  In the Tempo Change window, enter the Loca-
tion and BPM value for the tempo change. 

4  To place the inserted tempo event cleanly on 
the first beat of the nearest measure, select the 
Snap To Bar option. 

5  To base the BPM value on something other 
than the default quarter note, select a different 
note value.

6  Click OK. The new tempo event is inserted and 
appears in the Tempo ruler.

Each tempo event has a small green triangle next 
to it that indicates its location. These triangles 
can be dragged to move the tempo event, and 
they can be double-clicked to edit the tempo 
event.

Tempo Change dialog

Inserted tempo event
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Moving and Editing Tempo 
Events
Existing tempo events can be moved, edited, de-
leted, copied, and pasted.

To move a tempo event by dragging:

 In the Tempo ruler, drag the triangle for the 
tempo event left or right.

If the Edit mode is set to Grid, the dragged event 
snaps to the current Grid value. 

To edit a tempo event:

1  In the Tempo ruler, double-click the tempo 
event.

2  In the Tempo Change window, enter a new Lo-
cation or BPM value for the tempo event.

3  Click OK.

To delete a tempo event:

 Alt-click (Windows) or Option-click (Mac) the 
tempo event (the cursor changes to a Grabber 
with a “–”).

Dragging a tempo event



To copy and paste several tempo events:

1  With the Selector tool, drag in the Tempo ruler 
to select the range of bars that includes the 
tempo events.

2  Choose Edit > Copy.

3  Click in the Tempo ruler at the point where you 
want to paste the tempo events.

4  Choose Edit > Paste. The contents of the Clip-
board are pasted from the insertion point, re-
placing any existing tempo events.

To extend an Edit selection in a track to the Tempo 
ruler:

1  With the Selector or Grabber tool, make a 
Timeline selection.

2  Shift-click in the Tempo ruler. 

To select all tempo events:

 Double-click with the Selector tool in the 
Tempo ruler.

Tempo events selected

Press Alt (Windows) or Option (Mac) while 
dragging to select across all Conductor 
tracks.
To clear a range of selected tempo events:

1  If you want to constrain the selection to the 
current Grid value, set the Edit mode to Grid. 

2  Drag with the Selector tool in the Tempo ruler 
to select the tempo events you want to remove.

3  Choose Edit > Clear to delete the selected 
tempo events.

Tap Tempo
You can manually set the tempo for a Pro Tools 
session by tapping on your computer keyboard. 
You can also use a connected MIDI keyboard to 
tap tempo.

To set the Manual Tempo by tapping on a computer 
keyboard:

1  To view the MIDI controls in the Transport 
window, select View > Transport > MIDI Controls.

2  In the Transport window, click the Tempo 
Ruler Enable (Conductor) button so it becomes 
unhighlighted. Pro Tools switches to Manual 
Tempo mode. In this mode, any tempo events in 
the Tempo track are ignored.

3  Click in the Tempo field so it becomes high-
lighted and tap the “T” key on your computer 
keyboard repeatedly at the new tempo.

Tempo Ruler button (unhighlighted), set to Manual 
Tempo mode

You can apply the new tempo to the entire 
session by changing the default tempo of the 
Song Start Marker. See “Song Start Marker” 
on page 774.
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To set the Manual Tempo by tapping on an external 
MIDI keyboard:

1  To view the MIDI controls in the Transport 
window, select View > Transport > MIDI Controls.

2  Choose Setup > Preferences and click the MIDI 
tab.

3  Ensure that Use MIDI to Tap Tempo is selected.

4  In the Transport window, click the Tempo 
Ruler Enable (Conductor) button so it becomes 
unhighlighted. Pro Tools switches to Manual 
Tempo mode. In this mode, any tempo events in 
the Tempo track are ignored.

5  Click in the Tempo field so it becomes high-
lighted and tap in the tempo by playing a note 
repeatedly at the new tempo on your MIDI key-
board controller.

To compute the new tempo, Pro Tools averages 
the last eight (or fewer) taps to determine the 
correct tempo. The computed BPM value ap-
pears in the Transport’s Tempo field.

Tempo and Automation Drift
(With Sample-Based Clips on Tick-Based 
Tracks Only)

When a track is sample-based, the track’s auto-
mation playlist is unaffected by changes in 
tempo. This means that automation is always 
aligned with any sample-based audio on the 
track with sample accuracy.

When a track is tick-based, the automation 
breakpoints change to match the changes in 
tempo. 
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Generally, when applying tempo changes with 
tick-based MIDI and Elastic Audio, this is desir-
able. In fact, you will probably want to set all of 
the tracks in your session that contain automa-
tion to tick-based. This way any tempo changes 
affect all tick-based track automation and track 
material equally. However, when working with 
sample-based (non-Elastic) audio on tick-based 
tracks, tempo changes affect the start location of 
audio clips, but not their duration.

Since the length of each sample-based audio clip 
in a track is unaffected by changes in tempo, ex-
isting automation data is not aligned with the 
audio after a tempo change is made to a tick-
based audio track. 

Tempo changes applied to (non-Elastic) audio clips 

When tempo changes on a tick-based audio track...

...automation gets out of sync with audio.

Tempo at 120 bpm
No Elastic Audio

Tick-based

Tempo at 146 bpm



Minimizing Automation Drift

In general, automation drift is more pro-
nounced with larger sample-based audio clips. 
By creating many small clips, the effects of auto-
mation drift can be minimized, because the start 
points of each subsequent clip changes as the 
tempo changes. When tempo is decreased, auto-
mation expands. When tempo is increased, au-
tomation contracts.

Tempo changes applied to small sample-based clips 
on a tick-based track

To break an audio clip into smaller clips, 
use Beat Detective. For more information, 
see Chapter 31, “Beat Detective.”

You can also separate clips at transients or 
based on the current grid resolution. For 
more information, see “Separate Com-
mands” on page 592

Using many smaller clips...

...keeps audio aligned with automation changes.
Tempo Changes and Tick-Based 
Elastic Audio Tracks
Clips on tick-based, Elastic Audio-enabled 
tracks apply Time Compression and Expansion 
(TCE) based on tempo changes. For simple 
tempo changes, clips on tick-based Elastic Au-
dio-enabled tracks automatically conform to 
match the new tempo. Tempo changes do not af-
fect sample-based, Elastic Audio-enabled 
tracks. 

In the following figure, the first two-bar clip is 
at its native tempo of 120 bpm. The second two-
bar clip has been conformed to the tempo 
change of 100 bpm. Since the second clip has 
been warped to remain two bars long at the 
slower tempo, it displays the Clip Warp indica-
tor in the upper right-hand corner of the clip.

Tempo conformed audio, linear tempo change
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For tempo curves, such as an accelerando or ri-
tardando, Tempo Event Warp markers are auto-
matically created corresponding to each tempo 
event, and the clip conforms accordingly. The 
following figure shows a clip in Warp view. No-
tice how the audio conforms to the tempo curve.

Tempo Event-generated Warp markers cannot 
be edited. They only show where the audio has 
been warped in order to conform to tempo 
changes.

Conform to Tempo
Pro Tools lets you conform clips on Elastic Au-
dio-enabled tracks (both sample- and tick-
based) to the session tempo. If necessary, the 
Conform to Tempo command analyzes the se-
lected clips to determine its tempo and duration 
(in bars and beats), and then applies Elastic Au-
dio processing to conform the clip to match the 
session tempo.

To conform a clip to the session tempo:

1  Select the clip you want to conform to the ses-
sion tempo.

Tempo conformed audio, tempo curve

If you change the track timebase from ticks 
to samples, any Tempo Event–generated 
Warp markers convert to regular, editable 
Warp markers.
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2  Do one of the following:

• Choose Clip > Conform to Tempo.

– or –

• Right-click the clip you wan to conform to 
tempo and select Conform to Tempo.

Pro Tools analyzes the clip’s entire file for Elas-
tic Audio events and tempo. If a tempo is de-
tected, and a duration in bars and beats is deter-
mined, the clip conforms automatically to the 
session tempo. If a tempo and duration is not 
detected (such as with a clip that is a single 
drum hit or with a long clip with no clear 
tempo), the clip is not conformed to the session 
tempo. 

Alternate Playlists and Tempo
Alternate playlists on Elastic Audio-enabled, 
tick-based tracks are only affected by tempo 
changes. Otherwise, alternate playlists are not 
affected by editing Warp or Event markers in the 
main playlist.

You can also use telescoping warp in Warp 
view to manually conform a long clip to the 
session tempo. See “Telescoping Warp” on 
page 895.

Conform to Tempo can only be applied to 
clips and cannot be applied to clip groups. 
To conform clip groups to the tempo, un-
group the clip group, then apply Conform to 
Tempo to the underlying clips, and then re-
group those clips.



Graphic Tempo Editor
The Tempo Editor, a resizeable window beneath 
the Tempo ruler in the Edit Window, lets you 
view and edit tempo information graphically.

Displaying the Tempo Editor 
The Tempo Editor is an expansion of the Tempo 
ruler, opening in the rulers section of the Edit 
Window. 

To display the Tempo Editor, do one of the 
following:

 Select View > Rulers > Tempo, then select 
View > Rulers > Tempo > Tempo Editor.

– or –

 Click the Tempo Editor expand/collapse 
triangle.

Tempo Editor

Tempo Editor expand/collapse triangle

Tempo events

Tempo Resolution
Tempo Density

Add Tempo Change
Zooming and Scrolling in the 
Tempo Editor 

To zoom in vertically in the Tempo Editor:

 Click the Tempo Editor Zoom In button (“+”).

To zoom out vertically in the Tempo Editor:

 Click the Tempo Editor Zoom Out button 
(“–”).

To scroll vertically in the Tempo Editor, do any of 
the following:

 Click the Scroll Up Arrow to scroll up.

 Click the Scroll Down Arrow to scroll down.

 Drag the Scroll bar up or down.

Editing Tempo Events in the 
Tempo Editor
Tempo events in the Tempo Editor can be edited 
with any of the following methods:

 Individual tempo events can be dragged with 
any of the Grabber tools to adjust their location 
or value.

 A group of selected tempos can be scaled up or 
down with the Trim tool.

 New tempo events can be drawn in with the 
Pencil tool to replace existing ones.

 Tempo events can be copied and pasted, 
nudged, and shifted.

Zoom In and Out buttons in the Tempo Editor
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Drawing Tempo Events
Tempo events can be drawn in the Tempo Editor 
using the follow Pencil tool shapes.

Free Hand The Free Hand shape draws freely ac-
cording to the movement of the mouse. The 
shape is reproduced as a series of steps accord-
ing to the Tempo Edit Density setting. (For more 
information, see “Selecting Tempo Edit Den-
sity” on page 783.)

Line The Line shape draws in a straight line 
from click to release. Tempo values change in 
steps according to the Tempo Edit Density and 
Resolution.

Parabolic The Parabolic shape draws the best 
possible curve to fit your freehand drawing. The 
shape is reproduced as a series of steps accord-
ing to the Tempo Edit Density setting.

S-Curve The S-Curve shape draws a best possi-
ble fit of an S-Curve to your freehand drawing. 
The shape is reproduced as a series of steps ac-
cording to the Tempo Edit Density setting.

The Triangle, Square, and Random Pencil 
tool shapes do not apply to tempo events.
Pro Tools Reference Guide
Selecting Tempo Resolution 
(BPM Rate) 
The Tempo Editor lets you specify the beat note 
value for tempo events by changing the Tempo 
Resolution. The beat note value selected for the 
Tempo Resolution is usually based on the meter. 
For example, in 4/4 the beat is a quarter note 
and in 6/8 the beat is (usually) a dotted-quarter 
note.

To select the Tempo Resolution (BPM rate) for 
Pencil tool edits, do one of the following:

 Click the Tempo Resolution selector and select 
the appropriate note value from the pop-up 
menu. The Tempo Resolution for tempo events 
created by drawing with the Pencil tool are set to 
the specified note value for the BPM rate.

– or –

 Click the Tempo Resolution selector and select 
Follow Metronome Click. The Tempo Resolution 
for tempo events created by drawing with the 
Pencil tool automatically mirror the click values 
set by meter events in the Meter ruler. 

A tempo curve can have different BPM values if 
there are meter click changes within the selected 
range.

Tempo Resolution selector and pop-up menu

Because it can be unnecessarily complicated 
to set meter events separately for each Tempo 
event, selecting Follow Metronome Click is 
recommended in most cases.



Selecting Tempo Edit Density
The Tempo Editor lets you specify the density of 
tempo events created in the Tempo ruler when 
you draw a tempo curve with the Pencil tool.

To select the Tempo Edit Density for Pencil tool 
edits:

 Click the Tempo Edit Density selector and se-
lect a time value from the pop-up menu. Tempo 
events created by drawing with the Pencil tool 
are placed in the Tempo ruler at the specified 
density.

Tempo curve with different click values

Tempo Edit Density selector and pop-up menu

Pressing Start (Windows) or Control (Mac) 
before drawing a pencil line conforms 
already created tempo events to the drawn 
line rather than creating new tempo events. 

Quarter note click Dotted-quarter click

Curve Adjustment Mode
Immediately after you draw new tempos using 
the Pencil tool, a tempo curve appears in blue, 
outlining the newly created tempo graph. Blue 
adjustment handles on the curve let you adjust 
the shape and size of the new tempo graph.

The blue adjustment handles are only active un-
til a new tool is selected or a new command is ex-
ecuted. 

Tempo Curve Adjustment handles

All the new tempo events under the curve 
will change as you move the Tempo Curve 
Adjustment Handles. To adjust the curve 
shape without the track data adjusting im-
mediately, press Start (Windows) or Control 
(Mac) while adjusting the curve. Tempo 
events will change to fit the new curve when 
you release the mouse button.
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Creating New Tempo Settings 
with Grabber Tools
The Grabber tools let you create new tempo set-
tings by dragging tempo events in the Tempo 
Editor.

To change the tempo of a tempo event:

 With the Grabber tool, drag a tempo event up 
or down.

To adjust the location of the tempo change:

 With the Grabber tool, drag a tempo event to 
the left or right.

To remove a tempo event:

 With the Grabber tool, Alt-click (Windows) or 
Option-click (Mac) the tempo event.

Selecting Tempo Events
You can easily select a single tempo event, or an 
entire tempo curve within the Tempo Editor.

To Select a tempo event in the Tempo Editor:

 Using the Selector tool or any Grabber tool, 
double-click between two tempo events. The 
first event is selected.

Using a Grabber tool to change a tempo event
Pro Tools Reference Guide
To Select a tempo curve in the Tempo Editor:

 Using the Selector tool or any Grabber tool, 
triple-click on a horizontal tempo line in the 
curve that you want to select.

Extending Tempo Selections
You can extend Tempo selections to the next or 
the previous tempo event.

To extend a tempo selection:

1  With the Selector tool, select a range of tempo 
events.

2  Do one of the following:

• Press Shift+Tab to extend the selection to 
the next tempo event.

– or –

• Press Shift+Control+Tab (Windows) or 
Shift+Option+Tab (Mac) to extend the se-
lection to the previous tempo event.

Selecting a single tempo event

Selecting a tempo curve



Scaling and Stretching Tempo 
Events with the Trim Tool
The Trim tool lets you scale all the tempo events 
of the session, or within a Timeline selection. 
The Trim tool also lets you stretch a clip of 
tempo events to cover a longer or shorter area in 
the Timeline. 

To scale all the session’s tempo events with the 
Trim tool:

1  Open the Tempo Editor.

2  With the Trim tool, click above any tempo 
event and drag up or down. Dragging up in-
creases the tempo values for all tempo event in 
BPM; dragging down decreases them.

To scale selected tempo events with the Trim tool:

1  Open the Tempo Editor.

2  With the Selector tool, select the area you want 
to edit.

Changing all tempo events with the Trim tool
3  With the Trim tool, click within the selected 
area, and drag up or down. Dragging up in-
creases the tempo values of the selection in 
BPM; dragging down decreases them.

To adjust the rate of tempo change over absolute 
time with the Trim tool:

1  Open the Tempo Editor.

2  With the Selector tool, select the area you want 
to edit.

3  With the Trim tool, click either the start or end 
handle for the selected range, and drag up or 
down. The BPM values for tempo events scale ac-
cordingly and tempo events scale over a longer 
or shorter amount of absolute time.

Changing selected tempo events with the Trim tool

Adjusting the rate of tempo change with the 
Trim tool
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To scale the duration of tempo changes with the 
Trim tool:

1  Open the Tempo Editor.

2  With the Selector tool, select the area you want 
to edit.

3  With the Trim tool, click at the start or end of 
the selection, and drag horizontally. Tempo 
events do not change in terms of actual BPM val-
ues, but they are scaled over a longer or shorter 
amount of absolute time.

Moving, Cutting, Pasting and 
Nudging in the Tempo Editor

To move a selected group of tempo events in the 
Tempo Editor:

1  Open the Tempo Editor.

2  With the Selector tool, select the area you want 
to move.

3  With any Grabber tool, click on any selected 
tempo event and drag horizontally to move the 
tempo events to a new location. 

Scaling the duration of selected tempo events with the 
Trim tool

Press Alt (Windows) or Option (Mac) while 
dragging to move a copy of the tempo events.
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To copy and Paste tempo events in the Tempo 
Editor:

1  Open the Tempo Editor.

2  With the Selector tool, select the area you want 
to copy.

3  Choose Edit > Copy.

4  Click in the Tempo Editor at the point where 
you want to paste the tempo events.

5  Choose Edit > Paste. Your copied selection is 
pasted from the insertion point, replacing any 
existing tempo events.

To nudge a selection in the Tempo Editor:

1  Open the Tempo Editor.

2  With the Selector tool, select the area you want 
to nudge.

3  Do one of the following:

• On the numeric keypad, press Plus (+) to 
move the selected tempo events forward by 
the Nudge value.

– or –

• Press Minus (–) to move the selection back 
by the Nudge value.



Changing the Linearity 
Display Mode
The Timeline can be viewed in either a Linear 
Tick (relative) scale or a Linear Sample (abso-
lute) Time Scale. MIDI and Instrument tracks, 
audio tracks, and Tempo curves can appear and 
function very differently depending on the time-
base display settings.

The Linearity Display Mode pop-up menu deter-
mines whether the Tempo Editor displays tempo 
events in an absolute (samples) timebase or a 
relative (ticks) timebase.

Linear Sample Display The display of the Time-
line is sample-based and the location of tick-
based events (like Bars and Beats) shift after a 
tempo curve is drawn. That is, as you change 
tempo, the location of bars and beats move 
against the fixed sample-based Timeline (such 
as Minutes:Seconds). When working with sam-
ple-based material, such as when you are track-
ing or mixing, make sure that Linear Sample 
Display is selected. This is especially true if you 
intend to align the tempo and meter map to 
sample-based events.

Linearity Display Mode selector and pop-up menu
Linear Tick Display The display of tempo events 
is tick-based and tempo event Bar|Beat locations 
remain constant after the tempo curve is drawn 
and all sample-based events move against bar 
beat locations in the Timeline. When working 
on any tick-based material, such as MIDI notes 
or Elastic Audio events, make sure that Linear 
Sample Display is selected. This is especially 
true if you will be making tempo changes, but 
want the bars and beats to remain fixed in the 
Timeline.

To change the timebase display:

 Click the Linearity Display Mode selector and 
select a timebase from the pop-up menu.

Tempo Edit Density and 
Linearity Display Mode
When the Tempo Edit Density setting (in the 
Tempo Editor) and the Linearity Display Mode 
setting are both set to either a Bars|Beats Time 
Scale or to an absolute Time Scale, Tempo edits 
appear evenly spaced. When the Tempo Edit 
Density setting and the Linearity Display Mode 
setting are set so that one is set to an absolute 
Time Scale and the other is set to a Bars|Beats 
Time Scale, the number of Tempo edits appear 
to increase or decrease over time (against abso-
lute time).

Drawing tempo events using the Linear 
Sample Display causes Bar|Beat based 
material to move. This can make it difficult 
to work on tick-based material. In most 
cases, you will want to use Linear Tick Dis-
play when drawing tempo changes.
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Tempo Operations Window
The Tempo Operations window lets you define 
tempo events over a range of time (or measures). 
The time range is specified in the time format 
chosen for your Main Time Scale. In addition, 
the Tempo Operations window lets you:

• Fit a specific number of Bars|Beats into a 
precise time range.

• Create tempos that speed up or slow down, 
both linearly and over various curves.

• Scale and stretch existing tempos.

The Tempo Operations window has six pages, 
one for each type of tempo operation.

Constant Lets you create a constant tempo over 
a selected range of time.

Linear Lets you create tempos that change 
evenly over a selected range of time.

Parabolic Lets you create tempos that accelerate 
or decelerate following a tempo curve that 
changes the tempo more rapidly or less rapidly 
over the selection time.

S-Curve Lets you create tempos that accelerate 
or decelerate following a tempo curve with a de-
finable breakpoint that determines mid-curve 
times and tempo values.

Scale Lets you scale tempos within the selection 
by a percentage amount. 

Stretch Lets you select a clip of tempo events 
and apply them to a larger or smaller selection 
area.

The Tempo Operations window is not avail-
able in Manual Tempo mode.
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To open a specific Tempo Operations window 
page:

 Choose Event > Tempo Operations, followed by 
one of the Tempo Operations page commands 
(such as Constant).

To open the last active Tempo Operations window 
page:

 Choose Event > Tempo Operations > Tempo 

Operations Window.

To define tempo events over a range of time:

1  Make a selection in the Timebase or in a track.

2  Choose Event > Tempo Operations > Tempo Op-

erations Window.

3  Select a Tempo Operation page from the pop-
up menu at the top of the Tempo Operation win-
dow.

4  Change the settings for the page you have cho-
sen, as necessary.

5  Do one of the following:

• Click Apply.

– or –

• Press Enter (Windows) or Return (Mac) to 
automatically apply the values and close the 
window.

If the Tempo Operations window is already 
open, you can select any of the pages from 
the pop-up menu at the top of the window.

Press Alt+2 (Windows) or Option+2 
(Mac) on the number keypad to open the 
Tempo Operations window and display 
the last active Tempo Operations page.



Constant
The Constant page in the Tempo Operations 
window lets you create a constant tempo over a 
selected range of time.

Advanced When the Advanced checkbox is se-
lected, the selection range changes to the Main 
Time Scale format, and additional and modified 
options become available.

Calculate (Advanced Option) Calculates either 
the tempo, or the selection end time.

Selection Start and End Specifies the start and 
end point for the tempo change in Bars|Beats. 
When an Edit selection is made, the Start and 
End fields will display the selection boundaries.

End Time (Advanced Option) Displays the selec-
tion end time. When the Main Time Scale is set 
to Bars|Beats, the end time is displayed in the 
Sub Time Scale. When the Main Time Scale is set 
to any absolute timebase, the end time is calcu-
lated and displayed in Bars|Beats. Changing the 
end time value causes the tempo to change.

Tempo Specifies the tempo, in beats per minute 
(BPM), to apply to the selected range.

Constant page (Advanced Option)
Resolution (Advanced Option) Lets you select 
the BPM note value for your tempo setting.

Density (Advanced Option) Lets you specify the 
density of the tempo change events written to 
the Tempo ruler.

Preserve Tempo after Selection If selected, the 
previous tempo setting that was in effect at the 
selection end point is preserved after the selec-
tion. If unselected, the last tempo event created 
by the tempo operation continues to the end of 
the session, or until the next tempo event be-
yond the selected range.

Linear
The Linear page in the Tempo Operations win-
dow lets you create tempos that change evenly 
over a selected range of time.

Advanced When the Advanced checkbox is se-
lected, the selection range changes to the Main 
Time Scale format, and additional and modified 
options become available.

Selecting “Follow Metronome Click” will set 
the tempo BPM note value to mirror the 
click value set in the meter markers.

Linear page (Advanced Option)
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Calculate (Advanced Option) Calculates either 
the selection end time, the start tempo, or the 
end tempo.

Selection Start and End  Displays the start and 
end points for the tempo change in the currently 
selected Main timebase. When an Edit selection 
is made, the Start and End fields will display the 
selection boundaries. Changing start or end val-
ues changes the selection range.

End Time (Advanced Option) Displays the abso-
lute time for the selection end. When the Main 
Time Scale is set to Bars|Beats, the end time is 
displayed in the Sub Time Scale. When the Main 
Time Scale is set to any absolute timebase, the 
end time is calculated and displayed in 
Bars|Beats. Changing the end time value causes 
the tempo to change.

Tempo Start and End Displays the tempo, in 
beats per minute (BPM), for the start and end 
points of the selected range. Changing the 
tempo causes the end time value to change.

Resolution (Advanced Option) Lets you select 
the BPM note value for your tempo setting.

Density (Advanced Option) Lets you specify the 
density of the tempo change events written to 
the Tempo ruler.

Preserve Tempo after Selection If selected, the 
previous tempo setting that was in effect at the 
selection end point is preserved after the selec-
tion. If unselected, the last tempo event created 
by the tempo operation continues to the end of 
the session, or until the next tempo event be-
yond the selected range.

Selecting “Follow Metronome Click” will set 
the tempo BPM note value to mirror the 
click value set in the meter markers.
Pro Tools Reference Guide
Parabolic
The Parabolic page in the Tempo Operations 
window lets you create tempos that accelerate or 
decelerate by following a tempo curve, which 
changes the tempo more rapidly or less rapidly 
over the selection time.

Advanced When the Advanced checkbox is se-
lected, the selection range changes to the Main 
Time Scale format, and additional and modified 
options become available.

Calculate (Advanced Option) Calculates the se-
lection end time, the start tempo, the end 
tempo, or the curvature of the tempo change. 

Selection Start and End Displays the start and 
end points for the tempo change in the currently 
selected Main timebase. When an Edit selection 
is made, the Start and End fields will display the 
selection boundaries. Changing start or end val-
ues changes the selection range.

Parabolic page (Advanced Option)



End Time (Advanced Option) Displays the abso-
lute time for the selection end. When the Main 
Time Scale is set to Bars|Beats, the end time is 
displayed in the Sub Time Scale. When the Main 
Time Scale is set to any absolute timebase, the 
end time is calculated and displayed in 
Bars|Beats. Changing the end time value causes 
the tempo to change.

Tempo Start and End Displays the tempo, in 
beats per minute (BPM), for the start and end 
points of the selected range. Changing the 
tempo causes the end time value to change.

Curvature Specifies and displays a numerical 
and graphic representation of the tempo curve. 
Negative numbers indicate a more rapid tempo 
change at the beginning of the time range, and 
positive numbers indicate a more rapid tempo 
change at the end of the time range. This value 
can be set with the Curvature slider.

Resolution (Advanced Option) Lets you select 
the BPM note value for your tempo setting.

Density (Advanced Option) Lets you specify the 
density of the tempo change events written to 
the Tempo ruler.

Preserve Tempo after Selection If selected, the 
previous tempo setting that was in effect at the 
selection end point is preserved after the selec-
tion. If unselected, the last tempo event created 
by the tempo operation continues to the end of 
the session, or until the next tempo event be-
yond the selected range.

Selecting “Follow Metronome Click” will set 
the tempo BPM note value to mirror the 
click value set in the meter markers.
S-Curve
The S-Curve page in the Tempo Operations win-
dow lets you create tempos that accelerate or de-
celerate by following a tempo curve with a defin-
able breakpoint that determines mid-curve 
times and tempo values.

Advanced When the Advanced checkbox is se-
lected, the selection range changes to the Main 
Time Scale format, and additional and modified 
options become available. 

Calculate (Advanced Option) Calculates either 
the selection end time, the start tempo, the end 
tempo or the curvature of the tempo change. 

Selection Start and End Displays the start and 
end points for the tempo change in the currently 
selected Main timebase. When an Edit selection 
is made, the Start and End fields will display the 
selection boundaries. Changing start or end val-
ues changes the selection range.

S-Curve page (Advanced Option)
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Start and End Time (Advanced Option) Displays 
the absolute time for the selection end. When 
the Main Time Scale is set to Bars|Beats, the end 
time is displayed in the Sub Time Scale. When 
the Main Time Scale is set to any absolute time-
base, the end time is calculated and displayed in 
Bars|Beats.

Tempo Start and End Displays the tempo, in 
beats per minute (BPM), for the start and end 
points of the selected range. Changing the 
tempo causes the end time value to change.

Curvature Specifies and displays a numerical 
and graphic representation of the tempo curve. 
Negative numbers indicate a more rapid tempo 
change at the start and end of the of the time 
range, with a low rate of change around the mid-
point. Positive numbers indicate a low rate of 
change near the start and end of the selected 
range, with rapid tempo change around the mid-
point. This value can be set with the Curvature 
slider.

Mid Point Specifies the Main Time Scale location 
for the curve mid point. This value can be set 
with the Mid Point slider.

Mid Tempo Specifies the tempo at the mid point. 
This value can be set with the Mid Tempo slider.

Resolution (Advanced Option) Lets you select 
the BPM note value for your tempo setting.

Density (Advanced Option) Lets you specify the 
density of the tempo change events written to 
the Tempo ruler.

Select “Follow Metronome Click” will set the 
tempo BPM note value to mirror the click 
value set in the meter markers.
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Preserve Tempo after Selection If selected, the 
previous tempo setting that was in effect at the 
selection end point is preserved after the selec-
tion. If unselected, the last tempo event created 
by the tempo operation continues to the end of 
the session, or until the next tempo event be-
yond the selected range.

Scale
The Scale page in the Tempo Operations window 
lets you scale tempos within the selection by a 
percentage amount.

Advanced When the Advanced checkbox is se-
lected, the selection range changes to the Main 
Time Scale format, and additional and modified 
options become available.

Calculate (Advanced Option) In combination 
with settings chosen in the Scale pop-up menu, 
the Calculate pop-up menu lets you calculate the 
selection end time, the average tempo, the start 
tempo, or the end tempo. 

Scale page (Advanced Option)



Scale (Advanced Option) In combination with 
settings chosen in the Calculate pop-up menu, 
the Scale pop-up menu lets you scale all tempos, 
the start tempo, or the end tempo.

Scaling all tempos scales each tempo in the se-
lected range equally. Scaling the start tempo 
scales the tempos unevenly, scaling the first 
tempo event the most, scaling each consecutive 
tempo event less until the end tempo which is 
not scaled. Scaling the end tempo scales the tem-
pos unevenly, scaling the last tempo the most, 
scaling each previous tempo event less until the 
start tempo which is not scaled.

Selection Start and End Displays the start and 
end points for the tempo operation in the cur-
rently selected Main timebase. When an Edit se-
lection is made, the Start and End fields will dis-
play the selection boundaries. Changing start or 
end values changes the selection range.

Start and End Time Displays the absolute time 
for the selection start and end points. When the 
Main Time Scale is set to Bars|Beats, times are 
displayed in the Sub Time Scale. When the Main 
Time Scale is set to any absolute timebase, times 
are calculated and displayed in Bars|Beats.

Average Tempo Displays the Average Tempo, in 
beats per minute (BPM), across the selected 
range. Changing the Average Tempo changes the 
Scale percentage.

Scale Displays the percentage by which the 
tempo is scaled, in beats per minute (BPM), 
across the selected range. Changing Scale 
changes Average Tempo.

Preserve Tempo after Selection If selected, the 
previous tempo setting that was in effect at the 
selection end point is preserved after the selec-
tion. If unselected, the last tempo event created 
by the tempo operation continues to the end of 
the session, or until the next tempo event be-
yond the selected range.
Stretch
The Stretch page in the Tempo Operations win-
dow lets you select a clip of tempo events and 
apply them to a larger or smaller selection area.

Advanced When the Advanced checkbox is se-
lected, the selection range changes to the Main 
Time Scale format, and additional and modified 
options become available.

Selection Start and End Specifies the range of 
tempo events that you want to modify. When an 
Edit selection is made, the Start and End fields 
will display the selection boundaries. 

Stretch To End Specifies a new end point for the 
clip to which you want to apply the selected 
tempo events. Changing the end point causes the 
Stretch percentage to change.

Stretch To Start (Advanced Option) Specifies a 
new start point for the clip to which you want to 
apply the selected tempo events. Changing the 
end point causes the Stretch percentage to 
change.

Stretch Specifies the percentage of time for the 
the selected tempo events to cover.

Stretch page (Advanced Option)
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Preserve Tempo after Selection If selected, the 
previous tempo setting that was in effect at the 
selection end point is preserved after the selec-
tion. If unselected, the last tempo event created 
by the tempo operation continues to the end of 
the session, or until the next tempo event be-
yond the selected range.

Identify Beat Command 
The Identify Beat command lets you establish a 
tempo/meter map for audio that was recorded 
without a click, or for imported audio with un-
known tempos.

The Identify Beat command analyzes a selection 
range (usually with a distinct number of beats or 
measures) and calculates its tempo based on the 
specified meter. In doing this, Bar|Beat Markers 
for the calculated tempo are inserted and appear 
in the Tempo ruler at the beginning and end of 
the selection; in addition, meter events are in-
serted into the Meter ruler.

Bar|Beat Markers
Bar|Beat Markers look similar to tempo events, 
but instead have small blue triangles to indicate 
their location.

Use Beat Detective to generate Bar|Beat 
Markers within a selection that includes 
rhythmic changes on beats or sub-beats (see 
Chapter 31, “Beat Detective”).

Bar|Beat Marker
Pro Tools Reference Guide
Choosing Bar|Beat Markers or 
Tempo Events
Because tempo events are tick-based, and 
Bar|Beat Markers are sample-based, they cannot 
be mixed. If a session contains tempo events and 
you attempt to insert Bar|Beat Markers, existing 
tempo events are converted to Bar|Beat Markers 
(and vice versa).

Tempo events can also be manually converted to 
Bar|Beat Markers and vice versa. When convert-
ing between Tempo events and Bar|Beat Mark-
ers, some amount of sample rounding may oc-
cur.

To use either tempo events or Bar|Beat Markers:

1  Press Control (Windows) or Command (Mac) 
and click the Add Tempo Change button.

2  Select either Tempo Events or Bar|Beat Mark-

ers from the pop-up menu. 

Identifying Beats

Identifying the beat of a one-bar drum loop and 
creating Bar|Beat Markers for it:

1  Place a one-bar drum loop at the beginning of 
an audio track.

2  Select View > Rulers > Samples. This ensures 
that the selected audio material will be sample-
accurate.

3  Select the audio clip with the Time Grabber 
tool and choose Event > Identify Beat.

Tempo ruler pop-up menu



4  In the Bar|Beat Markers dialog, specify the 
start and end locations for the inserted Bar|Beat 
Markers. Since this example deals with a one-bar 
loop, enter 1|1|000 and 2|1|000.

5  If necessary, specify a time signature for the 
start and end range.

6  Click OK to automatically calculate the new 
tempo and insert the necessary Bar|Beat Mark-
ers and meter events. Any existing tempo and 
meter events residing within the selection are 
deleted.

When working with a selection, the Identify Beat 
command only calculates a single tempo for the 
selected range. If the tempo varies from measure 
to measure, or beat to beat, you’ll need to use the 

Identify Beat dialog

Bar|Beat Markers inserted
Identify Beat command for each tempo variance 
(making sure to accurately define a precise se-
lection range or beat location for the tempo 
change).

To accurately define tempos for a range of audio 
with the Identify Beat command, make certain 
that the initial selection represents an accurate 
length of bars and beats. You may want to first 
loop the selection on playback to see if it plays 
accurately (see “Loop Playback Mode” on 
page 428). To avoid drift, and remain sample-
accurate, select the audio material with the Time 
Scale set to Samples rather than Bars|Beats.

Dragging Bar|Beat Markers
Bar|Beat Markers can be dragged to new loca-
tions so they can align with audio clips that have 
been moved, or so that they can align to a 
slightly different point within an audio clip. 
This results in neighboring MIDI data being ad-
justed to align with the new tempo map.

Because Bar|Beat Markers are sample-based and 
tempo events are tick-based, they behave differ-
ently when you drag them in the Tempo ruler.

When identifying beats, select as large an 
area as possible. For example, if you 
have a four-bar-long audio file you want to 
identify, select the entire four bars instead 
of just one bar, in order to minimize round-
ing errors (see “Sample Rounding and Edit 
Operations” on page 774).
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When dragging a Bar|Beat Marker:

• Its BPM value is recalculated along with the 
Bar|Beat Marker to its immediate left. 
Bar|Beat Markers to the right of the dragged 
marker remain unchanged.

• Its bar and beat location is dragged with the 
Bar|Beat Marker. If the Bar|Beat Marker was 
originally placed at 3|1|000, it remains there 
(unless it is edited).

• Its sample and SMPTE locations change, as 
calculated for by the new tempo for the 
Bar|Beat Marker.

• Neighboring MIDI events, along with the 
Bars|Beats ruler, shrink or expand as neces-
sary to adjust for the new tempo.

When dragging a tempo event:

• The tempo event is placed at a new bar and 
beat location. The sample and SMPTE loca-
tions for the event are updated as well.

• The BPM value for the dragged tempo event 
remains constant, as do any other tempo 
events in the session.

• Neighboring MIDI events and audio clips on 
tick-based tracks, along with the ruler, shrink 
or expand as necessary to adjust for the new 
tempo location.

Dragging a Bar|Beat Marker
Pro Tools Reference Guide
Editing Bar|Beat Markers
A Bar|Beat Marker can be edited to redefine its 
bar and beat location, which also redefines the 
start or end point of the range being analyzed 
for tempo. This is different from dragging a 
Bar|Beat Marker. 

To edit a Bar|Beat Marker:

1  In the Tempo ruler, double-click the Bar|Beat 
Marker.

2  In the Edit Bar|Beat dialog, enter a new Loca-
tion for the Bar|Beat Marker.

3  Enter a new Time Signature. 

4  Click OK.

To delete a Bar|Beat Marker:

 With the Grabber tool, Alt-click (Windows) or 
Option-click (Mac) the Bar|Beat Marker.

Edit Bar|Beat dialog



Inserting Bar|Beat Markers One 
at a Time
Sample-Based Material with Varying Tempos

You can insert Bar|Beat Markers one at a time by 
setting an Edit insertion point (instead of mak-
ing a selection) before using the Identify Beat 
command. The ability to identify each beat, one 
at a time, is especially useful when working with 
sample-based material with varying tempos.

For instance, if you have a measure that acceler-
ates slightly, you can insert a Bar|Beat Marker 
on each beat so the tempo is accurately re-
flected.

After the Bar|Beat Markers are inserted, further 
adjustments in the tempo map are possible by 
dragging each of the Markers, as necessary, to 
align with the associated beat within the audio.

Bar|Beat Markers on each beat
Meter Events
You can change meter in the Meter ruler, or 
make precise meter changes in the Time Opera-
tions window.

Meter events can be inserted at the beginning of 
a session to replace the default meter (of 4/4), 
and they can be inserted anywhere within the 
session for additional meter changes.

To display the Meter ruler:

 Select View > Rulers > Meter.

Current Meter
As meter events are encountered during play-
back, the session’s current meter is displayed in 
the Transport window.

Current meter displayed in Transport window
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Inserting Meter Events

To insert a meter event:

1  Do one of the following:

• Choose Event > Time Operations > Change 

Meter.

• Click the Add Meter Change button at the 
right of the Meter ruler.

• With the Grabber, Start-click (Windows) or 
Control-click (Mac) at the location where 
you want to insert the event.

• Double click the meter display in the Trans-
port window.

2  In the Meter Change window, do the following:

• Enter the Location and Meter for the meter 
change.

– and –

• If you want the inserted meter event to fall 
cleanly on the first beat of the nearest mea-
sure, select the Snap To Bar option.

Add Meter Change button

Manually inserting a meter event

Current meter displayed in Transport window
Pro Tools Reference Guide
3  Select a note value for the number of clicks to 
sound in each measure. For a dotted-note click 
value, select the dot (.) option.

4  Click OK to insert the new meter event. The 
new meter event is inserted and appears in the 
Meter ruler.

Each meter event has a small yellow triangle 
next to it that indicates its location. These trian-
gles can be selected for copying and pasting, and 
they can be double-clicked to edit the meter 
event.

Meter Change window

For some meters, it may be desirable to use a 
dotted value for the click. For instance, if us-
ing a meter of 6/8, a dotted quarter note 
click (yielding two clicks per measure) is 
generally more suitable than a straight 
eighth note click (six clicks per measure).

Inserted meter event



Editing Meter Events
Existing meter events can be edited, deleted, 
copied, and pasted.

To edit a meter event:

1  In the Meter ruler, double-click the meter 
event.

2  In the Meter Change dialog, enter a new Loca-
tion or Meter for the event.

3  Click OK.

To delete a meter event:

 Alt-click (Windows) or Option-click (Mac) the 
meter event.

To copy and paste several meter events:

1  If you want to constrain the selection to the 
current Grid value, set the Edit mode to Grid. 

2  Drag in the Meter ruler to select the range that 
includes the meter events.

If the beginning of the selection includes a me-
ter event, press Control (Windows) or Com-
mand (Mac) so the Selector tool appears.

3  Choose Edit > Copy.

4  Click in the Meter ruler at the point where you 
want to paste the meter events.

5  Choose Edit > Paste. The contents of the Clip-
board are pasted from the insertion point, re-
placing any existing meter events.

Press Alt (Windows) or Option (Mac) while 
dragging to select across all Conductor 
tracks.
To extend an Edit selection in a track to the Meter 
ruler:

1  Using the Selector tool or any Grabber tool, se-
lect a track range.

2  Shift-click in the Meter ruler.

Shift-click again in the Meter ruler to remove it 
from the selection.

To select all meter events:

 With the Selector tool, double-click in the Me-
ter ruler.

To clear a range of selected meter events:

1  If you want to constrain the selection to the 
current Grid value, set the Edit mode to Grid. 

2  Drag in the Meter ruler to select the meter 
events you want to remove.

3  Choose Edit > Clear to delete the selected meter 
events.

Partial Measures
As necessary, Pro Tools will create a partial 
measure to accommodate the inserted meter 
event. When a meter event is preceded by a par-
tial measure, the meter event is displayed in ital-
ics in the Meter ruler.

Partial measures can also occur when pasting 
meter events to locations other than the first 
beat of a measure.

Partial measure of 4/4

To insert meter events while avoiding par-
tial bars, use the Change Meter command in 
the Time Operations window. See “Change 
Meter” on page 800.
Chapter 36: Time, Tempo, Meter, Key, and Chords 799



800
Time Operations
The Time Operations window lets you:

• Change Meter

• Insert Time

• Cut Time

• Move Song Start

To open a specific Time Operations window:

 Choose Event > Time Operations, followed by 
one of the Time Operations commands (such as 
Change Meter).

To open the last active Time Operations window:

 Choose Event > Time Operations > Time Opera-

tions Window.

Change Meter
Change Meter in the Time Operation window 
lets you specify complex meter changes for 
Bar|Beat-based material. You can enter meter 
changes at a particular bar, make a meter change 
over a selected area of time, or add meter 
changes sequentially one bar at a time.

If the Time Operations window is already 
open, you can select any Time Operation 
from the pop-up menu at the top of the win-
dow.

Press Alt+1 (Windows) or Option+1 
(Mac) on the number keypad to open the 
Time Operations window and display the 
last active Time Operations window.
Pro Tools Reference Guide
Change Meter Examples

To change the meter over a range of bars:

1  Do one of the following:

• Drag with the Selector tool to select a range 
of bars to change.

– or –

• To have the meter change apply until the 
next meter event, click where you want the 
meter change to begin with the Selector 
tool. The meter change will be made at the 
beginning of the nearest bar.

2  Choose Event > Time Operations > Change Me-

ter.

3  Specify a new meter and click setting. 
Pro Tools will automatically set the selection op-
tions to fit the new meter to the selected range as 
closely as possible, adding or subtracting beats a 
necessary.

4  Select To Selected Range in the Apply Change 
pop-up menu.

5  Select which rulers and tracks you want to re-
align after meter changes have been made.

6  Click Apply.

Change Meter window



To add a series of meter changes, one measure at 
a time:

1  Do one of the following:

• With the Selector tool, click where you want 
the meter change to begin. The meter 
change will be made at the beginning the 
nearest bar.

– or –

• Enter the first measure number in the 
Starting At Bar field. 

2  Choose Event > Time Operations > Change Me-

ter.

3  Specify a new meter and click setting. 

4  Select Until the Next Bar from the Apply Change 

To pop-up menu.

5  Click Apply to enter the new meter and to move 
the insertion point to the end of the new mea-
sure.

6  Specify a new meter and click setting for the 
next measure.

7  Repeat steps 5–6 for every additional meter 
change you want to insert.
Change Meter Options
Options for the Change Meter command include:

New Meter Lets you specify a new time signa-
ture. The first field lets you enter the number of 
beats (up to 99) in a measure, and the second 
field lets you enter the note length that counts as 
one beat.

Click Lets you specify the note value that will 
trigger the metronome click. For example, if an 
eighth note is chosen, a click is played for every 
eighth note, regardless of tempo.

Starting at Bar Sets the bar where the meter 
change is added. Meter changes made in the 
Change Meter page can only be made at the be-
ginning of a bar.

Apply Change To Lets you apply the meter 
change to the selected range, to the end of the 
session, or until the next bar. 

Change The Change fields let you specify the 
number of bars of the new meter that you want 
to have replace the selected range.

Pro Tools automatically calculates the nearest 
whole bar number, or you can specify a number 
of bars to be affected. Time is inserted or de-
leted, in whole bar increments, at the end of the 
selection, as necessary on all affected tracks 
when you override the calculated range.
Chapter 36: Time, Tempo, Meter, Key, and Chords 801



802
Realign

The Realign controls let you choose which items 
to realign after a meter change has been made. 
You can choose to realign meter events, or 
choose to realign meter and tempo events, tick-
based markers and tracks, and also all or none of 
the sample-based markers and tracks.

Meter Ruler Only Applies the meter change and 
realigns only the Meter ruler. All other rulers 
and tracks are unaffected.

Meter, Tempo, Key, and Chord Rulers, all Tick-
Based Markers and Tracks, and Sample-Based 
Markers and Tracks Applies the meter change 
and realigns the Meter, Tempo, Key, and Chord 
rulers, and all tick-based markers and tracks. 
Using the pop-up menu, you can also choose to 
realign All or No sample-based markers and 
tracks. Time is inserted or deleted as needed at 
the end of the selection to preserve the align-
ment of material following the selection.
Pro Tools Reference Guide
Insert Time
Insert Time in the Time Operation window lets 
you insert an amount of blank time (silence) 
into Conductor rulers, MIDI tracks, and audio 
tracks.

Insert Time Example

To insert four empty measures of 4/4 time into a 
session:

1  Set the Main Time Scale to Bars|Beats.

2  Choose Event > Time Operations > Insert Time.

3  Enter the measure where you want to insert the 
measures in the Start field. 

4  Enter four measures in the Length field.

5  Select the Realign option for Meter, Tempo, 

Key, and Chord Rulers, Tick-Based Markers and 

Tracks and All Sample-Based Markers and Tracks.

6  Click Apply.

Insert Time window



Insert Time Options
Options for the Insert Time command include:

Start, End, and Length Sets the start and end 
points for the selection, and the selection 
length. 

Set Meter If your Main Time Scale is Bars|Beats, 
Set Meter lets you specify a new meter for the in-
serted time. The selection is quantized to the 
nearest bars, and the previous meter is inserted 
after the selection. If your Main Time Scale is 
sample-based, Set Meter is not available.

Realign

The Realign settings let you select which items 
shift (occur later) when time is inserted, as fol-
lows:

• If your Main Time Scale is set to Bars|Beats, 
you can choose to realign meter events only, or 
choose to realign a combination of Meter and 
Tempo rulers, all tick-based markers and 
tracks, and your choice of sample-based 
tracks.

• If your Main Time Scale is set to an absolute 
timebase (such as Min:Secs), you can choose 
to independently realign conductor events, 
tick-based markers and tracks, and your 
choice of sample-based tracks. 
Meter Ruler Only If your Main Time Scale is 
Bars|Beats, you have the option to insert time 
into the Meter ruler only. Meter events after the 
start point of the selection are shifted past the 
end point by the length of time selection. 

If your Main Time Scale is sample-based, Re-

align Meter Ruler Only is not available.

Meter, Tempo, Key, and Chord Rulers, Tick-Based 
Markers and Tracks, and Sample-Based Markers 
and Tracks Lets you insert time into the Meter, 
Tempo, Key, and Chord rulers, and all tick-
based markers and tracks. Events after the start 
point of the selection are shifted past the end 
point by the length of time inserted. 

If the Timeline selection includes any audio 
clips on tick-based tracks, the audio clips are 
separated at the Start point, and the new clip 
containing the previous selection is shifted to 
the end point.

Using the pop-up menu, you can also choose to 
insert time into All or No sample-based markers 
and tracks. If All is selected and the selection in-
cludes any audio clips on sample-based tracks, 
the selected portions of the audio clips are sepa-
rated at the Start point, and the new clip con-
taining the previous selection is shifted to the 
end point.
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Cut Time 
Cut Time in the Time Operation window lets you 
cut a specified amount of time (both Timebase 
and track data) from Conductor rulers, MIDI 
tracks, and audio tracks.

Cut Time Example

To cut thirty seconds of time from a session:

1  Set the Main Time Scale to Minutes:Seconds.

2  Choose Event > Time Operations > Cut Time.

3  With the Selector tool, click at the beginning 
of the area that you want to cut. 

4  Enter thirty seconds (0:30.000) in the Length 
field.

5  Select the Realign option for Meter, Tempo, 

Key, and Chord Rulers, all Tick-Based Markers 

and Tracks and All Sample-Based Markers and 

Tracks.

6  Click Apply.

Cut Time window
Pro Tools Reference Guide
Cut Time Options
Options for the Cut Time command include:

Start, End, and Length Sets the start and end 
points for the selection, and the selection 
length. 

Realign

The Realign controls let you choose which items 
shift when time is cut, as follows:

• If your Main Time Scale is set to Bars|Beats, 
you can choose to realign meter events only, or 
choose to realign a combination of Meter and 
Tempo rulers together, all tick-based markers 
and tracks, and your choice of sample-based 
tracks.

• If your Main Time Scale is set to an absolute 
timebase (such as Min:Secs), you can choose 
to independently realign conductor events, 
tick-based markers and tracks, and your 
choice of sample-based tracks. 

Meter Ruler Only If your Main Time Scale is 
Bars|Beats, you have the option to remove time 
from the Meter ruler only. Meter events within 
the selection are removed, and meter events that 
occur after the end point of the selection are 
shifted to the selection start point. 

If your Main Time Scale is sample-based, Re-

align Meter Ruler Only is not available.

Meter, Tempo, Key, and Chord Rulers, Tick-Based 
Markers and Tracks, and Sample-Based Markers 
and Tracks Cuts time and realigns the Meter, 
Tempo, Key, and Chord rulers, and all tick-
based markers and tracks. 

If the time selection includes any tick-based 
clips, the selected area of the clips is deleted, 
and clips following the selection are shifted for-
ward.



Using the pop-up menu, you can also choose to 
cut time from All or No sample-based markers 
and tracks. If All is selected and the selection in-
cludes any audio clips on sample-based tracks, 
the selected area of the clips is deleted, and clips 
following the selection are shifted forward.

Move Song Start 
Move Song Start in the Time Operation window 
lets you redefine the location of the Song Start 
Marker.

Move Song Start Example

To move the Song Start Marker to 15 seconds on 
the Timeline:

1  Choose Event > Time Operations > Move Song 

Start.

2  Select Minutes:Seconds from the Timebase 
pop-up menu. 

3  In the Move Song Start To field, enter 
“0:15:000” to move the song start forward by 15 
seconds.

Move Song Start window
4  If you want to renumber the bars so that the 
Song Start Marker sits at a different bar, select 
the Renumber Song Start option, and enter the 
bar number.

5  Select whether you want to move All or No sam-
ple-based markers and tracks. 

6  Click Apply.

Move Song Start Options
Options for the Move Song Start command in-
clude:

Timebase Lets you precisely redefine the posi-
tion of the Song Start Marker measured by any 
supported timebase.

Move Start To Sets the location for the Song 
Start Marker in the chosen timebase. 

Renumber Song Start To When enabled, this lets 
you set the Song Start Marker to any bar 
number.

Move

The Move controls let you choose which items 
shift when the Song Start is moved, as follows:

Song Start Only Moves the Song Start Marker 
only.

Meter, Tempo, Key, and Chord Rulers, all Tick-
Based Markers and Tracks, and Sample-Based 
Markers and Tracks Moves the Song Start 
Marker, events in the Meter, Tempo, Key, and 
Chord rulers, all tick-based markers and tracks, 
and your choice of all or no sample-based mark-
ers and tracks.
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Renumbering Bars
You can use the Renumber Bars command to re-
number all bars in the session, effectively 
changing the bar locations for all clips, meter 
and tempo events while leaving their position 
intact. In doing so, however, the SMPTE and 
sample locations of the session data are not 
changed.

To renumber bars:

1  Choose Event > Renumber Bars.

2  Specify the bar you want to renumber, along 
with the new bar number, then click Renumber.

Key Signatures
The Key Signature ruler lets you add key signa-
tures to Pro Tools sessions. Key signatures can 
be imported and exported with MIDI data. This 
is especially useful when exporting MIDI se-
quences for use in notation programs like Sibel-
ius (see “Exporting Sibelius Files” on page 351). 
The default key signature is C major.

Renumber Bars dialog
Pro Tools Reference Guide
Key Signature Ruler
The Key Signature ruler lets you add, edit, and 
delete key signatures. You can use key signa-
tures to indicate key and key changes in your 
Pro Tools session. Key signatures can also be 
used for certain diatonic functions, such as 
transposing in key or constraining pitches to the 
specified key.

To view the Key Signature ruler, do one of the 
following:

 Select View > Rulers > Key Signature.

– or –

 From the Ruler View selector in the Edit win-
dow, select Key.

You can also show or hide the Key Signature 
Staff for the Key Signatures ruler.

To view the staff for the Key Signature ruler:

1  Show the Key Signature ruler.

2  Do one of the following:

• Select View > Rulers > Key Signature Staff.

– or –

• Click the Show/Hide triangle on the Key 
Signature ruler.

Key Signature ruler



Changing Key Signatures
You can add, edit, or delete key signatures.

To add a key signature:

1  Place the cursor in the Timeline where you 
want to add a key signature.

2  Do one of the following:

• Choose Event > Add Key Change.

– or –

• Click the Plus (+) button in the Key Signa-
ture ruler.

3  In the Key Change dialog, select the mode 
(major or minor), the key, its location and range, 
and how you want it to affect pitched tracks.

4  Click OK.

To edit a key signature:

1  Double-click the Key Signature marker in the 
Key Signature ruler.

2  Make changes in the Key Change dialog.

3  Click OK.

To delete a key signature, do one of the following:

 Alt-click (Windows) or Option-click (Mac) the 
Key Signature marker in the Key Signature ruler.

– or –

 Make a selection in the Key Signature ruler 
that includes the key signature you want to de-
lete and choose Edit > Clear or press Delete.
Key Change Dialog
The Key Change dialog lets you specify the mode 
(major or minor), the key (from seven flats to 
seven sharps), the range affected (for example, 
from Bar 1 to the next key change), and whether 
or not MIDI notes on pitched tracks are trans-
posed or constrained to key (see “Pitched 
Tracks” on page 808). The Key Change dialog 
opens whenever you add or edit a Key Signature 
marker.

Major Keys Displays the major keys from seven 
flats to seven sharps.

Minor Keys Displays the minor keys from seven 
flats to seven sharps. Pro Tools only applies the 
natural minor mode.

Sharps Lets you select any of the sharp keys to 
seven sharps and C major (or A minor).

Flats Lets you select any of the flat keys to seven 
flats and C major (or A minor).

From Lets you specify where to place the Key 
Signature marker in Bars|Beats.

To Lets you specify to where you want the key 
change to take effect: to the next Key Signature 
marker, to a selection, or to the end of the ses-
sion.

Snap to Bar Snaps the Key Signature marker to 
the barline.

Key Change dialog
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Edit Pitched Tracks Enabling the Edit Pitched 
Tracks option lets you transpose existing MIDI 
notes on Pitched tracks up or down, either dia-
tonically or chromatically based on the key 
change, or constrain pitches to the new key. For 
more information on Pitched tracks, see 
“Pitched Tracks” on page 808.

Transpose When the Edit Pitched Tracks option 
is enabled, lets you transpose existing MIDI 
notes on Pitched tracks up or down, diatonically 
or chromatically. For example, if the session is 
in C major and you are adding a key change to D 
minor, select Edit Pitched Tracks, Transpose, 
Up, and Diatonically to transpose notes on 
Pitched tracks up a whole step and then lower 
the third, sixth, and seventh scale degrees by a 
half step. The sequence C, D, E is transposed to 
D, E, F (natural, rather than sharp as happens 
when transposing chromatically). 

When transposing diatonically, chromatic notes 
are maintained when changing key. For exam-
ple, when changing key from C major to E major, 
the note B-flat is transposed to D-natural. This 
lets you maintain “blue-notes” when changing 
keys and applying diatonic transposition.

Constrain Pitches To Key When the Edit Pitched 
Tracks option is enabled, lets you constrain 
pitches to the notes of the new key. This means 
that any diatonic pitches of the old key on 
Pitched tracks that are not in the new key are in-
dividually transposed to the nearest diatonic 
pitch of the new key. For example, when chang-
ing from C major to D major, the sequence C, D, 
E, F, G changes to C-sharp, D, E, F-sharp, G.

Constraining pitches to key also constrains any 
chromatic pitches to the new diatonic scale. For 
example, when changing from C major to D ma-
jor, the sequence C, D, D-sharp, E changes to C-
sharp, D, D, E.
Pro Tools Reference Guide
Pitched Tracks
Pitched tracks are MIDI or Instrument tracks 
that can be affected by transpositions due to key 
changes (including constrain to key). MIDI and 
Instrument tracks are “pitched” by default. 
However, if you have MIDI or Instrument tracks 
assigned to drum machines or samplers, you do 
not want those tracks to be affected by key 
changes because of key mappings. You can dese-
lect the Pitched option for specific MIDI and In-
strument tracks so that they will not be affected 
by key changes.

To select (or deselect) Pitched tracks:

 Click the track’s Playlist selector and select (or 
deselect) the Pitched option.

Pitched enabled in Playlist selector



Importing Key Signatures
When importing MIDI (or session data with 
MIDI), you can select whether or not to import 
any key signatures stored in MIDI files.

Import MIDI

The Import MIDI dialog includes the Import Key 

Signature from MIDI File option. When selected, 
key signatures (if present) are imported into 
Pro Tools with any other MIDI data.

Import Session Data

The Import Session Data dialog includes the Im-

port Key Signature/Chord Map option. When se-
lected, key signatures (if present) and chord 
markers (if present) are imported into the cur-
rent session with the imported session data.

Import MIDI dialog

Import Session Data
Chord Symbols
The Chord Symbols ruler lets you add chord 
symbols to Pro Tools sessions in the Edit win-
dow and in MIDI Editor windows. You can also 
add chord symbols and diagrams in the Score 
Editor (“Chord Symbols and Diagrams” on 
page 754). 

Chord symbols have no effect on MIDI data. 
Also, chord symbols are not included when ex-
porting MIDI data from Pro Tools to a MIDI file, 
but they are included when exporting to a Sibel-
ius file (.sib) or when using the Send to Sibelius 
command.

Chord Symbols Ruler
The Chord Symbols ruler lets you add, edit, and 
delete chord symbols. You can use chord sym-
bols to indicate the chord changes in your 
Pro Tools session. 

To view the Chord Symbols ruler, do one of the 
following:

 Select View > Rulers > Chord Symbols.

– or –

 From the Ruler View selector in the Edit win-
dow or in a MIDI Editor window, select Chords.

Chord Symbols ruler

Chords ruler
Add Chord Symbol

Chord Symbol markers
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To add a chord symbol:

1  Place the cursor in the Timeline where you 
want to add a chord symbol.

2  Do one of the following:

• Place the cursor in the timeline, then click 
the Plus (+) button in the Chords ruler.

– or –

• While pressing the Start key (Windows) or 
Control (Mac), move the cursor into the 
Chords ruler (where the cursor changes to 
the Grabber with a “+”) and click at the lo-
cation where you want to place the chord 
symbol.

3  In the Chord Change dialog, select the name 
for the root of the chord, the chord quality, the 
bass note of the chord, and the chord diagram 
(chord diagrams are only displayed in the Score 
Editor).

4  Click OK.

To change a chord symbol:

1  Double-click the Chord Symbol marker in the 
Chord Symbol ruler.

2  Make changes in the Chord Change dialog.

3  Click OK.

To move a chord symbol:

 Drag the Chord Symbol marker to a new time 
location.

To delete a chord symbol, do one of the following:

 Alt-click (Windows) or Option-click (Mac) the 
Chord Symbol marker in the Chords ruler.

– or –

 Make a selection in the Chords ruler that in-
cludes the chord symbols you want to delete and 
choose Edit > Clear or press Delete.
Pro Tools Reference Guide
Chord Change Dialog
The Chord Change dialog lets you specify a com-
mercial chord symbol and chord diagram (gui-
tar tab) to place in the Chords ruler or on the 
score in the Score Editor. The Chord Change di-
alog opens whenever you add or edit a Chord 
marker.

Chord Select the name for the root of the Chord 
(such as D).

Chord Quality Select the chord quality from the 
selector (such as major or minor).

Bass Select the bass note of the chord (such as 
B-flat for a G minor chord in first inversion).

Chord Diagram Select the chord diagram for gui-
tar tablature.

Chord Change dialog

To show or hide chord symbols and diagrams 
in the Score Editor, select or deselect the cor-
responding option in the Score Setup dialog.

Chord selector Chord Quality
selector

Bass Note

Chord Diagrams

selector



Chapter 37: Memory Locations
Memory Locations provide a powerful way to 
navigate your session while editing and arrang-
ing. 

Each session can save up to 999 Memory Loca-
tions that can be used to recall:

• Markers to important locations in the ses-
sion

• Edit selections across one or more tracks

• Record and play ranges, along with pre- and 
post-roll times

• Track settings that include Show/Hide sta-
tus, Track Heights, and zoom values

• Edit and Mix Groups enables

• Window Configurations

Memory Locations are viewed and sorted in the 
Memory Locations window, where they can be 
recalled by clicking the Memory Location.
Creating Memory Locations
Memory Locations can be created in different 
ways, based on the type of Memory Location:

Marker Memory Location Refers to a specific 
point in the timeline.

Selection Memory Location Refers to an Edit Se-
lection

General Properties Memory Location Refers to a 
combination of session settings (such as zoom 
settings, pre- and post-roll times, Show/Hide 
status for tracks, Track Heights, and Edit and 
Mix Group enables).

When creating Memory Locations, the next 
available number is assigned to it (1–999). This 
number is used in recalling the Memory Loca-
tion from the numeric keypad.
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To create a Marker Memory Location:

1  Configure any session settings you will save 
with the Marker Memory Location, such as zoom 
settings, pre- and post-roll times, Show/Hide 
status for tracks, Track Heights, and Edit and 
Mix Group enables.

2  If necessary, enable Options > Link Timeline and 

Edit Selection.

3  Ensure that the Markers ruler is displayed 
(View > Rulers > Markers).

4  Do one of the following:

• Click with the Selector tool in any track or 
ruler at the location where you want to 
place the Marker. To place a Marker at the 
beginning of a clip, select the clip with the 
Time Grabber tool. Click the Add 
Marker/Memory Location button (or press 
Enter on the numeric keypad).

– or –

• While pressing the Start key (Windows) or 
Control (Mac), move the cursor into the 
Markers ruler (where the cursor changes to 
the Grabber with a “+”) and click at the lo-
cation where you want to place the Marker.

Add Marker/Memory Location button

Manually inserting a Marker
Pro Tools Reference Guide
5  In the New Memory Location dialog, select the 
Marker option and set the Reference to either 
Bar|Beat or Absolute.

6  Enter a Name for the new Marker and select 
any General Properties you want to save with the 
Marker.

7  Click OK. The Marker is created and appears in 
the Markers ruler, and in the Memory Locations 
window.

To create a Selection Memory Location:

1  Configure any session settings you will save 
with the Selection Memory Location, such as 
zoom settings, pre- and post-roll times, 
Show/Hide status for tracks, Track Heights, and 
Edit and Mix Group enables.

2  Select a range of material in one or more 
tracks. 

3  Do one of the following:

• Press Enter on the numeric keypad.

– or –

• From the Memory Locations Window 
menu, choose Add Memory Location.

4  In the New Memory Location dialog, select the 
Selection option and set the Reference to either 
Bar|Beat or Absolute.

5  Enter a Name for the new Memory Location 
and select any General Properties you want to 
save with it.

6  Click OK. The Selection Memory Location is 
created and appears in the Memory Locations 
window.

To create a General Properties Memory Location:

1  Configure any session settings you will save 
with the Selection Memory Location, such as 
zoom settings, pre- and post-roll times, 
Show/Hide status for tracks, Track Heights, and 
Edit and Mix Group enables.



2  Press Enter on the numeric keypad.

3  In the Memory Location dialog, select the 
None option.

4  Enter a Name for the new Memory Location 
and select any General Properties you want to 
save with it.

5  Click OK. The General Properties Memory Lo-
cation is created and appears in the Memory Lo-
cations window.

Creating Memory Locations 
On-the-Fly
When the Auto-Name Memory Locations When 

Playing option is enabled in the Editing Prefer-
ences page, Memory Locations can be created 
during playback, without opening the New 
Memory Location dialog. This option can also be 
selected from the Memory Locations Window 
menu.

This capability is useful if you want to mark cer-
tain locations while listening during a record 
pass, or if you want to mark frame locations 
while viewing a video scene.

To create a Marker during playback:

1  From the Memory Locations Window menu, 
select Default To Marker. This ensures that new 
Memory Locations default to being Markers.

2  From the Memory Locations Window menu, 
select Auto-Name Memory Locations.

In the New Memory Location dialog, you 
can Alt-click (Windows) or Option-click 
(Mac) any General Property to enable or 
disable all properties. You can also Control-
click (Windows) or Command-click (Mac) 
any property to toggle its state and the state 
of all other General Properties.
3  For inserted Markers to have a Bar|Beat refer-
ence, make sure to set the Main Time Scale to 
Bars|Beats.

4  Click Play in the Transport.

5  When the location is reached, press Enter on 
the numeric keypad. A Marker is automatically 
created and appears in the Markers ruler.

Auto-created Markers are named with increas-
ing numbers, for example, “Marker 1,” 
“Marker 2,” and “Marker 3.”

When the Default To Marker option is deselected, 
new Memory Locations default to whatever type 
was last created. Therefore, if a Selection Mem-
ory Location was created last, it will be the type 
that is created on-the-fly. In this case, the name 
for the created Memory Location is based on the 
start of the Edit selection using the time format 
for the Main Time Scale (such as “2|2|305” or 
“0:02.658”).

When Use Separate Play and Stop Keys op-
tion is enabled in the Operation Preferences 
page, it overrides using the Enter key to add 
Memory Location markers. When this op-
tion is enabled, press Period (.) and then 
Enter on the numeric keypad to add a Mem-
ory Location marker. The new marker is 
created when you press Enter.
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Properties of Memory 
Locations
When creating a new Memory Location (see 
“Creating Memory Locations” on page 811) you 
are prompted to define its Time Properties and 
General Properties.

Time Properties
Under Time Properties, a Memory Location can 
be set to Marker, Selection, or None. This deter-
mines the type of Memory Location that is cre-
ated. Each of these three Memory Location types 
can also save any combination of General Prop-
erties.

Marker Recalls a Timeline location whose refer-
ence can be either Bar|Beat (tick-based) or Ab-
solute (sample-based). When recalling a Marker 
Memory Location, the playback cursor moves to 
the Marker’s location and the start and end 

Memory Locations window
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times in the Transport window are also updated. 
If the Timeline and Edit Selections are linked, 
the edit cursor also moves to the Marker loca-
tion.

Markers appear in the Markers ruler with a thin 
yellow line extending down through all tracks in 
the Edit window (to assist in arranging and 
aligning track material). You can click a Marker 
in the Markers ruler to recall its location along 
with its stored General Properties.

Selection Recalls an Edit selection or edit cursor 
location whose reference can be either Bar|Beat 
(tick-based) or Absolute (sample-based). A Se-
lection Memory Location lets you store Edit se-
lections, for one or more tracks, that you return 
to often within a session. If the Timeline and 
Edit Selections are linked, a Selection Memory 
Location can recall record and play ranges.

None Recalls no Time Properties and is there-
fore referred to as a General Properties Memory 
Location.

Markers in the Markers ruler

Only contiguous selections can be saved 
with Memory Locations. Noncontiguous se-
lections, made with the Object Grabber tool, 
will be recalled as if the selections were 
made with the Time Grabber tool.



Bar|Beat and Absolute Reference

The Reference pop-up determines whether the 
Marker or Selection Memory Location is 
Bar|Beat or Absolute. When set to Bar|Beat, the 
Memory Location is tick-based and its bar and 
beat location remains constant if the tempo is 
changed—though its relation to the absolute 
sample location changes accordingly.

When set to Absolute, the Memory Location is 
sample-based and its bar and beat location 
shifts if the tempo is changed—though its sam-
ple location remains constant, along with its re-
lation to audio material.

In the Markers ruler, Markers that are Bar|Beat 
appear as yellow chevrons, and Markers that are 
Absolute appear as yellow diamonds.

General Properties
All three types of Memory Locations (Marker, 
Selection, and None) can store and recall any 
combination of the following General Proper-
ties:

Number Change the number to overwrite an ex-
isting Memory Location, or to reorder Memory 
Locations in the Memory Locations window.

Name Enter a descriptive name for each memory 
location.

Zoom Settings Recalls the horizontal, audio, 
and MIDI zoom values for audio, MIDI, and In-
strument tracks.

Bar|Beat Marker (left) and Absolute Marker (right)
Pre/Post Roll Times Recalls pre- and post-roll 
times (but not whether they are enabled). This 
property can be stored with a Selection Memory 
Location to recall record and play ranges along 
with pre- and post-roll.

Track Show/Hide Recalls which tracks are hid-
den. Use this property to display groups of 
tracks for editing and mixing.

Track Heights Recalls all Track Heights. Use this 
option along with Zoom Settings to recall edit 
environments that are suited for particular 
tasks, such as editing down to the sample level 
or trimming MIDI notes.

Group Enables Recalls which Edit and Mix 
Groups are enabled. This option is helpful in re-
calling groups for particular edit and mixing op-
erations, such as muting all drum tracks or fad-
ing a stereo pair.

Window Configuration Recalls a specific Win-
dow Configuration. This option is helpful in re-
calling specific Window Configurations to facil-
itate editing or mixing tasks. For more 
information on Window Configurations, see 
“Window Configurations” on page 198.

Comments
All three types of Memory Locations (Marker, 
Selection, and None) can store and recall com-
ments. You can enter a maximum of 255 charac-
ters to describe the Memory Location. You can 
also edit comments previously entered.

See “Creating Memory Locations” on 
page 811 and “Editing Memory Locations” 
on page 816 for more information.
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Recalling Memory Locations
Memory Locations can be recalled from the 
Memory Locations window and from the nu-
meric keypad. Additionally, Memory Location 
Markers can be recalled by clicking them in the 
Markers ruler.

To recall a Memory Location:

1  Select Window > Memory Locations to display 
the Memory Locations window.

2  If recalling a Selection Memory Location that 
defines a record or play range, ensure that Op-

tions > Link Timeline and Edit Selection is se-
lected.

3  Do one of the following:

• In the Memory Locations window, click the 
Memory Location to recall it.

• With the Numeric Keypad mode set to Clas-
sic, press the Memory Location number fol-
lowed by Period (.). 

• With the Numeric Keypad mode set to 
Transport or Shuttle, press Period (.), the 
Memory Location number, and Period (.) 
again.

To recall a Marker from the Markers ruler:

1  Select View > Rulers > Markers to display the 
Markers ruler.

2  Click the Marker you want. The playback cur-
sor locates to the Marker and any General Prop-
erties stored with the Marker are recalled.

When recalling a Memory Location from the 
numeric keypad, the Memory Locations 
window does not need to be open.

Even if the Markers ruler is not displayed, 
Markers can be recalled from the Memory Lo-
cations window, or from the numeric keypad.
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Editing Memory Locations
Memory Locations can be renamed, edited, de-
leted, and copied and pasted.

To rename a Memory Location:

1  Do one of the following:

• In the Memory Locations window, double-
click the Memory Location to open the Edit 
Memory Location dialog.

• In the Marker ruler, double-click the 
Marker to open the Edit Memory Location 
dialog and relocate the insertion point at 
the marker location.

• In the Marker ruler, Start-click (Windows) 
or Control-click (Mac) the Marker to open 
the Edit Memory Location dialog without 
locating the insertion point at the marker 
location.

2  Enter the new name for the Memory Location, 
and click OK.

To redefine the General Properties stored with a 
Memory Location:

1  Make changes to the session’s zoom settings, 
pre- and post-roll times, Show/Hide status of 
tracks, Track Heights, or Group Enables.

2  Do one of the following:

• In the Memory Locations window, double-
click the Memory Location to open the Edit 
Memory Location dialog.

• In the Marker ruler, double-click the 
Marker to open the Edit Memory Location 
dialog and relocate the insertion point at 
the marker location.

• In the Marker ruler, Start-click (Windows) 
or Control-click (Mac) the Marker to open 
the Edit Memory Location dialog without 
locating the insertion point at the marker 
location.



3  In the Memory Location dialog, select the 
General Properties you want to save with the 
Memory Location.

4  Enter a name for the Memory Location and 
click OK.

To change a Memory Location from one type to 
another:

1  Do one of the following:

• In the Memory Locations window, double-
click the Memory Location to open the Edit 
Memory Location dialog.

• In the Marker ruler, double-click the 
Marker to open the Edit Memory Location 
dialog and relocate the insertion point at 
the marker location.

• In the Marker ruler, Start-click (Windows) 
or Control-click (Mac) the Marker to open 
the Edit Memory Location dialog without 
locating the insertion point at the marker 
location.

2  In the Memory Location dialog, select either 
Marker, Selection, or None as the Memory Loca-
tion type. 

3  Enter a name for the Memory Location and 
click OK.
To change the Selection stored with a Memory 
Location:

1  Select View > Rulers > Markers to display the 
Markers ruler.

2  Select a range of material in one or more 
tracks. 

3  In the Memory Locations window, Right-click 
(Windows) or Control-click (Mac) the Memory 
Location that you want to redefine.

4  Enter a name for the Memory Location and 
click OK.

To move a Marker by dragging:

 In the Markers ruler, drag the Marker left or 
right.

If the Edit mode is set to Grid, the dragged event 
snaps to the current Grid value. If using Spot 
mode, the Spot dialog opens.

To align a Marker to a different location:

1  If necessary, select Options > Link Timeline and 

Edit Selection.

2  Do one of the following:

• In any of the Timebase rulers, click with the 
Selector tool at the new location.

– or –

• Click in the playlist for any track. To align 
the Marker to the start of a clip, select the 
clip with the Time Grabber tool.

3  In the Memory Locations window or the Mark-
ers ruler, Start-click (Windows) or Control-click 
(Mac) the Marker Memory Location that you 
want to redefine.

4  Enter a name for the Marker and click OK.
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Deleting Memory Locations
To delete a Memory Location, do one of the 
following:

 Select the Memory Location and choose Delete 

Memory Location from the Memory Locations 
Window menu.

– or –

 In the Memory Locations window, Alt-click 
(Windows) or Option-click (Mac) the Memory 
Location.

To delete all Memory Locations, do one of the 
following:

 Choose Delete All from the Memory Locations 
Window menu.

– or –

 Alt-Shift-click (Windows) or Option-Shift-
click (Mac) any Memory Location in the Memory 
Locations window.

To delete a Marker from the Markers ruler:

 Alt-click (Windows) or Option-click (Mac) the 
Marker.
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Copying Marker Memory 
Locations
To copy and paste a range of Markers:

1  If you want to constrain the selection to the 
current Grid value, set the Edit mode to Grid. 

2  Drag in the Tempo ruler to select the range of 
measures that includes the Markers.

If the beginning of the selection includes a 
Marker, press Control (Windows) or Command 
(Mac) so the Selector tool appears.

3  Choose Edit > Copy.

4  Click in the Markers ruler at the point where 
you want to paste the tempo events.

5  Choose Edit > Paste. The contents of the Clip-
board are pasted from the insertion point, re-
placing any existing Markers.

To extend an Edit selection in a track to the 
Markers ruler:

1  Using the Selector or Grabber tool, select a 
track range.

2  Shift-click in the Markers ruler. 

Shift-click again in the Markers ruler to remove 
it from the selection.

To select all Markers in the Markers ruler:

 With the Selector tool, double-click in the 
Markers ruler.

Press Alt (Windows) or Option (Mac) while 
dragging to select across all Conductor 
tracks.



Memory Locations Window
In the Memory Locations windows, Memory Lo-
cations are listed with assigned number, name, 
and View Filter icons. Locations can be recalled 
or edited from this window.

To recall a Memory Location from the Memory 
Location window:

 Click the Memory Location.

Memory Locations 
Commands and Options
You can select viewing and sorting options, 
along with commands for creating and removing 
Memory Locations, from the Memory Locations 
Window menu.

Memory Locations window with View Filter icons

With the Numeric Keypad mode set to Clas-
sic, press the Memory Location number fol-
lowed by Period (.). With the Numeric Key-
pad mode set to Transport or Shuttle, press 
Period (.), the Memory Location 
number, and Period (.) again.

Memory Locations Window menu
View Filter Submenu Provides commands to 
show or hide specific memory location proper-
ties:

• Show Icons

• View Markers

• View Selections

• View Locations with Zoom Info

• View Locations with Pre/Post Roll Info

• View Locations with Track Show/Hide Info

• View Locations with Track Height Info

• View Locations with Group Info

• View Locations with Window Configura-
tion Info 

• Show Markers Only

• View All

Show Main Counter When selected, a column 
appears in the Memory Locations window that 
displays the locations based on the Main Time-
scale for Markers, and the start times for Selec-
tion Memory Locations. General Property Mem-
ory Locations display nothing in this column.

Main/Sub Counters in the Memory Locations window

Sub Time Scale
Main Time Scale
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You can click at the top of the Main Time Scale 
column for a pop-up menu that lets you change 
the Main Time Scale.

Show Sub Counter When selected, a column ap-
pears in the Memory Locations window that dis-
plays the locations based on the Sub Time Scale 
for Markers, and the start times for Selection 
Memory Locations. General Property Memory 
Locations display nothing in this column.

You can click at the top of the Sub Time Scale 
column for a pop-up menu that lets you change 
the Sub Time Scale.

Show Comments When selected, a column ap-
pears in the Memory Locations window that dis-
plays the comments for each of the Markers.

Sort by Time When selected, Markers are sorted 
by their order in the Timeline, followed by Selec-
tion and General Properties Memory Locations, 
which are listed in the order in which they were 
created.

When Sort by Time is deselected, all Memory Lo-
cations are listed in the order of their assigned 
numbers.

Memory Locations Window, selecting the Main Time 
Scale

Comments in the Memory Locations window
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New Memory Location Choose this command to 
create a new Memory Location.

Edit <Name> Opens the Edit Memory Location 
dialog for the selected Memory Location. You 
can also double-click a Memory Location in the 
Memory Locations window to edit it.

Clear <Name> Clears the selected Memory Loca-
tion, but does not remove its slot. Subsequent 
Memory Locations are not renumbered.

Delete All Deletes all Memory Locations. The 
next Memory Location you add starts at slot 
number 1.

Insert Slot Before <Name> Adds a new, empty 
Memory Location slot above the selected Mem-
ory Location, and renumbers all subsequent 
Memory Locations.

Delete <Name> Slot Deletes the selected Mem-
ory Location, and renumbers all subsequent 
Memory Locations.

Default To Marker When selected, new Memory 
Locations default to Markers, though in the New 
Memory Location dialog you can still define the 
new Memory Location as one of the other types.

Auto-Name Memory Location When selected, 
Memory Locations are created automatically 
without encountering the New Memory Loca-
tion dialog. If the Default To Marker option is se-
lected, a Marker Memory Location is auto-cre-
ated. Otherwise, the Memory Location type is 
determined by whatever type (Marker, Selec-
tion, or None) was created last.

Alt-click (Windows) or Option-click (Mac) 
a Memory Location in the Memory Loca-
tions window to clear it.



View Filter Icons
When Show Icons is selected in the Memory Lo-
cations pop-up menu, the Memory Locations 
window provides an icon-based “View Filter” 
that lets you show or hide Memory Locations 
based on the properties they contain. 

To show or hide Memory Locations containing a 
specific property:

 Click the appropriate icon.

Color and Properties

When a view icon is enabled, it appears in color. 
When it is disabled, it appears gray.

If an icon is disabled (grayed out), all Memory 
Locations associated with that property are hid-
den. However, if a Memory Location contains 
other properties for an icon that is enabled, it is 
still displayed. 

In addition, the View Filter provides a useful 
reference for which properties are stored in each 
Memory Location (indicated by a row of icons 
for each Memory Location).

Memory Locations View Filter icons

Marker

Selection
Memory Location

Zoom

Pre- and Post-Roll

Show/Hide
Track HeightsSettings

Active Groups

Window Configuration
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Chapter 38: Arranging Clips
Once you have created a clip, it appears in the 
Clip List. From the Clip List you can drag it to a 
track to add to an existing arrangement of clips, 
or you can create a new track and start adding 
clips from scratch. The exact placement of clips 
in a track depends on whether the Edit mode is 
set to Shuffle, Slip, Spot, or Grid (see “Edit 
Modes” on page 539).

Placing Clips in Tracks
To place a clip in a track:

1  In the Clip List, select the clip or clips you 
want to place.

2  Drag the selected clips from the Clip List to a 
location in a track. 

You can locate clips in the Clip List by typ-
ing the first few letters of their name (see 
“Keyboard Selection of Clips” on 
page 274).
If dragging multiple clips, the clips are placed 
on adjacent tracks left to right or on multiple 
tracks from top to bottom depending on the se-
lected Timeline Drop Order option (see “Setting 
Timeline Drop Order” on page 824). If dragging 
a stereo audio clip, it must be placed in a stereo 
track or in two mono tracks.

Clips are placed according to the current Edit 
mode:

• In Shuffle mode, existing track clips are slid as 
necessary to make room for the new clip.

• In Spot mode, you are prompted by the Spot 
dialog to enter a location for the dragged clip 
(see “Spotting Clips” on page 831). 

• In Grid mode, the dragged clip snaps to the 
nearest Grid boundary.

• In Slip mode, the clips are placed exactly 
where they are dropped in the destination 
track.

You can temporarily disable Grid mode 
while dragging a clip by holding down the 
Control key (Windows) or Command key 
(Mac) after clicking with the mouse.
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Working with Multiple Items 
from the Clip List

Setting Timeline Drop Order
The Timeline Drop Order option in the Clip List 
menu sets whether tracks dragged from the Clip 
List are dropped sequentially in a single track or 
spread across multiple tracks, as follows:

Top to Bottom When enabled, clips spread 
across multiple destination (drop) tracks or on 
new tracks (when dragging to the area below the 
last track or to the Track List). 

Left to Right When enabled, clips are placed se-
quentially in a single destination (drop) track or 
on a new track (when dragging to the area below 
the last track or on to the Track List).

To set the Clip List Drop Order:

 Choose Clip List > Timeline Drop Order, and 
then Top to Bottom or Left to Right. 

Dragging and Dropping Multiple 
Items from the Clip List

To drag and drop multiple items from the Clip List 
to multiple new tracks:

1  From the Clip List menu, choose Timeline Drop 

Order > Top to Bottom.

2  Search and sort the Clip List to configure the 
order in which items will be placed. 
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3  Select multiple items in the Clip List and do 
one of the following:

• To create new tracks and place items to a 
specific location, drop items at the location 
along the area below the last track. 

– or –

• To create new tracks and have items placed 
at the start of the session, drop the items on 
the Track List. 

To place multiple items across multiple existing 
tracks:

1  From the Clip List menu, choose Timeline Drop 

Order > Top to Bottom.

2  Select multiple items in the Clip List and drop 
them in the playlist of a compatible track at the 
target location. When the cursor is over a com-
patible destination, the clip outlines appear at 
the location. 

New tracks after dropping multiple Clip List items, with 
Timeline Drop Order set to Top to Bottom mode



To drag and drop multiple items from the Clip List 
to a single track: 

1  From the Clip List menu, choose Timeline Drop 

Order > Left to Right.

2  Search and sort the Clip List to configure the 
order in which items will be placed. 

3  Select multiple items in the Clip List and do 
one of the following:

• To create a new track and spot the first item 
to a specific location, drop at the location 
in the area below the last track shown in the 
Edit window. 

• To create a new track and have the first item 
placed at the start of the session, drop the 
items on the Track List. 

• To place items in an existing track, drop the 
items in the Edit playlist for the track. 

If the selected items include mixed types of clips 
(such as audio and MIDI, or clip groups and 
MIDI) the appropriate track types will be cre-
ated and each corresponding item will be placed 
in them. Similarly, if the selected items include 
multiple formats (mono, stereo, or other) new 
tracks of each format will be created and those 
clips placed in them. 

A new track created by dropping multiple Clip List 
items with Timeline Drop Order set to Left to Right 
mode
Placing Clips at the Edit 
Insertion Point
You can drag a clip from the same track, from 
another track, or from the Clip List, and align its 
start, end, or sync point to the Edit insertion 
point. This technique is useful in post produc-
tion since it lets you set an Edit selection point 
during playback or while stopped and then 
quickly place sound effects at the edit insertion 
point.

To place the start of a clip at the Edit insertion 
point:

1  With the Selector tool, click in the track at the 
time location where you want to place the start 
of the clip. 

2  Do one of the following:

• While pressing the Start key (Windows) or 
Control (Mac), drag the clip from the Clip 
List, or from another track, to the destina-
tion track.

– or –

• If the clip is already in the track, Start-click 
(Windows) or Control-click (Mac) the clip 
with the Time Grabber tool.

With Pro Tools HD, when the Scrolling op-
tion is set to Center Playhead, clips snap to 
the playhead, instead of the Edit insertion 
point.
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To place the end of a clip at the Edit insertion point:

1  With the Selector tool, click in the track at the 
time location where you want to place the end of 
the clip. 

2  Do one of the following:

• While pressing Control+Start (Windows) 
or Command+Control (Mac), drag the clip 
from the Clip List, or from another track, to 
the destination track.

– or –

• If the clip is already in the track, Control-
Start-click (Windows) or Command-Con-
trol-click (Mac) the clip with the Time 
Grabber tool.

To place the sync point of a clip at the Edit 
insertion point:

1  With the Selector tool, click in the track at the 
time location where you want to place the sync 
point of the clip. 

2  Do one of the following:

• While pressing Start+Shift (Windows) or 
Control+Shift (Mac), drag the clip from the 
Clip List, or from another track, to the des-
tination track.

– or –

• If the clip is already in the track, Shift-
Start-click (Windows) or Shift-Control-
click (Mac) the clip with the Time Grabber 
tool.
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Aligning Clip Start Points
The start, end, and sync point of one clip can be 
aligned to the start of a different clip on another 
track.

To align the start points of clips on different tracks:

1  With the Time Grabber tool, select the clip you 
want to align to by clicking it.

2  If the Scrolling option is set to Center Playhead 
(Pro Tools HD only), move the playhead to the 
start of the selected clip. For details, see “Mov-
ing the Playhead” on page 427.

3  Do one of the following:

• Start-drag (Windows) or Control-drag 
(Mac) a clip from the Clip List to another 
track.

– or –

• If the clip is already in the track, Start-click 
(Windows) or Control-click (Mac) the clip 
you want to move with the Time Grabber 
tool.

With Pro Tools HD, when the Scrolling op-
tion is set to Center Playhead, clip start, 
end, and sync points align to the playhead.



To align the end point of a clip to the start of 
another clip (on a different track):

1  With the Time Grabber tool, select the clip you 
want to align to by clicking it.

2  If the Scrolling option is set to Center Playhead 
(Pro Tools HD only), move the playhead to the 
start of the selected clip (see “Moving the Play-
head” on page 427).

3  Do one of the following:

• Control-Start-drag (Windows) or Com-
mand-Control-drag (Mac) a clip from the 
Clip List to another track.

– or –

• If the clip is already in the track, Control-
Start-click (Windows) or Command-Con-
trol-click (Mac) the clip you want to move 
with the Time Grabber tool.

To align the sync point of a clip to the start of 
another clip (on a different track):

1  With the Time Grabber tool, select the clip you 
want to align.

2  If the Scrolling option is set to Center Playhead 
(Pro Tools HD only), move the playhead to the 
start of the selected clip (see “Moving the Play-
head” on page 427).

3  Do one of the following:

• Start-Shift-drag (Windows) or Control-
Shift-drag (Mac) a clip from the Clip List to 
another track.

– or –

• If the clip is already in the track, Start-
Shift-click (Windows) or Control-Shift-
click (Mac) the clip you want to move with 
the Time Grabber tool.
Sliding Clips
A clip or group of selected clips (on the same 
track or on multiple tracks) can be slid with the 
Time Grabber tool to new locations or to other 
tracks. This feature is useful in post production 
applications where the timing of audio events 
such as sound effects and dialog need to be spot-
ted to music, film, or video.

Sliding clips is affected by whether the current 
Edit mode is set to Shuffle, Slip, Spot, or Grid 
(see “Edit Modes” on page 539).

Shuffling Clips
In Shuffle mode, you can move clips freely 
within a track or onto another track, but their 
movement is constrained by other clips. That is, 
if you place several clips in a track, their start 
and end points automatically snap to each other. 
You can then “shuffle” their order, but you can-
not separate them from each other and you can-
not make them overlap as in Slip mode. In Shuf-
fle mode, adding another clip to the beginning 
of a track moves all subsequent clips to the right 
by the length of the clip added.

You can slide a copy of a clip to another lo-
cation or track by pressing Alt (Windows) or 
Option (Mac) while dragging.

To retain a clip’s time location when 
dragging to another track, press the Start 
key (Windows) or Control (Mac) while 
dragging.
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To shuffle clips:

1  Enable Shuffle mode (see “Edit Modes” on 
page 539).

2  Drag a mono clip from the Clip List to an 
empty track. The clip snaps to the beginning of 
the track.

3  Drag a second clip from the Clip List to the 
same track, somewhere in the middle. The start 
point for the second clip snaps to the end of the 
first clip.

4  With the Time Grabber tool, drag the second 
clip to the beginning of the track.

Pro Tools “shuffles” the position of the two 
clips. The second clip now occurs first, yet the 
two still cling together.

5  Experiment more with Shuffle mode by drag-
ging additional clips to the track and rearrang-
ing them.

Locked clips (see “Locking Clips” on page 839), 
and all clips occurring after the locked clip, are 
not displaced when other neighboring clips are 
moved in Shuffle mode. If there is not enough 
room to place or duplicate a clip in front of a 
locked clip, the insertion area is disabled.

If you place a clip while in Slip mode and switch 
to Shuffle mode, Pro Tools preserves the relative 
timing and position of the slipped clip, and any 
space between it and other 
clips.

With certain workflows, it is important to 
exclude Shuffle mode in order to ensure that 
clips stay time-aligned while editing. Shuffle 
Lock prevents you from inadvertently enter-
ing Shuffle mode by disabling all key com-
mands and control surface switches for 
Shuffle mode. For more information, see 
“Shuffle Lock” on page 540.
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Shuffling Multiple Tracks and 
Multichannel Clips
Selections across multiple tracks or on multi-
channel tracks can be shuffled. Unlike shuffling 
clips on a single track, any partially selected 
clips are cut and moved along with the dragged 
clip. This lets you retain only the material that 
corresponds to the dragged clip.

Shuffling a clip results in cutting the channel



Moving Clips with the 
Grabber Tools
Use the Grabber tools to move one or more clips, 
or the Edit selection, to another location. The 
Grabber tools cut the selection and paste it to 
the new location. 

To move one or more clips, or the Edit selection, 
with one of the Grabber tools:

1  Make a selection.

2  With one of the Grabber tools (Time, Separa-
tion, or Object), drag the selection to the new lo-
cation.

Time Grabber and Object 
Grabber
If you are moving audio data, the Time Grabber 
and Object Grabber tools overlay only the audio 
data on the destination track.

Hold Alt (Windows) or Option (Mac) when 
dragging the selection with a Grabber tool to 
copy the selection rather than cut it.

Moving a selection with the Time Grabber
Separation Grabber
The Separation Grabber replaces the entire se-
lected range on the destination track Timeline. 

Snapping to the Preceding or 
Next Clip on a Track
A clip—or an Edit selection including one or 
more clips on the same track or on multiple 
tracks—can snap to the end of the preceding clip 
or to the beginning of the following clip. This is 
useful for “butt splicing” adjacent clips on a 
track.

To snap to the preceding clip on a track:

1  Do one of the following:

• With the Time Grabber, select a clip.

– or –

• With the Selector, select an area in a track 
that contains whole clips. The clips do not 
need to be adjacent.

Moving a selection with the Separation Grabber
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2  Do one of the following:

• Choose Edit > Snap To > Previous. 

– or –

• Right-click the clip or Edit selection and 
choose Snap to Previous.

The selected clip snaps to the preceding clip on 
the track so that the two clips are “butt-spliced.”

To snap to the next clip on a track:

1  Do one of the following:

• With the Time Grabber, select a clip.

– or –

• With the Selector, select an area in a track 
that contains whole clips. The clips do not 
need to be adjacent.

2  Do one of the following:

• Choose Edit > Snap To > Next. 

– or –

• Right-click the clip or Edit selection and 
choose Snap to Next.
Pro Tools Reference Guide
The selected clip snaps to the following clip on 
the track so that the two clips are “butt-spliced.”

Snapping a clip to the next clip in a track

You can also use the Snap To commands 
with an Edit selection that includes multiple 
clips on one or more tracks.



Slipping Clips
In Slip mode, clips can be moved with the Time 
Grabber tool freely within a track, or onto other 
tracks. In this mode, it is possible to place a clip 
so that there is space between it and other clips 
in a track. When the track is played back, this 
space is silent. It is also possible to move a clip 
so that it overlaps or completely covers another 
clip.

To slip clips:

1  Enable Slip mode (see “Edit Modes” on 
page 539).

2  Drag a clip from the Clip List to an empty 
track.

3  Drag a second clip from the Clip List to the 
same track, somewhere in the middle. The sec-
ond clip is placed wherever you release it. It does 
not snap to the first clip as in Shuffle mode.

4  Drag the clips to different locations within the 
track to get a feel for moving them in Slip mode. 
Try placing the second clip so that it slightly 
overlaps the first clip. Play back the results.
Spotting Clips
Spot mode is useful for sessions in which you 
want to spot clips to precise locations based on 
any of the Time Scales. This is useful when per-
forming post production tasks. In Spot mode 
you can spot a clip by specifying a SMPTE frame 
or bar and beat location, by capturing an incom-
ing timecode address, or by using the clip’s time 
stamps.

For even quicker spotting, if you are using 
VITC, use the Auto-Spot Clips command to 
spot a clip to the current SMPTE frame loca-
tion with the Time Grabber tool. For more 
information, see “Auto-Spotting Clips” on 
page 1162.

For more information on using SMPTE with 
Pro Tools, see Chapter 50, “Working with 
Synchronization.”
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To spot a clip:

1  Enable Spot mode (see “Edit Modes” on 
page 539).

2  Do one of the following:

• Drag a clip from the Clip List, or drag audio 
files or sessions from a DigiBase browser, to 
an existing track. 

– or –

• Click a clip already in a track with the Time 
Grabber tool.

3  In the Spot dialog, select a time format from 
the Time Scale pop-up menu.

Each of the fields in the Spot dialog are dis
played in the chosen Time Scale.

4  If the Time Scale is set to Timecode, select the 
Use Subframes option to display subframes in 
the fields for improved accuracy.

Spot dialog
Pro Tools Reference Guide
5  Do one of the following:

• Click in the field for Start, Sync Point, or 
End and type in a new location. Changing 
one of these locate points automatically up-
dates the other locate points.

• Click one of the up arrows next to Original 
Time Stamp or User Time Stamp to enter 
the associated values into the currently se-
lected field.

• If you are using an external SMPTE time-
code source, click the down arrow next to 
the Current Timecode display—or press 
Equal (=) on the numeric keypad—to cap-
ture an incoming timecode address.

6  Click OK. The clip is moved to the new location 
specified for its start, end, or sync point.

If a clip does not have a sync point defined, the 
Sync Point field in the Spot dialog functions the 
same as the Start field.

Right-Click Commands for 
Spotting Clips
You can use Right-click commands with a key 
combination to spot clips in a track.

To spot a clip to a selection:

1  Click or drag with the Selector tool to locate 
the cursor or make a selection in the track where 
you want to spot the clip.

2  Control-Right-click (Windows) or Command-
Right-click (Mac) the clip and choose any of the 
following from the pop-up menu:

• Move Clip Start to Selection Start 

• Move Clip Sync to Selection Start 

• Move Clip End to Selection Start 

In lower versions of Pro Tools, Right-click-
ing in a clip with the Grabber tool would 
spot the clip to a selection.



Clip Time Stamps
When a clip is created, it is time stamped rela-
tive to the SMPTE start time specified for the 
session. This Original Time Stamp is perma-
nently stored with the clip and cannot be 
changed. If a clip is ever moved, it can easily be 
placed at its original position from the Spot dia-
log.

When the Original Time Stamp for a clip is ini-
tially set, this same location is also used to de-
fine the clip’s User Time Stamp.

Unlike the Original Time Stamp, the User Time 
Stamp can be redefined with the Time Stamp 
command in the Clip List menu (see “Time 
Stamping” on page 1162). 

Time Stamps in DigiBase

Columns are provided in DigiBase browsers for 
both the Original and User Time Stamps. 

Time Stamps and Matches

Clips with identical User Time Stamps appear 
together in the Matches submenu in the Right-
click menu when auditioning takes (see “Select-
ing Alternate Takes on a Track” on page 475).

Sliding Clips in Grid Mode
Grid mode provides several useful capabilities 
for sliding and moving clips in track playlists. 
This mode is especially useful for lining up clips 
at precise intervals, as when working with a ses-
sion that is bar- and beat-based. Grid boundar-
ies, depending on the Main Time Scale, can be 
based on frames, bar and beat values, minutes or 
seconds, or a number of samples. 
Grid mode also provides two operational modes, 
Absolute and Relative. These modes control how 
the Grid is applied (see “Absolute and Relative 
Grid Mode” on page 834).

Setting Up the Grid
When the Draw Grid in Edit Window option is 
enabled in the Display Preferences page, vertical 
Grid lines appear in the Edit window.

Grid lines in the Edit window can also be en-
abled and disabled by clicking the Timebase 
ruler name after it becomes highlighted.

Defining the Grid Value
In addition to affecting the placement of clips, 
the Grid value also constrains Timeline and Edit 
selections, and determines how the Clip > Quan-

tize to Grid command works.

To set the Grid value:

1  Do one of the following:

• From the View > Main Counter menu, select 
the Time Scale for the Grid value.

– or –

• To keep the Main Time Scale and use a dif-
ferent time format for the Grid, deselect 
Follow Main Timebase in the Grid value 
pop-up menu.

To temporarily suspend Grid mode and 
switch to Slip mode while dragging a clip, 
hold down the Control key (Windows) or 
Command key (Mac).
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2  Do one of the following:

• From the Grid value pop-up menu, select 
the time value for the Grid boundaries.

– or –

• To define a Grid based on the session’s 
Markers, selections, and clip boundaries, 
select Clips/Markers from the Grid value 
pop-up menu.

Absolute and Relative Grid Mode
Grid mode can be applied in Absolute or Rela-
tive mode. 

 In Absolute Grid mode, moving any clip snaps 
the clip start to Grid boundaries. If a clip’s start 
point falls between beats, and the Grid is set to 
1/4 notes, dragging the clip will snap its start 
time to the nearest 1/4 note (the current abso-
lute Grid value). 

 In Relative Grid mode, clips can be moved by 
Grid (or Nudge) units. If a clip’s start point falls 
between beats and the Grid is set to 1/4 notes, 
dragging the clip will be constrained to 1/4 
notes, preserving the clip’s relative position to 
the nearest beat.

Grid value pop-up menu showing Bars|Beats
Pro Tools Reference Guide
To select Absolute or Relative Grid mode:

 Click the Grid mode selector and select Abso-

lute Grid or Relative Grid.

To place or move a clip while in Grid mode:

1  Configure the Grid value (see “Defining the 
Grid Value” on page 833).

2  Do one of the following:

• Drag a clip from the Clip List to an existing 
track. 

– or –

• With the Time Grabber tool, drag a clip al-
ready in a track to a new location.

The clip’s start point snaps to the closest Grid 
boundary. If the clip has a sync point defined, 
the sync point snaps to the Grid boundary.

Replacing Audio Clips
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Use the Replace Clip function to replace multi-
ple instances of an audio clip in a playlist with 
another clip. This is useful in post production if 
you use a sound effect, room noise, or atmo-
sphere clip many times in a session, and later 
decide to replace one or all of the original clips 
with a different clip.

This is also useful in music production if you 
want to replace a certain loop or sample (for ex-
ample, a drum beat) with a new one. You can use 
this compositionally, if you know the tempo of a 
section or session, to create a scratch piece with 
“rough” clips of the correct length, and later re-
place them with “final” clips of the same length.

To temporarily suspend Grid mode and 
switch to Slip mode while dragging a clip, 
hold down the Control key (Windows) or 
Command key (Mac).



To replace clips by dragging and dropping:

1  Select a clip in a track’s playlist that you want 
to replace. The selection can extend beyond the 
clip’s end point, to include material from the re-
placement clip that is longer than the original 
clip.

2  Control-Shift-drag (Windows) or Command-
Shift-drag (Mac) the replacement clip from the 
Clip List to the selected clip. The Replace Clip 
dialog opens.

3  Configure the Replace Clip dialog (see “Re-
place Clip Dialog Options” on page 836).

4  Click OK.

Replacing Clips from the Clip 
List
The Replace Clips command is also available in 
the Clip List menu. To use this command, make 
sure there is a clip selected in a track and a dif-
ferent (replacement) clip selected in the Clip 
List. 

To replace clips using the Clip List menu:

1  Select a clip in a track to be replaced. 

Control-Shift-drag (Windows) or Com-
mand-Shift-drag (Mac) any clip from the 
Clip List to any unselected clip on a track to 
open the Replace Clip dialog without first 
making a selection.
2  Do one of the following:

• Right-click the replacement clip in the Clip 
List and choose Replace Clips from the pop-
up menu.

– or –

• Select the replacement clip in the Clip List 
and choose Replace Clips from the Clip List 
menu. (If the Clip List Selection Follows 
Edit Selection preference is enabled, Con-
trol-click (Windows) or Command-click 
(Mac) the selected clip to deselect it, then 
Control-click (Windows) or Command-
click (Mac) the replacement clip to select it, 
and then choose Replace Clips from the 
Clip List menu.)

3  Configure the Replace Clip dialog (see “Re-
place Clip Dialog Options” on page 836).

4  Click OK.

Replace Clip and Multichannel 
Tracks
The Replace Clip command supports dragging 
multichannel clips from the Clip List to multi-
channel tracks, provided they are the same 
channel format. For example, you can replace a 
selected stereo clip in a stereo audio track with 
another stereo clip from the Clip List. However, 
you cannot replace it with two mono audio clips. 
Additionally, you cannot replace clips in multi-
ple mono tracks with multichannel clips.
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Replace Clip Dialog Options

The following options are available in the Re-
place Clip dialog:

Replace: Original Clip Only Replaces only the se-
lected clip with the replacement clip dragged 
from the Clip List.

Replace Clip dialog
Pro Tools Reference Guide
Replace: All Instances of the Original Clip Re-
places all instances of the selected clip that fit 
the On criteria with the replacement clip from 
the Clip List.

• On This Track: replaces clips that fit the 
Match criteria and are on the same track as 
the original clip.

• On All Tracks: replaces clips that fit the 
Match criteria for all tracks in the session.

• On Within the Selection: replaces clips that 
fit the Match criteria within the current se-
lection.

Replace: All Clips that Match Original Clip’s Re-
places all clips that fit the Match criteria and the 
On criteria with the replacement clip from the 
Clip List. 

• Start Position: replaces all clips that have 
the same original start time as the selected 
clip. This includes clips that may have been 
auto-created when trimming end points.

• End Position: replaces all clips that have the 
same original end time as the selected clip. 
This includes clips that may have been 
auto-created when trimming start points.

• Name: replaces all clips that come from the 
same audio file and have been renamed to 
the same name

• On This Track: replaces clips that fit the 
Match criteria and are on the same track as 
the original clip.

• On All Tracks: replaces clips that fit the 
Match criteria for all tracks in the session.

• On Within the Selection: replaces clips that 
fit the Match criteria within the current se-
lection.

Clip matching uses all specified Match criteria. 
For example, if you select Start Position and End 
Position, all clips from the same original audio 
file as your selection with the same original start 
and end times will be replaced.



Fit Clip Using The: Original Clip Length If the re-
placement clip is smaller than the original clip, 
the clip is placed in the playlist and any remain-
ing audio from the original clip is removed. 

If the replacement clip is larger than the selec-
tion, it is placed in the playlist and trimmed to 
fit within the length of the original clip.

Fit Clip Using The: Original Selection 
Length When the playlist selection extends be-
yond the original clip, the replacement clip (if 
larger than the original clip) is trimmed to fit 
within the selection.

Fit Clip Using The: Replacement Clip Length 

The replacement clip is placed in its entirety, re-
gardless of the length of the original clip or se-
lection.

Sync Points
The placement of clips in Grid and Spot mode 
can be based on the definition of a clip sync 
point. Sync points can be added to audio, MIDI, 
and video clips and also to clip groups. Sync 
points are used when a specific point within a 
clip must be aligned to the Grid or to a particu-
lar SMPTE or bar/beat location. This capability 
is especially important when placing music and 
sound effects for film and video work.

For example, suppose you had an audio clip for a 
door slam that included the creak of the door 
closing, the actual slam, and the reverb of the 
slam. Using a sync point for the slam sound in 
the clip lets you spot it to a specific time in the 
session.

To define a clip sync point:

1  Enable Slip mode (see “Edit Modes” on 
page 539).

2  Do one of the following:
• With the Selector tool, click at the point in 
the clip where you want the sync point.

– or –

• Press the Down Arrow key while playing 
back. 

3  Choose Clip > Identify Sync Point. A small down 
arrow appears at the bottom of the clip, with a 
vertical, light gray line indicating the location of 
the sync point.

To change the location of a sync point:

 With the Selector tool, click at a point in a clip 
and choose Clip > Identify Sync Point. The new lo-
cation is identified as the sync point for the clip.

Removing Sync Points

To remove a sync point, do one of the following:

 Select the entire clip and choose Clip > Re-

move Sync Point.

– or –

 Choose the Time Grabber tool, then Alt-click 
(Windows) or Option-click (Mac) the sync point 
to delete it.

Sync Point

You can also move the location of a sync 
point by dragging it (see “Dragging Sync 
Points” on page 838).
Chapter 38: Arranging Clips 837



838
Displaying Sync Points
Sync points in audio clips may displayed or hid-
den.

To disable the display of sync points in audio clips:

 Deselect View > Clip > Sync Point.

To enable the display of sync points in audio clips:

 Choose View > Clip > Sync Point. 

Dragging Sync Points
You can drag a sync point to another position in 
the audio clip. 

To set the sync point by dragging:

1  If you want the sync point to snap to the cur-
rent Grid value, enable Grid mode (see “Edit 
Modes” on page 539).

2  Select the Time Grabber tool.

3  Drag the sync point to a new location.

Scrubbing Sync Points
While viewing an audio waveform can be a good 
way to set a sync point, a waveform display may 
not always reveal the desired spot in the audio 
material. By scrubbing while moving the sync 
point over an audio waveform, you can listen for 
the exact location to place the sync point.

Scrubbing a Sync Point (cursor)
Pro Tools Reference Guide
To scrub while dragging the sync point:

1  If you want the sync point to snap to the cur-
rent Grid value when you finish scrubbing, set 
the Edit mode to Grid (see “Edit Modes” on 
page 539).

2  Select the Scrubber tool.

3  Drag the sync point to a new location. The sync 
point scrubs the audio as you move it.

Shift Command
Use the Shift command to move track material 
forward or back in time by a specified amount. 
The Shift command can operate on selections, 
clips, MIDI notes, MIDI controller data, and au-
tomation breakpoints.

To shift a selection or clip:

1  With the Selector or Time Grabber tool, select 
the track material you want to shift. The selected 
material can reside on multiple tracks.

2  Choose Edit > Shift. In the Shift dialog, select 
whether the data will be moved Earlier or Later.

3  Click in one of the Timebase fields to specify 
the amount by which the material will be 
shifted. Entering a value in one Timebase field 
automatically updates the others.

Shift dialog



4  If you want to shift material with greater pre-
cision, select the Use Subframes option.

5  Click OK. The material is shifted earlier or 
later by the specified amount. 

If a portion of a clip was selected, new clips are 
created from the selection and from any mate-
rial outside of the selection. 

The Shift command works the same regardless of 
the Edit mode. For example, adjacent clips are 
overlapped in Shuffle mode, the Spot dialog 
does not appear when in Spot mode, and shifted 
material does not snap to the Grid when in Grid 
mode.

Locking Clips
In many cases you may want to “lock” clips or 
clip groups to a specific time location to keep 
them from being moved or otherwise edited in-
advertently. Pro Tools provides two different 
commands for locking clips: Edit locking and 
Time locking.

Edit Locking Clips
If you have a clip or group of clips that you want 
to protect from being inadvertently edited, you 
can Edit lock them. Clips that are Edit-locked 
cannot be edited (such as cutting, deleting, sep-
arating, trimming, or adjusting clip gain) or 
moved to a different time location. Copied edit-
locked clips can be pasted to any other track or 
time location, but the copy will also be Edit-
locked at the new time location.

To Edit lock (or unlock) a clip:

1  With the Time Grabber, select the clip or clips 
to Edit lock (or unlock). The clips can reside on 
multiple tracks.
2  Choose Clip > Edit Lock/Unlock.

When Edit-locked, a small Edit Lock icon ap-
pears in the clip and it cannot be moved, de-
leted, or edited. If you attempt to perform edits 
on a locked clip, Pro Tools alerts you (see “Al-
lowing Editing of Edit-Locked Clips” on 
page 840).

In Shuffle mode, Edit-locked clips, and all clips 
occurring after the locked clip, are not displaced 
when other neighboring clips are moved.

On tick-based Elastic Audio-enabled tracks, 
Edit-locked clips conform to tempo changes, but 
not other Elastic Audio processing (such as 
Quantize or manual warping) can be applied.

Time Locking Clips
For clips that you want to lock to a particular lo-
cation in a track (a beat, SMPTE frame, or sam-
ple location), you can lock it in place so it cannot 
be moved accidentally. Time-locked clips can-
not be moved. However, they can be edited in 
ways that do not move the clip to a different 
time location (such as separating, trimming, 
AudioSuite processing, or even moving the clip 

Press Control+L (Windows) or Com-
mand+L (Mac) to Edit lock or unlock the se-
lected clip.

Edit Lock icon
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to another track). Time-locked clips can also be 
deleted. When separating a Time-locked clip, 
any new clips will also be locked to their time lo-
cations.

To Time lock (or unlock) a clip:

1  With the Time Grabber, select the clip or clips 
to Time lock (or unlock). The clips can reside on 
multiple tracks.

2  Choose Clip > Time Lock/Unlock.

When Time-locked, a small Time Lock icon ap-
pears in the clip and the clip cannot be moved, 
but it can be edited or even deleted.

In Shuffle mode, Time-locked clips, and all clips 
occurring after the locked clip, are not displaced 
when other neighboring clips are moved.

On tick-based Elastic Audio-enabled tracks, 
Time-locked clips conform to tempo changes, 
but not other Elastic Audio processing (such as 
Quantize or manual warping) can be applied.

Allowing Editing of Edit-Locked 
Clips
If you attempt to edit an Edit-locked clip, 
Pro Tools warns you and prompts you to Cancel 
or Allow the edit. If you allow an edit that keeps 
any part of the clip intact, the clip remains 
locked.

Press Alt+Start+L (Windows) or Op-
tion+Control+L (Mac) to Time lock or un-
lock the selected clip.

Time Lock icon
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Muting/Unmuting Clips
Choosing the Mute/Unmute Clip command mutes 
playback of a selected clip. Choosing the com-
mand a second time unmutes the clip. Clips that 
are muted become dimmed to indicate their sta-
tus.

To mute or unmute a clip or clips:

1  With the Time Grabber, select the clip or clips 
you want to mute or unmute. The clips can even 
reside on multiple tracks.

2  Choose Edit > Mute/Unmute. When muted, clips 
are dimmed.

Stripping Silence from Clips
Strip Silence analyzes audio selections—across 
multiple tracks—and removes (or extracts) any 
areas of silence, dividing the selection into 
smaller clips and removing the silent areas.

You can use Strip Silence to strip (remove) si-
lence from a clip, or instead, extract the audio 
and keep the silence. Getting rid of silent areas 
is useful when preparing to compact audio (see 
“Compacting an Audio File” on page 611). Strip 
Silence automatically separates the selection 
into separate clips, which is useful if you want to 
quantize audio to musical values, or locate 
sound effects to SMPTE locations.

Muted audio clip (middle)



Auto-Naming for Strip Silence
The Rename button in the Strip Silence window 
opens the Rename Selected Clips dialog, which 
determines how clips are named when stripping 
silence. The dialog remembers your previous 
settings, which can be cleared by clicking the 
Clear button.

Name Specifies the base name for clips created 
with Strip Silence.

Number Specifies the number at which sequen-
tial auto-numbering starts. 

Zeros Specifies the number of zeroes that occur 
before the appended auto numbers.

Suffix Specifies text appended to the end of the 
name, after the auto numbering.

For example, if you set these naming options to:

• Name = SFX

• Auto Number Start = 23

• Leading Zeros = 1

• Suffix = .Reel1

The names generated for clips created by Strip 
Silence would be:

• SFX023.Reel1

• SFX024.Reel1

• SFX025.Reel1

• SFX026.Reel1

• SFX027.Reel1

Rename Selected Clips dialog
Using Strip Silence

To strip silence from an audio selection:

1  Select one or more audio clips. 

2  Choose Edit > Strip Silence.

3  To set the naming scheme for clips created 
with Strip Silence, click Rename to open the Re-
name Selected Clips dialog. For details, see 
“Auto-Naming for Strip Silence” on page 841.

4  In the Strip Silence window, adjust the settings 
for Strip Threshold and Minimum Strip Duration 
(Min Strip) until Strip Silence rectangles appear 
in the selection.

For finer resolution on these controls, press 
Control (Windows) or Command (Mac) while 
adjusting them.

Press Control+U (Windows) or Com-
mand+U (Mac) to open the Strip Silence 
window.

Strip Silence rectangles
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5  To retain material before and after the new 
clips, adjust the settings for Clip Start Pad and 
Clip End Pad.

6  Once the Strip Silence rectangles encompass 
the audio that you want to keep, press the Strip 
button.

The material defined as silence is removed from 
the selection and new clips are created, which 
also appear in the Clip List.

Strip Silence is nondestructive and does not re-
move audio data from parent audio files. In ad-
dition to the Undo command, you can use the 
Heal Separation command to restore stripped 
material.

Strip Silence, padding clip start and end points

Strip Silence works with stereo and multi-
channel tracks, and keeps their audio clips 
phase-coherent.

Attack to be padded Decay to be padded
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To extract audio from an audio selection using 
Strip Silence:

1  Make an Edit selection.

2  Choose Edit > Strip Silence.

3  To set the naming scheme for clips created 
with Strip Silence, click Rename to open the Re-
name Selected Clips dialog (see “Auto-Naming 
for Strip Silence” on page 841).

4  In the Strip Silence window, adjust the settings 
for Strip Threshold and Minimum Strip Duration 
(Min Strip) until the Strip Silence rectangles ap-
pear in the selection.

5  Click the Extract button.

All audio above the designated threshold is de-
leted and the “silent” portions of the track are 
left.

To separate clips using Strip Silence:

1  Make an Edit or Timeline selection.

2  Choose Edit > Strip Silence.

3  To set the naming scheme for clips created 
with Strip Silence, click Rename to open the Re-
name Selected Clips dialog (see “Auto-Naming 
for Strip Silence” on page 841).

4  In the Strip Silence window, adjust the settings 
for Strip Threshold and Minimum Strip Duration 
(Min Strip) until the Strip Silence rectangles ap-
pear in the selection.

5  Click the Separate button.

New clips are created based on the boundaries 
detected by Strip Silence. 



The Strip Silence Window
The Strip Silence window contains the following 
controls that let you set the parameters by which 
silence is defined when using Strip Silence.

Adjusting these controls causes rectangles to 
temporarily appear in the selection, indicating 
areas of silence that will be affected by the Strip, 
Extract, or Separate commands.

Strip Threshold Sets the amplitude threshold 
(from –96 dB to 0 dB) for Strip Silence. Audio 
falling below this threshold is considered si-
lence and removed. Audio above the threshold is 
retained and defined as new clips.

Minimum Strip Duration Sets the minimum dura-
tion (from 0 to 4,000 ms) that the material above 
the threshold must last to be considered silence. 
Use this control to avoid countless small clips 
that may occur within a selection.

Strip Silence window

Strip Silence rectangles
Clip Start Pad Specifies a time value to be added 
to the beginning of each new clip created with 
Strip Silence. This is useful for preserving musi-
cal material that falls below the threshold, such 
as the breath before a vocal phrase, or the finger 
slide before a guitar chord.

Clip End Pad Specifies a time value to be ap-
pended to the end of each new clip created with 
Strip Silence, thereby preserving the nuances in 
the decay of the material.

Strip Clears the detected silence, but leaves the 
clips containing audio on the track.

Extract Clears the audio and leaves the silent 
portions of the track (in other words, an “in-
verse” strip silence feature that is ideal for gen-
erating room tone or ambience to use else-
where).

Rename Opens the Rename Selected Clips dialog 
(see “Auto-Naming for Strip Silence” on 
page 841).

Separate Separates clips based on the boundar-
ies detected by Strip Silence. 

Inserting Silence
The Insert Silence command is a simple and con-
venient way to insert silence on audio, MIDI, 
and Instrument tracks. This command lets you 
make a selection on a track (or tracks) and insert 
precisely that amount of silence. 

In Shuffle mode, all data on the track is shuffled 
later in the track by an amount equal to the se-
lection.

The Insert Silence command also affects 
markers in any selected Conductor Rulers 
(such as the Tempo or Meter rulers).
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In Grid mode, the Insert Silence command 
works just like the Clear command.

Shuffle Mode When inserting silence on multi-
ple tracks in Shuffle mode, the following condi-
tions apply:

 If any track is displayed as audio or MIDI data, 
the selected duration of silence is inserted into 
the audio or MIDI data and all underlying auto-
mation data on all selected tracks. All subse-
quent clips are shuffled by the amount of silence 
inserted. On MIDI tracks, only notes that are se-
lected from the beginning are affected, so if you 
have selected the tail of a note and you Insert Si-
lence, the note will remain unchanged.

 If all selected tracks are displayed as automa-
tion data, the selected range is cleared of auto-
mation data only of the type visible on each 
track. Clips are not shuffled. Instead, a blank gap 
appears equal to the length of the selection.

 If all selected tracks are displayed as automa-
tion data, press the Start key (Windows) or Con-
trol (Mac) while choosing the Insert Silence 
command to inserts silence on all automation 
playlists for all selected tracks. Clips are not 
shuffled.

Slip Mode When inserting silence on multiple 
tracks in Slip mode, the following conditions ap-
ply:

 If any track is displayed as audio or MIDI data, 
the selected range is cleared of audio or MIDI 
data and all underlying automation data on all 
selected tracks.

 If all selected tracks are displayed as automa-
tion data, silence is inserted only into the auto-
mation type visible on each track.
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 If all selected tracks are displayed as automa-
tion data, press the Start key (Windows) or Con-
trol (Mac) while choosing the Insert Silence 
command to insert silence on all automation 
playlists for all selected tracks.

To insert silence into a track:

1  Make a selection in a track or tracks. The 
length of the selection determines the duration 
of the silence inserted.

2  Choose Edit > Insert Silence.

In Shuffle mode, Pro Tools inserts the selected 
amount of silence. In the process, it splits the 
clips at the beginning of the insertion point, and 
moves the new clips later in the track by an 
amount equal to the length of the selection.

Duplicating Clips
The Duplicate command copies a selection and 
places it immediately after the end of the selec-
tion. Though this is similar to using Copy and 
Paste, Duplicate is more convenient and faster, 
particularly when working with data on multiple 
tracks. 

To make more than one copy of a selection, use 
the Repeat command (see “Repeating Clips” on 
page 845). You can also loop clips (see “Clip 
Looping” on page 847).

As with the Copy and Paste commands, certain 
rules apply when duplicating material on multi-
ple tracks (see “Editing Across Multiple Tracks” 
on page 537).



To duplicate a selection or clip:

1  If working with material that is bar- and beat-
based, such as loops, set the Main Time Scale to 
Bars|Beats.

2  If you want to constrain the selection to the 
current Grid value, set the Edit mode to Grid. 

3  Make an Edit selection.

4  Choose Edit > Duplicate. The material is placed 
immediately after the selection’s end point.

In Shuffle mode, the duplicated data is placed 
directly after the end of the selection. Clips oc-
curring after it slide to accommodate the dupli-
cated material. In Slip mode, the duplicated ma-
terial overlaps any adjacent data.

When using Duplicate (or Repeat) with MIDI 
notes that were selected with the Time Grabber 
tool, material is always duplicated one measure 
later, and is merged with existing track material 
(instead of replacing it).

Duplicating Audio and Keeping 
It On The Beat
When using Duplicate (or Repeat) for audio that 
must fall cleanly on the beat (such as rhythmic 
loops), it is important that you select the audio 
material with the Selector tool, or by typing in 
the start and end points in the Event Edit area. If 
you select an audio clip with the Time Grabber 
tool (or by double-clicking it with the Selector 
tool), the material may drift by several ticks be-
cause of sample-rounding.

Press Control+D (Windows) or Com-
mand+D (Mac) to Duplicate any selected 
clips.
If, on the other hand, you want to Duplicate (or 
Repeat) audio that is not bar- and beat-based, 
set the Time Scale to any format except 
Bars|Beats. This ensures that the duplicated au-
dio material has the correct number of samples 
and is accurately placed.

Repeating Clips
The Repeat command is similar to Duplicate, but 
lets you specify the number of times the selected 
material is duplicated.

As with the Copy and Paste commands, certain 
rules apply when repeating material on multiple 
tracks (see “Editing Across Multiple Tracks” on 
page 537).

You can repeatedly paste copied data until it 
completely fills a selection (see “Repeat To Fill 
Selection” on page 537).

You can also loop clips (see “Clip Looping” on 
page 847).

To repeat a selection or clip:

1  If working with material that is bar- and beat-
based, such as loops, set the Main Time Scale to 
Bars|Beats.

2  If you want to constrain the selection to the 
current Grid value, set the Edit mode to Grid. 
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3  Make an Edit selection.

4  Choose Edit > Repeat. In the Repeat dialog, en-
ter the number of times you want the material to 
repeat, then click OK.

The material is placed immediately after the se-
lection’s end point, and duplicated the specified 
number of times.

In Shuffle mode, the repeated data is placed di-
rectly after the end of the selection. Clips occur-
ring after it slide to accommodate the repeated 
material. In Slip mode, the repeated material 
overlaps any subsequent data.

Repeat dialog

Press Alt+R (Windows) or Option+R (Mac) 
to open the Repeat dialog for any selected 
clips.
Pro Tools Reference Guide



Chapter 39: Clip Loops and Groups
Pro Tools lets you loop clips or a group of clips 
(called a clip group).

Clip Looping
Pro Tools lets you loop audio clips, MIDI clips, 
and clip groups. Looping clips is an easy and 
powerful way to repeat a single clip on a track or 
clips across tracks for composing and arranging. 
Looping clips provides more flexibility than the 
Repeat and Duplicate commands.

Looped clips repeat the source clip as many 
times as specified in the Clip Looping dialog, or 
enough to fill the specified Loop Length (such as 
30 seconds or until the next clip on the track). 
The source clip is the original clip selected for 
looping. Loop iterations are all looped clips fol-
lowing the source clip. In cases where a specific 
number of repetitions has not been indicated, 
the last loop iteration is truncated to fill to the 
end of the selection or specified Loop Length.

Once looped, the looped clip can be edited much 
like a clip group. For example, selecting and 
moving a looped clip selects and moves the 
source clip and all its loop iterations together.
Looped clips (all iterations) display a Loop icon 
in the lower, right corner or each loop iteration. 

Looped clip

Looping a clip does not loop any automa-
tion associated with the source clip. Use the 
Copy Special and Paste Special Repeat To 
Fill Selection commands to copy automa-
tion for the source loop to all loop iterations 
(see “Automation and Looped Clips” on 
page 850).

Loop icons

Source clip Loop iterations

Looped clip
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Creating Looped Clips
You can create looped clips using the Loop com-
mand or using the Loop Trim tool. 

To loop a clip:

1  Select an audio or MIDI clip, or clip group. 

2  Do one of the following:

• Choose Clip > Loop. 

– or –

• Right-click the clip you want to loop and se-
lect Loop.

For information on using the Loop Trim 
tool, see “Loop Trim Tool” on page 557.

You can also select clips across tracks for 
looping.

Clip Looping dialog

Press Control+Alt+L (Windows) or 
Command+Option+L (Mac) to open the 
Clip Looping dialog.
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3  In the Clip Looping dialog, do one of the fol-
lowing:

• Select the Number of Loops option and enter 
the number of times to loop the clip.

• Select the Loop Length option and enter the 
duration according to the main timebase. If 
the duration is not an exact multiple of the 
source loop’s duration, the last loop itera-
tion will be truncated.

• Select the Loop Until End of Session or Next 

Clip option. The looped clip will be repeated 
until the end of the session, or until the 
next clip on the track. If necessary, the last 
loop iteration will be truncated to fit.

4  To add a crossfade at the loop point, select the 
Enable Crossfade option. To edit the loop cross-
fade, do the following:

• Click the Settings button.

• Configure the Loop Crossfades.

• Click OK.

5  In the Clip Looping dialog, click OK.

Loop Crossfade dialog

For information on working with crossfades, 
see Chapter 29, “Fades and Crossfades.”



Unlooping Clips
To unloop a looped clip:

1  Select the looped clip.

2  Do one of the following:

• Choose Clip > Unloop. 

– or –

• Right-click the clip you want to unloop and 
select Unloop.

3  Do one of the following:

• Click Remove to unloop and remove all 
loop iterations except the first full loop it-
eration (source clip).

– or –

• Click Flatten to unloop and create individ-
ual clips from each loop iteration.

To unloop and ungroup a selection down to its 
individual clips:

1  Select a looped clip that contains one or more 
clip groups.

2  Choose Clip > Ungroup All.

Unlooping and Flattening Looped Clips with 
Separate Clips Menu Commands

The Separate Clips commands (At Selection, On 

Grid, and At Transients) automatically unloop 
and flatten looped clips before separating.

Clip Ungroup functions on loops the same as 
using the Unloop command and choosing 
Flatten.
Editing Looped Clips
Looped clips can be edited as a group (all loop it-
erations together) or as individual clips (each 
loop iteration). For example, selecting a looped 
clip with the Grabber tool selects the entire loop 
(the source clip and all its loop iterations), but 
clicking the Loop icon of one of the loop itera-
tions selects only that one iteration.

Moving a looped clip moves the source clip and 
all its loop iterations together as a group. Loop 
iterations cannot be moved independently of 
their source clip. If you move or paste another 
shorter clip over a looped clip the loop is contin-
ued after the new clip. The parts of a separated 
looped clip can be adjusted independently. 

To select a looped clip as a group (all loop 
iterations), do one of the following:

 With the Grabber tool or Smart Tool, single-
click the looped clip. 

– or –

 With the Selector tool, double-click the looped 
clip.

The source clip and all its loop iterations are se-
lected.

Manually warping any part of a looped clip 
in Warp view separates only that iteration 
from the looped clip.
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To select an individual source clip or loop 
iteration, do one of the following:

 With the Grabber tool or Smart Tool, single-
click the Loop icon of the source clip or loop it-
eration.

– or –

 With the Selector tool, single click the Loop 
icon and drag to the left until the clip is selected.

Tabbing to Transients and Clip Boundaries

With Tab to Transients enabled you can tab both 
to transients and clip boundaries in a looped 
clip. Normal Tab (Tab to Transients disabled) 
tabs to the start and end boundaries of the entire 
looped clip. For more information, see “Tabbing 
to Transients” on page 580.

Trimming Looped Clips
Trimming looped clips can be done using the 
Trim tool, the Loop Trim tool, or one of the 
Trim Clip commands. The Loop Trim tool trims 
the entire looped clip. The Trim tool trims only 
the individual loop iteration while increasing or 
decreasing the number of loop iterations to fill 
the total length of the looped clip.

Loop icon

For information on trimming looped clips 
using the Loop Trim tool, see “Loop Trim 
Tool” on page 557.
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If the source clip is extended to the left by using 
the Trim tool to change the total length of the 
looped clip, the source clip is moved earlier in 
the Timeline and loop iterations fill in up to the 
point where the last original loop iteration 
ended. If the trim to the left is part of the source 
clip’s length, the source clip is not moved and a 
partial loop iteration is created to the left of the 
source clip. This is a powerful feature that lets 
you make quick changes to your arrangement by 
using partial loops as upbeats, or by extending 
looped sound effects or ambience earlier in a 
film score.

To trim a looped clip to the selection:

1  Use the Selector tool to make an Edit selection 
including some or all of the looped clip.

2  Choose Edit > Trim Clip and one of the Trim Clip 

commands (To Selection, To Fill Selection, Start 

to Fill Selection, or End to Fill Selection).

Automation and Looped Clips
Looping an audio clip does not loop any automa-
tion associated with the source clip. This lets 
you apply automation across an entire looped 
clip. For example, you may want to have a long 
volume fade across part or all of a looped clip 
that is independent of any one single loop itera-
tion. 

You can also repeat automation on each loop it-
eration. For looped audio clips, use the Copy 

Special and Paste Special Repeat to Fill Selection 
commands to copy and paste any or all automa-
tion data from the source clip to some or all of 
its loop iterations. 



To copy and paste automation from the source clip 
to loop iterations:

1  Select the source clip.

2  Choose Edit > Copy Special and one of the Copy 

Special commands (All Automation, Pan Automa-

tion, or Plug-In Automation), depending on what 
automation you want to copy.

3  Select the entire looped clip.

4  Choose Edit > Paste Special > Repeat to Fill Se-

lection.

Clip Groups
A clip group is a collection of any combination of 
audio and MIDI clips that looks and acts like a 
single clip. Clip groups are essentially contain-
ers holding one or more clips. Clip groups can be 
created on single or multiple adjacent audio, 
MIDI, and Instrument tracks. Clip groups let 
you “nest” multiple clips into “macro” clips for 
groove and tempo manipulation, editing, and 
arranging. 

Selected Pan automation for Special Copy

Pan automation Special Paste to Fill Selection
Clip groups can be placed on tracks alongside 
standard clips, and edited using many of the 
same editing techniques as regular clips. Certain 
edits to a clip group will apply to all clips con-
tained by the clip group, such as Cut or Delete. 
Other edits only apply to the boundaries of the 
clip group and do not affect the underlining 
clips, such as Trim.

Each clip group is saved with the session as a 
Clip Group file (.rgrp). Clip group files can be 
exported from and imported into different 
Pro Tools sessions.

Clip groups are especially useful for:

• Grouping tick-based audio clips that have 
been separated into many small clips, such as 
with individual hits of a drum pattern. Many 
such small clips can easily be created with 
Beat Detective or the Separate Clip At Tran-

sients command, or imported as REX or ACID 
files.

• Grouping parts and sections of your session to 
facilitate composition and arranging. For ex-
ample, grouping the clips of a brass section 
during the chorus to copy it to the next cho-
rus.

Clip groups are completely independent of 
and unique from Mix and Edit Groups.

Editing Elastic Properties is disallowed for 
clip groups.

Clip groups are not supported on audio 
tracks set to Playlists view. Changing an au-
dio track to Playlist View automatically un-
groups any clip groups on the track. 
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Creating Clip Groups
To create a clip group:

1  Select one or more clips on one or more tracks. 
(For more information on multitrack clip 
groups, see “Multitrack Clip Groups” on 
page 854).

The size of the selection determines the size of 
the clip group. The selection can start and end 
on any clip boundary, empty space, or even in 
the middle of a clip. Selections starting or end-
ing within a clip will separate the clip at the se-
lection boundary when you create a clip group. 
Clip groups created from object-based selec-
tions include all selected and unselected clips 
between the first and last selected clip on the 
track.

2  Do one of the following:

• Choose Clip > Group.

– or –

• Right-click the Edit selection and choose 
Group.

Selecting clips to be grouped on a single audio track

Press Control+Alt+G (Windows) or 
Command+Option+G (Mac) to group 
selected clips.

The Group and Ungroup Clip menu 
commands apply to any Edit selection 
regardless of the current Track View.
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The clip group appears as one clip with the clip 
groups icon in the lower left corner. Clip groups 
also appear in the Clip List.

Clip Group Timebase Format

Clip groups are created in the same timebase 
format (samples or ticks) as the tracks on which 
they are created. Multitrack clip groups can in-
clude both sample-based and tick-based tracks.

Clip Group icons on an audio track and in the Clip List

Audio Clip Group icon on an audio track

MIDI Clip Group icon on a MIDI track

Clip groups can be created from empty 
selections. This can be useful when working 
in Shuffle mode to preserve the gaps between 
clips.



Ungrouping Clips
To ungroup a clip group:

1  Select a clip group. 

2  Do one of the following:

• Choose Clip > Ungroup.

– or –

• Right-click the Edit selection and choose 
Ungroup.

The clip group disappears, revealing all underly-
ing clips and any nested clip groups. When there 
are multiple nested clip groups, the Ungroup 
command will ungroup the front-most top-layer 
clip group only, preserving any underlying clip 
groups.

To ungroup a clip group (and include all of its 
nested clip groups):

1  Select a clip group.

2  Choose Clip > Ungroup All.

Press Control+Alt+U (Windows) or 
Command+Option+U (Mac) to ungroup 
selected clip groups.
Regrouping Clips
The Regroup menu command undoes the last 
Ungroup command and regroups all the individ-
ual clips as a clip group. This lets you ungroup a 
grouped clip, edit its underlying clips, and re-
group it to continue working on higher-level 
composition and arranging.

To regroup a clip group:

1  Select any clip from the ungrouped clip group.

2  Choose Clip > Regroup.

If you used the Ungroup All command, the Re-

group command recreates all previous nested 
clip groups.

3  If you regrouped an ungrouped clip group that 
was used more than once in the session, do one 
of the following when the Change All dialog 
opens.

• Choose Modify to apply your changes to all 
other instances of the same clip group. 

– or –

• Choose Copy to create a copy and apply 
your changes only to the copied clip group. 

Press Control+Alt+R (Windows) or 
Command+Option+R (Mac) to regroup 
selected clips that were formally part of a 
clip group.
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Multitrack Clip Groups
Multitrack clip groups (clip groups created 
across multiple tracks) are useful for grouping 
parts (such as multi-miked drum tracks), and 
for composing and arranging. Multitrack clip 
groups can be created across any combination of 
audio, MIDI, and Instrument tracks, and can in-
clude either or both tick-based or sample-based 
tracks.

Multitrack clip groups work much like single-
track clip groups. Multitrack clip groups appear 
as a single object across adjacent tracks.

To create a multitrack clip group:

1  Select clips across multiple adjacent tracks.

2  Choose Clip > Group.

Selecting clips to be grouped across multiple tracks

Clip Group icon
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Separated Multitrack Clip 
Groups
You can insert, move, hide, or delete tracks in 
multitrack clip groups, but it may break the clip 
group. A separated clip group displays a break in 
the Clip Group icon. Separated clip groups will 

Mixed Clip Group icon (for a multitrack clip group of 
sample- and tick-based audio, and tick-based MIDI)

Multitrack clip groups create nested 
clip groups of multiple clips by track before 
grouping them across tracks.

The Regroup command supports multitrack 
clip groups.



continue to function as a single clip group, but 
the separated icon indicates that the clip group 
displayed is somehow incomplete or separated 
across nonadjacent tracks.

A clip group is separated when you do any of the 
following:

• Insert a track within a multitrack clip group.

• Move a track that is part of a multitrack clip 
group so that it is no longer adjacent with the 
other tracks of the clip group.

• Hide a track that is part of a multitrack clip 
group.

• Delete a track that is part of a multitrack clip 
group.

• Change the tempo of a mixed sample-based 
and tick-based clip group.

• Record into a clip group.

• Change playlists on a track that is part of a 
multitrack clip group.

• Change to Playlists view.

• Apply manual warping in Warp view.

Separated Clip Group icon
There may be situations where you want sepa-
rated clip groups. For example, if you use the 
same accompaniment on verses one and two of a 
song, you can group the parts of verse one and 
copy them as a clip group for verse two, but still 
have a continuous vocal track in the middle of 
those clip groups.

Clip Groups on Tick-Based 
Tracks
When changing tempos, clip groups on tick-
based tracks adjust their length by adjusting the 
position of all enclosed clips accordingly. This 
can be useful for arranging rhythmic material 
and for playing back clip groups imported from 
REX and ACID files. 

If you want to delete a track and keep the 
clip group intact, first ungroup the clip 
group, then delete track, and then Regroup 
the clip group. The clip group will be recre-
ated intact, but without the deleted track.

A clip group on a tick-based audio track at 120 BPM 
and at 160 BPM
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Changing Clip Group Timebase
The timebase format of a clip group can be 
changed by:

• Changing the track’s timebase.

– or –

• Dragging the clip group to a track with a 
different timebase.

Changing the timebase creates a copy of the 
original clip group. Both clip groups (the origi-
nal and the copy) appear in the Clip List, but 
they have different timebases.

Converting Samples to Ticks

When dragging a clip group from a sample-
based track to a tick-based track, the length of 
the clip group does not change. This is because 
clip groups are converted from samples to ticks 
after they are moved into tick-based tracks. The 
length of the clip group only changes with sub-
sequent tempo changes. If appropriate, change 
the local tempo on the tick-based track to match 
the tempo of the sample-based clip group before 
moving a sample-based clip group to a tick-
based track.

Converting Ticks to Samples 

When dragging a clip group from a tick-based 
track to a sample-based track, the length of the 
clip group does not change unless it is moved to 
another time location with a different tempo. 
This is because clip groups are converted from 
ticks to samples after they are moved into the 
sample-based tracks. 
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Multitrack Clip Groups with Sample- and Tick-
Based Tracks

Multitrack clip groups can include both sample-
based and tick-based tracks. However, changing 
the tempo separates the clip group between sam-
ple-based tracks and tick-based tracks.

Editing Clip Groups
Clip groups are edited in much the same way as 
regular clips: They can be named, moved, cut, 
copied, pasted, trimmed, muted, locked, and so 
on. However, there are a few significant differ-
ences between editing regular clips and clip 
groups. 

Editing MIDI Clip Groups
If a MIDI clip within a clip group is modified in 
any way, a new clip copy is created and placed 
over the clip group. For example, if you record, 
draw in a new note, edit MIDI controller data, or 
quantize a Timeline selection, a new clip is cre-
ated over the clip group.

A multitrack clip group separated across sample-
based and tick-based tracks after changing tempo



Editing Audio Clip Groups
Certain audio editing commands create new 
clips over clip groups. To use these commands 
and maintain the clip group, ungroup the clip 
group, perform the edit, and then regroup the 
clip group.

The following edit commands create new clips 
over clip groups:

• AudioSuite processing of a grouped clip re-
sults in a new clip over the clip group.

• Consolidating a selection of a grouped clip 
creates a new audio file and clip over the clip 
group.

• Recording into a clip group creates a new au-
dio file and clip over the clip group.

• Pencil tool waveform redraw results in a new 
clip over the clip group.

Tabbing to Transients and Clip 
Boundaries
With Tab to Transients enabled, the Tab key 
moves the Location Cursor to transients and clip 
boundaries within a clip group. 

With Tab to Transients disabled, the Tab key 
moves the Location Cursor to clip group bound-
aries only (and the sync point, if present).

For more information, see “Tabbing to 
Transients” on page 580.
Trimming Clip Groups

Trimming clip groups with the Standard Trim 
tool works the same way as trimming regular 
clips, regardless of whether you are trimming a 
single-track clip group or a multitrack clip 
group.

Trimming a clip group does not trim the under-
lying clips, but rather trims the clip group 
boundaries. All underlying clips retain their 
original length and location. This is true for all 
underlying audio and MIDI clips, and nested 
clip groups. If you trim the clip group shorter, 
underlying clips may not be heard on playback 
because they are outside the clip boundaries of 
the trimmed clip group. 

When trimming clip groups with the TC/E Trim 
tool, it applies only to audio or MIDI clips, de-
pending on which clip type in the group you 
trim, and creates a new clip over the clip group.

If you ungroup clips after trimming a clip group 
in (shorter), audio clips falling outside of the 
bounds of the current clip group are trimmed to 
fit the clip group boundary or removed.

Recording
When recording audio or MIDI, new clips are 
created over (in front) of clip groups instead of 
being included in the clip group. To record into 
a clip group, first ungroup the clip group, then 
record, and then regroup the clip group. The clip 
group will be recreated intact with the newly re-
corded material.
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Fades and Crossfades on Clip 
Groups
Clip groups can have fades and crossfades just 
like regular clips. Fades only apply to audio 
clips. In addition to crossfading between clip 
groups, you can also crossfade between clip 
groups and regular audio clips.

Two adjacent multitrack clip groups with crossfades on 
the audio tracks, but not on the MIDI track

Ungrouping a clip group removes any clip 
group level fades or crossfades. Fades and 
crossfades are restored by the Regroup com-
mand.

Clip groups that contain clips with fades are 
not allowed on Elastic Audio-enabled tracks.

When changing tempo with clip groups on 
tick-based tracks, you may need to Ungroup, 
redo or create new fades, and then Regroup 
in order to maintain the fades.

For information on working with fades and 
crossfades in Pro Tools, see Chapter 29, 
“Fades and Crossfades.”
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Clip Groups and Clip Gain
Clip gain settings for individual clips are pre-
served in clip groups. Additionally, you can ad-
just the clip gain settings for clip groups. Clip 
gain editing on clip groups behaves just like in-
dividual clip gain editing (see “Clip Gain” on 
page 602).

To adjust the clip gain settings for individual 
clips within a clip group, the clips must first be 
ungrouped, edited, and then regrouped. 

Clip gain settings are preserved when clip 
groups are exported. Clip groups can then be 
imported into other sessions with the same clip 
gain settings.

Clip group with clip gain settings shown



Importing and Exporting Clip 
Group Files
Pro Tools can export and import clip groups as 
clip group files (.cgrp) to do any of the follow-
ing:

• Separate clip group metadata from audio 
files to avoid unnecessary file copy opera-
tions when exporting audio clip groups 
composed from multiple source files

• Export MIDI data as part of a clip group

• Create multitrack loops

Clip group files store the following metadata:

• References to all audio files within the clip 
group

• Clip names and relative location in tracks

• Embedded fades and crossfades

• Clip gain settings for the clip groups as well 
as for individual clips within the group

• Clip group names and format (single or 
multitrack)

• All MIDI data present in the clip group 
(such as notes, controllers, Sysex, and so 
on)

• Track names

• Elastic Audio Warp markers and TCE factor

• Clip timebase (samples or ticks)

• Sync points

• Loops

• Tempo map

Clip groups created in Pro Tools 10 (.cgrp) 
cannot be imported into lower versions of 
Pro Tools, but region groups (.rgp) created 
in lower versions of Pro Tools can be im-
ported into Pro Tools 10.
Clip group files do not store the following:

• Automation 

• Plug-ins

• Track routing

• Meter map 

• Clip List information

For more information, see “Importing and 
Exporting Clip Group Files” on page 386.
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Part VIII: Processing





Chapter 40: AudioSuite Processing
The following explains the use of AudioSuite 
plug-ins in Pro Tools. AudioSuite plug-ins are 
used to render processing and modify audio files 
on disk. AudioSuite processing applies non-
real-time, or rendered, audio processing to se-
lected audio clips in your Pro Tools session. De-
pending on how you configure an AudioSuite 
plug-in, it will either alter the original source 
audio file or create an entirely new audio source 
file. 

AAX, TDM, and RTAS plug-ins process audio 
playing back on or through a track (the AAX 
plug-in format also supports non-real-time 
AudioSuite processing in addition to real-time, 
track-based plug-in processing). These plug-ins 
are nondestructive and real time. For informa-
tion on using real-time plug-ins (as well as hard-
ware inserts) on tracks, see Chapter 44, “Plug-In 
and Hardware Inserts.”

For information on individual AudioSuite 
plug-ins included with Pro Tools, see the 
Audio Plug-Ins Guide.
AudioSuite Menu
AudioSuite plug-ins are accessed through the 
AudioSuite menu. Plug-ins can be organized in 
the AudioSuite menu in Pro Tools by Flat List 
(with plug-ins in alphabetical order), Category, 
Manufacturer, or Category and Manufacturer. 

To open the AudioSuite Plug-In window:

1  Make an Edit selection that includes the audio 
clip, or clips, you want to process.

2  From the AudioSuite menu, select the plug-in 
you want.

For more information, see “Plug-In Menu 
Organization” on page 995.
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AudioSuite Window
When you select a plug-in from the AudioSuite 
menu, the AudioSuite window appears. From 
this floating window you can access and edit the 
controls for the selected AudioSuite plug-in.

AudioSuite Window Header
The AudioSuite Window header provides con-
trols for changing AudioSuite plug-ins and set-
ting presets, and how AudioSuite processing 
will be applied.

 AudioSuite window, EQ III 1-Band shown

 AudioSuite window header

Plug-In selector
Selection Reference

Use in Playlist button

Librarian menu

File Mode selector

Process Mode selector Compare
Settings Select

Next Setting
Previous Setting

Target button

Plug-in Settings menu
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AudioSuite Plug-In Selector
From this menu you can select any AudioSuite 
plug-in installed in your Plug-Ins folder. Plug-
Ins are listed in the Plug-In selector pop-up 
menu according to the Organize Plug-Ins Menu 
By setting in the Display Preferences page.

Selection Reference
This menu aims the selected process at either 
clips selected in an audio track or playlist, or at 
clips selected in the Clip List.

When you select a clip on-screen (in either a 
track/playlist or the Clip List) Pro Tools nor-
mally selects both occurrences of the clip. Since 
you may not want to process both, this menu 
provides a convenient means of limiting the 
AudioSuite process to clips selected in one or 
the other.

Plug-In menu (flat list, non-category view)

Selection Reference pop-up menu (Invert plug-in 
shown)



Playlist Applies AudioSuite processing to clips 
on the Timeline (playlists on audio tracks). Pro-
cessed clips also appear in the Clip List.

Clip List Applies AudioSuite processing only to 
selected clips in the Clip List. Processing is not 
be applied to clips on the Timeline (playlists on 
audio tracks).

AudioSuite Processing Clip Groups in the Clip 
List

AudioSuite plug-ins process Clip Groups in the 
Clip List with certain limitations. With audio 
files, AudioSuite processes are applied to all 
copies of a unique audio file in your session 
when the Clip List option and the Use in Playlist 
option are selected. However, when a Clip Group 
is selected for Audio Suite processing in the Clip 
List, Pro Tools does not recognize the Clip 
Group as audio. This is because a Clip Group is 
not treated as audio until it is actually used in a 
track. To apply AudioSuite processing to a Clip 
Group in the Clip List, first ungroup the Clip 
Group, and then regroup it after processing.

To apply an AudioSuite process to all copies of a 
Clip Group in a session at once, do the following:

1  Select the Clip Group to be processed.

2  From the Clip List menu, select Ungroup All. 
All elements of the group will remain selected.

3  Perform the AudioSuite processing.

4  From the Clip List menu, select Regroup.

When prompted, choose Modify to apply the 
AudioSuite process to all copies of the Clip 
Group in the session, or Copy to apply it only to 
the selected Clip Group.

If the Use In Playlist option is enabled in 
addition to Clip List being selected in the 
Selection Reference pop-up menu, the pro-
cessing will be applied to the selected clip in 
both the playlist and the Clip List.
Use In Playlist Button
This button determines whether AudioSuite 
processing will replace all instances of the se-
lected clips everywhere in the session, or only 
the occurrences of the clips that are currently 
selected.

Use In Playlist Off When Use in Playlist is dis-
abled, a new, processed version of the selected 
clip will be added to the Clip List. No original 
clips will be replaced or overwritten anywhere 
in the session.

Use In Playlist On, Reference = Clip 
List When Use in Playlist is enabled and the Se-
lection Reference pop-up menu is set to Clip 
List, all copies of the selected clip will be re-
placed everywhere in the session.

Use In Playlist On, Reference = Playlist When 
Use in Playlist is enabled and the Selection Refer-
ence is set to Playlist, only clips selected in tracks 
in the Edit window will be replaced. If the ses-
sion includes other copies of the clip used in 
other playlists, those copies of the original, un-
processed clip will not be replaced.

File Mode Selector
This menu lets you select whether or not the 
AudioSuite plug-in will process the selected au-
dio destructively or nondestructively, and how 
the original files will be modified.

If the Selection Reference pop-up menu is 
set to Clip List, the Use in Playlist button 
will automatically be disabled to ensure 
that you do not accidentally replace every 
occurrence of the clip in a session.

File Mode pop-up menu (Invert plug-in shown)
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There are three options:

Overwrite Files Processes the selected clips de-
structively, overwriting the original audio. Not 
all AudioSuite plug-ins can be used destruc-
tively. 

Create Individual Files Processes the selected 
clips nondestructively, creating a new audio file 
for each clip. The new audio files are added to 
the session, leaving the original source audio 
files in the Clip List unchanged. (Whether the 
processed audio is added to the current playlist 
or only to the Clip List, is determined by the Se-
lection Reference setting.)

Create Continuous File Processes the selected 
clips nondestructively and creates a new audio 
file consisting of the selected clips consolidated 
into a single, unbroken clip. This mode is partic-
ularly useful if you are assembling a composite 
track from multiple takes. This mode is not 
available when the Selection Reference is set to 
Clip List.

Process Mode Selector
If you have made a selection that includes mul-
tiple clips, this pop-up menu lets you specify 
whether AudioSuite processing is performed on 
a clip-by-clip, or entire-selection basis.

The Create Continuous File option is not 
available with some time domain plug-ins. 
To achieve a similar result, use the Dupli-
cate plug-in to consolidate clips processed 
with these plug-ins.

Process Mode selector (Invert plug-in shown)
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Clip by Clip Analyzes each clip in a selection in-
dividually, rather than over the entire multi-clip 
selection as a whole. 

Entire Selection Uses the entire selection for 
analysis. All clips will be analyzed and processed 
relative to the entire selection.

AudioSuite Plug-In Preset 
Controls
Most AudioSuite plug-ins let you load and save 
presets (plug-in settings files). However, some 
AudioSuite plug-ins, such as DC Offset Removal 
or Duplicate, do not provide Preset controls 
since they have no parameter controls.

Plug-In Selector Lets you select any AudioSuite 
plug-in installed on your system.

Plug-In Settings Menu Lets you copy, paste, 
save, and import plug-in presets.

Plug-In Librarian Menu Recalls settings files 
(presets) saved in the plug-in’s root settings 
folder or in the current session’s Settings folder.

 AudioSuite Preset controls

For more information about plug-in presets, 
see “Plug-In Presets” on page 1005.

Librarian menu

Compare
Settings Select

Next Setting
Previous Setting

Plug-In Settings menu



Next (+) and Previous (–) Setting Buttons Lets 
you select the next or previous plug-in setting 
from the Plug-In Librarian menu.

Plug-Ins Settings Select Button Accesses the 
Plug-In Settings dialog, which lists the presets 
for the current plug-in. From this list, you can 
select a new preset, or audition a series of pre-
sets.

Compare Toggles between the original saved 
plug-in preset and any changes you have made 
to it so you can compare them.

Target Button
Pro Tools lets you view multiple AudioSuite 
Plug-in windows at the same time. The Audio-
Suite plug-ins window provides a Target button. 
Untargeted plug-in windows remain open, while 
the targeted plug-in window can switch between 
different AudioSuite plug-ins and receive key-
board input.

To target or untarget AudioSuite plug-in windows:

 Click the Target button in the AudioSuite 
plug-in window so that it is lit (targeted) or unlit 
(untargeted).

Other AudioSuite Controls
In addition to the standard AudioSuite controls 
that are common to all AudioSuite plug-ins, 
there are a number of special-purpose controls 
found only on certain plug-ins:

You will lose the current plug-in settings if 
they are not saved before you use the Next 
and Previous Setting buttons. Always save 
your plug-ins settings as presets using the 
Plug-In Settings menu.
Chan/Track Process Mode Selector

If you have made a selection that includes clips 
from multiple tracks, the Normalize 
AudioSuite plug-in (as well as some third-party 
AudioSuite plug-ins) lets you choose whether 
you want to perform processing on a channel-
by-channel/track-by-track, or an all-chan-
nel/all-tracks basis using the Chan/Track Pro-
cess Mode selector.

Peak On Each Chan/Track Analyzes and pro-
cesses each selected track individually. If you 
apply the Normalize plug-in to multiple tracks 
or a multichannel track in Peak On Each 
Chan/Track mode, each channel or track will be 
normalized independently, without regard to 
the other selected tracks.

Peak On All Chans/Tracks Uses all currently se-
lected channels and tracks for analysis. If you 
apply the Normalize plug-in to a multichannel 
track or multiple tracks in Peak On All 
Chans/Tracks mode, the tracks will be analyzed 
as a single entity and clips will be normalized 
relative to the averaged peak level within all se-
lected channels and tracks.

Find Level Button 

For some gain processing plug-ins, the Find 

Level button can be found next to the Render 
button in the AudioSuite Plug-In Window 
footer. It can analyze a selection without actu-
ally processing it. For example, using the Gain 
plug-in, you can use the Find Level button to de-
termine the maximum peak level on a track at a 
specific gain value before you process the audio.
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Key Input Selector

Selects a track/bus to be used to trigger process-
ing. In order to use this feature, the key input 
source audio must occur at the same time as the 
target audio. Side-chain input is monophonic. 
See “Side-Chain Input” on page 1004.

Channel Mode Button

The Channel Mode button lets you process con-
tiguous channels within a selected clip as 
though they were mono or stereo tracks (and in 
some cases greater-than-stereo tracks), regard-
less of the type of tracks they occupy.

Mono Mode Processes each contiguous channel 
within a selected clip as a separate mono track. 
For example, a clip comprised of six mono 
tracks would be processed as six mono tracks.

Stereo Mode Processes each contiguous pair of 
channels within a selected clip as a stereo track. 
When applied to an odd number of channels, the 
plug-in processes the last odd, unpaired channel 
as mono, using the left channel settings of the 
stereo plug-in. If you want the last track to be 
processed in stereo, you must select an addi-
tional track to pair it with—an empty one if nec-
essary.

For example, a clip comprised of two mono 
tracks would be processed as a stereo track, with 
the first mono track processed as the left chan-
nel and the second mono track processed as the 
right channel.

Multi Mode Processes each set of three or more 
contiguous channels within a selected clip as a 
multichannel greater-than-stereo track, with 
the number of selected channels determining 

Side-chain inputs for plug-ins have no effect 
on AudioSuite processes when the Selection 
Reference is set to Clip List.
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the type of track. For example, five contigu-
ously-selected channels would be processed as a 
5.0 track, while seven contiguously-selected 
channels will be processed as a 7.1 track.

AudioSuite Window Footer
The AudioSuite Window footer provides con-
trols for previewing and applying AudioSuite 
processing.

Preview Button
The Preview button in the AudioSuite window 
lets you audition the effect of a plug-in before 
you process the audio. By adjusting the plug-in 
controls while you listen to this audio preview, 
you can fine-tune the effect. Not all AudioSuite 
plug-ins support previewing. 

The Preview function routes audio to the spe-
cific outputs selected for the Audition Path set-
ting in the Outputs page of the I/O Setup dialog. 
Make sure you have configured this option cor-
rectly for your system or you may not be able to 
hear previewed audio. 

Multi mode is available only for certain 
plug-ins, such as Dynamics III.

 AudioSuite window footer

For more information on using the I/O 
Setup dialog to configure your system’s 
audio outputs, see “Audition Paths” on 
page 93.

Preview button

Bypass button

Render buttonPreview Level meters

Preview volume

Handle Length
Whole File button



Before you previewing AudioSuite processing, 
be aware that: 

 The performance of the Preview function de-
pends on the speed of your CPU. Faster comput-
ers preview AudioSuite effects better than 
slower computers.

 Regardless of how many tracks and clips are 
currently selected, the Preview button will audi-
tion only the first selected stereo track or the 
first selected pair of mono tracks.

 In Mono mode, only the first channel of any 
selected multichannel clip will be previewed.

 If you are processing using Clip-by-Clip mode, 
the Preview function will preview only the first 
clip within a multi-clip selection. To hear all se-
lected clips, temporarily select Create Continu-

ous File from the File Mode menu before 
previewing.

Preview Volume Control
The Preview Volume control in the AudioSuite 
window lets you adjust the volume for preview-
ing AudioSuite processing.

To adjust the volume for previewing AudioSuite 
processing:

1  Click the Preview Volume control.

2  In the resulting pop-up fader, drag up to in-
crease the preview volume or drag down to de-
crease the preview volume.

Adjust the volume for previewing AudioSuite 
processing
Preview Volume Level Meters

The Preview Volume Level meters display the 
levels for previewed AudioSuite processing. 
This can help you watch for clipping in the pro-
cessed signal.

Bypass Button
When Bypass is enabled in the AudioSuite win-
dow, the selected audio is auditioned without 
AudioSuite processing. The Bypass button ap-
plies only to previewing. It does not affect actual 
AudioSuite processing. 

Reverse Button
Pro Tools provides a Reverse button in the 
AudioSuite plug-in window footer for Reverb 
and Delay plug-ins. This lets you easily render 
reverse delay and reverb effects with a single 
click. Clicking the Reverse button provides 
three processes in one: 

• First, it reverses the Edit selection.

• Then, it processes the reversed Edit selec-
tion with the current plug-in settings.

• Finally, it reverses the processed Edit selec-
tion. 

Whole File Button
When the Whole File button is enabled in the 
AudioSuite window, the selected audio is ren-
dered as a new clip whose duration exactly 
matches the selection. However, the clip can be 
trimmed out as far as the whole file. This option 
is not available in Create Continuous File mode 
or when rendering with Entire Selection mode 
combined with Create Individual Files mode.
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Handle Length
The Handle Length field lets you set the Handle 
Length for rendering from 0.00 to 60.00 sec-
onds. This means that you trim clips out past the 
rendered selection after processing up to the set 
Handle Length. For more information, see “Au-
dioSuite Handles” on page 872.

Render Button
Clicking the Render button in the AudioSuite 
window begins AudioSuite processing of the se-
lected audio. Processing can occur during play-
back (though it may take slightly longer). Pro-
cessed files are auto-named with the clip or 
audio file’s name and include an acronym for 
the chosen AudioSuite process. 

New files are written to the hard disk specified 
for that track in the Disk Allocation dialog, or to 
the same drive as the original file if the clip is 
not currently on a track. See “Automatic File 
Naming of AudioSuite-Processed Audio” on 
page 870.

Multichannel Processing

Most AudioSuite plug-ins can process up to 48 
channels of audio simultaneously.

When processing multiple clips of 
different formats (mono and multichannel 
surround, for example), all channels will be 
processed according to the channel format 
of the AudioSuite plug-in. Mono AudioSuite 
plug-ins can process stereo clips and 
stereo AudioSuite plug-ins can process 
mono clips.
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Undoing AudioSuite Processing

If you have processed an audio selection nonde-
structively, the Undo and Redo commands let 
you undo the selected AudioSuite process. You 
can undo or redo an AudioSuite process during 
audio playback. 

Automatic File Naming of AudioSuite-
Processed Audio

When new audio files are created as a result of 
AudioSuite processing, Pro Tools will auto-
name these files according to the type of plug-in 
used. The name of the clip determines the pre-
fix, while the type of AudioSuite plug-in deter-
mines the suffix.

Automatic file naming follows these rules:

 New clips are named beginning with the clip 
name, followed by an abbreviation of the current 
AudioSuite process, followed by standard 
Pro Tools file and clip numbering.

 If a plug-in’s File Mode is set to Overwrite Files, 
the original clip’s name will not be changed. 

 If a plug-in’s File Mode is set to Create Individ-

ual Files, the resulting clips will have an abbrevi-
ated version of the plug-in name appended to 
them.

Undo is not available when a plug-in is 
configured for destructive editing since the 
process has already overwritten the source 
audio file.



Using AudioSuite Plug-Ins
AudioSuite plug-ins can be applied to whole 
clips, partial clips, or selections that are made 
up of whole and partial clips across one or more 
tracks.

When audio selected in the Edit window in-
cludes partial clips, the clips will automatically 
be split into two or more clips when they are 
processed. Processing is applied only to the se-
lection, leaving other clips unchanged.

Only audio files on locally connected hard drives 
can be processed with AudioSuite plug-ins. You 
cannot process audio files on remote hard drives 
over a network (unless it is an Avid Unity net-
work). 

To process audio with an AudioSuite plug-in: 

1  Do one of the following:

• Make an Edit selection of the audio you 
want to process.

– or –

• Select audio clips in the Clip List that you 
want to process.

2  Choose an AudioSuite plug-in from the 
AudioSuite menu. 

3  Adjust the plug-in controls for the effect you 
want. These settings determine how the file is 
processed and what effect the processing has on 
the original clips. 

Processing a locked clip will cause the clip to 
become unlocked, and processing a muted 
clip will cause it to become unmuted.
Follow these guidelines:

• To process the selected clip only in the 
track in which it appears, select Playlist for 
the Selection Reference. Alternatively, if 
you want to process the selected clip in the 
Clip List only, select Clip List.

• If you want to process and update every oc-
currence of the selected clip throughout 
your session, enable the Use In Playlist but-
ton (and also select Clip List as the Selection 
Reference). Alternatively, if you do not 
want to update every occurrence of the se-
lected clip, deselect the Use In Playlist but-
ton.

• To configure the plug-in for destructive 
processing, select Overwrite Files for the 
File Mode. This will overwrite and perma-
nently modify the original source audio 
files. 

• Alternatively, to configure the plug-in for 
nondestructive processing, select Create In-

dividual Files for the File Mode. This will 
create new audio files that have been pro-
cessed with the AudioSuite plug-in settings 
and leave the original source audio files un-
touched.

• If you have selected multiple clips for pro-
cessing and want to create a new file that 
connects and consolidates all of these clips 
together, select Create Continuous File for 
the File Mode.

4  Click the Preview button to audition the 
AudioSuite processing of the selected material. 

5  Make any further adjustments to the plug-in 
controls if necessary.

6  When you are satisfied with the results, click 
the Render button. 
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The selected audio is processed according to the 
specified settings. Pro Tools appends an acro-
nym to the clip name indicating the AudioSuite 
process that has been applied. Any new audio 
files appear in the Clip List.

Selecting Tracks for AudioSuite 
Processing
Because AudioSuite processes are performed on 
the specific clips that you select, it is important 
that you select only those clips, or parts of clips, 
you actually want to process. 

Selecting Tracks for Delay or 
Reverb Processing
Because some AudioSuite effects such as delay 
and reverb add additional material to the end of 
the selected audio, it is important that you make 
a selection that is longer than the original source 
material so that the plug-in can write it to the 
audio file. If you select only the original mate-
rial, without leaving additional space at the end, 
any reverb decay or delay that occurs after the 
end of the clip will be cut off.

When processing a single audio channel with 
an AudioSuite plug-in, make sure that the 
plug-in is set to Mono mode, if available.
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To compensate for this, place the clip in a track 
and select the audio plus an amount of blank 
space at the end of the clip equal to the amount 
of delay or reverb decay that you have added in 
the plug-in. The plug-in will then have space at 
the end of the clip in which to write the final de-
lay or decay. If you select more time than 
needed, you can trim it after applying Audio-
Suite processing.

AudioSuite Handles
Pro Tools lets you render clips with AudioSuite 
plug-ins and include “handles” beyond the cur-
rent edit selection from 0.00 to 60.00 seconds, or 
even the whole file referenced by the clip. This 
means that you trim clips out past the rendered 
selection after processing.

To render a clip with AudioSuite handles:

1  Make the audio selection that you want to ren-
der.

2  Select the AudioSuite plug-in you want to use 
from the AudioSuite menu.

3  Adjust the AudioSuite plug-in options and set-
tings as desired.



4  Do one of the following:

• In the Handle Length field, enter the de-
sired Handle Length (0.00 to 60.00 sec-
onds). The default Handle Length can be set 
in the Preferences dialog.

– or –

• Select the Whole File option to render the 
whole file. Note that only the current edit 
selection will appear in the Timeline.

5  Click Render.

The selection is rendered as a new clip whose 
duration exactly matches the selection. How-
ever, the clip can be trimmed out as far as the 
specified Handle Length.

Handle Length field in the AudioSuite plug-in window

Whole File option selected in the AudioSuite plug-in 
window
AudioSuite Default Handle Length 
Preferences

Pro Tools provides two preferences for setting 
the default AudioSuite Handle Length. 

To set the default AudioSuite Handle Length:

1  Choose Setup > Preferences.

2  Click the Processing tab.

3  In the AudioSuite section, select one of the fol-
lowing options:

• Whole File—by default, renders the whole 
file referenced by the selection.

– or –

• Length—by default, renders the selection 
plus any additional available audio up to 
the specified Handle Length (0.00 to 60.00 
seconds)

4  Click OK.

Default Handle Length in the AudioSuite section of the 
Processing Preferences
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Using AudioSuite Plug-Ins in 
Stereo
Some AudioSuite plug-ins can be used in either 
mono or stereo. If you plan to use them in ste-
reo, consider the following:

 To process a mono track and obtain a stereo 
result, select the track or clip plus an empty 
track or clip. Then set the plug-in to Stereo mode 
and select the Sum Inputs button (if present) to 
center the dry signal. When you process the au-
dio, the result will be two tracks or clips that 
represent the right and left channels of the pro-
cessed audio. You should then pan these tracks 
hard right and hard left in your mix. 

 If you set a plug-in to Stereo mode, then select 
an odd number of Pro Tools tracks for process-
ing (as opposed to an even number), the plug-in 
will process the selected tracks in pairs, in ste-
reo. However, the last odd, unpaired track will 
be processed as mono, using the left channel set-
tings of the stereo plug-in. If you want the last 
track to be processed in stereo, you must select 
an additional track to pair it with—an empty one 
if necessary. 

For more information, see “Channel Mode 
Button” on page 868.
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Conditions for AudioSuite Rendering with Handles, Fades, 
Clip Gain, and Metadata
Most AudioSuite plug-ins provide several options for rendering clips, but only certain settings let you 
apply AudioSuite handles. For example, AudioSuite Handles are not available with Entire Selection 
mode (since the point of this option is to render the whole selection only). Fades and crossfades, and 
clip gain settings are preserved or rendered depending on the File mode and AudioSuite Rendering 
mode settings. Additionally, clip metadata can be preserved for rendered clips under certain condi-
tions. The following conditions apply.

Handle creation, and Fade, Clip Gain, and Metadata pre
servation criteria for AudioSuite rendering
File Mode
Rendering 
Mode

Handle 
Behavior

Whole File Fades Clip Gain Metadata

Overwrite 
File

Clip By 
Clip

No Handles Unavailable Preserved Preserved Preserved

Overwrite 
File

Entire 
Selection

No Handles Unavailable Rendered Rendered Preserved

Individual 
Files

Clip By 
Clip

Handles cre-
ated

Available Preserved Preserved Preserved

Individual 
Files

Entire 
Selection

No Handles Unavailable Rendered Rendered Preserved

Continuous 
File

Clip By 
Clip

Handles cre-
ated at the 
beginning and 
end of the new 
continuous file

Unavailable Rendered Rendered Not preserved

Continuous 
File

Entire 
Selection

Handles cre-
ated at the 
beginning and 
end of the new 
continuous file

Unavailable Rendered Rendered Not preserved
Some plug-ins that rely on the Edit selection for processing (including plug-ins that require an analysis 
pass) may not work as expected when using handles. In this case, it is recommended that the handle 
length be set to zero.
Destructive recording and Destructive Punch recording are not supported with AudioSuite rendered 
clips with handles.
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Chapter 41: Elastic Audio
Elastic Audio provides track-based Real-Time 
and Rendered Time Compression and Expan-
sion (TCE) and clip-based pitch shifting (trans-
position). Pro Tools Elastic Audio uses excep-
tionally high-quality transient detection 
algorithms, beat and tempo analysis, and real-
time TCE and pitch shifting processing algo-
rithms. Elastic Audio lets you quickly and easily 
transpose the pitch of audio clips and tempo 
conform (beat match) audio to the session’s 
Tempo map. It also provides an unprecedented 
degree of control over transient detection and 
TCE processing on an event-by-event basis.

With Elastic Audio, Pro Tools analyzes entire 
audio files for transient events. For example, an 
event can be a drum hit, a sung note, or chord 
played by a guitar. These detected events can 
then serve as control points for warping the au-
dio. Pro Tools can warp (TCE) audio events au-
tomatically, such as automatically conforming 
audio to the session tempo or quantizing audio 
events, or you can warp audio manually using 
standard editing tools in Warp view.

Elastic Audio is useful in several common work-
flows: working with loops, correcting perfor-
mances, remixing, sound design and special ef-
fects, and film scoring. 
Working with Loops

If you work with loops, Elastic Audio lets you 
preview your loops in DigiBase browsers at their 
native tempo (BPM) or at the session tempo 
(BPM). You can even preview the loop while the 
session is playing back. When you find the loop 
you like, drag it from the browser and drop it 
into the session. The loop automatically con-
forms to the session tempo map and Bar|Beat 
grid. You can then further manipulate its timing 
and also transpose the clip to match the pitch of 
other loops in your session.

Correcting Performances

Elastic Audio lets you quantize audio to tighten 
up a performance or even manually re-align that 
one note that was played just a little late. Or, you 
might decide that the performance is excellent, 
but just a little under tempo. Tick-based Elastic 
Audio automatically warps audio to conform to 
tempo changes. When you change your tracks to 
tick-based and increase the session tempo, the 
audio automatically time compresses to match.
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Remixing

Elastic Audio lets you quickly beat match an en-
tire song to the session tempo and Bar|Beat grid. 
You can also transpose clips to match pitch.

Sound Design and Special Effects

Use Elastic Audio to achieve special effects with 
extreme or widely variable TCE or pitch manip-
ulation. Use the Varispeed algorithm to achieve 
tape-like effects for speed and pitch change.

Film Scoring

If you are scoring a film scene, use Elastic Audio 
to fit the music to the required duration. You 
can even use tempo changes to achieve accele-
randos and ritardandos.

Remember, when using tempo adjustments 
for sessions that include multiple cues, 
tempo changes may affect the timecode 
position of other cues later on the Timeline.

Elastic Audio is not recommended for pull-
up and pull-down workflows. Use the 
Session Setup window real time pull-up or 
pull downs, or the presets included with 
Time Shift or X-Form AudioSuite plug-ins.
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Example Elastic Audio 
Workflow
In this workflow, you will be introduced to some 
common Elastic Audio tasks for working with 
loops:

• Create and configure a new session for this 
workflow.

• Locate and preview a loop in DigiBase at 
the session tempo.

• Import the loop at the session tempo on a 
tick-based, Elastic Audio-enabled track.

• Change the session tempo to change the 
tempo of the clip on tick-based, Elastic Au-
dio-enabled tracks.

• Quantize the audio to apply a Groove Tem-
plate to the rhythm.

• Transposition the clip to match the pitch of 
the imported audio to other audio and 
MIDI in the session.

Create and configure a new session

1  Create a new Pro Tools session.

2  Set the session’s Main Timebase ruler to 
Bars|Beats. 

3  Be sure to display the Tempo and Meter rulers. 

4  Use the default tempo of quarter-note equals 
120 BPM.



Locate and preview a loop in DigiBase at the 
session tempo:

1  Open the Workspace (Window > Workspace).

2  Navigate to the folder where you keep your 
drum loops. Double-click the folder name to 
open a volume browser of just the folder’s con-
tents.

3  Select the loop you want to preview.

4  Click the Preview button to preview the loop at 
its native tempo.

5  Click the Audio Files Conform to Session 
Tempo button so that it highlights. 

6  Click the Preview button again and the file 
previews at the session tempo.

Audition Paths for previewing are selected 
in the I/O Setup window (Choose Setup > I/O 
and click the Output tab).

Preview and Audio Files Conform to Session Tempo 
buttons in a DigiBase browser

Audio Files Conform
to Session Tempo buttonPreview button
7  Notice that if the loop was sample-based to be-
gin with, the column to the left of the file name 
initially indicates that DigiBase is analyzing the 
file. When the analysis is done a check mark ap-
pears in that column, the file’s Duration is now 
measured in Bars and Beats instead of Minutes 
and Seconds, the Sample-based icon is replaced 
by the Tick-based icon, and the detected tempo 
of the file is displayed in the Tempo column.

8  Repeat the preceding steps to preview other 
loops at the session tempo.

Import the loop at the session tempo:

1  Make sure that the Audio Files Conform to 
Session Tempo button is still highlighted. This 
ensures that the file will be imported as a tick-
based, Elastic Audio clip and can be conformed 
to the session tempo.

Elastic Audio controls and indicators in DigiBase

Sample-based
file iconElastic Audio

Analysis icon Duration
Detected

tempo

Tick-based
file icon
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2  Drag and drop the loop from the browser to the 
Track List in the session’s Edit window (see 
Figure  below).

3  One of the following occurs:

• If there are no tracks in the session and the 
file is tick-based, you are prompted to ei-
ther import the tempo from the file or use 
the session tempo. To keep the session 
tempo and have the loop conform to the 
session tempo, click Don’t Import. 

– or –

• If there are tracks in the session, the file is 
imported and automatically conformed to 
the session tempo.

If All Files is selected as the Drag and Drop 
From Desktop Conforms to Session Tempo 
option in the Processing Preferences page, 
you can also drag and drop audio files from 
the Desktop and they are imported as tick-
based Elastic Audio.
Pro Tools Reference Guide
4  A new tick-based audio track is created with 
the Default Elastic Audio plug-in enabled.

5  Since you chose to not import the file’s original 
tempo, you will notice that the loop conforms to 
the tempo map and Bar|Beat grid of the session. 
A Warp indicator appears in both the clip in the 
track and in the Clip List (see Figure  on 
page 881). 

Also in the Clip List, notice that there are two 
clips. One is the sample-based whole file clip 
(the imported source file) and the other is the 
tick-based Elastic Audio–processed copy.

You can also conform clips on Elastic 
Audio-enabled tracks to the session tempo 
using the Conform to Tempo command (see 
“Conform to Tempo” on page 780).
Dragging and dropping a tick-based audio file from a DigiBase browser to the Track List

New tick-based, 
Elastic Audio–enabled
track



Imported tick-based audio file with Elastic Audio processing

Warp indicators

Sample-based whole-file Tick-based Elastic Audio–processed 
clipclip
Change the session tempo to change the tempo of 
the clip:

1  Change the tempo from the default 120 BPM to 
110 BPM (see “Tempo” on page 775).

2  Notice that since the clip is on a tick-based, 
Real-Time Elastic Audio-enabled track it auto-
matically conforms to the new tempo.

Changing the default tempo
Quantize audio to apply a Groove Template:

1  Select the clip on the tick-based, Real-Time 
Elastic Audio-enabled track.

2  Choose Event > Event Operations > Quantize.

3  In the What to Quantize section, make sure 
Elastic Audio Events option is selected.

4  From the Quantize Grid pop-up menu, select a 
Groove Template.

5  Set any other options.

6  Click Apply.

7  In the following figure, notice that the audio 
has been quantized according to the selected 
Groove Template. In Warp view, you can see that 
Warp markers have been added at every Event 
marker near the Quantize Grid and were used to 
apply quantization to those events (see Figure  
on page 882).
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Quantized audio events (Warp markers) in Warp view
Transpose the audio clip down a whole-tone:

1  Select the clip on the Elastic Audio-enabled 
track.

2  Choose Event > Event Operations > Transpose.

3  Select the Transpose By option.

4  Enter “–2” semitones.

5  Click Apply.



Elastic Audio Tracks
Any audio track in your Pro Tools session can be 
Elastic Audio enabled. Elastic Audio tracks can 
be either sample- or tick-based. Sample-based 
Elastic Audio-enabled tracks let you apply real-
time or rendered Elastic Audio processing by 
editing in Warp view, applying Quantize, and 
using the TCE Trim tool. However, only tick-
based Elastic Audio tracks also automatically 
apply Elastic Audio processing based on tempo 
changes in the session.

To have all new tracks be tick-based, enable 
the New Tracks Default To Tick Timebase 
option in the Editing preferences. 

When creating new tracks by dragging and 
dropping audio from a DigiBase browser, if 
the Audio Files Conform to Session Tempo 
option is enabled, Pro Tools creates tick-
based Elastic Audio-enabled tracks regard-
less of whether the Elastic Audio analyzed 
file is tick-based or sample-based. If the Au-
dio Files Conform to Session Tempo option 
is not enabled, Pro Tools creates regular 
sample-based tracks.

With Pro Tools HD, Elastic Audio is disal-
lowed on voiced tracks. Use dynamic voice 
allocation for tracks on which you want to 
use Elastic Audio. (Pro Tools only supports 
dynamic voice allocation, and cannot spe-
cifically allocate individual voices.)
Enabling Elastic Audio 
Tracks
To enable Elastic Audio on a track:

1  Create a new audio track or choose an existing 
audio track.

2  Click the track’s Elastic Audio Plug-In selector, 
and select the Elastic Audio plug-in appropriate 
to your track material and the results you want 
from the pop-up menu: Polyphonic, Rhythmic, 
Monophonic, Varispeed, or X-Form (see “Elastic 
Audio Plug-Ins” on page 888). 

Any audio clips on the track temporarily go of-
fline while they are analyzed and come back on-
line when the analysis is finished. The waveform 
for audio clips that are offline for Elastic Audio 
analysis appears grayed out.

When recording to a real-time Elastic Audio-en-
abled track, once recording is stopped, the 
newly recorded audio temporarily goes offline 
while it is analyzed and comes back online as 
soon as the analysis is finished.

Elastic Audio Plug-In pop-up menu
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3  From the track’s Elastic Audio Plug-In pop-up 
menu, select Real-Time Processing or Rendered 

Processing for Real-Time or Rendered Elastic 
Audio processing. 

Creating New Tracks with 
Elastic Audio Enabled
New tracks are created with Elastic Audio auto-
matically enabled in the following cases:

• When the Enable Elastic Audio On New 

Tracks option is enabled in the Processing 
Preferences page (see “Elastic Audio Op-
tions” on page 344).

• When dragging and dropping tick-based, 
Elastic Audio analyzed files from DigiBase 
browsers to the Track List or empty space in 
the Edit window with the Audio Files Con-

form to Session Tempo option enabled (see 
“Elastic Audio on Import” on page 337).

• When dragging and dropping REX or ACID 
files from the Desktop (if either REX and 

ACID Files Only or the All Files option is en-
abled for the Drag and Drop from Desktop 

Conforms to Session Tempo setting in the 
Processing Preferences page) or a DigiBase 
browser (if the Audio Files Conform to Ses-
sion Tempo button is enabled) to the Track 
List or empty space in the Edit window (see 
“Importing ACID and REX Files” on 
page 341).

Elastic Audio processing can be Real-Time 
or Rendered. Real-Time Elastic Audio pro-
cessing is immediate, but it is more demand-
ing of system resources. Rendered Elastic 
Audio processing is non-real-time, but is 
less demanding of system resources. If you 
are working on a system with limited re-
sources, use Rendered Elastic Audio process-
ing. For more information, see “Real-Time 
and Rendered Elastic Audio Processing” on 
page 887.
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Disabling Elastic Audio 
Tracks
To disable Elastic Audio on a track:

1  From the track’s Elastic Audio Plug-In selector, 
select None – Disable Elastic Audio.

2  If the track had any Elastic Audio-based pro-
cessing, you are prompted to Cancel, Revert, or 
Commit.

Cancel Leaves Elastic Audio enabled on the 
track.

Revert Removes any Elastic Audio processing, 
reverts clips on the track to their original dura-
tion, and disables Elastic Audio on the track.

Commit Renders and commits any Elastic Audio 
processing on the track, writes new files to disk, 
and disables Elastic Audio on the track.

Committed Clips
Clips that are committed, either by disabling 
Elastic Audio on a track or by moving a clip to a 
track without Elastic Audio enabled, are written 
to disk as new audio files. These new audio files 
include the audio in the clip, plus any fades, and 
also an additional 5 seconds of audio before and 
after the clip, if available. 

Disabling Elastic Audio and 
Alternate Playlists
Disabling Elastic Audio on a track affects all 
playlists on the track. All playlists on the track 
are committed or reverted depending on which 
option you choose.



Elastic Audio Track Controls
Audio tracks provide controls for enabling Elas-
tic Audio, selecting the Elastic Audio plug-in, 
and selecting whether Real-Time or Rendered 
Elastic Audio processing. 

Elastic Audio Plug-In Selector Selects the Elastic 
Audio plug-in for Elastic Audio processing (see 
“Elastic Audio Plug-Ins” on page 888). You can 
also use the Elastic Audio Plug-In selector to 
disable Elastic Audio processing, and to select 
either Real-Time or Rendered processing (see 
“Real-Time and Rendered Elastic Audio Pro-
cessing” on page 887).

Elastic Audio Plug-In Button Displays the name 
of the selected Elastic Audio plug-in. Click the 
Elastic Audio Plug-In button to open the Elastic 
Audio Plug-In window (see “Elastic Audio Plug-
Ins” on page 888).

Real-Time or Rendered Processing 
Indicator Lights when Elastic Audio processing 
is real-time and dims when Elastic Audio pro-
cessing is rendered (see “Real-Time and Ren-
dered Elastic Audio Processing” on page 887).

Elastic Audio Track controls

Elastic Audio
Plug-In selector

Elastic Audio
Plug-In button

Real-Time or 
Rendered
Processing
indicator
Elastic Audio Track Views
There are two special Track Views for Elastic 
Audio-enabled tracks: Warp and Analysis.

Warp View
Warp view lets you manually “time warp” (Elas-
tic Audio process) audio. In Warp view you can 
create and edit Warp markers. If you are using 
Elastic Audio to correct the timing of a perfor-
mance, or to achieve special effects, work in 
Warp view (see “Editing in Warp View” on 
page 893).

Analysis View
Analysis view lets you edit detected Event mark-
ers. In most cases you will not need to use Anal-
ysis view. However, with material that does not 
have clear transients, you may want to work in 
Analysis view to add or relocate Event markers, 
or to delete erroneous Event markers. For exam-
ple, when using Elastic Audio to correct the tim-
ing of a performance, you may need to add, 
move, or remove Event markers in Analysis view 
to achieve the highest quality Elastic Audio pro-
cessing (see “Editing in Analysis View” on 
page 899). 

Track View pop-up menu
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Elastic Audio Analysis
When recording, pasting, moving, or importing 
un-analyzed audio to an Elastic Audio-enabled 
track, or when enabling Elastic Audio on an ex-
isting audio track, Pro Tools automatically ana-
lyzes the audio for transient events. In Wave-
form view, the waveform initially appears 
grayed out because clips go offline during Elas-
tic Audio analysis. Once the analysis is com-
plete, the audio comes back online. Elastic Au-
dio analysis is file-based, which means that even 
if you are only working with a small clip of a 
large file, the entire audio file is analyzed.

Elastic Audio analysis detects transient events in 
the audio file. These transient events are indi-
cated by Event markers. Event markers are dis-
played in both the Warp and Analysis track 
views. Elastic Audio analysis also calculates the 
native tempo of the analyzed audio file and its 
duration in bars and beats.

Elastic Audio analysis data (detected events, 
tempo, and duration in Bars|Beats) is stored 
with the file. In DigiBase browsers, analyzed au-
dio files are indicated by a check mark to the left 
of the file name, and these files display their du-
ration in Bars|Beats, their timebase as ticks, and 
their native tempo in BPM.

Tempo Detection
Elastic Audio analysis does its best to detect a 
regular tempo for all analyzed audio. Any audio 
containing regular periodic rhythm can be suc-
cessfully analyzed for tempo and duration in 
bars and beats. Analyzed files in which a tempo 
was detected are treated as tick-based files. 
Tick-based files can be conformed to the session 
tempo for preview and import.
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Analyzed files in which no tempo was detected 
are treated as sample-based files. If there is only 
a single transient in the file (such as with a sin-
gle snare hit), no tempo will be detected. Also, 
longer files that contain tempo changes or ru-
bato, or that do not contain regular periodic 
rhythmic patterns will probably not have a de-
tected tempo and will be treated as sample-
based files.

Event Confidence
Transient events are detected with a certain de-
gree of confidence. The level of confidence is 
based on the relative clarity of transients.

For example, a drum loop is likely to have clear, 
sharp transients. These will be detected with a 
high degree of confidence. However, a legato vi-
olin melody may not have clear, sharp tran-
sients, so transients will be detected with a 
lower degree of confidence. 

Note that peak amplitude is not the most im-
portant measure for event confidence. The 
clarity of transients is measured in part by 
the spectral transition from one moment to 
the next. This tends to favor higher fre-
quency content in terms of event confidence. 
For example, changing the Event Sensitivity 
in the Elastic Properties window for a se-
lected drum loop results in the clearer tran-
sients of the higher frequency hi-hat hits 
having more event confidence than the less 
well defined transients of the lower fre-
quency kick drum hits even though kick 
drum hits have a higher peak amplitude.



Pro Tools is very aggressive with its transient 
detection in order to detect every possible audio 
event. Consequently, it is possible to have erro-
neously detected events. These events will be an-
alyzed with a low degree of confidence and can 
be filtered out by lowering the Event Sensitivity 
in the Elastic Properties window (see “Event 
Sensitivity Property” on page 903). Filtering out 
any false transients can result in higher quality 
Elastic Audio processing. 

Conversely, for material with few clear tran-
sients, Elastic Audio analysis may not accurately 
detect audio events, and those detected may be 
detected with a low level of confidence. You can 
relocate or add Event markers where necessary 
in Analysis view (see “Editing in Analysis View” 
on page 899). 

For example, a slow synth pad may not have 
clear transients and detected Event markers may 
be incorrectly located or may have not been de-
tected at all. In Analysis view, you can relocate, 
remove, and add Event markers as necessary 
(such as where the chord changes). Accurately 
locating Event markers yields better results 
when applying Elastic Audio processing.

When processing non-rhythmic audio (such 
as legato strings) with the Polyphonic plug-
in, reducing the number of Event markers 
often yields better sounding results. You can 
either manually remove Event markers in 
Analysis view (see “Editing in Analysis 
View” on page 899) or lower the Event Sen-
sitivity setting in the Elastic Properties win-
dow for the clip you want to process (see 
“Elastic Properties Window” on page 902).
Real-Time and Rendered 
Elastic Audio Processing
Real-Time Elastic Audio processing means that 
any changes to Elastic Audio processing—
whether it be a tempo change or a manual TCE 
warp, or pitch shifting—take effect immedi-
ately. However, Real-Time Elastic Audio pro-
cessing can be very demanding on your system’s 
resources. Consequently, you may want to use 
Rendered Elastic Audio processing in some 
cases. With Rendered Elastic Audio processing, 
when you make a change to Elastic Audio pro-
cessing, any affected audio clips temporarily go 
offline, a new “rendered” audio file is generated, 
and any affected audio clips come back online.

To set an Elastic Audio track to Real-Time or 
Rendered:

1  Click the track’s Elastic Audio Plug-In selector.

2  From the pop-up menu, select an Elastic Audio 
plug-in.

3  From the pop-up menu, select one of the 
following:

• Real-Time Processing 

– or –

• Rendered Processing 

In rendered mode, any change you make is 
rendered using the original source audio to 
avoid generational loss from multiple subse-
quent edits.

Select Real-Time processing for tick-based 
Elastic Audio processing (such as tempo 
changes). Rendered audio processing can be 
useful for sample-based Elastic Audio 
processing or if you need to save system 
resources.
Chapter 41: Elastic Audio 887



888
About Rendered Files
Pro Tools creates temporary files for Rendered 
Elastic Audio processing. These files are kept in 
an auto-created Rendered Files folder in the ses-
sion folder. Once you commit Rendered Elastic 
Audio processing to a track, a new file is written 
to disk in the Audio Files folder, and the tempo-
rary rendered file from which it was created is 
deleted from the Rendered Files folder.

Clipping Indicator
(Rendered Processing Only)

Since Rendered Elastic Audio processing is not 
real-time, it does not report clipping due to 
Elastic Audio processing in the Elastic Audio 
plug-in window. Instead, when clipping occurs 
due to Rendered Elastic Audio processing, the 
clip displays an Elastic Audio Processing Clip-
ping indicator just to the left of the Warp indi-
cator. 

To avoid clipping on playback, lower the Input 
Gain for the clip in the Elastic Properties win-
dow (see “Elastic Properties Window” on 
page 902).

Elastic Audio Plug-In selector and pop-up menu

To toggle between Real-Time and Rendered 
Elastic Audio processing, Control-Start-click 
(Windows) or Command-Control-click 
(Mac) the Elastic Audio Plug-In button.
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Elastic Audio Plug-Ins
Pro Tools provides several algorithms for real-
time and rendered track-based Elastic Audio 
processing. The selected Elastic Audio plug-in 
determines how the audio is processed. Each 
plug-in uses different algorithms for Elastic Au-
dio processing. Different algorithms are better 
suited to different types of audio. Select the 
plug-in whose algorithm is appropriate to the 
material on the track you want to process.

Elastic Audio plug-ins have their own selector 
that is only available in the Edit window. You 
cannot insert Elastic Audio plug-ins on track in-
serts. 

Elastic Audio plug-ins provide few to no adjust-
able parameters. The adjustable controls, if any, 
are available in the Elastic Audio Plug-In win-
dow. Elastic Audio plug-in parameters cannot 
be automated.

To open an Elastic Audio Plug-In window:

 Click the Elastic Audio Plug-In button.

Elastic Audio Clipping indicator

Elastic Audio plug-in button

Elastic Audio
Clipping indicators

Warp 
indicators



Elastic Audio Plug-In Window 
Controls
The Elastic Audio Plug-In window provides a set 
of controls in the window header that are com-
mon to all Elastic Audio plug-ins.

Track Selector Lets you access any other audio 
track in the session.

Plug-In Selector Lets you select any Elastic Au-
dio plug-in or disable Elastic Audio.

Plug-In Settings Menu Lets you copy, paste, 
save, and import plug-in presets.

Plug-In Librarian Menu Recalls Elastic Audio 
plug-in settings files (presets) saved in the plug-
in’s root settings folder or in the current ses-
sion’s Settings folder.

Elastic Audio plug-in controls

Librarian menu

Track selector Settings menu
Target 
button

Clip 
LED

Plug-In selector

Next Setting button

Compare button
Plug-In Settings Select button

Previous Setting button
Next (+) and Previous (–) Setting Buttons Lets 
you select the next or previous preset from the 
Plug-In Librarian menu.

Plug-Ins Settings Select Button Accesses the 
Plug-In Settings dialog, which lists the presets 
for the current plug-in. From this list, you can 
select a new preset, or audition a series of pre-
sets.

Compare Toggles between the original saved 
plug-in settings and any changes you have made 
to it so you can compare them.

Clip LED Lights red to indicate clipping in the 
Elastic Audio processing. Clipping can occur 
when time compressing audio. If clipping oc-
curs, you can lower the Input Gain in the Elastic 
Properties window (“Input Gain Property” on 
page 904), or attenuate the Default Input Gain 
in the Processing Preferences page (see “Elastic 
Audio Options” on page 344). 

You can undo any Elastic Audio processing and 
apply an appropriate amount of AudioSuite 
Gain reduction, and then try the Elastic Audio 
processing again. The Clip LED only functions 
for Real-Time Elastic Audio processing; it does 
not function for Rendered Elastic Audio pro-
cessing. For Real-Time Elastic Audio plug-ins, 
the Elastic Audio plug-in button on the audio 
track also turns red to indicate clipping.

You will lose the current plug-in settings if 
they are not saved before you use the Next 
and Previous Setting buttons. Always save 
your plug-in settings as presets using the 
Plug-In Settings menu.

For Rendered Elastic Audio processing, clip-
ping is indicated by the appearance of the 
Elastic Audio Processing Clip indicator on 
the clip (see “Clipping Indicator” on 
page 888).
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Target Button When multiple Elastic Audio 
Plug-In windows are open, clicking this button 
selects that plug-in as the target for any com-
puter keyboard commands. Deselecting the Tar-
get button lets you open another targeted Elastic 
Audio Plug-In window.

Polyphonic Plug-In
The Polyphonic plug-in is a general, all-purpose 
algorithm that is effective with a wide range of 
material. For complex loops and multi-instru-
ment mixes, use the Polyphonic plug-in. The 
Polyphonic plug-in supports clip-based pitch 
shifting.

Follow

Selecting the Follow option enables an envelope 
follower that simulates the original acoustics of 
the audio being stretched. Click the Follow but-
ton to enable or disable envelope following.

The Polyphonic plug-in is the default plug-
in for previewing and importing from Di-
giBase browsers or the Clip List.

Elastic Audio plug-in: Polyphonic
Pro Tools Reference Guide
Window

The Polyphonic plug-in provides a single con-
trol for adjusting the analysis window size for 
TCE processing. Experiment with adjusting the 
Window size for different types of material until 
you achieve the best results. The following table 
provides some recommended Window sizes for 
different types of material.

Rhythmic Plug-In
The Rhythmic plug-in is best suited to material 
with clear attack transients, such as drums. The 
Rhythmic plug-in supports clip-based pitch 
shifting.

If you frequently work with distinct types of 
material, you may want to find the best 
Window settings for each type of material 
and save them as plug-in settings for quick 
and easy recall.

Type of Material
Recommended 
Window Size

General purpose 30–40 ms

Percussive 20 ms or lower

Pads and other legato 
material

60 ms or higher

Elastic Audio plug-in: Rhythmic



Decay Rate

The Decay Rate control determines how much of 
the decay from a transient is heard in the pro-
cessed audio when time stretching. When the 
Rhythmic plug-in is selected, any gaps between 
transients resulting from time stretching are 
filled in with audio. The Decay Rate determines 
how much of this audio is heard by applying a 
fade out rate. Adjust the Decay Rate up to 100% 
to hear the audio that is filling the gaps created 
by the time stretching with only a slight fade, or 
adjust down to 1.0% to completely fade out be-
tween the original transients.

Monophonic Plug-In
The Monophonic plug-in is best suited to mono-
phonic material where you want to keep the for-
mant relationships intact, such as with vocals. 
The Monophonic plug-in is also well suited to 
monophonic instrumental lines, such as a bass 
track. The Monophonic plug-in provides no 
plug-in specific parameters.

Elastic Audio plug-in: Monophonic

Elastic Audio pitch shifting is not supported 
with the Monophonic algorithm.
Varispeed Plug-In
Use the Varispeed plug-in to link time and pitch 
changes for tape-like speed change effects, and 
post production workflows. The Varispeed plug-
in provides no plug-in specific controls.

The Monophonic plug-in analyzes pitch as 
well as peak transients in order to provide 
higher quality TCE to pitched material. 
Consequently, analysis for the Monophonic 
algorithm takes longer than for the Poly-
phonic, Rhythmic, and Varispeed algo-
rithms. Also, when switching from another 
Elastic Audio plug-in to Monophonic, 
Pro Tools reanalyzes any audio on the track 
to collect the extra analysis data.

Elastic Audio plug-in: Varispeed

Try using Varispeed with Quantize on drum 
loops for some interesting effects.
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X-Form Plug-In
(Rendered Only)

The X-Form Elastic Audio plug-in is a modified 
version of the standalone X-Form AudioSuite 
processing plug-in (based on the Radius® algo-
rithm from iZotope). The X-Form Elastic Audio 
plug-in is for Rendered Elastic Audio processing 
only and cannot process in real-time or as an 
AudioSuite plug-in. It provides the highest qual-
ity time compression algorithms for music pro-
duction, sound design, and audio loop applica-
tions. Use it to manipulate audio loops for 
tempo matching or to change vocal tracks for 
formant correct pitch shifting.

Quality

Select either Maximum or Low (Faster) from the 
Quality pop-up menu. Maximum is the slowest 
processing algorithm, but provides the highest 
quality results. Low (Faster) produces relatively 
good results and is much faster than the Maxi-

mum setting.

Elastic Audio plug-in: X-Form
Pro Tools Reference Guide
Formant

For audio material with clear formants, enable 
Formant to preserve the formant shape of audio 
when applying TCE processing.

Audio with a fundamental pitch has an 
overtone series, or set of higher harmonics. 
The strength of these higher harmonics cre-
ates a formant shape, which is apparent if 
viewed using a spectrum analyzer. The over-
tone series, or harmonics, have the same 
spacing related to the pitch and have the 
same general shape regardless of what the 
fundamental pitch is. It is this formant 
shape that gives the audio its overall charac-
teristic sound or timbre. When pitch shifting 
audio, the formant shape is shifted with the 
rest of the material, which can result in an 
unnatural sound. Keeping this shape con-
stant is critical to formant correct pitch 
shifting and achieving a natural sounding 
result.



Editing in Warp View
In Warp view, you can manually “time warp” 
(TCE) audio to correct or adjust the timing of a 
performance, or create special effects. In Warp 
view, you can add, move, and delete Warp mark-
ers. Warp markers are used to fix a specific 
point in the audio (typically a detected transient 
event) to a specific point in the Timeline. In this 
way, you can apply detailed and nuanced “warp-
ing” (TCE) of audio events.

To display Warp view:

1  Click the Elastic Audio-enabled track’s Track 
View selector.

2  Select Warp from the Track View pop-up menu.

Elastic Audio Markers in Warp 
View
Three types of markers are visible in Warp view: 
Event markers, Warp markers, and Tempo 
Event–generated Warp markers. Use Event 
markers and Warp markers as control points for 
applying Elastic Audio processing. 

Warp view is only available for Elastic 
Audio-enabled tracks.

Elastic Audio markers in Warp view

Warp marker
Event marker

Tempo Event
Warp markers
Event Markers
Event markers indicate detected (or manually 
created) audio events. Event markers are only 
displayed in Warp view and Analysis view. In 
Warp view, Event markers appear as gray verti-
cal lines that do not fully extend to the top and 
bottom of the track. With the Grabber tool in 
Warp view, you can drag Event markers to apply 
various kinds of warping depending on whether 
or not Warp markers are present in the clip as 
well. In Warp view, you cannot add, relocate, or 
delete Event markers. Use Analysis view to edit 
Event markers (see “Editing in Analysis View” 
on page 899).

Warp Markers
Warp markers anchor the audio to a specific 
point in the Timeline. Warp markers are only 
displayed in Warp view. In Warp view, a Warp 
marker appears as a thick black vertical line 
with a triangle at its base.

To better understand how Warp markers work, 
think of the audio clip as a rubber band, the 
Timeline as a ruler, and Warp markers as pins. 
Warp markers can be used to pin a specific point 
of the rubber band (the audio) to a specific point 
on the ruler (the Timeline). If you pin down one 
point of the rubber band to one point on the 
ruler, use a second pin to pin down another 
point of the rubber band to another point on the 
ruler, and then place a third pin equally between 
them on the rubber band, but fix it to a point on 
the ruler closer to the second pin, the rubber 
band will be stretched (or expanded) between 
the first and middle pins, and relaxed (or com-
pressed) between the middle pin and the last 
pin. 

The display of Event markers is dependent 
on Horizontal Zoom. If you are zoomed out 
too far, Event markers are not displayed. 
To see Event markers, zoom in.
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In Warp view, you can add, relocate (without 
warping), and delete Warp markers. You can 
also move a Warp marker to apply Elastic Audio 
processing (see “Warping Audio” on page 895).

To add a Warp marker:

 In Warp view, do one of the following:

• With the Pencil tool, click anywhere in the 
clip to add a Warp marker at that location. 
If you click on an Event marker, a Warp 
marker is created on top of the Event 
marker.

• With the Grabber tool, Start-click (Win-
dows) or Control-click (Mac) anywhere in 
the clip to add a Warp marker at that loca-
tion. If you click on an Event marker, a 
Warp marker is created on top of the Event 
marker.

• With the Grabber tool, if no Warp markers 
are present in the clip, or if Warp markers 
are only present prior to the location where 
you want to add a new Warp marker, dou-
ble-click an Event marker to add a Warp 
marker on top of the Event marker.

• With the Grabber tool, double-click any-
where in the clip where an Event marker is 
not present to add a Warp marker at that lo-
cation.

• With the Grabber tool, single-click any 
Event marker prior to another existing 
Warp marker in the clip to add a Warp 
marker on top of that Event marker.

• With any Edit tool, Right-click anywhere in 
the clip and select Add Warp Marker from 
the pop-up menu to add a Warp marker at 
that location. If there is an Edit selection, 
Warp markers are added at the selection 
start and end.
Pro Tools Reference Guide
To relocate a Warp marker (without applying 
warping):

 With the Grabber or the Pencil tool, Start-drag 
(Windows) or Control-drag (Mac) a Warp 
marker to a new location.

To delete a Warp marker:

 In Warp view, do one of the following:

• With the Grabber tool, double-click a Warp 
marker.

• With the Grabber or the Pencil tool, Alt-
click (Windows) or Option-click (Mac) a 
Warp marker.

• With any Edit tool, Right-click a Warp 
marker and select Remove Warp Marker 
from the pop-up menu.

To delete all Warp markers in a selection:

1  In Warp view, make an Edit selection that in-
cludes only the Warp markers you want to delete 
(and none of the Warp markers you want to 
keep).

2  Do one of the following:

• Press Delete or Backspace on your com-
puter keyboard.

– or –

• With any Edit tool, Right-click the Edit se-
lection and select Remove Warp Marker 
from the pop-up menu.

Tempo Event–Generated Warp 
Markers
Tempo Event–generated Warp markers are not 
editable and are only displayed to indicate 
where Elastic Audio processing has been applied 
to conform the audio to Tempo Events. You will 
only see Tempo Event–generated Warp markers 
on tick-based tracks.



If you change the track timebase from ticks to 
samples, any Tempo Event–generated Warp 
markers convert to regular, editable Warp 
markers.

Warping Audio
In Warp view, you can manually warp audio in 
three specific ways: Telescoping Warp, Accor-
dion Warp, and Range Warp. 

Telescoping Warp
Telescoping Warp can be applied to any audio 
clip before or after a Warp marker as long as no 
other Warp marker precedes or follows it ac-
cordingly. The audio can be on a sample- or tick-
based track. Telescoping Warp is especially use-
ful for adjusting audio files to match the session 
tempo map and Bar|Beat grid. 

For more information, see “Tempo Changes 
and Tick-Based Elastic Audio Tracks” on 
page 779.

Automation does not follow manual warp-
ing of audio clips, including TCE trimming 
and quantization of Elastic Audio. How-
ever, automation does follow tempo changes 
on tick-based tracks.
To apply Telescoping Warp to a clip:

 In Warp view, do one of the following:

• With the Grabber tool, drag any Event 
marker that is after the last Warp marker in 
the clip to the left or right to Telescope-
Warp the audio that is after the Warp 
marker in or out. If no Warp marker is pres-
ent in the clip, one is created automatically 
at the clip start. The clip start remains an-
chored to its location on the Timeline.

– or –

• With the Grabber tool, Alt-drag (Windows) 
or Option-drag (Mac) any Event marker 
that is before the first Warp marker in the 
clip to the left or right to Telescope-Warp 
the audio that is before the Warp marker in 
or out. If no Warp marker is present in the 
clip, one is created automatically at the clip 
end. The clip end remains anchored to its 
location on the Timeline.

Before and after warping, applying Telescoping Warp 
with the clip start fixed
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Workflow Example

Beat match a song to the session tempo and 
Bar|Beat grid using Telescoping Warp:

1  Make sure the Main Timebase ruler is set to 
Bars|Beats.

2  Set the default tempo and meter.

3  Select Grid mode.

4  Import a song, or any other longer audio file 
from a DigiBase browser.

5  Make sure that Elastic Audio is enabled on the 
track. 

6  Select Warp view.

7  Make sure there are no Warp markers present 
on the clip. If necessary, delete any existing 
Warp markers.

8  With the Pencil tool, add a Warp marker at the 
bar 1 downbeat location within the clip.

9  With the Grabber tool, drag the single Warp 
marker to the bar in the Timeline where you 
want the downbeat of the audio file to start.

10  Drag the Event marker on the downbeat of 
bar 2 of the clip to Telescope warp the audio such 
that the Event marker matches the correspond-
ing bar number in the Bars|Beats ruler.

11  If the clip’s tempo varies, add a Warp marker 
to the next downbeat location at the tempo 
change and repeat the preceding steps.

Accordion Warp
Accordion Warp applies Elastic Audio process-
ing on both sides of a singe Warp marker in a 
clip. This lets you expand or compress the audio 
equally on both sides of a fixed point. Accordion 
warp is useful for audio files where the down-
beat occurs in the middle of the clip.
Pro Tools Reference Guide
To apply Accordion Warp to a clip:

1  In Warp view, add a single Warp marker at the 
point in the clip that you want to remain fixed on 
the Timeline.

2  With the Grabber tool, drag any Event marker 
that is before or after the single Warp marker to 
the left or the right.

Range Warp
Range Warp applies Elastic Audio processing 
between two fixed points in a clip. To apply 
Range Warp, there must be at least two Warp 
markers present in the clip.

To apply Range Warp within a clip:

1  In Warp view, add a Warp marker at the first 
point that you want to fix to the Timeline.

2  Add another Warp marker to the end point 
that you want to fix to the Timeline.

Before and after warping, applying Accordion Warp to 
a clip around a fixed point



3  With the Grabber tool, drag an Event marker 
between the two Warp markers to the left or 
right. A Warp marker is added on top of the 
Event marker and the audio is compressed or ex-
panded on either side of the dragged marker 
while the audio outside the bounding markers 
remains unaffected.

Range Warp with an Edit 
Selection
Pro Tools lets you apply Range Warp between 
bounding Warp markers, but keeps the timing 
intact between other Warp markers within an 
Edit selection.

To apply Range Warp with an Edit Selection:

1  In Warp view, add a Warp marker at the first 
point that you want to fix to the Timeline.

2  Add another Warp marker to the end point 
that you want to fix to the Timeline.

3  Add any number of Warp markers in between.

4  With the Selector tool, make an Edit selection 
that includes the Warp markers in between the 
bounding Warp markers.

Before and after warping, applying Range Warp 
between two Warp markers in a clip
5  With the Grabber tool, drag any of the Warp 
markers within the Edit Selection to the left or 
the right. 

Elastic Audio processing is only applied to the 
audio between the bounding Warp markers and 
the first and last Warp markers in the Edit Selec-
tion. All audio between the first and last Warp 
markers in the Edit Selection maintain their rel-
ative timing.

Individual Range Warp
Individual Range Warp applies warping to a sin-
gle audio event in relation to the adjacent audio 
events.

To apply Individual Range Warp:

1  In Warp view, with the Grabber tool, Shift-
click a Warp marker or an Event marker. If not 
already present, Warp markers are automatically 
created on the adjacent Event markers.

2  Drag to the left or right to warp the clicked 
event.

Before and after warping, applying Range Warp to a 
selection between bounding Warp markers
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Warped Clips
Clips that have been warped either manually or 
automatically by tempo change, quantization, or 
pitch shifting display a Warp indicator in the 
upper right-hand corner of the clip. This indica-
tor is visible in any track view. Since unwarped 
clips can reside on Elastic Audio-enabled tracks, 
clips on Elastic Audio-enabled tracks do not 
necessarily display the Warp indicator. The 
Warp indicator only indicates that Elastic Audio 
processing has been applied to a clip.

Displaying the Warp Indicator
The Warp indicator for Elastic Audio clips can 
displayed or hidden.

Before and after warping, applying Individual Range 
Warp 

Warp indicator in a clip in Waveform view
Pro Tools Reference Guide
To toggle the display of the Warp indicator in 
Elastic Audio clips:

 Select or deselect View > Clip > Processing 

State.

Out of Range Processing
Pro Tools lets you apply extreme amounts of 
Elastic Audio processing. However, at such ex-
tremes, it is possible to go out of the selected 
Elastic Audio plug-in’s processing range. When 
this happens, it is possible that not every sample 
will be processed correctly and you may encoun-
ter audio drop outs.

The valid range for Elastic Audio TCE process-
ing is 1/4x to 4x for all Elastic Audio plug-ins ex-
cept X-Form, which supports 1/8x to 8x. TCE 
less than or greater than these ranges is effec-
tively “out of range.”

When out of range processing occurs, the sec-
tion of the audio clip that is out of range turns 
red. You can still apply Elastic Audio process-
ing, but you are warned by the color change that 
the TCE factor is out of the normal range of Elas-
tic Audio processing.

TCE Factor is out of range (in red)

The TCE Factor in the Elastic Properties 
window supports extreme ranges from 
1–9999%. However anything outside of 
25–400% will be “out-of-range” and will be 
displayed in red.



Removing Clip Warping
If you have applied any warping to a clip, you 
can remove warping and revert the clip to its 
original duration. This can be useful if you are 
not satisfied with the results and want to revert 
to the pre-warped clip. Warp markers are not 
deleted when applying the Remove Warp com-
mand, but any warping is undone.

To remove clip warping:

1  Select the clip for which you want to remove 
warping.

2  Do one of the following:

• Choose Clip > Remove Warp.

– or –

• With any Edit tool, Right-click the clip and 
select Remove Warp from the pop-up menu.

Edit Groups and Warp Editing
Elastic Audio-enabled tracks can be included in 
Edit Groups. For Elastic Audio-enabled tracks 
that are part of an Edit Group, applying Elastic 
Audio processing on one track likewise applies 
it to all other tracks within that Edit Group. 

If corresponding Warp markers are not already 
present on Elastic Audio-enabled tracks that are 
part of an Edit Group, new Warp markers are 
created on those tracks when you add or move a 
Warp marker on any track that is part of the Edit 
Group.

Remove Warp can only be applied to clips 
and cannot be applied to clip groups. To un-
warp clip groups you must first ungroup the 
clip, then apply Remove Warp to the under-
lying clips, and then regroup those clips.
Editing in Analysis View
In Analysis view, you can add, move, promote, 
and delete Event markers. Usually, Pro Tools ac-
curately detects all the transient events (Event 
markers) in an audio file and you will not need 
to work in Analysis view. However, Pro Tools 
may not accurately detect every audio event or 
may erroneously detect audio events with some 
types of audio material. This is especially true 
for audio without clear transients, such as legato 
strings, melismatic vocals, or soft synth pads. 

Use Analysis view to manually correct the pres-
ence and location of Event markers. The accu-
rate identification of audio events yields the 
best results when applying Elastic Audio pro-
cessing.

To display Analysis view:

1  Click the Elastic Audio-enabled track’s Track 
View selector.

2  Select Analysis from the Track View pop-up 
menu.

Analysis view is only available for Elastic 
Audio-enabled tracks.

In Analysis view, you can only edit Analysis 
markers using the Edit tools. You cannot 
use the Edit tools for any clip editing. 
Switch to Warp or Waveform views for 
clip-based editing capabilities with the Edit 
tools.

When manually editing Analysis markers, 
Pro Tools writes temporary Elastic Audio 
analysis files (.aan) to the session’s 
Rendered Files folder. Any unused tempo-
rary analysis files are purged when you 
close the session.
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Adding Event Markers

To add an Event marker:

 In Analysis view, do one of the following:

• With the Pencil tool, click at the location 
where you want to add an Event marker.

• With the Grabber tool, double-click at the 
location where you want to add an Event 
marker.

• With the Grabber tool, Start-click (Win-
dows) or Control-click (Mac) at the loca-
tion where you want to add an Event 
marker.

• With any Edit tool, Right-click at the loca-
tion where you want to add an Event marker 
and select Add Event Marker from the pop-
up menu.

Moving Event Markers

To move an Event marker:

 In Analysis view, do one of the following:

• With the Pencil tool, drag the Event marker 
to a new location.

– or –

• With the Grabber tool, drag the Event 
marker to a new location.

Adding an Event marker with the Pencil tool

Moving an Event marker
Pro Tools Reference Guide
Promoting Event Markers
Event markers are detected with relative degrees 
of confidence (between 1% and 100%). You can 
filter out extraneous Event markers by adjusting 
the Event Sensitivity setting in the Elastic Prop-
erties window; event markers with the least con-
fidence are filtered out first. However, some sig-
nificant events may not be recognized with a 
high degree of confidence. In this case, you may 
want to promote the Event marker to ensure that 
it is not filtered out when reducing the Event 
Sensitivity setting. Promoted Event markers, 
like manually created or moved Event markers, 
have 100% confidence.

To promote an Event marker:

 In Analysis view, with the Grabber or Pencil 
tool (or with the Smart Tool in the bottom half of 
the track), single-click the Event marker you 
want to promote. 

Promoted Event markers look the same as 
detected Event Markers. To see all Event 
markers that have 100% confidence, reduce 
the Event Sensitivity setting in the Elastic 
Properties window (see “Event Sensitivity 
Property” on page 903).



Deleting Event Markers

To delete an Event marker:

 In Analysis view, do one of the following:

• With the Pencil tool, Alt-click (Windows) 
or Option-click (Mac) the Event marker you 
want to delete.

• With the Grabber tool, Alt-click (Windows) 
or Option-click (Mac) the Event marker you 
want to delete.

• With the Selector tool, make an Edit selec-
tion that includes any Event markers you 
want to delete and press Delete or Back-
space on your computer keyboard.

• With the Selector tool, make an Edit selec-
tion that includes any Event markers you 
want to delete, Right-click the selection, 
and choose Remove Event Marker from the 
pop-up menu.

Edit Groups and Event Editing
Elastic Audio-enabled tracks can be included in 
Edit Groups. For Elastic Audio-enabled tracks 
that are part of an Edit Group, editing Event 
markers on one track likewise applies to all 
other tracks within that Edit Group.

Deleting an Event marker with the Pencil tool
Elastic Properties
Each clip on an Elastic Audio-enabled track has 
specific Elastic Audio properties (such as 
tempo, meter, TCE factor, Input Gain, and Pitch 
Shift). 

The Elastic Properties window lets you view and 
change the properties for selected clips. For ex-
ample, you can reduce the Input Gain for Elastic 
Audio processing to avoid clipping that can oc-
cur during processing.

From the Elastic Properties window, you can 
also filter Event markers for Elastic Audio clips 
on tick-based tracks. Filtering Event markers 
can result in better quality Elastic Audio pro-
cessing of material with ambiguous transients.

To view the Elastic Properties for a clip:

1  Select a clip on an Elastic Audio-enabled track. 
The track can be either sample- or tick-based.

2  Do one of the following:

• Choose Clip > Elastic Properties. 

– or –

• Right-click the clip and choose Elastic Prop-

erties.

Press Alt+5 (Windows) or Option+5 (Mac) 
on the numeric keypad to open the Elastic 
Properties window.
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Elastic Properties Window
The Elastic Properties window displays infor-
mation about Elastic Audio processing and anal-
ysis for one or more clips. You can also use the 
Elastic Properties window to adjust Elastic Au-
dio processing and analysis data.

There are different Elastic Properties available 
in the Elastic Properties window, depending on 
whether the track is tick-based or sample-based. 
If the track is sample-based, a reduced set of 
Elastic Audio Properties are displayed.

Elastic Properties, tick-based

Elastic Properties, sample-based
Pro Tools Reference Guide
Clip Property
The Clip property in the Elastic Properties win-
dow displays the name of the clip and indicates 
whether or not the clip is on a tick or sample-
based track. If more than one clip is selected, the 
number of selected clips is displayed. If clips on 
both tick and sample-based tracks are selected, 
only the reduced set of properties are displayed.

Source Length Property (Tick-
Based Tracks Only)
The Source Length property in the Elastic Prop-
erties window displays the length of the clip 
based on the source file in bars and beats. If the 
length of the source file was analyzed incor-
rectly, you can change it. 

To change the Source Length of a clip:

1  Open the Elastic Properties window for the 
clip.

2  Do one of the following:

• Type the correct bar, beat, and tick values 
in the Source Length field.

• If the duration was incorrectly analyzed as 
being half the duration of the source file, 
click the x2 button.

• If the duration was incorrectly analyzed as 
being twice the duration of the source file, 
click the 1/2 button.

Changing the duration of a clip on an Elas-
tic Audio-enabled track using the TCE Trim 
tool updates the Source Length in the Elastic 
Properties window.



Source Tempo Property (Tick-
Based Tracks Only)
The Source Tempo property in the Elastic Prop-
erties window displays the average tempo of the 
source file, which is calculated based on the de-
tected transient events and the length of the file. 
If the tempo of the source file was analyzed in-
correctly, you can change it.

To change Source Tempo of a clip:

1  Open the Elastic Properties window for the 
clip.

2  Select the correct note value for the beat from 
the Tempo Resolution pop-up menu. For exam-
ple, if the source file is in 5/8, select 1/8 note.

3  Do one of the following:

• Type the tempo in the Source Tempo field.

• If the tempo was incorrectly analyzed as be-
ing half the tempo of the source file, click 
the x2 button.

• If the tempo was incorrectly analyzed as be-
ing twice the tempo of the source file, click 
the 1/2 button.

Meter Field (Tick-Based Only)
Elastic Audio analysis does not calculate meter 
and assumes all files are in 4/4. If you work with 
meters other than 4/4, use the Meter property to 
correctly identify the source meter.

To change Meter of a clip:

1  Open the Elastic Properties window for the 
clip.

2  Click in the Meter nominator field and type the 
correct number of beats per measure. For exam-
ple, if the clip is in 3/4, type 3.

3  Click the Meter denominator field and type the 
correct note value. For example, if the meter is in 
6/8, type 8.
TCE Factor Property
The TCE Factor property in the Elastic Proper-
ties window displays the percentage of change 
applied to the source file. On tick-based tracks, 
this property is display only and cannot be ed-
ited. On sample-based tracks, you can change 
the TCE Factor to apply TCE to the clip. The per-
centage of the TCE factor is always calculated in 
relation to the source file. The TCE Factor value 
turns red when Elastic Audio processes exceeds 
the valid range (see “Out of Range Processing” 
on page 898).

Event Sensitivity Property
The Event Sensitivity property in the Elastic 
Properties window lets you filter Event markers 
based on the analysis confidence level. The con-
fidence level for any detected transient event is 
based, in part, on the clarity of the transient. For 
example, if the file is a drum loop, loud accented 
hits will be analyzed with a higher degree of con-
fidence than a soft, unaccented hit. 

The Event Sensitivity acts like a threshold for 
showing only the transient events that were de-
tected with a high degree of confidence. In Warp 
or Analysis track views you will see the number 
of Event markers decrease or increase as you 
lower or raise the Event Sensitivity. 

Lowering the event sensitivity can help reduce 
the number of erroneously detected transients. 
In turn, this can result in better sounding Elastic 
Audio processing. Pro Tools preserves the de-
tected transients when applying TCE in order to 
avoid flamming and granulation of the tran-
sients. Consequently, false transients are also 
preserved and the resulting sound quality can be 
less than desirable. If you are working with au-
dio material that does not have clearly defined 
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transients, you may want to lower the Event 
Sensitivity in the Elastic Properties, or you may 
want to even edit the Event markers in Analysis 
view.

If lowering the Event Sensitivity results in filter-
ing out important Event markers, you can pro-
mote those Event markers in Analysis view (see 
“Promoting Event Markers” on page 900).

Reset Button
Click the Reset button in the Elastic Properties 
window to reset event analysis data for the clip 
to match the original file. The Event Sensitivity 
property is reset to 100%.

Input Gain Property
It is possible to encounter clipping when time 
compressing audio. Real-Time Elastic Audio 
plug-ins provide a Clip indicator to let you know 
when clipping has occurred and the Elastic Au-
dio plug-in button turns red. Rendered Elastic 
Audio clips display a Clip indicator on the clip 
when clipping has occurred (see “Clipping Indi-
cator” on page 888).

For REX files, Pro Tools converts the slices 
as Events with 100% confidence. Conse-
quently, setting the Event Sensitivity from 
99% to 1% does not filter out any events 
based on slices. However, if you set the 
Event Sensitivity to 0%, all markers are 
filtered out regardless.

When you change the Event Sensitivity 
property, Pro Tools writes temporary fil-
tered Elastic Audio analysis files (.aan) to 
the session’s Rendered Files folder. Any 
unused temporary filtered analysis files are 
purged when you close the session.
Pro Tools Reference Guide
If you encounter clipping when processing Elas-
tic Audio, use the Input Gain property in the 
Elastic Properties window to attenuate the gain 
of the audio signal before it is processed.

Pitch Shift Property(Polyphonic, 
Rhythmic, and X-Form Only)
The Pitch Shift property in the Elastic Proper-
ties window lets you pitch shift whole clips on 
Elastic Audio-enabled tracks using the Poly-
phonic, Rhythmic, and X-Form plug-ins. You 
apply real-time or rendered pitch shifting in 
semitones and cents by +/– 2 octaves.

Elastic Audio Clip-Based 
Pitch Shifting
(Polyphonic, Rhythmic, and X-Form Only)

In addition to Pro Tools Elastic Audio time 
compression and expansion capabilities, you 
can also change the pitch of whole audio clips in 
semitones and cents in the range of +/– 2 oc-
taves. 

To pitch shift a clip:

1  Make sure the clip, or clips, you want to pitch 
shift are on Elastic Audio-enabled tracks (using 
the Polyphonic, Rhythmic, or X-Form algo-
rithm).

Elastic Audio pitch transposition is not sup-
ported with the Monophonic algorithm. 
However, if you switch to the Monophonic 
plug-in after pitch shifting with another 
plug-in, the pitch metadata for the clip is 
maintained.

Elastic Audio pitch transposition cannot be 
applied to looped clips or clip groups.



2  With the Grabber or Selector tool, select the 
audio clip you want to pitch shift. Only clips that 
are completely selected will be affected.

3  Open the Elastic Properties window for the 
clip.

4  Adjust the Pitch Shift settings up (“+”) or down 
(“–”) by an amount in semitones and cents.

To transpose the pitch of an audio clip in the 
Transpose window:

1  Make sure the clip, or clips, you want to Trans-
pose are on Elastic Audio-enabled tracks (using 
the Polyphonic, Rhythmic, or X-Form algo-
rithm).

2  With the Grabber or Selector tool, select the 
audio clip you want to transpose. Only clips that 
are completely selected will be affected.

3  Choose Event > Event Operations > Transpose.

Elastic Properties window
4  Do one of the following:

• Adjust the Transpose By settings by an 
amount in semitones and cents.

– or –

• Adjust the Transpose From and To settings 
by an amount in Semitones and Cents.

5  Click Apply.

Event Operations, Transpose

The Transpose All Notes To and the Trans-
pose In Key settings can only be applied to 
MIDI notes. When only audio clips are se-
lected, these options are unavailable.
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Varispeed and Pitch Shifting
When using the Varispeed algorithm, pitch 
transposition and time compression/expansion 
are always linked. If you apply pitch transposi-
tion to an audio clip using the Polyphonic or 
Rhythmic algorithms, that transposition data is 
stored in the metadata for the clip. Conse-
quently, if you then switch to Varispeed, change 
the TCE factor, and then switch back to the orig-
inal Elastic Audio algorithm, the clip will revert 
to the original amount of pitch shifting while 
maintaining the amount of time compres-
sion/expansion applied by the Varispeed algo-
rithm.

Removing Clip Pitch Shifting
If you have applied any pitch shifting to a clip, 
you can remove pitch shifting and revert the clip 
to its original pitch. This can be useful if you are 
not satisfied with the results and want to revert 
to the pre–pitch shifted clip.

To remove clip pitch shifting:

1  Select the clip for which you want to remove 
warping.

2  Do one of the following:

• Choose Clip > Remove Pitch Shift.

– or –

• With any Edit tool, Right-click the clip and 
select Remove Pitch Shift.

Remove Pitch Shift can only be applied to 
clips and cannot be applied to clip groups. 
To remove pitch shifting from clip groups 
you must first ungroup the clip, then apply 
Remove Pitch Shift to the underlying clips, 
and then regroup those clips.
Pro Tools Reference Guide
AudioSuite Processing and 
Elastic Audio Clips
Real-Time Elastic Audio processing is non-de-
structive. However, since AudioSuite plug-ins 
process the entire clip and write a new audio file 
(or actually apply destructive processing), when 
applying AudioSuite processing to clips on Elas-
tic Audio-enabled tracks, any Elastic Audio pro-
cessing is rendered first, the rendered file is 
then processed by AudioSuite, and the resulting 
new audio file is analyzed for Elastic Audio pro-
cessing. 



Moving Elastic Audio Between Tracks
Pro Tools analyzes, conforms, and commits audio in different ways when moving audio clips between 
tracks with Elastic Audio enabled and tracks without Elastic Audio enabled. The following table 
shows the different results for moving clips between real-time Elastic Audio-enabled tracks, Ren-
dered Elastic Audio-enabled tracks, and audio tracks without Elastic Audio.
Moving Elastic Audio between tracks
From To Result

Real-time Elastic 
Audio–enabled track

Rendered Elastic 
Audio–enabled track

Render clip with destination track’s Elastic Audio plug-in

Real-time Elastic 
Audio–enabled track

Audio track 
(no Elastic Audio)

Render clip with source track’s Elastic Audio plug-in and 
commit the clip to the destination track

Rendered Elastic 
Audio–enabled track

Real-time Elastic 
Audio–enabled track

Apply real-time Elastic Audio processing using the des-
tination track’s Elastic Audio plug-in

Rendered Elastic 
Audio–enabled track

Audio track 
(no Elastic Audio)

Commit to track

Audio track 
(no Elastic Audio)

Real-time Elastic 
Audio–enabled track

Calculate Elastic Audio analysis and apply real-time 
Elastic Audio processing using the destination track’s 
Elastic Audio plug-in

Audio track 
(no Elastic Audio)

Rendered Elastic 
Audio–enabled track

Calculate Elastic Audio analysis and render the clip 
using the destination track’s Elastic Audio plug-in

Pitched Elastic 
Audio–enabled track

Audio track 
(no Elastic Audio)

Render clip pitch shift with source track’s Elastic Audio 
plug-in and commit the clip to the destination track

Clips that are committed, either by disabling Elastic Audio on a track or by moving a clip to a track 
without Elastic Audio enabled, are written to disk as new audio files (see “Committed Clips” on 
page 884.)
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Approximate Waveforms
With Real-Time Elastic Audio processing, the 
drawing of waveforms is only approximate. For 
example, if you bus record a Real-Time Elastic 
Audio processed track, you will notice that the 
Waveform on the source track does not neces-
sarily exactly match the recorded track. How-
ever, be assured that what you hear is an accu-
rate rendition of the Real-Time Elastic Audio 
processing even if the waveform drawing on the 
source track is only approximate.

Elastic Audio Preferences
The Elastic Audio settings in the Processing 
Preferences page determine which Elastic Audio 
plug-in is used for preview and import, and 
whether or not new tracks are created with Elas-
tic Audio enabled using the selected default 
plug-in.

Default Plug-In Lets you select any Real-Time 
Elastic Audio plug-in as the default plug-in for 
previewing and importing Elastic Audio. The se-
lected default Elastic Audio plug-in is also used 
when new tracks are created with Elastic Audio 
enabled. The Elastic Audio Plug-In selector in 
DigiBase browsers inherits the selected Default 
Plug-In setting. Likewise, changing the selected 
plug-in in DigiBase browsers updates the se-
lected Default Plug-In setting in the Processing 
Preferences page.

Elastic Audio preferences
Pro Tools Reference Guide
Default Input Gain Lets you attenuate the signal 
input to Elastic Audio plug-ins by 0 to –6 dB for 
preview and import. If you experience clipping 
due to Elastic Audio processing during preview 
or after import, you may want to set the Default 
Input Gain to slightly attenuate the audio signal 
input for Elastic Audio processing. This prefer-
ence also applies to any audio imported to an 
Elastic Audio-enabled track.

If you commit any clips on a track (by disabling 
Elastic Audio on the track) that were imported 
with Input Gain, their clip-based In put Gain is 
reset to 0.

The Elastic Properties window inherits the De-
fault Input Gain preference. To apply further 
clip-based Input Gain for Elastic Audio process-
ing, select the clip and adjust the Input Gain set-
ting in the Elastic Properties window (see “Elas-
tic Properties Window” on page 902).

Enable Elastic Audio on New Tracks When se-
lected, new tracks are created with Elastic Audio 
enabled. The selected default Elastic Audio 
plug-in is used.

If the Enable Elastic Audio on New Tracks 
option is selected, you may want to also 
select the New Tracks Default to Tick Time-
base option in the Editing Preferences page.



Chapter 42: Event Operations
Various events in Pro Tools (such as groups of 
MIDI Notes, audio clip start times or sync 
points, and whole clips) can be transformed 
with Event Operations.

Event Operations Window
The Event Operations window provides com-
mands to transform groups of MIDI notes to af-
fect pitch, timing, and phrasing. The Quantize 
and Restore Performance Event Operations can 
also be applied to audio clip start times (or sync 
points) and Elastic Audio events. The Transpose 
Event Operation can also be applied to whole 
clips on Elastic Audio-enabled tracks.

The Event Operations window has nine pages, 
one for each Event Operations command.

• Quantize

• Restore Performance

• Flatten Performance

• Change Velocity

• Change Duration

• Transpose

• Select/Split Notes

• Input Quantize

• Step Input
The Event Operations window can be left open, 
This provides quick access to apply a command 
or try out different options for a particular com-
mand.

To open a specific Event Operations window page:

 Choose Event > Event Operations, followed by 
one of the Event Operations (such as Quantize).

You can also apply quantize, duration, 
delay, and transpose to MIDI nondestruc-
tively using MIDI Real-Time Properties. See 
“MIDI Real-Time Properties” on page 709.

Event Operations window (Quantize page shown)
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To open the last active Event Operations window 
page:

 Choose Event > Event Operations > Event Oper-

ations.

To apply an Event Operations command, do one of 
the following:

 Click Apply or press Enter on the numeric key-
pad. This applies the command and leaves the 
window in the foreground.

– or –

 Press Enter on the alphanumeric keyboard 
(Windows) or Return (Mac). This applies the 
command and closes the window.

To undo a command in the Event Operations 
window:

 Choose Edit > Undo.

To open the Event Operations window, press 
Option+3 (Mac) or Alt+3 (Windows).

If the Event Operations window is already 
open, you can select any of the pages from 
the pop-up menu at the top of the window.

When using the Event Operations window 
and MIDI Real-Time Properties at the same 
time, Event Operations are applied to the 
actual MIDI data. MIDI Real-Time 
Properties continue to applied on top of the 
actual MIDI data.
Pro Tools Reference Guide
Using the Event Operations 
Window
Use the following methods to configure options 
in the Event Operations window:

 To move forward and back through the various 
fields, press Tab or Shift+Tab.

 Increment or decrement selected fields with 
the Up and Down Arrow keys. Press and hold 
these keys to scroll quickly through the values.

 Drag up or down in a selected field to scroll to 
a new value.

 Press Control (Windows) or Command (Mac) 
while adjusting sliders for finer resolution.

 For selected pitch and velocity fields, play a 
note on your MIDI controller keyboard to auto-
matically enter it.

 Changing a value for a particular control (such 
as the Swing Percentage in the Quantize win-
dow), automatically enables the control. 

Quantize Command
The Quantize command in the Event Operations 
window can be applied to MIDI notes, audio 
clips, and Elastic Audio events. For MIDI, quan-
tization adjusts MIDI note locations and dura-
tions so that timing is improved, or so that a 
particular rhythmic “feel” is achieved. For audio 
clips, quantization adjusts the start times (or 
sync points) of audio clips. For Elastic Audio, 
quantization adjusts to the location of detected 
transient events and applies Elastic Audio pro-
cessing accordingly.



The Quantize Event Operations window lets you 
apply Grid Quantize based on rhythmic values 
(such as 1/16 note) or using Groove Quantize 
based on Groove Templates. Slightly different 
options are provided for Grid Quantize and 
Groove Quantize.

The Quantize Event Operation and Quantize to 

Grid commands can both be used to quantize 
clips. However, each command also has a spe-
cific additional use.

Use the Quantize to Grid command (Clip > Quan-

tize to Grid) to adjust the start points (or sync 
points) for selected clips. The Quantize to Grid 
command can be applied to both MIDI and au-
dio clips (see “Quantizing Clips to Grid” on 
page 601).

The Quantize Event Operation, on the other 
hand, can be applied to MIDI notes and Elastic 
Audio events individually in addition to audio 
clip start times (or sync points). Some notes or 
events may be moved back in time, others for-
ward. For MIDI notes only, some may be short-
ened, some lengthened, and some more drasti-
cally affected than others.

You can also quantize MIDI input, see “In-
put Quantize Command” on page 933.

The settings in the Quantize window are 
saved with each session. To store your favor-
ite settings for use in future sessions, save 
them as part of a session template (see “Ses-
sion Templates” on page 174). 
To open the Quantize window:

 Choose Event > Event Operations > Quantize. 

To select Grid Quantize:

 From the Quantize Grid pop-up menu, select a 
note value.

To select Groove Quantize:

 From the Quantize Grid pop-up menu, select a 
groove template.

Press Option+0 (Mac) or Alt+0 (Windows) 
to open the Quantize window.

Event Operations window, Quantize
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Grid Quantize
The Quantize window can apply Grid Quantize 
when a specific rhythmic value is selected in the 
Quantize Grid pop-up menu. When a groove 
template is selected in the Quantize pop-up 
menu, Groove Quantize can be applied. For in-
formation on Groove Quantize, see “Groove 
Quantize” on page 916.

What to Quantize
The What to Quantize settings determine what 
aspects of any selected MIDI notes are quan-
tized: Note Ons (attacks), Note Offs (releases), 
or both. You can also select whether to quantize 
audio clips or Elastic Audio events. Depending 
on what type of track material is selected, not all 
options will be available. If only MIDI is se-
lected, the Audio Clips and Elastic Audio Events 
options are unavailable. If only audio is se-
lected, the Note On, Note Off, and Preserve Note 

Duration options are not available.

Note On When selected, MIDI note start points 
are quantized.

Note Off When selected, MIDI note end points 
are quantized.

Preserve Note Duration When selected, MIDI 
note durations are preserved. 

When deselected with the Note On option se-
lected, note end points are not moved. 

When deselected with the Note Off option se-
lected, note start points are not moved.

If the options for both Note On and Note Off are 
selected, the Preserve Note Durations option is 
unavailable.
Pro Tools Reference Guide
The following figure shows how MIDI notes are 
adjusted by the different What To Quantize op-
tions.

Audio Clips When selected in the What to Quan-
tize pop-up menu, Quantize is applied to clip 
start times (or sync points if present) for se-
lected audio clips. MIDI clips are not affected. 
Typically, you will only want to apply quantiza-
tion to sliced audio clips or clip groups (such as 
imported REX files or clips created using the 
Separate Clips at Transients command or Beat 
Detective). Quantization can be applied to 
mixed selections of MIDI notes and audio clips.

Elastic Audio Events When selected in the What 
to Quantize pop-up menu, Quantize is applied to 
detected transient events within the Edit selec-
tion on Elastic Audio-enabled tracks. Quantiza-
tion can be applied to mixed selections of MIDI 

Before quantizing, followed by two examples showing 
the results of different What To Quantize settings



notes and Elastic Audio events. Warp markers 
are created automatically on top of Event mark-
ers nearest the quantize grid. Quantize then uses 
these Warp markers to apply quantization.

Quantize Grid
Quantize Grid Pop-Up Menu Determines the beat 
boundaries to which MIDI notes, Elastic Audio 
events, and audio clip start points are aligned. 
Any size from whole notes (1/1) to sixty-fourth 
notes (1/64), including dotted and triplet val-
ues, can be selected for the Grid size. 

Tuplet Select the Tuplet option to quantize ac-
cording to irregular note groupings, such as 
quintuplets (5 in the time of 4). The Quantize 
Grid for tuplets is calculated from the note size 
selection and the Tuplet value. For example, if 
an sixteenth note equals 240 ticks, quintuplet 
sixteenth notes with 5 in time of 4 would yield a 
Grid size of 192 ticks or (240 ticks/5)*4.

Offset Grid By Offsets the Quantize Grid for-
ward or back in time by a specified number of 
ticks. Use this option to achieve a pushed feel 
(by using positive values) or a laid back feel (by 
using negative values).

Randomize When selected, MIDI notes, Elastic 
Audio events, and audio clips are moved ran-
domly forward or back in time (after the Quan-
tize occurs). For example, with the Quantize 
Grid set to eighth notes and Randomize set to 
50%, notes and events are placed up to a 32nd 
note before or after the beat boundary. The Ran-
domize setting also affects note durations (if Re-
leases is selected).

Relative Grid mode does not affect the 
Quantize Grid.

To Quantize just the backbeats, set the 
Quantize Grid to half-notes with an Offset of 
960 ticks.
Additional Grid Quantize 
Options
Additional Grid Quantize options include:

Swing When selected, every other Grid bound-
ary is shifted by the specified percentage value 
(0–300) to achieve a “swing” feel. A Swing value 
of 0% yields no swing, while 100% yields a trip-
let feel. Settings above 100% progressively nar-
row the swing until the maximum of 300%, at 
which every other Grid boundary is moved to 
the next Grid point.

Include Within When selected, MIDI Note Ons 
and MIDI Note Offs, Elastic Audio events, and 
audio clips are only quantized if located within 
the specified percentage of the Quantize Grid. 
Use this option to clean up downbeats without 
affecting notes that are “swung” or wildly off the 
beat.

The following figure shows the Quantize Grid 
set to quarter notes with the Include Within op-
tion set to 50%. In this example, only the MIDI 
Note Ons and MIDI Note Offs falling within the 
shaded area (equivalent to an eighth note area 
around each beat) are quantized.

100% Swing, eighth note Grid

Include Within option

Every other Grid
point shifted by swing

0% Swing
(480 ticks)

100% Swing
(640 ticks)
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Exclude Within When selected, MIDI Note Ons 
and MIDI Note Offs, Elastic Audio events, and 
audio clips are not quantized if located within 
the specified percentage of the Quantize Grid. 
Use this option to preserve the feel of events 
close to the beat, while correcting others that are 
drastically away from the beat.

The following figure shows the Quantize Grid 
set to quarter notes with the Exclude Within op-
tion set to 25%. In this example, MIDI Note Ons 
and MIDI Note Offs falling within the shaded 
area (equivalent to a sixteenth note area around 
each beat) are not quantized.

Strength When selected, MIDI notes, Elastic Au-
dio events, and audio clips are moved a percent-
age toward the Quantize Grid. Lower percent-
ages preserve the original feel of the events, 
higher percentages align the notes more tightly 
to the Grid.

Exclude Within option
Pro Tools Reference Guide
Grid Quantize Examples
The following examples illustrate some of the 
more common uses for Grid Quantize.

If you intend to loop playback while quantizing, 
you may want to deselect Options > Link Time-
line and Edit Selection. This ensures that the 
play range does not change when selected events 
are moved in the course of quantizing and undo-
ing.

Straight Quantize

To quantize to a straight sixteenth note feel:

1  Select the range of MIDI notes, Elastic Audio 
events, or audio clips to be quantized.

2  Choose Event > Event Operations > Quantize.

3  Under What to Quantize, select the Note On 

option for quantizing MIDI notes. To also quan-
tize MIDI note durations, select the Note Off op-
tion. If you are quantizing audio, select Audio 

Clips or Elastic Audio Events from the pop-up 
menu.

4  From the Quantize Grid pop-up menu, select 
sixteenth notes (1/16). Make sure that the other 
options for Tuplet, Offset Grid By, and Swing are 
not selected.

5  Ensure that the remaining Quantize options 
are deselected.

6  Click Apply.

After quantizing, you can use Restore Per-
formance to revert to the original version 
(see “Restore Performance Command” on 
page 923.)



Quantizing While Preserving the 
Original “Feel”
You can quantize less strictly, to preserve the 
original feel of your recorded MIDI and audio 
tracks.

To quantize while preserving the original feel:

1  Select the range of MIDI notes, Elastic Audio 
events, or audio clips to be quantized.

2  Choose Event > Event Operations > Quantize.

3  Under What to Quantize, select the Note On 
option for quantizing MIDI notes. To also quan-
tize MIDI note durations, select the Note Off op-
tion. If you are quantizing audio, select Audio 

Clips or Elastic Audio Events from the pop-up 
menu.

4  From the Quantize Grid pop-up menu, select 
the note value you want to use. 

5  Ensure that the other options for Tuplet, Offset 
Grid By, and Swing are not selected.

6  Select the Exclude Within option with a value of 
10–15%.

7  Select the Strength option with a value of 
70–80%.

8  Ensure that the remaining Quantize options 
are deselected.

9  Click Apply.

10  Audition the change. If the desired effect is 
not achieved, undo the edit and experiment with 
different values for Exclude Within and Strength.
Quantizing with Swing
If you are working with MIDI hi-hats or bass 
lines or audio equivalents, you may want to ap-
ply more of a swing feel when quantizing.

To quantize with an eighth note swing feel:

1  Select the range of MIDI notes, Elastic Audio 
events, or audio clips to be quantized.

2  Choose Event > Event Operations > Quantize.

3  Under What to Quantize, select the Note On 
option for quantizing MIDI notes. To also quan-
tize MIDI note durations, select the Note Off op-
tion. If you are quantizing audio, select Audio 

Clips or Elastic Audio Events from the pop-up 
menu.

4  From the Quantize Grid pop-up menu, select 
eighth notes (1/8). 

5  Select the Swing option with the Swing per-
centage you want:

• For a light swing, use 12%.

• For a tighter swing-like groove, use 24%.

• For a true “triplet-like” swing feel, use 
50–75%.

6  Ensure that the options for Tuplet, Offset Grid 
By, and Randomize are not selected. 

7  Click Apply.

8  Audition the change. If the desired effect is not 
achieved, undo the edit and experiment with dif-
ferent Swing percentages.
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Quantizing with Randomize
If quantized events sound too mechanical or “on 
the beat,” use the Randomize option in the 
Quantize window to make them sound more nat-
ural.

To “humanize” the rhythmic feel of events:

1  Select the range of MIDI notes, Elastic Audio 
events, or audio clips to be quantized.

2  Choose Event > Event Operations > Quantize.

3  Under What to Quantize, select the Note On 
option for quantizing MIDI notes. To also quan-
tize MIDI note durations, select the Note Off op-
tion. If you are quantizing audio, select Audio 

Clips or Elastic Audio Events from the pop-up 
menu.

4  From the Quantize Grid pop-up menu, select 
the note value you want to use. 

5  Select the Randomize option and enter a value 
of 5%.

6  Click Apply.

7  Audition the change. If the desired effect is not 
achieved, undo the edit and experiment with dif-
ferent Randomize percentages.

Experimenting with Grid 
Quantize
When using the Quantize command, you may 
have to experiment with many of the controls to 
achieve the results you want. Try different val-
ues for Include Within and Exclude Within, and 
Strength; these controls determine which notes 
are affected and how drastically they are 
changed. Additionally, use the Randomize 
option, which adds a percentage of randomness 
to the quantization, to make tracks sound less 
“mechanical.”
Pro Tools Reference Guide
Groove Quantize
In the Quantize window, you can apply Groove 
Quantize when a groove template is selected in 
the Quantize Grid pop-up menu. Groove quan-
tize adjusts MIDI note locations and durations, 
Elastic Audio events, and audio clips according 
to a groove template rather than a strict quanti-
zation grid. Groove templates extract the partic-
ular rhythmic feel of a recorded audio or MIDI 
performance so that is can be applied to another 
MIDI sequence or audio selection. DigiGroove 
templates can be generated using Beat Detec-
tive.

Quantize options with a groove template selected



Groove Templates
Groove templates (such as DigiGroove tem-
plates) are “quantization maps” derived from 
real musical performances. The rhythmic char-
acter of each performance is analyzed and stored 
as a groove template. Groove templates can be 
used to transfer the feel of a particular perfor-
mance to MIDI notes (Timing, Duration, and 
Velocity), Elastic Audio events, and audio clips.

DigiGroove templates can be created using Beat 
Detective. Beat Detective analyzes an audio se-
lection for transient peaks according to a de-
fined threshold and maps the rhythmic relation-
ships to a 960 parts per quarter note (ppq) 
template. Beat Detective can also analyze a MIDI 
selection for Note Ons and velocities to generate 
groove templates. These template can then be 
used with Groove Quantize, as well as with Beat 
Detective.

DigiGroove templates are also available from 
Avid and third-party manufacturers. 

For information on Beat Detective and 
creating groove templates, see Chapter 31, 
“Beat Detective.”

Numerical Sound’s Feel Injector Templates 
(960 ppq) are supported in Pro Tools, but 
DNA Groove Templates (192 ppq) are not.
Groove Quantize Settings
Quantize Grid Pop-Up Menu Determines which 
groove template to use for quantization. All 
groove template files in the Grooves folder are 
available in the Quantize Grid pop-up menu. 

The directory path for the Grooves folder is: 

• On Windows: C:\Program Files\ 
Digidesign\Pro Tools\Grooves

• On Mac: Applications/Digidesign/ 
Pro Tools/Grooves

If you organize your groove templates in sub-
folders in the Groove folder, they appear as sub-
menus in the pop-up menu. Once you have se-
lected a groove template, specific information 
about the template’s meter and duration (in 
bars) is displayed under the pop-up menu.

Show Comments The Comments field displays 
any comments saved with the groove template 
from Beat Detective. The Comments field can-
not be edited in the Quantize page, but can be 
edited when saving a groove template from the 
Groove Quantize page.

Pre-Quantize Enable to hard quantize the se-
lected MIDI notes to a sixteenth-note grid be-
fore applying Groove Quantize. 

Groove Quantize Options

Timing Enable to apply Groove Quantize to the 
selected MIDI notes, Elastic Audio events, or au-
dio clips. Use the slider to change the amount of 
quantization applied to the selection. If the 
slider is set to 0%, there is no change in timing. 
A setting of 100% moves notes to the underlying 
template locations. If the slider is set to 200%, 
events move to a tick location that is twice the 
difference between the original event location 
and the position of the referenced template 
event. 
Chapter 42: Event Operations 917



918
For example, if an event was played at Bar 
1|1|060 (a 16th note), and the corresponding 
template event is at 1|1|073, a slider value of 
100% results in the event being shifted to 
1|1|073 (a slider value of 200% shifts the note to 
1|1|086).

The default value for the Timing slider is 100%.

Duration Enable to influence the durations of 
the selected MIDI notes. The Duration option 
does not apply to audio selections. At a setting 
of 100%, durations are changed to match the 
current groove template. Set to 200%, durations 
increase and decrease based on the ratio of the 
original duration of the selected notes and the 
durations in the template. 

The default value for the Duration slider is 
100%.

Velocity Enable to influence the velocities of the 
selected MIDI notes. The Velocity option does 
not apply to audio selections. If the slider is set 
to 0% there is no change to the selected veloci-
ties, a setting of 100% sets all velocities to match 
the current groove template. A velocity setting 
of 200% typically results in over-exaggerated ve-
locities—loud notes increasing and soft notes 
decreasing in volume. 

For example, if two adjacent notes have equal 
velocities of 80, and the two corresponding tem-
plate velocities are 70 and 90, setting the slider 
to 200% changes the velocities to 60 and 100.

The default value for the Velocity slider is 100%.

Beat Detective does not extract duration in-
formation from audio performances. 
DigiGroove templates created using Beat 
Detective contain a fixed duration value that 
is 50% of the selected template resolution (see 
“Defining a Beat Detective Selection” on 
page 656).
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Recalling Options Slider 
Settings

To Save the groove template with the current 
Options Slider Settings:

1  In the Quantize window, select Recall with 

Template if you want to restore all Groove Quan-
tize Options to the settings that are saved with 
the current template

2  Click the Save button.

3  Enter or edit any comments you want to save 
with the template.

4  Do one of the following:

• Click the Save button to save the groove 
template with the current Options Slider 
Settings.

– or –

• Click the Save As button to make a copy of 
the groove template with the current Op-
tions Slider Settings. In the resulting Save 
dialog, enter a name for the copy and click 
Save.

Slider settings can be lost if any of the following 
operations are performed without saving the 
settings first:

• Another Event Operations window is se-
lected.

• The Event Operations window is closed.

• You switch to another groove template.



Applying Groove Templates
Groove templates can be of any length and can 
be applied to any number of bars. Typically, you 
will apply groove templates to selections of the 
same bar length and meter. However, groove 
templates can be applied to different meters—
for example, a groove template in 6/8 can be ap-
plied to a selection in 4/4. Also, it is not neces-
sary to start on the downbeat when making a se-
lection to apply a groove template.
To apply Groove Quantize:

1  With the Grabber or Selector tool, select the 
MIDI notes, Elastic Audio events, or audio clips 
you want to Groove Quantize.

2  Choose Event > Event Operations > Quantize.

3  Select a groove template from the Grid Quan-
tize pop-up menu.

4  Enable Timing, Duration, and Velocity, and ad-
just their sliders to the percentages you want.

5  If desired, enable Pre-Quantize.

6  Click the Apply button. 
A DigiGroove template (derived from the audio shown) applied to a series of sixteenth-notes with Timing and 
Velocity both set to 100%
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Mapping Groove Templates
Pro Tools applies groove templates relative to 
the song start. For example, a two-bar groove 
template repeats starting at every odd-num-
bered bar in the session (bar 1, 3, 5, 7…).

Template Mapping for Equal Meters And Odd 
Numbered Bars

If a two-bar groove template is applied to a se-
lection of one bar of the same meter, only the 
first bar of the template is used. If the selection 
does not encompass bar boundaries, for exam-
ple 1|2|000 to 2|1|000, the groove template only 
modifies the selected notes.

2-bar groove template, repeating template grid

Applying 2-bar groove template to a 1-bar selection, 
odd numbered bar

2-bar
groove

template

2-bar
groove

template

2-bar
groove

template

2-bar
groove

template

4/4 bar 1 4/4 bar 2 (not used)

4/4 1-bar selection
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Template Mapping for Equal Meters And Even 
Bars

If a selection starts on an even bar, only the ap-
propriate portion of the groove template will be 
used. For example, if the selection is two bars 
long and starts on an even bar, the template ap-
plies bar 2 before bar 1. 

Template Mapping for Unequal Meters

In cases where the Groove Templates and track 
selections are based on different meters, the 
template will be repeated or truncated to match 
the number of beats in the selection.

For example, if the Groove Template contains 
fewer beats than the selection, such as a one-bar 
template in 6/8 being applied to a one-bar selec-
tion in 4/4, the template repeats to make up the 
difference.

Applying a 2-bar groove template to a 1-bar selection, 
even numbered bar

Applying a 1-bar groove template in 6/8 to a 1-bar 
selection in 4/4

4/4 bar 1 (not used) 4/4 bar 2

4/4 1-bar selection

6/8 bar 1

4/4 1-bar selection

6/8 bar 1 repeated
(beats 3–6 
not used)



If the Groove Template contains more beats 
than the selection on a track, such as a one-bar 
template in 6/4 being applied to a two-bar selec-
tion in 4/4, only uses the appropriate number of 
beats.

Behavior for Mixed Meters

If the selection contains mixed meters, the 
groove template will always be mapped so that 
the downbeats are aligned. For example, if the 
Groove Template consists of one-bar of 4/4 and 
it is being applied to a selection of one-bar of 4/4 
followed by a bar of 7/16 and one-bar of 5/8, the 
downbeat of the Groove Template is aligned 
with the downbeats in the selection and only 
uses the appropriate number of beats from the 
Groove Template.

Applying a 1-bar groove template in 6/4 to a 1-bar 
selection in 4/4

6/4 bar 1

4/4 1-bar selection

(beats 3–6 
not used)
Quantizing Elastic Audio
Pro Tools lets you apply Quantize to Elastic Au-
dio events as well as MIDI notes. Quantize can 
be applied to Event and Warp markers closest to 
the quantize grid on Elastic Audio-enabled 
tracks, regardless of whether they are sample- or 
tick-based. When quantizing, Event markers 
closest to the quantize grid are promoted to 
Warp markers and all Warp markers closest to 
the quantize grid are quantized based on the 
Quantize settings.

Quantization can also be applied to clip start 
times (or sync points) on all audio tracks, 
whether they are Elastic Audio-enabled, or sam-
ple- or tick-based. This lets you quickly quantize 

Applying a 1-bar groove template in 4/4 to a 3-bar 
selection in different meters

You can reset the groove template grid by 
adding a new meter marker (it can be the 
same meter). The groove template will 
restart at the meter marker regardless of the 
measure number or whether or not the me-
ter has actually changed.

3-bar selection of changing meters

4/4 bar 1

4/4 bar 1

4/4 bar 1

(not used)
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audio clips without applying TCE, and is espe-
cially useful when working with “one-shot” clips 
(single-event clips) such as sliced clips or clip 
groups.

To quantize Elastic Audio events:

1  Select the audio you want to quantize on Elas-
tic Audio-enabled tracks. (Audio not on Elastic 
Audio-enabled tracks will not be quantized.)

2  Choose Events > Event Operations > Quantize. 

3  In the Quantize window, select Elastic Audio 

Events from the What to Quantize pop-up menu.

4  Set the Quantize Grid and Options settings.

5  Click Apply.

The Warp and Event markers closest to the 
Quantize Grid are quantized accordingly. TCE is 
applied between these markers and all other 
markers maintain their position relative to the 
Quantize Grid.

Use Restore Performance to undo quantiza-
tion of audio and MIDI. See “Restore Per-
formance Command” on page 923.

Before quantizing Elastic Audio Events in Warp view

After quantizing Elastic Audio Events in Warp view
Pro Tools Reference Guide
Quantizing Audio Clips
Pro Tools lets you quantize audio clip start 
times (or sync points) using the Quantize oper-
ation. Audio clip start times (or sync points) are 
quantized to the nearest quantize grid value. 

To quantize audio clips:

1  Select the audio clips you want to quantize. 

2  Choose Events > Event Operations > Quantize. 

3  In the Quantize window, select Audio Clips 
from the What to Quantize pop-up menu.

4  Set the Quantize Grid and Options settings.

5  Click Apply.

The clip start times (or sync points if present) 
are quantized according to the quantize set-
tings.

Quantizing clip groups only adjust the 
location of the clip group start (or sync 
point). To quantize the underlying sliced 
clips in a clip group, you must first 
ungroup, then quantize, and then regroup. 
For more information on clip groups, see 
“Clip Groups” on page 851.

Before and after quantized audio clips



Quantizing Mixed Selections
You can apply Quantize to both MIDI notes and 
audio clips, or both MIDI notes and Elastic Au-
dio events at the same time. However, you can-
not apply Quantize to both audio clips (non-
Elastic Audio) and Elastic Audio events at the 
same time.

Restore Performance 
Command
The Restore Performance command in the Event 
Operations window reverts all selected MIDI 
notes to their original state (when first recorded 
or manually inserted), even after the session has 
been saved, or the Undo queue has been cleared. 
Restore Performance can also be applied to 
quantized Elastic Audio Events or quantized au-
dio clips.

Event Operations window, Restore Performance page

The Restore Performance command can be 
undone.
The following MIDI note, Elastic Audio Event, 
and audio clip attributes can be restored:

Timing (Quantization) Restores the original start 
times of the selected notes, audio clips, and 
Elastic Audio Events. For MIDI only, this 
changes the durations of selected notes if the 
Duration option is not enabled. 

Duration Restores the original durations of the 
selected notes. If the Timing (Quantization) op-
tion is not enabled, the start times of selected 
notes are not restored and the end times are af-
fected. Duration has no effect on audio.

Velocity Restore the original velocities of the se-
lected notes. Velocity has no effect on audio.

Pitch Restores the original pitches of the se-
lected notes and pitch shifted Elastic Audio 
clips.

To restore the original time, duration, velocity, or 
pitch for selected MIDI notes, audio clips, or 
Elastic Audio Events:

1  Select the MIDI notes, audio clips, or Elastic 
Audio Events you want to restore.

2  Choose Event > Event Operations > Restore 

Performance.

3  Select which performance attributes to re-
store.

4  Click Apply.
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Any changes made through the Quantize, 
Change Duration (MIDI only), Change Velocity 
(MIDI only), or Transpose commands are un-
done and the original “performance” is restored. 
Also, any MIDI notes that were recorded with 
Input Quantize enabled are restored (see “Input 
Quantize Command” on page 933).

Removing Input Quantize
Restore Performance can be used to remove 
quantization on input for MIDI notes. For exam-
ple, if you recorded a performance with Input 
Quantize on, you can still restore the perfor-
mance as it was actually played.

Restore Performance does not undo cut, 
copied, pasted, or otherwise manually 
moved MIDI notes, audio clips, or Elastic 
Audio events.

Restore Performance does not undo Dura-
tion changes made by trimming the start of 
a note. Trimming the start of a note essen-
tially changes the note’s timing, and there-
fore is treated by Pro Tools the same as if it 
were manually moved.

For information on Input Quantize, see “In-
put Quantize Command” on page 933.
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Flatten Performance
The Flatten Performance command in the Event 
Operations window “locks in” the current per-
formance for selected notes, creating a new “re-
store to” state for the specified note attributes 
when using Restore Performance.

To flatten the performance:

1  With the Grabber or Selector tool, select the 
MIDI notes you want to flatten.

2  Choose Event > Event Operations > Flatten Per-

formance to open the Flatten Performance page.

3  Select the note attributes to flatten. (For de-
scriptions of these attributes, see “Restore Per-
formance Command” on page 923).

4  Click Apply. 

Event Operations window, Flatten Performance page

The Flatten Performance command can be 
undone.



Change Velocity
The Change Velocity command in the Event Op-
erations window automatically adjusts Note On 
(attack) and Note Off (release) velocities for se-
lected MIDI notes. Use it to make notes louder 
or softer, or to create crescendos or decrescen-
dos.

Velocities can also be edited manually with the 
Pencil and Grabber tools (see “Manually Editing 
MIDI Notes” on page 686).

Fading Velocities

To change velocities smoothly over time:

1  Select the range of MIDI notes to be edited.

2  Choose Event > Event Operations > Change Ve-

locity.

3  Select the Change Smoothly option with the 
range set from 127 to 0.

4  Click Apply.

Preserving Existing Velocity 
Relationships
To partially preserve the existing velocity rela-
tionships and still achieve velocity fades, use the 
option for Change Smoothly by Percentage. The 
following figures illustrates the difference be-
tween the two Change Smoothly options

You can also change velocity nondestruc-
tively in real-time using MIDI Real-Time 
Properties. See “MIDI Real-Time Proper-
ties” on page 709.
Scaling Velocities
Many times existing note velocities already have 
the relationship between them that you want, 
but are either too soft or too loud overall. In 
these instances, use the Scale By option.

For example, to make velocities 20% louder:

1  Select the range of MIDI notes to be edited.

2  Choose Event > Event Operations > Change Ve-

locity.

3  Select the Scale By option with the percentage 
value set to 120.

4  Click Apply.

Original velocities

Velocities after Change Smoothly by Percentages, 
100% to 20%

Velocities after Change Smoothly by Percentages, 
100 to 10

After Change Smoothly, from velocity of 100 to 10
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Change Velocity Settings

Event Operations window, Change Velocity page

Velocity values usually affect the loudness 
of MIDI notes. Depending on how velocity is 
mapped with any MIDI instrument, veloci-
ties may also affect other aspects of an in-
strument’s sound (such as filter cutoff, enve-
lopes, and modulations).

The settings in the Change Velocity window 
are saved with each session. To store your 
favorite settings as the default for use in fu-
ture sessions, save them as part of a session 
template (see “Session Templates” on 
page 174).
Pro Tools Reference Guide
Note On Applies the Change Velocity options to 
the MIDI Note On.

Note Off Applies the Change Velocity options to 
the MIDI Note Off.

Set All To Sets all velocities to the specified 
value (1–127).

Add Adds to existing velocity values by the spec-
ified amount (1–127).

Subtract Subtracts from existing velocity values 
by the specified amount (1–127).

Scale By Scales all velocities by a percentage 
amount (1–400%).

Change Smoothly Allows velocities to change 
smoothly from one value to another over time.

Change Smoothly by Percentage Allows veloci-
ties to change smoothly from one percentage 
value to another over time. 

The curve for this change can be adjusted 
(+/– 99) to affect how gradually the change oc-
curs.

Limit To When selected, restricts the Change Ve-

locity command to a minimum and maximum 
range after the selected Change Velocity option 
has been applied (and also after any randomiza-
tion has been applied).

Randomize When selected, the selected Change 
Velocity option is randomized by the specified 
percentage value after the selected Change Ve-
locity option has been applied. For example, 
with the Set All To option enabled and set to a 

While there are options for adjusting both 
the Note On (attack) and Note Off (release) 
velocities for notes, most MIDI devices ig-
nore release velocity information. To see if 
your instrument supports release velocities, 
see the manufacturer’s documentation.



value of 64, and with Randomize enabled and set 
to a value of 50%, the resulting velocities will be 
anywhere between 48 and 80 (+/– 25% of the ve-
locity value). 

To randomize selected velocities without applying 
any other Change Velocity options:

1  Enable the Scale By option and set it to 100%.

2  Enable Randomize and set the amount of ran-
domization you want.

3  Click Apply.

Velocity Ranges
The valid range for MIDI note velocities is 
1–127. The Change Velocity command will 
never result in moving velocities outside this 
range; 1 is always the lowest and 127 is always 
the highest. This means that you can encounter 
situations where the Change Velocity command 
has no effect on a particular note.

For example, if a note with a velocity 64 is scaled 
by 200%, the new velocity would be 127. At-
tempting to scale or increase the velocity any 
further yields no further change.

Change Duration
The Change Duration command in the Event Op-
erations window adjusts durations for selected 
MIDI notes. Use it to affect the articulation of 
the selected notes by making them more stac-
cato or legato.

You can also change note duration nonde-
structively in real-time using MIDI Real-
Time Properties. See “MIDI Real-Time 
Properties” on page 709.
Change Duration Settings

Set/Add/Subtract/Scale Option

Set All To Sets all durations to a length specified 
in quarter notes and ticks.

Add Adds to the durations by a specified num-
ber of quarter notes and ticks.

Subtract Subtracts from the durations by a spec-
ified number of quarter notes and ticks.

Scale by Shortens or lengthens durations based 
on a percentage value (1–400%).

Event Operations window, Change Duration

The settings in the Change Duration page 
are saved with each session. To store your 
favorite settings as the default for use in fu-
ture sessions, save them as part of a session 
template (see “Session Templates” on 
page 174).
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Legato

Enable the legato option to add legato to the 
MIDI selection. Select Gap or Overlap from the 
Legato pop-up menu and enter the gap or over-
lap in beats and ticks.

Remove Overlap

The Remove Overlap option removes any note 
overlap for all notes of the same pitch. This com-
mand is different from Legato in that non-over-
lapping notes of the same or different pitches re-
main unchanged. To create a gap between 
previously overlapping notes, enter the gap in 
beats and ticks. 

Transform Sustain Pedal To Duration

The Transform Sustain Pedal To Duration option 
extends the length of all notes that are sounding 
when the sustain pedal (controller 64) is down 
(64 to 127) to the point when the sustain pedal 
goes up (0 to 63). Enable the Delete Sustain 

Pedal Events option to convert sustain pedal 
events to note durations. Converting sustain 
pedal events to note duration can greatly sim-
plify editing while maintaining the desired per-
formance effect. For example, if a sustain pedal 
down event is deleted while editing, the subse-
quent MIDI performance loses its legato effect.

Change Continuously Option

The Change Continuously option lets you change 
the duration of notes continuously in ticks or by 
percentage. Adjust the Curve slider to modify 
the shape of the change.

Change Continuously in Ticks Allows note 
lengths to change smoothly from one duration 
to another over time. Duration values are speci-
fied in quarter notes and ticks.
Pro Tools Reference Guide
Change Continuously by Percentage Allows 
note lengths to change smoothly from one per-
centage value to another over time. 

The curve for this change can be adjusted 
(+/– 99) to affect how gradually the change oc-
curs.

Limit Range When selected, restricts the Change 

Duration command to a minimum and maximum 
range (in quarter notes and ticks).

Randomize When selected, the Change Duration 
command is randomized by the specified per-
centage value. For example, using “Set all to” 
with a value of 480 ticks, along with a Random-
ize value of 50%, yields durations anywhere be-
tween 360 and 600 (+/– 25% of the duration 
value).

Change Duration Examples

To make notes more staccato:

1  Select the range of MIDI notes to be edited.

2  Choose Event > Event Operations > Change Du-

ration.

3  Select the option for Scale By with a percent-
age value of 50.

4  Click Apply. The durations for the selected 
notes are reduced by 50%.

With this option you may have to experiment 
with the percentage value to achieve the desired 
effect.

Press Alt+P on Windows or Option+P on 
Mac to open the Change Duration window.



To make notes more legato:

1  Select the range of MIDI notes to be edited.

2  Choose Event > Event Operations > Change Du-

ration.

3  Select the Legato option.

4  From the Legato pop-up menu, select Overlap.

5  Enter 0|000 for the amount of overlap.

6  Click Apply. 

The end points for the selected notes are ex-
tended to the start point of the next note, 
thereby eliminating the space between each 
note.

Transpose
While the Grabber tools can be used to manually 
transpose individual MIDI notes, or small 
groups of notes, the Transpose command in the 
Event Operations window can be used for entire 
MIDI tracks and clips. One of the more common 
uses for Transpose is to change the key for your 
MIDI tracks. You can define an Edit Group for 
MIDI tracks that you want to transpose, making 
sure to exclude any drum tracks from the group 
so they aren’t transposed. You can even trans-
pose in key. 

The Transpose command can also be applied to 
whole clips on Elastic Audio-enabled tracks us-
ing the Polyphonic, Rhythmic, or X-Form plug-
ins.

You can also transpose MIDI notes nonde-
structively in real-time using MIDI Real-
Time Properties. See “MIDI Real-Time 
Properties” on page 709.
Transpose By (Octaves) Transposes selected 
MIDI notes by up to +/– 10 octaves, or trans-
poses selected Elastic Audio clips up to +/– 2 oc-
taves.

Transpose By (Semitones) Transposes selected 
MIDI notes up or down chromatically by up to 
+/–127 semitones, or transposes selected Elastic 
Audio clips up or down chromatically by up to 
+/– 48 semitones (4 octaves).

Transpose (From and To) Transposes selected 
MIDI notes, or selected Elastic Audio clips, by 
semitones, as expressed by the difference be-
tween the source and destination pitches. 
Transposing from C3 to F#3, for example, trans-
poses the notes up by an augmented fourth (six 
semitones). 

For information on Transposing Elastic Au-
dio clips, see “Elastic Audio Clip-Based 
Pitch Shifting” on page 904.

Elastic Audio pitch transposition is not sup-
ported with the Monophonic algorithm.

Elastic Audio pitch transposition cannot be 
applied to looped clips or clip groups.

Event Operations window, Transpose
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Transpose All Notes To Transposes all selected 
notes to the same pitch. Use the slider or the 
number entry box to enter the pitch to which to 
transpose all selected notes. This option is not 
applicable to Elastic Audio clips.

Transpose In Key Transposes selected notes in 
key up or down by scale steps (based on the Key 
Signature ruler). This option is not applicable to 
Elastic Audio clips.

To transpose MIDI notes:

1  If you will be transposing a group of tracks, en-
able the Edit Group.

2  Select the MIDI notes you want to transpose.

3  Choose Event > Event Operations > Transpose.

4  Select the Transpose option (By, From and To, 
All Notes To, or In Key).

5  Set the corresponding pitch fields.

With any pitch field selected, play a note on your 
MIDI controller to automatically enter it as the 
pitch value.

6  Click Apply.

To transpose all notes on a track down by an 
octave:

1  With the Selector tool, double-click in the 
track to select all of its MIDI notes.

2  Choose Event > Event Operations > Transpose.

3  Select the Transpose By option.

4  Enter a value of –1 octave.

5  Click Apply.

Press Option+T (Mac) or Alt+T (Windows) 
to open the Transpose window.
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To transpose selected notes in key:

1  Select the MIDI notes you want to transpose.

2  Choose Event > Event Operations > Transpose.

3  Select Transpose in Key.

4  Adjust the slider (or type a number) for the 
number of scale steps (+ or –) by which you want 
to transpose the selection. For example, to trans-
pose down a third, enter “–2.”

5  Click Apply.

To transpose an Elastic Audio clip:

1  Make sure the clip, or clips, you want to Trans-
pose are on Elastic Audio-enabled tracks.

2  With the Grabber or Selector tool, select the 
audio clip you want to transpose. Only clips that 
are completely selected will be affected.

3  Choose Event > Event Operations > Transpose.

4  Do one of the following:

• Adjust the Transpose By settings by an 
amount in semitones and cents.

– or –

• Adjust the Transpose From and To settings 
by an amount in Semitones and Cents.

5  Click Apply.

Elastic Audio pitch transposition is not sup-
ported with the Monophonic algorithm.

The Transpose All Notes To and the Trans-
pose In Key settings can only be applied to 
MIDI notes. When only audio clips are se-
lected, these options are unavailable.



Select/Split Notes Command
The Select/Split Notes command in the Event 
Operations window provides a complete set of 
tools to select and split MIDI notes based on a 
wide variety of criteria. Additional tools are 
provided to specify whether selected data is cop-
ied to the clipboard or to new tracks, whether 
the data is split to multiple new tracks or a sin-
gle destination, and more. 

Select/Split Notes Settings

Pitch Criteria

All Notes Selects all notes.

Notes Between Selects a range of notes between 
the specified upper and lower note. Values for 
the notes can be entered in pitch (C1–G8) or 
MIDI note numbers (0–127).

Top Selects the highest note or notes in each 
chord.

Event Operations window, Select/Split Notes
Bottom Selects the lowest note or notes in each 
chord.

Other Criteria

Velocity Enable the Velocity option to specify a 
range of velocities for selecting or splitting 
notes. Enter minimum and maximum velocities. 

Duration Enable the Duration option to specify a 
range of durations (in beats and ticks) for select-
ing or splitting notes. Enter minimum and max-
imum durations.

Position Enable the Position option to select or 
split all notes that fall into a range of relative 
beat and tick locations within each bar. The 
minimum value determines the start of the 
range, the maximum value sets the end of the 
range.

Action

Select Notes Selects MIDI notes based on the 
specified criteria.

Split Notes: The Clipboard Copies the selected 
data to the clipboard only.

Split Notes: A New Track Copies all selected data 
to a single, new track. If the selection includes 
multiple tracks, that same number of tracks are 
created. The new tracks duplicate the original 
track type (Instrument or MIDI). 

Split Notes: A New Track per Pitch Copies all se-
lected data to multiple new tracks (one new 
track for each pitch). New tracks zoom to single-
note display. If the selection includes multiple 
tracks, each track has its data split separately.

Include All Continuous MIDI Data Includes all 
continuous MIDI data, including pitch bend and 
aftertouch, on the entire track, without any re-
striction on time selection.
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Selecting and Splitting Notes

To select and split notes:

1  Do one of the following:

• With the Grabber or Selector tool, select 
the range of MIDI notes that contains the 
notes.

– or –

• To affect all the MIDI notes on a track, click 
in the track with the Selector tool, so that it 
contains a flashing edit cursor.

2  Choose Event > Event Operations > Select/Split 

Notes. 

3  Configure the Pitch Criteria.

4  Configure the Other Criteria (Velocity, Dura-
tion, and Position).

5  Enable the Select or Split option. 

6  From the Split Notes pop-up menu, select Copy 
or Cut. 

7  If splitting notes, select the Copy or Cut to des-
tination.

8  If splitting notes, enable the Include All Contin-

uous MIDI Data option. Enabling this option in-
cludes all controller data associated with the 
split notes in newly created tracks. Leave this 
option unchecked to split only note data to new 
tracks. 

9  Click Apply. 

Any Real-Time Properties associated with the 
track or clips are copied to new tracks created by 
Select/Split Notes. 
Pro Tools Reference Guide
Selecting a Pitch Range of 
Notes
A common use for Select/Split Notes is to select 
a single note for the entire length of a clip or 
track. This is especially useful if you want to se-
lect a note in a MIDI drum track (such as a hi-
hat), and affect it over the selected time range 
with the Quantize, Groove Quantize, Transpose, 
or Change Duration command.

To select only the hi-hats in a General MIDI drum 
track:

1  Do one of the following:

• With the Grabber or Selector tool, select 
the range of MIDI notes that contains the 
notes.

– or –

• To affect all the MIDI notes on a track, click 
in the track with the Selector tool, so that it 
contains a flashing edit cursor.

2  Choose Event > Event Operations > Select/Split 

Notes.

3  Select the Notes Between option with the note 
range set to F#1 and F#1 (if the MIDI Note Display 
setting in the MIDI Preferences page is set to 
Standard Pitch).

For a General MIDI drum kit, the closed hi-hat 
is assigned to MIDI note number 42 (F#1 at 
Standard Pitch). If the hi-hat for your drum kit 
is assigned to a different note, make sure to 
specify it.

4  Click Apply.

You can also select all notes of a specific 
pitch on a track using the mini-keyboard. 
For more information, see “Selecting MIDI 
Notes” on page 686.



Selecting Notes in a Chord
Another use for Select/Split Notes is to select 
only the upper or lower notes in a chord. Many 
times you may only want to affect the upper or 
lower notes in a chord—for example, to increase 
velocities or transpose pitches.

To select only the bass notes in a chord:

1  Do one of the following:

• With the Grabber or Selector tool, select 
the range of MIDI notes that contains the 
notes.

– or –

• To affect all the MIDI notes on a track, click 
in the track with the Selector tool, so that it 
contains a flashing edit cursor.

2  Choose Event > Event Operations > Select/Split 

Notes.

3  Select the Bottom option and leave the number 
of notes set to 1.

4  Click Apply.

In order for notes to be considered a chord, 
their start times must be within thirty-two 
ppq ticks of each other.
Input Quantize Command
When Input Quantize is enabled in the Event 
Operations window, all recorded MIDI notes are 
quantized automatically.

To enable Input Quantize:

1  Choose Event > Event Operations > Input Quan-

tize.

2  In the Input Quantize page, select Enable Input 

Quantize.

3  Configure the other options in the Input Quan-
tize page. (For more information on the Quan-
tize options, see “Quantize Command” on 
page 910.) 

4  When finished, close the Event Operations 
window.

Event Operations window, Input Quantize

Use Input Quantize for drum machine style 
loop recording (see “Loop Recording in 
MIDI Merge Mode” on page 491).
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Step Input Command
Step Input in the Event Operations window lets 
you use a MIDI controller to enter notes individ-
ually, one step at a time. This gives you precise 
control over note placement, duration, and ve-
locity. With MIDI step input you can also create 
musical passages that might be difficult to play 
accurately, or at a fast tempo. 

To enter MIDI notes with Step Input (using an 
external MIDI device):

1  Make certain your external MIDI device is 
properly connected and working with Pro Tools.

2  Choose Event > Event Operations > Step Input.

3  Select the Enable option.

Step Input window

Use Step Input to enter MIDI notes in the 
Score Editor or in MIDI Editor windows.
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4  Choose the MIDI or Instrument track for step 
entry from the Destination track pop-up menu.

5  Choose the note value you want to enter from 
the Step Increment section.

6  Play a note or chord on your MIDI instrument. 
This enters the note and moves to the next step 
of the insertion point.

To increase a note’s length while using Step Input:

1  Play and hold a note on your MIDI instrument.

2  Choose the note value that you would like to 
add and press the Increment button.

Release the note on your MIDI keyboard to move 
to the next step insertion point.

Step Input Controls
The Step Input page has the following controls:

Enable When selected, adds MIDI events to the 
destination track when you play your external 
MIDI keyboard. Additionally, each previously 
record-enabled MIDI track is taken out of re-
cord enable. 

If a Default Thru Instrument is defined in the 
MIDI Preferences page, it is disabled when Step 
Input is enabled, and is re-enabled when Step 
Input is no longer disabled.

When Step Input is enabled, each previously 
record-enabled MIDI or Instrument track is 
taken out of record enable, and if the De-
fault Thru Instrument preference is defined, 
it is disabled.

When a note is being held on the MIDI key-
board, Next Step changes to read “Incre-
ment.” 



Destination Lets you select the destination track 
for the Step Input from a pop-up list of all the 
MIDI tracks in your session. 

Step Increment Section Controls

The controls in the Step Increment section let 
you set the spacing and duration of MIDI events 
entered using the Step Input operation. You can 
select any size from whole notes to sixty-fourth 
notes (including dotted values). 

Tuplet Lets you input irregular note groupings 
(such as triplets or quintuplets). The tuplet 
length is calculated from the note spacing selec-
tion and the Tuplet values. For example, an 
eighth note equals 480 ticks, so tuplet eighth 
notes with 3 in time of 2 would yield a note spac-
ing of 320 ticks (480 ticks / 3 * 2).

Note Length Lets you select the note length as a 
percentage of the spacing value. For example, an 
eighth note equals 480 ticks, so an eighth note 
with an 80% duration would be 384 ticks long.

Step Input Options

Use Input Velocity When selected, MIDI notes 
are recorded using the velocity that you play on 
your MIDI keyboard.

Set Velocity To When selected, MIDI notes are 
recorded with the velocity that you specify in the 
Velocity field. This value can be set with the Ve-
locity slider.

Note length percentages

100% 80% 120%
Enable Numeric Keypad Shortcuts When se-
lected, Step Input options can be selected from 
the numeric keypad. See “Numeric Keypad 
Shortcuts for Step Input” on page 936.

Undo Step, Next Step, and Redo Step

Use the Undo Step and Next Step buttons to do 
the following:

• Move the step insertion point, by either re-
moving the previous note or by advancing 
the insertion point by the Step Increment 
value.

• Lengthen and shorten notes that are being 
held on the MIDI controller, by adding or 
removing Step Increment values. The Step 
Increment value can be changed mid-note 
to create a note with a hybrid note length.

Use the Redo Step button to sequentially redo 
any previously undone steps. 

Undo Step When the previous note has been re-
leased from the MIDI keyboard, and the inser-
tion point has moved forward to the next note, 
Undo Step removes the entire last note.

When a note is being held on the MIDI key-
board, Undo Step changes to read “Decrement,” 
and removes the last Step Increment length that 
was added to the held note.

Next Step (or Increment) When no note is being 
held on the MIDI keyboard, Next Step moves the 
insertion point by the Step Increment value, es-
sentially inserting a musical rest.

When a note is being held on the MIDI key-
board, Next Step changes to read “Increment” 
and adds the Step Increment value to the held 
note, increasing its length by the Step Increment 
value. 
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While the note is being held, the Step Increment 
value can be changed, allowing you to create 
notes of any musical length.

Redo Step Reinserts the last note that was re-
moved by the Undo Step operation. 

Triggering the Undo Step, Next 
Step, or Redo Step Buttons
The Undo Step, Next Step, and Redo Step but-
tons can be set to be triggered by an external 
MIDI synth, drum pad, or other controller. 

To set Undo Step, Next Step and Redo Step MIDI 
triggers:

1  Place the Edit insertion on a track at the loca-
tion where you want to enter the first MIDI note.

2  Choose Event > Event Operations > Step Input.

3  Locate the button you want to assign a MIDI 
event to, and click in the field below the button.

4  Play the MIDI event you want to use as a trig-
ger. 

5  Press Enter to confirm the MIDI trigger as-
signment.

If you use a continuous controller as a trig-
ger (such as Pitch Bend), you should make 
certain to use an extreme controller value to 
avoid erroneous data input.
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Numeric Keypad Shortcuts for 
Step Input
When Enable Numeric Keypad Shortcuts is se-
lected, you can apply many of the controls in the 
Step Input page, as well as several selection con-
trols, using your computer’s numeric keypad. 
:

Step Input Shortcuts Key

Whole note 1

1/2 note 2

1/4 note 4

1/8 note 5

1/16 note 6

1/32 note 7

1/64 note 8

Dotted note . (decimal key)

Toggle Tuplet on/off 3

Next step Enter

Undo step 0

Nudge forward +

Nudge back –

Select Main Counter =

Edit Selection indicators /
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Chapter 43: Basic Mixing
Mixing in Pro Tools involves working with ele-
ments of audio signal flow, including inputs, 
outputs, busses, inserts, and sends, for purposes 
of submixing and mixdown.

In addition to the final mixdown, mixing tasks 
can occur any time during a session. 

During mixing, real-time plug-ins and hardware 
inserts provide effects and signal processing 
(see Chapter 44, “Plug-In and Hardware In-
serts”). 
Mixing Concepts
Mixing involves making decisions about ele-
ments such as volume levels, panning, and ef-
fects in your studio. While you can control many 
variables in your studio (such as speakers and 
room acoustics), you cannot control the listen-
ing environment in which your final mix will be 
heard. The following tips will help you make 
your mix sound as good as possible to as many 
listeners as possible:

Alternate Speakers and Reference 
Monitoring Listen to your mixes on a variety of 
different speakers to gauge how well the mix will 
translate to different playback systems.

Reference Mixes Make audio CDs and MP3-en-
coded files of rough mixes and audition them 
outside the studio in different listening environ-
ments.

Format Compatibility Monitoring Check stereo 
mixes for compatibility with mono playback 
systems, and multichannel surround mixes for 
compatibility with stereo playback systems. (see 
the Pro Tools Sync & Surround Concepts Guide).
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Metering and Calibration
Meters provide a visual display of signal levels. 
They tell whether signal is getting to a channel, 
and how loud or soft a signal is relative to (above 
or below) “0.” 

By calibrating all your equipment to standard 
reference levels, a consistent level can be 
achieved (and metered) among different record-
ing devices in a studio, throughout a facility, or 
throughout an entire production chain. For ex-
ample, a level of –18 dBFS coming out of a DAT 
deck should play and meter at –18 dBFS in 
Pro Tools.

Calibrating Audio Interfaces
(HD I/O or 192 I/O Only)

If you are using a Pro Tools|HD system with an 
HD I/O or 192 I/O, use the Calibration Reference 
Level option (in the Operation Preferences 
page) to set the reference level when Pro Tools is 
in Calibration mode.

For instructions on calibrating an HD I/O, 
see the HD I/O Guide.

For instructions on calibrating a 192 I/O, 
see the 192 I/O Guide.
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Signal Flow by Track Type
Pro Tools provides the following track types:

• Audio

• Auxiliary Input

• Master Fader

• MIDI

• Instrument

• VCA Master (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

Audio, Auxiliary Input, Master Fader, and In-
strument tracks can route audio. MIDI and In-
strument tracks can route MIDI data. 

VCA Master tracks do not pass audio or MIDI 
data, but do affect controls on other tracks. See 
“VCA Master Tracks” on page 945. 

Tracks can be identified in the Mix window by 
their Track Type icon.

Audio Tracks and Signal Flow
Audio tracks play audio from disk, record audio 
to disk, and monitor input signals when record-
enabled or in TrackInput monitoring mode. In-
serts on audio tracks are pre-fader. Sends on au-
dio tracks can be pre- or post-fader.

Mono and stereo audio tracks are available on 
all Pro Tools systems. 

Audio, Auxiliary Input, Master Fader, VCA Master, 
MIDI, and Instrument tracks

For information on creating tracks, see 
“Creating Tracks” on page 220.

Track Type icons



Multichannel audio tracks and surround mixing 
formats are supported by Pro Tools HD or 
Pro Tools with Complete Production Toolkit 
only.

Audio track audio signal flow

Inserts

Sends, 

Volume 

(plug-ins or

Main Output 

pre-fader

Solo

Panner

Additional Outputs 

Sends, post-fader

Output

+

Source: any mono, stereo, or 
multichannel audio file, playing
back from disk

Source 
or Input

inserts)
hardware

Input: while record-monitoring or 
in TrackInput monitoring mode

Record
Mute

Input

HEAT, pre-insert
(Pro Tools HD with HEAT option only)

HEAT, post-insert
(Pro Tools HD with HEAT option only)
Auxiliary Input Tracks and 
Signal Flow
Auxiliary Input tracks provide the same signal 
routing options as audio tracks, except that 
their input must come from an internal bus or 
hardware input. Inserts on Auxiliary Inputs are 
pre-fader.

Auxiliary Input tracks are used as inputs for au-
dio from external MIDI instrument and other 
sources, as well as to submix internal bus and 
output paths. They can be fully automated. 
When using Auxiliary Input tracks as inputs for 
external sources, adjust the source output levels 
to achieve proper recording levels. 

Auxiliary Input track audio signal flow
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Common Uses for Auxiliary 
Inputs
Auxiliary Inputs can be used to:

• Apply real-time plug-ins or an external 
processor to a submix, using the Auxiliary 
Input as an effects return (such as reverb or 
bus line compression)

• Input audio from external MIDI instru-
ments and other audio sources into the mix, 
to monitor or route to audio tracks for re-
cording to disk (such as from the audio out-
puts of a MIDI synthesizer)

• Consolidate volume control of any submix 
under a single fader

• Mix multiple outputs from an instrument 
plug-in (such as Structure, Strike, or Trans-
fuser)

Routing an Auxiliary Input

To route an Auxiliary Input:

1  Click the Input Path selector of the Auxiliary 
Input and choose an input or bus path.

2  Click the Output Path selector of the Auxiliary 
Input and choose an output or bus path. 

3  Adjust the Auxiliary Input fader to set the re-
turn volume. 

See the submix examples in “Signal Routing 
for Monitoring and Submixing” on 
page 970.
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Master Fader Tracks and 
Signal Flow
Master Fader tracks control the master output 
levels of output and bus paths. When assigned to 
an active output or bus path, they provide post-
fader effects processing and master level control 
for a main mix, headphone and cue mixes, 
stems, effects sends, and other signal routing 
applications. Master Faders support all track 
formats supported on your Pro Tools system.

Master Faders do not consume any of your sys-
tem’s audio processing power. Master Faders 
provide up to five post-fader inserts and no 
sends. Also, Master Fader tracks do not have 
Pan sliders, or Mute and Solo buttons.

Master Fader track audio signal flow
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Unlike inserts on audio tracks and Auxiliary In-
puts, Master Fader inserts are post-fader. This 
lets you insert a dither plug-in, or similar plug-
in, on your master mix, and affect its processing 
with the Master Fader level (for more informa-
tion, see “Dither” on page 984). 

Master Fader Meters

Meters on Master faders always show post-fader 
levels, regardless of the Pre-Fader Metering set-
ting in the Options menu. 

Master Faders and Paths

Master Faders can be assigned to main or sub-
paths as defined in the I/O Setup. Multiple Mas-
ter Faders cannot be assigned to the same path.

Active and Inactive Master Faders

When a Master Fader track is inactive, its asso-
ciated plug-ins, I/O assignments, and their re-
sources are made inactive. 

When a Master Fader output assignment (path 
assignment) is made inactive, the Master Fader 
no longer controls the master gain of that path.

When you duplicate a Master Fader track, the 
duplicated track’s assignment will be inactive.

If you absolutely must have a pre-fader in-
sert on your Master Fader signal, set up an 
Auxiliary Input before the Master Fader. 
For example, if you want compression on the 
mix, but you also want to fade out the mix, 
insert a compression plug-in on the Auxil-
iary Input track and insert a dither plug-in 
on the Master Fader track that is assigned to 
the Output path of the Auxiliary Input 
track. Then you can fade out with the Mas-
ter Fader without changing the compression 
threshold for the mix.
Common Uses for Master Faders
Master Faders can be used to:

• Control and process output mixes

• Monitor and meter an output (such as a bus 
or hardware output) to guard against clip-
ping

• Control submix levels

• Control effects sends levels

• Control submaster (bussed tracks) levels 

• Apply dither or other inserts to an entire 
mix

Use Master Faders to control submix levels, 
send level masters, and other outputs. Master 
Faders can control either output or internal bus-
ses. You can use a Master Fader track assigned to 
an Output path as a master volume control. You 
can also use a Master Fader track assigned to a 
bus to trim the inputs to Auxiliary Input tracks 
for submixes to avoid clipping. 

Using a Master Fader

To use a Master Fader as a stereo master volume 
control:

1  Create a stereo Master Fader track.

2  Set the outputs of all audio tracks in the ses-
sion to the main output path (for example, out-
puts 1–2 of your primary audio interface) and 
set the panning for each track.

3  Set the output of the Master Fader to the main 
output path. 

To use a Master Fader to trim the input to a submix:

1  Create an Auxiliary Input track.

2  Bus the signal from audio tracks in your ses-
sion to the input of the Auxiliary Input track.
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3  Create a stereo Master Fader track and assign 
the Output to the bus path that feeds the Auxil-
iary Input track.

Instrument Tracks and Signal 
Flow
Instrument tracks provide the same audio signal 
routing options as Auxiliary Input tracks, ex-
cept that their input must come from an instru-
ment plug-in inserted on that Instrument track, 
or from a bus or hardware input.

Instrument track audio signal flow
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Instrument tracks are used as inputs for instru-
ment plug-ins, and other sources (including in-
ternal busses). They can be fully automated. 
When using an Instrument track as an input for 
an external source, adjust the output level at the 
source to achieve proper recording level. 

Common Uses for Instrument 
Tracks
By playing back MIDI from or through an In-
strument track you can control and monitor the 
audio from:

• Instrument plug-ins, such as software syn-
thesizers or samplers.

• External MIDI instruments, such as synthe-
sizers and samplers

Routing with an Instrument 
Track

To route audio from an external MIDI instrument to 
an Instrument track:

1  Click the Input Path selector of the Instrument 
track and choose the corresponding hardware 
input for your external MIDI instrument.

2  Click the Output Path selector of the Instru-
ment track and choose an output or bus path. 

3  In Instruments view, click the MIDI Input se-
lector, and assign a device and channel from the 
pop-up menu to record and control the external 
MIDI instrument.

4  In Instruments view, click the MIDI Output se-
lector, and assign the port and channel for the 
external MIDI instrument from the pop-up 
menu.

5  Adjust the Instrument fader to set the volume.



VCA Master Tracks 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

VCA Master tracks emulate the operation of 
voltage-controlled amplifier channels on analog 
consoles, where a VCA channel fader would be 
used to control, group, or offset the signal levels 
of other channels on the console.

VCA Master tracks do not pass audio, so they do 
not have inputs, outputs, inserts or sends. A Mix 
group is assigned to a VCA Master track, which 
appears in the VCA track’s Group Assignment 
selector. The controls of the tracks in that Mix 
group, called the slave tracks, are modified by 
the controls on the VCA Master. 

For information on assigning MIDI input 
and output for Instrument tracks, see “As-
signing MIDI Input and Output for Instru-
ment Tracks” on page 246.

For information inserting plug-ins on 
tracks, see “Inserting Plug-Ins on Tracks” 
on page 994.
VCA Slave Track Control 
Indications
Unlike VCAs on traditional analog consoles, 
VCA Master tracks in Pro Tools directly affect 
their slave tracks, so that the controls on each 
slave track always show their actual values: 

• The output level of each slave track is indi-
cated by the position of its fader. 

• The solo, mute, record enable, and TrackIn-
put status of each slave track are indicated 
by the corresponding controls on the track.

This ensures that even when a VCA Master track 
is not visible, the true state of its slave tracks is 
accurately displayed. 

VCA Slave Track Controls and 
Group Behavior
When a group is assigned to a VCA Master, the 
VCA-modifiable controls (Volume, Mute, Solo, 
Record Enable and TrackInput) on its slave 
tracks, by default, do not follow any grouped be-
havior that may be set in the Attributes page of 

VCA Master track

Group Assignment
selector

VCA Track Type indicator

TrackInput 

Mute

Volume

Solo

Record

Level meter
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the Groups dialog. This lets you control the out-
put levels of the group’s member tracks while re-
taining the ability to adjust individual member 
track levels. 

Slave tracks can be set to follow normal grouped 
behavior. See “Assigning Groups to VCA Mas-
ters” on page 947.

Common Uses for VCA Master 
Tracks
By grouping tracks in a Mix group and assigning 
that group to a VCA Master track, you can:

• Control the output levels of all the VCA 
group’s member tracks without the need to 
bus them to an Auxiliary Input track or to 
the same output path

• Create multiple, nested VCA groups and 
control the output levels of multiple sub-
mixes at the same time

• Automate a submix by automating its VCA 
Master track

VCA Master Track Controls
The controls on a VCA Master track affect the 
corresponding controls on the slave tracks in its 
assigned Mix group. VCA Master tracks have the 
following controls:

Volume

The VCA Volume fader controls the Volume 
fader on audio, Auxiliary Input, Instrument, 
Master Fader, and other VCA Master tracks in a 
VCA-controlled group. (Volume faders on MIDI 
tracks are not affected.) Volume faders on slave 
tracks move to show the composite level, or the 
level on each track resulting from the position of 
the VCA Master Volume fader. 
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Mute

The VCA Mute button controls the mute state of 
audio, Auxiliary Input, Instrument, MIDI, and 
other VCA Master tracks in a VCA-controlled 
group. Muting a VCA-controlled group does not 
change the underlying mute state of slave tracks. 
(Mute buttons on slave tracks that were previ-
ously unmuted show an implicit mute.) 

Solo

The VCA Solo button controls the solo state of 
audio, Auxiliary Input, Instrument, MIDI, and 
other VCA Master tracks in a VCA-controlled 
group.

• Soloing a VCA Master will implicitly mute 
all tracks except its slave tracks, thereby in-
directly soloing the slave tracks.

• Soloing a VCA Master will clear any explicit 
solos on its slave tracks, leaving them indi-
rectly soloed, and implicitly mute all other 
tracks.

• Explicitly soloing a slave track while its 
VCA Master track is soloed will override 
the VCA Master solo.

Record Enable

The VCA Record Enable button toggles the Re-
cord Enable status of only those audio, Instru-
ment, and other VCA tracks that have already 
been record-enabled individually. You can then 
toggle record enable on and off for those tracks 
using the VCA Master Record Enable. 

To temporarily force all slave tracks to toggle their 
record enable status:

 Option-click (Mac) or Alt-click (Windows) the 
Record Enable button on the VCA Master.



TrackInput

The VCA TrackInput button toggles the input 
monitor status of only those audio tracks in a 
VCA-controlled group that are record-enabled. 
You can toggle input monitor status for those 
tracks using the VCA Master TrackInput button. 

To temporarily force all slave tracks to toggle their 
input monitoring status:

 Option-click (Mac) or Alt-click (Windows) the 
VCA Master TrackInput button on the VCA Mas-
ter. 

Level Meter

On VCA Master tracks, level meters indicate the 
highest level occurring on any of its individual 
tracks, not a summed level of all slave tracks. 

The channel format of level meters on the VCA 
Master is set according to the channel formats of 
its slave tracks, as follows:

• If all slave tracks are the same channel for-
mat (mono, stereo or a multichannel for-
mat), the number of level meters on the 
VCA Master track is identical to that of the 
slave tracks.

• If the slave tracks are different formats, the 
number of level meters on the VCA Master 
track is set to one.

Record Enable, TrackInput and 
Slave Tracks
When a slave track is record-enabled (the Re-
cord Enable button is lit) or set to Input Only 
mode (the TrackInput button is lit), its automa-
tion is temporarily turned off, and its Volume 
fader is no longer affected by the VCA Master.
Assigning Groups to VCA 
Masters
An existing Mix group can be assigned to a VCA 
Master, or a new Mix group can be assigned to a 
VCA Master while it is being created. Only one 
group can be assigned to a VCA Master at a time. 
A VCA Master cannot control a group that in-
cludes itself.

To assign an existing group to a VCA Master:

 Click the Group Assignment selector on the 
VCA Master track and choose an available group 
from the pop-up menu.

To assign a new group to a VCA Master:

1  While creating a new group, select Mix or 
Mix/Edit as the Group type.

2  In the Group dialog, choose an available VCA 
Master track from the VCA pop-up menu. 

Track Membership in Multiple VCA Groups

It is possible for a single slave track to be a mem-
ber of more than one VCA-controlled group. In 
this case, the contribution of all VCA Master 
Volume faders is summed on the slave track. 
Mute, Solo, Record Enable, and TrackInput fol-
low the same rules for enabling or disabling 
slave tracks. 

Assigning an existing group to a VCA Master
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Allowing Grouped Behavior of 
VCA Slave Track Controls
When a track is a VCA slave track, its Volume, 
Mute, Solo, Record Enable, and TrackInput con-
trols follow VCA functions, and normally do not 
follow Mix group behavior. 

However, these slave track controls can be set to 
allow Mix group behavior in addition to their 
VCA functions.

To allow grouped behavior of VCA-related controls 
on slave tracks:

1  Choose Setup > Preferences and click the Mix-

ing tab. 

2  In the Automation section, deselect the Stan-

dard VCA Logic for Group Attributes option. 

3  Click OK.

Volume, Mute, Solo, Record Enable, and Track-
Input are made available as Mix group attributes 
in the Group dialog. 

Inserts
Pro Tools lets you insert up to ten inserts (A–E 
and F–J) on each audio, Auxiliary Input, Master 
Fader, or Instrument track. Each insert can be 
either a software plug-in insert or a hardware in-
sert, or an instrument plug-in (see Chapter 44, 
“Plug-In and Hardware Inserts”). 

Inserts provide the following features: 

• Plug-Ins and hardware inserts route the signal 
from the track through the effect of your 
choice, and automatically return it to the same 
track. 

• Hardware inserts send and return the signal 
to corresponding input and output channels 
of an audio interface, which can be connected 
to outboard effects.
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• Some Instrument plug-ins (such as Trans-
fuser) accept audio from the track input (let-
ting you use them as processing plug-ins.

• Inserts on audio, Auxiliary Input, and Instru-
ment tracks are pre-fader. 

• Inserts on Master Faders are post-fader.

• Inserts can be bypassed or made inactive.

• Most plug-in controls are fully automatable.

Track Output Format and Plug-
Ins
Pro Tools supports mono, multi-mono, stereo, 
and multichannel plug-ins (Pro Tools HD with 
Surround Mixer only). 

Because inserts process in series, changing the 
plug-in format can alter the channel format. For 
example, inserting a mono-to-stereo plug-in on 
a mono Auxiliary Input changes the signal path 
from that plug-in through the rest of the track. 
This restricts all hardware inserts or plug-ins af-
ter the stereo plug-in to be stereo-in/stereo-out 
plug-ins (or the supported multichannel for-
mat). 

Plug-In Formats
Pro Tools supports mono and stereo plug-ins, 
including the following three types of plug-in 
paths: 

• mono-in/mono-out

• mono-in/stereo-out

• stereo-in/stereo-out

Pro Tools HD sessions running with the Sur-
round mixer also support 3–8 channel multi-
mono and multichannel plug-ins.



Configuring Inserts View in 
the Mix and Edit Windows
Audio tracks, Auxiliary Inputs, Master tracks, 
and Instrument tracks include two sets of in-
serts Views: Inserts A–E (inserts 1–5) and In-
serts F–J (inserts 6–10). The View menu pro-
vides separate options for viewing each of set of 
inserts in the Mix and Edit windows.

To display inserts in the Mix window:

 Select any of the following:

• View > Mix Window > Inserts A–E.

• View > Mix Window > Inserts F–J.

To display inserts in the Edit window:

 Select any of the following:

• View > Edit Window > Inserts A–E.

• View > Edit Window > Inserts F–J.

HEAT
(Pro Tools|HD Systems with HEAT Option 
Only)

HEAT (Harmonically Enhanced Algorithm 
Technology) is a paid software option that adds 
“analog color” to Pro Tools|HD systems. HEAT 
is applied to all active audio tracks in your ses-
sion, emulating the effect of an analog mixing 
console. Use HEAT to open up your mixes with 
warm, analog-modeled soft-saturated distor-
tion. Using HEAT in conjunction with the Stereo 
Pan Depth option (in the Session Setup window) 
lets you emulate the effect of classic analog con-
soles right in Pro Tools.

For more information about HEAT, see the 
HEAT Software Option Guide.
Stereo Pan Depth
Pro Tools lets you select the pan depth for stereo 
output paths. You can set the Pan Depth in the 
Session Setup window. The Pan Depth setting 
lets you set the amount of signal attenuation 
when a track is routed to a stereo output and 
panned to center.

Session Setup window

On Pro Tools|HD systems only, if the Stereo 
Mixer plug-in is installed in the Plug-ins 
folder, the Pan Depth setting defaults to 
–2.5 dB and cannot be changed. Move the 
Stereo Mixer plug-in to the Plug-ins (Un-
used) folder to be able to change the Pan 
Depth setting. 

The Surround Mixer requires slightly more 
DSP resources than the Stereo Mixer. Conse-
quently, if you plan to regularly mix in ste-
reo and use a Pan Depth of –2.5, you may 
want to use the Stereo Mixer plug-in. 
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To set the stereo pan depth:

1  Choose Setup > Session to open the Session 
Setup window.

2  Select an option from the Pan Depth selector.

Stereo Pan Depth Options
The following Pan Depth options are available:

–2.5 Used to be the standard stereo pan depth 
setting in Pro Tools 8.0.x and lower. When 
opening Pro Tools 8.0.x or lower session in 
Pro Tools 8.1, this is the default option.

–3.0 Is the industry standard for surround mix-
ers and many consoles. This is the default set-
ting for new Pro Tools 8.1 sessions.

–4.5 Is the standard for many British analog 
consoles.

–6.0 Is the standard for full mono compatibility.

Views in the Mix and Edit 
Windows
The Mix and Edit windows can be configured to 
show or hide various mixing controls, using 
menu commands or view selectors. 

Most of these views are available in both win-
dows, unless noted.

Session Setup window

For greater than stereo formats (such as 
5.1), all surround output panning is fixed at 
–3.0 dB. The variable pan depth options are 
only available for stereo outputs.
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Window View Selectors
Both the Edit window and Mix window provide 
Window View selectors to configure their views.

Edit Window View selector

Mix Window View selector



Displaying Views

To display all views in the Mix or Edit window, do 
one of the following:

 Select View > Mix Window (or Edit Window) > 

All.

– or –

 Click the Mix Window View selector (or Edit 
Window View selector), and select All.

To display none of the views in the Mix or Edit 
window, do one of the following:

 Select View > Mix Window (or Edit Window) > 

None.

– or –

 Click the Mix Window View selector (or Edit 
Window View selector), and select None.

To show or hide available views in the Mix and Edit 
windows, do one of the following:

 Choose View > Mix Window (or Edit Window) 
and select or deselect one of the view types (such 
as Comments).

– or –

 Click the Mix Window View selector (or Edit 
Window View selector), and select or deselect 
one of the view types (such as Comments).

Hiding Views in the Edit Window
You can quickly hide View columns in the Edit 
window using the mouse with keyboard modi-
fier. 

To hide a View column in the Edit window:

 Alt-click (Windows) or Option-click (Mac) at 
the top of the column you want to hide (Mic Pre, 
Comments, Instrument, Inserts A–E, Inserts 
F–J, Sends A–E, Sends F–J, I/O, Real-Time Prop-
erties, or Track Color).
Window View Options
Comments View Shows any text entered as com-
ments in the Track Name/Comments dialog. For 
more information, see “Naming Tracks” on 
page 222.

Mic Preamps View Shows controls in each track 
for PRE. For detailed information, see the PRE 
Guide.

Instruments View Shows MIDI controls on In-
strument tracks (MIDI Input selector, MIDI 
Output selector, MIDI volume, MIDI pan, and 
MIDI mute).

Comments View in the Mix and Edit windows

Mic Preamps View

Instruments View
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HEAT View (Pro Tools HD with HEAT Option 
Only) (Mix Window Only) Shows HEAT track 
controls on audio tracks in the Mix window. 
This view is only available in the Mix window for 
Pro Tools|HD systems with an authorized ver-
sion of the HEAT option installed. For more in-
formation, see the HEAT Software Option Guide.

Inserts View (Inserts A–E and Inserts F–J) Shows 
inserts (software plug-ins and hardware I/O in-
serts) in each track. For more information, see 
“Configuring Inserts View in the Mix and Edit 
Windows” on page 949.

Sends View (Sends A–E and Sends F–J) Shows 
send assignments in each track. Deselect to hide. 
For more information, see “Configuring Sends 
View in the Mix and Edit Windows” on 
page 959.

HEAT View

Views in the Mix window

Inserts (A–E) View

Sends (A–E) View

I/O View

Sends (F–J) View

Inserts (F–J) View
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I/O View (Edit Window Only) Shows Input and 
Output selectors, and Volume and Pan indica-
tors in each track.

Click on the volume or pan indicators in the Edit 
window I/O View to adjust the volume or pan 
controls with a pop-up fader.

I/O View (Edit window)

I/O View Volume pop-up fader (Edit window)

I/O View Pan pop-up slider (Edit window)



Real-Time Properties View (Edit Window 
Only) Shows controls for Real-Time Properties 
for MIDI and Instrument tracks. For more infor-
mation on Real-Time Properties, see “MIDI 
Real-Time Properties” on page 709.

Delay Compensation View The Delay Compensa-
tion View displays the total amount of plug-in 
(TDM and RTAS) and hardware insert delay on 
each track, lets you apply a user offset of track 
delay, and displays the total amount of delay 
that Pro Tools applies to each track. The Delay 
Compensation View can be shown or hidden in 
the Mix Window.

Delay values can be specified in either samples 
or milliseconds, as selected in the Operation 
Preferences page. For more information on De-
lay Compensation, see “Delay Compensation” 
on page 977.

Track Color View Shows track color in each 
track. For detailed information, see “Color Cod-
ing for Tracks, Clips, Markers, and Groups” on 
page 251.

Real-Time Properties View (Edit window)

Delay Compensation View

User Offset 

Track Compensation
indicator 

Delay indicator
Audio Input and Output Paths
Pro Tools lets you configure the physical input 
and outputs of your audio interfaces and also in-
ternal bus paths and subpaths in the I/O Setup 
dialog and the Hardware Setup dialog. These 
hardware inputs and outputs, and internal bus 
paths can be assigned as inputs and outputs on 
audio, Auxiliary Input, Instrument, and Master 
Fader tracks.

Input Audio Path
Input Path selectors determine the source input 
for audio, Auxiliary Input, and (optionally) In-
strument tracks. Track inputs can be set from 
hardware inputs or internal bus paths or 
subpaths. For detailed information on assigning 
track inputs, see “Assigning Audio Inputs” on 
page 236.

Hardware input and bus paths can be configured 
in the I/O Setup. For more information, see 
Chapter 7, “I/O Setup.”

You can also define what physical ports are 
routed to Pro Tools input ports in the Hardware 
Setup dialog. For more information, see “Con-
figuring Pro Tools System Settings” on page 60.

Output Audio Path
Track Output Path selectors route the post-fader 
signals to the assigned output or bus paths. The 
Output Path selector routes the main track out-
put to the chosen main or sub-path. Tracks can 
be routed directly to hardware output or inter-
nal bus paths and subpaths for submixing (main 
or sub-paths). 
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The track format (mono, stereo, or multichan-
nel) determines the available main and sub-path 
choices for track output. For detailed informa-
tion on assigning track outputs, see “Assigning 
Audio Outputs” on page 237.

When audio, Auxiliary Input, Master Fader, and 
Instrument tracks are created, their mono, ste-
reo, or greater-than-stereo multichannel format 
is defined:

• Mono tracks can be assigned to any available 
mono, stereo, multichannel main and sub-
paths.

• Stereo tracks can be assigned to any available 
mono, stereo, or multichannel main and sub-
paths.

• Multichannel tracks (Pro Tools HD or 
Pro Tools with Complete Production Toolkit 
only) can be assigned to any mono path, or 
path of the same number of channels (for ex-
ample, an LCRS track can be assigned to a 
mono or LCRS path). 

Output Windows
Output windows provide the essential track 
mixing controls (such as track panning and vol-
ume), as an alternative to Mix and Edit window 
views. Multichannel Output and Send windows 
also provide expanded Panner views, and other 
surround-specific controls. See Chapter 49, 
“Surround Panning and Mixing.” 

Output windows are useful in large sessions to 
leave important tracks in an anchored location, 
unaffected by Mix and Edit window (or control 
surface) banking. See “Output Windows for 
Tracks and Sends” on page 965.
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Multiple Output Assignments
Pro Tools audio, Auxiliary Input, and Instru-
ment tracks can be assigned to multiple output 
paths. Assigning to multiple paths is an efficient 
way to route an identical mix to other discrete 
outputs, for simultaneous monitor feeds, head-
phone mixes, or other situations where a paral-
lel mix is needed.

To assign a track to multiple outputs:

1  Assign a main output path by selecting it from 
the track’s Output Path selector. 

2  Start-click (Windows) or Control-click (Mac) 
an additional output path in the track’s Output 
Path selector. The newly selected output destina-
tion is added as an additional output. 

Display of Multiple Output 
Assignments
When a track is assigned to multiple output 
paths, the Output Path selector denotes multiple 
assignment status and active/inactive status 
with the following indicators:

• A plus sign (+) indicates that the track has 
multiple output assignments. 

Option-Control-click (Mac) or Alt-Start-
click (Windows) to add the assignment to 
all tracks, or Option-Shift-Control-click 
(Mac) or Alt-Shift-Start-click (Windows) to 
add to all selected tracks.

Indication of multiple output assignments



• In the Output Path selector menu, all cur-
rently assigned track outputs are checked to 
indicate they are active for the current track. 

• An asterisk (*) indicates that one or more cur-
rently assigned outputs is Inactive. 

Inactive Outputs
An output path can be made inactive, either 
globally in the I/O Setup dialog (affecting all 
tracks assigned to that path), or locally per as-
signment (only affecting that output on that au-
dio track Auxiliary Input track, or Instrument 
track). 

To make an output path inactive, do one of the 
following:

 Command-Control-click (Mac) or Control-
Start-click (Windows) the Output selector.

– or –

 Right-click the Output selector and select 
Make Inactive.

When opening sessions, outputs will be made 
inactive automatically if the required hardware 
or other resources are not available. 

Inactive outputs retain all associated automa-
tion playlists. Edits made in the session also af-
fect the inactive track’s output automation play-
lists.

Indication of multiple output assignments with at least 
one inactive output

See “Making Tracks Inactive” on page 251.
To make an inactive output path active, do one of 
the following:

 Command-Control-click (Mac) or Control-
Start-click (Windows) the Output selector.

– or –

 Right-click the Output selector and select 
Make Active.

Inactive Outputs and DSP 
Resources
Making a track output inactive silences the out-
put, while retaining all automation and playlist 
data. Inactive outputs do not consume resources 
for TDM mixer connections, but any assigned 
plug-ins on the track continue to use their re-
quired DSP resources. RTAS plug-ins require 
CPU resources, and TDM plug-ins use the DSP 
available on Pro Tools|HD cards. 

You can free up DSP of an unused plug-in by 
making its track inactive, or by making just the 
plug-in inactive. 

About the “No Output” Option
Track outputs can be set to No Output. Assigning 
a track output to No Output causes any panning 
automation associated with the track to be lost.

Tracks assigned to No Output will not be audible, 
but they do not free their associated DSP re-
sources. 

See “Active and Inactive Items” on page 22, 
and “Making Inserts Inactive” on page 993 
for more information.
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Sends
Pro Tools lets you insert up to ten sends (A–E 
and F–J) on each audio track, Auxiliary Input, or 
Instrument track.

Sends provide the following features: 

• Sends can be set as pre- or post-fader.

• Send level, pan, mute, and LFE controls can be 
configured to follow Groups.

• Send level, send mute, and send pan (for ste-
reo and multichannel sends) are fully autom-
atable. See “Automating Sends” on page 1036.

• Send controls can be displayed and edited 
from the Mix or Edit windows, or in their own 
output windows.

• Sends can be assigned to available output and 
bus paths (main or sub-paths), in mono or ste-
reo, or any of the supported multichannel for-
mats for surround mixing. 

• Each send can have multiple assignments (for 
example, to available output and bus paths).

To be audible in Pro Tools, sends must be re-
turned to the mix through an Auxiliary Input, 
audio track, or Instrument track. The sends can 
then be monitored and processed through an 
Auxiliary Input (or Instrument track), recorded 
to audio tracks, and bounced to disk. (Bouncing 
and mixdown are explained in Chapter 46, 
“Mixdown.”)
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Assigning Sends to Tracks

To add a send to a track:

1  Make sure Sends View is enabled in the Mix or 
Edit window (see “Views in the Mix and Edit 
Windows” on page 950 for information). 

2  Click the Send selector on the track and choose 
a path from the pop-up menu.

The send can be a mono or stereo (or any of the 
supported multichannel formats for surround 
mixing) output or bus path.

Assigning a send to a stereo bus path 

Send window (stereo)



3  Set the output level of the send in the Send 
window by doing one of the following:

• Adjust the Send Level fader.

– or –

• Set the send level to unity gain (0 dB) by 
Alt-clicking (Windows) or Option-clicking 
(Mac) the Send Level fader.

When you create a new send, its initial output 
level depends on the setting of the Sends Default 

to –INF preference.

Pans for sends can be linked to the panning on 
the track’s main output path by enabling the 
Send Pans Default To Follow Main Pan prefer-
ence. 

To change the default setting for sends:

1  Choose Setup > Preferences and click the Mix-

ing tab.

2  Do one of the following:

• Select Sends Default to “–INF.”

– or –

• Deselect Sends Default to “–INF” and new 
sends will default to unity gain (0 dB).

3  Do one of the following:

• Select Send Pans Default to Follow Main 

Pan.

– or –

• Deselect Send Pans Default to Follow Main 

Pan to have panning control over the sends 
independent of the panning on the track’s 
main output path.

To remove a send from a track:

 Click the Sends button on the track and choose 
No Send from the pop-up menu. 
Create and Assign a New Track 
from a Send
Pro Tools lets you create a new Auxiliary Input, 
Audio, or Instrument track from the Send selec-
tor and automatically assign the send to the In-
put of the new track using an available internal 
mix bus.

To create a new track from a send:

1  On an existing track, click the Send selector 
and select New Track.

2  In the resulting New Destination dialog, select 
the Width, Type, and Time Base for the new 
track.

3  Type a Name for the new track.

The name entered is used for both the new track 
and the new mix bus. (For example, if you en-
tered the name “Drum Sub,” Pro Tools creates a 
new Auxiliary Input track named “Drum Sub” 
and also creates an internal mix bus named 
“Drum Sub.”)

4  Select (or deselect) whether you want the new 
track to be created next to the current track 
(with the send).

5  Click OK.

New Destination dialog
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Pro Tools creates a new track with the output of 
the originating send automatically routed to the 
input of the new track using an available inter-
nal mix bus. 

Assign an Existing Track from a 
Send
Pro Tools lets you assign a send directly to an 
active Auxiliary Input, Audio, or Instrument 
track using an available internal mix bus. Note 
that the destination track must be set to either 
an internal mix bus or to No Input in order to be 
available for assignment.

New Auxiliary Input track with audio track send 
automatically assigned to Bus 1–2
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To assign a send to an available input on an 
existing track:

1  On an existing track, click the Send selector 
and select Track.

2  From the Track submenu, select the destina-
tion track you want.

Pro Tools automatically routes the send to the 
input of the selected track using an available in-
ternal mix bus.

Assigning a send to an existing Auxiliary Input track



Send Formats
Mono and Stereo Sends When you click the 
Sends button on a track, you can choose from a 
list of mono or stereo output or bus paths. 

Multichannel Sends (Pro Tools HD and Pro Tools 
with Complete Production Toolkit Only) When 
you click the Sends button on a track, you can 
choose from a list of multichannel output or bus 
paths. 

Send Path Selector Choices
The choices available in track Send selectors in-
clude bus and output paths.

Internal Mix Busses Pro Tools provides 256 in-
ternal mix busses for routing signals internally. 
Internal bus paths are useful for submixing and 
processing with plug-ins. Bus paths are defined 
in the I/O Setup dialog, and are available in all 
supported channel formats (mono, stereo, or 
multichannel, as supported on your system).

Hardware Outputs Hardware sends are often 
used for headphone cue mixes, or for sending 
signals to external effects processors. Sends do 
not automatically return audio as do hardware 
inserts. 

The names, format, and channel mapping of 
busses and output paths can be customized 
in the I/O Setup dialog. See “Output Busses” 
on page 109.
Configuring Sends View in 
the Mix and Edit Windows
Audio tracks, Auxiliary Inputs, and Instrument 
tracks include two sets of Sends Views: Sends 
A–E (sends 1–5) and Sends F–J (sends 6–10). 
The View menu provides separate options for 
viewing these sends in the Mix and Edit win-
dows.

To display sends in the Mix window:

 Select any of the following:

• View > Mix Window > Sends A–E.

• View > Mix Window > Sends F–J.

To display sends in the Edit window:

 Select any of the following:

• View > Edit Window > Sends A–E.

• View > Edit Window > Sends F–J.

Sends View Options
Sends are displayed in the Mix and Edit window 
according to the Sends A–E View and Sends F–J 
View options. Each Send View has six view 
choices: Assignments View and five individual 
Send Views (A–E or F–J).
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Assignments View
This is the default Sends View, showing all five 
of the Sends A–E or Sends F–J sends on all 
tracks displayed in the Mix and Edit windows.

In Assignment View, send controls are adjusted 
from Send windows. See “To view a different 
track Output or Send window:” on page 966.

To show all send assignments:

1  If sends are not currently visible on your 
tracks, select View > Mix Window (or Edit Win-

dow) > Sends A–E (or Sends F–J).

2  Do one of the following:

• Select View > Sends A–E > Assignments or 
View > Sends F–J > Assignments. 

– or –

• When displaying sends in an individual 
Send View (such as Send A View), Control-
click (Windows) or Command-click (Mac) 
the Send selector and select Assignments.

Assignments View, no sends (left) and with an 
assigned send (right)

Send selectors (A–E) 

Send A, Assignment View
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Individual Send Views (A–J)
Individual Send Views (such as Send A) provide 
send level, pan, and mute controls for a single 
send across all tracks. 

Send controls can be adjusted directly from 
these Send Views. Sends can also be opened for 
control or metering in Send windows. See “Out-
put Windows for Tracks and Sends” on 
page 965.

To display the controls for an individual send 
across all tracks:

1  If sends are not currently visible on your 
tracks, select View > Mix Window (or Edit Win-
dow) > Sends A–E (or Sends F–J).

2  Do one of the following:

• Select View > Sends A–E (or Sends F-J) and 
select one of the individual Send Views 
(such as Send A).

– or –

• In Assignment View, Control-click (Win-
dows) or Command-click (Mac) the Send 
Assignment selector.

Send A View, with different types of send assignments

pre-fader 
multichannel

post-fader 
no assignmentstereo



Editing Sends in the Mix and 
Edit Windows (Individual 
Send Views)
Individual Send Views (such as Send A) display 
all the controls of an individual send in the 
sends area of the Mix and Edit windows. These 
views provide full access to all controls for that 
send on all tracks. 

Send level and mute can follow Mix groups, to 
adjust multiple send controls from a single set of 
controls.

Sends Views, A–E set to “A” and F–J set to 
“Assignments”

Send A View, with mono send shown

Send Mute button

Send Pan

Send meter

Send level

Pre/Post Fader button

Send Assignment buttonSend selector
Individual Send Views and 
Meters
When you display the controls for an individual 
send, you also have the option of displaying 
send level meters.

Send level meters show peak values and indicate 
clipping that occurs while the meter is displayed 
(if a send clips any time before its meter is dis-
played, this is not shown). If you are using a 
slower computer, hiding send level meters can 
improve screen redraw times.

To clear a send meter’s Clip indicator:

 Click the Clip indicator. 

To clear all meters, do one of the following:

 Option-click any Clip indicator.

 Choose Track > Clear All Clip Indicators.

 Press Alt+C (Windows) or Option+C (Mac).

Send Status Display
When displaying all controls for an individual 
sends, the Send status is visible directly in the 
Mix or Edit windows.

In Assignment View, Send status is displayed as 
follows:

• By default, the Send button is gray, to indicate 
that it is unmuted.

• The Send button text is red when the send has 
clipped.

• The Send button is blue when the send is 
muted. 

• The Send button is lit whenever a send’s win-
dow is open. 

In Assignment View, edit sends by opening 
their Output windows. See “Output Win-
dows for Tracks and Sends” on page 965.
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If you use a control surface (such as D-Control 
or 003) with Pro Tools, colored outlines around 
sends, inserts, and outputs indicate the current 
controller focus.

Inactive Sends 
Sends can be made inactive. Inactive sends free 
their DSP and mixer resources, while retaining 
their position in track Sends View. Inactive 
sends do not output audio. However, Inactive 
sends retain all related automation playlists. In 
addition, edits made to clips on tracks with in-
active sends can still affect the sends automa-
tion playlists.

When opening sessions, sends will automati-
cally be made inactive if the required hardware 
or other resources are not available. 

Indication of Send mute, clipping, and window status

Display of inactive sends

Unmuted Window is open
(lit Send)

Muted 
(blue) 

Clipped 
(red text) 

Inactive sendActive Inactive track 
(italicized and
grayed out)

send 
(plain text)

(entire track is italicized
and grayed out)
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To make a send inactive, do one of the following:

 Control-Start-click (Windows) or Command-
Control-click (Mac) on the Send assignment.

– or –

 Make the Track inactive. See “Making Tracks 
Inactive” on page 251.

To toggle sends in the same position (A–J) and 
assigned to the same path on all tracks active or 
inactive:

 Control-Start-Alt click (Windows) or Com-
mand-Control-Option click (Mac) a send button 
in the position you want to toggle.

To toggle sends in the same position (A–J) and 
assigned to the same path on all selected tracks 
active or inactive:

 Control-Start-Alt-Shift-click (Windows) or 
Command-Control-Option-Shift-click (Mac) a 
send button in the position you want to toggle.

Moving or Copying Sends 
Sends can be moved or copied to other tracks, or 
to other positions on the same track by drag-
ging. Sends can be dragged to create new sends 
at the destination, or dragged onto existing send 
assignments to replace them. 

Sends can be moved and copied to tracks with 
compatible send formats (mono, stereo, or 
other). Pro Tools alerts you when you try to 
move or copy a send to an incompatible destina-
tion. (For more information, see “Send Format 
and Track Compatibility” on page 963). 



To move a send:

 Drag the send name to a new position in the 
original track or in a different track. 

To copy a send:

 Alt-drag (Windows) or Option-drag (Mac) the 
send to a new position. 

Moving or copying a send maintains all routing 
assignments, automation, level/pan/mute set-
tings, and output format. 

Send Format and Track Compatibility

Sends can only be copied to other tracks with a 
compatible send output format (mono, stereo, 
or other). In addition, the following conditions 
apply when moving or copying sends among 
tracks:

• When copying a stereo send from a mono 
track to a stereo track, Send pan automation 
(if any) will be dropped without warning. 

• When copying a stereo send from a stereo 
track to a mono track, the left Send pan auto-
mation data is retained and the right side data 
is dropped. A warning dialog appears for you 
to confirm or cancel this destructive opera-
tion. 

• When moving or copying a send and replacing 
an existing send, all automation on the exist-
ing send will be replaced. A warning dialog 
appears for you to confirm or cancel this de-
structive operation. 
Copying Track Settings to Sends
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Sometimes you need send settings to match the 
settings in the track itself—for example, to pro-
vide a headphone mix based on the main mix. 
You can copy the current values or the entire au-
tomation playlist from selected tracks to any of 
their sends. 

Linking Send Pan and Main Pan 
Controls
You can link pan controls of individual Sends to 
the Main pan controls of their corresponding 
tracks. This can help you quickly setup cue mix 
(headphone mix) or effects processing bus rout-
ing.

Linked Send pan controls appear in light gray.

For more information, see “Copying Track 
Automation to Sends” on page 1036.

Follow Main Pan button
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To link a Send’s Pan controls to the Main Pan 
controls of a track:

1  Click the Send Assignment button for the Send 
you want to link to open the Send window. 

2  In the Send window, click the FMP (Follow 
Main Pan) button. 

To change the default FMP (Follows Main Pan) 
setting for newly created Sends:

1  Choose Setup > Preferences and click the Mix-

ing tab.

2  Under Setup, select or deselect the Send Pans 

Default to Follow Main Pan option.

Bus Interrogation Options
Pro Tools lets you select or show tracks based on 
the track input or output assignment, send as-
signment, or hardware insert assignment. This 
can be useful for quickly identifying all tracks 
that use a specific input, internal bus, output 
bus, or hardware insert.

Right-click the assignment selector and choose 
from the following options:

Select Assignments To This option selects all 
tracks that use a specific input, internal bus, 
output bus, or hardware insert.

Show Assignments To This option shows all 
tracks, including hidden tracks, that use a spe-
cific input, internal bus, output bus, or hard-
ware insert. All other tracks remain shown as 
well.

Show Only Assignments To This option shows 
only those tracks that use a specific input, inter-
nal bus, output bus, or hardware insert. All 
other tracks are automatically hidden.
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Restore Previously Shown Tracks This option 
restores the previous state of shown and hidden 
tracks. This option is only available if tracks 
have been hidden by using the Show Only As-

signments To option.

To select tracks based on the track Input or Output 
assignment, Send assignment, or Hardware Insert 
assignment:

 Right-click the assignment selector and 
choose Select Assignments To for the bus you 
want.

To show all tracks based on the track Input or 
Output assignment, Send assignment, or 
Hardware Insert assignment:

 Right-click the assignment selector and 
choose Show Assignments To for the bus you 
want. Any hidden tracks with the corresponding 
assignment are shown.

Press Option (Mac) or Alt (Windows) while 
Right-clicking and selecting any of the Bus 
Interrogation commands to apply the com-
mand to all related paths and sub-paths. 
For example, Press Option (Mac) or Alt 
(Windows) while Right-clicking an output 
selector and choosing Show Only Assign-
ments To Bus 1. If Bus 1 is a sub-path of Bus 
1–2, all tracks using path Bus 1–2, and all 
tracks using sub-paths Bus 1 and Bus 2 are 
shown, and all other tracks are hidden.

Choosing the Select Assignments To Bus 1–2 option



To show only tracks based on the track Input or 
Output assignment, Send assignment, or 
Hardware Insert assignment:

 Right-click the assignment selector and 
choose Show Only Assignments To for the bus 
you want. All other tracks are automatically hid-
den.

To restore all previously shown tracks:

 Right-click any assignment selector and 
choose Restore Previously Shown Tracks.

Choosing the Show Only Assignment To Bus 5–6 
option

Choosing the Previously Shown Tracks option
Output Windows for Tracks 
and Sends
Track outputs and sends can be opened for dis-
play and editing in dedicated windows. 

• Track Output windows provide track fader, 
pan, automation, solo, and mute controls. 

• Send windows provide send level, pan, auto-
mation, and mute controls. 

• Standard Output and Send window controls 
provide additional routing, assignment, and 
display settings.

To open a track Output window:

 Click the Output Window button in the chan-
nel strip. 

Opening a track Output window
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To open a Send window:

 Click the Send Assignment button in the Mix 
or Edit window. 

To view a different track Output or Send window:

 Click an Output Window button, or Send As-
signment button, in the Mix or Edit window. 

If a similar Output window was already open 
with a highlighted Target icon (red, lit), the 
newly selected send will open in its place. 

Opening a Send window
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Opening Multiple Output 
Windows
Multiple track and Send windows can be dis-
played simultaneously using either of the fol-
lowing methods. 

To open additional Output windows:

 Shift-click any Output Window button or Send 
Assignment button.

To set a window to remain open when opening 
additional Output windows:

 Make sure the Target is disabled. 

For additional information, see “Targeted Win-
dows” on page 969.

Multiple Send windows

Target enabled Target disabled



Panner Linking
Stereo outputs provide two panning controls, 
one for each side of the left/right pair. Multi-
channel outputs provide a multichannel panner.

The Output window provides controls to link 
channels for precise panning of stereo and mul-
tichannel tracks.

In the linked state, all sides match changes to 
any other side’s Pan control. This is Absolute 
Link mode. To mirror panning changes, see “In-
verse Linked Panning” on page 967.

When unlinked, Pan controls are completely in-
dependent of each other.

To enable linking:

 Enable the Link icon.

To unlink an output for independent panning:

 Deselect the Link icon. 

Unlinked (left), linked (middle), front inverse linked 
(right) Send windows

Link icon

Inverse icon
Inverse Linked Panning
When linked and set to Inverse mode, panning 
moves are inverted or reversed in the other 
channels. 

Inverse panning reflects one side’s location and 
direction in the other side. For example, when 
enabled for Front Inverse, if you pan one side of 
a stereo track output from right to left, the other 
side will exactly mirror that movement and pan 
left to right. 

Front Inverse linking is available on all systems. 
Rear Inverse, and Front/Rear Inverse linking are 
available on Pro Tools|HD systems only, and 
only appear as options on multichannel plug-ins 
and panners/output windows.

To enable inverse linking:

1  Enable the Link icon.

2  Select an Inverse mode. 

Link and Inverse selectors (multichannel track)

Link 

Front/Rear Inverse

Front Inverse

Rear Inverse
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Standard Selector Controls in 
Output Windows
All Output windows provide standard selectors 
for path, automation, and other controls in the 
top area of the window (the Output Editor area).

Track Selector Provides access to any audio 
track, Auxiliary Input, or Master Fader in the 
session.

Output View Selector Provides access to other 
outputs (track and send) in the track, if any, dis-
playing the selected output in the current win-
dow.

Send View Selector (Send Window Only) Pro-
vides access to other sends on the track.

Output Path Selector Allows you to assign the 
Output path for the current track or send. 

Pre/Post Fader Button (Send Window Only) De-
termines whether the send is pre- or post-fader.

FMP (Follow Main Pan) (Send Window Only) De-
termines whether or not panning for the send 
follows the panning settings of the track. When 
the FMP button is enabled, the Panning controls 
in the Send window become unavailable and the 
panning for the send is determined by the pan-
ning settings for the track.

Output window standard controls

Send window standard controls

Automation Safe 

Target

Path selector

Track selector

Inverse Pan

Linkbutton

Output View
selector

Pre/Post Fader
Automation Safe 

Target

Path selector

Track selector

Inverse PanLink

Send selector

Follow Main Pan
Pro Tools Reference Guide
Automation Safe Protects track and send level, 
pan, and other controls from automation over-
writes by placing them in Automation Safe 
mode. See Chapter 45, “Automation” for more 
information. 

Inverse Pan Reflects one side’s panning location 
and direction in the other side (for example, 
left- and right-channel Pan controls). 

Link and Unlink Lets you link and unlink left and 
right (or other) outputs in stereo (or multichan-
nel). Unlinked mode provides discrete adjust-
ment of individual sides, or channels. When 
linked, all changes affect all channels. See “Pan-
ner Linking” on page 967. 

Target Identifies the target of plug-in settings 
commands. Also sets the current window for 
display of Output windows. See “Targeted Win-
dows” on page 969. 

Path Meter View Opens the path Meter View. 
These meters display levels of the selected path 
(not the levels of the track or send). 

Path Meter View in a Send window

Path 

Path Meter 

Send meter

Path Meter

selector

meters

View button



Track Fader, Pan Controls, and 
Solo, Mute, and Automation 
Controls
Output windows provide the associated track’s 
Volume fader, Pan controls, Solo and Mute 
switches, and Automation Mode selector. Use 
these to adjust or automate the controls of the 
Output window. 

Targeted Windows
When lit (red), the Target indicates its window 
is “targeted,” and the next window opened of the 
same type replaces the current display (unless it 
is opened as an additional window with the Shift 
modifier). When unlit, the target is gray, and the 
current window anchors to its current contents 
and location on-screen. Opening additional 
windows does not affect anchored windows.

To set an open Send window as the target window:

 Click the Target, so that it is lit (red).

Plug-In windows have additional features 
related to the Target (such as Focus of Set-
tings commands). See “The Plug-In Win-
dow” on page 998.
Using Output Windows
Output windows provide standard Pro Tools 
track, send, Target, and other controls. 

To move to a different track:

 Click the Track selector and choose a track 
from the pop-up menu.

To reassign output:

 Click the Output Path selector and select a 
path from the pop-up menu. 

To display the controls for a different send on the 
same track:

 Click the Send View selector and select the 
send.

To assign a different send to the same track:

 Click the Send selector and choose an output 
or bus path from the pop-up menu.

To add an additional output assignment to the 
current send:

 Press Start (Windows) or Control (Mac) while 
selecting an additional output path from the 
Send selector (or Output Path selector.
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Signal Routing for Monitoring 
and Submixing
The bussing and mixing features in Pro Tools 
support many possibilities for submixing and 
monitoring, including the ability to:

• Monitor and mix playback of audio tracks with 
audio inputs or with MIDI instruments

• Bus submixes for effects processing or moni-
toring (including headphone or “cue” mixes)

• Mix submixes with Master Faders

Monitoring and Mixing Audio 
with Auxiliary Input Tracks
Use Auxiliary Input tracks to monitor and mix 
audio from external sources, such as MIDI in-
struments, tape, or microphone inputs, in a 
Pro Tools mix.

To use an Auxiliary Input track to monitor and mix 
external audio sources:

1  Connect the audio outputs of your audio 
source (such as a MIDI synthesizer or tape out-
put) to available inputs on your Pro Tools audio 
interface. 

2  If necessary, configure the I/O Setup dialog for 
the input paths you plan to use (see Chapter 7, 
“I/O Setup.”)

3  Use an existing or create a new Auxiliary Input 
track with a channel format that corresponds to 
the channel format of your audio source (mono, 
stereo, or multichannel).

4  Set the input of the Auxiliary Input track to the 
corresponding input path.

5  Assign the track output to the appropriate path 
or paths for monitoring.

6  Adjust the Auxiliary Input fader to mix the au-
dio input. 
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Monitoring and Mixing Audio 
with Instrument Tracks
Use Instrument tracks to monitor and mix audio 
from instrument plug-ins or external MIDI in-
struments in a Pro Tools mix.

To use an Instrument track to monitor and mix the 
output of an instrument plug-in:

1  Use an existing or create a new Instrument 
track.

2  Choose View > Mix Window > Instruments to 
show the MIDI controls of the Instrument track. 

3  Select an instrument plug-in from the first In-
sert selector on the Instrument track (such as 
Xpand2).

Instrument track configured to control and monitor an 
instrument plug-in (Xpand2 shown)

MIDI Output selector
MIDI Volume control

Audio Input selector
Audio Output

MIDI Pan control

Instrument plug-in

selector
(set to no input)

MIDI Input selector MIDI Mute

MIDI Velocity meter



4  The virtual MIDI node (port) for the instru-
ment plug-in should be automatically selected 
for the Instrument track’s MIDI Output. If not, 
select the MIDI channel and corresponding port 
for the instrument plug-in from the MIDI Out-
put selector.

5  Assign the track audio output to the appropri-
ate path or paths for monitoring.

6  Adjust the Instrument track fader to mix the 
audio input. 

7  If you are controlling the Instrument plug-in 
from the Instrument track, you can also mix us-
ing the MIDI Volume and Pan controls in the In-
strument View.

To use an Instrument track to monitor and mix 
audio from an external MIDI instrument:

1  Connect the audio outputs of your external 
MIDI instrument (such as a MIDI synthesizer) to 
available inputs on your Pro Tools audio inter-
face. 

2  If necessary, configure the I/O Setup dialog for 
the input paths you plan to use (see Chapter 7, 
“I/O Setup.”)

3  Connect the MIDI input and output of your ex-
ternal MIDI instrument to available MIDI input 
and output ports on your MIDI interface.

4  If necessary, configure the MIDI Studio Setup 
(Setup > MIDI > MIDI Studio). 

5  Use an existing or create a new Instrument 
track with a channel format that corresponds to 
the channel format of your audio source (mono, 
stereo, or multichannel).

6  Choose View > Mix Window > Instruments to 
show the MIDI controls of the Instrument track. 

For information on configuring audio and 
MIDI signal routing for controlling and 
monitoring ReWire client applications, see 
the Audio Plug-Ins Guide.
7  Set the audio input of the Instrument track to 
the corresponding input path.

8  In the Instrument track’s Instrument View, set 
the MIDI output to the corresponding MIDI port 
connected to the MIDI input of your external 
MIDI instrument.

9  Assign the track output to the appropriate path 
or paths for monitoring.

10  Adjust the Instrument track fader to mix the 
audio input. 

11  If you are controlling the external MIDI in-
strument from the Instrument track, you can 
also mix using the MIDI Volume and Pan con-
trols in the Instrument View.

Instrument track configured to control and monitor an 
external MIDI instrument (Yamaha TG-77 shown)

MIDI Output selector
MIDI Volume control

Audio Input selector
Audio Output

MIDI Pan control

selector
(set to no input)

MIDI Input selector MIDI Mute

MIDI Velocity meter
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To monitor and mix audio from an Instrument plug-
in with multiple audio outputs:

1  Use an existing or create a new Instrument 
track.

2  Choose View > Mix Window > Instruments to 
show the MIDI controls of the Instrument track. 

3  Select a multi-output instrument plug-in from 
the first Insert selector on the Instrument track 
(such as Transfuser).

4  The virtual MIDI node (port) for the instru-
ment plug-in should be automatically selected 
for the Instrument track’s MIDI Output. If not, 
select the MIDI channel and corresponding port 
for the instrument plug-in.

5  In the plug-in window, assign the individual 
audio outputs of the plug-in.

6  Create an Auxiliary Input track for each output 
of the plug-in. Make sure the channel format of 
the Auxiliary Inputs corresponds to the channel 
format of the plug-in outputs (mono, stereo, or 
multichannel).

7  Set the inputs of the Auxiliary Input tracks to 
receive the individual outputs of the plug-in. 

8  Assign the outputs of the Auxiliary Input 
tracks to the appropriate path or paths for 
monitoring.
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9  Adjust the Auxiliary Input faders to mix the 
individual outputs of the plug-in.

Creating a Submix
A submix is created by routing multiple audio 
sources to a common bus or output path. This 
“submixes” the sources to a single path that can 
be returned to an Auxiliary Input, where the 
submix can be processed with plug-ins or exter-
nal effects processors.

Audio is routed to a submix by assigning any 
combination of sends and track output to avail-
able bus or output paths.

Instrument plug-in with multiple outputs routed to 
Auxiliary Input tracks

When routing mono signals with internal 
mix busses, be sure to use mono busses 
rather than splitting stereo busses. Since 
Pro Tools keeps stereo busses phase aligned, 
splitting stereo busses can result in inaccu-
rate delay compensation.

Instrument plug-in 

Inputs from 
plug-in outputs



Submixing with Track Outputs or Sends 

You can use both track outputs and sends to 
route audio for submixing, depending on 
whether you want a discrete or send and return 
submix. 

Discrete Submix Output
Pro Tools lets you discretely route source audio 
through a submix. This is preferred for dither or 
other mastering processing, where you do not 
want unprocessed audio heard in addition to the 
processed signals. Use track outputs (not sends) 
to assign tracks to a bus path for discrete sub-
mixing. In this arrangement, the balance of pro-
cessed and unprocessed signal is controlled by 
plug-in wet/dry settings.

To create a discrete submix:

1  Set the output of the tracks you want to include 
in the submix to a stereo bus path. 

2  Pan each track.

3  Choose Track > New.

4  Specify the track type (Aux Input) and format 
(stereo), then click Create.

5  Set the input of the Auxiliary Input to the same 
bus path to which you assigned all contributing 
tracks.

6  Set the output of the Auxiliary Input track to 
your main stereo mix outputs (typically, outputs 
1–2). 

7  Set the Auxiliary Input Track level.

8  To process the submix, assign a plug-in or 
hardware insert on the Auxiliary Input. 

9  Set the controls of the plug-in. The plug-in By-
pass and Wet/Dry controls (if available) deter-
mine the amount of effect heard.
The contributing track faders control the bal-
ance within the submix. The Auxiliary Input 
track controls the output levels of all tracks 
routed to it. 

You can apply mix automation to the volume, 
pan, mute, and send level, send pan, and send 
mute controls of the Auxiliary Input.

You can also bounce a submix to disk to free up 
the voices for use by other tracks. See 
Chapter 46, “Mixdown” for more information.

Send and Return Submixing for 
Effects Processing
When you are submixing for reverb, delay, and 
similar effects processing, use sends to achieve 
traditional send/return bussing. You can use a 
real-time plug-in or a hardware insert as a 
shared resource for all tracks included in a sub-
mix. The wet/dry balance in the mix can be con-
trolled using the track faders (dry level) and 
Auxiliary Input fader (effect return, or wet, 
level).

See Chapter 44, “Plug-In and Hardware In-
serts” for more information.
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To create an effects return submix with a plug-in or 
hardware insert:

1  Assign each track’s main output to your main 
mix outputs.

2  On the source tracks, assign a send (mono or 
stereo) and select a mono or stereo bus path 
from the Send selector. Configure the sends for 
pre- or post-fader, as needed.

3  Choose Track > New.

4  Specify the track type (Aux Input) and format 
(stereo), then click Create.

5  From the Auxiliary Input track’s Input Path se-
lector, select the send bus path.

6  Solo safe the track so that if you solo another 
track that uses the effects send, you won’t mute 
the effects return (see “Solo Safe Mode” on 
page 250).

7  Assign a plug-in or hardware insert on the 
Auxiliary Input.

8  Set the effect to “100% wet,” and set any other 
controls.

9  From the Auxiliary Input track’s Output Path 
selector, select an output path (main outputs).

Adjust the individual track faders to balance the 
dry (unprocessed) tracks. With the send set to 
pre-fader, the amount of effect is controlled by 
the level of the Send Level fader or the Auxiliary 
Input Volume fader. If the send is post-fader, 
the Send Level fader follows volume level.
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Send and Return Submixes with 
External Devices

To create an effects return submix with an external 
device:

1  Assign each track’s main output to your main 
mix outputs.

2  Assign a send (mono or stereo) and set the 
send destinations on the source tracks to the 
output path connected to the external device. 
Configure the sends for pre- or post-fader, as 
needed.

3  Choose Track > New.

4  Specify the track type (Aux Input) and format 
(stereo or mono), then click Create.

Send/return setup for a plug-in or hardware insert

Send to effect bus

Input set to send bus path
Output set to main mix outs 

Controls level of dry signal

Controls level of effect return

Effect (plug-in or hardware) 
Insert

Controls level of send 
to effects bus



5  From the Auxiliary Input track’s Input Path se-
lector, select the input path connected to the ex-
ternal device.

6  From the Auxiliary Input track’s Output Path 
selector, select an output path (main outputs).

7  Adjust the individual track faders to balance 
the dry (unprocessed) tracks. 

The amount of effect is controlled by the level of 
the Send Level fader or the Auxiliary Input Vol-
ume fader.

Send/return setup for an external device

Send to external device

Input set to device’s return
Output set to main mix outs 

Controls level of dry signal

Controls level of effect return

Controls level of send 
to external device
Creating Monitor Submixes
Route track sends to one or more Auxiliary In-
put tracks to monitor submixes in a studio envi-
ronment. You can monitor the main mix in the 
control room on one or more pairs of audio out-
puts while you route a submix to another pair of 
audio outputs for a headphone or “cue” mix for 
the “talent.” For example, you may want to pro-
vide the bassist with a submix of the drums and 
their own track for overdubbing a new bass part.

To create a monitor submix:

1  Assign each track’s main output to your main 
mix outputs.

2  Assign a send (mono or stereo) and set the 
send destinations on the source tracks to the 
output path connected to the external device. 
Configure the sends for pre- or post-fader, as 
needed.

3  Choose Track > New.

4  Specify the track type (Aux Input) and format 
(stereo or mono), then click Create.

5  From the Auxiliary Input track’s Output Path 
selector, select the output path (not the main 
outputs) for monitoring the mix. 

With cue mixes, when recording overdubs it 
is recommended that there be no inserts (or 
at least only inserts with very low delays) on 
the record track to avoid any unnecessary 
latency in the monitoring signal path.
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Adjust the Auxiliary Input track fader to control 
the volume for the monitor mix.

Creating a Master Send Level 
Control 
A Master Fader can control the overall level of 
bus and output paths. 

To create a Master send level control:

1  Choose Track > New.

2  Specify the track type (Master Fader), and 
mono, stereo, or any of the supported multi-
channel formats for surround mixing.

3  Click Create.

Drum submix for monitoring
Pro Tools Reference Guide
4  Do one of the following:

• Set the output of the Master Fader to the 
same path that you are using to send to an 
Auxiliary Input track.

• Set the output of the Master Fader to match 
the path that you have chosen for your ef-
fects send.

You can then adjust send levels to balance the 
source tracks, and use the Master Fader as a 
master level control for the entire submix.

Soloing Tracks in a Submix
Soloing any tracks implicitly mutes all other 
tracks, including Auxiliary Inputs. Solo-safing 
an Auxiliary Input prevents this implicit muting 
and lets the Auxiliary Input continue to pass au-
dio when its source tracks are in Solo.

To solo safe an Auxiliary Input:

 Control-click (Windows) or Command-click 
(Mac) the Solo button on the Auxiliary Input 
track.

To solo an individual track that is part of a group:

 Start-click (Windows) or Control-click (Mac) 
the Solo button. 

Generating Stereo Output from 
a Mono Send/Return
You can use an Auxiliary Input to generate a ste-
reo output from a mono send. Set the send des-
tination to a mono Auxiliary Input track and 
place a mono to stereo plug-in on the Auxiliary 
Input. The output of the Auxiliary Input be-
comes stereo. 

To create a “stereo” effect from a mono source, 
you must use reverb, delay, or other time do-
main effects.



Delay Compensation
Pro Tools provides automatic Delay Compensa-
tion for managing DSP and host-based delays 
from plug-in inserts, and mixer routing (bus-
sing and sends). With Delay Compensation en-
abled, Pro Tools maintains phase coherent time 
alignment between tracks that have plug-ins 
with differing delays, tracks with different mix-
ing paths, tracks that are split off and recom-
bined within the mixer, and tracks with hard-
ware inserts.

To maintain phase coherent time alignment, De-
lay Compensation should always be enabled 
during playback and mixing. Delay Compensa-
tion should also be used in most recording situ-
ations.

Enabling Delay Compensation

To enable Delay Compensation:

 Select Options > Delay Compensation.

When Delay Compensation is enabled, the Delay 
Compensation status indicator in the Edit Win-
dow Toolbar is displayed.

Delay Compensation indicator
The Delay Compensation View for tracks can be 
displayed in the Mix Window (see “Delay Com-
pensation View” on page 979).

Configuring Delay 
Compensation Engine
The amount of Delay Compensation available 
for your session is set in the Playback Engine. 
The total amount of delay due to inserts and 
mixer routing for the entire session is displayed 
in the Session Setup window.

There are three settings in the Playback Engine 
dialog to dedicate processing resources for De-
lay Compensation:

None Allocates no resources for Delay Compen-
sation.

Short Provides 1,023 samples at 44.1/48 kHz, 
2,047 samples at 88.2/96 kHz, or 4,094 samples 
at 176.4/192 kHz of Delay Compensation for 
each channel. This is the most efficient setting. 
For sessions with only a few plug-ins that do not 
induce too much DSP and host–based delay, this 
setting should be sufficient.

The Delay Compensation indicator in the 
Edit window turns red if you have any de-
lays in the session that exceeds the maxi-
mum available delay compensation (see 
“Delay that Exceeds the Compensation 
Limit” on page 980).

Red can also indicate that you have created 
a feedback loop that cannot be compensated 
for. For example, if the output of a track is 
routed to the input of the same track. Mouse 
over the Delay Compensation indicator in 
the Edit window to see if the tooltip identi-
fies this as a problem.
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Long Allocates 4,095 samples at 44.1/48 kHz, 
8,191 samples at 88.2/96 kHz, or 16,382 samples 
at 176.4/192 kHz of Delay Compensation for 
each mixer channel. For sessions with a lot of 
plug-ins resulting in a large amount of DSP and 
host–based delay, select this setting.

Maximum Allocates 16,383 samples at 
44.1/48 kHz, 32,767 samples at 88.2/96 kHz, or 
65,534 samples at 176.4/192 kHz of Delay Com-
pensation for each mixer channel. For sessions 
with certain plug-ins that result in more the 
4,000 samples of delay, select this setting. This 
option is unavailable with Pro Tools|HD sys-
tems due to certain limitations with TDM hard-
ware.

To configure the Delay Compensation Engine:

1  Choose Setup > Playback Engine.

2  From the Delay Compensation Engine pop-up 
menu, select a Delay Compensation setting.

3  Click OK.

Delay Compensation Time Mode
Delay values can be specified in either samples 
or milliseconds, as selected with the Delay Com-

pensation Time Mode setting in the Operation 
Preferences page. 

Delay Compensation Limit
The Delay Compensation limit is displayed in 
samples in the Delay Compensation Engine pop-
up menu in the Playback Engine dialog. This is 
the maximum amount of Delay Compensation 
available for the session. This value is different 
depending on the session sample rate and which 
Delay Compensation Engine option is selected.
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System Delay
Pro Tools adds the exact amount of delay to each 
track necessary to make that particular track’s 
delay equal to the total System Delay. The total 
system delay is the longest delay reported on a 
track, plus any additional delay caused by mixer 
routing.

The System Delay is shown in the Session Setup 
window (Session > Setup). Reference the re-
ported System Delay to monitor whether or not 
you are close to exceeding the Delay Compensa-
tion limit.

System Delay in Session Setup window

Pro Tools HD accounts for converter delays 
when using Automatic Delay Compensa-
tion. However, when using non-HD hard-
ware, System Delay only displays internal 
delay and does not take into account any la-
tency incurred by the analog-to-digital 
(ADC) or digital-to-analog (DAC) convert-
ers in your audio interface.



Delay Compensation View
The Delay Compensation View displays the total 
amount of plug-in (TDM and RTAS) and hard-
ware insert delay (HD only), and the total 
amount of delay that Pro Tools applies to each 
track. You can also apply an offset for track de-
lay on a track-by-track basis. The Delay Com-
pensation View can be shown or hidden in the 
Mix Window.

To view Delay Compensation information: 

 Select View > Mix Window > Delay Compensa-

tion.

Delay Compensation View

Delay Compensation view only shows the in-
sert delay for each track. To view the com-
plete system delay, including mixer delays, 
check the System Delay in the Session Setup 
window (see “System Delay” on page 978).

Track
Compensation 

Delay indicator
User Offset field

indicator 
Delay Compensation View 
Indicators and Field

Delay (dly) Indicator

The Delay (dly) indicator reports the total plug-
in (TDM and RTAS) and hardware insert delay 
on the track. The Delay indicator’s report to 
Pro Tools Delay Compensation Engine can be 
bypassed when Delay Compensation is enabled. 
This is useful for manually time-aligning a track 
when the total delay on a track exceeds the Delay 
Compensation limit. See “Delay that Exceeds the 
Compensation Limit” on page 980.

The display color indicates reported track delay, 
as follows:

Green Indicates that track delay reporting is en-
abled and the track does not exceed the available 
amount of Delay Compensation.

Orange Indicates that this is the track reporting 
the longest plug-in and hardware insert delay in 
the session. 

Red Indicates that the amount of plug-in and 
hardware insert delay on the track exceeds the 
available amount of Delay Compensation (see 
“Delay that Exceeds the Compensation Limit” 
on page 980). 

Gray Track delay report is bypassed.

User Offset (+/–) Field 

This field lets you adjust track delays manually 
while Delay Compensation is enabled. The User 
Offset is added to or subtracted from the 
amount of delay applied by Track Compensa-
tion. The User Offset is useful for the following 
cases:

• For manually time-aligning a track if a 
plug-in is incorrectly reporting its delay.

• For adjusting the timing “feel” of a track.
Chapter 43: Basic Mixing 979



980
To change track delay using the User Offset field:

1  In the Delay Compensation View, click in the 
User Offset edit field.

2  To set your delay value (in samples or millisec-
onds depending on your current preferences), 
do one of the following:

• Enter a positive number (with or without 
the “+” modifier) for a positive delay (later 
in time) or negative number (with the “–” 
modifier) for a negative delay (earlier in 
time). 

• Drag in the User Offset field to scroll to a 
new value. For finer resolution, Control-
drag (Windows) or Command-drag (Mac).

• Press the Up and Down Arrow keys to in-
crease or decrease the numerical values. 

3  Press Enter.

To bypass the user delay:

 Command-Control-click (Mac) or Start-Con-
trol-click (Windows) the User Offset field. The 
user-defined delay appears grayed out and does 
not apply to the track.

Track Compensation (cmp) Indicator 

This indicator shows the amount of Delay Com-
pensation Pro Tools applies to each track. 

The display color indicates the amount of Delay 
Compensation applied, as follows:

Green Track compensation is enabled and the 
track does not exceed the Delay Compensation 
limit. The amount of Delay Compensation 
shown in the indicator is applied to the track.
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Blue (Audio Tracks Only) Indicates that Delay 
Compensation is force-enabled on the track. 
When the track is record-enabled or TrackIn-
put-enabled, Delay Compensation is not sus-
pended and remains enabled (see “Overriding 
Low Latency Monitoring During Recording” on 
page 981).

Red Indicates that the track delay exceeds the 
available amount of Delay Compensation and no 
Delay Compensation is applied to the track (see 
“Delay that Exceeds the Compensation Limit” 
on page 980). 

Gray Indicates that Delay Compensation for the 
track is bypassed and no delay is applied to the 
track.

Delay that Exceeds the 
Compensation Limit
When the total delay on a track exceeds the total 
available amount of available Delay Compensa-
tion (selected in the Playback Engine dialog), no 
Delay Compensation is applied on that track. 
Any audio on that track will no longer be prop-
erly time-aligned and will be out of phase. Both 
the Delay indicator and Track Compensation in-
dicator turn red to show that the track delay ex-
ceeds the Delay Compensation limit. The maxi-
mum available Delay Compensation is applied 
to all other tracks. 

However, you can manually compensate for de-
lay on tracks that exceed the Delay Compensa-
tion limit.



To compensate for delay that exceeds the 
compensation limit, do one of the following:

 If the Delay Compensation Engine setting in 
the Playback Engine is set to Short, change the 
setting to Long.

– or –

 If the Delay Compensation Engine is already 
set to Long, do the following:

• Bypass the reported delay for the track by 
Start-Control-clicking (Windows) or Com-
mand-Control-clicking (Mac) the Delay in-
dicator. The track information is grayed out 
once it is bypassed.

– and –

• Manually nudge any audio data on the track 
earlier by the amount of delay reported in 
the track’s Delay indicator.

Low Latency Monitoring During 
Recording
When an audio track is armed for recording (re-
cord-enabled), TrackInput-enabled, Destruc-
tivePunch-enabled, or punched in, the track’s 
Delay Compensation is automatically suspended 
(and the Track Compensation indicator displays 
0). This reduces monitoring latency on those 
track outputs. When the track is played back 
(with both record-enable and TrackInput dis-
abled) it is correctly time-aligned with the other 
delay-compensated tracks.

Tracks that are not record-enabled still apply 
Delay Compensation. Pro Tools automatically 
compensates for any timing discrepancies be-
tween the recorded material and the delay-com-
pensated mix. 
Overriding Low Latency 
Monitoring During Recording
You can override Low Latency Monitoring Dur-
ing Recording on record-enabled tracks, but this 
may introduce latency in the signal path corre-
sponding to the amount of Delay Compensation. 
This latency may be acceptable depending on 
the recording source. For example, in certain 
“non-performance” workflows, overriding Low 
Latency Monitoring During Recording ensures 
that delay compensation is applied consistently 
regardless of whether a track is record- or 
punch-enabled, or whether Pro Tools is record-
ing or playing back.

To override Low Latency Monitoring During 
Recording on specific record tracks:

 Command-Control-click (Mac) or Control-
Start-click (Windows) the Track Compensation 
indicator. Delay Compensations is applied to the 
track and the Track Compensation indicator dis-
plays in blue.

In certain dubbing workflows you may want 
to cascade bus recordings to multiple tracks. 
In these cases you should be sure to override 
Low Latency Monitoring on the recording 
tracks.

Command-Control-Shift-click (Mac) or 
Control-Start-Shift-click (Windows) the 
Track Compensation indicator to override 
Low Latency Monitoring for all selected 
tracks.

Command-Option-Control-click (Mac) or 
Control-Alt-Start-click (Windows) the 
Track Compensation indicator to override 
Low Latency Monitoring for all tracks. 
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Delay Compensation on 
Auxiliary Inputs
Delay Compensation on Auxiliary Inputs can be 
bypassed to let you monitor outside sources 
(such as the audio tracks of a slaved video deck) 
with minimal latency, while still reporting the 
track’s delay.

To bypass an Auxiliary Input’s Delay 
Compensation:

 Start-Control-click (Windows) or Command-
Control-click (Mac) the Track Compensation in-
dicator. The reported track delay will be zero, 
and will appear grayed out.

Delay Compensation for MIDI
Pro Tools automatically maintains time align-
ment between recorded MIDI events and delay 
compensated playback. 

When Delay Compensation is enabled, a MIDI 
event that is recorded to sound “in time” with 
delay-compensated material actually is re-
corded late by the length of total delay in effect. 
To compensate, MIDI events are shifted back in 
time by the total session delay following each 
MIDI recording pass. MIDI playback after a re-
cord pass with Delay Compensation enabled ac-
counts for the low latency recording path and 
maintains phase coherent time alignment with 
MIDI playback.

When any Instrument or MIDI track is re-
cord enabled, all Instrument and Auxiliary 
Input tracks with Instrument plug-in inserts 
that are configured to receive MIDI in 
Pro Tools are set to low-latency mode. In 
this case, the Delay Compensation indica-
tors for those tracks display 0. 
Pro Tools Reference Guide
Low-Latency Recording with 
Virtual MIDI Instruments and 
Delay Compensation
When a MIDI or Instrument track that is routing 
MIDI data to an instrument plug-in is record-
enabled, Pro Tools automatically suspends De-
lay Compensation through the main outputs of 
the audio track, Auxiliary Input, or Instrument 
track on which the instrument plug-in is in-
serted. This allows for latency-free monitoring 
of the instrument plug-in during recording.

MIDI and Audio Processing Plug-Ins

Some audio processing plug-ins (such as Bruno 
and Reso) and many instrument plug-ins let you 
process audio while allowing MIDI data to con-
trol processing parameters. When you record 
enable a MIDI or Instrument track that is con-
trolling an audio processing plug-in, the track 
the plug-in is inserted on will go into low-la-
tency mode, effectively making the processed 
audio play early. The steps to prevent this and 
keep audio time-aligned depend on the type of 
track on which the plug-in resides. 

To keep audio time-aligned when recording using 
a MIDI controlled plug-in on an audio track:

 Start-Control-click (Windows) or Command-
Control-click (Mac) the Track Compensation in-
dicator for the audio track to apply Delay Com-
pensation. 

Delay Compensation for Instrument plug-ins 
works only when all MIDI and audio connec-
tions take place inside Pro Tools. While 
Pro Tools does not suspend Delay Compensa-
tion when you are using ReWire to connect 
software synthesizers and samplers in other 
ReWire client applications (such as Reason), 
Pro Tools cannot account for any latency 
within the ReWire client itself.



To keep audio time-aligned when recording using 
a MIDI controlled plug-in on an Auxiliary Input:

1  Start-Control-click (Windows) or Command-
Control-click (Mac) the Track Compensation in-
dicator for the Auxiliary Input to bypass Delay 
Compensation.

2  Enter the total system delay into the User Off-
set field.

Configuring Cue Mixes with 
Delay Compensation
If you already have a Pro Tools session that uses 
various plug-in inserts and mixer routing, you 
will most likely want to have Delay Compensa-

tion enabled. However, if you want to record 
overdubs with a recording artist, “the talent,” 
you will need to configure monitoring mixes 
(headphone or “cue” mixes). 

Use sends to bus cue mixes to audio output 
paths for headphone monitoring by the talent. 
In addition to the main mix, which will monitor 
in the control room, route track sends to one or 
more additional audio output paths tracks for 
cue mix monitoring. Using sends lets you con-
figure different mixes from the main mix for cue 
mix monitoring. For example, when recording a 
guitarist, they may want to hear themselves 
more in the cue mix than you will want to hear in 
the main mix.

Example configuration using sends for cue mixes:

1  Assign each track’s main output to your main 
mix outputs.

2  Assign a send (mono or stereo) for each track 
and set the send outputs to output paths 3 and 4 
on your audio interface. 

3  Enable the FMP (Follow Main Pan) button on 
all of the sends so that the cue mix has the same 
panning as the main mix.
4  Set all of the sends to unity and to post-fader. 
This lets you use the same mix for the talent, but 
also lets you boost (or attenuate) the level of the 
talent’s signal in the cue mix by adjusting the 
send level as needed.

5  Choose Track > New.

6  Specify the track type (Main Fader) and format 
(stereo), then click Create.

7  From the Master Fader track’s Output Path se-
lector, select output paths 3 and 4 for monitoring 
the mix. 

8  Adjust the Master Fader track’s fader to con-
trol the overall volume for the cue mix.

9  Repeat the preceding steps for additional cue 
mixes on additional outputs on your audio inter-
face as necessary.

Setting a Hardware Insert Delay 
Offset
You can manually compensate for the delay (la-
tency) of any external hardware devices (such as 
an effects unit) used in your session, you can set 
the amount of Hardware Insert Delay Compen-
sation (in milliseconds) for each external device 
in the I/O Setup. These times will be used by the 
Delay Compensation Engine to time-align input 
paths when the hardware insert is in use and De-
lay Compensation is enabled

With Delay Compensation enabled, it is rec-
ommended that you do not use any inserts 
on any Auxiliary Input or Master Fader 
tracks you may be using to control the cue 
mix volume. Also, you should avoid using 
inserts on any record tracks. (Some low la-
tency inserts may be acceptable depending 
on the talent’s preference.)
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To set an insert delay offset:

1  Choose Setup > I/O.

2  Click the H/W Insert Delay tab.

3  Type a value, in milliseconds, in the field cor-
responding with the input where the hardware 
insert is connected.

Determining Your Hardware’s 
Insert Delay
Check the documentation for your external 
hardware to see if it identifies the hardware la-
tency, or use the following procedure in 
Pro Tools to determine the latency for hardware 
inserts.

To determine your hardware’s insert delay:

1  Ensure that Automatic Delay Compensation is 
enabled (Options > Delay Compensation).

2  Change your session’s Main Time Scale to 
Min:Sec.

3  Create two tracks. 

4  Place a short tone (or other sound with a de-
finitive beginning) on track 1.

5  Insert the HW insert on track 1. 

6  Ensure that only the dry signal is being passed 
through the device. 

7  Bus the output of track 1 to the input of track 
2. 

8  Record enable track 2 and press Record Enable 
and Play in the Transport window to play back 
the audio in track 1 and record it to track 2.

Insert delay offsets only have an effect when 
the I/O is used for hardware inserts.
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9  After recording, zoom in and measure the dif-
ference between where the audio starts in track 1 
and track 2. The difference is the value you 
would enter as your hardware’s insert delay off-
set.

Dither
Dither is used to minimize quantization arti-
facts when reducing the bit depth of an audio 
signal, for example, from 24-bit to 16-bit. Quan-
tization artifacts are most apparent when a sig-
nal is near the low end of its dynamic range, such 
as during a quiet passage or a fade-out.

Dither minimizes quantization artifacts by in-
troducing very low-level random noise to a sig-
nal, which smooths out the distortion that can 
result when the signal’s bit depth is reduced. 

With dither there is a trade-off between signal-
to-noise performance and less-apparent distor-
tion. Proper use of dither lets you get better sub-
jective performance when reducing the bit depth 
of audio. 

Dither in Pro Tools
There are several ways dither can be used in 
Pro Tools. Each has a specific application within 
the various operations that could benefit from 
using dither. 

Dither Plug-Ins for Mixdown Whenever you are 
mixing down or bouncing to disk and your 
destination bit depth is lower than 24-bit, insert 
a dither plug-in on a Master Fader that controls 
the output mix. You can use real-time dither 
plug-ins from Avid or third-party manufactur-
ers. 



For important information on using dither 
when mixing down or bouncing to disk, see 
“Dithering” on page 1082.

AudioSuite Dither Some AudioSuite plug-ins can 
automatically apply dither when processing. 
You can select this option in the Processing 
Preferences page.

The Use AudioSuite Dither option enables a pre-
set, noise-shaped dither for the following 
AudioSuite plug-ins: 

• Gain

• Normalize

• Smack!

• Sonic NoNOISE

Dither in Fades and Crossfades In the Fades di-
alog (Edit > Fades > Create), the Use AudioSuite 

Dither option enables a preset, noise-shaped 
dither. 

Dither on Export and Import When you export 
audio to a lower bit depth, or when you import 
an audio file into a session that is at a lower bit 
depth than the file, a preset, noise-shaped dither 
is applied.

For more information on Dither plug-ins, see 
the Audio Plug-Ins Guide.

For more information on AudioSuite 
Dither, see the Audio Plug-Ins Guide.

For more information on using the Dither in 
fades and crossfades, see “Use Dither” on 
page 620. 

For more information about the application 
of dither on export, see “Exporting Audio” 
on page 345. 

For more information about the application 
of dither on import, see “Bit Depth Conver-
sion and Dithering” on page 334. 
Dithered Mixer Plug-Ins (Pro Tools HD Only) 

Avid has developed a mixer that provides all of 
the benefits of the standard Stereo Mixer and 
Surround Mixer plug-ins, but also provides un-
correlated dither on any summed output. There 
are two Mixer plug-ins that feature dither with 
noise shaping: Stereo Dithered Mixer and Sur-
round Dithered Mixer. 

Noise Shaping
Noise shaping can further improve audio per-
formance and reduce perceived noise inherent 
in dithered audio. Noise shaping uses filtering 
to shift noise away from frequencies in the mid-
dle of the audio spectrum (around 4 kHz), where 
the human ear is most sensitive.

Noise Shaping is available in the Dither and 
POW-r Dither plug-ins. 

For more information on using the Dithered 
Mixer plug-ins, see the Pro Tools|HD 
User Guide.  

For more information on using Noise Shaping, 
see the Audio Plug-Ins Guide.
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Using an Ethernet Control 
Surface with Pro Tools
Avid offers several Ethernet-based control sur-
face options for Pro Tools.

D-Control and D-Command
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

D-Control and D-Command tactile worksur-
faces are part of ICON, a flexible, integrated sys-
tem that extends the functionality of Pro Tools. 

C|24

C|24 is a dedicated control surface that provides 
access to nearly all Pro Tools recording, mixing, 
editing, signal routing, plug-in control, and au-
tomation features. 

EUCON

Pro Tools supports Avid control surfaces using 
EUCON (Extended User Control) control (see 
the Pro Tools EUCON Guide.) EUCON is an inno-
vative high-speed Ethernet protocol developed 
by Avid to allow hardware control surfaces to di-
rectly communicate with software applications 
(such as Pro Tools).
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Enabling an Ethernet Control 
Surface in Pro Tools

To enable an Ethernet control surface in Pro Tools:

1  Choose Setup > Peripherals and click the Ether-

net Controllers tab.

2  Select Enable. 

3  If your Ethernet control surface consists of 
more than one unit, select the units in numerical 
order as you want them arranged left to right. 

4  Click OK.

To enable EUCON control in Pro Tools:

1  Choose Setup >Peripherals.

2  Select the Ethernet Controllers tab.

3  Select the EUCON option.

4  Click OK.

When the EUCON option is selected, Pro Tools 
is enabled for control by one or more EUCON-
compatible controllers.

For more information, see the documentation 
that came with your Ethernet control surface.

For more information about using Pro Tools 
with EUCON, see the Pro Tools EUCON 
Guide.



Using a MIDI Control Surface 
with Pro Tools
MIDI Control Surfaces add hands-on control to 
many Pro Tools functions, allowing you to ad-
just faders and knobs, activate transport con-
trols, or edit plug-in parameters. 

Command|8

Command|8 is a compact USB-based MIDI con-
trol surface for Pro Tools systems. 

Other MIDI Control Surfaces

Pro Tools supports MIDI control surfaces from 
CM Labs (such as MotorMate and MotorMix), 
and Mackie (such as Mackie Control and HUI), 
as well as other control surfaces that support the 
MotorMix and HUI controller personalities.

MIDI Control Surface 
Personalities
MIDI Control Surface Personalities are files that 
allow Pro Tools to communicate with the MIDI 
control surface. When you install Pro Tools, 
these files are installed by default in the Con-
trollers folder inside the Pro Tools application 
folder. If the files are not present, run the 
Pro Tools installer to install the personality 
files.

For complete instructions on connecting 
and configuring Command|8, see the 
Command|8 Guide.
Connecting a MIDI Control 
Surface
If your Pro Tools hardware includes MIDI ports, 
you can connect a MIDI control surface directly 
to your system. If it does not include MIDI 
ports, you will need to use a MIDI Interface, 
such as the MIDI I/O or M-Audio MIDISPORT). 
USB MIDI control surfaces (such as the Com-
mand|8) and FireWire control surfaces (such as 
the 003) do not require an additional MIDI con-
nection to your computer.

To connect a (non-USB or FireWire) MIDI control 
surface:

1  Using a standard 5-pin MIDI cable, connect 
the MIDI Out port on your MIDI control surface 
to the MIDI In port on your Pro Tools hardware 
or MIDI interface.

2  Using a standard 5-pin MIDI cable, connect 
the MIDI In port on your MIDI control surface to 
the MIDI Out port on your Pro Tools hardware 
or MIDI interface.

3  If you have a multi-port MIDI interface, note 
which MIDI port the control surface is con-
nected to.

Configuring Your System for a 
MIDI Control Surface
A MIDI Control Surface is configured in the 
same way as any other MIDI device in Pro Tools, 
using MIDI Studio Setup (Windows) or Audio 
MIDI Setup (Mac).

For complete instructions on configuring 
your MIDI studio, see the User Guide that 
came with your system.
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Enabling a MIDI Control Surface 
in Pro Tools

To enable a MIDI control surface in Pro Tools:

1  Choose Setup > Peripherals and click the MIDI 

Controllers tab.

2  Choose your MIDI control surface device name 
from the Type pop-up menu.

3  Choose the MIDI control surface’s source port 
from the Receive From pop-up menu.

4  Choose a destination port from the Send To 
pop-up menu.

5  If your MIDI control surface has more than 
eight channel strips, or if you are using multiple 
devices of the same type in series, choose the ap-
propriate number of channel strips from the pop 
up menu under #Ch’s.

6  Click OK.

You can configure additional MIDI control sur-
faces (up to a total of four) by repeating the 
above steps. Make sure that none of the control 
surfaces are assigned to the same MIDI source 
and destination ports or channels in the 
Pro Tools Peripherals dialog. 

MIDI control surface (Command|8) enabled
Pro Tools Reference Guide
Enabling the MIDI Control 
Surface as an Input Device
You must ensure that the MIDI control surface 
is enable as an input device in Pro Tools.

To enable a MIDI control surface as an input 
device:

1  Choose Setup > MIDI > Input Devices.

2  Select the source port that you selected in the 
Receive From pop-up menu in the MIDI Control-
lers page of the Peripherals dialog. 

3  Click OK.

If you want to prevent control surface MIDI data 
from reaching Pro Tools, you can deselect its 
source port in the MIDI Input Enable window.

Enabling a MIDI input device
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Pro Tools provides up to ten unity-gain inserts 
on each audio, Auxiliary Input, Master Fader, 
and Instrument track. Audio, Auxiliary Input, 
and Instrument track inserts are pre-fader, and 
Master Faders inserts are post-fader.

An insert can be either a software DSP plug-in or 
a hardware insert. A Pro Tools insert routes the 
signal from the track to a plug-in or external 
hardware effect of your choice and automati-
cally returns it to the same track. Inserts do not 
alter the original audio source files, but process 
audio in real time, during playback. You can 
permanently apply real-time effects to tracks by 
recording or bouncing the effect to disk (see 
Chapter 46, “Mixdown” for more information).

Insert button and selector on a track

Insert button

Insert selector
General Insert Information

When more than one plug-in or hardware insert 
is used on a track, they are processed in series. 
Each effect is added to that of any previous in-
serts (flowing from top to bottom in the Mix 
window Inserts View, and left to right in the 
Edit window Inserts View).

Inserts on audio tracks and Auxiliary Inputs and 
Instrument tracks are pre-fader. You can cause 
clipping if you boost their gain to extremes, es-
pecially on tracks recorded at high amplitude. 
Watch on-screen metering for indication of 
clipping. (Inserts on Master Faders are post-
fader.)

Plug-In Inserts
Plug-In inserts are software inserts that process 
audio material on a track in real time. For exam-
ple, the EQ, compressor, and delay plug-ins sup-
plied with your Pro Tools system can be used as 
real-time plug-in inserts.

Additional real-time plug-ins are available from 
Avid and from many third-party developers. 

For more information about the plug-ins 
included with your Pro Tools system, see the 
Audio Plug-Ins Guides.

For information about optional plug-ins, 
visit www.avid.com.
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Hardware I/O Inserts
Hardware I/O inserts can route audio through 
an external device connected to parallel inputs 
and outputs of an audio interface. You can pro-
cess the audio material on a track with a hard-
ware insert in real time.
 

Insert paths require audio interface inputs and 
outputs, and are determined by the I/O Setup 
configuration of your system.

Using Inserts for Effects 
Processing 
Inserts can be used in two ways: 

On Single Tracks An insert can be applied to an 
individual audio, Auxiliary Input, Master Fader, 
or Instrument track.

With in-line inserts, you control the amount of 
effect by adjusting the balance (or the wet/dry 
mix) controls of the plug-in or external device.

As Shared Resources An insert can be used as a 
shared resource in a send-and-return arrange-
ment, by bussing signals from several tracks to 
an Aux Input, and then applying the insert to 
that track. You can then control the send level 
for each track, and the overall level of the effect 
can be controlled from the Auxiliary Input 
track. Using sends and other signal routing fea-
tures helps maximize your system’s processing 
power. 

Hardware I/O insert

For examples of send and return busses and 
other submixing setups, see “Signal Routing 
for Monitoring and Submixing” on 
page 970. 
Pro Tools Reference Guide
Insert Formats
Mono Inserts Used on mono tracks. Inserts that 
occur on a track after a stereo insert are auto-
matically used in stereo as well.

Stereo Inserts Used on stereo tracks. A stereo 
hardware I/O insert sends the signal to an in-
put/output path.

Mono In/Stereo Out Plug-In Inserts Used to re-
turn a stereo effect from a mono source. Certain 
plug-ins (such as D-Verb) let you generate ste-
reo output from a mono channel. A track made 
into stereo in this way has panning controls for 
each channel of the stereo signal. Any inserts 
that occur on a track after a stereo insert are au-
tomatically used in stereo as well.

Multi-Mono Plug-In Inserts Used on stereo or 
greater-than-stereo multichannel tracks when a 
multichannel version of the plug-in is not avail-
able. Controls for all channels are linked by de-
fault so that you can adjust them in tandem. You 
can unlink controls for independent adjustment 
using the Master Link button. See “Linking and 
Unlinking Controls on Multi-Mono Plug-Ins” on 
page 1017.

Multichannel Plug-In Inserts Used on stereo and 
greater-than-stereo multichannel tracks. On 
greater-than-stereo multichannel tracks, the 
controls for all channels are generally linked to-
gether.

Relinking may cause automation to be lost. 
See “Linking and Unlinking Controls on 
Multi-Mono Plug-Ins” on page 1017



Plug-In Formats
There are four plug-in formats supported by 
Pro Tools (AAX, TDM, RTAS, and AudioSuite), 
three of which can be used as real-time inserts, 
as follows:

TDM Plug-Ins Provide real-time plug-in process-
ing using dedicated DSP processing with 
Pro Tools|HD systems. TDM plug-in files use 
the “.dpm” file suffix.

AAX (Avid Audio Extension) Plug-Ins Provide 
real-time plug-in processing using host-based 
(“Native”) processing. The AAX plug-in format 
also supports AudioSuite non-real-time, file-
based rendered processing. AAX plug-in files 
use the “.aax” file suffix.

RTAS (Real Time Audio Suite) Plug-Ins Provide 
real-time plug-in processing using host-based 
(“Native”) processing. RTAS plug-in files use 
the “.dpm” file suffix.

AudioSuite Plug-Ins Provide non-real-time (ren-
dered), file-based processing plug-ins for 
Pro Tools. AudioSuite plug-in files may use ei-
ther the “.aax” or “.dpm” file suffix.

For information on using AudioSuite plug-
ins in Pro Tools, see Chapter 40, “Audio-
Suite Processing.”
Depending on your Pro Tools software, real-
time plug-ins can be used as follows:

Pro Tools|HD Systems

• TDM, AAX, and RTAS plug-ins can be used on 
audio, Auxiliary Input, Master Fader, and In-
strument tracks.

Pro Tools Host-based Systems

• AAX and RTAS plug-ins can be used on audio, 
Auxiliary Input, Master Fader, and Instrument 
tracks. 

Voice Usage and Total Latency 
for Native (Host-Based) Plug-Ins
(Pro Tools|HD Systems Only)

With Pro Tools|HD systems, the initial insert of 
a host-based, or “Native” plug-in (AAX and 
RTAS) may cause additional latency, and will 
take up two additional voices per channel (one 
voice for input and one voice for output) in the 
following conditions:

• When inserted on an Auxiliary Input or 
Master Fader track 

• When inserted on an Instrument track that 
does not contain an instrument plug-in

• When inserted after a TDM plug-in on any 
kind of track

With Pro Tools|HD systems, Native (AAX 
and RTAS) plug-ins on Auxiliary Input, 
Master Fader, and Instrument tracks use 
additional voices and may introduce extra 
latency based on the HW Buffer Size. See 
“Voice Usage and Total Latency for Native 
(Host-Based) Plug-Ins” on page 991. 

For tips on maximizing Native plug-in per-
formance, see “Configuring Pro Tools Sys-
tem Settings” on page 60.
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For example, the initial insert of a host-based 
plug-in on a mono Auxiliary Input track uses 
two voices (one channel with two voices), while 
the initial insert of that plug-in on a stereo Aux-
iliary Input track uses four voices (two channels 
with two voices each).

Subsequent host-based plug-ins on the same 
track do not take up additional voices unless a 
TDM plug-in is inserted between other 
host-based plug-ins. 

Audio tracks that have active host-based plug-in 
inserts cannot be explicitly voiced. The voice al-
location must be set to Dynamic or Off.

Furthermore, one additional voice is used for 
each occurrence of any of the following condi-
tions when using voices for host-based plug-ins 
on a track:

• When you use the external key side-chain 
of a host-based plug-in on that track

• When you select multiple track outputs for 
that track (one voice used for each output)

• When you select an AFL/PFL Path output in 
the Output tab of the I/O Setup dialog (one 
voice used for each channel)

Avoid inserting TDM plug-ins between host-
based (“Native”) plug-ins on any kind of 
track—this causes unnecessary voice usage 
and may cause additional latency.
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Viewing Inserts 
Both the Mix and Edit windows can be config-
ured to show or hide inserts A–E and F–J. Plug-
In windows provide complete access to plug-in 
controls. 

To show (or hide) inserts, do one of the following:

 In the Mix window (or Edit window), select 
View > Mix Window (or Edit Window) > Inserts 

A–E or Inserts F–J.

– or –

 Select Inserts A–E or Inserts F–J from the Edit 
Window or Mix Window View selector.

inserts and Sends in the Mix window

Inserts (A–E) View

Sends (A–E) View

I/O View

Sends (F–J) View

Inserts (F–J) View



Display of Plug-In Window 
Status
In the Mix and Edit window, the plug-in button 
and selector display the currently inserted plug-
in, its bypass state (see “Bypassing Plug-Ins” on 
page 1016), focus status, and window status.

Indicating the Controller Focus

For most control surfaces, only one plug-in can 
be focused at a time. ICON worksurfaces can 
have up to four plug-ins focused at once (using 
the EQ and Dynamics controls, and Custom Fad-
ers on your worksurface).

The current controller focus, if any, is indicated 
with a color outline around its name:

Lit plug-in name indicates open plug-in window

Controller focus
Making Inserts Inactive
Plug-in and hardware inserts can be made inac-
tive to free up their resources for other uses. 
When a plug-in insert is inactive it retains its as-
signment, position, and related automation 
playlists. However, it will not pass audio and 
does not consume any DSP or TDM resources.

When opening sessions, inserts will automati-
cally be made inactive in any of the following 
situations:

• The system has insufficient DSP resources.

• A plug-in is not installed.

• A plug-in type is not available (AAX, RTAS, or 
TDM). 

• Opening the session results in plug-in type 
substitutions. This can happen if the type is 
available but substituting would result in an 
unsupported condition, such as opening a ses-
sion containing a TDM plug-in for which an 
AAX or RTAS version is unavailable.

To make an insert inactive, do one of the following:

 Control-Start-click (Windows) or Command-
Control-click (Mac) the Insert button.

 Right-click the Insert button and select Make 

Inactive.

 Make the track inactive. See “Making Tracks 
Inactive” on page 251.

To toggle inserts in the same position on all tracks 
active or inactive:

 Control-Start-Alt click (Windows) or Com-
mand-Control-Option click (Mac) an Insert but-
ton in the position you want to toggle.
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To toggle inserts in the same position on all 
selected tracks active or inactive:

 Control-Start-Alt-Shift-click (Windows) or 
Command-Control-Option-Shift-click (Mac) an 
Insert button in the position you want to toggle.

Inactive Plug-In Inserts 

Inactive plug-in inserts retain all associated au-
tomation playlists. In addition, any edits made 
in the session affect the plug-in automation 
playlists. You cannot record automation or ad-
just the controls for an inactive plug-in. 

Inactive Hardware Inserts

Inactive hardware inserts retain their assign-
ments, but do not pass audio and do not con-
sume any DSP resources.

Display of inactive plug-ins

Display of inactive Plug-In window

Hardware inserts do not provide a bypass 
control. You can use the inactive feature 
whenever you need to mute or bypass a 
hardware insert. 

(italicized)
Active 
(plain text)

Inactive 
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Inserting Plug-Ins on Tracks
To use a real-time plug-in, insert it on a track. 

To insert a plug-in on a track:

1  Make sure the Inserts (A–E or F–J) View is 
shown in the Mix or Edit window.

2  Click the Insert selector on the track and select 
the plug-in that you want to use. (See “Plug-In 
Formats” on page 991 for related information.)

To remove an insert from a track:

 Click the Insert selector and choose No Insert.

Plug-Ins cannot be inserted or removed dur-
ing recording.

Inserting a DSP plug-in

You can insert a plug-in on a track by drag-
ging one of its Plug-In Settings (.txf) files 
from a DigiBase browser onto an available 
track Insert position in the Mix window. See 
“Dragging and Dropping Plug-In Settings 
Files” on page 1009. 



Ordering Native and DSP 
Plug-Ins on Audio Tracks
(Pro Tools|HD Systems Only)

With Pro Tools|HD systems, when Native (AAX 
and RTAS) and DSP (TDM) plug-ins are com-
bined on an audio track, Auxiliary Input, or 
Master Fader, the order in which they are in-
serted produces different results:

Native Plug-Ins Grouped Before DSP 
Plug-Ins No additional voices will be used, and 
no processing latency will occur. Native plug-ins 
will be bypassed when Record Enable or Track-
Input monitoring is enabled for that track. 

Native Plug-Ins Grouped After DSP 
Plug-Ins Each initial insert of an Native plug-in 
after a DSP plug-in on a track will cause process-
ing latency, and will use voices as described in 
“Voice Usage and Total Latency for Native 
(Host-Based) Plug-Ins” on page 991. Native 
plug-ins will stay active while Record Enable or 
TrackInput monitoring is enabled for that track. 

Ordering Recommendations

When combining Native and DSP plug-ins on an 
audio track, use one of the following two strate-
gies based on your recording needs:

• To ensure that Native plug-ins stay active 
when you record enable a track or use Track-
Input monitoring, order all DSP plug-ins be-
fore Native plug-ins.

– or –

• To conserve voices and minimize processing 
latency, order all Native plug-ins before DSP 
plug-ins.

As a rule, always group plug-ins of the same 
type together, especially if inserting Native 
after DSP plug-ins. Otherwise, additional 
voices may be unnecessarily used.
Plug-In Menu Organization
You can customize how plug-in lists (plug-in 
menus) are organized in the Insert selector and 
Plug-In selector. 

Use the Organize Plug-In Menus By setting in the 
Display Preferences page to organize plug-in 
menus in a Flat List (with plug-ins in alphabeti-
cal order), or by Category, Manufacturer, or Cat-

egory and Manufacturer. 

Control Surface Support

Control surfaces with multi-color LCDs (such as 
D-Control) indicate plug-ins as follows:

• Plug-In categories (such as EQ) and plug-in 
manufacturers (such as Aphex) are indi-
cated in yellow (amber) text.

• Specific plug-ins located in the plug-in sub-
folders (such as EQ III in the EQ subfolder) 
are indicated in green text.

Control surfaces with single-color displays 
(such as Command|8) do not indicate plug-in 
view choices. They display contents of a plug-in 
folder as a single list of plug-ins.

“Organize Plug-In Menus By” 
Setting
Flat List Organizes plug-ins in a single list, in al-
phabetical order.

Category Organizes plug-ins by process cate-
gory (such as EQ, Dynamics, and Delay), with 
individual plug-ins listed in the category sub-
menus. Plug-Ins that do not fit into a standard 
category (such as the Signal Generator), or 
third-party plug-ins that have not had a cate-
gory designated by their developers, appear in 
the Other category. Plug-Ins can appear in more 
than one category. 
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Plug in categories include:

• EQ

• Dynamics

• Pitch Shift

• Reverb

• Delay

• Modulation

• Harmonic

• Noise Reduction

• Dither

• Sound Field

• Instrument

• Other

• Effects

The Effects subfolder organizes special effects, 
multi-effect processors, and other plug-ins. All 
plug-ins that specify their plug-in category as an 
“Effects” type will be displayed within the Ef-
fects subfolder.

Plug-Ins organized by category (using the Insert 
selector)

If no plug-ins within a certain category are 
installed on your system, the subfolder 
named for that category will not appear in 
the menu.
Pro Tools Reference Guide
Manufacturer Organizes plug-ins by their manu-
facturer (such as Bomb Factory, Digidesign, and 
Trillium Lane Labs), with individual plug-ins 
listed in the manufacturer submenus. Plug-Ins 
that do not have a Manufacturer defined will ap-
pear in the “Other” manufacturer folder. 

Most Avid-distributed third-party plug-ins will 
be grouped under Digidesign when this option is 
enabled.

Category and Manufacturer Organizes plug-ins 
in two levels of menus. The top menus display 
plug-ins by process category (such as EQ, Dy-
namics, and Delay), with individual plug-ins 
listed in the category submenus. The bottom 
menus display plug-ins by manufacturer (such 
as Bomb Factory, Digidesign, and Trillium Lane 
Labs), with individual plug-ins listed in the 
manufacturer submenus.

To select how plug-ins are organized:

1  Open or create a session. 

2  Choose Setup > Preferences, and click Display.

3  Click the Organize Plug-In Menus By pop-up 
menu, and select one of the view options.

Plug-Ins organized by Manufacturer (using the Insert 
selector)

If no plug-ins by a certain manufacturer are 
installed on your system, the subfolder 
named for that manufacturer will not ap-
pear in the menu.



s

4  Click OK.

The Organize Plug-In Menus By setting is saved 
with Pro Tools preferences (it is not saved with 
the Pro Tools session file).

Default EQ and Dynamics 
Plug-Ins
You can set a default EQ plug-in and Dynamics 
plug-in, which places them at the top of the In-
sert selector pop-up menu on-screen, and first 
in the list of menu choices when assigning in-
serts on ICON worksurfaces.

To set a default plug-in:

1  Choose Setup > Preferences and click Mixing. 

2  Under Setup, choose a plug-in from the Default 

EQ or Default Dynamics pop-up menu.

3  Click OK to close the Preferences window.

Default plug-in display in the Insert selector menu
Plug-In Favorites
To find a plug-in faster, a plug-in can be desig-
nated as a favorite. Favorite plug-ins are shown 
at the top of the plug-in menu. 

When a plug-in becomes a favorite, it is still 
shown in its plug-in category and its name ap-
pears in bold.

To designate a plug-in as a favorite:

 Control-click (Windows) or Command-click 
(Mac) the Insert selector and select a plug-in to 
designate it as a favorite.

To change the status of a plug-in favorite:

 Control-click (Windows) or Command-click 
(Mac) the Insert selector and select a plug-in fa-
vorite that you no longer want designated as a fa-
vorite. 

When selecting the plug-in favorite to change, 
you can select the plug-in from the list of favor-
ites at the top of the plug-in menu, or in its plug-
in category (where the plug-in appears in bold).

Menu display of favorite plug-ins

Favorite plug-in

Plug-In categorie
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Moving and Duplicating 
Plug-In and Hardware Inserts
You can move or duplicate an insert by dragging 
it to a different position on the same track or a 
different track. Inserts that are moved or dupli-
cated retain their original settings and automa-
tion.

To move an insert:

 Drag the insert to a new insert location.

To duplicate an insert:

 Alt-drag (Windows) or Option-drag (Mac) the 
insert to a new insert location. Duplicated plug-
in inserts retain their original settings and auto-
mation.

Plug-ins cannot be moved or duplicated 
during recording.

Moving a plug-in

Dragging an insert on top of an existing in-
sert will replace it and any automation.

You can also duplicate Sends. See “Moving 
or Copying Sends” on page 962
Pro Tools Reference Guide
The Plug-In Window
The Plug-In window appears whenever you click 
a plug-in’s Insert button on a track. This float-
ing window lets you edit the adjust the controls 
of any real-time plug-in insert in use on a track.

Insert button and selector on a track

Plug-In window (mono 1-Band EQ III shown)

Insert button

Insert selector

Target 
button

Effect 
Bypass

Automation Safe

Auto button

Convert 
plug-in

Clip 
LED

Plug-In Mapping
controls

Track
controls

Preset 
controls



Track Controls in the Plug-In 
Window

Track Selector Accesses any track in the session 
except MIDI, VCA, and Video tracks.

Insert Position Selector Accesses any insert on 
the current track.

Plug-In Selector Lets you select any real-time 
plug-in installed in the Plug-Ins folder (that is 
created when you install Pro Tools).

Key Input Selector Lets you select audio on a 
particular input or bus and route it to trigger the 
plug-in. This selector only appears on plug-ins 
that feature side-chain processing. Key inputs 
are monophonic.

Track controls in the plug-in window

Key Input selector (Dyn III Compressor/Limiter shown)

Track selector

Insert Position selector

Plug-In selector
MIDI Node Display Shows MIDI node informa-
tion for MIDI-enabled plug-ins. MIDI nodes are 
virtual connections from Pro Tools to software 
instruments and other MIDI-enabled plug-ins. 
MIDI nodes are useful for routing multiple 
MIDI tracks to different channels of a single vir-
tual MIDI device. MIDI node numbers are also 
displayed in a track’s MIDI Output selector. The 
MIDI node indicator only appears in plug-ins 
that can receive MIDI.

Preset Controls in the Plug-In Window

Plug-In Settings Menu Lets you copy, paste, 
save, and import plug-in settings.

Plug-In Librarian Menu Recalls plug-in presets 
(plug-in settings files saved in the plug-in’s root 
settings folder or in the current session’s Set-
tings folder). See “Plug-In Presets” on 
page 1005.

MIDI Node Display indicator (Transfuser shown)

Preset controls in the plug-in window

Plug-In Settings menu

Plug-In Librarian menu

Compare button

Next Setting
Previous Setting

Settings Select
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Next (+) and Previous (–) Setting Buttons Let 
you select the next or previous preset from the 
Librarian menu.

Plug-In Settings Select Button Accesses the 
Plug-In Settings dialog, which lists the presets 
for the selected plug-in. From this list, you can 
audition and select plug-in presets.

Compare Toggles between the original saved 
plug-in settings and any changes you have made 
to it so you can compare them.

Automation Controls in the Plug-
In Window

Auto Button Lets you enable individual plug-in 
controls for automation recording. See “Auto-
mating Plug-Ins” on page 1037.

Automation Safe When enabled, prevents exist-
ing plug-in automation from being overwritten.

You will lose the current settings if they are 
not saved before you use the Next and Pre-
vious Setting buttons. Always save your 
plug-in settings as a preset using the Plug-In 
Settings menu.

Automation controls in the plug-in window

Auto button

Automation Safe button
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Plug-In Map Controls in the Plug-
In Window
When a supported control surface is declared in 
Pro Tools, Plug-In Map controls appear in the 
plug-in window. 

Map Options Menu Lets you create, rename, 
save, delete, import, export, and set default 
plug-in maps. 

Map Presets Menu Lets you choose from avail-
able custom Plug-In Maps for the plug-in. 

Learn Button Puts the plug-in in Learn mode, 
where you can map plug-in parameters to a con-
trol surface. 

Parameter Menu When in Learn mode, lets you 
select a parameter on the plug-in for mapping. If 
you click a parameter in the plug-in window 
while in Learn mode, this menu shows the name 
of the parameter. 

Plug-In Map controls in the plug-in window

Map Options menu

Map Presets menu

Learn button

Parameter menu



Additional Plug-In Controls in 
the Plug-In Window

Effect Bypass Button Disables the currently dis-
played plug-in. This lets you compare the track 
with and without the effect.

Convert Plug-In Selector Lets you convert the 
insert from a DSP plug-in to a Native plug-in of 
the same type (or vice-versa). This feature can 
only be used on plug-ins that are available in 
both DSP (TDM) and Native (AAX or RTAS) for-
mats.

Clip LED Lights red to indicate if any meter in a 
plug-in has clipped (not available on all plug-
ins). The Plug-In Clip LED follows Pro Tools 
settings for clip indication. 

Target Button When multiple Plug-In windows 
are open, clicking this button selects that plug-
in as the target for any computer keyboard com-
mands. For more information, see “Targeted 
Windows” on page 969.

Plug-In Map controls in the plug-in window

Plug-In Bypass button

Clip indicator

Target button

Convert Plug-In selector
Multi-Mono Controls in the Plug-
In Window

Master Link Button When enabled, links the 
controls on all channels of a multi-mono plug-in 
so that they can be adjusted in tandem.

Link Enable Buttons Let you selectively link or 
unlink the controls of specific channels of a 
multi-mono plug-in. Each square represents a 
speaker channel. The Master Link button must 
be disabled to use the Link Enable buttons. See 
“Linking and Unlinking Controls on Multi-
Mono Plug-Ins” on page 1017.

Channel Selector Accesses a specific channel 
within a multichannel track for plug-in control 
editing. This menu appears only on multi-mono 
plug-ins inserted on tracks with more than one 
channel. Shift-clicking this selector opens a sep-
arate Plug-In window for each channel of the 
multichannel track on which the plug-in is in-
serted.

Plug-In window (multi-mono 1-Band EQ shown)

Channel Selector

Link Enable buttons

Master Link button
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Opening Plug-In Windows
To open a plug-in window:

 Click the plug-in button in Inserts view in the 
Mix or Edit window.

By default, each plug-in you open will appear in 
the same location as a currently open plug-in, 
replacing it in the same window location. 

Opening Multiple Plug-In 
Windows
Pro Tools normally displays a single plug-in 
window from which you can adjust the controls 
of any session plug-in. You can also open addi-
tional Plug-In windows for specific plug-ins. 
Once you begin working with multiple plug-in 
windows, you will need to click the Target but-
ton on the plug-in whose controls you want to 
adjust using keyboard commands.

To open an additional plug-in window:

 In the Mix window, Shift-click the Insert but-
ton of a plug-in. The new plug-in window opens 
untargeted.

To open plug-in windows for each channel of a 
multi-mono plug-in:

 Alt-click (Windows) or Option-click (Mac) the 
Channel selector in the Plug-In window of a 
plug-in insert. 

To close all currently open plug-in windows:

 Alt-click (Windows) or Option-click (Mac) the 
close box of any currently open plug-in window. 
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Using Plug-In Window 
Controls
All plug-ins provide standard Pro Tools con-
trols for track and insert selection, bypass, and 
other controls, in addition to the EQ, dynamics, 
and other processor-specific controls. 

To select a different plug-in on the same track:

 Click the Insert selector and select another 
plug-in from the pop-up menu.

To choose a different track:

 Click the Track selector and select another 
track from the pop-up menu.

Target Window and Settings Shortcuts

When multiple plug-in windows are open, a 
highlighted target indicates the target window. 
Pro Tools keeps a single plug-in target window. 
Opening a new plug-in opens it as the new target 
window, in the same location. In addition, the 
plug-in target window is also the focus of key-
board shortcuts for plug-in settings. 



Editing Plug-In Controls
You can adjust plug-in controls by dragging the 
control’s slider or knob, or by typing a value into 
the control’s text box. For instructions on edit-
ing specific plug-ins, see the plug-in’s documen-
tation.

To adjust a plug-in control:

1  Begin audio playback so that you can hear the 
control changes in real time.

2  Adjust the controls of the plug-in for the effect 
you want.

3  Close the Plug-In window to save the most re-
cent changes.

Editing Plug-In Parameters 
Using a Mouse
You can adjust rotary controls by dragging hor-
izontally or vertically. Parameter values in-
crease as you drag upward or to the right, and 
decrease as you drag downward or to the left.

Keyboard Shortcuts

 For finer adjustments, Control-drag (Win-
dows) or Command-drag (Mac) the control.

 To return a control to its default value, Alt-
click (Windows) or Option-click (Mac) the con-
trol. 

For information about the specific controls 
of each of the plug-ins (installed with 
Pro Tools), see the Audio Plug-Ins Guide. 
Additional free plug-ins (and paid plug-in 
options) that can be installed with 
Pro Tools are also documented in the Audio 
Plug-Ins Guide.
Editing Plug-In Parameters 
Using a Computer Keyboard
You can use your computer keyboard to edit 
plug-in controls.

If multiple Plug-In windows are open, Tab and 
keyboard entry remain focused on the plug-in 
that is the target window.

To change control values with a computer 
keyboard:

1  Click or Navigate to the control text field that 
you want to edit to activate the field. 

2  Change the value by doing one of the follow-
ing.

• To increase a value, press the Up Arrow on 
your keyboard. 

• To decrease a value, press the Down Arrow 
on your keyboard.

• Type the value.

The plug-in target window is the focus of 
keyboard shortcuts for plug-in settings. To 
make a plug-in the target for any computer 
keyboard commands (including key short-
cuts), click the plug-in’s Target button in its 
Plug-In window.

To move forward through the different con-
trol fields, press the Tab key. To move back-
ward, press Shift+Tab.

In fields that support values in kilohertz, 
typing “k” after a number value will multi-
ply the value by 1,000. For example, type 
“8k” to enter a value of 8,000.
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3  Do one of the following to confirm the value:

• Press Enter on the numeric keyboard to in-
put the value and remain in keyboard edit-
ing mode.

– or –

• Press Enter on the alpha keyboard (Win-
dows) or Return (Mac) to enter the value 
and leave keyboard editing mode.

To clear all clip indicators in the session, including 
plug-in clipping:

 Press Alt+C (Windows) or Option+C (Mac).

Plug-In Automation and Safe 
Modes
All real-time plug-ins can be fully automated, 
and support all Pro Tools Automation modes 
(Write, Touch, and Latch, plus Trim). 

The Auto button opens the Plug-In Automation 
dialog, where you can enable individual plug-in 
controls for automation recording (see “Auto-
mating Plug-Ins” on page 1037).

The Safe button engages Automation Safe mode. 
When enabled, existing plug-in automation is 
protected from being overwritten (see “Record 
Safing Plug-In Automation” on page 1039).

Side-Chain Input
The side-chain input is the split-off signal used 
by a plug-in's detector to trigger dynamics pro-
cessing, and is generally drawn internally from 
the input signal. However, some plug-ins let you 
switch between internal and external side-chain 
processing.
Pro Tools Reference Guide
With external side-chain processing, a plug-in's 
detector is triggered by an external signal (such 
as a separate reference track or audio source) 
known as the key input.

A typical use for external side-chain processing 
is to control the dynamics of one audio signal 
using the dynamics of another signal (the key 
input). For example, a kick drum track could be 
used to trigger gating of a bass track to tighten it 
up, or a rhythm guitar track could be used to 
gate a keyboard pad.

Side-Chain Filters

Some plug-ins feature key high-pass and low-
pass filters. These controls let you define a spe-
cific frequency range in the side-chain signal 
with which to trigger the plug-in effect. A com-
mon production technique is to use these con-
trols to filter a drum track so that only specific 
high frequency sounds (such as a hi-hat) or low 
frequency ones (such a tom or a kick) trigger the 
effect.

Using a Key Input for External 
Side-Chain Processing

To use a key input for external side-chain 
processing:

1  Click the plug-in’s Key Input selector and se-
lect the input or bus carrying the audio you want 
to use to trigger the plug-in.

Selecting a Key Input



2  Click the External Key to activate external 
side-chain processing.

3  Press the Spacebar to begin playback. The 
plug-in uses the input or bus that you chose as a 
key input to trigger its effect.

4  During playback, do any of the following to 
fine-tune key input triggering:

• To hear the audio source you have selected 
to control the key input, enable Side-Chain 
Listen or Key Listen (depending on the 
plug-in). When finished, disable Side-
Chain Listen/Key Listen to resume normal 
plug-in monitoring.

• To filter the key input so that only specific 
frequencies trigger the plug-in, use the fil-
tering controls (if available) to select the 
frequency range.

5  Adjust the plug-in’s Threshold control (if 
available) and other controls as needed.

Plug-In Presets
Pro Tools makes it easy to create your own li-
brary of plug-in settings, or presets. Using the 
Plug-In Settings menu, you can copy, paste, 
save, and import these settings from plug-in to 
plug-in, or from session to session.

Once you create and save settings files to disk 
(and tell Pro Tools where to find them by as-
signing to a root folder) they appear both in the 
Plug-In Librarian menu and in the Plug-In Set-
tings dialog. They also appear as plug-in settings 
files (.txf) in DigiBase browsers.

You can use the Plug-In Settings dialog to 
audition and select plug-in settings (see 
“Plug-In Settings Dialog” on page 1008).
Plug-In Settings Menu
Use the Plug-In Settings menu commands to 
save, copy, paste, and manage plug-in settings 
as presets (plug-in settings files).

Plug-In Settings menu commands include:

Save Settings Saves the current settings. This 
command overwrites any previous version of the 
preset.

Save Settings As Saves the current settings as a 
new preset under a different name.

Copy Settings Copies the current plug-in set-
tings. You can then apply these settings to the 
same type of plug-in on a different track by 
choosing the track in the Plug-In window and 
pasting the settings with the Paste Settings com-
mand.

Paste Settings Pastes plug-in settings copied 
with the Copy Settings command.

Import Settings Imports a plug-in settings file 
(.tfx) from a location other than the Root Set-
tings folder or Session folder. 

Delete Current Settings File Permanently deletes 
the current plug-in settings file (.tfx) from disk.

Lock Settings File Prevents the current preset 
from being overwritten by the Save command. 
If you attempt to save any changes to the plug-in 
settings, you will be prompted to save them us-
ing a different name or disk location.

Plug-In Settings menu
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Set As User Default Defines the current preset 
as the User Default for the selected plug-in.

Settings Preferences
The Settings Preferences submenu provides 
commands for configuring preferences for sav-
ing and importing presets. They include:

Set Plug-In Default To Sets the default preset to 
either Factory Default (the standard default set-
ting for that plug-in) or User Default (your cus-
tom setting).

Save Plug-In Settings To Selects the folder 
where presets (plug-in settings files) are saved. 
If you select Session Folder, the settings are 
saved in a folder named “Plug-In Settings” 
within the current Session folder. If you select 
Root Settings Folder, the settings are saved in the 
folder you specified with the Set Root Settings 

Folder command.

Set Root Settings Folder Selects a location or 
root folder for saving and importing presets. 
This root settings folder must be named “Plug-
In Settings.” Use this command only if you want 
to choose a location other than the default Plug-
In Settings folder.

The default location for the Root Plug-In Set-
tings folder is as follows:

Windows Program Files\Common Files\
Digidesign\DAE\Plug-In Settings

Mac Library/Application Support/
Digidesign/Plug-In Settings 

To save plug-in settings to any location 
other than the default Plug-In Settings 
folder, you must first create a folder named 
“Plug-In Settings” in the new location and 
then save to that folder.
Pro Tools Reference Guide
Choosing a Destination for 
Settings
Before you save plug-in settings, select their 
destination folder.

To select a destination folder: 

 From the Plug-In Settings menu, choose Set-

tings Preferences > Save Plug-In Settings To, and 
select Session Folder or Root Settings Folder.

If you selected Root Settings Folder, Pro Tools 
saves to the default Root Plug-In Settings folder 
unless you have specified a different location for 
the Root Settings folder.

To select a different Root Settings folder:

1  From the Plug-In Settings menu, choose Set-

tings Preferences > Set Root Settings Folder.

2  Select the folder you want to use as your Root 
folder and click Select. 

Creating Subfolders for Settings
To make it easier to find specific types of set-
tings, you can subdivide settings files by creat-
ing subfolders for them.

To create a settings subfolder:

1  From the Plug-In Settings menu, choose Save 

Settings.

2  Click the New Folder button and type a name 
for the subfolder.

3  Name the preset and click Save. The plug-in 
settings file is saved within the subfolder. 



Managing Presets
Use the Plug-In Settings menu to manage plug-
in presets.

To save a preset: 

1  Choose Save Settings from the Plug-In Set-
tings menu.

2  Type a name and click OK. The setting appears 
in the Plug-In Librarian menu.

To load a plug-in preset:

 Choose the name of the preset from the 
Plug-In Librarian menu.

To import a preset: 

1  Choose Import Settings from the Plug-In Set-
tings menu.

2  Locate the settings file you want to import and 
click Open. Pro Tools loads the setting and cop-
ies it to the root destination folder.

To copy plug-in settings: 

 Choose Copy Settings from the Plug-In Set-
tings menu.

Unlinked multi-mono plug-ins have specific 
rules for settings. See “Linking and Unlink-
ing Controls on Multi-Mono Plug-Ins” on 
page 1017.

Press Control+Shift+S (Windows) or Com-
mand+Shift+S (Mac) to save plug-in set-
tings.

Press Control+Shift+C (Windows) or Com-
mand+Shift+C (Mac) to copy plug-in set-
tings.
To paste plug-in settings: 

1  Open the destination plug-in.

2  Choose Paste Settings from the Plug-In Set-
tings menu.

To create a custom User Default preset: 

1  Create and save a plug-in settings file.

2  Select Set As User Default from the Plug-In 
Settings menu. 

To make a plug-in default to your custom preset: 

 From the Plug-In Settings menu, select Set-

tings Preferences > Set Plug-In Default To > User 

Setting.

Changing Presets with the Next 
(+) and Previous (–) Setting 
Buttons
These buttons let you select the next or previous 
preset in the Plug-In Librarian menu.

To change plug-in presets using the +/– buttons:

 Click the Plus (+) or Minus (–) buttons to se-
lect the next or previous preset. The next (or 
previous) preset is enabled, and the Plug-In Li-
brarian menu changes to show the name of the 
new preset.

Press Control+Shift+V (Windows) or Com-
mand+Shift+V (Mac) to paste plug-in set-
tings.

You will lose the current plug-in settings if 
they are not saved before you use the Next 
and Previous Setting buttons. Always save 
your plug-in settings to the selected Root 
Settings folder.
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Editing Settings on Unlinked 
Multi-Mono Plug-Ins
When a multi-mono plug-in is unlinked, im-
porting, copying, pasting, or bypassing settings 
affects only the currently selected channel.

Plug-In Settings Dialog
The Plug-In Settings dialog lists the presets for 
the current plug-in type. From this list, you can 
audition and select presets.

Use the Folder pop-up menu at the top of the 
Plug-In Settings dialog to switch between plug-
in settings subfolders, or root and session set-
tings folders.

The Plug-In Settings dialog includes the 
following:

Folder This pop-up menu lets you switch be-
tween presets located in root or session folders 
(and any available subfolders).

Patch Field This field displays the name of the 
active (highlighted) preset.

Plug-In Settings dialog
Pro Tools Reference Guide
Increment Patch Every X Sec This option lets 
you audition plug-in presets in series by auto-
matically scrolling through them for a specified 
number of seconds.

To change plug-in presets using the Plug-In 
Settings dialog:

1  Click the Settings Select button.

2  Do one of the following:

• Select a preset from the dialog list.

– or –

• Use the Arrow keys to scroll through the 
available presets. 

3  Click Done.

Auditioning Plug-In Presets
When the Plug-In Settings dialog is open, you 
can have Pro Tools automatically scroll through 
and audition the plug-in settings files saved in 
the plug-in’s root settings folder or in the cur-
rent session’s settings folder.

To audition plug-in presets:

1  Click the Settings Select button.

2  From the dialog list, click a preset—the start-
ing point from which you will scroll through the 
settings files.

3  Enter a value for the number of seconds that 
will elapse between each preset change.

4  Select the Increment Setting option.

After the specified number of seconds, 
Pro Tools selects the next preset. 

To switch between plug-in settings subfold-
ers, press Control (Windows) or Command 
(Mac) and use the Up/Down Arrow keys.



5  When you are finished auditioning presets, do 
one of the following:

• Click Done to stop incrementing patches, 
and to close the Plug-In Settings dialog.

– or –

• Deselect the Increment Patch option to stop 
incrementing patches and keep the Plug-In 
Settings dialog open. Then select the preset 
you want and click Done.

DigiBase and Plug-In Settings 
Files
DigiBase browsers recognize plug-ins settings 
files (.txf) as a known Type and lets you drag and 
drop them to Pro Tools plug-in windows and In-
serts. You can also search for plug-in settings by 
type.

Searching for Plug-In Settings 
Files

To search for plug-in settings files:

1  In the Workspace browser, click the Search 
icon.

2  Select Plug-In Settings File from the Kind pop-
up menu.

3  To further narrow your search, type all or part 
of the name of the plug-in settings file you want.

Searching for plug-in settings files
4  Click Search.

5  To sort your search by Plug-In Name or Manu-
facturer, click the corresponding column title.

Dragging and Dropping Plug-In 
Settings Files
You can insert a plug-in with a specific plug-in 
settings file, as well as change plug-in settings of 
inserted plug-ins by dragging and dropping 
plug-in settings files from a DigiBase browser.

Plug-In settings files found in the Workspace browser 
and sorted by Plug-In Name

You can create catalogs of specific plug-in 
settings that you work with frequently to 
streamline your workflow. For more infor-
mation on Catalogs, see “Catalogs” on 
page 323.
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To insert a plug-in by drag and drop:

 Drag a plug-in settings file from a DigiBase 
browser to an Insert in the Mix (or Edit) window.

To change a plug-in preset by drag and drop:

 Drag a plug-in settings file from a DigiBase 
browser to the plug-in window. The plug-in set-
tings file must be for the same plug-in name. For 
example, you cannot replace a 1-Band EQ 3 with 
a plug-in setting for 4-Band EQ 3.

Dragging and dropping a plug-in settings file to an 
Insert

Dragging and dropping a plug-in settings file to a plug-
in
Pro Tools Reference Guide
Plug-In Mapping
Pro Tools lets you customize the arrangement of 
plug-in parameter controls on supported con-
trol surfaces. You can save these customized 
plug-in maps as presets and export them for use 
across different sessions and systems.

Plug-In Learn Mode

Plug-Ins can be put into Learn mode, from 
which any automatable plug-in parameter can 
be mapped to a channel strip encoder, switch, or 
(in Flip mode) fader on the control surface. 

Plug-In Map Presets

A map for a plug-in can be saved and recalled for 
any plug-in of the same type. 

You can save multiple map presets for a single 
plug-in, and switch between maps at any time 
during a session. 

You can also use multiple map presets on differ-
ent instances of a plug-in at the same time. This 
is useful for virtual instrument plug-ins with 
multiple configurations, or for multi-user work-
flows on large systems.

You can set a custom plug-in map to be the de-
fault map for a plug-in, so that the same map is 
used for all default instances of that plug-in.

Plug-In Map Files

Plug-In maps can be exported (as .pim files) for 
use in other sessions and on other systems with 
a similar type of control surface (8-fader sur-
face, 24-fader surface, or ICON surface). 



Control Surface Mapping

When you create a custom plug-in map, its pa-
rameters are arranged in pages that correspond 
to the controls on the control surface. The size 
of a page depends on the type of control surface. 
Each custom plug-in map allows up to 200 pages 
of mapped parameters.

Plug-In mapping is stored according to the fol-
lowing types of control surfaces:

8-Fader Surfaces The following have a page size 
of 8 mappable encoders/switches:

• 003

• Digi 002

• Command|8

• M-Audio Axiom Pro

24-Fader Surfaces The following have a page 
size of 24 mappable encoders/switches:

• C|24

• Control|24
ICON Surfaces The following have a separately 
mappable encoders and switches with the fol-
lowing page sizes:

• D-Control®

• Custom Faders display 6 rows (pages) of 
8 encoders and switches at a time

• Channel strips display 1 column (page) of 6 
encoders and switches at a time

• D-Command

• Custom Faders display 2 rows (pages) of 
8 encoders and switches at a time

• Channel strips display 1 column (page) of 6 
encoders and switches, 2 at a time

Plug-In Mapping is not supported with 
ProControl.

If you import a plug-in map that was cre-
ated on a different type of control surface, it 
will appear as an inactive choice in the Map 
Presets menu.
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Plug-In Map Controls
When a supported control surface is declared in 
Pro Tools, Plug-In Map controls appear in the 
plug-in window. 

Map Options Menu Lets you create, rename, 
save, delete, import, export, and set default 
plug-in maps. 

Map Presets Menu Lets you choose from avail-
able custom Plug-In Maps for the plug-in. 

Learn Button Puts the plug-in in Learn mode, 
where you can map plug-in parameters to a con-
trol surface. 

Parameter Menu When in Learn mode, lets you 
select a parameter on the plug-in for mapping. If 
you click a parameter in the plug-in window 
while in Learn mode, this menu shows the name 
of the parameter. 

Plug-In Map controls can be shown or hidden.

To show (or hide) Plug-In Map controls:

 Select (or deselect) View > Plug-In > Map Con-

trols.

Plug-In Map controls in the plug-in window

Map Options menu

Map Presets menu

Learn button

Parameter menu
Pro Tools Reference Guide
Creating Plug-In Maps
This topic covers creating plug-in maps on the 
following control surfaces:

• C|24

• Control|24

• 003

• Digi 002

• Command|8

Putting a Plug-In into Learn Mode

When you first put a plug-in into Learn mode, a 
new plug-in map is created (with the default 
name “Custom Map”), and the plug-in is focused 
on the control surface, but with a blank page of 
controls, ready for mapping.

Only one plug-in can be in Learn mode at a time.

To put a plug-in into Learn mode, do one of the 
following:

 Click the Learn button in the plug-in window.

– or –

 From the Map Options pop-up menu, choose 
New Map.

To take a plug-in out of Learn mode, do one of the 
following:

 Click the active Learn button in the plug-in 
window. 

 Close the plug-in window.

 Click the Learn button in a different plug-in 
window. 

For details on plug-in mapping for D-Con-
trol and D-Command, see the D-Control 
Guide and D-Command Guide. 



Creating and Editing Plug-In 
Maps

To create a custom map of plug-in parameters:

1  Open the plug-in whose mapping you want to 
customize. 

2  Put the plug-in into Learn mode. The plug-in 
is focused on the control surface, but with a 
blank page of controls, ready for mapping. 

3  In the plug-in window, click the plug-in pa-
rameter you want to map. The parameter name 
appears in the Parameter menu. 

4  On the control surface, do one of the following: 

• Turn the encoder or press the channel Se-
lect switch where you want to map the pa-
rameter. 

– or –

• If the control surface is in Flip mode, move 
the fader or press the channel Select switch 
where you want to map the parameter. 

5  Repeat steps 3-4 for each parameter you want 
to map. 

6  Take the plug-in out of Learn mode.

To change parameter mapping in a plug-in map:

1  Open the plug-in whose custom map you want 
to change.

2  Choose the map you want to change from the 
Map Preset pop-up menu. 

3  Put the plug-in into Learn mode. The plug-in 
is focused on the control surface.

Plug-Ins are automatically taken out of 
Learn mode when moved to a different 
insert position, made inactive, or converted 
between DSP and Native formats. 
4  Do the following for each parameter mapping 
you want to change:

• In the plug-in window, click the new plug-
in parameter you want to map. The param-
eter name appears in the Parameter menu. 

– and –

• On the control surface, page to the encoder 
or switch where you want to change the 
mapping, and turn the encoder or press the 
switch.

5  Take the plug-in out of Learn mode.

To remove parameter mapping from a plug-in map:

1  Open the plug-in whose custom map you want 
to change.

2  Choose the map you want to change from the 
Map Preset pop-up menu. 

3  Put the plug-in into Learn mode. The plug-in 
is focused on the control surface.

4  Do the following for each parameter mapping 
you want to remove:

• Make sure the Parameter menu displays No 

Control. 

– and –

• On the control surface, page to the encoder 
or switch where you want to remove the 
mapping, and turn the encoder or press the 
switch.

5  Take the plug-in out of Learn mode.
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Saving Plug-In Maps
You can save plug-in maps as presets for reuse 
on the same Pro Tools system. 

Plug-In maps are saved as global preferences on 
a Pro Tools system, so they are available to all 
sessions created on the system. 

When you create a map for a plug-in, that map 
becomes available to all other plug-ins of the 
same type and channel format. 

You can also export plug-in maps for use on 
other Pro Tools systems with a similar control 
surface (see “Exporting and Importing Plug-In 
Maps” on page 1016.

To save a copy of a custom plug-in map:

1  Open the plug-in whose map you want to copy.

2  Choose the map you want to copy from the 
Map Presets pop-up menu. 

3  From the Map Options pop-up menu, choose 
Save Map As. 

4  Enter a name for the plug-in map.

5  Click OK. The new copy becomes the active 
plug-in map.

If you want to map the same plug-in in dif-
ferent channel formats (such as mono, ste-
reo and 5.1 surround) you need to create a 
separate plug-in map for each format.
Pro Tools Reference Guide
To rename a custom plug-in map:

1  Open the plug-in whose map you want to re-
name.

2  Choose the map you want to rename from the 
Map Presets pop-up menu. 

3  From the Map Options pop-up menu, choose 
Rename Map. 

4  Enter a new name for the plug-in map.

5  Click OK.

Deleting Plug-In Maps
From the plug-in window, you can delete indi-
vidual plug-in maps. 

You can also delete all custom plug-in maps on 
the system, reverting all plug-ins to their Fac-
tory Default plug-in maps.

To delete a custom plug-in map:

1  Open the plug-in whose map you want to de-
lete.

2  Choose the map you want to delete from the 
Map Presets pop-up menu. 

3  From the Map Options pop-up menu, choose 
Delete Current Map.

4  Click Delete.

To delete all plug-in maps from the system:

1  Open any plug-in in the session. 

2  From the Map Options pop-up menu, choose 
Delete All Maps.

3  Click Delete.

On D-Control and D-Command systems, 
when you delete all plug-in maps, you are 
also deleting all Custom Fader Plug-In map-
pings.



Setting a Custom Plug-In Map as 
the Default Map
You can set a custom plug-in map as the default 
map for a plug-in, instead of the Factory Default 
map.

When you set a custom plug-in map as the de-
fault, it applies across the entire session. All in-
stances of that plug-in that were set to the Fac-
tory Default map, or to another custom default 
map, change to the new default.

If you change parameter mapping in the custom 
plug-in map that has been set as the default, the 
changes will propagate to all instances of the 
plug-in using that default.

How Default Plug-In Map Settings are Stored

Default map settings are stored as global (sys-
tem-wide) Pro Tools preferences, so they are ap-
plied to all sessions that you subsequently open 
or create on that system.

When you export a plug-in map, the default 
map setting for that plug-in is also exported. 
When that map is imported, the default set-
ting is also updated, and all instances of the 
plug-in change to the new default. 

If you plan to work with the same plug-in 
mapping on multiple sessions, back up your 
settings by exporting all plug-in maps on a 
regular basis and saving the .pim file with 
your sessions.
To set a custom plug-in map as the default plug-in 
map:

1  Open the plug-in whose default plug-in map 
you want to change.

2  Choose the map you want to use as the new de-
fault from the Map Presets pop-up menu. 

3  From the Map Options pop-up menu, choose 
Set As Default.

Hiding Default Plug-In Map 
Pages
When you create a custom plug-in map, its pa-
rameters are arranged in pages that correspond 
to the groups of controls that appear on a con-
trol surface. 

When you page through the controls for a plug-
in on a control surface, the pages for custom 
plug-in maps appear first, and the pages for the 
Factory Default map appear after the custom 
pages.

You can hide the Factory Default pages of a 
plug-in, so that only the custom pages appear on 
the control surface. This applies to all instances 
of the plug-in. 

To hide the Factory Default pages of a plug-in map:

1  Open the plug-in whose default plug-in map 
pages you want to hide.

2  From the Map Options pop-up menu, choose 
Hide Factory Default Pages.
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Exporting and Importing Plug-In 
Maps
Plug-In maps can be exported as .pim files for 
use on other Pro Tools systems. 

When exporting plug-in maps, you can choose 
to save individual map files for each plug-in, or 
a single map file containing all the plug-in maps 
for the system. 

To export an individual plug-in map:

1  Open the plug-in whose map you want to ex-
port.

2  Choose the map you want to export from the 
Map Presets pop-up menu. 

3  From the Map Options pop-up menu, choose 
Export Current Plug-In Map.

4  Choose a location for the map file.

5  Click Save. 

To export all plug-in maps in the system to a single 
map file:

1  Open any plug-in in the session. 

2  From the Map Options pop-up menu, choose 
Export All Plug-In Maps.

3  Choose a location for the map file.

4  Click Save. 

On D-Control and D-Command systems, 
when you export all plug-in maps, you are 
also exporting Custom Fader Plug-In map-
ping to the same file. For more information, 
see the D-Control Guide or D-Command 
Guide.
Pro Tools Reference Guide
To import a map file:

1  Open the plug-in where you want to import a 
plug-in map.

2  From the Map Options pop-up menu, choose 
Import Plug-In Maps From File.

3  Locate the plug-in map (.pim) file you want to 
import. 

4  Click Open.

Bypassing Plug-Ins
Plug-Ins can be bypassed from their Plug-In 
window, or from the Mix and Edit window In-
serts View. 

To bypass a plug-in, do one of the following:

 Click the Plug-In window’s Effect Bypass but-
ton.

– or –

 Control-click (Windows) or Command-click 
(Mac) the plug-in’s Insert button in the Mix or 
Edit window. 

When a plug-in is bypassed, its Insert button 
turns blue. If only some of the channels of a 
multi-mono plug-in are bypassed, its Insert but-
ton turns purple.

Indication of bypassed plug-in state

bypassed (blue) not bypassed



Linking and Unlinking 
Controls on Multi-Mono 
Plug-Ins
When a multi-mono plug-in is used on a stereo 
track or greater-than-stereo multichannel track 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only), the controls are 
linked by default. Adjusting the Gain control on 
one channel, for example, will adjust it for all 
channels.

You can unlink multi-mono plug-in controls on 
specific channels of a track and edit them inde-
pendently. You can also selectively link the con-
trols of specific channels.

To unlink controls on a multi-mono plug-in:

 Deselect the Master Link button.

To access controls for a specific channel:

 Select the channel from the Channel selector.

To link the controls of specific channels:

1  Deselect the Master Link button if it is not al-
ready deselected.

2  Click the Link Enable buttons for the channels 
whose controls you want to link. 

Channel selector and Link controls (shown with Link 
disabled)

All channels linked except the LFE

Channel Selector

Link Enable buttons

Master Link button
Using Hardware Inserts
You can connect external devices, such as reverb 
or effects processors, to your Pro Tools system 
and use them as hardware inserts on individual 
tracks or on submixes.

Pro Tools inserts utilize corresponding hard-
ware input and output channels to send and re-
turn the audio. Inserts can be defined, and their 
channels mapped to audio interface channels on 
the Insert page in the I/O Setup dialog. 

If you plan to use a device as an insert, be sure to 
connect the device to matching inputs and out-
puts on your system. For example, a hardware 
insert being supplied by outputs 7–8 needs to be 
returned to hardware inputs 7–8. 

To define a hardware insert:

1  Choose Setup > I/O, then click the Insert tab. 

2  Select an insert path, or click New Path to cre-
ate a new Insert path.

3  Double-click the Path Name to enter a custom 
path name for the insert.

4  Make sure the insert path is set to the correct 
format (mono, stereo, or other).

5  Map inserts in the Channel Grid as needed. In-
sert and Output paths have special rules regard-
ing channel mapping (see “Valid Paths and 
Requirements” on page 109).

Delay Compensation can be applied to 
Hardware Inserts. See “H/W Insert Delay 
(Compensation) Page” on page 90.
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Assigning Hardware Inserts

To assign an external hardware insert to a track:

 Select an insert from the track Insert selector. 

Bypassing Hardware Inserts
Hardware inserts do not provide a bypass con-
trol. To monitor playback without a hardware 
insert, either set it to Inactive, remove it by re-
assigning it to No Insert, or use a bypass switch 
on the hardware device itself. (See “Making In-
serts Inactive” on page 993 for more informa-
tion.)

Selecting a hardware I/O insert

Hardware Insert window
Pro Tools Reference Guide
Connecting and Integrating 
External Devices
Pro Tools can create dedicated connections to 
external analog or digital devices. The number 
and type of connections depends on what kind 
of system you have.

To connect an external device to a Pro Tools 
system: 

1  Connect an unused output (or pair of outputs 
for a stereo device) of your Pro Tools system to 
an input of the external signal processor.

2  Connect the output of the external signal pro-
cessor to an unused input (or pair of inputs for a 
stereo device) of your Pro Tools system.

3  Define what physical ports are routed to 
Pro Tools input and output ports, as appropri-
ate, in either the Hardware Setup dialog or 
I/O Setup dialog.

4  Define output, input, or insert paths as appro-
priate in the I/O Setup dialog. 

If you plan to use a device as an insert, be sure to 
connect the device to matching inputs and out-
puts on your system. For example, to use out-
puts 7–8, the insert has to use inputs 7–8 also. 

For additional information on connecting 
external devices, see the User Guide that 
came with your system.



Connecting Effects Units 
Digitally
If you want to use the digital inputs and outputs 
on your Pro Tools system as effects sends and 
returns to a digital effects device, Pro Tools 
should be the clock master in most cases. Set 
your digital effects device to accept an external 
digital clock so that it synchronizes to 
Pro Tools.

To set up a digital send to an external device for 
Pro Tools|HD and HD Native systems:

1  Choose Setup > Hardware

2  Select the audio interface from the Peripherals 
list (HD I/O, HD OMNI, 192 I/O, 192 Digital I/O, 
96 I/O, or 96i I/O).

3  Select the desired format and clock format, 
and set the appropriate channel pair to Digital.

4  Select Internal from the Clock Source pop-up 
menu.

5  Click OK. 

To set up a digital send to an external device from 
a Pro Tools system with 003, 003 Rack+, 003 Rack, 
Digi 002, or Digi 002 Rack:

1  Choose Setup > Playback Engine and choose 
the peripheral.

2  Do one of the following:

• If the external device is connected to the 
S/PDIF RCA jacks, deselect S/PDIF Mirror-
ing. (When S/PDIF Mirroring is on, digital 
output at the S/PDIF RCA jacks exactly mir-
rors the output of analog Channels 1–2.)

• If the external device is connected to the 
Optical ports, choose a format (most likely 
S/PDIF for an effects device) from the Opti-
cal Format pop-up menu.

3  Choose Internal from the Clock Source pop-up 
menu.
4  Click OK.

5  Optionally, configure the I/O Setup dialog with 
new path names for effects routing. 

Using External Clock Sources 
(for Recording and Monitoring)
When recording or monitoring, Pro Tools can 
synchronize to an external clock source. Options 
for external clock vary according to the type of 
Pro Tools system you are using.

Pro Tools|HD and HD Native Systems

Pro Tools|HD and HD Native systems can re-
ceive external clock through any of the digital 
inputs on any Avid HD audio interface (includ-
ing AES/EBU, S/PDIF, and Optical).

To select an external clock source for 
Pro Tools|HD or HD Native systems:

1  Choose Setup > Hardware.

2  Select the appropriate audio interface in order 
to display its settings in the Main page.

3  If necessary, enable the appropriate Digital 
Format (if you have not already done so, accord-
ing to the instructions in your User Guide or I/O 
Guide).

4  Set the Clock Source to match the type of in-
put.

5  Configure input routing of the digital source, 
using the Input and Output pop-up menus, if 
necessary.

6  Click OK to close the Hardware Setup dialog.

If you set the Optical Format to S/PDIF, 
Pro Tools will watch the Optical port for 
any audio input, and ignore any audio in-
put on the S/PDIF RCA jacks.

For details on audio interface connections, 
see the guide for your audio interface.
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Pro Tools Systems with 003, 003 Rack+, 003 
Rack, Digi 002, or Digi 002 Rack

Pro Tools can receive external clock from the 
Optical input or S/PDIF input.

To select an external clock source for a Pro Tools 
system with 003, 003 Rack+, 003 Rack, Digi 002, 
Digi 002 Rack:

1  Choose Setup > Hardware.

2  Set the Clock Source to match the type of in-
put.

3  If you select Optical, make sure the Optical For-

mat matches the type of optical input you are 
sending to your Pro Tools system. 

Pro Tools Systems with Eleven Rack

Pro Tools can receive external clock from the 
AES/EBU input or S/PDIF input.

To select an external clock source for Eleven 
Rack:

1  Choose Setup > Hardware.

2  Set the Clock Source to match the type of 
input.

If you set the Optical Format to S/PDIF, 
Pro Tools will watch the Optical port for ex-
ternal clock, and ignore any clock input on 
the S/PDIF RCA jacks.
Pro Tools Reference Guide
Pro Tools Systems with Mbox Pro, Mbox 2 Pro, 
Mbox (3rd generation), or Mbox 2

Pro Tools can receive external clock from the 
S/PDIF input on these interfaces.

To select an external clock source from Pro Tools 
with an Mbox Pro, Mbox 2 Pro, Mbox (3rd 
generation), or Mbox 2:

1  Choose Setup > Hardware.

2  Select SPDIF (Windows) or SPDIF/RCA (Mac) 
from the Clock Source pop-up menu. 

3  Click OK.

Your digital input device must be con-
nected and powered on for Pro Tools to 
synchronize to it. If your input device is 
not powered on, leave the Clock Source set 
to Internal.



Chapter 45: Automation
Pro Tools features dynamic automation of mix-
ing controls on each of the track types. You can 
write automation moves and view them in real 
time during playback of your session. You can 
also edit automation data with the same tech-
niques you use to edit audio and MIDI data.

Automation Accuracy with 
Control Surfaces
Control Surfaces D-Control, D-Command, Pro-
Control, C|24, Control|24, and Command|8 con-
trol surfaces (as well as the 003 and Digi 002 in-
tegrated audio and MIDI interfaces with control 
surfaces for Pro Tools) support the automation 
features in Pro Tools. Pro Tools control surfaces 
provide 10-bit resolution, or 1,024 steps of fader 
resolution. Pro Tools interpolates this input to 
24-bit resolution on playback, resulting in ex-
tremely accurate and smooth fader automation.

EUCON Avid control surfaces using EUCON 
provide 12-bit resolution fader and knob con-
trol.

MIDI Control Surfaces Most MIDI control sur-
faces have 7-bit resolution, or 128 steps. 
Pro Tools interpolates this input to 24-bit reso-
lution on playback, resulting in accurate and 
smooth fader automation.

For details on using control surfaces to cre-
ate mix automation, see your control sur-
face guide.
Automation QuickStart
Pro Tools provides many options for recording, 
replacing, and editing automation data. 

The basic steps for automation recording are:

• Enable the automation type that you want to 
record (volume, pan, mute, send level, send 
pan, send mute, or plug-in automation). 

• Put the appropriate tracks in an automation 
writing mode (Write, Touch, or Latch, or a 
Trim mode). 

• If you are automating a plug-in, enable the in-
dividual plug-in controls to be automated.

• Automation Safe any plug-ins, outputs, or 
sends that have existing automation data that 
you want to protect from being overwritten. 

• Begin playback to begin automation record-
ing, and adjust controls as needed. Pro Tools 
remembers all moves performed on enabled 
controls. 

To edit automation once it has been recorded, 
you can:

• Repeat the above steps to write new automa-
tion over the previous data.

• Graphically edit the automation data in the 
Edit window.

• Cut, copy, paste, or delete automation data 
(certain restrictions apply).
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Automation Playlists
Each Pro Tools track contains a single automa-
tion playlist for each automatable parameter.

On audio tracks, these parameters include:

• Volume

• Volume Trim (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

• Pan

• Mute

• Send Level

• Send Level Trim (Pro Tools HD and 
Pro Tools with Complete Production Tool-
kit only)

• Send Pan

• Send Mute

• Plug-In controls

On Auxiliary Input tracks, these parameters in-
clude:

• Volume

• Volume Trim (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

• Mute

• Pan

On Master Faders, these parameters include:

• Volume

• Volume Trim (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only)

• On MIDI tracks, these parameters include:

• MIDI Volume

• MIDI Pan

• MIDI Mute
Pro Tools Reference Guide
On Instrument tracks, these parameters include:

• Volume (audio)

• Volume Trim (audio) (Pro Tools HD and 
Pro Tools with Complete Production Tool-
kit only)

• Mute (audio)

• Pan (audio)

On VCA Master tracks (Pro Tools HD and 
Pro Tools with Complete Production Toolkit 
only), these parameters include:

• Volume

• Volume Trim

• Mute

You can display and edit each of these automat-
able playlists individually from Pro Tools, even 
during playback.

In addition, on MIDI and Instrument tracks you 
can display and edit other continuous MIDI con-
troller data (such as mod wheel, breath control-
ler, foot controller, or sustain) in a similar man-
ner. For more information on editing MIDI 
data, see “Continuous Controller Events” on 
page 697.

Automation Playlists with Audio 
and MIDI Clips
Pro Tools handles audio clips and their automa-
tion playlists differently from MIDI clips and 
their automation playlists.

Audio Tracks

On audio tracks, automation data resides on a 
separate playlist from audio data and clips. Each 
edit playlist on an audio track shares the same 
automation data. 



MIDI and Instrument Tracks

On MIDI tracks and Instrument tracks, all con-
troller automation data except for MIDI Mute 
data, or audio mute (Instrument tracks only), is 
stored in the MIDI clip that contains it. Each 
edit playlist on the track is separate, and repre-
sents a distinct performance, complete with 
controller automation. 

Trim Automation Playlists
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Separate Trim automation playlists are available 
for Volume trim and Send Level trim. Volume 
trim is available on all track types except MIDI 
tracks. Send Level trim is available on audio 
tracks only. 

Each Trim automation playlist shows the posi-
tion of the Trim fader with yellow breakpoint 
automation that can be edited. For more infor-
mation on Trim playlists, see “Trim Mode” on 
page 1026 and “Viewing Automation” on 
page 1030. 

MIDI Mute data is independent of the MIDI 
data in a MIDI clip. This lets you mute play-
back of individual MIDI or Instrument 
tracks in Pro Tools without altering the 
controller data. 
Multiple Edit Playlists and Audio 
Track Automation 
All edit playlists on a single audio track share 
the same automation data. When you record or 
edit automation data in an audio track, the au-
tomation data is stored in the track’s corre-
sponding automation playlist so it can be edited 
with, or independently from, its associated au-
dio clips. 

 When you copy or cut audio data from a track 
while it is in Waveform view, the underlying au-
tomation data is cut or copied with it. 

 If you paste audio data from other locations or 
tracks into an edit playlist, you may change the 
underlying automation data on the track. 

 When you trim clips using Edit > Trim, the un-
derlying automation data remains unchanged. 

Duplicating Tracks for Playlist 
Editing
The Duplicate Track command provides a conve-
nient way to make a working copy of a track to 
experiment with routing, plug-ins, and automa-
tion. This protects the original track and its au-
tomation data from being edited or overwritten. 

MIDI continuous controller data always fol-
lows clip editing, with the exception of 
mute. See “MIDI and Instrument Tracks” on 
page 1023 for more information.

For more information, see “Editing Auto-
mation” on page 1049.

For more information on duplicating tracks 
command, see “Duplicating Tracks” on 
page 225.
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Automation Modes
Automation modes control how a track’s auto-
mation data is written and played back. Each 
track provides an Automation Mode selector for 
selecting the track’s Automation mode.

Off Mode
Off mode turns off automation for all automat-
able parameters:

• Volume

• Pan

• Mute

• Send volume, pan, and mute

• Plug-In controls

• MIDI volume, pan, and mute

In Off mode, automation data for these parame-
ters is ignored during playback. All other MIDI 
controller data is sent. 

Automation can be switched from Off to another 
Automation mode during playback or record.

Read Mode
Read mode plays any automation that was previ-
ously written for a track.

Write Mode
Write mode writes automation from the time 
playback starts to the time it stops, erasing any 
previously written automation for the duration 
of the automation pass. 

AutoMatch can be applied to a Write automa-
tion pass. See “AutoMatch Time” on page 1029.
Pro Tools Reference Guide
“After Write Pass, Switch To” Option

You can set Pro Tools to automatically change to 
Touch mode or Latch mode, or remain in Write 
mode after the completion of an automation 
pass in Write mode.

To set the Automation mode after a Write pass:

1  Choose Setup > Preferences and click Mixing.

2  Under Automation, select an After Write Pass, 

Switch To option (Touch, Latch, or No Change).

3  Click OK to close the Preferences window.

Touch Mode
Touch mode writes automation only while a 
fader or switch is touched or clicked with the 
mouse. When the fader is released, the writing 
of automation stops and the fader returns to any 
previously automated position, at a rate deter-
mined by the AutoMatch and Touch Timeout 
settings. See “Automation Preferences” on 
page 1028.

In Touch mode, certain control surfaces start 
writing automation as soon as you touch them. 
These include touch-sensitive fader controllers, 
such as D-Control, D-Command, ProControl, 
C|24, 003, Digi 002, or Command|8.

With other control surfaces in Touch mode, 
writing of automation does not begin until the 
fader hits the pass-through point, or the previ-
ously automated position. Once you reach the 
pass-through point with the fader, or a non-
touch sensitive rotary control, writing of auto-
mation begins and continues until you stop 
moving the fader.



Latch Mode
Latch mode works in the same way as Touch 
mode, writing automation only if you touch or 
move a control. However, unlike Touch, writing 
of automation continues until you stop playback 
or “punch out” of the automation pass by chang-
ing the Automation mode to Read or Touch.

AutoMatch can be applied to a Latch automation 
pass. See “AutoMatch Time” on page 1029.

Latch mode is particularly useful for automating 
Pan controls and plug-ins on non-touch sensi-
tive rotary controls, since it does not time out 
and revert to its previous position when you re-
lease a control. 

AutoJoin with Latch Mode
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools provides two different methods to re-
sume writing automation on controls that were 
active at the point where the transport stopped:

AutoJoin Lets you automatically resume writing 
automation in Latch mode.

Join Lets you manually resume writing automa-
tion in Latch mode. Join is available only with 
supported control surfaces.

See also “Writing Automation to the Start, 
End, or All of a Track or Selection” on 
page 1060.
To enable AutoJoin from Pro Tools:

1  Choose Window > Automation.

2  Click the AutoJoin button.

AutoJoin Enable button in the Automation window

See your control surface guide for details on 
using Join and AutoJoin with a control surface.
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AutoJoin Indicator

After a Latch automation pass with AutoJoin en-
abled, the AutoJoin indicator appears in the 
Pro Tools Edit window.

The AutoJoin indicator is a vertical line that sig-
nifies the point where the last automation pass 
was stopped, and the point where the “join” will 
automatically occur on all tracks that were writ-
ing during that previous pass. When automation 
writing is resumed from this point, the line dis-
appears.

AutoJoin indicator in the Edit window

To use Join or AutoJoin to resume writing 
on controls that were writing when the 
transport stopped, restart the transport be-
fore the AutoJoin indicator.
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Touch/Latch Mode
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Touch/Latch Automation mode places a track’s 
Volume control in Touch mode and all other au-
tomatable controls in Latch mode. 

In Touch/Latch mode, the Volume control fol-
lows Touch behavior, writing automation when 
touched and returning to previously written lev-
els when released. 

All other controls follow Latch behavior, writing 
automation when touched and continuing until 
playback stops, or until you punch out of writing 
automation.

Trim Mode
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools HD can adjust (or trim) existing track 
volume and send level automation data in real 
time. Pan, mute and plug-in automation cannot 
be trimmed in this manner. Trim mode works in 
combination with the other Automation modes 
(Read, Touch, Latch, Touch/Latch, and Write) 
and is useful when you want to preserve all of 
your volume automation moves, but need to 
make levels a bit louder or softer to balance a 
mix. For more information, see “Trim Automa-
tion Modes” on page 1027.

Selecting Touch/Latch mode



When writing automation in Trim mode, fader 
moves write relative rather than absolute values. 
The existing automation data is changed by the 
amount of increase or decrease (or the delta 
value) indicated by the faders. 

When Trim mode is enabled, non-trimmable 
controls behave in the same manner as in the 
standard Automation modes, with the exception 
of Write/Trim mode, where non-trimmable con-
trols operate as in Touch mode.

Trim Automation Modes
When a track is in a Trim automation mode (ex-
cept for Trim Off) its main Volume faders and 
all Send level faders are displayed in yellow. 
When trimming, a track’s Volume indicator or 
Send Level indicator shows the delta value being 
written rather than the absolute value.

Behavior of the Trim Automation modes also 
depends on the Coalesce Trim Automation pref-
erence setting. See “Coalescing Trim Automa-
tion” on page 1059. 

Trim Off

Trim Off turns off reading and writing of all au-
tomation (main and trim) for a track. All auto-
mation moves are ignored during playback. 
Trim faders are temporarily set to zero when a 
track is set to Trim Off mode.

Depending on the Coalesce Trim Automation 
preference setting, changing a track to Trim Off 
can coalesce Trim automation on that track. See 
“Coalescing Trim Automation” on page 1059. 

Automation can be switched from Trim Off to 
another Automation mode during playback or 
record.
Read Trim

In Read Trim mode, Volume and Send level 
Trim faders are disengaged from the main auto-
mation playlist and follow any existing Trim au-
tomation. You can move a Trim fader during 
playback to audition new trim values, but no au-
tomation is written. When the Trim fader is re-
leased, it returns to any previously written Trim 
automation values.

If a track does not contain Trim automation, you 
can move a Trim fader during playback to audi-
tion new trim values, but no automation is writ-
ten. The Trim fader retains its position until the 
track is removed from Trim mode, or if you 
manually coalesce the Trim level.

When this mode is enabled, non-trimmable con-
trols (all controls other than track volume and 
send level) behave as if they are in regular Read 
mode—no automation data is written.

Touch Trim

In Touch Trim mode, Volume and Send level 
Trim faders are disengaged from the main auto-
mation playlist and follow any existing Trim au-
tomation. When a Trim fader is touched, writing 
of Trim automation begins. When the fader is 
released, writing stops and the fader returns to 
any previously written Trim automation values.

The rate of the fader’s return to previous trim 
values is determined by the AutoMatch Time 
specified in the Automation Preferences page. 
See “AutoMatch Time” on page 1029 for more 
information.

When this mode is enabled, non-trimmable con-
trols (all controls other than track volume and 
send level) behave as if they are in regular Touch 
mode—they follow the previously written auto-
mation until touched. When they are touched, 
their absolute positions are written until the 
control is released or until playback stops. 
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Latch Trim

In Latch Trim mode, Volume and Send level 
Trim faders are disengaged from the main auto-
mation playlist and follow any existing Trim au-
tomation. When a Trim fader is touched, writing 
of Trim automation begins. Writing of Trim au-
tomation continues until playback stops, or un-
til you punch out of writing automation. 

When this mode is enabled, non-trimmable con-
trols (all controls other than track volume and 
send level) behave as if they are in regular Latch 
mode—they follow the previously written auto-
mation until touched. When they are touched, 
their absolute positions are written until play-
back is stopped.

Touch/Latch Trim

In Touch/Latch Trim mode, Volume and Send 
level faders are disengaged from the main auto-
mation playlist and follow any existing Trim au-
tomation. The main Volume Trim fader follows 
Touch Trim behavior, and Send level Trim fad-
ers follow Latch Trim behavior. 

Write Trim

In Write Trim mode, as soon as playback begins, 
writing of Trim automation begins for Volume 
and Send levels, and continues until playback 
stops, or until you punch out of writing automa-
tion.

When Write Trim mode is enabled, non-trim-
mable controls (all controls other than track 
volume and send level) are not in Write mode, 
but behave as if they are in regular Touch mode 
(no automation is written unless a control is 
touched). This is to prevent the controls from 
overwriting all of their automation data on ev-
ery pass in Write Trim mode.
Pro Tools Reference Guide
Automation Preferences
Pro Tools gives you several options for control-
ling the writing and playback of automation 
data.

To display Automation preferences:

 Choose Setup > Preferences and click Mixing.

The “After Write Pass, Switch To” prefer-
ence affects Write Trim mode. After an au-
tomation pass in Write/Trim mode, tracks 
automatically switch to the Trim mode ver-
sion of the setting specified by this prefer-
ence.

Mixing Preferences page

For detailed information on Pro Tools 
Automation preferences, see “Mixing 
Preferences” on page 130.



Send Levels and Trim Mode
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

You can set Pro Tools to exclude Send levels 
from Trim mode, so that only the Main Volume 
goes into Trim when a track is put into Trim 
mode. This gives you more flexibility in setting 
Send levels while in Trim mode.

To exclude Send levels from Trim mode:

1  Choose Setup > Preferences and click Mixing.

2  Under Automation, deselect Include Sends in 

Trim Mode.

3  Click OK.

Smoothing
When you perform automation moves (includ-
ing Trim moves) with a continuous control, 
Pro Tools records the move as a series of very 
small steps, resulting in a staircase pattern with 
many breakpoints. Smoothing intelligently re-
solves this staircase pattern into a single, 
smooth ramp from one breakpoint to the next. 
(Smoothing does not apply to switched controls 
such as mutes or plug-in bypasses.) With 
smoothing enabled, the resulting automation 
data is often a more accurate representation of 
actual automation moves. 

Any uncoalesced automation on a Send will 
still coalesce when the other automation on 
its track is coalesced, even if “Include Sends 
in Trim Mode” is deselected.
Thinning
Thinning automatically reduces the overall 
number of breakpoints in an automation playlist 
(including Trim playlists) in order to improve 
system performance. The amount of thinning 
applied is determined by the Degree of Thinning 
setting in the Automation Preferences page. 
When using high amounts of thinning, the re-
sulting automation may differ noticeably from 
the original automation moves. Thinning only 
applies to audio tracks, and does not affect MIDI 
tracks. For instructions, see “Thinning Automa-
tion” on page 1047.

AutoMatch Time
AutoMatch Time is the amount of time it takes 
for a fader to return (by ramping up or down) to 
the level of automation still on the track as the 
automation pass ends. This time value is set in 
the Automation Preferences page (see “Automa-
tion Preferences” on page 1028).

AutoMatch is automatically applied to all Touch 
mode passes, and can be applied to Latch or 
Write passes.

The AutoMatch Time also determines the rate at 
which delta values written with the Trim will re-
turn to 0 dB (delta value of zero).

The AutoMatch feature works with continuous 
controls (such as Volume or Pan) by ramping 
their values back to previously automated levels. 
There are some stepped controls (for example, 
the EQ type in the 1-band EQ plug-in) that pro-
vide more than two discrete steps over their op-
erational range. AutoMatch has no effect on 
these controls.
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Automation Follows Edit Option
When disabled, automation events are not af-
fected by edits to audio or MIDI notes. When en-
abled, automation events are affected by edits to 
audio or MIDI notes.

To enable or disable Automation Follows Edit, do 
one of the following:

 Select or deselect Options > Automation Follows 

Edit.

– or –

 Click the Automation Follows Edit indicator in 
the Edit window toolbar. The indicator is high-
lighted when enable and not highlighted when it 
is disabled.

Automation Follows Edit indicator in the Edit window
Pro Tools Reference Guide
Automation Safe 
Outputs, sends, and plug-ins can be placed in 
Automation Safe mode. In Automation Safe 
mode, any automation associated with an Out-
put window (such as track or send level, pan-
ning, or mute), or plug-in on that track, is pro-
tected from being overwritten while automating 
other items on that track. 

Automation Safe mode suspends automation re-
cording for the selected track output, send, or 
plug-in that is enabled. You can also suspend 
automation recording and playback session-
wide from the Automation window. See “En-
abling and Suspending Automation” on 
page 1044. 

Viewing Automation
Pro Tools creates a separate playlist in the Edit 
window for each type of automation in a track, 
including a playlist for each type of Trim auto-
mation. This data can be viewed and edited in 
the same way as audio and MIDI data. You can 
either change Track Views to show the automa-
tion you want, or you can reveal an Automation 
lane under the track regardless of its Track 
View.

Automation Safe enabled send

You can easily toggle between different 
Track Views. See “Changing Track Views” 
on page 229.



Track Views
You can view automation data by type by select-
ing the corresponding Track View.

To display an automation playlist in the Track 
View:

 Click the Track View selector and select from 
the automation type you want to view.

Displaying a standard automation playlist

Displaying Trim automation playlists

Trim automation playlist
Automation and Controller 
Lanes
In the Edit window, you can view automation 
and controller data under a track (regardless of 
the selected Track View). Each track provides 
Automation and Controller lanes that let you 
edit track automation and controller data with-
out changing the Track View. You can edit auto-
mation and controller data in lanes exactly the 
same way that you do in different automation 
and controller Track Views.

Automation and Controller lanes can be shown 
or hidden. You can also add and remove lanes. 
These lanes always remain under the track, but 
you can resize and reorder lanes independently 
of one another.

To show or hide Automation lanes under the main 
track view:

 Click the Show/Hide Lanes button.

To add a lane:

 Click the Add Lane button.

To remove lanes:

 Click the Remove Lane button.

Revealing an Automation lane

Automation Type
selector

Show/Hide
Lanes button
Remove Lane

Add Lane
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To change the Automation or Controller type for a 
lane:

 Click the Automation/Controller Type selector 
and select the Automation or Controller type 
you want.

To replace all Automation and Controller lanes 
under the track with a single lane of the specified 
automation or controller type:

1  Right-click the Show/Hide Lanes button.

2  Select the Automation or Controller type you 
want.

Selecting the Automation type for a lane

Right-click menu for selecting a single Automation or 
Controller lane
Pro Tools Reference Guide
To resize the height of all Automation and 
Controller lanes for a track, do one of the 
following:

 Right-click on the vertical zoom scale just to 
the right of the track controls and select the 
height from the pop-up menu.

– or –

 Drag the bottom line of any given Lane Con-
trols column up or down. The cursor changes to 
indicate that you can resize the lane.

To resize the height of a single Automation or 
Controller lane for a track:

 Press Start (Windows) or Control (Mac) while 
selecting the Lane Height setting.

To reorder lanes:

 To reorder lanes on-screen, drag the lane con-
trol section to new positions in the Edit window.

Displaying Trim Automation 
Along with the Main Playlist
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

The appearance of Trim automation depends on 
how it is set to be coalesced. See “Coalescing 
Trim Automation” on page 1059. 

If automation is not set to coalesce after every 
automation pass, you can display Trim automa-
tion data along with the main Volume or Send 
level automation data in the same automation 
view. This Trim automation display cannot be 
directly edited.

Press Start+Up/Down Arrow key (Win-
dows) or Control+Up/Down Arrow key 
(Mac) to increase or decrease height of any 
lane that contains the Edit cursor or an Edit 
selection.



To display the Trim automation playlist along with 
main automation playlist on tracks:

 Select View > Automation > Trim Playlist.

Displaying the Composite 
Automation Playlist
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

If automation is not set to coalesce after every 
automation pass, you can display a composite 
automation playlist that shows the contribution 
of the Trim automation to the main Volume or 
Send Level automation data. This composite 
playlist display cannot be directly edited.

The composite playlist is shown in both the 
main automation playlist and the Trim automa-
tion playlist.

To display the composite playlist: 

 Select View > Automation > Composite Playlist. 

Display of Trim automation in a main Volume playlist 

Display of Trim automation and the composite playlist 
in a main Volume playlist 

Volume
data

Volume
Trim 
data

Volume
data

Volume
Trim 
data

Composite
playlist
AutoMatch Indicators
There are triangular AutoMatch indicators at 
the bottom left of each channel strip in the Mix 
window. When lit, these indicate the direction 
the fader will automatically move when Auto-
Matching. 

Writing Automation
You can write automation for all automatable 
controls by moving those controls during play-
back. 

To write automation on tracks:

1  Choose Window > Automation. 

2  Make sure the automation type is write-en-
abled.

Triangular AutoMatch indicator on a channel strip
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3  In the Mix or Edit window, click the Automa-
tion Mode selector on each of the tracks you 
want to automate, and set the Automation mode. 
For the initial automation pass, select Write.

4  Start playback to begin writing automation.

5  Move the controls you want to automate (such 
as a track volume fader).

6  When you have finished, stop playback.

Automation window

Setting the Automation mode of a track
Pro Tools Reference Guide
After the first automation pass, you can write 
additional automation to the track without com-
pletely erasing the previous pass by choosing 
Touch mode or Latch mode. These modes add 
new automation only when you actually move a 
control. (See “Automation Modes” on 
page 1024.)

To write additional automation to a previous pass:

1  Enable Options > Link Timeline and Edit Selec-

tion.

2  In the Edit window, make a selection or place 
the cursor in the location where you want to 
start writing automation.

3  In the Mix or Edit window, click the Automa-
tion Mode selector on each of the tracks you 
want to automate, and set the Automation mode 
to Touch or Latch mode.

4  Start playback to begin writing automation. 

5  Move the controls you want to automate.

6  When you have finished, stop playback.

If you write automation in Touch mode with 
Loop Playback enabled, writing of automa-
tion will automatically stop at the end of the 
looped selection. At the beginning of each 
successive loop, you can then touch or move 
the control again to write new data.



Storing an Initial Control 
Position
When you create a new audio, Auxiliary Input, 
VCA Master, MIDI, or Instrument track, it is au-
tomatically placed in Read mode. Even though 
the track is in Read mode, you can set the initial 
position of any automatable control, and it is 
saved with your session.

In this initial state, only a single automation 
breakpoint appears at the beginning of each au-
tomation playlist. If you move the control with-
out writing automation, this breakpoint will 
move to the new value.

You can permanently store the initial position 
of an automatable control by doing any of the 
following:

• Place the track in Write mode and press Play 
to write a few seconds of automation data to 
the track

• Manually place a breakpoint on the automa-
tion playlist somewhere after the initial break-
point. (See “Graphical Editing of Automation 
Data” on page 1049 for more information.)

Automating Switched Controls
When automating switched controls (such as 
mutes, plug-in bypasses, or switched controls 
on plug-ins) Pro Tools treats them as touch sen-
sitive controls. Automation data is written for as 
long as the switch or button for that control is 
pressed or touched.

For example, if you have just written a series of 
mute on/off states on a track in quick succes-
sion, the manual method for clearing this auto-
mation data would require you to move to the 
Edit window, choose automation playlist for 
Mute, select the mute automation data, and de-
lete it. In Pro Tools, this can be done automati-
cally.
To automate a switched control (such as the Mute 
button):

1  Perform another automation pass on the track.

2  When you reach the location of the mute state 
you want to remove, press and hold down the 
switched control (such as the Mute button). 

3  As long as the button is held down, Pro Tools 
overwrites the underlying data on the track with 
the current state of the switch (on or off ) until 
playback is stopped. 

Automating Switched Controls 
in Touch Mode
When automating switched controls (including 
mute, plug-in bypass, and any switched control 
on a plug-in) in Touch mode, these controls will 
latch in their current state after they are 
touched.

However, to preserve any automation for that 
switched control later in the Timeline, this 
latched behavior ends if either of the following 
occurs:

• If an existing automation breakpoint is en-
countered, Pro Tools stops writing automa-
tion at that point.

• If you stop playback or punch out of writing 
automation before reaching an existing au-
tomation breakpoint, Pro Tools Au-
toMatches to the underlying automation 
state.

When playback gets to the first muted sec-
tion, the Mute button becomes highlighted. 
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Setting Switched Controls for 
Momentary Behavior
In some cases, such as when overwriting or ex-
tending Mute automation, you may want to mo-
mentarily write automation for a control by 
holding it down, and not have the control latch.

To set switched controls for momentary behavior: 

1  Choose Options > Preferences and click Mixing.

2  Deselect Latching Behavior for Switch Controls 

in “Touch.”

3  Click OK to close the Preferences window.

Automating Sends 
Pro Tools provides automation of send level, 
send mute, and send pan (for stereo and multi-
channel sends only). This makes it easy to con-
trol effect levels and placement during mixdown 
with great precision.

Send level and mute can also be configured to 
follow groups. 

To automate a send level, mute or pan:

1  In the Automation window, make sure the au-
tomation type is write-enabled (send level, send 
mute, send pan).

2  In the Mix or Edit window, set the Automation 
mode for each track containing sends you want 
to automate. For each track, click the Automa-
tion Mode selector and set the Automation 
mode. For the initial automation pass, choose 
Write mode.

3  If sends are not currently visible on your 
tracks, select View > Mix Window (or Edit Win-

dow) > Sends A–E (or Sends F–J).
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4  To display send controls, do one of the follow-
ing:

• Click the send to open the Output window 
for the send that you want to automate.

– or –

• Select View > Sends A–E (or Sends F–J) and 
select one of the individual views (such as 
Send A).

5  Start playback to begin writing automation. 

6  Move the controls you want to automate.

7  When you have finished, stop playback. 

Send level, mute, and pan can also be configured 
to follow Mix Groups (see “Automation Prefer-
ences” on page 1028). 

Copying Track Automation to 
Sends
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

There may be times where you want a track’s 
send settings or automation to mirror the set-
tings or automation in the track itself, for exam-
ple, when creating a headphone mix based on 
the main mix, or when an effect level needs to 
follow the levels in a main mix. You can copy the 
current settings or the entire automation play-
list for the selected controls to the correspond-
ing playlist for the send.



To copy a track’s settings or automation to one of 
its sends:

1  Select the tracks you want to edit by clicking 
on the track names to highlight them.

2  Choose Edit > Automation > Copy to Send.

3  In the Copy to Send dialog, do any of the fol-
lowing: 

• Select Current Value to copy the current set-
tings of the corresponding controls. 

• Select Automation to copy the entire auto-
mation playlist for the corresponding con-
trols.

4  Select the controls you want to copy. 

5  Select the sends to which to copy the automa-
tion, and click OK.

You can undo the results of the Copy to Send 
command.

Copy To Send dialog

When overwriting automation, Pro Tools 
presents a confirmation dialog. To suppress 
this dialog, press Alt (Windows) or Option 
(Mac) while clicking OK.
Automating Plug-Ins 
You can automate changes to virtually all plug-
in controls. Automating a plug-in is slightly dif-
ferent from other automation procedures, be-
cause you must enable individual plug-in con-
trols for automation. 

To enable plug-in controls for automation: 

1  Open the Plug-In window for the plug-in you 
want to automate.

2  Do one of the following:

• Click the Automation Enable button in the 
Plug-In window.

– or –

• Control-Alt-Start-click (Windows) or Com-
mand-Option-Control-click the Track View 
selector in the Edit window.

3  In the plug-in automation dialog, choose the 
controls to automate and click Add. If there are 
multiple plug-ins on the same track, you can se-
lect from among them by clicking their buttons 
in the Inserts section of this dialog. 

Automation Enable button for accessing the Plug-In 
Automation dialog
Chapter 45: Automation 1037



1038
4  Click OK to close the Plug-In Automation 
dialog.

To automate a plug-in:

1  In the Plug-In Automation Enable window, 
make sure plug-in automation is enabled for the 
controls you want to automate.

2  In the Mix or Edit window, for each track con-
taining plug-ins you want to automate, click the 
Automation Mode selector and set the Automa-
tion mode. For the initial automation pass, se-
lect Write.

3  Start playback to begin writing automation, 
and move the controls you want to automate.

4  When you have finished, stop playback.

Plug-In automation dialog
Pro Tools Reference Guide
Enabling Automation for 
Individual Plug-In Parameters
You can enable individual plug-in controls di-
rectly from the Plug-In window.

To enable a plug-in parameter from the plug-in 
window:

1  Make sure the plug-in window is open for the 
plug-in you want to automate. 

2  Command-Option-Control-click (Mac) or 
Control-Alt-Start-click (Windows) the control 
for the parameter.

Enabling Automation for All 
Plug-In Parameters

To enable all plug-in parameters:

1  Make sure the plug-in window is open for the 
plug-in you want to automate. 

2  Command+Option+Control-click (Mac) or 
Control+Alt+Start-click (Windows) on the Auto 
button at the top of the plug-in window. 

Enabling plug-in automation for individual parameters



Automatically Enabling Plug-Ins 
for Automation
You can set Pro Tools to automatically enable all 
controls of a plug-in for automation when you 
first add the plug-in to your session. 

To automatically enable all plug-in controls for 
automation:

1  Choose Setup > Preferences and click Mixing.

2  Select Plug-In Controls Default to Auto-Enabled.

3  Click OK to close the Preferences window.

Color Indication of Automation 
Mode for Plug-In Parameters
In the Plug-In window, the controls for plug-in 
parameters highlight in different colors to indi-
cate whether or not a control is automated in 
what automation mode. The color also is differ-
ent depending on whether or not a parameter is 
being controlled by a control surface (such as 
D-Command or Command|8). 

The following table shows the color coding for 
automated plug-in parameters, with and with-
out a control surface.

Color coding for automated plug-in parameters

Automatio
n Mode:

Off Read
Touch, 
Latch, 
Write

No Control 
Surface

none Green Red

Control 
Surface

none Blue Yellow
Record Safing Plug-In 
Automation
You can protect plug-in automation from being 
overwritten by using Automation Safe mode.

To enable plug-in safe mode:

1  Open a plug-in. 

2  Click the Safe button so that it is highlighted.

AutoMatching Controls
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Use the AutoMatch button in the Automation 
window to automatically change automation 
controls to their existing automation levels.

Automation Safe enabled plug-in

AutoMatch button in the Automation window
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AutoMatching All Controls
You can AutoMatch all currently writing con-
trols to their existing automation levels.

To AutoMatch all currently writing controls:

1  Choose Window > Automation.

2  Make sure the automation types you want to 
AutoMatch are write-enabled.

3  Start playback. 

4  When you reach a point in the track where you 
want to return control to their previously writ-
ten values, click the AutoMatch button in the 
Automation window.

All currently writing controls stop writing auto-
mation and return to any previously written val-
ues according to the AutoMatch Time setting in 
the Mixing preferences.

AutoMatching Individual Tracks
You can invoke AutoMatch on individual tracks. 
All controls currently writing automation on the 
track stop writing and return to existing auto-
mation levels.

To AutoMatch all controls on a track:

 Control-click (Windows) or Command-click 
(Mac) the Automation Mode selector on the 
track.
Pro Tools Reference Guide
AutoMatching Individual 
Automation Types
You can invoke AutoMatch on individual auto-
mation types across a session. 

To AutoMatch all controls of one automation type:

 In the Automation window, Control-click 
(Windows) or Command-click (Mac) the button 
for the automation type (Volume, Pan, Mute, 
Plug-In, Send level, Send pan, or Send mute). 

AutoMatching Individual 
Controls
(D-Control and D-Command Only)

On ICON worksurfaces, you can invoke Au-
toMatch on individual controls or control types 
on single channels.

To AutoMatch all controls of a type on a channel:

 Hold Control (Windows) or Command (Mac) 
and press any of the following in the Channel 
Strip Mode controls for the track whose controls 
you want to AutoMatch:

• Inserts

• Sends

• Pan

• Dyn (D-Control only)

• EQ (D-Control only)



To AutoMatch a pan control or the controls for an 
individual insert or send:

1  Press the switch in the Channel Strip Mode 
controls to display the Pan controls or the top 
level of Inserts or Sends for the channel. 

2  Hold Control (Windows) or Command (Mac) 
and press the Rotary Encoder Select switch for 
the control you want to AutoMatch:

• For Sends, the Send level, pan, and mute 
will AutoMatch. 

• For Inserts, all automated controls will Au-
toMatch. 

• For Pan, all pan sliders on the channel will 
AutoMatch. 

To AutoMatch all controls for a plug-in displayed 
in the Dynamics or EQ section:

 Hold Control (Windows) or Command (Mac) 
and press the Auto switch in the Dyn or EQ sec-
tion of the console. 

Priming Controls for Writing 
Automation in Latch Mode
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

If a track is in Latch or Touch/Latch automation 
mode, you can prime individual controls for 
writing automation while the transport is 
stopped. This Latch Prime capability lets you 
prepare for an automation pass before starting 
playback.
To prime controls for writing automation in Latch 
mode while the transport is stopped:

1  Choose Setup > Preferences and click Mixing.

2  Under Automation, select Allow Latch Prime in 

Stop.

3  Click OK to close the Preferences window.

4  In the Automation window, make sure the con-
trols you want to automate are write-enabled.

5  Click the Automation Mode selector on the 
track where you want to write automation and do 
one of the following:

• Choose Latch mode to allow priming of all 
automation-enabled controls on the track.

– or –

• Choose Touch/Latch mode to leave the 
main Volume fader in Touch mode and al-
low priming of all other automation-en-
abled controls.

6  While the transport is stopped, touch or move 
the controls you want to start writing at the be-
ginning of the automation pass. When at least 
one control on a track is primed, the Automation 
Mode selector displays in red.

7  Start playback. All primed controls begin writ-
ing automation at their primed values.

Automation mode indicator before (left) and after 
priming of latched controls (right)
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8  Stop playback to finish the automation pass. 
All tracks are taken out of their Latch Prime 
state.

Taking Tracks and Controls Out 
of Latch Prime
You can take individual tracks or automation 
types out of their Latch Prime state before or 
during an automation pass. 

 When you take a track or automation type out 
of Latch Prime before starting playback, it stays 
in Latch mode but the corresponding controls 
are not primed to write when playback starts.

 When you take a track or automation type out 
of Latch Prime during an automation pass, the 
corresponding controls AutoMatch to their cur-
rently written values.

 If you AutoMatch a control that is in a Latch 
Prime state, the control will no longer be 
primed. 

To take a track out of Latch Prime:

 Control-click (Windows) or Command-click 
(Mac) the Automation Mode selector on the 
track. 

The selector button unbolds to indicate that the 
track is no longer primed.

You can use the Write to Punch command at 
the end of your automation pass to write the 
current value back to the start of the pass. 
Pro Tools Reference Guide
To take all tracks out of Latch Prime, do one of the 
following:

 Alt-Control-click (Windows) or Option-Com-
mand-click (Mac) the Automation Mode selector 
on a track. 

– or –

 Click the AutoMatch button in the Automation 
window. 

To take all selected tracks out of Latch Prime, do 
one of the following:

 Alt-Control-Shift-click (Windows) or Option-
Command-Shift-click (Mac) the Automation 
Mode selector on a track. 

– or –

 Alt-Shift-click (Windows) Option-Shift-click 
(Mac) the AutoMatch button in the Automation 
window. 

To take an automation type out of Latch Prime on 
all tracks, do one of the following:

 In the Automation window, Control-click 
(Windows) or Command-click (Mac) the button 
for the automation type (Volume, Pan, Mute, 
Plug-In, Send level, Send pan, or Send mute). 

AutoMatch button in the Automation window



Rolling Through Automation 
Punch Points in Latch Prime
After you prime controls for writing automation 
while the transport is stopped, you can set 
Pro Tools to automatically punch in at that 
point after issuing a back and play command, or 
after rolling back and locking to timecode.

To set Pro Tools to automatically punch in 
automation writing on a track:

1  Locate the cursor where you want to punch in 
automation. 

2  Prime controls for writing while the transport 
is stopped. (See “Priming Controls for Writing 
Automation in Latch Mode” on page 1041.)

3  In the Automation window, click the AutoJoin 

button.

Automation type buttons in the Automation window
4  In the Automation window, click the Capture 
button and then click the Punch Capture button. 
The AutoJoin marker (a vertical red line) ap-
pears on-screen at the punch point.

5  Issue a Back and Play command, roll back the 
external machine to before the punch in point, 
or enable pre-roll.

6  Start playback. When the transport reaches the 
punch-in point, automation writing begins.

Capture button in the Automation window

Punch Capture button in the Automation window
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Enabling and Suspending 
Automation
From the Automation window, you can enable 
or suspend writing for the following types of au-
tomation across all tracks:

• Volume

• Volume trim

• Pan

• Mute

• Plug-In

• Send level

• Send level trim

• Send pan

• Send mute

Automation can be suspended or enabled during 
playback (without having to stop the Trans-
port).

Suspending Automation on All 
Tracks

To suspend automation on all tracks:

1  Choose Window > Automation. 

2  Do one of the following:

• To suspend writing of all automation on all 
tracks, click the Suspend button.

– or –

• To suspend writing of a specific type of au-
tomation on all tracks, click the button for 
that automation type (volume, mute, pan, 
plug-in, send level, send mute, or send 
pan).
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To suspend Trim automation on all tracks 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only):

 In the Automation window, Command-click 
(Mac) or Control-click (Windows) the Suspend 
button. 

The Suspend button highlights yellow to indi-
cate that Trim automation is suspended. 

Suspending Automation for 
Individual Controls
You can suspend automation for one or more 
controls. When a control is suspended, its con-
trol name is italicized in the Track View selec-
tor.

Suspend button in the Automation window

Suspending automation from the Edit win-
dow obeys Edit groups. To suppress grouped 
behavior, hold Start (Windows) or Control 
(Mac) while suspending a control.



To suspend automation for individual controls on 
a track:

1  In the Edit window, set the Track View selector 
to show the automation playlist for the control 
you want to suspend.

2  Do one of the following:

• To suspend writing and playback of auto-
mation for only the displayed control, Con-
trol-click (Windows) or Command-click 
(Mac) the control name in the Track View 
selector. 

• To suspend writing and playback of auto-
mation for all controls, Control-Shift-click 
(Windows) or Command-Shift-click (Mac) 
the name of any control in the Track View 
selector.

• To suspend writing and playback of auto-
mation for a specific control on all tracks, 
Control-Alt-click (Windows) or Command-
Option-click (Mac) the name of the control 
in the Track View selector.

To suspend Trim automation for individual 
controls on a track (Pro Tools HD and Pro Tools 
with Complete Production Toolkit only):

1  In the Edit window, set the Track View selector 
to show the automation playlist for the Trim 
control you want to suspend (Volume Trim or 
Send level Trim). 

2  Do one of the following:

• To suspend only the displayed Trim control 
on a single track, Control-click (Windows) 
or Command-click (Mac) the control name 
in the Track View selector.

– or –

• To suspend the displayed Trim control on 
all tracks, Control-Alt-click (Windows) or 
Command-Option-click (Mac) the control 
name in the Track View selector.
Viewing Automation Enable 
Status

Track Automation Mode Selectors

 When a track is enabled for automation but 
not writing automation, the Automation mode 
selector shows the mode in normal red text. 

 When any control on a track is writing auto-
mation, the Automation mode selector shows 
the mode highlighted in red.

Automation Window Buttons

 When an automation type is writing automa-
tion on any track in the session, the correspond-
ing button in the Automation window displays 
bold red text. 

 When an automation type is enabled but is not 
writing anywhere in the session, the correspond-
ing button in the Automation window displays 
normal red text. 

Automation Mode selector showing enabled state 
(left) and writing state (right)

Automation window showing possible automation 
states

Enabled

Not Enabled
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Automation Enable Guidelines
The following rules determine whether automa-
tion is enabled for a track:

 Although Pro Tools shows a single Automa-
tion mode for each track, all automatable con-
trols associated with that track are not 
necessarily in the same Automation mode.

 If automation is globally suspended in the Au-
tomation window, all automatable controls be-
have as if they were in Off mode, regardless of 
the track’s current Automation mode.

 If automation for a control is suspended by 
Control-clicking (Windows) or Command-click-
ing (Mac) its name in the Track View selector, 
that control behaves as if it were in Off mode, re-
gardless of the track’s current Automation mode.

 If automation for a control is suspended in the 
Automation window, that control behaves as if it 
is in Read mode when the track is in a recordable 
Automation mode (Touch, Latch, or Write 
mode).

Deleting Automation
Automation data takes the form of a line graph 
with editable breakpoints. The easiest way to re-
move automation in a track or selection is to 
manually delete breakpoints from the automa-
tion playlist.

Removing data in this manner is different from 
using the Cut command, which creates anchor 
breakpoints at the boundaries of the remaining 
data. For details, see “Cutting, Copying, and 
Pasting Automation” on page 1053. 
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To remove automation data, display the auto-
mation playlist you want to edit by selecting it 
from the Track View selector, or by revealing it 
in an Automation lane, and do one of the follow-
ing:

To remove a single breakpoint:

 With the Pencil tool or any Grabber tool, Op-
tion-click (Mac)ro Alt-click (Windows) the 
breakpoint.

To remove several breakpoints at once:

 Use the Selector tool to select a range that con-
tains the breakpoints, and press Delete (Mac) or 
Backspace (Windows).

To remove all automation data of the displayed 
type:

 Click with the Selector tool in the track and 
choose Edit > Select All, then press Delete (Mac) 
or Backspace (Windows).

To remove all automation for all automation 
playlists on a track:

1  Use the Selector tool to select a range of data to 
be removed.

2  Press Control+Delete (Mac) or Start+Back-
space (Windows).

All automation data within the selection is re-
moved for all automation playlists on that track, 
regardless of whether automation is write-en-
abled for those controls.

Clearing Trim Automation
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

If Trim automation has not been coalesced on a 
track, you can clear it. When you clear Trim au-
tomation, automation breakpoints on all Trim 
playlists are deleted and all Trim faders are reset 
to zero.



To clear Trim automation:

1  Select the track where you want to clear the 
Trim automation.

2  Do one of the following:

• Choose Track > Clear Trim Automation.

– or –

• Right-click the track name and choose 
Clear Trim Automation.

Thinning Automation
Pro Tools writes a maximum density of automa-
tion data during an automation pass in the form 
of breakpoints. Since Pro Tools creates ramps 
between breakpoints, it may not need all of the 
captured points to create a sonically accurate 
representation of the automation moves that 
you have made. Each breakpoint takes up space 
in memory allocated for automation, so thin-
ning data by removing unneeded breakpoints 
can maximize system efficiency and perfor-
mance.

Pro Tools provides two different ways to thin 
automation data: automatically with the Smooth 

and Thin Data After Pass option and manually 
with the Thin Automation commands.

Smooth and Thin Data After 
Pass
When this option is selected in the Mixing Pref-
erences page, Pro Tools automatically thins the 
automation breakpoint data after each automa-
tion pass.

In the default settings for new sessions, the 
Smooth and Thin Data After Pass option is se-
lected, with the Degree of Thinning setting set to 
Some. In most cases, this setting yields opti-
mum performance while providing an accurate 
reproduction of your automation moves.
If you select None for the Degree of Thinning set-
ting, Pro Tools writes the maximum possible 
number of breakpoints. You can still perform 
thinning at any time with the Thin Automation 

command. For more information on smoothing 
automation data, see “Smoothing” on 
page 1029.

Thin Automation Commands
The Thin Automation and the Thin All Automation 
commands lets you selectively thin areas where 
automation data is too dense. You can use the 
Undo command to audition the results of thin-
ning (comparing thinning and not thinning) be-
fore you apply it permanently.

To manually thin automation:

1  In the Edit window, click the Track View selec-
tor to display an automation type you want to 
thin, or reveal the corresponding Automation 
lane.

2  With the Selector tool, highlight the automa-
tion data you want to thin. To thin automation 
for the entire track, click in the track with the 
Selector tool and choose Edit > Select All.

3  Do one of the following:

• To thin only the currently displayed type of 
automation, choose Edit > Automation > 

Thin.

• To thin all types of automation, choose Edit 

> Automation > Thin All.
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Drawing Automation
Use the Pencil tool to create automation events 
for audio and MIDI tracks by drawing in any au-
tomation or MIDI controller playlist, including 
Trim automation if it has not been coalesced.

The Pencil tool can be set to draw a series of au-
tomation events with the following shapes:

Free Hand Draws freely according to the move-
ment of the mouse. In audio tracks, the shape 
has the number of breakpoints needed to 
smoothly interpolate and reproduce the auto-
mation shape. In MIDI tracks, the shape is re-
produced as a series of steps, according to the 
resolution setting in the MIDI Preferences page.

Line Draws a straight line. In audio tracks, the 
line has a single breakpoint at either end. In 
MIDI tracks, the controller value changes in 
steps according to the resolution setting in the 
MIDI Preferences page.

Triangle Draws a sawtooth pattern that repeats 
at a rate based on the current Grid value. In au-
dio tracks, the pattern has a single breakpoint at 
each extreme. In MIDI tracks, the controller 
value changes in steps according to the resolu-
tion setting in the MIDI Preferences page. Am-
plitude is controlled by vertical movement of 
the Pencil tool. 

Square Draws a square pattern that repeats at a 
rate based on the current Grid value. Amplitude 
is controlled by vertical movement of the Pencil 
tool. 

Random Draws a random pattern of levels that 
change at a rate based on the current Grid value. 
Amplitude is controlled by vertical movement of 
the Pencil tool.

The Parabolic and S-Curve Pencil shapes 
are not available for editing automation.
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Using Pencil Tool Shapes
You can draw automation for audio as well as 
MIDI tracks. For example, use the Triangle pat-
tern to control continuous functions, or the 
Square pattern to control switched functions 
such as Mute or Bypass.

Since the Pencil tool draws these shapes using 
the current Grid value, you can use it to perform 
panning in tempo with a music track, or on 
frame scene changes when working in post pro-
duction.

Resolution of MIDI Controller 
Data
When using the Pencil tool to draw MIDI auto-
mation, the data is drawn as a series of discrete 
steps. You can control the resolution (or den-
sity) of these steps to help manage the amount of 
MIDI data sent for a given MIDI controller 
move.

To set the resolution for the Pencil tool:

1  Choose Setup > Preferences and click MIDI.

2  Enter a value for Pencil Tool Resolution When 

Drawing Controller Data. The value can range 
from 1 to 100 milliseconds.

3  Click OK to close the Preferences window.

For more information on MIDI continuous 
controller data, see “Continuous Controller 
Events” on page 697.



The illustrations below show the same MIDI 
controller automation drawn with different 
Pencil tool resolution settings.

For better performance, consider selecting a 
smaller value for MIDI controls that need higher 
resolution (such as MIDI volume), and a larger 
value for controls that may not require a high 
resolution (such as Pan).

Editing Automation
For all tracks in a session, Pro Tools provides 
several ways to edit automation data—including 
Trim automation if it has not been coalesced 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit only). You can edit automa-
tion data graphically by adjusting breakpoints 
in any automation playlist. You can also cut, 
copy, and paste automation data in the same 
manner as audio and MIDI data.

MIDI Data drawn with resolution of 10 ms 

MIDI Data drawn with resolution of 100 ms 
Graphical Editing of Automation 
Data
Automation data takes the form of a line graph 
with editable breakpoints. 

By dragging these breakpoints, you can modify 
the automation data directly in the Edit window 
and MIDI Editor windows. When you drag an 
automation breakpoint up or down, the change 
in value is numerically or textually indicated. 

Dragging an automation breakpoint to the left 
or right adjusts the timing of the automation 
event. 

To view the breakpoint automation type on any 
track, either select the corresponding Track 
View or reveal the corresponding Automation or 
Controller lane under the track.

Automation breakpoint

Automation breakpoint value
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Using the Grabber Tools

The Grabber tools lets you create new break-
points by clicking on the graph line, or adjust 
existing breakpoints by dragging them. Alt-click 
(Windows) or Option-click (Mac) breakpoints 
with a Grabber tool to remove them.

Using the Pencil Tool

The Pencil tool lets you create new breakpoints 
by clicking once on the graph line. Alt-click 
(Windows) or Option-click (Mac) breakpoints 
with the Pencil tool to remove them.

Using the Trim Tools

The Trim tools let you adjust all selected break-
points up or down by dragging anywhere within 
that selection.

Using the Grabber tool to create a new breakpoint

Using the Pencil tool to delete a breakpoint

Using the Trim tool to move breakpoints
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Editing Automation Types
Each automatable control has its own automa-
tion playlist, that can be displayed by choosing 
it from the Track View selector. “Viewing Auto-
mation” on page 1030.

Editing Volume Automation

Drag a breakpoint up or down to change the vol-
ume (dB value). Drag a breakpoint to the left or 
right to adjust the timing of the volume change.

Editing Pan Automation

Drag a breakpoint down to pan right, and up to 
pan left. Drag a breakpoint to the left or right to 
adjust the timing of the panning moves.

Track volume automation

Track Pan automation



Editing Mute Automation

Drag the breakpoint down to mute a section. 
Drag a breakpoint up to unmute the section. 
Drag a breakpoint to the left or right to adjust 
the timing of the mute.

Editing Stepped Control Automation

Automation for certain controls (such as MIDI 
controller values or plug-in settings) appears as 
a stepped pattern on the breakpoint line. Drag a 
breakpoint up or down to a different step to 
change to a new control value. Drag a break-
point to the left or right to adjust the timing of 
the stepped control change.

Editing Automation Breakpoints
To edit automation breakpoints, display the au-
tomation playlist for the control you want to 
edit by selecting it from the Track View selector, 
then do one of the following:

Track mute automation

Stepped control automation
To create a new breakpoint:

 Click with the Pencil tool or any Grabber tool 
on the line graph.

To edit a single breakpoint:

 Click an existing point on the line graph with 
any Grabber tool and drag it to a new position.

To clear a single breakpoint:

 Alt-click (Windows) or Option-click (Mac) 
with any Grabber tool.

To edit several breakpoints at once:

 Use the Selector tool to select a range in the 
automation playlist that contains the break-
points, and do one of the following:

• To move the breakpoints earlier or later in 
the track, press the Plus key (+) to nudge 
them later (to the right) or the Minus key 
(–) to move them earlier (to the left). The 
breakpoints move by the current Nudge 
value.

• To adjust the breakpoint values, click with 
any of the Trim tools in the selection and 
drag the breakpoints up or down.

To edit all breakpoint values in a clip:

 Click in the clip with any of the Trim tools and 
drag the breakpoints up or down.

When you use a Trim tool to edit a selection 
containing breakpoints, new anchor break-
points are created before and after the se-
lected area. To suppress creation of anchor 
breakpoints, press Alt (Windows) or Option 
(Mac) while using a Trim tool.
Chapter 45: Automation 1051



1052
Constrain New Breakpoints to 
Next or Previous Automation 
Value
New automation breakpoints can be constrained 
and written to the same value as the next or pre-
vious breakpoint.

To write a new breakpoint to the next automation 
value:

 Press and hold Alt+Shift (Windows) or Op-
tion+Shift (Mac) while writing a breakpoint (by 
clicking with any Grabber tool in a track’s auto-
mation playlist).

To write a new breakpoint to the previous 
automation value:

 Press and hold Control+Alt (Windows) or 
Command+Option (Mac) while writing a break-
point (by clicking with any Grabber tool in a 
track’s automation playlist).

Constraining and writing new breakpoints (at Marker 
1)

Writing a new breakpoint to the next or pre-
vious automation value is accomplished us-
ing any Grabber tool, but is not supported 
with the Smart Tool.

Original automation

After write to previous breakpoint

After write to next breakpoint
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Editing Automation on Stereo 
and Multichannel Tracks
Stereo and multichannel tracks display a single 
automation playlist per track. Only one playlist 
for volume and mute is available for the stereo 
or multichannel track.

Plug-In Automation Playlists on Stereo and 
Multichannel Tracks

Some multichannel plug-ins provide a single set 
of automatable controls for all channels in a 
track. Other multichannel plug-ins and all 
multi-mono plug-ins provide a single set of con-
trols for all channels when linked, or discrete 
controls for each channel when unlinked. See 
your plug-in guide for more information.

For multi-mono plug-ins, automation playlists 
for each individual channel can be displayed and 
edited when the plug-in is unlinked, and the 
track is in showing Automation lanes. 

To view and edit the individual playlists of a multi-
mono plug-in:

1  Unlink the plug-in. 

2  Select the automation playlist from the Track 
View selector or reveal it in an Automation lane 
under the track.

Selecting an automation lane for an unlinked multi-
mono plug-in control



Editing Automation on Grouped 
Tracks
When you edit automation on an audio track 
that is a member of an active Edit Group, the 
same type of automation is also edited on all 
tracks that are part of that group. This occurs 
even if the playlist for that type of automation is 
not currently displayed on the other grouped 
tracks.

Examples

 If you create new automation breakpoints on a 
grouped track (with the Pencil tool or any Grab-
ber tool), other members of the group have 
breakpoints placed relative to that track.

 If you move automation on a grouped track 
(with any of the Trim tools), other members of 
the group have their breakpoints trimmed rela-
tive to that track. This lets you trim entire sec-
tions of a mix.

To individually edit a automation for a member of a 
group without affecting the other members, do 
one of the following:

 Press the Start key (Windows) or Control 
(Mac) while you perform the edit.

Trimming automation on an active grouped track
Cutting, Copying, and Pasting 
Automation
Cutting automation data is different from delet-
ing it, and yields different results (although both 
change the existing automation data). Copying 
automation leaves the original automation data 
intact.

You delete automation data by selecting a range 
of breakpoints and pressing Backspace (Win-
dows) or Delete (Mac). See “Deleting Automa-
tion” on page 1046 for details.

You cut automation data by selecting a range of 
breakpoints from an automation playlist and se-
lecting the Cut command.

When you cut automation data and when you 
paste it into a new location, anchor breakpoints 
are added to the beginning and end points of the 
data. This is done to preserve the true slope (of 
continuous controls, such as Volume faders or 
pans) or state (of switched or stepped controls, 
such as Mutes) of the automation data both in-
side and outside the selection.

The following illustrations show the difference 
between cutting and deleting automation data. 
In the following figure, a track is set to display 
volume automation, and a range of automation 
data is selected.

Selecting automation data
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If the Cut command is chosen, anchor break-
points are created at each end of the selection, 
and the automation slope on either side of the 
cut data is preserved, as shown in the following 
figure. 

If the data is deleted by pressing Backspace 
(Windows) or Delete (Mac), the automation 
data is removed, and automation values span the 
gap between pre-existing breakpoints, as shown 
in the following figure. 

In addition, if cut or copied data is pasted else-
where in a track, breakpoints are created at the 
end points of the pasted data to preserve its 
“neighboring” (incoming and outgoing) auto-
mation value and slope, as shown in the follow-
ing figure.

After cutting the automation data

After deleting the automation data

After pasting the automation data in another location
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Editing and Track Views
Audio, MIDI, and Instrument tracks each have a 
Track View that acts as the Master View for pur-
poses of editing. When the Master View is dis-
played, any edits performed on the track apply 
to all data in the track.

The Master Views are:

• Audio tracks: Blocks and Waveform

• MIDI and Instrument tracks: Blocks, Clips, 
and Notes

For example, when an audio track is set to 
Waveform or Blocks, cutting, copying and past-
ing affects the audio data and all types of auto-
mation data on that track. If the track is set to 
show Pan automation, only the Pan data is af-
fected.

When a selection includes multiple tracks, if any 
of those tracks is in its Master View, all data on 
all selected tracks is affected.

To edit all automation types on an Auxiliary Input 
or Master Fader track, do one of the following:

 Make an Edit selection that includes at least 
one audio or MIDI track that is displayed in its 
main format.

– or –

 Press Control while cutting or copying the au-
tomation data. 

For additional flexibility, you can use play-
lists or the Duplicate Track command to 
work nondestructively on a copy of the edit 
data. 



Tips for Cutting, Copying and 
Pasting Automation
 On audio tracks, when you are in Waveform 
View and cut or copy a section of the waveform, 
any automation data associated with the wave-
form is also cut or copied.

 On audio tracks, when you are in Waveform 
View and cut audio data from a track also con-
taining automation data, breakpoints are auto-
matically created at the boundaries of the 
remaining automation data.

 On audio tracks, pasting waveform data also 
pastes any associated automation data. 

 On Auxiliary Input, Master Fader, or Instru-
ment tracks, only the displayed automation data 
is cut or copied. To cut or copy all automation 
data on these types of tracks, press Control while 
cutting or copying.

 In tracks where an automation playlist con-
tains no data (when there is only a single break-
point at the very beginning of the track), if you 
cut data, no new breakpoints are created.

 In cases where clips overlap (such as when 
moving clips in Slip mode) and an overlapping 
clip is removed, any overlapped automation 
breakpoints are lost.

 If cut or copied data contains a type of auto-
mation not currently on the target track, 
Pro Tools prompts you before allowing you to 
paste the data. 

 Cut or copied automation data for plug-ins or 
sends that do not exist on the target track is ig-
nored when pasted.
Cut, Copy, Clear, and Paste 
Special Commands
Four “special” commands—Cut Special, Copy 

Special, Paste Special, and Clear Special—sim-
plify the tasks involved with moving or clearing 
different types of automation data and MIDI 
controller data between tracks, sends, and plug-
ins. These commands let you

• Edit automation and MIDI controller data 
only (without associated audio or MIDI 
notes).

• Edit automation and MIDI controller data 
without having to change Track Views

In addition, the Paste Special command lets you 
copy one data type to another (for example, Left 
Pan data into the Right Pan playlist)

Cut Special

The Cut Special commands let you cut just auto-
mation data from the current selection (without 
associated audio or MIDI notes) and place it in 
memory to paste elsewhere, as follows:

All Automation Cuts all automation or MIDI 
controller data whether it is shown or not. 

Pan Automation Cuts only pan automation or 
MIDI pan data whether it is shown or not.

Plug-In Automation Cuts only the plug-in auto-
mation that is shown.

You cannot paste MIDI controller data to 
automation data nor automation to MIDI.
Chapter 45: Automation 1055



1056
Copy Special

The Copy Special commands let you copy just 
automation data from the current selection 
(without associated audio or MIDI notes) and 
place a copy of it in memory to paste elsewhere, 
as follows:

All Automation Copies all automation or MIDI 
controller data whether it is shown or not. 

Pan Automation Copies only pan automation or 
MIDI pan data whether it is shown or not.

Plug-In Automation Copies only the plug-in au-
tomation that is shown.

Paste Special

The Paste Special commands let you paste auto-
mation data into another clip (without affecting 
associated audio or MIDI notes) in the following 
ways: 

Merge Lets you add the pasted data to any exist-
ing automation data of the same type in the des-
tination selection. This can be useful for consol-
idating MIDI data from several tracks into a 
single MIDI track. For example, you like the 
pitch bend on the synth trombones and want to 
apply it to the synth guitar.

Repeat to Fill Selection Pastes multiple itera-
tions of the automation data to the entire selec-
tion range. If you select an area that is not an ex-
act multiple of the copied clip size, the 
remaining selection area is filled with a trimmed 
version of the original selection. This lets you 
easily create drum loops and other repetitive ef-
fects. Before the data is pasted, Pro Tools 
prompts you to specify a crossfade to smooth 
transitions between clips. 
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To Current Automation Type Pastes the automa-
tion data or MIDI controller data from the clip-
board to the selection as current automation 
type or MIDI controller. This lets you copy auto-
mation from any type to any other type. For ex-
ample, you can copy a Left Pan automation to 
Plug-In automation. Or, you can copy MIDI vol-
ume data and paste it to MIDI pan.

Clear Special

The Clear Special commands let you clear just 
automation data from the current clip, as fol-
lows:

All Automation Clears all automation or MIDI 
controller data whether it is shown or not. 

Pan Automation Clears only pan automation or 
MIDI pan whether it is shown or not.

Plug-In Automation Clears only the plug-in auto-
mation that is shown.

Special Paste Function for 
Automation Data
Normally, when you copy and paste automation 
data, it is pasted in an automation playlist of the 
exact same type (for example, Left Pan data is 
pasted into the Left Pan playlist). 

However, there may be times when you want to 
paste from one data type to another (for exam-
ple, Left Pan data into the Right Pan playlist).

The Special Paste command lets you copy one 
data type to another. 

If you want to paste automation or MIDI con-
troller data only (without its associated audio or 
MIDI notes), use the Paste Special command.



For this special paste mode to function, the fol-
lowing must be true:

• Every track selected for pasting must be cur-
rently displayed as automation data.

– and –

• There must be only one automation playlist on 
the Clipboard for each target track. (The Spe-

cial Paste command cannot copy multiple au-
tomation playlists for each track.)

To paste data into a different automation playlist:

 Press the Start key (Windows) or Control 
(Mac) when choosing Edit > Paste.

Converting Volume Automation 
and Clip Gain
(Pro Tools HD or Pro Tools with Complete 
Production Toolkit Only)

Pro Tools lets you convert clip gain settings to 
track-based volume automation, as well as let-
ting you convert track-based volume automa-
tion to clip gain settings. For more information, 
see “Converting Clip Gain and Track Volume 
Automation” on page 609.

Coalescing Volume Automation 
and Clip Gain
(Pro Tools HD or Pro Tools with Complete 
Production Toolkit Only)

Pro Tools lets you coalesce clip gain settings to 
track-based volume automation, as well as let-
ting you coalesce track-based volume automa-
tion to clip gain settings. For more information, 
see “Coalescing Clip Gain and Track Volume 
Automation” on page 610.

You cannot interchange automation data 
between audio and MIDI tracks, or between 
continuous controls (such as faders or pans) 
and switched or stepped controls (such as 
mute or MIDI controllers).
Glide Automation
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

The Glide Automation commands let you manu-
ally create an automation transition (or glide) 
from an existing automation value to a new one, 
over a selected area.

To apply a Glide Automation to the current 
automation parameter type:

1  In the Automation window, make sure the au-
tomation type is write-enabled.

2  Click the Track View selector to choose the au-
tomation type you want to automate. 

3  Drag with the Selector tool in the track to se-
lect the area you want to write the glide to.

4  Change the automation parameter to the value 
you want at the end of the selection. For exam-
ple, to glide automation volume to –Infinity, 
move the Volume fader to –Infinity.

5  Choose Edit > Automation > Glide to Current.

To do a Glide Automation to all current enabled 
parameters:

1  In the Automation window, make sure the au-
tomation types are write-enabled.

When gliding multiple parameters at the 
same time, such as with the Surround Pan-
ner or plug-ins, use the Edit > Automation > 
Glide to All Enabled option.

For MIDI automation, Glide To commands 
only apply to MIDI Volume, MIDI Pan, and 
MIDI Mute. MIDI parameters cannot use 
the Write To commands.

You can also press Alt+Forward Slash (/) 
(Windows) or Option+Forward Slash (/) 
(Mac).
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2  In each track you want to automate, click the 
Track View selector and select from the pop-up 
menu the automation type you want to automate.

3  With the Selector tool, drag horizontally to in-
clude all the tracks you want to automate in a se-
lection (drag vertically to define the time range).

4  In each track you want to automate, change the 
automation parameter to the value you want at 
the end of the selection.

5  Choose Edit > Automation > Glide to All Enabled.

Glide Automation 
Considerations
When Glide Automation is applied to automa-
tion data, it behaves as follows:

• When a selection is made, automation break-
points are written at the start and end points 
of the Glide Automation. The automation 
value at the start of the selection is the start 
point of the Glide Automation and the end of 
the selection is the end point of the Glide Au-
tomation. The Glide Automation that is cre-
ated between the two is based on the length of 
the selection and the end value that is se-
lected.

• If automation breakpoints follow the selec-
tion, they are not changed, but the value se-
lected for the end of the selection is written 
from the end point up until the next break-
point.

• If no automation breakpoints follow the selec-
tion, the value selected for the end of the se-
lection is written to the end of the track.

You can also press Alt+Shift+Forward 
Slash (/) (Windows) or Option+Shift+For-
ward Slash (/) (Mac).
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• If no selection is made, a breakpoint is written 
to the current location, and the value selected 
for the Glide Automation is written to the next 
breakpoint.

Trimming Automation
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

If you have already written automation, you can 
modify automation data for track volume and 
send levels in real time by using Trim mode. 
When a track is trim-enabled, you are not re-
cording absolute fader positions, but relative 
changes in the existing automation. See “Trim 
Mode” on page 1026 for more information.

To enable Trim mode:

 In the Mix or Edit window, click the Automa-
tion Mode selector of the track where you want 
to trim automation, and select Trim.

When a track’s Trim mode is enabled, its Vol-
ume and Send Level faders turn yellow, and its 
Automation Mode selector is outlined in yellow. 
This outline appears solid if the track is trim-en-
abled, and flashes whenever trimming is occur-
ring on the track’s volume or send levels. 

Enabling Trim mode



Writing Trim Automation
The writing of Trim automation depends on how 
it is set to be coalesced. See “Coalescing Trim 
Automation” on page 1059. If automation is not 
set to coalesce after every automation pass, Trim 
automation moves are written to a separate 
Trim playlist. 

To trim track Volume or Send levels:

1  In the Automation window, make sure the au-
tomation type (Volume or Send level) is write-
enabled.

2  Click the Automation Mode selector of the 
track where you want to write automation and 
choose the automation mode (Touch, Latch, 
Touch/Latch, or Write). 

3  Click the Automation Mode selector and select 
Trim.

4  Start playback, and adjust the Volume or Send 
levels.

5  Stop playback to finish the Trim pass. 

Coalescing Trim Automation
You can set Pro Tools to commit, or coalesce, 
Trim automation to the main automation play-
list by the following methods:

After Every Pass Trim moves are automatically 
applied when the transport is stopped at the end 
of an automation pass. Trim automation play-
lists are cleared, and Trim faders are returned to 
zero.

On Exiting Trim Mode Trim moves are stored 
separately in the Trim automation playlist until 
they are coalesced. Trim automation is automat-
ically coalesced on a track only when you take 
the track out of Trim mode. You can repeat an 
automation pass, edit Trim automation manu-
ally on any of the Trim playlists, or clear Trim 
automation before coalescing with this method.

Manually Trim moves are stored separately in 
the Trim automation playlist until they are co-
alesced. With this setting, the only way to co-
alesce Trim moves is with the Coalesce Trim Au-

tomation command. You can repeat an 
automation pass, edit Trim automation manu-
ally on any of the Trim playlists, or clear Trim 
automation before coalescing with this method. 

To set the method by which Trim Automation is 
coalesced:

1  Choose Setup > Preferences and click Mixing.

2  Under Coalesce Trim Automation, select one 
of the following:

• After Every Pass 

• On Exiting Trim Mode 

• Manually 

Even when automation is set to coalesce on 
exiting Trim mode, you can use the 
Coalesce Trim Automation command to 
commit Trim moves at any time.
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To coalesce Trim automation on a track when 
exiting Trim mode:

1  Choose Setup > Preferences and click Mixing.

2  Under Coalesce Trim Automation, select On 

Exiting Trim Mode.

3  Click OK to close the Preferences window.

4  Make sure the Pro Tools transport is stopped.

5  On the track where you want to coalesce Trim 
automation, click the Automation Mode selector 
and deselect Trim.

The Trim automation is applied to the main au-
tomation playlist, Trim automation playlists are 
cleared, and Trim faders are returned to zero. 

To manually coalesce Trim automation on a track:

1  Select the track where you want to coalesce the 
Trim automation.

2  Do one of the following:

• Choose Track > Coalesce Trim Automation.

– or –

• Right-click the track name and choose Co-

alesce Trim Automation.

The Trim automation is applied to the main au-
tomation playlist, Trim automation playlists are 
cleared, and Trim faders are returned to zero.

If transport is playing and you are writing 
automation, you cannot directly enter or 
exit Trim mode. You must AutoMatch be-
fore exiting Trim mode. This prevents any 
abrupt jumps in automation values. 
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Writing Automation to the 
Start, End, or All of a Track 
or Selection
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools lets you write current automation val-
ues from any insertion point forward (or back-
ward) to the end (or beginning) of a track or Edit 
selection in a track, or to an entire track or Edit 
selection, while performing an automation pass.

The standard Write Automation to Start, All, or 
End commands do not operate when the 
Pro Tools transport is stopped. It only affects 
automation for those parameters that are cur-
rently write-enabled and currently writing auto-
mation data. 

Write Automation to Start, End, and All buttons in the 
Automation window



Optionally, Write Automation to Start, All, and 
End can be configured to always be applied au-
tomatically. See “Writing Automation to the 
Start, End or All of a Track or Selection on Stop” 
on page 1062. 

Requirements for Standard 
Write Automation Commands
For automation data to be written for a specific 
parameter, the associated track must be in one 
of the following Automation modes and meet 
the following conditions:

Latch Mode The control for the parameter must 
be changed (touched) during the automation 
pass. 

Touch Mode The control for the parameter must 
be changed (touched). 

Write Mode All controls on that track must be in 
Write mode. 

This command can be undone.

To write current automation values to the start, 
end, or all of a track or Edit selection:

1  Choose Window > Automation.

2  Make sure that the automation type is write-
enabled.

3  Do one of the following:

• Click in a track at an insertion point.

– or –

• Drag with the Selector tool to select a por-
tion of the track.

4  Start playback.

For MIDI automation, the Write To com-
mands only apply to MIDI Volume, MIDI 
Pan, and MIDI Mute. MIDI parameters 
cannot use the Write To commands.
5  Make sure you are actively writing on the ap-
propriate track if you are in Latch or Touch 
mode.

6  When you reach a point in the track or selec-
tion that contains the automation data you want 
to apply, click the Write Automation to Start, All, 
or End button in the Automation window. 

7  Stop playback.

The current values of all write-enabled automa-
tion at that point are written to the correspond-
ing area of the track/selection.

Write to Start, End or All and 
Trim Mode
While in Trim mode, it is also possible to write 
trim delta values for track volume and send lev-
els to the start, end or all of a track or Edit selec-
tion. 

To write current trim delta values to the start, end, 
or all of a track or selection:

1  Choose Window > Automation.

2  Make sure the automation type (track volume 
or send level) is write-enabled.

3  In the Mix or Edit window, click the Automa-
tion Mode selector of the track you want to trim 
automation, and select Trim. The track Volume 
and Send Level faders turn yellow.

4  Do one of the following:

• Click in a track at an insertion point.

– or –

• Drag with the Selector tool to select a por-
tion of the track.

5  Click Play to begin playback. 
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6  When you reach a point in the track or selec-
tion that contains the trim setting (delta value) 
you want to apply, click the Write Automation to 

Start, All, or End button in the Automation win-
dow.

7  Stop playback. 

The relative changes to the track volume and 
send levels at that point are written to the corre-
sponding area of the track/selection.

Writing Automation to the Start, 
End or All of a Track or Selection 
on Stop
The Automation window provides options for 
writing automation on any automation playlist 
(including Trim playlists) after a valid automa-
tion pass has been performed. 

The Write Automation to Start, End, or All 
modes can be configured to disable or remain 
enabled after a valid automation pass.

See “Requirements for Standard Write Automa-
tion Commands” on page 1061. 

Write On Stop buttons in the Automation window
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To configure Write on Stop modes to disable after 
an automation pass:

1  Choose Window > Automation.

2  Click to enable one of the Write On Stop modes 
(Start, All, End).

The enabled Write on Stop arrow appears in 
blue.

To configure Write on Stop modes to remain 
enabled after an automation pass:

1  Choose Window > Automation.

2  Alt-click (Windows) or Option-click (Mac) one 
of the Write On Stop buttons (Start, All or End) 
to enable the Write On Stop mode.

The enabled Write on Stop arrow appears in red.

Writing Automation to the 
Next Breakpoint or to the 
Punch Point
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

While performing an automation pass, 
Pro Tools lets you write current automation val-
ues from the current insertion point forward to 
the next automation breakpoint, or back to the 
punch point (the location in the track where au-
tomation writing started). 

 Write Automation to Next Breakpoint lets you 
update automation within a track without over-
writing automation located earlier or later in the 
Timeline, and without having to define a selec-
tion before editing automation.

 Write Automation to Punch Point lets you fill 
back an automation value within a track after 
finding the right level or setting during an auto-
mation pass, without having to go back and re-
peat the pass.



Like the standard Write Automation to Start, End, 
and All commands, the Write Automation to Next 

Breakpoint and Write Automation to Punch Point 
commands do not operate when the Pro Tools 
transport is stopped. They only affect automa-
tion for those parameters that are currently 
write-enabled and currently writing automation 
data. 

Optionally, the Write Automation to Next Break-

point and Write Automation to Punch Point com-
mands can be configured to be applied automat-
ically after a valid automation pass has been 
performed. See“Writing Automation to the Next 
Breakpoint or to the Punch Point on Stop” on 
page 1064.

To write current automation values to the next 
breakpoint:

1  Choose Window > Automation.

2  Make sure that the automation type is write-
enabled.

3  Click in a track to define an insertion point.

4  Start playback.

5  Make sure you are actively writing on the ap-
propriate track if you are in Touch, Latch, or 
Touch/Latch mode.

For MIDI automation, the Write To com-
mands only apply to MIDI Volume, MIDI 
Pan, and MIDI Mute. Other MIDI parame-
ters cannot use the Write To commands.

Write Automation to Next Breakpoint and 
Write Automation to Punch Point have the 
same requirements as Write Automation to 
Start, End and All commands. See “Writing 
Automation to the Start, End, or All of a 
Track or Selection” on page 1060.
6  When you reach a point in the track where you 
want to apply the current settings, click the 
Write Automation to Next Breakpoint button.

7  Stop Playback. 

The current values of all controls being written 
at that point are written up to the next break-
point.

To write current automation values back to the 
automation punch point:

1  Choose Window > Automation.

2  Make sure the automation type is write en-
abled. 

3  Click in a track to define an insertion point.

4  Start playback.

5  Make sure you are actively writing on the ap-
propriate track if you are in Touch, Latch, or 
Touch/Latch mode.

Write To Next Breakpoint buttons in the Automation 
window

Write Automation to Next Breakpoint re-
mains enabled after a valid automation 
pass. Unlike standard Write Automation 
commands, it cannot be configured to dis-
able after an automation pass.

Write to Next Breakpoint

Write to Next Breakpoint
on Stop

button

button
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6  When you reach a point in the track where you 
want to apply the current settings, click the 
Write Automation to Punch Point button.

The current values of all write-enabled parame-
ters are written back to the point where the first 
control began writing automation.

Write To Next Breakpoint or 
Punch Point and Trim Mode
While in Trim mode, it is also possible to write 
trim values for track volume and send levels to 
the next written breakpoint or back to the auto-
mation punch-in point. 

To write current trim values to the next breakpoint 
or to the punch point:

1  Choose Window > Automation.

2  Make sure that the automation type (track vol-
ume or send level) is write-enabled.

3  In the Mix or Edit window, click the Automa-
tion Mode selector and select Trim. The track 
Volume and Send Level faders turn yellow.

4  Click in a track to define an insertion point.

Write To Punch Point buttons in the Automation 
window

Write to Punch Point

Write to Punch Point
on Stop

button

button
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5  Start playback. 

6  When you reach a point in the track where you 
want to apply the current trim values, click the 
Write Automation to Next Breakpoint button in 
the Automation window.

To write current trim values to the punch point:

1  Choose Window > Automation.

2  Make sure that the automation type (track vol-
ume or send level) is write-enabled.

3  In the Mix or Edit window, click the Automa-
tion Mode selector and select Trim. The track 
Volume and Send Level faders turn yellow.

4  Click in a track to define an insertion point.

5  Start playback. 

6  When you reach a point in the track where you 
want to apply the current trim values, click the 
Write Automation to Punch Point button in the 
Automation window.

Writing Automation to the Next 
Breakpoint or to the Punch Point 
on Stop
The Automation window provides an option for 
automatic Write Automation to Next Break-
point on Stop or Write Automation to Punch 
Point on Stop.

Write Automation to Next Breakpoint 
remains enabled after a valid automation 
pass. Unlike standard Write Automation 
commands, it cannot be configured to 
disable after an automation pass.



To configure Write Automation to Next Breakpoint 
on Stop:

1  Choose Window > Automation.

2  Click the Write Automation to Next Breakpoint 
on Stop button or the Write Automation to 
Punch Point button. 

When this option is enabled, automation writ-
ing will be performed automatically forward to 
the next breakpoint after a valid automation 
pass has been performed.

To configure Write Automation to Punch Point on 
Stop:

1  Choose Window > Automation.

2  Click the Write Automation to Punch Point on 
Stop button. 

When this option is enabled, automation writ-
ing will be performed automatically back to the 
automation punch-in point after a valid auto-
mation pass has been performed.
Guidelines for “Write To” 
Commands
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Using “Write To” Commands 
During Playback
You can carry out any of the Write Automation To 
commands without stopping the Pro Tools 
transport. On supported control surfaces, the 
corresponding “Write To” button flashes until 
you stop the transport.

While the Pro Tools transport is moving, issuing 
Write Automation To commands affects writing of 
automation in the following ways:

• Write to Start/Selection Start: Currently 
writing controls continue writing automa-
tion

• Write to All/Selection: Currently writing 
controls (except controls in Write mode) 
punch out of writing automation

• Write to End/Selection End: Currently writ-
ing controls (except controls in Write 
mode) punch out of writing automation

• Write to Next Breakpoint: Currently writing 
controls (except controls in Write mode) 
punch out of writing automation

• Write to Punch point: Currently writing 
controls continue writing automation

For MIDI automation, the Write To com-
mands only apply to MIDI Volume, MIDI 
Pan, and MIDI Mute. MIDI parameters 
cannot use the Write To commands.
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Applying “Write To” Commands 
to Selected Tracks
The Write Automation To commands normally 
apply to all tracks currently writing automation. 
It is possible to apply these commands to se-
lected tracks only. 

To apply any of the “Write Automation To” 
commands to currently selected tracks:

1  Select the tracks where you want to apply the 
Write To commands.

2  Alt-Shift-click (Windows) or Option-Shift-
click the corresponding “Write Automation To” 
button.

Supressing Warnings when 
Using “Write To” Commands
When you carry out any of the Write Automation 

To commands (except Write to Next Break-
point), Pro Tools posts a dialog warning that au-
tomation values will be changed in the session. 
You can suppress these warnings. 

To suppress “Write To” warning dialogs:

1  Choose Setup > Preferences and click Mixing.

2  Under Automation, select Suppress Automa-

tion “Write To” Warnings. 

Overwriting or Extending 
Mute Automation 
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools lets you overwrite or extend an exist-
ing mute event in real time, without changing 
the current mute state.
Pro Tools Reference Guide
A mute event can be overwritten when the auto-
mation pass begins before the first mute event 
and ends after the second event. In this case, the 
current on/off state of the mute is maintained.

A mute event can be extended when the automa-
tion pass begins before an on or off event and 
stops before the end of the second event.

Overwriting a mute automation event

Extending a mute automation event

Mute on event overwritten

Original mute automation
(mute off, mute on, mute off)

Mute off event extended (up to automation pass end)

Original mute automation
(mute off, mute on, mute off)



Mute Overwrite/Extend is supported in Touch 
and Latch mode, as follows:

Touch Mode Writes the current state as long as 
the Mute button is held.

Latch Mode Writes the current state until you 
stop or AutoMatch out.

To overwrite a mute state on one or more tracks:

1  Choose Window > Automation. 

2  Make sure Mute is write-enabled.

3  In the Mix or Edit window, click the Automa-
tion Mode selector of the track where you want 
to overwrite the mute state, and set the Automa-
tion mode to Touch or Latch mode.

4  In each track you want to automate, click the 
Track View selector and select mute.

5  Place the cursor before the start of the mute 
event you want to overwrite.

Mute enable button in the Automation window

To overwrite mute states on multiple tracks, 
set all tracks to the same Automation mode.
6  Start playback.

7  Press Control (Windows) or Command (Mac) 
and the track Mute button before the start of the 
mute event you want to overwrite.

8  After the end of the second mute event, release 
the key and the Mute button.

9  When you have finished the automation pass, 
stop playback.

Placing the cursor before the start of a mute event

To overwrite mute states on multiple tracks, 
press Alt+Control (Windows) or Op-
tion+Command (Mac) and the Mute button 
on one of the tracks to be automated.

With Touch mode, you have to hold the 
Mute button for the duration of the write.

Stopping automation pass after the end of a mute 
event

Example of mute state overwritten

Mute on state overwritten
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To extend a mute state on a track:

1  Choose Window > Automation. 

2  Make sure mute is write-enabled.

3  In the Mix or Edit window, click the Automa-
tion Mode selector of the track you want to auto-
mate, and select Touch or Latch mode.

4  In each track you want to automate, click the 
Track View selector and select mute.

5  Place the cursor before the start of the mute 
event you want to extend.

6  Start playback.

7  Press Control (Windows) or Command (Mac) 
and the track Mute button before the start of the 
mute event you want to extend.

8  Before the end of the second mute event, re-
lease the key and the Mute button.

To extend mute states on multiple tracks, set 
all the tracks to the same Automation mode.

Placing the cursor before the start of a mute event

To extend mute states on multiple tracks, 
press Alt+Control (Windows) or Op-
tion+Command (Mac) and the Mute button 
on the track.

If you extend past the subsequent on or off 
event, the entire event will be changed.
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9  When you have finished the automation pass, 
click Stop.

Creating Snapshot 
Automation
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Pro Tools HD and Pro Tools with Complete Pro-
duction Toolkit let you write automation data 
values for multiple parameters in a single step. 
You can write snapshot automation in two ways:

To a Selection Automation data is written to the 
Timeline selection (as well as the Edit selection 
if linked). Anchor breakpoints are placed just 
before and after the selection so that data out-
side the selection is not affected.

To a Cursor Location Automation data is written 
at the insertion point. After the insertion point, 
the automation ramps to the next breakpoint 
value, or if no breakpoints exist, remains at the 
newly written value for the remainder of the 
session.

Stopping automation before the end of a mute event

Example of mute state extended (up to automation 
pass end)



For more information on cutting, copying, and 
pasting automation data within a session, see 
“Writing Automation to the Start, End, or All of 
a Track or Selection” on page 1060.

To write snapshot automation:

1  In the Automation window, make sure that the 
parameters you want to edit are write-enabled. 
Deselect any parameters whose automation you 
want to preserve.

2  In the Edit window, click the Track View selec-
tor to show the automation you want to edit.

3  Write a breakpoint in the playlist if none cur-
rently exists, as follows:

• Place the cursor in the playlist (or make an 
Edit selection), then choose Control+For-
ward Slash (/) (Windows) or Com-
mand+Forward Slash (/) (Mac).

– or –

• Select the Grabber tool and click anywhere 
in the playlist.

4  Do one of the following:

• Select an area in the track’s playlist (or 
within multiple tracks) where you want to 
apply the automation. 

– or –

• Place the cursor at an Edit insertion point.

For MIDI automation, the Write To, Trim 
To, and Glide To commands only apply to 
MIDI Volume, MIDI Pan, and MIDI Mute. 
MIDI parameters cannot use the Write To 
commands.
5  Adjust the controls you want to automate. You 
can also change a plug-in preset.

6  Choose Edit > Automation and do one of the fol-
lowing:

• To write the current value to only the cur-
rently displayed automation parameter, 
choose Write to Current.

– or –

• To write the current settings for all automa-
tion parameters enabled in the Automation 
window, choose Write to All Enabled.

Adding Snapshot Automation to 
Empty Automation Playlists
When you use a Write Automation command on 
an automation playlist with no previously writ-
ten automation data, the selected value is writ-
ten to the entire playlist and not just the selected 
area.

This is because a playlist with no automation 
data contains only a single automation break-
point that corresponds to the current position of 
the control for the parameter. The position of 
the breakpoint is updated whenever the param-
eter value is changed. 

If you do not want the Write Automation com-
mand to write the selected automation value to 
the entire playlist, you can:

• Anchor the automation data by placing the 
cursor at the end of the session (or any other 
end point) and choosing Write to Current.

– or –

• Click with any Grabber tool on each side of the 
selection.

This lets the Write Automation command write 
only to the selected area.
Chapter 45: Automation 1069



1070
Writing Snapshot Automation 
over Existing Automation Data
When you move the playback cursor, the auto-
mated controls in Pro Tools update to reflect the 
automation data that is already on the track. To 
keep the settings you have made for a snapshot, 
you can suspend automation parameters to pre-
vent them from updating.

To write snapshot automation over existing data:

1  In the Automation window, make sure that the 
automation parameters you want to edit are 
write-enabled. Deselect any parameters whose 
automation you want to preserve.

2  Adjust the controls for the parameters you 
want to automate.

3  Click the Automation Mode selector and select 
Off mode for the tracks where you want to apply 
the automation.

4  With the Selector, select the range where you 
want to apply the automation.

5  Choose Edit > Automation and select one of the 
following from the submenu:

• To write the current value to only the auto-
mation parameter currently displayed in 
the Edit window, choose Write to Current.

– or –

• To write the current settings for all automa-
tion parameters enabled in the Automation 
window, choose Write to All Enabled.

6  Click the Automation Mode selector and select 
Read mode for the tracks you want to play back 
with automation.
Pro Tools Reference Guide
Capturing Automation and 
Applying it Elsewhere
The Write Automation commands can also be 
used to capture automation states at specific lo-
cations in a track and apply them to other loca-
tions in the track.

To capture and apply automation:

1  In the Automation window, make sure that the 
automation parameters you want to edit are 
write-enabled. Deselect any parameters whose 
automation you want to preserve.

2  Click the Automation Mode selector and select 
Read mode for the tracks that have automation 
you want to capture.

3  Ensure that Options > Link Timeline and Edit Se-

lection is selected.

4  With the Selector tool, select the location 
where you want to capture automation. All auto-
mated controls update to reflect the automation 
at that location. (If you make a selection, the 
controls update to reflect the automation at the 
beginning of the selection.)

5  In each track you want to apply the captured 
automation, click the track’s Automation Mode 
selector and set the Automation mode to Off.

6  With the Selector tool, select the location 
where you want to apply the automation.

7  Enable the automation parameters previously 
suspended.



8  Choose Edit > Automation and select one of the 
following from the submenu:

• To write the current value to only the auto-
mation parameter currently displayed in 
the Edit window, choose Write To Current.

– or –

• To write the current settings for all automa-
tion parameters enabled in the Automation 
Enable window, choose Write To All En-

abled.

9  Click the Automation Mode selector and select 
Read mode for the tracks you want to play back 
with automation.

Snapshot Automation and 
Trimming of Automation Data
Pro Tools lets you use trim values as snapshots 
and apply the relative changes (delta values) to 
the selected automation by using the Trim Auto-
mation command. This works in much the same 
way as the Write Automation command, except 
that it writes delta values instead of absolute 
values to automation data. 

You can use trim values in writing snapshot au-
tomation to any automatable parameter.

To create a snapshot of relative changes in 
automation data:

1  In the Automation window, make sure that the 
automation parameters you want to edit are 
write-enabled. Deselect any parameters whose 
automation you want to preserve.

2  Select the area of the track you want to edit. All 
automated controls update to reflect the auto-
mation at the beginning of the selection.

3  Move the controls for the parameter up or 
down by the amount you want to change the 
data. 
4  Choose Edit > Automation and do one of the fol-
lowing:

• To write the current delta value to only the 
currently displayed automation parameter, 
choose Trim to Current.

– or –

• To write the current delta value for all auto-
mation parameters enabled in the Automa-
tion window, choose Trim to All Enabled.

Previewing Automation
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Automation Preview mode lets you audition 
changes to a mix and compare them to existing 
automation values without committing them to 
the automation playlist.

When you put Pro Tools in Automation Preview 
mode, you can preview values for automation-
enabled controls on any track that is in a writ-
able automation mode. 

While in Automation Preview mode, when you 
touch or move a control, it isolates the control, 
disengaging it from its automation playlist. The 
control stops reading or writing automation, al-
lowing you to freely audition changes.

When you have found a level or state that you 
want to use, you can then commit or punch the 
previewed value to the automation playlist for 
the isolated controls. 

 If you punch during playback, the automation 
mode is set to Latch and writing begins at the 
preview value. 
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 If you punch while the transport is stopped, 
the automation mode is set to Latch and the con-
trol is primed at the preview value.

Previewing New Automation 
Values

To preview a new automation value for a control:

1  Make sure the track where you want to preview 
the value is enabled for automation (Touch, 
Latch, Touch/Latch or their corresponding Trim 
modes). 

2  Make sure the automation type you want to 
preview is enabled in the Automation window 
(Volume, Pan, Mute, Send level, Send pan, Send 
mute, or Plug-In). 

3  Click the Preview button in the Automation 
window. The button lights green to indicate that 
Preview mode is active.

It is not necessary for the Allow Latch Prime 
in Stop preference to be enabled for Preview 
to put a control into Latch Prime.

Preview controls in the Automation window
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4  To isolate a control, touch or move an automa-
tion-enabled control.You can isolate controls 
during playback or while the transport is 
stopped. 

The Automation Mode indicator on the track 
lights green to indicate that at least one of its 
controls is isolated, and the Punch Preview but-
ton in the Automation window lights to indicate 
a preview value is available to punch.

5  Start playback and adjust the isolated control 
to audition the changes.

Taking Controls Out of Isolated 
State
You can take controls out of their isolated state 
without leaving Preview mode.

To take all controls on a track out of their isolated 
state, do one of the following:

 Control-click (Windows) or Command-click 
(Mac) the automation mode selector on the 
track.

– or –

 Change the track automation mode to Read or 
Off. 

To take all controls of an automation type out of 
their isolated state:

 In the Automation window, disable the auto-
mation type.

Isolating Multiple Controls
In some cases, such as when starting a new mix, 
you may want to isolate multiple controls at the 
same time.

To isolate all currently write-enabled controls:

 Alt-click (Windows) or Option-click (Mac) the 
Preview button.



To isolate all write-enabled controls on all selected 
tracks:

 Alt-Shift-click (Windows) or Option-Shift- 
click (Mac) the Preview button.

Suspending Preview Mode
You can temporarily suspend Preview mode, al-
lowing you to toggle between preview values and 
existing automation. 

To suspend Preview mode:

 Control-click (Windows) or Command-click 
(Mac) the Preview button.

Punching Preview Values
After you have isolated a control and auditioned 
a new value, you can punch (write) the value to 
the automation playlist. 

To punch a preview value to the automation 
playlist:

 Click the lit Punch Preview button.

Preview Mode and “Write To” 
Commands
The Write Automation To commands work as fol-
lows with Preview mode:

Before Punching Preview Values The Write Auto-

mation To commands (except Write to Next Break-

point) can be used to extend previewed values. 
The Write Automation To command will only ap-
ply to isolated controls. Pro Tools remains in 
Preview mode.

After Punching Preview Values The Write Auto-

mation To commands (except Write to Next Break-

point) can be used to extend the punched value in 
the same manner as other automation. 
Capturing Automation
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

You can capture current automation values at 
one location in a session and quickly apply them 
in another location with the Capture and Punch 

Capture commands. The Capture command tem-
porarily stores the value of all controls currently 
writing automation, and the Punch Capture 
commands writes those stored values to all en-
abled automation types.

 ICON Systems allow for the capture of up to 48 
different values, or snapshots. 

 All other systems allow for the capture of a 
single value.

Capturing Automation Values
You can capture the current automation values 
of actively writing controls. 

Capture controls in the Automation window
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To capture automation values:

1  Make sure all tracks whose automation values 
you want to capture are in a write-enabled state 
(Write, Touch, Latch, Touch/Latch or Latch).

2  Make sure the automation types you want to 
capture are enabled in the Automation window 
(Volume, Pan, Mute, Send level, Send pan, Send 
mute, or Plug-In).

3  Start playback. When you reach a location 
where you want to capture the current automa-
tion states, click the Capture button in the Auto-
mation window.

The Punch Capture button in the Automation 
window lights to indicate a captured value is 
available to punch.

Punching Captured Automation 
Values
After automation values are captured, they can 
be punched (written) to another location in the 
track. Any tracks set to Read or Off are unaf-
fected.

 If you punch during playback, the automation 
mode of any track set to Touch is set to Latch and 
writing begins at the captured value.

 If you punch while the transport is stopped, 
the automation mode of any track set to Touch is 
set to Latch and the control is primed at the cap-
tured value.

To punch captured automation values:

1  Move to a location where you want to apply the 
captured automation states. You can do this dur-
ing playback or while the transport is stopped.

2  Click the Punch Capture button in the Auto-
mation window to apply the captured automa-
tion states. The captured states are applied to all 
automation types that are currently enabled in 
the Automation window.
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Capturing Automation Values for 
All Controls
You can capture the state of all automatable 
controls (except on tracks with their Automa-
tion Mode set to Off) in a session, regardless of 
whether they are currently writing automation.

To capture the automation values of all controls:

 When you reach a location where you want to 
capture the current automation states, Alt-click 
(Windows) or Option-click (Mac) the Capture 
button.

To capture the automation values of all controls on 
selected tracks only:

 When you reach a location where you want to 
capture the current automation states, Alt-Shift-
click (Windows) or Option-Shift-click (Mac) the 
Capture button.

Punching Automation Values for 
All Controls
You can punch all captured automation values 
to another location on their corresponding 
tracks (except those tracks with their Automa-
tion Mode set to Off). 

To punch the automation values of all controls:

 When you reach a location where you want to 
apply the captured automation states, Alt-click 
(Windows) or Option-click (Mac) the Punch 
Capture button. Any track set to Read or Touch 

are set to Latch. Any tracks set to Off are unaf-
fected. 



To punch the automation values of all controls on 
selected tracks only:

 When you reach a location where you want to 
apply the captured automation states, Alt-Shift-
click (Windows) or Option-Shift-click (Mac) the 
Punch Capture button. Any selected tracks set to 
Read or Touch are set to Latch. Any selected 
tracks set to Off are unaffected. 

Capture and Trim Mode
The Capture and Punch Capture commands 
work with Trim automation in the same way as 
regular automation. Pro Tools saves Trim status 
when capturing, so if you attempt to punch cap-
tured Trim values while displaying a non-Trim 
automation playlist, Pro Tools will automati-
cally apply the values to the corresponding Trim 
playlist. 

Punch Capture and “Write To” 
Commands
After issuing a Punch Capture command, the af-
fected controls are writing automation (in Latch 
mode), so any of the Write Automation To com-
mands can be used to extend the punched value 
in the same manner as other automation. 

Capture and Preview Mode

Loading Captured Values into Preview

You can preview and modify captured automa-
tion values in Preview mode before punching 
the values to the automation playlist. 

To capture an automation value and use it to 
preview:

1  Make sure the track where you want to preview 
the value is enabled for automation (Touch, 
Latch, Touch/Latch or their corresponding Trim 
modes).
2  Make sure the automation type you want to 
preview is enabled in the Automation window 
(Volume, Pan, Mute, Send level, Send pan, Send 
mute, or Plug-In). 

3  Capture an automation value that you want to 
preview in another location on a track. (See 
“Capturing Automation Values” on page 1073.)

4  Go to a location where you want to preview the 
captured automation states, and click the Pre-
view button in the Automation window. 

5  Click the Punch Capture button.

The affected controls are isolated and updated 
to the captured values. The Punch Preview but-
ton in the Automation window lights to indicate 
the preview value is available to punch.

6  Start playback and adjust the isolated control 
to audition the changes.

7  When you are ready to punch the preview 
value to the automation playlist, click the lit 
Punch Preview button.

Capturing Values While in Preview Mode

When you are in Preview mode, you can capture 
the values of isolated controls and apply them 
elsewhere on a track. By capturing preview val-
ues, you can leave the underlying automation 
unchanged at the place where you capture.

On ICON systems, you can use preview mode to 
capture multiple snapshots without changing 
automation. 

To capture a preview value:

1  Activate Preview mode and isolate a control. 
(See “Previewing New Automation Values” on 
page 1072). 

2  Start playback and adjust the isolated control 
to audition the changes.
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3  When you are ready to capture preview value, 
click the Capture button in the Automation win-
dow.

The Punch Capture button in the Automation 
window lights to indicate a captured value is 
available to punch.

VCA Master Track 
Automation
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

You can automate changes to VCA Master track 
controls (as well as the controls for VCA slave 
tracks).

Displaying Automation on VCA 
Master Tracks
The following controls on VCA Master tracks 
can be automated and have separate automation 
playlists:

• Volume

• Volume trim

• Mute

These automation playlists follow the same be-
havior as automation playlists on other track 
types. For more information on Volume trim au-
tomation, see “Trimming Automation” on 
page 1058. 
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Displaying the Composite 
Automation Playlist on Slave 
Tracks
When a track is a VCA slave, you can display a 
composite automation playlist that shows the 
contribution of the VCA Master to the Volume 
or Mute automation data on the slave track. This 
composite playlist reflects the actual position of 
the Volume fader on the slave track.The com-
posite playlist display cannot be directly edited.

To display the composite playlist on VCA slave 
tracks:

 Select View > Automation > Composite Playlist. 

Excluding VCA Slave Tracks 
from VCA Master Automation
When you are writing automation on a VCA 
Master track, the corresponding moves will ap-
pear on the composite automation playlist of 
each of its slave tracks. If you want to exclude a 
slave track from an automation pass, write-en-
able the slave track for automation.

To exclude a slave track from VCA Master track 
automation pass:

1  Write-enable the VCA Master track for auto-
mation (Write, Touch or Latch mode). 

2  Write-enable the slave track you want to ex-
clude for automation (Write mode). 

3  Make sure other slave tracks that you want to 
include in the pass are not write-enabled for au-
tomation. 

4  Start playback. 

Viewing composite automation on a VCA slave track

Volume
automation

Composite
playlist

playlist



5  Move the fader on the VCA Master track.

6  Stop playback. 

Automation is written on the excluded slave 
track such that the fader moves on the VCA Mas-
ter track are canceled out, and the fader on the 
excluded slave track does not move on subse-
quent playback. 

Coalescing VCA Automation
There are several ways to commit, or coalesce, 
the contribution of a selected VCA Master 
track’s Volume and Mute automation to the au-
tomation playlists of its slave tracks.

Clearing the VCA Master
You can use a VCA Master to write grouped au-
tomation, coalesce the VCA automation to all of 
the slave tracks, and clear the automation on the 
VCA Master. The coalesced tracks will play back 
exactly as they did when they were in the VCA 
group.

To coalesce automation from a VCA Master to all of 
its slave tracks and retain the VCA Master:

1  Select the VCA Master track whose automation 
you want to coalesce. 

Automation for excluded VCA slave track, canceling 
VCA Master automation

VCA Master

included slave

excluded slave
2  Do one of the following:

• Choose Track > Coalesce VCA Master Auto-

mation. 

– or –

• Right-click the VCA Master track name and 
choose Coalesce VCA Master Automation.

The composite Volume level and Mute state are 
coalesced to each of the slave tracks. The VCA 
Master Volume fader is reset to zero, the VCA 
Mute is set to unmuted, and any automation on 
the VCA Master is cleared.

Deleting the VCA Master
You can temporarily use a VCA Master to write 
grouped automation, then coalesce the VCA au-
tomation to all of the slave tracks by deleting the 
VCA Master. The coalesced tracks will play back 
exactly as they did when they were in the VCA 
group.

To coalesce automation from a VCA Master to all of 
its slave tracks and delete the VCA Master track:

1  Select the VCA Master track whose automation 
you want to coalesce.

2  Choose Track > Delete.

The composite Volume level and Mute state are 
committed to each of the slave tracks.

This action cannot be undone.
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Removing a Slave Track from a 
VCA Group
You can remove an individual slave track from a 
VCA group, which commits the VCA automation 
to that track, leaving the VCA Master and the 
other slave tracks untouched. The coalesced 
slave track plays back exactly as it did when it 
was in the VCA group.

To coalesce automation from a VCA Master to an 
individual slave track:

1  Do one of the following:

• Choose Modify Groups from the Group List 
menu. 

• Click the Group ID indicator on the track 
and choose Modify. 

• Right-click the Group name in the Group 
List and choose Modify.

2  In the Groups dialog, select the VCA-con-
trolled group that includes the slave track.

3  In the Groups dialog, click Tracks and remove 
the slave track from the group.

4  Click OK.

The slave track is removed from the VCA group, 
and the composite Volume level and Mute state 
are coalesced to the track. 
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Duplicating a Slave Track
When you duplicate a slave track without dupli-
cating its group assignments, the VCA automa-
tion is coalesced to the duplicate track. The co-
alesced duplicate plays back exactly as if it were 
in the VCA group. 

To coalesce automation from a VCA Master to a 
single slave track by duplicating the track:

1  Select the slave track whose automation you 
want to coalesce. 

2  Choose Track > Duplicate.

3  In the Duplicate Track dialog, deselect Group 

Assignments.

4  Click OK. 

The composite Volume level and Mute state are 
coalesced to the duplicate track. The original 
slave track is preserved, and the VCA group is 
unchanged.



Coalescing Automation Across 
an Edit Selection
You can commit VCA automation across an Edit 
selection in a VCA Master track, without com-
mitting the automation on the entire length of 
the track.

To coalesce automation in an Edit selection on a 
VCA Master track:

1  Select the VCA Master track whose automation 
you want to coalesce.

2  Make an Edit selection in the VCA Master 
track that includes the range of automation you 
want to coalesce.

3  Do one of the following:

• Hold Start (Windows) or Control (Mac) and 
choose Track > Coalesce VCA Master Auto-

mation. 

– or –

• Hold Start (Windows) or Control (Mac) and 
Right-click the VCA Master track name and 
choose Coalesce VCA Master Automation. 

The composite Volume level and Mute state are 
committed to each of the slave tracks over the 
Edit selection. The VCA Master Volume is set to 
zero, the VCA Mute state is set to unmuted, and 
any automation on the VCA Master is cleared for 
the selected area only. 
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Chapter 46: Mixdown
Pro Tools lets you mix down by recording a mix 
to new audio tracks or by bouncing a mix to disk.

Recording to Tracks This is the process of sub-
mixing and recording the submix to new audio 
tracks, as you would any other track input sig-
nals. This method requires available tracks, 
voices, and bus paths to accommodate the sub-
mix and the new tracks. While recording to 
tracks, you can manually adjust mixer or other 
controls.

Record to new tracks if you want to adjust mixer 
controls during the mixdown. 

Bouncing to Disk The Bounce to Disk command 
lets you write a final mix, create a new loop, 
print effects, or consolidate any submix to new 
audio files on disk. This method lets you write 
all available voices to disk without holding any 
in reserve.

Any available output or bus path can be selected 
as the bounce source. Sample rate, bit depth, 
and other conversion processes can be applied 
during or after the bounce. Though you can hear 
the bounce being created in real time, you can-
not adjust mixer or other controls while bounc-
ing to disk. 

Use Bounce to Disk if you need to convert the 
bounced files, or if you do not want to manually 
adjust mixer controls during the mixdown. 
Selecting Audio for Loops, 
Submixes, and Effects
Both Bounce to Disk and recording to tracks op-
erate on the current Timeline or Edit selection, 
if one exists. This makes it easy to turn multi-
track selections into mono, stereo, or multi-
channel loops. Submixes, stems, and other spe-
cialized types of mixes can also be recorded (or 
“printed”) to disk using either method, or 
played out to another recording, transfer, or ar-
chiving medium. 

Printing effects to disk is the technique of per-
manently adding real-time effects, such as EQ or 
reverb, to an audio track by bussing and record-
ing it to new tracks with the effects added. The 
original audio is preserved, so you can return to 
the source track at any time. This can be useful 
when you have a limited number of tracks or ef-
fects devices. 

AudioSuite plug-ins provide another option 
for writing (or “printing”) a plug-in effect to 
disk. For more information, see Chapter 40, 
“AudioSuite Processing.”
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Dithering
Dither can significantly improve audio quality 
when reducing the bit depth of digital audio. 

When to Use a Dither Plug-In
You should use a dither plug-in in any situation 
where you are reducing bit depth, for example, 
when mixing down to a 16-bit file with the 
Bounce to Disk command, or when sending your 
final mix to an external digital device that re-
cords at 16-bit resolution.

A dither plug-in is necessary even when mixing 
down to 16-bit from a 16-bit session. Even 
though 16-bit sessions use 16-bit files, they are 
still processed at higher internal bit depths.

• Pro Tools|HD systems use 24-bit audio input 
and output signal paths, and internal 48-bit 
mixing and processing

• Pro Tools systems use 24-bit audio input and 
output signal paths, and internal 32-bit float-
ing point processing for mixing and audio pro-
cessing

For this reason, whether you are working with a 
24-bit session or a 16-bit session, the following 
are recommended:

• When mixing down to a 16-bit destination, 
use a dither plug-in on the main output.

• When bus recording a submix to a track in the 
same session, do not use a dither plug-in on 
the destination track.

• When mixing down to a 24-bit destination, 
do not use a dither plug-in on the main
output.

• When mixing down to an analog destination 
with any 24-bit capable interface, do not use a 
dither plug-in on the main output. 
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• During normal recording and playback, by-
pass any dither plug-in on the main output.

Bounce to Disk and Dither
Bouncing to disk does not apply dither when re-
ducing bit depth. To apply dither when bounc-
ing to disk, you should insert a dither plug-in as 
the last processor in the signal path on a Master 
Fader assigned to the bounce source audio out-
put path. 

Using a dither plug-in on a Master Fader is pref-
erable to an Auxiliary Input because Master 
Fader inserts are post-fader. As a post-fader in-
sert, the dither plug-in can process changes in 
Master Fader level. 

If you do not use a dither plug-in on your 
bounce source path, and you choose to convert 
to a lower resolution during or after bouncing to 
disk, the resulting file will be converted by trun-
cation. 

Using Dither on an Output Mix
Pro Tools includes real-time dither plug-ins 
that improve 16-, 18-, or 20-bit performance 
and reduce quantization artifacts when reduc-
ing the bit depth of an output mix.

To use a dither plug-in on an output mix:

1  Choose Track > New and create a (stereo) Mas-
ter Fader track.

2  Set the output of the Master Fader to the out-
put or bus path you want to bounce.

3  Assign the outputs of all audio tracks in the 
session to the same path you selected in step 2. 
The Master Fader now controls the output levels 
of all tracks routed to it.

4  On the Master Fader, insert a dither plug-in as 
the last processor in the signal chain.



5  In the dither plug-in window, choose an output 
Bit Resolution and Noise Shaping setting.

6  Do one of the following:

• Play back the session to record (or “lay-
back”) Pro Tools output to lower bit-rate 
media (such as a DAT).

– or –

• Choose File > Bounce To > Disk. In the 
Bounce to Disk dialog, select the appropri-
ate bit depth (such as 16-bit for CD audio). 
Before being converted by the Bounce to 

Disk command, the signal is processed ac-
cording to the resolution and noise shaping 
settings in the dither plug-in inserted on 
the Master Fader.

Sample Rate Conversion and Bit 
Depth Reduction
If you want to do both a sample rate conversion 
and a bit depth reduction when mixing down, 
first convert the sample rate while maintaining 
the higher bit depth, and then reduce the sample 
rate-converted file to the lower bit depth, using 
a dither. By keeping the higher bit depth when 
performing the sample rate conversion, you en-
sure the highest possible audio quality.

 For information about dither plug-ins, see 
the Audio Plug-Ins Guide.
Bus Recording to Tracks
You can create a submix in your Pro Tools ses-
sion and bus record it to available tracks in the 
same session. This technique lets you add live 
input to the mix, as well as adjust volume, pan, 
mute, and other controls during the recording 
process. You can also use this technique instead 
of Bounce to Disk to create mixed tracks directly 
in your Pro Tools session.

Voice Requirements for 
Recording a Submix
Recording a submix to new tracks requires an 
available voice for each track that you want to 
record. Make sure you have enough voices avail-
able to play back all tracks that you want to re-
cord and enough voices available to record the 
destination tracks. 

In contrast, the Bounce to Disk command lets 
you bounce all available voices to disk without 
holding any in reserve, but you cannot manually 
change any controls during the bounce. For 
more information, see “Bounce to Disk” on 
page 1084.

For information about voice management, 
see “Track Priority and Voice Assignment” 
on page 241.

With Pro Tools HD, RTAS plug-ins placed 
on Auxiliary Input, Master Fader, and In-
strument tracks will use additional voices 
and may introduce extra latency based on 
the H/W Buffer Size. For more information, 
see “Voice Usage and Total Latency for Na-
tive (Host-Based) Plug-Ins” on page 991. 
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To record a submix to a track:

1  Apply any plug-ins or external processors you 
want to add to your audio tracks or Auxiliary In-
puts before you record.

2  Set the main channel output of the tracks you 
want to include in the submix to a bus path. If 
you are using stereo or multichannel tracks, set 
the panning of each track.

3  Make sure Loop Record is not enabled.

4  Choose Track > New and create one or more 
mono, stereo, or multichannel audio tracks. 

5  If you are recording in stereo, pan the new ste-
reo track (or mono tracks) hard left and right.

6  Set the input of each destination track to the 
bus path from which you are recording.

7  Set the output of your new tracks to your main 
output path.

8  Ensure that Options > Link Timeline and Edit Se-

lection is selected.

9  Select audio to record. The start, end, and 
length of the recording can be based on the cur-
sor location or Timeline and Edit selections. 

• Selection-based recording automatically 
punches in and out of recording at the se-
lection start and end. Be sure to include 
time at the end of a selection for reverb 
tails, delays, and other effects.

• If you do not make a selection, recording 
will begin from the location of the playback 
cursor. Recording will continue until you 
press Stop. 

10  Record enable the new tracks and click Re-
cord in the Transport. 

11  Click Play to begin recording the submix.

12  If recording a selection, recording will stop 
automatically. If performing an open-ended re-
cording, click Stop, or punch out of recording. 
Pro Tools Reference Guide
13  When the recording has finished, you can ex-
port the bus recorded clip using the Export Clips 

as Files command (see “Exporting a Clip as a 
New Audio File” on page 346). 

Bounce to Disk
The Bounce to Disk command lets you mix down 
any or all of the available voices on your system. 
Bouncing records to separate audio files, so you 
do not have to reserve any tracks for a bounce. 
Pro Tools bounces are real-time, so you can lis-
ten to audio playback of your mix during the 
bounce process. 

You can use the Bounce to Disk command to cre-
ate and automatically import or export loops, 
sub-mixes, or any other session generated audio 
clips into your session. You can use it to create a 
final mono, stereo, or multichannel master files 
in any of several audio file formats. Bounce to 

Disk also provides conversion options for sam-
ple rate, bit resolution, and format. 

To Bounce to Disk (basic instructions): 

1  Make a Timeline selection to define the range 
to be bounced.

2  Choose File > Bounce to > Disk.

3  Configure the Bounce options (see “Bounce 
Options” on page 1085). 

4  Click Bounce.

When you bounce to disk, the resulting file in-
cludes the following:

Audible Tracks All audible tracks that are routed 
to the output which is selected as the source of 
the bounce are included in the bounce. Any 
muted tracks are not included in the bounce. If 
you solo one or more tracks, only the soloed 
tracks are included in the bounced mix.



Automation All read-enabled automation is 
played back and incorporated in the bounced 
mix. 

Inserts and Sends All active inserts, including 
real-time plug-ins and hardware inserts, are ap-
plied to the bounced mix.

Selection or Track Length If you make a selec-
tion in a track, the bounced mix will be the 
length of the selection. If there is no selection in 
any track, the bounce will be the length of the 
longest audible track in the session.

Time Stamp Information Bounced material is au-
tomatically time stamped so that you can drag it 
into a track and place it at the same location as 
the original material. For more information 
about time stamping, see “Time Stamping” on 
page 1162.

Bounced Files Are Delay-Compensated

Pro Tools compensates for any bus and plug-in 
delays when bouncing to disk. This means that if 
a bounced file is imported back into a session, 
and placed directly in time against the source 
mix, it is time-aligned with the original source 
mix.

Record-Enabled Tracks and TrackInput-
Enabled Tracks Cannot Be Bounced

Pro Tools does not include tracks that are either 
record-enabled or in Input Only monitoring 
mode in the bounce.

Bouncing with Mute Frees 
Assigned Voice 
(Pro Tools|HD Systems Only)

When bouncing sessions that include muted 
tracks, enabling “Mute Frees Assigned Voice” 
can, in some instances, increase the number of 
tracks that can be successfully bounced. See 
“Mute Frees Assigned Voice” on page 250.
Bounce Options
When you use the Bounce to Disk command, you 
can configure several file options.

Bounce Source
All currently active output paths (both internal 
mix busses and output busses) and physical out-
puts as defined in the I/O Setup dialog are avail-
able as the Bounce Source. 

To set the bounce source:

 Select a bus path, output path, or physical out-
put from the Bounce Source selector.

Bus bounced file includes only audio routed to 
the selected internal mix bus path.

Output The bounced file includes only audio 
routed to the selected output bus path.

Physical Output The bounced file includes only 
audio from all output paths mapped to the se-
lected physical output. This is useful when 
working with overlapping output paths. 

Bounce to Disk dialog, with conversion and options 
enabled
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File Type
The File Type selector lets you select the file type 
for bounced files.

SD II (Sound Designer II)
(Mac Only)

This was the native format for older Mac-based 
Pro Tools systems. Pro Tools can export SD II 
format files, but they will have to been con-
verted to .WAV or .AIF on import.

WAV (Broadcast .WAV Format)

This format is supported on Windows and Mac. 
To use a WAV file in Pro Tools, you can drag 
and drop from the DigiBase browser, Windows 
Explorer or Mac Finder, or a folder, or you can 
use the Import Audio command. Files in this for-
mat do not have to be converted to be used in 
Pro Tools.

AIFF (Audio Interchange File Format)

This format is supported on Windows and Mac. 
To use an AIFF file in Pro Tools, you can drag 
and drop from the DigiBase browser, Windows 
Explorer or Mac Finder, or you can use the Im-

port Audio command. Files in this format do not 
have to be converted to be used in Pro Tools.
Pro Tools Reference Guide
MP3 (MPEG-1 Layer 3)

The MPEG-1 Layer 3 (MP3) compression format 
is used for streaming and downloading audio 
over the Internet, and for playback on portable 
devices. 

When you select this format, the Resolution pop-
up menu in the Pro Tools Output Options dialog 
is unavailable. The resolution is set by the en-
coder.

The sample rate chosen is given to the codec as a 
base sample rate for operations. The actual sam-
ple rate of the resulting file is determined in the 
MP3 Encoder Options dialog. For example, if a 
base sample rate of 48000 Hz is chosen, the MP3 
Encoder Options dialog will allow output 
streams in 48, 24, or 12 kHz, depending on en-
coding quality.

MP3 Export Options



When you export or bounce to MP3 format, you 
can set the following options:

Encoder Settings

Encoder Speed Determines the audio quality of 
the bounced file. There are two options: Highest 

Quality and Fastest Encoding Time. 

The Highest Quality option can take up to five 
times longer to process audio than the Fastest 

Encoding option, so you should use it only when 
the highest fidelity is essential and you have the 
time to devote to the encoding process. 

Constant Bit Rate (CBR) Encodes the file at a 
single bit rate that you choose from the Constant 

Bit Rate (CBR) pop-up menu. Because the bit 
rate is fixed, the quality of the encoded audio 
will vary depending on the nature of the mate-
rial being compressed. The 128 kbit/s option is 
generally best for streaming over the Internet, 
since it has predictable bandwidth require-
ments. 

Enable MP3 Surround Encoding This option is 
available only when bouncing stereo output to 
an interleaved MP3 file. The stereo output is up-
mixed and encoded to a 5.1-channel surround 
MP3 file that is also compatible with stereo MP3 
playback.

For complete information on requirements 
for MP3 surround playback, visit 
www.fraunhofer.com.
ID3 Tag Info Settings

ID3 Tag Type The ID3 tag stores data about the 
encoded audio file that is used by MP3 players to 
display information about the file. Pro Tools 
supports three versions of this tag, in order to 
provide backward compatibility with older MP3 
players: 

• ID3 v1.0: Appears at the end of a streaming 
MP3 file, so that tag information is only dis-
played after software streaming is finished.

• ID3 v1.1: Same as version 1.0, but adds track 
number information to the tag.

• ID3 v2.3: Appears at the front of a streaming 
MP3 file, so that tag information is displayed 
when streaming begins.

Title/Artist/Album/Comment Type the title, art-
ist, and other information for the MP3 file. This 
information is displayed by many MP3 players.

Genre Choose a genre for the file. This informa-
tion is displayed by many MP3 players, and can 
appear in searchable catalogs and databases.

Track Number If you select ID3 tag type v1.1 or 
v2.3, you can enter a CD track number for the 
file. This information is displayed by many MP3 
players.

Year Enter a year for the file. This information is 
displayed by many MP3 players.

While ID3 v2.3 is the current standard MP3 
format, not all MP3 players support ID3 
v2.3. Contact the player software 
developer for compatibility information.
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Mac File Settings

Mac File Type and Creator If you expect your file 
to be used on a Mac, you can enter the Mac file 
type and creator. This will allow users to double-
click the file to open their MP3 player.

Default Button

To restore all settings in this dialog to their de-
fault values, click Defaults.

QuickTime 

QuickTime is Apple’s multimedia audio file for-
mat. Pro Tools does not directly support this 
type of file in its sessions. To use a QuickTime 
audio file within Pro Tools, use the Import Audio 
command. The QuickTime format is popular for 
attaching to emails, to simplify long-distance 
project review and approval. Many popular mul-
timedia applications also support QuickTime.

Windows Media 
(Windows Only)

Windows Media formatted files can contain au-
dio, video, or script data stored in Windows Me-
dia Format. A Windows Media Format file may 
have an .asf, .wma, or .wmv file name extension.

MXF (Material Exchange Format)

MXF is a media file format that includes both 
video and audio files, and is designed for the in-
terchange of audio-visual material with associ-
ated data and metadata. It was designed for im-
proving file-based interoperability between 
servers, workstations, and other content cre-
ation devices.

AAF and OMF sequence format files can refer to 
MXF media files, or have MXF media files em-
bedded within them. Pro Tools supports AAF 
embedded sequences.
Pro Tools Reference Guide
Format
This is the format for the bounced result. Op-
tions include Mono (Summed), Multiple Mono, 
and Interleaved. 

To set the format of the bounced file:

 Select a file format from the Format selector.

Mono (Summed) Creates a single disk file that is 
a summed mono mix of the current sources be-
ing monitored. 

Before bouncing to disk, make sure your levels 
are below –3 dB to avoid clipping that occurs 
when left and right signals exceed –3 dB below 
maximum, or full code (0 dBFS).

Multiple Mono Creates multiple mono files with 
the same number of channels as the source path. 

• If the source output or bus path is stereo, two 
mono files will be created, and appended with 
“.L” and “.R” suffixes on bounce. 

• If a multichannel format is used (for example, 
six-channel, 5.1), individual mono files will be 
created for each member of the path. Files will 
be appended with path suffixes according to 
the path definition in the I/O Setup dialog.

• If the source output or bus path is mono, the 
pop-up menu will switch from multiple mono 
to mono, and will create one mono file (no 
summing of multiple sources).

Interleaved Creates a single, interleaved file that 
contains all of the bounced streams from the 
chosen output path. In an interleaved stereo 
bounce, tracks assigned to odd-numbered out-
puts are sent to the left channel, and tracks as-
signed to even-numbered outputs are sent to the 
right channel.



Pro Tools also lets you bounce multichannel in-
terleaved files of any supported multichannel 
file type (such as 5.1). This can simplify file 
management of mixes and projects for backup 
and archiving. 

Bit Depth
This setting lets you select between four differ-
ent bit-depths for the bounce conversion. Note 
that Bounce to Disk does not apply dither when 
converting during or after a bounce to a lower 
resolution. If you need to bounce to a lower res-
olution file, use a dither plug-in on a Master 
Fader track assigned to the bounce source path. 
This dithers the bounced file, before the Bounce 

to Disk conversion truncates the bounced file to 
the selected bit depth resolution. (See “Dither-
ing” on page 1082.)

The following Bit Depth options are available:

8-Bit This resolution is often used in multimedia 
applications. If the material you are working 
with is relatively simple, you can use the 
Pro Tools “Squeezer” feature for optimal re-
sults. See “Use Squeezer” on page 1090 for de-
tails.

16-Bit This is the Compact Disc standard bit res-
olution. 

24-Bit This setting provides the highest resolu-
tion that is compatible with most audio inter-
faces. It is useful when you want to create a final 
mix without losing any resolution (for example, 
if you are delivering a final mix that will be 
ready to master).

If your session is 16-bit, you should still use 
a dither plug-in on the output mix, because 
all Pro Tools systems process audio inter-
nally at higher bit depths.
32-Bit Float This setting provides the highest 
resolution for internal Pro Tools mixing and 
plug-in processing. It is useful when you want to 
export and re-import loops and sound effects 
into your Pro Tools session, or when you are ex-
changing files between Pro Tools sessions.

To set the resolution of the bounced file:

 Select a bit depth from the Bit Depth

selector.

Sample Rate
This option lets you save to any of several sam-
ple rates. Choices are dependent on your 
Pro Tools system and audio interfaces. Options 
can include sample rates from 8 kHz to 192 kHz, 
including sample rates with Pull Up and Pull 
Down options.

Sample Rate Conversion Quality

If you choose a sample rate that differs from the 
original sample rate of the session, the conver-
sion options become available. You can config-
ure the conversion quality, and schedule con-
version to occur during, or after, the bounce. See 
“Sample Rate Conversion Quality” on page 1090 
for more information.

Common Sample Rates

The following are the more common sample 
rates, and their applications. Higher sampling 
rates will provide better audio fidelity for re-
cording and playback, and also for processing 
with dynamics, dither (with noise shaping), and 
analog emulation plug-ins.

192 kHz This is a supported sample rate for some 
audio DVDs, and provides the highest quality 
audio fidelity with compatible audio interfaces 
(such as the 192 I/O).
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176.4 kHz You may want to work at a sample rate 
of 176.4 kHz if the final delivery will be at 
44.1 kHz (such as compact disc). This will pro-
vide a slightly faster sample rate conversion to 
44.1 kHz than from 192 kHz.

96 kHz This is a supported sample rate for DVD 
audio and provides high-quality audio fidelity 
with compatible audio interfaces (such as the 
192 I/O, 96 I/O, 96i I/O, 003, and Digi 002). 

88.2 kHz You may want to work at a sample rate 
of 88.2 kHz if the final delivery will be at 
44.1 kHz (such as compact disc). This will pro-
vide a slightly faster sample rate conversion to 
44.1 kHz than from 96 kHz.

48 kHz This is a standard sample rate for Profes-
sional and DVD video, as well as some broadcast 
and recording label archiving, and is supported 
by DA-88/98, DAT, and ADAT decks.

44.1 kHz This is the standard sample rate for 
compact discs (CD), and is supported by DA-
88/98, DAT, and ADAT decks.

Additional sample rate options include 8 kHz, 
11.025 kHz, 16 kHz, 22.050 kHz, and 32 kHz.

Custom For a custom sample rate, click in the 
sample rate window and manually enter in a 
value from 4,000 to 200,200 samples.

Pull-Up and Pull-Down Rates All available sam-
ple rates support pull-up and pull-down rates, 
or other specialized rates. 

Sample Rate Conversion Quality
When you specify a different sample rate for a 
bounced file (for example, when mixing a ses-
sion recorded at 96 kHz to 44.1 kHz for release 
on an audio CD), Pro Tools uses the Conversion 

Quality option to determine the quality of sam-
ple rate conversion used. 
Pro Tools Reference Guide
There are five possible settings, ranging from 
Low (lowest quality) to Tweak Head (highest 
quality). The higher the quality of sample rate 
conversion, the longer it takes to convert the 
bounced file.

Use Squeezer
(8-Bit Resolution Only)

The Use Squeezer option uses a proprietary DSP 
algorithm specifically designed for performing 
8-bit conversion of simple source files such as 
voice-overs. It optimizes the dynamics of the au-
dio by preprocessing it using compression, lim-
iting, and gating before conversion to 8-bit res-
olution. This results in greater apparent 
loudness in the signal, and improved intelligi-
bility. If you are converting a more complex 16-
bit audio file to 8-bit resolution, test this option 
before converting all of your material.

Enforce Avid Compatibility
Enable this option in the Bounce to Disk dialog 
to create a bounced file with frame-accurate ed-
its, wrapped as OMFI (unless File Type is MXF), 
and with the sample rate options limited to 
44.1 kHz or 48 kHz. Dither without noise shap-
ing will be applied to files being exported from 
24-bit to 16-bit.

Convert During or After Bounce
The Bounce to Disk dialog can perform any con-
version options, including sample rate and bit 
depth conversion, during a bounce or post-
bounce. 

The following options are only available when 
bouncing to a different file type, format, resolu-
tion, or sample rate.



Convert During Bounce This option may take 
less time than Convert After Bounce, but does so 
at the expense of plug-in automation playback 
accuracy.

Convert After Bounce The Convert After Bounce 
option, though it takes more time, offers the 
highest level of plug-in automation accuracy 
possible. 

Add to iTunes Library
Pro Tools lets you bounce your mix to your 
iTunes library using the Add to iTunes Library op-
tion in the Bounce to Disk dialog. When this op-
tion is selected, the bounced file is copied to 
your local iTunes library. You can specify the lo-
cation of your iTunes library using the new 
iTunes Library Folder setting in the Pro Tools Op-
eration preferences.

If the Add to iTunes Library option is enabled 
when bouncing to disk, the resultant audio file 
is automatically imported into iTunes the next 
time you launch the iTunes application. If 
iTunes is not installed on your computer, this 
option does not do anything.

To export your mix to your iTunes library:

1  Choose File > Bounce to > Disk.

2  In the Bounce to Disk dialog, select the Bounce 

Source and set the other options as desired.

3  Enable the Add to iTunes Library option.

4  Click Bounce.

The Add to iTunes Library option is only 
available if the Bounce Source is set to a 
mono or stereo path, and Format is set to 
Mono (Summed) or Interleaved.
Share with SoundCloud
SoundCloud is a social audio sharing site. Users 
create a public profile and fill it with audio they 
want to share. The audio can then be played by 
anyone, or by a select group of users. Sound-
Cloud's easy sharing tools let you feature your 
tracks or playlists on any website, including so-
cial networks (such as Twitter, Facebook, and 
Google+).

Pro Tools lets you share your mix with Sound-
Cloud using the Share with SoundCloud option in 
the Bounce to Disk dialog and in the Export Se-
lected dialog. When this option is selected, the 
bounced file is automatically uploaded to your 
SoundCloud account. If you do not have an ac-
count, you can create one for free. 

To share your mix with SoundCloud using Bounce 
to Disk:

1  Choose File > Bounce to > Disk.

2  In the Bounce to Disk dialog, select the Bounce 

Source. 

3  Ensure that Format is set to Mono (Summed) or 
Interleaved.

4  Enable the Share with SoundCloud option.

5  Click Bounce.

6  Configure the Share with SoundCloud dialog 
as desired (see “Share With SoundCloud Dialog” 
on page 1093).

7  Click Share.

The Share with SoundCloud option is only 
available if the Format is set to Mono 
(Summed) or Interleaved.

For more information about SoundCloud, 
visit www.soundcloud.com.
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8  If you are not already logged in to your Sound-
Cloud account, you are prompted to log in (see 
“Logging In To SoundCloud” on page 1092).

The bounced file is written to your local drive 
and then posted directly to your SoundCloud ac-
count if you are logged in.

Monitoring the Progress of the Upload

You can monitor the progress of the upload in 
the Task Manager (Window > Task Manager).

If the Notify me when the upload is complete op-
tion is enabled in the Share with Sound Cloud 
dialog, you are notified by the Upload Successful 
dialog (where you can copy the URL to the clip-
board) once the bounced file has posted to your 
SoundCloud account.

Task Manager displaying the progress of an upload to 
SoundCloud

Upload Successful dialog
Pro Tools Reference Guide
Logging In To SoundCloud

To log in to (and, if necessary, set up) your 
SoundCloud account:

1  Choose Setup > Login to SoundCloud.

2  Do one of the following:

• To use an existing account, enter the 
Email\Login and Password for your Sound-
Cloud account, and click the Connect but-
ton.

– or –

• To create a new account, click the Not a 

member? Signup! button. Once the Sound-
Cloud site opens in your default web 
browser, follow the on­screen instructions

Login to SoundCloud dialog



Share With SoundCloud Dialog

The Share with SoundCloud dialog provides text 
entry fields, settings, and options that deter-
mine what information is included with the 
track you upload to SoundCloud. It also includes 
licensing and permissions settings for what your 
track can be used for and who can access it. The 
information, options, and settings associated 
with your track can also be edited online later 
from your SoundCloud account. 

Title

Type in the Title for the track you are uploading 
to SoundCloud.

Description

Type in a Description for the track you are up-
loading to SoundCloud.

For more information, visit 
www.soundcloud.com.

Share with SoundCloud dialog
License

Select the License option appropriate to the 
track you are uploading to SoundCloud.

Type

Select the Type of track you are uploading to 
SoundCloud.

Downloadable

Select the Downloadable option if you want your 
track to be downloadable from SoundCloud. If 
this option is not enabled, your track can only be 
streamed (listened to) online and cannot be 
downloaded.

Genre

Type a Genre for the track you are uploading to 
SoundCloud.

Tags

Type any Tags you want associated with the 
track you are uploading to SoundCloud. Sepa-
rate multiple tags with spaces. Encapsulate tags 
with multiple words and spaces using quotes.

Private Track

Enable the Private Track option to ensure that 
the track you are uploading to SoundCloud is 
only available to specific people. When this op-
tion is selected, you can enter the email ad-
dresses for the people who you want to have ac-
cess to your track. Separate multiple addresses 
with commas.

Notify

Enable the Notify me when the upload is complete 
option to be notified when your track has fin-
ished uploading to your SoundCloud account.
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Import After Bounce
The Import After Bounce option automatically 
imports the newly bounced files into the Clip 
List so you can place them in tracks. If your 
newly bounced files are split stereo files (Multi-
ple Mono), they are listed together in the Clip 
List.

Cancel
The Cancel button closes the Bounce to Disk di-
alog without initiating the bounce to disk con-
version.

Help
The Help button in the Bounce to Disk dialog 
opens a display-only dialog that describes the 
Bounce to Disk features.

Bounce
The Bounce button initiates the bounce to disk 
conversion. A Save dialog opens in which you 
can navigate to and select where you want to 
save the bounced file. Once you have selected 
the location and clicked Save, a progress win-
dow opens and progressively shows you how 
much time remains for the bounce to complete.

The Import After Bounce option is only 
available if the target file type and sample 
rate for the bounce is the same as the file 
type and sample rate of the current session, 
and the target resolution (bit rate) is the 
same or lower than the resolution of the ses-
sion. In addition, tracks bounced to a Stereo 
Interleaved file cannot be automatically 
imported after a bounce.
Pro Tools Reference Guide
Recording a Submix (with 
Bounce to Disk)
You can create a submix with the Bounce to Disk 
command by muting tracks or bypassing inserts 
that are not part of the submix, and selecting the 
part of the session you want to bounce; or, you 
could solo only the audio you want to bounce.

You can also create a submix by recording to 
new tracks. For details, see “Sample Rate Con-
version and Bit Depth Reduction” on page 1083.

To bounce a submix to disk:

1  Configure your submix using sends, Auxiliary 
Inputs, and Master Faders. (See “Signal Routing 
for Monitoring and Submixing” on page 970.)

2  Do one of the following:

• To bounce the entire session, click Return 
to Zero in the Transport window to go to 
the beginning of the session. 

– or –

• To bounce a portion of the session, enable 
Options > Link Timeline and Edit Selection, 
and make a selection in the Edit window.

3  Choose File > Bounce to > Disk.

4  Configure bounce options and settings. 

5  Verify the bit resolution for the bounced file 
matches the bit resolution of the session.

6  Verify the sample rate for the bounced file is 
supported by the session and the audio interface.

7  If required, verify the file type and format for 
the bounced file matches the file type and format 
of the session.

8  If you want to bring the bounced file into your 
current session, select the Import After Bounce 
option.



9  Click Bounce.

10  Select a destination for the new audio file, en-
ter a name, and click Save.

Pro Tools bounces are done in real time, so you 
hear audio playback of your mix during the 
bounce process. You cannot adjust controls 
while bouncing to disk. 

To bring bounced files back into tracks:

1  Do one of the following:

• If the newly bounced audio was automati-
cally imported into the session, drag the 
new files from the Clip List to existing 
tracks in your session.

• If the bounced files are not available in the 
Clip List, import them into the session with 
the Import Audio command, or drag and 
drop the bounced files from a DigiBase 
browser. 

• If you are placing multiple files, keep chan-
nels time-aligned with each other by Shift-
selecting them in the Clip List, and drag-
ging them simultaneously into existing 
tracks of the correct format. 

2  When working with stereo tracks, set the Pan 
controls hard left and hard right.

3  Solo the track with the bounce on it.

4  Click Play in the Transport to hear the results 
of the bounce.

If you bounced from a selection point, you 
can snap the file to the bounce point: Start-
drag (Windows) or Control-drag (Mac) the 
clip from the Clip List to the destination 
track.
Final Mixdown (with Bounce 
to Disk)
In final mixdown, you create a mix that includes 
all your edits, automation, and effects process-
ing.

To bounce a final mix to disk:

1  Adjust track output levels, and finalize any 
mix automation for each track in the session.

2  Adjust any real-time plug-in and effects set-
tings and their automation for each track in the 
session.

3  Make sure that all of the tracks you want to in-
clude in the bounce are audible (not muted or in-
active).

4  Assign the output of each of the tracks you 
want to include in your bounce to the same out-
put or bus path.

5  Add dither (see “Dithering” on page 1082).

6  Do one of the following:

• To bounce the entire session, click Return 
to Zero in the Transport to go to the begin-
ning of the session. 

– or –

• To bounce a portion of the session, enable 
Options > Link Timeline and Edit Selection, 
and make a selection in the Edit window.

7  Choose File > Bounce to > Disk.

8  Choose the source path you want to bounce.

9  Configure other Bounce to Disk settings as ap-
propriate. See “Bounce Options” on page 1085.

By default, the bounce will end at the last au-
dio waveform or MIDI note. To end the 
bounce sooner, make an Edit or Timeline 
selection to define the end (and start) of the 
bounce.
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10  Click Bounce.

11  Select a destination for the new audio file, en-
ter a name, and click Save.

Mastering
In the final mastering process, you might record 
directly to disk, DAT, DVD, CD, stereo master-
ing recorder, or a multitrack recorder (for sur-
round mixes).

Once you have created a master of your session, 
you can transfer it to a portable medium for du-
plication. You can transfer the master file to CD 
or DAT to be used as a master for pressing com-
pact discs.

Mastering to a Digital Recorder
Although it is usually best to master sessions di-
rectly to hard disk, Pro Tools also lets you mas-
ter digitally, direct to any AES/EBU-equipped or 
S/PDIF-equipped digital recorder such as a DAT 
deck.

24-Bit Input and Output
Pro Tools|HD systems support full 24-bit audio 
input and output signal paths, with 48-bit inter-
nal mixing and processing, providing an addi-
tional 16 bits of headroom at the top of a chan-
nel’s dynamic range, and 8 bits at the bottom. 
You can exchange files with other 24-bit record-
ing systems without any bit-depth conversion 
(as long as they are in a compatible file format).

Pro Tools systems support 24-bit input and out-
put, and uses 32-bit floating point mixing and 
processing internally. You can exchange files 
with other 24-bit recording systems without any 
bit-depth conversion (as long as they are in a 
compatible file format).
Pro Tools Reference Guide
Mastering and Audio 
Compression
Although audio compression is often an indis-
pensable tool in analog recording, it can present 
problems in the digital domain. If you compress 
an input signal at a very high ratio, you create a 
signal that contains a much higher overall power 
level compared to its transients. By recording a 
number of such signals at the highest possible 
level on multiple tracks, you create a scenario 
that is more likely to clip the mixed output sig-
nal.

High-power compressed signals, when mixed 
together, create an extremely high-level output. 
This output may rise above the full-code level, 
resulting in clipping. 

To avoid this problem, watch the overall level of 
your program material—use a meter on a Master 
Fader, or use an external mastering deck’s me-
ters to help identify clipping. If you are master-
ing to hard disk, avoid mixing full-code audio 
signals together at unity or “0” level, as this in-
variably causes clipping.

Mastering and Error-Correcting 
Media
Random access media (such as hard disks, opti-
cal cartridges, Bernoulli cartridges or WORM 
drives) can produce a true digital copy of your 
data, because every bit value is maintained. Se-
quential media (such as DAT tapes) use error 
correction schemes to fix the occasional bad 
data that is received in a digital transfer. These 
corrections are deviations from the actual data, 
and with successive reproductions, represent a 
subtle form of generation loss.



You can avoid this loss by creating and main-
taining masters on random-access digital media 
(such as a hard drive) and transferring them to 
sequential digital media (such as DAT tapes) 
only as needed.

To configure Pro Tools for direct digital stereo 
mastering:

1  Connect your digital recorder to your system’s 
digital outputs. If your system has multiple dig-
ital outputs, use channel 1 and 2 of the audio in-
terface.

2  In Pro Tools, set the appropriate digital format 
and output from the Hardware Setup dialog or 
I/O Setup dialog. (See “Configuring Pro Tools 
Hardware Settings” on page 70.)

3  Set the clock on the master device to slave to 
Pro Tools digital clock, or to provide master 
clock to Pro Tools. (See “Configuring Pro Tools 
Hardware Settings” on page 70.)

4  On your digital recorder, choose the appropri-
ate digital format for the connections.

5  In Pro Tools, set all audio tracks you want to 
your master outputs 1–2 path.

6  Click Return to Zero in the Transport to go to 
the beginning of the session.

7  Press Record on your digital recorder.

8  Start playback of your session.

9  When your session has finished playing, stop 
the digital recorder.
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Part X: Surround





Chapter 47: Pro Tools Setup for Surround
Pro Tools HD and Pro Tools with Complete 
Production Toolkit let you work with surround 
formats up to 7.1. 

Surround Mixing in Pro Tools
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit)

Pro Tools supports mixing in the following mul-
tichannel (greater than stereo) formats: LCR, 
Quad, LCRS, 5.0, 5.1, 6.0, 6.1, 7.0, 7.0 SDDS 
(Sony Dynamic Digital Sound), 7.1, and 7.1 
SDDS.

Pro Tools Audio Connections 
for 5.1 Mixing
While all 5.1 mixing formats provide the same 
speaker arrangement, there are three primary 
standards in use for the track layout of the indi-
vidual channels that comprise the 5.1-format 
multichannel mix. 

For information on fundamental surround 
concepts, see the Pro Tools Sync & Surround 
Concepts Guide.

For Pro Tools with Complete Production 
Toolkit, depending on your Pro Tools 
device, you may not be able to monitor all 
available surround formats. For more 
information, see the Complete Production 
Toolkit Guide.
In the following table, it is assumed that sur-
round channels are assigned to outputs 1–6 of a 
Pro Tools audio interface. Use channels 7–8 to 
monitor a stereo mix for a stereo version, or for 
cue mixes and monitoring. 

The following table shows the X-MON mono 
track routing for a 7.1 SDDS mix. A 5.1 mix 
should use the same routing, excluding outputs 
2 and 4 (Lc and Rc).

Track Layouts for 5.1 Formats

Formats Track Layout

1 2 3 4 5 6

Film 
(Pro Tools 

default)

L C R Ls Rs LFE

SMPTE/ITU 
for Dolby 

Digital (AC3)

L R C LF
E

Ls Rs

DTS
or ProControl

L R Ls Rs C LFE

C|24 L C R Ls Rs Lf

Control|24 L R C Lf Ls Rs

Default Track Layout for 7.1 SDDS Format

Formats Track Layout

1 2 3 4 5 6 7 8

ICON 
X-MON

L Lc C Rc R Ls Rs LFE
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To connect your audio interfaces for 5.1 format 
mixing and monitoring:

1  Determine the 5.1 format and track layout you 
want to use. 

2  Connect the output channels of your audio in-
terface to the corresponding input channels of 
your monitoring system according to the assign-
ments listed in the tables above.

7.1 and 7.0 Formats

7.1 and 7.0 Format
HD-DVD and Blu-Ray systems use the following 
track layout for 7.1 and 7.0 surround formats: 

• 3 front channels (Left, Center, Right)

• 2 side channels (Left Surround Side, Right 
Surround Side)

• 2 rear channels (Left Surround Rear, Right 
Surround Rear)

• 1 LFE channel (x.1 formats only)

The following table shows the default mono 
track routing for a 7.1 mix in Pro Tools.

If you use a control surface, see its guide for 
more information.

Default Track Layout for 7.1 Format

Track Layout

1 2 3 4 5 6 7 8

L C R Lss Rss Lsr Rsr LFE
Pro Tools Reference Guide
7.1 and 7.0 SDDS Formats
The Sony Dynamic Digital Sound (SDDS) 7.1 
and 7.0 surround formats use the following 
track layout: 

• 5 front channels (Left, Left Center, Center, 
Right Center, Right)

• 2 rear channels (Left Rear, Right Rear)

• 1 LFE channel (x.1 formats only)

The following table shows default mono track 
routing for a 7.1 SDDS mix in Pro Tools. 

Configuring Pro Tools for 
Multichannel Sessions
Configuring Pro Tools and sessions for multi-
channel mixing can be done in any (or all) of the 
following ways:

New Sessions

You can create a new session and choose a sur-
round mix I/O Settings file as the default 
I/O Setup. See “New Sessions and I/O Settings” 
on page 1103. 

Remixing Sessions in Surround (Importing 
Multichannel I/O Setups)

By creating or importing a surround mix I/O 
Settings file in the I/O Setup dialog, multichan-
nel paths can be made available in any stereo (or 
other format) session. You can then reassign 
track routing from the original stereo paths to 
multichannel paths. Inactive and active paths 
simplify reassignment. See “Importing Multi-
channel I/O Setups” on page 1105.

Default Track Layout for 7.1 SDDS Format

Track Layout

1 2 3 4 5 6 7 8

L Lc C Rc R Ls Rs LFE



Custom Multichannel Paths

You can customize and redefine existing paths 
in the I/O Setup dialog. For more information, 
see “Custom Multichannel Paths” on page 1105. 

Importing Session Data

By using the Import Session Data command (File 

> Import > Session Data), you can import tracks 
and media from other sessions plus their associ-
ated paths and track assignments. After import-
ing session data, you can use the I/O Setup dia-
log to configure main and sub-paths for the 
requirements of the session. For more informa-
tion, see Chapter 7, “I/O Setup.”

New Sessions and I/O Settings
When you create a new session, you can specify 
a surround format that you want to use as your 
I/O Setup. Default path configurations are pro-
vided as I/O Settings files, for stereo and sur-
round mixing. 

Once you create the new session, you can create 
and import tracks, import audio, and assign sig-
nal routing to set up your mix. 

To see multichannel options in Pro Tools, 
the Surround Mixer plug-in must be in-
stalled in the Plug-Ins folder. This plug-in 
can be installed with Pro Tools (see the User 
Guide for your Pro Tools system). If it is not 
installed, you can move it from the Plug-Ins 
(Unused) folder to the Plug-Ins folder.
To create a new session for multichannel mixing:

1  Choose File > New Session.

2  Select the Create Blank Session option.

3  Select the Audio File Type, Sample Rate, and 
Bit Depth.

4  From the I/O Settings menu, select one of the 
following options: 

• 5.1 Film Mix 

• SMPTE/ITU 

• DTS/ProControl Monitoring 

• C24 Mix 

• Control 24 Mix 

• ICON X-MON Mix 

5  Click OK.

6  In the Save dialog, name the session, navigate 
to the location where you want to save the new 
session, and click Save.

The surround presets preconfigure the 
I/O Setup dialog for the new session with default 
5.1 format main and sub-paths for outputs and 
busses.

New Session dialog, 5.1 Film Mix I/O setting selected
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Surround Mix Settings Files
The surround mix I/O Settings provide output 
and bus paths for six specific track layout stan-
dards in the new session. (For information on 
inputs and insert paths, see “Default Input and 
Insert Paths with 5.1 Settings” on page 1105.) 

Standard 5.1 format (film) output paths

Settings Files and Track Layouts

5.1 Settings Track Layout

5.1 Film Mix L C R Ls Rs LFE

SMPTE/ITU Mix L R C LFE Ls Rs

DTS Mix 
(ProControl)

L R Ls Rs C LFE

C24 Mix L C R Ls Rs Lf

Control 24 Mix L R C Lf Ls Rs

ICON X-MON Mix L Lc C Rc R Ls Rs LFE
Pro Tools Reference Guide
All available 5.1 format (and greater) I/O Set-
tings (Film, SMPTE/ITU, DTS, C24 Mix, 
Control 24 Mix, or ICON X-MON Mix) provide 
the following default output and bus paths for 
the new session:

Default 5.1 Output Paths

• One 5.1 main output path. 

– and –

• One stereo main path.

Default 5.1 Bus Paths

• One 5.1 main output bus path, with sub-
paths for 5.0 (no LFE), left/right (stereo), 
LCR, and center (mono). 

– and –

• One stereo main output bus path with two 
mono sub-paths.

I/O Setup, Output page, default 5.1 (Film) Output 
assignments

I/O Setup, Bus page, default 5.1 (Film) Output Bus 
assignments



Default Input and Insert Paths with 5.1 Settings

The 5.1 Mix settings files provide default stereo 
main paths and mono sub-paths for inputs and 
inserts. If you need multichannel input paths or 
inserts, you can create them in the I/O Setup 
(see “Custom Multichannel Paths” on 
page 1105). 

Importing Multichannel 
I/O Setups
The I/O Setup dialog can import and export set-
tings files. This is useful when you want to remix 
a stereo session in surround. You can also use 
this feature to prepare a session for transfer to a 
different Pro Tools system, or to save and ex-
change I/O Settings. 

To import a multichannel I/O Setup settings file:

1  Choose Setup > I/O.

2  Click the Output tab.

3  Click Import Settings.

4  Select the settings file (.pio) to import and 
click Open.

5  If the current session has path definitions that 
do not match those in the imported settings file, 
Pro Tools asks whether you want to delete the 
existing paths or retain them and add the im-
ported settings to your session. 

• Click No to add new paths to your current I/O 
Setup configuration.

• Click Yes to replace your current I/O Setup 
configuration with the imported settings. 

6  Click the Bus tab.

7  If the Bus page does not show the correct out-
put bus mappings for the imported I/O Settings 
file, click the Default button (for All Busses or for 
Output Busses).

8  Click OK to close the I/O Setup.
Exporting I/O Settings
Exporting I/O Setup settings files lets you build 
a library of multichannel setups for different 
projects. 

To export an I/O Setup settings file:

1  Choose Setup > I/O.

2  Click Export Settings.

3  Name and Save your current I/O Settings.

Custom Multichannel Paths
The I/O Setup dialog lets you create and custom-
ize signal paths for any supported multichannel 
mixing format. 

Multichannel paths and sub-paths are assigned 
to input and output channels in the Channel 
Grid. When you select a preset 5.1 I/O Settings 
file, default layout for the corresponding multi-
channel format paths you create will match the 
selected format’s track layout. 

In addition, the I/O Setup dialog, like the Main 
page of the Hardware Setup dialog, provides 
controls for routing the physical inputs and out-
puts on your audio interface to available inputs 
and outputs in Pro Tools.

Reassigning Channels
The I/O Setup dialog and its Channel Grid also 
let you reassign channels. This is especially use-
ful for routing channels within a multichannel 
path, without having to repatch your audio in-
terfaces.

When creating 5.1 format paths, you can 
specify the default track layout. See “Default 
Path Order for 5.1 Tracks” on page 1107. 
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You can reassign paths to any required configu-
ration, limited only by your systems resources, 
and the I/O Setup dialog requirements for chan-
nel overlapping and naming (see “Valid Paths 
and Requirements” on page 109 for more infor-
mation).

Example LCRS Setup
The following example shows one possible way 
to configure the I/O Setup dialog to mix in 
4-channel LCRS format, with an HD I/O.

To define an LCRS path:

1  Choose Setup > I/O, and click the Output tab. 

2  Click New Path.

3  Select LCRS from the Path Format selector.

4  Name the path LCRS.

5  In the Channel Grid, click in the box below the 
first (left-most) audio interface channel for the 
path. Pro Tools automatically fills up the adja-
cent units to the right. If you click in the LCRS 
row under channel 1, the LCRS path will be as-
signed to channels 1–4. 

6  Click the Bus tab.

See also “Example Paths and Signal Routing 
for a Surround Mix” on page 1117. 

For additional I/O Setup information, see 
“Output Busses” on page 109. 

Output page, LCRS output path
Pro Tools Reference Guide
7  If the Bus page does not show the correct out-
put bus mappings for the LCRS output, click the 
Default button (for All Busses or for Output Bus-

ses).

8  Select the new LCRS path and click the Reveal 
Sub-paths triangle.

9  If not all of the sub-paths are present, do the 
following:

• Click New Sub-Path.

• Name the new sub-path LCR and select LCR 
as the Path format. Click in channel 1 in the 
LCR row to assign the bus path.

• Select the LCRS path, click New Sub-Path, 
and create a stereo sub-path for front Left 
and front Right.

• Select the LCRS path, click New Sub-Path, 
and create a mono sub-path for the Center 
channel.

• Select the LCRS path, click New Sub-Path, 
and create a mono sub-path for the Sur-
round channel.

10  Click OK to close the I/O Setup.

5.1 Tracks, Formats, 
Assignments, and Metering
Path definitions in I/O Setup determine how au-
dio is routed through, and metered on, your au-
dio interfaces.

Pro Tools internal (on-screen) metering of 5.1 
format paths always follows the Film track lay-
out:

L C R Ls Rs LFE

Bus page, LCRS output bus with sub-paths



Pro Tools track layout of 5.1 format audio tracks 
in the Edit window also conforms to the Film 
layout (arranged top to bottom). See “5.1 Track 
Layouts, Routing, and Metering” on page 1108

In the I/O Setup dialog, you can route these sig-
nals out of your audio interfaces according to 
any track layout (such as DTS or SMPTE/ITU). 

To re-assign channels in a path:

 Drag a channel to a new valid location in the 
Grid. Other channel assignments will move 
(shuffle) to accommodate dragged channels.

Default I/O Selectors in I/O 
Setup
The Output page of the I/O Setup dialog pro-
vides selectors for setting I/O defaults in your 
multichannel sessions.

Default Monitor Format Sets the default monitor 
format (Stereo, 5.1, or 7.1) for new Output paths 
and for when you click the Default button.

Default selectors in the I/O Setup dialog

Default 5.1 Path Order I/O Setup Options
5.1 Path Order Selects the default track layout 
(or, path order) for new 5.1 format (six-chan-
nel) Output paths.

Controller Meter Path Selects the path that will 
be shown in the control surface output meters. 
See “5.1 Tracks, Formats, Assignments, and Me-
tering” on page 1106 for more information.

Audition Paths Selects the monitoring path for 
previewing audio in the Clip List, Import Audio 
dialogs, and DigiBase. Only outputs on your pri-
mary interface can be used as your Audition 
path.

New Track Default Output Selects the default 
output path for all new tracks, for each sup-
ported track format. 

AFL/PFL Path Selects where tracks are routed to 
when they are soloed in AFL (After Fader Listen) 
or PFL (Pre Fader Listen) Solo mode.

AFL/PFL Mutes (Output Path) Selects which out-
put is muted when AFL (After Fader Listen) or 
PFL (Pre Fader Listen) Solo mode is enabled, 
and a track is soloed.

Default Path Order for 5.1 
Tracks
You can specify the default track layout for all 
new 5.1 format paths you create. 

To choose a new default 5.1-format path order 
(track layout):

1  Choose Setup > I/O. 

2  Click the Output tab.

3  Use the 5.1 Default Path Order setting to select 
the track layout you want (Film, SMPTE/ITU, or 
DTS/ProControl Monitoring). 

The New Track Default Output can be set to 
bus paths, as well as output paths.
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5.1 Track Layouts, Routing, and Metering
Pro Tools Reference Guide
Track layout of different 5.1 formats

Channel Assignments in I/O Setup5.1 Format

Film 

SMPTE/ITU

DTS 

L C R Ls Rs LFE

(Control|24 Mix)

L R Ls Rs C LFE

L C R Ls Rs LFE

Track Meters Tracks

L C R Ls Rs LFE
(top to bottom)

L C R Ls Rs LFE
(left to right)

(Pro Tools Standard,

(ProControl Monitoring)

L C R Ls Rs LFE

L R C LFE Ls Rs

L R Ls Rs C LFE

L R C LFE Ls Rs

and C|24 Mix)

ICON X-MON
(8-channel 7.1)

L C R Ls Rs LFE
(top to bottom)

same same
L C R Ls Rs LFE

(left to right)

L x C x R Ls Rs LFE
L x C x R Ls Rs LFE

L C R Ls Rs LFE
same

L C R Ls Rs LFE
same

samesame



Chapter 48: Multichannel Tracks and 
Signal Routing
Surround sessions typically include a combina-
tion of mono, stereo, and multichannel audio, 
Auxiliary Input, Master Fader, and Instrument 
tracks, and inserts and busses.

Once the appropriate I/O Setup has been im-
ported or configured, audio, Auxiliary Input, 
Master Fader, and Instrument tracks can be 
mixed in multichannel for surround using 
Pro Tools mixing features. 

Multichannel I/O and signal routing is deter-
mined by the paths defined in the I/O Setup dia-
log.

Multichannel surround mixing is supported 
with Pro Tools HD or Pro Tools with Com-
plete Production Toolkit only.
Multichannel Audio Tracks
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit)

Multichannel audio tracks contain an individual 
channel for each signal in the track (for exam-
ple, a 5.1 track would have six channels for left, 
center, right, left surround, right surround, and 
LFE). 

Multichannel audio tracks can be:

• Recorded directly into Pro Tools, using multi-
ple microphones or microphone arrays, or 
routed to appropriate multichannel Pro Tools 
Input paths

• Imported from other Pro Tools sessions

• Edited, processed, and mixed in combination 
with mono and stereo tracks

5.1 format audio files and tracks conform to the 
Film track layout standard. Regardless of path 
assignments in the I/O Setup dialog, all 5.1 for-
mat audio tracks and meters follow the Film 
standard track layout:

L C R Ls Rs LFE 

5.1 format multichannel audio track
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Multichannel audio tracks are not required to 
mix in multichannel formats. Mono, stereo, and 
all supported track formats can be mixed using 
Pro Tools track outputs and sends (see “Multi-
channel Signal Routing” on page 1112).

Placing Audio in Multichannel 
Tracks
You can drag audio files and clips from DigiBase 
browsers, the Clip List, Windows Explorer, or 
Mac Finder, or from other tracks, to place them 
in multichannel audio tracks.

To do so, the number of channels being dragged 
must match the destination track format. For 
example, you can only drag a stereo pair or two 
mono clips onto a stereo audio track. Similarly, 
you can only place audio into an LCR track when 
you have selected three clips. With 5.1 tracks, 
you must select six mono files or clips. 

When dragged into a multichannel track, 
audio files are placed from top to bottom in 
the exact order that they appear in the Clip 
List or playlist from which they came (Top 
to Bottom must be selected for in the Clip 
List menu > Timeline Drop Order). For this 
reason, you may want to rename audio files 
before dragging them, so that they are 
placed in the preferred order. Rename them 
so that sorting them By Clip Name in the 
Clip List results in the preferred order. (For 
example, with a 5.1-format track, you can 
rename the audio tracks so that the ar-
rangement of the tracks corresponds to L, C, 
R, Ls, Rs, and LFE.)
Pro Tools Reference Guide
Solo, Mute, and Gain in 
Multichannel Tracks and Paths
Stereo and multichannel tracks consist of multi-
ple audio signals, linked together. By default, 
multichannel tracks are linked and are con-
trolled by a single channel fader, and solo and 
mute switches. 

For discrete control of signals, multichannel 
tracks can be converted into individual mono 
tracks. For discrete level and phase adjustment, 
you can insert and unlink a multi-mono Trim 
plug-in. Both of these techniques are explained 
below.

To convert a multichannel track into discrete mono 
tracks:

1  Select the multichannel track.

2  Choose Track > Split Into Mono. 

Once converted to mono, multichannel 
tracks cannot be relinked into their original 
multichannel format. However, a multi-
channel track can be reassembled by drag-
ging the corresponding number of mono 
files (with the appropriate file suffixes) into 
a multichannel track, although some auto-
mation data may be lost. As an alternative, 
record the submix of the mono tracks to disk 
on a multichannel track.



To have discrete control of gain on individual 
channels of a multichannel track: 

1  Insert a multi-mono Trim plug-in on the mul-
tichannel track.

2  Unlink the Trim plug-in by clicking the Link 
icon so that it is unlit. 

3  Use the Channel selector to display the con-
trols for a channel, and adjust the gain. 

Track and Output Formats
When you create new tracks, you specify mono, 
stereo, or a supported multichannel format for 
the new tracks. 

In the Mix and Edit windows, the track format of 
a track’s output is always visible by the number 
of track meters contained in its fader strip (for 
example, a single meter for mono tracks, a pair 
of meters for stereo tracks, and six meters for 
5.1 tracks).

Assigning track output determines the format of 
that output. For example, a mono track always 
has a single track meter, even when assigned to a 
stereo output path. If that same mono track is 
assigned to a 5.1 output path, it's output will be 
split among those six output channels, depend-
ing on the position of its panner. 

See “Linking and Unlinking Controls on 
Multi-Mono Plug-Ins” on page 1114 for 
more information. 
Changing Format

Changing the output format for a given track has 
several effects:

• The panner that appears in the track will 
change to reflect the new output format.

• It may be necessary for one or more pan re-
lated automation playlists to be created or de-
leted.

Because changing the output format has these 
effects, a warning dialog appears whenever you 
change the output format of a track to a format 
of fewer channels. Specifically, this will occur 
whenever automation playlists will have to be 
deleted.

Multiple Output Assignments and Track Format

When a track is assigned to more than one path 
of differing formats, the main output for that 
track will match the format of the assigned path 
with the greatest number of channels.

Multiple Outputs and Automation Playlists

When a track has multiple output assignments, 
Pro Tools sorts panning data appropriately for 
each assigned path. For example, if you assign a 
mono track to a stereo path and a 5.1 path simul-
taneously, that track will have a 5.1 panner in 
the Mix or Edit window. When you pan the 
track, Pro Tools interprets the 5.1 panning 
moves into stereo panning moves. 

This provides a type of parallel mixing. You can 
create a variety of mixes of differing formats all 
at the same time by routing your elements to 
multiple paths. 

Command-Control-click (Mac) or Control-
Start-click (Windows) any control in an 
Output window to show its automation 
playlist in the Edit window and view any 
pan automation. 
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Multichannel Signal Routing
To mix in a multichannel format, tracks are as-
signed to multichannel paths. 

Tracks can be mixed in surround using the fol-
lowing two methods:

• By setting a track main output to a multichan-
nel path. 

• By assigning a multichannel send to route au-
dio to a multichannel path. 

Two different ways to configure tracks for multichannel 
mixing

multichannel output path

multichannel send
Pro Tools Reference Guide
Multichannel Track Outputs
Tracks can be routed to multichannel output or 
bus paths using the track’s Output Path selector. 
This provides a multichannel panner and meter 
in the Mix and Edit window I/O View. 

Additional output assignments can be added by 
Start-clicking (Windows) or Control-clicking 
(Mac) the Selector tool and assigning another 
path. 

Multichannel Sends
All track formats, including mono and stereo, 
let you assign one or more multichannel sends. 
This provides a multichannel panner in the 
Sends View. Sends are also useful to bus tracks 
for multichannel plug-in processing. 

The following figure shows a mono audio track 
with a 5.1 (6-channel) send (View > Sends A–E > 
Send A).



Pro Tools bussing and submixing features are 
available for all channel formats, from 
mono/stereo through 8-channel. For examples 
of multichannel monitoring, effects processing, 
and bussing, see “Mixing with Paths and Sub-
Paths” on page 1115. For mono and stereo mix 
examples, see Chapter 43, “Basic Mixing.” 

Multichannel Auxiliary Inputs 
and  Master Faders
A multichannel Auxiliary Input or Master Fader 
is used as a return for the multichannel bus. 
Sends are useful when you need to create an ad-
ditional, independent mix simultaneously (per-
haps of a distinct format), requiring dedicated 
fader, mute, solo, and automation controls.

A mono audio track with a mono output format and a 
multichannel send

Multichannel send panner

Mono meter

Mono output format
You can assign Master Faders to main and sub-
paths. Main paths must match the format of the 
Master Fader, and only one Master Fader can be 
active and assigned to any single (active) main 
or sub-path. A Master Fader cannot be assigned 
to a sub-path if its associated main path is al-
ready assigned on another Master Fader. See 
“Master Fader Tracks and Signal Flow” on 
page 942. 

Multichannel Instrument Tracks
Multichannel tracks can be used to monitor and 
route multichannel instrument plug-ins or mul-
tichannel external MIDI instruments.

Mono, Multi-Mono and 
Multichannel Plug-Ins
Plug-Ins can be used in mono, multi-mono, or 
multichannel formats.

For information about mono, stereo, and mono-
in/stereo-out plug-ins, see Chapter 44, “Plug-In 
and Hardware Inserts.”

Multi-Mono Plug-Ins Are designed for use on ste-
reo or greater-than-stereo multichannel tracks. 
Multi-mono plug-ins are useful, or required, in 
the following situations: 

• When a plug-in does not involve multichannel 
correlated processing (for example, when ap-
plying EQ to select sides of a multichannel sig-
nal)

• When you need to adjust signals within the 
multichannel track independently

• When a plug-in does not support multichan-
nel formats
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When a multi-mono plug-in is first inserted on a 
multichannel track, the plug-in controls are 
linked. You can unlink them for independent 
adjustment. See “Linking and Unlinking Con-
trols on Multi-Mono Plug-Ins” on page 1114 for 
more information.

Multi-mono plugs-ins can also be inserted on 
stereo tracks, to apply unlinked plug-ins on the 
left and right channels.

Multichannel Plug-Ins Are designed for use on 
stereo and multichannel tracks that require cor-
related processing, including stereo and multi-
channel limiting, compression, and similar ef-
fects. 

Linking and Unlinking Controls 
on Multi-Mono Plug-Ins
When a multi-mono plug-in is used on a multi-
channel track of more than two channels, the 
controls are normally linked. Adjusting the Gain 
control on one channel, for example, will adjust 
it for all channels.

If necessary, you can unlink plug-in controls on 
specific channels of a track and edit them inde-
pendently. You can also selectively link the con-
trols of specific channels. 

For example, to apply equal filter cutoffs to the 
Ls and Rs (surround) channels in a 5.1 mix, you 
could link enable just those channels in an un-
linked, multi-mono EQ plug-in. Adjusting the 
controls in the plug-in window for either chan-
nel (Ls or Rs) adjusts the other, linked channel 
as well. 
Pro Tools Reference Guide
Channel Selector Accesses a specific channel 
within a multichannel track for plug-in parame-
ter editing. This menu appears only on multi-
mono plug-ins inserted on tracks with more 
than two channels. 

Master Link Button When enabled, links the 
controls on all channels of a multi-mono plug-in 
so that they can be adjusted in tandem.

Link Enable Buttons Let you selectively link the 
controls of specific channels of a multi-mono 
plug-in. Each square represents a speaker chan-
nel. The Master Link button must be disabled to 
use the Link Enable buttons. 

To unlink controls on a multi-mono plug-in:

 Deselect the Master Link button. It is lit when 
linked, unlit when unlinked.

To access controls for a specific channel:

 Select the channel from the Channel selector.

To open a plug-in window for all channels of a 
multi-mono plug-in:

 Alt-click (Windows) or Option-click (Mac) the 
Channel selector. 

To link the controls of specific channels:

1  Deselect the Master Link button if it is not al-
ready deselected.

2  Click the Link Enable buttons for the channels 
whose controls you want to link.

Channel selector and Link controls

Channel selector

Link Enable buttons

Master Link button



Paths in Surround Mixes
Because Pro Tools provides a flexible routing 
and submixing environment, you can maximize 
your system’s available resources by first identi-
fying the elements that you want to pan dynam-
ically and those that can be placed in certain 
channels only (see “Mixing with Paths and Sub-
Paths” on page 1115).

Once you have identified these elements in your 
session, you can use a combination of main and 
sub-path assignments, and multichannel pan-
ning.

Mixing with Paths and Sub-Paths
It is rare that every track needs to be “flown” 
(actively panned in between more than a pair of 
speakers). In most situations, certain elements 
are placed in certain speakers and remain there, 
providing the foundation for a mix.

The following figure illustrates an example of 
how panning and signal routing can be com-
bined in a multichannel mix. 

See “Extending Stereo Mixing Conventions 
to Surround Mixing” on page 1119 for re-
lated information. 
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 Pro Tools Reference Guide
Using signal routing and sub-paths to mix in surround

Effect
bus rout-

Outputs to
sub-paths

Outputs to main 5.1 path for surround panning

Tracks routed to main
5.1 surround path

Tracks routed to subpaths Auxiliary Input
routed to main 
5.1 surround path
When to Assign Multichannel Outputs

 Assign 5.1 paths only to those tracks that need 
to be panned to all six channels. 

For example, a sound effects track with a jet fly-
over should be assigned a 5.1 path to fly the 
sound from front-to-back. In a music mix, you 
can fly a solo instrument or make a synth pad 
swirl around the room as a special effect. 
Elements that need to be heard in all speakers si-
multaneously can also be assigned to the multi-
channel output, whether or not they require ac-
tive panning in the sound field. 

When to Use Sub-Paths 

 To help simplify large sessions, use sub-paths 
to route static (or, stationary) elements directly 
to the output channel or channels. 



For example, film dialog is often mixed to the 
center channel to anchor this essential sound el-
ement to the picture. Instead of assigning a six-
channel panner to dialog tracks and panning the 
tracks to the center speaker only, you can route 
the dialog track’s main output to a mono (Cen-
ter) sub-path.
Extending Stereo Mixing 
Conventions to Surround Mixing
Stereo mixing sets the precedent for active and 
static panning, and surround mixing can benefit 
from the same basic principles. 

Panning a sound back-and-forth between the 
left and right speakers is best used as a special 
effect. In a typical music mix, the basic tracks 
are placed in the stereo sound field and remain 
there. 

Surround mixes can become incoherent if too 
many elements are continuously moving, For 
special effects, some tracks can be panned dy-
namically, bouncing between speakers or sweep-
ing from one side to the other.

Example Paths and Signal 
Routing for a Surround Mix
Signal routing is the key element in any 
Pro Tools surround session. Signal routing is 
configured and defined in the I/O Setup dialog.

The examples that follow show how Auxiliary 
Inputs, Master Faders, and other Pro Tools sig-
nal routing features can be used for stem mixes, 
submixes, and similar project needs. 

In these examples, music and effects are being 
mixed for a trailer, in 5.1 surround. Separate 
stem mixes (for music and for effects) are to be 
mastered to 8-track MDM.
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Example Output Paths
The following figure shows output paths defined 
in the I/O Setup dialog of an example session 
that was created on a Pro Tools|HD system with 
one HD I/O audio interface.

Different Output paths have been defined for 
Mix, Music, and FX main output paths. 

Additional stereo output paths, with mono sub-
paths, have also been defined for the remaining 
channels. 

I/O Setup, example output paths
Pro Tools Reference Guide
Example Bus Paths
The following figure shows example bus paths.

An LCR format path (“Dialog”) and two 5.1 for-
mat paths (“Music” and “FX”) have been de-
fined, each with several sub-paths.

Example Sub-Paths
Sub-paths let you route to selective channels 
within the multichannel surround output. In the 
following figure, the Mix 5.1 bus has several 
sub-paths that show this. 

I/O Setup, example bus paths

I/O Setup, example sub-paths



5.0 Sub-Path The 5.0 path is a 5-channel sub-
path. Use this type of sub-path routing to con-
serve mixing resources with tracks you want to 
keep out of the LFE channel. 

LFE Path A custom LFE sub-path (“Lf”) has been 
added to provide a discrete mono path for the 
LFE channel. 

Signal Routing Examples
The following examples show how main and 
sub-paths can be used, using an example session 
consisting of a 5.1 main mix, with music and ef-
fects stems (or submixes). 

Submix Stem Examples

The figure below shows a routing configuration 
for an effects submix. Two tracks are routed to 
stereo bus sub-paths, while others are assigned 
to an LCR and a mono bus sub-path. Two tracks 
(one mono, one stereo) are assigned to multi-
channel busses for surround panning. A 5.1 
Auxiliary Input assigned to the FX main bus 
path serves as a submixer. 

Extending Stereo Mixing Conventions to 
Surround Mixing

Stereo mixing sets the precedent for active and 
static panning, and surround mixing can benefit 
from the same basic principles. 

Panning a sound back-and-forth between the 
left and right speakers is best used as a special 
effect. In a typical music mix, the basic tracks 
are placed in the stereo sound field and remain 
there. 

Surround mixes can become incoherent if too 
many elements are continuously moving, For 
special effects, some tracks can be panned dy-
namically, bouncing between speakers or sweep-
ing from one side to the other.
FX stem
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The following figure shows a routing configuration for music tracks.
Pro Tools Reference Guide
Music stem
Most of the music tracks in this example are 
routed to the front left/right channels, using a 
stereo sub-path. A 5.1 Auxiliary Input controls 
the bus and stem output. 

Multiple Output Assignments

Multiple output assignments make it possible to 
configure a number of multi-format mixes. For 
example, you can assign an additional stereo 
output to tracks and create a stereo mix at the 
same time as a 5.1 mix. For more information, 
see “Multiple Output Assignments” on page 954.
LFE Examples
LFE tracks and other audio can contribute to the 
LFE output in two ways:

• Using the LFE fader in Output windows. 
This LFE signal is post-fader. 

– or –

• Using a custom sub-path to route channels 
discretely.

The following figure shows a channel Output 
window, sending and metering the LFE channel. 



Using the LFE fader, you can add any amount of 
any multichannel path to the overall LFE output. 
In the above example, the track’s Center per-
centage has been turned off, and the LFE fader 
has been raised to route it to the LFE channel. 

The following figure shows how a “traditional” 
LFE track can be routed to only the LFE channel. 
This example uses a custom-defined LFE sub-
path to the FX main bus path. 

LFE fader
LFE and Filtering
Pro Tools applies no filtering to LFE signals. 
Some delivery requirements may require filter-
ing for the LFE track. For more information, see 
the Pro Tools Sync & Surround Concepts Guide. 

Discrete LFE routing, with main output to mono LFE 
channel

LFE faders can follow Mix and Edit Groups. 
For information, see “Selecting Group Attri-
butes” on page 265.

For instructions on how to create a sub-
path, see “Custom Multichannel Paths” on 
page 1105. 
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Chapter 49: Surround Panning and Mixing
Before you can pan a track in surround, it must 
be assigned to an appropriate multichannel out-
put or bus path. 

The I/O Setup dialog defines the bussing and 
output architecture of the Pro Tools multichan-
nel surround mixer. If you have not already 
done so, it is recommended that you become fa-
miliar with main and sub-paths and the 
I/O Setup dialog before starting multichannel 
Pro Tools projects. 

See Chapter 47, “Pro Tools Setup for Sur-
round” for more information on multichan-
nel configurations and I/O Setup options. For 
multichannel signal routing, see Chapter 48, 
“Multichannel Tracks and Signal Routing.”

Multichannel surround mixing is supported 
with Pro Tools HD or Pro Tools with Com-
plete Production Toolkit only.
Introduction to Pro Tools 
Surround Panning
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit)

There are four different track panning methods 
available: 

• In the Edit window, using the reduced-height 
Panner Grid in the I/O View

• In the Mix window, using the reduced-height 
Panner Grid

• In the Output window, using the full-size 
Panner Grid

• Through pan automation editing

Certain Pro Tools control surfaces provide addi-
tional panning options. See the documentation 
for your control surface. 
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Mix and Edit Window Panner 
Grids
In the Mix and Edit window, multichannel Pan-
ner Grids are displayed on tracks that have mul-
tichannel track or send output assignments. 

To pan from the Mix or Edit window:

1  To pan in the Edit window, make sure I/O View 
is being shown (View > Edit Window > I/O). Pan-
ner Grids are always displayed in Mix window 
tracks that support panning.

2  Begin playback. 

3  Drag in the appropriate multichannel track’s 
Panner Grid in the Mix or Edit windows. 

The Pan Location cursor follows your move-
ments as long as you hold down the mouse but-
ton. Movements are scaled so that, once you 
click to “grab” the Pan Location cursor, you do 
not need to limit your movements to the small 
Track Grid area. 

Drag to pan in the Track Grid
Pro Tools Reference Guide
Pan Location Cursor Color while Automating

The Pan Location cursor is green when the track 
is in Automation Read mode, red in an Automa-
tion Touch, Latch, Touch/Latch, or Write 
modes, and yellow in Automation Off (or Auto-
mation Suspend) mode. 

In Trim mode, the Volume fader and LFE fader 
are yellow.

Output windows provide additional features and 
controls (and a much larger Grid). For details, 
see “Output Windows” on page 1124. 

Output Windows
Output windows provide panning controls 
(called panners), as well as standard Pro Tools 
controls, for tracks of all mix formats (from 3-
channel LCR through 8-channel 7.1). 

For information on Output window standard 
controls, see “Standard Controls” on page 1125. 
For information on Output window panning 
controls, see “Surround Panner Controls” on 
page 1126.

Some of the features of Output windows include:

• X/Y (joystick-style) panning

• 3-Knob panning

• Full Divergence and Center Percentage con-
trol

• AutoGlide

• LFE feed

• Multichannel meters

• Pro Tools target window support

Multiple panners can be opened simultaneously, 
or a single window can display the current 
panner.



To open an Output window:

 Click the Output Window button (the small 
fader at the right edge of the Output selector for 
a track in the Mix or Edit window (I/O View).

Opening a multichannel Output window

For instructions on managing multiple Out-
put windows, see “Output Windows for 
Tracks and Sends” on page 965.
Standard Controls
All Output windows provide standard Pro Tools 
controls for routing, path assignment and other 
track features. These controls are located at the 
top of all Output, Send, Insert, and Plug-In win-
dows (see “Standard Selector Controls in Output 
Windows” on page 968).

Track Fader, Solo, Mute, and 
Auto
All Output windows provide track volume and 
mute controls. You can adjust and automate 
track volume, or mute, directly using these con-
trols. The larger fader and Mute button are 
equivalent to those in the Pro Tools Mix 
window. 

Panner Control section

Track selector

Output selector

Path selector Target icon
Show meters

Automation Safe
Chapte
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Surround Panner Controls
When assigned to tracks or paths with four or more channels, the Output window provides an X/Y 
Grid for surround panning. The speakers associated with the panner’s multichannel format are dis-
played in their relative positions outside the Panner Grid. These speakers are also used as Snap Pan 
to Speaker controls.

This section identifies all the controls and features found in Pro Tools multichannel panners. 
Pro Tools Reference Guide
Output window with a 7.1 format multichannel panner

X/Y Grid

LFE fader

Track fader and meter
Position

(knob panners)

Divergence

Pan Location
cursor

Panning Mode button

Track Automation. 
Solo, and Mute

Center %

Click to show meters

Snap Pan to Speaker icons

Side %



The X/Y Grid and Pan Location 
Cursor
The X/Y Grid is where multichannel panning in-
formation is input and displayed. You can input 
pan information using X/Y mode, 3-Knob mode, 
or by entering numeric values in the Position 
data fields. You can also edit pan automation 
graphically in the Edit window.

Multichannel panners default to X/Y mode. In 
X/Y mode, the track’s current pan position is 
represented by a green dot. This dot is the Pan 
Location cursor, and its color indicates track au-
tomation status using standard Pro Tools col-
ors: 

Green The track is in automation Read mode.

Red The track is in automation Write, Touch, 
Latch, or Touch/Latch mode.

Yellow The track is in automation Off mode (or 
Automation Suspend) mode.

X/Y Grid and Pan Location cursor

X/Y grid

Pan Location
cursor
Panning Mode Button
This button, located below the X/Y Grid, pro-
vides access to Surround panning modes (see 
“Panning Modes” on page 1129). 
 

Position Controls
The Position controls let you set the positions of 
the panner.

Front Displays and controls the current front X-
axis (left/right) position of the panner. 

Rear Displays and controls the current rear X-
axis (left/right) position of the panner. In de-
fault X/Y Panning mode, Rear is linked to Front 
position and cannot be controlled indepen-
dently. 

F/R (Front/Rear) Displays and controls the cur-
rent Y-axis position of the panner. 

Center % Control
Center % controls how much of the signal is 
routed to the center speaker. This lets you mix a 
track to the front with a phantom center (0% 
Center value) or to three-channel (LCR) when 
panning front. 

Panner Mode button set to X/Y mode

Position and Center % controls
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Divergence Controls
Divergence determines the width of the panned 
signal with respect to neighboring speakers. 
(For more information, see the Pro Tools Sync & 
Surround Concepts Guide). There are three Di-
vergence controls:

Front, Rear, and F/R Divergence Provide sepa-
rate, automatable divergence control over front 
speakers, rear speakers, and between front/rear, 
respectively.

Snap Pan to Speaker Icons
The Snap Pan to Speaker icons let you force the 
panner to the speaker’s location. For example, 
clicking on the upper left speaker moves the Pan 
Location cursor to the upper left corner of the 
X/Y Grid.

LFE Fader
The LFE fader is only available in “.1” surround 
formats (5.1, 6.1, and 7.1). 

Divergence controls

For examples of how divergence settings af-
fect output panning, see “Divergence and 
Center Percentage” on page 1132.

LFE fader
Pro Tools Reference Guide
The LFE fader determines how much of the cur-
rent track’s signal will be routed to the LFE 
channel. LFE faders in Track and Send windows 
can follow groups. The Pro Tools LFE channel is 
always full-bandwidth. For more information 
on how to use the LFE fader, see “LFE Faders in 
Multichannel Panners” on page 1134.

Multichannel Panner Linking
Stereo tracks with multichannel outputs provide 
left and right multichannel panners. The Output 
window provides controls to link the left and 
right channels for precise panning.

When you create a stereo track that is routed to 
a multichannel output, the following pan link-
age controls are active by default:

• Link (links Left and Right pan controls)

• Front Inverse (inverts Left and Right pan 
control linkage across front)

• Rear Inverse (inverts Left and Right pan 
control linkage across rear)

The Front/Rear Inverse pan control is unlinked 
by default. 

Stereo multichannel panner controls showing default 
linking

Link 

Front/Rear Inverse

Front Inverse

Rear Inverse



Panning Modes
The Panning Mode button provides access to 
four panning modes: X/Y mode, Divergence 
Editing, 3-Knob mode, and AutoGlide mode. 
Panning controls can be automated in all four 
modes.

Pro Tools provides the following Panning 
Modes:

X/Y Mode Joystick-style panning by dragging the 
Pan Location cursor within the X/Y Speaker 
Grid. See “X/Y Panning” on page 1129 for more 
information.

3-Knob Mode Point-to-point panning, between 
pairs of speakers. See “3-Knob Panning” on 
page 1130 for more information. 

Divergence Editing The divergence X/Y Grid can 
be dragged to resize the divergence boundaries. 
See “Divergence Editing Mode” on page 1133. 

AutoGlide Mode Point-to-point panning from 
the Pan Location cursor to a new destination 
over a specified AutoGlide Time. See “AutoGlide 
Mode” on page 1131 for more information.

Panning Mode button (X/Y mode shown)

Panning Mode button
To enable a Panning Mode:

 Click on the Panning Mode button in the Sur-
round Panner until the mode icon is displayed.

X/Y Panning

To pan in X/Y mode:

1  Click on the Panning Mode button until the 
X/Y mode icon is displayed.

2  Drag the Pan Location cursor, or click any-
where in the Grid and drag to pan the track. The 
location of the Pan Location cursor determines 
the pan position of the signal. For example, to 
pan something to the left rear speaker, move the 
Pan Location cursor to the lower-left corner of 
the Grid. 

Panner Mode button set to X/Y mode

It is not necessary to click exactly on the Pan 
Location cursor. Clicking anywhere in the 
Grid will move the Pan Location cursor rel-
ative to where you click or take over with a 
hardware panner. Panning does not jump to 
the click position. 

X/Y Panning
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To snap the Pan Location cursor to a location in 
the Grid:

 Control-Shift-click (Windows) or Command-
Shift-click (Mac) at the location in the X/Y Grid. 

Grid Options and Shortcuts

Fine-Adjust Mode Hold down the Control key 
(Windows) or Command key (Mac) for fine ad-
justment of all Panner controls. 

Constraining to X or Y Movement Shift-drag the 
Pan Location cursor to constrain its movement 
to the X or Y direction.

Reset to Default Alt-click (Windows) or Option-
click (Mac) in the Panner Grid to reset all con-
trols to their default position. 

Snap Pan to Speaker Click one of the Snap Pan 
to Speaker icons to force the panner to that 
speaker location. 

Display Automation in Edit Window Control-
Start-click (Windows) or Command-Control-
click (Mac) a control to display that control’s 
playlist in the Edit window.

3-Knob Panning
Pro Tools provides 3-Knob mode as an addi-
tional way to input pan moves. 

3-Knob mode lets you:

• Pan in straight lines, moving the Pan Location 
cursor using the Position rotary knobs with 
full movement of front, rear, and front-rear 
position. 

– and –

• Pan discretely between pairs of speakers.

All Pan controls can be automated, includ-
ing pan position and divergence. See 
Chapter 45, “Automation” for details. 
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For example, when panning front-left to rear-
right in 3-Knob mode, audio will be heard from 
just those two speakers (assuming full diver-
gence is in effect). 

By comparison, in X/Y mode a diagonal pan may 
result in audio being heard in some or all chan-
nels. 

The difference is that 3-Knob mode pans dis-
cretely between the front and rear position of 
the panning trajectory, while X/Y mode panning 
takes place in the full 360° Panning Grid. Diver-
gence and Center Percentage are variable in 
both Panning modes. 

To enable 3-Knob Panning mode:

 Click on the Panning Mode button until the 3-
Knob mode icon is displayed.

The panner trajectory line appears across the 
Grid, extending from the front (X-axis) to the 
rear (Y-axis).

Panning and metering in 3-Knob mode

Panner Mode button set to 3-Knob mode

3-Knob trajectory

3-Knob mode



To pan in 3-Knob mode:

1  Adjust the Front and Rear Position knobs to 
set the trajectory line. 

2  Rotate the Front/Rear Position knob to pan 
along the trajectory. The Pan Location cursor is 
constrained to the white trajectory line. 

To change the 3-Knob trajectory angles, do one of 
the following:

 Drag either end point (Front or Rear) of the 
trajectory line. 

– or –

 Adjust the Front or Rear Position controls. 

To change the current trajectory position (left-to-
right) and retain its current angles:

 Drag the trajectory line (not its end points) to 
a new position. 

AutoGlide Mode
AutoGlide mode lets you quickly write Surround 
Panner automation by clicking new locations in 
the Surround Panner window, instead of manu-
ally moving the Surround Panner controls.

The time it takes to glide from point to point 
(from the Pan Location cursor to the new desti-
nation) is called the AutoGlide Time. This time 
is set in the Mixing Preferences page and has a 
range of 10 msec to 10000 msec (10 seconds).

To set the AutoGlide Time

1  Choose Setup > Preferences and click the Mix-

ing tab.

2  Set the AutoGlide Time in the Automation sec-
tion.

When writing automation in AutoGlide 
mode, the Pan Location cursor cannot be 
dragged from its location.
To do an AutoGlide automation pass:

1  Click the Panning Mode button until the 
AutoGlide mode icon is displayed.

The Panning Mode button displays a slanted 
dotted line that ends with a filled in dot (repre-
senting a cursor) at its top right corner.

2  In the Mix or Edit window, click the Automa-
tion Mode selector and select an Automation 
mode for the track you want to automate.

3  Press Play to begin playback.

4  Set a new destination for the cursor by doing 
one of the following:

• Click a Snap Pan to Speaker icon to glide to 
its speaker location.

– or –

• Click in the pan window to glide to a spe-
cific location in the X/Y Grid.

Panner Mode button set to AutoGlide mode

Panning Mode button (AutoGlide mode shown)

AutoGlide mode

Snap Pan to
Speaker

icons

Pan Location
cursor
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The Pan Location cursor will begin to move to-
wards the new destination in the time it takes to 
travel the AutoGlide Time. When the new desti-
nation point is reached, a new breakpoint will be 
written at the new location.

5  Repeat the previous step if you want to write 
additional panning moves.

6  Stop the transport when finished.

Divergence and Center 
Percentage
The Divergence and Center Percentage controls 
range from 0 to 100, and can be automated. They 
are especially useful for ensuring audibility and 
coverage in large venues, and to increase clarity 
of voices. 

Front Divergence Controls divergence between 
front speakers (X-axis only). 

Rear Divergence Controls divergence between 
the rear speakers (X-axis only).

Front/Rear Divergence Controls divergence be-
tween front and rear (the Y-axis).

Center % (Percentage) Determines whether 
there is a discrete center image, a completely 
phantom center image, or a variable amount in 
between. 

Side % (Percentage) Determines whether there 
is a discrete side image, a completely phantom 
side image, or a variable amount in between the 
right and left side channels for 7.1 and 7.0 for-
mats. 
Pro Tools Reference Guide
Divergence
In the Panner Grid, the current divergence val-
ues are displayed using a purple outline. 

By default, Pro Tools surround panners are 
100% or fully divergent, meaning that a signal 
that is panned completely to one speaker will 
only be audible in that speaker. 

Lower divergence settings result in a progres-
sively wider source signal. When Divergence is 
less than 100%, tracks will be routed to neigh-
boring speakers to some degree, even when the 
Pan Location cursor is positioned next to a sin-
gle speaker. 

Divergence display and controls

Front Divergence at less than 100% for wider panning

Divergence display

Divergence controls

Front
Divergence

Pan Location
cursor



To adjust divergence:

 Adjust the Front, Rear, and Front/Rear Diver-
gence controls as necessary. 

Divergence Editing Mode
In Divergence Editing mode, you can adjust the 
divergence boundaries by dragging directly in 
the Divergence Grid. 

To adjust divergence graphically:

1  Click on the Panning Mode button until the Di-
vergence Editing icon is displayed.

2  Drag in the Grid to resize the divergence 
boundaries. 

Center % (Percentage)
In LCR, LCRS, 5.0, 5.1, 6.0, 6.1 7.0, 7.0 SDDS, 
7.1, and 7.1 SDDS surround formats, the 
Center % controls whether there is a discrete 
center channel for the track or a phantom center 
channel. 

Center Percentage Example

In film and video production, the center channel 
often contains dialog. To enhance the clarity of 
dialog, it is often beneficial to keep elements 
such as music out of the center speaker. By re-
ducing the Center Percentage on music tracks, 
music panned to the front of the soundfield can 
be panned to only the left and right speakers, 
forcing them to have a variable phantom center 
image.

Panner Mode button set to Divergence Editing
To adjust Center Percentage:

 Adjust the Center Percentage knob as appro-
priate. 

As you reduce the Center Percentage value, the 
center speaker at the top of the Grid becomes 
less visible. At 0, the center speaker is com-
pletely invisible, reflecting the setting for fully 
phantom center.

Side % (Percentage)
For 7.1 and 7.0 surround formats, the Side % 
controls whether there are discrete side chan-
nels for the track or a phantom side channel. 

To adjust Side Percentage:

 Adjust the Side Percentage knob. 

Center % set to 0 (no center speaker shown)
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As you reduce the Side Percentage value, the 
speakers at the sides of the Grid become less vis-
ible. At 0, the side speakers are completely invis-
ible, reflecting the setting for fully phantom 
center.

LFE Faders in Multichannel 
Panners
The LFE fader controls how much of the track is 
sent to LFE. LFE faders are only available when a 
track is assigned to a path whose format sup-
ports LFE (5.1, 6.1, or 7.1). 

To mix to the LFE channel:

 Adjust the LFE fader in any “.1” surround for-
mat Output window. 

Side % set to 50% (side center speakers dimmed)

For general information about LFE, sub 
channels, and related topics, see the 
Pro Tools Sync & Surround Concepts Guide.
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LFE Faders and Groups
Track and send LFE faders can follow Mix and 
Edit Groups by being enabled in the Group At-
tributes page in either the Create Groups or 
Modify Groups dialog. LFE faders can be as-
signed to follow groups as a global attribute or 
on a group by group basis. See “Selecting Group 
Attributes” on page 265.

LFE Enable
Some multichannel plug-ins, including the mul-
tichannel Dynamics III Compressor/Limiter, 
provide LFE Enable. This lets you enable or by-
pass processing of the LFE channel if present. 

To process the LFE channel in a multichannel 
plug-in:

 Click to enable LFE Enable in supporting mul-
tichannel plug-ins. LFE Enable is highlighted 
when LFE processing is enabled, and unhigh-
lighted when LFE processing is bypassed.

LFE Enable in the multichannel Dynamics III 
Compressor/Limiter

When LFE Enable is unavailable, try using 
the multi-mono version of the plug-in.



Pan Playlists
Multichannel panners have an automation play-
list for each position and divergence control. 

Surround Scope Plug-In
The Surround Scope plug-in provides a 360° me-
ter for metering multichannel paths during mix-
ing.

5.1 Format Track Layouts

All 5.1-format meters (including those dis-
played in the Surround Scope meter, on tracks, 
and in Output windows and their Path Meter 
Views) are always arranged in the following or-
der:

L C R Ls Rs LFE

To use the Surround Scope Plug-In:

 On a multichannel Master Fader, click an In-
sert button and select Multichannel TDM plug-in > 

Sound Field > Surround Scope. 

Surround Scope displays output levels in both a 
360° Grid, and in traditional LED meters. 

Pan automation can be drawn, edited, cut, 
copied, and pasted from the Edit window. 
For more information, see Chapter 45, “Au-
tomation.”

For more information on Pro Tools meter-
ing, see “5.1 Tracks, Formats, Assignments, 
and Metering” on page 1106. 

For details on Surround Scope, see the Au-
dio Plug-Ins Guide.
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Part XI: Sync and Video





Chapter 50: Working with Synchronization
Synchronization allows one system to output 
timecode and the other device to chase (follow) 
that timecode. Pro Tools is synchronized to 
other devices using SMPTE/EBU timecode or 
MIDI Timecode.

See the Sync & Surround Concepts Guide for an 
introduction to key synchronization, surround 
mixing and monitoring concepts.

Pro Tools Synchronization 
Options
There are several options for synchronizing 
Pro Tools to an external source or using 
Pro Tools as the master device. Not all options 
are available on all Pro Tools systems, as noted. 

SMPTE Trigger Only
This solution is useful for short projects if both 
systems are extremely close in speed, but even 
the best systems will rarely stay perfectly syn-
chronized for longer than a couple of minutes.
SMPTE Trigger Resolved with a 
SYNC Peripheral
(Pro Tools|HD and HD Native Systems Only)

You can use an optional Synchronization pe-
ripheral (such as the SYNC HD) to resolve 
Pro Tools recording and playback speed with 
any of the following clock reference sources 
while slaving Pro Tools to timecode:

• LTC 

• Video source

• House video reference (SD or HD)

• VITC

• 1x Word Clock

• AES/EBU “null” clock

• Pilot Tone

• Bi-Phase

This enables long-term, high-fidelity synchroni-
zation when all transports within the system are 
resolved to this common synchronization 
source, or by resolving to any variations in in-
coming timecode while slaving to timecode.
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SMPTE Trigger while Locking to 
an Unresolved Source
SMPTE Trigger can be used with an optional 
SYNC peripheral or equivalent qualified device 
to resolve Pro Tools recording and playback 
speed while slaving to LTC. This enables long-
term, accurate synchronization by resolving to 
any variations in incoming timecode. SYNC pe-
ripherals also support VITC and Bi-phase/Tach 
positional reference.

SYNC Peripheral 
Synchronization Options
By adding a Synchronization peripheral to your 
Pro Tools|HD system, you can use Pro Tools as 
the master device in your synchronization 
setup. All other devices are then slaved to 
Pro Tools. 

You can use Pro Tools in conjunction with a 
Synchronization peripheral to generate LTC, 
MIDI Timecode, or MMC commands. When the 
SYNC peripheral is reading incoming SMPTE 
timecode, it regenerates the timecode through 
the LTC or MTC output connector. This signal 
can be passed along to other slave devices.
Pro Tools Reference Guide
MachineControl
Synchronization peripherals also support Ma-
chineControl software, which provides many 
specialized features for post production syn-
chronization tasks including remote track arm-
ing, VTR emulation, serial timecode, and other 
capabilities. (See the MachineControl Guide for 
more information, or contact your dealer.)

Ext. Clock Output
Pro Tools can be used as the master device in 
your synchronization setup, where all other de-
vices are then slaved to Pro Tools Word Clock 
output. 

To set Ext. Clock Output:

1  In Pro Tools, choose Setup > Hardware.

2  Click the Ext. Clock Output pop-up menu and 
select an available signal. 

3  Click OK to close the Hardware Setup dialog 
when you have finished.

For instructions on connecting an external 
synchronization peripheral to your 
Pro Tools system, see your User Guide. If you 
are using a SYNC peripheral, see its docu-
mentation.



Session Setup Window
The Session Setup window lets you configure various timecode-related settings on your system, as 
well as certain session format settings (such as bit depth, pan depth, audio format, and interleaved). 
The window also includes display-only areas for session sample rate, system delay, and timecode-re-
lated data (such as incoming time). 

The Session Setup window is organized into three sections. The Format section is at the top of the 
window. The SYNC Setup & Session Offsets section, and the Timecode Settings section, can be shown 
or hidden using their dedicated expand/collapse triangles.
Session Setup window with a SYNC Peripheral

SYNC Setup settings

Timecode Settings
section

Generator settings Pull Up/Pull Down
settings

External Timecode 
Offset settings

Session displays 
and settings

Timecode Reader 

Freewheel settings

Clock Source

offset

Format Section

& Timecode Offsets
section

SYNC Setup
To show the Session Setup window:

 From a Pro Tools session, choose Setup > 

Session.

To expand SYNC Setup & Session Offset section:

 Click the SYNC Setup & Timecode Offsets ex-
pand/collapse triangle.

Press Control+2 (Windows) or 
Command+2 (Mac) to open the Session 
Setup window.
The controls in this section configure settings of 
Synchronization Peripherals. Settings are pro-
vided for Clock and Positional Reference, Video 
Ref Format, Video In Format, and Variable 
Speed Override. 

To show Timecode Settings section:

 Click the Timecode Settings expand/collapse 
triangle.

The controls in this section provide timecode 
generation and freewheel options, and separate 
pull up and down selectors for audio and video 
rates.
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Format Displays and Controls 
in the Session Setup Window
The Format section of the Session Setup window 
includes displays and controls for timecode-re-
lated settings on your system, as well as certain 
session format settings (such as bit depth, pan 
depth, audio format, and interleaved).

Sample Rate

This display indicates the sample rate for the 
current session. 

Bit Depth

This menu indicates the bit depth for the cur-
rent session. You can change the bit depth for 
for all newly recorded or imported (and con-
verted) files in the session by selecting a differ-
ent Bit Depth option. For information on each 
option, see “Bit Depths” on page 163.

Clock Source

Use this menu to configure the system Clock 
Source. You can choose between a SYNC periph-
eral, an internal clock source from a peripheral, 
or an external clock source connected to a 
Pro Tools|HD audio interface.

The following Clock Source options are pro-
vided:

Clock Source Options

SYNC When using a SYNC Peripheral, Pro Tools 
receives its clock source from the SYNC periph-
eral. The SYNC Peripheral can in turn reference 
an external clock source, selected in the SYNC 
Setup section of the Session Setup window. 

Changes made to Clock Source in the 
Hardware Setup dialog will be reflected in 
the Session Setup window and vice versa.
Pro Tools Reference Guide
Internal In Internal mode, your system refer-
ences your peripheral’s internal clock and plays 
back at the session’s sample rate.

External Clock Sources Depending on your au-
dio interface, external Clock Source options can 
include AES/EBU, S/PDIF, S/PDIF Optical, ADAT 

Optical, TDIF, and Word Clock (optional word 
clock rates are available at higher session sam-
ple rates). External sources can be any multiple 
of the “base” rate. The base rate is 44.1 kHz for 
88.2 and 176.4 kHz sources. The base rate is 
48 kHz for 96 and 192 kHz sources. If an exter-
nal source is chosen and no valid sync clock is 
detected at the External Clock In, the I/O reverts 
to Internal mode.

System Delay

When Delay Compensation is enabled (Options > 

Delay Compensation), this display indicates the 
total amount of delay (in samples) applied by 
the system to compensate for plug-ins and mixer 
routing delays. 

Pan Depth

This menu lets you select the pan depth for ste-
reo output paths in a Pro Tools session. Pan 
depth is the amount of signal attenuation when 
a track is routed to a stereo output and panned 
to center. For information on each option, see 
“Stereo Pan Depth” on page 949.

If a SYNC Peripheral is enabled in the 
Peripherals dialog, and is correctly 
connected in the Loop Sync chain, the 
SYNC peripheral can be the Loop 
Master, and your audio interfaces will 
clock as Loop Sync slaves.

For more information on external clock 
sources, see your SYNC peripheral docu-
mentation.



Audio Format

This display indicates the current file format for 
files recorded in the session. You can change the 
audio file format for all newly recorded or im-
ported (and converted) files in the session by se-
lecting a different Audio Format option. For 
more information, see “Mixed Audio File For-
mats” on page 164.

Interleaved

Enable the Interleaved option to ensure that all 
newly recorded or imported (and converted) 
stereo or greater-than-stereo multichannel files 
in the session will be interleaved audio files. For 
more information, see “Interleaved Multichan-
nel Versus Mutli-Mono Audio Files” on 
page 164.

Session Start

Use this field to specify a SMPTE start frame 
edge location for your session. For more infor-
mation, see “Setting a SMPTE Session Start 
Time (Start Frame)” on page 1147

Incoming Time (Current Time)

This display indicates incoming timecode from 
an external source (such as a VTR). 

Timecode Rate

The Timecode Rate setting lets you set the 
SMPTE timecode rate for the current session. 

Feet+Frame Rate 

The Feet+Frame Rate setting lets you set the 
Feet+Frame rates for sessions. Supported rates 
include 23.976, 24, and 25 fps.
Set this rate to match the rate of the film projec-
tor, or the video if the film projector speed is 
taken into account. For example, doing a Tele-
cine transfer from a 24 fps film projector to 
NTSC video would necessitate the projector run-
ning at 23.976 fps. This is regardless of whether 
the session is using pull down audio or not.

Timecode 2 Rate 

The Timecode 2 Rate setting lets you set a sec-
ondary frame rate that can be displayed in the 
ruler alongside the main Timecode ruler. This 
lets you reference frame rates in the Timeline 
that are different from the session timecode rate 
(also see “Timebase Rulers” on page 767).

SYNC Setup and Timecode 
Offsets in the Session Setup 
Window
The SYNC Setup and Timecode Offsets section 
of the Session Setup window includes displays 
and menus for timecode-related settings on 
your system. 

SYNC Setup
(Pro Tools|HD and HD Native Systems with a 
SYNC Peripheral Only)

The controls in the SYNC Setup section of the 
Session Setup window let you configure SYNC 
peripheral settings, including clock reference, 
positional reference, video reference format, 
video input format, and Variable Speed Over-
ride (VSO).
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Sync Setup

Clock Reference This menu lets you set the 
Pro Tools clock reference.

 When using a Synchronization peripheral, the 
Clock Reference selector lists all supported clock 
types for the Synchronization peripheral.

 When using Pro Tools|HD systems without a 
Synchronization peripheral, choices include any 
currently-enabled digital format or source avail-
able from your Pro Tools|HD I/O (such as AES, 
S/PDIF, or 1x Word arriving at the Pro Tools|HD 
interface’s Word Clock In port).

Positional Reference Sets the timecode source 
for Pro Tools to use for positional reference. 

Video Ref Format Sets the video reference for-
mat for a Synchronization peripheral.

Video In Format Indicates the expected format at 
the Video In connector on a Synchronization pe-
ripheral. At certain HD rates, a pop-up menu is 
provided for selecting a format.

SYNC Setup
Pro Tools Reference Guide
Variable Speed Override (VSO) Requires a Syn-
chronization peripheral. When a Synchroniza-
tion peripheral is connected to a Pro Tools|HD 
system, the VSO controls are located in the 
SYNC Setup section of the Session Setup win-
dow. 

When using Varispeed with HD MADI, it is pos-
sible to exceed the available bandwidth. When 
Varispeed exceeds the maximum frequency for 
the current nominal sample rate, audio drops 
out. The maximum frequency for Varispeed at 
each nominal sample rate is listed in the follow-
ing table.

See your SYNC peripheral documentation for 
instructions on using VSO to varispeed 
Pro Tools playback.

Varispeed maximum sample rate limits

Nominal 
sample rate

Channel 
Count

Maximum 
Frequency

44.1/48 kHz 64 48.8 kHz

44.1/48 kHz 56 55.6 kHz

88.2/96 kHz 32 97.5 kHz

88.2/96 kHz 28 111.5 kHz

176.4/192 kHz 16 194.9 kHz

176.4/192 kHz 14 223.0 kHz



Ref Present, Locked, and Speed Cal Indicators

The Ref Present, Locked, and Speed Cal indica-
tors in the SYNC Setup section of the Session 
Setup window display synchronization status of 
the SYNC peripheral. The Locked and Speed Cal 
indicators reflect the state of the same LEDs on 
the front panel.

Ref Present Indicator The Ref Present indicator 
lights when the Video Ref In connector is receiv-
ing a valid video signal. 

Locked Indicator The Locked indicator lights 
solid green when the SYNC peripheral is locked 
to the selected clock reference. The Locked indi-
cator flashes yellow if the selected clock refer-
ence source is missing or out of lockable fre-
quency range.

Ref Present, Locked, and Speed Cal Indicators
Speed Cal Indicator This indicator shows the 
status of the incoming clock reference:, depend-
ing on the type of SYNC peripheral you are us-
ing:

• SYNC I/O

• Lit: SYNC I/O is locked and the clock refer-
ence is within 0.025% of the expected rate

• Flashing fast: SYNC I/O is locked but the 
clock reference is more than 0.025% faster 
than the expected rate

• Flashing slow: SYNC I/O is locked but the 
clock reference is more than 0.025% slower 
than the expected rate

• Unlit: Clock reference is not within 0.025% 
of the expected rate

• SYNC HD

• Yellow Solid: SYNC HD is locked and the 
clock reference is within 0.025% of the ex-
pected rate

• Yellow Flashing Fast: SYNC HD is locked 
but the clock reference is between 0.025% 
and 4% faster than the expected rate

• Yellow Flashing Slow: SYNC HD is locked 
but the clock reference is between 0.025% 
and 4% slower than the expected rate

• Red Flashing Fast: SYNC HD is locked but 
the clock reference is more than 4% faster 
than the expected rate

• Red Flashing Slow: SYNC HD is locked but 
the clock reference is more than 4% slower 
than the expected rate

• Unlit: SYNC HD is not locked to the chosen 
clock reference
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External Timecode Offsets
In the External Timecode Offsets section, 
Pro Tools lets you compensate for devices that 
are consistently offset by a fixed number of 
frames (such as some color–corrected video 
masters), or for material that starts at a differ-
ent time than the session. 

Pro Tools provides four different types of Exter-
nal Timecode Offset settings. These offsets in-
clude:

• MMC (MIDI Machine Control)

• 9-Pin (Deck Control)

• Synchronization peripherals, including 
SYNC HD (Pro Tools|HD and HD Native 
systems only), or other peripherals (such as 
MIDI interfaces that provide MIDI Time-
code). 

• Satellite (Pro Tools|HD and HD Native sys-
tems with Satellite Link or Video Satellite, 
or Pro Tools with Video Satellite LE)

Unique values can be defined for each of these 
types of offsets, or you can link all to adjust in 
unison. 

Positive and negative offset values can be en-
tered to offset Pro Tools timecode display later 
or earlier, respectively. 

If you are using the MachineControl option, ad-
ditional options for External Timecode Offsets 
are available. See the MachineControl Guide for 
more information.
Pro Tools Reference Guide
To redefine the External Timecode offsets:

1  Choose Setup > External Timecode Offset.

2  In the Redefine External Timecode Offset dia-
log, enter the offset you want in the Desired 
Timecode Position field.

3  Click OK.

Sample Offset (Sync Offset)

This field lets you set a trigger offset for incom-
ing MIDI Timecode (anywhere from –100000 to 
+100000 samples). This lets you create a perma-
nent offset to fine-tune the point at which 
Pro Tools synchronizes relative to incoming 
timecode. For example, a value of –50 makes an 
event in Pro Tools occur 50 samples before the 
same event in the incoming MIDI Timecode. Use 
this to compensate for timing differences be-
tween various SMPTE-to-MIDI Timecode con-
verters or analog-to-digital/digital-to-analog 
converters. 

Timecode Settings

Freewheel

The choices in the Freewheel section let you 
configure how Pro Tools will freewheel, or con-
tinue playback if timecode is interrupted or cor-
rupted. Use these options to protect against er-
rors that can occur if your SMPTE timecode 
source has “drop outs” or temporary lost sig-
nals.

None No freewheel is applied. 

Redefine External Timecode Offset dialog



Frames Sets a number of frames to freewheel, 
from 1 to 120 frames. This value defaults to 8 
frames, which is the recommended setting for 
most applications.

Jam Sync Lets Pro Tools trigger synchroniza-
tion to incoming timecode, and continue to play 
back even if timecode input is completely inter-
rupted. It can be useful if timecode is damaged, 
or has been accidentally erased from your 
source tape.

Pull Up/Down

When Pro Tools is used in conjunction with a 
Synchronization peripheral, or a qualified 
third-party peripheral that supports pulled sam-
ple rates, this option lets you “pull up” or “pull 
down” the current sample rate.

For general information, see the Pro Tools Sync 
& Surround Concepts Guide. For more informa-
tion on applying pull factors in Pro Tools, see 
“Pull Up and Pull Down” on page 1150. 

Preparing to Work with 
SMPTE
The first step when preparing to work with 
SMPTE is to choose an appropriate SMPTE 
frame rate. Pro Tools supports all standard 
SMPTE frame rates. If you are working with 
SMPTE striped tape, it is important to know the 
frame rate. In some cases, a SYNC peripheral 
can be used to do this.

Remember, pull up and pull down are ap-
plied differently in different workflows. 
Make sure you check each project’s specific 
workflow before you begin your work.

For a full explanation of SMPTE frame 
rates, see the Pro Tools Sync & Surround 
Concepts Guide.
Configuring Pro Tools for 
SMPTE
Synchronization and MachineControl system 
settings are enabled in the Pro Tools Peripherals 
dialog (Setup > Peripherals). These settings are 
system settings, and remain constant regardless 
of the particular session you are working on. 
Configure these settings before opening a ses-
sion.

Other settings are configured in the Session 
Setup window, such as the session Timecode 
rate, the Feet+Frames rate, the session start 
frame, and time display format. These settings 
are session-specific settings. These settings can 
only be configured when a session is open.

Selecting a SMPTE Format

To choose a SMPTE format:

1  In Pro Tools, choose Setup > Session.

2  Choose a frame rate (SMPTE format) from the 
Timecode Rate selector. 

3  Enter the Timecode Freewheel frames (if any) 
in the designated box (see “Freewheel” on 
page 1146).

Setting a SMPTE Session Start 
Time (Start Frame)
The Session Setup window also allows you to set 
a SMPTE Start Frame for your session. Video 
work tapes are rarely striped beginning at a 
SMPTE frame address of 00:00:00:00. You can 
quickly enter a start time for your session based 
on an appropriate frame number from your 

MachineControl is supported on 
Pro Tools|HD systems only.
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project tape. The Pro Tools SMPTE-related 
functions (such as Spot mode) will then use this 
value as their reference for the session’s start 
point.

Start Time When Striping Tape

If you are generating timecode, it is a good prac-
tice to stripe your timecode beginning at 
01:00:00:00 (subtracting time for the head for-
mat, such as initial black, bars and tone, or lo-
gos). This prevents problems that can occur 
with some synchronizers when the striped time-
code crosses from 23:59:59:29 to 00:00:00:00 
(commonly referred to as the “midnight” 
boundary).

To set a SMPTE Start Time for your session:

1  Choose Setup > Session. 

2  Enter a SMPTE frame number in the Session 
Start field.

To capture an incoming SMPTE address as the 
session start time:

1  Click in the Session Start field.

2  Begin playback of the timecode source. 

3  At the location where you want to capture the 
incoming value, press Equal (=) in the numeric 
keypad. 
Pro Tools Reference Guide
4  Press Enter to accept the value. You can then 
edit the captured address. The session uses the 
frame number you enter as its SMPTE start 
frame when online.

• If there are existing clips on the tracks and 
you are changing the original SMPTE start 
frame to a later time (from 00:00:00:00 to 
01:00:00:00, for example), all existing clips 
on tracks will remain in their relative posi-
tions, but will start later by the time value 
added to the start frame.

• If you are changing the session start time in 
an open session in which tracks already ex-
ist, a warning dialog appears when you 
press Enter. Choose from one of two op-
tions:

Maintain Timecode Places the additional session 
time at the start of the session, and keeps exist-
ing clips in their original timecode locations.

Maintain Relative Position Places the additional 
session time at the start of the session, and 
maintains the relative position of existing clips 
to the new start frame. For example, if you 
change the session start frame from 01:00:00:00 
to 00:59:00:00, Pro Tools adds one minute of 
session time to accommodate the new start 
frame, and moves all existing clips earlier in 
time to maintain their relative position to the 
start frame. 



Redefining a Feet+Frames 
Position
Use the Current Feet+Frames command to rede-
fine the Feet+Frames position at the current in-
sertion point. The session start time is recalcu-
lated based on the new, relative Feet+Frames 
location. 

Typically, this command is used for integrating 
test tones, pre-roll, Academy leader, and similar 
pre-program material into Pro Tools sessions. 
Redefining Feet+Frames does not redefine the 
session start time.

To set a relative frame position for a session 
(Feet+Frames):

1  With the Selector tool, click in a track (or 
make a selection) where you want to redefine the 
position.

2  Choose Setup > Current Feet+Frames Position.

3  Enter a Feet+Frame position to correspond to 
the timecode shown in the dialog.

4  Click OK.

Redefining a Timecode Position
Use the Current Timecode Position command to 
redefine the current timecode position and ses-
sion start time. By creating an insertion point 
(or selection), and then entering the new time-
code position for that location, the session start 
time will be recalculated based on the new, rela-
tive Timecode location.

To redefine a current Timecode code position:

1  With the Selector tool, click in a track (or 
make a selection) where you want to redefine the 
position.

If your insertion or selection is not on a grid 
boundary, it will round to the closest 
boundary.
2  Choose Setup > Current Timecode Position.

3  Enter a new SMPTE frame number in the dia-
log to correspond to the timecode shown in the 
dialog.

4  Click OK.

Displaying Time in SMPTE 
Frames
In Pro Tools, you can set the Main Time Scale to 
Timecode (SMPTE) and this will be displayed in 
the Main Counter. Though Pro Tools will still 
synchronize to incoming SMPTE timecode if the 
Time Scale is displayed in Bars|Beats, Min-
utes:Seconds, or Feet.Frames, it is usually more 
useful to use SMPTE timecode as your reference.

To set the Main Time Scale to SMPTE Timecode, do 
one of the following:

 Choose View > Rulers > Timecode.

– or –

 Click the Main Counter selector in the Edit 
window and select Timecode.

Pro Tools displays timecode values in the cur-
rently selected SMPTE frame rate.

Sub Counter and Sub Time Scale Display

You can display a Sub Time Scale in the Sub 
Counter. For example, if the Main Time Scale is 
set to Timecode, and you want to compare 
SMPTE time to “wall clock,” when you are using 
29.97 Non-Drop frame rate, click the Sub Coun-
ter selector and select Min:Secs as the Sub Time 
Scale.

If your insertion or selection is not on a grid 
boundary, it will round to the closest 
boundary.
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Pull Up and Pull Down
Pro Tools supports up to 4% pull up and pull 
down, with support for an additional 0.1% up or 
down. Separate rates can be set for session audio 
and video (when video has been imported or 
captured into the session). 

When referring to 4% pull up and pull down, the 
precise percentages used in pull ups is 4.167%.

While a Synchronization peripheral is not re-
quired in order to use the extended pull up and 
down options provided in Pro Tools, a Synchro-
nization peripheral is the only device that can be 
controlled from within Pro Tools, and that re-
calls and restores pull factors automatically 
when a session opens. Other synchronization 
peripherals must be configured manually. 

Pull up and down settings do not affect 
timecode generated by a SYNC peripheral.
Pro Tools Reference Guide
Configuring Pull Up and Pull 
Down

To pull up or pull down audio or video:

1  Choose Setup > Session.

2  From the Timecode Settings section of the Ses-
sion Setup window, select a Pull Up/Down Rate.

Audio Rate Pull Up/Down Controls the audio 
sample rate. See “Audio Sample Rate Pull Up 
and Down” on page 1151.

Video Rate Pull Up/Down Controls the video 
rate. See “Video Frame Rate Pull Up and Down” 
on page 1152. 

The choices available in these menus are deter-
mined by the session frame rate. Combinations 
can be applied by choosing from both menus. 

The choices available in these menus are also de-
termined by the Preferences and the Auto Match 

Pull Factors option in the Timecode Rate menu. 
See “Extended Pull Up and Pull Down Prefer-
ence and Session Setup Controls” on page 1151 
and “Auto Match Pull Factors” on page 1151.

Press Control+2 (Windows) or Com-
mand+2 (Mac) to open the Session Setup 
window.

Session Setup window 

4% pull factors are not available in 176.4 
and 192 kHz sessions.



Extended Pull Up and Pull Down 
Preference and Session Setup 
Controls
The Audio Rate Pull Up/Down setting offers all 
possible combinations of pull ups and pull 
downs for the audio sample rate, regardless of 
the session frame rate. 

In addition, if there is a QuickTime movie in the 
Timeline, the video rate can be pulled up or 
down by 0.1%, regardless of the session frame 
rate. Though not a recommended workflow, ear-
lier versions of Pro Tools also enabled pull down 
of QuickTime video clips when audio was pulled 
down, so this option is included in Pro Tools 
5.3.1 and higher to maintain compatibility with 
earlier sessions. 

Auto Match Pull Factors
The Auto Match Pull Factors option is available 
from the session Timecode Rate menu in the 
Session Setup window. When Auto Match Pull 

Factors is enabled, Pro Tools adjusts audio and 
video playback rates as needed to match any 
changes to the current session Timecode Rate. 

Auto Match Pull is applied relative to the cur-
rent pull up setting. While enabled, if the ses-
sion frame rate is changed in such a way that the 
video would have to be pulled by an unsup-
ported amount, the video remains unaffected. 

This setting is latching, is not enabled by de-
fault, and its state is stored with the session.
Example of Auto Match Pull 
Factors
The Auto Match Pull Factors option links audio 
and video pull factors when changing session 
frame rate. 

For example, assume a Pro Tools session is set to 
a frame rate of 25 fps, the audio and video are 
both playing with no pull ups, and Auto Match 
Pull Factors is enabled. 

If you then change the session Frame Rate to 
24 fps, both the Audio and Video Rate Pull set-
tings would change by –4.0% (the appropriate 
pull setting required by the change in frame 
rate). 

Auto Match-enabled pull factors are applied to 
any existing Audio Rate Pull Up/Down or Video 
Rate Pull Up/Down settings. 

For example, if audio was already being pulled 
–0.1% when you changed the session Frame Rate 
from 29.97 to 24 fps, then the Audio Rate Pull 
Up/Down menu would switch to None. 

Audio Sample Rate Pull Up and 
Down
The Audio Rate Pull Up/Down setting applies pull 
up or down factors to session audio record and 
playback. All pull rates are available, regardless 
of session frame rate. 

See also “Auto Match Pull Factors” on 
page 1151.
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Audio Rates and Pull Up/Down Options
The following table lists actual sample rates of each pull up and pull down option and combination 
(rounded to the nearest whole Hz):

Sample Rates at Pull Up and Pull Down Settings
Pro Tools Reference Guide
Pull 
Up/Down 

Sample Rate

44100 48000 88200 96000 176400 192000

+4.1667% 
and +0.1%

45983 50050 91967 100100 n/a n/a

+4.1667% 45938 50000 91875 100000 n/a n/a

+4.1667% 
and –0.1%

45892 49950 91783 99900 n/a n/a

+0.1% 44144 48048 88288 96096 176576 192192

–0.1% 44056 47952 88112 95904 176224 191808

–4.0% and 
+0.1%

42378 46126 84757 92252 n/a n/a

–4.0% 42336 46080 84672 92160 n/a n/a

–4.0% and 
–0.1%

42294 46034 84587 92068 n/a n/a
Video Frame Rate Pull Up and 
Down
The Video Pull Up/Down setting lets you change 
the frame rate of QuickTime movie playback in-
dependently from the audio pull-up/down rate.

The choices available for Video Rate Pull 

Up/Down depend on the file format and frame 
rate of the QuickTime movie. Video pull rates 
are saved with the session. 

Avid video tracks cannot be pulled up or 
pulled down.

See also “Auto Match Pull Factors” on 
page 1151.
Effect of Using Pull Up or Pull 
Down
This topic describes how related Pro Tools fea-
tures are affected by pull up and down rates. 

Video Pull Up and Pull Down and 
Timecode Ruler
Video pull up and down does not affect the 
Timecode ruler. Be sure to set the session Frame 
Rate to the correct frame rate for your project. 
For example, if working with 24 fps video and 
you pull the video up by 4%, switch the session 
Frame Rate to 25 fps to keep the Timecode ruler 
aligned. Similarly, if working with 24 fps video 
that is pulled down by 0.1%, switch the frame 
rate of the session to 29.97.



When working with 25 fps Avid media and the 
video is set to pull down by 4%, set the session 
Frame Rate to 24 fps.

Plug-Ins and Pull Up and Pull 
Down
For proper operation at larger (4%) pull rates, 
plug-ins must utilize sample clock instead of an 
absolute time clock. All Pro Tools audio plug-
ins are based on sample clock. 

Higher Sample Rates and Pull 
Factors
4% audio pull rates are not available in 176.4 
and 192 kHz sample rate sessions.

No Video Recording with Pull Up 
or Pull Down
(Avid Video Peripheral Required)

Since Avid video cannot be pulled up or pulled 
down, video cannot be recorded to the Timeline 
if a video pull up or down is selected. If the video 
track is record-enabled while video pull ups are 
enabled, or if you attempt to set a video pull up 
rate while the video track is record-enabled, 
Pro Tools posts a dialog and disallows video re-
cording. To proceed with digitization, reset the 
Video Rate Pull Up/Down setting to None. 
Putting Pro Tools Online
To trigger playback or recording from an exter-
nal source, the Pro Tools Transport must be 
placed online. This tells Pro Tools to listen for 
incoming timecode. 

To put the Pro Tools Transport online, do one of 
the following:

 Choose Options > Transport Online. 

– or –

 Click the Online button in the Transport. 

The Online button flashes while Pro Tools waits 
for a SMPTE frame to trigger playback. When 
timecode is received, playback begins and the 
Online button becomes highlighted. The Edit 
Selection indicators in the Edit window, and the 
Incoming Time field in the Session Setup win-
dow display the incoming timecode. 

To take Pro Tools offline, do one of the following:

 Deselect Options > Transport Online.

– or –

 Deselect the Online button in the Transport 
window.

Press Command+J (Mac) or Control+J 
(Windows) to put the Transport Online. 

Clicking the Online button in the Transport 
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Recording Online
The Operation Preferences page contains two 
options that affect how Pro Tools initiates re-
cording when online.

Record Online at Timecode (or ADAT) 
Lock Makes online recording begin as soon as 
Pro Tools receives and locks to timecode or 
ADAT sync. In this case, you do not need to 
make an insertion or selection in a track to des-
ignate a start point.

Record Online at Insertion/Selection Makes on-
line recording begin wherever you have placed 
the insertion point in a track. Recording then 
continues until Pro Tools stops receiving time-
code. If you make a Timeline selection, 
Pro Tools will record online only for the length 
of the selection. 

Generating Timecode
Using a SYNC peripheral, Pro Tools can gener-
ate SMPTE and MIDI Timecode (MTC). Without 
a SYNC peripheral, Pro Tools can only generate 
MTC. This lets Pro Tools function as a master 
synchronization source with other devices slave 
to it (chase).

To generate MIDI Timecode from Pro Tools:

1  Choose Setup > Peripherals and click the Syn-

chronization tab.

2  From the MTC Generator Port setting, select 
the MIDI output port on which you want to 
transmit MIDI Timecode (MTC).
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3  From the Transport Window menu (or the Edit 
Window menu), select Synchronization.

4  Click the Gen MTC button so that it highlights.

5  Start playback.

To generate timecode using a SYNC peripheral:

1  Connect the SYNC peripheral LTC Out to the 
SMPTE in connector on the devices you are slav-
ing. If you are slaving a device that recognizes 
MTC, connect the MTC OUT connector of the 
SYNC peripheral to the MIDI IN connector of 
the slaved device. 

2  Make sure your SYNC peripheral is powered 
on.

3  In Pro Tools, choose Setup > Peripherals and 
click the Synchronization tab.

4  In the Synchronization Device section of the 
Synchronization page, select Enable SYNC Pe-

ripheral.

5  Click OK to close the Peripherals dialog.

6  Choose Setup > Session, and choose the appro-
priate frame rate for the Timecode Rate setting.

Selecting the MTC Generator Port

Transport, Gen MTC enabled



7  In the SYNC Setup section of the Session Setup 
window, choose a clock reference from the Clock 
Reference selector. Not all clock choices are 
available at all sample rates. See “External Clock 
Sources” on page 1142.)

8  From the Transport Window menu (or the Edit 
Window menu), select Synchronization.

9  Select one of the following:

• Gen MTC to generate MIDI Timecode.

– or –

• Gen LTC to generate Linear Timecode.

10  Start playback.

Pro Tools generates and outputs timecode from 
the SYNC peripheral.

Limitations for SYNC 
Peripherals Locked to Video 
Input or Video Reference
A SYNC peripheral can generate timecode at any 
frame rate when locked to Video Reference or 
Video In, regardless of the frame rate of the in-
coming video reference signal. However, if you 
choose to generate timecode using a frame rate 
which does not match that of the video signal, 

Transport window, Synchronization options shown

Press Command+Control+J (Mac) or Con-
trol+Start+J (Windows) to enable (or dis-
able) Generate LTC (GEN LTC).
the frame edges in the Pro Tools session (and 
the frame edges of the timecode you are generat-
ing) will not be aligned with the video frame 
edges.

Using MIDI Machine Control
Pro Tools provides the capability to transmit lo-
cation information to external devices and to 
control their transports using MIDI Machine 
Control (MMC). 

Controlling External Devices 
Using MMC
Any device that supports MMC can be con-
trolled directly from within Pro Tools, with ei-
ther the device or Pro Tools acting as clock mas-
ter.

The external devices supported by Pro Tools im-
plement “open loop” communications only. Be-
cause of this, while Pro Tools is the Transport 
Master, any direct operation of the receiving de-
vice’s transport will not be communicated back 
to Pro Tools. Instead, you can use the Transport 
pop-up to select the external device (MMC in the 
pop-up) and use the Pro Tools on-screen trans-
port controls to drive the device. 

If you change timecode rates in the middle 
of a session, many SMPTE-to-MIDI Time-
code converters need to be turned off and 
turned on again to be able to recognize the 
new frame rate.
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Pro Tools does not support remote track arming 
of MMC-controlled external devices. You need 
to manually arm tracks for recording on the ex-
ternal device. 

Enabling MIDI Machine 
Control in Pro Tools

Pro Tools as MMC Master
When Pro Tools is the Master, it sends MMC 
commands to the slave device and receives MTC 
information back from the slave device.

To slave an external device to Pro Tools using MIDI 
Machine Control:

1  Connect a MIDI Out port on your Pro Tools 
MIDI interface to an appropriate port on the 
slave device.

2  Connect the MTC out from the slave device to 
a MIDI In port on your Pro Tools MIDI Inter-
face.

3  In Pro Tools, choose Setup > Peripherals and 
click the Synchronization tab.

4  Deselect Enable SYNC Peripheral if it is se-
lected. 

5  From the MTC Reader Port pop-up menu, se-
lect the MIDI In port to which the slave device is 
connected (the source of MTC information from 
the slave device). 

6  Click the Machine Control tab in the Peripher-
als dialog.

7  In the MIDI Machine Control (Master) section, 
select Enable.

The MachineControl option supports re-
mote track arming for Sony 9-pin and V-
LAN enabled devices. See “Remote Track 
Arming” on page 1159.
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8  In the MIDI Machine Control (Master) section, 
select the MIDI Out port to which the slave de-
vice is connected from the pop-up menu.

9  Set the MMC ID number for which this infor-
mation will be sent in the “ID” field. 

MMC commands contain an ID number to iden-
tify which machine should respond to the MMC 
command. There are 128 MMC ID numbers, 
from 0–127. The default of ID #127 is a special 
setting that transmits to all 128 MMC IDs. With 
a setting of 127, Pro Tools will transmit MMC 
commands to all MMC IDs. 

10  Set a pre-roll time for your MMC slave device. 
Pre-roll is needed to provide the device with suf-
ficient time to lock to the timecode transmitted 
by Pro Tools. This value will vary depending on 
the external device. If the pre-roll time is insuf-
ficient, the device may not be ready to lock until 
after the current timecode position has passed.

11  Click OK to close the Peripherals dialog.

12  In the Pro Tools Transport window, choose 
Transport = MMC.

Selecting the MIDI Out port for MMC

Selecting Transport = MMC 



Pro Tools will now be able to control the se-
lected device’s transport and act as the clock 
master.

13  To have the Pro Tools transport chase the 
playback location of the slave device, click the 
Online button in the Transport window.

Pro Tools as MMC Slave
When Pro Tools is the slave, it receives MMC 
commands from the master device and sends 
MTC information back to the slave device.

To slave Pro Tools to an external device using MIDI 
Machine Control:

1  Connect a MIDI In port on your Pro Tools 
MIDI interface to an appropriate port on the 
master device.

2  Connect a MIDI Out port on your Pro Tools 
MIDI Interface to the MTC in port on the master 
device.

3  In Pro Tools, choose Setup > Session.

4  In the Timecode Settings section of the Session 
Setup window, select Using MTC. 

5  Choose Setup > Peripherals and click the Syn-

chronization tab. 

6  Deselect Enable SYNC Peripheral if it is se-
lected.

7  From the MTC Generator Port pop-up menu, 
select the MIDI Out port to which the master de-
vice is connected (this the destination of MTC 
information from Pro Tools). 

8  Click the Machine Control tab in the Peripher-
als dialog.

In order for Pro Tools to receive MMC com-
mands, the MMC source must be enabled in 
the MIDI Input Enable dialog. For more in-
formation, see “Enabling Input Devices” on 
page 482
9  In the MIDI Machine Control (Slave) section, 
select Enable.

10  Set the MMC ID number (channel) on which 
this information will be received in the “ID” 
field. 

11  Click OK to close the Peripherals dialog.

Pro Tools will now respond to MMC commands 
from the external device.

Operating MMC Devices with the 
Pro Tools Transport 
You can use the Pro Tools Transport window as 
the remote controller for all your enabled de-
vices (such as a nonlinear video deck). To do so, 
set the enabled devices to listen to the address 
you enter for MMC. The Transport window will 
then drive the Pro Tools transport and any 
slaved devices. 

Machine Control page of the Peripherals dialog
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To control external devices from the Pro Tools 
Transport:

 Select either Pro Tools or MMC from the 
Transport pop-up in the Pro Tools Transport 
window. The selected item will act as Transport 
Master.

• When the Transport Master is set to 
Pro Tools, the playback position is gov-
erned by the on-screen cursor in Pro Tools. 

• When the Transport Master is set to MMC, 
the playback position is governed by the ex-
ternal device’s play position. 

MMC Transport Settings
When using MMC, you can set the following op-
tions for machine transport behavior in the Syn-
chronization Preferences page.

Machine Chases Memory Location When se-
lected, navigating to a specific location in a ses-
sion with a Memory Location causes a connected 
transport to chase to that location. 

Machine Follows Edit Insertion/Scrub When se-
lected, navigating to a specific location in a ses-
sion by moving the selection point or by scrub-
bing a track causes a connected transport to 
chase to that location.

Selecting the Transport Master
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Taking a Device Offline
Use the Online pop-up menu in the Transport 
Master selector to take a MIDI (or Machine) de-
vice offline.

To take a device offline:

1  Click the Transport Master selector.

2  In the Transport, click on the Online pop-up 
menu and deselect the device (Machine or 
MIDI). Device choices depend on the current 
Transport Master and which devices have been 
set up in Pro Tools.

To bring a device back online, click and reselect 
it in the Online pop-up menu.

Online pop-up menu with device deselected to take it 
offline

The Online pop-up menu will only display 
devices that have been properly set up in 
Pro Tools.

To set up MIDI devices, see “Enabling MIDI 
Machine Control in Pro Tools” on 
page 1156.

To set up machine devices, see the 
MachineControl Guide.



Setting Minimum Sync Delay
Lock-up time delay is the initial amount of 
prime time your system’s devices need to 
achieve synchronization “lock.” This amount 
varies for each device. Pro Tools lock up delay is 
set by entering a value for Minimum Sync Delay 
in the Synchronization preferences. The lowest 
value available is 15 frames. Find the shortest 
possible lock-up time that your equipment can 
operate at consistently, and set this as the Mini-

mum Sync Delay. On systems utilizing Machine-
Control, enabling the Use Serial Timecode set-
ting in the Session Setup window will make 
machines lock up much faster. (Serial timecode 
requires both the SYNC peripheral and external 
devices to be locked to house video reference.)

To set a Minimum Sync Delay:

1  Choose Setup > Preferences, and click the 
Synchronization tab. 

2  Enter a number of frames in the Minimum Sync 

Delay field. 

3  Click OK to close the Preferences dialog. 

Configuring Minimum Sync Delay for External 
MMC Devices Locked to House Sync

When controlling a house-synced device from 
Pro Tools through MMC, the device will first 
lock to the MMC location and then align the 
color framing. Within house sync code are 4 
frames for ensuring color frame lock. If the min-
imum synchronization setup time is less than 
the time required to achieve both location and 
color frame lock, playback will begin before the 
device has aligned the color frames. In this sce-
nario, you should set the Minimum Sync Delay to 
be more than the time required for color frame 
lock. This is not a problem with a SYNC periph-
eral, which will drop out of lock until the color 
frame is locked. 
Remote Track Arming
The MachineControl option for Pro Tools lets 
you remotely arm tracks on supported 9-pin (or 
V-LAN for transport only) decks. Without Ma-
chineControl, Pro Tools does not support re-
mote track arming of external devices. Machine-
Control lets Pro Tools act as the master or slave 
to external Sony 9-pin (or V-LAN for transport 
only) machines, in addition to providing remote 
track arming from within Pro Tools.

Choose Setup > Machine Track Arming 
Profiles to configure your system, and 
choose Window > Machine Track Arming to 
display the Machine Track Arming window.

Press Command+Option+Control+J (Mac) 
or Control+Alt+Start+J (Windows) to en-
able (or disable Remote mode. If using a 
D-Command or D-Control work surface, 
press the 9-pin Remote button.

For information on remote track arming 
with MachineControl, see the 
MachineControl Guide.
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Spotting Clips to SMPTE 
Frame Locations
Spotting is the process of assigning music and 
sound cues to specific SMPTE frame locations in 
a film or video. This function can be used to 
spot:

 Entire clips, selected with the Time Grabber 
tool. Multiple clips can also be selected, and 
Pro Tools will reference the first clip in your se-
lection.

 A specific location within a clip, by clicking 
with the Selector tool at that location, and 
choosing Clip > Identify Sync Point. 

 Sessions or tracks, dragged from a browser to 
the session Timeline or Clip List. 

Spot Mode
In Spot mode, a clip in a track can be quickly 
spotted by simply clicking it with the Time 
Grabber tool. 

You can also drag a clip from a DigiBase 
browser, or from the Clip List, to a track while in 
Spot mode. 

The Spot Dialog
The Spot dialog appears when you drag a clip to 
a track or click a clip with the Time Grabber tool 
in Spot mode. The numeric fields function as 
both data displays and editing controls for the 
currently selected clips. 
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Information in these fields is displayed in 
SMPTE Timecode, Minutes:Seconds, 
Feet.Frames, Samples, or Bars & Beats, depend-
ing on which Time Scale format is selected.

A highlighted numeric field indicates the cur-
rent active field for numeric entry editing. En-
tering a value in a field allows you to move a se-
lected element to the time location that you 
enter. The Start, Sync Point, and End fields are 
accessible when the Time Grabber tool is active. 
Only the Start or End (depending on where you 
click the mouse) and Duration fields are active 
when one of the Trim tools is active (see “Using 
the Trim Tools in Spot Mode” on page 1162).

Spot dialog

To increase or decrease SMPTE values in the 
Spot dialog by a specific number of frames, 
press Plus (+) or Minus (–) on the numeric 
keypad, enter a number, and press the Enter 
key.



Use Subframes Option
A subframe is 1/100th of a frame. The Use Sub-

frames option enables you to use these smaller 
units for greater accuracy. This command adds 
an additional time field in the SMPTE 
hours:minutes:seconds:frames box, which ap-
pears as the far right time field when enabled. 
Use a Period (.) to separate subframe values 
from whole frames.

Capturing Timecode
Pro Tools also allows you to easily capture frame 
locations on-the-fly in the Spot dialog by press-
ing the Equal key, or by clicking the Current 

Timecode button while valid timecode is being 
received by Pro Tools. With VITC, you can accu-
rately capture a paused or “crawling” VTR’s 
SMPTE location.

When Timecode is selected for the Time Scale, 
pressing the Equal key captures the incoming 
timecode. When Bars|Beats is selected for the 
Time Scale, pressing the Equal key will capture 
to the nearest measure.

Although Capture Timecode works with free-
running Linear Timecode (LTC) or VITC, frame 
numbers of a paused frame can only be captured 
with VITC. 

Additional time field with “Use Subframes” enabled 

Subframe measurements are not available 
in the Current Time field.
SYNC peripherals can read VITC. With 
MachineControl and a SYNC peripheral, you can 
also read serial timecode.

To spot a clip to a specific SMPTE frame:

1  Enable Spot mode.

2  Set the Main Time Scale to Timecode. (See 
“Setting a SMPTE Session Start Time (Start 
Frame)” on page 1147.)

3  Identify the SMPTE frame location where you 
want to trigger playback of your clip by pausing 
your video deck on that frame. 

4  With the Time Grabber tool, click a clip in a 
track, or in the Clip List, and drag it into a track. 
The Spot dialog appears.

5  Enter the SMPTE frame location by doing one 
of the following: 

• If you are using VITC, you can press the 
Equal (=) key on the numeric keypad, or 
click Current Timecode to enter a paused 
VTR’s current SMPTE location.

– or –

• If you are using LTC, when Timecode is se-
lected for the Time Scale, press the Equal 
(=) key on the numeric keypad to capture 
the incoming timecode. When Bars|Beats is 
selected for the Time Scale, press the Equal 
key to capture the nearest measure.

6  If you recorded the clip while online, you can 
use the Original Time Stamp button to recall and 
enter the SMPTE frame location at which the 
clip was originally recorded. You can also access 
a user-defined Time Stamp by clicking the User 

Time Stamp button. See “Time Stamping” on 
page 1162 for more information.

To use Remote mode with MachineControl, 
you will need an approved serial port. For a 
complete list of currently approved ports, 
visit www.avid.com.
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7  Click OK to close this dialog. The clip spots to 
the chosen SMPTE frame location. When the 
session is online, this frame number will trigger 
playback of the clip.

Auto-Spotting Clips
The Pro Tools Auto-Spot Clips option simplifies 
the task of spotting clips even further. If you are 
using VITC with this option enabled, or Ma-
chineControl software, you can pause your 
video at an appropriate SMPTE frame location, 
click a clip with the Time Grabber tool, and the 
clip will be automatically spotted to the current 
timecode location. 

You can also use MachineControl’s serial time-
code ability to auto-spot by enabling Machine-
Control and enabling serial timecode in the pe-
ripheral. 

To Auto-Spot a clip:

1  Choose Options > Auto-Spot Clips.

2  If you are using VITC, identify the SMPTE 
frame location where you want to trigger play-
back of your clip by pausing your video deck on 
that frame. 

3  Click the clip with the Time Grabber tool. The 
clip will be automatically spotted to the current 
timecode location (or machine location).

Clicking a clip with any of the Trim tools 
will allow you to trim the clip to the current 
timecode location.

Auto-spotted clips are spotted by their start 
times, unless you have identified a Sync 
Point (see “Identifying a Synchronization 
Point” on page 1164). If the clip contains a 
Sync Point, the clip is spotted to it. 
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Using the Trim Tools in Spot 
Mode
You can use the Spot dialog to trim your clips, 
including start/end/duration times and refer-
encing incoming timecode addresses. If you 
click a clip with any of the Trim tools in Spot 
mode, the Spot dialog will appear, allowing you 
to enter a value in the Start or End and Duration 
fields to specify exactly where you want to trim 
the clip’s beginning or end. Use this to edit the 
length of a clip to correspond to a particular vi-
sual “hit point.” 

Trimming a clip that contains a sync point (see 
“Identifying a Synchronization Point” on 
page 1164) does not affect the SMPTE location 
of the sync point, unless the clip is trimmed past 
the sync point.

Time Stamping
Pro Tools time stamps every clip recorded on-
line with the original SMPTE time at which au-
dio was recorded. You can recall this original 
SMPTE time for a clip by clicking the Original 
Time Stamp button in the Spot dialog.

You can also spot a clip to a separate user-de-
fined SMPTE time stamp, defined using the Time 

Stamp command in the Clip List menu. Once the 
clip is time stamped using this command, you 
can click the User Time Stamp button to re-spot 
a clip to its user-defined SMPTE location.



Show Original Timecode in Clips
This command displays the original “time 
stamped” SMPTE times in all clips currently 
placed in tracks. This SMPTE frame number 
represents the time at which the clip was origi-
nally recorded online with Pro Tools, and does 
not necessarily reflect the clip’s current SMPTE 
location in a track.

To show (or hide) Original Time Stamps in clips:

 Select (or deselect) View > Clip > Original Time 

Stamp.

Creating a User Time Stamp 
If you want to create a separate user-defined 
SMPTE time stamp, you can use the Time Stamp 
command in the Clip List menu. This command 
lets you select a clip (or clips) and redefine its 
SMPTE time stamp. The Original Time Stamp 
and the User-Time Stamp are then stored with 
your session.

When audio is first recorded, the User Time 
Stamp will match the Original Time Stamp, but 
you can change the User Time Stamp at any time 
using the Time Stamp command. This feature is 
particularly useful in post production situations 
where the SMPTE timecode on video “work 
prints” often changes from one edit revision to 
another.

To time stamp a clip (or clips) with a new SMPTE 
frame number:

1  In a track, select the clip that you want to time 
stamp.

2  From the Clip List menu, choose the Time 

Stamp command.
3  Enter a new SMPTE time by doing one of the 
following: 

• Enter the numbers manually (with the help 
of the arrow keys). 

• Click the Current Timecode button (or press 
the Equal key), if you want to capture the 
incoming timecode address.

• Click the Current Selection button, if you 
want to enter the start time of the current 
on-screen selection.

4  Click OK to close this dialog.

This command can be used in “batch mode” to 
set new time stamps for several clips at a time. 
To do this, simply select several clips and choose 
the Time Stamp command. One after another, a 
dialog will open for each clip, allowing you to 
quickly enter new values.

Once entered, the user time stamps can be dis-
played in all clips currently placed in tracks. 

To show (or hide) User Time Stamps in clips:

 Select (or deselect) View > Clip > User Time 

Stamp.

User Time Stamp dialog
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Identifying a Synchronization 
Point
The Pro Tools Identify Sync Point command lets 
you identify a specific point within a clip for au-
dio spotting purposes. 

Imagine the following sound effects spotting 
scenario: You have a single sound effect that 
consists of a creaky door slamming shut, fol-
lowed by a few seconds of ambient reverbera-
tion. The slam portion of the effect—which you 
must precisely match to picture—occurs neither 
at the very beginning of the audio file nor at the 
very end. It is somewhere in the middle, making 
it tough to spot. In this scenario, use the Identify 

Sync Point command to create a point in the clip 
and synchronize that point to a SMPTE frame. 

To create a sync point in a clip:

1  Do one of the following:

• Click with the Selector tool at the point in 
the clip that you want to synchronize to a 
SMPTE frame location. 

– or –

• Press the Down Arrow key while playing 
back. 

2  Choose Clip > Identify Sync Point. The current 
SMPTE time is automatically entered as the 
SMPTE location for the sync point. A small 
down arrow appears at the bottom of the clip, 
with a vertical, light gray line indicating the lo-
cation of the sync point.

For more information on Sync Points, see 
“Sync Points” on page 837.

Sync Point in an audio clip
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Troubleshooting SMPTE 
Synchronization
If you are having problems getting SMPTE syn-
chronization to work properly, you can trouble-
shoot your system and solve common problems. 

Stripe SMPTE Before You 
Record
All tapes in your setup (both audio and video) 
must be striped with SMPTE Timecode before 
any audio is recorded onto them or to Pro Tools. 
If tapes aren’t striped, your system may seem to 
work, but synchronization will never properly 
occur. The machines and Pro Tools will drift 
farther and farther apart the longer they run.

The same problem occurs when audio is re-
corded into Pro Tools without a resolved 
SMPTE source (for example, if it was recorded 
before the current session). The audio cannot be 
accurately synchronized with an analog tape re-
corder or video tape deck, since the Pro Tools 
audio was not recorded referenced to the SMPTE 
timecode from the analog tape deck or video 
tape deck.

Resolve All Components of Your 
System
When striping timecode, make sure that the 
timecode generator and the video record deck 
are resolved to the same crystal reference. For 
example, when striping 29.97 Drop Frame time-
code onto a VTR, both the SMPTE generator and 
the VTR should be resolved to the same “black 
burst” or house sync generator. During play-
back, the master deck should be resolved to 
“black burst” or house sync. 



This convention provides compatibility for your 
tape between the record and playback passes, 
and when it is played back in other facilities on 
different equipment. This also means that when 
playing back a tape striped with timecode, the 
playback deck should be resolved to the same 
synchronization rate as the record deck was re-
solved to at the time of the striping. When you 
stripe timecode using an audio transport, it 
should be “free-running” and unresolved, but 
should be resolved with a house sync-referenced 
synchronizer during playback.

Know the True Frame Rate on 
Your Media
If you get your media from a production com-
pany instead of recording them yourself, be ab-
solutely sure that they indicate the SMPTE 
frame rate used on the tape correctly. Several 
timecode formats use the same frame count 
(such as 23.976 fps and 24 fps) yet they run at 
slightly different frame rates per second.

A Synchronization peripheral (and some third-
party products) can be used to help determine 
frame rate.

29.97 fps Non-Drop Rate Not 
Recognized
29.97 fps Non-Drop is a slightly slower version 
of 30 fps Non-Drop timecode. When 29.97 fps 
Non-Drop is used with color video, each video 
frame matches up with each SMPTE frame with-
out having to use a drop-frame coding. This 
makes any frame number mathematics much 
simpler, since no frame numbers are dropped.

Some hardware and software devices do not rec-
ognize 29.97 Non-Drop as a separate frame rate. 
For example, any standard SMPTE-to MTC-con-
verter does not explicitly recognize it. You must 
set the convertor to expect 30 fps Non-Drop in-
stead. In fact, many devices that read SMPTE 
work acceptably by reading 29.97 Non-Drop if 
they are set to expect 30 fps Non-Drop.

Any SMPTE reader that uses the timecode num-
bers to make real-time calculations (as 
Pro Tools does when it tries to trigger and syn-
chronize to SMPTE) also needs to know that the 
frame format is 29.97 and not 30 fps. Since 
Pro Tools allows this choice of frame rate this 
does not really pose a problem. The problem ex-
ists because many users cannot readily distin-
guish 29.97 from 30 fps.

Even though NTSC tapes only use 29.97, some 
production companies will distribute video 
work prints striped with 29.97 fps but mark 
them as “30 fps NTSC,” by which they actually 
mean 29.97 fps Non-Drop.

By the time you get the tape, you may have no 
idea what’s actually on it. Feeding 29.97 Non-
Drop to Pro Tools when it is set for 30 fps Non-
Drop will result in timing errors of about 1.8 
frames per minute, causing audio playback to 
trigger out of sync.

Use a Consistent Clock Source
When possible, media files should be played 
back using the same sync reference signal they 
were recorded with. This assures the closest 
match between record and playback sample 
rates. 
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Speed Correction for Film, NTSC Video, and PAL Video
Pro Tools Reference Guide
Frame rates, telecine transfers, and relative playback speeds

faster

slower

25 fps 

24 fps 

23.976 fps

30 fps

29.97 fps

same program speed,
 less frames per second more frames per second

same program speed, 

 x104.1667% up      x96.0% down

x100.1% up
(0.1% pull up) (0.1% pull down)

x99.9% down

Telecine

Telecine

(0.1% pull down)
x99.9% downx100.1% up

(0.1% pull up)

(4% pull up) (4% pull down)



Sample Rate Conversion Using Source Sample Rates a
t Pull Up and Pull Down Setting
From: To: Pull: Source Sample Rate

NTSC 
Video

PAL +0.1% then 
+4.1667%

45983 50050 91967 100100 n/a n/a

Film PAL +4.1667% 45938 50000 91875 100000 n/a n/a

NTSC 
Video

Film +0.1% 44144 48048 88288 96096 176576 192192

Film NTSC 
Video

–0.1% 44056 47952 88112 95904 176224 191808

PAL Film –4.0% 42336 46080 84672 92160 n/a n/a

PAL NTSC 
Video

–4.0% then 
0.1%

42294 46034 84587 92068 n/a n/a

NTSC Video = 23.976/29.97 fps
Film = 24/30 fps
PAL = 25 fps

Destination Sample Rate

44100 48000 88200 96000 176400 192000
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Sample Rate Conversion Using Destination Sample Rate
Pro Tools Reference Guide
s at Pull Up and Pull Down Setting
NTSC Video = 23.976/29.97 fps
Film = 24/30 fps
PAL = 25 fps

Source Sample Rate

44100 48000 88200 96000 176400 192000

From: To: Pull: Destination Sample Rate

NTSC 
Video

PAL +0.1% then 
+4.1667%

42294 46034 84587 92068 n/a n/a

Film PAL +4.1667% 42336 46080 84672 92160 n/a n/a

NTSC 
Video

Film +0.1% 44056 47952 88112 95904 176224 191808

Film NTSC 
Video

–0.1% 44144 48048 88288 96096 176576 192192

PAL Film –4.0% 45938 50000 91875 100000 n/a n/a

PAL NTSC 
Video

–4.0% then 
0.1%

45983 50050 91967 100100 n/a n/a



Chapter 51: Working with Video in Pro Tools
This topic covers video features in Pro Tools. 
Differences between support for QuickTime, 
Windows Media, and Avid video are noted 
throughout.

The Avid Video Peripherals Guide provides in-
structions for using an Avid Mojo SDI video pe-
ripheral with Pro Tools systems.

Introduction to Pro Tools and 
Video
Pro Tools lets you do the following with video:

• Create video tracks and import QuickTime 
and Windows Media video to the Timeline 
using menu commands or drag and drop

• Lock video tracks

• Extract audio from QuickTime or Windows 
Media video

• Scrub audio in tandem with video

• View video in the Video window or output it 
through a FireWire peripheral to an exter-
nal monitor

• Bounce the video track to QuickTime or 
Windows Media video
Pro Tools HD, Pro Tools with Complete Produc-
tion Toolkit 2, and Pro Tools with an Avid video 
peripheral let you do the following with video:

• Import multiple video files into the Time-
line

• Select from multiple video playlists on each 
video track

• Mix multiple codecs in video tracks

• Organize, group, and edit video clips in the 
Timeline much like audio clips

• Organize, group, and edit video clips with 
audio clips

• Manage video clips

• Undo multiple video operations

• Create multiple video tracks with Quick-
Time, Windows Media, and Avid video in 
the Timeline

An Avid video peripheral is required to 
work with Avid video.
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QuickTime Movies Support in 
Pro Tools
Pro Tools supports the import, playback, and 
editing of QuickTime movies. 

QuickTime Required
Quicktime must be installed if you plan to in-
clude movie files, or import MP3 or MP4 (AAC) 
files in your Pro Tools sessions. QuickTime for 
Windows is available as a free download from 
the Apple website (www.apple.com).

QuickTime Movie Playback 
Performance Options

High Quality QuickTime Image

When the High Quality QuickTime Image (DV25 

Only) option is enabled in the Operation Prefer-
ences page, Pro Tools decompresses both fields 
of each interlaced frame of QuickTime video. 
When viewing a QuickTime movie in the 
Pro Tools Video window, select this option to 
display the movie at the highest possible resolu-
tion. For interlaced video that was transcoded 
from a progressive source, enabling option pro-
vides a crisper image in the Pro Tools Video 
window. For true interlaced video, enabling this 
option provides a smoother and clearer image 
when viewing the video on a client monitor.

Deselecting this option can help improve perfor-
mance if your system experiences problems 
playing back a session with QuickTime video 
(such as comb-like interlacing artifacts or flick-
ering video when monitoring using an Avid 
Mojo SDI).

For information on which version of Quick-
Time is compatible with your version of 
Pro Tools, visit www.avid.com.
Pro Tools Reference Guide
Supported QuickTime Movies
When working with someone who is preparing 
QuickTime movies for use with Pro Tools, en-
sure that you communicate the following:

Consolidated and Referenced Media QuickTime 
DV movies can be either complete (consoli-
dated) Quicktime files (where media is copied 
into a Quicktime file) or Quicktime reference 
files (where just a small composition is in the 
Quicktime file which references the original DV 
files). 

Codec Requirements When exporting from 
Avid, always use the Apple DV codec. Do not en-
able “Use Avid Codec” in the export dialog. If an 
Avid-codec DV movie is imported into 
Pro Tools, you cannot play it unless you have in-
stalled an Avid video peripheral. 

DV Stream Movies  Pro Tools does not support 
audio from a DV Stream file. DV Stream files 
contain the entire data stream that has been 
transferred or recorded over the FireWire cable 
from a camera. In this type of file, the audio and 
video data are stored in an interleaved fashion, 
as opposed to a QuickTime file where audio and 
video are stored separately. 

Limitations for Applying Pull-
Ups to QuickTime Movies in 
Sessions Containing Avid Video
Applying a pull-up to QuickTime movies is dis-
allowed if you also have Avid video in that ses-
sion. You can only use video pull-up for sessions 
that do not contain Avid video.

See also “Exporting QuickTime DV from 
Avid” on page 1190. 



Windows Media Video (VC-1 
AP Codec) Support in 
Pro Tools
(Windows Only)

Pro Tools supports the import and playback of 
Windows Media video files created using the 
VC-1 Advanced Profile codec. See your Win-
dows documentation for detailed information 
about Windows Media video.

Windows Media Video File 
Caveats
The following limitations apply to Windows Me-
dia video in Pro Tools.

• Pro Tools cannot open Windows Media video 
files that require Windows Media File Digital 
Rights Management (DRM) passwords to 
view.

• High-resolution Windows Media video files 
play back accurately at normal speed on the 
Windows desktop or an external monitor with 
a qualified DirectShow output device. How-
ever, due to processing requirements for VC-1 
decompression, Avid cannot guarantee accu-
rate playback of video frames when perform-
ing other transport commands (such as 
scrubbing, looping, and off-speed play).

• Pro Tools does not support Windows Media 
playback via Avid video peripherals.

Though not prohibited, editing Windows 
Media video or adding multiple clips to the 
Timeline can lead to irregular video output 
performance.
Before Starting Your Project
Before you start any project that requires work-
ing with video, consider the following:

Frame Rate Before receiving video, find out the 
frame rate. Use this frame rate when setting the 
frame rate of your Pro Tools sessions and when 
capturing video.

Creator Application and Codec Before receiving 
video as media files, find out the application and 
codec used to create those files. Then confirm 
that you can play those files in Pro Tools. It is al-
ways a good idea to get a sample file in advance.

QuickTime Movie Timecode Burn-in Before re-
ceiving QuickTime movies, request the time-
code display to be “burned in” (superimposed) if 
possible. This ensures that Pro Tools places the 
file at the correct timecode location in the Time-
line.

Sufficient Space on Video Drives Ensure suffi-
cient space is available on separate dedicated 
video-only drives. Video files take up signifi-
cantly more space and bandwidth than audio, 
and must be kept on separate drives from audio 
files to prevent performance problems.

Separate Video-Only and Audio-Only Drives For 
best results, always use separate video-only and 
audio-only drives. For complete information on 
hard drive requirements, visit www.avid.com.
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Video Tracks
Video tracks let you add or import video to the 
Timeline, as follows:

• Pro Tools lets you add or import one video 
track per session, with a limit of one video 
playlist and one QuickTime or Windows Media 
video file on that track.

• Pro Tools HD, Pro Tools with Complete Pro-
duction Toolkit 2, and Pro Tools with an Avid 
video peripheral let you add multiple video 
tracks to the Timeline, with multiple video 
playlists and multiple video files per track.

• Pro Tools with an Avid video peripheral lets 
you mix QuickTime and Avid video tracks in 
the Timeline (but not on the same video 
track). 

To create a video track in Pro Tools, do one of the 
following:

 Use File > Import to import a video file. 

 Drag a video file to the Timeline. 

 Use File > Import > Session Data to import a 
session containing a video track.

For more information, see “Importing Video 
into Pro Tools” on page 1177.

An Avid video peripheral is required to 
import, play back, and edit Avid video.
Pro Tools Reference Guide
To create a new video track with Pro Tools HD, 
Pro Tools with Complete Production Toolkit, or 
Pro Tools with an Avid video peripheral:

1  Choose Track > New.

2  In the New Tracks dialog, do the following:

• Select Video Track from the Track Type 
pop-up menu.

– and –

• Enter the number of new video tracks.

3  Click Create.

A new empty video track appears. Video tracks 
may appear slightly different depending on your 
system configuration or the type of video added 
to a video track.

Multiple Video Tracks in the 
Timeline
(Pro Tools HD, Pro Tools with Complete 
Production Toolkit, and Pro Tools with an Avid 
Video Peripheral Only)

You can add multiple video tracks to the Time-
line, but only one video track can be played back 
at a time. This track is known as the main video 
track.

Empty video track



Multiple Video Track Playlists
(Pro Tools HD, Pro Tools with Complete 
Production Toolkit, and Pro Tools with an Avid 
Video Peripheral Only)

Playlists provide an easy way of changing back 
and forth between alternate versions of a video 
track.

You can perform all of the same operations with 
video playlists as you can with audio playlists, 
including:

• Duplicating a playlist

• Creating a playlist

• Assigning a playlist to another video track

• Renaming a playlist

• Deleting a playlist

Multiple Codecs on an Individual 
Video Track
(Pro Tools HD, Pro Tools with Complete 
Production Toolkit, and Pro Tools with an Avid 
Video Peripheral Only)

A single video track can contain video clips 
compressed with different video codecs of the 
same type of video. For example, you can add 
QuickTime files that were compressed using 
multiple codecs to the same video track.

However, once the first video file has been 
added to a session, all additional video files 
added to the Timeline must have the same video 
frame rate as the first video file. 

For more information, see Chapter 30, 
“Playlists.”
Main Video Track
The main video track is the video track that is 
currently online, and will be played back with 
any audio in the session. 

When the main video track is offline, you can 
play back the audio in your session without 
playing back the video. When the video is of-
fline, the Video Online button changes to gray 
so you can tell at a glance whether your video is 
offline or simply playing black fill.

If no video track is currently online, the main 
video track is the video track that was last on-
line.

To select the main video track:

 Click the Video Online button of any track that 
is offline (gray) to put it online (blue), making 
that track the main video track. 

Video Online button (offline and online, respectively)
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Video Track Controls and 
Indicators

Video Track View
The video track can be viewed in Frames View or 
in Blocks View, both of which display all video 
clip boundaries and metadata. Video frame im-
ages are displayed only in Frames View.

To set the view for the video track:

 On the video track, select Frames or Blocks 
from the View Options pop-up menu.

Frames View
In Frames View, video data is displayed as pic-
tures in the video track. These pictures are com-
puted based on the video image, and scale ac-
cording to your track zoom and height settings. 
They allow you to easily find a scene or sequence 
in the video track.

Frames do not display properly if you change 
zoom settings during playback. Black frames are 
drawn until playback is stopped. You should 
stop playback before changing zoom settings if 
you want to view frames.

If video pull-up or pull-down is enabled, frames 
do not change position.

When switching from Blocks mode to 
Frames mode during playback, the video 
track will not update to displaying frames 
until playback is stopped.

Video track in Frames View
Pro Tools Reference Guide
Frames View Performance

When using Frames View to view video content 
in the video track, your computer may exhibit 
reduced or sluggish performance. If this hap-
pens on your computer, hide the video track or 
switch to Blocks View.

Blocks View
In Blocks View, video frames are replaced by 
colored blocks. 

Video Track Type Icons
A video track displays a QuickTime icon, Win-
dows Media icon, or an Avid icon depending on 
the type of video added to it. No icon displays 
when the video track is empty.

Video track in Blocks View

Video tracks displaying QuickTime, Windows Media, 
and Avid icons

Avid 
icon

Quick-
Time icon

Windows Media icon



You can add any supported video to an empty 
video track, in which case the icon will update 
and the video track will play back only that type 
of video.

Differences in Video Tracks with 
Avid Video
When an Avid video peripheral (such as an 
Avid Mojo SDI) is connected to your system and 
powered on, the following conditions apply:

• All video tracks display a Video Output se-
lector, but only tracks containing Avid 
video display a Video Input selector.

• You can add Avid video to an empty video 
track. 

• Only Avid video tracks contain a Record 
Enable button.

See the Avid Video Peripherals Guide for 
detailed information on using the Record 
Enable button and the controls in the I/O 
View.
Video Online Button
The Video Online button lets you select the main 
video track, switch that track online or offline, 
and see at a glance by color whether a video 
track is offline (gray) or online (blue).

To switch a video track online or offline:

 Click the Video Online button of any track that 
is offline (gray) to put it online (blue), making 
that track the main video track. 

 Click the Video Online button of the main 
video track to take it offline, and Pro Tools will 
not output video.

Video Online button (offline (top) and online (bottom)
Chapter 51: Working with Video in Pro Tools 1175



1176
Locking Video Tracks
You can lock one or more video tracks to pre-
vent any video clips on those tracks from being 
edited.

When a video track is locked, Pro Tools restricts 
all editing operations involving the track (ex-
cept for locking and unlocking video clips).

A locked video track displays a small lock to in-
dicate that the video track has been locked and 
cannot be edited. (The lock does not appear if 
the Track Height of the video track is set to 
Mini.)

To lock a video track:

1  Select the video track or tracks you want to 
lock.

2  Do one of the following:

• Start-click (Windows) or Control-click 
(Mac) the name of any selected video track, 
and select Locked.

– or –

• Right-click the name of any selected video 
track, and select Locked.

Locking or unlocking a video track does not al-
ter the lock status of individual clips. If a clip 
was locked before you lock the track, the clip 
will still be locked when you unlock the track. 
However, unlocking a clip in a locked track will 
not allow you to edit that clip. It will behave as if 
the clip were locked until you unlock the track.

You can Edit lock or Time lock individual 
Video clips. For more information about 
locking clips, see “Locking Clips” on 
page 839.
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Video Engine Rate
The video engine rate represents the number of 
video frames output by Pro Tools per second, 
and is determined automatically by the frame 
rate of the first video file added to a session. 
Video files subsequently added to the session 
must have the same video frame rate as the video 
engine rate.

The video frame rate is displayed for each video 
file in the DigiBase browsers, and the current 
video engine rate is displayed in the I/O View of 
the main video track.

The video engine rate is independent of the ses-
sion's timecode rate, which determines the 
number of frames displayed per second in grids, 
rulers, and counters. You can set the session 
timecode rate manually with the Timecode Rate 
pop-up menu in the Session Setup window. In 
order for the grids and rulers to align with the 
actual frames of the video files in the Timeline, 
the session's Timecode Rate setting should be 
set to match the video engine rate.

See “Video Engine Rate Indicator” on 
page 1177 for information on the Video 
Engine Rate indicator in the I/O View.



Video Engine Rate Indicator
The Video Engine Rate indicator displays only 
in the main video track (whether it is online or 
offline) and shows the video engine rate, which 
is the number of video frames per second output 
by Pro Tools. 

The Video Engine Rate indicator is normally 
black, but turns red if one of the following con-
ditions are present:

• The video engine rate does not match the 
session’s current Timecode Rate setting.

– or –

• A pull-up has been applied to the video, 
causing the video engine rate to differ from 
the session Timecode Rate.

Video Frame Rate

The Timecode Rate is set in the Session 
Setup window. For more information, see 
“Session Setup Window” on page 1141.

See “Pull Up and Pull Down” on page 1150 
for detailed information on using video 
pull up and pull down.
Importing Video into 
Pro Tools
Pro Tools provides the following methods of im-
porting video files into the Timeline, Clip List, 
and new or existing video tracks:

• Using the Import Video command (File > 

Import > Video)

• Dragging from the Clip List to the Timeline 
(Pro Tools HD, Pro Tools with Complete 
Production Toolkit, or Pro Tools with an 
Avid video peripheral only)

• Dragging from a DigiBase browser or from 
Windows Explorer or Mac Finder

• Using the Import Session Data command 
(File > Import > Session Data)—this lets you 
import video from another Pro Tools ses-
sion, or from and AAF or OMF file, but not 
individual video files

The video frame rate of the first video file 
added to a session determines the session’s 
video engine rate. Video files subsequently 
added to the session must have the same 
video frame rate as the video engine rate.

In general, audio and video media should be 
stored on separate dedicated drives. When 
importing audio and video at the same time 
by linking to media, however, Pro Tools 
may copy both to the same drive. To avoid 
performance problems, move the video to a 
video playback drive before importing the 
audio and video into your session. 

When you import MPEG-2 video into 
Pro Tools, only the video portion of the file 
is imported and the resulting video clips 
cannot be edited.
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Importing Video into Pro Tools 
Using the Import Video 
Command
The Import Video menu command lets you 
choose one or more video files to import into 
Pro Tools. 

When you use this method to import video into 
Pro Tools, the Video Import Options dialog ap-
pears. This dialog contains multiple options for 
customizing how files are imported.

To import video into Pro Tools using the Import 
Video command:

1  Do one of the following:

• Choose File > Import > Video.

– or –

• Press Control+Alt+Shift+I (Windows) or 
Command+Option+Shift+I (Mac).

2  In the Select Video File to Import dialog, select 
one or more video files.

3  Click Open.

4  Configure the Video Import Options dialog, 
and click OK to import video into Pro Tools.

In a DigiBase browser, you can designate 
your audio drives to play or record audio 
but only transfer video, or vice versa. You 
may use these settings to ensure that your 
audio and video are on the correct volumes. 
For detailed instructions, see “Audio and 
Video Volume Designators” on page 319.

See “Configuring Video Import Options” on 
page 1179 for detailed instructions.
Pro Tools Reference Guide
Importing Video into Pro Tools 
with Drag and Drop 
You can drag and drop video files from a 
DigiBase browser or from Windows Explorer or 
Mac Finder to the Timeline, a track, a Track List, 
or the Clip List.

When you use this method to import video into 
Pro Tools, the Video Import Options dialog ap-
pears. This dialog contains multiple options for 
customizing how files are imported. 

To import video into Pro Tools using drag and 
drop:

1  Drag and drop one or more video files from a 
DigiBase browser or from Windows Explorer or 
Mac Finder to the Track List, Timeline, or an ex-
isting video track.

2  Configure the Video Import options, and click 
OK to import video into Pro Tools.

Importing Video into Pro Tools 
Using Import Session Data
You can use the Import Session Data command 
to import video from other Pro Tools sessions or 
(with DigiTranslator 2.0) from an AAF or OMF 
sequence. Any video files you import must have 
the same video frame rate as any video file al-
ready present in the session.

See “Configuring Video Import Options” on 
page 1179 for detailed instructions.

For information on importing session data, 
see “Importing Session Data” on page 352.



Dragging Video Files from the 
Clip List to the Timeline
(Pro Tools HD, Pro Tools with Complete 
Production Toolkit, and Pro Tools with an Avid 
Video Peripheral Only)

You can add video files to the Timeline by drag-
ging and dropping directly from the Clip List to 
a video track.

To add video files to a video track by dragging 
them from the Clip List:

1  Select one or more video files in the Clip List.

2  In any Edit mode, drag the selected video files 
to a blank area in the Timeline (to create a new 
video track) or an existing video track (to place 
it within that track).

Configuring Video Import 
Options
The Video Import Options dialog appears when 
you import video into Pro Tools by using the 
Import Video command or dragging video files 
from a DigiBase browser or from Windows Ex-
plorer or Mac Finder.

Video Import Options dialog
Destination Section
The Destination section of the Video Import Op-
tions dialog lets you choose a general destina-
tion for imported video in Pro Tools.

Main Video Track The video file is imported di-
rectly to the track that is currently online 
(known as the main video track) and into the 
Clip List. If no track is currently online, the 
video file will be imported to the last existing 
video track that was online.

New Track Each video file is imported into its 
own individual track and into the Clip List.

Clip List (Pro Tools HD, Pro Tools with Complete 
Production Toolkit, and Pro Tools with an Avid 
Video Peripheral Only) Each video file is im-
ported directly into the Clip List, where it will be 
available to drag and drop into the Timeline.

Location Pop-Up Menu
If you do not select the Clip List as a destination 
in the Destination section, the Location pop-up 
menu lets you choose precisely where in the 
Timeline Pro Tools places imported video.

Session Start Places the video file at the start of 
the session.

Song Start Places the video file at the Song Start 
position.

Selection Places the video file at the edit cursor 
position or within the selection (if one was 
made).

See “Bypassing the Video Import Options 
Dialog” on page 1180 for details on 
bypassing the Video Import Options dialog 
when dragging and dropping video files.
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Spot Displays the Spot dialog, which lets you 
spot video to precise locations based on any of 
the Time Scales.

Original Time Stamp (Avid Video Only) Places 
Avid video in the Timeline at a timecode loca-
tion that corresponds to the timestamps from 
the original source tape. With multiple video 
files, this places all video files in the Timeline at 
their respective original timestamps.

Additional Video Import Options
Gaps Between Clips (Pro Tools HD, Pro Tools 
with Complete Production Toolkit, and Pro Tools 
with an Avid Video Peripheral Only)  When you 
import more than one video file into a track, 
they will be shuffled together by default. This 
option lets you indicate the number of seconds 
by which each video clip will be separated when 
imported into the video track.

Import Audio from File (QuickTime and Windows 
Media Video Only) 

When selected, the audio from the QuickTime or 
Windows Media video file you are importing 
will be extracted and placed into new mono or 
stereo audio tracks in the Timeline. (Mono or 
stereo audio with a sampling rate of 48 kHz or 
lower are supported.) When unselected, only the 
video portion of the video file will be imported 
into Pro Tools.

Remove Existing Video Tracks When selected, 
all existing video tracks will be deleted before 
Pro Tools imports video into the session.

Remove Existing Video Clips When selected, all 
existing video clips will be removed from the 
Timeline and the Clip List before Pro Tools im-
ports video into the session (but left on disk). 
This option is useful if you want to import a 
video file into the session with a video frame 
rate that does not match the current video en-
gine rate. 
Pro Tools Reference Guide
Clear Main Video Track Playlist When selected, 
all existing video clips in the currently-selected 
playlist on the main video track will be removed 
from the track before Pro Tools imports video 
into the session. No other playlists, video tracks, 
or video clips will be affected. (This option is 
only enabled if the main video track is selected 
as the Destination option.)

Bypassing the Video Import 
Options Dialog
You can bypass the Video Import Options dialog 
when dragging video files into Pro Tools. The 
video files are added exactly where you drop 
them in the Timeline following the current 
Pro Tools editing mode.

To bypass the Video Import Options dialog when 
importing video into Pro Tools:

 Alt-drag (Windows) or Option-drag (Mac) one 
or more video files from a DigiBase browser, 
Windows Explorer, or Mac Finder into the Clip 
List or the Timeline.

Extracting Audio from 
QuickTime and Windows 
Media Video
(QuickTime and Windows Media Video Only)

You can extract many audio file formats from 
QuickTime and Windows Media video files 
without importing the video.

See “Video Engine Rate” on page 1176 for 
more information.

Pro Tools cannot extract audio from 
Windows Media video files that require 
Windows Media File Digital Rights 
Management (DRM) passwords.



The audio is converted to the session’s sample 
rate and bit resolution, and a new clip appears in 
the Clip List for each imported file. The clips are 
listed in the Clip List with the clip name, the 
number of the originating track, and the number 
of the clip from the track.

To import audio from a QuickTime or Windows 
Media video file without importing the video, do 
the following:

1  Choose File > Import > Audio.

2  In the Import Audio dialog, navigate to the 
video file from which you want to import audio, 
and select it.

3  Under the Clip section, click the name of the 
audio clip you want to extract from the video 
file, and click Convert Clip or Add Clip.

4  Select other audio files, and click Done to im-
port the audio.

5  In the Audio Import Options dialog, choose 
whether to import the audio into a new track 
(and the Clip List) or the Clip List only. 

Sample Rate Conversion Quality 
If you import QuickTime audio that was not 
originally recorded at the session’s sample rate, 
the sample rate is converted to match the audio 
to your session. Pro Tools allows you to choose 
the quality of the sample rate conversion by 
means of the Conversion Quality setting in the 
Editing Preferences page. 

There are five possible settings, ranging from 
Low (lowest quality) to Tweak Head (highest 
quality). The higher the quality of sample rate 
conversion, the longer it takes to convert the 
bounced file.
To set the sample rate conversion quality:

1  Choose Setup > Preferences and click the 
Processing tab.

2  Click the Conversion Quality pop-up menu and 
select a conversion setting.

Video Clips
You can create video clips that function in much 
the same way as audio clips. 

A video clip is a segment of video data, and can 
be a portion of video or an entire video file. In 
Pro Tools, video clips are created from Quick-
Time, Windows Media, or Avid video files, and 
can be arranged in corresponding video track 
playlists. Video clips can also be grouped, 
looped, and color coded.

When using Pro Tools HD, Pro Tools with Com-
plete Production Toolkit, or Pro Tools with an 
Avid video peripheral, you can add, edit, and 
change viewing options for video clips in the 
same ways as audio clips. All edits to video clips 
are nondestructive. (See “General Video Edit-
ing” on page 1182 for more information.)

Just like audio clips, video clips display in 
Pro Tools in the Clip List or the Timeline.

When using Pro Tools, the following limitations 
apply to video clips:

• You can add only one video clip to a session. It 
can be played back, but cannot be edited and 
will not be listed in the Clip List.

Video clip as displayed in Frames View in the Timeline
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• When you import video or open a session cre-
ated by Pro Tools HD, Pro Tools with Com-
plete Production Toolkit, or Pro Tools with an 
Avid video peripheral, only the main or first 
available video track containing QuickTime 
clips will be imported. You can play back and 
view multiple clips, and tab through clip 
boundaries. However, you cannot edit them. 
(See “Using Pro Tools to Import Video from 
Other Versions of Pro Tools” on page 1195 for 
more information.)

Video Clips in the Clip List
(Pro Tools HD, Pro Tools with Complete 
Production Toolkit, and Pro Tools with an Avid 
Video Peripheral Only)

A video clip displays in the Clip List with a small 
video icon next to its name.

Video clip icon in the Clip List

For information on working with clips in 
the Clip List, see Chapter 15, “The Clip 
List.”
Pro Tools Reference Guide
Showing or Hiding Video Clips in 
the Clip List
The Clip List menu provides commands that let 
you show or hide video clips in the Clip List.

To show or hide video clips in the Clip List:

1  In the Edit window, click the Clip List menu, 
and choose Show.

2  Select the Video option to show or hide video 
clips.

General Video Editing
(Pro Tools HD, Pro Tools with Complete 
Production Toolkit, and Pro Tools with an Avid 
Video Peripheral Only)

Most editing operations that are available for 
audio clips can also be applied to video clips. 
This section describes all available video editing 
operations. Unless noted, the procedure for each 
video editing operation is the same as its audio 
editing counterpart.

Basic Video Editing Features

• Nondestructive editing

• Display of clip names, clip times, and other 
data in playlists

• Multiple video playlists

• Multiple Undo

• Video clips and video clip groups in Clip 
List

• All Edit modes

• All Edit Tools (except for Time Compres-
sion Expansion and Pencil tools)

See the appropriate topic for detailed infor-
mation on performing editing operations.



Playing and Selecting Video Track Material

• Selecting within video frame boundaries (see 
“Selecting within Video Frame Boundaries” on 
page 1184)

• Selecting and editing across multiple tracks 
(see “Selecting and Editing Across Multiple 
Audio and Video Tracks” on page 1184)

• Link or unlink track and Edit selections

• Auto-scroll video tracks

• Loop playback

• Video Universe window (see “Browsing Video 
in the Video Universe Window” on page 1187)

Working with Clips and Selections

• Capture clips

• Separate clips and Separate Grabber Tool

• Clip overlap and underlap

• All trimming commands except for TCE

• Heal separated clips

• Place, align, slide, shuffle, and spot clips

• Nudging (quantized to frame boundaries)

• Shift command (moving track material back or 
forward in time by a specified amount)

• Quantize Clip to Grid (rounds to nearest video 
frame)

• Replace Clip command

• Cut, Copy, Paste, and Clear commands

• Special Cut, Copy, Paste, and Clear commands

• Repeat to fill selection

• Editing across multiple tracks

• Duplicate command

• Repeat command

• Clip groups (see “Video Clip Groups” on 
page 1185)

• Clip looping
Managing Clips

• Insert space (see “Using the Insert Silence 
Command to Insert Space in Video Tracks” on 
page 1184)

• Compact Selected (nothing happens to the 
video, and at least one audio track must be se-
lected)

• All naming and displaying of clip commands

Video Editing Caveats
The following caveats apply to video editing in 
Pro Tools:

• MPEG-2 video in the Timeline cannot be ed-
ited.

• If you create and enable a track group contain-
ing audio and video tracks—and any audio 
track has clip boundaries that do not line up 
with video frame boundaries— you cannot tab 
through those clip boundaries.

General Editing Operations Not 
Applicable to Video Clips
The following editing operations are applicable 
to audio clips, but are not applicable to video 
clips:

• Fades

• Mute/unmute clips

• AudioSuite plug-ins

• Waveform Repair with the Pencil tool

• Strip silence

• Consolidate clips
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Selecting and Editing Across 
Multiple Audio and Video Tracks
You can create a selection across multiple audio 
and video tracks, and cut, copy, or paste audio 
and video simultaneously.

Audio and video that is selected and cut, copied, 
or pasted follow the current Edit mode.

Selecting and editing across multiple tracks (Slip 
mode shown)
Pro Tools Reference Guide
Selecting within Video Frame 
Boundaries
Pro Tools does not let you select, play back, or 
edit a partial video frame. The following rules 
apply when selecting or editing video:

• When you make a selection in a video track, 
the selection boundaries follow the current 
Grid setting but round to the nearest video 
frame boundary, as follows:

• If the selection includes more than half of a 
video frame, the full video frame is in-
cluded within the selection.

• If the selection includes less than half of a 
video frame, that video frame is not in-
cluded in a video selection.

• When you paste a selection containing video 
to a video track, the insertion point automati-
cally aligns with the closest video frame 
boundary.

Using the Insert Silence 
Command to Insert Space in 
Video Tracks
The Insert Silence command lets you make a se-
lection on a track (or tracks) and insert precisely 
that amount of space. You can also select across 
video and audio tracks, and use the Insert Si-
lence command to insert audio silence and space 
simultaneously.

In Shuffle mode, all video data on the track is 
shuffled later in the track by an amount equal to 
the selection. In Slip, Grid, or Spot mode, the In-

sert Silence command works just like the Edit > 

Clear command.

When you paste audio and video simultane-
ously, this video frame re-alignment may 
result in the audio not being positioned 
exactly where you placed it. A warning 
dialog displays when this occurs.



To insert space into a video track:

1  Make a selection in a track or tracks. The 
length of the selection determines the duration 
of the space inserted.

2  Choose Edit > Insert Silence.

Renaming Video Disk Files
When renaming audio clips in either the Time-
line or the Clip List, you have the option of also 
renaming the audio files on disk. However, this 
does not apply to video files on disk.

To rename video files on disk, you must rename 
them in a DigiBase browser or in Windows Ex-
plorer or Mac Finder.

Video Clip Groups
(Pro Tools HD, Pro Tools with Complete 
Production Toolkit, and Pro Tools with an Avid 
Video Peripheral Only)

You can include video clips within clip groups 
for the following operations:

• Creating clip groups

• Creating multitrack clip groups (including 
audio tracks)

• Editing clip groups

• Creating fades and crossfades for audio 
files in clip groups

• Importing and exporting clip group files

Changes made in the operating system will 
not automatically update the information 
displayed in the DigiBase browser.

See “Clip Groups” on page 851 for 
detailed information on working with 
clip groups.
Using the Video Window
Pro Tools provides a Video window that lets you 
view, display, or scrub video.

To display the Video window, do one of the 
following:

 Select Window > Video.

– or –

 Press Control+9 (Windows) or Command+9 
(Mac).

Changing Video Window Options
The Video window pop-up menu lets you do the 
following:

• Toggle online status of the main video track.

• Toggle output of QuickTime video between the 
Video window and an external monitor using 
the FireWire port (without an Avid Video pe-
ripheral this is supported with Mac only) or 
PCIe (with a qualified video card).

• Resize the Video window.

Avid video displays in the Video window 
only when scrubbed or shuttled.

Video window
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To toggle the online status of the main video track:

 Right-click (Windows or Mac) or Control-
click (Mac) the Video window, and select Online.

To toggle output of QuickTime video between the 
Video window and FireWire, do one of the 
following (Mac only):

 Select (or deselect) Options > Video Out 

FireWire.

– or –

 Right-click, or Control-click, the Video win-
dow, and select (or deselect) Video Out FireWire.

To toggle output of QuickTime video between the 
Video window and PCIe, do one of the following 
(Mac only):

 Select (or deselect) Options > Video Out PCIe.

– or –

 Right-click, or Control-click, the Video win-
dow, and select (or deselect) Video Out PCIe

Video window (with pop-up menu shown)

For information on playing video through 
FireWire, see “Playing QuickTime DV Video 
to an External Monitor Over FireWire” on 
page 1190.

For information on playing video through 
PCIe, see “Playing Video to an External 
Monitor Using a Video Card” on page 1191.
Pro Tools Reference Guide
Resizing the Video Window
You can resize the Video window by dragging or 
using the Video window pop-up menu.

To resize the Video window by dragging:

 Place the cursor at the bottom left or bottom 
right of the Video window, and drag the window 
to the size you want.

To resize the Video window by using the Video 
window pop-up menu:

 Right-click (Windows or Mac) or Control-
click (Mac) the Video window, and choose from 
the following resize options:

• Half Size

• Actual Size

• Double Size

• Fit Screen

Scrubbing the Video Track
Due to the latency introduced by all FireWire-
based video peripherals, the video on an exter-
nal monitor will not be in sync with the Scrub-
ber tool. To scrub video without latency, you can 
scrub in the Video window.

If you scrub directly on the video track, only the 
video will scrub (no audio will play). If you 
scrub on an audio track, audio and video will 
scrub simultaneously.

To scrub a video track:

1  Ensure that scrubbing in the Video window is 
enabled by selecting Options > Scrub in Video 

Window.

2  Select the Scrubber tool.

3  Click in the video track and drag the Scrubber.

To scrub with finer precision, press the 
Command key while scrubbing.



Shuttling the Video Track
Shuttle Lock mode lets you use the numeric key-
pad to shuttle a video track and one or two audio 
tracks forward or backwards at specific speeds. 
Numbers 0 through 9 provide progressively 
faster speeds, as follows:

• To stop shuttling, press 0.

• To increase the speed progressively towards 
normal speed, press numbers 1 through 4.

• To shuttle at normal speed, press 5.

• To increase the speed progressively faster than 
normal speed, press numbers 6 through 9.

Only the main video track is shuttled. When 
multiple audio tracks are selected, only the first 
two tracks are shuttled.

To play the video track with the shuttle lock: 

1  With Pro Tools HD, make sure the Operation 
preference for Numeric Keypad mode is not set 
to Shuttle (see “Operation Preferences” on 
page 124).

2  Make sure the Video Online button in the 
video track you want to scrub is set to an online 
(blue) status.

3  With the Selector tool, click in the audio track 
where you want playback to begin. To shuttle on 
two tracks, Shift-click in a second audio track. 

4  Press the Start key (Windows) or Control 
(Mac) and a number on the numeric keypad: 0–9 
(9 is fastest, 5 is normal speed, and 0 stops shut-
tling). 

Once Shuttle Lock mode is initiated, Fast For-
ward and Rewind become highlighted in the 
Transport window. 

5  Press additional keys to change the playback 
speed, or press Plus (+) or Minus (–) to switch 
the playback direction (plus for forward, minus 
for backward). 
6  To stop playback, press Start+0 (Windows) or 
Control+0 (Mac). 

To exit Shuttle Lock mode, do one of the following: 

 Click Stop in the Transport. 

– or –

 Press the Spacebar. 

Browsing Video in the Video 
Universe Window
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

The Video Universe window lets you view, navi-
gate, zoom, and select video clips on the main 
video track.

The Video Universe window displays the center 
video frame of each video clip in the main video 
track. Video frames are ordered sequentially ac-
cording to their order in the Timeline, and the 
colored strip under each frame represents the 
color coding for that clip.

To display the Video Universe window:

1  Make sure the Video Online button in the main 
video track is set to online status (blue).

2  Choose Window > Video Universe.

Video Universe with video frames representing video 
clips on the main video track
Chapter 51: Working with Video in Pro Tools 1187



1188
Increasing or Decreasing the 
Size of Video Frames

To increase or decrease the size of video frames in 
the Video Universe window:

 Right-click (Windows or Mac) or Control-
click (Mac) anywhere in the Universe, and select 
Increase or Decrease.

Selecting Zoom Resolutions in 
the Video Universe 
When you move the cursor over the top half of a 
video frame in the Video Universe, it displays 
and behaves as a zoom tool. This tool lets you 
zoom in on one or more video clips to fill the en-
tire Edit window display.

Video frame with zoom tool
Pro Tools Reference Guide
To use the Video Universe window to zoom video 
clips in the Edit window:

1  Move the cursor over the top half of any video 
frame until it becomes a zoom tool.

2  Do one of the following:

• To move the beginning of a video clip to the 
far left of the Timeline while maintaining 
the current zoom resolution in the Edit 
window, click the video frame representing 
the clip once.

• To zoom in on a video clip so that it fills the 
entire Edit window, double-click the video 
frame representing the clip.

• To zoom a range of selected clips so that 
they fill the Edit window, drag on the video 
frames that represent the clips.

Selecting Ranges in the Video 
Universe 
When you move the cursor over the bottom half 
of a video frame in the Video Universe, it dis-
plays and behaves as a selector tool. This tool 
lets you select ranges within one or more video 
clips in the Edit window.

Video frame with selector tool



To use the Video Universe window to select ranges 
in video clips in the Edit window:

1  Move the cursor over the bottom half of any 
video frame until it becomes a selector tool.

2  Do one of the following:

• To place the cursor at the beginning of a 
video clip, click the video frame represent-
ing the video clip.

• To select an entire video clip from start to 
end, double-click the video frame repre-
senting that clip.

• To select one or more entire clips from start 
to end, drag the video frames representing 
the video clips.

Selecting Zoom Resolutions and 
Ranges Simultaneously in the 
Video Universe 
When you move the cursor over a video frame in 
the Video Universe while pressing Alt (Win-
dows) or Option (Mac), the cursor appears as a 
selector tool. This tool lets you zoom and select 
ranges simultaneously.

To use the Video Universe window to select and 
zoom simultaneously in the Edit window:

1  Move the cursor over any area of any video 
frame in the Video Universe window until it be-
comes a selector or zoom tool.

2  To select a range of video clips while simulta-
neously zooming to fill the Edit window, Alt-
drag (Windows) or Option-drag (Mac) multiple 
video frames.

If the Edit window does not display the se-
lected video clips, it will automatically 
scroll to show the beginning of the selection.
Playback of High-Definition 
QuickTime and Windows 
Media Video
Pro Tools lets you import and play back High-
Definition QuickTime and Windows Media 
video files.

Setting Session Timecode Rate 
for HD QuickTime and HD 
Windows Media Video Import
When playing back QuickTime and Windows 
Media video with frame rates higher than 30 fps, 
Pro Tools syncs properly only if the Timecode 
Rate in the Session Setup window is set to half of 
the video frame rate of the video files.

For example, to properly play back QuickTime 
or Windows Media HD video at 59.94 fps, 
change the session’s Timecode Rate to 29.97 
frames per second.

To set the session’s Timecode Rate:

1  Choose Setup > Session.

2  In the Session Setup window, select the appro-
priate timecode rate in the Timecode Rate pop-
up menu.

When playing HD video through an Avid 
video peripheral (QuickTime only) or other 
device locked to a standard-definition video 
reference (such as a black burst generator), 
the display updates at the frame rate of the 
video reference.

Press Control+2 (Windows) or 
Command+2 (Mac) to open the Session 
Setup window.
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Playing QuickTime DV Video 
to an External Monitor Over 
FireWire
When using a DV decoder, you can output 
QuickTime DV25 video (including QuickTime 
movies exported as QuickTime DV from Avid) 
through your computer’s FireWire port.

For the latest compatibility information on 
Firewire transcoders, visit www.avid.com. 

Performance may vary, depending on the specif-
ics of your system and projects. 

Playing QuickTime DV Video 
Through the FireWire Port
(Mac Only)

To Play QuickTime DV video through the FireWire 
Port: 

1  Import a QuickTime video file into a Pro Tools 
session. (See “Importing Video into Pro Tools” 
on page 1177 for detailed information.)

2  Choose Options > Video Out Firewire. 

When this option is enabled, Pro Tools will play 
the video (NTSC or PAL) out the FireWire port 
to an external DV decoder. 

If the Video window is open while video plays 
out the FireWire port, it displays text indicating 
that video is playing out the FireWire port.

When using an Avid video peripheral (such 
as an Avid Mojo SDI), you can output 
QuickTime video formats to an external dis-
play using the FireWire port on Windows 
and Mac. See the Avid Video Peripherals 
Guide for more information.
Pro Tools Reference Guide
Exporting QuickTime DV from 
Avid
The following instructions describe export set-
tings for Media Composer, Media Station|PT, or 
Avid Xpress Pro. These settings are required to 
create QuickTime DV movies that can be played 
back in Pro Tools through the Firewire port. 

To export a QuickTime DV reference movie for 
Pro Tools Firewire playback, set the following: 

1  Enable the following export options:

• Flatten video tracks

• Fill in spaces with black

• Render all video effects

• Use Apple DV Codec

• Enable the Apple DV codec

2  Make sure the Use Avid Codec option is not en-
abled.

Tips for Optimizing Video 
Playback
When using Pro Tools to play video files, the 
quality of the playback is dependent on the fol-
lowing:

• Speed of your computer and hard drive

• Size (in pixels) of the video file

• Quality of the video hardware used to capture 
and play back the digitized video

• Codec and level of compression used

These export settings can be saved in 
Avid Xpress Pro as a default, simplifying fu-
ture media exchange. See your Avid XPress 
documentation for more information on ex-
port settings and defaults.



For more consistently smooth video playback, 
here are some suggestions:

• Use an Avid video peripheral.

• Use the fastest computer possible.

• Set Scrolling option to None (Options > Scroll-

ing > None).

• Recompress the video at a reduced pixel di-
mension, for example 320 x 240 pixels to 
640 x 480 pixels.

• Use a video clip with less compression (heavily 
compressed files require more processor 
speed to decompress for display).

• Hide the video track when not needed (or 
change from Frames to Blocks view). 

• Ensure that any unnecessary software is not 
running.

• Resize the Video window to a small desktop 
size, for example by using half size instead of 
whole or full screen.

Compensating for Video 
Monitoring Delays 
You can compensate for delays in the video out-
put that may be introduced by external decoders 
and certain types of displays (such as projectors 
or plasma screens).

To compensate for delays caused by video 
monitoring devices:

1  Choose Setup > Video Sync Offset.

2  In the Set Video Sync Offset dialog, enter a 
value in the QuickTime Video Offset field or 
Windows Media Video Offset field that is appro-
priate to compensate for the delay caused by 
your video monitor chain. 
The amount of delay introduced varies based on 
your system and the type of video peripheral you 
are using. When using an Avid peripheral with 
QuickTime, 18 quarter-frames is a good starting 
point, but you will need to verify the precise set-
ting for your system. (Third-party devices are 
available to help you measure this delay.

Once this value is set, it should not need to be 
updated unless you change components in your 
video monitoring chain (such as projectors or 
plasma screens).

Playing Video to an External 
Monitor Using a Video Card

QuickTime HD or SD Output 
Pro Tools lets you output QuickTime HD or SD 
video to an external HD-SDI, HDMI, NTSC, or 
PAL monitor.

Pro Tools offers professional quality support of 
most SD and HD Quicktime video formats, in-
cluding 720p, 1080p, and 1080i at all standard 
frame rates.

Video Sync Offset dialog

For a list of devices explicitly tested for 
QuickTime HD or SD output from Pro Tools, 
visit www.avid.com.
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Playing QuickTime HD or SD 
Video Through PCIe
(Mac Only)

With a qualified PCIe video card, Pro Tools can 
play and display QuickTime SD or QuickTime-
based HD video files with frame edge-locked HD 
image output to a variety of professional HD 
monitors.

To Play QuickTime video through PCIe: 

1  Import a QuickTime-based video file into a 
Pro Tools session. (See “Importing Video into 
Pro Tools” on page 1177 for detailed informa-
tion.)

2  Select Options > Video Out PCIe. 

When this option is enabled, Pro Tools will play 
the video out the PCIe video card to the con-
nected HD monitor. 

If the Video window is open while video plays 
out the PCIe video card, it displays text indicat-
ing that video is playing out PCIe.

To toggle output of QuickTime video between the 
Video window and PCIe, do one of the following:

 Select (or deselect) Options > Video Out PCIe.

– or –

 Right-click, or Control-click, the Video win-
dow, and select (or deselect) Video Out PCIe.

Though no PCI video cards have been 
qualified for use with Pro Tools, some may 
work. Visit www.avid.com for more infor-
mation.
Pro Tools Reference Guide
Video Reference

Video output can be locked to external video ref-
erence, including Black Burst and Tri-Level 
Sync.

Supported QuickTime codecs

Most common QuickTime codecs are supported, 
including HD codecs such as h.264, DVCPro 100 
HDV, and DV25.

Supported Video Formats

Pro Tools HD should be locked to a suitable 
clock reference, such as a Synchronization 
peripheral. If no external audio clock is 
referenced, audio will not be frame-edge 
aligned and may drift. 

Supported Video Formats using a PCIe video card

Video 
Format

Video 
Reference 
Rate

PT 
Frame 
Rate

Video 
Output 
Format*

23.976p 
NTSC

NTSC 23.976 NTSC

720p/ 
23.976

720p/ 
59.94 or 
NTSC

23.976 720p/
59.94

1080p/ 
23.976

1080psf/23
.98

23.976 1080psf/
23.98

24p NTSC NTSC 24 NTSC

24p PAL PAL 24 PAL

1080p/ 24 1080psf/
24

24 1080psf/
24

25p PAL PAL 25 PAL

25i PAL PAL 25 PAL

1080p/ 25 1080i/50 or 
PAL

25 1080i/50

30i NTSC NTSC 29.97 NTSC



* The video output format may be displayed on the 
external monitor.

Windows Media (VC-1 AP) 
Output 
(Windows Only)

Pro Tools lets you output Windows Media (VC-1 
AP) video to NTSC or PAL monitors via any de-
vice that is compatible with standard Direct-
Show output. 

720p/ 
29.97 
HDV

720p/ 
59.94 or 
NTSC

29.97 720p/ 
59.94

720p/50 720p/50 or 
PAL

25 720p/50

1080i/50 1080i/50 or 
PAL

25 1080i/50

720p/ 
59.94

720p/ 
59.94 or 
NTSC

29.97 720p/ 
59.94

1080i/ 
59.94

1080i/ 
59.94 or 
NTSC

29.97 1080i/ 
59.94

For a list of devices explicitly tested for 
Windows Media (VC-1 AP) output from 
Pro Tools, visit www.avid.com.

Supported Video Formats using a PCIe video card

Video 
Format

Video 
Reference 
Rate

PT 
Frame 
Rate

Video 
Output 
Format*
Bouncing the Video Track to 
a QuickTime Movie
When you have finished your final mix and syn-
chronized your audio events to the movie, you 
can bounce the main video track (QuickTime or 
Avid video) and a mono or stereo mixdown of 
your session to a new QuickTime movie. 

You can choose from a variety of standard 
QuickTime codecs, which are fully compatible 
with other QuickTime applications.

To bounce video and audio in the video track to a 
QuickTime movie:

1  Finalize your mix.

2  Make sure the video track you want to bounce 
is currently the main video track. (The track’s 
Video Online button must be highlighted blue.)

3  Make sure that all of the audio tracks you want 
to include in the bounce are audible (not muted 
or inactive). 

4  Assign the output of each of the tracks you 
want to include in your bounce to the same ste-
reo output or bus path.

Because all formats and codecs have not 
been tested, you should verify the 
QuickTime movie bounced successfully.

Pro Tools cannot bounce audio or video to 
an MPEG-2 video file.
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5  Do one of the following:

• To bounce the entire session, click Return 
to Zero in the Transport window to go to 
the beginning of the session. 

– or –

• To bounce a portion of the session, enable 
Options > Link Timeline and Edit Selection, 
and make a selection in the Edit window or 
the Timeline. 

6  Choose File > Bounce to > QuickTime Movie.

The Bounce dialog appears (if you are bouncing 
QuickTime movies) or the Bounce to QuickTime 
dialog appears (if you are bouncing Avid video 
to QuickTime movies).

7  Select your mix’s output or bus path from the 
Bounce Source selector.

8  If you are bouncing Avid to QuickTime and you 
want to configure QuickTime video settings, 
click Options.

9  Configure other settings as appropriate.

10  Click Bounce.

11  Select a destination for the new QuickTime 
movie, enter a new name, and click Save.

Bouncing video may take quite a bit longer than 
real-time, depending on the format of the source 
video, the format of the bounced video, and pro-
cessing speed.

Pro Tools is qualified to bounce to Quick-
Time DV25. Bouncing to other formats is 
has not been qualified.

See Apple documentation for detailed 
information on configuring QuickTime 
movie settings.
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Bouncing a Video Track with 
Windows Media Video to a 
WIndows Media Movie
You can bounce the main video track and a 
mono or stereo mixdown of your session to a 
new Windows Media movie.

To bounce video and audio in the video track to a 
Windows Media movie:

1  Finalize your mix.

2  Make sure the video track you want to bounce 
is currently the main video track. (The track’s 
Video Online button must be highlighted blue.)

3  Make sure that all of the audio tracks you want 
to include in the bounce are audible (not muted 
or inactive). 

4  Assign the output of each of the tracks you 
want to include in your bounce to the same ste-
reo output or bus path.

5  Do one of the following:

• To bounce the entire session, click Return 
to Zero in the Transport window to go to 
the beginning of the session. 

– or –

• To bounce a portion of the session, enable 
Options > Link Timeline and Edit Selection, 
and make a selection in the Edit window or 
the Timeline. 

QuickTime and Avid video cannot be 
bounced to Windows Media video, and 
vice versa.

Because all formats and codecs have not 
been tested, you should verify the Windows 
Media movie file bounced successfully.



6  Choose File > Bounce to > Windows Media 

Movie. The Bounce dialog appears.

7  Select your mix’s output or bus path from the 
Bounce Source selector.

8  Click Bounce.

9  In the Windows Media dialog, do the follow-
ing:

• In the Profile pop-up menu, select the pro-
file matching the size and data rate of the 
exported video—the larger the resolution, 
the larger the resulting video file.

• To include uncompressed audio in the 
video file that will be exported, select Loss-

less Audio Compression.

10  Select a destination for the new video file, en-
ter a new name, and click Save.

Bouncing video may take quite a bit longer than 
real-time, depending on the format of the source 
video, the format of the bounced video, and pro-
cessing speed.
Using Pro Tools to Import 
Video from Other Versions of 
Pro Tools
When you use Pro Tools to import video or open 
a session created by Pro Tools HD or Pro Tools 
with Complete Production Toolkit, or an Avid 
video peripheral, some components of the ses-
sion may open differently or not open at all, as 
follows:

• Only the main video track is displayed. If no 
video track was selected as the main video 
track when the session was saved, the first 
video track containing QuickTime or Windows 
Media video in that session is displayed.

• Only the playlist that was chosen when the 
session was saved will be displayed.

• All QuickTime or Windows Media video on the 
main video track will be displayed, but the 
video track will be locked and cannot be ed-
ited.

• All additional video tracks, playlists, and 
video clips will not be shown. However, they 
will continue to be saved with the session, and 
will be available if the session is opened on a 
system that supports them.

When using Pro Tools to work with video in 
such a session, you can do the following:

• Use the Tab key to move the Location Cursor 
to video clip boundaries.

• Add and edit audio tracks.

• Bounce the video track to disk as a QuickTime 
or Windows Media video file.

• Export the session, including the full video 
track.

See “Bouncing the Video Track to a Quick-
Time Movie” on page 1193.
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Chapter 52: Working with Field Recorders in 
Pro Tools
Pro Tools HD and Pro Tools with Complete 
Production Toolkit let you import multichannel 
audio files and metadata recorded by field 
recorders. 

Field Recorder and 
Production Workflow 
Terminology
Before working with field recorders in Pro Tools 
HD or Pro Tools with Complete Production 
Toolkit, you may want to review a brief glossary 
of common field recorder and production terms.

Field Recorder Terminology
The following terminology applies to field re-
corders in general:

Metadata

Metadata is used to describe the following:

• Information embedded in a media file. This 
may include scene, take, sample rate, bit 
depth, external clip names, the name of the 
videotape from which the media file was cap-
tured, and even timecode values.

• Information embedded in Pro Tools sessions 
or other sequences, including what files are 
used, where they appear in a timeline, and au-
tomation.
• For AAF or OMF sequences, information 
about automation or clip-based gain.

Digital Field Recorders

A field recorder, also known as a hard disk loca-
tion audio recorder, is a device used by a pro-
duction sound mixer during a film or video 
shoot to make a multichannel recording of mul-
tiple microphone inputs recorded simultane-
ously.

Depending on the capabilities and settings of a 
field recorder, multichannel recordings can in-
clude one or more tracks (up to 32) and are 
saved as monophonic or polyphonic audio files 
on a hard drive, DVD-RAM, or Flash media.

Multichannel recordings made by a field re-
corder should be encoded with start and end 
time stamps representing SMPTE timecode or 
linear timecode (also known as LTC). Most field 
recorders also allow manual entry of additional 
types of metadata, including Channel 
Name/Number, Scene, Take, Circled Take, User 
Bits, and more.

Pro Tools can import monophonic and poly-
phonic files and certain types of metadata en-
tered on field recorders. 
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Production Sound Mix

For each multichannel recording made by a field 
recorder, the production sound mixer may des-
ignate a production sound mix comprising either 
a representative channel or a mixdown of other 
selected channels in the recording.

The production sound mix is intended to func-
tion as a general reference of all audio recorded 
within an individual multichannel recording, 
and is typically used by the Avid® video editor 
when assembling a sequence.

Broadcast WAV Files (BWF)

A WAV file containing a BEXT chunk is known 
as a Broadcast WAV file (or BWF) while still 
maintaining a .WAV file extension. Broadcast 
WAV files can contain both BEXT and iXML 
chunks, or a BEXT chunk by itself.

BEXT and iXML Chunks

BEXT and iXML chunks are sets of metadata 
found within a Broadcast WAV file. 

Caveats

The following caveats apply to handling of im-
ported metadata from field recorders.

• The BEXT specification as described here adds 
some features that conform to standards used 
by Avid video editing applications and 
Pro Tools—specifically, Description meta-
data is interpreted differently.

• When you import multiple files in which the 
same metadata are populated with different 
values, Pro Tools imports the value that is first 
present based on the following order:

• Avid OMF-wrapped media or MXF media

• Any iXML chunk metadata in a BWF

• Any BEXT chunk metadata in a BWF 
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Production Terminology for All 
Production Workflows
The following terminology applies to all produc-
tion workflows:

Timecode

There are four types of timecode, depending on 
your production:

Keycode Each frame of film stock is embedded 
during manufacturing with a unique identifying 
timecode position known as keycode.

SMPTE Timecode Also known as LTC or linear 
timecode. The generating clock of this timecode 
can be based on the time of day or can be set to 
ascend beginning from a certain starting time of 
day.

Minutes:Seconds Timecode based on minutes 
and seconds.

Wild No timecode. Most consumer digital video 
recorders do not have the ability to generate 
timecode.

Production Sound Mixer

The production sound mixer uses a field re-
corder to record multichannel audio during a 
shoot, and later delivers those source files to one 
or more parties:

• Telecine operator (film workflow only)

• Avid video editor

• Pro Tools editor



Production Terminology for Film 
Workflows Only
The following terminology applies only to film 
workflows:

Shootlist

The shootlist is a document in which the camera 
assistant records each scene and take relative to 
its keycode value on the film stock. It is later 
used by the telecine operator to synchronize the 
audio and video together.

Sound Log

The sound log is a document in which the pro-
duction sound mixer records each scene and 
take relative to its beginning timecode position. 

Slate Operator and Clapboard Information

The slate operator holds and labels the slate 
(also known as a clapboard) for each new scene 
and take. At the start of each take, the slate op-
erator claps the slate, which simultaneously cap-
tures the following information:

• The scene, take, and timecode information 
is captured visually on film.

• The sound of the slate clapping is captured 
by the field recorder, which should be using 
the same timecode as displayed on the 
slate.

The telecine operator uses all of the information 
above to synchronize used film stock to the re-
corded audio in order to create the telecine vid-
eotape.
Telecine and Telecine Videotape

The Telecine is a machine used to transfer film 
footage and synchronized audio to videotape 
(referred to as the dailies).

The telecine videotape contains the dailies. The 
SMPTE timecode on the telecine videotape will 
be different from the timecode recorded on loca-
tion.

FLEx File

The FLEx file is a text file generated during a te-
lecine session that relates film keycode, field re-
corder timecode, and telecine videotape time-
code. When the telecine videotape is batch 
digitized in the Avid video editing application, 
the information in the FLEx file is used to assign 
the original (location) timecode to the resulting 
audio and video source files.

Supported Field Recorder 
Audio Files and Metadata
Pro Tools supports the following audio files re-
corded by field recorders:

• OMF-wrapped media

• MXF

• Broadcast WAV (BWF) files with the following 
metadata:

• Both BEXT and iXML chunks

• BEXT metadata but no iXML metadata
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Displaying Field Recorder 
Metadata in Pro Tools
You can enable or disable the display of field re-
corder metadata within clips in the Timeline 
and the Clip List.

To enable or disable the display of field recorder 
metadata in playlists, do the following:

 From View > Clip, select or deselect either of 
the following options:

• Channel Name

• Scene and Take

To show or hide field recorder metadata in the Clip 
List:

1  Click the Clip List pop-up menu, and choose 
Show.

2  From the Show submenu, select or deselect ei-
ther of the following options:

• Channel Name

• Scene and Take

When enabled in the Clip List, Scene and Take 
metadata are added to every clip when available 
in the corresponding audio file.
Pro Tools Reference Guide
DigiBase Support for Field 
Recorder Metadata
DigiBase browsers display the following meta-
data from multichannel recordings made with 
field recorders.

• Duration

• File Comment

• Date Modified

• Date Created

• # Channels

• Format

• Sample Rate

• Bit-Depth

• Original Time Stamp

• User Time Stamp

• Tape

• TC Rate (renamed from FPS)

• Channel Names

• Scene

• Take

• Shoot Date

• Sound Roll

• Sound Roll TC

• Sound Roll TC Rate

• User Bits

• Tape ID

• Project

• Circled

• Clip Name

For more information on using DigiBase, 
see Chapter 16, “DigiBase.”



To show or hide field recorder metadata in 
DigiBase browsers:

 Control-click (Mac) or Start-click (Windows) 
the column header and select or deselect either 
of the following options:

• Channel Name

• Scene and Take

About Tape and Sound Roll 
Metadata
Avid video editing applications and field record-
ers use Tape to represent different kinds of 
metadata: Avid uses Tape to store the telecine 
videotape name, while a BWF file with a BEXT 
chunk or iXML chunk uses Tape to store the 
name of the sound roll.

To avoid this overlap, Pro Tools preserves Tape 
metadata from the Avid video editing applica-
tion and maintains the Sound Roll and Tape 
metadata from BWF audio files in their respec-
tive metadata fields.

About Shoot Date Metadata
Many field recorders do not populate the Shoot 
Date field, relying instead on the file's Creation 
Date to indicate date of production. When 
Pro Tools imports a field recorder file, it checks 
to see if the Shoot Date field is populated. If it is 
empty, Pro Tools copies the Creation Date of the 
original file to the Shoot Date field of the new 
files.
Editing the Channel Name
The Channel Name field in DigiBase displays the 
channel name, followed the by channel number 
in parentheses. When using Pro Tools 8 or 
higher, it is possible to edit the Channel name 
for BWF files. When editing the channel name, 
anything you enter in parentheses will be dis-
carded. However, the channel number will al-
ways be preserved.

Field Recorder Workflows
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Using Pro Tools to work with field recorder files 
from a film, video, or digital shoot involves the 
following steps:

1  Before receiving source files, ensure that 
metadata have been preserved (“Ensuring Meta-
data of Source Files Have Been Preserved” on 
page 1202).

2  Receive source files (“Receiving Source Files” 
on page 1202).

3  Import source files into Pro Tools (“Importing 
Source Files into Pro Tools” on page 1203).

4  Replace edits from the production sound mix 
with audio from different takes of the same 
scene (“Selecting a Matching Field Recorder 
Channel to Replace a Clip” on page 1206).
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Ensuring Metadata of Source 
Files Have Been Preserved
Before you receive source files, it is important to 
ensure that the files have been prepared prop-
erly at each phase of the production process so 
that their original metadata is preserved.

If the original metadata has not been preserved, 
you can use other types of data (such as File Cre-
ation Date or File Name) to find related chan-
nels. However, the matching process will be eas-
ier if metadata has been preserved.

Receiving Source Files
When involved in the audio post-production of 
edited video sequences, you need both of the fol-
lowing sets of source files:

• AAF or OMF sequence with an edited pro-
duction sound mix synced to video (such as 
referenced QuickTime movies or Avid 
video)

• Raw Production source files representing 
multichannel recordings from a field re-
corder

You will receive these files either separately 
(from the Avid video editor and production 
sound mixer) or together as part of an AAF or 
OMF sequence export including raw production 
source audio (from the Avid video editor).

For detailed information about preserving 
metadata during the production process, see 
“Overview of Production Workflows” on 
page 1214.
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Separate Deliveries of Source 
Files
When you receive an AAF or OMF sequence 
from the Avid editor and raw production source 
audio from the production sound mixer, you im-
port the sequence, then either import the raw 
production source audio, or instruct Pro Tools 
to search for matching audio outside the ses-
sion. 

Once the production audio is imported or lo-
cated, Pro Tools will be able to match them to-
gether.

Single Delivery of Source Files
There are two methods the Avid editor may use 
to prepare the files before exporting them:

• Production source audio has been auto-
synced in the Avid Bin and placed on the 
Timeline

• Production source audio has been auto-
synced and resides only in the Avid Bin

Production Source Audio in Timeline Auto-
Synced to Edited Production Sound Mix The 
production source audio in the Avid Bin has 
been auto-synced to the edited located sound 
mix, and all audio channels reside in the Avid 
Timeline. 

When you import this type of sequence into 
Pro Tools, the edited video, edited production 
sound mix, and all production source audio will 
be available to import directly into the Timeline.

See “Importing an AAF or OMF Sequence 
into Pro Tools” on page 1203 and “Import-
ing Raw Production Source Audio Directly 
into Pro Tools” on page 1204.



Production Source Audio Auto-Synced and Re-
sides Only in the Avid Bin In the Avid video ed-
iting application, the raw production source au-
dio has been auto-synced to the edited produc-
tion sound mix, but all audio channels reside 
only in the Avid Bin. 

Importing Source Files into 
Pro Tools
This topic describes importing production 
source audio from the following types of files:

• AAF or OMF sequences

• Raw production source audio (if received 
separately from the AAF or OMF sequence)

Importing an AAF or OMF 
Sequence into Pro Tools

To open an AAF (or OMF) sequence as a Pro Tools 
session:

1  Launch Pro Tools.

2  Choose File > Open Session.

3  In the Open Session dialog, navigate to the 
AAF or OMF sequence you want to import.

4  Click Open.

5  Name your session in the File Name field.

6  Select WAV from the Audio File Type pop-up 
menu.

In this case, the AAF or OMF sequence does 
not contain or reference the production 
source audio when imported into Pro Tools. 
The Avid editor must deliver the production 
files to Pro Tools separately. The Avid edi-
tor may either deliver the production audio 
files from the Avid or OMFI Media Files 
folder, or they may deliver the raw produc-
tion source audio files, which have not 
passed through Media Composer.
7  Select the I/O Settings to use for the session. 
Several pre-configured I/O Settings are included 
with your system, or you can select a custom I/O 
Setting that you have created.

8  Click Save.

The Import Session Data dialog appears.

9  Choose Link to Source Media (Where Possible) 
from the Audio Media Options pop-up menu.

10  Choose Link to Source Media from the Video 
Media Options pop-up menu.

11  In the Source Tracks section, select tracks to 
import by clicking the pop-up menu to the right 
of each track name and selecting Import As New 
Track. 

12  Change other parameters.

13  Click OK.

Pro Tools creates a new Audio Files folder, 
Video Files folder, cache.wfm file, and session 
file at the designated locations. This session 
matches the audio file type, sample rate, and bit 

Pro Tools lets you open and import OMF or 
AAF sequences that reference audio files with 
mixed sample rates or bit depths. Audio files 
will be converted to the highest sample rate 
and of the files being imported (for new ses-
sions) or to the current sample rate (for exist-
ing sessions). Files with mixed bit depths that 
are already at the target sample rate are im-
ported without conversion.

To select multiple tracks, Option-click (Mac) 
or Alt-click (Windows) on any track pop-up 
menu and select Import As New Track.
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depth of the audio in the selected AAF or OMF. 
Any selected tracks in the Source Tracks section 
of the Import Session Data dialog are automati-
cally placed in the Timeline. 

Importing Raw Production 
Source Audio Directly into 
Pro Tools
If the AAF or OMF sequence you imported into 
Pro Tools did not include raw production source 
audio, you may import it into the session sepa-
rately using media supplied by the production 
sound mixer. 

You can import monophonic or polyphonic au-
dio files from field recorders into Pro Tools us-
ing any of the following methods:

• Using File > Import > Audio, and selecting 
the files you want to import

• Dragging files to the Clip List from the 
Workspace browser or the desktop (and 
then using the Audio Import Options dialog 
to place them in the Clip List)

For more information about importing AAF 
and OMF sequences in Pro Tools, see “Im-
porting AAF and OMF Sequences” on 
page 361.

In projects with large amounts of produc-
tion audio, it may not be convenient to im-
port all production audio into Pro Tools for 
reference. You can set Pro Tools to search 
for matching audio in areas outside the ses-
sion when it looks for matching field re-
corder files. For more information, see “Se-
lect Areas to Search” on page 1209.
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Repairing Audio Misalignment 
When Importing Audio Not 
Exported from Avid
When you use Pro Tools to import raw produc-
tion source audio that was not exported from an 
Avid video editing application—such as audio 
delivered separately from an AAF or OMF se-
quence—that audio may be offset with the audio 
in the AAF or OMF sequence by as much as half 
a frame.

This misalignment results from the incompati-
bility between frame-accurate time stamping in 
Avid video editing applications and sample-ac-
curate time stamping in Pro Tools. When you 
attempt to link the two, the misalignment re-
sults.

In order to repair this discrepancy, you may 
need to offset the raw production source audio 
after importing it into Pro Tools, either manu-
ally, or with a utility like SynchroArts Titan.

Don’t Convert Sample Rate on 
Import Preference
In some workflows, it is common for production  
audio to be recorded at 48.048 kHz to accommo-
date for a pull down to 48 kHz applied  down-
stream in the workflow. When importing  audio 
at this special sample rate, Pro Tools can  either 
sample rate convert the file to 48 kHz, or pull the 
file down to 48 kHz in real time during playback.

If you plan to import audio at 48.048 kHz and  
want Pro Tools to apply the 48 kHz pull down in 
real time, follow the procedure below:



To set the Don’t Convert Sample Rate on Import 
Preference:

1  Open the Preferences dialog by clicking 
File>Preferences.

2  Select the Processing tab.

3  In the Import section, find the Don’t Convert 

Sample Rates on Import preference setting.

4  Enable that preference to activate real-time 
pull  down for 48.048 kHz audio files.

Designating Field Recorder 
Tracks
Working with field recorder data often requires  
Pro Tools to do additional administrative work  
to locate and keep track of production field re-
corder  channels and metadata. This file han-
dling can be system-intensive when working  
with large amounts of data. 

Pro Tools lets you specially designate field re-
corder  tracks after importing them, ensuring  
that Po Tools only does field-recorder-specific 
file operations on channels that actually contain 
field recorder data.

To designate a field recorder track:

1  Right-click on the nameplate for the track you 
want to designate as a field recorder track.

2  A menu will open.

3  Click Field Recorder Guide Track.

To designate more than one track as a field 
recorder track, select the desired tracks and 
right-click the nameplate of one of the se-
lected tracks.
4  Repeat for each field recorder track in the ses-
sion.

Displaying Multichannel Files 
from a Field Recorder in the 
Clip List
When importing multichannel recordings from 
a field recorder, Pro Tools saves the multichan-
nel audio as interleaved audio files, which dis-
play as single items in the Clip List. 

In previous versions of Pro Tools, multichannel 
files were saved as separate files, one for each 
channel. Pro Tools treats these groups of related 
clips as single items. An expand/collapse trian-
gle next to an item in the Clip List indicates this 
type of grouped multichannel clip. If you’re 
working with material imported by an earlier 
version of Pro Tools, you may see these collec-
tive clips.

For multichannel audio clips imported from 
field recorders to be shown as collective clips, 
both component clips must have the following 
properties:

• Same length

• Same clip name prefix (such as Audio File 
or Audio File_01)

• Consecutively-numbered clip name suffix, 
from A1 through A8

Each mono field recorder track must be des-
ignated to enable the special Pro Tools field 
recorder features for that track.

To remove the field recorder designation 
from a track that has been designated, right 
click its nameplate and uncheck the Field 
Recorder Guide Track option. 
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For example, the clips Audio File_01.A1 and Au-
dio File_01.A2 would be grouped as a multi-
channel clip in the Clip List.

If an existing stereo or multichannel grouped 
clip has been dragged onto multiple mono tracks 
and edited in such a way that one or more com-
ponents are no longer the same length, the ste-
reo display is removed and the clips are dis-
played as individual clips in the Clip List. 

Selecting a Matching Field 
Recorder Channel to Replace 
a Clip
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

Once you have imported an AAF or OMF se-
quence into the Timeline, you can replace the 
original production sound mix with an equiva-
lent matching field recorder channel while pre-
serving the original edits.

If the Import Session Data process imported 
all production source audio directly into the 
Timeline, this procedure is unnecessary.
Pro Tools Reference Guide
Replacing a Clip with a Matching 
Segment from a Matching Field 
Recorder Channel
You can replace a mono clip (or selected portion 
of a mono clip) with a matching segment of a 
matching field recorder channel that was re-
corded simultaneously. Any fades performed on 
the original clip are automatically applied to the 
replacement clip, and any pre-existing automa-
tion on that track is unchanged.

To replace a clip with a matching field recorder 
channel:

1  In the Timeline, make a selection that includes 
or overlaps the clip or portion of the clip you 
want to replace.

2  Do one of the following:

• With any Edit tool, Right-click the selec-
tion you want to replace, then select Match-
ing Field Recorder Channels from the pop-
up menu.

• With the Selector tool, Command-option-
click (Mac) or Control-alt-click (Windows) 
the selection you want to replace.

Using this feature is especially useful when 
combining it with duplicating the produc-
tion sound mix track. For example, you 
could replace the audio from a boom micro-
phone with the audio from a lavalier micro-
phone—while preserving any edits or fades 
from the original edited production sound 
mix in the AAF or OMF sequence. 



3  From the Matching Field Recorder Channels 
pop-up menu, select the name of the matching 
clip that you want to use to replace the original 
clip. 

4  Repeat this procedure for every clip you want 
to replace on each track.

You can hold Command-option (Mac) or 
Control-alt (Windows) and use the up and 
down arrow keys to step through the list of 
available matches for the selection.

The first time you open the Matching Field 
Recorder Channels menu for a certain clip, 
Pro Tools must search for matching chan-
nels, and displays “Searching for metadata 
in the background.” Close and open the 
menu again once the search is complete to 
see the found matches.

If the production sound mixer entered the 
channel name (or some other descriptive 
reference) during shooting, the Matching 
Field Recorder Channels pop-up menu dis-
plays this information.
Conditions for Matching Field 
Recorder Channel Availability
By default, a matching field recorder channel is 
available to replace the original channel (repre-
sented by the clip or portion of a clip selected on 
the Timeline) if all of the following are true:

• Both channels are part of a multichannel part 
of a recording made simultaneously on one or 
more field recorders.

• Both channels overlap at least once between 
their start timecode and end timecode posi-
tions.

• Criteria set in the Match Criteria dialog is 
met.

• The metadata embedded during shooting and 
recording has been preserved prior to import 
into Pro Tools.

However, different field recorders can behave 
differently, and in some cases, available meta-
data can be incorrect, incomplete, or missing. 
To aid in finding matching field recorder chan-
nels in these situations, Pro Tools lets you con-
trol its channel match criteria.

For information on how to ensure that 
metadata have been properly preserved in 
your source files, see “Ensuring Metadata of 
Source Files Have Been Preserved” on 
page 1202.
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Field Recorder Channels Match Criteria

For maximum flexibility, the Field Recorder 
Channels Match Criteria dialog lets you set the 
criteria Pro Tools uses to find matching field re-
corder channels. 

You can find matches using any or all of the fol-
lowing identifying data points:

File Creation Date The date the files were cre-
ated, as specified by the operating system.

Shoot date The shoot date of the content, as 
specified by iXML metadata.

Scene  The scene number of the content, as 
specified by iXML metadata.

Field Recorder Channels Match Criteria window
Pro Tools Reference Guide
Scene and Take The scene number and take 
number, as specified by iXML metadata.

Tape Name The tape name, as specified by iXML 
metadata, must match the tape name of the 
guide file.

Sound Roll Name The sound roll name, as speci-
fied by iXML metadata, must match the sound 
roll name of the guide file.

Sound Roll Name to Tape Name The tape name, 
as specified by iXML metadata, matches the 
sound roll name of the guide file.

Tape Name to Sound Roll Name The sound roll 
name, as specified by iXML metadata, matches 
the tape name of the guide file.

First X Characters in File Name Matches files 
based on a user-specified number of characters 
in the file name, starting at the beginning.

Channel Name The channel name, as specified 
by iXML metadata.

Channel Number The channel number, as speci-
fied by iXML metadata.

Name and Sort Tracks By

This option lets you set the method Pro Tools 
uses to name and sort the audio files created by 
expanding matching field recorder channels. 

Matching channels by take can only be done 
if also matching by scene.

When matching by the above criteria, 
Pro Tools will accept timecode matches in 
both Original Time Stamp and Sound Roll 
Timecode.



To set match criteria:

1  Do one of the following:

• In the Edit window, Right-click on a mono 
clip, and choose Matching Field Recorder 

Channels > Match Criteria... in the pop-up 
menu that opens.

• In the Edit window, Command-option click 
(Mac) or Control-alt-click (Windows) on a 
mono clip, and choose Field Recorder Chan-

nel Match Criteria... from the pop-up menu 
that opens.

• Right-click the name plate of the track you 
want to find matches for, and choose Field 

Recorder Channel Match Criteria... from the 
pop-up menu that opens.

2  The Field Recorder Channels Match Criteria 
window will open.

3  Click the check boxes next to the matching 
conditions you want Pro Tools to search by.

4  Choose ANY or ALL from the Match Timecode 
Plus... drop-down menu. Choosing ANY will 
find matches based on any one of the criteria 
you’ve set. Choosing ALL will require that all of 
the criteria you’ve set must be matched for 
Pro Tools to consider a prospective match valid.

When looking for the largest number of 
matches, choose ANY. Then, you can use 
ALL to narrow down your matches to a spe-
cific shoot date, channel name, or other 
identifying data point.
5  In future searches for matching field recorder 
channels, Pro Tools will follow the guidelines 
you’ve set, until you change them again.

Select Areas to Search

By default, Pro Tools searches for matching 
field  recorder files in the Audio Files folder for 
the  current session. Because field recorders of-
ten accumulate  large amounts of audio data, im-
porting  the necessary files into your Pro Tools 
session  can be a slow and complex task.

The Select Areas to Search option lets you spec-
ify  additional locations (such as alternate fold-
ers or  hard drives) for Pro Tools to search for 
matches.

To select areas to search for matching field 
recorder tracks:

1  Right-click the nameplate of a field recorder 
track.

2  A menu will open.

3  Click Select Areas to Search...

The Reset button toggles all check boxes to 
their default values.

Option-click (Mac) or Alt-click (Windows) 
any check box to check or uncheck all boxes 
in the dialog.

Select Areas to Search dialog
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4  The Select Areas to Search dialog will open. By 
default the list of areas to search will be empty.

5  Press the Plus (+) button to add a new alter-
nate search location.

6  A file navigation window will appear.

7  Navigate to a folder or hard drive you want 
Pro Tools to search for matches.

8  Select the desired folder or hard drive.

9  Press the Choose button to confirm your 
choice.

10  Repeat this procedure to add additional 
search areas, if necessary.

11  If you need to delete a search area from the 
list, select it and click the Minus (-) button.

12  Do one of the following:

• Press Save to close the Select Areas to 
Search dialog and save the new search area 
settings.

• Press Save & Index to save the new search 
area settings and re-index the selected fold-
ers. For more information, see “Re-Index-
ing” on page 1210.

Re-Indexing

When new audio is added to one of the desig-
nated search areas, Pro Tools must  index the 
contents of that folder before the new audio can 
be accessed. 

To re-index all alternate search areas:

1  In the Field Recorder Channels Match dialog,  
click the Select Areas to Search button.

2  The Select Areas to Search dialog will open.

Pro Tools will show an error message if you 
try to add a subfolder whose parent folder is 
already in the list of search areas.
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3  Click the Save & Index button to save the  cur-
rent settings and re-index all search areas in  the 
list.

Missing Search Folders

Folders that you select as search areas can go  
missing for a variety of reasons (such as deletion 
or the absence of a  needed hard drive). If a 
folder is missing,  Pro Tools shows an error mes-
sage when you open the Select Areas to Search 
dialog. The missing  path name is displayed in 
the list in gray-colored italic text.

Expanding Matching Field 
Recorder Channels to New 
Tracks
(Pro Tools HD and Pro Tools with Complete 
Production Toolkit Only)

When working with a mono clip that is part of a 
multichannel recording, you can expand that 
clip (or a selected portion of it) to new tracks 
that reflect its matching channels while preserv-
ing any edits or fades. 

Field recorder files imported through 
searches outside the session are always im-
ported as .wav if any conversion needs to 
take place, to preserve the field recorder 
metadata. Session file type selected in the 
Session Setup window is ignored.

Matching field recorder channels are mono 
channels that were usually recorded simul-
taneously with the original clip (such as 
multichannel recordings made by one or 
more field recorders). For information on 
setting the detailed criteria that matching 
channels must meet, see “Conditions for 
Matching Field Recorder Channel Avail-
ability” on page 1207.



For example, this feature lets you easily create 
different versions of an edited dialogue track 
corresponding to multiple channel inputs (mi-
crophones) that were recorded simultaneously.

To expand matching field recorder channels to 
new tracks:

1  In the Timeline, do one of the following:

• To expand a single clip on a single track, 
right-click the clip.

• To expand a portion of the clips on the 
track, make a selection that includes or 
overlaps any number of clips, and Com-
mand-option-click (Mac) or Control-alt-
click (Windows) the selection.

• To expand all of the clips on a mono track, 
Right-click the track’s name plate. 

2  Choose the Expand Channels to New Tracks 
submenu, and select one of the following meth-
ods by which to expand matching field recorder 
channels for the selection to new tracks:

• By Match Criteria

• By Timecode Only

The channel you plan to expand must be 
mono.

When expanding only a portion of the clips 
on a track, the By Match Criteria option will 
be grayed out if there are no valid matches 
found, or if the ANY option is chosen in the 
Field Recorder Channels Match Criteria di-
alog and no boxes are checked.

See “Determining the Method of Expanding 
Matching Field Recorder Channels to New 
Tracks” on page 1211 for more information 
on how each of these options expand to new 
tracks.
If matching field recorder channels are avail-
able, Pro Tools expands them (plus the channel 
represented in the original track) to new tracks 
according to the chosen parameters.

Determining the Method of 
Expanding Matching Field 
Recorder Channels to New 
Tracks
Matching field recorder channels may be ex-
panded to new tracks based on the channel 
match criteria specified in the Field Recorder 
Channels Match Criteria dialog (For more info, 
see “Field Recorder Channels Match Criteria” on 
page 1208), or by timecode only.

Expanding Matching Field 
Recorder Channels by Match 
Criteria
Choosing Expand Channels to New Tracks > By 

Match Criteria creates a new track for each 
unique channel found in matching channels of 
the selection that meets the criteria you’ve spec-
ified.

If channels with duplicate match criteria (such 
as Channel Name or Channel Number) are en-
countered, additional tracks are created for each 
duplicate channel. The new channels share the 

Result of expanding a selection to new tracks
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name of the original channel they were ex-
panded from, appended with a period, followed 
by an identifying number. The first matching 
channel will be appended by .2, the second by .3, 
and so on.

Each new track contains only channels that 
match according to the specified match criteria, 
with edits and fades preserved from the original 
selection. Gaps reflect clips from the original se-
lection that did not have a matching channel 
with that channel name.

Naming and Sorting Expanded 
Channels

For maximum flexibility, Pro Tools lets you 
control the naming and sorting of new channels 
created by the Expand Channels to New Tracks 
by Match Criteria command.
.

This parameter can be set in the Field Recorder 
Channels Match Criteria dialog (for more info, 
see “Field Recorder Channels Match Criteria” on 
page 1208.)

How Tracks Are Named When Expanding 
Matching Field Recorder Channels by Channel 
Name

Tracks expanded this way are named as follows:

• For unique channel names that create only one 
track, each track is named using the original 
track’s name plus the channel name. For ex-
ample, expanding the unique channel name 
Boom from the track Guide.A1 would create a 
new track called Guide.A1.Boom.

Name and Sort Tracks by: section of the Field 
Recorder Channels Match Criteria dialog
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• For unique channel names that create two or 
more tracks, each of the new tracks that share 
channel names are named by appending a pe-
riod, followed by an identifying number. The 
first matching channel will be appended by .2, 
the second by .3, and so on. For example, ex-
panding the duplicate channel names Boom 
from the track Guide.A1 would create 
Guide.A1.2 and Guide.A1.3.

How Tracks Are Named When Expanding 
Matching Field Recorder Channels by Channel 
Number

Tracks expanded this way are named as follows:

• For unique channel numbers that create only 
one track, each track is named using the orig-
inal track’s name plus the channel number. 
For example, expanding the unique channel 
number A1 from the track Guide.A1 would 
create a new track called Guide.A1.A1.

• For unique channel number that create two or 
more tracks, each of the new tracks that share 
channel numbers are named by appending a 
period, followed by an identifying number. 
The first matching channel will be appended 
by .2, the second by .3, and so on. For example, 
expanding the duplicate channel numbers A1 
from the track Guide.A1 would create 
Guide.A1.A1.2 and Guide.A1.A1.3.

How Tracks Are Named When Expanding 
Matching Field Recorder Channels by Channel 
Name & Number

Tracks expanded this way are named as follows:

• For unique channel name and number combi-
nations that create only one track, each track 
is named using the original track’s name plus 
the channel name and number. For example, 
expanding the unique channel name and num-
ber combination Boom.A1 from the track 
Guide.A1 would create a new track called 
Guide.A1.Boom.A1.



• For unique channel name and number combi-
nations that create two or more tracks, each of 
the new tracks that share channel name and 
numbers are named by appending a period, 
followed by an identifying number. The first 
matching channel will be appended by .2, the 
second by .3, and so on. For example, expand-
ing the duplicate channel names Boom.A1 
from the track Guide.A1 would create 
Guide.A1.A1.2 and Guide.A1.A1.3.

Expanding Matching Field 
Recorder Channels by Timecode 
Only
The Expand To New Tracks By Timecode Only 

command lets you expand an entire track or 
only selected clips to new playlists on the same 
track or to new separate tracks, thus revealing 
all other clips recorded at the same timecode lo-
cation, regardless of channel name or number. 
This is especially useful when expanding edited 
guide tracks to original source audio that was 
recorded while referenced to timecode, but 
where channel names or numbers were not writ-
ten to the audio files. 

When finding matches by timecode only, 
Pro Tools will reference both Original Time 
Stamp and Sound Roll Timecode. If a cross-
match is found between Tape and Sound Roll 
Name (or vice versa) Pro Tools will also look for 
cross-matches between Original Time Stamp 
and Sound Roll Timecode.

Example Workflow: Working 
with a Guide Track
For live concert videos, the video is captured 
separately while the audio is recorded in 
Pro Tools. The video editor will use a guide au-
dio track that is edited along with the video in 
their video editing software (such as Avid Media 
Composer). The edited guide track is then re-
turned to Pro Tools, but it needs to be expanded 
to the conformed original source tracks for mix-
ing and mastering.

1  Multitrack audio is recorded in Pro Tools 
while chasing timecode. A mono or stereo mix is 
recorded simultaneously as a guide track for the 
video editor.

2  The picture and audio guide tracks are edited 
in a video editing application (such as Avid 
Media Composer). 

3  The edited audio guide tracks are exported 
from the video editor as an AAF (or OMF) se-
quence, including handles of at least 2 frames. 

4  The AAF (or OMF) sequence is imported into 
Pro Tools as a new session.

5  The original source audio files and unedited 
guide track are also imported into the session.

6  The original unedited guide track is relinked 
to the session (see “Relinking the Original 
Unedited Guide Track” on page 1213).

7  The Pro Tools editor Right-clicks the name of 
the guide track and selects Expand to New Tracks 

> By Timecode Only. The original source tracks 
expand to new tracks with edits and fades that 
match the guide track.

Relinking the Original Unedited Guide Track

After importing the AAF (or OMF) sequence and 
original source audio files into the session, it is 
recommended that you relink the edited guide 
track to the original unedited source audio.

To relink the original unedited guide track:

1  Open the Project Browser for the session and 
open the Audio Files folder. 

2  Right-click the edited guide track audio file in 
the browser and choose Relink Selected.
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3  In the upper pane of the Relink window, navi-
gate to the original unedited guide track audio 
file that was recorded in Pro Tools. 

4  In the Select Files To Relink pane, select the 
edited guide track file.

5  Drag the original unedited guide track audio 
file into the Candidates pane. If a dialog appears 
stating that one or more files are shorter than 
the media file you are trying to relink, click Yes 
to select it for relinking anyway.

6  Check the box to the left of the file in the Can-
didates pane so that the Link icon appears. 

7  Click Commit Links at the top of the Relink 
window and then close the Relink window.

• You can now Right-click the name of the 
guide and select Expand To New Tracks > By 

Timecode Only. All expanded tracks should 
be synchronous with the guide track.

Overview of Production 
Workflows
This topic describes overviews of various work-
flows for preparing the following media during 
and after shooting picture:

• “Film Workflow” on page 1214

• “Video and Fully Non-Linear Workflows” 
on page 1217

If the original unedited file is not available, 
you can relink to any of the source audio 
files as long as they have the same start and 
end times as the guide track.
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Distributing this Document to 
Intended Audiences
The purpose of these example workflows are to 
ensure that the Pro Tools editor receives origi-
nal source files containing usable metadata that 
was entered or captured during a shoot, and is 
therefore written for a broad range of audiences.

It is strongly recommended that the following 
parties read and understand this appendix:

For film workflows:

• Production sound mixer

• Telecine operator

• Camera assistant

• Camera operator

• Avid editor

• Pro Tools editor

For all other workflows:

• Production sound mixer

• Avid editor

• Pro Tools editor

Film Workflow
This topic describes the film workflow from 
shooting to the point where the Avid editor is 
ready for editing, and is intended for the follow-
ing parties:

• Camera assistant

• Camera operator

• Production sound mixer

• Telecine operator

• Pro Tools editor

If you are the Pro Tools editor, you should 
distribute this documentation to the appro-
priate parties listed below.



Overview of Film Workflow

The following describes an overview of the steps 
necessary to a film workflow:

1  Set up before shooting.

2  Shoot.

3  Telecine transfer.

4  Batch digitize in Avid video editing applica-
tion.

Following these steps ensures that timecode 
metadata are preserved from the moment shoot-
ing begins to the final delivery of source files to 
the Pro Tools editor.

Setting Up Before Shooting 
(Film Workflow)
Before each day’s shooting begins, the produc-
tion sound mixer should decide on a unique 
name—preferably ascending by day—and enter 
that exact name in the Tape BEXT or iXML 
metadata field inside the Broadcast WAV file. 

For example, the production sound mixer might 
use T001 for the first day’s shooting, T002 for 
the second day’s shooting, and so forth.

Shooting (Film Workflow)
1  Shooting proceeds as follows:

• Film camera begins rolling.

• One or more field recorders begin record-
ing. The production sound mixer has desig-
nated one or two channels as a production 
sound mix, which is a consolidation of one 
or more channels in each multichannel re-
cording.
2  During shooting, the following timecode in-
formation is captured:

• The camera captures images to film, each 
frame of which is embedded during manu-
facturing with a unique identifying time-
code position known as keycode.

• One or more field recorders simultaneously 
make multichannel recordings that are em-
bedded with SMPTE timecode based on 
time of day (or longitudinal timecode).

3  During shooting, the following information is 
noted:

• The camera assistant keeps a written record 
(called a shootlist) documenting each scene 
and take with a corresponding keycode po-
sition.

• The production sound mixer also keeps a 
written record (also called a sound log) doc-
umenting each scene and take with a corre-
sponding timecode position.

4  The slate operator claps the slate to indicate 
the beginning of the take. The field recorder re-
cords the audio of the clap, and the film camera 
captures the following images:

• Scene and take number (written on the 
slate)

• Exact moment the slate closes

• Timecode position of the slate closing

5  Shooting ends and the take is complete.

Telecine Transfer (Film 
Workflow)
When shooting is complete for the day, the fol-
lowing components are delivered to the telecine 
operator:

• Processed film stock

• Multichannel location audio 

• Written shootlist and sound log
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The telecine operator generates the dailies (a 
videotape containing the day’s shots) by trans-
ferring the film and audio to a videotape. The 
shootlists will be used as a guide.

To use a telecine to create dailies:

1  Load film and audio into the telecine.

2  Enter the Tape name or Sound Roll name 
(whichever was used during the production) 
character for character into the telecine. 

3  Using the camera assistant’s shootlist, locate 
the film frame representing the first keycode po-
sition of the film in the shootlist (which should 
be just before the slate is clapped).

4  Locate the film to the first frame where the 
slate clap occurs, and note the timecode position 
displayed on the slate.

5  Locate the audio to the exact timecode posi-
tion listed on the slate in the film frame (which 
lines up the audio with the film).

To ensure that metadata are preserved for 
the Pro Tools editor, it is critical to enter 
the Tape name or Sound Roll name charac-
ter for character. For example, if the meta-
data was T001 (with two zeroes), enter 
T001 with two zeroes—not T01 with one 
zero or T0001 with three zeroes.
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6  Play back the film and audio to test that they 
are synchronized. If they are not synchronized, 
make small manual adjustments as needed until 
the film and audio are synchronized.

7  Once the film and audio are properly synchro-
nized, lock the film and audio in place.

8  Insert a blank videotape into the VTR con-
nected to the telecine, and manually assign lin-
ear timecode (LTC) information to the 
videotape. 

9  Begin the telecine capture. During the telecine 
capture, the following occurs:

• The telecine begins capturing the synchro-
nized film and audio to the videotape, with 
linear timecode (LTC) being assigned to the 
videotape beginning from where you en-
tered the start timecode.

• A FLEx file is created, where scene and take 
information is automatically written and 
associated to the film keycode and telecine 
videotape timecode relative to audio time-
code.

10  When the telecine transfer is complete, de-
liver the following to the Avid editor:

• Telecine videotape

• FLEx file

• Shootlist

• Sound log

• Location audio media



Batch Digitizing the Telecine 
Videotape to Digital Files (Film 
Workflow)
This phase of the workflow begins after the Avid 
editor receives the following components from 
the telecine operator:

• Telecine videotape

• FLEx file

• Shootlist

• Sound log

In a film workflow, the Avid editor batch digi-
tizes the telecine videotape to digital video and 
audio files in order to edit them.

To batch digitize a telecine videotape to digital 
source files:

1  In the Avid video editing application, import 
all relevant FLEx files into Avid Log Exchange.

Avid Log Exchange displays a list of all scene 
and take combinations, with associated film 
keycode, audio timecode, and relative videotape 
timecode.

2  In Avid Log Exchange, select the items in the 
FLEx file that represent the scenes and takes you 
want to batch digitize from the videotape.

3  Process the selected scenes and takes in the 
FLEx file. Avid Log Exchange sends the selected 
items to the Avid video editing application, 
where they are loaded into the Bin as offline me-
dia.

4  In the Avid Bin, select the items you want to 
capture.

In some cases, you may also receive location 
audio from the production sound mixer.

Any metadata required for matching (such 
as Tape name) should be visible in the un-
digitized clips.
5  Load the telecine videotape into the Avid, and 
begin the batch digitize.

The Avid automatically batch digitizes the 
scenes and takes selected in the Avid Bin, and 
uses the FLEx file to assign each of the digitized 
video and audio files with the timecode informa-
tion matching the original keycode and time-
code information from the shoot.

6  When the batch digitize is complete, use the 
Avid video editing application to edit audio and 
video.

7  When you are finished editing, export the ed-
ited sequence as an AAF or OMF sequence so 
that it can be imported into Pro Tools.

Video and Fully Non-Linear 
Workflows
This topic describes both video and fully non-
linear workflows from shooting to the point 
where the Avid editor is ready for editing, and is 
intended for the following parties:

• Camera assistant

• Camera operator

• Production sound mixer

• Avid editor

• Pro Tools editor

Overview of Video and Fully Non-Linear 
Workflows

The following describes an overview of the steps 
that are necessary in these workflows:

1  Set up before shooting.

2  Shoot.

3  Digitize video in Avid video editing applica-
tion (video workflow only) or import digital 
video files directly into Avid video editing appli-
cation (fully non-linear workflow only).
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Following these steps ensures that timecode and 
other metadata are preserved from the moment 
shooting begins to the final delivery of source 
files to the Pro Tools editor.

Setting Up Before Shooting 
(Video and Fuly Non-Linear 
Workflows)
Before shooting begins, the camera operator and 
the production sound mixer should ensure the 
following:

• The field recorder’s audio output feeds the 
video camera’s audio input.

• Both the field recorder and the video camera 
should be locked to the same production time-
code.

Matching Tape Name to Sound Roll Metadata 
for Video Shoots

Before loading the videotape into the video cam-
era, the camera operator physically labels the 
videotape with a unique name. The production 
sound mixer must enter that exact name in the 
Tape BEXT or iXML metadata field inside the 
Broadcast WAV file. 

Matching Tape Name to Sound Roll Metadata 
for Fully Non-Linear Shoots

After loading the digital video storage into the 
camera, the camera operator gives it a unique 
name. The production sound mixer must enter 
that exact name in the Tape BEXT or iXML 
metadata field inside the Broadcast WAV file. 

After you import a file containing Tape 
metadata into Pro Tools, the metadata dis-
plays in the Sound Roll field in DigiBase 
browsers.
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Shooting (Video and Fuly Non-
Linear Workflows)
1  Shooting proceeds as follows:

• Camera begins rolling.

• One or more field recorders begin record-
ing. The production sound mixer has desig-
nated one or two channels as a production 
sound mix, which is a consolidation of one 
or more channels in each multichannel re-
cording.

2  During shooting, the following timecode in-
formation is captured:

• The camera captures images to video or file 
embedded with SMPTE timecode based on 
time of day (or longitudinal timecode).

• One or more field recorders simultaneously 
make multichannel recordings that are em-
bedded with SMPTE timecode based on 
time of day (or longitudinal timecode).

3  The slate operator claps the slate to indicate 
the beginning of the take. The field recorder re-
cords the audio of the clap, and the film camera 
captures the following images:

• Scene and take number (displayed on the 
slate)

• Exact moment the slate closes

• Timecode position of the slate closing

4  Shooting ends and the take is complete.

To ensure that metadata are preserved for 
the Pro Tools editor, it is critical to enter 
the Tape name character for character. For 
example, if the metadata was T001 (with 
two zeroes), enter T001 with two zeroes—
not T01 with one zero or T0001 with three 
zeroes.



Digitizing a Videotape in the 
Avid Video Editing Application
(Video Workflow Only)

This phase of the workflow begins after the Avid 
editor receives the following components from 
the camera operator and the production sound 
mixer:

• Videotape

• Multichannel recordings

In a video workflow, the Avid editor digitizes 
the videotape to digital video and audio files in 
order to edit them. Before doing so, however, 
the Avid editor must name the tape.

To digitize a videotape to digital source files:

1  Load the videotape into the Avid system.

2  When prompted to name the videotape, enter 
the exact Tape name used by the camera operator 
and the production sound mixer.

3  Digitize the videotape loaded into the Avid.

4  When the digitize is complete, use the Avid 
video editing application to edit audio and 
video.

When you are finished editing, export the edited 
sequence as an AAF or OMF sequence so that it 
can be imported into Pro Tools.

To ensure that metadata are preserved for 
the Pro Tools editor, it is critical to enter 
the Tape name character for character. For 
example, if the metadata was T001 (with 
two zeroes), enter T001 with two zeroes—
not T01 with one zero or T0001 with three 
zeroes.
Importing Digital Video Directly 
into the Avid Video Editing 
Application
(Fully Non-Linear Workflow Only)

This phase of the workflow begins after the Avid 
editor receives the following components from 
the camera operator and the production sound 
mixer:

• Digital video (on flash card, hard drive, or 
some other file-based storage)

• Multichannel recordings

In a fully non-linear workflow, the Avid editor 
simply has to import the video and audio media 
into the Avid video editing application in order 
to edit them. 

To import video into the Avid video editing 
application:

1  In the Avid video editing application, create a 
Bin.

2  Import the video files directly into the Bin.

3  When the Disk Label Import dialog appears, 
enter the exact Tape name used by the camera 
operator and the production sound mixer.

4  Use the Avid video editing application to edit 
audio and video.

5  When you are finished editing, export the ed-
ited sequence as an AAF or OMF sequence so 
that it can be imported into Pro Tools.

To ensure that metadata are preserved for 
the Pro Tools editor, it is critical to enter 
the Tape name character for character. For 
example, if the metadata was T001 (with 
two zeroes), enter T001 with two zeroes—
not T01 with one zero or T0001 with three 
zeroes.
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96i I/O 48, 54, 79
9-Pin Machine Control (Deck Control) settings 144
9-Pin Remote (Deck Emulation) settings 145
A
AAF

import translation settings 369
linked media 28
metadata 25, 1197
opening in Pro Tools 362

AAF file format 361, 373
Absolute Grid mode 541, 834
Accel Core card 46
ACID files 333

importing 341
active 22, 23

inserts 993
tracks 251

Active Busses display 113
Add Key Change command 807
Add Marker/Memory Location button 812
Add Meter Change button 798
Add Tempo Change button 775, 794
Add Unique Triggers 674
adding

new playlist 634
sends 956

Adjust Session Start Time to Match Source Start 
Time 356

AFL (After Fader Listen) 248
AFL/PFL Mutes (Output Path) selector 95
AFL/PFL Path 94
AFL/PFL Path selector 94
After Fader Listen mode 248
After Playback Scrolling option 424
After Write Pass, Switch To option 133, 1024
AIFC 371
AIFF file format 1086
All MIDI Notes Off command 708
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all tracks
hiding 234
selecting all clips in 572
selecting in Timebase rulers 578

Allow Latch Prime in Stop option 132
Allow Track Arm Commands in Local Mode option 

139
alternate channels

Expand to New Playlists 649
alternate matching takes 475, 646
Alternate Takes pop-up menu 476, 646
Always Display Market Colors option 123
Always Fill Channel Strips When Banking option 

131
analog monitoring 52
Analysis view 885, 899
AND (DigiBase search modifier) 301
Apple DV codec 1170
Apply Real-Time Properties option 350
archiving sessions (with Compact command) 611
ASIO 11
Assignments View (Sends View option) 960
attributes (groups) 264
Attributes Group command 258
Audio Bit Depth 381
audio clips 523

and automation 527
fitting to an Edit selection 613
stripping silence from 840
whole-file 522

Audio Clips List menu
Export Selected As Files command 378

Audio Designator 319
Audio During Fast Forward/Rewind option 124, 421
audio file format 164
audio files

compacting 612
concepts 16
default names 448
formats 1086
importing 333
mixed file types 172

Audio Files Conform to Session Tempo button 307
Audio Files folder 165
Audio Format 381
audio format, for session 1143
audio interfaces

input channels 18
Pro Tools|HD 50

Audio Media Options 381
Pro Tools Reference Guide
on export 381
on import 365

Audio Media options 355
Audio MIDI Setup 69
Audio MIDI Setup (AMS) (Mac) 151
Audio Pull Up and Pull Down 1150
audio signal paths 86
Audio Track RecordLock option 126, 504
audio tracks 15

5.1 format 1101
and Output format 1111
and surround sessions 1109
bouncing to disk 1084
channel strips 211
creating a tempo map for 794
disabling Elastic Audio 884
enabling Elastic Audio 883
loop recording 473
placing audio in multichannel tracks 1110
punch recording 470
recording multiple 463
signal flow 940
track controls 214
Waveform View 523

Audio Zoom In button 545
Audio Zoom Out button 545
AudioSuite

Default Handle Length preferences 134
Dither 985
Handle Length setting 870
multichannel processing 870
Plug-In selector 864
plug-ins 985
Preview 868
processing 612, 871
Whole File button 869

AudioSuite menu 206
AudioSuite plug-ins 871
AudioSuite processing on networked hard drives 

871
AudioSuite window 864
audition

in Clip List, configuring path 93
Audition Paths selector 93
auditioning

clips in the Clip List 275
fades 617
in browsers 305
MIDI notes 687
pre/post-roll 426



programs 704
selection start and end points 426
takes 475

Auto Backup option 125
Auto button 1000
Auto Input Monitoring mode 456, 457
Auto Match Pull Factors 1151
Auto Rename Clip List command 277
auto-created clips 522

hiding 278
renaming 276

auto-fades 626
AutoGlide mode 1131
AutoGlide Time preference 133, 1131
AutoJoin

command 1025
indicator 1026

AutoMatch
all controls 1040
button 1039
indicators 1033
individual automation types 1040
individual controls 1040

AutoMatch Time preference 133, 1029
automatic delay compensation 67
Automatically Copy Files on Import option 134, 343, 

354
Automatically Create Click Track in New Sessions 

option 137
Automatically Find and Relink 392
automating

plug-ins 1037, 1038, 1039
sends 1036
switched controls 1035
tracks 1033
VCA Masters 1076

automation 1021
and audio clips 527
and multichannel pan 1135
and multiple output assignments 1111
breakpoints 1051
capturing and applying elsewhere 1070, 1073
coalescing clip gain to volume automation 610
coalescing Trim automation 1059
coalescing VCA automation 1077
coalescing volume automation to clip gain 610
converting clip gain to volume automation 609
converting volume automation to clip gain 609
copying 1053
creating 1038
cutting 1053
deleting 1046
delta 1027
display of fade boundaries and shapes 632
drawing with Pencil 1048
editing 1049
editing with Smart Tool 563
enabling 1044
for grouped tracks 1053
for hidden tracks 234
modes 1024
on multichannel tracks 1052
On Stop 1062
pass-through point 1024
pasting 1053
playlists 633, 1022, 1030
plug-in accuracy in bounce 1091
relative and absolute 1027
Safe button 1000
safing 1030
smoothing 1029
snapshot 1068
Special Paste mode 1056
stepped 1051
suspending 1044
thinning 1029, 1047
to next breakpoint 1062
Track View 534
trimming 1058
writing 1033
writing to selection, selection start, or selection 

end 1060
Automation Enable window 1033
Automation Follows Edit option 1030
Automation lanes 1031

in MIDI Editor windows 734
in the Edit window 1031

Automation Mode selector 1024
Automation modes

Off 1024
automation modes

Latch 1025
Latch Trim 1028
Read 1024
Read Trim 1027
Touch 1024
Touch Trim 1027
Touch/Latch 1026
Touch/Latch Trim 1028
Trim Off 1027
Index 1223
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Write 1024
Write Trim 1028

Automation Preferences
AutoMatch Time preference 1029
Smooth and Thin Data After Pass option 1047

Automation Preview mode 1071
Punch Preview button 1073
suspending 1073
Write Automation To commands 1073

Auto-Name Memory Locations While Playing option 
129, 813

Auto-Name Separated Clips option 129, 593
auto-naming

and Strip Silence 841
audio files and clips 448
playlists 633
QuickPunch clips 502
separated clips 593
takes 448

Auto-Spot Clips command 1162
Auxiliary Inputs 19, 209

channel strips 211
monitoring and mixing 970
signal flow 941
track controls 214

Avid Audio Forums command 197
Avid Marketplace browser 196
Avid Support and Training 196
Avid video

codec requirements for export to QuickTime 
1170

Avid Video Errors Stop Playback option 126
Avid Video NTSC Has Setup option 126
Avid video playback in Pro Tools 1190

B
Back and Play command 422
Back command 422
Back/Forward Amount 422
Back/Forward Amount preference 125
Back/Forward commands 422

extending selections 423
repeating 423

backing up sessions automatically 125, 166
bank select 12, 700
Bar|Beat Markers

and tempo events 795
audio with varying tempos 797
editing 796
from Identify Beat command 794
Pro Tools Reference Guide
generated with Beat Detective 664
moving 795

Bars|Beats Time Scale 767
Batch Fades dialog 627
Beat Detective 653, 654, 655

beat triggers
deleting 662
generating 658
inserting 662
moving 662
promoting 663

Collection Mode 673
conforming clips 668
defining a selection 656
detecting transients 658
DigiGroove templates 665
edit smoothing 671
extrapolation 666
generating Bar|Beat Markers 664
groove templates 665
Scroll Next 663
separating clips 667
system requirements 654
templates 665
Trigger Pad 667
window 655
with multiple tracks 668

Big Counter window 419
Bi-Phase/Tach

pulses-per-frame setting 142
Wiring setting 142

bit depth, for session 163, 1142
black burst 1164
Blocks View

audio track 226
video track 1174

Bounce to Disk
16-bit 1089
24-bit 1089
32-bit float 1089
Bit Depth 1089
interleaved files 1088
mono files 1088
multiple mono files 1088

Bounce to Disk command 1081, 1084
and dither 1082
and time stamps 1085
Bounce options 1085
Convert After Bounce 1091
Convert During Bounce 1091



File Type 1086
Format 1088
Help 1094
recording a submix 1094
sample rate conversion options 1089
sample rate conversion quality 1090
source path 1085
Use Squeezer option 1090

Bounce to QuickTime Movie command 1193
bouncing

to a stereo mix 1095
to a submix 1094

breakpoints 1051
Avid keyframes 1049
clip gain 605

Bring to Front command 595
browsers 193, 285

display options 292
foreground 287
navigating 286
opening 286
sorting 293

Buffer Size (Hardware) 459
bus interrogation 964
bussing

multichannel sends 1113
sends 956
signal paths 85
submixing and effects processing 970
surround examples 1118

BWF (.WAV) file format 1086
Bypass button 869

for real-time plug-ins 1001
Bypass Clip Gain setting 610

C
C|24 55
Cache Size 68
Calculator Entry mode (for numeric entry) 577
Calibration Mode command 439
Calibration Reference Level preference 128
cancelling record takes 463, 489
Capture Clip command 591
capturing automation values 1073
capturing timecode 1161
catalog.ddb 284
Catalogs

Clip Name 324
creating folders in 288
deleting folders 299
Center % (Percentage) 1132
Center % in Output window 1133
Center Playhead Scrolling option 425
centered crossfade 615
Chan/Track Process Mode 867
Change Duration command 909, 927
Change Edit to Match Timeline command 582
Change Meter command 754, 798, 800
Change Tempo command 776
Change Timeline to Match Edit command 582
Change Velocity command 909, 925
channel mapping

default path order 95
editing 107
re-mapping 108

Channel selector 1001
for multi-mono plug-ins 1114

channel strips 18
audio tracks 211
Auxiliary Inputs 211
Instrument tracks 213
Master Fader tracks 212
MIDI tracks 213
VCA Master tracks 212

channels 18
chasing

controller events 706
MIDI notes 706
program changes 706

Check for Updates 58
Chord Change dialog 810
Chord symbols

in the Score Editor 754
Chord Symbols ruler 809
chords 809

diagrams 810
symbols 810

Classic Numeric Keypad mode 32, 125
Clear All Clip Indicators command 219, 961
Clear Clip Gain command 608
Clear command (Clip List) 279
Clear command (Edit menu) 536
Clear command Clip List) 278
Clear Special commands (automation) 1056
Clear Trim Automation Track command 235, 1047
clearing Elastic Audio analysis 304
click 440

configuring 442
enabling 441

Click plug-in 440
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click track 440
clicks and pops, avoiding 480, 526
Clip 226
clip 17
Clip Auto Fade In/Out Length preference 627
clip boundaries

extending selections to 576
moving edit cursor to 579
moving Playhead to 427

Clip by Clip mode 866
clip definitions 347
Clip gain 602
clip gain

adjusting with the Clip Gain Fader 605
breakpoint editing 605
bypassing 610
clearing 608
Clip Gain Info view 603
Clip Gain Line 604
clip groups 858
coalescing clip gain to volume automation 610
coalescing volume automation to clip gain 610
converting clip gain to volume automation 609
converting volume automation to clip gain 609
copying 608
cutting 608
Default Handle Length preferences 134
dynamic 603
editing 605
editing with the Grabber tool 605
editing with the Pencil tool 606
pasting 609
rendering 610
static 603
static clip gain value display 603

Clip Gain Fader 605
Clip Gain Fader icon 603
Clip Gain Info view 603
Clip Gain Line 604
clip group file format (.rgrp) 386, 859
clip groups 523, 851

changing timebase format 856
creating 852
editing 856
exporting to different hard drives 388
fades and crossfades 858
importing 387
importing and exporting 386
mixed 854
multitrack 854
Pro Tools Reference Guide
regrouping 853
separated 855
tick-based 855
timebase format 852
trimming 857
ungrouping 853

Clip Groups folder 165
Clip Hold options 122, 219
Clip LED 1001
Clip List 269

and MIDI clips 269
auditioning clips 275
displaying file info for audio clips 270
dragging from 823
Export Clips as Files command 346
Find History 273
finding clips 272
Keyboard Focus 30
pop-up menu 269
previewing clips 275
repeating a previous search 272
selecting clips 273
sorting 271

Clip List command 865
Clip List Keyboard Focus 274
Clip List menu 1163

Auto Rename command 277
Clear command 278
Compact command 611
Export Clip Definitions command 347
Find command 272
Rename command 277
Select options 274
Selected Unused command 278
Show Auto-Created option 278
Sort By options 271
Time Stamp Selected command 833
Timeline Drop Order option 824

Clip List Selection Follows Edit Selection option 
129, 270, 572

Clip menu 206
Bring to Front command 595
Capture command 591
Identify Sync Point 1164
Lock command 839
Mute/Unmute command 840
Quantize to Grid command 601
Remove Sync Point command 837
Send to Back command 595
Ungroup Clips command 853



Unlock command 839
Unloop Clips command 849

Clip Name
Right-click menu 207, 279
View option 531

Clip Time View option 531
clip-based gain 369, 602
clipping 438, 1001
Clips

gain 602
clips 17

aligning to clip start points 826
auto-created 522
auto-naming options 277
auto-spotting 1162
bringing to front 595
capturing 591
clearing 536
clearing Real-Time Properties 715
Conform to Tempo 780
conforming with Beat Detective 668
consolidating 611
copying 535
creating 591
crossfading between 625
cutting 535
default names 448
displaying names 531
displaying times 531
dragging from Clip List 823
dragging to multichannel tracks 602
duplicating 845
Edit-locking 839
exporting as audio files 346
extending selections to include 576
finding 272
healing separations 596
hiding auto-created 278
inserting silence into 843
locking 839
looping 847
managing 276
MIDI 488
moving clips with fades 628
moving in Grid mode 834
multichannel 523
muting 840
nudging 599
nudging clips with fades 628
offline 523
Original Time Stamp 833
pasting 536
placing at Edit insertion point 825
placing in tracks 823
quantizing 601, 922
removing pitch shift (Elastic Audio) 906
removing silence from 841
removing unused 278
removing warp (Elastic Audio) 899
renaming in the Clip List 277
renaming on a track 530
repeating 845
replacing 834
Select options 274
selecting 560, 571
selecting all in a track 572
sending to back 595
separating 592
separating with Beat Detective 667
separating with Separation Grabber 594
shifting 838
shuffling 828

on multiple tracks 828
sliding 827
slipping 831
snapping to 829
snapping to next 830
sorting 271
spotting 832, 1161
sync points 837, 1164
time stamping 1162
Time-locking 840
trimming by Nudge value 598, 690
trimming start/end points 554
trimming to Edit insertion point 597
trimming unwanted data from 596
unlocking 839
User Time Stamp 833
user-defined 276, 278, 522
warped (Elastic Audio) 523, 898
whole-file audio clips 522

Clips menu
Ungroup All Clips command 853

Clips View 226, 227, 527
Clock Source 72, 1019
clock source 1019
Close Session command 177
closing multiple plug-in windows 1002
Coalesce Clip Gain to Volume Automation 

command 610
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Coalesce Trim Automation options 133
Coalesce Trim Automation Track command 235
Coalesce VCA Master Automation Track command 

235
Coalesce Volume to Clip Gain command 610
Coalesce when Removing Slaves from VCA Group 

option 132
coalescing

Trim automation 1059
VCA automation 1077

Collection Mode (Beat Detective) 673
Color Coding

Apply to Channel Strip 254
options 123, 251

Color Palette window 253
Color setting (for window dub) 143
Command|8 55, 987
Commands Keyboard Focus 30
Comments View 222, 951
Committing Elastic Audio 884
Compact command 611
Compact Selected command 279
Compare button 1000
compatibility 7
Compensation for Input Delays After Record Pass 

option 92
Compensation for Output Delays After Record Pass 

option 93
Complete Production Toolkit

features 56
Complete Production Toolkit option 56
compositing 636
compressed QuickTime audio formats 1180
Conductor button 190
Conductor rulers 769

including in selections 578
configuring

click options 442
MMC 1156, 1157
SMPTE 1147

Conform to Tempo command 780
connecting

effects units digitally 1019
external audio devices 1018

Consolidate command
audio 611
MIDI notes 691

Consolidate From Source Media 382
Consolidate Handle Length 366, 382
Consolidate Handle Size 382
Pro Tools Reference Guide
Consolidate Source Audio Media 366
consolidating media 325
Constant command (Tempo Operations) 789
continuous controller events 12
Continuous Scroll with Playhead option 425
Continuous Scrolling During Playback option 424, 

425
continuous zoom 544
control surfaces

C|24 986
Command|8 987
D-Command 986
D-Control 986

controller events 12, 697
and MIDI clips 528
chasing 706
editing 698
editing with Smart Tool 563
inserting 698

Controller lanes 697, 1031
in MIDI Editor windows 734
in the Edit window 1031

Controller Meter Path selector 93
Controllers folder (controller personalities) 987
Conversion Quality option 334, 1090, 1181
Convert Clip Gain to Volume Automation command 

609
Convert Plug-In selector 1001
Convert Volume to Clip Gain command 609
Convert WAV files to AES31/BroadcastWave 

option 134, 343, 394
converting session

audio file format 170
bit depth 170
sample rate 170

Copy Clip Gain command 608
Copy command 535
Copy From Source Media 381
Copy from Source Media (Video) 356, 366
Copy Settings command 1005
Copy Source Audio Media 365
Copy Special commands 1056
Copy to Send command 1037
copying

MIDI notes with the Split command 931
plug-in settings 1007
selections and clips 535
track automation to sends 1036
track control settings to sends 963

Core Audio 11



count off 441
Countoff button 190
CPU (Elastic Audio) processing activity 81
CPU (RTAS) processing activity 81
CPU Usage Limit 63, 64
Create Click Track command 440
Create Continuous File command 866
Create Fades command 625, 626
Create Individual Files command 866
creating

clip groups 852
clips 591
crossfades 625
fade-ins/outs 623
Mac and PC compatible sessions 396
Markers and Memory Locations 811
sessions 162
settings subfolders 1006

Crossfade Preference for Pre/Post-Roll option 129, 
622

crossfades
and dither 985
creating with Smart Tool 562
DestructivePunch 503
equal gain 620
equal power 619, 622
Fades dialog 616
in batches 627
linear 621
overlap 622
Overlapping Waveforms view 616
pre/post 626
removing 625
TrackPunch 503
trimming 625
with dither 620

Current Engine setting 61
Current Feet+Frames command 1149
current meter 190, 797
Current Meter indicator 190
current tempo 191, 775
Current Time display 1143
Current Timecode Position command 1149
Custom Note Duration

Follow Grid 680
custom session templates 174
Custom Shuttle Lock Speed 566
Custom Shuttle Lock Speed preference 124
Cut Clip Gain command 608
Cut command 535
Cut Special commands 1055
All Automation 1055
Pan Automation 1055
Plug-In Automation 1055

Cut Time command 800, 804
cutting

automation 1053
MIDI notes with the Split command 931
selections and clips 535

D
DAE 10
DAE errors, avoiding 480
DAT recorder, recording from 479
database

files and sharing 284
databases 284
D-Command 55, 986
D-Control 55, 986
default

audition path 93
meter 442
metering path 93
output path 94
path order 95
paths 104
program change 700
tempo 443

Default (Paths) 104
Default Automatic Naming to English option 122
Default Clip Color Coding options 123
Default Dynamics preference 131, 997
Default EQ preference 131, 997
Default Fade Settings 130
Default Handle Length options 134
Default Input Gain preference 136
Default Monitor Format selector 95
Default Note Duration 680
Default Note On Velocity setting 680
Default Plug-In preference 136
Default Settings, for TC/E plug-in 136
Default Thru Instrument 483
Default Thru Instrument preference 137
Default Track Color Coding options 123
Degree of Thinning preference 132
delay

MIDI Track Offsets 707
Delay (dly) indicator 979
Delay After Play Command preference 139
Delay Before Locking to LTC option 139
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Delay Before Locking to Timecode option 139
Delay Compensation 67, 977

applying to automatically bypassed tracks 501, 
981

bypassing 980
changing track delay 980
configuring Delay Compensation Engine 978
dedicating DSP resources 67
Delay (dly) indicator 979
enabling 977
engine 67
exceeding compensation limit 980
H/W Insert 90
hardware insert delays 90, 983
information 979
MIDI Beat Clock 138
MIDI Timecode 138
mode 978
settings 977
Time Mode option 128
User Offset (+/–) field 979
viewing 220, 953

Delay Compensation Engine 978
Delay Compensation limit 978
Delay Compensation Status indicator 184
Delay Compensation Time Mode option 128, 978
Delay Compensation View 220, 953
Delay Compensation View option 979
Delay for External Devices options 138
Delay plug-ins 989
Delay setting (Real-Time Properties) 712
Delete Active Groups (Group List) command 258, 

264
Delete Current Settings File command 1005
Delete Fades command 625
Delete Group command 258, 263
Delete Path 107
Delete Track command 224, 235
deleting

automation 1046, 1053
existing I/O paths 106
groups 263
in MIDI Event List 763
Memory Locations 818
MIDI notes 695
playlists 635
program changes 704
sysex events 705
tracks 224
unused clips 278
Pro Tools Reference Guide
delta
trimming automation 1027

designating volumes 319
Destination Audio Sample Rate 368, 381
destination folder for plug-in settings 1006
destructive editing

compacting audio files 612
Destructive Record mode 446, 472
destructive recording 472
DestructivePunch 510

crossfades 503
Prepare DPE Tracks 512
preparing for 512

DestructivePunch File Length preference 128, 512
Digi 002 44

punching with footswitch 505
Digi 002 Rack 44
DigiBase 304

Advanced Search mode 302
auditioning 305
Automatically Find and Relink 312
Auto-Preview mode 308
browser display options 292
browser menu 290, 291
browsers 282, 285
Calculate Waveform 303
candidates for relinking 314
catalog database file 284
Catalogs 283, 323, 324, 325
Clip Name 324
commands 292
Comments 296, 297
Copy and Relink 311
copying database items 297
database items 294, 295, 296
deleting

database items 297
folders from Catalogs 299

Elastic Audio analysis 303
Elastic Audio Plug-In selector 307
Failed Tasks 329
Find Links 316
indexing 288
Linking Options 316
links 310
Loop Audition mode 308
managing tasks 329
Manually Find and Relink 312
Missing files 310, 312
modifiers (browser search) 301



moving database items 297
Paused Tasks 328
Performance Volume 283
Plus (+) and Minus (–) buttons 301
preferences 329
preview at session tempo 308
preview controls 306
previewing 305
Project browser 283, 321
Quick Search 299
Quick Search mode 302
Regenerate Missing Rendered Files 313
Relink window 283, 314
relinking 310
saving a search as a Catalog 303
search modes 302
search modifiers 301
searching 299, 301
sharing catalog database files 284
sharing database files 284
Skip All 312
sorting columns 293
suitable volumes (see Transfer files) 311
Task window 283, 327
Tasks 328
Transfer files 310, 311
Transfer Volume 283
Volume browsers 282
volume database file 284
volumes 284
WaveCache 284
waveform display 303
Workspace browser 282, 318, 320

DigiDelivery 389
DigiGroove templates 665
digital clipping 438
digital mastering 1096
DigiTest 60
Disable “Input” When Disarming Track (In “Stop”) 

option 127
discrete signal control 1110
Disk Allocation 453

and cross-platform sessions 454
and system volume 455
window 453

Disk Cache meter 81
Disk Processing Activity 81
Disk Space window 452
Display (Group List) command 258
Display Events as Modified by Real-Time 
Properties option 137, 715

display in browsers 292
Display Preferences 121

Clip Hold options 122
Draw Grids in Edit Window option 541
Language options 122
Peak Hold options 122

displaying
all rulers 769
clip names 531
clip times 531
file info for audio clips 270
Meter Ruler 797
Original Time Stamps 1163
Tempo ruler 775
User Time Stamps 1163

dither
and Bounce to Disk 1082
and fades 620, 985
AudioSuite 985
on Master Faders 1082
preferences 985
resolution and Bounce to Disk 1089

Dither Mixer plug-ins 985
Dither Plug-In preference 134
divergence

drawing 1133
using 1132

Double-Clicking a MIDI Clip Opens option 137
drag and drop

from the Clip List to tracks 824, 825
importing audio files 335
importing MIDI files 349

Drag and Drop From Desktop Conforms to Session 
Tempo options 135, 344

Draw Grids in Edit Window option 541
DSP

active and inactive items 22
and inactive inputs and outputs 239
and inactive outputs 955
and inactive sends 962
and no output 955
and overall resources 21
and Send meters 961

DSP delays
automatic compensation 67

DSP usage meters 82
dubber

preference to emulate 127, 504
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Duplicate command 844
Duplicate Group command 258
Duplicate Track command 225, 235, 1023
duplicating

inserts 998
MIDI note selections 845
playlists 634
selections and clips 845
sends 962

Duration
Real-Time Properties 711

durations, for MIDI notes
editing with Change Duration command 927
making more legato 929
making more staccato 928
randomizing 928

DV
and sync offset 1191

DV Stream 1170
DV25 Movies

playback through FireWire 1190
Dynamic Transport mode 429
Dynamically Allocated Voicing 242
Dynamics plug-ins 989

E
Edit commands 534

copy 535
cut 535
paste 536

edit cursor 420
and scrubbing 564
moving to clip boundaries 579
placing with the Selector tool 559

Edit Groups 260
and selections 571

Edit Insertion Follows Scrub/Shuttle option 124, 564
Edit insertion point

placing clips at 825
trimming clips to 597

Edit Markers 570
and selection length 575

Edit menu 206
Change Edit to Match Timeline command 582
Change Timeline to Match Edit command 582
Clear command 536
Clear Special commands 1056
Consolidate command 611
Copy command 535
Copy Special commands (automation) 1056
Pro Tools Reference Guide
Copy to Send command 1037
Create Fades command 625, 626
Cut command 535
Cut Special commands 1055
Delete Fades command 625
Duplicate command 844
Fade To End command 624
Fade To Start command 624
Fades command 616
Heal Separation command 596
Identify Sync Point command 837
Insert Silence command 843
Paste command 536
Play Edit Selection command 427
Play Timeline Selection command 427
Redo command 532
Repeat command 845
Repeat to Fill Selection command 537
Select All command 572
Separate Clip commands 592
Shift command 838
Strip Silence command 840, 841
TCE Edit to Timeline Selection command 612
Thin All Automation command 1047
Thin Automation command 1047
Trim Automation to All Enabled command 

1071
Trim Automation to Current command 1071
Trim Clip End to Fill Selection command 597
Trim Clip End to Insertion command 597
Trim Clip Start to Fill Selection command 597
Trim Clip Start to Insertion command 597
Trim Clip to Fill Selection command 598
Trim Clip to Selection command 596
Undo command 532
Write Automation commands 1069, 1070

Edit mode buttons 183, 539
Edit modes 539

and placing clips 823
Grid 541
Relative Grid 541
Shuffle 539
Shuffle Lock 540
Slip 540
Spot 540, 1160

edit playlists 633
Edit Selection Follows Clip List Selection option 

129, 572
Edit Selection indicators 576



Edit selections
auditioning with Playhead enabled 427
copied from Timeline selection 582
copied to Timeline selection 582
making with the Selector tool 559
sliding in the Ruler 579

edit smoothing, with Beat Detective 671
Edit tools 543

Grabber 543, 573
Pencil 543, 567
Scrubber 543, 563
Selector 420, 543
Smart Tool 543
Trim 543, 554
Zoomer 543, 544

Edit window 181, 182, 183
All View option 951
half-screen 425
None Views option 951
scrolling from the Ruler 583
Universe view 585
View options 183

Edit Window Default Length 187
Edit Window Default Length preference 121
Edit Window Follows Bank Selection option 131
Edit Window option 183
Edit Window View options 951
Edit Window View selector 950
Edit/Tool Mode Keyboard Lock 568
editing

across multiple tracks 537
and Edit modes 539
and Grid modes 834
and hidden tracks 234
and Track View 534
automation 1049
Bar|Beat Markers 796
breakpoints 1051
clips as grid 543
controller events 698
during playback 522
Grid mode 541, 542
in MIDI Event List 762
Markers 816
Memory Locations 816
meter events 799
MIDI clips 528
MIDI notes 686
nondestructive 521
nondestructively for audio 527
nondestructively for MIDI 530
note attributes 694
note durations 927
note velocities 692, 925
program changes 704
Shuffle Lock mode 540
Shuffle mode 539
Slip mode 540
Spot mode 540
tempo events 776
waveforms 526

Editing Preferences 129
Auto-Name Memory Locations While Playing 

option 813
Auto-Name Separated Clips option 593
Clip List Selection Follows Edit Selection 

option 270, 572
Conversion Quality option 334
Crossfade Preference for Pre/Post-Roll option 

129, 622
Edit Selection Follows Clip List Selection 

option 572
QuickPunch Crossfade Length preference 503
Separate Clip Operates On All Related Takes 

option 593
Edit-locking clips 839
Effect Bypass button 1001
effects, printing to disk 1081
Elastic Audio 877

Accordion Warp 896
adding Event markers 900
analysis 886
analysis in DigiBase 303
Analysis view 885, 899
and AudioSuite processing 906
and Edit Groups 899
batch analysis 304
calculating analysis in DigiBase 304
clearing analysis in DigiBase 304
Clipping indicator 888
Clipping indicator (Rendered) 888
committing 884
common workflows 877
Conform to Tempo 780
CPU processing activity 81
creating new tracks 884
deleting Event markers 901
disabling 884
enabling on tracks 883
event confidence 886
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Event markers 893
example workflow 878
Individual Range Warp 897
Monophonic plug-in 891
moving clips between tracks 907
moving Event markers 900
out of range processing 898
pitch shift 904
Plug-In selector in browsers 307
plug-ins 888
Polyphonic plug-in 890
preview at session tempo in browsers 308
promoting Event markers 900
properties 901
quantizing 921
Range Warp 896
Real-Time processing 887
removing pitch shift 906
removing warp 899
Rendered files 888

regenerating 313, 392
Rendered processing 887
Rhythmic plug-in 890
setting to Real-Time or Rendered 887
TCE algorithms 888
Telescoping Warp 895
tempo detection 886
Tempo Event–generated Warp markers 894
tempo-based warping 779
track controls 885
track views 885
tracks 883
transpose 905
Varispeed plug-in 891
Warp indicator 898
Warp markers 893
Warp view 885, 893
warped clips 898
X-Form plug-in 892

Elastic Audio Plug-In Selector 885
Elastic Audio preferences 136
Elastic Audio-enabled tracks 883
Elastic Properties window 901
Eleven Rack 44
Eleven Rack Control window 192
embedded media 27
Enable Dub Window option 143
Enable Elastic Audio on New Tracks preference 

136
Enable Session File Auto Backup option 125
Pro Tools Reference Guide
Enable SYNC Peripheral option 142
enabling

Auto Backup option 125
automation 1044
groups 267
MIDI input devices 482
plug-in automation 1004

End To Insertion command 597
Enforce Avid Compatibility 379
Enforce Mac/PC Compatibility option 173, 396
Entire Selection mode 866
EQ plug-ins 989
equal gain crossfades 620
equal power crossfades 619, 622
error suppression 64
Ethernet Controllers 146
EUCON 147, 986, 1021
Event Edit Area 694
Event menu 206

All MIDI Notes Off command 708
Beat Detective command 655
Change Meter command 798
Event commands 909
Identify Beat command 794
MIDI commands 909
MIDI Event List 757
MIDI Track Offsets command 707
Remove Duplicate Notes command 708
Renumber Bars command 806
Tempo commands 788
Time commands 800

Event Operations commands 909
Change Duration command 927
Change Velocity command 925
Flatten Performance command 924
Input Quantize command 933
Quantize command 910
Restore Performance command 923
Select/Split Notes command 932
Step Input command 934
Transpose command 929

Event Operations window 909, 910
Exit command (Windows) 177
Expand Channels to New Playlists 649
Expand to New Tracks command 236
Expanded Transport View 204, 466
explicit voice allocation 242
Export 381

OMF/AAF Options 378
Sample Rate Conversion Options 380



Export Clip Definitions command 279, 347
Export Clip Groups command 388
Export Clips as Files command 279, 346
Export MIDI command 350
Export MIDI Settings dialog

Apply Real-Time Properties option 350
MIDI File Format pop-up menu 350

export OMF/AAF
Consolidate From Source Media 382
Copy From Source Media 381
Refer To Source Media 381
translation settings 378

Export Selected As Files command 378
Export Selected dialog 346, 378
Export Selected Tracks as OMF/AAF 375
Export Selected Tracks as OMF/AAF command 

373, 375
Export Session Info as Text command 384
Export Settings button (I/O Setup) 115
exporting 332

AAF files 373
audio 345
audio from clips 346
clip definitions 347
clip groups 388
markers 350
MIDI tracks 350
OMFI files 373
Score to Sibelius 756
sessions as text 384
Sibelius (.sib) files 756
stereo interleaved files 347

Ext. Clock Output 74, 1140
extending selections 576, 784

to adjacent tracks 577, 578
to clip boundaries 576
to include adjacent clips 576
to Markers and Memory Locations 576
to next tempo event 784

external clock source 1019
External MIDI instrument

recording audio from 497
external side-chain processing 1004
External Timecode Offsets 1146
extrapolation 666

F
factory I/O settings 113
Fade Files folder 165
Fade To End command 624
Fade To Start command 624
fade-in shapes 620
fade-out shapes 618
fades 623

and dither options 985
auto-fades 626
creating 623
creating with Smart Tool 561
in batches 627
moving 628
nudging 628
with dither 620

Fades command 616
Fades dialog 616

In Shape 620
Link option 619
Out Shape 618
Use Dither option 620

Fast Forward
incrementally 421
locating with 421

Fast Forward button 188
Feet.Frames Time Scale 768
Feet+Frame Rate setting 1143
Feet+Frames

redefining position 1149
field recorder

expanding alternate channels to new playlists 
649

importing monophonic audio files 342
importing polyphonic audio files 342

file formats (audio) 1086
AIFF 1086
BWF (.WAV) 1086
MP3 1086
MXF 1088
QuickTime 1088
Sound Designer II 1086

file management 391
File menu 206

Bounce to Disk command 1084
Close Session command 177
Exit command (Windows) 177
Export MIDI command 350
Export Selected Tracks as OMF/AAF 

command 373
Export Session Info as Text command 384
Import Audio to Track command 338
Import Clip Groups command 387
Open Session command 166
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Revert to Saved command 169
Save As command 170
Save command 169
Save Copy In command 170, 397
Send via DigiDelivery 389
Send via DigiDelivery command 389

File Mode selector 865
files

Clip Name 324
final mixdown 1095
Find All Candidates 315
Find Clip List command 272
Find Clips

By Name 272
Include Subsequently Added Clips 272

Find History 273
Find Matching Tracks option 358
finding clips 272

Find History 273
FireWire

QuickTime DV25 playback 1190
First Selected MIDI Track option 137
Flatten Performance command 909, 924
folders

creating and opening 288
footswitch 73
Force Audio Media to Target Session Format 366
foreground 287
Forward and Play command 422
Forward command 422
frame rate

pull up and pull down 1150
Frames 1174
Frames View

video track 1174
freewheeling timecode 1146
Front Divergence 1132
Front/Rear Divergence 1132

G
generating timecode 1154
Glide Automation commands 1057
global (system-wide) preferences 120
Global MIDI Playback Offset preference 137, 707
Go to End button 188
Grabber tool

editing clip gain breakpoints with 605
Grabber tools 543, 560, 573, 688

editing breakpoints with 784, 1050
Object Grabber tool 560, 573
Pro Tools Reference Guide
selecting MIDI notes with 686
Separation Grabber tool 560, 594
Time Grabber tool 560

Grid mode 541, 834
Absolute 541, 834
Clips/Markers option 543
configuring 542
Draw Grids in Edit Window option 541
Relative 541, 834
setting the Grid value 833
suspending 834
with Slip, Shuffle, or Spot enabled 542

grid panners in Mix and Edit 1124
Grid value 681, 833

setting for MIDI editing 681
Grid Value selector 542
Groove Quantize 916
groove templates 665, 917

applying 919
mapping 920

Group 258
Group Assignment selector 945
Group ID indicator 258
Group List 257

hiding 257
Keyboard Focus 30
pop-up menu 258
showing 257

Group Name 258
Group Track command 260, 261
groups

and automation editing 1053
and hidden tracks 234
attributes 264
control offsets 268
creating 260
deleting 263
duplicating 264
Edit Groups 260
enabling 267
keyboard selection 267
linking Mix and Edit Groups 256
Mix Groups 260
modifying 262
renaming 262
unlinking Mix and Edit Groups 256

Groups dialog 259
guitar tablature 810



H
H/W Buffer Size 459
H/W Insert Delay 90
half-screen 425
half-speed playback 428
half-speed recording 480
hard drives

and Compacting Audio 611
recording to system volume 455
Round Robin Allocation 454

Hardware Buffer Size 10, 60, 62
hardware I/O inserts 990

delays 90
hardware I/O sends 959
Hardware Insert Delay Compensation 90, 983
Hardware Setup

Buffer Size 459
Ext. Clock Output 74
selecting multiple outputs 80

HD Accel 46
HD Core card 46
HD I/O 48, 52

Analog Expansion cards 52
analog I/O 52
configurations 52
Digital Expansion cards 52
Digital I/O 52
synchronization 52

HD MADI 48, 53
HD OMNI 48, 51

Analog I/O 51
configuring Hardware Setup 75
Digital I/O 51
features 51
Monitoring 52
synchronization 52

HD Process card 46
Heal Separation command 596
HEAT

import Master Settings 360
HEAT (Harmonically Enhanced Algorithm 

Technology) 55
Help 206
help

Bounce to Disk 1094
Tool Tips 121, 208

Help menu 29, 206
HFS+ Disk Support option 394
HFS+ drives

and Windows systems 395
hidden tracks
and group edits 234
and groups 234
and selections 571

Hide All Floating Windows command 201
Hide and Make Inactive Track command 235
Hide/Show Track command 235
hiding

all tracks 234
auto-created clips 278
tracks 233

High Quality QuickTime Image option 126
history (Find clips) 273
Horizontal Position setting 143
Horizontal Zoom In button 544
Horizontal Zoom Out button 544
Host Engine 64
Host Processors setting 63

I
I/O Settings 113
I/O Setup 85

and surround sessions 1103
Bus page 89
configuring I/O routing 97
controls 91
creating paths 101
creating sub-paths 103
customizing 96
dialog 86
displaying unavailable I/O 117
factory settings files 113
H/W Insert Delay page 90
importing for surround 1105
Input page 88
Insert page 90
last used 115
Low Latency Monitoring 95
Mic Preamps 90
options 92
Output page 89
resizing 86
settings files 113
surround mix examples 1117
surround mix settings file 113

I/O View 217, 952
Identify Beat command 794, 795
Identify Sync Point command 837, 1164
Idle MTC Enabled option 142
Ignore Errors During Playback/Record option 65
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Ignore Track Arming option 139
illegal characters 167, 393
Import

Audio Media Options 365
Sample Rate Conversion Options 368
Timecode Mapping Options 367

Import as Offline Satellite Media 356, 366
Import Audio dialog 338
Import Audio to Track command 338
Import Clip Groups command 387
Import HEAT Master Settings 360
Import Key Signature Map option 360
Import Marker/Memory Locations 360
Import MIDI 348
Import Rendered Audio Effects 369
Import REX Files as Clip Groups option 135, 343
Import Session Data

Text Encoding 355
Import Session Data command 352
Import Session Data dialog 354
Import Settings button (I/O Setup) 114
Import Settings command (plug-ins) 1005
Import Video command 1178
Import Volume Automation 369
Import Window Configurations 360
importing 331

audio 333
audio and Conversion Quality 334
clip groups 387
copying during 354
HEAT Master Settings 360
key signature map 360
Marker/Memory Locations 360
Markers 349
MIDI tracks 348
multichannel audio files from a field recorder 

342
multichannel I/O Settings 1105
offline items from Catalogs 326
plug-in settings 1007
Pre settings 360
QuickTime audio 1180
reference or copy 354
tempo and meter map 360
tracks for other sessions 352
using drag and drop 335
Window Configurations 360

inactive 22, 23
inputs 239
inserts 993
Pro Tools Reference Guide
Master Faders and assignments 943
outputs 239
paths 107
paths, global 107
sends 962
track path assignments 239
tracks 251

Include Control Changes in Undo Queue option 133
Include Sends in Trim Mode option 133
Incoming Time display 1143
Infinite Clip Hold option 122, 219
Infinite Peak Hold option 122, 219
in-place auditioning 275
input connections 18, 438
Input Devices command 482
Input Filter command 484

MIDI Event List View Filter dialog 759
MIDI Input Filter dialog 484

input levels 438
Input Only Monitoring mode 456, 457
Input Path selector 217, 236
Input Quantize command 909, 933
Input selectors 236
Insert Position selector 999
Insert Silence command 843

and Shuffle mode 844
and Slip mode 844

Insert Time command 800, 802
inserting

controller events 698
events in MIDI Event List 760
meter events 798
MIDI notes 684
plug-ins on tracks 994
program changes 703
tempo events 775

Insertion Follows Playback option 124, 431
inserts 948, 989

as a shared bus 990
duplicating 998
for hardware I/O 990
for plug-ins 989
hardware insert delays 90
labeling 1017
making inactive (and active) 993
mono 990
moving 998
on single tracks 990
post-fader on Master Faders 942, 989
shared within a submix 973



stereo 990
Inserts A–E View options 949
Inserts F–J View options 949
Inserts View 952
Instrument plug-in

recording audio from 496
Instrument tracks 210

and surround mixing 1113
channel strips 213
Clips View 226
configuring for recording 486
MIDI Input selector 247
MIDI Output selector 247
monitoring and mixing 970
Notes View 226
signal flow 944
track controls 216

Instruments View 951
Interchange Workflow

Embedded Media 27
linked media 28

interleaved audio file 164
interleaved option (sessions) 164, 1143
Internal mode (Clock Source option) 1142
internal side-chain processing 1004
Inverse linked panning 967
Items To Copy

Preserve Folder Hierarchy 174
Items to Copy 173

J
Jam Sync 1147
Join command 1025

K
key input 999, 1004
Key Input selector 868, 999
key signature map

importing 360
Keyboard Focus 29

Clip List 30, 274
Commands 30
Group List 30

keyboard shortcuts 1003
global key commands 29
numeric entry 577
recording 464

Knowledge Base 206
L
labeling

inserts and sends 1017
Language options 122
Last Used 115
Latch automation mode 1025

AutoJoin 1025
Join 1025

Latch option 249
Latch Record Enable Buttons option 126
Latch Trim automation mode 1028
Latching Behavior for Switch Controls in “Touch” 

option 132
latency

Hardware Buffer Size 62
LCRS path examples 1106
length, for selections 574
level faders

sends 956
Level meters

for audio tracks 219
for Aux Input, Master Fader, and Instrument 

tracks 219
Levels of Undo preference 130, 533
LFE

enable in plug-ins 1134
example sub-path 1119
examples of discrete versus contribution 1120
faders 1134

Librarian menu 999
Limit Character Set option 173
Linear command (Tempo Operations) 789
linear crossfades 621
Linear Sample Display 787
Linear Tick Display 787
Linearity Display Mode 787
Link Enable buttons 1001

in multi-mono plug-ins 1114
Link Mix and Edit Group Enables option 131
Link Record and Play Faders option 126, 458
Link Selection button 569, 571
Link Timeline and Edit Selection option 569
Link to Source Media (Video) 356, 366
Link Track and Edit Selection option 224, 570
linked media 28
linking

inverse panning 967
multi-mono plug-ins 1114
plug-in controls 1017
stereo panners 967, 1128
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local (current session) preferences 120
Local Control 12, 483
locating

the playback cursor 420
with Fast Forward/Rewind 421
with Location indicators 583

Location indicators 583
locating with 583

locations, for MIDI notes
dragging 689
quantizing 914
randomizing 913, 916

Locators to Import 369
Lock Clip command 839
Lock Settings File command 1005
locked clips and AudioSuite rendering 871
Locked indicator 1145
Locked Track command 235
Loop Playback option 428

and Touch mode 1034
loop points 464

Timeline Selection Markers 465
Loop Record mode 446, 474
loop recording

and pre/post-roll 473
audio 473
MIDI 491

multiple takes 493
Loop Trim tool 557

creating loops 557
looped clips 847

copying and pasting automation 851
creating 848
editing 849
selecting 849
trimming with Loop Trim tool 558, 559
unlooping 849

looping
clips 847
playback 428
selections 428

loops
creating with the Loop Trim tool 557
recording with reverb or delay 1084

low latency monitoring
Bounce to Disk 460
Low Latency Monitoring path 95

Low Latency Monitoring option 459
LTC Output Level setting 142
Pro Tools Reference Guide
M
Mac sessions

compatibility with Windows 396
Machine Chases Memory Location option 138, 1158
Machine Control 143
Machine Cues Intelligently option 138
Machine Follows Edit Insertion/Scrub option 138, 

1158
Machine Track Arming window 1159
MachineControl option 56
Main Counters 770
main paths 86
Main Time Scale 770, 1149
Main Timebase ruler 770
Make Active command 251
Make Active/Inactive Track command 235
Make Inactive command 251
making an Edit selection 559
managing clips 276
Manual Tempo mode 191, 443
Manually Find and Relink 392
mapping paths in I/O Setup 107
Marker/Memory Locations

importing 360
Markers 369, 814

creating 811
creating on the fly 813
deleting 818
editing 816
exporting 350
extending selections to 576
importing 349
moving 817
sorting 820
tick-based and sample-based 815
viewing options 819

Markers ruler 769, 814
Marketplace

Plug-ins 196
Support and Training 196
Upgrades 196
Your Account 196

Marketplace menu 196
Master Faders 942

as a stereo master volume control 943
as master send level control 976
channel strips 212
inactive 943
inserts 989
meters pre/post fader 943



multichannel 1113
post-fader inserts 942
signal flow 942
track controls 214
trimming the input to a submix 943

Master Link button 1001
in multi-mono plug-ins 1114

Master View for tracks 230, 1054
mastering

digitally 1096
to disk 1095

Matches 646
Matches (alternate takes) 475, 646
Matching Criteria window 476, 645
M-Audio Control Panel 71
Mbox (3rd generation) 44
Mbox 2 44
Mbox 2 Micro 44
Mbox 2 Mini 44
Mbox 2 Pro 44
Mbox Mini 44
Mbox Pro 44
measures

renumbering 806
media data 24
Memory Locations 811, 815

creating 811
creating on the fly 813
deleting 818
deleting all 818
editing 816
extending selections to 576
Markers 814
recalling 816
recalling Edit selections 468
renaming 816
Selection Memory Locations 814
storing Edit selections 467

Memory Locations window 814, 816
View Filter 821
viewing options for Markers 819

Merge mode (see MIDI Merge mode)
metadata 25, 1197
meter

current 797
default 442
display 190

Meter button 443
meter events 797

editing 799
inserting 798
meter map

importing 360
Meter Path selector 93
Meter Ruler

displaying 797
extending an Edit selection to 799

meters
and control surfaces 93
for MIDI tracks 219
pre/post fader levels 219
Sends View 961
SurroundScope plug-in 1135

Meters options 122
Metronome button 441
Metronome Click button 190
Mic Preamps

configuring 147
I/O Setup 90

Mic Preamps View 951
MIDI 11

assigning channels 246
channels 12
common misconceptions 12
configuring MIDI setup 69
consolidating notes 691
control surfaces 12
controller devices 12
controller events 697
Default Thru Instrument 483
devices 11
editing in a MIDI Editor window 729
import by drag and drop 349
importing 348
interface 11
Local Control 12
loop recording 491
muting notes 691
offsets 707
patch name files (.midnam) 701
patch names 701
playing back 418
ports 12
select and split notes 931
separating notes 690
setting the Grid value for editing 681
setup (Mac) 151
setup (Windows) 154
signal paths 13

MIDI Beat Clock 433
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offsets 434
transmitting 433
transmitting over IAC 434

MIDI clips 527
and Clip List 269
and controller events 528
and punch recording 491
created on barlines 488
guidelines for editing 528

MIDI controller devices 481
Local Control 483

MIDI Controllers 145
MIDI Editor

Automation lanes 734
Controller lanes 734
editing MIDI notes 729
Notation View 732
Superimposed Notes View 727
Velocity lane 734

MIDI Editor view (in the Edit window) 191
MIDI Editor windows 717
MIDI Event List 757

deleting events 763
editing events 762
inserting events 760
navigating in 759
Options menu 764
selecting events 763
View Filter 758

MIDI File Format pop-up menu 350
MIDI files (see Standard MIDI Files)
MIDI I/O 55
MIDI Input selector 217, 245

Instrument track 247
MIDI Machine Control (MMC) 1155

configuring in Pro Tools 1156, 1157
controlling external devices with 1155
Master settings 143
Slave settings 144

MIDI Merge mode 190, 447, 485
MIDI meter 219
MIDI Note Color Shows Velocity option 123
MIDI Note Display options 137
MIDI notes

attributes for 694
auditioning with the mini-keyboard 687
chasing 706
deleting 695
duplicating selected 845
editing 686
Pro Tools Reference Guide
durations 927
pitch 688
velocities 692, 925

inserting 684
lengths in ticks 772
moving 689
quantizing 916
scrolling 529
selecting 686
selecting with the mini-keyboard 687
splitting 931
transposing 688, 929
trimming start/end points 689

MIDI Operations window 909
MIDI Output selector 217, 246

Instrument track 247
MIDI Preferences 136

Global MIDI Playback Offset preference 707
Pencil Tool Resolution When Drawing 

Controller Data option 137, 698, 1048
MIDI Preferences page 136
MIDI Real-Time Properties 709

on tracks and clips 714
settings 711

MIDI recording 481
cancelling takes 489
enabling input devices 482
Input Filter 484
Merge/Replace mode 485
monitoring with MIDI Thru 483
quantizing on input 484, 933
System Exclusive data 494
undoing a take 489
Wait for Note 484

MIDI Replace mode 190, 447, 485
MIDI Setup commands

Input Devices command 482
Input Filter command 484
MIDI Beat Clock command 433

MIDI Studio Setup 69
MIDI Studio Setup (MSS) (Windows) 154
MIDI Studio Setup window 702
MIDI Thru command 483
MIDI Timecode (MTC)

Idle MTC Output 142
MIDI Track Offsets command 707
MIDI tracks

and MIDI offsets 707
assigning to multiple channels 486
channel strips 213



Clips View 226, 227, 527
configuring for recording 486
default program change 700
input 245
loop recording 491
note chasing 706
Notes View 226, 227, 529
output 246
punch recording 489
punching on the fly 490
recording 481
selecting a pitch range in 932
Sysex View 705
track controls 215
Velocity View 692

MIDI Volume fader 218
MIDI Zoom In button 545
MIDI Zoom Out button 545
mini-keyboard 687
Minimize Additional I/O Latency option 65
Minimum Sync Delay option 139, 1159
Minutes:Seconds Time Scale 768
Mirror MIDI Editing 681
missing files 392

skipping 312
mix buses 398, 959
Mix Groups 260
Mix window 180, 181

All View option 180, 951
None Views option 951
track controls 180
track width 220

Mix Window Follows Bank Selection option 131
Mix Window option 180
Mix Window View options 951
Mix Window View selector 950
mixed audio file formats 164
mixed bit depths 172
mixed file types 172
mixing down to stereo 1095
Mixing Preferences 130

AutoMatch Time preference 133
Mixing Preferences page

Touch Timeout option 132
MMC (see MIDI Machine Control)
Modify Group command 258
Modify Groups (Group List) command 258
Momentary Solo Latch option 249
monitoring

during punch recording 471
MIDI recording with MIDI Thru 483
monitoring modes 456

Auto Input 456
Input Only 456

mono
inserts 990
paths 103

mono in/stereo out 990
Move Song Start command 800, 805
moving

Bar|Beat Markers 795
clips with fades 628
fades 628
inserts 998
Markers 817
MIDI notes 689
program changes 704
sysex events 705

MP3 file format 1086
importing 333

MTC (MIDI Timecode)
outputting 1146

MTC Generator Port setting 141
MTC Reader Port setting 141
Multi-Cam Resolution files 363
multichannel clips 523
multichannel plug-ins 990, 1114
multichannel tracks 461

and automation 1052
dragging clips to 602
names for 449
replacing clips in 835
splitting 601

multilingual application support 405
multi-mono

plug-in Channel selector 1114
plug-ins 990, 1113

multi-mono audio files 164
multiple outputs

Hardware Setup 80
multiple tracks

and Beat Detective 668
audition takes 476, 647
editing across 537
extending selections to 577, 578
fitting audio clips to Edit selection 613
nudging clips in 599
pasting to 538
selecting 577
separating clips on 594
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shuffling clips on 828
multitimbral 12
Mute Audio Inputs in Auto Input option 517
Mute automation 1051
Mute button 250
Mute Frees Assigned Voice option 250
Mute Overwrite/Extend 1066
Mute Record-Armed Tracks While Stopped option 

127, 517
Mute/Unmute Clip command 840
muted clips and AudioSuite processing 871
muting

clips 840
MIDI notes 691
tracks 250

MXF format 333, 1088

N
Narrow Mix View option 220
navigating 286
New Group (Group List) command 258
New Memory Location dialog 467
New Paths dialog 102
New Session command 115, 162
New Track command 221, 235
New Track Default Output selector 94
New Tracks Default To Tick Timebase option 129, 

345
New Tracks dialog 221
Next Setting button 1000
No Clip Hold option 122, 219
No Output

by deleting paths 106
No Output option 955
No Peak Hold option 122, 219
no scrolling during playback 424
noncontiguous selections 573
nondestructive editing 521

for audio 527
for MIDI 530

Nondestructive Record mode 445
nondestructive recording 471

recording to a new playlist 472
with QuickPunch 502

nonlinear 9
Non-Linear Transport Error Suppression option 139
non-real-time plug-ins 863
Normal Zoom mode 547, 736
Notation

in MIDI Editor windows 732
Pro Tools Reference Guide
Notation Display Track settings 746
Note Chasing option 706
Note Selector tool 687
notes (see MIDI notes)
Notes report 167
Notes View 226, 227, 529

MIDI and Instrument tracks 529
mini-keyboard 529
scrolling up or down 529

Nudge value 599
trimming clips by 598
trimming MIDI notes by 690

nudging 598
by next Nudge value 600
clip contents 600
clips with fades 628
fades 628
multiple clips 599
selection range 575
selection start/end points 575
selections and clips 599
setting the Nudge value 599

Number of Voices setting 65
numeric entry

shortcuts 577
Numeric Keypad modes 31, 125

Classic 32, 125
Shuttle 33, 125, 566
Transport 32, 125
Use Separate Play and Stop Keys 125

O
Object Grabber 573

and Edit Groups 573
Object Grabber tool 560
Object Select in Edit Window command 279
Object selections 573
offline

clips 523
files, selecting in DigiBase 290

OMF
embedded media 27
import translation settings 369
linked media 28
media data 24
metadata 25, 1197
opening in Pro Tools 362
publishing options 382

OMF file format 361



OMF/AAF Options
on export 378

OMFI file format 373
On Stop 1062
Online button 187
Online options 128
online recording 1154
on-the-fly punch recording

MIDI tracks 490
QuickPunch 446, 505

Open Ended Record Allocation preference 455
Open Session command 166
Open Unresourced TDM Plug-Ins as RTAS 

preference 136
Opening an AAF sequence in Pro Tools 362
Opening an OMF sequence in Pro Tools 362
opening multiple plug-in windows 1002
Operation Preferences 124

Audio During Fast Forward/Rewind option 421
Clip Auto Fade In/Out Length preference 627
Edit Insertion Follows Scrub/Shuttle option 564
Link Record and Play Faders option 458
Machine Chases Memory Location option 1158
Machine Follows Edit Insertion/Scrub option 

1158
Open Ended Record Allocation preference 455
Record Online option 1154
Use F11 for Wait for Note 485

Operation/Destination Track pop-up menus 357
Operations menu

Calibration Mode command 439
Link Timeline and Edit Selection option 569
Link Track and Edit Selection 224, 570
Low Latency Monitoring option 459

Options menu 206
Auto-Spot Clips command 1162
Delay Compensation option 977
Destructive Record mode 472
Link Track and Edit Selection option 224, 570
Loop Playback option 428
Loop Record mode 474
MIDI Thru command 483
Mirror MIDI Editing command 681
Mute Frees Assigned Voice option 250
Pre/Post Roll option 469
Pre-Fader Metering option 219
Scrolling options 424
Solo Latch options 249
Transport Online command 1153
Video Out FireWire Port command 1190
Video Out PCIe command 1192
OR (DigiBase search modifier) 301
Organize Plug-In Menus By option 121, 995
Original Time Stamp 833, 1163
Other Playlists menu 634
Output Options

Conversion Quality option 1090
Sample Rate 1089

Output Path selector 217, 237
Output Window button 1125
Output windows 954
outputs

assigning multiple outputs 954
default 5.1 paths and sub-paths 1104
format and tracks 1111
to multichannel paths 1112

overlap crossfades 622
overlapping paths 109
Overwrite File command 866

P
P (Playback Only volumes) 319
Page Scrolling option 424, 723, 742
Pan automation 1050
Pan Depth 949
Pan indicator 218
Pan Odd Tracks Left/Even Tracks Right 369
Pan slider 218
panning

3-knob 1130
automation and groups 1053
fine-adjust mode 1130
grids 1124
guidelines 1117, 1119
linked stereo 967, 1128
multichannel automation playlists 1135
take over in grid 1129
trajectory 1131
Use Absolute Pan Linking option 131
X/Y mode 1129

Parabolic command (Tempo Operations) 790
parallel mixing 1111
pass-through point 1024
Paste command 536
Paste Settings command 1005
Paste Special commands (automation) 1056
pasting

automation 1056
multiple data types 538
plug-in settings 1007
Index 1245
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selections and clips 536
to multiple tracks 538
with Repeat to Fill Selection command 537

Patch Select button 700
Patch Select dialog 700
paths 86

active and inactive 107
audition 93
creating 101
creating multichannel 1105
customizing 104
default mono and stereo 104
default order 95
default output 94
deleting 106
editing 104
for surround 1115
last used 115
main 86
mapping 107
mono versus stereo 103
multichannel example 108
overlapping 109
reordering 106
selecting 106
sub-path surround examples 1118
sub-paths 86

PCI bus activity 81
PCIe video card

QuickTime HD playback 1192
Peak Hold options 122

3 Second 219
Infinite 219
None 219

Peak indicator 217
Peak On All Chans/Tracks mode 867
Peak On Each Chan/Track mode 867
Peak view 524
PEC/Direct Style Input Monitoring option 127
Pencil tool 543, 567, 682

as Eraser 695
drawing automation with 1048
editing breakpoints with 1050
editing clip gain with 606
Free Hand 682
inserting MIDI notes with 684
Line 683

Tempo editing 782
Random 683
repairing waveforms with 567
Pro Tools Reference Guide
resolution for inserted controller events 698
selecting the Pencil tool shape 682
shapes 682, 1048
Square 683
Triangle 683

Pencil Tool Resolution When Drawing Controller 
Data option 137, 698, 1048

pending tasks 329
Performance Volume 283
Peripherals

Ethernet controllers 146
Machine Control 143
MIDI Controllers 145
PRE 147
Satellites 148
Synchronization 141
VENUE 149

Peripherals dialog 141, 481
Peripherals list 73, 74
personalities 987
PFL (Pre Fader Listen) 248
Pitch Memory Enabled option 142
pitch shifting 904
pitch, for MIDI notes

transposing 688
transposing with Transpose command 929

Play button 188
Play Edit Selection command 426, 427
Play MIDI Notes When Editing option 679
Play Start Follows Timeline Selection option 124
Play Start Marker Follows Timeline Selection option 

431
Play Timeline Selection command 426, 427
playback

audio 417
MIDI 418
no scrolling 424
starting 417
stopping 417

playback cursor 419
Playback Cursor locator 420
Playback Engine 60

Cache Size 68
CPU Usage Limit 64
Delay Compensation 67
H/W Buffer Size 62
Host Engine 64
Host Processors setting 63
Minimize system memory allocation 67
Number of Voices 65



Plug-In Streaming Buffer Size 68
Plug-in Streaming Buffer Size 69
Sample Rate 66

Playhead 425, 723
and Edit selections 427
and Timeline selections 427
moving to clip boundaries 427

playing
and on-the-fly selections 573
at half-speed 428
audio 417
Edit selections with Playhead enabled 427
from a track point 421
MIDI 418
selections 425
Timeline selections with Playhead enabled 427
tracks 417, 462

Playlist command 865
Playlist lanes 639
Playlist selector 17, 633
playlists 17, 633

adding new 634
and groups 635
and multichannel tracks 1052
and nondestructive MIDI editing 530
assigning 634
automation playlists 633, 1022, 1030
auto-naming 633
changing timebase of 773
deleting 635
duplicating 634
edit playlists 633
Playlist selector 633
recalling 634
recording to new 473
renaming 635
setting pre/post-roll in 469

Playlists view 639
plug-in controls

adjusting 1003
linking 1017

Plug-In Controls Default to Auto-Enabled option 132
plug-in inserts 989
plug-in maps 1010

creating 1012
deleting 1014
importing and exporting 1016
Learn mode 1010
managing 1014
setting default 1015
Plug-In selector
for AudioSuite plug-ins 864
for real-time plug-ins 999

plug-in settings
creating User Default 1007

Plug-In Settings menu 999
Plug-in Settings menu 1005
Plug-In Settings Select button 1000
Plug-In Streaming Buffer 69
Plug-In Streaming Buffer Size 68
Plug-in Streaming Buffer Size 69
plug-in window

closing multiple windows 1002
opening multiple windows 1002

plug-ins
and pull rates 1153
and surround mixing 1113
automating 1037
automation accuracy in bounce 1091
bypassing from window 1016
Category 995
Category and Manufacturer 996
Channel selector for multi-mono 1114
creating a default setting 1007
enabling for automation 1004, 1038, 1039
favorites 997
Flat List 995
for surround 1114
Host Processors setting 63
inserting on tracks 994
Librarian menu 999
linking and unlinking 1017, 1114
Manufacturer 996
mono-to-stereo 990
multichannel 990
multi-mono 990, 1113
multiprocessors 63
Next Setting button 1000
Organize Plug-In Menus By command 995
Plug-In Settings menu 999
Plug-In Settings Select button 1000
presets 1005
Previous Setting button 1000
removing from tracks 994

pops, avoiding 480
post crossfades 616, 626
Post-Roll button 189
Power view 524
Index 1247
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PRE 55
configuring 147
I/O Setup 90

pre crossfades 616, 626
Pre Fader Listen mode 248
PRE settings

importing 360
Pre/Post Fader button 968
Pre/Post Roll option 469
pre/post-fader inserts 989
pre/post-roll

and loop recording 473
and punch recording 470
auditioning 426
setting 468

Pre/Post-Roll Flags 469, 570
Pre-Fader Metering option 219
Preferences

Automatically Copy Files on Import option 354
DestructivePunch 503
DestructivePunch File Length 512
Mute Audio Inputs in Auto Input 517
Mute Record-Armed Tracks While Stopped 

517
Pause during Playback 329
Tool Tips Display 208
TrackInput 458
TrackPunch 503
Zoom Toggle 130

preferences
changing 119
global 120
local 120

Preferences dialog 119
Prepare DPE Tracks 512
Pre-Process using Standard Conform 671
Pre-Roll button 189
Preserve Fades when Editing option 129
Preserve Folder Hierarchy command 174
presets

plug-in maps 1010
plug-ins 1005

preview
AudioSuite processing 868
in context 309
reserving voices 309
voice requirements 309

Preview Volume
AudioSuite 869
Pro Tools Reference Guide
previewing
audio in browsers 305
clips in the Clip List 275

Previous Setting button 1000
Prime for Playback mode (Play Pause) 428
Prime for Record mode (Record Pause) 464
Print Score 756
Pro Tools

Additional Software Options 206
Check For Updates 206
file management 391
guides 3, 4
Help 206
Knowledge Base 206
main menus 206
session file 165
session file icon 14
systems 43
video track 1174
Web browsers 195

Pro Tools and Avid terms 26
Pro Tools HD

capabilities with HD Native hardware 43, 47
capabilities with Pro Tools|HD hardware 45

Pro Tools Help command 197
Pro Tools Knowledge Base command 197
Pro Tools menu

Quit command (Mac) 177
Pro Tools Online browser 197
Pro Tools systems

QuickPunch 500
Pro Tools|HD

audio interfaces 50
control surfaces 55
I/O capabilities 50
synchronization peripherals 55
worksurfaces 55

Pro Tools|HD Accel systems 46
Pro Tools|HD systems

QuickPunch 500, 501
Process Mode selector 866
processing

AudioSuite 870
multichannel for AudioSuite 870

processing bandwidth 81
Processing Preferences 134
Program Change dialog 701, 702
program changes 12, 700

and bank select 700
auditioning 704



chasing 706
default, for MIDI tracks 700
deleting 704
editing 704
inserting 703
moving 704

Project browser 322, 392
pull up and pull down

and plug-ins 1153
and rulers 1152
audio 1150
video 1150

pulses-per-frame
Bi-Phase/Tach 142

Punch Capture button 1074
Punch In Frame Offset preference 139
Punch Out Frame Offset preference 139
punch points 464

Timeline Selection Markers 465
Punch Preview button 1073
punch recording

and monitoring 471
and pre/post-roll 470
audio 470
MIDI 489
MIDI on-the-fly 490

Q
Quantize

audio clips 912, 922
Elastic Audio events 913, 921
quantizing clips to grid 601
Real-Time Properties 711

Quantize Clips command
and Grid value 833

Quantize command 909, 910
experimenting with 916

Quantize Edits to Frame Boundaries 379
Quantize to Grid command 601
Quantize window 913
quantizing

MIDI notes 912, 916
MIDI on input 484, 933

Quick Start dialog 159
QuickPunch 446, 500, 505

clip/take numbering 502
crossfades 503
Pro Tools|HD systems 500

QuickPunch Crossfade Length preference 129, 503
QuickTime file formats 1088
QuickTime movies
and Avid video 1190
optimizing for playback 1190
requirements 1170
sync 1191

Quit command (Mac) 177

R
R (Record and Playback volumes) 319
randomizing

note durations 928
note locations 913

Read automation mode 1024
Read Trim automation mode 1027
real-time editing 522
real-time plug-ins 989
Real-Time Properties

clearing 715
clip-based 714
Delay 712
Display Events as Modified by Real-Time 

Properties option 137
Duration 711
enabling 710
in the Edit window 716
in the MIDI Event List 715
on tracks and clips 714
Quantize 711
settings 711
track-based 714
Transpose 713
Velocity 713
View 709
viewing 709
writing to clips 715
writing to tracks 714

Real-Time Properties View 709, 953
Real-Time Properties window 710
Rear Divergence 1132
Recalculate Waveform Overviews command 279
Recall Memory Location Selection at Original Track 

option 129
Record button 188
Record Enable button 450, 507
record modes 445

and MIDI 447
Destructive Record mode 446
Loop Record mode 446
Nondestructive Record mode 445
QuickPunch 446
Index 1249
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Record Online at Insertion/Selection option 128
Record Online at Timecode (or ADAT) Lock option 

128
Record Online option 1154
Record Safe mode 452
recording 461

a mono audio track 461
a stereo audio track 461
a submix to disk 1083
additional takes 471
at half-speed 480
bouncing to disk 1084
cancelling takes 463
configuring Instrument tracks 486
configuring MIDI tracks 486
destructively 472
from a digital source 478
from Record Pause mode 464
keyboard shortcuts 464
Loop Record 474
MIDI clips 488
multichannel tracks 461
multiple audio tracks 463
nondestructively 9, 471
nonlinear 9
online 1154
QuickPunch mode 505
record enabling tracks 450
status LED 507
System Exclusive data 494
to a new playlist 473
to the system volume 455
undoing a take 463
with a count off 441
with Round Robin Allocation 454
with the click 440

Rectified view 524
ReCycle 333
redefining

Feet+Frames position 1149
timecode position 1149

Redo command 532
Ref Present indicator 1145
Refer to Source Audio Media Where Possible 365
Refer To Source Media 381
reference or copy when importing 354
Regenerate Missing Rendered Files 392
Regroup Clip command 853
related takes

and Separate Clip command 593
Pro Tools Reference Guide
Relative Grid mode 541, 834
relinking

Find Links 316
Linking Options 316

Remote Mode options 139
Remove Duplicate Notes command 708
Remove Sync Point command 837
removing

crossfades 625
plug-ins from tracks 994
sends 957

Rename command (Clip List) 279
Rename command Clip List) 277
Rename Track command 235
Renamed Audio Files

save copy in 393
renaming

auto-created clips 276
Memory Locations 816
playlists 635

renaming clips in the Clip List 277
renaming clips on tracks 530
Render Clip Gain command 610
Render Sources 321, 326
Rendered Files folder 165, 888
Renumber Bars command 806
Repeat command 845
Repeat to Fill Selection command 537
repeating selections and clips 845
Replace Clip command 279, 834

and multichannel tracks 835
Replace Clip dialog 836

Replace mode (see MIDI Replace mode)
Reserve Voices For Preview In Context option 124, 

309
Reset Bi-Phase button 143
Restore Performance command 909, 923
Rests (in the Score Editor) 751
Return to Zero button 187
Reveal in Explorer command (Windows) 279
Reveal in Finder command (Mac) 279
Reverse button 869
Revert to Saved command 169
Rewind

incrementally 421
locating with 421

Rewind button 187
REX files 333

importing 341
Root Settings folder 1005, 1006



Round Robin Allocation 454
RTAS plug-ins 991

additional latency 991
voice usage 991

Ruler View options 769
Bars|Beats Time Scale 767
Feet.Frames Time Scale 768
Minutes:Seconds Time Scale 768
Samples Time Scale 768
Timecode Time Scale 768

Ruler View selector 769
rulers

changing display order 769
Conductor rulers 769
displaying all 769
pull up and pull down 1152
scrolling in 583
Timebase rulers 767
zooming in 548

S
safing automation 1030
Sample Offset (Sync Offset) 1146
Sample Rate

Hardware Setup dialog 72
Playback Engine dialog 66

Sample Rate Conversion Options
on export 380
on import 368

Sample Rate Conversion options 357
Sample Rate Conversion Quality 369, 381
sample rate conversion quality 334, 1089, 1181
Sample Rate Conversion Quality preference 135, 

344
Sample Rate Convert Audio 368
Sample Rate setting 1089
sample-based timing 771, 815
Samples Time Scale 768
Satellite Link option 56, 148

preferences 140
Satellites 148
Save As command 170
Save command 169
Save Copy In command 170, 397
saving a copy of a session 170
saving a session 169
saving plug-in settings 1007

Save Plug-In Settings To command 1006
Save Settings As command 1005
Save Settings command 1005
saving the session file with a new name 170
Scale command (Tempo Operations) 792
scaling note velocities 693, 925
Score Editor

chord symbols and diagrams 754
editing in 749
exporting a score 756
opening 736
page controls 744
printing 756
rests 751
zoom controls 745

Score Setup window 747
Scroll Into View command 235
Scroll into View command 224
Scroll to Track Banks Controllers option 131
Scroll To Track command 223, 584
scroll wheel

and MIDI track Note display 529
and MIDI track’s Note display 553
scrolling a Pro Tools window 584
zooming in the Edit window 553
zooming in the Edit windows 553

scrolling
a track into view 224
in the ruler 583
Mix and Edit to tracks 584
Notes View up or down 529, 553
Pro Tools window vertically or horizontally 584

Scrolling options 424
After Playback 424
Center Playhead 425
Continuous Scrolling During Playback 424
None 424
Page 424, 723, 742

Scrub in Video Window command 1186
Scrub Trim tool 557
Scrubber tool 543, 563

in Shuttle mode 565
selecting with 579

scrubbing 563
a single audio track 564
and edit cursor 564
on two audio tracks 564
playback speed and direction 564
resolution 564
video tracks 1186
with Scrub Trim tool 557
with the Selector 564

S-Curve command (Tempo Operations) 791
Index 1251
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SDDS 1102
Secondary Timecode Ruler 768
Select All command 572
Select Clip List options 274
Select Parent in Project browser 322
Select Parent in Workspace command 279
Select Tracks in Group command 258
Select Unused Clips command 278
Select/Split Notes command 909, 931, 932

Split notes action 931
selecting

a pitch range of notes 932
across all tracks 578
across multiple tracks 577
all clips in a track 572
all clips in all tracks 572
clips 571
during playback 573
in MIDI Event List 763
items in browsers 297
MIDI notes 686, 687
noncontiguous clips 573
notes in a chord 933
track material 571
with Edit Selection indicators 577
with Scrubber 579

selecting tracks for AudioSuite processing 872
Selection Changes Alternate Playlists 773
Selection commands

Play Edit Selection 426
Play Timeline 426

Selection Memory Location 814
moving stored selection 817

Selection Reference selector 864
selections

across multiple tracks 571, 577
and Bounce to Disk 1085
and Edit Groups 571
and hidden tracks 571
and Timeline Selection Markers 571
auditioning start and end points 426
changing length of 574
clearing 536
consolidating 611
copying 535
cutting 535
duplicating 845
extending 576, 784
extending to the Meter Ruler 799
extending to the Tempo ruler 777, 818
Pro Tools Reference Guide
including Conductor rulers 578
looping 428
moving to adjacent tracks 578
moving to the next/previous clip 579
non-contiguous 573
nudging 575, 599
nudging start/end points 575
Object 573
on-the-fly 573
pasting 536
playing 425
removing a track from 579
repeating 845
shifting 838
storing with Memory Locations 814

Selector tool 420, 543, 559
making a Timeline selection 560
making an Edit selection 559
placing the edit cursor 559
scrubbing with 564
selecting an entire clip 560
selecting an entire track 560
selecting MIDI notes with 686

Send controls 956
Send mute 956
Send pan 956
Send Pans Default to Follow Main Pan option 131
Send to Back command (Clip menu) 595
Send To Sibelius 756
Send via DigiDelivery command 389
sends 956

adding 956
and multichannel mixing 1112
Assignments View 960
automating 1036
changing default setting 957
copying track automation to 1036
default level 957
displaying controls for 961
for hardware I/O 959
for mix buses 959
labeling 1017
mono or stereo 959
multichannel 1112
removing 957
view options 959

Sends Default to -INF option 131
Sends View 952
Separate Clip commands 592

and multiple tracks 594



and related takes 593
At Selection 592
At Transients 592
On Grid 592

Separate Clip Operates On All Related Takes 
option 129, 593

Separate MIDI notes 690
Separation Grabber 594
Separation Grabber tool 560
session data

importing 352
Session Data Online Status indicator 184
Session Data to Import menu 358
session file 165
Session File Backups folder 166
session parameters 172
Session Setup window 1141
sessions 14

audio format 1143
backups 125, 166
bit depth 163, 1142
closing 177
creating 162
creating for surround mixing 1102
files 14
frame rate 1143
interleaved 164, 1143
interleaved multichannel audio files 164
mixed audio file formats 164
mixed audio formats 172
mixed bit depths 172
multi-mono audio files 164
opening 166
opening from a Transfer volume 167
sample rate 163, 1142
saving 169
start frame 1143
templates 174

Sessions Overwrite Current I/O Setup When 
Opened option 96

Set As User Default command 1006
Set Plug-In Default To command 1006
Set Record Tracks to Auto Input command 457
Set Record Tracks to Input Only command 457
Set Root Settings Folder command 1006
Set Servo Lock Bit at Play option 139
setting punch/loop points 464
settings

choosing a destination for 1006
copying 1007
creating subfolders 1006
pasting 1007
saving 1007
Settings Preferences command 1006

Setup menu 206
Click/Countoff Options dialog 442
Disk Allocation 453
I/O Setup 86
MIDI windows 702
Preferences command 119
Session Setup 1141
Video Sync Offset command 1191

Share with SoundCloud 1091
Shift command 838
Shift dialog 838
shortcuts for keyboard input 1003
Show All Tracks Group command 259
Show Auto-Created option 278
Show Meters in Sends View option 122
Show Only Tracks in Group command 258
Show/Hide Clip List button 269
Show/Hide Track List/Group List View button 232, 

257
Show/Hide Tracks in Group command 258
Shuffle

and locked clips 840
Shuffle Lock mode 540
Shuffle mode 539

and locked clips 839
and moving clips 827

shuttle
fixed mode option 566

Shuttle Numeric Keypad mode 33, 125, 566
Sibelius (.sib) file

exporting 756
Side % (Percentage) 1132
side-chain

definition 1004
filters 1004
processing 999

signal flow
audio tracks 941
Auxiliary Inputs 941
Instrument tracks 944
Master Faders 942

signal paths 86
signal routing

and default path order 95
basics for surround 1112
example 19
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surround examples 1119
Single Zoom mode 548, 737
SIP (Solo In Place) 248
Size setting (for window dub) 143
Skip All 392
slices 654
sliding clips 827
Slip mode 540

and moving clips 831
Smart Tool 543, 561

and audio tracks 561
and Elastic Audio tracks 562
and MIDI tracks 562
and multichannel tracks 563
creating crossfades with 562
creating fades with 561
editing automation with 563
editing controller events with 563

Smooth and Thin Data After Pass option 132, 1047
smoothing automation 1029
SMPTE

configuration 1147
start frame for session 1143

Snap Pan to Speaker icons 1128
Snap To Bar option 798
Snap To commands 829
Snap To Grid 542
snapping to the following or preceding clip 829
snapshot automation 1068

adding to empty automation playlists 1069
and trim values 1071
writing over existing automation 1070

software updates 58
Solo button 248
Solo in Place mode 248
Solo Latch options 249
Solo modes 248
Solo Safe mode 250
soloing

tracks 247
tracks in a submix 976

Song Start Marker 774
editing tempo 775
moving 774

Sony Dynamic Digital Sound (SDDS) 1102
Sort By options 271
sorting

clips 271
data in browsers 293
Markers 820
Pro Tools Reference Guide
secondary sorts 294
Sound Designer II file format 1086
SoundCloud 1091
Source Audio Sample Rate 368, 381
source media 365, 381
Source Path 1085
Special Paste 1056
Speed Cal indicator 1145
split (MIDI) 931
Split Into Mono Track command 235, 601, 1110
split mono audio files 164
Split notes action 931
splitting stereo and multichannel tracks 601
Spot dialog 832, 1160

Use Subframes option 1161
User Time Stamp button 1162

Spot mode 540, 1160
and moving clips 831
trimming clips in 1162

spotting
auto-spotting 1162
clips 832, 1160, 1161

SRC options 357
Standard MIDI Files 348

exporting 350
importing 348
Type 0 348
Type 1 348

Standard VCA Logic for Group Attributes option 133
start frame, for sessions 1143
Start To Insertion command 597
Start, End, and Length display 466
Step Input command 909, 934
stepped control automation 1051
stereo inserts 990
stereo interleaved files, exporting 347
stereo tracks

dragging clips to 602
names for 448
replacing clips in 835
splitting 601

Stop at Shuttle Speed Zero option 138
Stop button 188
Stretch command (Tempo Operations) 793
Strip Silence command 840, 841

and clip naming 841
Strip Silence window 843
stuck notes 708
Sub Counter selectors 771
Sub Time Scale 771, 1149



subfolders, creating for settings 1006
subframes 1161
submixes

applying an insert to 973
bouncing to 1094
bouncing to disk 1083
soloing tracks in 976

sub-paths 86, 103
examples for surround 1116

Suppress Automation “Write To” Warnings option 
132

surround
and sends 1112
basic signal routing 1112
center percentage (%) 1133
configuring Pro Tools 1109
configuring Pro Tools and sessions 1102
discrete level, solo, mute 1110
example 5.1 format paths 1106
importing I/O Settings 1105
pan playlists and automation 1135
panning grids 1124
settings files 1103
side center percentage (%) 1133
using paths 1115
using sub-paths, examples 1116

SurroundScope 1135
Suspend All Groups (Group List) command 258
suspending

automation 1044
writing automation 1044

swing 913, 915
Sync Mode field 1142
Sync Offset 1146
SYNC peripherals

generating timecode with 1154
resolving with 1139
sync options 1140

Sync Point View option 838
sync points 1164

for clips 837
from Beat Detective 672
identifying 837, 1164

Synchronization 141
synchronization 141

black burst 1164
MIDI Beat Clock 433
MMC 1155
options 1139
resolving 1164
troubleshooting 1164
Synchronization Device settings 142
Synchronization Preferences 138
Sysex View 705
system

shutting down 59
starting up 59

System Exclusive data 12, 705
deleting 705
moving 705
recording 494

System Memory Allocation 67
system resources 21
system settings

Cache Size 68
Clock Source system setting 72
CPU Usage Limit 64
Current Engine 61
Hardware Buffer Size 10, 60, 62
Hardware Setup 72
Host Engine 64
Number of Voices 65
Plug-In Streaming Buffer 69
Plug-In Streaming Buffer Size 68
Sample Rate 66
System Memory Allocation 67

System Usage window 81, 82

T
T (Transfer volumes) 319
Tab to Transients button 423, 580
take over (surround pan) 1129
Takes

multiple tracks 476, 647
takes

auditioning 475
default names 448
matching alternates 475, 646
MIDI 494
numbering for QuickPunch 502
recording additional 471
selecting an alternate take 475, 646

tapping in the tempo 444
Target button 1001
Target Project Timecode Format 379
Task Manager 340
tasks

failed 329
grouped 330
paused 328
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pausing during playback 329
pending 329

tasks (DigiBase)
active 328

TC/E Plug-In preference 135
TC/E Plug-in preference 555
TCE Edit to Timeline command 612
TCE Trim tool 555

using in Grid mode 556
using in Slip mode 556
using in Spot mode 556

TDM plug-ins 991
TDM Time Slot usage 82
TDM Voices Allocated 82
templates

Beat Detective 665
DigiGroove 665
Pro Tools session 174

tempo
current 775
default 443
display 191
effects on Markers and Memory Locations 815
Manual Tempo mode 443
tapping in 444

Tempo Edit Density pop-up menu 783
Tempo Editor

zooming 781
Tempo Event Warp markers 780
Tempo Event–generated Warp markers 894
tempo events 775

and Bar|Beat Markers 795
editing 776
extending selections to 784
inserting 775

tempo map
from Identify Beat command 794
importing 360

Tempo Operations commands
Constant command 789
Linear command 789
Parabolic command 790
Scale command 792
S-Curve command 791
Stretch command 793

Tempo Operations window 788
Tempo Resolution selector 782
Tempo ruler

displaying 775
extending an Edit selection to 777, 818
Pro Tools Reference Guide
Tempo Ruler Enable button 190
test 1090
Text Encoding

Import Session Data 355
Thin All Automation command 1047
Thin Automation command 1047
thinning automation 1029, 1047
tick-based timing 771, 815
Time Compression/Expansion plug-in 612
Time Compression/Expansion Trim tool 135, 555

trimming MIDI 695
Time Grabber tool 560, 574
Time Operations commands 800

Change Meter command 800
Cut Time command 804
Insert Time command 802
Move Song Start command 805

Time Operations window 797, 800
Time Scale 770

Bars|Beats 767
Feet.Frames 768
Main 770, 1149
Minutes:Seconds 768
Samples 768
Sub 771, 1149
Timecode 768

time stamp 382
Time Stamp command 279, 476, 647, 1163
Time Stamp Selected command 833
time stamps 1162

and Bounce to Disk 1085
Timebase rulers 767

and selecting on all tracks 578
and Timeline selections 581
Edit Markers 570
Pre/Post-Roll Flags 570
sliding Edit selections 579
sliding Timeline selections 582
Timecode 2 768
Timeline Selection Markers 570

timecode
and Jam Sync 1147
capturing 1161
freewheeling 1146
generating 1154
redefining position 1149

Timecode 2 Rate setting 1143
Timecode 2 ruler 768
Timecode Mapping Options

on import 367



Timecode Mapping options 356
Timecode Rate setting 1143
Timecode Time Scale 768
Timeline and Edit selection, unlinked 569
Timeline Cached meter 81
Timeline Data Online Status indicator 184
Timeline Drop Order option 824
Timeline Insertion/Play Start Marker Follows 

Playback button 424
Timeline Insertion/Play Start Marker Follows 

Playback option 124, 431
Timeline Selection Markers 465, 570

and Edit selections 571
selection length 574
Timeline selections 582

Timeline selections 581
auditioning with Playhead enabled 427
copied from Edit selection 582
copied to Edit selection 582
in Timebase rulers 581
making with the Selector tool 560
sliding in the Ruler 582
start, end, and length fields 189
Timeline Selection Markers 582

Time-locking clips 840
toggling

track height 230
Track View 229

Tool Tips 121, 208
Toolbar focus 31
Touch automation mode 1024
Touch Timeout option 132
Touch Trim automation mode 1027
Touch/Latch automation mode 1026
Track Color View 953
Track Compensation (cmp) indicator 980
track compositing 636
track controls

audio tracks 214
Auxiliary Input tracks 214
Edit window 214, 215, 216
Elastic Audio 885
Instrument tracks 216
Master Fader tracks 214
MIDI tracks 215
VCA Master tracks 215
video tracks 216

track data 522
Track Height 230

resizing 231
track layout
default path order 95

track level meters 219
Track List 232

hiding 232
pop-up menu 232
showing 232

Track menu 206
Auto Input Monitoring mode 457
Clear All Clip Indicators command 219, 961
Delete command 224
Duplicate command 225, 1023
Group command 260, 261
Input Only Monitoring mode 457
Make Active command 251
Make Inactive command 251
New Track command 221
Scroll to Track 223
Scroll to Track command 584
Set Record Tracks to Auto Input 457
Set Record Tracks to Input Only 457
Split Into Mono command 601, 1110
Write MIDI Real-Time Properties command 

715
Track Name

Right-click menu 235
Track Name/Comments dialog 222
Track Number command 222, 584
Track Offset options 357, 367
Track Position Numbers Stay with Hidden Tracks 

option 121
Track Record Enable indicator 189
Track selector 999
Track View 226

and edit content 534
Blocks 226
changing 229
Clips 226, 227, 527
Master View 1054
Notes 226, 227, 529
Playlists 639
Sysex 705
toggling 229
Velocity 692
Waveform 523

Track View selector 228
Track View Toggle 229
track width 220
TrackInput Monitor button 457
TrackInput Monitor indicator 189
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TrackPunch
crossfades 503
preferences 503

tracks
5.1 format track layout 1109
adding comments 222
adding to selection 577, 578
and surround 1109
appending new material to end of 472
Color Coding options 251
concepts 15
configuring MIDI recording 486
converting multichannel tracks into mono 

tracks 1110
creating a click track 440
creating new Elastic Audio tracks 884
deleting 224
duplicating 225, 1023
Elastic Audio 883
formats 210
grouping 255
hiding 233
locating with Fast Forward/Rewind 421
making inactive/active 251
Master View 230, 1054
metering 219
moving selections between 578
muting 250
names 220, 222
placing clips in 823
playback priority 242
playing 417, 462
record enabling 450
removing from a selection 579
scrolling shortcut 584
selecting across multiple 577
selecting all clips in 572
selecting material in 571
soloing 247
Track Height 230
Track View 226, 229
transposing 929
trimming unwanted data from 596
types 209

Tracks Group command 258
trajectory panning 1131
Transfer files 392

selecting in DigiBase 290
Transfer volume 283
transients 523
Pro Tools Reference Guide
detecting with Beat Detective 658
tabbing to 423, 580

Transport 187
Count Off 441
Meter 443
Metronome 441

Transport Master 1158
Transport Numeric Keypad mode 32, 125
Transport Online option 1153
Transport RecordLock option 127, 504, 516
Transport View options 190, 419, 466, 468
Transport window 187

MIDI controls 189
pre/post-roll 189, 468
record status display 507
start, end, and length fields 189, 466
transport controls 187

Transpose
Elastic Audio 905
MIDI notes 929
Real-Time Properties 713

Transpose command 909, 929
transposing 929

by octave 930
key 930
MIDI notes 688
tracks 929

Trim automation
coalescing 1059

Trim Automation commands 1071
Trim to All Enabled 1071
Trim to Current 1071

Trim Clip commands
End to Fill Selection 597
End to Insertion 597
Start to Fill Selection 597
Start to Insertion 597
To Fill Selection 598
To Selection 596

Trim to All Enabled Automation command 1071
Trim to Current Automation command 1071
Trim tools 543, 554

Loop Trim tool 557
Scrub Trim tool 557
Time Compression/Expansion Trim tool 135, 

555, 695
trimming automation 785, 1050
trimming clip gain 607



trimming
automation breakpoints 785, 1050, 1058
clip gain breakpoints 607
clip start/end points 554
clips by Nudge value 598, 690
clips to Edit insertion point 597
clips with Scrub Trim tool 557
crossfades 625
note start/end points 689
unwanted clip and track data 596

Tweak Head setting (Conversion Quality) 1090, 
1181

U
unavailable I/O 117
unavailable resources 167
Undo and audio recording 463
Undo command 532
Undo History window 532
Undo Queue 533
Ungroup All Clips command 853
Ungroup Clip command 853
Ungroup Clips command 853
Universe view 585
unlinked Timeline and Edit selection 569
unlinking plug-in controls 1017, 1114
Unlock Clip command 839
Unloop Clips command 849
Use Absolute Pan Linking option 131
Use AudioSuite Dither option 134, 985
Use F11 for Wait for Note option 137, 485
Use in Playlist button 865
Use MIDI to Tap Tempo option 137
Use Separate Play and Stop Keys option 125
Use Squeezer option 1090
Use Subframes option 1161
User Default setting, creating 1007
User Offset (+/–) field 979
User Time Stamp 833, 1163
user-defined clips 276, 278, 522
Using Sample-Rate Conversion 380

V
VCA Masters

assigning groups 947
channel strips 212
clearing 1077
controls 946
deleting 1077
displaying automation 1076
mixing 945
track controls 215
track type 209, 945

velocities, for MIDI notes
drawing with Pencil 693
editing 692, 925
editing velocity 692
fading 925
Real-Time Properties 713
scaling 925
scaling with Trim tool 693

Velocity Trim tool 693
Velocity View 692
VENUE 149
VENUE Link 56, 149
Vertical Position setting 143
video

recording limits with pull 1153
Video Designator 319
Video Media options 356
Video Online button 1173, 1175
Video Out FireWire Port command 1190
Video Out PCIe command 1192
Video Pull Up/Down 1150
Video Satellite LE option 56, 148
Video Satellite Link option 56
Video Satellite option 148
Video Sync Offset command 1191
video track

scrubbing 1186
viewing as blocks 1174

video tracks 210
track controls 216

Video Universe window 1187
Video Window command 1185
View Filter (Memory Locations window) 821
View Filter (MIDI Event List) 758
View menu 206

Clip Name View option 531
Clip Sync Point View option 838
Clip Time View options 531
Edit Window View options 183, 951
Edit Window view options 951
Mix Window option 180
Mix Window View options 951
Narrow Mix View option 220
Track Number command 222, 584
Transport View options 190, 419, 466, 468

viewing blocks in the video track 1174
Index 1259
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views
Delay Compensation 220
I/O View 217
Inserts View 952
Sends View 952
Wide Meters View 220

VITC
Generate Lines setting 142
Read Lines setting 142
Read Lines, defaults 142

VITC Insertion Enabled option 142
voice allocation

dynamic 242
explicit 242
host-bast plug-ins 992

Voice selector 243
voices

and RTAS 991
and track priority 242
auto-assignment of ascending 244
QuickPunch on Pro Tools host-based systems 

500
volume

Performance 283
Transfer 283

Volume automation 1050
Volume browsers 193, 285
Volume fader 218
Volume indicator 217
volume.ddb 284

W
Wait for Note 190, 484
Warp indicator 898
Warp markers 893

adding 894
deleting 894
relocating (without applying warping) 894

Warp view 885, 893
warped clips (Elastic Audio) 523
warping audio (Elastic Audio) 895
WAV file format 394, 1086

AES31/Broadcast compliant 394
WaveCache 303
WaveCache.wfm file 165, 284
Waveform View 523
Waveform View options 523

Outlines 525
Peak 524
Power 524
Pro Tools Reference Guide
Rectified 524
waveforms 523

and zero-crossing 526
avoiding clicks and pops 526
DigiBase 303
guidelines for editing 526
repairing with Pencil tool 567
WaveCache 303

website 7
Whole File button

AudioSuite 869
whole-file audio clips 522
Wide Meters View 220
Window Configuration List 203
Window Configurations 198

importing 360
window dub

horizontal position 143
setting color 143
size 143
vertical position 143

Window menu 206
Automation Enable command 1033
Big Counter command 419
Color Palette 253
Disk Space command 452
Edit command 183
Machine Track Arming command 1159
Memory Locations command 816
Mix command 180
Project command 392
System Usage command 82
Task Manager command 340
Transport command 187
Undo History command 532
Workspace command 454

windows
arranging 201
Cascade 201
closing 201
hiding all floating windows 201
Tile 201
Tile Horizontal 201
Tile Vertical 201

Windows sessions
compatibility with Mac 396

Word Clock 74
workflows 515
Workspace browser 454, 455
Write 1070



Write Automation commands 1069, 1070
Write automation mode 1024
Write Automation To commands 1073
Write Automation to Next Breakpoint command 

1063
Write Automation to Next Breakpoint on Stop 

command 1064
Write Automation to Selection/Selection 

Start/Selection End buttons 1060
Write MIDI Real-Time Properties command 715
Write Trim automation mode 1028
writing

automation 1033
automation on stop 1062
automation to next breakpoint 1062
automation to selection, selection start, or 

selection end 1060
snapshot automation 1069

X
XML (MIDI patch names) 701
X–OR (Cancels Previous Solos) Solo Latch option 

249

Z
zero-crossing 526
Zoom buttons 544
Zoom Presets 549
Zoom Toggle 550
Zoom Toggle preferences 130, 550
Zoomer tool 543, 544, 546
zooming 544

a track area 547, 737
around a track point 547, 736
continuously 544
horizontally for all tracks 544
in the ruler 548
in the Tempo Editor 781
on a selection 546
out to the entire session 546
recalling zoom levels 549
return to the previous zoom level 546
storing zoom levels 549
to make all clips visible 546
vertically for all audio tracks 545
vertically for all MIDI tracks 545
with a scroll wheel 553
Zoom Toggle 550
Index 1261
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